[Touch-packages] [Bug 1859754] Re: add ucm to make alsa/sof driver work under PA (variants of Lenovo X1 Carbon 7th, Dell cnl and cml machines)

2020-03-21 Thread Hui Wang
"I was unable to use the "test" feature of gnome settings : I can open
the window, but neither the front right nor front left buttons in the
test play any sound"

That is sth I never met before, please check if speaker-sof-skl_hda_card
is selected and if profile is play HiFi Music.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-lib in Ubuntu.
https://bugs.launchpad.net/bugs/1859754

Title:
  add ucm to make alsa/sof driver work under PA (variants of Lenovo X1
  Carbon 7th, Dell cnl and cml machines)

Status in HWE Next:
  New
Status in alsa-lib package in Ubuntu:
  Fix Committed
Status in alsa-lib source package in Bionic:
  Fix Committed
Status in alsa-lib source package in Eoan:
  Fix Committed

Bug description:
  This ucm is only for Eoan and Bionic, for focal and future versions,
  we plan to integrate the ucm2 instead of this ucm, and the ucm2
  depends on the alsa-lib-1.2.1 and pluseaudio-v14, the ucm2 is under
  developing by the community, is not ready yet.

  [Impact]
  In the oem project, we have a couple of Lenovo and Dell machines which
  connect the digital mic to PCH directly, this design needs the new
  sound driver soc/sof, and this driver can't work under pulseaudio
  automatically, we need to integrate the ucm for the driver, then the
  sof dirver could work under pulseaudio and gnome.

  This ucm is maintained by intel audio team, and it is not upstreamed
  and will not be upstreamed, since the community is developing the ucm2
  which is based on at least alsa-lib-1.2.1 and pulseaudio-v14.0 (still
  under developing), for bionic and eoan, we have to integrate this ucm
  since the alsa-lib version is too low. For focal and future version, we
  are going to integrate the ucm2 after the ucm2 is ready.

  This ucm is already verified in the oem project, now it is time to put it
  into the stock ubuntu. 

  [Fix]
  These ucm files are backported from sof_ucm1 branch of
  https://github.com/thesofproject/alsa-ucm-conf.git

  [Test Case]
  Boot the eoan kernel or oem-osp1-bionic kernel, then check the log of
  pulseaudio, the ucm files are loaded successfully, then check the
  gnome-sound-setting, both output and input devices work well.

  [Regression Risk]
  Low, just add some new ucm files, and this will not affect other machines,
  and those new added ucm files are only used by specific machines which enable
  the sof driver.

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/1859754/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868330] Re: Lenovo ThinkPad-X1-Carbon-7th Gen microphone doesnt work

2020-03-21 Thread Hui Wang
You could test with the latest mainline kernel, let us see if it is
kernel issue or userspace issue.

thx.

https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.6-rc6/

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1868330

Title:
  Lenovo ThinkPad-X1-Carbon-7th Gen microphone doesnt work

Status in alsa-driver package in Ubuntu:
  New

Bug description:
  On Focal Fossa the microphone is recognised but doesn't work.

  Chromium shows the microphone as present but off, and if it is
  renabled it goes off again after a couple of seconds.

  Chromium logs this error:

  [ 2149.047888] sof-audio-pci :00:1f.3: error: no reply expected, received 
0x0
  [ 2149.177469] sof-audio-pci :00:1f.3: firmware boot complete
  [ 2160.561825] sof-audio-pci :00:1f.3: error: no reply expected, received 
0x0
  [ 2160.656755] sof-audio-pci :00:1f.3: firmware boot complete
  [ 2414.391790] sof-audio-pci :00:1f.3: error: no reply expected, received 
0x0
  [ 2414.487256] sof-audio-pci :00:1f.3: firmware boot complete

  Mar 20 23:09:24 user-ThinkPad-X1-Carbon-7th
  chromium_chromium.desktop[9531]:
  [9531:9531:0320/230924.861503:ERROR:pulse_util.cc(300)] pa_operation
  is nullptr.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: alsa-base 1.0.25+dfsg-0ubuntu5
  ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
  Uname: Linux 5.4.0-18-generic x86_64
  ApportVersion: 2.20.11-0ubuntu20
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  user   1687 F pulseaudio
   /dev/snd/pcmC0D0p:   user   1687 F...m pulseaudio
  CurrentDesktop: ubuntu:GNOME
  Date: Fri Mar 20 23:03:01 2020
  InstallationDate: Installed on 2020-03-11 (9 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200309)
  PackageArchitecture: all
  SourcePackage: alsa-driver
  Symptom: audio
  Symptom_AlsaRecordingTest: ALSA recording test through plughw:sofhdadsp failed
  Symptom_Card: sof-hda-dsp - sof-hda-dsp
  Symptom_Jack: Black Mic, Right
  Symptom_Type: None of the above
  Title: [20R1000RUS, Realtek ALC285, Black Mic, Right] Recording problem
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 01/15/2020
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N2QET19W (1.13 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20R1000RUS
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0J40697 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN2QET19W(1.13):bd01/15/2020:svnLENOVO:pn20R1000RUS:pvrThinkPadX1Carbon7th:rvnLENOVO:rn20R1000RUS:rvrSDK0J40697WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad X1 Carbon 7th
  dmi.product.name: 20R1000RUS
  dmi.product.sku: LENOVO_MT_20R1_BU_Think_FM_ThinkPad X1 Carbon 7th
  dmi.product.version: ThinkPad X1 Carbon 7th
  dmi.sys.vendor: LENOVO
  mtime.conffile..etc.modprobe.d.alsa-base.conf: 2020-03-12T15:40:19.308712

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1868330/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868407] Re: PCI/internal sound card not detected

2020-03-21 Thread Hui Wang
*** This bug is a duplicate of bug 1868319 ***
https://bugs.launchpad.net/bugs/1868319

Please refer to #1868319.
thx.


** This bug has been marked a duplicate of bug 1868319
   PCI/internal sound card not detected

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1868407

Title:
  PCI/internal sound card not detected

Status in alsa-driver package in Ubuntu:
  New

Bug description:
  After the most recent Ubuntu update to kernel 5.3.0-42-generic, built-in 
sound card is no longer detected. I have no sound at all. Booting  Ubuntu with 
the previous kernel 5.3.0-40-generic restores everything to normal (as a 
temporary fix I set GRUB_DEFAULT="1>2").
  Configuration:
  Dell G3 3590 laptop with i7-9750H intel CPU.
  Ubuntu 18.04.
  Realtek built in sound (I'll add details later after I reboot with the older 
kernel).
  Wiht the current (newest kernel) the output of aplay -l is:
  -
  aplay -l
   List of PLAYBACK Hardware Devices 
  card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
  -

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: alsa-base 1.0.25+dfsg-0ubuntu5
  ProcVersionSignature: Ubuntu 5.3.0-42.34~18.04.1-generic 5.3.18
  Uname: Linux 5.3.0-42-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  ApportVersion: 2.20.9-0ubuntu7.12
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  user   2833 F pulseaudio
  CurrentDesktop: ubuntu:GNOME
  Date: Sat Mar 21 21:28:58 2020
  InstallationDate: Installed on 2019-07-27 (238 days ago)
  InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 
(20190210)
  PackageArchitecture: all
  SourcePackage: alsa-driver
  Symptom: audio
  Title: PCI/internal sound card not detected
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 07/01/2019
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.4.3
  dmi.board.name: 0NK0C0
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 10
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvr1.4.3:bd07/01/2019:svnDellInc.:pnG33590:pvr:rvnDellInc.:rn0NK0C0:rvrA00:cvnDellInc.:ct10:cvr:
  dmi.product.family: GSeries
  dmi.product.name: G3 3590
  dmi.product.sku: 0949
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1868407/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1850667] Re: cgroup v2 is not fully supported yet, proceeding with partial confinement

2020-03-21 Thread Stéphane Graber
LXD, LXCFS and LXC all have cgroupv2 support now.
It's certainly not perfect and things like CRIU (lxc-checkpoint) will not work 
until such time as cgroupv2 support is fully on part in the kernel with 
cgroupv1 and the needed additional interfaces are added to projects like CRIU.

But for normal day to day use, we should be in pretty good shape now.

** Changed in: lxd (Ubuntu)
   Status: New => Fix Released

** Changed in: lxcfs (Ubuntu)
   Status: New => Fix Released

** Changed in: lxc (Ubuntu)
   Importance: Unknown => Undecided

** Changed in: lxc (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lxc in Ubuntu.
https://bugs.launchpad.net/bugs/1850667

Title:
  cgroup v2 is not fully supported yet, proceeding with partial
  confinement

Status in docker.io package in Ubuntu:
  New
Status in lxc package in Ubuntu:
  Fix Released
Status in lxcfs package in Ubuntu:
  Fix Released
Status in lxd package in Ubuntu:
  Fix Released
Status in snapd package in Ubuntu:
  In Progress

Bug description:
  Systemd upstream switched the default cgroup hierarchy to unified with
  v243. This change is reverted by the Ubuntu systemd packages, but as
  unified is the way to go per upstream support should be added to all
  relevant Ubuntu packges (and snaps):

  https://github.com/systemd/systemd/blob/v243/NEWS#L56

  * systemd now defaults to the "unified" cgroup hierarchy setup during
build-time, i.e. -Ddefault-hierarchy=unified is now the build-time
default. Previously, -Ddefault-hierarchy=hybrid was the default. 
This
change reflects the fact that cgroupsv2 support has matured
substantially in both systemd and in the kernel, and is clearly the
way forward. Downstream production distributions might want to
continue to use -Ddefault-hierarchy=hybrid (or even =legacy) for
their builds as unfortunately the popular container managers have 
not
caught up with the kernel API changes.

  
  Systemd is rebuilt using the new default and is available from the following 
PPA for testing:

  https://launchpad.net/~rbalint/+archive/ubuntu/systemd-unified-cgh

  The autopkgtest results against other packges are available here:

  
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac
  /autopkgtest-eoan-rbalint-systemd-unified-cgh/?format=plain

  
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac
  /autopkgtest-focal-rbalint-systemd-unified-cgh/?format=plain

  lxc autopkgtest failing:

  
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac
  /autopkgtest-eoan-rbalint-systemd-unified-
  cgh/eoan/amd64/d/docker.io/20191030_155944_2331e@/log.gz

  snapd autopkgtest failing:

  
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac
  /autopkgtest-eoan-rbalint-systemd-unified-
  cgh/eoan/amd64/s/snapd/20191030_161354_94b26@/log.gz

  
  docker.io autopkgtest failing:

  
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac
  /autopkgtest-eoan-rbalint-systemd-unified-
  cgh/eoan/amd64/d/docker.io/20191030_155944_2331e@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/docker.io/+bug/1850667/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1860930] Re: [Asus GX531GX] Internal speakers are sometimes noisy - bad audio

2020-03-21 Thread Adam Niedling
I'm uploading another example of distorted audio.

Original:
https://www.youtube.com/watch?v=wDdyn4Kbffs

** Attachment added: "bad-sound3.m4a"
   
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1860930/+attachment/5339861/+files/bad-sound3.m4a

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1860930

Title:
  [Asus GX531GX] Internal speakers are sometimes noisy - bad audio

Status in alsa-driver package in Ubuntu:
  New
Status in pulseaudio package in Ubuntu:
  New

Bug description:
  I have an Asus Zephyrus S GX531GX laptop and a pair of Asus Delta USB
  headphones. When the headphones are plugged in during boot the
  internal speakers won't work. There is only crackling sound coming
  from them. It doesn't help in I unplug the headphones. There is no
  problem if they are not plugged in during boot. I'm using Ubuntu
  19.10.

  Please let me know if you need more information.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: pulseaudio 1:13.0-1ubuntu1.1
  ProcVersionSignature: Ubuntu 5.3.0-26.28-generic 5.3.13
  Uname: Linux 5.3.0-26-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  ApportVersion: 2.20.11-0ubuntu8.2
  Architecture: amd64
  Date: Sun Jan 26 19:26:35 2020
  InstallationDate: Installed on 2019-12-19 (38 days ago)
  InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   LANG=hu_HU.UTF-8
   SHELL=/bin/bash
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
  SourcePackage: pulseaudio
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 06/28/2019
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: GX531GXR.304
  dmi.board.asset.tag: ATN12345678901234567
  dmi.board.name: GX531GXR
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: 1.0
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: ASUSTeK COMPUTER INC.
  dmi.chassis.version: 1.0
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrGX531GXR.304:bd06/28/2019:svnASUSTeKCOMPUTERINC.:pnZephyrusSGX531GXR_GX531GXR:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnGX531GXR:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
  dmi.product.family: Zephyrus S
  dmi.product.name: Zephyrus S GX531GXR_GX531GXR
  dmi.product.version: 1.0
  dmi.sys.vendor: ASUSTeK COMPUTER INC.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1860930/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868409] [NEW] gnome-{calculator, logs, characters} snaps not removed after the equivalent APT packages are installed on 20.04, and gnome-software APT package not replaced by sna

2020-03-21 Thread Naël
Public bug reported:

I'm trialing the development release of Ubuntu 20.04, installed in
December and kept up-to-date by regularly running apt full-upgrade.

I understand from [1] that 20.04 will ship
gnome-{calculator,logs,characters} as APT packages rather than snap
apps, and gnome-software as a snap app (called snap-store) rather than
an APT package.

Following an apt full-upgrade in late February, I now have:

* both the snap and the APT versions of gnome-{calculator,logs,characters}
* still only the APT version of gnome-software, no snap-store

Is this normal? A user in the #ubuntu+1 IRC channel reports that a fresh
install of the development release:

* only features the APT versions of gnome-{calculator,logs,characters}
* features the snap-store (but also the APT version of gnome-software)

Are users of older installs of the development release supposed to
manually uninstall the snap versions of
gnome-{calculator,logs,characters} and manually install the snap-store?

[1] https://discourse.ubuntu.com/t/is-ubuntu-software-going-to-be-
remove-for-snap-snap-store/14542

** Affects: ubuntu-meta (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu.
https://bugs.launchpad.net/bugs/1868409

Title:
  gnome-{calculator,logs,characters} snaps not removed after the
  equivalent APT packages are installed on 20.04, and gnome-software APT
  package not replaced by snap-store

Status in ubuntu-meta package in Ubuntu:
  New

Bug description:
  I'm trialing the development release of Ubuntu 20.04, installed in
  December and kept up-to-date by regularly running apt full-upgrade.

  I understand from [1] that 20.04 will ship
  gnome-{calculator,logs,characters} as APT packages rather than snap
  apps, and gnome-software as a snap app (called snap-store) rather than
  an APT package.

  Following an apt full-upgrade in late February, I now have:

  * both the snap and the APT versions of gnome-{calculator,logs,characters}
  * still only the APT version of gnome-software, no snap-store

  Is this normal? A user in the #ubuntu+1 IRC channel reports that a
  fresh install of the development release:

  * only features the APT versions of gnome-{calculator,logs,characters}
  * features the snap-store (but also the APT version of gnome-software)

  Are users of older installs of the development release supposed to
  manually uninstall the snap versions of
  gnome-{calculator,logs,characters} and manually install the snap-
  store?

  [1] https://discourse.ubuntu.com/t/is-ubuntu-software-going-to-be-
  remove-for-snap-snap-store/14542

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-meta/+bug/1868409/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1845801] Re: [nvidia] Automatic login fails and then all subsequent logins fail. Killing gnome-session-binary fixes it, or just not using automatic login.

2020-03-21 Thread Paulo Narciso
Is this going to be fixed in 20.04?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1845801

Title:
  [nvidia] Automatic login fails and then all subsequent logins fail.
  Killing gnome-session-binary fixes it, or just not using automatic
  login.

Status in gdm3 package in Ubuntu:
  Confirmed
Status in gnome-session package in Ubuntu:
  Confirmed
Status in nvidia-graphics-drivers-390 package in Ubuntu:
  Confirmed
Status in nvidia-graphics-drivers-430 package in Ubuntu:
  Confirmed
Status in nvidia-graphics-drivers-435 package in Ubuntu:
  Confirmed
Status in systemd package in Ubuntu:
  Confirmed
Status in gdm3 source package in Eoan:
  Confirmed
Status in gnome-session source package in Eoan:
  Confirmed
Status in nvidia-graphics-drivers-435 source package in Eoan:
  Confirmed

Bug description:
  I just updated to the Ubuntu 19.10 beta. After boot, I'm shown the GDM
  login screen (which I shouldn't; I have auto login enabled), and
  logging in just takes me back to the same user selection screen even
  though the password is correct.

  If I switch to a TTY and run `sudo pkill gnome-session-binary`,
  logging in through GDM starts working again.

  I should add that the do-release-upgrade was rocky; I did it in a
  terminal from within gnome, went away for a while, and when I
  returned, I just saw an Ubuntu 19.10 in a TTY. I was able to do `sudo
  dpkg --configure -a` and complete the upgrade, but I don't know if
  something's still messed up due to that.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: xorg 1:7.7+19ubuntu12
  ProcVersionSignature: Ubuntu 5.3.0-13.14-generic 5.3.0
  Uname: Linux 5.3.0-13-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  .proc.driver.nvidia.gpus..01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:01:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  435.21  Sun Aug 25 08:17:57 
CDT 2019
   GCC version:  gcc version 9.2.1 20190909 (Ubuntu 9.2.1-8ubuntu1)
  ApportVersion: 2.20.11-0ubuntu7
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Sat Sep 28 19:55:42 2019
  DistUpgraded: 2019-09-28 18:35:15,142 INFO cache.commit()
  DistroCodename: eoan
  DistroVariant: ubuntu
  DkmsStatus: nvidia, 435.21, 5.3.0-13-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   NVIDIA Corporation GP102 [GeForce GTX 1080 Ti] [10de:1b06] (rev a1) (prog-if 
00 [VGA controller])
 Subsystem: ASUSTeK Computer Inc. GP102 [GeForce GTX 1080 Ti] [1043:85e4]
  InstallationDate: Installed on 2019-09-14 (13 days ago)
  InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
  MachineType: MSI MS-7A67
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-13-generic 
root=UUID=04974c80-e732-49b6-8148-c3dce7c02a25 ro quiet splash vt.handoff=7
  SourcePackage: xorg
  Symptom: display
  Title: Xorg crash
  UpgradeStatus: Upgraded to eoan on 2019-09-28 (0 days ago)
  dmi.bios.date: 01/25/2018
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 2.60
  dmi.board.asset.tag: Default string
  dmi.board.name: H270I GAMING PRO AC (MS-7A67)
  dmi.board.vendor: MSI
  dmi.board.version: 1.0
  dmi.chassis.asset.tag: Default string
  dmi.chassis.type: 3
  dmi.chassis.vendor: MSI
  dmi.chassis.version: 1.0
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr2.60:bd01/25/2018:svnMSI:pnMS-7A67:pvr1.0:rvnMSI:rnH270IGAMINGPROAC(MS-7A67):rvr1.0:cvnMSI:ct3:cvr1.0:
  dmi.product.family: Default string
  dmi.product.name: MS-7A67
  dmi.product.sku: Default string
  dmi.product.version: 1.0
  dmi.sys.vendor: MSI
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.99-1ubuntu1
  version.libgl1-mesa-dri: libgl1-mesa-dri 19.1.6-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.5+git20190820-0ubuntu3
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.0.1-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gdm3/+bug/1845801/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868319] Re: PCI/internal sound card not detected

2020-03-21 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: alsa-driver (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1868319

Title:
  PCI/internal sound card not detected

Status in alsa-driver package in Ubuntu:
  Confirmed

Bug description:
  Any time now, the sound card was deactivated, and it appears as a
  "Dummy device". I searched many forums about it, but nothing works.
  I'll be grateful if a program exists that I could install for sound
  card recognition.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: alsa-base 1.0.25+dfsg-0ubuntu5
  ProcVersionSignature: Ubuntu 5.3.0-42.34-generic 5.3.18
  Uname: Linux 5.3.0-42-generic x86_64
  ApportVersion: 2.20.11-0ubuntu8.6
  Architecture: amd64
  AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', 
'/dev/snd/timer'] failed with exit code 1:
  CurrentDesktop: ubuntu:GNOME
  Date: Fri Mar 20 16:13:53 2020
  InstallationDate: Installed on 2020-03-19 (0 days ago)
  InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
  PackageArchitecture: all
  ProcEnviron:
   LANGUAGE=es_CL:es
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=es_CL.UTF-8
   SHELL=/bin/bash
  SourcePackage: alsa-driver
  Symptom: audio
  Title: PCI/internal sound card not detected
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/08/2019
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.6.0
  dmi.board.name: 054J60
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 10
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvr1.6.0:bd08/08/2019:svnDellInc.:pnG33590:pvr:rvnDellInc.:rn054J60:rvrA00:cvnDellInc.:ct10:cvr:
  dmi.product.family: GSeries
  dmi.product.name: G3 3590
  dmi.product.sku: 0949
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1868319/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868407] Re: PCI/internal sound card not detected

2020-03-21 Thread David
Additional information to the reported bug:
After rebooting with the older kernel (5.3.0-40-generic) sound is restored and 
the output of aplay -l is:
aplay -l
 List of PLAYBACK Hardware Devices 
card 0: PCH [HDA Intel PCH], device 0: ALC3254 Analog [ALC3254 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1868407

Title:
  PCI/internal sound card not detected

Status in alsa-driver package in Ubuntu:
  New

Bug description:
  After the most recent Ubuntu update to kernel 5.3.0-42-generic, built-in 
sound card is no longer detected. I have no sound at all. Booting  Ubuntu with 
the previous kernel 5.3.0-40-generic restores everything to normal (as a 
temporary fix I set GRUB_DEFAULT="1>2").
  Configuration:
  Dell G3 3590 laptop with i7-9750H intel CPU.
  Ubuntu 18.04.
  Realtek built in sound (I'll add details later after I reboot with the older 
kernel).
  Wiht the current (newest kernel) the output of aplay -l is:
  -
  aplay -l
   List of PLAYBACK Hardware Devices 
  card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
  -

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: alsa-base 1.0.25+dfsg-0ubuntu5
  ProcVersionSignature: Ubuntu 5.3.0-42.34~18.04.1-generic 5.3.18
  Uname: Linux 5.3.0-42-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  ApportVersion: 2.20.9-0ubuntu7.12
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  user   2833 F pulseaudio
  CurrentDesktop: ubuntu:GNOME
  Date: Sat Mar 21 21:28:58 2020
  InstallationDate: Installed on 2019-07-27 (238 days ago)
  InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 
(20190210)
  PackageArchitecture: all
  SourcePackage: alsa-driver
  Symptom: audio
  Title: PCI/internal sound card not detected
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 07/01/2019
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.4.3
  dmi.board.name: 0NK0C0
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 10
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvr1.4.3:bd07/01/2019:svnDellInc.:pnG33590:pvr:rvnDellInc.:rn0NK0C0:rvrA00:cvnDellInc.:ct10:cvr:
  dmi.product.family: GSeries
  dmi.product.name: G3 3590
  dmi.product.sku: 0949
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1868407/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868407] [NEW] PCI/internal sound card not detected

2020-03-21 Thread David
Public bug reported:

After the most recent Ubuntu update to kernel 5.3.0-42-generic, built-in sound 
card is no longer detected. I have no sound at all. Booting  Ubuntu with the 
previous kernel 5.3.0-40-generic restores everything to normal (as a temporary 
fix I set GRUB_DEFAULT="1>2").
Configuration:
Dell G3 3590 laptop with i7-9750H intel CPU.
Ubuntu 18.04.
Realtek built in sound (I'll add details later after I reboot with the older 
kernel).
Wiht the current (newest kernel) the output of aplay -l is:
-
aplay -l
 List of PLAYBACK Hardware Devices 
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
-

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: alsa-base 1.0.25+dfsg-0ubuntu5
ProcVersionSignature: Ubuntu 5.3.0-42.34~18.04.1-generic 5.3.18
Uname: Linux 5.3.0-42-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.9-0ubuntu7.12
Architecture: amd64
AudioDevicesInUse:
 USERPID ACCESS COMMAND
 /dev/snd/controlC0:  user   2833 F pulseaudio
CurrentDesktop: ubuntu:GNOME
Date: Sat Mar 21 21:28:58 2020
InstallationDate: Installed on 2019-07-27 (238 days ago)
InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 (20190210)
PackageArchitecture: all
SourcePackage: alsa-driver
Symptom: audio
Title: PCI/internal sound card not detected
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/01/2019
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.4.3
dmi.board.name: 0NK0C0
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 10
dmi.chassis.vendor: Dell Inc.
dmi.modalias: 
dmi:bvnDellInc.:bvr1.4.3:bd07/01/2019:svnDellInc.:pnG33590:pvr:rvnDellInc.:rn0NK0C0:rvrA00:cvnDellInc.:ct10:cvr:
dmi.product.family: GSeries
dmi.product.name: G3 3590
dmi.product.sku: 0949
dmi.sys.vendor: Dell Inc.

** Affects: alsa-driver (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug bionic

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1868407

Title:
  PCI/internal sound card not detected

Status in alsa-driver package in Ubuntu:
  New

Bug description:
  After the most recent Ubuntu update to kernel 5.3.0-42-generic, built-in 
sound card is no longer detected. I have no sound at all. Booting  Ubuntu with 
the previous kernel 5.3.0-40-generic restores everything to normal (as a 
temporary fix I set GRUB_DEFAULT="1>2").
  Configuration:
  Dell G3 3590 laptop with i7-9750H intel CPU.
  Ubuntu 18.04.
  Realtek built in sound (I'll add details later after I reboot with the older 
kernel).
  Wiht the current (newest kernel) the output of aplay -l is:
  -
  aplay -l
   List of PLAYBACK Hardware Devices 
  card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
  -

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: alsa-base 1.0.25+dfsg-0ubuntu5
  ProcVersionSignature: Ubuntu 5.3.0-42.34~18.04.1-generic 5.3.18
  Uname: Linux 5.3.0-42-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  ApportVersion: 2.20.9-0ubuntu7.12
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  user   2833 F pulseaudio
  CurrentDesktop: ubuntu:GNOME
  Date: Sat Mar 21 21:28:58 2020
  InstallationDate: Installed on 2019-07-27 (238 days ago)
  InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 
(20190210)
  PackageArchitecture: all
  SourcePackage: alsa-driver
  Symptom: audio
  Title: PCI/internal sound card not detected
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 07/01/2019
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.4.3
  dmi.board.name: 0NK0C0
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 10
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvr1.4.3:bd07/01/2019:svnDellInc.:pnG33590:pvr:rvnDellInc.:rn0NK0C0:rvrA00:cvnDellInc.:ct10:cvr:
  dmi.product.family: GSeries
  dmi.product.name: G3 3590
  dmi.product.sku: 0949
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1868407/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868329] Re: ifupdown does not render viable /etc/network/interfaces on bionic ec2 cloud-images

2020-03-21 Thread Chad Smith
** Also affects: ifupdown (Ubuntu Bionic)
   Importance: Undecided
   Status: New

** Also affects: ifupdown (Ubuntu Focal)
   Importance: Undecided
   Status: New

** Also affects: ifupdown (Ubuntu Eoan)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ifupdown in Ubuntu.
https://bugs.launchpad.net/bugs/1868329

Title:
  ifupdown does not render viable /etc/network/interfaces on bionic ec2
  cloud-images

Status in ifupdown package in Ubuntu:
  New
Status in ifupdown source package in Bionic:
  New
Status in ifupdown source package in Eoan:
  New
Status in ifupdown source package in Focal:
  New

Bug description:
  Filing this bug for clarification and tracking on Ubuntu Bionic and
  later.

  Canonical cloudimages for Ec2 and other clouds leave an artifact that
  disables /etc/network/interface with the following content:

  # ifupdown has been replaced by netplan(5) on this system.  See
  # /etc/netplan for current configuration.
  # To re-enable ifupdown on this system, you can run:
  #sudo apt install ifupdown

  In following the suggested text, installing the ifupdown deb continues
  to leave a broken system because ifupdown.postinst script creates an
  /etc/network/interfaces.d parts directory but does not write out a
  working /etc/network/interfaces file if the file exists on the system.

  This leaves a broken /etc/network/interfaces files which doesn't
  source /etc/network/interfaces.d/* and 3rd parties cannot use the
  interfaces.d parts directory to extend networking config.

  Cloud-init is one of those users of /etc/network/interfaces.d/ for
  rendering system networking on cloud images. Per LP: #1867029

  I have attached ifupdwown-test.sh which exercises this issue on lxc by
  mocking the CPC cloudimage artifact.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ifupdown/+bug/1868329/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868405] [NEW] Untranslatable "Monitor of ..."

2020-03-21 Thread Nicholas Guriev
Public bug reported:

It is impossible to translate string "Monitor of %s". Please add gettext
call here and export the string into the .pot template.

https://git.launchpad.net/ubuntu/+source/pulseaudio/tree/src/pulsecore/sink.c?id=25a10a09f88d51bfd7d80574fa6c329086630531#n373

** Affects: pulseaudio (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: focal i18n

** Tags added: focal i18n

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1868405

Title:
  Untranslatable "Monitor of ..."

Status in pulseaudio package in Ubuntu:
  New

Bug description:
  It is impossible to translate string "Monitor of %s". Please add
  gettext call here and export the string into the .pot template.

  
https://git.launchpad.net/ubuntu/+source/pulseaudio/tree/src/pulsecore/sink.c?id=25a10a09f88d51bfd7d80574fa6c329086630531#n373

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1868405/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868401] Re: nm-online crashed with SIGSEGV in g_source_set_ready_time()

2020-03-21 Thread Apport retracing service
*** This bug is a duplicate of bug 1866783 ***
https://bugs.launchpad.net/bugs/1866783

Thank you for taking the time to report this crash and helping to make
this software better.  This particular crash has already been reported
and is a duplicate of bug #1866783, so is being marked as such.  Please
look at the other bug report to see if there is any missing information
that you can provide, or to see if there is a workaround for the bug.
Additionally, any further discussion regarding the bug should occur in
the other report.  Please continue to report any other bugs you may
find.

** Attachment removed: "CoreDump.gz"
   
https://bugs.launchpad.net/bugs/1868401/+attachment/5339803/+files/CoreDump.gz

** Attachment removed: "Disassembly.txt"
   
https://bugs.launchpad.net/bugs/1868401/+attachment/5339805/+files/Disassembly.txt

** Attachment removed: "ProcMaps.txt"
   
https://bugs.launchpad.net/bugs/1868401/+attachment/5339815/+files/ProcMaps.txt

** Attachment removed: "ProcStatus.txt"
   
https://bugs.launchpad.net/bugs/1868401/+attachment/5339816/+files/ProcStatus.txt

** Attachment removed: "Registers.txt"
   
https://bugs.launchpad.net/bugs/1868401/+attachment/5339817/+files/Registers.txt

** Attachment removed: "Stacktrace.txt"
   
https://bugs.launchpad.net/bugs/1868401/+attachment/5339819/+files/Stacktrace.txt

** Attachment removed: "ThreadStacktrace.txt"
   
https://bugs.launchpad.net/bugs/1868401/+attachment/5339820/+files/ThreadStacktrace.txt

** This bug has been marked a duplicate of private bug 1866783

** Information type changed from Private to Public

** Tags removed: need-amd64-retrace

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1868401

Title:
  nm-online crashed with SIGSEGV in g_source_set_ready_time()

Status in network-manager package in Ubuntu:
  New

Bug description:
  The following bug was found after installing Microsoft fonts. using -
  sudo apt install ubuntu-restricted-extras

  ProblemType: Crash
  DistroRelease: Ubuntu 20.04
  Package: network-manager 1.22.10-1ubuntu1
  ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
  Uname: Linux 5.4.0-18-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  ApportVersion: 2.20.11-0ubuntu21
  Architecture: amd64
  Date: Sun Mar 22 01:26:08 2020
  ExecutablePath: /usr/bin/nm-online
  IfupdownConfig:
   # interfaces(5) file used by ifup(8) and ifdown(8)
   auto lo
   iface lo inet loopback
  InstallationDate: Installed on 2020-03-21 (0 days ago)
  InstallationMedia: Ubuntu 18.04.4 LTS "Bionic Beaver" - Release amd64 
(20200203.1)
  IpRoute:
   default via 192.168.0.1 dev wlp2s0 proto dhcp metric 600 
   169.254.0.0/16 dev wlp2s0 scope link metric 1000 
   192.168.0.0/24 dev wlp2s0 proto kernel scope link src 192.168.0.101 metric 
600
  NetworkManager.state:
   [main]
   NetworkingEnabled=true
   WirelessEnabled=true
   WWANEnabled=true
  ProcCmdline: /usr/bin/nm-online -s -q --timeout=30
  ProcEnviron:
   LANG=en_IN
   LANGUAGE=en_IN:en
   PATH=(custom, no user)
  SegvAnalysis:
   Segfault happened at: 0x7f74279cbbf3 :   cmp
0x10(%rax),%rbp
   PC (0x7f74279cbbf3) ok
   source "0x10(%rax)" (0x0010) not located in a known VMA region (needed 
readable region)!
   destination "%rbp" ok
  SegvReason: reading NULL VMA
  Signal: 11
  SourcePackage: network-manager
  StacktraceTop:
   g_source_set_ready_time () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
   ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
   ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
   g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
   g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
  Title: nm-online crashed with SIGSEGV in g_source_set_ready_time()
  UpgradeStatus: Upgraded to focal on 2020-03-21 (0 days ago)
  UserGroups:
   
  nmcli-nm:
   RUNNING  VERSION  STATE  STARTUP  CONNECTIVITY  NETWORKING  WIFI-HW  
WIFI WWAN-HW  WWAN
   running  1.22.10  connected  started  full  enabled enabled  
enabled  enabled  enabled
  separator:

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1868401/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868330] Re: Lenovo ThinkPad-X1-Carbon-7th Gen microphone doesnt work

2020-03-21 Thread Thomas Parrott
Thanks Hui, for the quick response. I've installed that package, and
indeed, the microphone now works in apps like Audacity. Great.

However it still does not work in Chromium in Google Meet, the
microphone appears as a device to use, but it shows as "disabled" and so
when I unmute in Google Meet it then re-mutes after 2s.

In syslog it shows still each time I unmute:

Mar 21 18:57:22 user-ThinkPad-X1-Carbon-7th
chromium_chromium.desktop[4806]:
[4806:4806:0321/185722.248501:ERROR:pulse_util.cc(300)] pa_operation is
nullptr.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1868330

Title:
  Lenovo ThinkPad-X1-Carbon-7th Gen microphone doesnt work

Status in alsa-driver package in Ubuntu:
  New

Bug description:
  On Focal Fossa the microphone is recognised but doesn't work.

  Chromium shows the microphone as present but off, and if it is
  renabled it goes off again after a couple of seconds.

  Chromium logs this error:

  [ 2149.047888] sof-audio-pci :00:1f.3: error: no reply expected, received 
0x0
  [ 2149.177469] sof-audio-pci :00:1f.3: firmware boot complete
  [ 2160.561825] sof-audio-pci :00:1f.3: error: no reply expected, received 
0x0
  [ 2160.656755] sof-audio-pci :00:1f.3: firmware boot complete
  [ 2414.391790] sof-audio-pci :00:1f.3: error: no reply expected, received 
0x0
  [ 2414.487256] sof-audio-pci :00:1f.3: firmware boot complete

  Mar 20 23:09:24 user-ThinkPad-X1-Carbon-7th
  chromium_chromium.desktop[9531]:
  [9531:9531:0320/230924.861503:ERROR:pulse_util.cc(300)] pa_operation
  is nullptr.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: alsa-base 1.0.25+dfsg-0ubuntu5
  ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
  Uname: Linux 5.4.0-18-generic x86_64
  ApportVersion: 2.20.11-0ubuntu20
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  user   1687 F pulseaudio
   /dev/snd/pcmC0D0p:   user   1687 F...m pulseaudio
  CurrentDesktop: ubuntu:GNOME
  Date: Fri Mar 20 23:03:01 2020
  InstallationDate: Installed on 2020-03-11 (9 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200309)
  PackageArchitecture: all
  SourcePackage: alsa-driver
  Symptom: audio
  Symptom_AlsaRecordingTest: ALSA recording test through plughw:sofhdadsp failed
  Symptom_Card: sof-hda-dsp - sof-hda-dsp
  Symptom_Jack: Black Mic, Right
  Symptom_Type: None of the above
  Title: [20R1000RUS, Realtek ALC285, Black Mic, Right] Recording problem
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 01/15/2020
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N2QET19W (1.13 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20R1000RUS
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0J40697 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN2QET19W(1.13):bd01/15/2020:svnLENOVO:pn20R1000RUS:pvrThinkPadX1Carbon7th:rvnLENOVO:rn20R1000RUS:rvrSDK0J40697WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad X1 Carbon 7th
  dmi.product.name: 20R1000RUS
  dmi.product.sku: LENOVO_MT_20R1_BU_Think_FM_ThinkPad X1 Carbon 7th
  dmi.product.version: ThinkPad X1 Carbon 7th
  dmi.sys.vendor: LENOVO
  mtime.conffile..etc.modprobe.d.alsa-base.conf: 2020-03-12T15:40:19.308712

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1868330/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1863239] Re: /dev/bus/usb/*/* device file of HP multi-function printer assigned to "audio" group

2020-03-21 Thread Till Kamppeter
Attached debdiff fixes this bug in the libmtp package, applying
effectively the patch of the previous comment.

** Patch added: "libmtp_1.1.17-2_1.1.17-2ubuntu1.debdiff"
   
https://bugs.launchpad.net/ubuntu/+source/udev/+bug/1863239/+attachment/5339786/+files/libmtp_1.1.17-2_1.1.17-2ubuntu1.debdiff

** Changed in: libmtp (Ubuntu)
   Status: Confirmed => Fix Committed

** Changed in: libmtp (Ubuntu)
   Status: Fix Committed => In Progress

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1863239

Title:
  /dev/bus/usb/*/* device file of HP multi-function printer assigned to
  "audio" group

Status in libmtp package in Ubuntu:
  In Progress
Status in pulseaudio package in Ubuntu:
  Invalid
Status in systemd package in Ubuntu:
  Invalid
Status in udev package in Ubuntu:
  Invalid

Bug description:
  When testing HPLIP I found out that CUPS backends can access my
  printer only when they are running as root, when they are running as
  the special user lp, as it is usually the case, they cannot access the
  printer.

  So I tried to find out why and saw that the /dev/bus/usb/*/* device
  file for the printer has group ownership "audio" and not "lp":

  till@till-x1yoga:~/ubuntu/hplip/focal/debian/hplip-3.19.12+dfsg0$ ll 
/dev/bus/usb/*/*
  crw-rw-r--  1 root root189,   0 Feb 11 14:17 /dev/bus/usb/001/001
  crw-rw-r--  1 root root189,   2 Feb 11 14:17 /dev/bus/usb/001/003
  crw-rw-r--  1 root root189,   3 Feb 11 14:17 /dev/bus/usb/001/004
  crw-rw-r--  1 root plugdev 189,   4 Feb 14 12:23 /dev/bus/usb/001/005
  crw-rw-r--  1 root root189,   5 Feb 11 14:17 /dev/bus/usb/001/006
  crw-rw+ 1 root audio   189,  62 Feb 14 12:37 /dev/bus/usb/001/063
  crw-rw-r--  1 root root189, 128 Feb 11 14:17 /dev/bus/usb/002/001
  crw-rw-r--  1 root root189, 130 Feb 13 09:38 /dev/bus/usb/002/003
  till@till-x1yoga:~/ubuntu/hplip/focal/debian/hplip-3.19.12+dfsg0$

  The printer is the device /dev/bus/usb/001/063:

  till@till-x1yoga:~/ubuntu/hplip/focal/debian/hplip-3.19.12+dfsg0$ lsusb
  Bus 002 Device 003: ID 0b95:1790 ASIX Electronics Corp. AX88179 Gigabit 
Ethernet
  Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
  Bus 001 Device 005: ID 138a:0097 Validity Sensors, Inc. 
  Bus 001 Device 004: ID 04f2:b5ce Chicony Electronics Co., Ltd Integrated 
Camera
  Bus 001 Device 003: ID 8087:0a2b Intel Corp. 
  Bus 001 Device 006: ID 056a:50b7 Wacom Co., Ltd Pen and multitouch sensor
  Bus 001 Device 063: ID 03f0:7a12 HP, Inc HP OfficeJet Pro 8730
  Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  till@till-x1yoga:~/ubuntu/hplip/focal/debian/hplip-3.19.12+dfsg0$ 

  There must be a bug somewhere in the UDEV rules.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libmtp/+bug/1863239/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868396] [NEW] crashes or freezes with nividia/xorg

2020-03-21 Thread SR
Public bug reported:

I have plugged in my Dell precision 5530 laptop a 4k HDMI screen.
Using it with 200% zoom makes xorg crash.
I have used proprietary 430, and changed to recommended proprietary 435 nvidia 
driver.
As the system was still very unstable (no to say unusable) I had a go with 440 
from ppa.
I also ensured that my system was up to date doing a sudo apt-get update and 
upgrade. I was suprised to discover a few packages that needed an upgrade 
although I had previously used the Software Updater tool. Maybe I was doing 
something wrong.
Anyway, with these updates and the newer 440 driver, I have successfully worked 
a day (sparsely) without problem, and using only 100% zoom.
As a test, I decided to try to set the zoom to 200% (through devices > display, 
and I have only the external display enabled).
After several minutes, I clicked on the « full screen » icon to maximize a 
shell, and the PC froze.
It was so close to my change in the zoom ratio, that I suspect this is related.

dmesg shew me that NVRM had a problem :
[97501.301998] NVRM: GPU at PCI::01:00: 
GPU-dee28f75-4083-96a8-1a0b-491b6109101a
[97501.302000] NVRM: Xid (PCI::01:00): 32, pid=493, Channel ID 0018 
intr 0004
[97501.302134] NVRM: Xid (PCI::01:00): 32, pid=2052, Channel ID 0018 
intr 0020
[97501.317307] NVRM: Xid (PCI::01:00): 69, pid=902, Class Error: ChId 001b, 
Class 902d, Offset 0250, Data 55d3, ErrorCode 000c

pid 493 is gone

pid 2052 is xorg
stan  2052  2050  1 mars20 tty200:25:38 /usr/lib/xorg/Xorg vt2 
-displayfd 3 -auth /run/user/1000/gdm/Xauthority -background none -noreset 
-keeptty -verbose 3

pid 902 is nvidia driver
root   902 2  0 mars20 ?   00:02:59 [irq/163-nvidia]

ppid 2052 is 2050 :
stan  2050  2004  0 mars20 tty200:00:00 /usr/lib/gdm3/gdm-x-session 
--run-script env GNOME_SHELL_SESSION_MODE=ubuntu /usr/bin/gnome-session 
--systemd --session=ubuntu

After such an event, the previous days, the system became unstable, and
I have got problems with other devices such as audio and network.

If I run the manufacturer self-check test, everything is fine.

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: xorg 1:7.7+19ubuntu12
ProcVersionSignature: Ubuntu 5.3.0-42.34-generic 5.3.18
Uname: Linux 5.3.0-42-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
.proc.driver.nvidia.gpus..01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:01:00.0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.suspend: suspend hibernate resume
.proc.driver.nvidia.suspend_depth: default modeset uvm
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
 GCC version:  gcc version 9.2.1 20191008 (Ubuntu 9.2.1-9ubuntu2)
ApportVersion: 2.20.11-0ubuntu8.6
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Sat Mar 21 18:36:53 2020
DistUpgraded: 2019-11-04 11:06:46,434 ERROR got error from PostInstallScript 
./xorg_fix_proprietary.py (g-exec-error-quark: Failed to execute child process 
“./xorg_fix_proprietary.py” (No such file or directory) (8))
DistroCodename: eoan
DistroVariant: ubuntu
DkmsStatus:
 nvidia, 440.64, 5.3.0-42-generic, x86_64: installed
 virtualbox, 6.0.14, 5.3.0-40-generic, x86_64: installed
 virtualbox, 6.0.14, 5.3.0-42-generic, x86_64: installed
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation UHD Graphics 630 (Mobile) [8086:3e9b] (prog-if 00 [VGA 
controller])
   Subsystem: Dell UHD Graphics 630 (Mobile) [1028:087d]
   Subsystem: Dell GP107GLM [Quadro P2000 Mobile] [1028:087d]
InstallationDate: Installed on 2019-04-26 (329 days ago)
InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
MachineType: Dell Inc. Precision 5530
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-42-generic 
root=UUID=2262d308-663c-47c3-9e75-b34611c8df1d ro nouveau.blacklist=1 
acpi_rev_override=1 acpi_osi=Linux nouveau.modeset=0 pcie_aspm=force 
drm.vblankoffdelay=1 scsi_mod.use_blk_mq=1 nouveau.runpm=0 
mem_sleep_default=deep quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: Upgraded to eoan on 2019-11-04 (138 days ago)
dmi.bios.date: 12/25/2019
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.15.0
dmi.board.name: 0N0DK2
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 10
dmi.chassis.vendor: Dell Inc.
dmi.modalias: 
dmi:bvnDellInc.:bvr1.15.0:bd12/25/2019:svnDellInc.:pnPrecision5530:pvr:rvnDellInc.:rn0N0DK2:rvrA00:cvnDellInc.:ct10:cvr:
dmi.product.family: Precision
dmi.product.name: Precision 5530
dmi.product.sku: 087D
dmi.sys.vendor: Dell Inc.
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.99-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 19.2.8-0ubuntu0~19.10.3
version.libgl1-mesa-glx: libgl1-mesa-glx N/A

[Touch-packages] [Bug 1840725] Re: Microphone not working in Ubuntu 18.04.3 LTS on new hp-spectre-x360-convertible-15 laptop

2020-03-21 Thread tobson
same on my Dell G3 15 3590 no sound after updating to kernel 5.3.0-42. The 
mentioned workaround in #28 solves the issue for the speakers. However, only 
'snd_hda_intel.dmic_detect=0' was necessary.
I tested the mainline Kernel (5.5.11) with the same result but here one has to 
use 'snd-intel-dspcfg.dsp_driver=1' to the sound running again.
(found it here: https://bugzilla.kernel.org/show_bug.cgi?id=205959)

as in #28 the microphone is still not working yet but with the addition
of 'options snd-hda-intel index=0 model=laptop-dmic' to '/etc/modprobe.d
/alsa-base.conf' it appears for the first time.

** Bug watch added: Linux Kernel Bug Tracker #205959
   https://bugzilla.kernel.org/show_bug.cgi?id=205959

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1840725

Title:
  Microphone not working in Ubuntu 18.04.3 LTS on new hp-
  spectre-x360-convertible-15 laptop

Status in alsa-driver package in Ubuntu:
  Confirmed

Bug description:
  Internal Microphone does not work in Ubuntu 18.04.3 LTS in a new hp-
  spectre-x360-convertible-15 laptop. The microphone works perfectly on
  Windows 10 (present in Dual boot mode).

  Initially, Internal Microphone was not even detected but installing
  alsa-tools-gui and overriding pin 0x12 to the Internal Microphone
  fixed that issue. [Pin 0x13 does not work and causes static in a
  headphone if it is plugged in.]

  Microphone is not able to pick up any sound. I changed levels/settings in 
alsamixer, pavucontrol without any success:
  In alsamixer: Experimented with levels ranging from very low to very high for 
Internal Mic, Capture, etc.
  In pavucontrol: Set the Internal Mic as a fallback device, unlocked the 
channels for the mic, experimented with reducing the level for one of the 
channels (reduced right mic level to Silence while keeping the left mic level 
normal/high and vice versa).

  alsa-info:
  http://alsa-project.org/db/?f=cf6d3ccc6372f955da7d99df07afbcb31d5a6c7f

  arecord -l
   List of CAPTURE Hardware Devices 
  card 0: PCH [HDA Intel PCH], device 0: ALC285 Analog [ALC285 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1840725/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868353] Re: regression: Bose SL III works in bionic but not in focal

2020-03-21 Thread Sebastien Bacher
Thanks!

** Changed in: pulseaudio (Ubuntu)
   Importance: Undecided => High

** Changed in: pulseaudio (Ubuntu)
   Status: New => Triaged

** Changed in: pulseaudio (Ubuntu)
   Importance: High => Low

** Also affects: pulseaudio via
   https://gitlab.freedesktop.org/pulseaudio/pulseaudio/issues/830
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1868353

Title:
  regression: Bose SL III works in bionic but not in focal

Status in PulseAudio:
  Unknown
Status in pulseaudio package in Ubuntu:
  Triaged

Bug description:
  blueman-manager successfully pairs and connects to the Bose SL III in
  both bionic and in focal.  in bionic, the Bose SL III then immediately
  shows up in pavucontrol.  in focal, it remains absent.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: pulseaudio 1:13.99.1-1ubuntu1
  ProcVersionSignature: Ubuntu 5.4.0-14.17-generic 5.4.18
  Uname: Linux 5.4.0-14-generic x86_64
  ApportVersion: 2.20.11-0ubuntu20
  Architecture: amd64
  Date: Fri Mar 20 19:53:54 2020
  InstallationDate: Installed on 2020-03-15 (5 days ago)
  InstallationMedia: Lubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200314)
  ProcEnviron:
   LC_TIME=en_DK.utf8
   TERM=screen
   PATH=(custom, no user)
   LANG=en_US.utf8
   SHELL=/bin/bash
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
  SourcePackage: pulseaudio
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 06/20/2018
  dmi.bios.vendor: LENOVO
  dmi.bios.version: J9ETA2WW (2.28 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20C6008SUS
  dmi.board.vendor: LENOVO
  dmi.board.version: 0B98401 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: 
dmi:bvnLENOVO:bvrJ9ETA2WW(2.28):bd06/20/2018:svnLENOVO:pn20C6008SUS:pvrThinkPadEdgeE540:rvnLENOVO:rn20C6008SUS:rvr0B98401WIN:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.family: ThinkPad Edge E540
  dmi.product.name: 20C6008SUS
  dmi.product.sku: LENOVO_MT_20C6_BU_Think_FM_ThinkPad Edge E540
  dmi.product.version: ThinkPad Edge E540
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/pulseaudio/+bug/1868353/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868392] Re: Touchscreen not working in 5.3.0-42

2020-03-21 Thread Johan
Forgot to say, the bug report was done with kernel 5.3.0-40 with a
working touch screen.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1868392

Title:
  Touchscreen not working in 5.3.0-42

Status in xorg package in Ubuntu:
  New

Bug description:
  My Asus Zenbook touch screen works in 5.3.0-40, but stops working when
  I boot into the 5.3.0-42 kernel.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: xorg 1:7.7+19ubuntu12
  ProcVersionSignature: Ubuntu 5.3.0-40.32-generic 5.3.18
  Uname: Linux 5.3.0-40-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  .proc.driver.nvidia.gpus..02.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:02:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  435.21  Sun Aug 25 08:17:57 
CDT 2019
   GCC version:  gcc version 9.2.1 20191008 (Ubuntu 9.2.1-9ubuntu2)
  ApportVersion: 2.20.11-0ubuntu8.6
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: KDE
  Date: Sat Mar 21 17:52:19 2020
  DistUpgraded: Fresh install
  DistroCodename: eoan
  DistroVariant: ubuntu
  DkmsStatus:
   nvidia, 435.21, 5.3.0-40-generic, x86_64: installed
   nvidia, 435.21, 5.3.0-42-generic, x86_64: installed
   virtualbox, 6.0.14, 5.3.0-40-generic, x86_64: installed
   virtualbox, 6.0.14, 5.3.0-42-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Device [8086:9b41] (rev 02) (prog-if 00 [VGA controller])
 Subsystem: ASUSTeK Computer Inc. Device [1043:13ff]
 Subsystem: ASUSTeK Computer Inc. GP108BM [GeForce MX250] [1043:13ff]
  InstallationDate: Installed on 2020-02-11 (38 days ago)
  InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 13d3:56cb IMC Networks USB2.0 HD IR UVC WebCam
   Bus 001 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
   Bus 001 Device 004: ID 8087:0026 Intel Corp. 
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: ASUSTeK COMPUTER INC. ZenBook UX481FL_UX481FL
  ProcEnviron:
   LANGUAGE=en_ZA:en
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=af_ZA.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-40-generic 
root=UUID=c157ba74-8933-4447-9f11-e965279079be ro quiet splash vt.handoff=7
  SourcePackage: xorg
  Symptom: display
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/06/2019
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: UX481FL.206
  dmi.board.asset.tag: ATN12345678901234567
  dmi.board.name: UX481FL
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: 1.0
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: ASUSTeK COMPUTER INC.
  dmi.chassis.version: 1.0
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrUX481FL.206:bd08/06/2019:svnASUSTeKCOMPUTERINC.:pnZenBookUX481FL_UX481FL:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnUX481FL:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
  dmi.product.family: ZenBook
  dmi.product.name: ZenBook UX481FL_UX481FL
  dmi.product.version: 1.0
  dmi.sys.vendor: ASUSTeK COMPUTER INC.
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.99-1ubuntu1
  version.libgl1-mesa-dri: libgl1-mesa-dri 19.2.8-0ubuntu0~19.10.3
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.5+git20191008-0ubuntu1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.0.1-1ubuntu1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1868392/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868392] [NEW] Touchscreen not working in 5.3.0-42

2020-03-21 Thread Johan
Public bug reported:

My Asus Zenbook touch screen works in 5.3.0-40, but stops working when I
boot into the 5.3.0-42 kernel.

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: xorg 1:7.7+19ubuntu12
ProcVersionSignature: Ubuntu 5.3.0-40.32-generic 5.3.18
Uname: Linux 5.3.0-40-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
.proc.driver.nvidia.gpus..02.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:02:00.0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.suspend: suspend hibernate resume
.proc.driver.nvidia.suspend_depth: default modeset uvm
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module  435.21  Sun Aug 25 08:17:57 
CDT 2019
 GCC version:  gcc version 9.2.1 20191008 (Ubuntu 9.2.1-9ubuntu2)
ApportVersion: 2.20.11-0ubuntu8.6
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CompositorRunning: None
CurrentDesktop: KDE
Date: Sat Mar 21 17:52:19 2020
DistUpgraded: Fresh install
DistroCodename: eoan
DistroVariant: ubuntu
DkmsStatus:
 nvidia, 435.21, 5.3.0-40-generic, x86_64: installed
 nvidia, 435.21, 5.3.0-42-generic, x86_64: installed
 virtualbox, 6.0.14, 5.3.0-40-generic, x86_64: installed
 virtualbox, 6.0.14, 5.3.0-42-generic, x86_64: installed
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation Device [8086:9b41] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:13ff]
   Subsystem: ASUSTeK Computer Inc. GP108BM [GeForce MX250] [1043:13ff]
InstallationDate: Installed on 2020-02-11 (38 days ago)
InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 13d3:56cb IMC Networks USB2.0 HD IR UVC WebCam
 Bus 001 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
 Bus 001 Device 004: ID 8087:0026 Intel Corp. 
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: ASUSTeK COMPUTER INC. ZenBook UX481FL_UX481FL
ProcEnviron:
 LANGUAGE=en_ZA:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=
 LANG=af_ZA.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-40-generic 
root=UUID=c157ba74-8933-4447-9f11-e965279079be ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/06/2019
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: UX481FL.206
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: UX481FL
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrUX481FL.206:bd08/06/2019:svnASUSTeKCOMPUTERINC.:pnZenBookUX481FL_UX481FL:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnUX481FL:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.family: ZenBook
dmi.product.name: ZenBook UX481FL_UX481FL
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.99-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 19.2.8-0ubuntu0~19.10.3
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.5+git20191008-0ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.0.1-1ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug eoan kubuntu ubuntu

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1868392

Title:
  Touchscreen not working in 5.3.0-42

Status in xorg package in Ubuntu:
  New

Bug description:
  My Asus Zenbook touch screen works in 5.3.0-40, but stops working when
  I boot into the 5.3.0-42 kernel.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: xorg 1:7.7+19ubuntu12
  ProcVersionSignature: Ubuntu 5.3.0-40.32-generic 5.3.18
  Uname: Linux 5.3.0-40-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  .proc.driver.nvidia.gpus..02.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:02:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  435.21  Sun Aug 25 08:17:57 
CDT 2019
   GCC version:  gcc version 9.2.1 20191008 (Ubuntu 9.2.1-9ubuntu2)
  ApportVersion: 2.20.11-0ubuntu8.6
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: 

[Touch-packages] [Bug 1859754] Re: add ucm to make alsa/sof driver work under PA (variants of Lenovo X1 Carbon 7th, Dell cnl and cml machines)

2020-03-21 Thread Jean-
After enabling selective updates from proposed, I ran

> sudo apt install linux-image-5.3.0-43-generic 
> linux-modules-extra-5.3.0-43-generic linux-firmware/eoan-proposed 
> libasound2/eoan-proposed
> sudo add-apt-repository ppa:hui.wang/audio-master
> sudo apt-get update
> sudo apt install libasound2

I removed "options snd-hda-intel dmic_detect=0" from /etc/modprobe.d
/alsa-base.conf and restarted.

I can see the onboard sound card and microphone in gnome's interface. I used 
alsa mixer to maxout all levels. 
I was able to record sound and play it back using sound recorder
I was able to  play music from spotify and youtube
I was unable to use the "test" feature of gnome settings : I can open the 
window, but neither the front right nor front left buttons in the test play any 
sound

Connecting my bluetooth headset correctly switched output automatically
to the headset but didn't switch input to the headset. I was however
able to manually set input to the headset. disconnecting and
reconnecting the headset after manually selecting it didn't fix the
autoselection of the microphone but that feels like an unrelated issue.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-lib in Ubuntu.
https://bugs.launchpad.net/bugs/1859754

Title:
  add ucm to make alsa/sof driver work under PA (variants of Lenovo X1
  Carbon 7th, Dell cnl and cml machines)

Status in HWE Next:
  New
Status in alsa-lib package in Ubuntu:
  Fix Committed
Status in alsa-lib source package in Bionic:
  Fix Committed
Status in alsa-lib source package in Eoan:
  Fix Committed

Bug description:
  This ucm is only for Eoan and Bionic, for focal and future versions,
  we plan to integrate the ucm2 instead of this ucm, and the ucm2
  depends on the alsa-lib-1.2.1 and pluseaudio-v14, the ucm2 is under
  developing by the community, is not ready yet.

  [Impact]
  In the oem project, we have a couple of Lenovo and Dell machines which
  connect the digital mic to PCH directly, this design needs the new
  sound driver soc/sof, and this driver can't work under pulseaudio
  automatically, we need to integrate the ucm for the driver, then the
  sof dirver could work under pulseaudio and gnome.

  This ucm is maintained by intel audio team, and it is not upstreamed
  and will not be upstreamed, since the community is developing the ucm2
  which is based on at least alsa-lib-1.2.1 and pulseaudio-v14.0 (still
  under developing), for bionic and eoan, we have to integrate this ucm
  since the alsa-lib version is too low. For focal and future version, we
  are going to integrate the ucm2 after the ucm2 is ready.

  This ucm is already verified in the oem project, now it is time to put it
  into the stock ubuntu. 

  [Fix]
  These ucm files are backported from sof_ucm1 branch of
  https://github.com/thesofproject/alsa-ucm-conf.git

  [Test Case]
  Boot the eoan kernel or oem-osp1-bionic kernel, then check the log of
  pulseaudio, the ucm files are loaded successfully, then check the
  gnome-sound-setting, both output and input devices work well.

  [Regression Risk]
  Low, just add some new ucm files, and this will not affect other machines,
  and those new added ucm files are only used by specific machines which enable
  the sof driver.

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/1859754/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1865907] Re: Loading IM context type 'ibus' failed

2020-03-21 Thread Gunnar Hjalmarsson
Reopening the ibus task, since there is a fix in Debian which will
prevent this issue from showing up going forward.

** Changed in: ibus (Ubuntu)
   Status: Fix Released => In Progress

** Changed in: ibus (Ubuntu)
 Assignee: (unassigned) => Gunnar Hjalmarsson (gunnarhj)

** Bug watch added: Debian Bug tracker #954207
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=954207

** Also affects: glib2.0 (Debian) via
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=954207
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to glib2.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1865907

Title:
  Loading IM context type 'ibus' failed

Status in glib2.0 package in Ubuntu:
  Fix Released
Status in ibus package in Ubuntu:
  In Progress
Status in glib2.0 package in Debian:
  Unknown

Bug description:
  Regression issue caused by recent system updates on Ubuntu 20.04 Focal
  Fossa (development branch)

  Many(or to say, most) applications,like eclipse,lazarus,gnome-shell,gedit... 
reported below error in syslog or console as,
  ...
  (lazarus-ide:20387): Gtk-WARNING **: 00:11:55.562: Loading IM context type 
'ibus' failed
  (lazarus-ide:20387): Gtk-WARNING **: 00:11:55.566: GModule 
(/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-ibus.so) initialization 
check failed: GLib version too old (micro mismatch)
  ...

  and Pinyin input method does not work in these applications.

  Symptom occurs since I updated below 17 packages some hours before,
  gir1.2-ibus-1.0
  gvfs
  gvfs-backends
  gvfs-bin
  gvfs-common
  gvfs-daemons
  gvfs-fuse
  gvfs-libs
  ibus
  ibus-data
  ibus-gtk
  ibus-gtk3
  libglib2.0-0
  libgtk-3-0
  libgtk2.0-0
  libibus-1.0-5
  python3-ibus-1.0

  current versions of above packages are,
  gir1.2-ibus-1.0/focal,now 1.5.22-1~exp1ubuntu1 amd64 [installed]
  gvfs/focal,now 1.43.92-1ubuntu1 amd64 [installed]
  gvfs-backends/focal,now 1.43.92-1ubuntu1 amd64 [installed,automatic]
  gvfs-bin/focal,now 1.43.92-1ubuntu1 amd64 [installed]
  gvfs-common/focal,focal,now 1.43.92-1ubuntu1 all [installed]
  gvfs-daemons/focal,now 1.43.92-1ubuntu1 amd64 [installed]
  gvfs-fuse/focal,now 1.43.92-1ubuntu1 amd64 [installed]
  gvfs-libs/focal,now 1.43.92-1ubuntu1 amd64 [installed]
  ibus/focal,now 1.5.22-1~exp1ubuntu1 amd64 [installed,automatic]
  ibus-data/focal,focal,now 1.5.22-1~exp1ubuntu1 all [installed,automatic]
  ibus-gtk/focal,now 1.5.22-1~exp1ubuntu1 amd64 [installed]
  ibus-gtk3/focal,now 1.5.22-1~exp1ubuntu1 amd64 [installed]
  libglib2.0-0/focal,now 2.63.5-2 amd64 [installed]
  libgtk-3-0/focal,now 3.24.13-1ubuntu1 amd64 [installed]
  libgtk2.0-0/focal,now 2.24.32-4ubuntu4 amd64 [installed]
  libibus-1.0-5/focal,now 1.5.22-1~exp1ubuntu1 amd64 [installed]
  python3-ibus-1.0/focal,focal,now 1.5.22-1~exp1ubuntu1 all 
[installed,automatic]

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/glib2.0/+bug/1865907/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868353] Re: regression: Bose SL III works in bionic but not in focal

2020-03-21 Thread gregrwm
done:  https://gitlab.freedesktop.org/pulseaudio/pulseaudio/issues/830

** Bug watch added: PulseAudio #830
   https://gitlab.freedesktop.org/pulseaudio/pulseaudio/issues/830

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1868353

Title:
  regression: Bose SL III works in bionic but not in focal

Status in pulseaudio package in Ubuntu:
  New

Bug description:
  blueman-manager successfully pairs and connects to the Bose SL III in
  both bionic and in focal.  in bionic, the Bose SL III then immediately
  shows up in pavucontrol.  in focal, it remains absent.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: pulseaudio 1:13.99.1-1ubuntu1
  ProcVersionSignature: Ubuntu 5.4.0-14.17-generic 5.4.18
  Uname: Linux 5.4.0-14-generic x86_64
  ApportVersion: 2.20.11-0ubuntu20
  Architecture: amd64
  Date: Fri Mar 20 19:53:54 2020
  InstallationDate: Installed on 2020-03-15 (5 days ago)
  InstallationMedia: Lubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200314)
  ProcEnviron:
   LC_TIME=en_DK.utf8
   TERM=screen
   PATH=(custom, no user)
   LANG=en_US.utf8
   SHELL=/bin/bash
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
  SourcePackage: pulseaudio
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 06/20/2018
  dmi.bios.vendor: LENOVO
  dmi.bios.version: J9ETA2WW (2.28 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20C6008SUS
  dmi.board.vendor: LENOVO
  dmi.board.version: 0B98401 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: 
dmi:bvnLENOVO:bvrJ9ETA2WW(2.28):bd06/20/2018:svnLENOVO:pn20C6008SUS:pvrThinkPadEdgeE540:rvnLENOVO:rn20C6008SUS:rvr0B98401WIN:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.family: ThinkPad Edge E540
  dmi.product.name: 20C6008SUS
  dmi.product.sku: LENOVO_MT_20C6_BU_Think_FM_ThinkPad Edge E540
  dmi.product.version: ThinkPad Edge E540
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1868353/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868352] Re: grub2 2.04-1ubuntu12.2 breaks boot on some machines

2020-03-21 Thread Joseph Yasi
I filed this against grub2 originally. Somehow ubuntu-bug changed that
to xorg. I added grub2 back. It's not letting me remove xorg.

** Also affects: grub2 (Ubuntu)
   Importance: Undecided
   Status: New

** No longer affects: xorg (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1868352

Title:
  grub2 2.04-1ubuntu12.2 breaks boot on some machines

Status in grub2 package in Ubuntu:
  New

Bug description:
  2.04-1ubuntu12.2 broke boot on my machine. It doesn't work with
  kernels that don't have CONFIG_EFI_STUB=y configured. This really
  needs to fall back to the old mode if EFI handover is not supported by
  the kernel.

  Also, after using a kernel with CONFIG_EFI_STUB=y it still failed to
  boot one of my machines with root specified by UUID. I was able to
  workaround it by manually specifying the boot device with
  /dev/nvme0n1p2 at the grub menu, and then specifying
  GRUB_DISABLE_LINUX_UUID=true in /etc/default/grub.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: xorg 1:7.7+19ubuntu12
  Uname: Linux 5.5.10-customskl x86_64
  NonfreeKernelModules: zfs zunicode zcommon znvpair zavl icp
  ApportVersion: 2.20.11-0ubuntu8.6
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: KDE
  Date: Fri Mar 20 21:19:01 2020
  DistUpgraded: 2019-10-26 18:15:16,011 DEBUG running apport_crash()
  DistroCodename: eoan
  DistroVariant: ubuntu
  DkmsStatus:
   zfs, 0.8.3, 5.5.10-customskl, x86_64: installed
   zfs, 0.8.3, 5.5.9-customskl, x86_64: installed
  GraphicsCard:
   Intel Corporation UHD Graphics 630 (Desktop) [8086:3e92] (prog-if 00 [VGA 
controller])
 Subsystem: ASUSTeK Computer Inc. UHD Graphics 630 (Desktop) [1043:872f]
  InstallationDate: Installed on 2012-12-04 (2664 days ago)
  InstallationMedia: Kubuntu 12.10 "Quantal Quetzal" - Release amd64 
(20121017.1)
  MachineType: System manufacturer System Product Name
  ProcKernelCmdLine: BOOT_IMAGE=/@/boot/vmlinuz-5.5.10-customskl 
root=/dev/nvme0n1p2 ro rootflags=subvol=@ 
drm_kms_helper.edid_firmware=DP-1:edid/monoprice_28_4k.edid
  SourcePackage: xorg
  Symptom: display
  UpgradeStatus: Upgraded to eoan on 2019-10-26 (146 days ago)
  dmi.bios.date: 10/07/2019
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 2203
  dmi.board.asset.tag: Default string
  dmi.board.name: ROG MAXIMUS X HERO (WI-FI AC)
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Default string
  dmi.chassis.type: 3
  dmi.chassis.vendor: Default string
  dmi.chassis.version: Default string
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr2203:bd10/07/2019:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnROGMAXIMUSXHERO(WI-FIAC):rvrRev1.xx:cvnDefaultstring:ct3:cvrDefaultstring:
  dmi.product.family: To be filled by O.E.M.
  dmi.product.name: System Product Name
  dmi.product.sku: SKU
  dmi.product.version: System Version
  dmi.sys.vendor: System manufacturer
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.100-4~yasi1~19.10
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.2-1ubuntu1~yasi1~19.10
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.2-1ubuntu1~yasi1~19.10
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.5+git20191008-0ubuntu1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20191209.2226.f66d3954-0ubuntu0+yasi1~19.10
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1868352/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868353] Re: regression: Bose SL III works in bionic but not in focal

2020-03-21 Thread Sebastien Bacher
Thank you for your bug report. Could you report that upstream on
https://gitlab.freedesktop.org/pulseaudio/pulseaudio/ ?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1868353

Title:
  regression: Bose SL III works in bionic but not in focal

Status in pulseaudio package in Ubuntu:
  New

Bug description:
  blueman-manager successfully pairs and connects to the Bose SL III in
  both bionic and in focal.  in bionic, the Bose SL III then immediately
  shows up in pavucontrol.  in focal, it remains absent.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: pulseaudio 1:13.99.1-1ubuntu1
  ProcVersionSignature: Ubuntu 5.4.0-14.17-generic 5.4.18
  Uname: Linux 5.4.0-14-generic x86_64
  ApportVersion: 2.20.11-0ubuntu20
  Architecture: amd64
  Date: Fri Mar 20 19:53:54 2020
  InstallationDate: Installed on 2020-03-15 (5 days ago)
  InstallationMedia: Lubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200314)
  ProcEnviron:
   LC_TIME=en_DK.utf8
   TERM=screen
   PATH=(custom, no user)
   LANG=en_US.utf8
   SHELL=/bin/bash
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
  SourcePackage: pulseaudio
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 06/20/2018
  dmi.bios.vendor: LENOVO
  dmi.bios.version: J9ETA2WW (2.28 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20C6008SUS
  dmi.board.vendor: LENOVO
  dmi.board.version: 0B98401 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: 
dmi:bvnLENOVO:bvrJ9ETA2WW(2.28):bd06/20/2018:svnLENOVO:pn20C6008SUS:pvrThinkPadEdgeE540:rvnLENOVO:rn20C6008SUS:rvr0B98401WIN:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.family: ThinkPad Edge E540
  dmi.product.name: 20C6008SUS
  dmi.product.sku: LENOVO_MT_20C6_BU_Think_FM_ThinkPad Edge E540
  dmi.product.version: ThinkPad Edge E540
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1868353/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1865351] Re: Update to poppler 0.86.1 in Focal

2020-03-21 Thread Sebastien Bacher
https://github.com/trueroad/extractpdfmark/issues/2

** Bug watch added: github.com/trueroad/extractpdfmark/issues #2
   https://github.com/trueroad/extractpdfmark/issues/2

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to poppler in Ubuntu.
https://bugs.launchpad.net/bugs/1865351

Title:
  Update to poppler 0.86.1 in Focal

Status in poppler package in Ubuntu:
  New

Bug description:
  Please update to poppler 0.86.1 in Focal

  https://gitlab.freedesktop.org/poppler/poppler/-/blob/master/NEWS

  Release 0.86.1:
  core:
  * Fix regression in Browse Link handling
  * Internal code improvements

  Release 0.86.0:
  core:
  * Fix link content exfiltration attack
  * Splash: Implement gouraudTriangleShadedFill for some non parametrized 
shadings
  * Fix case unsensitive search for Old Hungarian, Warang Citi, Medefaidrin and 
Adlam
  * Internal code improvements

  glib:
  * Automatic handle of page's cropbox on annots. Issue #129
  * Fix memory leak if poppler_document_new_from_file fails
  * Minor speed optimization on poppler_page_get_annot_mapping

  utils:
  * pdfdetach: add 'savefile' option
  * pdftoppm/pdftocairo: Fix more odd/even mismatch

  qt5:
  * Fix loading from iodevice

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/poppler/+bug/1865351/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1865351] Re: Update to poppler 0.86.1 in Focal

2020-03-21 Thread Sebastien Bacher
https://bugs.documentfoundation.org/show_bug.cgi?id=131353 for
libreoffice

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to poppler in Ubuntu.
https://bugs.launchpad.net/bugs/1865351

Title:
  Update to poppler 0.86.1 in Focal

Status in poppler package in Ubuntu:
  New

Bug description:
  Please update to poppler 0.86.1 in Focal

  https://gitlab.freedesktop.org/poppler/poppler/-/blob/master/NEWS

  Release 0.86.1:
  core:
  * Fix regression in Browse Link handling
  * Internal code improvements

  Release 0.86.0:
  core:
  * Fix link content exfiltration attack
  * Splash: Implement gouraudTriangleShadedFill for some non parametrized 
shadings
  * Fix case unsensitive search for Old Hungarian, Warang Citi, Medefaidrin and 
Adlam
  * Internal code improvements

  glib:
  * Automatic handle of page's cropbox on annots. Issue #129
  * Fix memory leak if poppler_document_new_from_file fails
  * Minor speed optimization on poppler_page_get_annot_mapping

  utils:
  * pdfdetach: add 'savefile' option
  * pdftoppm/pdftocairo: Fix more odd/even mismatch

  qt5:
  * Fix loading from iodevice

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/poppler/+bug/1865351/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1865351] Re: Update to poppler 0.86.1 in Focal

2020-03-21 Thread Sebastien Bacher
The poppler update is tricky, as usual they bumped the soname and did some code 
changes that impact other projects. Testing in a ppa e.g libreoffice fails to 
build, and looks like upstream didn't fix that yet. Same of e.g extractpdfmark
https://launchpadlibrarian.net/469668101/buildlog_ubuntu-focal-amd64.extractpdfmark_1.1.0-1ubuntu3_BUILDING.txt.gz

We might look at backporting specific fixes, keeping away from API
changes for this cycle

** Bug watch added: Document Foundation Bugzilla #131353
   https://bugs.documentfoundation.org/show_bug.cgi?id=131353

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to poppler in Ubuntu.
https://bugs.launchpad.net/bugs/1865351

Title:
  Update to poppler 0.86.1 in Focal

Status in poppler package in Ubuntu:
  New

Bug description:
  Please update to poppler 0.86.1 in Focal

  https://gitlab.freedesktop.org/poppler/poppler/-/blob/master/NEWS

  Release 0.86.1:
  core:
  * Fix regression in Browse Link handling
  * Internal code improvements

  Release 0.86.0:
  core:
  * Fix link content exfiltration attack
  * Splash: Implement gouraudTriangleShadedFill for some non parametrized 
shadings
  * Fix case unsensitive search for Old Hungarian, Warang Citi, Medefaidrin and 
Adlam
  * Internal code improvements

  glib:
  * Automatic handle of page's cropbox on annots. Issue #129
  * Fix memory leak if poppler_document_new_from_file fails
  * Minor speed optimization on poppler_page_get_annot_mapping

  utils:
  * pdfdetach: add 'savefile' option
  * pdftoppm/pdftocairo: Fix more odd/even mismatch

  qt5:
  * Fix loading from iodevice

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/poppler/+bug/1865351/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1867972] Re: [FFe] Please accept systemd 245.2-1ubuntu1 to Focal

2020-03-21 Thread Balint Reczey
Thanks! Uploaded.

** Changed in: systemd (Ubuntu)
   Status: Confirmed => Fix Released

** Changed in: systemd (Ubuntu)
   Status: Fix Released => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1867972

Title:
  [FFe] Please accept systemd 245.2-1ubuntu1 to Focal

Status in systemd package in Ubuntu:
  Fix Committed

Bug description:
  Focal currently has 244.3-1ubuntu1.

  Upstream released 245 after the Focal Feature Freeze date, but
  updating to v245 will allow us to carry fewer patches in Focal and
  have the latest upstream fixes without cherry-picking the important
  ones.

  The proposed package is tested in Bileto and there are no unfixed regressions 
compared to the results of the latest tests.
  https://bileto.ubuntu.com/#/ticket/3801

  The fixed gpsd upload invalidated the default excuses page, but it is still 
available at:
  
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_39a8dbb93caf4ec889f8a1b7f69885db/bileto-3801-excuses/2020-03-18_14:40:01/3801_focal_excuses.html

  The changelog is not final in the Bileto PPA, the final one is at:
  
https://code.launchpad.net/~rbalint/ubuntu/+source/systemd/+git/systemd/+ref/ubuntu-focal

  New notable upstream features, such as systemd-homed and systemd-
  repart are _not_ enabled in this upload.

  Please find the full NEWS file at:
  https://github.com/systemd/systemd/blob/v245/NEWS

  There is one notable failing test, netplan.io's which is failing in
  the release pocket, too. I'd like to have this passing, too, with
  systemd 245 before in migrates to the release pocket.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1867972/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp