Re: [Touch-packages] [Bug 1882136] Re: I can't connect to 5GHz wifi

2020-06-04 Thread Szilveszter Balogh
Update history:

less /var/log/apt/history.log

Start-Date: 2020-06-04 11:46:02
Commandline: apt upgrade
Requested-By: szili (1000)
Upgrade: gir1.2-nm-1.0:amd64 (1.22.10-1ubuntu1, 1.22.10-1ubuntu2.1),
gnome-logs:amd64 (3.34.0-1, 3.34.0-1ubuntu1), xserver-common:amd64
(2:1.20.8-2ubuntu2, 2:1.20.8-2ubuntu2.1), xserver-xorg-core:amd64
(2:1.20.8-2ubuntu2, 2:1.20.8-2ubuntu2.1), libgamemode0:amd64
(1.5.1-0ubuntu3, 1.5.1-0ubuntu3.1), gnome-desktop3-data:amd64
(3.36.2-0ubuntu1, 3.36.2-0ubuntu2), gamemode:amd64 (1.5.1-0ubuntu3,
1.5.1-0ubuntu3.1), liblilv-0-0:amd64 (0.24.6-1, 0.24.6-1ubuntu0.1),
google-chrome-stable:amd64 (83.0.4103.61-1, 83.0.4103.97-1),
xserver-xorg-legacy:amd64 (2:1.20.8-2ubuntu2, 2:1.20.8-2ubuntu2.1),
libnm0:amd64 (1.22.10-1ubuntu1, 1.22.10-1ubuntu2.1),
network-manager:amd64 (1.22.10-1ubuntu1, 1.22.10-1ubuntu2.1),
libgamemodeauto0:amd64 (1.5.1-0ubuntu3, 1.5.1-0ubuntu3.1),
libapparmor1:amd64 (2.13.3-7ubuntu5, 2.13.3-7ubuntu5.1),
gir1.2-gnomedesktop-3.0:amd64 (3.36.2-0ubuntu1, 3.36.2-0ubuntu2),
xserver-xephyr:amd64 (2:1.20.8-2ubuntu2, 2:1.20.8-2ubuntu2.1),
libgnome-desktop-3-19:amd64 (3.36.2-0ubuntu1, 3.36.2-0ubuntu2),
xwayland:amd64 (2:1.20.8-2ubuntu2, 2:1.20.8-2ubuntu2.1),
network-manager-config-connectivity-ubuntu:amd64 (1.22.10-1ubuntu1,
1.22.10-1ubuntu2.1), apparmor:amd64 (2.13.3-7ubuntu5, 2.13.3-7ubuntu5.1)
End-Date: 2020-06-04 11:46:26 

The phenomenon is that it tries to connect to 5GHz and then after few
seconds reconnects to the 2.4GHz network. 

I send the log enclosed.

2020-06-04 22:43 időpontban Sebastien Bacher ezt írta:

> Thank you for your bug report, from what version to what version did you 
> update? What error do you get? Could you do 
> $ journalctl -f
> try to connect and copy the log there?
> 
> ** Changed in: network-manager (Ubuntu)
> Status: New => Incomplete
> 
> -- 
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1882136
> 
> Title:
> I can't connect to 5GHz wifi
> 
> Status in network-manager package in Ubuntu:
> Incomplete
> 
> Bug description:
> After updating the NetworkManager I can't connect to 5GHz wifi. The
> router is a mikrotik hap ac2.The notebook is a Dell Latitude 5580.
> 
> ProblemType: Bug
> DistroRelease: Ubuntu 20.04
> Package: network-manager 1.22.10-1ubuntu2.1
> ProcVersionSignature: Ubuntu 5.4.0-33.37-generic 5.4.34
> Uname: Linux 5.4.0-33-generic x86_64
> ApportVersion: 2.20.11-0ubuntu27.2
> Architecture: amd64
> CasperMD5CheckResult: skip
> CurrentDesktop: ubuntu:GNOME
> Date: Thu Jun  4 22:20:15 2020
> InstallationDate: Installed on 2020-05-15 (20 days ago)
> InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
> ProcEnviron:
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=
> LANG=hu_HU.UTF-8
> SHELL=/bin/bash
> SourcePackage: network-manager
> UpgradeStatus: No upgrade log present (probably fresh install)
> nmcli-nm:
> RUNNING  VERSION  STATE  STARTUP  CONNECTIVITY  NETWORKING  WIFI-HW  WIFI 
> WWAN-HW  WWAN
> running  1.22.10  connected  started  full  enabled enabled  
> enabled  enabled  enabled
> 
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1882136/+subscriptions

** Attachment added: "journalctl.txt"
   
https://bugs.launchpad.net/bugs/1882136/+attachment/5380527/+files/journalctl.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1882136

Title:
  I can't connect to 5GHz wifi

Status in network-manager package in Ubuntu:
  Incomplete

Bug description:
  After updating the NetworkManager I can't connect to 5GHz wifi. The
  router is a mikrotik hap ac2.The notebook is a Dell Latitude 5580.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: network-manager 1.22.10-1ubuntu2.1
  ProcVersionSignature: Ubuntu 5.4.0-33.37-generic 5.4.34
  Uname: Linux 5.4.0-33-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.2
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Jun  4 22:20:15 2020
  InstallationDate: Installed on 2020-05-15 (20 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  ProcEnviron:
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=hu_HU.UTF-8
   SHELL=/bin/bash
  SourcePackage: network-manager
  UpgradeStatus: No upgrade log present (probably fresh install)
  nmcli-nm:
   RUNNING  VERSION  STATE  STARTUP  CONNECTIVITY  NETWORKING  WIFI-HW  
WIFI WWAN-HW  WWAN
   running  1.22.10  connected  started  full  enabled enabled  
enabled  enabled  enabled

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1882136/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : 

[Touch-packages] [Bug 1867424] Re: motd-news transmitting private hardware data without consent or knowledge in background

2020-06-04 Thread Guy Baconniere
Thanks Canonical for this great Telemetry master piece
hidden in a Daily "News" (Message of the Day) deep inside
the core of Ubuntu.

I found it active on all the Ubuntu laptop of my friends
and coworkers, all Ubuntu servers from local ISP and my
work. As well as on all Ubuntu flavours and Ubuntu derived
Linux distros.

It is also present in cloud-init images of major cloud providers,
and all Docker images from Docker Registry based on Ubuntu.

What a (s)hell for transparency!

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to base-files in Ubuntu.
https://bugs.launchpad.net/bugs/1867424

Title:
  motd-news transmitting private hardware data without consent or
  knowledge in background

Status in base-files package in Ubuntu:
  Confirmed

Bug description:
  In package base-files there is a script /etc/update-motd.d/50-motd-
  news that harvests private hardware data from the machine and
  transmits it in the background every day.  There is no notice, no
  consent, no nothing.  This should be by default disabled until there
  is informed consent.

  This solution is simple:

  1. Change ENABLED=1 to ENABLED=0 in the file /etc/default/motd-news and 
  2. Place a comment in the file disclosing the fact that the 50-motd-news 
script will harvest private hardware data and upload it to motd.ubuntu.com 
daily if the end-user enables it.

  Creating databases that maps ip address to specify hardware is a
  threat to both privacy and security.  If an adversary knows the
  specific hardware and the ip address for that hardware their ability
  to successfully attack it is greatly increased.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/base-files/+bug/1867424/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1882173] Re: Xorg crash

2020-06-04 Thread Daniel van Vugt
*** This bug is a duplicate of bug 1543192 ***
https://bugs.launchpad.net/bugs/1543192

** Tags added: nvidia

** Summary changed:

- Xorg crash
+ [nvidia] Xorg crash: Fatal server error: no screens found(EE)

** Package changed: xorg (Ubuntu) => xorg-server (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1882173

Title:
  [nvidia] Xorg crash: Fatal server error: no screens found(EE)

Status in xorg-server package in Ubuntu:
  New

Bug description:
  System randomly "hangs" for about 30 seconds before rebooting.  Crash
  has never occurred while system is idle.  I typically am editing code
  with VS code with Chrome and a terminal window open at the save time.
  There does not seem to be a pattern to the crashes.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: xorg 1:7.7+19ubuntu14
  ProcVersionSignature: Ubuntu 5.4.0-33.37-generic 5.4.34
  Uname: Linux 5.4.0-33-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia wl
  .proc.driver.nvidia.gpus..01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:01:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
   GCC version:  gcc version 9.3.0 (Ubuntu 9.3.0-10ubuntu2)
  ApportVersion: 2.20.11-0ubuntu27
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Jun  4 20:29:21 2020
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroVariant: ubuntu
  DkmsStatus:
   bcmwl, 6.30.223.271+bdcom, 5.4.0-31-generic, x86_64: installed
   bcmwl, 6.30.223.271+bdcom, 5.4.0-33-generic, x86_64: installed
   nvidia, 440.64, 5.4.0-31-generic, x86_64: installed
   nvidia, 440.64, 5.4.0-33-generic, x86_64: installed
  ExtraDebuggingInterest: Yes, if not too technical
  GraphicsCard:
   Subsystem: ASUSTeK Computer Inc. Xeon E3-1200 v3/4th Gen Core Processor 
Integrated Graphics Controller [1043:8534]
   NVIDIA Corporation GK104 [GeForce GTX 770] [10de:1184] (rev a1) (prog-if 00 
[VGA controller])
 Subsystem: ASUSTeK Computer Inc. GK104 [GeForce GTX 770] [1043:8465]
  InstallationDate: Installed on 2019-06-10 (361 days ago)
  InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 
(20190210)
  MachineType: ASUS All Series
  ProcEnviron:
   LANGUAGE=en_US
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-33-generic 
root=UUID=90ed235f-b540-4361-b3d0-73a0c0e44038 ro quiet splash 
nvidia-drm.modeset=1 vt.handoff=1
  SourcePackage: xorg
  Symptom: display
  Title: Xorg crash
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 10/27/2015
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 2702
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: Z97-DELUXE
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: To Be Filled By O.E.M.
  dmi.chassis.version: To Be Filled By O.E.M.
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr2702:bd10/27/2015:svnASUS:pnAllSeries:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnZ97-DELUXE:rvrRev1.xx:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
  dmi.product.family: ASUS MB
  dmi.product.name: All Series
  dmi.product.sku: All
  dmi.product.version: System Version
  dmi.sys.vendor: ASUS
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.4-2ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.4-2ubuntu1
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1882173/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1882179] [NEW] package lvm2 2.03.07-1ubuntu1 failed to install/upgrade: installed lvm2 package post-installation script subprocess returned error exit status 1

2020-06-04 Thread Omkar Nath Singh
Public bug reported:

I had run "sudo apt install qemu qemu-kvm libvirt-clients libvirt-
daemon-system bridge-utils virt-manager", when this system problem
detected error came. Please check it if it causes any issue.

ProblemType: Package
DistroRelease: Ubuntu 20.04
Package: lvm2 2.03.07-1ubuntu1
ProcVersionSignature: Ubuntu 5.4.0-33.37-generic 5.4.34
Uname: Linux 5.4.0-33-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20.11-0ubuntu27.2
Architecture: amd64
CasperMD5CheckResult: skip
Date: Fri Jun  5 09:40:05 2020
ErrorMessage: installed lvm2 package post-installation script subprocess 
returned error exit status 1
InstallationDate: Installed on 2019-08-17 (292 days ago)
InstallationMedia: Ubuntu 18.04.3 LTS "Bionic Beaver" - Release amd64 (20190805)
Python3Details: /usr/bin/python3.8, Python 3.8.2, python3-minimal, 
3.8.2-0ubuntu2
PythonDetails: /usr/bin/python2.7, Python 2.7.18rc1, python-is-python2, 2.7.17-4
RelatedPackageVersions:
 dpkg 1.19.7ubuntu3
 apt  2.0.2ubuntu0.1
SourcePackage: lvm2
Title: package lvm2 2.03.07-1ubuntu1 failed to install/upgrade: installed lvm2 
package post-installation script subprocess returned error exit status 1
UpgradeStatus: Upgraded to focal on 2020-05-08 (27 days ago)

** Affects: lvm2 (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package focal

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lvm2 in Ubuntu.
https://bugs.launchpad.net/bugs/1882179

Title:
  package lvm2 2.03.07-1ubuntu1 failed to install/upgrade: installed
  lvm2 package post-installation script subprocess returned error exit
  status 1

Status in lvm2 package in Ubuntu:
  New

Bug description:
  I had run "sudo apt install qemu qemu-kvm libvirt-clients libvirt-
  daemon-system bridge-utils virt-manager", when this system problem
  detected error came. Please check it if it causes any issue.

  ProblemType: Package
  DistroRelease: Ubuntu 20.04
  Package: lvm2 2.03.07-1ubuntu1
  ProcVersionSignature: Ubuntu 5.4.0-33.37-generic 5.4.34
  Uname: Linux 5.4.0-33-generic x86_64
  NonfreeKernelModules: wl
  ApportVersion: 2.20.11-0ubuntu27.2
  Architecture: amd64
  CasperMD5CheckResult: skip
  Date: Fri Jun  5 09:40:05 2020
  ErrorMessage: installed lvm2 package post-installation script subprocess 
returned error exit status 1
  InstallationDate: Installed on 2019-08-17 (292 days ago)
  InstallationMedia: Ubuntu 18.04.3 LTS "Bionic Beaver" - Release amd64 
(20190805)
  Python3Details: /usr/bin/python3.8, Python 3.8.2, python3-minimal, 
3.8.2-0ubuntu2
  PythonDetails: /usr/bin/python2.7, Python 2.7.18rc1, python-is-python2, 
2.7.17-4
  RelatedPackageVersions:
   dpkg 1.19.7ubuntu3
   apt  2.0.2ubuntu0.1
  SourcePackage: lvm2
  Title: package lvm2 2.03.07-1ubuntu1 failed to install/upgrade: installed 
lvm2 package post-installation script subprocess returned error exit status 1
  UpgradeStatus: Upgraded to focal on 2020-05-08 (27 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lvm2/+bug/1882179/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1882173] Re: Xorg crash

2020-06-04 Thread Ubuntu Foundations Team Bug Bot
** Package changed: ubuntu => xorg (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1882173

Title:
  Xorg crash

Status in xorg package in Ubuntu:
  New

Bug description:
  System randomly "hangs" for about 30 seconds before rebooting.  Crash
  has never occurred while system is idle.  I typically am editing code
  with VS code with Chrome and a terminal window open at the save time.
  There does not seem to be a pattern to the crashes.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: xorg 1:7.7+19ubuntu14
  ProcVersionSignature: Ubuntu 5.4.0-33.37-generic 5.4.34
  Uname: Linux 5.4.0-33-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia wl
  .proc.driver.nvidia.gpus..01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:01:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
   GCC version:  gcc version 9.3.0 (Ubuntu 9.3.0-10ubuntu2)
  ApportVersion: 2.20.11-0ubuntu27
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Jun  4 20:29:21 2020
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroVariant: ubuntu
  DkmsStatus:
   bcmwl, 6.30.223.271+bdcom, 5.4.0-31-generic, x86_64: installed
   bcmwl, 6.30.223.271+bdcom, 5.4.0-33-generic, x86_64: installed
   nvidia, 440.64, 5.4.0-31-generic, x86_64: installed
   nvidia, 440.64, 5.4.0-33-generic, x86_64: installed
  ExtraDebuggingInterest: Yes, if not too technical
  GraphicsCard:
   Subsystem: ASUSTeK Computer Inc. Xeon E3-1200 v3/4th Gen Core Processor 
Integrated Graphics Controller [1043:8534]
   NVIDIA Corporation GK104 [GeForce GTX 770] [10de:1184] (rev a1) (prog-if 00 
[VGA controller])
 Subsystem: ASUSTeK Computer Inc. GK104 [GeForce GTX 770] [1043:8465]
  InstallationDate: Installed on 2019-06-10 (361 days ago)
  InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 
(20190210)
  MachineType: ASUS All Series
  ProcEnviron:
   LANGUAGE=en_US
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-33-generic 
root=UUID=90ed235f-b540-4361-b3d0-73a0c0e44038 ro quiet splash 
nvidia-drm.modeset=1 vt.handoff=1
  SourcePackage: xorg
  Symptom: display
  Title: Xorg crash
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 10/27/2015
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 2702
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: Z97-DELUXE
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: To Be Filled By O.E.M.
  dmi.chassis.version: To Be Filled By O.E.M.
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr2702:bd10/27/2015:svnASUS:pnAllSeries:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnZ97-DELUXE:rvrRev1.xx:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
  dmi.product.family: ASUS MB
  dmi.product.name: All Series
  dmi.product.sku: All
  dmi.product.version: System Version
  dmi.sys.vendor: ASUS
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.4-2ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.4-2ubuntu1
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1882173/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1864558] Re: Printer adds automatically at boot with notification or if printer deleted

2020-06-04 Thread Jonathan Kayne
It also seems that the notification repeats at midnight as well

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to cups in Ubuntu.
https://bugs.launchpad.net/bugs/1864558

Title:
  Printer adds automatically at boot with notification or if printer
  deleted

Status in cups package in Ubuntu:
  Confirmed

Bug description:
  When booting 20.04 I get a notification on the logon screen each time
  advising that my wireless printer has been setup. If I remove the
  printer via settings, then as soon as it's removed, it gets re-added
  and I see the same notification as I do on the logon screen about the
  printer having been setup. I've attached a screenshot of this
  notification.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: gnome-control-center 1:3.35.91-0ubuntu1
  ProcVersionSignature: Ubuntu 5.4.0-14.17-generic 5.4.18
  Uname: Linux 5.4.0-14-generic x86_64
  ApportVersion: 2.20.11-0ubuntu18
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Mon Feb 24 21:49:43 2020
  ExecutablePath: /usr/bin/gnome-control-center
  InstallationDate: Installed on 2020-02-24 (0 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200221)
  ProcEnviron:
   LANG=en_GB.UTF-8
   LANGUAGE=en_GB:en
   PATH=(custom, no user)
   SHELL=/bin/bash
   XDG_RUNTIME_DIR=
  SourcePackage: gnome-control-center
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1864558/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1882173] [NEW] Xorg crash

2020-06-04 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

System randomly "hangs" for about 30 seconds before rebooting.  Crash
has never occurred while system is idle.  I typically am editing code
with VS code with Chrome and a terminal window open at the save time.
There does not seem to be a pattern to the crashes.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: xorg 1:7.7+19ubuntu14
ProcVersionSignature: Ubuntu 5.4.0-33.37-generic 5.4.34
Uname: Linux 5.4.0-33-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia wl
.proc.driver.nvidia.gpus..01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:01:00.0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.suspend: suspend hibernate resume
.proc.driver.nvidia.suspend_depth: default modeset uvm
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
 GCC version:  gcc version 9.3.0 (Ubuntu 9.3.0-10ubuntu2)
ApportVersion: 2.20.11-0ubuntu27
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CasperMD5CheckResult: skip
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Thu Jun  4 20:29:21 2020
DistUpgraded: Fresh install
DistroCodename: focal
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 6.30.223.271+bdcom, 5.4.0-31-generic, x86_64: installed
 bcmwl, 6.30.223.271+bdcom, 5.4.0-33-generic, x86_64: installed
 nvidia, 440.64, 5.4.0-31-generic, x86_64: installed
 nvidia, 440.64, 5.4.0-33-generic, x86_64: installed
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Subsystem: ASUSTeK Computer Inc. Xeon E3-1200 v3/4th Gen Core Processor 
Integrated Graphics Controller [1043:8534]
 NVIDIA Corporation GK104 [GeForce GTX 770] [10de:1184] (rev a1) (prog-if 00 
[VGA controller])
   Subsystem: ASUSTeK Computer Inc. GK104 [GeForce GTX 770] [1043:8465]
InstallationDate: Installed on 2019-06-10 (361 days ago)
InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 (20190210)
MachineType: ASUS All Series
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-33-generic 
root=UUID=90ed235f-b540-4361-b3d0-73a0c0e44038 ro quiet splash 
nvidia-drm.modeset=1 vt.handoff=1
SourcePackage: xorg
Symptom: display
Title: Xorg crash
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/27/2015
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 2702
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: Z97-DELUXE
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr2702:bd10/27/2015:svnASUS:pnAllSeries:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnZ97-DELUXE:rvrRev1.xx:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.family: ASUS MB
dmi.product.name: All Series
dmi.product.sku: All
dmi.product.version: System Version
dmi.sys.vendor: ASUS
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.101-2
version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.4-2ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.4-2ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug crash focal ubuntu
-- 
Xorg crash
https://bugs.launchpad.net/bugs/1882173
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to xorg in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1872118] Re: DHCP Cluster crashes after a few hours

2020-06-04 Thread atom
Any update on this? I just spent a few hours troubleshooting this only
to find this bug.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to isc-dhcp in Ubuntu.
https://bugs.launchpad.net/bugs/1872118

Title:
  DHCP Cluster crashes after a few hours

Status in isc-dhcp package in Ubuntu:
  Confirmed

Bug description:
  
  I have a pair of DHCP serevrs running in a cluster on ubuntu 20.04, All 
worked perfectly until recently, when they started stopping with code=killed, 
status=6/ABRT.
  This is being fixed by 

  https://bugs.launchpad.net/bugs/1870729

  However now one stops after a few hours with the following errors. One
  can stay on line but not both.


  
  Syslog shows 
  Apr 10 17:20:15 dhcp-primary sh[6828]: 
../../../../lib/isc/unix/socket.c:3361: INSIST(!sock->pending_send) failed, 
back trace
  Apr 10 17:20:15 dhcp-primary sh[6828]: #0 0x7fbe78702a4a in ??
  Apr 10 17:20:15 dhcp-primary sh[6828]: #1 0x7fbe78702980 in ??
  Apr 10 17:20:15 dhcp-primary sh[6828]: #2 0x7fbe7873e7e1 in ??
  Apr 10 17:20:15 dhcp-primary sh[6828]: #3 0x7fbe784e5609 in ??
  Apr 10 17:20:15 dhcp-primary sh[6828]: #4 0x7fbe78621103 in ??

  
  nothing in kern.log

  
  apport.log shows
  ERROR: apport (pid 6850) Fri Apr 10 17:20:15 2020: called for pid 6828, 
signal 6, core limit 0, dump mode 2
  ERROR: apport (pid 6850) Fri Apr 10 17:20:15 2020: not creating core for pid 
with dump mode of 2
  ERROR: apport (pid 6850) Fri Apr 10 17:20:15 2020: executable: 
/usr/sbin/dhcpd (command line "dhcpd -user dhcpd -group dhcpd -f -4 -pf 
/run/dhcp-server/dhcpd.pid -cf /etc/dhcp/dhcpd.conf")
  ERROR: apport (pid 6850) Fri Apr 10 17:20:15 2020: is_closing_session(): no 
DBUS_SESSION_BUS_ADDRESS in environment
  ERROR: apport (pid 6850) Fri Apr 10 17:20:15 2020: wrote report 
/var/crash/_usr_sbin_dhcpd.0.crash


  /var/crash/_usr_sbin_dhcpd.0.crash shows

  ProblemType: Crash
  Architecture: amd64
  CrashCounter: 1
  Date: Fri Apr 10 17:20:15 2020
  DistroRelease: Ubuntu 20.04
  ExecutablePath: /usr/sbin/dhcpd
  ExecutableTimestamp: 1586210315
  ProcCmdline: dhcpd -user dhcpd -group dhcpd -f -4 -pf 
/run/dhcp-server/dhcpd.pid -cf /etc/dhcp/dhcpd.conf
  ProcEnviron: Error: [Errno 13] Permission denied: 'environ'
  ProcMaps: Error: [Errno 13] Permission denied: 'maps'
  ProcStatus:
   Name:  dhcpd
   Umask: 0022
   State: D (disk sleep)
   Tgid:  6828
   Ngid:  0
   Pid:   6828
   PPid:  1
   TracerPid: 0
   Uid:   113 113 113 113
   Gid:   118 118 118 118
   FDSize:128
   Groups:
   NStgid:6828
   NSpid: 6828
   NSpgid:6828
   NSsid: 6828
   VmPeak:  236244 kB
   VmSize:  170764 kB
   VmLck:0 kB
   VmPin:0 kB
   VmHWM:12064 kB
   VmRSS:12064 kB
   RssAnon:   5940 kB
   RssFile:   6124 kB
   RssShmem: 0 kB
   VmData:   30792 kB
   VmStk:  132 kB
   VmExe:  592 kB
   VmLib: 5424 kB
   VmPTE:   76 kB
   VmSwap:   0 kB
   HugetlbPages: 0 kB
   CoreDumping:   1
   THP_enabled:   1
   Threads:   4
   SigQ:  0/7609
   SigPnd:
   ShdPnd:
   SigBlk:
   SigIgn:1000
   SigCgt:00018000
   CapInh:
   CapPrm:
   CapEff:
   CapBnd:003f
   CapAmb:
   NoNewPrivs:0
   Seccomp:   0
   Speculation_Store_Bypass:  thread vulnerable
   Cpus_allowed:  3
   Cpus_allowed_list: 0-1
   Mems_allowed:  
,,,,,,,,,,,,,,,,,,,,,,,,,,,,
  ,,,0001
   Mems_allowed_list: 0
   voluntary_ctxt_switches:   111
   nonvoluntary_ctxt_switches:144
  Signal: 6
  Uname: Linux 5.4.0-21-generic x86_64
  UserGroups:

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/isc-dhcp/+bug/1872118/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1881812] Re: gdm can't open session for ldap users with usernames that begin with a number

2020-06-04 Thread Bug Watch Updater
** Changed in: systemd
   Status: Unknown => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1881812

Title:
  gdm can't open session for ldap users with usernames that begin with a
  number

Status in gdm:
  Unknown
Status in systemd:
  Fix Released
Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  Description:Ubuntu 20.04 LTS

  with ubuntu-desktop and libnss-ldapd

  Trying to log in to the desktop environment when the username (e.g
  9912345) begins with a number results in a black screen, and then
  quits back to the log in screen.

  Here is the error:
  `...gdm-password][5010]: pam_systemd(gdm-password:session): Failed to get 
user record: Invalid argument`

  However, these users can log-in via ssh, and via TTY without issue.

  This error does not occur if I log in with other users, without a
  number (e.g. test.user)

  Also, the error does not occur if I switch to LightDM.  With LightDM,
  a username such as 9912345 can login to the desktop desktop
  environment.

  $ apt-cache policy gdm3
  gdm3:
Installed: 3.34.1-1ubuntu1
Candidate: 3.34.1-1ubuntu1
Version table:
   *** 3.34.1-1ubuntu1 500
  500 http://ca.archive.ubuntu.com/ubuntu focal/main amd64 Packages
  100 /var/lib/dpkg/status

To manage notifications about this bug go to:
https://bugs.launchpad.net/gdm/+bug/1881812/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1882112] Re: Xorg freeze

2020-06-04 Thread Daniel van Vugt
This detail:

> The cursor stays active but ineffective.

suggests that Xorg is still running and it's only the compositor
(compiz/unity) that's having trouble.

** Tags added: radeon

** Summary changed:

- Xorg freeze
+ [radeon] Xorg freeze

** Summary changed:

- [radeon] Xorg freeze
+ [radeon] Screen freeze

** Package changed: xorg (Ubuntu) => compiz (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1882112

Title:
  [radeon] Screen freeze

Status in compiz package in Ubuntu:
  Incomplete
Status in xorg-server package in Ubuntu:
  Incomplete

Bug description:
  This may be correlated to the move to Bionic Beaver(?) LTS, now
  18.04.4.  It may also be correlated to getting low on disk space on my
  system drive (50GB SSD) and putting pressure on swap space. e.g when
  system HDD <= 1GB.   My secondary HDD is a 1TB USB spinning device
  that sometimes seems to go into sleep mode and then fails to rapidly
  respond to IO request or may be is in a 'hot IO' state. On my Bus I
  have a low capacity HDD that is essentially unused because it rarely
  comes ready when I boot.  If it is partially alive it is conceivable
  that it might be chattering and so competing for IO interrupt handling
  bandwidth?

  The problem only occurs when I have selected the desktop management
  tile from the 'side tray' and if I then shuffle or better align the
  windows inside one of the four desktops so as to stop them running
  into the neighbouring desktop area. Particularly, it seems to me, when
  at least one of the desktops is quite busy with windows open in it and
  the overlapped desktop has a few also.  The fewer windows in total
  across the desktops the less likely it seems that rearranging a few
  will have any bad effect.

  When the freeze occurs then 60%(?) of the time it ends in a 'big red
  switch' reboot.  The cursor stays active but ineffective.  Keyboard
  combinations, like Alt+W, will sometimes succeed in bringing up to
  full screen mode and active the desktop that was in focus and
  constitutes a recovery.  Other times, and keys, will delete focussed
  windows in the focussed desktop, and Tab will move focus around the 4
  desktops.  SHIFT+Print Screen also executes but just takes the whole
  screen and dumps it somewhere I haven't yet located... with sound
  effect.

  Hope this helps... I am not at fully at home with Ubuntu/Linux yet... having 
spent a lifetime on glasshouse legacy IBM mainframe field systems engineering.  
I am making myself more system disk space meanwhile, and while extract my old 
Maxtor.  It would be nice if I didn't have to up my system disk to hundreds of 
GB!   
  best regards,
  Rob

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: xorg 1:7.7+19ubuntu7.1
  ProcVersionSignature: Ubuntu 4.15.0-101.102-generic 4.15.18
  Uname: Linux 4.15.0-101-generic x86_64
  .tmp.unity_support_test.0:
   
  ApportVersion: 2.20.9-0ubuntu7.15
  Architecture: amd64
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  CurrentDesktop: Unity:Unity7:ubuntu
  Date: Thu Jun  4 11:31:56 2020
  DistUpgraded: Fresh install
  DistroCodename: bionic
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes
  GpuHangFrequency: Several times a week
  GpuHangReproducibility: Occurs more often under certain circumstances
  GpuHangStarted: I don't know
  GraphicsCard:
   Advanced Micro Devices, Inc. [AMD/ATI] Trinity [Radeon HD 7480D] [1002:9993] 
(prog-if 00 [VGA controller])
 Subsystem: ASUSTeK Computer Inc. Trinity [Radeon HD 7480D] [1043:8526]
  InstallationDate: Installed on 2016-11-27 (1284 days ago)
  InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 
(20160719)
  MachineType: System manufacturer System Product Name
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-101-generic 
root=UUID=1d959d4a-ac83-43a5-8c0f-a6956d68c1f8 ro quiet splash vt.handoff=1
  SourcePackage: xorg
  Symptom: display
  Title: Xorg freeze
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 10/10/2013
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 0802
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: A55BM-E
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: Rev X.0x
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr0802:bd10/10/2013:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnA55BM-E:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.family: To be filled by O.E.M.
  dmi.product.name: System Product Name
  dmi.product.version: System Version
  dmi.sys.vendor: System manufacturer
  version.compiz: compiz 

[Touch-packages] [Bug 1882102] Re: Gnome Desktop only starting with root rights

2020-06-04 Thread Daniel van Vugt
Can you log in normally from the login screen? Is it only an issue with
'startx'?

** Tags added: vmware

** Summary changed:

- Gnome Desktop only starting with root rights
+ [vmwgfx] Gnome Desktop only starting with root rights

** Package changed: xorg (Ubuntu) => xorg-server (Ubuntu)

** Changed in: xorg-server (Ubuntu)
   Status: New => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1882102

Title:
  [vmwgfx] Gnome Desktop only starting with root rights

Status in xorg-server package in Ubuntu:
  Incomplete

Bug description:
  All files in home folder are owned by the user. startx is only working
  with root rights.

  xinit: connection to X server lost/usr/bin/gnome-session: 29: exec:
  /usr/libexec/gnome-session-binary: Permission denied

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: xorg 1:7.7+19ubuntu14
  ProcVersionSignature: Ubuntu 5.4.0-33.37-generic 5.4.34
  Uname: Linux 5.4.0-33-generic x86_64
  NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
  ApportVersion: 2.20.11-0ubuntu27.2
  Architecture: amd64
  CasperMD5CheckResult: skip
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  Date: Thu Jun  4 16:25:19 2020
  DistUpgraded: 2020-04-26 18:18:02,277 ERROR Cache can not be locked (E:Konnte 
keinen exklusiven Zugang zur Sperrdatei /var/lib/dpkg/lock erhalten. Diese wird 
vom Prozess 21979 (dpkg) gehalten., W:Beachten Sie, dass das Entfernen der 
Sperrdatei keine Lösung ist und Ihr System zerstören kann., E:Sperren des 
Administrationsverzeichnisses (/var/lib/dpkg/) nicht möglich, wird es von einem 
anderen Prozess verwendet?)
  DistroCodename: focal
  DistroVariant: ubuntu
  DkmsStatus:
   rapiddisk, 5.2, 5.4.0-31-generic, x86_64: installed
   rapiddisk, 5.2, 5.4.0-33-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   VMware SVGA II Adapter [15ad:0405] (prog-if 00 [VGA controller])
 Subsystem: VMware SVGA II Adapter [15ad:0405]
  Lsusb: Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  Lsusb-t: /:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
  MachineType: QEMU Standard PC (i440FX + PIIX, 1996)
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-5.4.0-33-generic 
root=UUID=f8fcb1ae-51b1-4ab2-b79d-66cf34ad77d9 ro nomodeset 
rootflags=subvol=ROOT
  SourcePackage: xorg
  UpgradeStatus: Upgraded to focal on 2020-04-26 (38 days ago)
  dmi.bios.date: 04/01/2014
  dmi.bios.vendor: SeaBIOS
  dmi.bios.version: rel-1.12.1-0-ga5cab58e9a3f-prebuilt.qemu.org
  dmi.chassis.type: 1
  dmi.chassis.vendor: QEMU
  dmi.chassis.version: pc-i440fx-4.1
  dmi.modalias: 
dmi:bvnSeaBIOS:bvrrel-1.12.1-0-ga5cab58e9a3f-prebuilt.qemu.org:bd04/01/2014:svnQEMU:pnStandardPC(i440FX+PIIX,1996):pvrpc-i440fx-4.1:cvnQEMU:ct1:cvrpc-i440fx-4.1:
  dmi.product.name: Standard PC (i440FX + PIIX, 1996)
  dmi.product.version: pc-i440fx-4.1
  dmi.sys.vendor: QEMU
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.4-2ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.4-2ubuntu1
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.6-1
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1882102/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1881812] Re: gdm can't open session for ldap users with usernames that begin with a number

2020-06-04 Thread Daniel van Vugt
** Also affects: systemd (Ubuntu)
   Importance: Undecided
   Status: New

** Bug watch added: github.com/systemd/systemd/issues #15141
   https://github.com/systemd/systemd/issues/15141

** Also affects: systemd via
   https://github.com/systemd/systemd/issues/15141
   Importance: Unknown
   Status: Unknown

** Tags added: fixed-upstream

** Tags added: focal

** Changed in: gdm
 Remote watch: gitlab.gnome.org/GNOME/gdm/-/issues #606 => 
gitlab.gnome.org/GNOME/gdm/-/issues #559

** No longer affects: gdm3 (Ubuntu)

** Changed in: systemd (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1881812

Title:
  gdm can't open session for ldap users with usernames that begin with a
  number

Status in gdm:
  Unknown
Status in systemd:
  Unknown
Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  Description:Ubuntu 20.04 LTS

  with ubuntu-desktop and libnss-ldapd

  Trying to log in to the desktop environment when the username (e.g
  9912345) begins with a number results in a black screen, and then
  quits back to the log in screen.

  Here is the error:
  `...gdm-password][5010]: pam_systemd(gdm-password:session): Failed to get 
user record: Invalid argument`

  However, these users can log-in via ssh, and via TTY without issue.

  This error does not occur if I log in with other users, without a
  number (e.g. test.user)

  Also, the error does not occur if I switch to LightDM.  With LightDM,
  a username such as 9912345 can login to the desktop desktop
  environment.

  $ apt-cache policy gdm3
  gdm3:
Installed: 3.34.1-1ubuntu1
Candidate: 3.34.1-1ubuntu1
Version table:
   *** 3.34.1-1ubuntu1 500
  500 http://ca.archive.ubuntu.com/ubuntu focal/main amd64 Packages
  100 /var/lib/dpkg/status

To manage notifications about this bug go to:
https://bugs.launchpad.net/gdm/+bug/1881812/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1882161] [NEW] module-switch-on-port-avaiable: switch the port on ucm devices based on the priority

2020-06-04 Thread Hui Wang
Public bug reported:

This bug is for tracking purpose.

** Affects: hwe-next
 Importance: Undecided
 Status: New

** Affects: pulseaudio (Ubuntu)
 Importance: Undecided
 Assignee: Hui Wang (hui.wang)
 Status: New

** Affects: pulseaudio (Ubuntu Focal)
 Importance: Undecided
 Status: New

** Affects: pulseaudio (Ubuntu Groovy)
 Importance: Undecided
 Assignee: Hui Wang (hui.wang)
 Status: New


** Tags: originate-from-1875597 somerville

** Also affects: pulseaudio (Ubuntu Groovy)
   Importance: Undecided
 Assignee: Hui Wang (hui.wang)
   Status: New

** Also affects: pulseaudio (Ubuntu Focal)
   Importance: Undecided
   Status: New

** Summary changed:

- module-switch-on-port-avaiable: switch the port based on the priority
+ module-switch-on-port-avaiable: switch the port on ucm devices based on the 
priority

** Tags added: originate-from-1875597 somerville

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1882161

Title:
  module-switch-on-port-avaiable: switch the port on ucm devices based
  on the priority

Status in HWE Next:
  New
Status in pulseaudio package in Ubuntu:
  New
Status in pulseaudio source package in Focal:
  New
Status in pulseaudio source package in Groovy:
  New

Bug description:
  This bug is for tracking purpose.

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/1882161/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1864558] Re: Printer adds automatically at boot with notification or if printer deleted

2020-06-04 Thread Jonathan Kayne
I want to add that it seems rather widespread, as just about every in depth 
review I have seen of 20.04 on YouTube brings up this issue.
Also, disabling the notification does not work because of the fact that it 
occurs at first login.
Considering how widespread this is, shouldn't it be at a higher priority?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to cups in Ubuntu.
https://bugs.launchpad.net/bugs/1864558

Title:
  Printer adds automatically at boot with notification or if printer
  deleted

Status in cups package in Ubuntu:
  Confirmed

Bug description:
  When booting 20.04 I get a notification on the logon screen each time
  advising that my wireless printer has been setup. If I remove the
  printer via settings, then as soon as it's removed, it gets re-added
  and I see the same notification as I do on the logon screen about the
  printer having been setup. I've attached a screenshot of this
  notification.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: gnome-control-center 1:3.35.91-0ubuntu1
  ProcVersionSignature: Ubuntu 5.4.0-14.17-generic 5.4.18
  Uname: Linux 5.4.0-14-generic x86_64
  ApportVersion: 2.20.11-0ubuntu18
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Mon Feb 24 21:49:43 2020
  ExecutablePath: /usr/bin/gnome-control-center
  InstallationDate: Installed on 2020-02-24 (0 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200221)
  ProcEnviron:
   LANG=en_GB.UTF-8
   LANGUAGE=en_GB:en
   PATH=(custom, no user)
   SHELL=/bin/bash
   XDG_RUNTIME_DIR=
  SourcePackage: gnome-control-center
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1864558/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1882157] [NEW] Can't report bug on package you have replaced

2020-06-04 Thread whitis
Public bug reported:

Ubuntu-bug will not let you report a bug if you have upgraded a package
using external sources.

Package zoom was so old the server rejected it.   Downloaded the new
.deb file from upstream source.  Now I can't report a bug on zoom that
the package is so far out of date.

Similarly, if a package is so broken you can't install it, it won't let
you report a bug.

Just note that you can't collect the data and do your job.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: apport 2.20.9-0ubuntu7.14
ProcVersionSignature: Ubuntu 5.3.0-53.47~18.04.1-generic 5.3.18
Uname: Linux 5.3.0-53-generic x86_64
ApportLog:
 
ApportVersion: 2.20.9-0ubuntu7.14
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Thu Jun  4 19:16:29 2020
InstallationDate: Installed on 2019-05-02 (399 days ago)
InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 (20190210)
PackageArchitecture: all
SourcePackage: apport
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: apport (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug bionic

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apport in Ubuntu.
https://bugs.launchpad.net/bugs/1882157

Title:
  Can't report bug on package you have replaced

Status in apport package in Ubuntu:
  New

Bug description:
  Ubuntu-bug will not let you report a bug if you have upgraded a
  package using external sources.

  Package zoom was so old the server rejected it.   Downloaded the new
  .deb file from upstream source.  Now I can't report a bug on zoom that
  the package is so far out of date.

  Similarly, if a package is so broken you can't install it, it won't
  let you report a bug.

  Just note that you can't collect the data and do your job.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: apport 2.20.9-0ubuntu7.14
  ProcVersionSignature: Ubuntu 5.3.0-53.47~18.04.1-generic 5.3.18
  Uname: Linux 5.3.0-53-generic x86_64
  ApportLog:
   
  ApportVersion: 2.20.9-0ubuntu7.14
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Jun  4 19:16:29 2020
  InstallationDate: Installed on 2019-05-02 (399 days ago)
  InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 
(20190210)
  PackageArchitecture: all
  SourcePackage: apport
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apport/+bug/1882157/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1873907] Re: initramfs no dhcp because of 'Error getting hardware address for " en2s0": No such device'

2020-06-04 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: initramfs-tools (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1873907

Title:
  initramfs no dhcp because of 'Error getting hardware address for "
  en2s0": No such device'

Status in initramfs-tools package in Ubuntu:
  Confirmed

Bug description:
  kernel cmdline "ip=dhcp"

  results in: 
  Error getting hardware address for " en2s0": No such device
  No network during boot

  I have to change /usr/share/initramfs-tools/scripts/functions

  fix:
  run_dhclient() {
  ...
  dhclient -v -1 -cf "$conffile" -pf "$pidfile" "$@"
  to 
  dhclient -v -1 -cf "$conffile" -pf "$pidfile" $@

  regards

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: initramfs-tools-core 0.136ubuntu6 [modified: 
usr/share/initramfs-tools/hook-functions 
usr/share/initramfs-tools/scripts/functions]
  ProcVersionSignature: Ubuntu 5.4.0-25.29-generic 5.4.30
  Uname: Linux 5.4.0-25-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: KDE
  Date: Mon Apr 20 18:49:00 2020
  InstallationDate: Installed on 2020-04-18 (2 days ago)
  InstallationMedia: Kubuntu 20.04 LTS "Focal Fossa" - Beta amd64 (20200401)
  PackageArchitecture: all
  SourcePackage: initramfs-tools
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1873907/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1556302] Re: Ubuntu patch to add HOME to env_keep makes custom commands vulnerable by default

2020-06-04 Thread Brian Murray
** Changed in: ubuntu-release-notes
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to sudo in Ubuntu.
https://bugs.launchpad.net/bugs/1556302

Title:
  Ubuntu patch to add HOME to env_keep makes custom commands vulnerable
  by default

Status in Release Notes for Ubuntu:
  Confirmed
Status in sudo package in Ubuntu:
  Fix Released
Status in sudo source package in Xenial:
  In Progress
Status in sudo source package in Bionic:
  In Progress
Status in sudo source package in Cosmic:
  Won't Fix
Status in sudo source package in Disco:
  Won't Fix
Status in sudo source package in Eoan:
  Fix Released

Bug description:
  [impact]

  sudo does not set HOME to the target user's HOME

  [test case]

  ddstreet@thorin:~$ sudo printenv | grep HOME
  HOME=/home/ddstreet

  [regression potential]

  this is a significant behavior change.  As mentioned in comment 11
  (and later, and other bugs duped to this, and the mailing list
  discussion, etc) users of Ubuntu so far have been used to running sudo
  with their own HOME set, not root's HOME.  Therefore, it's
  inappropriate to change this behavior for existing releases; this
  should be changed starting in Eoan, and only the sudo and sudoers man
  pages changed in previous releases to indicate the actual behavior of
  sudo in those releases.

  [other info]

  Shortly after upstream changed the behavior, the patch to keep HOME as
  the calling (instead of target) user was added in bug 760140.

  For quick reference to anyone coming to this bug, the pre-19.10
  behavior (of sudo keeping the calling user's $HOME) can be disabled by
  running 'sudo visudo' and adding this line:

  Defaultsalways_set_home

  or, run sudo with the -H param.

  --
  original description:
  --

  I wanted to allow certain users to execute a python script as another user, 
so I created the following sudoers config:
  Defaults env_reset
  source_user ALL=(target_user) NOPASSWD: /home/target_user/bin/script.py

  This results in a highly insecure Python environment because the
  source user can set HOME and override any Python package by putting
  files in $HOME/.local/lib/python*/site-packages/.

  This should be a safe configuration because the default behaviour (as
  specified in the man page) is that env_reset will replace HOME with
  the target user's home directory. The "env_reset" option even has
  special behaviour for bash which has its own potential environment
  vulnerabilities.

  However there is an Ubuntu-specific patch in the package
  (keep_home_by_default.patch) that makes sudo preserve HOME by default,
  which negates the correct behaviour of "env_reset". It should not be
  necessary to explicitly specify the "always_set_home" option in order
  to negate this patch.

  The patch should be removed and the default /etc/sudoers should
  explicitly add HOME to "env_keep" for the "allow admins to run any
  command as root" entries, to get the desired behaviour without
  creating security issues for other sudoers commands.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-release-notes/+bug/1556302/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1748956] Re: replace uses of net-tools with iproute2

2020-06-04 Thread Brian Murray
** No longer affects: ubuntu-release-notes

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu.
https://bugs.launchpad.net/bugs/1748956

Title:
  replace uses of net-tools with iproute2

Status in byobu:
  Fix Committed
Status in byobu package in Ubuntu:
  Fix Released
Status in ubuntu-meta package in Ubuntu:
  Fix Released

Bug description:
  As ubuntu goes forward, net-tools is looking to be dropped.

  Byobu currently depends on net-tools.  That code should be replaced by
  iproute2.

  
  Related bugs:
   * bug 925145: cloud-init  Use ip instead of ifconfig and route

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: byobu 5.124-0ubuntu1
  ProcVersionSignature: Ubuntu 4.13.0-25.29-generic 4.13.13
  Uname: Linux 4.13.0-25-generic x86_64
  NonfreeKernelModules: zfs zunicode zavl zcommon znvpair
  ApportVersion: 2.20.8-0ubuntu8
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Mon Feb 12 13:34:27 2018
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2015-07-23 (935 days ago)
  InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20150722.1)
  PackageArchitecture: all
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: byobu
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/byobu/+bug/1748956/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1764172] Re: Unable to change hostname from the one specified during Bionic server installation

2020-06-04 Thread Brian Murray
** No longer affects: ubuntu-release-notes

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to hostname in Ubuntu.
https://bugs.launchpad.net/bugs/1764172

Title:
  Unable to change hostname from the one specified during Bionic server
  installation

Status in subiquity:
  Fix Released
Status in hostname package in Ubuntu:
  Confirmed

Bug description:
  In Bionic Beta 2 I am not able on a host or in a guest VM to change
  the hostname of a Bionic Beta 2 installation by changing
  /etc/hostname. The name in the file can be changed but it always
  reverts to the hostname configured during installation.

  In the following thread on the topic it is suggested to remove a
  number of cloud packages. When doing this in a VM install I could
  change the hostname again via /etc/hostname.

  https://ubuntuforums.org/showthread.php?t=2389098=2

To manage notifications about this bug go to:
https://bugs.launchpad.net/subiquity/+bug/1764172/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1858883] Re: date utility format unexpectedly changed after upgrade from bionic to focal

2020-06-04 Thread Brian Murray
** Changed in: ubuntu-release-notes
   Status: New => Triaged

** Changed in: coreutils (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to coreutils in Ubuntu.
https://bugs.launchpad.net/bugs/1858883

Title:
  date utility format unexpectedly changed after upgrade from bionic to
  focal

Status in Release Notes for Ubuntu:
  Triaged
Status in coreutils package in Ubuntu:
  Confirmed

Bug description:
  After upgrading my Bionic system to Focal, I noticed a significant
  change in the output of the `date` utility. This could potentially
  cause regressions for those who are relying on a consistent date
  format when using `date` in shell scripts.

  EXPECTED BEHAVIOR
  =

  I expected to see the same date format that can be seen on Ubuntu
  releases (at least) from Trusty through Bionic:

  $ date -u
  Wed Jan  8 21:00:14 UTC 2020

  ACTUAL BEHAVIOR
  ===

  On Focal (and Eoan) the following date format is seen by default:

  $ date -u
  Wed 08 Jan 2020 09:00:14 PM UTC

  Note the differences in zero-padding, whitespace, placement of the
  year, and the extraneous "PM" (I had expected to see a 24-hour time).

  FURTHER DETAILS
  ===

  This machine was originally on Bionic and has been upgraded to
  development releases between Bionic and Focal.

  $ locale
  LANG=en_US.UTF-8
  LANGUAGE=
  LC_CTYPE="en_US.UTF-8"
  LC_NUMERIC="en_US.UTF-8"
  LC_TIME="en_US.UTF-8"
  LC_COLLATE="en_US.UTF-8"
  LC_MONETARY="en_US.UTF-8"
  LC_MESSAGES="en_US.UTF-8"
  LC_PAPER="en_US.UTF-8"
  LC_NAME="en_US.UTF-8"
  LC_ADDRESS="en_US.UTF-8"
  LC_TELEPHONE="en_US.UTF-8"
  LC_MEASUREMENT="en_US.UTF-8"
  LC_IDENTIFICATION="en_US.UTF-8"
  LC_ALL=

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-release-notes/+bug/1858883/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1872902] Re: Upgrade to Focal now removes chrony

2020-06-04 Thread Brian Murray
** Changed in: ubuntu-release-notes
   Status: New => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1872902

Title:
  Upgrade to Focal now removes chrony

Status in Release Notes for Ubuntu:
  Invalid
Status in apt package in Ubuntu:
  Invalid
Status in chrony package in Ubuntu:
  Invalid
Status in germinate package in Ubuntu:
  New
Status in ntp package in Ubuntu:
  Invalid
Status in systemd package in Ubuntu:
  Invalid
Status in ubuntu-release-upgrader package in Ubuntu:
  Fix Released
Status in apt source package in Focal:
  Invalid
Status in chrony source package in Focal:
  Invalid
Status in germinate source package in Focal:
  New
Status in ntp source package in Focal:
  Invalid
Status in systemd source package in Focal:
  Invalid
Status in ubuntu-release-upgrader source package in Focal:
  Fix Released

Bug description:
  Due to changes in systemd for bug 1849156 this issue now happens.

  On an upgrade for people that had chrony installed on a do-release upgrade it 
now will:
  Calculating the changes
    MarkInstall systemd-timesyncd:amd64 < none -> 245.4-4ubuntu1 @un uN Ib > 
FU=1
     Removing: chrony
  MarkDelete chrony:amd64 < 3.2-4ubuntu4.2 -> 3.5-6ubuntu3 @ii umU Ib > FU=0

  That isn't what users want, those who had chrony installed would want
  to get chrony upgraded and systemd-timesyncd (which now is a separate
  pacakge) not installed.

  Test Case
  -
  1) On a system running Ubuntu 19.10 or Ubuntu 18.04 LTS install the package 
chrony
  2) Run do-release-upgrade with the appropriate switches
  3) Observe that chrony is marked for deletion

  With the version of dist-upgrader from -proposed (accessed with the -p
  switch) chrony is no longer marked for deletion.

  Regression Potential
  
  Given that Dimitri's change is now ignoring the tasks minimal and standard 
(which are handled by _keepBaseMetaPkgsInstalled) we should still be cautious 
and test desktop upgrades and ensure that packages in those tasks are not 
marked for removal.

  Regression Test
  ---
  1) Run do-release-upgrade on an Ubuntu 19.10 or Ubuntu 18.04 LTS system
  2) Record the list of packages marked for removal

  Compare the list of packages marked for removal with the release-
  upgrader from -proposed from Focal.

  Original Description
  
  I'd ask you to revise the dependencies that got changes in systemd 
245.4-2ubuntu1 so that on an upgrade from e.g. Bionic chrony stays installed as 
that was an opt-in chances are quite high people would want to keep it that way.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-release-notes/+bug/1872902/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1882092] Re: goa-daemon Error resolving “autodiscover.outlook.office365.com”

2020-06-04 Thread Sebastien Bacher
** Changed in: gnome-online-accounts (Ubuntu)
   Importance: Undecided => Low

** Changed in: gnome-online-accounts (Ubuntu)
   Status: New => Triaged

** Bug watch added: gitlab.gnome.org/GNOME/gnome-online-accounts/-/issues #57
   https://gitlab.gnome.org/GNOME/gnome-online-accounts/-/issues/57

** Also affects: gnome-online-accounts via
   https://gitlab.gnome.org/GNOME/gnome-online-accounts/-/issues/57
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gnome-online-accounts in
Ubuntu.
https://bugs.launchpad.net/bugs/1882092

Title:
  goa-daemon Error resolving “autodiscover.outlook.office365.com”

Status in gnome-online-accounts:
  Unknown
Status in gnome-online-accounts package in Ubuntu:
  Triaged

Bug description:
  Evolution is no longer receiving able to refresh Inbox from Exchange Web 
Services.
  `journalctl` provides the following clues

  systemd-resolved: Server returned error NXDOMAIN, mitigating potential DNS 
violation DVE-2018-0001, retrying transaction with reduced feature level UDP
  goa-daemon: goa_ews_client_autodiscover() failed: 2 — Error resolving 
“autodiscover.outlook.office365.com”: Name or service not known

  This may be upstream issue https://gitlab.gnome.org/GNOME/gnome-
  online-accounts/-/issues/57

  $ lsb_release -rd
  Description:  Ubuntu 18.04.4 LTS
  Release:  18.04

  $ apt-cache policy gnome-online-accounts
  gnome-online-accounts:
Installed: 3.28.0-0ubuntu2.1
Candidate: 3.28.0-0ubuntu2.1
Version table:
   *** 3.28.0-0ubuntu2.1 500
  500 http://fi.archive.ubuntu.com/ubuntu bionic-updates/main amd64 
Packages
  100 /var/lib/dpkg/status
   3.28.0-0ubuntu2 500
  500 http://fi.archive.ubuntu.com/ubuntu bionic/main amd64 Packages

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: gnome-online-accounts 3.28.0-0ubuntu2.1
  ProcVersionSignature: Ubuntu 4.15.0-101.102-generic 4.15.18
  Uname: Linux 4.15.0-101-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.15
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Jun  4 17:11:45 2020
  InstallationDate: Installed on 2018-01-10 (875 days ago)
  InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64 
(20170801)
  SourcePackage: gnome-online-accounts
  UpgradeStatus: Upgraded to bionic on 2019-02-12 (478 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/gnome-online-accounts/+bug/1882092/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1871721] Re: Second Monitor on HDMI blank screen with Nvidia & Ubuntu 20.04? (ASUS Laptop)

2020-06-04 Thread Noctis Bennington
** Also affects: focal (Ubuntu)
   Importance: Undecided
   Status: New

** No longer affects: focal (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1871721

Title:
  Second Monitor on HDMI blank screen with Nvidia & Ubuntu 20.04? (ASUS
  Laptop)

Status in kernel-package package in Ubuntu:
  Confirmed
Status in mesa package in Ubuntu:
  Confirmed
Status in mesa-utils package in Ubuntu:
  Confirmed
Status in nouveau-firmware package in Ubuntu:
  Confirmed
Status in nvidia-graphics-drivers-440 package in Ubuntu:
  Confirmed
Status in xserver-xorg-video-intel package in Ubuntu:
  Confirmed

Bug description:
  I installed Ubuntu 20.04 on my ASUS laptop with Intel+Nvidia with propietary 
drivers of Nvidia (I have 440.64 rn) and I connected a second monitor to use 
it, but I saw that I cannot use it, I just see a blank screen. I tried with a 
TV of my room and same. The funny part is when I start the laptop to work, I 
can see the logo of my BIOS and the ASUS logo in the second monitor, even the 
grub, but after that I can't see nothing.
  When I reduce the resolution of the second monitor (800x600) then works, but 
even with that sometimes blinks to black again.
  On W10 for example it works perfectly, so I deduce it's not 'cause my HDMI.

  I tried with noveau drivers and I have the same results btw.

  Laptop Asus with:
  Graphic card  Nvidia GTX960M
  Processor  Intel i5 6300

  I tried with Nvidia Prime to Nvidia, Intel and On-demand. None of them
  works. All of them with Xorg.

  I have this with xrandr:

  Screen 0: minimum 8 x 8, current 2720 x 1080, maximum 16384 x 16384
  eDP-1-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y 
axis) 344mm x 193mm
     1920x1080 60.00*+  59.9759.9659.93
     1680x1050 59.9559.88
     1600x1024 60.17
     1400x1050 59.98
     1600x900  59.9959.9459.9559.82
     1280x1024 60.02
     1440x900  59.89
     1400x900  59.9659.88
     1280x960  60.00
     1440x810  60.0059.97
     1368x768  59.8859.85
     1360x768  59.8059.96
     1280x800  59.9959.9759.8159.91
     1152x864  60.00
     1280x720  60.0059.9959.8659.74
     1024x768  60.0460.00
     960x720   60.00
     928x696   60.05
     896x672   60.01
     1024x576  59.9559.9659.9059.82
     960x600   59.9360.00
     960x540   59.9659.9959.6359.82
     800x600   60.0060.3256.25
     840x525   60.0159.88
     864x486   59.9259.57
     800x512   60.17
     700x525   59.98
     800x450   59.9559.82
     640x512   60.02
     720x450   59.89
     700x450   59.9659.88
     640x480   60.0059.94
     720x405   59.5158.99
     684x384   59.8859.85
     680x384   59.8059.96
     640x400   59.8859.98
     576x432   60.06
     640x360   59.8659.8359.8459.32
     512x384   60.00
     512x288   60.0059.92
     480x270   59.6359.82
     400x300   60.3256.34
     432x243   59.9259.57
     320x240   60.05
     360x202   59.5159.13
     320x180   59.8459.32
  DP-1-1 disconnected (normal left inverted right x axis y axis)
  HDMI-1-1 disconnected (normal left inverted right x axis y axis)
  HDMI-1-2 connected 800x600+1920+0 (normal left inverted right x axis y axis) 
1600mm x 900mm
     1920x1080 60.00 +  50.0059.9430.0025.0024.0029.97  
  23.98
     1920x1080i60.0050.0059.94
     1280x1024 60.02
     1360x768  60.02
     1152x864  59.97
     1280x720  59.8160.0050.0059.94
     1024x768  60.00
     800x600   60.32*
     720x576   50.00
     720x576i  50.00
     720x480   60.0059.94
     640x480   60.0059.94
     720x400   70.08
  DP-1-2 disconnected (normal left inverted right x axis y axis)
  HDMI-1-3 disconnected (normal left inverted right x axis y axis)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/kernel-package/+bug/1871721/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1882136] Re: I can't connect to 5GHz wifi

2020-06-04 Thread Sebastien Bacher
Thank you for your bug report, from what version to what version did you 
update? What error do you get? Could you do 
$ journalctl -f
try to connect and copy the log there?

** Changed in: network-manager (Ubuntu)
   Status: New => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1882136

Title:
  I can't connect to 5GHz wifi

Status in network-manager package in Ubuntu:
  Incomplete

Bug description:
  After updating the NetworkManager I can't connect to 5GHz wifi. The
  router is a mikrotik hap ac2.The notebook is a Dell Latitude 5580.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: network-manager 1.22.10-1ubuntu2.1
  ProcVersionSignature: Ubuntu 5.4.0-33.37-generic 5.4.34
  Uname: Linux 5.4.0-33-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.2
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Jun  4 22:20:15 2020
  InstallationDate: Installed on 2020-05-15 (20 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  ProcEnviron:
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=hu_HU.UTF-8
   SHELL=/bin/bash
  SourcePackage: network-manager
  UpgradeStatus: No upgrade log present (probably fresh install)
  nmcli-nm:
   RUNNING  VERSION  STATE  STARTUP  CONNECTIVITY  NETWORKING  WIFI-HW  
WIFI WWAN-HW  WWAN
   running  1.22.10  connected  started  full  enabled enabled  
enabled  enabled  enabled

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1882136/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1882136] [NEW] I can't connect to 5GHz wifi

2020-06-04 Thread Szilveszter Balogh
Public bug reported:

After updating the NetworkManager I can't connect to 5GHz wifi. The
router is a mikrotik hap ac2.The notebook is a Dell Latitude 5580.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: network-manager 1.22.10-1ubuntu2.1
ProcVersionSignature: Ubuntu 5.4.0-33.37-generic 5.4.34
Uname: Linux 5.4.0-33-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.2
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Thu Jun  4 22:20:15 2020
InstallationDate: Installed on 2020-05-15 (20 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=
 LANG=hu_HU.UTF-8
 SHELL=/bin/bash
SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
nmcli-nm:
 RUNNING  VERSION  STATE  STARTUP  CONNECTIVITY  NETWORKING  WIFI-HW  WIFI  
   WWAN-HW  WWAN
 running  1.22.10  connected  started  full  enabled enabled  
enabled  enabled  enabled

** Affects: network-manager (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug focal

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1882136

Title:
  I can't connect to 5GHz wifi

Status in network-manager package in Ubuntu:
  New

Bug description:
  After updating the NetworkManager I can't connect to 5GHz wifi. The
  router is a mikrotik hap ac2.The notebook is a Dell Latitude 5580.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: network-manager 1.22.10-1ubuntu2.1
  ProcVersionSignature: Ubuntu 5.4.0-33.37-generic 5.4.34
  Uname: Linux 5.4.0-33-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.2
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Jun  4 22:20:15 2020
  InstallationDate: Installed on 2020-05-15 (20 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  ProcEnviron:
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=hu_HU.UTF-8
   SHELL=/bin/bash
  SourcePackage: network-manager
  UpgradeStatus: No upgrade log present (probably fresh install)
  nmcli-nm:
   RUNNING  VERSION  STATE  STARTUP  CONNECTIVITY  NETWORKING  WIFI-HW  
WIFI WWAN-HW  WWAN
   running  1.22.10  connected  started  full  enabled enabled  
enabled  enabled  enabled

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1882136/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1867424] Re: motd-news transmitting private hardware data without consent or knowledge in background

2020-06-04 Thread Guy Baconniere
Please give the Message of the Day (MOTD) every time I get online on the 
Internet 
or I reboot my Ubuntu computer ...

Hold on, connecting to Amazon Cloud (Amazon Data Services)
motd.ubuntu.com ...

Your message of the day is

Building Trust is Hard, Breaking Trust is Easy

In exchange, please give me your User-Agent will all your private informations
so I know who you are (IP, Ubuntu Cloud ID, Linux Kernel Version, Curl version, 
etc.)

GET /bionic/x86_64 HTTP/1.1
Host: motd.ubuntu.com
User-Agent: curl/7.58.0-2ubuntu3.8 Ubuntu/18.04.3/LTSGNU/Linux/4.15.0-72-generic
/x86_64 Intel(R)/Core(TM)/i5-8500B/CPU/@/3.00GHz uptime/108266.13/21
2047.71 cloud_id/unknown
Accept: */*

https://ma.ttias.be/what-exactly-being-sent-ubuntu-motd/

[Unit]
Description=Message of the Day
After=network-online.target
Documentation=man:update-motd(8)

[Service]
Type=oneshot
ExecStart=/etc/update-motd.d/50-motd-news --force

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to base-files in Ubuntu.
https://bugs.launchpad.net/bugs/1867424

Title:
  motd-news transmitting private hardware data without consent or
  knowledge in background

Status in base-files package in Ubuntu:
  Confirmed

Bug description:
  In package base-files there is a script /etc/update-motd.d/50-motd-
  news that harvests private hardware data from the machine and
  transmits it in the background every day.  There is no notice, no
  consent, no nothing.  This should be by default disabled until there
  is informed consent.

  This solution is simple:

  1. Change ENABLED=1 to ENABLED=0 in the file /etc/default/motd-news and 
  2. Place a comment in the file disclosing the fact that the 50-motd-news 
script will harvest private hardware data and upload it to motd.ubuntu.com 
daily if the end-user enables it.

  Creating databases that maps ip address to specify hardware is a
  threat to both privacy and security.  If an adversary knows the
  specific hardware and the ip address for that hardware their ability
  to successfully attack it is greatly increased.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/base-files/+bug/1867424/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1871721] Re: Second Monitor on HDMI blank screen with Nvidia & Ubuntu 20.04? (ASUS Laptop)

2020-06-04 Thread Noctis Bennington
** Tags added: focal

** Tags added: amd64

** Tags added: asus intel nvidia

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1871721

Title:
  Second Monitor on HDMI blank screen with Nvidia & Ubuntu 20.04? (ASUS
  Laptop)

Status in kernel-package package in Ubuntu:
  Confirmed
Status in mesa package in Ubuntu:
  Confirmed
Status in mesa-utils package in Ubuntu:
  Confirmed
Status in nouveau-firmware package in Ubuntu:
  Confirmed
Status in nvidia-graphics-drivers-440 package in Ubuntu:
  Confirmed
Status in xserver-xorg-video-intel package in Ubuntu:
  Confirmed

Bug description:
  I installed Ubuntu 20.04 on my ASUS laptop with Intel+Nvidia with propietary 
drivers of Nvidia (I have 440.64 rn) and I connected a second monitor to use 
it, but I saw that I cannot use it, I just see a blank screen. I tried with a 
TV of my room and same. The funny part is when I start the laptop to work, I 
can see the logo of my BIOS and the ASUS logo in the second monitor, even the 
grub, but after that I can't see nothing.
  When I reduce the resolution of the second monitor (800x600) then works, but 
even with that sometimes blinks to black again.
  On W10 for example it works perfectly, so I deduce it's not 'cause my HDMI.

  I tried with noveau drivers and I have the same results btw.

  Laptop Asus with:
  Graphic card  Nvidia GTX960M
  Processor  Intel i5 6300

  I tried with Nvidia Prime to Nvidia, Intel and On-demand. None of them
  works. All of them with Xorg.

  I have this with xrandr:

  Screen 0: minimum 8 x 8, current 2720 x 1080, maximum 16384 x 16384
  eDP-1-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y 
axis) 344mm x 193mm
     1920x1080 60.00*+  59.9759.9659.93
     1680x1050 59.9559.88
     1600x1024 60.17
     1400x1050 59.98
     1600x900  59.9959.9459.9559.82
     1280x1024 60.02
     1440x900  59.89
     1400x900  59.9659.88
     1280x960  60.00
     1440x810  60.0059.97
     1368x768  59.8859.85
     1360x768  59.8059.96
     1280x800  59.9959.9759.8159.91
     1152x864  60.00
     1280x720  60.0059.9959.8659.74
     1024x768  60.0460.00
     960x720   60.00
     928x696   60.05
     896x672   60.01
     1024x576  59.9559.9659.9059.82
     960x600   59.9360.00
     960x540   59.9659.9959.6359.82
     800x600   60.0060.3256.25
     840x525   60.0159.88
     864x486   59.9259.57
     800x512   60.17
     700x525   59.98
     800x450   59.9559.82
     640x512   60.02
     720x450   59.89
     700x450   59.9659.88
     640x480   60.0059.94
     720x405   59.5158.99
     684x384   59.8859.85
     680x384   59.8059.96
     640x400   59.8859.98
     576x432   60.06
     640x360   59.8659.8359.8459.32
     512x384   60.00
     512x288   60.0059.92
     480x270   59.6359.82
     400x300   60.3256.34
     432x243   59.9259.57
     320x240   60.05
     360x202   59.5159.13
     320x180   59.8459.32
  DP-1-1 disconnected (normal left inverted right x axis y axis)
  HDMI-1-1 disconnected (normal left inverted right x axis y axis)
  HDMI-1-2 connected 800x600+1920+0 (normal left inverted right x axis y axis) 
1600mm x 900mm
     1920x1080 60.00 +  50.0059.9430.0025.0024.0029.97  
  23.98
     1920x1080i60.0050.0059.94
     1280x1024 60.02
     1360x768  60.02
     1152x864  59.97
     1280x720  59.8160.0050.0059.94
     1024x768  60.00
     800x600   60.32*
     720x576   50.00
     720x576i  50.00
     720x480   60.0059.94
     640x480   60.0059.94
     720x400   70.08
  DP-1-2 disconnected (normal left inverted right x axis y axis)
  HDMI-1-3 disconnected (normal left inverted right x axis y axis)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/kernel-package/+bug/1871721/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1867424] Re: motd-news transmitting private hardware data without consent or knowledge in background

2020-06-04 Thread Guy Baconniere
Part of the base OS ... resistance is futile

dpkg -L base-files | grep motd-news
/etc/default/motd-news
/etc/update-motd.d/50-motd-news
/lib/systemd/system/motd-news.service
/lib/systemd/system/motd-news.timer

sudo grep news /var/log/syslog
Jun  4 04:44:22 mbx 50-motd-news[94986]:  * MicroK8s gets a native Windows 
installer and command-line integration.
Jun  4 04:44:22 mbx 50-motd-news[94986]:  
https://ubuntu.com/blog/microk8s-installers-windows-and-macos
Jun  4 04:44:22 mbx systemd[1]: motd-news.service: Succeeded.
Jun  4 08:57:00 mbx systemd[1]: motd-news.timer: Succeeded.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to base-files in Ubuntu.
https://bugs.launchpad.net/bugs/1867424

Title:
  motd-news transmitting private hardware data without consent or
  knowledge in background

Status in base-files package in Ubuntu:
  Confirmed

Bug description:
  In package base-files there is a script /etc/update-motd.d/50-motd-
  news that harvests private hardware data from the machine and
  transmits it in the background every day.  There is no notice, no
  consent, no nothing.  This should be by default disabled until there
  is informed consent.

  This solution is simple:

  1. Change ENABLED=1 to ENABLED=0 in the file /etc/default/motd-news and 
  2. Place a comment in the file disclosing the fact that the 50-motd-news 
script will harvest private hardware data and upload it to motd.ubuntu.com 
daily if the end-user enables it.

  Creating databases that maps ip address to specify hardware is a
  threat to both privacy and security.  If an adversary knows the
  specific hardware and the ip address for that hardware their ability
  to successfully attack it is greatly increased.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/base-files/+bug/1867424/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1867424] Re: motd-news transmitting private hardware data without consent or knowledge in background

2020-06-04 Thread Guy Baconniere
Well known... 
https://twitter.com/search?q=ubuntu%20motd-news=typed_query=live

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to base-files in Ubuntu.
https://bugs.launchpad.net/bugs/1867424

Title:
  motd-news transmitting private hardware data without consent or
  knowledge in background

Status in base-files package in Ubuntu:
  Confirmed

Bug description:
  In package base-files there is a script /etc/update-motd.d/50-motd-
  news that harvests private hardware data from the machine and
  transmits it in the background every day.  There is no notice, no
  consent, no nothing.  This should be by default disabled until there
  is informed consent.

  This solution is simple:

  1. Change ENABLED=1 to ENABLED=0 in the file /etc/default/motd-news and 
  2. Place a comment in the file disclosing the fact that the 50-motd-news 
script will harvest private hardware data and upload it to motd.ubuntu.com 
daily if the end-user enables it.

  Creating databases that maps ip address to specify hardware is a
  threat to both privacy and security.  If an adversary knows the
  specific hardware and the ip address for that hardware their ability
  to successfully attack it is greatly increased.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/base-files/+bug/1867424/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1311056] Re: [SRU] apt-add-repository adds duplicate commented/disabled source lines

2020-06-04 Thread Launchpad Bug Tracker
This bug was fixed in the package python-apt - 1.6.5ubuntu0.3

---
python-apt (1.6.5ubuntu0.3) bionic; urgency=medium

  * Don't duplicate disabled sources during add() (LP: #1311056)

 -- Dave Jones   Fri, 24 Jan 2020 22:06:25
+

** Changed in: python-apt (Ubuntu Bionic)
   Status: Fix Committed => Fix Released

** Changed in: python-apt (Ubuntu Xenial)
   Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to python-apt in Ubuntu.
https://bugs.launchpad.net/bugs/1311056

Title:
  [SRU] apt-add-repository adds duplicate commented/disabled source
  lines

Status in python-apt package in Ubuntu:
  Fix Released
Status in python-apt source package in Xenial:
  Fix Released
Status in python-apt source package in Bionic:
  Fix Released
Status in python-apt source package in Eoan:
  Fix Released

Bug description:
  Impact
  ==

  Under most circumstances, the impact is minimal (a few extra redundant
  comment lines in apt sources. However, if users are automating source
  removal / addition on a machine (as in comment 11), there is the
  potential to wind up with an excessively large (and thus slow to
  parse) apt sources configuration.

  Test packages for the supported releases are available from the
  following PPA:

  https://launchpad.net/~waveform/+archive/ubuntu/python-apt

  Built from the source which can be found in the following branches:

  https://code.launchpad.net/~waveform/ubuntu/+source/python-apt/+git
  /python-apt/+ref/sru-dupe-ppa-xenial

  https://code.launchpad.net/~waveform/ubuntu/+source/python-apt/+git
  /python-apt/+ref/sru-dupe-ppa-bionic

  https://code.launchpad.net/~waveform/ubuntu/+source/python-apt/+git
  /python-apt/+ref/sru-dupe-ppa-eoan

  Test Case
  =

  * sudo add-apt-repository -y ppa:deadsnakes/ppa
  * cat /etc/apt/sources.list.d/deadsnakes*.list
  * Note the presence of one uncommented "deb" line, and one commented 
"deb-src" line
  * sudo add-apt-repository -y ppa:deadsnakes/ppa
  * cat /etc/apt/sources.list.d/deadsnakes*.list
  * Note the uncommented "deb" line is still there but the commented "deb-src" 
line has now been duplicated
  * sudo add-apt-repository ppa:waveform/python-apt
  * sudo apt upgrade  # update python-apt to fixed version
  * sudo add-apt-repository -y ppa:deadsnakes/ppa
  * cat /etc/apt/sources.list.d/deadsnakes*.list
  * Note there has been no further duplication of the commented "deb-src" line

  Regression Potential
  

  Minimal; test cases have been added to cover the duplication case, and
  to cover the enabling of sources (which was not covered by existing
  tests, but was part of the code altered to fix the duplication case),
  and insertion of sources at a position (again, not covered by existing
  tests but modified as part of the fix). The test case has been used
  successfully on all targeted releases (xenial, bionic, and eoan).

  Original Description
  

  Trusty Tahr 14.04

  0 root@osprey:/etc/apt/sources.list.d#cat aims-aims-desktop-trusty.list
  deb http://ppa.launchpad.net/aims/aims-desktop/ubuntu trusty main
  # deb-src http://ppa.launchpad.net/aims/aims-desktop/ubuntu trusty main
  0 root@osprey:/etc/apt/sources.list.d#apt-add-repository -y 
ppa:aims/aims-desktop
  gpg: keyring `/tmp/tmp0ufdhnmv/secring.gpg' created
  gpg: keyring `/tmp/tmp0ufdhnmv/pubring.gpg' created
  gpg: requesting key BE796FF2 from hkp server keyserver.ubuntu.com
  gpg: /tmp/tmp0ufdhnmv/trustdb.gpg: trustdb created
  gpg: key BE796FF2: public key "Launchpad PPA for AIMS" imported
  gpg: Total number processed: 1
  gpg:   imported: 1  (RSA: 1)
  OK
  0 root@osprey:/etc/apt/sources.list.d#cat aims-aims-desktop-trusty.list deb 
http://ppa.launchpad.net/aims/aims-desktop/ubuntu trusty main
  # deb-src http://ppa.launchpad.net/aims/aims-desktop/ubuntu trusty main
  # deb-src http://ppa.launchpad.net/aims/aims-desktop/ubuntu trusty main
  0 root@osprey:/etc/apt/sources.list.d#

  That deb-src line should have stayed commented out, and not been
  duplicated. (Commented deb lines should of course be uncommented, as
  already fixed per https://bugs.launchpad.net/ubuntu/+source/python-
  apt/+bug/1042916 .)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/python-apt/+bug/1311056/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1311056] Re: [SRU] apt-add-repository adds duplicate commented/disabled source lines

2020-06-04 Thread Launchpad Bug Tracker
This bug was fixed in the package python-apt -
1.1.0~beta1ubuntu0.16.04.9

---
python-apt (1.1.0~beta1ubuntu0.16.04.9) xenial; urgency=medium

  * Don't duplicate disabled sources during add() (LP: #1311056)

 -- Dave Jones   Fri, 24 Jan 2020 22:05:23
+

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to python-apt in Ubuntu.
https://bugs.launchpad.net/bugs/1311056

Title:
  [SRU] apt-add-repository adds duplicate commented/disabled source
  lines

Status in python-apt package in Ubuntu:
  Fix Released
Status in python-apt source package in Xenial:
  Fix Released
Status in python-apt source package in Bionic:
  Fix Released
Status in python-apt source package in Eoan:
  Fix Released

Bug description:
  Impact
  ==

  Under most circumstances, the impact is minimal (a few extra redundant
  comment lines in apt sources. However, if users are automating source
  removal / addition on a machine (as in comment 11), there is the
  potential to wind up with an excessively large (and thus slow to
  parse) apt sources configuration.

  Test packages for the supported releases are available from the
  following PPA:

  https://launchpad.net/~waveform/+archive/ubuntu/python-apt

  Built from the source which can be found in the following branches:

  https://code.launchpad.net/~waveform/ubuntu/+source/python-apt/+git
  /python-apt/+ref/sru-dupe-ppa-xenial

  https://code.launchpad.net/~waveform/ubuntu/+source/python-apt/+git
  /python-apt/+ref/sru-dupe-ppa-bionic

  https://code.launchpad.net/~waveform/ubuntu/+source/python-apt/+git
  /python-apt/+ref/sru-dupe-ppa-eoan

  Test Case
  =

  * sudo add-apt-repository -y ppa:deadsnakes/ppa
  * cat /etc/apt/sources.list.d/deadsnakes*.list
  * Note the presence of one uncommented "deb" line, and one commented 
"deb-src" line
  * sudo add-apt-repository -y ppa:deadsnakes/ppa
  * cat /etc/apt/sources.list.d/deadsnakes*.list
  * Note the uncommented "deb" line is still there but the commented "deb-src" 
line has now been duplicated
  * sudo add-apt-repository ppa:waveform/python-apt
  * sudo apt upgrade  # update python-apt to fixed version
  * sudo add-apt-repository -y ppa:deadsnakes/ppa
  * cat /etc/apt/sources.list.d/deadsnakes*.list
  * Note there has been no further duplication of the commented "deb-src" line

  Regression Potential
  

  Minimal; test cases have been added to cover the duplication case, and
  to cover the enabling of sources (which was not covered by existing
  tests, but was part of the code altered to fix the duplication case),
  and insertion of sources at a position (again, not covered by existing
  tests but modified as part of the fix). The test case has been used
  successfully on all targeted releases (xenial, bionic, and eoan).

  Original Description
  

  Trusty Tahr 14.04

  0 root@osprey:/etc/apt/sources.list.d#cat aims-aims-desktop-trusty.list
  deb http://ppa.launchpad.net/aims/aims-desktop/ubuntu trusty main
  # deb-src http://ppa.launchpad.net/aims/aims-desktop/ubuntu trusty main
  0 root@osprey:/etc/apt/sources.list.d#apt-add-repository -y 
ppa:aims/aims-desktop
  gpg: keyring `/tmp/tmp0ufdhnmv/secring.gpg' created
  gpg: keyring `/tmp/tmp0ufdhnmv/pubring.gpg' created
  gpg: requesting key BE796FF2 from hkp server keyserver.ubuntu.com
  gpg: /tmp/tmp0ufdhnmv/trustdb.gpg: trustdb created
  gpg: key BE796FF2: public key "Launchpad PPA for AIMS" imported
  gpg: Total number processed: 1
  gpg:   imported: 1  (RSA: 1)
  OK
  0 root@osprey:/etc/apt/sources.list.d#cat aims-aims-desktop-trusty.list deb 
http://ppa.launchpad.net/aims/aims-desktop/ubuntu trusty main
  # deb-src http://ppa.launchpad.net/aims/aims-desktop/ubuntu trusty main
  # deb-src http://ppa.launchpad.net/aims/aims-desktop/ubuntu trusty main
  0 root@osprey:/etc/apt/sources.list.d#

  That deb-src line should have stayed commented out, and not been
  duplicated. (Commented deb lines should of course be uncommented, as
  already fixed per https://bugs.launchpad.net/ubuntu/+source/python-
  apt/+bug/1042916 .)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/python-apt/+bug/1311056/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1311056] Update Released

2020-06-04 Thread Brian Murray
The verification of the Stable Release Update for python-apt has
completed successfully and the package is now being released to
-updates.  Subsequently, the Ubuntu Stable Release Updates Team is being
unsubscribed and will not receive messages about this bug report.  In
the event that you encounter a regression using the package from
-updates please report a new bug using ubuntu-bug and tag the bug report
regression-update so we can easily find any regressions.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to python-apt in Ubuntu.
https://bugs.launchpad.net/bugs/1311056

Title:
  [SRU] apt-add-repository adds duplicate commented/disabled source
  lines

Status in python-apt package in Ubuntu:
  Fix Released
Status in python-apt source package in Xenial:
  Fix Released
Status in python-apt source package in Bionic:
  Fix Released
Status in python-apt source package in Eoan:
  Fix Released

Bug description:
  Impact
  ==

  Under most circumstances, the impact is minimal (a few extra redundant
  comment lines in apt sources. However, if users are automating source
  removal / addition on a machine (as in comment 11), there is the
  potential to wind up with an excessively large (and thus slow to
  parse) apt sources configuration.

  Test packages for the supported releases are available from the
  following PPA:

  https://launchpad.net/~waveform/+archive/ubuntu/python-apt

  Built from the source which can be found in the following branches:

  https://code.launchpad.net/~waveform/ubuntu/+source/python-apt/+git
  /python-apt/+ref/sru-dupe-ppa-xenial

  https://code.launchpad.net/~waveform/ubuntu/+source/python-apt/+git
  /python-apt/+ref/sru-dupe-ppa-bionic

  https://code.launchpad.net/~waveform/ubuntu/+source/python-apt/+git
  /python-apt/+ref/sru-dupe-ppa-eoan

  Test Case
  =

  * sudo add-apt-repository -y ppa:deadsnakes/ppa
  * cat /etc/apt/sources.list.d/deadsnakes*.list
  * Note the presence of one uncommented "deb" line, and one commented 
"deb-src" line
  * sudo add-apt-repository -y ppa:deadsnakes/ppa
  * cat /etc/apt/sources.list.d/deadsnakes*.list
  * Note the uncommented "deb" line is still there but the commented "deb-src" 
line has now been duplicated
  * sudo add-apt-repository ppa:waveform/python-apt
  * sudo apt upgrade  # update python-apt to fixed version
  * sudo add-apt-repository -y ppa:deadsnakes/ppa
  * cat /etc/apt/sources.list.d/deadsnakes*.list
  * Note there has been no further duplication of the commented "deb-src" line

  Regression Potential
  

  Minimal; test cases have been added to cover the duplication case, and
  to cover the enabling of sources (which was not covered by existing
  tests, but was part of the code altered to fix the duplication case),
  and insertion of sources at a position (again, not covered by existing
  tests but modified as part of the fix). The test case has been used
  successfully on all targeted releases (xenial, bionic, and eoan).

  Original Description
  

  Trusty Tahr 14.04

  0 root@osprey:/etc/apt/sources.list.d#cat aims-aims-desktop-trusty.list
  deb http://ppa.launchpad.net/aims/aims-desktop/ubuntu trusty main
  # deb-src http://ppa.launchpad.net/aims/aims-desktop/ubuntu trusty main
  0 root@osprey:/etc/apt/sources.list.d#apt-add-repository -y 
ppa:aims/aims-desktop
  gpg: keyring `/tmp/tmp0ufdhnmv/secring.gpg' created
  gpg: keyring `/tmp/tmp0ufdhnmv/pubring.gpg' created
  gpg: requesting key BE796FF2 from hkp server keyserver.ubuntu.com
  gpg: /tmp/tmp0ufdhnmv/trustdb.gpg: trustdb created
  gpg: key BE796FF2: public key "Launchpad PPA for AIMS" imported
  gpg: Total number processed: 1
  gpg:   imported: 1  (RSA: 1)
  OK
  0 root@osprey:/etc/apt/sources.list.d#cat aims-aims-desktop-trusty.list deb 
http://ppa.launchpad.net/aims/aims-desktop/ubuntu trusty main
  # deb-src http://ppa.launchpad.net/aims/aims-desktop/ubuntu trusty main
  # deb-src http://ppa.launchpad.net/aims/aims-desktop/ubuntu trusty main
  0 root@osprey:/etc/apt/sources.list.d#

  That deb-src line should have stayed commented out, and not been
  duplicated. (Commented deb lines should of course be uncommented, as
  already fixed per https://bugs.launchpad.net/ubuntu/+source/python-
  apt/+bug/1042916 .)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/python-apt/+bug/1311056/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1311056] Re: [SRU] apt-add-repository adds duplicate commented/disabled source lines

2020-06-04 Thread Launchpad Bug Tracker
This bug was fixed in the package python-apt - 1.9.0ubuntu1.4

---
python-apt (1.9.0ubuntu1.4) eoan; urgency=medium

  * Don't duplicate disabled sources during add() (LP: #1311056)

 -- Dave Jones   Fri, 24 Jan 2020 22:08:17
+

** Changed in: python-apt (Ubuntu Eoan)
   Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to python-apt in Ubuntu.
https://bugs.launchpad.net/bugs/1311056

Title:
  [SRU] apt-add-repository adds duplicate commented/disabled source
  lines

Status in python-apt package in Ubuntu:
  Fix Released
Status in python-apt source package in Xenial:
  Fix Released
Status in python-apt source package in Bionic:
  Fix Released
Status in python-apt source package in Eoan:
  Fix Released

Bug description:
  Impact
  ==

  Under most circumstances, the impact is minimal (a few extra redundant
  comment lines in apt sources. However, if users are automating source
  removal / addition on a machine (as in comment 11), there is the
  potential to wind up with an excessively large (and thus slow to
  parse) apt sources configuration.

  Test packages for the supported releases are available from the
  following PPA:

  https://launchpad.net/~waveform/+archive/ubuntu/python-apt

  Built from the source which can be found in the following branches:

  https://code.launchpad.net/~waveform/ubuntu/+source/python-apt/+git
  /python-apt/+ref/sru-dupe-ppa-xenial

  https://code.launchpad.net/~waveform/ubuntu/+source/python-apt/+git
  /python-apt/+ref/sru-dupe-ppa-bionic

  https://code.launchpad.net/~waveform/ubuntu/+source/python-apt/+git
  /python-apt/+ref/sru-dupe-ppa-eoan

  Test Case
  =

  * sudo add-apt-repository -y ppa:deadsnakes/ppa
  * cat /etc/apt/sources.list.d/deadsnakes*.list
  * Note the presence of one uncommented "deb" line, and one commented 
"deb-src" line
  * sudo add-apt-repository -y ppa:deadsnakes/ppa
  * cat /etc/apt/sources.list.d/deadsnakes*.list
  * Note the uncommented "deb" line is still there but the commented "deb-src" 
line has now been duplicated
  * sudo add-apt-repository ppa:waveform/python-apt
  * sudo apt upgrade  # update python-apt to fixed version
  * sudo add-apt-repository -y ppa:deadsnakes/ppa
  * cat /etc/apt/sources.list.d/deadsnakes*.list
  * Note there has been no further duplication of the commented "deb-src" line

  Regression Potential
  

  Minimal; test cases have been added to cover the duplication case, and
  to cover the enabling of sources (which was not covered by existing
  tests, but was part of the code altered to fix the duplication case),
  and insertion of sources at a position (again, not covered by existing
  tests but modified as part of the fix). The test case has been used
  successfully on all targeted releases (xenial, bionic, and eoan).

  Original Description
  

  Trusty Tahr 14.04

  0 root@osprey:/etc/apt/sources.list.d#cat aims-aims-desktop-trusty.list
  deb http://ppa.launchpad.net/aims/aims-desktop/ubuntu trusty main
  # deb-src http://ppa.launchpad.net/aims/aims-desktop/ubuntu trusty main
  0 root@osprey:/etc/apt/sources.list.d#apt-add-repository -y 
ppa:aims/aims-desktop
  gpg: keyring `/tmp/tmp0ufdhnmv/secring.gpg' created
  gpg: keyring `/tmp/tmp0ufdhnmv/pubring.gpg' created
  gpg: requesting key BE796FF2 from hkp server keyserver.ubuntu.com
  gpg: /tmp/tmp0ufdhnmv/trustdb.gpg: trustdb created
  gpg: key BE796FF2: public key "Launchpad PPA for AIMS" imported
  gpg: Total number processed: 1
  gpg:   imported: 1  (RSA: 1)
  OK
  0 root@osprey:/etc/apt/sources.list.d#cat aims-aims-desktop-trusty.list deb 
http://ppa.launchpad.net/aims/aims-desktop/ubuntu trusty main
  # deb-src http://ppa.launchpad.net/aims/aims-desktop/ubuntu trusty main
  # deb-src http://ppa.launchpad.net/aims/aims-desktop/ubuntu trusty main
  0 root@osprey:/etc/apt/sources.list.d#

  That deb-src line should have stayed commented out, and not been
  duplicated. (Commented deb lines should of course be uncommented, as
  already fixed per https://bugs.launchpad.net/ubuntu/+source/python-
  apt/+bug/1042916 .)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/python-apt/+bug/1311056/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868520] Re: Wayland apps fail to run with zwp_linux_dmabuf error (failed to import supplied dmabufs: Unsupported buffer format 808669784 [DRM_FORMAT_XRGB2101010]) (or 808665665

2020-06-04 Thread Timo Aaltonen
The last release of the stable series will be backported once it's
released, just like on every Ubuntu version since many years. It is
expected to be 20.0.8 and should be out in a week or two.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1868520

Title:
  Wayland apps fail to run with zwp_linux_dmabuf error (failed to import
  supplied dmabufs: Unsupported buffer format 808669784
  [DRM_FORMAT_XRGB2101010]) (or 808665665 [DRM_FORMAT_ABGR2101010])

Status in Mesa:
  Fix Released
Status in MPV:
  Unknown
Status in mesa package in Ubuntu:
  Fix Released
Status in mesa source package in Focal:
  Confirmed

Bug description:
  [Impact]

  Wayland apps fail to start in focal with:

  error 7: failed to import supplied dmabufs: Unsupported buffer format
  808669784

  [Test Case]

  Just run: es2gears_wayland

  [Regression Potential]

  Medium/unknown. The fix is quite new.

  [Other Info]

  When attempting to run es2gears_wayland against GNOME Shell, it fails
  with:

  EGL_VERSION = 1.5
  vertex shader info:
  fragment shader info:
  info:
  [destroyed object]: error 7: failed to import supplied dmabufs: Unsupported 
buffer format 808669784

  The full wayland protocol trace is:

  [3104432.914]  -> wl_display@1.get_registry(new id wl_registry@2)
  [3104432.972]  -> wl_disp...@1.sync(new id wl_callback@3)
  [3104433.139] wl_display@1.delete_id(3)
  [3104433.175] wl_registry@2.global(1, "wl_drm", 2)
  [3104433.207] wl_registry@2.global(2, "wl_compositor", 4)
  [3104433.240]  -> wl_regis...@2.bind(2, "wl_compositor", 1, new id 
[unknown]@4)
  [3104433.285] wl_registry@2.global(3, "wl_shm", 1)
  [3104433.316] wl_registry@2.global(4, "wl_output", 2)
  [3104433.347] wl_registry@2.global(5, "zxdg_output_manager_v1", 3)
  [3104433.376] wl_registry@2.global(6, "wl_data_device_manager", 3)
  [3104433.404] wl_registry@2.global(7, "gtk_primary_selection_device_manager", 
1)
  [3104433.432] wl_registry@2.global(8, "wl_subcompositor", 1)
  [3104433.459] wl_registry@2.global(9, "xdg_wm_base", 2)
  [3104433.485] wl_registry@2.global(10, "zxdg_shell_v6", 1)
  [3104433.513] wl_registry@2.global(11, "wl_shell", 1)
  [3104433.542]  -> wl_regis...@2.bind(11, "wl_shell", 1, new id [unknown]@5)
  [3104433.582] wl_registry@2.global(12, "gtk_shell1", 3)
  [3104433.611] wl_registry@2.global(13, "wp_viewporter", 1)
  [3104433.640] wl_registry@2.global(14, "zwp_pointer_gestures_v1", 1)
  [3104433.670] wl_registry@2.global(15, "zwp_tablet_manager_v2", 1)
  [3104433.699] wl_registry@2.global(16, "wl_seat", 5)
  [3104433.728] wl_registry@2.global(17, "zwp_relative_pointer_manager_v1", 1)
  [3104433.758] wl_registry@2.global(18, "zwp_pointer_constraints_v1", 1)
  [3104433.787] wl_registry@2.global(19, "zxdg_exporter_v1", 1)
  [3104433.816] wl_registry@2.global(20, "zxdg_importer_v1", 1)
  [3104433.846] wl_registry@2.global(21, "zwp_linux_dmabuf_v1", 3)
  [3104433.875] wl_registry@2.global(22, 
"zwp_keyboard_shortcuts_inhibit_manager_v1", 1)
  [3104433.904] wl_registry@2.global(23, "zwp_text_input_manager_v3", 1)
  [3104433.933] wl_registry@2.global(24, "gtk_text_input_manager", 1)
  [3104433.960] wl_registry@2.global(26, "wl_eglstream_controller", 1)
  [3104433.991] wl_callb...@3.done(3421)
  [3104436.266]  -> wl_display@1.get_registry(new id wl_registry@3)
  [3104436.279]  -> wl_disp...@1.sync(new id wl_callback@6)
  [3104436.647] wl_display@1.delete_id(6)
  [3104436.672] wl_registry@3.global(1, "wl_drm", 2)
  [3104436.726]  -> wl_regis...@3.bind(1, "wl_drm", 2, new id [unknown]@7)
  [3104436.744] wl_registry@3.global(2, "wl_compositor", 4)
  [3104436.780] wl_registry@3.global(3, "wl_shm", 1)
  [3104436.790] wl_registry@3.global(4, "wl_output", 2)
  [3104436.803] wl_registry@3.global(5, "zxdg_output_manager_v1", 3)
  [3104436.833] wl_registry@3.global(6, "wl_data_device_manager", 3)
  [3104436.868] wl_registry@3.global(7, "gtk_primary_selection_device_manager", 
1)
  [3104436.882] wl_registry@3.global(8, "wl_subcompositor", 1)
  [3104436.898] wl_registry@3.global(9, "xdg_wm_base", 2)
  [3104436.913] wl_registry@3.global(10, "zxdg_shell_v6", 1)
  [3104436.925] wl_registry@3.global(11, "wl_shell", 1)
  [3104436.937] wl_registry@3.global(12, "gtk_shell1", 3)
  [3104436.950] wl_registry@3.global(13, "wp_viewporter", 1)
  [3104436.963] wl_registry@3.global(14, "zwp_pointer_gestures_v1", 1)
  [3104436.976] wl_registry@3.global(15, "zwp_tablet_manager_v2", 1)
  [3104436.990] wl_registry@3.global(16, "wl_seat", 5)
  [3104437.001] wl_registry@3.global(17, "zwp_relative_pointer_manager_v1", 1)
  [3104437.013] wl_registry@3.global(18, "zwp_pointer_constraints_v1", 1)
  [3104437.026] wl_registry@3.global(19, "zxdg_exporter_v1", 1)
  [3104437.038] wl_registry@3.global(20, "zxdg_importer_v1", 1)
  [3104437.051] wl_registry@3.global(21, "zwp_linux_dmabuf_v1", 3)
  [3104437.066]  -> wl_regis...@3.bind(21, "zwp_linux_dmabuf_v1", 3, 

[Touch-packages] [Bug 1874953] Re: dpkg: conffile difference visualizer subprocess returned error exit status 127

2020-06-04 Thread Brian Murray
** Tags removed: rls-ff-incoming

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to less in Ubuntu.
https://bugs.launchpad.net/bugs/1874953

Title:
  dpkg: conffile difference visualizer subprocess returned error exit
  status 127

Status in dpkg package in Ubuntu:
  Triaged
Status in less package in Ubuntu:
  Triaged
Status in smartmontools package in Ubuntu:
  Invalid
Status in dpkg source package in Focal:
  New
Status in less source package in Focal:
  Triaged
Status in smartmontools source package in Focal:
  New
Status in dpkg source package in Groovy:
  Triaged
Status in less source package in Groovy:
  Triaged
Status in smartmontools source package in Groovy:
  Invalid
Status in dpkg package in Debian:
  New

Bug description:
  Issue occurred on upgrade from 19.10 to 20.04

  ProblemType: Package
  DistroRelease: Ubuntu 20.04
  Package: smartmontools 7.1-1build1
  ProcVersionSignature: Ubuntu 5.3.0-46.38-generic 5.3.18
  Uname: Linux 5.3.0-46-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27
  Architecture: amd64
  CasperMD5CheckResult: skip
  Date: Fri Apr 24 21:33:08 2020
  ErrorMessage: conffile difference visualizer subprocess returned error exit 
status 127
  InstallationDate: Installed on 2011-06-18 (3233 days ago)
  InstallationMedia: Ubuntu-Server 11.04 "Natty Narwhal" - Release amd64 
(20110426)
  Python3Details: /usr/bin/python3.8, Python 3.8.2, python3-minimal, 
3.8.2-0ubuntu2
  PythonDetails: /usr/bin/python2.7, Python 2.7.18rc1, python-is-python2, 
2.7.17-4
  RelatedPackageVersions:
   dpkg 1.19.7ubuntu3
   apt  2.0.2
  SourcePackage: smartmontools
  Title: package smartmontools 7.1-1build1 failed to install/upgrade: conffile 
difference visualizer subprocess returned error exit status 127
  UpgradeStatus: Upgraded to focal on 2020-04-25 (0 days ago)
  mtime.conffile..etc.default.smartmontools: 2017-12-08T19:12:02.064375
  mtime.conffile..etc.smartd.conf: 2017-12-08T20:27:28.727282

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dpkg/+bug/1874953/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868520] Re: Wayland apps fail to run with zwp_linux_dmabuf error (failed to import supplied dmabufs: Unsupported buffer format 808669784 [DRM_FORMAT_XRGB2101010]) (or 808665665

2020-06-04 Thread Christian Rauch
Is Mesa 20.0.7 going to be backported to Ubuntu Focal? It would be a
shame to be unable to use native OpenGL programs on Wayland for the next
5 years.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1868520

Title:
  Wayland apps fail to run with zwp_linux_dmabuf error (failed to import
  supplied dmabufs: Unsupported buffer format 808669784
  [DRM_FORMAT_XRGB2101010]) (or 808665665 [DRM_FORMAT_ABGR2101010])

Status in Mesa:
  Fix Released
Status in MPV:
  Unknown
Status in mesa package in Ubuntu:
  Fix Released
Status in mesa source package in Focal:
  Confirmed

Bug description:
  [Impact]

  Wayland apps fail to start in focal with:

  error 7: failed to import supplied dmabufs: Unsupported buffer format
  808669784

  [Test Case]

  Just run: es2gears_wayland

  [Regression Potential]

  Medium/unknown. The fix is quite new.

  [Other Info]

  When attempting to run es2gears_wayland against GNOME Shell, it fails
  with:

  EGL_VERSION = 1.5
  vertex shader info:
  fragment shader info:
  info:
  [destroyed object]: error 7: failed to import supplied dmabufs: Unsupported 
buffer format 808669784

  The full wayland protocol trace is:

  [3104432.914]  -> wl_display@1.get_registry(new id wl_registry@2)
  [3104432.972]  -> wl_disp...@1.sync(new id wl_callback@3)
  [3104433.139] wl_display@1.delete_id(3)
  [3104433.175] wl_registry@2.global(1, "wl_drm", 2)
  [3104433.207] wl_registry@2.global(2, "wl_compositor", 4)
  [3104433.240]  -> wl_regis...@2.bind(2, "wl_compositor", 1, new id 
[unknown]@4)
  [3104433.285] wl_registry@2.global(3, "wl_shm", 1)
  [3104433.316] wl_registry@2.global(4, "wl_output", 2)
  [3104433.347] wl_registry@2.global(5, "zxdg_output_manager_v1", 3)
  [3104433.376] wl_registry@2.global(6, "wl_data_device_manager", 3)
  [3104433.404] wl_registry@2.global(7, "gtk_primary_selection_device_manager", 
1)
  [3104433.432] wl_registry@2.global(8, "wl_subcompositor", 1)
  [3104433.459] wl_registry@2.global(9, "xdg_wm_base", 2)
  [3104433.485] wl_registry@2.global(10, "zxdg_shell_v6", 1)
  [3104433.513] wl_registry@2.global(11, "wl_shell", 1)
  [3104433.542]  -> wl_regis...@2.bind(11, "wl_shell", 1, new id [unknown]@5)
  [3104433.582] wl_registry@2.global(12, "gtk_shell1", 3)
  [3104433.611] wl_registry@2.global(13, "wp_viewporter", 1)
  [3104433.640] wl_registry@2.global(14, "zwp_pointer_gestures_v1", 1)
  [3104433.670] wl_registry@2.global(15, "zwp_tablet_manager_v2", 1)
  [3104433.699] wl_registry@2.global(16, "wl_seat", 5)
  [3104433.728] wl_registry@2.global(17, "zwp_relative_pointer_manager_v1", 1)
  [3104433.758] wl_registry@2.global(18, "zwp_pointer_constraints_v1", 1)
  [3104433.787] wl_registry@2.global(19, "zxdg_exporter_v1", 1)
  [3104433.816] wl_registry@2.global(20, "zxdg_importer_v1", 1)
  [3104433.846] wl_registry@2.global(21, "zwp_linux_dmabuf_v1", 3)
  [3104433.875] wl_registry@2.global(22, 
"zwp_keyboard_shortcuts_inhibit_manager_v1", 1)
  [3104433.904] wl_registry@2.global(23, "zwp_text_input_manager_v3", 1)
  [3104433.933] wl_registry@2.global(24, "gtk_text_input_manager", 1)
  [3104433.960] wl_registry@2.global(26, "wl_eglstream_controller", 1)
  [3104433.991] wl_callb...@3.done(3421)
  [3104436.266]  -> wl_display@1.get_registry(new id wl_registry@3)
  [3104436.279]  -> wl_disp...@1.sync(new id wl_callback@6)
  [3104436.647] wl_display@1.delete_id(6)
  [3104436.672] wl_registry@3.global(1, "wl_drm", 2)
  [3104436.726]  -> wl_regis...@3.bind(1, "wl_drm", 2, new id [unknown]@7)
  [3104436.744] wl_registry@3.global(2, "wl_compositor", 4)
  [3104436.780] wl_registry@3.global(3, "wl_shm", 1)
  [3104436.790] wl_registry@3.global(4, "wl_output", 2)
  [3104436.803] wl_registry@3.global(5, "zxdg_output_manager_v1", 3)
  [3104436.833] wl_registry@3.global(6, "wl_data_device_manager", 3)
  [3104436.868] wl_registry@3.global(7, "gtk_primary_selection_device_manager", 
1)
  [3104436.882] wl_registry@3.global(8, "wl_subcompositor", 1)
  [3104436.898] wl_registry@3.global(9, "xdg_wm_base", 2)
  [3104436.913] wl_registry@3.global(10, "zxdg_shell_v6", 1)
  [3104436.925] wl_registry@3.global(11, "wl_shell", 1)
  [3104436.937] wl_registry@3.global(12, "gtk_shell1", 3)
  [3104436.950] wl_registry@3.global(13, "wp_viewporter", 1)
  [3104436.963] wl_registry@3.global(14, "zwp_pointer_gestures_v1", 1)
  [3104436.976] wl_registry@3.global(15, "zwp_tablet_manager_v2", 1)
  [3104436.990] wl_registry@3.global(16, "wl_seat", 5)
  [3104437.001] wl_registry@3.global(17, "zwp_relative_pointer_manager_v1", 1)
  [3104437.013] wl_registry@3.global(18, "zwp_pointer_constraints_v1", 1)
  [3104437.026] wl_registry@3.global(19, "zxdg_exporter_v1", 1)
  [3104437.038] wl_registry@3.global(20, "zxdg_importer_v1", 1)
  [3104437.051] wl_registry@3.global(21, "zwp_linux_dmabuf_v1", 3)
  [3104437.066]  -> wl_regis...@3.bind(21, "zwp_linux_dmabuf_v1", 3, new id 
[unknown]@8)
  [3104437.083] 

[Touch-packages] [Bug 1867424] Re: motd-news transmitting private hardware data without consent or knowledge in background

2020-06-04 Thread Guy Baconniere
Thanks security-conscious Dustin Kirkland for this great bash script 
("I've insisted on shell here for transparency! - Dustin ")
and other contributions like NSA's SELinux or security sensible
software like Pollinate  (Entropy-as-a-Service in the cloud) via
https://entropy.ubuntu.com

Packing so many sensible info inside User-Agent sent daily by default
from all Ubuntu to https://motd.ubuntu.com is brillant!

less /etc/update-motd.d/50-motd-news
```
#50-motd-news - print the live news from the Ubuntu wire
#Copyright (C) 2016-2017 Canonical Ltd.
#Copyright (C) 2016-2017 Dustin Kirkland

##
# This program could be rewritten in C or Golang for faster performance.
# Or it could be rewritten in Python or another higher level language
# for more modularity.
# However, I've insisted on shell here for transparency!
# - Dustin
##

# Curl browser version, for debug purposes
curl_ver="$(dpkg -l curl | awk '$1 == "ii" { print($3); exit(0); }')"

# Distribution version, for messages releated to this Ubuntu release
. /etc/lsb-release
lsb=$(echo "$DISTRIB_DESCRIPTION" | sed -e "s/ /\//g")
codename="$DISTRIB_CODENAME"

# Kernel version and CPU type, for messages related to a particular revision or 
hardware
platform="$(uname -o)/$(uname -r)/$(uname -m)"
arch="$(uname -m)"
cpu="$(grep -m1 "^model name" /proc/cpuinfo | sed -e "s/.*: //" -e 
"s:\s\+:/:g")"
cloud_id="unknown"
if [ -x /usr/bin/cloud-id ]; then
/usr/bin/cloud-id > "$CLOUD" 2>/dev/null
if [ $? -eq 0 ]; then
# sanitize it a bit, just in case
cloud_id=$(cut -c -40 "${CLOUD}" | tr -c -d '[:alnum:]')
if [ -z "${cloud_id}" ]; then
cloud_id="unknown"
fi
fi
fi

# Some messages may only be pertinent before or after some amount of uptime
read up idle < /proc/uptime
uptime="uptime/$up/$idle"

# Piece together the user agent
USER_AGENT="curl/$curl_ver $lsb $platform $cpu $uptime cloud_id/$cloud_id"

...

# Fetch and print the news motd
if curl --connect-timeout "$WAIT" --max-time "$WAIT" -A "$USER_AGENT" 
-o- "$u" >"$NEWS" 2>"$ERR"; then

```

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to base-files in Ubuntu.
https://bugs.launchpad.net/bugs/1867424

Title:
  motd-news transmitting private hardware data without consent or
  knowledge in background

Status in base-files package in Ubuntu:
  Confirmed

Bug description:
  In package base-files there is a script /etc/update-motd.d/50-motd-
  news that harvests private hardware data from the machine and
  transmits it in the background every day.  There is no notice, no
  consent, no nothing.  This should be by default disabled until there
  is informed consent.

  This solution is simple:

  1. Change ENABLED=1 to ENABLED=0 in the file /etc/default/motd-news and 
  2. Place a comment in the file disclosing the fact that the 50-motd-news 
script will harvest private hardware data and upload it to motd.ubuntu.com 
daily if the end-user enables it.

  Creating databases that maps ip address to specify hardware is a
  threat to both privacy and security.  If an adversary knows the
  specific hardware and the ip address for that hardware their ability
  to successfully attack it is greatly increased.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/base-files/+bug/1867424/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1874953] Re: dpkg: conffile difference visualizer subprocess returned error exit status 127

2020-06-04 Thread Dimitri John Ledkov
We must not change the location of binaries from /bin to /usr/bin or
vice-versa, inside the deb.

It doesn't matter on freshly installed systems that have usr-merge, but
breaks upgraded systems.

This must be reverted.

** Also affects: dpkg (Ubuntu Groovy)
   Importance: High
   Status: Triaged

** Also affects: less (Ubuntu Groovy)
   Importance: Critical
   Status: Confirmed

** Also affects: smartmontools (Ubuntu Groovy)
   Importance: Undecided
   Status: Invalid

** Also affects: dpkg (Ubuntu Focal)
   Importance: Undecided
   Status: New

** Also affects: less (Ubuntu Focal)
   Importance: Undecided
   Status: New

** Also affects: smartmontools (Ubuntu Focal)
   Importance: Undecided
   Status: New

** Changed in: less (Ubuntu Focal)
   Importance: Undecided => Critical

** Changed in: less (Ubuntu Focal)
   Status: New => Triaged

** Changed in: less (Ubuntu Groovy)
   Status: Confirmed => Triaged

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to less in Ubuntu.
https://bugs.launchpad.net/bugs/1874953

Title:
  dpkg: conffile difference visualizer subprocess returned error exit
  status 127

Status in dpkg package in Ubuntu:
  Triaged
Status in less package in Ubuntu:
  Triaged
Status in smartmontools package in Ubuntu:
  Invalid
Status in dpkg source package in Focal:
  New
Status in less source package in Focal:
  Triaged
Status in smartmontools source package in Focal:
  New
Status in dpkg source package in Groovy:
  Triaged
Status in less source package in Groovy:
  Triaged
Status in smartmontools source package in Groovy:
  Invalid
Status in dpkg package in Debian:
  New

Bug description:
  Issue occurred on upgrade from 19.10 to 20.04

  ProblemType: Package
  DistroRelease: Ubuntu 20.04
  Package: smartmontools 7.1-1build1
  ProcVersionSignature: Ubuntu 5.3.0-46.38-generic 5.3.18
  Uname: Linux 5.3.0-46-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27
  Architecture: amd64
  CasperMD5CheckResult: skip
  Date: Fri Apr 24 21:33:08 2020
  ErrorMessage: conffile difference visualizer subprocess returned error exit 
status 127
  InstallationDate: Installed on 2011-06-18 (3233 days ago)
  InstallationMedia: Ubuntu-Server 11.04 "Natty Narwhal" - Release amd64 
(20110426)
  Python3Details: /usr/bin/python3.8, Python 3.8.2, python3-minimal, 
3.8.2-0ubuntu2
  PythonDetails: /usr/bin/python2.7, Python 2.7.18rc1, python-is-python2, 
2.7.17-4
  RelatedPackageVersions:
   dpkg 1.19.7ubuntu3
   apt  2.0.2
  SourcePackage: smartmontools
  Title: package smartmontools 7.1-1build1 failed to install/upgrade: conffile 
difference visualizer subprocess returned error exit status 127
  UpgradeStatus: Upgraded to focal on 2020-04-25 (0 days ago)
  mtime.conffile..etc.default.smartmontools: 2017-12-08T19:12:02.064375
  mtime.conffile..etc.smartd.conf: 2017-12-08T20:27:28.727282

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dpkg/+bug/1874953/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1879533] Autopkgtest regression report (busybox/1:1.30.1-4ubuntu6.1)

2020-06-04 Thread Ubuntu SRU Bot
All autopkgtests for the newly accepted busybox (1:1.30.1-4ubuntu6.1) for focal 
have finished running.
The following regressions have been reported in tests triggered by the package:

casper/1.445 (amd64)


Please visit the excuses page listed below and investigate the failures, 
proceeding afterwards as per the StableReleaseUpdates policy regarding 
autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-
migration/focal/update_excuses.html#busybox

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to busybox in Ubuntu.
https://bugs.launchpad.net/bugs/1879533

Title:
  busybox does not verify TLS connections with
  CONFIG_FEATURE_WGET_OPENSSL=y and CONFIG_FEATURE_WGET_HTTPS unset, and
  doesn't warn either about it

Status in busybox package in Ubuntu:
  Fix Released
Status in busybox source package in Focal:
  Fix Committed
Status in busybox source package in Groovy:
  Fix Released

Bug description:
  [Impact]

   * CONFIG_FEATURE_WGET_OPENSSL=y enables https support in wget busybox
  applet using openssl

   * CONFIG_FEATURE_WGET_HTTPS=y enables https support in wget busybox
  applet using internal TLS code

   * CVE-2018-1000500 ensured that when CONFIG_FEATURE_WGET_HTTPS=y is
  used, a message is printed to notify the users that TLS verification
  is not perfomed.

   * However, when one configures with CONFIG_FEATURE_WGET_OPENSSL=y and
  CONFIG_FEATURE_WGET_HTTPS unset - no such message is printed.

   * Also TLS verification is not performed under OPENSSL case.

   * When performing https requests, it works openssl s_client and communicates 
with it to perform https download
   * Whilst doing so, it does not pass `-verify_return_error` option, meaning 
any verification errors are ignored

   * There is no warning that TLS verification was not performed

  [Test Case]

   * Preparation: sudo apt install busybox; or build busybox with
  CONFIG_FEATURE_WGET_OPENSSL=y

   * Test case: /bin/busybox wget https://untrusted-root.badssl.com/

   * Expected: download failed, or download suceeds with warning printed
  that verification is disabled

   * Observed: download success without a warning that verification is
  disabled.

  $ /bin/busybox wget https://untrusted-root.badssl.com/
  Connecting to untrusted-root.badssl.com (104.154.89.105:443)
  index.html   100% 
|*|
   600  0:00:00 ETA

  $ cat index.html  | grep certificate
    The certificate for this site is signed using an untrusted root.

  [Regression Potential]

   * The fact that /bin/busybox wget https:// succeeds without TLS
  verification might be relied upon. If this issue is fixed, ensure that
  `--no-check-certificate` is honored.

  [Other Info]

   * Proposed fix

     pass `-verify_return_error` to s_client, unless `--no-check-
  certificate` is specified

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/busybox/+bug/1879533/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1879525] Autopkgtest regression report (busybox/1:1.30.1-4ubuntu6.1)

2020-06-04 Thread Ubuntu SRU Bot
All autopkgtests for the newly accepted busybox (1:1.30.1-4ubuntu6.1) for focal 
have finished running.
The following regressions have been reported in tests triggered by the package:

casper/1.445 (amd64)


Please visit the excuses page listed below and investigate the failures, 
proceeding afterwards as per the StableReleaseUpdates policy regarding 
autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-
migration/focal/update_excuses.html#busybox

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to busybox in Ubuntu.
https://bugs.launchpad.net/bugs/1879525

Title:
  Add TLS support

Status in busybox package in Ubuntu:
  Fix Released
Status in busybox source package in Focal:
  Fix Committed

Bug description:
  [Impact]

   * busybox in the initramfs provides wget applet that is used by casper for 
netboot support
   * It does not support https at the moment, but it is desirable that it does
   * There is built-in TLS code, or "fork & execute openssl"
   * Enable the later one, and optionally include /usr/bin/openssl & certs, 
when building casper-like initrds which should support netboot.

  [Test Case]

   * Boot casper created initrd, with break=bottom
   * Configure dhcp based networking
   * Attempt to wget https://start.ubuntu.com/connectivity-check
   * It should succeed

  [Regression Potential]

   * The openssl codepath is optional in busybox wget, and we only include 
openssl & certs for casper.
   * The casper based initrd will grow in size, due to inclusion of openssl & 
certs

  [Other Info]
   
   * Parity with d-i, which includes https support already

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/busybox/+bug/1879525/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1880853] Re: libc6-lse lets update-initramfs fail on AWS m6g instances

2020-06-04 Thread Gianfranco Costamagna
** Tags removed: verification-needed
** Tags added: verification-done

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1880853

Title:
  libc6-lse lets update-initramfs fail on AWS m6g instances

Status in cloud-images:
  New
Status in btrfs-progs package in Ubuntu:
  Invalid
Status in glibc package in Ubuntu:
  Invalid
Status in initramfs-tools package in Ubuntu:
  Fix Released
Status in btrfs-progs source package in Focal:
  Invalid
Status in glibc source package in Focal:
  Invalid
Status in initramfs-tools source package in Focal:
  Fix Committed

Bug description:
  [Impact]

   * update-initramfs -u fails on arm64 m6g instances in AWS

  [Test Case]

   * launch m6g instance in AWS
   * install libc6-lse (if not installed)
   * run $ update-initramfs -u
   * It should suceed

  [Regression Potential]

   * Adding one more path to libgcc_s1 resolution. This will still fail
  if something compiles libc6 for _two_ optimisations like
  /lib/$arch/foo/bar/libpthread.

  [Other Info]

   * libphtread dlopens libgcc_s1, thus whenever libpthread is needed in
  the initrd libgcc_s1 must be copied in too. However the logic to find
  matching libgcc_s1 is broken for optimizied builds of libc6 without
  optimized build of libgcc_s1. I think libpthread should link against
  libgcc_s1 to prevent these issues.

   * Original bug report

  With Ubuntu 20.04 on AWS m6g.* instance family, installing libc6-lse
  lets update-initramfs always fail with the following error:

  ubuntu@ip-10-18-23-79:~$ sudo update-initramfs -u
  update-initramfs: Generating /boot/initrd.img-5.4.0-1011-aws
  E: /usr/share/initramfs-tools/hooks/btrfs failed with return 1.
  update-initramfs: failed for /boot/initrd.img-5.4.0-1011-aws with 1.

  ## Steps to reproduce (on AWS)

  ### With focal 20200423 AMI

  1. Find the following AMI and launch on m6g instance family

     ubuntu/images/hvm-ssd/ubuntu-focal-20.04-arm64-server-20200423

  2. Run: sudo apt update && sudo apt install libc6-lse
  3. Try: sudo update-initramfs -u

  ### With focal 20200522 AMI

  1. Find the following AMI and launch on m6g instance family

     ubuntu/images/hvm-ssd/ubuntu-focal-20.04-arm64-server-20200522

  2. Try: sudo update-initramfs -u

  ## Note

  - The entire log of the above steps performed on 20200423 AMI is attached.
  - Latest cloud-image AMI 
"ubuntu/images/hvm-ssd/ubuntu-focal-20.04-arm64-server-20200522" includes 
libc6-lse. On 20200522 AMI, this doesn't reproduce after removing libc6-lse 
manually.
  - This doesn't reproduce on EC2 a1.* instance family.

  ## Expected behavior

  Does not fail.

  ## Background to find this bug

  As the 20200522 AMI includes libc6-lse out-of-the-box & apt-get
  upgrade pulls newer package that triggers update-initramfs, apt-get
  upgrade always fail on 20200522 AMI.

  the following is an apport report on 20200423 AMI:

  

  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27
  Architecture: arm64
  CasperMD5CheckResult: skip
  Date: Wed May 27 09:52:16 2020
  Dependencies:
   gcc-10-base 10-20200411-0ubuntu1
   libc6 2.31-0ubuntu9
   libcrypt1 1:4.4.10-10ubuntu4
   libgcc-s1 10-20200411-0ubuntu1
   libidn2-0 2.2.0-2
   libunistring2 0.9.10-2
  DistroRelease: Ubuntu 20.04
  Ec2AMI: ami-061102f51d47b1c24
  Ec2AMIManifest: (unknown)
  Ec2AvailabilityZone: ap-northeast-1c
  Ec2InstanceType: m6g.medium
  Ec2Kernel: unavailable
  Ec2Ramdisk: unavailable
  Package: libc6-lse 2.31-0ubuntu9
  PackageArchitecture: arm64
  ProcCpuinfoMinimal:
   processor  : 0
   BogoMIPS   : 243.75
   Features   : fp asimd evtstrm aes pmull sha1 sha2 crc32 atomics fphp 
asimdhp cpuid asimdrdm lrcpc dcpop asimddp ssbs
   CPU implementer: 0x41
   CPU architecture: 8
   CPU variant: 0x3
   CPU part   : 0xd0c
   CPU revision   : 1
  ProcEnviron:
   LANG=C.UTF-8
   TERM=screen-256color
   PATH=(custom, no user)
   SHELL=/bin/bash
  ProcVersionSignature: Ubuntu 5.4.0-1009.9-aws 5.4.30
  SourcePackage: glibc
  Tags:  focal ec2-images
  Uname: Linux 5.4.0-1009-aws aarch64
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/cloud-images/+bug/1880853/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1882112] [NEW] Xorg freeze

2020-06-04 Thread Robin
Public bug reported:

This may be correlated to the move to Bionic Beaver(?) LTS, now 18.04.4.
It may also be correlated to getting low on disk space on my system
drive (50GB SSD) and putting pressure on swap space. e.g when system HDD
<= 1GB.   My secondary HDD is a 1TB USB spinning device that sometimes
seems to go into sleep mode and then fails to rapidly respond to IO
request or may be is in a 'hot IO' state. On my Bus I have a low
capacity HDD that is essentially unused because it rarely comes ready
when I boot.  If it is partially alive it is conceivable that it might
be chattering and so competing for IO interrupt handling bandwidth?

The problem only occurs when I have selected the desktop management tile
from the 'side tray' and if I then shuffle or better align the windows
inside one of the four desktops so as to stop them running into the
neighbouring desktop area. Particularly, it seems to me, when at least
one of the desktops is quite busy with windows open in it and the
overlapped desktop has a few also.  The fewer windows in total across
the desktops the less likely it seems that rearranging a few will have
any bad effect.

When the freeze occurs then 60%(?) of the time it ends in a 'big red
switch' reboot.  The cursor stays active but ineffective.  Keyboard
combinations, like Alt+W, will sometimes succeed in bringing up to full
screen mode and active the desktop that was in focus and constitutes a
recovery.  Other times, and keys, will delete focussed windows in the
focussed desktop, and Tab will move focus around the 4 desktops.
SHIFT+Print Screen also executes but just takes the whole screen and
dumps it somewhere I haven't yet located... with sound effect.

Hope this helps... I am not at fully at home with Ubuntu/Linux yet... having 
spent a lifetime on glasshouse legacy IBM mainframe field systems engineering.  
I am making myself more system disk space meanwhile, and while extract my old 
Maxtor.  It would be nice if I didn't have to up my system disk to hundreds of 
GB!   
best regards,
Rob

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xorg 1:7.7+19ubuntu7.1
ProcVersionSignature: Ubuntu 4.15.0-101.102-generic 4.15.18
Uname: Linux 4.15.0-101-generic x86_64
.tmp.unity_support_test.0:
 
ApportVersion: 2.20.9-0ubuntu7.15
Architecture: amd64
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity:Unity7:ubuntu
Date: Thu Jun  4 11:31:56 2020
DistUpgraded: Fresh install
DistroCodename: bionic
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GpuHangFrequency: Several times a week
GpuHangReproducibility: Occurs more often under certain circumstances
GpuHangStarted: I don't know
GraphicsCard:
 Advanced Micro Devices, Inc. [AMD/ATI] Trinity [Radeon HD 7480D] [1002:9993] 
(prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Trinity [Radeon HD 7480D] [1043:8526]
InstallationDate: Installed on 2016-11-27 (1284 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
MachineType: System manufacturer System Product Name
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-101-generic 
root=UUID=1d959d4a-ac83-43a5-8c0f-a6956d68c1f8 ro quiet splash vt.handoff=1
SourcePackage: xorg
Symptom: display
Title: Xorg freeze
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/10/2013
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0802
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: A55BM-E
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr0802:bd10/10/2013:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnA55BM-E:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.family: To be filled by O.E.M.
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.13.1+18.04.20180302-0ubuntu1
version.libdrm2: libdrm2 2.4.99-1ubuntu1~18.04.2
version.libgl1-mesa-dri: libgl1-mesa-dri 19.2.8-0ubuntu0~18.04.3
version.libgl1-mesa-glx: libgl1-mesa-glx 19.2.8-0ubuntu0~18.04.3
version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4.4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.5-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.0.1-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20171229-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2
xserver.bootTime: Sat Aug 18 06:53:30 2018
xserver.configfile: default
xserver.errors:
 
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.18.4-0ubuntu0.7
xserver.video_driver: radeon

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: 

[Touch-packages] [Bug 1875665] Re: rtkit-daemon[*]: Failed to make ourselves RT: Operation not permitted after upgrade to 20.04

2020-06-04 Thread Oleg B
The fix does not work for me:

uname -r
5.4.0-33-generic

ournalctl -b0 -u rtkit-daemon
-- Logs begin at Wed 2020-04-29 18:57:09 EEST, end at Thu 2020-06-04 18:41:05 
EEST. --
Jun 04 18:26:06 n552vw systemd[1]: Starting RealtimeKit Scheduling Policy 
Service...
Jun 04 18:26:06 n552vw systemd[1]: Started RealtimeKit Scheduling Policy 
Service.
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Successfully called chroot.
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Successfully dropped privileges.
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Successfully limited resources.
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Running.
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Canary thread running.
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Watchdog thread running.
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Supervising 0 threads of 0 processes 
of 1 users.
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Supervising 0 threads of 0 processes 
of 1 users.
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Supervising 0 threads of 0 processes 
of 1 users.
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Supervising 0 threads of 0 processes 
of 1 users.
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Supervising 0 threads of 0 processes 
of 1 users.
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Supervising 0 threads of 0 processes 
of 1 users.
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Supervising 0 threads of 0 processes 
of 1 users.
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Supervising 0 threads of 0 processes 
of 1 users.
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Supervising 0 threads of 0 processes 
of 1 users.
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Supervising 0 threads of 0 processes 
of 1 users.
Jun 04 18:26:06 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:49 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:49 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:49 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:49 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:49 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:49 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:49 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:49 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:49 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:49 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:49 n552vw rtkit-daemon[1430]: Failed to make ourselves RT: 
Operation not permitted
Jun 04 18:26:49 n552vw rtkit-daemon[1430]: Supervising 0 threads of 0 processes 
of 1 users.
Jun 04 18:26:49 

[Touch-packages] [Bug 1874953] Re: dpkg: conffile difference visualizer subprocess returned error exit status 127

2020-06-04 Thread Dimitri John Ledkov
** Changed in: less (Ubuntu)
   Importance: Undecided => Critical

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to less in Ubuntu.
https://bugs.launchpad.net/bugs/1874953

Title:
  dpkg: conffile difference visualizer subprocess returned error exit
  status 127

Status in dpkg package in Ubuntu:
  Triaged
Status in less package in Ubuntu:
  Confirmed
Status in smartmontools package in Ubuntu:
  Invalid
Status in dpkg package in Debian:
  New

Bug description:
  Issue occurred on upgrade from 19.10 to 20.04

  ProblemType: Package
  DistroRelease: Ubuntu 20.04
  Package: smartmontools 7.1-1build1
  ProcVersionSignature: Ubuntu 5.3.0-46.38-generic 5.3.18
  Uname: Linux 5.3.0-46-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27
  Architecture: amd64
  CasperMD5CheckResult: skip
  Date: Fri Apr 24 21:33:08 2020
  ErrorMessage: conffile difference visualizer subprocess returned error exit 
status 127
  InstallationDate: Installed on 2011-06-18 (3233 days ago)
  InstallationMedia: Ubuntu-Server 11.04 "Natty Narwhal" - Release amd64 
(20110426)
  Python3Details: /usr/bin/python3.8, Python 3.8.2, python3-minimal, 
3.8.2-0ubuntu2
  PythonDetails: /usr/bin/python2.7, Python 2.7.18rc1, python-is-python2, 
2.7.17-4
  RelatedPackageVersions:
   dpkg 1.19.7ubuntu3
   apt  2.0.2
  SourcePackage: smartmontools
  Title: package smartmontools 7.1-1build1 failed to install/upgrade: conffile 
difference visualizer subprocess returned error exit status 127
  UpgradeStatus: Upgraded to focal on 2020-04-25 (0 days ago)
  mtime.conffile..etc.default.smartmontools: 2017-12-08T19:12:02.064375
  mtime.conffile..etc.smartd.conf: 2017-12-08T20:27:28.727282

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dpkg/+bug/1874953/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1879206] Re: cups hplip not install printer

2020-06-04 Thread Manfred Hampl
Ubuntu 20.04 needs
- either the HPLIP version 3.20.3+dfsg0-2 packages from the Ubuntu repositories
- or HPLIP version 3.20.5 (or higher) from the HPLIP pages

Version 3.20.3 from the HPLIP pages does not work.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to cups in Ubuntu.
https://bugs.launchpad.net/bugs/1879206

Title:
  cups hplip not install printer

Status in cups package in Ubuntu:
  Incomplete
Status in hplip package in Ubuntu:
  Incomplete

Bug description:
  After upgrading to Ubuntu 20.04 I can't print anymore.

  Description:  Ubuntu 20.04 LTS
  Release:  20.04

  cups:
Installato: 2.3.1-9ubuntu1.1
Candidato:  2.3.1-9ubuntu1.1
Tabella versione:
   *** 2.3.1-9ubuntu1.1 500
  500 http://it.archive.ubuntu.com/ubuntu focal-updates/main amd64 
Packages
  500 http://security.ubuntu.com/ubuntu focal-security/main amd64 
Packages
  100 /var/lib/dpkg/status
   2.3.1-9ubuntu1 500
  500 http://it.archive.ubuntu.com/ubuntu focal/main amd64 Packages

  hplip:
Installato: 3.20.3+dfsg0-2
Candidato:  3.20.3+dfsg0-2
Tabella versione:
   *** 3.20.3+dfsg0-2 500
  500 http://it.archive.ubuntu.com/ubuntu focal/main amd64 Packages
  100 /var/lib/dpkg/status

  
  I tried to reinstall the printer, but it is not being re-saved by cups / hplip

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: cups 2.3.1-9ubuntu1.1
  ProcVersionSignature: Ubuntu 5.4.0-29.33-generic 5.4.30
  Uname: Linux 5.4.0-29-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Mon May 18 02:24:07 2020
  InstallationDate: Installed on 2020-05-17 (0 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  Lpstat: device for DeskJet_3630: 
hp:/usb/DeskJet_3630_series?serial=CN8AM7H3230658
  MachineType: LENOVO 80G0
  Papersize: a4
  PpdFiles: Error: command ['fgrep', '-H', '*NickName', 
'/etc/cups/ppd/DeskJet_3630.ppd'] failed with exit code 2: grep: 
/etc/cups/ppd/DeskJet_3630.ppd: Permission denied
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-29-generic 
root=UUID=6a8469e0-ecea-4a86-8040-b0caaa938fe4 ro quiet splash vt.handoff=7
  SourcePackage: cups
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 07/18/2014
  dmi.bios.vendor: LENOVO
  dmi.bios.version: A7CN40WW
  dmi.board.asset.tag: NO Asset Tag
  dmi.board.name: Lancer 5A6
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0F82993WIN
  dmi.chassis.asset.tag: NO Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Lenovo G50-30
  dmi.modalias: 
dmi:bvnLENOVO:bvrA7CN40WW:bd07/18/2014:svnLENOVO:pn80G0:pvrLenovoG50-30:rvnLENOVO:rnLancer5A6:rvrSDK0F82993WIN:cvnLENOVO:ct10:cvrLenovoG50-30:
  dmi.product.family: IDEAPAD
  dmi.product.name: 80G0
  dmi.product.sku: LENOVO_MT_80G0_BU_idea_FM_Lenovo G50-30
  dmi.product.version: Lenovo G50-30
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1879206/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1861408] Re: firefox apparmor messages

2020-06-04 Thread Launchpad Bug Tracker
This bug was fixed in the package firefox -
77.0.1+build1-0ubuntu0.20.04.1

---
firefox (77.0.1+build1-0ubuntu0.20.04.1) focal; urgency=medium

  * New upstream stable release (77.0.1+build1)

  * Minor fixes to the script that creates the source tarball for regressions
that were introduced by the port to Python 3
- debian/build/create-tarball.py

 -- Olivier Tilloy   Wed, 03 Jun 2020
17:17:48 +0200

** Changed in: firefox (Ubuntu)
   Status: Triaged => Fix Released

** Changed in: firefox (Ubuntu)
   Status: Triaged => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apparmor in Ubuntu.
https://bugs.launchpad.net/bugs/1861408

Title:
  firefox apparmor messages

Status in apparmor package in Ubuntu:
  New
Status in firefox package in Ubuntu:
  Fix Released

Bug description:
  firefox version 72.0.1 64 bit, 72.0.1+linuxmint1+tricia , linux mint
  19.3.

  i see there is newer ubuntu version in
  
https://www.ubuntuupdates.org/package/ubuntu_mozilla_security/bionic/main/base/firefox
  , 72.0.2+build1-0ubuntu0.18.04.1 , but its changes are not for
  apparmor.

  i have not found a page for firefox bugs in linux mint sites, so i
  belive i should report here. but i have also asked about that in linux
  mint's irc and then github.

  i have enabled apparmor for firefox and see these types of messages in
  syslog:

  Jan 28 18:43:33 dinar-HP-Pavilion-g7-Notebook-PC dbus-daemon[735]:
  [system] Activating via systemd: service
  name='org.freedesktop.hostname1' unit='dbus-
  org.freedesktop.hostname1.service' requested by ':1.111' (uid=1000
  pid=1922 comm="/usr/lib/firefox/firefox " label="unconfined")

  Jan 28 18:44:36 dinar-HP-Pavilion-g7-Notebook-PC kernel: [
  5525.077960] audit: type=1400 audit(1580226276.440:27):
  apparmor="DENIED" operation="capable"
  profile="/usr/lib/firefox/firefox{,*[^s][^h]}" pid=15948
  comm="firefox" capability=21  capname="sys_admin"

  Jan 28 18:44:37 dinar-HP-Pavilion-g7-Notebook-PC kernel: [
  5526.471731] audit: type=1107 audit(1580226277.832:28): pid=735
  uid=103 auid=4294967295 ses=4294967295 msg='apparmor="DENIED"
  operation="dbus_method_call"  bus="system"
  path="/org/freedesktop/RealtimeKit1"
  interface="org.freedesktop.DBus.Properties" member="Get" mask="send"
  name="org.freedesktop.RealtimeKit1" pid=15948
  label="/usr/lib/firefox/firefox{,*[^s][^h]}" peer_pid=1320
  peer_label="unconfined"

  Jan 28 18:44:47 dinar-HP-Pavilion-g7-Notebook-PC dbus-daemon[1181]:
  apparmor="DENIED" operation="dbus_method_call"  bus="session"
  path="/org/gtk/vfs/Daemon" interface="org.gtk.vfs.Daemon"
  member="ListMonitorImplementations" mask="send" name=":1.10" pid=15948
  label="/usr/lib/firefox/firefox{,*[^s][^h]}" peer_pid=1262
  peer_label="unconfined"

  Jan 28 18:44:47 dinar-HP-Pavilion-g7-Notebook-PC dbus-daemon[1181]:
  apparmor="DENIED" operation="dbus_method_call"  bus="session"
  path="/org/gtk/Private/RemoteVolumeMonitor"
  interface="org.gtk.Private.RemoteVolumeMonitor" member="IsSupported"
  mask="send" name=":1.35" pid=15948
  label="/usr/lib/firefox/firefox{,*[^s][^h]}" peer_pid=1385
  peer_label="unconfined"

  Jan 28 18:44:47 dinar-HP-Pavilion-g7-Notebook-PC dbus-daemon[1181]:
  apparmor="DENIED" operation="dbus_method_call"  bus="session"
  path="/org/gtk/vfs/mounttracker" interface="org.gtk.vfs.MountTracker"
  member="ListMounts2" mask="send" name=":1.10" pid=15948
  label="/usr/lib/firefox/firefox{,*[^s][^h]}" peer_pid=1262
  peer_label="unconfined"

  Jan 28 18:44:47 dinar-HP-Pavilion-g7-Notebook-PC dbus-daemon[1181]:
  apparmor="DENIED" operation="dbus_method_call"  bus="session"
  path="/org/gtk/vfs/mounttracker" interface="org.gtk.vfs.MountTracker"
  member="LookupMount" mask="send" name=":1.10" pid=15948
  label="/usr/lib/firefox/firefox{,*[^s][^h]}" peer_pid=1262
  peer_label="unconfined"

  Jan 28 18:44:48 dinar-HP-Pavilion-g7-Notebook-PC dbus-daemon[735]:
  [system] Activating via systemd: service
  name='org.freedesktop.hostname1' unit='dbus-
  org.freedesktop.hostname1.service' requested by ':1.119' (uid=1000
  pid=15948 comm="/usr/lib/firefox/firefox "
  label="/usr/lib/firefox/firefox{,*[^s][^h]} (enforce)")

  Jan 28 18:44:48 dinar-HP-Pavilion-g7-Notebook-PC kernel: [
  5536.783313] audit: type=1107 audit(1580226288.143:34): pid=735
  uid=103 auid=4294967295 ses=4294967295 msg='apparmor="DENIED"
  operation="dbus_method_call"  bus="system"
  path="/org/freedesktop/hostname1"
  interface="org.freedesktop.DBus.Properties" member="GetAll"
  mask="send" name=":1.120" pid=15948
  label="/usr/lib/firefox/firefox{,*[^s][^h]}" peer_pid=16177
  peer_label="unconfined"

  Jan 28 18:45:02 dinar-HP-Pavilion-g7-Notebook-PC dbus-daemon[1181]:
  apparmor="DENIED" operation="dbus_method_call"  bus="session"
  path="/ca/desrt/dconf/Writer/user" interface="ca.desrt.dconf.Writer"
  member="Change" mask="send" name="ca.desrt.dconf" pid=15948
  

[Touch-packages] [Bug 1861408] Re: firefox apparmor messages

2020-06-04 Thread Launchpad Bug Tracker
This bug was fixed in the package firefox -
77.0.1+build1-0ubuntu0.18.04.1

---
firefox (77.0.1+build1-0ubuntu0.18.04.1) bionic; urgency=medium

  * New upstream stable release (77.0.1+build1)

  * Minor fixes to the script that creates the source tarball for regressions
that were introduced by the port to Python 3
- debian/build/create-tarball.py

 -- Olivier Tilloy   Wed, 03 Jun 2020
17:08:48 +0200

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apparmor in Ubuntu.
https://bugs.launchpad.net/bugs/1861408

Title:
  firefox apparmor messages

Status in apparmor package in Ubuntu:
  New
Status in firefox package in Ubuntu:
  Fix Released

Bug description:
  firefox version 72.0.1 64 bit, 72.0.1+linuxmint1+tricia , linux mint
  19.3.

  i see there is newer ubuntu version in
  
https://www.ubuntuupdates.org/package/ubuntu_mozilla_security/bionic/main/base/firefox
  , 72.0.2+build1-0ubuntu0.18.04.1 , but its changes are not for
  apparmor.

  i have not found a page for firefox bugs in linux mint sites, so i
  belive i should report here. but i have also asked about that in linux
  mint's irc and then github.

  i have enabled apparmor for firefox and see these types of messages in
  syslog:

  Jan 28 18:43:33 dinar-HP-Pavilion-g7-Notebook-PC dbus-daemon[735]:
  [system] Activating via systemd: service
  name='org.freedesktop.hostname1' unit='dbus-
  org.freedesktop.hostname1.service' requested by ':1.111' (uid=1000
  pid=1922 comm="/usr/lib/firefox/firefox " label="unconfined")

  Jan 28 18:44:36 dinar-HP-Pavilion-g7-Notebook-PC kernel: [
  5525.077960] audit: type=1400 audit(1580226276.440:27):
  apparmor="DENIED" operation="capable"
  profile="/usr/lib/firefox/firefox{,*[^s][^h]}" pid=15948
  comm="firefox" capability=21  capname="sys_admin"

  Jan 28 18:44:37 dinar-HP-Pavilion-g7-Notebook-PC kernel: [
  5526.471731] audit: type=1107 audit(1580226277.832:28): pid=735
  uid=103 auid=4294967295 ses=4294967295 msg='apparmor="DENIED"
  operation="dbus_method_call"  bus="system"
  path="/org/freedesktop/RealtimeKit1"
  interface="org.freedesktop.DBus.Properties" member="Get" mask="send"
  name="org.freedesktop.RealtimeKit1" pid=15948
  label="/usr/lib/firefox/firefox{,*[^s][^h]}" peer_pid=1320
  peer_label="unconfined"

  Jan 28 18:44:47 dinar-HP-Pavilion-g7-Notebook-PC dbus-daemon[1181]:
  apparmor="DENIED" operation="dbus_method_call"  bus="session"
  path="/org/gtk/vfs/Daemon" interface="org.gtk.vfs.Daemon"
  member="ListMonitorImplementations" mask="send" name=":1.10" pid=15948
  label="/usr/lib/firefox/firefox{,*[^s][^h]}" peer_pid=1262
  peer_label="unconfined"

  Jan 28 18:44:47 dinar-HP-Pavilion-g7-Notebook-PC dbus-daemon[1181]:
  apparmor="DENIED" operation="dbus_method_call"  bus="session"
  path="/org/gtk/Private/RemoteVolumeMonitor"
  interface="org.gtk.Private.RemoteVolumeMonitor" member="IsSupported"
  mask="send" name=":1.35" pid=15948
  label="/usr/lib/firefox/firefox{,*[^s][^h]}" peer_pid=1385
  peer_label="unconfined"

  Jan 28 18:44:47 dinar-HP-Pavilion-g7-Notebook-PC dbus-daemon[1181]:
  apparmor="DENIED" operation="dbus_method_call"  bus="session"
  path="/org/gtk/vfs/mounttracker" interface="org.gtk.vfs.MountTracker"
  member="ListMounts2" mask="send" name=":1.10" pid=15948
  label="/usr/lib/firefox/firefox{,*[^s][^h]}" peer_pid=1262
  peer_label="unconfined"

  Jan 28 18:44:47 dinar-HP-Pavilion-g7-Notebook-PC dbus-daemon[1181]:
  apparmor="DENIED" operation="dbus_method_call"  bus="session"
  path="/org/gtk/vfs/mounttracker" interface="org.gtk.vfs.MountTracker"
  member="LookupMount" mask="send" name=":1.10" pid=15948
  label="/usr/lib/firefox/firefox{,*[^s][^h]}" peer_pid=1262
  peer_label="unconfined"

  Jan 28 18:44:48 dinar-HP-Pavilion-g7-Notebook-PC dbus-daemon[735]:
  [system] Activating via systemd: service
  name='org.freedesktop.hostname1' unit='dbus-
  org.freedesktop.hostname1.service' requested by ':1.119' (uid=1000
  pid=15948 comm="/usr/lib/firefox/firefox "
  label="/usr/lib/firefox/firefox{,*[^s][^h]} (enforce)")

  Jan 28 18:44:48 dinar-HP-Pavilion-g7-Notebook-PC kernel: [
  5536.783313] audit: type=1107 audit(1580226288.143:34): pid=735
  uid=103 auid=4294967295 ses=4294967295 msg='apparmor="DENIED"
  operation="dbus_method_call"  bus="system"
  path="/org/freedesktop/hostname1"
  interface="org.freedesktop.DBus.Properties" member="GetAll"
  mask="send" name=":1.120" pid=15948
  label="/usr/lib/firefox/firefox{,*[^s][^h]}" peer_pid=16177
  peer_label="unconfined"

  Jan 28 18:45:02 dinar-HP-Pavilion-g7-Notebook-PC dbus-daemon[1181]:
  apparmor="DENIED" operation="dbus_method_call"  bus="session"
  path="/ca/desrt/dconf/Writer/user" interface="ca.desrt.dconf.Writer"
  member="Change" mask="send" name="ca.desrt.dconf" pid=15948
  label="/usr/lib/firefox/firefox{,*[^s][^h]}" peer_pid=1370
  peer_label="unconfined"

  Jan 28 21:51:30 dinar-HP-Pavilion-g7-Notebook-PC kernel:
  

[Touch-packages] [Bug 1861408] Re: firefox apparmor messages

2020-06-04 Thread Launchpad Bug Tracker
This bug was fixed in the package firefox -
77.0.1+build1-0ubuntu0.19.10.1

---
firefox (77.0.1+build1-0ubuntu0.19.10.1) eoan; urgency=medium

  * New upstream stable release (77.0.1+build1)

  * Minor fixes to the script that creates the source tarball for regressions
that were introduced by the port to Python 3
- debian/build/create-tarball.py

 -- Olivier Tilloy   Wed, 03 Jun 2020
17:16:09 +0200

** Changed in: firefox (Ubuntu)
   Status: Triaged => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apparmor in Ubuntu.
https://bugs.launchpad.net/bugs/1861408

Title:
  firefox apparmor messages

Status in apparmor package in Ubuntu:
  New
Status in firefox package in Ubuntu:
  Fix Released

Bug description:
  firefox version 72.0.1 64 bit, 72.0.1+linuxmint1+tricia , linux mint
  19.3.

  i see there is newer ubuntu version in
  
https://www.ubuntuupdates.org/package/ubuntu_mozilla_security/bionic/main/base/firefox
  , 72.0.2+build1-0ubuntu0.18.04.1 , but its changes are not for
  apparmor.

  i have not found a page for firefox bugs in linux mint sites, so i
  belive i should report here. but i have also asked about that in linux
  mint's irc and then github.

  i have enabled apparmor for firefox and see these types of messages in
  syslog:

  Jan 28 18:43:33 dinar-HP-Pavilion-g7-Notebook-PC dbus-daemon[735]:
  [system] Activating via systemd: service
  name='org.freedesktop.hostname1' unit='dbus-
  org.freedesktop.hostname1.service' requested by ':1.111' (uid=1000
  pid=1922 comm="/usr/lib/firefox/firefox " label="unconfined")

  Jan 28 18:44:36 dinar-HP-Pavilion-g7-Notebook-PC kernel: [
  5525.077960] audit: type=1400 audit(1580226276.440:27):
  apparmor="DENIED" operation="capable"
  profile="/usr/lib/firefox/firefox{,*[^s][^h]}" pid=15948
  comm="firefox" capability=21  capname="sys_admin"

  Jan 28 18:44:37 dinar-HP-Pavilion-g7-Notebook-PC kernel: [
  5526.471731] audit: type=1107 audit(1580226277.832:28): pid=735
  uid=103 auid=4294967295 ses=4294967295 msg='apparmor="DENIED"
  operation="dbus_method_call"  bus="system"
  path="/org/freedesktop/RealtimeKit1"
  interface="org.freedesktop.DBus.Properties" member="Get" mask="send"
  name="org.freedesktop.RealtimeKit1" pid=15948
  label="/usr/lib/firefox/firefox{,*[^s][^h]}" peer_pid=1320
  peer_label="unconfined"

  Jan 28 18:44:47 dinar-HP-Pavilion-g7-Notebook-PC dbus-daemon[1181]:
  apparmor="DENIED" operation="dbus_method_call"  bus="session"
  path="/org/gtk/vfs/Daemon" interface="org.gtk.vfs.Daemon"
  member="ListMonitorImplementations" mask="send" name=":1.10" pid=15948
  label="/usr/lib/firefox/firefox{,*[^s][^h]}" peer_pid=1262
  peer_label="unconfined"

  Jan 28 18:44:47 dinar-HP-Pavilion-g7-Notebook-PC dbus-daemon[1181]:
  apparmor="DENIED" operation="dbus_method_call"  bus="session"
  path="/org/gtk/Private/RemoteVolumeMonitor"
  interface="org.gtk.Private.RemoteVolumeMonitor" member="IsSupported"
  mask="send" name=":1.35" pid=15948
  label="/usr/lib/firefox/firefox{,*[^s][^h]}" peer_pid=1385
  peer_label="unconfined"

  Jan 28 18:44:47 dinar-HP-Pavilion-g7-Notebook-PC dbus-daemon[1181]:
  apparmor="DENIED" operation="dbus_method_call"  bus="session"
  path="/org/gtk/vfs/mounttracker" interface="org.gtk.vfs.MountTracker"
  member="ListMounts2" mask="send" name=":1.10" pid=15948
  label="/usr/lib/firefox/firefox{,*[^s][^h]}" peer_pid=1262
  peer_label="unconfined"

  Jan 28 18:44:47 dinar-HP-Pavilion-g7-Notebook-PC dbus-daemon[1181]:
  apparmor="DENIED" operation="dbus_method_call"  bus="session"
  path="/org/gtk/vfs/mounttracker" interface="org.gtk.vfs.MountTracker"
  member="LookupMount" mask="send" name=":1.10" pid=15948
  label="/usr/lib/firefox/firefox{,*[^s][^h]}" peer_pid=1262
  peer_label="unconfined"

  Jan 28 18:44:48 dinar-HP-Pavilion-g7-Notebook-PC dbus-daemon[735]:
  [system] Activating via systemd: service
  name='org.freedesktop.hostname1' unit='dbus-
  org.freedesktop.hostname1.service' requested by ':1.119' (uid=1000
  pid=15948 comm="/usr/lib/firefox/firefox "
  label="/usr/lib/firefox/firefox{,*[^s][^h]} (enforce)")

  Jan 28 18:44:48 dinar-HP-Pavilion-g7-Notebook-PC kernel: [
  5536.783313] audit: type=1107 audit(1580226288.143:34): pid=735
  uid=103 auid=4294967295 ses=4294967295 msg='apparmor="DENIED"
  operation="dbus_method_call"  bus="system"
  path="/org/freedesktop/hostname1"
  interface="org.freedesktop.DBus.Properties" member="GetAll"
  mask="send" name=":1.120" pid=15948
  label="/usr/lib/firefox/firefox{,*[^s][^h]}" peer_pid=16177
  peer_label="unconfined"

  Jan 28 18:45:02 dinar-HP-Pavilion-g7-Notebook-PC dbus-daemon[1181]:
  apparmor="DENIED" operation="dbus_method_call"  bus="session"
  path="/ca/desrt/dconf/Writer/user" interface="ca.desrt.dconf.Writer"
  member="Change" mask="send" name="ca.desrt.dconf" pid=15948
  label="/usr/lib/firefox/firefox{,*[^s][^h]}" peer_pid=1370
  

[Touch-packages] [Bug 1867424] Re: motd-news transmitting private hardware data without consent or knowledge in background

2020-06-04 Thread Guy Baconniere
Anyone privacy-conscious using any version of Ubuntu should do this in a shell 
ASAP

sudo sed -i -r 's/(ENABLED)=.+/\1=0/' /etc/default/motd-news

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to base-files in Ubuntu.
https://bugs.launchpad.net/bugs/1867424

Title:
  motd-news transmitting private hardware data without consent or
  knowledge in background

Status in base-files package in Ubuntu:
  Confirmed

Bug description:
  In package base-files there is a script /etc/update-motd.d/50-motd-
  news that harvests private hardware data from the machine and
  transmits it in the background every day.  There is no notice, no
  consent, no nothing.  This should be by default disabled until there
  is informed consent.

  This solution is simple:

  1. Change ENABLED=1 to ENABLED=0 in the file /etc/default/motd-news and 
  2. Place a comment in the file disclosing the fact that the 50-motd-news 
script will harvest private hardware data and upload it to motd.ubuntu.com 
daily if the end-user enables it.

  Creating databases that maps ip address to specify hardware is a
  threat to both privacy and security.  If an adversary knows the
  specific hardware and the ip address for that hardware their ability
  to successfully attack it is greatly increased.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/base-files/+bug/1867424/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1867424] Re: motd-news transmitting private hardware data without consent or knowledge in background

2020-06-04 Thread Guy Baconniere
This ticket should be updated to Security issue +250 points

I highly doubt that this Motd News "feature" is compliant with EU's
General Data Protection Regulation since daily reporting of computer's
infos are proceeded without the user's consent. Cf. GDPR application
comments [https://gdpr.eu/eu-gdpr-personal-data/], in particular with
respect to Recital 30 [https://gdpr.eu/recital-30-online-identifiers-
for-profiling-and-identification/]

Internet protocol (IP) addresses; information that is related to an
individual’s tools, applications, or devices, like their computer.

Daily report of computer's private infos without the users consent


It affects Ubuntu Servers and Desktop (including roaming computers like laptops)
since at least 18.04 LTS and also the current 20.04 LTS

Sensible data sent
- IP address of the computer running Ubuntu
- Date of the HTTPS query
- Kernel Version
- CPU Vendor and Model
- Uptime
- Cloud identifier
- Version of Curl so version of Ubuntu running ...

$curl_ver $lsb $platform $cpu $uptime $cloud_id

Sample from our PC Engines running Ubuntu 18.04 LTS:
```
curl/7.58.0-2ubuntu3.8 GNU/Linux/4.15.0-101-generic/x86_64 AMD/GX-412TC/SOC 
uptime/692518.54/2755023.47 cloud_id/unknown
```

https://motd.ubuntu.com/ 
```
 * MicroK8s gets a native Windows installer and command-line integration.

 https://ubuntu.com/blog/microk8s-installers-windows-and-macos
```

The perfect opportunity to map all Ubuntu Linux users worldwide on a
daily basis?

https://gdpr.eu/eu-gdpr-personal-data/
https://gdpr.eu/checklist/

See also
https://askubuntu.com/questions/1105825/why-lubuntu-18-04-calls-amazon-servers-motd-ubuntu-com

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to base-files in Ubuntu.
https://bugs.launchpad.net/bugs/1867424

Title:
  motd-news transmitting private hardware data without consent or
  knowledge in background

Status in base-files package in Ubuntu:
  Confirmed

Bug description:
  In package base-files there is a script /etc/update-motd.d/50-motd-
  news that harvests private hardware data from the machine and
  transmits it in the background every day.  There is no notice, no
  consent, no nothing.  This should be by default disabled until there
  is informed consent.

  This solution is simple:

  1. Change ENABLED=1 to ENABLED=0 in the file /etc/default/motd-news and 
  2. Place a comment in the file disclosing the fact that the 50-motd-news 
script will harvest private hardware data and upload it to motd.ubuntu.com 
daily if the end-user enables it.

  Creating databases that maps ip address to specify hardware is a
  threat to both privacy and security.  If an adversary knows the
  specific hardware and the ip address for that hardware their ability
  to successfully attack it is greatly increased.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/base-files/+bug/1867424/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1882102] [NEW] Gnome Desktop only starting with root rights

2020-06-04 Thread Tim Mueller
Public bug reported:

All files in home folder are owned by the user. startx is only working
with root rights.

xinit: connection to X server lost/usr/bin/gnome-session: 29: exec:
/usr/libexec/gnome-session-binary: Permission denied

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: xorg 1:7.7+19ubuntu14
ProcVersionSignature: Ubuntu 5.4.0-33.37-generic 5.4.34
Uname: Linux 5.4.0-33-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu27.2
Architecture: amd64
CasperMD5CheckResult: skip
CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
Date: Thu Jun  4 16:25:19 2020
DistUpgraded: 2020-04-26 18:18:02,277 ERROR Cache can not be locked (E:Konnte 
keinen exklusiven Zugang zur Sperrdatei /var/lib/dpkg/lock erhalten. Diese wird 
vom Prozess 21979 (dpkg) gehalten., W:Beachten Sie, dass das Entfernen der 
Sperrdatei keine Lösung ist und Ihr System zerstören kann., E:Sperren des 
Administrationsverzeichnisses (/var/lib/dpkg/) nicht möglich, wird es von einem 
anderen Prozess verwendet?)
DistroCodename: focal
DistroVariant: ubuntu
DkmsStatus:
 rapiddisk, 5.2, 5.4.0-31-generic, x86_64: installed
 rapiddisk, 5.2, 5.4.0-33-generic, x86_64: installed
ExtraDebuggingInterest: Yes
GraphicsCard:
 VMware SVGA II Adapter [15ad:0405] (prog-if 00 [VGA controller])
   Subsystem: VMware SVGA II Adapter [15ad:0405]
Lsusb: Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Lsusb-t: /:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
MachineType: QEMU Standard PC (i440FX + PIIX, 1996)
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-5.4.0-33-generic 
root=UUID=f8fcb1ae-51b1-4ab2-b79d-66cf34ad77d9 ro nomodeset 
rootflags=subvol=ROOT
SourcePackage: xorg
UpgradeStatus: Upgraded to focal on 2020-04-26 (38 days ago)
dmi.bios.date: 04/01/2014
dmi.bios.vendor: SeaBIOS
dmi.bios.version: rel-1.12.1-0-ga5cab58e9a3f-prebuilt.qemu.org
dmi.chassis.type: 1
dmi.chassis.vendor: QEMU
dmi.chassis.version: pc-i440fx-4.1
dmi.modalias: 
dmi:bvnSeaBIOS:bvrrel-1.12.1-0-ga5cab58e9a3f-prebuilt.qemu.org:bd04/01/2014:svnQEMU:pnStandardPC(i440FX+PIIX,1996):pvrpc-i440fx-4.1:cvnQEMU:ct1:cvrpc-i440fx-4.1:
dmi.product.name: Standard PC (i440FX + PIIX, 1996)
dmi.product.version: pc-i440fx-4.1
dmi.sys.vendor: QEMU
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.101-2
version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.4-2ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.4-2ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.6-1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug focal third-party-packages ubuntu

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1882102

Title:
  Gnome Desktop only starting with root rights

Status in xorg package in Ubuntu:
  New

Bug description:
  All files in home folder are owned by the user. startx is only working
  with root rights.

  xinit: connection to X server lost/usr/bin/gnome-session: 29: exec:
  /usr/libexec/gnome-session-binary: Permission denied

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: xorg 1:7.7+19ubuntu14
  ProcVersionSignature: Ubuntu 5.4.0-33.37-generic 5.4.34
  Uname: Linux 5.4.0-33-generic x86_64
  NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
  ApportVersion: 2.20.11-0ubuntu27.2
  Architecture: amd64
  CasperMD5CheckResult: skip
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  Date: Thu Jun  4 16:25:19 2020
  DistUpgraded: 2020-04-26 18:18:02,277 ERROR Cache can not be locked (E:Konnte 
keinen exklusiven Zugang zur Sperrdatei /var/lib/dpkg/lock erhalten. Diese wird 
vom Prozess 21979 (dpkg) gehalten., W:Beachten Sie, dass das Entfernen der 
Sperrdatei keine Lösung ist und Ihr System zerstören kann., E:Sperren des 
Administrationsverzeichnisses (/var/lib/dpkg/) nicht möglich, wird es von einem 
anderen Prozess verwendet?)
  DistroCodename: focal
  DistroVariant: ubuntu
  DkmsStatus:
   rapiddisk, 5.2, 5.4.0-31-generic, x86_64: installed
   rapiddisk, 5.2, 5.4.0-33-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   VMware SVGA II Adapter [15ad:0405] (prog-if 00 [VGA controller])
 Subsystem: VMware SVGA II Adapter [15ad:0405]
  Lsusb: Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  Lsusb-t: /:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
  MachineType: QEMU Standard PC (i440FX + PIIX, 1996)
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-5.4.0-33-generic 

[Touch-packages] [Bug 1833174] Re: Shadowing the vim-window results in vim-gtk3 crash

2020-06-04 Thread Brian Murray
** Tags removed: rls-gg-incoming

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to vim in Ubuntu.
https://bugs.launchpad.net/bugs/1833174

Title:
   Shadowing the vim-window results in vim-gtk3 crash

Status in vim:
  Unknown
Status in vim package in Ubuntu:
  Triaged
Status in vim source package in Focal:
  Triaged
Status in vim source package in Groovy:
  Triaged

Bug description:
  With XFCE when I try to "shadow" the vim-gtk3 window (just to show only the 
title bar) it results in a vim crash and the window just disappears without any 
core dump neither .swp files on.
  The only message I get on the terminal is

  BadMatch (invalid parameter attributes)
  Vim: Got X error
  Vim: Finished.

  This behaviour started from Xubuntu 18.04.
  The vim-gtk package is not suffering from this problem.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.04
  Package: vim-gtk3 2:8.1.0320-1ubuntu3.1
  ProcVersionSignature: Ubuntu 5.0.0-16.17-generic 5.0.8
  Uname: Linux 5.0.0-16-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  ApportVersion: 2.20.10-0ubuntu27
  Architecture: amd64
  CurrentDesktop: XFCE
  Date: Tue Jun 18 09:10:38 2019
  InstallationDate: Installed on 2019-04-23 (55 days ago)
  InstallationMedia: Xubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
  SourcePackage: vim
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/vim/+bug/1833174/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1882092] [NEW] goa-daemon Error resolving “autodiscover.outlook.office365.com”

2020-06-04 Thread Eero Aaltonen
Public bug reported:

Evolution is no longer receiving able to refresh Inbox from Exchange Web 
Services.
`journalctl` provides the following clues

systemd-resolved: Server returned error NXDOMAIN, mitigating potential DNS 
violation DVE-2018-0001, retrying transaction with reduced feature level UDP
goa-daemon: goa_ews_client_autodiscover() failed: 2 — Error resolving 
“autodiscover.outlook.office365.com”: Name or service not known

This may be upstream issue https://gitlab.gnome.org/GNOME/gnome-online-
accounts/-/issues/57

$ lsb_release -rd
Description:Ubuntu 18.04.4 LTS
Release:18.04

$ apt-cache policy gnome-online-accounts
gnome-online-accounts:
  Installed: 3.28.0-0ubuntu2.1
  Candidate: 3.28.0-0ubuntu2.1
  Version table:
 *** 3.28.0-0ubuntu2.1 500
500 http://fi.archive.ubuntu.com/ubuntu bionic-updates/main amd64 
Packages
100 /var/lib/dpkg/status
 3.28.0-0ubuntu2 500
500 http://fi.archive.ubuntu.com/ubuntu bionic/main amd64 Packages

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: gnome-online-accounts 3.28.0-0ubuntu2.1
ProcVersionSignature: Ubuntu 4.15.0-101.102-generic 4.15.18
Uname: Linux 4.15.0-101-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.15
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Thu Jun  4 17:11:45 2020
InstallationDate: Installed on 2018-01-10 (875 days ago)
InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64 (20170801)
SourcePackage: gnome-online-accounts
UpgradeStatus: Upgraded to bionic on 2019-02-12 (478 days ago)

** Affects: gnome-online-accounts (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug bionic

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gnome-online-accounts in
Ubuntu.
https://bugs.launchpad.net/bugs/1882092

Title:
  goa-daemon Error resolving “autodiscover.outlook.office365.com”

Status in gnome-online-accounts package in Ubuntu:
  New

Bug description:
  Evolution is no longer receiving able to refresh Inbox from Exchange Web 
Services.
  `journalctl` provides the following clues

  systemd-resolved: Server returned error NXDOMAIN, mitigating potential DNS 
violation DVE-2018-0001, retrying transaction with reduced feature level UDP
  goa-daemon: goa_ews_client_autodiscover() failed: 2 — Error resolving 
“autodiscover.outlook.office365.com”: Name or service not known

  This may be upstream issue https://gitlab.gnome.org/GNOME/gnome-
  online-accounts/-/issues/57

  $ lsb_release -rd
  Description:  Ubuntu 18.04.4 LTS
  Release:  18.04

  $ apt-cache policy gnome-online-accounts
  gnome-online-accounts:
Installed: 3.28.0-0ubuntu2.1
Candidate: 3.28.0-0ubuntu2.1
Version table:
   *** 3.28.0-0ubuntu2.1 500
  500 http://fi.archive.ubuntu.com/ubuntu bionic-updates/main amd64 
Packages
  100 /var/lib/dpkg/status
   3.28.0-0ubuntu2 500
  500 http://fi.archive.ubuntu.com/ubuntu bionic/main amd64 Packages

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: gnome-online-accounts 3.28.0-0ubuntu2.1
  ProcVersionSignature: Ubuntu 4.15.0-101.102-generic 4.15.18
  Uname: Linux 4.15.0-101-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.15
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Jun  4 17:11:45 2020
  InstallationDate: Installed on 2018-01-10 (875 days ago)
  InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64 
(20170801)
  SourcePackage: gnome-online-accounts
  UpgradeStatus: Upgraded to bionic on 2019-02-12 (478 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-online-accounts/+bug/1882092/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1867424] Re: motd-news transmitting private hardware data without consent or knowledge in background

2020-06-04 Thread Guy Baconniere
** Tags added: bionic cosmic disco

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to base-files in Ubuntu.
https://bugs.launchpad.net/bugs/1867424

Title:
  motd-news transmitting private hardware data without consent or
  knowledge in background

Status in base-files package in Ubuntu:
  Confirmed

Bug description:
  In package base-files there is a script /etc/update-motd.d/50-motd-
  news that harvests private hardware data from the machine and
  transmits it in the background every day.  There is no notice, no
  consent, no nothing.  This should be by default disabled until there
  is informed consent.

  This solution is simple:

  1. Change ENABLED=1 to ENABLED=0 in the file /etc/default/motd-news and 
  2. Place a comment in the file disclosing the fact that the 50-motd-news 
script will harvest private hardware data and upload it to motd.ubuntu.com 
daily if the end-user enables it.

  Creating databases that maps ip address to specify hardware is a
  threat to both privacy and security.  If an adversary knows the
  specific hardware and the ip address for that hardware their ability
  to successfully attack it is greatly increased.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/base-files/+bug/1867424/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1882089] Re: RM: ubuntu-app-launch obsolete, unused, ftbfs

2020-06-04 Thread Matthias Klose
Removing packages from groovy:
url-dispatcher 0.1+17.04.20170328-0ubuntu6 in groovy
liburl-dispatcher1 0.1+17.04.20170328-0ubuntu6 in groovy amd64
liburl-dispatcher1 0.1+17.04.20170328-0ubuntu6 in groovy arm64
liburl-dispatcher1 0.1+17.04.20170328-0ubuntu6 in groovy armhf
liburl-dispatcher1 0.1+17.04.20170328-0ubuntu6 in groovy ppc64el
liburl-dispatcher1 0.1+17.04.20170328-0ubuntu6 in groovy s390x
liburl-dispatcher1-dev 0.1+17.04.20170328-0ubuntu6 in groovy 
amd64
liburl-dispatcher1-dev 0.1+17.04.20170328-0ubuntu6 in groovy 
arm64
liburl-dispatcher1-dev 0.1+17.04.20170328-0ubuntu6 in groovy 
armhf
liburl-dispatcher1-dev 0.1+17.04.20170328-0ubuntu6 in groovy 
ppc64el
liburl-dispatcher1-dev 0.1+17.04.20170328-0ubuntu6 in groovy 
s390x
url-dispatcher 0.1+17.04.20170328-0ubuntu6 in groovy amd64
url-dispatcher 0.1+17.04.20170328-0ubuntu6 in groovy arm64
url-dispatcher 0.1+17.04.20170328-0ubuntu6 in groovy armhf
url-dispatcher 0.1+17.04.20170328-0ubuntu6 in groovy ppc64el
url-dispatcher 0.1+17.04.20170328-0ubuntu6 in groovy s390x
url-dispatcher-testability 0.1+17.04.20170328-0ubuntu6 in 
groovy amd64
url-dispatcher-testability 0.1+17.04.20170328-0ubuntu6 in 
groovy arm64
url-dispatcher-testability 0.1+17.04.20170328-0ubuntu6 in 
groovy armhf
url-dispatcher-testability 0.1+17.04.20170328-0ubuntu6 in 
groovy i386
url-dispatcher-testability 0.1+17.04.20170328-0ubuntu6 in 
groovy ppc64el
url-dispatcher-testability 0.1+17.04.20170328-0ubuntu6 in 
groovy riscv64
url-dispatcher-testability 0.1+17.04.20170328-0ubuntu6 in 
groovy s390x
url-dispatcher-tools 0.1+17.04.20170328-0ubuntu6 in groovy amd64
url-dispatcher-tools 0.1+17.04.20170328-0ubuntu6 in groovy arm64
url-dispatcher-tools 0.1+17.04.20170328-0ubuntu6 in groovy armhf
url-dispatcher-tools 0.1+17.04.20170328-0ubuntu6 in groovy 
ppc64el
url-dispatcher-tools 0.1+17.04.20170328-0ubuntu6 in groovy s390x
url-dispatcher-tools-gui 0.1+17.04.20170328-0ubuntu6 in groovy 
amd64
url-dispatcher-tools-gui 0.1+17.04.20170328-0ubuntu6 in groovy 
arm64
url-dispatcher-tools-gui 0.1+17.04.20170328-0ubuntu6 in groovy 
armhf
url-dispatcher-tools-gui 0.1+17.04.20170328-0ubuntu6 in groovy 
ppc64el
url-dispatcher-tools-gui 0.1+17.04.20170328-0ubuntu6 in groovy 
s390x
Comment: LP: #1882089, remove
1 package successfully removed.


** Changed in: url-dispatcher (Ubuntu)
   Status: Triaged => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to url-dispatcher in Ubuntu.
https://bugs.launchpad.net/bugs/1882089

Title:
  RM: ubuntu-app-launch obsolete, unused, ftbfs

Status in ubuntu-app-launch package in Ubuntu:
  Fix Released
Status in url-dispatcher package in Ubuntu:
  Fix Released

Bug description:
  RM: ubuntu-app-launch obsolete, unused, ftbfs

  ubuntu-app-launch is obsolete, unused by any Desktop Environment in
  the Archive.

  It also ftbfs with new glib / unity bindings.

  There are four packages in the archive that still link/depend/use
  ubuntu-app-launch, and all of them are now fixed in groovy-proposed,
  and should migrate soon.

  url-dispatcher is also obsolete and should be simply removed together
  with ubuntu-app-launch.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-app-launch/+bug/1882089/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1882089] Re: RM: ubuntu-app-launch obsolete, unused, ftbfs

2020-06-04 Thread Matthias Klose
Removing packages from groovy:
ubuntu-app-launch 0.12+17.04.20170404.2-0ubuntu6 in groovy
gir1.2-ubuntu-app-launch-3 0.12+17.04.20170404.2-0ubuntu6 in 
groovy amd64
gir1.2-ubuntu-app-launch-3 0.12+17.04.20170404.2-0ubuntu6 in 
groovy arm64
gir1.2-ubuntu-app-launch-3 0.12+17.04.20170404.2-0ubuntu6 in 
groovy armhf
gir1.2-ubuntu-app-launch-3 0.12+17.04.20170404.2-0ubuntu6 in 
groovy ppc64el
gir1.2-ubuntu-app-launch-3 0.12+17.04.20170404.2-0ubuntu6 in 
groovy s390x
libubuntu-app-launch3-dev 0.12+17.04.20170404.2-0ubuntu6 in 
groovy amd64
libubuntu-app-launch3-dev 0.12+17.04.20170404.2-0ubuntu6 in 
groovy arm64
libubuntu-app-launch3-dev 0.12+17.04.20170404.2-0ubuntu6 in 
groovy armhf
libubuntu-app-launch3-dev 0.12+17.04.20170404.2-0ubuntu6 in 
groovy ppc64el
libubuntu-app-launch3-dev 0.12+17.04.20170404.2-0ubuntu6 in 
groovy s390x
libubuntu-app-launch4 0.12+17.04.20170404.2-0ubuntu6 in groovy 
amd64
libubuntu-app-launch4 0.12+17.04.20170404.2-0ubuntu6 in groovy 
arm64
libubuntu-app-launch4 0.12+17.04.20170404.2-0ubuntu6 in groovy 
armhf
libubuntu-app-launch4 0.12+17.04.20170404.2-0ubuntu6 in groovy 
ppc64el
libubuntu-app-launch4 0.12+17.04.20170404.2-0ubuntu6 in groovy 
s390x
ubuntu-app-launch 0.12+17.04.20170404.2-0ubuntu6 in groovy amd64
ubuntu-app-launch 0.12+17.04.20170404.2-0ubuntu6 in groovy arm64
ubuntu-app-launch 0.12+17.04.20170404.2-0ubuntu6 in groovy armhf
ubuntu-app-launch 0.12+17.04.20170404.2-0ubuntu6 in groovy 
ppc64el
ubuntu-app-launch 0.12+17.04.20170404.2-0ubuntu6 in groovy s390x
ubuntu-app-launch-tools 0.12+17.04.20170404.2-0ubuntu6 in 
groovy amd64
ubuntu-app-launch-tools 0.12+17.04.20170404.2-0ubuntu6 in 
groovy arm64
ubuntu-app-launch-tools 0.12+17.04.20170404.2-0ubuntu6 in 
groovy armhf
ubuntu-app-launch-tools 0.12+17.04.20170404.2-0ubuntu6 in 
groovy ppc64el
ubuntu-app-launch-tools 0.12+17.04.20170404.2-0ubuntu6 in 
groovy s390x
ubuntu-app-test 0.12+17.04.20170404.2-0ubuntu6 in groovy amd64
ubuntu-app-test 0.12+17.04.20170404.2-0ubuntu6 in groovy arm64
ubuntu-app-test 0.12+17.04.20170404.2-0ubuntu6 in groovy armhf
ubuntu-app-test 0.12+17.04.20170404.2-0ubuntu6 in groovy ppc64el
ubuntu-app-test 0.12+17.04.20170404.2-0ubuntu6 in groovy s390x
Comment: LP: #1882089, remove
1 package successfully removed.


** Changed in: ubuntu-app-launch (Ubuntu)
   Status: Triaged => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to url-dispatcher in Ubuntu.
https://bugs.launchpad.net/bugs/1882089

Title:
  RM: ubuntu-app-launch obsolete, unused, ftbfs

Status in ubuntu-app-launch package in Ubuntu:
  Fix Released
Status in url-dispatcher package in Ubuntu:
  Fix Released

Bug description:
  RM: ubuntu-app-launch obsolete, unused, ftbfs

  ubuntu-app-launch is obsolete, unused by any Desktop Environment in
  the Archive.

  It also ftbfs with new glib / unity bindings.

  There are four packages in the archive that still link/depend/use
  ubuntu-app-launch, and all of them are now fixed in groovy-proposed,
  and should migrate soon.

  url-dispatcher is also obsolete and should be simply removed together
  with ubuntu-app-launch.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-app-launch/+bug/1882089/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1867424] Re: motd-news transmitting private hardware data without consent or knowledge in background

2020-06-04 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: base-files (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to base-files in Ubuntu.
https://bugs.launchpad.net/bugs/1867424

Title:
  motd-news transmitting private hardware data without consent or
  knowledge in background

Status in base-files package in Ubuntu:
  Confirmed

Bug description:
  In package base-files there is a script /etc/update-motd.d/50-motd-
  news that harvests private hardware data from the machine and
  transmits it in the background every day.  There is no notice, no
  consent, no nothing.  This should be by default disabled until there
  is informed consent.

  This solution is simple:

  1. Change ENABLED=1 to ENABLED=0 in the file /etc/default/motd-news and 
  2. Place a comment in the file disclosing the fact that the 50-motd-news 
script will harvest private hardware data and upload it to motd.ubuntu.com 
daily if the end-user enables it.

  Creating databases that maps ip address to specify hardware is a
  threat to both privacy and security.  If an adversary knows the
  specific hardware and the ip address for that hardware their ability
  to successfully attack it is greatly increased.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/base-files/+bug/1867424/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1882089] [NEW] RM: ubuntu-app-launch obsolete, unused, ftbfs

2020-06-04 Thread Dimitri John Ledkov
Public bug reported:

RM: ubuntu-app-launch obsolete, unused, ftbfs

ubuntu-app-launch is obsolete, unused by any Desktop Environment in the
Archive.

It also ftbfs with new glib / unity bindings.

There are four packages in the archive that still link/depend/use
ubuntu-app-launch, and all of them are now fixed in groovy-proposed, and
should migrate soon.

url-dispatcher is also obsolete and should be simply removed together
with ubuntu-app-launch.

** Affects: ubuntu-app-launch (Ubuntu)
 Importance: Undecided
 Status: Triaged

** Affects: url-dispatcher (Ubuntu)
 Importance: Undecided
 Status: Triaged


** Tags: update-excuse

** Changed in: ubuntu-app-launch (Ubuntu)
   Status: New => Triaged

** Also affects: url-dispatcher (Ubuntu)
   Importance: Undecided
   Status: New

** Changed in: url-dispatcher (Ubuntu)
   Status: New => Triaged

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to url-dispatcher in Ubuntu.
https://bugs.launchpad.net/bugs/1882089

Title:
  RM: ubuntu-app-launch obsolete, unused, ftbfs

Status in ubuntu-app-launch package in Ubuntu:
  Triaged
Status in url-dispatcher package in Ubuntu:
  Triaged

Bug description:
  RM: ubuntu-app-launch obsolete, unused, ftbfs

  ubuntu-app-launch is obsolete, unused by any Desktop Environment in
  the Archive.

  It also ftbfs with new glib / unity bindings.

  There are four packages in the archive that still link/depend/use
  ubuntu-app-launch, and all of them are now fixed in groovy-proposed,
  and should migrate soon.

  url-dispatcher is also obsolete and should be simply removed together
  with ubuntu-app-launch.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-app-launch/+bug/1882089/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1859829] Re: server will not boot after updating lvm2 package

2020-06-04 Thread Steve Dodd
This has just bitten me again on yet another machine - is it ever going
to be fixed? If it helps I suspect it's something to do with having
snapshots kicking around ..

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lvm2 in Ubuntu.
https://bugs.launchpad.net/bugs/1859829

Title:
  server will not boot after updating lvm2 package

Status in lvm2 package in Ubuntu:
  Confirmed

Bug description:
  After updating lvm2 from 2.02.176-4.1ubuntu3.18.04.1 to
  2.02.176-4.1ubuntu3.18.04.2, server will not boot.

  1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> 
About Ubuntu
  Description:Ubuntu 18.04.3 LTS
  Release:18.04

  2) The version of the package you are using, via 'apt-cache policy pkgname' 
or by checking in Software Center
  2.02.176-4.1ubuntu3.18.04.2

  3) What you expected to happen
  I expect the server to boot.

  4) What happened instead
  The server hangs at boot.

  As the server will not boot, I can not provide any logs.  I can only
  provide a screen captures of the boot failure messages.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lvm2/+bug/1859829/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1861082] Re: ubuntu-bug doesn't know how to file bugs against snaps

2020-06-04 Thread Lukas Märdian
My Merge Proposal can be found here:

https://code.launchpad.net/~slyon/apport/apport/+merge/385120

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apport in Ubuntu.
https://bugs.launchpad.net/bugs/1861082

Title:
  ubuntu-bug doesn't know how to file bugs against snaps

Status in Snapcraft:
  New
Status in snapd:
  Triaged
Status in Snap Store:
  New
Status in apport package in Ubuntu:
  Triaged
Status in apport source package in Focal:
  Triaged

Bug description:
  Hello, I had problems with subiquity in the focal live server install
  image. I tried to use 'ubuntu-bug subiquity' to report the bug, but
  ubuntu-bug apparently cannot file bug reports against snaps.

  This is frustrating that users need to know which portions of Ubuntu
  are delivered via debs, which portions are delivered by snaps, and try
  to find a way to report bugs correctly.

  ubuntu-bug should know how to report bugs for Canonical software.

  Thanks

To manage notifications about this bug go to:
https://bugs.launchpad.net/snapcraft/+bug/1861082/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1861082] Re: ubuntu-bug doesn't know how to file bugs against snaps

2020-06-04 Thread Lukas Märdian
** Branch linked: lp:~slyon/apport/apport

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apport in Ubuntu.
https://bugs.launchpad.net/bugs/1861082

Title:
  ubuntu-bug doesn't know how to file bugs against snaps

Status in Snapcraft:
  New
Status in snapd:
  Triaged
Status in Snap Store:
  New
Status in apport package in Ubuntu:
  Triaged
Status in apport source package in Focal:
  Triaged

Bug description:
  Hello, I had problems with subiquity in the focal live server install
  image. I tried to use 'ubuntu-bug subiquity' to report the bug, but
  ubuntu-bug apparently cannot file bug reports against snaps.

  This is frustrating that users need to know which portions of Ubuntu
  are delivered via debs, which portions are delivered by snaps, and try
  to find a way to report bugs correctly.

  ubuntu-bug should know how to report bugs for Canonical software.

  Thanks

To manage notifications about this bug go to:
https://bugs.launchpad.net/snapcraft/+bug/1861082/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1311056] Re: [SRU] apt-add-repository adds duplicate commented/disabled source lines

2020-06-04 Thread Dave Jones
All regressions now cleared after a re-run (thanks!), and verifications
done.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to python-apt in Ubuntu.
https://bugs.launchpad.net/bugs/1311056

Title:
  [SRU] apt-add-repository adds duplicate commented/disabled source
  lines

Status in python-apt package in Ubuntu:
  Fix Released
Status in python-apt source package in Xenial:
  Fix Committed
Status in python-apt source package in Bionic:
  Fix Committed
Status in python-apt source package in Eoan:
  Fix Committed

Bug description:
  Impact
  ==

  Under most circumstances, the impact is minimal (a few extra redundant
  comment lines in apt sources. However, if users are automating source
  removal / addition on a machine (as in comment 11), there is the
  potential to wind up with an excessively large (and thus slow to
  parse) apt sources configuration.

  Test packages for the supported releases are available from the
  following PPA:

  https://launchpad.net/~waveform/+archive/ubuntu/python-apt

  Built from the source which can be found in the following branches:

  https://code.launchpad.net/~waveform/ubuntu/+source/python-apt/+git
  /python-apt/+ref/sru-dupe-ppa-xenial

  https://code.launchpad.net/~waveform/ubuntu/+source/python-apt/+git
  /python-apt/+ref/sru-dupe-ppa-bionic

  https://code.launchpad.net/~waveform/ubuntu/+source/python-apt/+git
  /python-apt/+ref/sru-dupe-ppa-eoan

  Test Case
  =

  * sudo add-apt-repository -y ppa:deadsnakes/ppa
  * cat /etc/apt/sources.list.d/deadsnakes*.list
  * Note the presence of one uncommented "deb" line, and one commented 
"deb-src" line
  * sudo add-apt-repository -y ppa:deadsnakes/ppa
  * cat /etc/apt/sources.list.d/deadsnakes*.list
  * Note the uncommented "deb" line is still there but the commented "deb-src" 
line has now been duplicated
  * sudo add-apt-repository ppa:waveform/python-apt
  * sudo apt upgrade  # update python-apt to fixed version
  * sudo add-apt-repository -y ppa:deadsnakes/ppa
  * cat /etc/apt/sources.list.d/deadsnakes*.list
  * Note there has been no further duplication of the commented "deb-src" line

  Regression Potential
  

  Minimal; test cases have been added to cover the duplication case, and
  to cover the enabling of sources (which was not covered by existing
  tests, but was part of the code altered to fix the duplication case),
  and insertion of sources at a position (again, not covered by existing
  tests but modified as part of the fix). The test case has been used
  successfully on all targeted releases (xenial, bionic, and eoan).

  Original Description
  

  Trusty Tahr 14.04

  0 root@osprey:/etc/apt/sources.list.d#cat aims-aims-desktop-trusty.list
  deb http://ppa.launchpad.net/aims/aims-desktop/ubuntu trusty main
  # deb-src http://ppa.launchpad.net/aims/aims-desktop/ubuntu trusty main
  0 root@osprey:/etc/apt/sources.list.d#apt-add-repository -y 
ppa:aims/aims-desktop
  gpg: keyring `/tmp/tmp0ufdhnmv/secring.gpg' created
  gpg: keyring `/tmp/tmp0ufdhnmv/pubring.gpg' created
  gpg: requesting key BE796FF2 from hkp server keyserver.ubuntu.com
  gpg: /tmp/tmp0ufdhnmv/trustdb.gpg: trustdb created
  gpg: key BE796FF2: public key "Launchpad PPA for AIMS" imported
  gpg: Total number processed: 1
  gpg:   imported: 1  (RSA: 1)
  OK
  0 root@osprey:/etc/apt/sources.list.d#cat aims-aims-desktop-trusty.list deb 
http://ppa.launchpad.net/aims/aims-desktop/ubuntu trusty main
  # deb-src http://ppa.launchpad.net/aims/aims-desktop/ubuntu trusty main
  # deb-src http://ppa.launchpad.net/aims/aims-desktop/ubuntu trusty main
  0 root@osprey:/etc/apt/sources.list.d#

  That deb-src line should have stayed commented out, and not been
  duplicated. (Commented deb lines should of course be uncommented, as
  already fixed per https://bugs.launchpad.net/ubuntu/+source/python-
  apt/+bug/1042916 .)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/python-apt/+bug/1311056/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1861082] Re: ubuntu-bug doesn't know how to file bugs against snaps

2020-06-04 Thread Lukas Märdian
** Changed in: apport (Ubuntu)
 Assignee: (unassigned) => Lukas Märdian (slyon)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apport in Ubuntu.
https://bugs.launchpad.net/bugs/1861082

Title:
  ubuntu-bug doesn't know how to file bugs against snaps

Status in Snapcraft:
  New
Status in snapd:
  Triaged
Status in Snap Store:
  New
Status in apport package in Ubuntu:
  Triaged
Status in apport source package in Focal:
  Triaged

Bug description:
  Hello, I had problems with subiquity in the focal live server install
  image. I tried to use 'ubuntu-bug subiquity' to report the bug, but
  ubuntu-bug apparently cannot file bug reports against snaps.

  This is frustrating that users need to know which portions of Ubuntu
  are delivered via debs, which portions are delivered by snaps, and try
  to find a way to report bugs correctly.

  ubuntu-bug should know how to report bugs for Canonical software.

  Thanks

To manage notifications about this bug go to:
https://bugs.launchpad.net/snapcraft/+bug/1861082/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1882042] Re: [SRU] Linux, Ubuntu, 18.4, CI, OLP15, PRTS, Audio/video is out of sync/lag when enter Suspend during playback

2020-06-04 Thread Hui Wang
** Description changed:

- This bug is for tracking purpose.
+ [Impact]
+ Users reported the audio and video is out of sync when entering suspend 
during playback on bionic.
+ 
+ [Fix]
+ The mainline pulseaudio already has the fix for this issue, and the fix is 
already in the eoan, focal and groovy, but it is not in the bionic.
+ 
+ [Test Case]
+ open a online video on the firefox, while it is playing, suspend the system, 
wait for 30 seconds, resume the system, the audio and video is still on the 
sync.
+ 
+ [Regression Risk]
+ Low, these 2 patches are already in the mainline pulseaudio, and already in 
the eoan, focal and groovy.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1882042

Title:
  [SRU] Linux,Ubuntu,18.4,CI,OLP15,PRTS, Audio/video is out of sync/lag
  when enter Suspend during playback

Status in HWE Next:
  New
Status in pulseaudio package in Ubuntu:
  New
Status in pulseaudio source package in Bionic:
  New

Bug description:
  [Impact]
  Users reported the audio and video is out of sync when entering suspend 
during playback on bionic.

  [Fix]
  The mainline pulseaudio already has the fix for this issue, and the fix is 
already in the eoan, focal and groovy, but it is not in the bionic.

  [Test Case]
  open a online video on the firefox, while it is playing, suspend the system, 
wait for 30 seconds, resume the system, the audio and video is still on the 
sync.

  [Regression Risk]
  Low, these 2 patches are already in the mainline pulseaudio, and already in 
the eoan, focal and groovy.

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/1882042/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1882042] Re: Linux, Ubuntu, 18.4, CI, OLP15, PRTS, Audio/video is out of sync/lag when enter Suspend during playback

2020-06-04 Thread Hui Wang
This is the debdiff for bionic.

Since the patches are already in the mainline, eoan and focal already
have the patches, no need to send debdiff for eoan and focal.


** Patch added: "pulseaudio_11.1-1ubuntu7.9.debdiff"
   
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1882042/+attachment/5380317/+files/pulseaudio_11.1-1ubuntu7.9.debdiff

** Summary changed:

- Linux,Ubuntu,18.4,CI,OLP15,PRTS, Audio/video is out of sync/lag when enter 
Suspend during playback
+ [SRU] Linux,Ubuntu,18.4,CI,OLP15,PRTS, Audio/video is out of sync/lag when 
enter Suspend during playback

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1882042

Title:
  [SRU] Linux,Ubuntu,18.4,CI,OLP15,PRTS, Audio/video is out of sync/lag
  when enter Suspend during playback

Status in HWE Next:
  New
Status in pulseaudio package in Ubuntu:
  New
Status in pulseaudio source package in Bionic:
  New

Bug description:
  This bug is for tracking purpose.

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/1882042/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1576844] Re: Touchpad/Trackpad freezes then eventually unfreezes (repeatedly)

2020-06-04 Thread Vincenzo
Same problem here with Ubuntu 20.04. I have an Asus ZenBook Flip S
(UX370UA). I tried two kernels: 5.6.11 and 5.4.2

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1576844

Title:
  Touchpad/Trackpad freezes then eventually unfreezes (repeatedly)

Status in xorg package in Ubuntu:
  Confirmed

Bug description:
  $ lsb_release -rd
  Description:  Ubuntu 16.04 LTS
  Release:  16.04

  Several times yesterday and today (April 28-29, 2016) the touchpad
  (trackpad) on the Dell XPS 13 9343 has frozen.  Other functions
  (keyboard, screen, etc.) have been fine but the pointer has been
  frozen in place.  Then after 1-3 minutes functionality returns.

  Thank you very much for your assistance and I'd be happy to provide
  more information.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: xorg 1:7.7+13ubuntu3
  ProcVersionSignature: Ubuntu 4.4.0-22.38-generic 4.4.8
  Uname: Linux 4.4.0-22-generic x86_64
  NonfreeKernelModules: wl
  .tmp.unity_support_test.0:

  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  BootLog:

  CompizPlugins: [core,composite,opengl,cube,rotate]
  CompositorRunning: None
  CurrentDesktop: GNOME-Flashback:Unity
  Date: Fri Apr 29 16:09:32 2016
  DistUpgraded: 2016-04-27 15:53:13,798 DEBUG icon theme changed, re-reading
  DistroCodename: xenial
  DistroVariant: ubuntu
  DkmsStatus:
   bcmwl, 6.30.223.248+bdcom, 4.2.0-36-generic, x86_64: installed
   bcmwl, 6.30.223.248+bdcom, 4.4.0-22-generic, x86_64: installed
  ExtraDebuggingInterest: Yes, if not too technical
  GraphicsCard:
   Intel Corporation Broadwell-U Integrated Graphics [8086:1616] (rev 09) 
(prog-if 00 [VGA controller])
     Subsystem: Dell Broadwell-U Integrated Graphics [1028:0665]
  InstallationDate: Installed on 2015-08-06 (267 days ago)
  InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
  MachineType: Dell Inc. XPS 13 9343
  ProcEnviron:
   LANGUAGE=en_US
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.4.0-22-generic 
root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
  SourcePackage: xorg
  UpgradeStatus: Upgraded to xenial on 2016-04-27 (2 days ago)
  dmi.bios.date: 07/14/2015
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A05
  dmi.board.name: 0TM99H
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 9
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvrA05:bd07/14/2015:svnDellInc.:pnXPS139343:pvr:rvnDellInc.:rn0TM99H:rvrA00:cvnDellInc.:ct9:cvr:
  dmi.product.name: XPS 13 9343
  dmi.sys.vendor: Dell Inc.
  version.compiz: compiz 1:0.9.12.2+16.04.20160415-0ubuntu1
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.67-1
  version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu2
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2
  version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20160325-1ubuntu1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 
1:1.0.12-1build2
  xserver.bootTime: Wed Apr 27 15:54:22 2016
  xserver.configfile: default
  xserver.logfile: /var/log/Xorg.0.log
  xserver.outputs:
   product id5152
   vendor SHP
  xserver.version: 2:1.18.3-1ubuntu2

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1576844/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1870359] Re: My machine as Wi-Fi Hotspot broken after upgrade to 20.04

2020-06-04 Thread Launchpad Bug Tracker
This bug was fixed in the package network-manager - 1.24.0-1ubuntu2

---
network-manager (1.24.0-1ubuntu2) groovy; urgency=medium

  * debian/rules:
- the iptables binary is in /usr/sbin now, use the correct location in
  the configure. Should fix the hotspot feature not working in GNOME
  on upgraded systems which haven't been usrmerged.
  (lp: #1870359)

 -- Sebastien Bacher   Wed, 20 May 2020 12:03:07
+0200

** Changed in: network-manager (Ubuntu)
   Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1870359

Title:
  My machine as Wi-Fi Hotspot broken after upgrade to 20.04

Status in network-manager package in Ubuntu:
  Fix Released
Status in network-manager source package in Focal:
  Fix Released

Bug description:
  * Impact
  The hotspot feature fails to forward the data to the clients

  * Test case
  - log into an Ubuntu or GNOME session
  - connect the machine to an eth cable for internet
  - go to gnome-control-center -> wifi
  - enable the hotspot from the menu in the headerbar
  - connect another device to the wifi created
  -> the client should connect and access to internet work correctly

  * Regression potential
  the change is only updating the iptables binary location, there shouldn't be 
any code impact out of having the command working on systems without usrmerge 
when it was not before

  -

  
  I have a machine with a wired network connection and a wifi card. I've been 
using the machine as a wireless router and server in my house. I've attached a 
screenshot of the Wi-Fi network settings. It looks as expected.

  Upon updating to 20.04, none of my machines can use the connection.
  The linux machine will not connect. The windows machine will connect
  but will not have internet.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: network-manager 1.22.10-1ubuntu1
  ProcVersionSignature: Ubuntu 5.4.0-21.25-generic 5.4.27
  Uname: Linux 5.4.0-21-generic x86_64
  NonfreeKernelModules: wl
  ApportVersion: 2.20.11-0ubuntu22
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Apr  2 15:47:02 2020
  IfupdownConfig:
   # interfaces(5) file used by ifup(8) and ifdown(8)
   auto lo
   iface lo inet loopback
  InstallationDate: Installed on 2015-09-30 (1645 days ago)
  InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
  IpRoute:
   default via 192.168.0.1 dev eth0 proto static metric 100
   169.254.0.0/16 dev eth0 scope link metric 1000
   192.168.0.0/24 dev eth0 proto kernel scope link src 192.168.0.100 metric 100
  SourcePackage: network-manager
  UpgradeStatus: Upgraded to focal on 2020-04-02 (0 days ago)
  WifiSyslog:

  mtime.conffile..etc.NetworkManager.NetworkManager.conf: 
2018-01-13T14:45:42.987041
  nmcli-nm:
   RUNNING  VERSION  STATE  STARTUP  CONNECTIVITY  NETWORKING  WIFI-HW  
WIFI WWAN-HW  WWAN
   running  1.22.10  connected  started  full  enabled enabled  
enabled  enabled  enabled

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1870359/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1882071] [NEW] service ntp restart fails with error: unable to bind to wildcard address

2020-06-04 Thread Tilman Schmidt
Public bug reported:

Description:Ubuntu 16.04.6 LTS
Release:16.04

Package: ntp
Version: 1:4.2.8p4+dfsg-3ubuntu5.10

Restarting the ntp daemon ntpd after a change in the configuration file
/etc/ntp.conf via the shell command

% sudo service ntp restart

fails in a small fraction of cases (about 2-3%), logging the error:

unable to bind to wildcard address :: - another process may be running -
EXITING

and leaving the system without a running ntpd process.

Expected behaviour: ntpd process running with new configuration

Actual behaviour: no ntpd process running

Additional information:

Syslog shows systemd launching the "start" action before the old daemon has 
exited.
Consequently, the new ntpd process races the old one for the UDP socket to 
listen on.
Example log excerpt:

May 25 06:31:12 capetown systemd[1]: Stopping LSB: Start NTP daemon...
May 25 06:31:12 capetown ntp[28437]:  * Stopping NTP server ntpd
May 25 06:31:12 capetown ntp[28437]:...done.
May 25 06:31:12 capetown systemd[1]: Stopped LSB: Start NTP daemon.
May 25 06:31:12 capetown systemd[1]: Starting LSB: Start NTP daemon...
May 25 06:31:12 capetown ntp[28449]:  * Starting NTP server ntpd
May 25 06:31:12 capetown ntpd[28457]: ntpd 4.2.8p4@1.3265-o Tue Jan  7 15:08:23 
UTC 2020 (1): Starting
May 25 06:31:12 capetown ntpd[28457]: Command line: /usr/sbin/ntpd -p 
/var/run/ntpd.pid -g -u 113:119
May 25 06:31:12 capetown ntp[28449]:...done.
May 25 06:31:12 capetown systemd[1]: Started LSB: Start NTP daemon.
May 25 06:31:12 capetown ntpd[28460]: proto: precision = 0.105 usec (-23)
May 25 06:31:12 capetown ntpd[2749]: 41.76.128.222 local addr 192.168.0.42 -> 

May 25 06:31:12 capetown ntpd[28460]: MS-SNTP signd operations currently block 
ntpd degrading service to all clients.
May 25 06:31:12 capetown ntpd[28460]: restrict 0.0.0.0: KOD does nothing 
without LIMITED.
May 25 06:31:12 capetown ntpd[28460]: restrict ::: KOD does nothing without 
LIMITED.
May 25 06:31:12 capetown ntpd[28460]: unable to bind to wildcard address :: - 
another process may be running - EXITING

Running the "service ntp restart" command a second time successfully
starts the ntpd daemon again.

** Affects: ntp (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ntp in Ubuntu.
https://bugs.launchpad.net/bugs/1882071

Title:
  service ntp restart fails with error: unable to bind to wildcard
  address

Status in ntp package in Ubuntu:
  New

Bug description:
  Description:Ubuntu 16.04.6 LTS
  Release:16.04

  Package: ntp
  Version: 1:4.2.8p4+dfsg-3ubuntu5.10

  Restarting the ntp daemon ntpd after a change in the configuration
  file /etc/ntp.conf via the shell command

  % sudo service ntp restart

  fails in a small fraction of cases (about 2-3%), logging the error:

  unable to bind to wildcard address :: - another process may be running
  - EXITING

  and leaving the system without a running ntpd process.

  Expected behaviour: ntpd process running with new configuration

  Actual behaviour: no ntpd process running

  Additional information:

  Syslog shows systemd launching the "start" action before the old daemon has 
exited.
  Consequently, the new ntpd process races the old one for the UDP socket to 
listen on.
  Example log excerpt:

  May 25 06:31:12 capetown systemd[1]: Stopping LSB: Start NTP daemon...
  May 25 06:31:12 capetown ntp[28437]:  * Stopping NTP server ntpd
  May 25 06:31:12 capetown ntp[28437]:...done.
  May 25 06:31:12 capetown systemd[1]: Stopped LSB: Start NTP daemon.
  May 25 06:31:12 capetown systemd[1]: Starting LSB: Start NTP daemon...
  May 25 06:31:12 capetown ntp[28449]:  * Starting NTP server ntpd
  May 25 06:31:12 capetown ntpd[28457]: ntpd 4.2.8p4@1.3265-o Tue Jan  7 
15:08:23 UTC 2020 (1): Starting
  May 25 06:31:12 capetown ntpd[28457]: Command line: /usr/sbin/ntpd -p 
/var/run/ntpd.pid -g -u 113:119
  May 25 06:31:12 capetown ntp[28449]:...done.
  May 25 06:31:12 capetown systemd[1]: Started LSB: Start NTP daemon.
  May 25 06:31:12 capetown ntpd[28460]: proto: precision = 0.105 usec (-23)
  May 25 06:31:12 capetown ntpd[2749]: 41.76.128.222 local addr 192.168.0.42 -> 

  May 25 06:31:12 capetown ntpd[28460]: MS-SNTP signd operations currently 
block ntpd degrading service to all clients.
  May 25 06:31:12 capetown ntpd[28460]: restrict 0.0.0.0: KOD does nothing 
without LIMITED.
  May 25 06:31:12 capetown ntpd[28460]: restrict ::: KOD does nothing without 
LIMITED.
  May 25 06:31:12 capetown ntpd[28460]: unable to bind to wildcard address :: - 
another process may be running - EXITING

  Running the "service ntp restart" command a second time successfully
  starts the ntpd daemon again.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ntp/+bug/1882071/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to 

[Touch-packages] [Bug 1879525] Re: Add TLS support

2020-06-04 Thread Łukasz Zemczak
Hello Dimitri, or anyone else affected,

Accepted busybox into focal-proposed. The package will build now and be
available at
https://launchpad.net/ubuntu/+source/busybox/1:1.30.1-4ubuntu6.1 in a
few hours, and then in the -proposed repository.

Please help us by testing this new package.  See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how
to enable and use -proposed.  Your feedback will aid us getting this
update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested, what testing has been
performed on the package and change the tag from verification-needed-
focal to verification-done-focal. If it does not fix the bug for you,
please add a comment stating that, and change the tag to verification-
failed-focal. In either case, without details of your testing we will
not be able to proceed.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification .  Thank you in
advance for helping!

N.B. The updated package will be released to -updates after the bug(s)
fixed by this package have been verified and the package has been in
-proposed for a minimum of 7 days.

** Changed in: busybox (Ubuntu Focal)
   Status: New => Fix Committed

** Tags added: verification-needed verification-needed-focal

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to busybox in Ubuntu.
https://bugs.launchpad.net/bugs/1879525

Title:
  Add TLS support

Status in busybox package in Ubuntu:
  Fix Released
Status in busybox source package in Focal:
  Fix Committed

Bug description:
  [Impact]

   * busybox in the initramfs provides wget applet that is used by casper for 
netboot support
   * It does not support https at the moment, but it is desirable that it does
   * There is built-in TLS code, or "fork & execute openssl"
   * Enable the later one, and optionally include /usr/bin/openssl & certs, 
when building casper-like initrds which should support netboot.

  [Test Case]

   * Boot casper created initrd, with break=bottom
   * Configure dhcp based networking
   * Attempt to wget https://start.ubuntu.com/connectivity-check
   * It should succeed

  [Regression Potential]

   * The openssl codepath is optional in busybox wget, and we only include 
openssl & certs for casper.
   * The casper based initrd will grow in size, due to inclusion of openssl & 
certs

  [Other Info]
   
   * Parity with d-i, which includes https support already

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/busybox/+bug/1879525/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1879533] Re: busybox does not verify TLS connections with CONFIG_FEATURE_WGET_OPENSSL=y and CONFIG_FEATURE_WGET_HTTPS unset, and doesn't warn either about it

2020-06-04 Thread Łukasz Zemczak
Hello Dimitri, or anyone else affected,

Accepted busybox into focal-proposed. The package will build now and be
available at
https://launchpad.net/ubuntu/+source/busybox/1:1.30.1-4ubuntu6.1 in a
few hours, and then in the -proposed repository.

Please help us by testing this new package.  See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how
to enable and use -proposed.  Your feedback will aid us getting this
update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested, what testing has been
performed on the package and change the tag from verification-needed-
focal to verification-done-focal. If it does not fix the bug for you,
please add a comment stating that, and change the tag to verification-
failed-focal. In either case, without details of your testing we will
not be able to proceed.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification .  Thank you in
advance for helping!

N.B. The updated package will be released to -updates after the bug(s)
fixed by this package have been verified and the package has been in
-proposed for a minimum of 7 days.

** Changed in: busybox (Ubuntu Focal)
   Status: New => Fix Committed

** Tags added: verification-needed verification-needed-focal

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to busybox in Ubuntu.
https://bugs.launchpad.net/bugs/1879533

Title:
  busybox does not verify TLS connections with
  CONFIG_FEATURE_WGET_OPENSSL=y and CONFIG_FEATURE_WGET_HTTPS unset, and
  doesn't warn either about it

Status in busybox package in Ubuntu:
  Fix Released
Status in busybox source package in Focal:
  Fix Committed
Status in busybox source package in Groovy:
  Fix Released

Bug description:
  [Impact]

   * CONFIG_FEATURE_WGET_OPENSSL=y enables https support in wget busybox
  applet using openssl

   * CONFIG_FEATURE_WGET_HTTPS=y enables https support in wget busybox
  applet using internal TLS code

   * CVE-2018-1000500 ensured that when CONFIG_FEATURE_WGET_HTTPS=y is
  used, a message is printed to notify the users that TLS verification
  is not perfomed.

   * However, when one configures with CONFIG_FEATURE_WGET_OPENSSL=y and
  CONFIG_FEATURE_WGET_HTTPS unset - no such message is printed.

   * Also TLS verification is not performed under OPENSSL case.

   * When performing https requests, it works openssl s_client and communicates 
with it to perform https download
   * Whilst doing so, it does not pass `-verify_return_error` option, meaning 
any verification errors are ignored

   * There is no warning that TLS verification was not performed

  [Test Case]

   * Preparation: sudo apt install busybox; or build busybox with
  CONFIG_FEATURE_WGET_OPENSSL=y

   * Test case: /bin/busybox wget https://untrusted-root.badssl.com/

   * Expected: download failed, or download suceeds with warning printed
  that verification is disabled

   * Observed: download success without a warning that verification is
  disabled.

  $ /bin/busybox wget https://untrusted-root.badssl.com/
  Connecting to untrusted-root.badssl.com (104.154.89.105:443)
  index.html   100% 
|*|
   600  0:00:00 ETA

  $ cat index.html  | grep certificate
    The certificate for this site is signed using an untrusted root.

  [Regression Potential]

   * The fact that /bin/busybox wget https:// succeeds without TLS
  verification might be relied upon. If this issue is fixed, ensure that
  `--no-check-certificate` is honored.

  [Other Info]

   * Proposed fix

     pass `-verify_return_error` to s_client, unless `--no-check-
  certificate` is specified

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/busybox/+bug/1879533/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1879533] Re: busybox does not verify TLS connections with CONFIG_FEATURE_WGET_OPENSSL=y and CONFIG_FEATURE_WGET_HTTPS unset, and doesn't warn either about it

2020-06-04 Thread Łukasz Zemczak
Ok, xnox cleared out the situation for me. This is not needed in
-security.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to busybox in Ubuntu.
https://bugs.launchpad.net/bugs/1879533

Title:
  busybox does not verify TLS connections with
  CONFIG_FEATURE_WGET_OPENSSL=y and CONFIG_FEATURE_WGET_HTTPS unset, and
  doesn't warn either about it

Status in busybox package in Ubuntu:
  Fix Released
Status in busybox source package in Focal:
  New
Status in busybox source package in Groovy:
  Fix Released

Bug description:
  [Impact]

   * CONFIG_FEATURE_WGET_OPENSSL=y enables https support in wget busybox
  applet using openssl

   * CONFIG_FEATURE_WGET_HTTPS=y enables https support in wget busybox
  applet using internal TLS code

   * CVE-2018-1000500 ensured that when CONFIG_FEATURE_WGET_HTTPS=y is
  used, a message is printed to notify the users that TLS verification
  is not perfomed.

   * However, when one configures with CONFIG_FEATURE_WGET_OPENSSL=y and
  CONFIG_FEATURE_WGET_HTTPS unset - no such message is printed.

   * Also TLS verification is not performed under OPENSSL case.

   * When performing https requests, it works openssl s_client and communicates 
with it to perform https download
   * Whilst doing so, it does not pass `-verify_return_error` option, meaning 
any verification errors are ignored

   * There is no warning that TLS verification was not performed

  [Test Case]

   * Preparation: sudo apt install busybox; or build busybox with
  CONFIG_FEATURE_WGET_OPENSSL=y

   * Test case: /bin/busybox wget https://untrusted-root.badssl.com/

   * Expected: download failed, or download suceeds with warning printed
  that verification is disabled

   * Observed: download success without a warning that verification is
  disabled.

  $ /bin/busybox wget https://untrusted-root.badssl.com/
  Connecting to untrusted-root.badssl.com (104.154.89.105:443)
  index.html   100% 
|*|
   600  0:00:00 ETA

  $ cat index.html  | grep certificate
    The certificate for this site is signed using an untrusted root.

  [Regression Potential]

   * The fact that /bin/busybox wget https:// succeeds without TLS
  verification might be relied upon. If this issue is fixed, ensure that
  `--no-check-certificate` is honored.

  [Other Info]

   * Proposed fix

     pass `-verify_return_error` to s_client, unless `--no-check-
  certificate` is specified

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/busybox/+bug/1879533/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1880853] Re: libc6-lse lets update-initramfs fail on AWS m6g instances

2020-06-04 Thread Sorah Fukumori
Confirmed the bug gets addressed with the initramfs-tools 0.136ubuntu6.1
on arm64 focal.

** Tags removed: verification-needed-focal
** Tags added: verification-done-focal

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1880853

Title:
  libc6-lse lets update-initramfs fail on AWS m6g instances

Status in cloud-images:
  New
Status in btrfs-progs package in Ubuntu:
  Invalid
Status in glibc package in Ubuntu:
  Invalid
Status in initramfs-tools package in Ubuntu:
  Fix Released
Status in btrfs-progs source package in Focal:
  Invalid
Status in glibc source package in Focal:
  Invalid
Status in initramfs-tools source package in Focal:
  Fix Committed

Bug description:
  [Impact]

   * update-initramfs -u fails on arm64 m6g instances in AWS

  [Test Case]

   * launch m6g instance in AWS
   * install libc6-lse (if not installed)
   * run $ update-initramfs -u
   * It should suceed

  [Regression Potential]

   * Adding one more path to libgcc_s1 resolution. This will still fail
  if something compiles libc6 for _two_ optimisations like
  /lib/$arch/foo/bar/libpthread.

  [Other Info]

   * libphtread dlopens libgcc_s1, thus whenever libpthread is needed in
  the initrd libgcc_s1 must be copied in too. However the logic to find
  matching libgcc_s1 is broken for optimizied builds of libc6 without
  optimized build of libgcc_s1. I think libpthread should link against
  libgcc_s1 to prevent these issues.

   * Original bug report

  With Ubuntu 20.04 on AWS m6g.* instance family, installing libc6-lse
  lets update-initramfs always fail with the following error:

  ubuntu@ip-10-18-23-79:~$ sudo update-initramfs -u
  update-initramfs: Generating /boot/initrd.img-5.4.0-1011-aws
  E: /usr/share/initramfs-tools/hooks/btrfs failed with return 1.
  update-initramfs: failed for /boot/initrd.img-5.4.0-1011-aws with 1.

  ## Steps to reproduce (on AWS)

  ### With focal 20200423 AMI

  1. Find the following AMI and launch on m6g instance family

     ubuntu/images/hvm-ssd/ubuntu-focal-20.04-arm64-server-20200423

  2. Run: sudo apt update && sudo apt install libc6-lse
  3. Try: sudo update-initramfs -u

  ### With focal 20200522 AMI

  1. Find the following AMI and launch on m6g instance family

     ubuntu/images/hvm-ssd/ubuntu-focal-20.04-arm64-server-20200522

  2. Try: sudo update-initramfs -u

  ## Note

  - The entire log of the above steps performed on 20200423 AMI is attached.
  - Latest cloud-image AMI 
"ubuntu/images/hvm-ssd/ubuntu-focal-20.04-arm64-server-20200522" includes 
libc6-lse. On 20200522 AMI, this doesn't reproduce after removing libc6-lse 
manually.
  - This doesn't reproduce on EC2 a1.* instance family.

  ## Expected behavior

  Does not fail.

  ## Background to find this bug

  As the 20200522 AMI includes libc6-lse out-of-the-box & apt-get
  upgrade pulls newer package that triggers update-initramfs, apt-get
  upgrade always fail on 20200522 AMI.

  the following is an apport report on 20200423 AMI:

  

  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27
  Architecture: arm64
  CasperMD5CheckResult: skip
  Date: Wed May 27 09:52:16 2020
  Dependencies:
   gcc-10-base 10-20200411-0ubuntu1
   libc6 2.31-0ubuntu9
   libcrypt1 1:4.4.10-10ubuntu4
   libgcc-s1 10-20200411-0ubuntu1
   libidn2-0 2.2.0-2
   libunistring2 0.9.10-2
  DistroRelease: Ubuntu 20.04
  Ec2AMI: ami-061102f51d47b1c24
  Ec2AMIManifest: (unknown)
  Ec2AvailabilityZone: ap-northeast-1c
  Ec2InstanceType: m6g.medium
  Ec2Kernel: unavailable
  Ec2Ramdisk: unavailable
  Package: libc6-lse 2.31-0ubuntu9
  PackageArchitecture: arm64
  ProcCpuinfoMinimal:
   processor  : 0
   BogoMIPS   : 243.75
   Features   : fp asimd evtstrm aes pmull sha1 sha2 crc32 atomics fphp 
asimdhp cpuid asimdrdm lrcpc dcpop asimddp ssbs
   CPU implementer: 0x41
   CPU architecture: 8
   CPU variant: 0x3
   CPU part   : 0xd0c
   CPU revision   : 1
  ProcEnviron:
   LANG=C.UTF-8
   TERM=screen-256color
   PATH=(custom, no user)
   SHELL=/bin/bash
  ProcVersionSignature: Ubuntu 5.4.0-1009.9-aws 5.4.30
  SourcePackage: glibc
  Tags:  focal ec2-images
  Uname: Linux 5.4.0-1009-aws aarch64
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/cloud-images/+bug/1880853/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1871154] Re: Error message displayed during boot (mountroot hook, premount)

2020-06-04 Thread Laurent Bonnaud
I installed this package:

  Package: initramfs-tools
  Version: 0.136ubuntu6.1

from focal-proposed, checked that the initramfs were recreated:

-rw-r--r-- 1 root root 54661886 Jun  4 09:37 /boot/initrd.img-5.4.0-34-generic
-rw-r--r-- 1 root root 54666889 Jun  4 09:37 
/boot/initrd.img-5.4.0-34-lowlatency
-rw-r--r-- 1 root root 55265839 Jun  4 09:37 
/boot/initrd.img-5.6.16-050616-generic

and rebooted my system.  It boots correctly and LVM is working.  No
error message is displayed during boot.

I also tried on another system where the lvm2 package is installed but
not used.  The error message also disappeared.

I also tried on another system where the lvm2 package is not installed
and saw no problem during boot.


** Tags removed: verification-needed verification-needed-focal
** Tags added: verification-done verification-done-focal

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lvm2 in Ubuntu.
https://bugs.launchpad.net/bugs/1871154

Title:
  Error message displayed during boot (mountroot hook, premount)

Status in initramfs-tools package in Ubuntu:
  Fix Released
Status in lvm2 package in Ubuntu:
  Fix Released
Status in initramfs-tools source package in Focal:
  Fix Committed
Status in lvm2 source package in Focal:
  Invalid

Bug description:
  [Impact] 
  * People using lvm2 on ubuntu focal are getting a strange and weird message 
due to a wrong path

  [Test Case]
  * Install lvm2 on Ubuntu 20.04

  [Regression Potential] 
  * Low, the fix is already part of groovy

  [Other info]
  Hi,

  my Ubuntu system uses LVM2 for its root file system.  It boots
  correctly, but an ugly error message is displayed during boot.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: lvm2 2.03.07-1ubuntu1
  Uname: Linux 5.6.2-050602-generic x86_64
  ApportVersion: 2.20.11-0ubuntu22
  Architecture: amd64
  CurrentDesktop: KDE
  Date: Mon Apr  6 17:59:03 2020
  SourcePackage: lvm2
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1871154/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1879533] Re: busybox does not verify TLS connections with CONFIG_FEATURE_WGET_OPENSSL=y and CONFIG_FEATURE_WGET_HTTPS unset, and doesn't warn either about it

2020-06-04 Thread Łukasz Zemczak
Seeing that this is a fix for a documented CVE, do we also want to
upload this to -security? Should we build this first in a security
enabled PPA?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to busybox in Ubuntu.
https://bugs.launchpad.net/bugs/1879533

Title:
  busybox does not verify TLS connections with
  CONFIG_FEATURE_WGET_OPENSSL=y and CONFIG_FEATURE_WGET_HTTPS unset, and
  doesn't warn either about it

Status in busybox package in Ubuntu:
  Fix Released
Status in busybox source package in Focal:
  New
Status in busybox source package in Groovy:
  Fix Released

Bug description:
  [Impact]

   * CONFIG_FEATURE_WGET_OPENSSL=y enables https support in wget busybox
  applet using openssl

   * CONFIG_FEATURE_WGET_HTTPS=y enables https support in wget busybox
  applet using internal TLS code

   * CVE-2018-1000500 ensured that when CONFIG_FEATURE_WGET_HTTPS=y is
  used, a message is printed to notify the users that TLS verification
  is not perfomed.

   * However, when one configures with CONFIG_FEATURE_WGET_OPENSSL=y and
  CONFIG_FEATURE_WGET_HTTPS unset - no such message is printed.

   * Also TLS verification is not performed under OPENSSL case.

   * When performing https requests, it works openssl s_client and communicates 
with it to perform https download
   * Whilst doing so, it does not pass `-verify_return_error` option, meaning 
any verification errors are ignored

   * There is no warning that TLS verification was not performed

  [Test Case]

   * Preparation: sudo apt install busybox; or build busybox with
  CONFIG_FEATURE_WGET_OPENSSL=y

   * Test case: /bin/busybox wget https://untrusted-root.badssl.com/

   * Expected: download failed, or download suceeds with warning printed
  that verification is disabled

   * Observed: download success without a warning that verification is
  disabled.

  $ /bin/busybox wget https://untrusted-root.badssl.com/
  Connecting to untrusted-root.badssl.com (104.154.89.105:443)
  index.html   100% 
|*|
   600  0:00:00 ETA

  $ cat index.html  | grep certificate
    The certificate for this site is signed using an untrusted root.

  [Regression Potential]

   * The fact that /bin/busybox wget https:// succeeds without TLS
  verification might be relied upon. If this issue is fixed, ensure that
  `--no-check-certificate` is honored.

  [Other Info]

   * Proposed fix

     pass `-verify_return_error` to s_client, unless `--no-check-
  certificate` is specified

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/busybox/+bug/1879533/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1882063] [NEW] package linux-image-generic-hwe-16.04 4.15.0.101.108 failed to install/upgrade: beroendeproblem - lämnar okonfigurerad

2020-06-04 Thread Håkan Elmqvist
Public bug reported:

happens all the time

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: linux-image-generic-hwe-16.04 4.15.0.101.108
ProcVersionSignature: Ubuntu 4.15.0-91.92~16.04.1-generic 4.15.18
Uname: Linux 4.15.0-91-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.23
Architecture: amd64
Date: Thu Jun  4 08:04:57 2020
ErrorMessage: beroendeproblem - lämnar okonfigurerad
InstallationDate: Installed on 2020-02-06 (118 days ago)
InstallationMedia: Ubuntu 16.04.5 LTS "Xenial Xerus" - Release amd64 (20180731)
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.4
 apt  1.2.32ubuntu0.1
SourcePackage: initramfs-tools
Title: package linux-image-generic-hwe-16.04 4.15.0.101.108 failed to 
install/upgrade: beroendeproblem - lämnar okonfigurerad
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: initramfs-tools (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package xenial

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1882063

Title:
  package linux-image-generic-hwe-16.04 4.15.0.101.108 failed to
  install/upgrade: beroendeproblem - lämnar okonfigurerad

Status in initramfs-tools package in Ubuntu:
  New

Bug description:
  happens all the time

  ProblemType: Package
  DistroRelease: Ubuntu 16.04
  Package: linux-image-generic-hwe-16.04 4.15.0.101.108
  ProcVersionSignature: Ubuntu 4.15.0-91.92~16.04.1-generic 4.15.18
  Uname: Linux 4.15.0-91-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.23
  Architecture: amd64
  Date: Thu Jun  4 08:04:57 2020
  ErrorMessage: beroendeproblem - lämnar okonfigurerad
  InstallationDate: Installed on 2020-02-06 (118 days ago)
  InstallationMedia: Ubuntu 16.04.5 LTS "Xenial Xerus" - Release amd64 
(20180731)
  RelatedPackageVersions:
   dpkg 1.18.4ubuntu1.4
   apt  1.2.32ubuntu0.1
  SourcePackage: initramfs-tools
  Title: package linux-image-generic-hwe-16.04 4.15.0.101.108 failed to 
install/upgrade: beroendeproblem - lämnar okonfigurerad
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1882063/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1880864] Re: networkmanager IKE VPN connection causes DNS leak

2020-06-04 Thread Fabrice Meyer
Done, here is the link to this issue :
https://gitlab.freedesktop.org/NetworkManager/NetworkManager/-/issues/462

** Bug watch added: 
gitlab.freedesktop.org/NetworkManager/NetworkManager/-/issues #462
   https://gitlab.freedesktop.org/NetworkManager/NetworkManager/-/issues/462

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1880864

Title:
  networkmanager IKE VPN connection causes DNS leak

Status in network-manager package in Ubuntu:
  New

Bug description:
  Description:  Ubuntu 20.04 LTS
  Release:  20.04

  network-manager:
Installé : 1.22.10-1ubuntu1
Candidat : 1.22.10-1ubuntu1
   Table de version :
   *** 1.22.10-1ubuntu1 500
  500 http://fr.archive.ubuntu.com/ubuntu focal/main amd64 Packages
  100 /var/lib/dpkg/status

  
  Connecting to a IPSEC IKE VPN does not update correctly update 
systemd-resolve dns parameters: DNS provided by the VPN tunnel is seen by 
systemd-resolve but not use to resolve dns queries resulting to a DNS leak. I 
tried to play with network manager priority which as no effect: default setting 
seems to be fine as the dns provided by the vpn appears on top of dns list 
provided by "systemd-resolve --status" result bellow.

  I found out a way to get it working by restarting systemd-resolve
  service after the vpn connection is established. I think (pure
  speculation, I don't know how systemd-resolve works) systemd-resolve
  evaluate which dns use, the one provided by the vpn is the first one
  then it decide to use it. This evaluation should be triggered when
  tunnel is bringed up.

  Bringing up an IPSEC IKE VPN does not create a new interface, it will
  use the same used by the default network interface where is configured
  the gateway. I think a fix would be to find out a way to triggered the
  dns election of systemd-resolve to update the "Current DNS Server".

  Maybe it is a bug with systemd-resolve but as I don't know how
  everything work together, I choose to report this here.

  You will find my network manager config for this particular ipsec
  tunnel bellow.

  Before systemctl restart systemd-resolved.service

  Global
 LLMNR setting: no  
  MulticastDNS setting: no  
DNSOverTLS setting: no  
DNSSEC setting: no  
  DNSSEC supported: no  
DNSSEC NTA: 10.in-addr.arpa 
16.172.in-addr.arpa 
168.192.in-addr.arpa
17.172.in-addr.arpa 
18.172.in-addr.arpa 
19.172.in-addr.arpa 
20.172.in-addr.arpa 
21.172.in-addr.arpa 
22.172.in-addr.arpa 
23.172.in-addr.arpa 
24.172.in-addr.arpa 
25.172.in-addr.arpa 
26.172.in-addr.arpa 
27.172.in-addr.arpa 
28.172.in-addr.arpa 
29.172.in-addr.arpa 
30.172.in-addr.arpa 
31.172.in-addr.arpa 
corp
d.f.ip6.arpa
home
internal
intranet
lan 
local   
private 
test

  Link 2 (eno1)
Current Scopes: DNS  
  DefaultRoute setting: yes  
 LLMNR setting: yes  
  MulticastDNS setting: no   
DNSOverTLS setting: no   
DNSSEC setting: no   
  DNSSEC supported: no   
Current DNS Server: 192.168.10.1
   DNS Servers: 192.168.1.1  #DNS from VPN
192.168.10.1 #DNS from DHCP
DNS Domain: lan
~.

  after systemctl restart systemd-resolved.service

  Global
 LLMNR setting: no  
  MulticastDNS setting: no  
DNSOverTLS setting: no  
DNSSEC setting: no  
  DNSSEC supported: no  
DNSSEC NTA: 10.in-addr.arpa 
16.172.in-addr.arpa 
168.192.in-addr.arpa
17.172.in-addr.arpa 
18.172.in-addr.arpa 
19.172.in-addr.arpa 
20.172.in-addr.arpa 
21.172.in-addr.arpa 
22.172.in-addr.arpa 
23.172.in-addr.arpa 
24.172.in-addr.arpa 

[Touch-packages] [Bug 1871721] Re: Second Monitor on HDMI blank screen with Nvidia & Ubuntu 20.04? (ASUS Laptop)

2020-06-04 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: mesa-utils (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1871721

Title:
  Second Monitor on HDMI blank screen with Nvidia & Ubuntu 20.04? (ASUS
  Laptop)

Status in kernel-package package in Ubuntu:
  Confirmed
Status in mesa package in Ubuntu:
  Confirmed
Status in mesa-utils package in Ubuntu:
  Confirmed
Status in nouveau-firmware package in Ubuntu:
  Confirmed
Status in nvidia-graphics-drivers-440 package in Ubuntu:
  Confirmed
Status in xserver-xorg-video-intel package in Ubuntu:
  Confirmed

Bug description:
  I installed Ubuntu 20.04 on my ASUS laptop with Intel+Nvidia with propietary 
drivers of Nvidia (I have 440.64 rn) and I connected a second monitor to use 
it, but I saw that I cannot use it, I just see a blank screen. I tried with a 
TV of my room and same. The funny part is when I start the laptop to work, I 
can see the logo of my BIOS and the ASUS logo in the second monitor, even the 
grub, but after that I can't see nothing.
  When I reduce the resolution of the second monitor (800x600) then works, but 
even with that sometimes blinks to black again.
  On W10 for example it works perfectly, so I deduce it's not 'cause my HDMI.

  I tried with noveau drivers and I have the same results btw.

  Laptop Asus with:
  Graphic card  Nvidia GTX960M
  Processor  Intel i5 6300

  I tried with Nvidia Prime to Nvidia, Intel and On-demand. None of them
  works. All of them with Xorg.

  I have this with xrandr:

  Screen 0: minimum 8 x 8, current 2720 x 1080, maximum 16384 x 16384
  eDP-1-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y 
axis) 344mm x 193mm
     1920x1080 60.00*+  59.9759.9659.93
     1680x1050 59.9559.88
     1600x1024 60.17
     1400x1050 59.98
     1600x900  59.9959.9459.9559.82
     1280x1024 60.02
     1440x900  59.89
     1400x900  59.9659.88
     1280x960  60.00
     1440x810  60.0059.97
     1368x768  59.8859.85
     1360x768  59.8059.96
     1280x800  59.9959.9759.8159.91
     1152x864  60.00
     1280x720  60.0059.9959.8659.74
     1024x768  60.0460.00
     960x720   60.00
     928x696   60.05
     896x672   60.01
     1024x576  59.9559.9659.9059.82
     960x600   59.9360.00
     960x540   59.9659.9959.6359.82
     800x600   60.0060.3256.25
     840x525   60.0159.88
     864x486   59.9259.57
     800x512   60.17
     700x525   59.98
     800x450   59.9559.82
     640x512   60.02
     720x450   59.89
     700x450   59.9659.88
     640x480   60.0059.94
     720x405   59.5158.99
     684x384   59.8859.85
     680x384   59.8059.96
     640x400   59.8859.98
     576x432   60.06
     640x360   59.8659.8359.8459.32
     512x384   60.00
     512x288   60.0059.92
     480x270   59.6359.82
     400x300   60.3256.34
     432x243   59.9259.57
     320x240   60.05
     360x202   59.5159.13
     320x180   59.8459.32
  DP-1-1 disconnected (normal left inverted right x axis y axis)
  HDMI-1-1 disconnected (normal left inverted right x axis y axis)
  HDMI-1-2 connected 800x600+1920+0 (normal left inverted right x axis y axis) 
1600mm x 900mm
     1920x1080 60.00 +  50.0059.9430.0025.0024.0029.97  
  23.98
     1920x1080i60.0050.0059.94
     1280x1024 60.02
     1360x768  60.02
     1152x864  59.97
     1280x720  59.8160.0050.0059.94
     1024x768  60.00
     800x600   60.32*
     720x576   50.00
     720x576i  50.00
     720x480   60.0059.94
     640x480   60.0059.94
     720x400   70.08
  DP-1-2 disconnected (normal left inverted right x axis y axis)
  HDMI-1-3 disconnected (normal left inverted right x axis y axis)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/kernel-package/+bug/1871721/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1871721] Re: Second Monitor on HDMI blank screen with Nvidia & Ubuntu 20.04? (ASUS Laptop)

2020-06-04 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: mesa (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1871721

Title:
  Second Monitor on HDMI blank screen with Nvidia & Ubuntu 20.04? (ASUS
  Laptop)

Status in kernel-package package in Ubuntu:
  Confirmed
Status in mesa package in Ubuntu:
  Confirmed
Status in mesa-utils package in Ubuntu:
  Confirmed
Status in nouveau-firmware package in Ubuntu:
  Confirmed
Status in nvidia-graphics-drivers-440 package in Ubuntu:
  Confirmed
Status in xserver-xorg-video-intel package in Ubuntu:
  Confirmed

Bug description:
  I installed Ubuntu 20.04 on my ASUS laptop with Intel+Nvidia with propietary 
drivers of Nvidia (I have 440.64 rn) and I connected a second monitor to use 
it, but I saw that I cannot use it, I just see a blank screen. I tried with a 
TV of my room and same. The funny part is when I start the laptop to work, I 
can see the logo of my BIOS and the ASUS logo in the second monitor, even the 
grub, but after that I can't see nothing.
  When I reduce the resolution of the second monitor (800x600) then works, but 
even with that sometimes blinks to black again.
  On W10 for example it works perfectly, so I deduce it's not 'cause my HDMI.

  I tried with noveau drivers and I have the same results btw.

  Laptop Asus with:
  Graphic card  Nvidia GTX960M
  Processor  Intel i5 6300

  I tried with Nvidia Prime to Nvidia, Intel and On-demand. None of them
  works. All of them with Xorg.

  I have this with xrandr:

  Screen 0: minimum 8 x 8, current 2720 x 1080, maximum 16384 x 16384
  eDP-1-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y 
axis) 344mm x 193mm
     1920x1080 60.00*+  59.9759.9659.93
     1680x1050 59.9559.88
     1600x1024 60.17
     1400x1050 59.98
     1600x900  59.9959.9459.9559.82
     1280x1024 60.02
     1440x900  59.89
     1400x900  59.9659.88
     1280x960  60.00
     1440x810  60.0059.97
     1368x768  59.8859.85
     1360x768  59.8059.96
     1280x800  59.9959.9759.8159.91
     1152x864  60.00
     1280x720  60.0059.9959.8659.74
     1024x768  60.0460.00
     960x720   60.00
     928x696   60.05
     896x672   60.01
     1024x576  59.9559.9659.9059.82
     960x600   59.9360.00
     960x540   59.9659.9959.6359.82
     800x600   60.0060.3256.25
     840x525   60.0159.88
     864x486   59.9259.57
     800x512   60.17
     700x525   59.98
     800x450   59.9559.82
     640x512   60.02
     720x450   59.89
     700x450   59.9659.88
     640x480   60.0059.94
     720x405   59.5158.99
     684x384   59.8859.85
     680x384   59.8059.96
     640x400   59.8859.98
     576x432   60.06
     640x360   59.8659.8359.8459.32
     512x384   60.00
     512x288   60.0059.92
     480x270   59.6359.82
     400x300   60.3256.34
     432x243   59.9259.57
     320x240   60.05
     360x202   59.5159.13
     320x180   59.8459.32
  DP-1-1 disconnected (normal left inverted right x axis y axis)
  HDMI-1-1 disconnected (normal left inverted right x axis y axis)
  HDMI-1-2 connected 800x600+1920+0 (normal left inverted right x axis y axis) 
1600mm x 900mm
     1920x1080 60.00 +  50.0059.9430.0025.0024.0029.97  
  23.98
     1920x1080i60.0050.0059.94
     1280x1024 60.02
     1360x768  60.02
     1152x864  59.97
     1280x720  59.8160.0050.0059.94
     1024x768  60.00
     800x600   60.32*
     720x576   50.00
     720x576i  50.00
     720x480   60.0059.94
     640x480   60.0059.94
     720x400   70.08
  DP-1-2 disconnected (normal left inverted right x axis y axis)
  HDMI-1-3 disconnected (normal left inverted right x axis y axis)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/kernel-package/+bug/1871721/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1871721] Re: Second Monitor on HDMI blank screen with Nvidia & Ubuntu 20.04? (ASUS Laptop)

2020-06-04 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: xserver-xorg-video-intel (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1871721

Title:
  Second Monitor on HDMI blank screen with Nvidia & Ubuntu 20.04? (ASUS
  Laptop)

Status in kernel-package package in Ubuntu:
  Confirmed
Status in mesa package in Ubuntu:
  Confirmed
Status in mesa-utils package in Ubuntu:
  Confirmed
Status in nouveau-firmware package in Ubuntu:
  Confirmed
Status in nvidia-graphics-drivers-440 package in Ubuntu:
  Confirmed
Status in xserver-xorg-video-intel package in Ubuntu:
  Confirmed

Bug description:
  I installed Ubuntu 20.04 on my ASUS laptop with Intel+Nvidia with propietary 
drivers of Nvidia (I have 440.64 rn) and I connected a second monitor to use 
it, but I saw that I cannot use it, I just see a blank screen. I tried with a 
TV of my room and same. The funny part is when I start the laptop to work, I 
can see the logo of my BIOS and the ASUS logo in the second monitor, even the 
grub, but after that I can't see nothing.
  When I reduce the resolution of the second monitor (800x600) then works, but 
even with that sometimes blinks to black again.
  On W10 for example it works perfectly, so I deduce it's not 'cause my HDMI.

  I tried with noveau drivers and I have the same results btw.

  Laptop Asus with:
  Graphic card  Nvidia GTX960M
  Processor  Intel i5 6300

  I tried with Nvidia Prime to Nvidia, Intel and On-demand. None of them
  works. All of them with Xorg.

  I have this with xrandr:

  Screen 0: minimum 8 x 8, current 2720 x 1080, maximum 16384 x 16384
  eDP-1-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y 
axis) 344mm x 193mm
     1920x1080 60.00*+  59.9759.9659.93
     1680x1050 59.9559.88
     1600x1024 60.17
     1400x1050 59.98
     1600x900  59.9959.9459.9559.82
     1280x1024 60.02
     1440x900  59.89
     1400x900  59.9659.88
     1280x960  60.00
     1440x810  60.0059.97
     1368x768  59.8859.85
     1360x768  59.8059.96
     1280x800  59.9959.9759.8159.91
     1152x864  60.00
     1280x720  60.0059.9959.8659.74
     1024x768  60.0460.00
     960x720   60.00
     928x696   60.05
     896x672   60.01
     1024x576  59.9559.9659.9059.82
     960x600   59.9360.00
     960x540   59.9659.9959.6359.82
     800x600   60.0060.3256.25
     840x525   60.0159.88
     864x486   59.9259.57
     800x512   60.17
     700x525   59.98
     800x450   59.9559.82
     640x512   60.02
     720x450   59.89
     700x450   59.9659.88
     640x480   60.0059.94
     720x405   59.5158.99
     684x384   59.8859.85
     680x384   59.8059.96
     640x400   59.8859.98
     576x432   60.06
     640x360   59.8659.8359.8459.32
     512x384   60.00
     512x288   60.0059.92
     480x270   59.6359.82
     400x300   60.3256.34
     432x243   59.9259.57
     320x240   60.05
     360x202   59.5159.13
     320x180   59.8459.32
  DP-1-1 disconnected (normal left inverted right x axis y axis)
  HDMI-1-1 disconnected (normal left inverted right x axis y axis)
  HDMI-1-2 connected 800x600+1920+0 (normal left inverted right x axis y axis) 
1600mm x 900mm
     1920x1080 60.00 +  50.0059.9430.0025.0024.0029.97  
  23.98
     1920x1080i60.0050.0059.94
     1280x1024 60.02
     1360x768  60.02
     1152x864  59.97
     1280x720  59.8160.0050.0059.94
     1024x768  60.00
     800x600   60.32*
     720x576   50.00
     720x576i  50.00
     720x480   60.0059.94
     640x480   60.0059.94
     720x400   70.08
  DP-1-2 disconnected (normal left inverted right x axis y axis)
  HDMI-1-3 disconnected (normal left inverted right x axis y axis)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/kernel-package/+bug/1871721/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1880575] Re: Cuenta Online en Google

2020-06-04 Thread David Navas Ricoy
I have been using version of ubuntu 18.04.4 LTS for some years and I
didn't have any problem to sync calendar, email and tasks from my
university with the account in google dnav...@uoc.edu

I just neeeded to go to the options and setup de online account with
google and university.

When I changed to 20.04 LTS and attempted to set the same account up,
didn work and a window with the message in English that says... "Error
performing TLS handshake: The Diffie-Hellman prime sent by the server is
not acceptable (not long enough)"

Are you or someone else that can give to me some solution that I can
change in my computer something to make this account turn to be
connected?

It is very useful for me to have the calendar and tasks synchronized
with my desktop and evolution.

Many thanks.

PD: I could finish the module in University in a satisfactory way, but I
need to continue during the next six months.

Thanks in advance.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gnome-online-accounts in
Ubuntu.
https://bugs.launchpad.net/bugs/1880575

Title:
  Cuenta Online en Google

Status in gnome-online-accounts package in Ubuntu:
  Incomplete

Bug description:
  Hasta la versión 18.04.4 LTS podía conectar la cuenta online de la
  universidad (@uoc.edu) sin problemas y sincronizar calendarios y
  contactos con evolution, es una cuenta que se accede a ella via
  google.

  Cuando lo intento con esta versión de ubuntu 20.04 LTS me da un error
  justo después de ingresar la cuenta de correo.

  "Error performing TLS handshake: The Diffie-Hellman prime sent by the
  server is not acceptable (not long enough).

  Y no puedo continuar con el registro de la cuenta.

  Puedo hacer algo yo a nivel local para solucionar este problema? Me
  resulta muy útil poder sincronizar los calendarios de actividades con
  la universidad y los contactos con mi tutor y los profesores de cada
  asignatura.

  Muchas gracias de antemano.
  Un saludo, quedo a la espera de alguna solución.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-online-accounts/+bug/1880575/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1882042] Re: Linux, Ubuntu, 18.4, CI, OLP15, PRTS, Audio/video is out of sync/lag when enter Suspend during playback

2020-06-04 Thread Hui Wang
** Tags added: originate-from-1880952 somerville

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1882042

Title:
  Linux,Ubuntu,18.4,CI,OLP15,PRTS, Audio/video is out of sync/lag when
  enter Suspend during playback

Status in HWE Next:
  New
Status in pulseaudio package in Ubuntu:
  New
Status in pulseaudio source package in Bionic:
  New

Bug description:
  This bug is for tracking purpose.

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/1882042/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1876065] Re: After unplug headphones and plug them again no sound can be heard

2020-06-04 Thread Daniel van Vugt
You might just need to disable -ffast-math. It's unclear if this is an
old issue or a new one so please use this new bug
https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/issues/908

** Bug watch added: gitlab.freedesktop.org/pulseaudio/pulseaudio/-/issues #908
   https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/issues/908

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1876065

Title:
  After unplug headphones and plug them again no sound can be heard

Status in pulseaudio package in Ubuntu:
  Fix Committed
Status in pulseaudio source package in Focal:
  Fix Committed
Status in pulseaudio source package in Groovy:
  Fix Committed

Bug description:
  * Impact
  Sound isn't automatically redirected to headphones when those are connected 
to a jack interface

  * Test case
  Disconnect the headsets
  Start your webbrowser/music player/video player and play some sound
  Connect the headsets to the jack interface

  -> the sound should be directly redirected to the plugged headsets

  * Regression potential
  Check that audio routing when connecting/disconnecting devices to the hack 
entry is working correctly

  

  After startup with headset plugged in they play sound nicely - no
  issue. When they are unplugged, the sound is switched to the speaker
  (laptop) - all good. However, when I plug the headset back there is no
  sound. I see the app on pavucontrol, the volume is fine - everything
  looks fine except there is no sound. I dumped output of "pactl list"
  command on startup (headset plugged), after unplugging the headset,
  and when it is plugged back. From the comparison of these outputs, it
  looks like the source has got muted after the headset is plugged.

  Source #1
   State: RUNNING
   Name: alsa_input.pci-_00_1f.3.analog-stereo
   Description: Built-in Audio Analog Stereo
   Driver: module-alsa-card.c
   Sample Specification: s16le 2ch 44100Hz
   Channel Map: front-left,front-right
   Owner Module: 7
   Mute: yes

  Attached three outputs:
  headset-in.txt - after startup with headset plugged - all fine.
  headset-out.txt - after unplugged headset - sound through the speaker - all 
fine.
  headset-back.txt - after plugged headset back - no sound.

  Any help greatly appreciated.

  Regards,
  Roman

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1876065/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1882042] [NEW] Linux, Ubuntu, 18.4, CI, OLP15, PRTS, Audio/video is out of sync/lag when enter Suspend during playback

2020-06-04 Thread Hui Wang
Public bug reported:

This bug is for tracking purpose.

** Affects: pulseaudio (Ubuntu)
 Importance: High
 Assignee: Hui Wang (hui.wang)
 Status: New

** Affects: pulseaudio (Ubuntu Bionic)
 Importance: Undecided
 Status: New

** Changed in: pulseaudio (Ubuntu)
   Importance: Undecided => High

** Also affects: pulseaudio (Ubuntu Bionic)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1882042

Title:
  Linux,Ubuntu,18.4,CI,OLP15,PRTS, Audio/video is out of sync/lag when
  enter Suspend during playback

Status in pulseaudio package in Ubuntu:
  New
Status in pulseaudio source package in Bionic:
  New

Bug description:
  This bug is for tracking purpose.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1882042/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1870359] Re: My machine as Wi-Fi Hotspot broken after upgrade to 20.04

2020-06-04 Thread Launchpad Bug Tracker
This bug was fixed in the package network-manager - 1.22.10-1ubuntu2.1

---
network-manager (1.22.10-1ubuntu2.1) focal; urgency=medium

  * debian/rules:
- the iptables binary is in /usr/sbin now, use the correct location in
  the configure. Should fix the hotspot feature not working in GNOME
  on upgraded systems which haven't been usrmerged.
  (lp: #1870359)

 -- Sebastien Bacher   Wed, 20 May 2020 18:23:10
+0200

** Changed in: network-manager (Ubuntu Focal)
   Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1870359

Title:
  My machine as Wi-Fi Hotspot broken after upgrade to 20.04

Status in network-manager package in Ubuntu:
  Fix Committed
Status in network-manager source package in Focal:
  Fix Released

Bug description:
  * Impact
  The hotspot feature fails to forward the data to the clients

  * Test case
  - log into an Ubuntu or GNOME session
  - connect the machine to an eth cable for internet
  - go to gnome-control-center -> wifi
  - enable the hotspot from the menu in the headerbar
  - connect another device to the wifi created
  -> the client should connect and access to internet work correctly

  * Regression potential
  the change is only updating the iptables binary location, there shouldn't be 
any code impact out of having the command working on systems without usrmerge 
when it was not before

  -

  
  I have a machine with a wired network connection and a wifi card. I've been 
using the machine as a wireless router and server in my house. I've attached a 
screenshot of the Wi-Fi network settings. It looks as expected.

  Upon updating to 20.04, none of my machines can use the connection.
  The linux machine will not connect. The windows machine will connect
  but will not have internet.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: network-manager 1.22.10-1ubuntu1
  ProcVersionSignature: Ubuntu 5.4.0-21.25-generic 5.4.27
  Uname: Linux 5.4.0-21-generic x86_64
  NonfreeKernelModules: wl
  ApportVersion: 2.20.11-0ubuntu22
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Apr  2 15:47:02 2020
  IfupdownConfig:
   # interfaces(5) file used by ifup(8) and ifdown(8)
   auto lo
   iface lo inet loopback
  InstallationDate: Installed on 2015-09-30 (1645 days ago)
  InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
  IpRoute:
   default via 192.168.0.1 dev eth0 proto static metric 100
   169.254.0.0/16 dev eth0 scope link metric 1000
   192.168.0.0/24 dev eth0 proto kernel scope link src 192.168.0.100 metric 100
  SourcePackage: network-manager
  UpgradeStatus: Upgraded to focal on 2020-04-02 (0 days ago)
  WifiSyslog:

  mtime.conffile..etc.NetworkManager.NetworkManager.conf: 
2018-01-13T14:45:42.987041
  nmcli-nm:
   RUNNING  VERSION  STATE  STARTUP  CONNECTIVITY  NETWORKING  WIFI-HW  
WIFI WWAN-HW  WWAN
   running  1.22.10  connected  started  full  enabled enabled  
enabled  enabled  enabled

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1870359/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1870359] Update Released

2020-06-04 Thread Łukasz Zemczak
The verification of the Stable Release Update for network-manager has
completed successfully and the package is now being released to
-updates.  Subsequently, the Ubuntu Stable Release Updates Team is being
unsubscribed and will not receive messages about this bug report.  In
the event that you encounter a regression using the package from
-updates please report a new bug using ubuntu-bug and tag the bug report
regression-update so we can easily find any regressions.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1870359

Title:
  My machine as Wi-Fi Hotspot broken after upgrade to 20.04

Status in network-manager package in Ubuntu:
  Fix Committed
Status in network-manager source package in Focal:
  Fix Released

Bug description:
  * Impact
  The hotspot feature fails to forward the data to the clients

  * Test case
  - log into an Ubuntu or GNOME session
  - connect the machine to an eth cable for internet
  - go to gnome-control-center -> wifi
  - enable the hotspot from the menu in the headerbar
  - connect another device to the wifi created
  -> the client should connect and access to internet work correctly

  * Regression potential
  the change is only updating the iptables binary location, there shouldn't be 
any code impact out of having the command working on systems without usrmerge 
when it was not before

  -

  
  I have a machine with a wired network connection and a wifi card. I've been 
using the machine as a wireless router and server in my house. I've attached a 
screenshot of the Wi-Fi network settings. It looks as expected.

  Upon updating to 20.04, none of my machines can use the connection.
  The linux machine will not connect. The windows machine will connect
  but will not have internet.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: network-manager 1.22.10-1ubuntu1
  ProcVersionSignature: Ubuntu 5.4.0-21.25-generic 5.4.27
  Uname: Linux 5.4.0-21-generic x86_64
  NonfreeKernelModules: wl
  ApportVersion: 2.20.11-0ubuntu22
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Apr  2 15:47:02 2020
  IfupdownConfig:
   # interfaces(5) file used by ifup(8) and ifdown(8)
   auto lo
   iface lo inet loopback
  InstallationDate: Installed on 2015-09-30 (1645 days ago)
  InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
  IpRoute:
   default via 192.168.0.1 dev eth0 proto static metric 100
   169.254.0.0/16 dev eth0 scope link metric 1000
   192.168.0.0/24 dev eth0 proto kernel scope link src 192.168.0.100 metric 100
  SourcePackage: network-manager
  UpgradeStatus: Upgraded to focal on 2020-04-02 (0 days ago)
  WifiSyslog:

  mtime.conffile..etc.NetworkManager.NetworkManager.conf: 
2018-01-13T14:45:42.987041
  nmcli-nm:
   RUNNING  VERSION  STATE  STARTUP  CONNECTIVITY  NETWORKING  WIFI-HW  
WIFI WWAN-HW  WWAN
   running  1.22.10  connected  started  full  enabled enabled  
enabled  enabled  enabled

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1870359/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1880968] Re: fixrtc fails due to bad format of input to the date command

2020-06-04 Thread Alfonso Sanchez-Beato
** Description changed:

  The fixrtc script is failing with message:
  
  date: invalid date '  Wed Apr  1 17:23:44 2020'
  
  when calling the date command. It looks like it does not like the
  leading spaces for the input date. The date is taken from 'dumpe2fs -h'
  ouptput, and some clean-up on it happens, but it looks like it is not
  enough for BusyBox' date command, at least for the version in focal.
+ 
+ [Impact]
+ 
+ The system date shown on first boot is incorrect, which can be
+ problematic on first boot if at that point in time there is no network
+ connection. If fixrtc works correctly at least we get the date of the
+ last time the rootfs was mounted, which is modern enough to avoid
+ problems with snap assertions validation, etc.
+ 
+ [Test case]
+ 
+ Boot an image with fixrtc in the kernel command line in a system with no
+ network. snap seeding will fail without the patch.
+ 
+ [Regression Potential]
+ 
+ Quite small, as the fix is small and targeted.

** Description changed:

  The fixrtc script is failing with message:
  
  date: invalid date '  Wed Apr  1 17:23:44 2020'
  
  when calling the date command. It looks like it does not like the
  leading spaces for the input date. The date is taken from 'dumpe2fs -h'
  ouptput, and some clean-up on it happens, but it looks like it is not
  enough for BusyBox' date command, at least for the version in focal.
+ 
+ Backporting this to focal is needed.
  
  [Impact]
  
  The system date shown on first boot is incorrect, which can be
  problematic on first boot if at that point in time there is no network
  connection. If fixrtc works correctly at least we get the date of the
  last time the rootfs was mounted, which is modern enough to avoid
  problems with snap assertions validation, etc.
  
  [Test case]
  
  Boot an image with fixrtc in the kernel command line in a system with no
  network. snap seeding will fail without the patch.
  
  [Regression Potential]
  
  Quite small, as the fix is small and targeted.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1880968

Title:
  fixrtc fails due to bad format of input to the date command

Status in initramfs-tools package in Ubuntu:
  New

Bug description:
  The fixrtc script is failing with message:

  date: invalid date '  Wed Apr  1 17:23:44 2020'

  when calling the date command. It looks like it does not like the
  leading spaces for the input date. The date is taken from 'dumpe2fs
  -h' ouptput, and some clean-up on it happens, but it looks like it is
  not enough for BusyBox' date command, at least for the version in
  focal.

  Backporting this to focal is needed.

  [Impact]

  The system date shown on first boot is incorrect, which can be
  problematic on first boot if at that point in time there is no network
  connection. If fixrtc works correctly at least we get the date of the
  last time the rootfs was mounted, which is modern enough to avoid
  problems with snap assertions validation, etc.

  [Test case]

  Boot an image with fixrtc in the kernel command line in a system with
  no network. snap seeding will fail without the patch.

  [Regression Potential]

  Quite small, as the fix is small and targeted.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1880968/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp