[Touch-packages] [Bug 1876055] Re: SRU: Backport 2.4.3-1ubuntu3 from groovy to focal/eoan/bionic/xenial for newer syscalls for core20 base and test suite robustness

2020-06-22 Thread Alex Murray
The systemd update for eoan is not in -proposed but the libseccomp
updates (for all releases) are - the systemd update for eoan needs to be
released in conjunction with the libseccomp update as it fixes a
regression in systemd/eoan/i386 when used in conjunction with the
libseccomp updates.

The systemd/eoan update is on only in the security-proposed PPA as I
don't have upload rights and so needs to be sponsored.

I believe the packages are ready to be released - all autopkgtests are
passing now for all releases of libseccomp - except systemd/eoan/i386
(hence the additional update for it).

The autopkgtests from the security-proposed PPA for systemd
https://people.canonical.com/~platform/security-
britney/current/security_eoan_excuses.html#systemd look pretty good.

openssh is failing - but this version 1:8.0p1-6build1 is failing already
- see http://autopkgtest.ubuntu.com/packages/o/openssh/eoan/amd64 for
instance where this version also failed in the same manner recently a
number of times.

pds, prometheus and stunnel4 are also failing but again these same
versions are already failing for the regular autopkgtests -
http://autopkgtest.ubuntu.com/packages/p/pdns/eoan/amd64
http://autopkgtest.ubuntu.com/packages/p/prometheus/eoan/amd64
http://autopkgtest.ubuntu.com/packages/s/stunnel4/eoan/amd64

snapd is failing for i386 but again is already failing for the same
version at http://autopkgtest.ubuntu.com/packages/s/snapd/eoan/i386

And similarly ubuntu-drivers-common is also failing for i386 but is
already failing for this same version -
http://autopkgtest.ubuntu.com/packages/u/ubuntu-drivers-common/eoan/i386

So I am confident this is ready to be released.

First, systemd 242-7ubuntu3.11  needs to be sponsored from the ubuntu-
security-proposed PPA to -proposed and then we can look at promoting all
the libseccomp updates and this systemd update for eoan to -updates (and
the security team can publish to -security and issue a USN once all are
in -updates).

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1876055

Title:
  SRU: Backport 2.4.3-1ubuntu3 from groovy to focal/eoan/bionic/xenial
  for newer syscalls for core20 base and test suite robustness

Status in libseccomp package in Ubuntu:
  Fix Released
Status in systemd package in Ubuntu:
  New
Status in libseccomp source package in Xenial:
  Fix Committed
Status in libseccomp source package in Bionic:
  Fix Committed
Status in libseccomp source package in Eoan:
  Fix Committed
Status in systemd source package in Eoan:
  New
Status in libseccomp source package in Focal:
  Fix Committed
Status in libseccomp source package in Groovy:
  Fix Released

Bug description:
  [Impact]

  The combination of snap-confine and snap-seccomp from snapd uses
  libseccomp to filter various system calls for confinement. The current
  version in eoan/bionic/xenial (2.4.1) is missing knowledge of various
  system calls for various architectures. As such this causes strange
  issues like python snaps segfaulting
  (https://github.com/snapcore/core20/issues/48) or the inadvertent
  denial of system calls which should be permitted by the base policy
  (https://forum.snapcraft.io/t/getrlimit-blocked-by-seccomp-on-focal-
  arm64/17237).

  libseccomp in groovy is using the latest upstream base release (2.4.3)
  plus it includes a patch to add some missing aarch64 system calls
  (https://bugs.launchpad.net/ubuntu/+source/libseccomp/+bug/1877633).

  SRUing this version back to older stable releases allows libseccomp to
  operate correctly on all supported architectures.

  
  Included as part of this SRU are test-suite reliability improvements - 
currently the xenial libseccomp package overrides test-suite failures at build 
time to ignore failures. This masks the fact that on ppc64el and s390x there 
are currently test suite failures at build time for xenial - these failures 
occur since libseccomp now includes knowledge of system calls for these 
architectures but which the linux-libc-dev package for xenial does not actually 
define (since this is based of the 4.4 kernel in xenial whereas libseccomp 
2.4.1 in xenial has knowledge of all system calls up to 5.4). 

  In this SRU I have instead fixed the test suite failures for xenial by
  including a local (test-suite specific) set of architecture specific
  kernel headers from the linux-libc-dev in focal for all releases.
  These are just the headers which define the system call numbers for
  each architecture *and* these are added to tests/include/$ARCH in the
  source package (and tests/Makefile.am is then updated to include these
  new headers only).  As such this ensures the actual build of
  libseccomp or any of the tools does not reference these headers. This
  allows the test suite in libseccomp to then be aware of theses system
  calls and so all unit tests for all architectures now pass.

  In any 

[Touch-packages] [Bug 1884595] Re: Bugged 3D display of multimaterial meshes after last Radeon driver update

2020-06-22 Thread Daniel van Vugt
** Package changed: xorg (Ubuntu) => xserver-xorg-video-ati (Ubuntu)

** Package changed: xserver-xorg-video-ati (Ubuntu) => xserver-xorg-
video-ati-hwe-18.04 (Ubuntu)

** Tags added: regression-update

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1884595

Title:
  Bugged 3D display of multimaterial meshes after last Radeon driver
  update

Status in xserver-xorg-video-ati-hwe-18.04 package in Ubuntu:
  New

Bug description:
  After the last driver update for my Radeon HD 7750 Im having viewport
  problems in Blender when displaying meshes with multiple materials
  (see attached screenshot).

  This happens both with both the latest version of Blender snap and the direct 
download from Blender.org
  I also have an older version installed and is having the same problem.

  It all worked fine before the driver update.

  Just in case these are the last lines from running  grep "upgrade " 
/var/log/dpkg.log
  :

  2020-06-20 00:48:38 upgrade xserver-xorg-legacy-hwe-18.04:amd64 
2:1.20.5+git20191008-0ubuntu1~18.04.1 2:1.20.8-2ubuntu2.1~18.04.1
  2020-06-20 00:48:39 upgrade xserver-xorg-core-hwe-18.04:amd64 
2:1.20.5+git20191008-0ubuntu1~18.04.1 2:1.20.8-2ubuntu2.1~18.04.1
  2020-06-20 00:48:40 upgrade xserver-xorg-video-amdgpu-hwe-18.04:amd64 
19.0.1-1ubuntu1~18.04.1 19.1.0-1~18.04.1
  2020-06-20 00:48:40 upgrade xserver-xorg-video-radeon-hwe-18.04:amd64 
1:19.0.1-1ubuntu1~18.04.1 1:19.1.0-1~18.04.1
  2020-06-20 00:48:41 upgrade xserver-xorg-video-ati-hwe-18.04:amd64 
1:19.0.1-1ubuntu1~18.04.1 1:19.1.0-1~18.04.1

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: xorg 1:7.7+19ubuntu7.1
  ProcVersionSignature: Ubuntu 5.3.0-59.53~18.04.1-generic 5.3.18
  Uname: Linux 5.3.0-59-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.15
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: Budgie:GNOME
  Date: Mon Jun 22 16:31:31 2020
  DistUpgraded: Fresh install
  DistroCodename: bionic
  DistroVariant: ubuntu
  DkmsStatus:
   openrazer-driver, 2.8.0, 5.3.0-53-generic, x86_64: installed
   openrazer-driver, 2.8.0, 5.3.0-59-generic, x86_64: installed
  ExtraDebuggingInterest: Yes, if not too technical
  GraphicsCard:
   Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde PRO [Radeon HD 7750/8740 / 
R7 250E] [1002:683f] (prog-if 00 [VGA controller])
 Subsystem: ASUSTeK Computer Inc. Cape Verde PRO [Radeon HD 7750/8740 / R7 
250E] [1043:0427]
  InstallationDate: Installed on 2019-08-03 (324 days ago)
  InstallationMedia: Ubuntu-Budgie 18.04.2 LTS "Bionic Beaver" - Release amd64 
(20190210)
  MachineType: System manufacturer System Product Name
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-59-generic 
root=UUID=bf94f108-3b15-444b-a40a-414115dcfedd ro quiet splash vt.handoff=1
  SourcePackage: xorg
  Symptom: display
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 02/25/2014
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 1107
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: P8H61-M LX3 R2.0
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: Rev X.0x
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr1107:bd02/25/2014:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnP8H61-MLX3R2.0:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.family: To be filled by O.E.M.
  dmi.product.name: System Product Name
  dmi.product.sku: SKU
  dmi.product.version: System Version
  dmi.sys.vendor: System manufacturer
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2~18.04.1
  version.libgl1-mesa-dri: libgl1-mesa-dri 19.2.8-0ubuntu0~18.04.3
  version.libgl1-mesa-glx: libgl1-mesa-glx 19.2.8-0ubuntu0~18.04.3
  version.xserver-xorg-core: xserver-xorg-core N/A
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
  version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati-hwe-18.04/+bug/1884595/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884455] Re: pulseaudio creates /root/.config/pulse/ before zfs-mount.service can mount the /root dataset

2020-06-22 Thread Daniel van Vugt
OK, if not the PulseAudio daemon then maybe a PulseAudio client did it.
That might happen if you log in graphically as root. Or it might be
something more obscure you have running as root.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1884455

Title:
  pulseaudio creates /root/.config/pulse/ before zfs-mount.service can
  mount the /root dataset

Status in pulseaudio package in Ubuntu:
  Incomplete

Bug description:
  I use 'zfs' and have /root as its own dataset which is mounted during
  startup by 'zfs-mount.service'.

  At one of the latest upgrades, the 'zfsutils-linux' package failed to
  update because the service 'zfs-mount' service had an issue and could
  not mount the '/root' dataset because the '/root' directory was not
  empty (temporary solution was to rename /root and call 'zfs mount'
  again).

  Further investigation shows that everytime at startup, the /root
  directory is created before the 'zfs-mount.service' has a chance to
  mount the 'root' dataset.

  The culprit seems to be something pulseaudio related: the content of /root 
folder after startup is as follows:
  -
  root@minighost:~# tree -a /root
  .
  ├── .cache
  └── .config
  └── pulse
  └── fe1417537ae0451abdb60c5df28fe825-runtime -> 
/tmp/pulse-PKdhtXMmr18n

  4 directories, 0 files
  root@minighost:~#
  -  


  Extra details:

  - Ubuntu release:
  -
  root@minighost:~# lsb_release -rd
  Description:  Ubuntu 20.04 LTS
  Release:  20.04
  -

  
  - status of 'zfs-mount.service' is the following:
  -  
  root@minighost:~# systemctl status zfs-mount
  ● zfs-mount.service - Mount ZFS filesystems
   Loaded: loaded (/lib/systemd/system/zfs-mount.service; enabled; vendor 
preset: enabled)
   Active: failed (Result: exit-code) since Sun 2020-06-21 12:56:08 CEST; 
6h ago
 Docs: man:zfs(8)
  Process: 2062 ExecStart=/sbin/zfs mount -a (code=exited, status=1/FAILURE)
 Main PID: 2062 (code=exited, status=1/FAILURE)

  Jun 21 12:56:08 minighost systemd[1]: Starting Mount ZFS filesystems...
  Jun 21 12:56:08 minighost zfs[2062]: cannot mount '/root': directory is not 
empty
  Jun 21 12:56:08 minighost systemd[1]: zfs-mount.service: Main process exited, 
code=exited, status=1/FAILURE
  Jun 21 12:56:08 minighost systemd[1]: zfs-mount.service: Failed with result 
'exit-code'.
  Jun 21 12:56:08 minighost systemd[1]: Failed to start Mount ZFS filesystems.
  root@minighost:~#
  -  


  - software versions:
  -
  root@minighost:~# apt-cache policy pulseaudio
  pulseaudio:
Installed: 1:13.99.1-1ubuntu3.3
Candidate: 1:13.99.1-1ubuntu3.3
Version table:
   *** 1:13.99.1-1ubuntu3.3 500
  500 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages
  100 /var/lib/dpkg/status
   1:13.99.1-1ubuntu3.2 500
  500 http://security.ubuntu.com/ubuntu focal-security/main amd64 
Packages
   1:13.99.1-1ubuntu3 500
  500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages

  root@minighost:~# apt-cache policy zfsutils-linux
  zfsutils-linux:
Installed: 0.8.3-1ubuntu12.1
Candidate: 0.8.3-1ubuntu12.1
Version table:
   *** 0.8.3-1ubuntu12.1 500
  500 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages
  100 /var/lib/dpkg/status
   0.8.3-1ubuntu12 500
  500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages
  -

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: pulseaudio 1:13.99.1-1ubuntu3.3
  ProcVersionSignature: Ubuntu 5.4.0-37.41-generic 5.4.41
  Uname: Linux 5.4.0-37-generic x86_64
  NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
  ApportVersion: 2.20.11-0ubuntu27.3
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  dumi   2419 F pulseaudio
  CasperMD5CheckResult: skip
  Date: Sun Jun 21 19:17:20 2020
  InstallationDate: Installed on 2018-09-08 (651 days ago)
  InstallationMedia: Ubuntu 18.04 "Bionic" - Build amd64 LIVE Binary 
20180608-09:38
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
  SourcePackage: pulseaudio
  UpgradeStatus: Upgraded to focal on 2020-04-24 (57 days ago)
  dmi.bios.date: 12/11/2019
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.12.1
  dmi.board.name: 0F6P3V
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 10
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvr1.12.1:bd12/11/2019:svnDellInc.:pnXPS139370:pvr:rvnDellInc.:rn0F6P3V:rvrA00:cvnDellInc.:ct10:cvr:
  dmi.product.family: XPS
  dmi.product.name: XPS 13 9370
  dmi.product.sku: 07E6
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go 

[Touch-packages] [Bug 1884547] Re: can't activate the bluethooth headsed with a2dp sound

2020-06-22 Thread Daniel van Vugt
Please explain what model of headset it is, and the steps you are taking
that are not working.

** Changed in: bluez (Ubuntu)
   Status: New => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to bluez in Ubuntu.
https://bugs.launchpad.net/bugs/1884547

Title:
  can't activate the bluethooth headsed with a2dp sound

Status in bluez package in Ubuntu:
  Incomplete

Bug description:
  I follow this bug, and still happend

  https://bugs.launchpad.net/ubuntu/+source/bluez/+filebug/e91ee546
  -b48f-11ea-a86b-68b5996a96c8

  
  dpkg --status bluez | grep '^Version:'
  Version: 5.53-0ubuntu3

  cat /etc/*-release
  DISTRIB_ID=Ubuntu
  DISTRIB_RELEASE=20.04
  DISTRIB_CODENAME=focal
  DISTRIB_DESCRIPTION="Ubuntu 20.04 LTS"
  NAME="Ubuntu"
  VERSION="20.04 LTS (Focal Fossa)"
  ID=ubuntu
  ID_LIKE=debian
  PRETTY_NAME="Ubuntu 20.04 LTS"
  VERSION_ID="20.04"
  HOME_URL="https://www.ubuntu.com/;
  SUPPORT_URL="https://help.ubuntu.com/;
  BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/;
  
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy;
  VERSION_CODENAME=focal
  UBUNTU_CODENAME=focal

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: bluez 5.53-0ubuntu3
  ProcVersionSignature: Ubuntu 5.4.0-37.41-generic 5.4.41
  Uname: Linux 5.4.0-37-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.3
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Mon Jun 22 10:54:05 2020
  InstallationDate: Installed on 2020-05-19 (33 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  InterestingModules: rfcomm bnep btusb bluetooth
  MachineType: LENOVO 20NYS04V00
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-5.4.0-37-generic 
root=/dev/mapper/vgubuntu-root ro quiet splash vt.handoff=7
  SourcePackage: bluez
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 03/27/2020
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N2JET87W (1.65 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20NYS04V00
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0J40697 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN2JET87W(1.65):bd03/27/2020:svnLENOVO:pn20NYS04V00:pvrThinkPadT490s:rvnLENOVO:rn20NYS04V00:rvrSDK0J40697WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad T490s
  dmi.product.name: 20NYS04V00
  dmi.product.sku: LENOVO_MT_20NY_BU_Think_FM_ThinkPad T490s
  dmi.product.version: ThinkPad T490s
  dmi.sys.vendor: LENOVO
  hciconfig:
   hci0:Type: Primary  Bus: USB
BD Address: 04:ED:33:30:BC:12  ACL MTU: 1021:4  SCO MTU: 96:6
UP RUNNING 
RX bytes:2532201 acl:38232 sco:36899 events:9437 errors:0
TX bytes:4236888 acl:2223 sco:36783 commands:6938 errors:0
  mtime.conffile..etc.bluetooth.input.conf: 2020-06-10T09:52:46.145873
  mtime.conffile..etc.bluetooth.main.conf: 2020-06-04T16:03:04.084396

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1884547/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1551623] Re: [SRU] package gconf2 3.2.6-3ubuntu6 failed to install/upgrade: dependency problems - leaving triggers unprocessed

2020-06-22 Thread Mathew Hodson
** Changed in: gconf (Ubuntu)
   Importance: Critical => Medium

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gconf in Ubuntu.
https://bugs.launchpad.net/bugs/1551623

Title:
  [SRU] package gconf2 3.2.6-3ubuntu6 failed to install/upgrade:
  dependency problems - leaving triggers unprocessed

Status in gconf package in Ubuntu:
  Triaged

Bug description:
  [Impact]

  During system upgrades, triggers for gconf2 might activate too early,
  while some of its dependencies aren't configured yet. This happens
  several times in a loop and stops the upgrade in the end.

  The attached debdiffs fix this issue by changing interest to interest-
  noawait in debian/gconf2.triggers file. The triggers will now activate
  near the end of upgrade.

  In addition, the debdiff for Bionic also contains a fix for FTBFS (bug
  1834211).

  [Test Case]

  Triggers for gconf2 are usually activated on changes in
  /usr/share/GConf/gsettings folder, so the main Ubuntu edition (with
  GNOME) is most suitable for reproducing the issue. To reproduce it,
  install that edition, apply all updates, then try upgrading to the
  next release.

  [Regression Potential]

  None, interest-noawait trigger is known to work well in other packages
  (comment 31).

  [Other Info]

  Even if Cosmic goes EOL next month, the fix for it might be worth it
  for release upgrades.

  [Original Description]

  When upgrading from 15.10 to 16.04Beta (2016-03-01), this error occured, 
alongside many others related to systemd and gnome.
  Notice that despite all warnings and errors, finally, the system remained 
functional.

  ProblemType: Package
  DistroRelease: Ubuntu 16.04
  Package: gconf2 3.2.6-3ubuntu6
  ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2
  Uname: Linux 4.4.0-8-generic x86_64
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  Date: Tue Mar  1 09:21:15 2016
  ErrorMessage: dependency problems - leaving triggers unprocessed
  InstallationDate: Installed on 2015-10-04 (148 days ago)
  InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20151002)
  RelatedPackageVersions:
   dpkg 1.18.4ubuntu1
   apt  1.2.3
  SourcePackage: gconf
  Title: package gconf2 3.2.6-3ubuntu6 failed to install/upgrade: dependency 
problems - leaving triggers unprocessed
  UpgradeStatus: Upgraded to xenial on 2016-03-01 (0 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gconf/+bug/1551623/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1880968] Re: fixrtc fails due to bad format of input to the date command

2020-06-22 Thread Mathew Hodson
** Changed in: initramfs-tools (Ubuntu Focal)
   Importance: Undecided => Medium

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1880968

Title:
  fixrtc fails due to bad format of input to the date command

Status in initramfs-tools package in Ubuntu:
  Fix Released
Status in initramfs-tools source package in Focal:
  Fix Committed

Bug description:
  The fixrtc script is failing with message:

  date: invalid date '  Wed Apr  1 17:23:44 2020'

  when calling the date command. It looks like it does not like the
  leading spaces for the input date. The date is taken from 'dumpe2fs
  -h' ouptput, and some clean-up on it happens, but it looks like it is
  not enough for BusyBox' date command, at least for the version in
  focal.

  Backporting this to focal is needed.

  [Impact]

  The system date shown on first boot is incorrect, which can be
  problematic on first boot if at that point in time there is no network
  connection. If fixrtc works correctly at least we get the date of the
  last time the rootfs was mounted, which is modern enough to avoid
  problems with snap assertions validation, etc.

  [Test case]

  Boot an image with fixrtc in the kernel command line in a system with
  no network. snap seeding will fail without the patch.

  [Regression Potential]

  Quite small, as the fix is small and targeted.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1880968/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1883027] Re: dump_acpi_tables.py: fix incorrect output and change format

2020-06-22 Thread Mathew Hodson
** Changed in: apport (Ubuntu Focal)
   Importance: Undecided => Medium

** Changed in: apport (Ubuntu Groovy)
   Importance: Undecided => Medium

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apport in Ubuntu.
https://bugs.launchpad.net/bugs/1883027

Title:
  dump_acpi_tables.py: fix incorrect output and change format

Status in Apport:
  Confirmed
Status in apport package in Ubuntu:
  Confirmed
Status in apport source package in Focal:
  Confirmed
Status in apport source package in Groovy:
  Confirmed

Bug description:
  dump_acpi_tables.py generates log files that is similar as the output
  from "acpidump" in acpica-tools. The output can be passed to other
  utilities in acpica-tools and fwts.

  It, however, has some subtle differences and some errors.

  Summary:

  1. ACPI tables have 4-char signatures - meaning SSDT's are SSDT, not
  SSDT1, SSDT2 and so on. Each table is unique by its table ID.

  Original:
    SSDT1, SSDT2, SSDT3 ...

  Changed:
    SSDT, SSDT, SSDT ...

  2. (Minor) acpidump outputs are all in upper cases

  3. (Minor) acpidump offset are aligned by data, not address

  Original:
    FFF0: 53 41 56 43 52 44 43 41 4E 43 52 4E 72 4E 50 4D  SAVCRDCANCRNrNPM
    1: 56 0A 04 00 0C FC FF FF FF 0A 03 0A 03 52 44 43  VRDC

  Changed:
  FFF0: 53 41 56 43 52 44 43 41 4E 43 52 4E 72 4E 50 4D  SAVCRDCANCRNrNPM
     1: 56 0A 04 00 0C FC FF FF FF 0A 03 0A 03 52 44 43  VRDC

  4. (Bug) dump_acpi_tables.py generates an extra line when data sizes
  are multiple of 16 bytes

  Original:
  05F0: 30 30 0B 00 08 00 A4 48 50 53 44 A4 53 50 53 44  00.HPSD.SPSD
  05F0: 30 30 0B 00 08 00 A4 48 50 53 44 A4 53 50 53 44 
 00.HPSD.SPSD

  Corrected:
  05F0: 30 30 0B 00 08 00 A4 48 50 53 44 A4 53 50 53 44  00.HPSD.SPSD

  5. (Bug) dump_acpi_tables.py misses an line when data sizes are
  multiple of 15 bytes

  Original:
  07E0: 42 0A 87 5C 2F 03 5F 53 42 5F 55 42 54 43 43 43  B..\/._SB_UBTCCC

  Corrected:
  07E0: 42 0A 87 5C 2F 03 5F 53 42 5F 55 42 54 43 43 43  B..\/._SB_UBTCCC
  07F0: 49 33 86 5C 2E 5F 53 42 5F 55 42 54 43 0A 80 I3.\._SB_UBTC..

To manage notifications about this bug go to:
https://bugs.launchpad.net/apport/+bug/1883027/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884682] Re: gtk_range_expose can set height/width < -1 when trough-under-steppers is enabled

2020-06-22 Thread Ceriand
** Also affects: light-themes
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gtk+2.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1884682

Title:
  gtk_range_expose can set height/width < -1 when trough-under-steppers
  is enabled

Status in light-themes:
  New
Status in gtk+2.0 package in Ubuntu:
  New

Bug description:
  The root cause of https://github.com/mate-desktop/mate-themes/issues/57 and 
https://bugs.launchpad.net/ubuntu/+source/emacs23/+bug/538541 
(murrine_style_draw_box: assertion `height >= -1' failed) is gtk_range_expose 
not clamping height and width to a sane value if trough-under-steppers is 
enabled, the window is very small (like in init), and the theme has non-zero 
offsets.
  The attached patch should solve the problem (based on 2.24.32-1ubuntu1).

To manage notifications about this bug go to:
https://bugs.launchpad.net/light-themes/+bug/1884682/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884682] Re: gtk_range_expose can set height/width < -1 when trough-under-steppers is enabled

2020-06-22 Thread Ubuntu Foundations Team Bug Bot
The attachment "Clamp height and width to at least -1" seems to be a
patch.  If it isn't, please remove the "patch" flag from the attachment,
remove the "patch" tag, and if you are a member of the ~ubuntu-
reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by
~brian-murray, for any issues please contact him.]

** Tags added: patch

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gtk+2.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1884682

Title:
  gtk_range_expose can set height/width < -1 when trough-under-steppers
  is enabled

Status in gtk+2.0 package in Ubuntu:
  New

Bug description:
  The root cause of https://github.com/mate-desktop/mate-themes/issues/57 and 
https://bugs.launchpad.net/ubuntu/+source/emacs23/+bug/538541 
(murrine_style_draw_box: assertion `height >= -1' failed) is gtk_range_expose 
not clamping height and width to a sane value if trough-under-steppers is 
enabled, the window is very small (like in init), and the theme has non-zero 
offsets.
  The attached patch should solve the problem (based on 2.24.32-1ubuntu1).

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gtk+2.0/+bug/1884682/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1866194] Re: External audio device shows up in the sound output options but the sound keeps being emitted from the internal laptop speaker, or none at all.

2020-06-22 Thread Mathew Hodson
** Bug watch removed: gitlab.freedesktop.org/pulseaudio/pulseaudio/-/issues #832
   https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/issues/832

** Bug watch removed: gitlab.gnome.org/GNOME/gnome-control-center/-/issues #898
   https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/898

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1866194

Title:
  External audio device shows up in the sound output options but the
  sound keeps being emitted from the internal laptop speaker, or none at
  all.

Status in PulseAudio:
  Fix Released
Status in pulseaudio package in Ubuntu:
  Fix Released
Status in pulseaudio source package in Focal:
  In Progress
Status in pulseaudio source package in Groovy:
  Fix Released

Bug description:
  Ubuntu version: focal dev
  Kernel version: 5.4.0-14-generic #17-Ubuntu SMP Thu Feb 6 22:47:59 UTC 2020
  Pulseaudio: 1:13.99.1-1ubuntu1
  Device CID: 201704-25503

  Steps to reproduce:

  1. Connect an audio interface. I tried with BT headphones and speakers as 
well as a USB microphone/output.
  2. Make sure it's the one selected as "Output device"
  3. Click "Test"
  -> the test sound outputs from the internal laptop speakers (NOK)
  4. Select "Speakers - Built-in Audio" as Output device and click "Test"
  -> the test sound outputs from the internal laptop speakers (OK)
  5. Try to switch back to the BT device and click Test
  -> same result as in step 3

  Tested with 2 different BT devices (one headset and one speaker) as
  well as a USB audio interface (Zoom H2N microphone).

  Attached are btmon logs captured during the procedure described above,
  and pactl logs capture after step 7.

  I was previously using 19.04 and 19.10 on this device and never
  experienced this kind of issue.

  Up to this morning, it was harder to connect the BT device, but once
  connected, the sound would output on it as expected. Now, the BT
  connection seems to work better, but I can't output the sound to the
  BT device...

  I tried to reboot the device, and also to suspend/resume, but in each
  case, the BT device can connect back, but the sound is still output
  from the internal laptop speakers, even when the BT device is selected
  in the Sound settings.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: pulseaudio 1:13.99.1-1ubuntu1
  ProcVersionSignature: Ubuntu 5.4.0-14.17-generic 5.4.18
  Uname: Linux 5.4.0-14-generic x86_64
  ApportVersion: 2.20.11-0ubuntu18
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  pieq   1566 F pulseaudio
   /dev/snd/pcmC0D0c:   pieq   1566 F...m pulseaudio
   /dev/snd/pcmC0D0p:   pieq   1566 F...m pulseaudio
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Mar  5 22:15:50 2020
  InstallationDate: Installed on 2020-01-17 (48 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200116)
  SourcePackage: pulseaudio
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 04/23/2019
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.14.0
  dmi.board.vendor: Dell Inc.
  dmi.chassis.type: 10
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvr1.14.0:bd04/23/2019:svnDellInc.:pnInspiron7370:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct10:cvr:
  dmi.product.family: Inspiron
  dmi.product.name: Inspiron 7370
  dmi.product.sku: 07E9
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/pulseaudio/+bug/1866194/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884682] [NEW] gtk_range_expose can set height/width < -1 when trough-under-steppers is enabled

2020-06-22 Thread Ceriand
Public bug reported:

The root cause of https://github.com/mate-desktop/mate-themes/issues/57 and 
https://bugs.launchpad.net/ubuntu/+source/emacs23/+bug/538541 
(murrine_style_draw_box: assertion `height >= -1' failed) is gtk_range_expose 
not clamping height and width to a sane value if trough-under-steppers is 
enabled, the window is very small (like in init), and the theme has non-zero 
offsets.
The attached patch should solve the problem (based on 2.24.32-1ubuntu1).

** Affects: gtk+2.0 (Ubuntu)
 Importance: Undecided
 Status: New

** Patch added: "Clamp height and width to at least -1"
   
https://bugs.launchpad.net/bugs/1884682/+attachment/5386254/+files/range-clamp.patch

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gtk+2.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1884682

Title:
  gtk_range_expose can set height/width < -1 when trough-under-steppers
  is enabled

Status in gtk+2.0 package in Ubuntu:
  New

Bug description:
  The root cause of https://github.com/mate-desktop/mate-themes/issues/57 and 
https://bugs.launchpad.net/ubuntu/+source/emacs23/+bug/538541 
(murrine_style_draw_box: assertion `height >= -1' failed) is gtk_range_expose 
not clamping height and width to a sane value if trough-under-steppers is 
enabled, the window is very small (like in init), and the theme has non-zero 
offsets.
  The attached patch should solve the problem (based on 2.24.32-1ubuntu1).

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gtk+2.0/+bug/1884682/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884665] [NEW] lightdm not starting after fresh install

2020-06-22 Thread magicsux
Public bug reported:

Full Bash History after fresh Ubuntu 18 install:
$ sudo apt install tasksel
$ sudo tasksel install ubuntu-mate-core
$ sudo service lightdm start

facing the problem that lightdm isn't starting at all.

Things I've tried:
* sudo dpkg-reconfigure lightdm
- no changes
* journalctl -u lightdm.service
- outputting:
systemd[1]: lightdm.service: Main process exited, code=exited, status=1/FAILURE
systemd[1]: lightdm.service: Failed with result 'exit-code'.
systemd[1]: lightdm.service: Service hold-off time over, scheduling restart.
systemd[1]: lightdm.service: Scheduled restart job, restart counter is at 1.
systemd[1]: Stopped Light Display Manager.
systemd[1]: Starting Light Display Manager...
lightdm[24112]: Seat type 'xlocal' is deprecated, use 'type=local' instead
systemd[1]: Started Light Display Manager.
lightdm[24112]: Error: can't open /lib/modules/4.19.56-x86_64-jb1/updates/dkms
* sudo apt --fix-broken install

Hopefully we can fix that problem somehow

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: lightdm 1.26.0-0ubuntu1
Uname: Linux 4.19.56-x86_64-jb1 x86_64
ApportVersion: 2.20.9-0ubuntu7.15
Architecture: amd64
Date: Tue Jun 23 00:07:58 2020
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: lightdm
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: lightdm (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: tasksel (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug bionic

** Also affects: tasksel (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lightdm in Ubuntu.
https://bugs.launchpad.net/bugs/1884665

Title:
  lightdm not starting after fresh install

Status in lightdm package in Ubuntu:
  New
Status in tasksel package in Ubuntu:
  New

Bug description:
  Full Bash History after fresh Ubuntu 18 install:
  $ sudo apt install tasksel
  $ sudo tasksel install ubuntu-mate-core
  $ sudo service lightdm start

  facing the problem that lightdm isn't starting at all.

  Things I've tried:
  * sudo dpkg-reconfigure lightdm
  - no changes
  * journalctl -u lightdm.service
  - outputting:
  systemd[1]: lightdm.service: Main process exited, code=exited, 
status=1/FAILURE
  systemd[1]: lightdm.service: Failed with result 'exit-code'.
  systemd[1]: lightdm.service: Service hold-off time over, scheduling restart.
  systemd[1]: lightdm.service: Scheduled restart job, restart counter is at 1.
  systemd[1]: Stopped Light Display Manager.
  systemd[1]: Starting Light Display Manager...
  lightdm[24112]: Seat type 'xlocal' is deprecated, use 'type=local' instead
  systemd[1]: Started Light Display Manager.
  lightdm[24112]: Error: can't open /lib/modules/4.19.56-x86_64-jb1/updates/dkms
  * sudo apt --fix-broken install

  Hopefully we can fix that problem somehow

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: lightdm 1.26.0-0ubuntu1
  Uname: Linux 4.19.56-x86_64-jb1 x86_64
  ApportVersion: 2.20.9-0ubuntu7.15
  Architecture: amd64
  Date: Tue Jun 23 00:07:58 2020
  ProcEnviron:
   TERM=xterm
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: lightdm
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/1884665/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 962082] Re: Profiles that require duplex audio like Head Set (HSP) and Hands Free (HFP) do not work on machines with Broadcom BCM20702A0 Bluetooth chips

2020-06-22 Thread Casey Bailey
** CVE added: https://cve.mitre.org/cgi-bin/cvename.cgi?name=2020-6236

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to bluez in Ubuntu.
https://bugs.launchpad.net/bugs/962082

Title:
  Profiles that require duplex audio like Head Set (HSP) and Hands Free
  (HFP) do not work on machines with Broadcom BCM20702A0 Bluetooth chips

Status in HWE Next:
  Fix Released
Status in bluez package in Ubuntu:
  Fix Released

Bug description:
  This problem seems to occur on every device that uses  the BCM20702A0
  Bluetooth hardware.

  How to reproduce:

  (1) Pair a bluetooth headset with a machine equipped with a BCM20702A0.
  (2) Activate the device.  Usually there is a button on the headset you should 
press to notify the bluetooth stack that you're ready to use the device.  This 
creates SCO link and the plumbs the audio components.
  (3) Open the sound settings tool and select the bluetooth device under the 
"Input" and "Output" tabs.  Under each tab you should see a table with an entry 
that has a headset icon on the left with the bluetooth device name to the 
right.  This is the item to select.

  Now, everything should be configured so that you can use your
  bluetooth device to hear and record audio.  Test this by:

  Testing Input:

  (1) In the sound settings tool, select the "Input" tab.
  (2) Make sure the "Input Volume" is not muted and the scale widget is not set 
to zero.
  (3) Make sounds into the headset mic -- you should see the "Input Level" bar 
raise.

  Testing Output:
  In the same program:
  (1) Select the "Hardware" tab.
  (2) In the box labeled "Choose a device to configure", select your bluetooth 
device.
  (3) A combobox should appear at the bottom of the window labeled "Settings 
for the selected device".  Choose "Telephony Duplex (HSP/HFP)".
  (4) Now click on the "Test Speakers" button to the right.
  (5) Run speaker test.  You should hear a sound.

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/962082/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868456] Re: "sudo: setrlimit(RLIMIT_CORE): Operation not permitted" error when using sudo in 20.04 LXD container

2020-06-22 Thread Stéphane Graber
We'll want that sudo fix included in Ubuntu.

It's the usual catch with unprivileged containers only being able to
lower their limits and never raise them so there's nothing we can really
do about it in LXD.

** Changed in: lxd (Ubuntu)
   Status: New => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to sudo in Ubuntu.
https://bugs.launchpad.net/bugs/1868456

Title:
  "sudo: setrlimit(RLIMIT_CORE): Operation not permitted" error when
  using sudo in 20.04 LXD container

Status in lxd package in Ubuntu:
  Invalid
Status in sudo package in Ubuntu:
  Confirmed

Bug description:
  I fired up a LXD container using ubuntu-daily:f on my machine and
  every time I issue a comment inside the container using sudo, I get
  this error:

  sudo: setrlimit(RLIMIT_CORE): Operation not permitted

  I did some digging online and found this was reported against Fedora last 
fall which lead me to this bugzilla report:
  https://bugzilla.redhat.com/show_bug.cgi?id=1773148

  which seems to tie this to a change in sudo between 1.8.28 and 1.8.29.

  Focal has 1.8.31:
  bladernr@focal-builder:~/development/kernels-ubuntu/focal$ apt-cache policy 
sudo
  sudo:
    Installed: 1.8.31-1ubuntu1
    Candidate: 1.8.31-1ubuntu1
    Version table:
   *** 1.8.31-1ubuntu1 500
  500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages
  100 /var/lib/dpkg/status

  This is not an issue on Bionic:
  bladernr@galactica:~/development/kernels-upstream/mainline$ apt-cache policy 
sudo
  sudo:
    Installed: 1.8.21p2-3ubuntu1.2
    Candidate: 1.8.21p2-3ubuntu1.2
    Version table:
   *** 1.8.21p2-3ubuntu1.2 500
  500 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 
Packages
  500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 
Packages
  100 /var/lib/dpkg/status
   1.8.21p2-3ubuntu1 500
  500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages

  From the redhat bug, the described workaround does clear these
  messages up:

  # set disable_coredump false

  Once I've done that, the error messages go away.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lxd/+bug/1868456/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884148] Re: /usr/share/apport/package_hook:ValueError:__getitem__:_apt_pkg:__getitem__:/usr/share/apport/package_hook@48:get_source:_apt_pkg

2020-06-22 Thread Brian Murray
I was able to recreate this during a distribution upgrade from 18.04 LTS
to 20.04 LTS with pure-ftpd installed.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apport in Ubuntu.
https://bugs.launchpad.net/bugs/1884148

Title:
  
/usr/share/apport/package_hook:ValueError:__getitem__:_apt_pkg:__getitem__:/usr/share/apport/package_hook@48:get_source:_apt_pkg

Status in apport package in Ubuntu:
  New

Bug description:
  The Ubuntu Error Tracker has been receiving reports about a problem regarding 
apport.  This problem was most recently seen with package version 
2.20.11-0ubuntu40, the problem page at 
https://errors.ubuntu.com/problem/976abccbca7b548c9ccf155c80c8eb6f36efa7de 
contains more details, including versions of packages affected, stacktrace or 
traceback, and individual crash reports.
  If you do not have access to the Ubuntu Error Tracker and are a software 
developer, you can request it at http://forms.canonical.com/reports/.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apport/+bug/1884148/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884635] Re: lxc 1:4.0.2-0ubuntu1 ADT test failure with linux-5.8 5.8.0-1.2

2020-06-22 Thread Stéphane Graber
** Changed in: lxc (Ubuntu)
 Assignee: (unassigned) => Christian Brauner (cbrauner)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lxc in Ubuntu.
https://bugs.launchpad.net/bugs/1884635

Title:
  lxc 1:4.0.2-0ubuntu1 ADT test failure with linux-5.8 5.8.0-1.2

Status in lxc package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/amd64/l/lxc/20200619_210334_814e1@/log.gz
  arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/arm64/l/lxc/20200619_213805_39c53@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/ppc64el/l/lxc/20200619_210431_b275f@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/s390x/l/lxc/20200619_210417_54a16@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/1884635/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884636] [NEW] systemd 245.5-3ubuntu1 ADT test failure with linux-5.8 5.8.0-1.2

2020-06-22 Thread Seth Forshee
Public bug reported:

Testing failed on:
amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/amd64/s/systemd/20200619_224023_f687b@/log.gz
arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/arm64/s/systemd/20200620_002130_9921a@/log.gz
ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/ppc64el/s/systemd/20200620_002108_b4135@/log.gz
s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/s390x/s/systemd/20200619_214658_5b596@/log.gz

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: kernel-adt-failure

** Tags added: kernel-adt-failure

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1884636

Title:
  systemd 245.5-3ubuntu1 ADT test failure with linux-5.8 5.8.0-1.2

Status in systemd package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/amd64/s/systemd/20200619_224023_f687b@/log.gz
  arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/arm64/s/systemd/20200620_002130_9921a@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/ppc64el/s/systemd/20200620_002108_b4135@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/s390x/s/systemd/20200619_214658_5b596@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1884636/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884635] [NEW] lxc 1:4.0.2-0ubuntu1 ADT test failure with linux-5.8 5.8.0-1.2

2020-06-22 Thread Seth Forshee
Public bug reported:

Testing failed on:
amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/amd64/l/lxc/20200619_210334_814e1@/log.gz
arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/arm64/l/lxc/20200619_213805_39c53@/log.gz
ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/ppc64el/l/lxc/20200619_210431_b275f@/log.gz
s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/s390x/l/lxc/20200619_210417_54a16@/log.gz

** Affects: lxc (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: kernel-adt-failure

** Tags added: kernel-adt-failure

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lxc in Ubuntu.
https://bugs.launchpad.net/bugs/1884635

Title:
  lxc 1:4.0.2-0ubuntu1 ADT test failure with linux-5.8 5.8.0-1.2

Status in lxc package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/amd64/l/lxc/20200619_210334_814e1@/log.gz
  arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/arm64/l/lxc/20200619_213805_39c53@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/ppc64el/l/lxc/20200619_210431_b275f@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/s390x/l/lxc/20200619_210417_54a16@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/1884635/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884595] [NEW] Bugged 3D display of multimaterial meshes after last Radeon driver update

2020-06-22 Thread Pablo Roldán
Public bug reported:

After the last driver update for my Radeon HD 7750 Im having viewport
problems in Blender when displaying meshes with multiple materials (see
attached screenshot).

This happens both with both the latest version of Blender snap and the direct 
download from Blender.org
I also have an older version installed and is having the same problem.

It all worked fine before the driver update.

Just in case these are the last lines from running  grep "upgrade " 
/var/log/dpkg.log
:

2020-06-20 00:48:38 upgrade xserver-xorg-legacy-hwe-18.04:amd64 
2:1.20.5+git20191008-0ubuntu1~18.04.1 2:1.20.8-2ubuntu2.1~18.04.1
2020-06-20 00:48:39 upgrade xserver-xorg-core-hwe-18.04:amd64 
2:1.20.5+git20191008-0ubuntu1~18.04.1 2:1.20.8-2ubuntu2.1~18.04.1
2020-06-20 00:48:40 upgrade xserver-xorg-video-amdgpu-hwe-18.04:amd64 
19.0.1-1ubuntu1~18.04.1 19.1.0-1~18.04.1
2020-06-20 00:48:40 upgrade xserver-xorg-video-radeon-hwe-18.04:amd64 
1:19.0.1-1ubuntu1~18.04.1 1:19.1.0-1~18.04.1
2020-06-20 00:48:41 upgrade xserver-xorg-video-ati-hwe-18.04:amd64 
1:19.0.1-1ubuntu1~18.04.1 1:19.1.0-1~18.04.1

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xorg 1:7.7+19ubuntu7.1
ProcVersionSignature: Ubuntu 5.3.0-59.53~18.04.1-generic 5.3.18
Uname: Linux 5.3.0-59-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.15
Architecture: amd64
CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CurrentDesktop: Budgie:GNOME
Date: Mon Jun 22 16:31:31 2020
DistUpgraded: Fresh install
DistroCodename: bionic
DistroVariant: ubuntu
DkmsStatus:
 openrazer-driver, 2.8.0, 5.3.0-53-generic, x86_64: installed
 openrazer-driver, 2.8.0, 5.3.0-59-generic, x86_64: installed
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde PRO [Radeon HD 7750/8740 / 
R7 250E] [1002:683f] (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Cape Verde PRO [Radeon HD 7750/8740 / R7 
250E] [1043:0427]
InstallationDate: Installed on 2019-08-03 (324 days ago)
InstallationMedia: Ubuntu-Budgie 18.04.2 LTS "Bionic Beaver" - Release amd64 
(20190210)
MachineType: System manufacturer System Product Name
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-59-generic 
root=UUID=bf94f108-3b15-444b-a40a-414115dcfedd ro quiet splash vt.handoff=1
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/25/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1107
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: P8H61-M LX3 R2.0
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr1107:bd02/25/2014:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnP8H61-MLX3R2.0:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.family: To be filled by O.E.M.
dmi.product.name: System Product Name
dmi.product.sku: SKU
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.101-2~18.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 19.2.8-0ubuntu0~18.04.3
version.libgl1-mesa-glx: libgl1-mesa-glx 19.2.8-0ubuntu0~18.04.3
version.xserver-xorg-core: xserver-xorg-core N/A
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug bionic corruption ubuntu

** Attachment added: "Screenshot."
   
https://bugs.launchpad.net/bugs/1884595/+attachment/5386190/+files/Captura%20de%20pantalla%20de%202020-06-22%2016-33-04.png

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1884595

Title:
  Bugged 3D display of multimaterial meshes after last Radeon driver
  update

Status in xorg package in Ubuntu:
  New

Bug description:
  After the last driver update for my Radeon HD 7750 Im having viewport
  problems in Blender when displaying meshes with multiple materials
  (see attached screenshot).

  This happens both with both the latest version of Blender snap and the direct 
download from Blender.org
  I also have an older version installed and is having the same problem.

  It all worked fine before the driver update.

  Just in case these are the last lines from running  grep "upgrade " 
/var/log/dpkg.log
  :

  2020-06-20 00:48:38 upgrade xserver-xorg-legacy-hwe-18.04:amd64 
2:1.20.5+git20191008-0ubuntu1~18.04.1 2:1.20.8-2ubuntu2.1~18.04.1
  2020-06-20 00:48:39 upgrade 

[Touch-packages] [Bug 1883495] Re: package openssh-server 1:7.2p2-4ubuntu2.8 [modified: usr/lib/tmpfiles.d/sshd.conf] failed to install/upgrade: Unterprozess installiertes post-installation-Skript gab

2020-06-22 Thread Mike Salvatore
Thanks for taking the time to report this bug and helping to make Ubuntu
better. We appreciate the difficulties you are facing, but this appears
to be a "regular" (non-security) bug.  I have unmarked it as a security
issue since this bug does not show evidence of allowing attackers to
cross privilege boundaries nor directly cause loss of data/privacy.
Please feel free to report any other bugs you may find.

** Information type changed from Private Security to Public

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssh in Ubuntu.
https://bugs.launchpad.net/bugs/1883495

Title:
  package openssh-server 1:7.2p2-4ubuntu2.8 [modified:
  usr/lib/tmpfiles.d/sshd.conf] failed to install/upgrade: Unterprozess
  installiertes post-installation-Skript gab den Fehlerwert 1 zurück

Status in openssh package in Ubuntu:
  New

Bug description:
  since months 0penssh can not be installed - not at all tried many
  times - tried to deinstall using terminal reinstall - no way -
  something totally broken

  ProblemType: Package
  DistroRelease: Ubuntu 16.04
  Package: openssh-server 1:7.2p2-4ubuntu2.8 [modified: 
usr/lib/tmpfiles.d/sshd.conf]
  ProcVersionSignature: Ubuntu 4.4.0-179.209-generic 4.4.219
  Uname: Linux 4.4.0-179-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.23
  AptOrdering:
   libwinpr-pool0.1: Install
   openssh-server: Configure
   libwinpr-pool0.1: Configure
   NULL: ConfigurePending
  Architecture: amd64
  Date: Mon Jun 15 06:19:25 2020
  ErrorMessage: Unterprozess installiertes post-installation-Skript gab den 
Fehlerwert 1 zurück
  InstallationDate: Installed on 2016-10-13 (1340 days ago)
  InstallationMedia: Ubuntu-MATE 16.04.1 LTS "Xenial Xerus" - Release amd64 
(20160719)
  RelatedPackageVersions:
   dpkg 1.18.4ubuntu1.6
   apt  1.2.32ubuntu0.1
  SSHDConfig:
   Error: command ['/usr/sbin/sshd', '-T'] failed with exit code 255: 
/etc/ssh/sshd_config: line 111: Bad configuration option: sudo
   /etc/ssh/sshd_config: terminating, 1 bad configuration options
  SourcePackage: openssh
  Title: package openssh-server 1:7.2p2-4ubuntu2.8 [modified: 
usr/lib/tmpfiles.d/sshd.conf] failed to install/upgrade: Unterprozess 
installiertes post-installation-Skript gab den Fehlerwert 1 zurück
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1883495/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884583] Re: vim is dependent on libcanberra0 in Ubuntu 20.04, had no such dependency in Ubuntu 18.04

2020-06-22 Thread Kai Kasurinen
https://salsa.debian.org/vim-
team/vim/-/commit/0aaaf0247c59488ca3dccac63c3aa33884a2c770

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to vim in Ubuntu.
https://bugs.launchpad.net/bugs/1884583

Title:
  vim is dependent on libcanberra0 in Ubuntu 20.04, had no such
  dependency in Ubuntu 18.04

Status in vim package in Ubuntu:
  New

Bug description:
  which pulls in libasound and some alsa packages which I am not sure why it is 
useful and desired on most text-only/headless systems.
  In Debian I also see this dependency arisen with Bullseye/testing and 
Sid/unstable (but not with Buster/stable) but I don't see any mention of this 
introduction and its usefulness in the package's changelog. Could the reason of 
this dependency creation please be investigated, its usefulness evaluated, and 
if possible, this dependency to be made optional for vim builds ? Surprisingly, 
installing vim-nox also pulls in libcanberra0. vim-tiny does not pull in 
libcanberra0, but it also does not have syntax highlighting. What should I do 
to have syntax highlighting without libcanberra0 overhead ?

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/vim/+bug/1884583/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884583] [NEW] vim is dependent on libcanberra0 in Ubuntu 20.04, had no such dependency in Ubuntu 18.04

2020-06-22 Thread Wladimir Mutel
Public bug reported:

which pulls in libasound and some alsa packages which I am not sure why it is 
useful and desired on most text-only/headless systems.
In Debian I also see this dependency arisen with Bullseye/testing and 
Sid/unstable (but not with Buster/stable) but I don't see any mention of this 
introduction and its usefulness in the package's changelog. Could the reason of 
this dependency creation please be investigated, its usefulness evaluated, and 
if possible, this dependency to be made optional for vim builds ? Surprisingly, 
installing vim-nox also pulls in libcanberra0. vim-tiny does not pull in 
libcanberra0, but it also does not have syntax highlighting. What should I do 
to have syntax highlighting without libcanberra0 overhead ?

** Affects: vim (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to vim in Ubuntu.
https://bugs.launchpad.net/bugs/1884583

Title:
  vim is dependent on libcanberra0 in Ubuntu 20.04, had no such
  dependency in Ubuntu 18.04

Status in vim package in Ubuntu:
  New

Bug description:
  which pulls in libasound and some alsa packages which I am not sure why it is 
useful and desired on most text-only/headless systems.
  In Debian I also see this dependency arisen with Bullseye/testing and 
Sid/unstable (but not with Buster/stable) but I don't see any mention of this 
introduction and its usefulness in the package's changelog. Could the reason of 
this dependency creation please be investigated, its usefulness evaluated, and 
if possible, this dependency to be made optional for vim builds ? Surprisingly, 
installing vim-nox also pulls in libcanberra0. vim-tiny does not pull in 
libcanberra0, but it also does not have syntax highlighting. What should I do 
to have syntax highlighting without libcanberra0 overhead ?

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/vim/+bug/1884583/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1718658] Re: ecryptfs-mount-private fails to initialize ecryptfs keys

2020-06-22 Thread Forest
I hate to say this, folks, but ecryptfs looks like a dead end for us.
It's no longer supported by Ubuntu (the package has been moved to the
Universe repo). Also, the problem at hand is caused by systemd, which is
run by a man famous for releasing poorly-vetted, system-breaking
software, and then refusing to fix the damage he causes.

For a year or so, I maintained a systemd patch to work around this bug.
(It is posted above, but no longer applies to current systemd code.)
There was a time when it looked like the problem was finally fixed
upstream, but then it just broke again.

Anyone who (like me) has been using ecryptfs to encrypt a private directory and 
unlock it only when needed, might consider switching to gocryptfs.  From a 
user's point of view, it works similarly to ecryptfs.  There's also a handy GUI 
called SiriKali that works with it.
https://nuetzlich.net/gocryptfs/
https://mhogomchungu.github.io/sirikali/

Good luck.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1718658

Title:
  ecryptfs-mount-private fails to initialize ecryptfs keys

Status in ecryptfs-utils package in Ubuntu:
  Confirmed
Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  ecryptfs-mount-private fails to mount the ecryptfs after the 1st
  reboot after creating the ecryptfs by ecryptfs-setup-private.

  After the unsucessful attempt dmesg contains:

  [ 1265.695388] Could not find key with description: []
  [ 1265.695393] process_request_key_err: No key
  [ 1265.695394] Could not find valid key in user session keyring for sig 
specified in mount option: []
  [ 1265.695395] One or more global auth toks could not properly register; rc = 
[-2]
  [ 1265.695396] Error parsing options; rc = [-2]

  Note: The correct key ID has been replaced in the "".

  I also accidentally found an workaround - just running ecrytpfs-
  manager and then the ecryptfs-mount-private (it does not ask for
  password for the second time and mounts the ecryptfs correctly):

  host:~$ ecryptfs-manager

  eCryptfs key management menu
  ---
1. Add passphrase key to keyring
2. Add public key to keyring
3. Generate new public/private keypair
4. Exit

  Make selection: 4
  host:~$ ls Private/
  Access-Your-Private-Data.desktop  README.txt
  host:~$ ecryptfs-mount-private 
  host:~$ ls Private/
  

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ecryptfs-utils/+bug/1718658/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1718658] Re: ecryptfs-mount-private fails to initialize ecryptfs keys

2020-06-22 Thread marius
I am getting exactly the same issue here after upgrading from 18.04 to
20.04. I use a custom folder and have some shell utilities to run the
mount command with the right paramaters. Below SIG and FNEK_SIG continue
to match what `ecryptfs-add-passphrase --fnek` reports (and the same as
before the update). I am seeing the same in kernel logs via `dmesg` as
OP reported.

mount -t ecryptfs /home/marius/Dropbox/private /home/marius/private -o
ecryptfs_sig=,ecryptfs_fnek_sig=,ecryptfs_cipher=aes,ecryptfs_key_bytes=16,ecryptfs_passthrough=n


$ uname -mrs


 Linux 5.4.0-37-generic x86_64

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:Ubuntu 20.04 LTS
Release:20.04
Codename:   focal

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1718658

Title:
  ecryptfs-mount-private fails to initialize ecryptfs keys

Status in ecryptfs-utils package in Ubuntu:
  Confirmed
Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  ecryptfs-mount-private fails to mount the ecryptfs after the 1st
  reboot after creating the ecryptfs by ecryptfs-setup-private.

  After the unsucessful attempt dmesg contains:

  [ 1265.695388] Could not find key with description: []
  [ 1265.695393] process_request_key_err: No key
  [ 1265.695394] Could not find valid key in user session keyring for sig 
specified in mount option: []
  [ 1265.695395] One or more global auth toks could not properly register; rc = 
[-2]
  [ 1265.695396] Error parsing options; rc = [-2]

  Note: The correct key ID has been replaced in the "".

  I also accidentally found an workaround - just running ecrytpfs-
  manager and then the ecryptfs-mount-private (it does not ask for
  password for the second time and mounts the ecryptfs correctly):

  host:~$ ecryptfs-manager

  eCryptfs key management menu
  ---
1. Add passphrase key to keyring
2. Add public key to keyring
3. Generate new public/private keypair
4. Exit

  Make selection: 4
  host:~$ ls Private/
  Access-Your-Private-Data.desktop  README.txt
  host:~$ ecryptfs-mount-private 
  host:~$ ls Private/
  

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ecryptfs-utils/+bug/1718658/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1883297] Re: dh-python's autopkg tests fail with python3.8 as the only supported python3 version

2020-06-22 Thread Bug Watch Updater
** Changed in: dh-python (Debian)
   Status: New => Fix Committed

** Changed in: dh-python (Debian)
   Importance: Undecided => Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to dh-python in Ubuntu.
https://bugs.launchpad.net/bugs/1883297

Title:
  dh-python's autopkg tests fail with python3.8 as the only supported
  python3 version

Status in dh-python package in Ubuntu:
  Fix Released
Status in dh-python package in Debian:
  Fix Committed

Bug description:
  Imported from Debian bug http://bugs.debian.org/956190:

  Package: dh-python
  Version: 4.20200315
  Severity: serious
  Tags: sid bullseye

  dh-python's autopkg tests fail with python3.8 as the only supported
  python3 version.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dh-python/+bug/1883297/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884455] Re: pulseaudio creates /root/.config/pulse/ before zfs-mount.service can mount the /root dataset

2020-06-22 Thread Dumitru Sipos
I checked and the option is not activated:
-
root@minighost:~# grep daemonize /etc/pulse/daemon.conf
; daemonize = no
root@minighost:~# 
-


In fact, the only option that is activated in the /etc/pulse/daemon.conf is the 
following:
-
root@minighost:~# egrep -v '^;|^#|^$' /etc/pulse/daemon.conf
deferred-volume-safety-margin-usec = 1
root@minighost:~# 
-


Is there something else I could check?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1884455

Title:
  pulseaudio creates /root/.config/pulse/ before zfs-mount.service can
  mount the /root dataset

Status in pulseaudio package in Ubuntu:
  Incomplete

Bug description:
  I use 'zfs' and have /root as its own dataset which is mounted during
  startup by 'zfs-mount.service'.

  At one of the latest upgrades, the 'zfsutils-linux' package failed to
  update because the service 'zfs-mount' service had an issue and could
  not mount the '/root' dataset because the '/root' directory was not
  empty (temporary solution was to rename /root and call 'zfs mount'
  again).

  Further investigation shows that everytime at startup, the /root
  directory is created before the 'zfs-mount.service' has a chance to
  mount the 'root' dataset.

  The culprit seems to be something pulseaudio related: the content of /root 
folder after startup is as follows:
  -
  root@minighost:~# tree -a /root
  .
  ├── .cache
  └── .config
  └── pulse
  └── fe1417537ae0451abdb60c5df28fe825-runtime -> 
/tmp/pulse-PKdhtXMmr18n

  4 directories, 0 files
  root@minighost:~#
  -  


  Extra details:

  - Ubuntu release:
  -
  root@minighost:~# lsb_release -rd
  Description:  Ubuntu 20.04 LTS
  Release:  20.04
  -

  
  - status of 'zfs-mount.service' is the following:
  -  
  root@minighost:~# systemctl status zfs-mount
  ● zfs-mount.service - Mount ZFS filesystems
   Loaded: loaded (/lib/systemd/system/zfs-mount.service; enabled; vendor 
preset: enabled)
   Active: failed (Result: exit-code) since Sun 2020-06-21 12:56:08 CEST; 
6h ago
 Docs: man:zfs(8)
  Process: 2062 ExecStart=/sbin/zfs mount -a (code=exited, status=1/FAILURE)
 Main PID: 2062 (code=exited, status=1/FAILURE)

  Jun 21 12:56:08 minighost systemd[1]: Starting Mount ZFS filesystems...
  Jun 21 12:56:08 minighost zfs[2062]: cannot mount '/root': directory is not 
empty
  Jun 21 12:56:08 minighost systemd[1]: zfs-mount.service: Main process exited, 
code=exited, status=1/FAILURE
  Jun 21 12:56:08 minighost systemd[1]: zfs-mount.service: Failed with result 
'exit-code'.
  Jun 21 12:56:08 minighost systemd[1]: Failed to start Mount ZFS filesystems.
  root@minighost:~#
  -  


  - software versions:
  -
  root@minighost:~# apt-cache policy pulseaudio
  pulseaudio:
Installed: 1:13.99.1-1ubuntu3.3
Candidate: 1:13.99.1-1ubuntu3.3
Version table:
   *** 1:13.99.1-1ubuntu3.3 500
  500 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages
  100 /var/lib/dpkg/status
   1:13.99.1-1ubuntu3.2 500
  500 http://security.ubuntu.com/ubuntu focal-security/main amd64 
Packages
   1:13.99.1-1ubuntu3 500
  500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages

  root@minighost:~# apt-cache policy zfsutils-linux
  zfsutils-linux:
Installed: 0.8.3-1ubuntu12.1
Candidate: 0.8.3-1ubuntu12.1
Version table:
   *** 0.8.3-1ubuntu12.1 500
  500 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages
  100 /var/lib/dpkg/status
   0.8.3-1ubuntu12 500
  500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages
  -

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: pulseaudio 1:13.99.1-1ubuntu3.3
  ProcVersionSignature: Ubuntu 5.4.0-37.41-generic 5.4.41
  Uname: Linux 5.4.0-37-generic x86_64
  NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
  ApportVersion: 2.20.11-0ubuntu27.3
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  dumi   2419 F pulseaudio
  CasperMD5CheckResult: skip
  Date: Sun Jun 21 19:17:20 2020
  InstallationDate: Installed on 2018-09-08 (651 days ago)
  InstallationMedia: Ubuntu 18.04 "Bionic" - Build amd64 LIVE Binary 
20180608-09:38
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
  SourcePackage: pulseaudio
  UpgradeStatus: Upgraded to focal on 2020-04-24 (57 days ago)
  dmi.bios.date: 12/11/2019
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.12.1
  dmi.board.name: 0F6P3V
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 10
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 

[Touch-packages] [Bug 1854403] Re: Need updated libimobiledevice and dependencies to access iOS 13 devices

2020-06-22 Thread Philip Langdale
Ah, sorry. Yes, if you rebuild the focal package with f56a65f and use
openssl, then connectivity and file transfers work correctly. There does
not appear to be any other changes required. I can't vouch for all the
functionality, of course. The device backup functionality seems popular,
but I don't use it. I've tried doing a device backup and that seems
fine, but I'm not going to attempt to restore it. :-)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libimobiledevice in
Ubuntu.
https://bugs.launchpad.net/bugs/1854403

Title:
  Need updated libimobiledevice and dependencies to access iOS 13
  devices

Status in libimobiledevice package in Ubuntu:
  Fix Released
Status in libplist package in Ubuntu:
  Fix Released
Status in libusbmuxd package in Ubuntu:
  Fix Released
Status in usbmuxd package in Ubuntu:
  Confirmed

Bug description:
  iOS 13 devices require updated libimobiledevice, libusbmuxd and
  usbmuxd to work correctly. Without the updates, the device appears to
  be accessible but it's impossible to copy files to the devices.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libimobiledevice/+bug/1854403/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1826639] Re: wpasupplicant: unknown keys in no-mac-addr-change.conf

2020-06-22 Thread Tom H
Working for me too. Many thanks.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to wpa in Ubuntu.
https://bugs.launchpad.net/bugs/1826639

Title:
  wpasupplicant: unknown keys in no-mac-addr-change.conf

Status in wpa package in Ubuntu:
  Fix Released
Status in wpa source package in Focal:
  Fix Committed
Status in wpa package in Debian:
  New

Bug description:
  * Impact
  wpa ships an invalid network-manager configuration that triggers warnings

  * Test case
  $ journalctl | grep no-mac-addr-change
  should not have errors listed

  * Regression potential
  the change removes configurations which are not needed (since they set the 
value to the same one as the default) and in the wrong section, it shouldn't 
have any visible impact

  

  Hi,

  NetworkManager warns that no-mac-addr-change.conf contains unknown
  configuration directives:

  # journalctl | grep no-mac-addr-change
  Apr 25 09:24:50 vougeot NetworkManager[573]:   [1556177090.0596] Read 
config: /etc/NetworkManager/NetworkManager.conf (lib: 10-dns-resolved.conf, 
20-connectivity-ubuntu.conf, no-mac-addr-change.conf) (etc: 
10-globally-managed-devices.conf, default-wifi-powersave-on.conf)
  Apr 25 09:24:50 vougeot NetworkManager[573]:   [1556177090.0596] 
config: unknown key 'wifi.cloned-mac-address' in section 
[device-mac-addr-change-wifi] of file 
'/usr/lib/NetworkManager/conf.d/no-mac-addr-change.conf'
  Apr 25 09:24:50 vougeot NetworkManager[573]:   [1556177090.0596] 
config: unknown key 'ethernet.cloned-mac-address' in section 
[device-mac-addr-change-wifi] of file 
'/usr/lib/NetworkManager/conf.d/no-mac-addr-change.conf'

  ProblemType: Bug
  DistroRelease: Ubuntu 19.04
  Package: wpasupplicant 2:2.6-21ubuntu3
  Uname: Linux 5.0.9-050009-generic x86_64
  ApportVersion: 2.20.10-0ubuntu27
  Architecture: amd64
  CurrentDesktop: KDE
  Date: Sat Apr 27 13:15:27 2019
  SourcePackage: wpa
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/wpa/+bug/1826639/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884547] [NEW] can't activate the bluethooth headsed with a2dp sound

2020-06-22 Thread Diego
Public bug reported:

I follow this bug, and still happend

https://bugs.launchpad.net/ubuntu/+source/bluez/+filebug/e91ee546-b48f-
11ea-a86b-68b5996a96c8


dpkg --status bluez | grep '^Version:'
Version: 5.53-0ubuntu3

cat /etc/*-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=20.04
DISTRIB_CODENAME=focal
DISTRIB_DESCRIPTION="Ubuntu 20.04 LTS"
NAME="Ubuntu"
VERSION="20.04 LTS (Focal Fossa)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 20.04 LTS"
VERSION_ID="20.04"
HOME_URL="https://www.ubuntu.com/;
SUPPORT_URL="https://help.ubuntu.com/;
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/;
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy;
VERSION_CODENAME=focal
UBUNTU_CODENAME=focal

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: bluez 5.53-0ubuntu3
ProcVersionSignature: Ubuntu 5.4.0-37.41-generic 5.4.41
Uname: Linux 5.4.0-37-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.3
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Mon Jun 22 10:54:05 2020
InstallationDate: Installed on 2020-05-19 (33 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
InterestingModules: rfcomm bnep btusb bluetooth
MachineType: LENOVO 20NYS04V00
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-5.4.0-37-generic 
root=/dev/mapper/vgubuntu-root ro quiet splash vt.handoff=7
SourcePackage: bluez
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/27/2020
dmi.bios.vendor: LENOVO
dmi.bios.version: N2JET87W (1.65 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20NYS04V00
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40697 WIN
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.modalias: 
dmi:bvnLENOVO:bvrN2JET87W(1.65):bd03/27/2020:svnLENOVO:pn20NYS04V00:pvrThinkPadT490s:rvnLENOVO:rn20NYS04V00:rvrSDK0J40697WIN:cvnLENOVO:ct10:cvrNone:
dmi.product.family: ThinkPad T490s
dmi.product.name: 20NYS04V00
dmi.product.sku: LENOVO_MT_20NY_BU_Think_FM_ThinkPad T490s
dmi.product.version: ThinkPad T490s
dmi.sys.vendor: LENOVO
hciconfig:
 hci0:  Type: Primary  Bus: USB
BD Address: 04:ED:33:30:BC:12  ACL MTU: 1021:4  SCO MTU: 96:6
UP RUNNING 
RX bytes:2532201 acl:38232 sco:36899 events:9437 errors:0
TX bytes:4236888 acl:2223 sco:36783 commands:6938 errors:0
mtime.conffile..etc.bluetooth.input.conf: 2020-06-10T09:52:46.145873
mtime.conffile..etc.bluetooth.main.conf: 2020-06-04T16:03:04.084396

** Affects: bluez (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: a2dp amd64 and apport-bug bluetooth focal mic

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to bluez in Ubuntu.
https://bugs.launchpad.net/bugs/1884547

Title:
  can't activate the bluethooth headsed with a2dp sound

Status in bluez package in Ubuntu:
  New

Bug description:
  I follow this bug, and still happend

  https://bugs.launchpad.net/ubuntu/+source/bluez/+filebug/e91ee546
  -b48f-11ea-a86b-68b5996a96c8

  
  dpkg --status bluez | grep '^Version:'
  Version: 5.53-0ubuntu3

  cat /etc/*-release
  DISTRIB_ID=Ubuntu
  DISTRIB_RELEASE=20.04
  DISTRIB_CODENAME=focal
  DISTRIB_DESCRIPTION="Ubuntu 20.04 LTS"
  NAME="Ubuntu"
  VERSION="20.04 LTS (Focal Fossa)"
  ID=ubuntu
  ID_LIKE=debian
  PRETTY_NAME="Ubuntu 20.04 LTS"
  VERSION_ID="20.04"
  HOME_URL="https://www.ubuntu.com/;
  SUPPORT_URL="https://help.ubuntu.com/;
  BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/;
  
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy;
  VERSION_CODENAME=focal
  UBUNTU_CODENAME=focal

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: bluez 5.53-0ubuntu3
  ProcVersionSignature: Ubuntu 5.4.0-37.41-generic 5.4.41
  Uname: Linux 5.4.0-37-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.3
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Mon Jun 22 10:54:05 2020
  InstallationDate: Installed on 2020-05-19 (33 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  InterestingModules: rfcomm bnep btusb bluetooth
  MachineType: LENOVO 20NYS04V00
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-5.4.0-37-generic 
root=/dev/mapper/vgubuntu-root ro quiet splash vt.handoff=7
  SourcePackage: bluez
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 03/27/2020
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N2JET87W (1.65 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20NYS04V00
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0J40697 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN2JET87W(1.65):bd03/27/2020:svnLENOVO:pn20NYS04V00:pvrThinkPadT490s:rvnLENOVO:rn20NYS04V00:rvrSDK0J40697WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad 

[Touch-packages] [Bug 1879087] Re: dbus errors, frequent roaming and unstable connectivity

2020-06-22 Thread Sebastien Bacher
@Thomas, any chance to give the SRU a try and tell us how it works for
you?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to wpa in Ubuntu.
https://bugs.launchpad.net/bugs/1879087

Title:
  dbus errors, frequent roaming and unstable connectivity

Status in wpa package in Ubuntu:
  Fix Released
Status in wpa source package in Focal:
  Fix Committed

Bug description:
  * Impact
  extra roaming events are been generated

  * Test case
  check the output of `journalctl -lu wpa_supplicant`, it shouldn't have those 
warnings
  dbus: wpa_dbus_property_changed: no property RoamComplete in object 
/fi/w1/wpa_supplicant1/Interfaces/3

  the roaming events should not be too frequent

  * Regression potential
  check that wifi connection keep working correctly

  --

  When using this version of wpa_supplicant with my company
  WPA2-Enterprise wireless setup, I'm experiencing far too frequent
  roaming events (even when not moving around) accompanied by hiccups in
  connectivity. I also see these messages in the wpa_supplicant log:

  dbus: wpa_dbus_property_changed: no property RoamComplete in object 
/fi/w1/wpa_supplicant1/Interfaces/3
  dbus: wpa_dbus_property_changed: no property RoamTime in object 
/fi/w1/wpa_supplicant1/Interfaces/3
  dbus: wpa_dbus_property_changed: no property SessionLength in object 
/fi/w1/wpa_supplicant1/Interfaces/3

  Having done a little research, at least the dbus errors seem to be
  fixed by this commit upstream:

  
https://w1.fi/cgit/hostap/commit/wpa_supplicant/dbus/dbus_new.c?id=23d87687c2428f3b94865580b0d33e05c03e6756

  So I built a version of wpa_supplicant including this particular patch
  and installed on my machine. Apart from solving the dbus errors
  completely, it seems to have had a positive impact on the frequent
  roaming and unstable connectivity as well (I've run for a day with no
  burst of roaming events at all, where they used to happen every few
  minutes most of the time.)

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: wpasupplicant 2:2.9-1ubuntu4
  ProcVersionSignature: Ubuntu 5.4.0-31.35-generic 5.4.34
  Uname: Linux 5.4.0-31-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: GNOME
  Date: Sat May 16 16:47:27 2020
  InstallationDate: Installed on 2020-05-12 (4 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  SourcePackage: wpa
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/wpa/+bug/1879087/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1826639] Re: wpasupplicant: unknown keys in no-mac-addr-change.conf

2020-06-22 Thread Sebastien Bacher
Thanks for testing!

** Tags removed: verification-needed verification-needed-focal
** Tags added: verification-done verification-done-focal

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to wpa in Ubuntu.
https://bugs.launchpad.net/bugs/1826639

Title:
  wpasupplicant: unknown keys in no-mac-addr-change.conf

Status in wpa package in Ubuntu:
  Fix Released
Status in wpa source package in Focal:
  Fix Committed
Status in wpa package in Debian:
  New

Bug description:
  * Impact
  wpa ships an invalid network-manager configuration that triggers warnings

  * Test case
  $ journalctl | grep no-mac-addr-change
  should not have errors listed

  * Regression potential
  the change removes configurations which are not needed (since they set the 
value to the same one as the default) and in the wrong section, it shouldn't 
have any visible impact

  

  Hi,

  NetworkManager warns that no-mac-addr-change.conf contains unknown
  configuration directives:

  # journalctl | grep no-mac-addr-change
  Apr 25 09:24:50 vougeot NetworkManager[573]:   [1556177090.0596] Read 
config: /etc/NetworkManager/NetworkManager.conf (lib: 10-dns-resolved.conf, 
20-connectivity-ubuntu.conf, no-mac-addr-change.conf) (etc: 
10-globally-managed-devices.conf, default-wifi-powersave-on.conf)
  Apr 25 09:24:50 vougeot NetworkManager[573]:   [1556177090.0596] 
config: unknown key 'wifi.cloned-mac-address' in section 
[device-mac-addr-change-wifi] of file 
'/usr/lib/NetworkManager/conf.d/no-mac-addr-change.conf'
  Apr 25 09:24:50 vougeot NetworkManager[573]:   [1556177090.0596] 
config: unknown key 'ethernet.cloned-mac-address' in section 
[device-mac-addr-change-wifi] of file 
'/usr/lib/NetworkManager/conf.d/no-mac-addr-change.conf'

  ProblemType: Bug
  DistroRelease: Ubuntu 19.04
  Package: wpasupplicant 2:2.6-21ubuntu3
  Uname: Linux 5.0.9-050009-generic x86_64
  ApportVersion: 2.20.10-0ubuntu27
  Architecture: amd64
  CurrentDesktop: KDE
  Date: Sat Apr 27 13:15:27 2019
  SourcePackage: wpa
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/wpa/+bug/1826639/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884366] Re: package libkrb5-3 1.16-2build1 failed to install/upgrade: unable to make backup link of './usr/lib/i386-linux-gnu/libkrb5.so.3.3' before installing new version: Inpu

2020-06-22 Thread guest271314
#3

> Are you running from a cdrom/flash drive?

Yes.

And trying to run

  $ sudo apt upgrade

as well where inevitably the issue described at #2 occurs for at least
this package and libgl1-mesa-dri:i386 and the solution to proceed is to
delete the referenced file and continue.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to krb5 in Ubuntu.
https://bugs.launchpad.net/bugs/1884366

Title:
  package libkrb5-3 1.16-2build1 failed to install/upgrade: unable to
  make backup link of './usr/lib/i386-linux-gnu/libkrb5.so.3.3' before
  installing new version: Input/output error

Status in krb5 package in Ubuntu:
  Invalid

Bug description:
  Unable to update or upgrade libkrb5-3:i386 at 18.04 i386

  $ sudo apt install libkrb5-3:i386
  Reading package lists... Done
  Building dependency tree   
  Reading state information... Done
  The following additional packages will be installed:
libgssapi-krb5-2 libkrb5support0
  Suggested packages:
krb5-doc krb5-user
  The following packages will be upgraded:
libgssapi-krb5-2 libkrb5-3 libkrb5support0
  3 upgraded, 0 newly installed, 0 to remove and 723 not upgraded.
  Need to get 467 kB of archives.
  After this operation, 0 B of additional disk space will be used.
  Do you want to continue? [Y/n] 
  Get:1 http://security.ubuntu.com/ubuntu bionic-security/main i386 
libkrb5support0 i386 1.16-2ubuntu0.1 [32.5 kB]
  Get:2 http://security.ubuntu.com/ubuntu bionic-security/main i386 
libgssapi-krb5-2 i386 1.16-2ubuntu0.1 [132 kB]
  Get:3 http://security.ubuntu.com/ubuntu bionic-security/main i386 libkrb5-3 
i386 1.16-2ubuntu0.1 [303 kB]
  Fetched 467 kB in 2s (300 kB/s)
  (Reading database ... 250947 files and directories currently installed.)
  Preparing to unpack .../libkrb5support0_1.16-2ubuntu0.1_i386.deb ...
  Unpacking libkrb5support0:i386 (1.16-2ubuntu0.1) over (1.16-2build1) ...
  Preparing to unpack .../libgssapi-krb5-2_1.16-2ubuntu0.1_i386.deb ...
  Unpacking libgssapi-krb5-2:i386 (1.16-2ubuntu0.1) over (1.16-2build1) ...
  Preparing to unpack .../libkrb5-3_1.16-2ubuntu0.1_i386.deb ...
  Unpacking libkrb5-3:i386 (1.16-2ubuntu0.1) over (1.16-2build1) ...
  dpkg: error processing archive 
/var/cache/apt/archives/libkrb5-3_1.16-2ubuntu0.1_i386.deb (--unpack):
   unable to make backup link of './usr/lib/i386-linux-gnu/libkrb5.so.3.3' 
before installing new version: Input/output error
  Errors were encountered while processing:
   /var/cache/apt/archives/libkrb5-3_1.16-2ubuntu0.1_i386.deb
  E: Sub-process /usr/bin/dpkg returned an error code (1)

  ProblemType: Package
  DistroRelease: Ubuntu 18.04
  Package: libkrb5-3 1.16-2build1
  ProcVersionSignature: Ubuntu 4.15.0-20.21-lowlatency 4.15.17
  Uname: Linux 4.15.0-20-lowlatency i686
  ApportVersion: 2.20.9-0ubuntu7
  AptOrdering:
   libkrb5support0:i386: Install
   libgssapi-krb5-2:i386: Install
   libkrb5-3:i386: Install
   NULL: ConfigurePending
  Architecture: i386
  CasperVersion: 1.394
  Date: Sat Jun 20 13:02:48 2020
  ErrorMessage: unable to make backup link of 
'./usr/lib/i386-linux-gnu/libkrb5.so.3.3' before installing new version: 
Input/output error
  LiveMediaBuild: Ubuntu-Studio 18.04 LTS "Bionic Beaver" - Release i386 
(20180426)
  Python3Details: /usr/bin/python3.6, Python 3.6.5, python3-minimal, 3.6.5-3
  PythonDetails: /usr/bin/python2.7, Python 2.7.15rc1, python-minimal, 
2.7.15~rc1-1
  RelatedPackageVersions:
   dpkg 1.19.0.5ubuntu2
   apt  1.6.1
  SourcePackage: krb5
  Title: package libkrb5-3 1.16-2build1 failed to install/upgrade: unable to 
make backup link of './usr/lib/i386-linux-gnu/libkrb5.so.3.3' before installing 
new version: Input/output error
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/krb5/+bug/1884366/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1883297] Re: dh-python's autopkg tests fail with python3.8 as the only supported python3 version

2020-06-22 Thread Launchpad Bug Tracker
This bug was fixed in the package dh-python - 4.20200315ubuntu1

---
dh-python (4.20200315ubuntu1) groovy; urgency=medium

  * Fix autopkgtests (Closes: #956190) (LP: #1883297)
- Cherry-pick upstream commit that isn't released in Debian yet
  (https://salsa.debian.org/python-team/tools/dh-python/-/commit/e289c25)
- Disable the Python2 tests (tests/Makefile) as was done in version
  4.20191017ubuntu4 in focal

 -- Olivier Tilloy   Fri, 19 Jun 2020
19:18:12 +0200

** Changed in: dh-python (Ubuntu)
   Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to dh-python in Ubuntu.
https://bugs.launchpad.net/bugs/1883297

Title:
  dh-python's autopkg tests fail with python3.8 as the only supported
  python3 version

Status in dh-python package in Ubuntu:
  Fix Released
Status in dh-python package in Debian:
  New

Bug description:
  Imported from Debian bug http://bugs.debian.org/956190:

  Package: dh-python
  Version: 4.20200315
  Severity: serious
  Tags: sid bullseye

  dh-python's autopkg tests fail with python3.8 as the only supported
  python3 version.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dh-python/+bug/1883297/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884326] Re: SRU the current 2.48.7 stable update

2020-06-22 Thread Sebastien Bacher
** Changed in: librsvg (Ubuntu Focal)
   Status: In Progress => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to librsvg in Ubuntu.
https://bugs.launchpad.net/bugs/1884326

Title:
  SRU the current 2.48.7 stable update

Status in librsvg package in Ubuntu:
  Fix Released
Status in librsvg source package in Focal:
  Fix Committed

Bug description:
  * Impact
  That's the current GNOME stable update, which fixes a number of issues: 
https://gitlab.gnome.org/GNOME/librsvg/-/blob/librsvg-2.48/NEWS

  * Test case

  The update is part of GNOME stable updates
  https://wiki.ubuntu.com/StableReleaseUpdates/GNOME

  Smoke testing by opening SVG images with eog or importing them with
  gimp can be performed to ensure there are no regressions.

  * Regression potential

  This is a bugfix-only stable micro-release, however librsvg is a core
  component with a number of reverse dependencies. A combination of
  autopkgtests and manual smoke testing to try and detect SVG rendering
  issues should be performed.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/librsvg/+bug/1884326/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1840592] Re: systemd-backlight does not save and restore brightness for nvidia display

2020-06-22 Thread Bump
@ayush-akarsh try this command to get and set backlight. Works for me on
nvidia.

xbacklight -get
xbacklight -set 40

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1840592

Title:
  systemd-backlight does not save and restore brightness for nvidia
  display

Status in nvidia-graphics-drivers package in Ubuntu:
  Confirmed
Status in nvidia-graphics-drivers-418 package in Ubuntu:
  Confirmed
Status in nvidia-settings package in Ubuntu:
  Confirmed
Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  Running nvidia gtx 1080 graphics card, with proprietary nvidia drivers
  on ubuntu 19.04. I can change screen brightness from 0% to 100% in 5%
  steps. However, after a reboot or after a shutdown, brightness level
  reverts to 100%. Please fix to is "remembers" the current brightness
  value at shutdown time, like in does Windows.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/1840592/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884535] Re: package network-manager 1.22.10-1ubuntu2.1 failed to install/upgrade: package is in a very bad inconsistent state; you should reinstall it before attempting configu

2020-06-22 Thread Apport retracing service
** Tags removed: need-duplicate-check

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1884535

Title:
  package network-manager 1.22.10-1ubuntu2.1 failed to install/upgrade:
  package is in a very bad inconsistent state; you should  reinstall it
  before attempting configuration

Status in network-manager package in Ubuntu:
  New

Bug description:
  20.04 LTS

  ProblemType: Package
  DistroRelease: Ubuntu 20.04
  Package: network-manager 1.22.10-1ubuntu2.1
  ProcVersionSignature: Ubuntu 5.4.0-37.41-generic 5.4.41
  Uname: Linux 5.4.0-37-generic x86_64
  NonfreeKernelModules: wl
  ApportVersion: 2.20.11-0ubuntu27.3
  AptOrdering:
   libnm0:amd64: Install
   NULL: ConfigurePending
  Architecture: amd64
  CasperMD5CheckResult: skip
  Date: Mon Jun 22 13:46:13 2020
  DuplicateSignature:
   package:network-manager:1.22.10-1ubuntu2.1
   Setting up libnm0:amd64 (1.22.10-1ubuntu2.1) ...
   dpkg: error processing package network-manager (--configure):
package is in a very bad inconsistent state; you should
  ErrorMessage: package is in a very bad inconsistent state; you should  
reinstall it before attempting configuration
  InstallationDate: Installed on 2020-06-22 (0 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  IpRoute:
   default via 192.168.0.1 dev wlp2s0 proto dhcp metric 600 
   169.254.0.0/16 dev wlp2s0 scope link metric 1000 
   192.168.0.0/24 dev wlp2s0 proto kernel scope link src 192.168.0.23 metric 600
  NetworkManager.state:
   [main]
   NetworkingEnabled=true
   WirelessEnabled=true
   WWANEnabled=true
  Python3Details: /usr/bin/python3.8, Python 3.8.2, python3-minimal, 
3.8.2-0ubuntu2
  PythonDetails: N/A
  RelatedPackageVersions:
   dpkg 1.19.7ubuntu3
   apt  2.0.2ubuntu0.1
  SourcePackage: network-manager
  Title: package network-manager 1.22.10-1ubuntu2.1 failed to install/upgrade: 
package is in a very bad inconsistent state; you should  reinstall it before 
attempting configuration
  UpgradeStatus: No upgrade log present (probably fresh install)
  nmcli-dev:
   DEVICE  TYPE  STATEIP4-CONNECTIVITY  IP6-CONNECTIVITY  DBUS-PATH 
 CONNECTION  CON-UUID   
   CON-PATH   
   wlp2s0  wifi  connectedfull  limited   
/org/freedesktop/NetworkManager/Devices/3  VM6807780   
8d657f17-f51d-480d-8ae2-241c4030a964  
/org/freedesktop/NetworkManager/ActiveConnection/1 
   enp3s0  ethernet  unavailable  none  none  
/org/freedesktop/NetworkManager/Devices/2  --  --   
 -- 
   lo  loopback  unmanagedunknown   unknown   
/org/freedesktop/NetworkManager/Devices/1  --  --   
 --
  nmcli-nm:
   RUNNING  VERSION  STATE  STARTUP  CONNECTIVITY  NETWORKING  WIFI-HW  
WIFI WWAN-HW  WWAN
   running  1.22.10  connected  started  full  enabled enabled  
enabled  enabled  enabled

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1884535/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884535] [NEW] package network-manager 1.22.10-1ubuntu2.1 failed to install/upgrade: package is in a very bad inconsistent state; you should reinstall it before attempting confi

2020-06-22 Thread B Williams
Public bug reported:

20.04 LTS

ProblemType: Package
DistroRelease: Ubuntu 20.04
Package: network-manager 1.22.10-1ubuntu2.1
ProcVersionSignature: Ubuntu 5.4.0-37.41-generic 5.4.41
Uname: Linux 5.4.0-37-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20.11-0ubuntu27.3
AptOrdering:
 libnm0:amd64: Install
 NULL: ConfigurePending
Architecture: amd64
CasperMD5CheckResult: skip
Date: Mon Jun 22 13:46:13 2020
DuplicateSignature:
 package:network-manager:1.22.10-1ubuntu2.1
 Setting up libnm0:amd64 (1.22.10-1ubuntu2.1) ...
 dpkg: error processing package network-manager (--configure):
  package is in a very bad inconsistent state; you should
ErrorMessage: package is in a very bad inconsistent state; you should  
reinstall it before attempting configuration
InstallationDate: Installed on 2020-06-22 (0 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
IpRoute:
 default via 192.168.0.1 dev wlp2s0 proto dhcp metric 600 
 169.254.0.0/16 dev wlp2s0 scope link metric 1000 
 192.168.0.0/24 dev wlp2s0 proto kernel scope link src 192.168.0.23 metric 600
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
Python3Details: /usr/bin/python3.8, Python 3.8.2, python3-minimal, 
3.8.2-0ubuntu2
PythonDetails: N/A
RelatedPackageVersions:
 dpkg 1.19.7ubuntu3
 apt  2.0.2ubuntu0.1
SourcePackage: network-manager
Title: package network-manager 1.22.10-1ubuntu2.1 failed to install/upgrade: 
package is in a very bad inconsistent state; you should  reinstall it before 
attempting configuration
UpgradeStatus: No upgrade log present (probably fresh install)
nmcli-dev:
 DEVICE  TYPE  STATEIP4-CONNECTIVITY  IP6-CONNECTIVITY  DBUS-PATH   
   CONNECTION  CON-UUID 
 CON-PATH   
 wlp2s0  wifi  connectedfull  limited   
/org/freedesktop/NetworkManager/Devices/3  VM6807780   
8d657f17-f51d-480d-8ae2-241c4030a964  
/org/freedesktop/NetworkManager/ActiveConnection/1 
 enp3s0  ethernet  unavailable  none  none  
/org/freedesktop/NetworkManager/Devices/2  --  --   
 -- 
 lo  loopback  unmanagedunknown   unknown   
/org/freedesktop/NetworkManager/Devices/1  --  --   
 --
nmcli-nm:
 RUNNING  VERSION  STATE  STARTUP  CONNECTIVITY  NETWORKING  WIFI-HW  WIFI  
   WWAN-HW  WWAN
 running  1.22.10  connected  started  full  enabled enabled  
enabled  enabled  enabled

** Affects: network-manager (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package focal need-duplicate-check

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1884535

Title:
  package network-manager 1.22.10-1ubuntu2.1 failed to install/upgrade:
  package is in a very bad inconsistent state; you should  reinstall it
  before attempting configuration

Status in network-manager package in Ubuntu:
  New

Bug description:
  20.04 LTS

  ProblemType: Package
  DistroRelease: Ubuntu 20.04
  Package: network-manager 1.22.10-1ubuntu2.1
  ProcVersionSignature: Ubuntu 5.4.0-37.41-generic 5.4.41
  Uname: Linux 5.4.0-37-generic x86_64
  NonfreeKernelModules: wl
  ApportVersion: 2.20.11-0ubuntu27.3
  AptOrdering:
   libnm0:amd64: Install
   NULL: ConfigurePending
  Architecture: amd64
  CasperMD5CheckResult: skip
  Date: Mon Jun 22 13:46:13 2020
  DuplicateSignature:
   package:network-manager:1.22.10-1ubuntu2.1
   Setting up libnm0:amd64 (1.22.10-1ubuntu2.1) ...
   dpkg: error processing package network-manager (--configure):
package is in a very bad inconsistent state; you should
  ErrorMessage: package is in a very bad inconsistent state; you should  
reinstall it before attempting configuration
  InstallationDate: Installed on 2020-06-22 (0 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  IpRoute:
   default via 192.168.0.1 dev wlp2s0 proto dhcp metric 600 
   169.254.0.0/16 dev wlp2s0 scope link metric 1000 
   192.168.0.0/24 dev wlp2s0 proto kernel scope link src 192.168.0.23 metric 600
  NetworkManager.state:
   [main]
   NetworkingEnabled=true
   WirelessEnabled=true
   WWANEnabled=true
  Python3Details: /usr/bin/python3.8, Python 3.8.2, python3-minimal, 
3.8.2-0ubuntu2
  PythonDetails: N/A
  RelatedPackageVersions:
   dpkg 1.19.7ubuntu3
   apt  2.0.2ubuntu0.1
  SourcePackage: network-manager
  Title: package network-manager 1.22.10-1ubuntu2.1 failed to install/upgrade: 
package is in a very bad inconsistent state; you should  reinstall it before 
attempting configuration
  UpgradeStatus: No upgrade log present (probably fresh install)
  nmcli-dev:
   DEVICE  TYPE  STATE

[Touch-packages] [Bug 1764044] Re: ssh-add asks about passphrases for keys already unlocked in the keychain

2020-06-22 Thread Sergio Durigan Junior
Thank you for following up with this.

It seems like an interesting bug to consider, but it appears to be low
priority, so I am marking it as such.

On a side note, I would like to point out that these kind of bugs are
usually better dealt with by upstream, so I would recommend you to file
a report against them.  If you do so, please let us know the link to the
bug so that we can keep track of the progress.

Thank you!

** Changed in: openssh (Ubuntu)
   Importance: Undecided => Low

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssh in Ubuntu.
https://bugs.launchpad.net/bugs/1764044

Title:
  ssh-add asks about passphrases for keys already unlocked in the
  keychain

Status in openssh package in Ubuntu:
  New

Bug description:
  In the below example, on the second invocation of ssh-add I should not
  be prompted to enter the passphrase again after I successfully entered
  it on the first instance.  This used to work fine in trusty i386
  setup.

  $ keychain && ssh-add

   * keychain 2.8.2 ~ http://www.funtoo.org
   * Starting ssh-agent...

  Enter passphrase for /home/rolf/.ssh/id_rsa:
  Identity added: /home/rolf/.ssh/id_rsa (/home/rolf/.ssh/id_rsa)
  Enter passphrase for /home/rolf/.ssh/id_dsa:
  Identity added: /home/rolf/.ssh/id_dsa (/home/rolf/.ssh/id_dsa)

  $ keychain && ssh-add

   * keychain 2.8.2 ~ http://www.funtoo.org
   * Found existing ssh-agent: 25744

  Enter passphrase for /home/rolf/.ssh/id_rsa:
  Identity added: /home/rolf/.ssh/id_rsa (/home/rolf/.ssh/id_rsa)
  Enter passphrase for /home/rolf/.ssh/id_dsa:
  Identity added: /home/rolf/.ssh/id_dsa (/home/rolf/.ssh/id_dsa)

  gnome-keyring is running:
  $ ps -ax|grep key
   2067 ?SLl0:05 /usr/bin/gnome-keyring-daemon --start --components 
ssh
   2078 ?Ssl0:01 
/usr/lib/x86_64-linux-gnu/indicator-keyboard/indicator-keyboard-service 
--use-gtk
   6987 ?S  0:00 /usr/bin/ssh-agent -D -a 
/run/user/1000/keyring/.ssh
  17832 pts/2S+ 0:00 grep --color=auto key

  ssh-agent is running:
  $ ps aux | grep ssh-agent
  leggewie  1928  0.0  0.0  15548   340 ?Ss   02:38   0:00 
/usr/bin/ssh-agent /usr/bin/im-launch env LD_PRELOAD=libgtk3-nocsd.so.0 
/usr/lib/gnome-session/run-systemd-session unity-session.target
  leggewie  6987  0.0  0.0  11304  1484 ?S02:50   0:00 
/usr/bin/ssh-agent -D -a /run/user/1000/keyring/.ssh
  leggewie  9952  0.0  0.0  11304   320 ?Ss   04:11   0:00 ssh-agent 
bash
  leggewie 17850  0.0  0.0  14492  1160 pts/2S+   06:06   0:00 grep 
--color=auto ssh-agent

  $ env|grep SSH
  SSH_AUTH_SOCK=/tmp/ssh-W6fuGBztRRds/agent.6992
  SSH_AGENT_PID=9952
  SSH_AGENT_LAUNCHER=gnome-keyring

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1764044/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884366] Re: package libkrb5-3 1.16-2build1 failed to install/upgrade: unable to make backup link of './usr/lib/i386-linux-gnu/libkrb5.so.3.3' before installing new version: Inpu

2020-06-22 Thread Andreas Hasenack
Your dmesg is full of errors like these:
[   19.583604] SQUASHFS error: zlib decompression failed, data probably corrupt
[   19.583608] SQUASHFS error: squashfs_read_data failed to read block 
0x8116e5ed
[   19.583610] SQUASHFS error: Unable to read fragment cache entry [8116e5ed]

Are you running from a cdrom/flash drive?
 /cow 8250080 1226092   7023988  15% /

In any case, this is filesystem corruption, or bad disk/cdrom, and not a
bug in the krb5 package.

** Changed in: krb5 (Ubuntu)
   Status: New => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to krb5 in Ubuntu.
https://bugs.launchpad.net/bugs/1884366

Title:
  package libkrb5-3 1.16-2build1 failed to install/upgrade: unable to
  make backup link of './usr/lib/i386-linux-gnu/libkrb5.so.3.3' before
  installing new version: Input/output error

Status in krb5 package in Ubuntu:
  Invalid

Bug description:
  Unable to update or upgrade libkrb5-3:i386 at 18.04 i386

  $ sudo apt install libkrb5-3:i386
  Reading package lists... Done
  Building dependency tree   
  Reading state information... Done
  The following additional packages will be installed:
libgssapi-krb5-2 libkrb5support0
  Suggested packages:
krb5-doc krb5-user
  The following packages will be upgraded:
libgssapi-krb5-2 libkrb5-3 libkrb5support0
  3 upgraded, 0 newly installed, 0 to remove and 723 not upgraded.
  Need to get 467 kB of archives.
  After this operation, 0 B of additional disk space will be used.
  Do you want to continue? [Y/n] 
  Get:1 http://security.ubuntu.com/ubuntu bionic-security/main i386 
libkrb5support0 i386 1.16-2ubuntu0.1 [32.5 kB]
  Get:2 http://security.ubuntu.com/ubuntu bionic-security/main i386 
libgssapi-krb5-2 i386 1.16-2ubuntu0.1 [132 kB]
  Get:3 http://security.ubuntu.com/ubuntu bionic-security/main i386 libkrb5-3 
i386 1.16-2ubuntu0.1 [303 kB]
  Fetched 467 kB in 2s (300 kB/s)
  (Reading database ... 250947 files and directories currently installed.)
  Preparing to unpack .../libkrb5support0_1.16-2ubuntu0.1_i386.deb ...
  Unpacking libkrb5support0:i386 (1.16-2ubuntu0.1) over (1.16-2build1) ...
  Preparing to unpack .../libgssapi-krb5-2_1.16-2ubuntu0.1_i386.deb ...
  Unpacking libgssapi-krb5-2:i386 (1.16-2ubuntu0.1) over (1.16-2build1) ...
  Preparing to unpack .../libkrb5-3_1.16-2ubuntu0.1_i386.deb ...
  Unpacking libkrb5-3:i386 (1.16-2ubuntu0.1) over (1.16-2build1) ...
  dpkg: error processing archive 
/var/cache/apt/archives/libkrb5-3_1.16-2ubuntu0.1_i386.deb (--unpack):
   unable to make backup link of './usr/lib/i386-linux-gnu/libkrb5.so.3.3' 
before installing new version: Input/output error
  Errors were encountered while processing:
   /var/cache/apt/archives/libkrb5-3_1.16-2ubuntu0.1_i386.deb
  E: Sub-process /usr/bin/dpkg returned an error code (1)

  ProblemType: Package
  DistroRelease: Ubuntu 18.04
  Package: libkrb5-3 1.16-2build1
  ProcVersionSignature: Ubuntu 4.15.0-20.21-lowlatency 4.15.17
  Uname: Linux 4.15.0-20-lowlatency i686
  ApportVersion: 2.20.9-0ubuntu7
  AptOrdering:
   libkrb5support0:i386: Install
   libgssapi-krb5-2:i386: Install
   libkrb5-3:i386: Install
   NULL: ConfigurePending
  Architecture: i386
  CasperVersion: 1.394
  Date: Sat Jun 20 13:02:48 2020
  ErrorMessage: unable to make backup link of 
'./usr/lib/i386-linux-gnu/libkrb5.so.3.3' before installing new version: 
Input/output error
  LiveMediaBuild: Ubuntu-Studio 18.04 LTS "Bionic Beaver" - Release i386 
(20180426)
  Python3Details: /usr/bin/python3.6, Python 3.6.5, python3-minimal, 3.6.5-3
  PythonDetails: /usr/bin/python2.7, Python 2.7.15rc1, python-minimal, 
2.7.15~rc1-1
  RelatedPackageVersions:
   dpkg 1.19.0.5ubuntu2
   apt  1.6.1
  SourcePackage: krb5
  Title: package libkrb5-3 1.16-2build1 failed to install/upgrade: unable to 
make backup link of './usr/lib/i386-linux-gnu/libkrb5.so.3.3' before installing 
new version: Input/output error
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/krb5/+bug/1884366/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1883027] Re: dump_acpi_tables.py: fix incorrect output and change format

2020-06-22 Thread Anthony Wong
** Also affects: apport (Ubuntu Groovy)
   Importance: Undecided
   Status: New

** Also affects: apport (Ubuntu Focal)
   Importance: Undecided
   Status: New

** Changed in: apport (Ubuntu Focal)
   Status: New => Triaged

** Changed in: apport (Ubuntu Focal)
   Status: Triaged => Confirmed

** Changed in: apport (Ubuntu Groovy)
   Status: New => Confirmed

** Changed in: apport
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apport in Ubuntu.
https://bugs.launchpad.net/bugs/1883027

Title:
  dump_acpi_tables.py: fix incorrect output and change format

Status in Apport:
  Confirmed
Status in apport package in Ubuntu:
  Confirmed
Status in apport source package in Focal:
  Confirmed
Status in apport source package in Groovy:
  Confirmed

Bug description:
  dump_acpi_tables.py generates log files that is similar as the output
  from "acpidump" in acpica-tools. The output can be passed to other
  utilities in acpica-tools and fwts.

  It, however, has some subtle differences and some errors.

  Summary:

  1. ACPI tables have 4-char signatures - meaning SSDT's are SSDT, not
  SSDT1, SSDT2 and so on. Each table is unique by its table ID.

  Original:
    SSDT1, SSDT2, SSDT3 ...

  Changed:
    SSDT, SSDT, SSDT ...

  2. (Minor) acpidump outputs are all in upper cases

  3. (Minor) acpidump offset are aligned by data, not address

  Original:
    FFF0: 53 41 56 43 52 44 43 41 4E 43 52 4E 72 4E 50 4D  SAVCRDCANCRNrNPM
    1: 56 0A 04 00 0C FC FF FF FF 0A 03 0A 03 52 44 43  VRDC

  Changed:
  FFF0: 53 41 56 43 52 44 43 41 4E 43 52 4E 72 4E 50 4D  SAVCRDCANCRNrNPM
     1: 56 0A 04 00 0C FC FF FF FF 0A 03 0A 03 52 44 43  VRDC

  4. (Bug) dump_acpi_tables.py generates an extra line when data sizes
  are multiple of 16 bytes

  Original:
  05F0: 30 30 0B 00 08 00 A4 48 50 53 44 A4 53 50 53 44  00.HPSD.SPSD
  05F0: 30 30 0B 00 08 00 A4 48 50 53 44 A4 53 50 53 44 
 00.HPSD.SPSD

  Corrected:
  05F0: 30 30 0B 00 08 00 A4 48 50 53 44 A4 53 50 53 44  00.HPSD.SPSD

  5. (Bug) dump_acpi_tables.py misses an line when data sizes are
  multiple of 15 bytes

  Original:
  07E0: 42 0A 87 5C 2F 03 5F 53 42 5F 55 42 54 43 43 43  B..\/._SB_UBTCCC

  Corrected:
  07E0: 42 0A 87 5C 2F 03 5F 53 42 5F 55 42 54 43 43 43  B..\/._SB_UBTCCC
  07F0: 49 33 86 5C 2E 5F 53 42 5F 55 42 54 43 0A 80 I3.\._SB_UBTC..

To manage notifications about this bug go to:
https://bugs.launchpad.net/apport/+bug/1883027/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1861177] Re: seccomp_rule_add is very slow

2020-06-22 Thread Ioanna Alifieraki
Debdiff for Groovy.

Currently, there is an ongoing sru of libseccomp for F,E,B and X stuck in 
proposed.
Once it is released in updates, I'll sru this one for F,E,B and X. 

** Description changed:

- There is a known and patched issue with version 2.4 of libseccomp where
- certain operations have a large performance regression. This is causing
- some packages that use libseccomp such as container orchestration
- systems to occasionally time out or otherwise fail under certain
- workloads.
+ [IMPACT]
+ There is a known and patched issue with version 2.4 of libseccomp where 
certain operations have a large performance regression. This is causing some 
packages that use libseccomp such as container orchestration systems to 
occasionally time out or otherwise fail under certain workloads.
  
  Please consider porting the patch into the various Ubuntu versions that
  have version 2.4 of libseccomp and into the backports. The performance
  patch from version 2.5 (yet to be released) applies cleanly on top of
  the 2.4 branch of libseccomp.
  
  For more information, and for a copy of the patch (which can also be
  cherry picked from the upstream libseccomp repos) see the similar Debian
  issue: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=943913
+ 
+ Upstream issue : https://github.com/seccomp/libseccomp/issues/153
+ Upstream fix : https://github.com/seccomp/libseccomp/pull/180/
+ 
+ [Test Case]
+ 
+ For this test case we use Docker on Ubuntu Groovy (20.10) :
+ 
+ --> Current libseccomp version
+ #dpkg -l | grep libseccomp
+ ii  libseccomp2:amd64  2.4.3-1ubuntu3 
 amd64high level interface to Linux seccomp filter
+ 
+ ## pull ubuntu image
+ # docker pull ubuntu
+ ## create a container
+ # docker run --name test_seccomp -it 74435f89ab78 /bin/bash
+ 
+ ## run test case
+ # for i in `seq 1 40`; do (time sudo docker exec test_seccomp true &); done
+ ...
+ MAX TIME :
+ real  0m10,319s
+ user  0m0,018s
+ sys   0m0,033s
+ 
+ 
+ --> Patched libseccomp version
+ 
+ # dpkg -l | grep libseccomp
+ ii  libseccomp2:amd64  2.4.3-1ubuntu4 
 amd64high level interface to Linux seccomp filter
+ 
+ # docker start test_seccomp
+ ## run test case
+ # for i in `seq 1 40`; do (time sudo docker exec test_seccomp true &); done
+ ...
+ MAX TIME :
+ real  0m3,650s
+ user  0m0,025s
+ sys   0m0,028s
+ 
+ [Regression Potential]
+ 
+ The first of the 2 patches cleans up the code that adds rules to a
+ single filter without changing the logic of the code. The second patch
+ introduces the idea of shadow transactions. On a successful transaction
+ commit the old transaction checkpoint is preserved and is brought up to
+ date with the current filter. The next time a new transaction starts, it
+ checks is the a shadow transaction exist and if so the shadow is used
+ instead of creating a new checkpoint from scratch [1]. This is the patch
+ that mitigates the performance regression. Any potential regression will
+ involve the parts of the code that add rules to filters and/or the code
+ that creates and checks the shadow transactions.
+ 
+ 
+ [Other]
+ 
+ Affected releases : Groovy, Focal, Eoan, Bionic, Xenial.
+ 
+ [1]
+ 
https://github.com/seccomp/libseccomp/pull/180/commits/bc3a6c0453b0350ee43e4925482f705a2fbf5a4d

** Patch added: "lp1861177_groovy.debdiff"
   
https://bugs.launchpad.net/ubuntu/+source/libseccomp/+bug/1861177/+attachment/5386079/+files/lp1861177_groovy.debdiff

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libseccomp in Ubuntu.
https://bugs.launchpad.net/bugs/1861177

Title:
  seccomp_rule_add is very slow

Status in snapd:
  Invalid
Status in libseccomp package in Ubuntu:
  In Progress
Status in libseccomp source package in Xenial:
  In Progress
Status in libseccomp source package in Bionic:
  In Progress
Status in libseccomp source package in Eoan:
  In Progress
Status in libseccomp source package in Focal:
  In Progress
Status in libseccomp source package in Groovy:
  In Progress

Bug description:
  [IMPACT]
  There is a known and patched issue with version 2.4 of libseccomp where 
certain operations have a large performance regression. This is causing some 
packages that use libseccomp such as container orchestration systems to 
occasionally time out or otherwise fail under certain workloads.

  Please consider porting the patch into the various Ubuntu versions
  that have version 2.4 of libseccomp and into the backports. The
  performance patch from version 2.5 (yet to be released) applies
  cleanly on top of the 2.4 branch of libseccomp.

  For more information, and for a copy of the patch (which can also be
  cherry picked from the upstream libseccomp repos) see the similar
  Debian issue: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=943913

  Upstream issue : https://github.com/seccomp/libseccomp/issues/153
  Upstream fix : 

[Touch-packages] [Bug 1884336] Re: Erratic ethernet connectivity and icon

2020-06-22 Thread Sebastien Bacher
Thank you for your bug report, could you add your 'journalctl -b 0'
after seeing the issue?

** Changed in: network-manager (Ubuntu)
   Importance: Undecided => Low

** Changed in: network-manager (Ubuntu)
   Status: New => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1884336

Title:
  Erratic ethernet connectivity and icon

Status in network-manager package in Ubuntu:
  Incomplete

Bug description:
  Ubuntu 18.04.4 LTS

  Installed: 1.10.6-2ubuntu1.4
Candidate: 1.10.6-2ubuntu1.4
Version table:
   *** 1.10.6-2ubuntu1.4 500

  Expected behavior is a stable high-speed internet connection when usb
  tethering with an Android phone.

  Instead, for the past three months, since covid slowed down internet
  connectivity on Jio telecom in India, my Ubuntu internet connectivity
  has become erratic.  In the early morning before 6 AM when I tether an
  Android phone to my laptop the internet connectivity indicator in the
  upper right-hand corner of the desktop shows the normal three boxes in
  a triangle and has decent speed.  As network traffic increases the
  indicator turns to three gray boxes with a question mark in the middle
  and connectivity speed remains decent for a few websites, such as
  YouTube, Google Search and some others, but connectivity stops for
  most websites.  Chromium, Vivaldi and Firefox browsers show the
  following error for such sites: “This site can’t be reached.
  askubuntu.com’s server IP address could not be found.”

  Oddly, in tri-booted Win 10 all websites open reliably 24/7, though
  sometimes at slow speeds.  In Fedora 31 on the same hardware the
  behavior is identical to Ubuntu.  I’ve tried changing the DNS settings
  in Ubuntu to use Cloud Flare, Google and even the DNS settings in
  Windows, but to no avail.  On Ask Ubuntu there were no helpful
  comments except a suggestion to file a bug report.

  Ideally, connectivity without "unable to connect" errors on most
  websites should be available always.

  BTW, when I allowed data to be collected for this bug report it was in
  the early morning, so the connection was working properly and the
  network icon was the normal three boxes in a triangle with decent
  speed.  If need be, I can send more information later when the "unable
  to connect" errors occur from Windows 10, or via email, which always
  works.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: network-manager 1.10.6-2ubuntu1.4
  ProcVersionSignature: Ubuntu 4.15.0-106.107-generic 4.15.18
  Uname: Linux 4.15.0-106-generic x86_64
  NonfreeKernelModules: wl
  ApportVersion: 2.20.9-0ubuntu7.15
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Sat Jun 20 06:49:22 2020
  IfupdownConfig:
   # interfaces(5) file used by ifup(8) and ifdown(8)
   auto lo
   iface lo inet loopback
  InstallationDate: Installed on 2018-08-25 (664 days ago)
  InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 
(20180725)
  IpRoute:
   default via 192.168.137.129 dev enp0s20u1 proto dhcp metric 100 
   169.254.0.0/16 dev enp0s20u1 scope link metric 1000 
   192.168.137.0/24 dev enp0s20u1 proto kernel scope link src 192.168.137.9 
metric 100
  NetworkManager.state:
   [main]
   NetworkingEnabled=true
   WirelessEnabled=true
   WWANEnabled=true
  RfKill:
   0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
  SourcePackage: network-manager
  UpgradeStatus: No upgrade log present (probably fresh install)
  nmcli-dev:
   DEVICE TYPE  STATE DBUS-PATH 
 CONNECTION  CON-UUID  CON-PATH 
  
   enp0s20u1  ethernet  connected /org/freedesktop/NetworkManager/Devices/4 
 Wired connection 3  d70d6035-59a6-34c1-a00a-d222c65aef1c  
/org/freedesktop/NetworkManager/ActiveConnection/1 
   wlp2s0 wifi  disconnected  /org/freedesktop/NetworkManager/Devices/3 
 --  ----   
  
   enp3s0f2   ethernet  unavailable   /org/freedesktop/NetworkManager/Devices/2 
 --  ----   
  
   lo loopback  unmanaged /org/freedesktop/NetworkManager/Devices/1 
 --  ----
  nmcli-nm:
   RUNNING  VERSION  STATE  STARTUP  CONNECTIVITY  NETWORKING  WIFI-HW  
WIFI WWAN-HW  WWAN
   running  1.10.6   connected  started  full  enabled enabled  
enabled  enabled  enabled

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1884336/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : 

[Touch-packages] [Bug 1861177] Re: seccomp_rule_add is very slow

2020-06-22 Thread Ioanna Alifieraki
** Also affects: libseccomp (Ubuntu Focal)
   Importance: Undecided
   Status: New

** Also affects: libseccomp (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Also affects: libseccomp (Ubuntu Groovy)
   Importance: Medium
   Status: In Progress

** Also affects: libseccomp (Ubuntu Bionic)
   Importance: Undecided
   Status: New

** Also affects: libseccomp (Ubuntu Eoan)
   Importance: Undecided
   Status: New

** Changed in: libseccomp (Ubuntu Focal)
   Status: New => In Progress

** Changed in: libseccomp (Ubuntu Eoan)
   Status: New => In Progress

** Changed in: libseccomp (Ubuntu Bionic)
   Status: New => In Progress

** Changed in: libseccomp (Ubuntu Xenial)
   Status: New => In Progress

** Changed in: libseccomp (Ubuntu Focal)
   Importance: Undecided => Medium

** Changed in: libseccomp (Ubuntu Eoan)
   Importance: Undecided => Medium

** Changed in: libseccomp (Ubuntu Bionic)
   Importance: Undecided => Medium

** Changed in: libseccomp (Ubuntu Xenial)
   Importance: Undecided => Medium

** Changed in: libseccomp (Ubuntu Xenial)
 Assignee: (unassigned) => Ioanna Alifieraki (joalif)

** Changed in: libseccomp (Ubuntu Bionic)
 Assignee: (unassigned) => Ioanna Alifieraki (joalif)

** Changed in: libseccomp (Ubuntu Eoan)
 Assignee: (unassigned) => Ioanna Alifieraki (joalif)

** Changed in: libseccomp (Ubuntu Focal)
 Assignee: (unassigned) => Ioanna Alifieraki (joalif)

** Changed in: libseccomp (Ubuntu Groovy)
 Assignee: (unassigned) => Ioanna Alifieraki (joalif)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libseccomp in Ubuntu.
https://bugs.launchpad.net/bugs/1861177

Title:
  seccomp_rule_add is very slow

Status in snapd:
  Invalid
Status in libseccomp package in Ubuntu:
  In Progress
Status in libseccomp source package in Xenial:
  In Progress
Status in libseccomp source package in Bionic:
  In Progress
Status in libseccomp source package in Eoan:
  In Progress
Status in libseccomp source package in Focal:
  In Progress
Status in libseccomp source package in Groovy:
  In Progress

Bug description:
  There is a known and patched issue with version 2.4 of libseccomp
  where certain operations have a large performance regression. This is
  causing some packages that use libseccomp such as container
  orchestration systems to occasionally time out or otherwise fail under
  certain workloads.

  Please consider porting the patch into the various Ubuntu versions
  that have version 2.4 of libseccomp and into the backports. The
  performance patch from version 2.5 (yet to be released) applies
  cleanly on top of the 2.4 branch of libseccomp.

  For more information, and for a copy of the patch (which can also be
  cherry picked from the upstream libseccomp repos) see the similar
  Debian issue: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=943913

To manage notifications about this bug go to:
https://bugs.launchpad.net/snapd/+bug/1861177/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884307] Re: no Montréal listed in city?

2020-06-22 Thread Sebastien Bacher
Thank you for your bug report, technically it's the same timezone, see

https://en.wikipedia.org/wiki/List_of_tz_database_time_zones where
America/Montreal is defined as an alias

that's not really a bug in tzdata and
./usr/share/zoneinfo/America/Montreal is available on disk so your
client software could display it if wanted

** Changed in: tzdata (Ubuntu)
   Status: New => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to tzdata in Ubuntu.
https://bugs.launchpad.net/bugs/1884307

Title:
  no Montréal listed in city?

Status in Ubuntu MATE:
  New
Status in tzdata package in Ubuntu:
  Incomplete

Bug description:
  It was olek @ UMC (https://ubuntu-mate.community/t/20-04-some-very-
  minor-annoyances-for-when-working-in-tty7/22142) whom suggested me to
  bug report this so why not ;)

  Why are the only 2 selectable cities from GMT-5 (Eastern) are: Toronto
  and NYC? There's also this other city called Montréal who hosts a
  whole bunch of different of people in between the two.

  Oh, and did you know that there was also a province and infrastructure
  surrounding this whole city? We better be start using it in 2020!

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-mate/+bug/1884307/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1882034] Re: cannot start X session with NIS account

2020-06-22 Thread Ketiw Simplistic
Similarly here this is not the hidepid problem: mount returns:
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1882034

Title:
  cannot start X session with NIS account

Status in systemd package in Ubuntu:
  Incomplete

Bug description:
  When login with a NIS account, X does not start, or more precisely it
  starts and exits immediately.

  Only errors in logs is:
   (EE) systemd-logind: failed to get session: PID 4335 does not belong to any 
known session

  X11/gdm login works fine with local accounts.

  SSH/terminal console login with NIS accounts works fine.

  /etc/X11/Xwrapper.config:
allowed_users=anybody

  I've seen several reports of such problems under other versions (eg
  19.10), but no working solutions was found. It seems that the problem
  is the same with lightdm.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: gdm3 3.34.1-1ubuntu1
  ProcVersionSignature: Ubuntu 5.4.0-29.33-generic 5.4.30
  Uname: Linux 5.4.0-29-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.2
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Jun  4 08:59:25 2020
  InstallationDate: Installed on 2019-11-26 (190 days ago)
  InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
  SourcePackage: gdm3
  UpgradeStatus: Upgraded to focal on 2020-04-24 (40 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1882034/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1883297] Re: dh-python's autopkg tests fail with python3.8 as the only supported python3 version

2020-06-22 Thread Sebastien Bacher
** Changed in: dh-python (Ubuntu)
   Importance: Undecided => High

** Changed in: dh-python (Ubuntu)
   Status: In Progress => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to dh-python in Ubuntu.
https://bugs.launchpad.net/bugs/1883297

Title:
  dh-python's autopkg tests fail with python3.8 as the only supported
  python3 version

Status in dh-python package in Ubuntu:
  Fix Committed
Status in dh-python package in Debian:
  New

Bug description:
  Imported from Debian bug http://bugs.debian.org/956190:

  Package: dh-python
  Version: 4.20200315
  Severity: serious
  Tags: sid bullseye

  dh-python's autopkg tests fail with python3.8 as the only supported
  python3 version.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dh-python/+bug/1883297/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1854403] Re: Need updated libimobiledevice and dependencies to access iOS 13 devices

2020-06-22 Thread Sebastien Bacher
@Philip, thanks, I guess my question was not specific enough, let's me
rephrase 'any idea if rebuilding focal with f56a65f included and openssl
is enough or do we need other changes/updates to have a working stack
there?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libimobiledevice in
Ubuntu.
https://bugs.launchpad.net/bugs/1854403

Title:
  Need updated libimobiledevice and dependencies to access iOS 13
  devices

Status in libimobiledevice package in Ubuntu:
  Fix Released
Status in libplist package in Ubuntu:
  Fix Released
Status in libusbmuxd package in Ubuntu:
  Fix Released
Status in usbmuxd package in Ubuntu:
  Confirmed

Bug description:
  iOS 13 devices require updated libimobiledevice, libusbmuxd and
  usbmuxd to work correctly. Without the updates, the device appears to
  be accessible but it's impossible to copy files to the devices.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libimobiledevice/+bug/1854403/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1876055] Re: SRU: Backport 2.4.3-1ubuntu3 from groovy to focal/eoan/bionic/xenial for newer syscalls for core20 base and test suite robustness

2020-06-22 Thread Łukasz Zemczak
Thanks for the info! Another question in this case: since this bugfix is
verified, does this mean the packages currently in -proposed are good to
be released? I wouldn't want to release a package that isn't 'ready' by
accident.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1876055

Title:
  SRU: Backport 2.4.3-1ubuntu3 from groovy to focal/eoan/bionic/xenial
  for newer syscalls for core20 base and test suite robustness

Status in libseccomp package in Ubuntu:
  Fix Released
Status in systemd package in Ubuntu:
  New
Status in libseccomp source package in Xenial:
  Fix Committed
Status in libseccomp source package in Bionic:
  Fix Committed
Status in libseccomp source package in Eoan:
  Fix Committed
Status in systemd source package in Eoan:
  New
Status in libseccomp source package in Focal:
  Fix Committed
Status in libseccomp source package in Groovy:
  Fix Released

Bug description:
  [Impact]

  The combination of snap-confine and snap-seccomp from snapd uses
  libseccomp to filter various system calls for confinement. The current
  version in eoan/bionic/xenial (2.4.1) is missing knowledge of various
  system calls for various architectures. As such this causes strange
  issues like python snaps segfaulting
  (https://github.com/snapcore/core20/issues/48) or the inadvertent
  denial of system calls which should be permitted by the base policy
  (https://forum.snapcraft.io/t/getrlimit-blocked-by-seccomp-on-focal-
  arm64/17237).

  libseccomp in groovy is using the latest upstream base release (2.4.3)
  plus it includes a patch to add some missing aarch64 system calls
  (https://bugs.launchpad.net/ubuntu/+source/libseccomp/+bug/1877633).

  SRUing this version back to older stable releases allows libseccomp to
  operate correctly on all supported architectures.

  
  Included as part of this SRU are test-suite reliability improvements - 
currently the xenial libseccomp package overrides test-suite failures at build 
time to ignore failures. This masks the fact that on ppc64el and s390x there 
are currently test suite failures at build time for xenial - these failures 
occur since libseccomp now includes knowledge of system calls for these 
architectures but which the linux-libc-dev package for xenial does not actually 
define (since this is based of the 4.4 kernel in xenial whereas libseccomp 
2.4.1 in xenial has knowledge of all system calls up to 5.4). 

  In this SRU I have instead fixed the test suite failures for xenial by
  including a local (test-suite specific) set of architecture specific
  kernel headers from the linux-libc-dev in focal for all releases.
  These are just the headers which define the system call numbers for
  each architecture *and* these are added to tests/include/$ARCH in the
  source package (and tests/Makefile.am is then updated to include these
  new headers only).  As such this ensures the actual build of
  libseccomp or any of the tools does not reference these headers. This
  allows the test suite in libseccomp to then be aware of theses system
  calls and so all unit tests for all architectures now pass.

  In any future updates for libseccomp to add new system calls, we can
  then similarly update these local headers to ensure the unit tests
  continue to work as expected.

  
  [Test Case]

  libseccomp includes a significant unit test suite that is run during
  the build and as part of autopkgtests. To verify the new aarch64
  system calls are resolved as expected the scmp_sys_resolver command
  can be used as well:

  $ scmp_sys_resolver -a aarch64 getrlimit
  163

  (whereas in the current version in focal this returns -10180 as
  libseccomp was not aware of this system-call at compile-time).

  As part of this SRU, the test suite in libseccomp has been patched to
  include a local copy of the architecture-specific kernel headers from
  the 5.4 kernel in focal *for all releases*, so that all system calls
  which are defined for the 5.4 kernel are known about *for the
  libseccomp test suite*. This allows all unit tests to pass on older
  releases as well and defaults the build to fail on unit test failures
  (whereas currently in xenial this has been overridden to ignore
  failures).

  
  [Regression Potential]

  This has a low regression potential due to significant testing with
  many packages that depend on libseccomp (lxc, qemu, snapd, apt, man
  etc) and none have shown any regression using this new version. The
  re-enablement of build failure on test failure at build time also
  ensures that we can reliably detect FTBFS issues in the future.

  No symbols have been removed (or added) with this update in version so
  there is no chance of regression due to ABI change etc. In the past,
  the security team has performed more significant version upgrades for
  libseccomp (2.2, 2.3, 2.4) -> 2.4.1 without major incident. In the
  case 

[Touch-packages] [Bug 1861941] Re: bcache by-uuid links disappear after mounting bcache0

2020-06-22 Thread Balint Reczey
Reopening against bcache-tools according to @raharper's comment about 
preferring a different fix.
https://bugs.launchpad.net/ubuntu/groovy/+source/bcache-tools/+bug/1861941/comments/28

** Changed in: bcache-tools (Ubuntu Groovy)
   Status: Fix Released => Triaged

** Changed in: bcache-tools (Ubuntu Groovy)
 Assignee: Balint Reczey (rbalint) => (unassigned)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1861941

Title:
  bcache by-uuid links disappear after mounting bcache0

Status in bcache-tools package in Ubuntu:
  Triaged
Status in linux package in Ubuntu:
  Incomplete
Status in linux-signed package in Ubuntu:
  Confirmed
Status in systemd package in Ubuntu:
  Fix Released
Status in bcache-tools source package in Focal:
  Confirmed
Status in linux source package in Focal:
  Invalid
Status in linux-signed source package in Focal:
  Confirmed
Status in systemd source package in Focal:
  Confirmed
Status in bcache-tools source package in Groovy:
  Triaged
Status in linux source package in Groovy:
  Incomplete
Status in linux-signed source package in Groovy:
  Confirmed
Status in systemd source package in Groovy:
  Fix Released

Bug description:
  1.
  root@ubuntu:~# lsb_release -rd
  Description:  Ubuntu Focal Fossa (development branch)
  Release:  20.04

  2. 
  root@ubuntu:~# lsb_release -rd
  Description:  Ubuntu Focal Fossa (development branch)
  Release:  20.04
  root@ubuntu:~# apt-cache policy linux-image-virtual 
  linux-image-virtual:
Installed: 5.4.0.12.15
Candidate: 5.4.0.12.15
Version table:
   *** 5.4.0.12.15 500
  500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages
  100 /var/lib/dpkg/status
  root@ubuntu:~# apt-cache policy linux-image-5.4.0-12-generic 
  linux-image-5.4.0-12-generic:
Installed: 5.4.0-12.15
Candidate: 5.4.0-12.15
Version table:
   *** 5.4.0-12.15 500
  500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages
  100 /var/lib/dpkg/status

  3. mount /dev/bcache0 && ls -al /dev/bcache/by-uuid/
  + ls -al /dev/bcache/by-uuid/
  total 0
  drwxr-xr-x 2 root root 60 Feb  4 23:31 .
  drwxr-xr-x 3 root root 60 Feb  4 23:31 ..
  lrwxrwxrwx 1 root root 13 Feb  4 23:31 abdfd1f6-44ce-4266-91db-24667b9ae51a 
-> ../../bcache0

  4.
  root@ubuntu:~# ls -al /dev/bcache/by-uuid
  ls: cannot access '/dev/bcache/by-uuid': No such file or directory

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: linux-image-5.4.0-12-generic 5.4.0-12.15
  ProcVersionSignature: Ubuntu 5.4.0-12.15-generic 5.4.8
  Uname: Linux 5.4.0-12-generic x86_64
  ApportVersion: 2.20.11-0ubuntu16
  Architecture: amd64
  Date: Tue Feb  4 23:31:52 2020
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   LANG=C.UTF-8
   SHELL=/bin/bash
  SourcePackage: linux-signed-5.4
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bcache-tools/+bug/1861941/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884391] Re: PCI/internal sound card not detected

2020-06-22 Thread Sebastien Bacher
Thanks, closing if it works in the current serie

** Changed in: alsa-driver (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1884391

Title:
  PCI/internal sound card not detected

Status in alsa-driver package in Ubuntu:
  Fix Released

Bug description:
  My sound card stopped being recognized suddenly today. lspci shows the
  card, but alsa and pulseaudio don't see it. I verified that the kernel
  modules are installed.

  I noticed this today when I logged on and the only audio device was
  the dummy device. I tried the various fixes I found online for this,
  but nothing worked. I haven't made any changes to any audio packages
  manually, but I have had automatic updates over the last few days
  which may have caused this.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: alsa-base 1.0.25+dfsg-0ubuntu5
  ProcVersionSignature: Ubuntu 5.3.0-59.53~18.04.1-generic 5.3.18
  Uname: Linux 5.3.0-59-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.15
  Architecture: amd64
  AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', 
'/dev/snd/timer'] failed with exit code 1:
  CurrentDesktop: ubuntu:GNOME
  Date: Sat Jun 20 15:29:04 2020
  InstallationDate: Installed on 2020-03-14 (98 days ago)
  InstallationMedia: Ubuntu 18.04.4 LTS "Bionic Beaver" - Release amd64 
(20200203.1)
  PackageArchitecture: all
  ProcEnviron:
   TERM=screen-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/usr/bin/zsh
  SourcePackage: alsa-driver
  Symptom: audio
  Title: PCI/internal sound card not detected
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 03/26/2020
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.5.1
  dmi.board.name: 0377MH
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 10
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvr1.5.1:bd03/26/2020:svnDellInc.:pnXPS137390:pvr:rvnDellInc.:rn0377MH:rvrA00:cvnDellInc.:ct10:cvr:
  dmi.product.family: XPS
  dmi.product.name: XPS 13 7390
  dmi.product.sku: 0962
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1884391/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1861941] Re: bcache by-uuid links disappear after mounting bcache0

2020-06-22 Thread Balint Reczey
** Changed in: systemd (Ubuntu Focal)
   Status: Invalid => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1861941

Title:
  bcache by-uuid links disappear after mounting bcache0

Status in bcache-tools package in Ubuntu:
  Fix Released
Status in linux package in Ubuntu:
  Incomplete
Status in linux-signed package in Ubuntu:
  Confirmed
Status in systemd package in Ubuntu:
  Fix Released
Status in bcache-tools source package in Focal:
  Confirmed
Status in linux source package in Focal:
  Invalid
Status in linux-signed source package in Focal:
  Confirmed
Status in systemd source package in Focal:
  Confirmed
Status in bcache-tools source package in Groovy:
  Fix Released
Status in linux source package in Groovy:
  Incomplete
Status in linux-signed source package in Groovy:
  Confirmed
Status in systemd source package in Groovy:
  Fix Released

Bug description:
  1.
  root@ubuntu:~# lsb_release -rd
  Description:  Ubuntu Focal Fossa (development branch)
  Release:  20.04

  2. 
  root@ubuntu:~# lsb_release -rd
  Description:  Ubuntu Focal Fossa (development branch)
  Release:  20.04
  root@ubuntu:~# apt-cache policy linux-image-virtual 
  linux-image-virtual:
Installed: 5.4.0.12.15
Candidate: 5.4.0.12.15
Version table:
   *** 5.4.0.12.15 500
  500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages
  100 /var/lib/dpkg/status
  root@ubuntu:~# apt-cache policy linux-image-5.4.0-12-generic 
  linux-image-5.4.0-12-generic:
Installed: 5.4.0-12.15
Candidate: 5.4.0-12.15
Version table:
   *** 5.4.0-12.15 500
  500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages
  100 /var/lib/dpkg/status

  3. mount /dev/bcache0 && ls -al /dev/bcache/by-uuid/
  + ls -al /dev/bcache/by-uuid/
  total 0
  drwxr-xr-x 2 root root 60 Feb  4 23:31 .
  drwxr-xr-x 3 root root 60 Feb  4 23:31 ..
  lrwxrwxrwx 1 root root 13 Feb  4 23:31 abdfd1f6-44ce-4266-91db-24667b9ae51a 
-> ../../bcache0

  4.
  root@ubuntu:~# ls -al /dev/bcache/by-uuid
  ls: cannot access '/dev/bcache/by-uuid': No such file or directory

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: linux-image-5.4.0-12-generic 5.4.0-12.15
  ProcVersionSignature: Ubuntu 5.4.0-12.15-generic 5.4.8
  Uname: Linux 5.4.0-12-generic x86_64
  ApportVersion: 2.20.11-0ubuntu16
  Architecture: amd64
  Date: Tue Feb  4 23:31:52 2020
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   LANG=C.UTF-8
   SHELL=/bin/bash
  SourcePackage: linux-signed-5.4
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bcache-tools/+bug/1861941/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1878194] Re: [Sennheiser HD 4.50 BTNC] Bluetooth headset not working when selecting HSP/HFP audio profile in Focal Fossa

2020-06-22 Thread David Jeffrey
*** This bug is a duplicate of bug 1871794 ***
https://bugs.launchpad.net/bugs/1871794

@Michael unfortunately, the fix did not persist for me through a reboot
either.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1878194

Title:
  [Sennheiser HD 4.50 BTNC] Bluetooth headset not working when selecting
  HSP/HFP audio profile in Focal Fossa

Status in bluez package in Ubuntu:
  Confirmed
Status in pulseaudio package in Ubuntu:
  Confirmed

Bug description:
  After updating the release from Ubuntu 19.10 to 20.04, the bluetooth
  headset doesn't work anymore when HSP/HFP profile is selected.

  With Ubuntu 19.10 the headset was working, there was audio and the mic
  was perfect for video conferencing.

  [Steps to reproduce]
  1. Connect headset (used blueman to setup and connect)
  1.1. When connected the system automatically selects A2DP profile
  2. Start playing audio (browser or other)
  3. Change profile to HSP/HFP with pavucontrol (or blueman)
  4. The audio disappears and microphone is not working (no input)
  5. Optionally switch back to A2DP and the audio comes back

  [Expected]
  When switching to HSP/HFP the audio should keep playing and the microphone 
should start working

  [Notes]
  I tried with pavucontrol to switch between profiles while playing audio from 
a browser.
  As side note there's a led in the headset that still blinks when switching 
profile.

  I tried deleting the pulse folder under user's profile .config without
  success, also reinstalled packages and did a `sudo alsa force-reload`
  and rebooting several times.

  Note: not sure this is a duplicate of [Bug #1576559], it looks quite
  different since the profile changes but the headset stops working.

  [System info]
  Ubuntu: 20.04 - Linux 5.4.0-29-generic x86_64
  pulseaudio: 1:13.99.1-1ubuntu3
  bluez: 5.53-0ubuntu3

  Headset: Sennheiser HD 4.50 BTNC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1878194/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868520] Re: Wayland apps fail to run with zwp_linux_dmabuf error (failed to import supplied dmabufs: Unsupported buffer format 808669784 [DRM_FORMAT_XRGB2101010]) (or 808665665

2020-06-22 Thread Daniel van Vugt
** Changed in: mesa (Ubuntu Bionic)
   Status: Fix Committed => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1868520

Title:
  Wayland apps fail to run with zwp_linux_dmabuf error (failed to import
  supplied dmabufs: Unsupported buffer format 808669784
  [DRM_FORMAT_XRGB2101010]) (or 808665665 [DRM_FORMAT_ABGR2101010])

Status in Mesa:
  Fix Released
Status in MPV:
  Unknown
Status in mesa package in Ubuntu:
  Fix Released
Status in mesa source package in Bionic:
  Invalid
Status in mesa source package in Focal:
  Fix Committed

Bug description:
  [Impact]

  Wayland apps fail to start in focal with:

  error 7: failed to import supplied dmabufs: Unsupported buffer format
  808669784

  [Test Case]

  Just run: es2gears_wayland

  [Regression Potential]

  Medium/unknown. The fix is quite new.

  [Other Info]

  When attempting to run es2gears_wayland against GNOME Shell, it fails
  with:

  EGL_VERSION = 1.5
  vertex shader info:
  fragment shader info:
  info:
  [destroyed object]: error 7: failed to import supplied dmabufs: Unsupported 
buffer format 808669784

  The full wayland protocol trace is:

  [3104432.914]  -> wl_display@1.get_registry(new id wl_registry@2)
  [3104432.972]  -> wl_disp...@1.sync(new id wl_callback@3)
  [3104433.139] wl_display@1.delete_id(3)
  [3104433.175] wl_registry@2.global(1, "wl_drm", 2)
  [3104433.207] wl_registry@2.global(2, "wl_compositor", 4)
  [3104433.240]  -> wl_regis...@2.bind(2, "wl_compositor", 1, new id 
[unknown]@4)
  [3104433.285] wl_registry@2.global(3, "wl_shm", 1)
  [3104433.316] wl_registry@2.global(4, "wl_output", 2)
  [3104433.347] wl_registry@2.global(5, "zxdg_output_manager_v1", 3)
  [3104433.376] wl_registry@2.global(6, "wl_data_device_manager", 3)
  [3104433.404] wl_registry@2.global(7, "gtk_primary_selection_device_manager", 
1)
  [3104433.432] wl_registry@2.global(8, "wl_subcompositor", 1)
  [3104433.459] wl_registry@2.global(9, "xdg_wm_base", 2)
  [3104433.485] wl_registry@2.global(10, "zxdg_shell_v6", 1)
  [3104433.513] wl_registry@2.global(11, "wl_shell", 1)
  [3104433.542]  -> wl_regis...@2.bind(11, "wl_shell", 1, new id [unknown]@5)
  [3104433.582] wl_registry@2.global(12, "gtk_shell1", 3)
  [3104433.611] wl_registry@2.global(13, "wp_viewporter", 1)
  [3104433.640] wl_registry@2.global(14, "zwp_pointer_gestures_v1", 1)
  [3104433.670] wl_registry@2.global(15, "zwp_tablet_manager_v2", 1)
  [3104433.699] wl_registry@2.global(16, "wl_seat", 5)
  [3104433.728] wl_registry@2.global(17, "zwp_relative_pointer_manager_v1", 1)
  [3104433.758] wl_registry@2.global(18, "zwp_pointer_constraints_v1", 1)
  [3104433.787] wl_registry@2.global(19, "zxdg_exporter_v1", 1)
  [3104433.816] wl_registry@2.global(20, "zxdg_importer_v1", 1)
  [3104433.846] wl_registry@2.global(21, "zwp_linux_dmabuf_v1", 3)
  [3104433.875] wl_registry@2.global(22, 
"zwp_keyboard_shortcuts_inhibit_manager_v1", 1)
  [3104433.904] wl_registry@2.global(23, "zwp_text_input_manager_v3", 1)
  [3104433.933] wl_registry@2.global(24, "gtk_text_input_manager", 1)
  [3104433.960] wl_registry@2.global(26, "wl_eglstream_controller", 1)
  [3104433.991] wl_callb...@3.done(3421)
  [3104436.266]  -> wl_display@1.get_registry(new id wl_registry@3)
  [3104436.279]  -> wl_disp...@1.sync(new id wl_callback@6)
  [3104436.647] wl_display@1.delete_id(6)
  [3104436.672] wl_registry@3.global(1, "wl_drm", 2)
  [3104436.726]  -> wl_regis...@3.bind(1, "wl_drm", 2, new id [unknown]@7)
  [3104436.744] wl_registry@3.global(2, "wl_compositor", 4)
  [3104436.780] wl_registry@3.global(3, "wl_shm", 1)
  [3104436.790] wl_registry@3.global(4, "wl_output", 2)
  [3104436.803] wl_registry@3.global(5, "zxdg_output_manager_v1", 3)
  [3104436.833] wl_registry@3.global(6, "wl_data_device_manager", 3)
  [3104436.868] wl_registry@3.global(7, "gtk_primary_selection_device_manager", 
1)
  [3104436.882] wl_registry@3.global(8, "wl_subcompositor", 1)
  [3104436.898] wl_registry@3.global(9, "xdg_wm_base", 2)
  [3104436.913] wl_registry@3.global(10, "zxdg_shell_v6", 1)
  [3104436.925] wl_registry@3.global(11, "wl_shell", 1)
  [3104436.937] wl_registry@3.global(12, "gtk_shell1", 3)
  [3104436.950] wl_registry@3.global(13, "wp_viewporter", 1)
  [3104436.963] wl_registry@3.global(14, "zwp_pointer_gestures_v1", 1)
  [3104436.976] wl_registry@3.global(15, "zwp_tablet_manager_v2", 1)
  [3104436.990] wl_registry@3.global(16, "wl_seat", 5)
  [3104437.001] wl_registry@3.global(17, "zwp_relative_pointer_manager_v1", 1)
  [3104437.013] wl_registry@3.global(18, "zwp_pointer_constraints_v1", 1)
  [3104437.026] wl_registry@3.global(19, "zxdg_exporter_v1", 1)
  [3104437.038] wl_registry@3.global(20, "zxdg_importer_v1", 1)
  [3104437.051] wl_registry@3.global(21, "zwp_linux_dmabuf_v1", 3)
  [3104437.066]  -> wl_regis...@3.bind(21, "zwp_linux_dmabuf_v1", 3, new id 
[unknown]@8)
  [3104437.083] wl_registry@3.global(22, 

[Touch-packages] [Bug 1557157] Re: apparmor profile denied for saslauthd: /run/saslauthd/mux

2020-06-22 Thread Launchpad Bug Tracker
This bug was fixed in the package openldap - 2.4.50+dfsg-1ubuntu2

---
openldap (2.4.50+dfsg-1ubuntu2) groovy; urgency=medium

  * d/apparmor-profile: Update apparmor profile to grant access to
the saslauthd socket, so that SASL authentication works. (LP: #1557157)

 -- Sergio Durigan Junior   Fri, 12 Jun
2020 18:20:42 -0400

** Changed in: openldap (Ubuntu Groovy)
   Status: Confirmed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openldap in Ubuntu.
https://bugs.launchpad.net/bugs/1557157

Title:
  apparmor profile denied for saslauthd: /run/saslauthd/mux

Status in openldap package in Ubuntu:
  Fix Released
Status in openldap source package in Trusty:
  Won't Fix
Status in openldap source package in Xenial:
  Confirmed
Status in openldap source package in Bionic:
  Confirmed
Status in openldap source package in Focal:
  Confirmed
Status in openldap source package in Groovy:
  Fix Released

Bug description:
  [Impact]

  When using openldap with sasl authentication, the slapd process will
  communicate with the saslauthd daemon via a socket in
  {,/var}/run/saslauthd/mux. Unfortunately, this will fail in every
  Ubuntu release from trusty onwards, because slapd's apparmor profile
  doesn't contain the necessary directive to allow it to read/write
  from/to the socket specified above.

  The fix is simple: just add the necessary directive to allow slapd to
  read/write from/to the saslauthd socket.

  [Test Case]

  One can reproduce the problem by doing:

  $ lxc launch ubuntu-daily:groovy openldap-bugbug1557157-groovy
  $ lxc shell openldap-bugbug1557157-groovy
  # apt install slapd sasl2-bin ldap-utils apparmor-utils

  (As the domain name, use "example.com").

  # sed -i -e 's/^START=.*/START=yes/' /etc/default/saslauthd
  # cat > /etc/ldap/sasl2/slapd.conf << __EOF__
  mech_list: PLAIN
  pwcheck_method: saslauthd
  __EOF__
  # adduser openldap sasl
  # aa-enforce /etc/apparmor.d/usr.sbin.slapd
  # systemctl restart slapd.service
  # systemctl restart saslauthd.service
  # passwd root

  (You can choose any password here. You will need to type it when
  running the next command.)

  # ldapsearch -H ldapi:/// -LLL -b 'dc=example,dc=com' -s base -U root
  -Y PLAIN

  The command will fail with something like:

  ldap_sasl_interactive_bind_s: Other (e.g., implementation specific) error (80)
  additional info: SASL(-1): generic failure: Password verification 
failed

  [Regression Potential]

  This is an extremely simple and well contained fix, so I don't
  envision any possible regressions after applying it.  It is important
  noticing that, since the problem affects older Ubuntu releases, the
  openldap package will have to be rebuilt against possible newer
  versions of libraries and other depencencies, which, albeit unlikely,
  may cause issues.

  [Original Description]

  When using slapd with saslauthd the processes communicate via the
  {,/var}/run/saslauthd/mux socket (this is the default location for the
  saslauthd server from the sasl2-bin package in the
  /etc/default/saslauthd config), but the apparmor profile for
  usr.sbin.slapd does not allow access to this socket/file.

  Syslog message:
  apparmor="DENIED" operation="connect" profile="/usr/sbin/slapd" 
name="/run/saslauthd/mux" pid=1880
  4 comm="slapd" requested_mask="r" denied_mask="r" fsuid=108 ouid=0

  Please add the following line to  /etc/apparmor.d/usr.sbin.slapd:
  /{,var/}run/saslauthd/mux rw,

  Ubuntu version: Ubuntu 14.04.4 LTS
  slapd version: 2.4.31-1+nmu2ubu

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openldap/+bug/1557157/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1882161] Re: module-switch-on-port-avaiable: switch the port on ucm devices based on the priority

2020-06-22 Thread Hui Wang
@Seb,

Looks like the input switch issue will not be fixed in a short period of
time
(https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/295),
and our OEM project wants the fix to be applied to output device first,
so could you please upload a build of this fix to focal.

Thx.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1882161

Title:
  module-switch-on-port-avaiable: switch the port on ucm devices based
  on the priority

Status in HWE Next:
  New
Status in pulseaudio package in Ubuntu:
  Fix Released
Status in pulseaudio source package in Focal:
  In Progress
Status in pulseaudio source package in Groovy:
  Fix Released

Bug description:
  This bug originates from an OEM private bug #1875597, then ubuntu
  users reported 2 public bugs #1871329 and #1881659. The 2nd issue of
  #1871329 and the 1st issue of #1881659 have the same root cause as
  #1875597

  [Impact]
  On the Dell machines with multi function audio jack, after installing the 
ubuntu 20.04 and if the audio driver is sof instead of legacy hda, the 
headphone/headset can't output sound automatically after users plug in a 
headphone/headset. This is different from ubuntu 18.04, on the 18.04, the 
headphone/headset could output sound automatically after plugging in the audio 
jack.

  [Fix]
  The root cause is the ucm2 conf defines 2 input devices: the Mic2 and Headset 
MIC, and the pulseaudio parse the input device Headset MIC first then Mic2, 
finally the audio jack is set to Mic2 mode, this make the audio jack can't 
output sound anymore. To fix it, let the audio jack set to Headset MIC mode by 
default (Headset MIC has higher priority than Mic2 in the ucm2 conf), to do so, 
let pulseaudio send the device event to module-switch-on-port-available by the 
order of priority in the umc2.

  [Test Case]
  applying the fix patch to pulseaudio, plug a headset/headphone to the multi 
function audio jack, play sound from headset/headphone, the sound could be 
heard from headset/headphone.

  [Regression Risk]
  Low, just do a small change to store the ucm devices by their priority. and 
upstream just merged this patch.

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/1882161/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1840592] Re: systemd-backlight does not save and restore brightness for nvidia display

2020-06-22 Thread Ayush Akarsh
I have a nvidia 1650 graphic card on my legion-Y540 with ubuntu 20.04
I had fixed my brightness issue(Function keys not working) by adding  Option 
"RegistryDwords" "EnableBrightnessControl=1" in the device section of 
/etc/x11/xorg.conf

It worked perfectly well until a software update, then now method
worked, and I am only able to adjust brightness with the help of
brightness controller, but in that I cannot use night mode, cause it
sets the brightness to maximum only, whenever I use that.

Please help!!

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1840592

Title:
  systemd-backlight does not save and restore brightness for nvidia
  display

Status in nvidia-graphics-drivers package in Ubuntu:
  Confirmed
Status in nvidia-graphics-drivers-418 package in Ubuntu:
  Confirmed
Status in nvidia-settings package in Ubuntu:
  Confirmed
Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  Running nvidia gtx 1080 graphics card, with proprietary nvidia drivers
  on ubuntu 19.04. I can change screen brightness from 0% to 100% in 5%
  steps. However, after a reboot or after a shutdown, brightness level
  reverts to 100%. Please fix to is "remembers" the current brightness
  value at shutdown time, like in does Windows.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/1840592/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1861941] Re: bcache by-uuid links disappear after mounting bcache0

2020-06-22 Thread Alexander Litvinov
Is it possible to backport this ^ to Bionic?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1861941

Title:
  bcache by-uuid links disappear after mounting bcache0

Status in bcache-tools package in Ubuntu:
  Fix Released
Status in linux package in Ubuntu:
  Incomplete
Status in linux-signed package in Ubuntu:
  Confirmed
Status in systemd package in Ubuntu:
  Fix Released
Status in bcache-tools source package in Focal:
  Confirmed
Status in linux source package in Focal:
  Invalid
Status in linux-signed source package in Focal:
  Confirmed
Status in systemd source package in Focal:
  Invalid
Status in bcache-tools source package in Groovy:
  Fix Released
Status in linux source package in Groovy:
  Incomplete
Status in linux-signed source package in Groovy:
  Confirmed
Status in systemd source package in Groovy:
  Fix Released

Bug description:
  1.
  root@ubuntu:~# lsb_release -rd
  Description:  Ubuntu Focal Fossa (development branch)
  Release:  20.04

  2. 
  root@ubuntu:~# lsb_release -rd
  Description:  Ubuntu Focal Fossa (development branch)
  Release:  20.04
  root@ubuntu:~# apt-cache policy linux-image-virtual 
  linux-image-virtual:
Installed: 5.4.0.12.15
Candidate: 5.4.0.12.15
Version table:
   *** 5.4.0.12.15 500
  500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages
  100 /var/lib/dpkg/status
  root@ubuntu:~# apt-cache policy linux-image-5.4.0-12-generic 
  linux-image-5.4.0-12-generic:
Installed: 5.4.0-12.15
Candidate: 5.4.0-12.15
Version table:
   *** 5.4.0-12.15 500
  500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages
  100 /var/lib/dpkg/status

  3. mount /dev/bcache0 && ls -al /dev/bcache/by-uuid/
  + ls -al /dev/bcache/by-uuid/
  total 0
  drwxr-xr-x 2 root root 60 Feb  4 23:31 .
  drwxr-xr-x 3 root root 60 Feb  4 23:31 ..
  lrwxrwxrwx 1 root root 13 Feb  4 23:31 abdfd1f6-44ce-4266-91db-24667b9ae51a 
-> ../../bcache0

  4.
  root@ubuntu:~# ls -al /dev/bcache/by-uuid
  ls: cannot access '/dev/bcache/by-uuid': No such file or directory

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: linux-image-5.4.0-12-generic 5.4.0-12.15
  ProcVersionSignature: Ubuntu 5.4.0-12.15-generic 5.4.8
  Uname: Linux 5.4.0-12-generic x86_64
  ApportVersion: 2.20.11-0ubuntu16
  Architecture: amd64
  Date: Tue Feb  4 23:31:52 2020
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   LANG=C.UTF-8
   SHELL=/bin/bash
  SourcePackage: linux-signed-5.4
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bcache-tools/+bug/1861941/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1881094] Re: Support kernel 5.4 Intel sound driver on bionic

2020-06-22 Thread Gabriel Zhi Chen
[Test Case]

 * install kernel 5.4 and check audio function
   1. enable Pre-released updates in Developer Options
  Software & Updates > Developer Options > Pre-released updates 
(bionic-proposed)
   2. $ sudo apt update
   3. $ sudo apt install linux-generic-hwe-18.04-edge
   4. $ sudo reboot

 * install updated linux-firmware and pulseaudio
   $ sudo add-apt-repository ppa:kchsieh/training
   $ sudo apt-get update
   $ sudo apt install linux-firmware
   $ sudo apt install pulseaudio
   $ sudo reboot

 * test items
   1. check internal speaker/mic to playback and record audio
   2. plug headset and check headset functions
   3. plug HDMI from external monitor/TV, and check audio functions
   4. 1, 2, 3 works fine after resume from suspend

[Test machines and results]
   1. Lenovo ThinkPad X1 Carbon 7th, internal speaker/mic, headset functions, 
HDMI monitor/TV before/after S3 working normally.
   2. Lenovo ThinkPad X390, internal speaker/mic, headset functions, HDMI 
monitor/TV before/after S3 working normally too.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1881094

Title:
  Support kernel 5.4 Intel sound driver on bionic

Status in OEM Priority Project:
  New
Status in pulseaudio package in Ubuntu:
  Invalid
Status in pulseaudio source package in Bionic:
  Triaged

Bug description:
  [Impact]

   * Some Intel platform bionic user audio function will be broken after
  upgrade to kernel 5.4

   * pulseaudio can't find working profile, since card name is changed
  in kernel 5.4

  [Test Case]

   * install kernel 5.4 and check audio function
     1. enable Pre-released updates in Developer Options
    Software & Updates > Developer Options > Pre-released updates 
(bionic-proposed)
     2. $ sudo apt update
     3. $ sudo apt install linux-generic-hwe-18.04-edge
     4. $ sudo reboot

   * install updated linux-firmware and pulseaudio
     $ sudo add-apt-repository ppa:kchsieh/training
     $ sudo apt-get update
     $ sudo apt install linux-firmware
     $ sudo apt install pulseaudio
     $ sudo reboot

   * test items
     1. check internal speaker/mic to playback and record audio
     2. plug headset and check headset functions
     3. plug HDMI from external monitor/TV, and check audio functions
     4. 1, 2, 3 works fine after resume from suspend

  [Regression Potential]

   * The updated pulseaudio breaks audio function on old kernel

  [Scope]

   * Need for bionic only

  [Bug Discussion]

   * https://bugs.launchpad.net/timbuktu/+bug/1880632
   * MP: 
https://code.launchpad.net/~kchsieh/pulseaudio/+git/bionic-1880632/+merge/384610

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1881094/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1883880] Re: fix non-8-bit x86 displacements breaking AVX512 builds on Bionic

2020-06-22 Thread Christian Ehrhardt 
A few dep8 tests failed in the sniff, but all of them are existing known
overrides in Bionic:

ubuntu-release:9:force-badtest dh-ada-library/6.12
ubuntu-release:18:force-badtest lintian/2.5.81ubuntu1
pitti:2:force-badtest rpmlint/1.9-6
ubuntu-sru:17:force-badtest snapcraft/2.43.1+18.04/amd64 
snapcraft/2.43.1+18.04/i386
ubuntu-sru:20:force-badtest snapcraft/2.43.1+18.04/armhf 
snapcraft/2.43.1+18.04/arm64
ubuntu-release:90:force-badtest linux-hwe/all
ubuntu-release:91:force-badtest linux-hwe-edge/all

So this should be good as-is, but needs Doko to sign-off and sponsor
with the experience of potential side effects of a binutils update.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to binutils in Ubuntu.
https://bugs.launchpad.net/bugs/1883880

Title:
  fix non-8-bit x86 displacements breaking AVX512 builds on Bionic

Status in binutils package in Ubuntu:
  Fix Released
Status in binutils source package in Bionic:
  New

Bug description:
  [Impact]

   * the assembler scales non 8 bit cases which was identified
 to break e.g. some AVX512 code. It is nasty as it isn't a compile/link/ 
 time error. Instead the instructions might silently be corrupted until 
 running. Things might even work on some but fail on other systems if 
 e.g. the AVX code paths only run on newer chips.

* The fix is upstream for a while and not re-changed again. Furthermore 
  it is in several Ubuntu releases without bugs due to that, which should 
  make the backport rather safe.

  [Test Case]

   * Simple example to trigger the bug:

  echo "vmovaps 0x40(,%rax,1),%zmm0" | as --64 -o avx.o && objdump -d
  avx.o | grep vmovaps

  The expected output is that the objdump output matches the vmovaps
  instruction input. When using binutils with the bug, the initial 0x40
  will be incorrect.

  Working:
  $ echo "vmovaps 0x40(,%rax,1),%zmm0" | as --64 -o avx.o && objdump -d avx.o | 
grep vmovaps
 0: 62 f1 7c 48 28 04 05 vmovaps 0x40(,%rax,1),%zmm0
  Failing:
  $ echo "vmovaps 0x40(,%rax,1),%zmm0" | as --64 -o avx.o && objdump -d avx.o | 
grep vmovaps
 0: 62 f1 7c 48 28 04 05 vmovaps 0x1(,%rax,1),%zmm0

  [Regression Potential]

   * Well, this is a double edged sword. On one hand this is fortunately a 
 small change and only affects something formerly clearly broken. So it 
 should be good and only change cases formerly being bad.
 But OTOH binutils areused in so many cases that I feel unable to say
 "nothing will happen". The change goes to the gnu assembler, so that is 
 the place to look out for regressions.

  [Other Info]
   
   * needs a sponsor experienced with binutils to check potential pitfalls


  
  ---

  
  Hi,
  DPDK has run into some issues in the past
   https://bugs.dpdk.org/show_bug.cgi?id=97
   https://bugs.dpdk.org/show_bug.cgi?id=249

  Eventually the issues got resolved in binutils via
   https://sourceware.org/bugzilla/show_bug.cgi?id=23465

  After binutils is fixed people rebuilding DPDK themselve can use
   http://patches.dpdk.org/patch/71679/
  to gain more performance while on Bionics bintuils level.

  Note: Bionic is on DPDK 17.11.x which will not get further stable release 
afaik. But quite often people build their own DPDK. In fact this came up as a 
request from Openvswitch upstream/Intel to allow such builds on Bionic.
  I'd ping those people about the bug and ask them to participate in the 
verification if this becomes an SRU.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/binutils/+bug/1883880/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884255] Status changed to Confirmed

2020-06-22 Thread Ubuntu Kernel Bot
This change was made by a bot.

** Changed in: linux (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1884255

Title:
  [AMD/ATI] SBx00 Azalia (Intel HDA) Audio Ubuntu 20.04 not working

Status in linux package in Ubuntu:
  Confirmed
Status in pulseaudio package in Ubuntu:
  New

Bug description:
  When you start playing some audio, the sound disappears.

  00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia 
(Intel HDA)
Subsystem: ASUSTeK Computer Inc. M5A78L LE
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel

  
  uname -a
  Linux Marcelo-STI-FX6300 5.4.0-37-generic #41-Ubuntu SMP Wed Jun 3 18:57:02 
UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

  alsa-info

  
  !!
  !!ALSA Information Script v 0.4.65
  !!

  !!Script ran on: Fri Jun 19 13:38:12 UTC 2020

  
  !!Linux Distribution
  !!--

  Ubuntu 20.04 LTS \n \l DISTRIB_ID=Ubuntu DISTRIB_DESCRIPTION="Ubuntu
  20.04 LTS" NAME="Ubuntu" ID=ubuntu ID_LIKE=debian PRETTY_NAME="Ubuntu
  20.04 LTS" HOME_URL="https://www.ubuntu.com/;
  SUPPORT_URL="https://help.ubuntu.com/;
  BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/;
  PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies
  /privacy-policy" UBUNTU_CODENAME=focal

  
  !!DMI Information
  !!---

  Manufacturer:  System manufacturer
  Product Name:  System Product Name
  Product Version:   System Version
  Firmware Version:  1201   
  Board Vendor:  ASUSTeK Computer INC.
  Board Name:M5A78L-M LX/BR

  
  !!ACPI Device Status Information
  !!---

  /sys/bus/acpi/devices/ATK0110:00/status15
  /sys/bus/acpi/devices/PNP0103:00/status15
  /sys/bus/acpi/devices/PNP0400:00/status15
  /sys/bus/acpi/devices/PNP0501:00/status15
  /sys/bus/acpi/devices/PNP0C0C:00/status11
  /sys/bus/acpi/devices/PNP0C0F:00/status9
  /sys/bus/acpi/devices/PNP0C0F:01/status9
  /sys/bus/acpi/devices/PNP0C0F:02/status9
  /sys/bus/acpi/devices/PNP0C0F:03/status9
  /sys/bus/acpi/devices/PNP0C0F:04/status9
  /sys/bus/acpi/devices/PNP0C0F:05/status9
  /sys/bus/acpi/devices/PNP0C0F:06/status9
  /sys/bus/acpi/devices/PNP0C0F:07/status9
  /sys/bus/acpi/devices/device:20/status 15
  /sys/bus/acpi/devices/device:21/status 15

  
  !!Kernel Information
  !!--

  Kernel release:5.4.0-37-generic
  Operating System:  GNU/Linux
  Architecture:  x86_64
  Processor: x86_64
  SMP Enabled:   Yes

  
  !!ALSA Version
  !!

  Driver version: k5.4.0-37-generic
  Library version:1.2.3
  Utilities version:  1.2.2

  
  !!Loaded ALSA modules
  !!---

  snd_hda_intel

  
  !!Sound Servers on this system
  !!

  Pulseaudio:
Installed - Yes (/usr/bin/pulseaudio)
Running - Yes

  
  !!Soundcards recognised by ALSA
  !!-

   0 [SB ]: HDA-Intel - HDA ATI SB
HDA ATI SB at 0xfe9f4000 irq 16

  
  !!PCI Soundcards installed in the system
  !!--

  00:14.2 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 
Azalia (Intel HDA) [1002:4383]
Subsystem: ASUSTeK Computer Inc. M5A78L LE [1043:8445]

  
  !!Modprobe options (Sound related)
  !!

  snd_pcsp: index=-2
  snd_usb_audio: index=-2
  snd_atiixp_modem: index=-2
  snd_intel8x0m: index=-2
  snd_via82xx_modem: index=-2
  snd_atiixp_modem: index=-2
  snd_intel8x0m: index=-2
  snd_via82xx_modem: index=-2
  snd_usb_audio: index=-2
  snd_usb_caiaq: index=-2
  snd_usb_ua101: index=-2
  snd_usb_us122l: index=-2
  snd_usb_usx2y: index=-2
  snd_cmipci: mpu_port=0x330 fm_port=0x388
  snd_pcsp: index=-2
  snd_usb_audio: index=-2
  snd_hda_intel: model=auto
  snd_hda_intel: dmic detect=0

  
  !!Loaded sound module options
  !!---

  !!Module: snd_hda_intel
align_buffer_size : -1
bdl_pos_adj : 
-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
beep_mode : 
N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N
dmic_detect : Y
enable : Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y
enable_msi : -1
id : 
(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)
index : 
-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1

[Touch-packages] [Bug 1883880] Re: fix non-8-bit x86 displacements breaking AVX512 builds on Bionic

2020-06-22 Thread Christian Ehrhardt 
Tested in Bionic Container:

no PPA:
root@b:~# echo "vmovaps 0x40(,%rax,1),%zmm0" | as --64 -o avx.o && objdump -d 
avx.o | grep vmovaps
   0:   62 f1 7c 48 28 04 05vmovaps 0x1(,%rax,1),%zmm0

with PPA:
root@b:~# echo "vmovaps 0x40(,%rax,1),%zmm0" | as --64 -o avx.o && objdump -d 
avx.o | grep vmovaps
   0:   62 f1 7c 48 28 04 05vmovaps 0x40(,%rax,1),%zmm0

Seems to work as intended

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to binutils in Ubuntu.
https://bugs.launchpad.net/bugs/1883880

Title:
  fix non-8-bit x86 displacements breaking AVX512 builds on Bionic

Status in binutils package in Ubuntu:
  Fix Released
Status in binutils source package in Bionic:
  New

Bug description:
  [Impact]

   * the assembler scales non 8 bit cases which was identified
 to break e.g. some AVX512 code. It is nasty as it isn't a compile/link/ 
 time error. Instead the instructions might silently be corrupted until 
 running. Things might even work on some but fail on other systems if 
 e.g. the AVX code paths only run on newer chips.

* The fix is upstream for a while and not re-changed again. Furthermore 
  it is in several Ubuntu releases without bugs due to that, which should 
  make the backport rather safe.

  [Test Case]

   * Simple example to trigger the bug:

  echo "vmovaps 0x40(,%rax,1),%zmm0" | as --64 -o avx.o && objdump -d
  avx.o | grep vmovaps

  The expected output is that the objdump output matches the vmovaps
  instruction input. When using binutils with the bug, the initial 0x40
  will be incorrect.

  Working:
  $ echo "vmovaps 0x40(,%rax,1),%zmm0" | as --64 -o avx.o && objdump -d avx.o | 
grep vmovaps
 0: 62 f1 7c 48 28 04 05 vmovaps 0x40(,%rax,1),%zmm0
  Failing:
  $ echo "vmovaps 0x40(,%rax,1),%zmm0" | as --64 -o avx.o && objdump -d avx.o | 
grep vmovaps
 0: 62 f1 7c 48 28 04 05 vmovaps 0x1(,%rax,1),%zmm0

  [Regression Potential]

   * Well, this is a double edged sword. On one hand this is fortunately a 
 small change and only affects something formerly clearly broken. So it 
 should be good and only change cases formerly being bad.
 But OTOH binutils areused in so many cases that I feel unable to say
 "nothing will happen". The change goes to the gnu assembler, so that is 
 the place to look out for regressions.

  [Other Info]
   
   * needs a sponsor experienced with binutils to check potential pitfalls


  
  ---

  
  Hi,
  DPDK has run into some issues in the past
   https://bugs.dpdk.org/show_bug.cgi?id=97
   https://bugs.dpdk.org/show_bug.cgi?id=249

  Eventually the issues got resolved in binutils via
   https://sourceware.org/bugzilla/show_bug.cgi?id=23465

  After binutils is fixed people rebuilding DPDK themselve can use
   http://patches.dpdk.org/patch/71679/
  to gain more performance while on Bionics bintuils level.

  Note: Bionic is on DPDK 17.11.x which will not get further stable release 
afaik. But quite often people build their own DPDK. In fact this came up as a 
request from Openvswitch upstream/Intel to allow such builds on Bionic.
  I'd ping those people about the bug and ask them to participate in the 
verification if this becomes an SRU.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/binutils/+bug/1883880/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884455] Re: pulseaudio creates /root/.config/pulse/ before zfs-mount.service can mount the /root dataset

2020-06-22 Thread Daniel van Vugt
The existence of a file in /root and also:

  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1:
No PulseAudio daemon running, or not running as session daemon.

both suggest that your pulseaudio daemon is running in system-wide mode
when it shouldn't.

Please look in /etc/pulse/daemon.conf and make sure you DO NOT have
something like:

  daemonize = yes

** Changed in: pulseaudio (Ubuntu)
   Status: New => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1884455

Title:
  pulseaudio creates /root/.config/pulse/ before zfs-mount.service can
  mount the /root dataset

Status in pulseaudio package in Ubuntu:
  Incomplete

Bug description:
  I use 'zfs' and have /root as its own dataset which is mounted during
  startup by 'zfs-mount.service'.

  At one of the latest upgrades, the 'zfsutils-linux' package failed to
  update because the service 'zfs-mount' service had an issue and could
  not mount the '/root' dataset because the '/root' directory was not
  empty (temporary solution was to rename /root and call 'zfs mount'
  again).

  Further investigation shows that everytime at startup, the /root
  directory is created before the 'zfs-mount.service' has a chance to
  mount the 'root' dataset.

  The culprit seems to be something pulseaudio related: the content of /root 
folder after startup is as follows:
  -
  root@minighost:~# tree -a /root
  .
  ├── .cache
  └── .config
  └── pulse
  └── fe1417537ae0451abdb60c5df28fe825-runtime -> 
/tmp/pulse-PKdhtXMmr18n

  4 directories, 0 files
  root@minighost:~#
  -  


  Extra details:

  - Ubuntu release:
  -
  root@minighost:~# lsb_release -rd
  Description:  Ubuntu 20.04 LTS
  Release:  20.04
  -

  
  - status of 'zfs-mount.service' is the following:
  -  
  root@minighost:~# systemctl status zfs-mount
  ● zfs-mount.service - Mount ZFS filesystems
   Loaded: loaded (/lib/systemd/system/zfs-mount.service; enabled; vendor 
preset: enabled)
   Active: failed (Result: exit-code) since Sun 2020-06-21 12:56:08 CEST; 
6h ago
 Docs: man:zfs(8)
  Process: 2062 ExecStart=/sbin/zfs mount -a (code=exited, status=1/FAILURE)
 Main PID: 2062 (code=exited, status=1/FAILURE)

  Jun 21 12:56:08 minighost systemd[1]: Starting Mount ZFS filesystems...
  Jun 21 12:56:08 minighost zfs[2062]: cannot mount '/root': directory is not 
empty
  Jun 21 12:56:08 minighost systemd[1]: zfs-mount.service: Main process exited, 
code=exited, status=1/FAILURE
  Jun 21 12:56:08 minighost systemd[1]: zfs-mount.service: Failed with result 
'exit-code'.
  Jun 21 12:56:08 minighost systemd[1]: Failed to start Mount ZFS filesystems.
  root@minighost:~#
  -  


  - software versions:
  -
  root@minighost:~# apt-cache policy pulseaudio
  pulseaudio:
Installed: 1:13.99.1-1ubuntu3.3
Candidate: 1:13.99.1-1ubuntu3.3
Version table:
   *** 1:13.99.1-1ubuntu3.3 500
  500 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages
  100 /var/lib/dpkg/status
   1:13.99.1-1ubuntu3.2 500
  500 http://security.ubuntu.com/ubuntu focal-security/main amd64 
Packages
   1:13.99.1-1ubuntu3 500
  500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages

  root@minighost:~# apt-cache policy zfsutils-linux
  zfsutils-linux:
Installed: 0.8.3-1ubuntu12.1
Candidate: 0.8.3-1ubuntu12.1
Version table:
   *** 0.8.3-1ubuntu12.1 500
  500 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages
  100 /var/lib/dpkg/status
   0.8.3-1ubuntu12 500
  500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages
  -

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: pulseaudio 1:13.99.1-1ubuntu3.3
  ProcVersionSignature: Ubuntu 5.4.0-37.41-generic 5.4.41
  Uname: Linux 5.4.0-37-generic x86_64
  NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
  ApportVersion: 2.20.11-0ubuntu27.3
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  dumi   2419 F pulseaudio
  CasperMD5CheckResult: skip
  Date: Sun Jun 21 19:17:20 2020
  InstallationDate: Installed on 2018-09-08 (651 days ago)
  InstallationMedia: Ubuntu 18.04 "Bionic" - Build amd64 LIVE Binary 
20180608-09:38
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
  SourcePackage: pulseaudio
  UpgradeStatus: Upgraded to focal on 2020-04-24 (57 days ago)
  dmi.bios.date: 12/11/2019
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.12.1
  dmi.board.name: 0F6P3V
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 10
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 

[Touch-packages] [Bug 1884437] Re: Windows are resized and reordered upon resume from lock or suspend

2020-06-22 Thread Daniel van Vugt
The XorgLog files seem to show at least one of the monitors being
redetected, like it was unplugged and replugged. If Xorg thinks that's
happening then yes windows would move to one screen. Please try a
different DisplayPort cable.

Also, please check that your gnome-shell process ID is the same before
and after lock/suspend, by running:

  pidof gnome-shell

both before and after.

** Package changed: xorg (Ubuntu) => gnome-shell (Ubuntu)

** Changed in: gnome-shell (Ubuntu)
   Status: New => Incomplete

** Tags added: multimonitor

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1884437

Title:
  Windows are resized and reordered upon resume from lock or suspend

Status in gnome-shell package in Ubuntu:
  Incomplete

Bug description:
  After a resume from a lock/suspend, windows sizes are changed, fonts
  are incorrect sizes (until mouse over), and windows have moved from
  the secondary monitor to the primary monitor. This happens every time
  the displays have been off (from a suspend or lock screen). AMD
  graphics with dual 4K displays.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: xorg 1:7.7+19ubuntu14
  ProcVersionSignature: Ubuntu 5.4.0-21.25-generic 5.4.27
  Uname: Linux 5.4.0-21-generic x86_64
  NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
  ApportVersion: 2.20.11-0ubuntu27.3
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Sun Jun 21 07:46:41 2020
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroVariant: ubuntu
  DkmsStatus:
   asus-wmi-sensors, b6c25d2, 5.4.0-21-generic, x86_64: installed
   asus-wmi-sensors, b6c25d2, 5.4.0-33-generic, x86_64: installed
   asus-wmi-sensors, b6c25d2, 5.4.0-37-generic, x86_64: installed
   virtualbox, 6.1.6, 5.4.0-33-generic, x86_64: installed
   virtualbox, 6.1.6, 5.4.0-37-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Advanced Micro Devices, Inc. [AMD/ATI] Vega 10 XL/XT [Radeon RX Vega 56/64] 
[1002:687f] (rev c1) (prog-if 00 [VGA controller])
 Subsystem: Micro-Star International Co., Ltd. [MSI] Vega 10 XL/XT [Radeon 
RX Vega 56/64] [1462:3680]
  InstallationDate: Installed on 2020-03-07 (105 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200304)
  MachineType: System manufacturer System Product Name
  ProcEnviron:
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/usr/bin/zsh
  ProcKernelCmdLine: BOOT_IMAGE=/BOOT/ubuntu_xbqp91@/vmlinuz-5.4.0-21-generic 
root=ZFS=rpool/ROOT/ubuntu_xbqp91 ro quiet splash
  SourcePackage: xorg
  Symptom: display
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 11/13/2019
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 5406
  dmi.board.asset.tag: Default string
  dmi.board.name: PRIME X470-PRO
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: Rev X.0x
  dmi.chassis.asset.tag: Default string
  dmi.chassis.type: 3
  dmi.chassis.vendor: Default string
  dmi.chassis.version: Default string
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr5406:bd11/13/2019:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnPRIMEX470-PRO:rvrRevX.0x:cvnDefaultstring:ct3:cvrDefaultstring:
  dmi.product.family: To be filled by O.E.M.
  dmi.product.name: System Product Name
  dmi.product.sku: SKU
  dmi.product.version: System Version
  dmi.sys.vendor: System manufacturer
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.4-2ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.4-2ubuntu1
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1884437/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884396] Re: Ubuntu freezing intermittently

2020-06-22 Thread Daniel van Vugt
Please:

1. Run the 'Extensions' app and check you don't have any non-Ubuntu
extensions enabled. If you do then please turn them off.

2. Immediately after the next freeze please run:

   journalctl -b0 > journal.txt

   and then attach the resulting file here.

3. Also leave 'top' running in a Terminal window and tell us if any
process is using high CPU, particularly around the time of a freeze.


** Package changed: xorg (Ubuntu) => gnome-shell (Ubuntu)

** Changed in: gnome-shell (Ubuntu)
   Status: New => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1884396

Title:
  Ubuntu freezing intermittently

Status in gnome-shell package in Ubuntu:
  Incomplete

Bug description:
  I had similar issues when 20.04 was released, then it disappeared with
  an upgrade - but sadly it's back. I have short intermittent freezings
  of the OS. About every 15-30 seconds Ubunut freezes for a second or
  two. Eg when writing this description, the OS freezes every second
  word. When the freeze goes away the OS is snappy. I have tried
  switching between Wayland and Xorg - but the problem persists. If I
  write something when it freezes up the last
  character will be replicated many times -
  like what happened jut now. This
  problem did not show up in ubuntu 18.04 through 19.10. Hope U can
  fix this soon - using my laptop in unbearable.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: xorg 1:7.7+19ubuntu14
  ProcVersionSignature: Ubuntu 5.4.0-37.41-generic 5.4.41
  Uname: Linux 5.4.0-37-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.3
  Architecture: amd64
  BootLog: Error: [Errno 13] Åtkomst nekas: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Sat Jun 20 23:54:52 2020
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroVariant: ubuntu
  DkmsStatus: evdi, 1.7.0, 5.4.0-33-generic, x86_64: installed
  ExtraDebuggingInterest: Yes, if not too technical
  GraphicsCard:
   Intel Corporation UHD Graphics 620 [8086:5917] (rev 07) (prog-if 00 [VGA 
controller])
 Subsystem: Huawei Technologies Co., Ltd. UHD Graphics 620 [19e5:3e04]
  InstallationDate: Installed on 2020-05-12 (38 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 05c8:03c0 Cheng Uei Precision Industry Co., Ltd 
(Foxlink) HD Camera
   Bus 001 Device 002: ID 8087:0a2b Intel Corp. 
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: HUAWEI MACH-WX9
  ProcEnviron:
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=sv_SE.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-37-generic 
root=UUID=a2cbbb7f-c619-418a-a98f-9a9cc31b42fa ro quiet splash vt.handoff=7
  SourcePackage: xorg
  Symptom: display
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 03/15/2019
  dmi.bios.vendor: HUAWEI
  dmi.bios.version: 1.28
  dmi.board.name: MACH-WX9-PCB
  dmi.board.vendor: HUAWEI
  dmi.board.version: M13
  dmi.chassis.type: 10
  dmi.chassis.vendor: HUAWEI
  dmi.chassis.version: M13
  dmi.modalias: 
dmi:bvnHUAWEI:bvr1.28:bd03/15/2019:svnHUAWEI:pnMACH-WX9:pvrM13:rvnHUAWEI:rnMACH-WX9-PCB:rvrM13:cvnHUAWEI:ct10:cvrM13:
  dmi.product.family: MateBook X
  dmi.product.name: MACH-WX9
  dmi.product.sku: C189
  dmi.product.version: M13
  dmi.sys.vendor: HUAWEI
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.4-2ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1884396/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp