[Touch-packages] [Bug 1890772] Re: Some external 4K monitor is not working properly

2020-08-06 Thread Daniel van Vugt
There doesn't seem to be any external monitor connected to this machine,
or any 'DP-3' connector.

Please attach 'xrandr --verbose' info with a monitor connected showing
the problem, or please open a new bug from the affected machine.

** Package changed: xorg (Ubuntu) => xorg-server (Ubuntu)

** Changed in: xorg-server (Ubuntu)
   Status: New => Incomplete

** Changed in: oem-priority
   Status: New => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1890772

Title:
  Some external 4K monitor is not working properly

Status in OEM Priority Project:
  Incomplete
Status in xorg-server package in Ubuntu:
  Incomplete

Bug description:
  The bug is originated from,
  https://bugs.launchpad.net/somerville/+bug/1887915/
  https://bugs.launchpad.net/somerville/+bug/1886778

  It has some problem when user connect to external 4K monitor with refresh 
rate 60.
  The problem can be solved by lower the bpc, or lower the refresh rate.

  `xrandr --output DP-3 --set "max bpc" 8`

  Would like to open this bug to open discussion for enhancing user experience.
  ---
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27.4
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistributionChannelDescriptor:
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-focal-amd64-20200502-85+fossa-samwell-tgl+X42
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus: nvidia, 440.100, 5.6.0-1021-oem, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Device [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:09fc]
     Subsystem: Dell GP107M [GeForce MX350] [1028:09fc]
  InstallationDate: Installed on 2020-08-07 (0 days ago)
  InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 
20200502-05:58
  MachineType: Dell Inc. Vostro 5301
  Package: xorg 1:7.7+19ubuntu14 [origin: unknown]
  PackageArchitecture: amd64
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.6.0-1021-oem 
root=UUID=41be2253-410a-4ef7-a096-4193a58efdbd ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.6.0-1021.21-oem 5.6.19
  Tags: third-party-packages focal ubuntu
  Uname: Linux 5.6.0-1021-oem x86_64
  UnreportableReason: This is not an official Ubuntu package. Please remove any 
third party package and try again.
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~20.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1890772/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890772] Re: Some external 4K monitor is not working properly

2020-08-06 Thread Shih-Yuan Lee
** Also affects: oem-priority
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1890772

Title:
  Some external 4K monitor is not working properly

Status in OEM Priority Project:
  Incomplete
Status in xorg-server package in Ubuntu:
  Incomplete

Bug description:
  The bug is originated from,
  https://bugs.launchpad.net/somerville/+bug/1887915/
  https://bugs.launchpad.net/somerville/+bug/1886778

  It has some problem when user connect to external 4K monitor with refresh 
rate 60.
  The problem can be solved by lower the bpc, or lower the refresh rate.

  `xrandr --output DP-3 --set "max bpc" 8`

  Would like to open this bug to open discussion for enhancing user experience.
  ---
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27.4
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistributionChannelDescriptor:
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-focal-amd64-20200502-85+fossa-samwell-tgl+X42
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus: nvidia, 440.100, 5.6.0-1021-oem, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Device [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:09fc]
     Subsystem: Dell GP107M [GeForce MX350] [1028:09fc]
  InstallationDate: Installed on 2020-08-07 (0 days ago)
  InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 
20200502-05:58
  MachineType: Dell Inc. Vostro 5301
  Package: xorg 1:7.7+19ubuntu14 [origin: unknown]
  PackageArchitecture: amd64
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.6.0-1021-oem 
root=UUID=41be2253-410a-4ef7-a096-4193a58efdbd ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.6.0-1021.21-oem 5.6.19
  Tags: third-party-packages focal ubuntu
  Uname: Linux 5.6.0-1021-oem x86_64
  UnreportableReason: This is not an official Ubuntu package. Please remove any 
third party package and try again.
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~20.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1890772/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890772] ProcCpuinfo.txt

2020-08-06 Thread Kai-Chuan Hsieh
apport information

** Attachment added: "ProcCpuinfo.txt"
   
https://bugs.launchpad.net/bugs/1890772/+attachment/5399479/+files/ProcCpuinfo.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1890772

Title:
  Some external 4K monitor is not working properly

Status in OEM Priority Project:
  New
Status in xorg package in Ubuntu:
  New

Bug description:
  The bug is originated from,
  https://bugs.launchpad.net/somerville/+bug/1887915/
  https://bugs.launchpad.net/somerville/+bug/1886778

  It has some problem when user connect to external 4K monitor with refresh 
rate 60.
  The problem can be solved by lower the bpc, or lower the refresh rate.

  `xrandr --output DP-3 --set "max bpc" 8`

  Would like to open this bug to open discussion for enhancing user experience.
  ---
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27.4
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistributionChannelDescriptor:
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-focal-amd64-20200502-85+fossa-samwell-tgl+X42
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus: nvidia, 440.100, 5.6.0-1021-oem, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Device [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:09fc]
     Subsystem: Dell GP107M [GeForce MX350] [1028:09fc]
  InstallationDate: Installed on 2020-08-07 (0 days ago)
  InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 
20200502-05:58
  MachineType: Dell Inc. Vostro 5301
  Package: xorg 1:7.7+19ubuntu14 [origin: unknown]
  PackageArchitecture: amd64
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.6.0-1021-oem 
root=UUID=41be2253-410a-4ef7-a096-4193a58efdbd ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.6.0-1021.21-oem 5.6.19
  Tags: third-party-packages focal ubuntu
  Uname: Linux 5.6.0-1021-oem x86_64
  UnreportableReason: This is not an official Ubuntu package. Please remove any 
third party package and try again.
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~20.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1890772/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890772] xdpyinfo.txt

2020-08-06 Thread Kai-Chuan Hsieh
apport information

** Attachment added: "xdpyinfo.txt"
   
https://bugs.launchpad.net/bugs/1890772/+attachment/5399488/+files/xdpyinfo.txt

** Description changed:

  The bug is originated from,
  https://bugs.launchpad.net/somerville/+bug/1887915/
  https://bugs.launchpad.net/somerville/+bug/1886778
  
  It has some problem when user connect to external 4K monitor with refresh 
rate 60.
  The problem can be solved by lower the bpc, or lower the refresh rate.
  
  `xrandr --output DP-3 --set "max bpc" 8`
  
  Would like to open this bug to open discussion for enhancing user experience.
- --- 
+ ---
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27.4
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistributionChannelDescriptor:
-  # This is the distribution channel descriptor for the OEM CDs
-  # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
-  canonical-oem-somerville-focal-amd64-20200502-85+fossa-samwell-tgl+X42
+  # This is the distribution channel descriptor for the OEM CDs
+  # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
+  canonical-oem-somerville-focal-amd64-20200502-85+fossa-samwell-tgl+X42
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus: nvidia, 440.100, 5.6.0-1021-oem, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
-  Intel Corporation Device [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
-Subsystem: Dell Device [1028:09fc]
-Subsystem: Dell GP107M [GeForce MX350] [1028:09fc]
+  Intel Corporation Device [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
+    Subsystem: Dell Device [1028:09fc]
+    Subsystem: Dell GP107M [GeForce MX350] [1028:09fc]
  InstallationDate: Installed on 2020-08-07 (0 days ago)
  InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 
20200502-05:58
  MachineType: Dell Inc. Vostro 5301
  Package: xorg 1:7.7+19ubuntu14 [origin: unknown]
  PackageArchitecture: amd64
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.6.0-1021-oem 
root=UUID=41be2253-410a-4ef7-a096-4193a58efdbd ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.6.0-1021.21-oem 5.6.19
  Tags: third-party-packages focal ubuntu
  Uname: Linux 5.6.0-1021-oem x86_64
  UnreportableReason: This is not an official Ubuntu package. Please remove any 
third party package and try again.
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
- dmi.bios.date: 08/03/2020
- dmi.bios.vendor: Dell Inc.
- dmi.bios.version: 0.6.0
- dmi.board.vendor: Dell Inc.
- dmi.chassis.type: 10
- dmi.chassis.vendor: Dell Inc.
- dmi.modalias: 
dmi:bvnDellInc.:bvr0.6.0:bd08/03/2020:svnDellInc.:pnVostro5301:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct10:cvr:
- dmi.product.family: Vostro
- dmi.product.name: Vostro 5301
- dmi.product.sku: 09FC
- dmi.sys.vendor: Dell Inc.
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~20.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1890772

Title:
  Some external 4K monitor is not working properly

Status in OEM Priority Project:
  New
Status in xorg package in Ubuntu:
  New

Bug description:
  The bug is originated from,
  https://bugs.launchpad.net/somerville/+bug/1887915/
  https://bugs.launchpad.net/somerville/+bug/1886778

  It has some problem when user connect to external 4K monitor with refresh 
rate 60.
  The problem can be solved by lower the bpc, or lower the refresh rate.

  `xrandr --output DP-3 --set "max bpc" 8`

  Would like to open this bug to open discussion for enhancing user experience.
  ---
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27.4
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistributionChannelDescriptor:
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-focal-amd64-20200502-85+fossa-samwell-tgl+X42
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  

[Touch-packages] [Bug 1890772] ProcCpuinfoMinimal.txt

2020-08-06 Thread Kai-Chuan Hsieh
apport information

** Attachment added: "ProcCpuinfoMinimal.txt"
   
https://bugs.launchpad.net/bugs/1890772/+attachment/5399480/+files/ProcCpuinfoMinimal.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1890772

Title:
  Some external 4K monitor is not working properly

Status in OEM Priority Project:
  New
Status in xorg package in Ubuntu:
  New

Bug description:
  The bug is originated from,
  https://bugs.launchpad.net/somerville/+bug/1887915/
  https://bugs.launchpad.net/somerville/+bug/1886778

  It has some problem when user connect to external 4K monitor with refresh 
rate 60.
  The problem can be solved by lower the bpc, or lower the refresh rate.

  `xrandr --output DP-3 --set "max bpc" 8`

  Would like to open this bug to open discussion for enhancing user experience.
  ---
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27.4
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistributionChannelDescriptor:
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-focal-amd64-20200502-85+fossa-samwell-tgl+X42
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus: nvidia, 440.100, 5.6.0-1021-oem, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Device [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:09fc]
     Subsystem: Dell GP107M [GeForce MX350] [1028:09fc]
  InstallationDate: Installed on 2020-08-07 (0 days ago)
  InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 
20200502-05:58
  MachineType: Dell Inc. Vostro 5301
  Package: xorg 1:7.7+19ubuntu14 [origin: unknown]
  PackageArchitecture: amd64
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.6.0-1021-oem 
root=UUID=41be2253-410a-4ef7-a096-4193a58efdbd ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.6.0-1021.21-oem 5.6.19
  Tags: third-party-packages focal ubuntu
  Uname: Linux 5.6.0-1021-oem x86_64
  UnreportableReason: This is not an official Ubuntu package. Please remove any 
third party package and try again.
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~20.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1890772/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890772] XorgLogOld.txt

2020-08-06 Thread Kai-Chuan Hsieh
apport information

** Attachment added: "XorgLogOld.txt"
   
https://bugs.launchpad.net/bugs/1890772/+attachment/5399486/+files/XorgLogOld.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1890772

Title:
  Some external 4K monitor is not working properly

Status in OEM Priority Project:
  New
Status in xorg package in Ubuntu:
  New

Bug description:
  The bug is originated from,
  https://bugs.launchpad.net/somerville/+bug/1887915/
  https://bugs.launchpad.net/somerville/+bug/1886778

  It has some problem when user connect to external 4K monitor with refresh 
rate 60.
  The problem can be solved by lower the bpc, or lower the refresh rate.

  `xrandr --output DP-3 --set "max bpc" 8`

  Would like to open this bug to open discussion for enhancing user experience.
  ---
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27.4
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistributionChannelDescriptor:
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-focal-amd64-20200502-85+fossa-samwell-tgl+X42
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus: nvidia, 440.100, 5.6.0-1021-oem, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Device [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:09fc]
     Subsystem: Dell GP107M [GeForce MX350] [1028:09fc]
  InstallationDate: Installed on 2020-08-07 (0 days ago)
  InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 
20200502-05:58
  MachineType: Dell Inc. Vostro 5301
  Package: xorg 1:7.7+19ubuntu14 [origin: unknown]
  PackageArchitecture: amd64
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.6.0-1021-oem 
root=UUID=41be2253-410a-4ef7-a096-4193a58efdbd ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.6.0-1021.21-oem 5.6.19
  Tags: third-party-packages focal ubuntu
  Uname: Linux 5.6.0-1021-oem x86_64
  UnreportableReason: This is not an official Ubuntu package. Please remove any 
third party package and try again.
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~20.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1890772/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890772] XorgLog.txt

2020-08-06 Thread Kai-Chuan Hsieh
apport information

** Attachment added: "XorgLog.txt"
   
https://bugs.launchpad.net/bugs/1890772/+attachment/5399485/+files/XorgLog.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1890772

Title:
  Some external 4K monitor is not working properly

Status in OEM Priority Project:
  New
Status in xorg package in Ubuntu:
  New

Bug description:
  The bug is originated from,
  https://bugs.launchpad.net/somerville/+bug/1887915/
  https://bugs.launchpad.net/somerville/+bug/1886778

  It has some problem when user connect to external 4K monitor with refresh 
rate 60.
  The problem can be solved by lower the bpc, or lower the refresh rate.

  `xrandr --output DP-3 --set "max bpc" 8`

  Would like to open this bug to open discussion for enhancing user experience.
  ---
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27.4
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistributionChannelDescriptor:
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-focal-amd64-20200502-85+fossa-samwell-tgl+X42
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus: nvidia, 440.100, 5.6.0-1021-oem, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Device [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:09fc]
     Subsystem: Dell GP107M [GeForce MX350] [1028:09fc]
  InstallationDate: Installed on 2020-08-07 (0 days ago)
  InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 
20200502-05:58
  MachineType: Dell Inc. Vostro 5301
  Package: xorg 1:7.7+19ubuntu14 [origin: unknown]
  PackageArchitecture: amd64
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.6.0-1021-oem 
root=UUID=41be2253-410a-4ef7-a096-4193a58efdbd ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.6.0-1021.21-oem 5.6.19
  Tags: third-party-packages focal ubuntu
  Uname: Linux 5.6.0-1021-oem x86_64
  UnreportableReason: This is not an official Ubuntu package. Please remove any 
third party package and try again.
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~20.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1890772/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890772] UdevDb.txt

2020-08-06 Thread Kai-Chuan Hsieh
apport information

** Attachment added: "UdevDb.txt"
   https://bugs.launchpad.net/bugs/1890772/+attachment/5399484/+files/UdevDb.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1890772

Title:
  Some external 4K monitor is not working properly

Status in OEM Priority Project:
  New
Status in xorg package in Ubuntu:
  New

Bug description:
  The bug is originated from,
  https://bugs.launchpad.net/somerville/+bug/1887915/
  https://bugs.launchpad.net/somerville/+bug/1886778

  It has some problem when user connect to external 4K monitor with refresh 
rate 60.
  The problem can be solved by lower the bpc, or lower the refresh rate.

  `xrandr --output DP-3 --set "max bpc" 8`

  Would like to open this bug to open discussion for enhancing user experience.
  ---
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27.4
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistributionChannelDescriptor:
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-focal-amd64-20200502-85+fossa-samwell-tgl+X42
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus: nvidia, 440.100, 5.6.0-1021-oem, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Device [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:09fc]
     Subsystem: Dell GP107M [GeForce MX350] [1028:09fc]
  InstallationDate: Installed on 2020-08-07 (0 days ago)
  InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 
20200502-05:58
  MachineType: Dell Inc. Vostro 5301
  Package: xorg 1:7.7+19ubuntu14 [origin: unknown]
  PackageArchitecture: amd64
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.6.0-1021-oem 
root=UUID=41be2253-410a-4ef7-a096-4193a58efdbd ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.6.0-1021.21-oem 5.6.19
  Tags: third-party-packages focal ubuntu
  Uname: Linux 5.6.0-1021-oem x86_64
  UnreportableReason: This is not an official Ubuntu package. Please remove any 
third party package and try again.
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~20.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1890772/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890772] ProcModules.txt

2020-08-06 Thread Kai-Chuan Hsieh
apport information

** Attachment added: "ProcModules.txt"
   
https://bugs.launchpad.net/bugs/1890772/+attachment/5399483/+files/ProcModules.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1890772

Title:
  Some external 4K monitor is not working properly

Status in OEM Priority Project:
  New
Status in xorg package in Ubuntu:
  New

Bug description:
  The bug is originated from,
  https://bugs.launchpad.net/somerville/+bug/1887915/
  https://bugs.launchpad.net/somerville/+bug/1886778

  It has some problem when user connect to external 4K monitor with refresh 
rate 60.
  The problem can be solved by lower the bpc, or lower the refresh rate.

  `xrandr --output DP-3 --set "max bpc" 8`

  Would like to open this bug to open discussion for enhancing user experience.
  ---
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27.4
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistributionChannelDescriptor:
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-focal-amd64-20200502-85+fossa-samwell-tgl+X42
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus: nvidia, 440.100, 5.6.0-1021-oem, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Device [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:09fc]
     Subsystem: Dell GP107M [GeForce MX350] [1028:09fc]
  InstallationDate: Installed on 2020-08-07 (0 days ago)
  InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 
20200502-05:58
  MachineType: Dell Inc. Vostro 5301
  Package: xorg 1:7.7+19ubuntu14 [origin: unknown]
  PackageArchitecture: amd64
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.6.0-1021-oem 
root=UUID=41be2253-410a-4ef7-a096-4193a58efdbd ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.6.0-1021.21-oem 5.6.19
  Tags: third-party-packages focal ubuntu
  Uname: Linux 5.6.0-1021-oem x86_64
  UnreportableReason: This is not an official Ubuntu package. Please remove any 
third party package and try again.
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~20.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1890772/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890772] Xrandr.txt

2020-08-06 Thread Kai-Chuan Hsieh
apport information

** Attachment added: "Xrandr.txt"
   https://bugs.launchpad.net/bugs/1890772/+attachment/5399487/+files/Xrandr.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1890772

Title:
  Some external 4K monitor is not working properly

Status in OEM Priority Project:
  New
Status in xorg package in Ubuntu:
  New

Bug description:
  The bug is originated from,
  https://bugs.launchpad.net/somerville/+bug/1887915/
  https://bugs.launchpad.net/somerville/+bug/1886778

  It has some problem when user connect to external 4K monitor with refresh 
rate 60.
  The problem can be solved by lower the bpc, or lower the refresh rate.

  `xrandr --output DP-3 --set "max bpc" 8`

  Would like to open this bug to open discussion for enhancing user experience.
  ---
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27.4
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistributionChannelDescriptor:
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-focal-amd64-20200502-85+fossa-samwell-tgl+X42
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus: nvidia, 440.100, 5.6.0-1021-oem, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Device [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:09fc]
     Subsystem: Dell GP107M [GeForce MX350] [1028:09fc]
  InstallationDate: Installed on 2020-08-07 (0 days ago)
  InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 
20200502-05:58
  MachineType: Dell Inc. Vostro 5301
  Package: xorg 1:7.7+19ubuntu14 [origin: unknown]
  PackageArchitecture: amd64
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.6.0-1021-oem 
root=UUID=41be2253-410a-4ef7-a096-4193a58efdbd ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.6.0-1021.21-oem 5.6.19
  Tags: third-party-packages focal ubuntu
  Uname: Linux 5.6.0-1021-oem x86_64
  UnreportableReason: This is not an official Ubuntu package. Please remove any 
third party package and try again.
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~20.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1890772/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890772] ProcInterrupts.txt

2020-08-06 Thread Kai-Chuan Hsieh
apport information

** Attachment added: "ProcInterrupts.txt"
   
https://bugs.launchpad.net/bugs/1890772/+attachment/5399482/+files/ProcInterrupts.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1890772

Title:
  Some external 4K monitor is not working properly

Status in OEM Priority Project:
  New
Status in xorg package in Ubuntu:
  New

Bug description:
  The bug is originated from,
  https://bugs.launchpad.net/somerville/+bug/1887915/
  https://bugs.launchpad.net/somerville/+bug/1886778

  It has some problem when user connect to external 4K monitor with refresh 
rate 60.
  The problem can be solved by lower the bpc, or lower the refresh rate.

  `xrandr --output DP-3 --set "max bpc" 8`

  Would like to open this bug to open discussion for enhancing user experience.
  ---
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27.4
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistributionChannelDescriptor:
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-focal-amd64-20200502-85+fossa-samwell-tgl+X42
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus: nvidia, 440.100, 5.6.0-1021-oem, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Device [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:09fc]
     Subsystem: Dell GP107M [GeForce MX350] [1028:09fc]
  InstallationDate: Installed on 2020-08-07 (0 days ago)
  InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 
20200502-05:58
  MachineType: Dell Inc. Vostro 5301
  Package: xorg 1:7.7+19ubuntu14 [origin: unknown]
  PackageArchitecture: amd64
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.6.0-1021-oem 
root=UUID=41be2253-410a-4ef7-a096-4193a58efdbd ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.6.0-1021.21-oem 5.6.19
  Tags: third-party-packages focal ubuntu
  Uname: Linux 5.6.0-1021-oem x86_64
  UnreportableReason: This is not an official Ubuntu package. Please remove any 
third party package and try again.
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~20.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1890772/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890772] Lsusb-v.txt

2020-08-06 Thread Kai-Chuan Hsieh
apport information

** Attachment added: "Lsusb-v.txt"
   
https://bugs.launchpad.net/bugs/1890772/+attachment/5399478/+files/Lsusb-v.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1890772

Title:
  Some external 4K monitor is not working properly

Status in OEM Priority Project:
  New
Status in xorg package in Ubuntu:
  New

Bug description:
  The bug is originated from,
  https://bugs.launchpad.net/somerville/+bug/1887915/
  https://bugs.launchpad.net/somerville/+bug/1886778

  It has some problem when user connect to external 4K monitor with refresh 
rate 60.
  The problem can be solved by lower the bpc, or lower the refresh rate.

  `xrandr --output DP-3 --set "max bpc" 8`

  Would like to open this bug to open discussion for enhancing user experience.
  ---
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27.4
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistributionChannelDescriptor:
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-focal-amd64-20200502-85+fossa-samwell-tgl+X42
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus: nvidia, 440.100, 5.6.0-1021-oem, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Device [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:09fc]
     Subsystem: Dell GP107M [GeForce MX350] [1028:09fc]
  InstallationDate: Installed on 2020-08-07 (0 days ago)
  InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 
20200502-05:58
  MachineType: Dell Inc. Vostro 5301
  Package: xorg 1:7.7+19ubuntu14 [origin: unknown]
  PackageArchitecture: amd64
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.6.0-1021-oem 
root=UUID=41be2253-410a-4ef7-a096-4193a58efdbd ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.6.0-1021.21-oem 5.6.19
  Tags: third-party-packages focal ubuntu
  Uname: Linux 5.6.0-1021-oem x86_64
  UnreportableReason: This is not an official Ubuntu package. Please remove any 
third party package and try again.
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~20.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1890772/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890772] DpkgLog.txt

2020-08-06 Thread Kai-Chuan Hsieh
apport information

** Attachment added: "DpkgLog.txt"
   
https://bugs.launchpad.net/bugs/1890772/+attachment/5399473/+files/DpkgLog.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1890772

Title:
  Some external 4K monitor is not working properly

Status in OEM Priority Project:
  New
Status in xorg package in Ubuntu:
  New

Bug description:
  The bug is originated from,
  https://bugs.launchpad.net/somerville/+bug/1887915/
  https://bugs.launchpad.net/somerville/+bug/1886778

  It has some problem when user connect to external 4K monitor with refresh 
rate 60.
  The problem can be solved by lower the bpc, or lower the refresh rate.

  `xrandr --output DP-3 --set "max bpc" 8`

  Would like to open this bug to open discussion for enhancing user experience.
  ---
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27.4
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistributionChannelDescriptor:
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-focal-amd64-20200502-85+fossa-samwell-tgl+X42
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus: nvidia, 440.100, 5.6.0-1021-oem, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Device [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:09fc]
     Subsystem: Dell GP107M [GeForce MX350] [1028:09fc]
  InstallationDate: Installed on 2020-08-07 (0 days ago)
  InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 
20200502-05:58
  MachineType: Dell Inc. Vostro 5301
  Package: xorg 1:7.7+19ubuntu14 [origin: unknown]
  PackageArchitecture: amd64
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.6.0-1021-oem 
root=UUID=41be2253-410a-4ef7-a096-4193a58efdbd ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.6.0-1021.21-oem 5.6.19
  Tags: third-party-packages focal ubuntu
  Uname: Linux 5.6.0-1021-oem x86_64
  UnreportableReason: This is not an official Ubuntu package. Please remove any 
third party package and try again.
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~20.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1890772/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890772] ProcEnviron.txt

2020-08-06 Thread Kai-Chuan Hsieh
apport information

** Attachment added: "ProcEnviron.txt"
   
https://bugs.launchpad.net/bugs/1890772/+attachment/5399481/+files/ProcEnviron.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1890772

Title:
  Some external 4K monitor is not working properly

Status in OEM Priority Project:
  New
Status in xorg package in Ubuntu:
  New

Bug description:
  The bug is originated from,
  https://bugs.launchpad.net/somerville/+bug/1887915/
  https://bugs.launchpad.net/somerville/+bug/1886778

  It has some problem when user connect to external 4K monitor with refresh 
rate 60.
  The problem can be solved by lower the bpc, or lower the refresh rate.

  `xrandr --output DP-3 --set "max bpc" 8`

  Would like to open this bug to open discussion for enhancing user experience.
  ---
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27.4
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistributionChannelDescriptor:
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-focal-amd64-20200502-85+fossa-samwell-tgl+X42
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus: nvidia, 440.100, 5.6.0-1021-oem, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Device [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:09fc]
     Subsystem: Dell GP107M [GeForce MX350] [1028:09fc]
  InstallationDate: Installed on 2020-08-07 (0 days ago)
  InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 
20200502-05:58
  MachineType: Dell Inc. Vostro 5301
  Package: xorg 1:7.7+19ubuntu14 [origin: unknown]
  PackageArchitecture: amd64
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.6.0-1021-oem 
root=UUID=41be2253-410a-4ef7-a096-4193a58efdbd ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.6.0-1021.21-oem 5.6.19
  Tags: third-party-packages focal ubuntu
  Uname: Linux 5.6.0-1021-oem x86_64
  UnreportableReason: This is not an official Ubuntu package. Please remove any 
third party package and try again.
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~20.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1890772/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890772] Lsusb.txt

2020-08-06 Thread Kai-Chuan Hsieh
apport information

** Attachment added: "Lsusb.txt"
   https://bugs.launchpad.net/bugs/1890772/+attachment/5399476/+files/Lsusb.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1890772

Title:
  Some external 4K monitor is not working properly

Status in OEM Priority Project:
  New
Status in xorg package in Ubuntu:
  New

Bug description:
  The bug is originated from,
  https://bugs.launchpad.net/somerville/+bug/1887915/
  https://bugs.launchpad.net/somerville/+bug/1886778

  It has some problem when user connect to external 4K monitor with refresh 
rate 60.
  The problem can be solved by lower the bpc, or lower the refresh rate.

  `xrandr --output DP-3 --set "max bpc" 8`

  Would like to open this bug to open discussion for enhancing user experience.
  ---
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27.4
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistributionChannelDescriptor:
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-focal-amd64-20200502-85+fossa-samwell-tgl+X42
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus: nvidia, 440.100, 5.6.0-1021-oem, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Device [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:09fc]
     Subsystem: Dell GP107M [GeForce MX350] [1028:09fc]
  InstallationDate: Installed on 2020-08-07 (0 days ago)
  InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 
20200502-05:58
  MachineType: Dell Inc. Vostro 5301
  Package: xorg 1:7.7+19ubuntu14 [origin: unknown]
  PackageArchitecture: amd64
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.6.0-1021-oem 
root=UUID=41be2253-410a-4ef7-a096-4193a58efdbd ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.6.0-1021.21-oem 5.6.19
  Tags: third-party-packages focal ubuntu
  Uname: Linux 5.6.0-1021-oem x86_64
  UnreportableReason: This is not an official Ubuntu package. Please remove any 
third party package and try again.
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~20.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1890772/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890772] Lsusb-t.txt

2020-08-06 Thread Kai-Chuan Hsieh
apport information

** Attachment added: "Lsusb-t.txt"
   
https://bugs.launchpad.net/bugs/1890772/+attachment/5399477/+files/Lsusb-t.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1890772

Title:
  Some external 4K monitor is not working properly

Status in OEM Priority Project:
  New
Status in xorg package in Ubuntu:
  New

Bug description:
  The bug is originated from,
  https://bugs.launchpad.net/somerville/+bug/1887915/
  https://bugs.launchpad.net/somerville/+bug/1886778

  It has some problem when user connect to external 4K monitor with refresh 
rate 60.
  The problem can be solved by lower the bpc, or lower the refresh rate.

  `xrandr --output DP-3 --set "max bpc" 8`

  Would like to open this bug to open discussion for enhancing user experience.
  ---
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27.4
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistributionChannelDescriptor:
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-focal-amd64-20200502-85+fossa-samwell-tgl+X42
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus: nvidia, 440.100, 5.6.0-1021-oem, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Device [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:09fc]
     Subsystem: Dell GP107M [GeForce MX350] [1028:09fc]
  InstallationDate: Installed on 2020-08-07 (0 days ago)
  InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 
20200502-05:58
  MachineType: Dell Inc. Vostro 5301
  Package: xorg 1:7.7+19ubuntu14 [origin: unknown]
  PackageArchitecture: amd64
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.6.0-1021-oem 
root=UUID=41be2253-410a-4ef7-a096-4193a58efdbd ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.6.0-1021.21-oem 5.6.19
  Tags: third-party-packages focal ubuntu
  Uname: Linux 5.6.0-1021-oem x86_64
  UnreportableReason: This is not an official Ubuntu package. Please remove any 
third party package and try again.
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~20.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1890772/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890772] Lspci.txt

2020-08-06 Thread Kai-Chuan Hsieh
apport information

** Attachment added: "Lspci.txt"
   https://bugs.launchpad.net/bugs/1890772/+attachment/5399474/+files/Lspci.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1890772

Title:
  Some external 4K monitor is not working properly

Status in OEM Priority Project:
  New
Status in xorg package in Ubuntu:
  New

Bug description:
  The bug is originated from,
  https://bugs.launchpad.net/somerville/+bug/1887915/
  https://bugs.launchpad.net/somerville/+bug/1886778

  It has some problem when user connect to external 4K monitor with refresh 
rate 60.
  The problem can be solved by lower the bpc, or lower the refresh rate.

  `xrandr --output DP-3 --set "max bpc" 8`

  Would like to open this bug to open discussion for enhancing user experience.
  ---
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27.4
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistributionChannelDescriptor:
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-focal-amd64-20200502-85+fossa-samwell-tgl+X42
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus: nvidia, 440.100, 5.6.0-1021-oem, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Device [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:09fc]
     Subsystem: Dell GP107M [GeForce MX350] [1028:09fc]
  InstallationDate: Installed on 2020-08-07 (0 days ago)
  InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 
20200502-05:58
  MachineType: Dell Inc. Vostro 5301
  Package: xorg 1:7.7+19ubuntu14 [origin: unknown]
  PackageArchitecture: amd64
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.6.0-1021-oem 
root=UUID=41be2253-410a-4ef7-a096-4193a58efdbd ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.6.0-1021.21-oem 5.6.19
  Tags: third-party-packages focal ubuntu
  Uname: Linux 5.6.0-1021-oem x86_64
  UnreportableReason: This is not an official Ubuntu package. Please remove any 
third party package and try again.
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~20.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1890772/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890772] Lspci-vt.txt

2020-08-06 Thread Kai-Chuan Hsieh
apport information

** Attachment added: "Lspci-vt.txt"
   
https://bugs.launchpad.net/bugs/1890772/+attachment/5399475/+files/Lspci-vt.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1890772

Title:
  Some external 4K monitor is not working properly

Status in OEM Priority Project:
  New
Status in xorg package in Ubuntu:
  New

Bug description:
  The bug is originated from,
  https://bugs.launchpad.net/somerville/+bug/1887915/
  https://bugs.launchpad.net/somerville/+bug/1886778

  It has some problem when user connect to external 4K monitor with refresh 
rate 60.
  The problem can be solved by lower the bpc, or lower the refresh rate.

  `xrandr --output DP-3 --set "max bpc" 8`

  Would like to open this bug to open discussion for enhancing user experience.
  ---
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27.4
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistributionChannelDescriptor:
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-focal-amd64-20200502-85+fossa-samwell-tgl+X42
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus: nvidia, 440.100, 5.6.0-1021-oem, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Device [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:09fc]
     Subsystem: Dell GP107M [GeForce MX350] [1028:09fc]
  InstallationDate: Installed on 2020-08-07 (0 days ago)
  InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 
20200502-05:58
  MachineType: Dell Inc. Vostro 5301
  Package: xorg 1:7.7+19ubuntu14 [origin: unknown]
  PackageArchitecture: amd64
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.6.0-1021-oem 
root=UUID=41be2253-410a-4ef7-a096-4193a58efdbd ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.6.0-1021.21-oem 5.6.19
  Tags: third-party-packages focal ubuntu
  Uname: Linux 5.6.0-1021-oem x86_64
  UnreportableReason: This is not an official Ubuntu package. Please remove any 
third party package and try again.
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~20.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1890772/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890772] Dependencies.txt

2020-08-06 Thread Kai-Chuan Hsieh
apport information

** Attachment added: "Dependencies.txt"
   
https://bugs.launchpad.net/bugs/1890772/+attachment/5399472/+files/Dependencies.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1890772

Title:
  Some external 4K monitor is not working properly

Status in OEM Priority Project:
  New
Status in xorg package in Ubuntu:
  New

Bug description:
  The bug is originated from,
  https://bugs.launchpad.net/somerville/+bug/1887915/
  https://bugs.launchpad.net/somerville/+bug/1886778

  It has some problem when user connect to external 4K monitor with refresh 
rate 60.
  The problem can be solved by lower the bpc, or lower the refresh rate.

  `xrandr --output DP-3 --set "max bpc" 8`

  Would like to open this bug to open discussion for enhancing user experience.
  ---
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27.4
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistributionChannelDescriptor:
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-focal-amd64-20200502-85+fossa-samwell-tgl+X42
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus: nvidia, 440.100, 5.6.0-1021-oem, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Device [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:09fc]
     Subsystem: Dell GP107M [GeForce MX350] [1028:09fc]
  InstallationDate: Installed on 2020-08-07 (0 days ago)
  InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 
20200502-05:58
  MachineType: Dell Inc. Vostro 5301
  Package: xorg 1:7.7+19ubuntu14 [origin: unknown]
  PackageArchitecture: amd64
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.6.0-1021-oem 
root=UUID=41be2253-410a-4ef7-a096-4193a58efdbd ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.6.0-1021.21-oem 5.6.19
  Tags: third-party-packages focal ubuntu
  Uname: Linux 5.6.0-1021-oem x86_64
  UnreportableReason: This is not an official Ubuntu package. Please remove any 
third party package and try again.
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~20.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1890772/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890772] Re: Some external 4K monitor is not working properly

2020-08-06 Thread Kai-Chuan Hsieh
apport information

** Tags added: apport-collected focal third-party-packages ubuntu

** Description changed:

  The bug is originated from,
  https://bugs.launchpad.net/somerville/+bug/1887915/
  https://bugs.launchpad.net/somerville/+bug/1886778
  
  It has some problem when user connect to external 4K monitor with refresh 
rate 60.
  The problem can be solved by lower the bpc, or lower the refresh rate.
  
  `xrandr --output DP-3 --set "max bpc" 8`
  
- Would like to open this bug to open discussion for enhancing user
- experience.
+ Would like to open this bug to open discussion for enhancing user experience.
+ --- 
+ ProblemType: Bug
+ ApportVersion: 2.20.11-0ubuntu27.4
+ Architecture: amd64
+ BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
+ CasperMD5CheckResult: skip
+ CompositorRunning: None
+ CurrentDesktop: ubuntu:GNOME
+ DistUpgraded: Fresh install
+ DistributionChannelDescriptor:
+  # This is the distribution channel descriptor for the OEM CDs
+  # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
+  canonical-oem-somerville-focal-amd64-20200502-85+fossa-samwell-tgl+X42
+ DistroCodename: focal
+ DistroRelease: Ubuntu 20.04
+ DistroVariant: ubuntu
+ DkmsStatus: nvidia, 440.100, 5.6.0-1021-oem, x86_64: installed
+ ExtraDebuggingInterest: Yes
+ GraphicsCard:
+  Intel Corporation Device [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
+Subsystem: Dell Device [1028:09fc]
+Subsystem: Dell GP107M [GeForce MX350] [1028:09fc]
+ InstallationDate: Installed on 2020-08-07 (0 days ago)
+ InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 
20200502-05:58
+ MachineType: Dell Inc. Vostro 5301
+ Package: xorg 1:7.7+19ubuntu14 [origin: unknown]
+ PackageArchitecture: amd64
+ ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.6.0-1021-oem 
root=UUID=41be2253-410a-4ef7-a096-4193a58efdbd ro quiet splash vt.handoff=7
+ ProcVersionSignature: Ubuntu 5.6.0-1021.21-oem 5.6.19
+ Tags: third-party-packages focal ubuntu
+ Uname: Linux 5.6.0-1021-oem x86_64
+ UnreportableReason: This is not an official Ubuntu package. Please remove any 
third party package and try again.
+ UpgradeStatus: No upgrade log present (probably fresh install)
+ UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
+ _MarkForUpload: True
+ dmi.bios.date: 08/03/2020
+ dmi.bios.vendor: Dell Inc.
+ dmi.bios.version: 0.6.0
+ dmi.board.vendor: Dell Inc.
+ dmi.chassis.type: 10
+ dmi.chassis.vendor: Dell Inc.
+ dmi.modalias: 
dmi:bvnDellInc.:bvr0.6.0:bd08/03/2020:svnDellInc.:pnVostro5301:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct10:cvr:
+ dmi.product.family: Vostro
+ dmi.product.name: Vostro 5301
+ dmi.product.sku: 09FC
+ dmi.sys.vendor: Dell Inc.
+ version.compiz: compiz N/A
+ version.libdrm2: libdrm2 2.4.101-2
+ version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~20.04.1
+ version.libgl1-mesa-glx: libgl1-mesa-glx N/A
+ version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.2
+ version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
+ version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
+ version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
+ version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

** Attachment added: "CurrentDmesg.txt"
   
https://bugs.launchpad.net/bugs/1890772/+attachment/5399471/+files/CurrentDmesg.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1890772

Title:
  Some external 4K monitor is not working properly

Status in OEM Priority Project:
  New
Status in xorg package in Ubuntu:
  New

Bug description:
  The bug is originated from,
  https://bugs.launchpad.net/somerville/+bug/1887915/
  https://bugs.launchpad.net/somerville/+bug/1886778

  It has some problem when user connect to external 4K monitor with refresh 
rate 60.
  The problem can be solved by lower the bpc, or lower the refresh rate.

  `xrandr --output DP-3 --set "max bpc" 8`

  Would like to open this bug to open discussion for enhancing user experience.
  ---
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27.4
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistributionChannelDescriptor:
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-focal-amd64-20200502-85+fossa-samwell-tgl+X42
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus: nvidia, 440.100, 5.6.0-1021-oem, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Device [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:09fc]
     Subsystem: Dell GP107M 

[Touch-packages] [Bug 1890772] [NEW] Some external 4K monitor is not working properly

2020-08-06 Thread Kai-Chuan Hsieh
Public bug reported:

The bug is originated from,
https://bugs.launchpad.net/somerville/+bug/1887915/
https://bugs.launchpad.net/somerville/+bug/1886778

It has some problem when user connect to external 4K monitor with refresh rate 
60.
The problem can be solved by lower the bpc, or lower the refresh rate.

`xrandr --output DP-3 --set "max bpc" 8`

Would like to open this bug to open discussion for enhancing user experience.
--- 
ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu27.4
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CasperMD5CheckResult: skip
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
DistUpgraded: Fresh install
DistributionChannelDescriptor:
 # This is the distribution channel descriptor for the OEM CDs
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-focal-amd64-20200502-85+fossa-samwell-tgl+X42
DistroCodename: focal
DistroRelease: Ubuntu 20.04
DistroVariant: ubuntu
DkmsStatus: nvidia, 440.100, 5.6.0-1021-oem, x86_64: installed
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation Device [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:09fc]
   Subsystem: Dell GP107M [GeForce MX350] [1028:09fc]
InstallationDate: Installed on 2020-08-07 (0 days ago)
InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 20200502-05:58
MachineType: Dell Inc. Vostro 5301
Package: xorg 1:7.7+19ubuntu14 [origin: unknown]
PackageArchitecture: amd64
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.6.0-1021-oem 
root=UUID=41be2253-410a-4ef7-a096-4193a58efdbd ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 5.6.0-1021.21-oem 5.6.19
Tags: third-party-packages focal ubuntu
Uname: Linux 5.6.0-1021-oem x86_64
UnreportableReason: This is not an official Ubuntu package. Please remove any 
third party package and try again.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 08/03/2020
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 0.6.0
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 10
dmi.chassis.vendor: Dell Inc.
dmi.modalias: 
dmi:bvnDellInc.:bvr0.6.0:bd08/03/2020:svnDellInc.:pnVostro5301:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct10:cvr:
dmi.product.family: Vostro
dmi.product.name: Vostro 5301
dmi.product.sku: 09FC
dmi.sys.vendor: Dell Inc.
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.101-2
version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~20.04.1
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: apport-collected focal third-party-packages ubuntu

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1890772

Title:
  Some external 4K monitor is not working properly

Status in xorg package in Ubuntu:
  New

Bug description:
  The bug is originated from,
  https://bugs.launchpad.net/somerville/+bug/1887915/
  https://bugs.launchpad.net/somerville/+bug/1886778

  It has some problem when user connect to external 4K monitor with refresh 
rate 60.
  The problem can be solved by lower the bpc, or lower the refresh rate.

  `xrandr --output DP-3 --set "max bpc" 8`

  Would like to open this bug to open discussion for enhancing user experience.
  --- 
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27.4
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistributionChannelDescriptor:
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-focal-amd64-20200502-85+fossa-samwell-tgl+X42
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus: nvidia, 440.100, 5.6.0-1021-oem, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Device [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
 Subsystem: Dell Device [1028:09fc]
 Subsystem: Dell GP107M [GeForce MX350] [1028:09fc]
  InstallationDate: Installed on 2020-08-07 (0 days ago)
  InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 
20200502-05:58
  MachineType: Dell Inc. Vostro 5301
  Package: xorg 1:7.7+19ubuntu14 [origin: unknown]
  PackageArchitecture: amd64
  ProcKernelCmdLine: 

[Touch-packages] [Bug 1560094] Re: Starting bluez service is denied

2020-08-06 Thread Launchpad Bug Tracker
[Expired for bluez (Ubuntu) because there has been no activity for 60
days.]

** Changed in: bluez (Ubuntu)
   Status: Incomplete => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to bluez in Ubuntu.
https://bugs.launchpad.net/bugs/1560094

Title:
  Starting bluez service is denied

Status in bluez package in Ubuntu:
  Expired

Bug description:
  If snappy core is updated in the background (on Raspberry Pi 2), and
  then bluez installed, starting the service is failing.

  
  Denials:

  [   45.955490] audit: type=1400 audit(1458574955.667:11): apparmor="DENIED" 
operation="mknod" profile="bluez5_bluez_5.37-2-armhf" 
name="/etc/dbus-1/system.d/bluez5_bluez_5.37-2-armhf.conf" pid=834 comm="c0
  [   46.197608] audit: type=1326 audit(1458574955.907:12): auid=4294967295 
uid=0 gid=0 ses=4294967295 pid=831 comm="obexd" 
exe="/snaps/bluez5/5.37-2-armhf/usr/lib/bluetooth/obexd" sig=31 arch=4028 
sysc0
  [   46.275680] audit: type=1400 audit(1458574955.987:13): apparmor="DENIED" 
operation="create" profile="bluez5_bluez_5.37-2-armhf" pid=829 
comm="bluetoothd" family="bluetooth" sock_type="raw" protocol=1
  [   46.276483] audit: type=1326 audit(1458574955.987:14): auid=4294967295 
uid=0 gid=0 ses=4294967295 pid=829 comm="bluetoothd" 
exe="/snaps/bluez5/5.37-2-armhf/usr/lib/bluetooth/bluetoothd" sig=31 arch=4000
  [   46.412021] audit: type=1326 audit(1458574956.123:15): auid=4294967295 
uid=0 gid=0 ses=4294967295 pid=839 comm="obexd" 
exe="/snaps/bluez5/5.37-2-armhf/usr/lib/bluetooth/obexd" sig=31 arch=4028 
sysc0
  [   46.504308] audit: type=1400 audit(1458574956.215:16): apparmor="DENIED" 
operation="mknod" profile="bluez5_bluez_5.37-2-armhf" 
name="/etc/dbus-1/system.d/bluez5_bluez_5.37-2-armhf.conf" pid=842 comm="c0
  [   46.520137] audit: type=1400 audit(1458574956.231:17): apparmor="DENIED" 
operation="create" profile="bluez5_bluez_5.37-2-armhf" pid=841 
comm="bluetoothd" family="bluetooth" sock_type="raw" protocol=1
  [   46.520800] audit: type=1326 audit(1458574956.231:18): auid=4294967295 
uid=0 gid=0 ses=4294967295 pid=841 comm="bluetoothd" 
exe="/snaps/bluez5/5.37-2-armhf/usr/lib/bluetooth/bluetoothd" sig=31 arch=4000
  [   46.625293] audit: type=1326 audit(1458574956.335:19): auid=4294967295 
uid=0 gid=0 ses=4294967295 pid=844 comm="obexd" 
exe="/snaps/bluez5/5.37-2-armhf/usr/lib/bluetooth/obexd" sig=31 arch=4028 
sysc0
  [   46.721080] audit: type=1400 audit(1458574956.431:20): apparmor="DENIED" 
operation="mknod" profile="bluez5_bluez_5.37-2-armhf" 
name="/etc/dbus-1/system.d/bluez5_bluez_5.37-2-armhf.conf" pid=847 comm="c2

  If trying to start bluetootctl:

  [  582.205066] audit: type=1400 audit(1458575491.915:31): apparmor="DENIED" 
operation="connect" profile="bluez5_bluetoothctl_5.37-2-armhf" 
name="/run/dbus/system_bus_socket" pid=993 comm="bluetoothctl" re0
  [bluetooth]# 

  
  ubuntu@localhost:~$ snappy list
  NameDate   Version  Developer 
  bluez5  2016-02-04 5.37-2-armhf canonical 
  canonical-pi2   2016-02-02 3.0  canonical 
  canonical-pi2-linux 2016-02-03 4.3.0-1006-3 canonical 
  ubuntu-core 2016-03-08 16.04.0-15.armhf canonical 
  ubuntu@localhost:~$ 

  ubuntu@localhost:~$ snappy info
  release: core/rolling
  architecture: armhf
  frameworks: bluez5.canonical
  apps:

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1560094/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1864287] Re: pulseaudio still trying to reproduce audio to HDMI without the HDMI cable connected

2020-08-06 Thread Launchpad Bug Tracker
[Expired for pulseaudio (Ubuntu) because there has been no activity for
60 days.]

** Changed in: pulseaudio (Ubuntu)
   Status: Incomplete => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1864287

Title:
  pulseaudio still trying to reproduce audio to HDMI without the HDMI
  cable connected

Status in pulseaudio package in Ubuntu:
  Expired

Bug description:
  Yesterday I was using the HDMI cable to duplicate the monitor in the
  tv and play sound with the tv by selecting HDMI exit sound in ubuntu
  settings.

  With the pc turned off I removed the HDMI from the tv but ubuntu
  doesn't automatically set the exit sound to the default till in the
  settings there is only that option and till I selected it, ubuntu was
  still trying to reproduce the audio via HDMI...

  Also rebooting the system the problem persists.

  Also by reloading pulseaudio the problem persists.

  The only solution was installing a third-party program to switch
  correctly to the default audio exit...

  lsb_release -rd:
  Description:  Ubuntu 18.04.3 LTS
  Release:  18.04

  apt-cache policy pulseaudio:
  pulseaudio:
Installato: 1:11.1-1ubuntu7.2
Candidato:  1:11.1-1ubuntu7.4
Tabella versione:
   1:11.1-1ubuntu7.4 500
  500 http://it.archive.ubuntu.com/ubuntu bionic-updates/main amd64 
Packages
   *** 1:11.1-1ubuntu7.2 100
  100 /var/lib/dpkg/status
   1:11.1-1ubuntu7 500
  500 http://it.archive.ubuntu.com/ubuntu bionic/main amd64 Packages

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1864287/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890593] Re: Xorg freeze

2020-08-06 Thread Daniel van Vugt
This sounds kind of like bug 1872159 or bug 1871641.

Can you please try editing /etc/default/grub and remove 'splash' then:

  sudo update-grub

and reboot.


** Tags added: hybrid nvidia

** Summary changed:

- Xorg freeze
+ [nvidia] Boot freeze - can't get to login screen without unplugging HDMI first

** Package changed: xorg (Ubuntu) => plymouth (Ubuntu)

** Changed in: plymouth (Ubuntu)
   Status: New => Incomplete

** Also affects: gdm3 (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1890593

Title:
  [nvidia] Boot freeze - can't get to login screen without unplugging
  HDMI first

Status in gdm3 package in Ubuntu:
  New
Status in plymouth package in Ubuntu:
  Incomplete

Bug description:
  Just installed ubuntu  20.04 and I am stuck on ubuntu with a spining
  logo. If I go to other tty and unplug the HDMI screens I can get to
  the login screen, Otherwise I cant. I did checked the md5sum of the
  iso before installing and its was correct.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: xorg 1:7.7+19ubuntu14
  ProcVersionSignature: Ubuntu 5.4.0-42.46-generic 5.4.44
  Uname: Linux 5.4.0-42-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  .proc.driver.nvidia.gpus..02.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:02:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.100  Fri May 29 08:45:51 
UTC 2020
   GCC version:
  ApportVersion: 2.20.11-0ubuntu27.6
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Aug  6 14:29:04 2020
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroVariant: ubuntu
  DkmsStatus: virtualbox, 6.1.10, 5.4.0-42-generic, x86_64: installed
  ExtraDebuggingInterest: Yes, including running git bisection searches
  GpuHangFrequency: This is the first time
  GraphicsCard:
   Intel Corporation HD Graphics 620 [8086:5916] (rev 02) (prog-if 00 [VGA 
controller])
 Subsystem: Lenovo ThinkPad T570 [17aa:2248]
 Subsystem: Lenovo GM108GLM [Quadro M520 Mobile] [17aa:2248]
  InstallationDate: Installed on 2020-08-05 (0 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  MachineType: LENOVO 20HCS0660M
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-42-generic 
root=UUID=be1cbba6-c044-4d36-a6f4-fe872353a538 ro quiet splash vt.handoff=7
  SourcePackage: xorg
  Symptom: display
  Title: Xorg freeze
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 05/08/2019
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N1VET49W (1.39 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20HCS0660M
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0K17763 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN1VET49W(1.39):bd05/08/2019:svnLENOVO:pn20HCS0660M:pvrThinkPadP51s:rvnLENOVO:rn20HCS0660M:rvrSDK0K17763WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad THINKPAD P51S
  dmi.product.name: 20HCS0660M
  dmi.product.sku: LENOVO_MT_20HC_BU_Think_FM_ThinkPad THINKPAD P51S
  dmi.product.version: ThinkPad P51s
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~20.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gdm3/+bug/1890593/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890411] Re: [bionic] Xorg crashes when starting gdm3. Bug in libgl1-mesa-dri.

2020-08-06 Thread Daniel van Vugt
Not that I can think of...

I forgot to mention: i965_dri isn't used in later Ubuntu releases. It's
been replaced by a new driver called 'iris_dri'.

You will probably find that Ubuntu 20.04.1 works better:
https://releases.ubuntu.com/20.04/

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1890411

Title:
  [bionic] Xorg crashes when starting gdm3. Bug in libgl1-mesa-dri.

Status in mesa package in Ubuntu:
  New
Status in xorg-server package in Ubuntu:
  New

Bug description:
  When ubuntu starts up, gdm3 does not start due to a crash in the the
  xserver:

  [  1271.342] (II) SELinux: Disabled on system
  [  1271.346] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
  [  1271.346] (II) AIGLX: enabled GLX_ARB_create_context
  [  1271.346] (II) AIGLX: enabled GLX_ARB_create_context_profile
  [  1271.346] (II) AIGLX: enabled GLX_EXT_create_context_es{,2}_profile
  [  1271.346] (II) AIGLX: enabled GLX_INTEL_swap_event
  [  1271.346] (II) AIGLX: enabled GLX_SGI_swap_control
  [  1271.346] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
  [  1271.346] (II) AIGLX: enabled GLX_ARB_fbconfig_float
  [  1271.346] (II) AIGLX: enabled GLX_EXT_fbconfig_packed_float
  [  1271.346] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
  [  1271.346] (II) AIGLX: enabled GLX_ARB_create_context_robustness
  [  1271.346] (II) AIGLX: Loaded and initialized i965
  [  1271.346] (II) GLX: Initialized DRI2 GL provider for screen 0
  [  1271.348] (II) modeset(0): Damage tracking initialized
  [  1271.348] (II) modeset(0): Setting screen physical size to 508 x 317
  [  1271.352] (EE) 
  [  1271.352] (EE) Backtrace:
  [  1271.352] (EE) 0: /usr/lib/xorg/Xorg (xorg_backtrace+0x4d) [0x5649b579bacd]
  [  1271.352] (EE) 1: /usr/lib/xorg/Xorg (0x5649b55e3000+0x1bc869) 
[0x5649b579f869]
  [  1271.352] (EE) 2: /lib/x86_64-linux-gnu/libpthread.so.0 
(0x7f5c7d0a5000+0x128a0) [0x7f5c7d0b78a0]
  [  1271.352] (EE) 3: /usr/lib/x86_64-linux-gnu/dri/i965_dri.so 
(0x7f5c77bfa000+0x8e8652) [0x7f5c784e2652]
  [  1271.352] (EE) 4: /usr/lib/x86_64-linux-gnu/dri/i965_dri.so 
(0x7f5c77bfa000+0x8e877f) [0x7f5c784e277f]
  [  1271.352] (EE) 5: /usr/lib/x86_64-linux-gnu/dri/i965_dri.so 
(0x7f5c77bfa000+0x122916) [0x7f5c77d1c916]
  [  1271.352] (EE) 6: /usr/lib/x86_64-linux-gnu/dri/i965_dri.so 
(0x7f5c77bfa000+0x1189bc) [0x7f5c77d129bc]
  [  1271.352] (EE) 7: /usr/lib/x86_64-linux-gnu/dri/i965_dri.so 
(0x7f5c77bfa000+0x109c1b) [0x7f5c77d03c1b]
  [  1271.352] (EE) 8: /usr/lib/x86_64-linux-gnu/dri/i965_dri.so 
(0x7f5c77bfa000+0x279558) [0x7f5c77e73558]
  [  1271.352] (EE) 9: /usr/lib/x86_64-linux-gnu/dri/i965_dri.so 
(0x7f5c77bfa000+0x2796e3) [0x7f5c77e736e3]
  [  1271.352] (EE) 10: /usr/lib/xorg/modules/libglamoregl.so 
(0x7f5c79937000+0x1a1ab) [0x7f5c799511ab]
  [  1271.352] (EE) 11: /usr/lib/xorg/Xorg (0x5649b55e3000+0x13ed03) 
[0x5649b5721d03]
  [  1271.352] (EE) 12: /usr/lib/xorg/Xorg (miPaintWindow+0x22f) 
[0x5649b577fd1f]
  [  1271.352] (EE) 13: /usr/lib/xorg/Xorg (miWindowExposures+0x112) 
[0x5649b577fa62]
  [  1271.352] (EE) 14: /usr/lib/xorg/Xorg (0x5649b55e3000+0xa9c41) 
[0x5649b568cc41]
  [  1271.352] (EE) 15: /usr/lib/xorg/Xorg (MapWindow+0x114) [0x5649b5665d04]
  [  1271.352] (EE) 16: /usr/lib/xorg/Xorg (0x5649b55e3000+0x56e79) 
[0x5649b5639e79]
  [  1271.352] (EE) 17: /lib/x86_64-linux-gnu/libc.so.6 
(__libc_start_main+0xe7) [0x7f5c7ccd5b97]
  [  1271.352] (EE) 18: /usr/lib/xorg/Xorg (_start+0x2a) [0x5649b5623b8a]
  [  1271.352] (EE) 
  [  1271.352] (EE) Segmentation fault at address 0x4
  [  1271.352] (EE) 
  Fatal server error:
  [  1271.352] (EE) Caught signal 11 (Segmentation fault). Server aborting
  [  1271.352] (EE) 
  [  1271.352] (EE) 

  As i965_dri.so is part of the libgl-mesa-dri package I downgraded this
  specific package from version 20.0.8-0ubuntu1~18.04.1 back to
  19.2.8-0ubuntu0~18.04.3.

  This solves the problem. So I suspect that the problem is in this
  specific package.

  My machine is (uname):
  4.4.0-66-generic #87-Ubuntu SMP Fri Mar 3 15:29:05 UTC 2017 x86_64 x86_64 
x86_64 GNU/Linux

  (lspci)
  00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller 
(rev 06)
  00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen 
Core Processor Integrated Graphics Controller (rev 06)
  00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family 
USB xHCI (rev 05)
  00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series 
Chipset Family MEI Controller #1 (rev 04)
  00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family 
USB EHCI #2 (rev 05)
  00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High 
Definition Audio Controller (rev 05)
  00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI 
Express Root Port #1 (rev d5)
  00:1c.2 PCI bridge: Intel Corporation 8 

[Touch-packages] [Bug 1871641] Re: Ubuntu never finishes booting: A start job is running for Hold until boot process finishes up (3min 7s / no limit) -- removing 'splash' kernel parm fixes it

2020-08-06 Thread Daniel van Vugt
Maybe related to bug 1872159, which supposedly happens when extra
monitors are connected. Although I doubt that's the only requirement to
make the bug happen.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1871641

Title:
  Ubuntu never finishes booting: A start job is running for Hold until
  boot process finishes up (3min 7s / no limit) -- removing 'splash'
  kernel parm fixes it

Status in plymouth package in Ubuntu:
  Confirmed
Status in systemd package in Ubuntu:
  Incomplete

Bug description:
  Boot process freezes at the splash screen and nothing happens after
  that. The computer can be suspended and it is able to return from
  suspend. Boot is possible by pressing escape early in the process to
  bypass plymouth.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: plymouth 0.9.4git20200323-0ubuntu5
  ProcVersionSignature: Ubuntu 5.4.0-21.25-generic 5.4.27
  Uname: Linux 5.4.0-21-generic x86_64
  ApportVersion: 2.20.11-0ubuntu24
  Architecture: amd64
  Date: Wed Apr  8 14:30:13 2020
  DefaultPlymouth: /usr/share/plymouth/themes/bgrt/bgrt.plymouth
  InstallationDate: Installed on 2020-04-08 (0 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Beta amd64 (20200402)
  MachineType: LENOVO 7469A23
  ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-21-generic 
root=UUID=e12af5fd-b700-4292-8727-70345cb61c8e ro quiet splash vt.handoff=7
  ProcFB: 0 i915drmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-21-generic 
root=UUID=e12af5fd-b700-4292-8727-70345cb61c8e ro quiet splash vt.handoff=7
  SourcePackage: plymouth
  TextPlymouth: /usr/share/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 10/25/2012
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 6DET72WW (3.22 )
  dmi.board.name: 7469A23
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Available
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: 
dmi:bvnLENOVO:bvr6DET72WW(3.22):bd10/25/2012:svnLENOVO:pn7469A23:pvrThinkPadX200s:rvnLENOVO:rn7469A23:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.family: ThinkPad X200s
  dmi.product.name: 7469A23
  dmi.product.version: ThinkPad X200s
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/1871641/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1888926] Re: tls.tlscfgcmd not recognized; rebuild rsyslog against librelp 1.5.0

2020-08-06 Thread Mauricio Faria de Oliveira
Verification/comparison steps to ensure that the modified
rsyslog package is built and working correctly, given its
importance in the distribution:

1) Compare test suite results in build logs
2) Compare configuration options in build logs
3) Compare packages' control file and contents

All look good.  Details:

1) Compare test suite results in build logs
---

The build-time test suite runs 550ish tests,
which gives us confidence it does look good.

There are 20 test files which name includes 'relp',
and 2 test files include the option name 'tlscfgcmd'.

$ grep -rl tlscfgcmd rsyslog-8.2001.0/tests/ 
rsyslog-8.2001.0/tests/sndrcv_relp_tls-cfgcmd.sh
rsyslog-8.2001.0/tests/imrelp-tls-cfgcmd.sh

These 2 are not mentioned in the previous build log,
but are mentioned and PASS in the test package's build log,
so the option is enabled and good as in tests.

Before:

# TOTAL: 551
# PASS:  544
# SKIP:  7
# XFAIL: 0
# FAIL:  0
# XPASS: 0
# ERROR: 0

After:

+PASS: imrelp-tls-cfgcmd.sh
+PASS: sndrcv_relp_tls-cfgcmd.sh

# TOTAL: 553
# PASS:  546
# SKIP:  7
# XFAIL: 0
# FAIL:  0
# XPASS: 0
# ERROR: 0

2) Compare configuration options in build logs
--

Download the old (focal-release) and new (ppa) build logs:

$ curl -s https://launchpadlibrarian.net/464664394
/buildlog_ubuntu-focal-amd64.rsyslog_8.2001.0-1ubuntu1_BUILDING.txt.gz |
gzip -dc > buildlog.old

$ curl -s buildlog_modified
https://launchpadlibrarian.net/492228312/buildlog_ubuntu-focal-
amd64.rsyslog_8.2001.0-1ubuntu1.1_BUILDING.txt.gz | gzip -dc >
buildlog.new

Filter the section for configure:

dh_auto_configure -- \
<...>
config.status: executing libtool commands

$ sed -n '/^dh_auto_configure --/,/^config.status: executing
libtool commands/p' buildlog.old > buildlog.old.configure

$ sed -n '/^dh_auto_configure --/,/^config.status: executing
libtool commands/p' buildlog.new > buildlog.new.configure

The only difference is the new/reported option 'relpSrvSetTlsConfigCmd'

$ diff -u buildlog.old.configure buildlog.new.configure
--- buildlog.old.configure  2020-08-06 23:44:34.072713719 +
+++ buildlog.new.configure  2020-08-06 23:44:38.080688125 +
@@ -407,8 +407,8 @@
 checking for relpSrvSetOversizeMode... yes
 checking for relpSrvSetLstnAddr... yes
 checking for relpEngineSetTLSLibByName... yes
-checking for relpSrvSetTlsConfigCmd... no
-checking for relpSrvSetTlsConfigCmd... (cached) no
+checking for relpSrvSetTlsConfigCmd... yes
+checking for relpSrvSetTlsConfigCmd... (cached) yes
 checking for LIBLOGGING_STDLOG... no
 configure: liblogging-stdlog not found, parts of the testbench will 
not run
 checking for ip... no


3) Compare packages' control file and contents
--

Get the old and new packages' control/contents:

mkdir debs-old && cd debs-old
pull-lp-debs rsyslog focal
cd ..

mkdir debs-new && cd debs-new
pull-ppa-debs --ppa mfo/lp1888926 rsyslog focal
cd ..

for dir in debs-old debs-new; do 
pushd $dir
for deb in *.deb; do 
  pkg=${deb%%_*}
  dpkg-deb -e $deb deb_control_$pkg
  dpkg-deb -c $deb \
| awk '{ $3 = "SIZE"; $4 = "DATE"; $5 = "TIME"; print $0 }' 
`#normalize` \
| sort \
> deb_content_$pkg
done
popd
done

Compare the control files:

for dir in debs-old/deb_control_*; do
  dir="$(basename $dir)"
  echo "DIR: $dir"
  diff -U0 debs-old/$dir/control debs-new/$dir/control
  echo
done

The only differences are:
1) the Version: bump,
2) the versioned dependency bump on rsyslog,
3) and rsyslog-relp also has versioned dependency bump on librelp0, as expected.

DIR: deb_control_rsyslog-relp
--- debs-old/deb_control_rsyslog-relp/control   2020-02-11 
15:25:29.0 +
+++ debs-new/deb_control_rsyslog-relp/control   2020-07-30 
19:53:18.0 +
@@ -3 +3 @@
-Version: 8.2001.0-1ubuntu1
+Version: 8.2001.0-1ubuntu1.1
@@ -7 +7 @@
-Depends: libc6 (>= 2.14), librelp0 (>= 1.4.0), rsyslog (= 
8.2001.0-1ubuntu1)
+Depends: libc6 (>= 2.14), librelp0 (>= 1.5.0), rsyslog (= 
8.2001.0-1ubuntu1.1)


Compare the contents:

for file in debs-old/deb_content_*; do
  file="$(basename $file)"
  echo "FILE: $file"
  diff -U0 debs-old/$file debs-new/$file
  echo
done

The 

[Touch-packages] [Bug 1888926] Re: tls.tlscfgcmd not recognized; rebuild rsyslog against librelp 1.5.0

2020-08-06 Thread Mauricio Faria de Oliveira
Hi Jorge,

Thanks for tracking this down in the build history.

> I suspect that the rsyslog package was built against and older librelp
version.

You're right, the build log shows 'librelp-dev_1.4.0-2'
in the package installs/'Build environment' section.

I slightly modified the changelog entry, and examined the
old/new packages (i.e., pre/post rebuild) for differences,
to ensure the changes are what we expect and nothing else.

It all looks good. Details in the next comment.

However this cannot be uploaded immediately because there
is currently another rsyslog upload in focal; fortunately
it's from Eric/@slashd and not yet approved, so we likely
merge both. I'll email him/you.

cheers,
Mauricio

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to rsyslog in Ubuntu.
https://bugs.launchpad.net/bugs/1888926

Title:
  tls.tlscfgcmd not recognized; rebuild rsyslog against librelp 1.5.0

Status in rsyslog package in Ubuntu:
  Fix Released
Status in rsyslog source package in Focal:
  In Progress
Status in rsyslog source package in Groovy:
  Fix Released

Bug description:
  [Description]

  Problem is according to 
https://launchpad.net/ubuntu/+source/librelp/+publishinghistory,
  librelp-dev 1.5.0 was published into focal at 2020-04-21, but reverse 
dependencies
  (such as rsyslog) weren't rebuilt after this new version was published

  # dpkg -l | grep librelp
  ii librelp-dev:amd64 1.5.0-1ubuntu2 amd64 Reliable Event Logging Protocol 
(RELP) library - development files
  ii librelp0:amd64 1.5.0-1ubuntu2 amd64 Reliable Event Logging Protocol (RELP) 
library

  rsyslogd: error during parsing file /etc/rsyslog.d/FILENAME.conf, on
  or before line 22: imrelp: librelp does not support input parameter
  'tls.tlscfgcmd'; it probably is too old (1.5.0 or higher should be
  fine); ignoring setting now. [v8.2001.0 try
  https://www.rsyslog.com/e/2207 ]

  [Reproducer]

  Setup a focal machine with rsyslog, using the following configuration:

  
  module(load="imrelp" tls.tlslib="openssl")

  input(
  type="imrelp" port="2515"
  tls="on"
  # This should work in rsyslog 8.2006.0:
  #tls.mycert="/etc/rsyslog.tls/fullchain.pem"
  # for now we use the work-around discussed in:
  # https://github.com/rsyslog/rsyslog/issues/4360
  tls.cacert="/etc/rsyslog.tls/chain.pem"
  tls.mycert="/etc/rsyslog.tls/cert.pem"
  tls.myprivkey="/etc/rsyslog.tls/privkey.pem"
  tls.tlscfgcmd="ServerPreference 
CipherString=ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384
 
Ciphersuites=TLS_AES_128_GCM_SHA256:TLS_CHACHA20_POLY1305_SHA256:TLS_AES_256_GCM_SHA384
 MinProtocol=TLSv1.2"
  )
  

  This error comes from this code in plugins/imrelp/imrelp.c:

  
  #if defined(HAVE_RELPENGINESETTLSCFGCMD)
  inst->tlscfgcmd = 
(uchar*)es_str2cstr(pvals[i].val.d.estr, NULL);
  #else
  parser_errmsg("imrelp: librelp does not support input 
parameter 'tls.tlscfgcmd'; "
  "it probably is too old (1.5.0 or higher 
should be fine); ignoring setting now.");
  #endif
  

  The build log for focal:
  
https://launchpadlibrarian.net/464665610/buildlog_ubuntu-focal-arm64.rsyslog_8.2001.0-1ubuntu1_BUILDING.txt.gz
  says:
  checking for relpSrvSetTlsConfigCmd... no
  checking for relpSrvSetTlsConfigCmd... (cached) no

  The build log for groovy:
  
https://launchpadlibrarian.net/486409321/buildlog_ubuntu-groovy-arm64.rsyslog_8.2006.0-2ubuntu1_BUILDING.txt.gz
  says:
  checking for relpSrvSetTlsConfigCmd... yes
  checking for relpSrvSetTlsConfigCmd... (cached) yes

  If I rebuild the rsyslog package, I get:
  checking for relpSrvSetTlsConfigCmd... yes
  checking for relpSrvSetTlsConfigCmd... (cached) yes

  I suspect that the rsyslog package was built against and older librelp
  version. A simple rebuild of rsyslog should fix this, though a more
  complete fix would be to raise the Build-Depends from librelp-dev (>=
  1.4.0) to librelp-dev (>= 1.5.0).

  [Risk potential]

  * No identified as this is a rebuild that should have been done on all 
  reverse dependencies of librelp-dev when upgraded from 1.4.0 to 1.5.0

  
  [Fix]

  Provide a rebuild SRU for focal.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/rsyslog/+bug/1888926/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1888926] Re: tls.tlscfgcmd not recognized; rebuild rsyslog against librelp 1.5.0

2020-08-06 Thread Mauricio Faria de Oliveira
** Patch added: "lp1888926-focal-v2.debdiff"
   
https://bugs.launchpad.net/ubuntu/+source/rsyslog/+bug/1888926/+attachment/5399433/+files/lp1888926-focal-v2.debdiff

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to rsyslog in Ubuntu.
https://bugs.launchpad.net/bugs/1888926

Title:
  tls.tlscfgcmd not recognized; rebuild rsyslog against librelp 1.5.0

Status in rsyslog package in Ubuntu:
  Fix Released
Status in rsyslog source package in Focal:
  In Progress
Status in rsyslog source package in Groovy:
  Fix Released

Bug description:
  [Description]

  Problem is according to 
https://launchpad.net/ubuntu/+source/librelp/+publishinghistory,
  librelp-dev 1.5.0 was published into focal at 2020-04-21, but reverse 
dependencies
  (such as rsyslog) weren't rebuilt after this new version was published

  # dpkg -l | grep librelp
  ii librelp-dev:amd64 1.5.0-1ubuntu2 amd64 Reliable Event Logging Protocol 
(RELP) library - development files
  ii librelp0:amd64 1.5.0-1ubuntu2 amd64 Reliable Event Logging Protocol (RELP) 
library

  rsyslogd: error during parsing file /etc/rsyslog.d/FILENAME.conf, on
  or before line 22: imrelp: librelp does not support input parameter
  'tls.tlscfgcmd'; it probably is too old (1.5.0 or higher should be
  fine); ignoring setting now. [v8.2001.0 try
  https://www.rsyslog.com/e/2207 ]

  [Reproducer]

  Setup a focal machine with rsyslog, using the following configuration:

  
  module(load="imrelp" tls.tlslib="openssl")

  input(
  type="imrelp" port="2515"
  tls="on"
  # This should work in rsyslog 8.2006.0:
  #tls.mycert="/etc/rsyslog.tls/fullchain.pem"
  # for now we use the work-around discussed in:
  # https://github.com/rsyslog/rsyslog/issues/4360
  tls.cacert="/etc/rsyslog.tls/chain.pem"
  tls.mycert="/etc/rsyslog.tls/cert.pem"
  tls.myprivkey="/etc/rsyslog.tls/privkey.pem"
  tls.tlscfgcmd="ServerPreference 
CipherString=ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384
 
Ciphersuites=TLS_AES_128_GCM_SHA256:TLS_CHACHA20_POLY1305_SHA256:TLS_AES_256_GCM_SHA384
 MinProtocol=TLSv1.2"
  )
  

  This error comes from this code in plugins/imrelp/imrelp.c:

  
  #if defined(HAVE_RELPENGINESETTLSCFGCMD)
  inst->tlscfgcmd = 
(uchar*)es_str2cstr(pvals[i].val.d.estr, NULL);
  #else
  parser_errmsg("imrelp: librelp does not support input 
parameter 'tls.tlscfgcmd'; "
  "it probably is too old (1.5.0 or higher 
should be fine); ignoring setting now.");
  #endif
  

  The build log for focal:
  
https://launchpadlibrarian.net/464665610/buildlog_ubuntu-focal-arm64.rsyslog_8.2001.0-1ubuntu1_BUILDING.txt.gz
  says:
  checking for relpSrvSetTlsConfigCmd... no
  checking for relpSrvSetTlsConfigCmd... (cached) no

  The build log for groovy:
  
https://launchpadlibrarian.net/486409321/buildlog_ubuntu-groovy-arm64.rsyslog_8.2006.0-2ubuntu1_BUILDING.txt.gz
  says:
  checking for relpSrvSetTlsConfigCmd... yes
  checking for relpSrvSetTlsConfigCmd... (cached) yes

  If I rebuild the rsyslog package, I get:
  checking for relpSrvSetTlsConfigCmd... yes
  checking for relpSrvSetTlsConfigCmd... (cached) yes

  I suspect that the rsyslog package was built against and older librelp
  version. A simple rebuild of rsyslog should fix this, though a more
  complete fix would be to raise the Build-Depends from librelp-dev (>=
  1.4.0) to librelp-dev (>= 1.5.0).

  [Risk potential]

  * No identified as this is a rebuild that should have been done on all 
  reverse dependencies of librelp-dev when upgraded from 1.4.0 to 1.5.0

  
  [Fix]

  Provide a rebuild SRU for focal.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/rsyslog/+bug/1888926/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1872118] Re: DHCP Cluster crashes after a few hours

2020-08-06 Thread Richard Laager
No crashes to report.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to isc-dhcp in Ubuntu.
https://bugs.launchpad.net/bugs/1872118

Title:
  DHCP Cluster crashes after a few hours

Status in DHCP:
  New
Status in bind9-libs package in Ubuntu:
  New
Status in isc-dhcp package in Ubuntu:
  Confirmed
Status in bind9-libs source package in Focal:
  New
Status in isc-dhcp source package in Focal:
  New
Status in bind9-libs source package in Groovy:
  New
Status in isc-dhcp source package in Groovy:
  Confirmed

Bug description:
  
  I have a pair of DHCP serevrs running in a cluster on ubuntu 20.04, All 
worked perfectly until recently, when they started stopping with code=killed, 
status=6/ABRT.
  This is being fixed by 

  https://bugs.launchpad.net/bugs/1870729

  However now one stops after a few hours with the following errors. One
  can stay on line but not both.


  
  Syslog shows 
  Apr 10 17:20:15 dhcp-primary sh[6828]: 
../../../../lib/isc/unix/socket.c:3361: INSIST(!sock->pending_send) failed, 
back trace
  Apr 10 17:20:15 dhcp-primary sh[6828]: #0 0x7fbe78702a4a in ??
  Apr 10 17:20:15 dhcp-primary sh[6828]: #1 0x7fbe78702980 in ??
  Apr 10 17:20:15 dhcp-primary sh[6828]: #2 0x7fbe7873e7e1 in ??
  Apr 10 17:20:15 dhcp-primary sh[6828]: #3 0x7fbe784e5609 in ??
  Apr 10 17:20:15 dhcp-primary sh[6828]: #4 0x7fbe78621103 in ??

  
  nothing in kern.log

  
  apport.log shows
  ERROR: apport (pid 6850) Fri Apr 10 17:20:15 2020: called for pid 6828, 
signal 6, core limit 0, dump mode 2
  ERROR: apport (pid 6850) Fri Apr 10 17:20:15 2020: not creating core for pid 
with dump mode of 2
  ERROR: apport (pid 6850) Fri Apr 10 17:20:15 2020: executable: 
/usr/sbin/dhcpd (command line "dhcpd -user dhcpd -group dhcpd -f -4 -pf 
/run/dhcp-server/dhcpd.pid -cf /etc/dhcp/dhcpd.conf")
  ERROR: apport (pid 6850) Fri Apr 10 17:20:15 2020: is_closing_session(): no 
DBUS_SESSION_BUS_ADDRESS in environment
  ERROR: apport (pid 6850) Fri Apr 10 17:20:15 2020: wrote report 
/var/crash/_usr_sbin_dhcpd.0.crash


  /var/crash/_usr_sbin_dhcpd.0.crash shows

  ProblemType: Crash
  Architecture: amd64
  CrashCounter: 1
  Date: Fri Apr 10 17:20:15 2020
  DistroRelease: Ubuntu 20.04
  ExecutablePath: /usr/sbin/dhcpd
  ExecutableTimestamp: 1586210315
  ProcCmdline: dhcpd -user dhcpd -group dhcpd -f -4 -pf 
/run/dhcp-server/dhcpd.pid -cf /etc/dhcp/dhcpd.conf
  ProcEnviron: Error: [Errno 13] Permission denied: 'environ'
  ProcMaps: Error: [Errno 13] Permission denied: 'maps'
  ProcStatus:
   Name:  dhcpd
   Umask: 0022
   State: D (disk sleep)
   Tgid:  6828
   Ngid:  0
   Pid:   6828
   PPid:  1
   TracerPid: 0
   Uid:   113 113 113 113
   Gid:   118 118 118 118
   FDSize:128
   Groups:
   NStgid:6828
   NSpid: 6828
   NSpgid:6828
   NSsid: 6828
   VmPeak:  236244 kB
   VmSize:  170764 kB
   VmLck:0 kB
   VmPin:0 kB
   VmHWM:12064 kB
   VmRSS:12064 kB
   RssAnon:   5940 kB
   RssFile:   6124 kB
   RssShmem: 0 kB
   VmData:   30792 kB
   VmStk:  132 kB
   VmExe:  592 kB
   VmLib: 5424 kB
   VmPTE:   76 kB
   VmSwap:   0 kB
   HugetlbPages: 0 kB
   CoreDumping:   1
   THP_enabled:   1
   Threads:   4
   SigQ:  0/7609
   SigPnd:
   ShdPnd:
   SigBlk:
   SigIgn:1000
   SigCgt:00018000
   CapInh:
   CapPrm:
   CapEff:
   CapBnd:003f
   CapAmb:
   NoNewPrivs:0
   Seccomp:   0
   Speculation_Store_Bypass:  thread vulnerable
   Cpus_allowed:  3
   Cpus_allowed_list: 0-1
   Mems_allowed:  
,,,,,,,,,,,,,,,,,,,,,,,,,,,,
  ,,,0001
   Mems_allowed_list: 0
   voluntary_ctxt_switches:   111
   nonvoluntary_ctxt_switches:144
  Signal: 6
  Uname: Linux 5.4.0-21-generic x86_64
  UserGroups:

To manage notifications about this bug go to:
https://bugs.launchpad.net/dhcp/+bug/1872118/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1872118] Re: DHCP Cluster crashes after a few hours

2020-08-06 Thread Jorge Niedbalski
Hello @Andrew, @rlaager,


Any crashes to report before I propose this patch? my env is running this patch 
for close to 3 days without any failures.


Thanks,

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to isc-dhcp in Ubuntu.
https://bugs.launchpad.net/bugs/1872118

Title:
  DHCP Cluster crashes after a few hours

Status in DHCP:
  New
Status in bind9-libs package in Ubuntu:
  New
Status in isc-dhcp package in Ubuntu:
  Confirmed
Status in bind9-libs source package in Focal:
  New
Status in isc-dhcp source package in Focal:
  New
Status in bind9-libs source package in Groovy:
  New
Status in isc-dhcp source package in Groovy:
  Confirmed

Bug description:
  
  I have a pair of DHCP serevrs running in a cluster on ubuntu 20.04, All 
worked perfectly until recently, when they started stopping with code=killed, 
status=6/ABRT.
  This is being fixed by 

  https://bugs.launchpad.net/bugs/1870729

  However now one stops after a few hours with the following errors. One
  can stay on line but not both.


  
  Syslog shows 
  Apr 10 17:20:15 dhcp-primary sh[6828]: 
../../../../lib/isc/unix/socket.c:3361: INSIST(!sock->pending_send) failed, 
back trace
  Apr 10 17:20:15 dhcp-primary sh[6828]: #0 0x7fbe78702a4a in ??
  Apr 10 17:20:15 dhcp-primary sh[6828]: #1 0x7fbe78702980 in ??
  Apr 10 17:20:15 dhcp-primary sh[6828]: #2 0x7fbe7873e7e1 in ??
  Apr 10 17:20:15 dhcp-primary sh[6828]: #3 0x7fbe784e5609 in ??
  Apr 10 17:20:15 dhcp-primary sh[6828]: #4 0x7fbe78621103 in ??

  
  nothing in kern.log

  
  apport.log shows
  ERROR: apport (pid 6850) Fri Apr 10 17:20:15 2020: called for pid 6828, 
signal 6, core limit 0, dump mode 2
  ERROR: apport (pid 6850) Fri Apr 10 17:20:15 2020: not creating core for pid 
with dump mode of 2
  ERROR: apport (pid 6850) Fri Apr 10 17:20:15 2020: executable: 
/usr/sbin/dhcpd (command line "dhcpd -user dhcpd -group dhcpd -f -4 -pf 
/run/dhcp-server/dhcpd.pid -cf /etc/dhcp/dhcpd.conf")
  ERROR: apport (pid 6850) Fri Apr 10 17:20:15 2020: is_closing_session(): no 
DBUS_SESSION_BUS_ADDRESS in environment
  ERROR: apport (pid 6850) Fri Apr 10 17:20:15 2020: wrote report 
/var/crash/_usr_sbin_dhcpd.0.crash


  /var/crash/_usr_sbin_dhcpd.0.crash shows

  ProblemType: Crash
  Architecture: amd64
  CrashCounter: 1
  Date: Fri Apr 10 17:20:15 2020
  DistroRelease: Ubuntu 20.04
  ExecutablePath: /usr/sbin/dhcpd
  ExecutableTimestamp: 1586210315
  ProcCmdline: dhcpd -user dhcpd -group dhcpd -f -4 -pf 
/run/dhcp-server/dhcpd.pid -cf /etc/dhcp/dhcpd.conf
  ProcEnviron: Error: [Errno 13] Permission denied: 'environ'
  ProcMaps: Error: [Errno 13] Permission denied: 'maps'
  ProcStatus:
   Name:  dhcpd
   Umask: 0022
   State: D (disk sleep)
   Tgid:  6828
   Ngid:  0
   Pid:   6828
   PPid:  1
   TracerPid: 0
   Uid:   113 113 113 113
   Gid:   118 118 118 118
   FDSize:128
   Groups:
   NStgid:6828
   NSpid: 6828
   NSpgid:6828
   NSsid: 6828
   VmPeak:  236244 kB
   VmSize:  170764 kB
   VmLck:0 kB
   VmPin:0 kB
   VmHWM:12064 kB
   VmRSS:12064 kB
   RssAnon:   5940 kB
   RssFile:   6124 kB
   RssShmem: 0 kB
   VmData:   30792 kB
   VmStk:  132 kB
   VmExe:  592 kB
   VmLib: 5424 kB
   VmPTE:   76 kB
   VmSwap:   0 kB
   HugetlbPages: 0 kB
   CoreDumping:   1
   THP_enabled:   1
   Threads:   4
   SigQ:  0/7609
   SigPnd:
   ShdPnd:
   SigBlk:
   SigIgn:1000
   SigCgt:00018000
   CapInh:
   CapPrm:
   CapEff:
   CapBnd:003f
   CapAmb:
   NoNewPrivs:0
   Seccomp:   0
   Speculation_Store_Bypass:  thread vulnerable
   Cpus_allowed:  3
   Cpus_allowed_list: 0-1
   Mems_allowed:  
,,,,,,,,,,,,,,,,,,,,,,,,,,,,
  ,,,0001
   Mems_allowed_list: 0
   voluntary_ctxt_switches:   111
   nonvoluntary_ctxt_switches:144
  Signal: 6
  Uname: Linux 5.4.0-21-generic x86_64
  UserGroups:

To manage notifications about this bug go to:
https://bugs.launchpad.net/dhcp/+bug/1872118/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1340177] Re: Python3-dbus attribute error, usb creator pendrive formatting.

2020-08-06 Thread Kai Kasurinen
** Package changed: dbus-python (Ubuntu) => usb-creator (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to dbus-python in Ubuntu.
https://bugs.launchpad.net/bugs/1340177

Title:
  Python3-dbus attribute error, usb creator pendrive formatting.

Status in usb-creator package in Ubuntu:
  New

Bug description:
  Python3-dbus attribute error, usb creator pendrive formatting. 14.04
  Trusty Tahr.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/usb-creator/+bug/1340177/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1760801] Re: package python3-dbus 1.2.0-3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 127

2020-08-06 Thread Kai Kasurinen
*** This bug is a duplicate of bug 1768379 ***
https://bugs.launchpad.net/bugs/1768379

** This bug has been marked a duplicate of bug 1768379
   python3-minimal should predepend on versioned version of python3-minimal

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to dbus-python in Ubuntu.
https://bugs.launchpad.net/bugs/1760801

Title:
  package python3-dbus 1.2.0-3 failed to install/upgrade: subprocess
  installed post-installation script returned error exit status 127

Status in dbus-python package in Ubuntu:
  Confirmed

Bug description:
  this error appeared during Ubuntu startup

  ProblemType: Package
  DistroRelease: Ubuntu 16.04
  Package: python3-dbus 1.2.0-3
  ProcVersionSignature: Ubuntu 4.4.0-116.140-generic 4.4.98
  Uname: Linux 4.4.0-116-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.15
  Architecture: amd64
  Date: Mon Mar 26 14:45:49 2018
  DuplicateSignature:
   package:python3-dbus:1.2.0-3
   Setting up python3-apt (1.1.0~beta1ubuntu0.16.04.1) ...
   /var/lib/dpkg/info/python3-apt.postinst: 6: 
/var/lib/dpkg/info/python3-apt.postinst: py3compile: not found
   dpkg: error processing package python3-apt (--configure):
subprocess installed post-installation script returned error exit status 127
  ErrorMessage: subprocess installed post-installation script returned error 
exit status 127
  InstallationDate: Installed on 2018-03-07 (26 days ago)
  InstallationMedia: Ubuntu-MATE 16.04 LTS "Xenial Xerus" - Release amd64 
(20160420.1)
  RelatedPackageVersions:
   dpkg 1.18.4ubuntu1.4
   apt  1.2.26
  SourcePackage: dbus-python
  Title: package python3-dbus 1.2.0-3 failed to install/upgrade: subprocess 
installed post-installation script returned error exit status 127
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dbus-python/+bug/1760801/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1669932] Re: package python-dbus 1.2.0-3 failed to install/upgrade: サブプロセス インストール済みの post-installation スクリプト はエラー終了ステータス 1 を返しました

2020-08-06 Thread Kai Kasurinen
*** This bug is a duplicate of bug 1715062 ***
https://bugs.launchpad.net/bugs/1715062

** This bug has been marked a duplicate of bug 1715062
   package python-six 1.10.0-3 failed to install/upgrade: subprocess installed 
pre-removal script returned error exit status 1

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to dbus-python in Ubuntu.
https://bugs.launchpad.net/bugs/1669932

Title:
  package python-dbus 1.2.0-3 failed to install/upgrade: サブプロセス
  インストール済みの post-installation スクリプト はエラー終了ステータス 1 を返しました

Status in dbus-python package in Ubuntu:
  New

Bug description:
  I don't know what exactly the problem is, but problem report is always
  displayed.

  ProblemType: Package
  DistroRelease: Ubuntu 16.04
  Package: python-dbus 1.2.0-3
  ProcVersionSignature: Ubuntu 4.4.0-64.85-generic 4.4.44
  Uname: Linux 4.4.0-64-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.4
  Architecture: amd64
  Date: Sat Mar  4 00:08:10 2017
  ErrorMessage: サブプロセス インストール済みの post-installation スクリプト はエラー終了ステータス 1 を返しました
  InstallationDate: Installed on 2017-01-22 (40 days ago)
  InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 
(20160719)
  RelatedPackageVersions:
   dpkg 1.18.4ubuntu1.1
   apt  1.2.15ubuntu0.2
  SourcePackage: dbus-python
  Title: package python-dbus 1.2.0-3 failed to install/upgrade: サブプロセス 
インストール済みの post-installation スクリプト はエラー終了ステータス 1 を返しました
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dbus-python/+bug/1669932/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890753] [NEW] DBusGMainLoop segfaults python if multi-threaded

2020-08-06 Thread Dan Streetman
Public bug reported:

python segfaults if DBusMainLoop is used in multiple threads; e.g.:

#!/usr/bin/python3

import dbus
import sys
import threading

from gi.repository import GLib

from dbus.mainloop.glib import DBusGMainLoop
#DBusGMainLoop(set_as_default=True) 
   

if __name__ == "__main__":
threading.Thread(target=GLib.MainLoop().run).start()

for r in range(1000):
print(".", flush=True, end="")
dbus.SessionBus(private=True, mainloop=DBusGMainLoop())
#dbus.SessionBus(private=True)  
   

print("")
sys.exit(0)


$ ./test.py
.Segmentation fault


It will also segfault if set_as_default is set to True, even without passing it 
to the SessionBus's mainloop parameter.

** Affects: dbus-python (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to dbus-python in Ubuntu.
https://bugs.launchpad.net/bugs/1890753

Title:
  DBusGMainLoop segfaults python if multi-threaded

Status in dbus-python package in Ubuntu:
  New

Bug description:
  python segfaults if DBusMainLoop is used in multiple threads; e.g.:

  #!/usr/bin/python3

  import dbus
  import sys
  import threading

  from gi.repository import GLib

  from dbus.mainloop.glib import DBusGMainLoop
  #DBusGMainLoop(set_as_default=True)   
 

  if __name__ == "__main__":
  threading.Thread(target=GLib.MainLoop().run).start()

  for r in range(1000):
  print(".", flush=True, end="")
  dbus.SessionBus(private=True, mainloop=DBusGMainLoop())
  #dbus.SessionBus(private=True)
 

  print("")
  sys.exit(0)


  $ ./test.py
  .Segmentation fault

  
  It will also segfault if set_as_default is set to True, even without passing 
it to the SessionBus's mainloop parameter.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dbus-python/+bug/1890753/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1405199] Re: Using open() on an optical drive with its tray open will close the tray

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1405199

Title:
  Using open() on an optical drive with its tray open will close the
  tray

Status in systemd package in Ubuntu:
  New

Bug description:
  I'm using Ubuntu 15.04 dev with udev 218-2ubuntu3 and if the tray of
  an optical drive is open and open() will then be used on the device
  file the tray will be closed. Here is an example code (compiled with
  "gcc -Wall -pedantic -o test test.c"):

  #include 

  int main()
  {
open("/dev/sr0", O_EXCL);
return 0;
  }

  
  Normally I would expect that the tray doesn't get closed so I'm assuming an 
udev rule causes this behavior.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1405199/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1456338] Re: USB floppy drive is running without floppy

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1456338

Title:
  USB floppy drive is running without floppy

Status in systemd package in Ubuntu:
  New

Bug description:
  When I connect USB floppy drive (Gembird) without floppy under Ubuntu, the 
drive engine seems to be running (the floppy drive LED is on and the drive is 
sounding). The same behaviour takes place if I connect the drive with a floppy 
and then remove the floppy. It seems that the system accesses the drive 
permanently when there is no floppy. Under Windows XP it works normally - when 
there is no floppy, the LED and engine are switched off. I have tried Ubuntu 
14.10 (amd64) with upstart, LXQt and KDE 5; Ubuntu 15.04 with systemd, LXQt - 
the same behaviour.
  If I boot using bash as init (init=/bin/bash) and connect the floppy drive 
after boot, the engine is off (the normal behaviour).
  lsof /dev/sdb during engine running outputs nothing.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1456338/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1495723] Re: Connecting USB devices failing

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1495723

Title:
  Connecting USB devices failing

Status in systemd package in Ubuntu:
  New

Bug description:
  rob@DesktopUbuntu:~$ lsb_release -rd
  Description:  Ubuntu 14.04.3 LTS
  Release:  14.04

  Ubuntu Software Center 13.10  (XUbuntu)

  I have had a problem with connecting my phone as a memory/disk device
  on Ubuntu 14.04 and found the same with a live install of 15.04. I
  recently bought an expensive 3-D Robox-CEL printer and was also
  experiencing no joy at all with extremely flaky connections.
  Fortunately one of the engineers at Robox-CEL published a patch to the
  udev .rules files and this cured the 3-D Printer connections and when
  I applied the same to the mobile phone .rules file it has been
  reliable as well.  His assertion was the later Linux's (I am not sure
  how wide he sees this problem here) have some sort of 'improvement'
  that interrogates the USB devices and in my case these two devices
  don't work with this new 'feature' and are extremely flaky.

  Here are the two new .rules I have added, that work for me

  # Samsung
  ATTRS{idVendor}=="04e8", ATTRS{idProduct}=="685b", 
ENV{ID_MM_DEVICE_IGNORE}="1"
  SUBSYSTEM=="usb", ATTR{idVendor}=="04e8", ATTR{idProduct}=="685b", 
GROUP="plugdev", NAME="GalaxySII", MODE="0666", OWNER=""

  #Robox Rules to stop the Linux sending disruptive commands to the 3D-Printer
  ATTRS{idVendor}=="16d0", ATTRS{idProduct}=="081b", 
ENV{ID_MM_DEVICE_IGNORE}="1"
  #Establish a standard name for the Robox tty interface
  SUBSYSTEM=="tty", ATTRS{idVendor}=="16d0", ATTRS{idProduct}=="081b", 
SYMLINK="robox%n", MODE="0666"

  The first line in the .rules is the really critical one.

  This has been a huge problem for me, and I registering it as a 'bug'
  as I believe the OS should be a bit more clever with these devices and
  should not require this sort of user work-around.  Over the last two
  years my phone went from super reliable to unusable, wasting huge
  amounts of my time, and recently made my 14 day old 3-D Printer from a
  quality manufacturer useless.

  Thank you for your time and patience. I can send you a log of the
  transactions of the Robox machine's interactions with the USB port if
  you need them.  However the above two files should give a good lead on
  where I feel the problems lie.

  Cheers, Rob Ward

  PS The Robox people also altered the shell script in their software to
  look for the newly named 'robox0' connection.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1495723/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1526111] Re: RAID1 + LVM in 14.04.3 causes intermittent boot failure

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1526111

Title:
  RAID1 + LVM in 14.04.3 causes intermittent boot failure

Status in systemd package in Ubuntu:
  New

Bug description:
  This problem seems to be related to a timing bug within `udev`, and has been 
experienced by other users as seen here;
  
http://serverfault.com/questions/567579/boot-failure-with-root-on-md-raid1-lvm-udev-event-timing

  Changing `/dev/md/0` to `/dev/md0` inside `/etc/mdadm/mdadm.conf`
  seems to resolve the problem. However unless you apply this patch, the
  system will intermittently fail to boot correctly, getting stuck here;

  kernel: [3.003506] md: bind
  kernel: [3.007705] md/raid1:md0: active with 1 out of 1 mirrors
  kernel: [3.007768] md0: detected capacity change from 0 to 499972440064
  kernel: [3.047284]  md0: unknown partition table
  kernel: [3.124709] device-mapper: table: 252:0: linear: dm-linear: Device 
lookup failed
  kernel: [3.124759] device-mapper: ioctl: error adding target to table
  kernel: [3.125156] device-mapper: table: 252:1: linear: dm-linear: Device 
lookup failed
  kernel: [3.125196] device-mapper: ioctl: error adding target to table

  There is also an example `/lib/udev/rules.d/` patch inside the thread
  I posted above, which proposes to add a `sleep` statement into LVM
  udev rules.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1526111/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1405199] [NEW] Using open() on an optical drive with its tray open will close the tray

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

I'm using Ubuntu 15.04 dev with udev 218-2ubuntu3 and if the tray of an
optical drive is open and open() will then be used on the device file
the tray will be closed. Here is an example code (compiled with "gcc
-Wall -pedantic -o test test.c"):

#include 

int main()
{
open("/dev/sr0", O_EXCL);
return 0;
}


Normally I would expect that the tray doesn't get closed so I'm assuming an 
udev rule causes this behavior.

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: vivid
-- 
Using open() on an optical drive with its tray open will close the tray
https://bugs.launchpad.net/bugs/1405199
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1618471] Re: udev: init script unconditionally writes to /sys/kernel/uevent_helper

2020-08-06 Thread Kai Kasurinen
Fixed in version systemd/208-8

** Package changed: udev (Debian) => systemd (Debian)

** Package changed: udev (Ubuntu) => systemd (Ubuntu)

** Changed in: systemd (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1618471

Title:
  udev: init script unconditionally writes to /sys/kernel/uevent_helper

Status in systemd package in Ubuntu:
  Fix Released
Status in systemd package in Debian:
  Fix Released

Bug description:
  The udev initramfs-tools script from trusty lts:

  /usr/share/initramfs-tools/scripts/init-top/udev

  does not check if uevent_helper does exist and fails to boot if it is
  missing - which it is in recent kernels (e.g. 4.7.2 from the mainline
  ppa or modern self build kernels where it is disabled per default
  afaik).

  See e.g.: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=756312

  Its fixed in xenials version (latest LTS) but fails in current supported LTS 
trusty to boot.
  Please backport those simple fix:

  if [ -w /sys/kernel/uevent_helper ]; then
echo > /sys/kernel/uevent_helper
  fi

  and maybe add

  udevadm settle || true

  at the end to support kernels without uevent_helper enabled.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1618471/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1559643] Re: kswapd0 high cpu

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1559643

Title:
  kswapd0 high cpu

Status in linux package in Ubuntu:
  Confirmed
Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  kswapd0 high cpu load.
  System doesn't have swap partition / swap file.

  Using AWS t2.nano

  ProblemType: Bug
  DistroRelease: Ubuntu 15.10
  Package: linux-image-4.2.0-34-generic 4.2.0-34.39
  ProcVersionSignature: User Name 4.2.0-34.39-generic 4.2.8-ckt4
  Uname: Linux 4.2.0-34-generic x86_64
  AlsaDevices:
   total 0
   crw-rw 1 root audio 116,  1 Mar 20 07:35 seq
   crw-rw 1 root audio 116, 33 Mar 20 07:35 timer
  AplayDevices: Error: [Errno 2] No such file or directory: 'aplay'
  ApportVersion: 2.19.1-0ubuntu5
  Architecture: amd64
  ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord'
  AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', 
'/dev/snd/timer'] failed with exit code 1:
  Date: Sun Mar 20 07:57:52 2016
  Ec2AMI: ami-b7443fc0
  Ec2AMIManifest: (unknown)
  Ec2AvailabilityZone: eu-west-1a
  Ec2InstanceType: t2.nano
  Ec2Kernel: unavailable
  Ec2Ramdisk: unavailable
  IwConfig: Error: [Errno 2] No such file or directory: 'iwconfig'
  Lsusb: Error: command ['lsusb'] failed with exit code 1: unable to initialize 
libusb: -99
  MachineType: Xen HVM domU
  PciMultimedia:
   
  ProcEnviron:
   TERM=xterm
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcFB:
   0 cirrusdrmfb
   1 xen
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-34-generic 
root=UUID=b079c5f1-8fc8-4bb0-aa26-31610f9c5615 ro console=tty1 console=ttyS0
  RelatedPackageVersions:
   linux-restricted-modules-4.2.0-34-generic N/A
   linux-backports-modules-4.2.0-34-generic  N/A
   linux-firmware1.149.3
  RfKill: Error: [Errno 2] No such file or directory: 'rfkill'
  SourcePackage: linux
  UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
  UpgradeStatus: Upgraded to wily on 2015-11-13 (127 days ago)
  dmi.bios.date: 12/07/2015
  dmi.bios.vendor: Xen
  dmi.bios.version: 4.2.amazon
  dmi.chassis.type: 1
  dmi.chassis.vendor: Xen
  dmi.modalias: 
dmi:bvnXen:bvr4.2.amazon:bd12/07/2015:svnXen:pnHVMdomU:pvr4.2.amazon:cvnXen:ct1:cvr:
  dmi.product.name: HVM domU
  dmi.product.version: 4.2.amazon
  dmi.sys.vendor: Xen

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1559643/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1564159] Re: vbox guest rules should be included by default

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1564159

Title:
  vbox guest rules should be included by default

Status in systemd package in Ubuntu:
  New

Bug description:
  Since vivid, Ubuntu ships the VirtualBox drivers as part of the main
  kernel package, by incorporating the virtualbox-guest-dkms package
  directly. See
  https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1418743 .
  However, the udev rules (/lib/udev/rules.d/60-virtualbox-guest-
  dkms.rules) from the same DKMS package are not beind shipped with the
  main udev installation. This leads to incorrect permissions of the
  /dev/vboxuser device. Since Ubuntu ships the kernel modules "by
  default" it should do the same for the udev rules. This is broken in
  vivid, wily and xenial.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1564159/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1583372] Re: 73-special-net-names.rules is renaming manually created wifi interface

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1583372

Title:
  73-special-net-names.rules is renaming manually created wifi interface

Status in systemd package in Ubuntu:
  New

Bug description:
  The 73-special-net-names.rules file from 229-4ubuntu5 is renaming USB
  wifi network interfaces that I create manually with "iw phy phy0
  interface add wifi0 type managed":

  # Use MAC based names for network interfaces which are directly or indirectly
  # on USB and have an universally administered (stable) MAC address (second bit
  # is 0).
  ACTION=="add", SUBSYSTEM=="net", SUBSYSTEMS=="usb", NAME=="", 
ATTR{address}=="?[014589cd]:*", IMPORT{builtin}="net_id", 
NAME="$env{ID_NET_NAME_MAC}"

  
  The device is being renamed by udev as soon as it is created:
  KERNEL[3299.499637] add  
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wifi0 (net)
  KERNEL[3299.500180] add  
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wifi0/queues/rx-0 (queues)
  KERNEL[3299.500388] add  
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wifi0/queues/tx-0 (queues)
  KERNEL[3299.500548] add  
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wifi0/queues/tx-1 (queues)
  KERNEL[3299.500680] add  
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wifi0/queues/tx-2 (queues)
  KERNEL[3299.500811] add  
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wifi0/queues/tx-3 (queues)
  KERNEL[3299.502911] move 
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wlxc83a35c1 (net)
  UDEV  [3299.546165] add  
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wlxc83a35c1 (net)
  UDEV  [3299.547977] add  
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wifi0/queues/rx-0 (queues)
  UDEV  [3299.549123] add  
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wifi0/queues/tx-0 (queues)
  UDEV  [3299.550082] add  
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wifi0/queues/tx-1 (queues)
  UDEV  [3299.550353] add  
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wifi0/queues/tx-2 (queues)
  UDEV  [3299.550495] add  
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wifi0/queues/tx-3 (queues)
  UDEV  [3299.552404] move 
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wlxc83a35c1 (net)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1583372/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1562589] Re: USB DVDRW's No Longer Function Correctly in 15.10 or 16.04

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1562589

Title:
  USB DVDRW's No Longer Function Correctly in 15.10 or 16.04

Status in systemd package in Ubuntu:
  New

Bug description:
  After upgrading several systems from 15.04 to 15.10, none of the
  systems were able to recognize the DVDRW in userland. This was tested
  with two different USB DVDRW's

  *-cdrom
 description: DVD-RAM writer
 product: SuperMultiPA3761
 vendor: Toshiba
 physical id: 0.0.0
 bus info: scsi@4:0.0.0
 logical name: /dev/cdrom
 logical name: /dev/cdrw
 logical name: /dev/dvd
 logical name: /dev/dvdrw
 logical name: /dev/sr0
 version: TO01
 capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
 configuration: status=ready
   *-medium
physical id: 0
logical name: /dev/cdrom

  
  And

*-cdrom
 description: DVD-RAM writer
 product: DVD RW DRU-830A
 vendor: SONY
 physical id: 0.0.0
 bus info: scsi@5:0.0.0
 logical name: /dev/cdrom
 logical name: /dev/cdrw
 logical name: /dev/dvd
 logical name: /dev/dvdrw
 logical name: /dev/sr0
 version: SS15
 capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
 configuration: status=ready
   *-medium
physical id: 0
logical name: /dev/cdrom

  This was also tested on 4 different systems. Three with Ubuntu and one
  with Kubuntu. I upgraded Kubuntu to 16.04. The difference in 16.04 is
  peculiar. The DVD player does not appear in any file manager. However,
  I could access the DVD via VLC. Attempting to play the DVD failed
  however. There was no sound and any option  chosen on the DVD menu
  resulted in a blank/black screen.

  This bug seems to afflict other users:

  http://askubuntu.com/questions/692934/after-upgrade-to-ubuntu-15-10
  -can-no-longer-access-video-files-on-cd-dvd

  I've also included this report here:

  https://bugs.launchpad.net/ubuntu/+source/udev/+bug/646293?comments=all

  But am filing a new bug since the other seems to be dead and/or
  outdated.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1562589/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1456338] [NEW] USB floppy drive is running without floppy

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

When I connect USB floppy drive (Gembird) without floppy under Ubuntu, the 
drive engine seems to be running (the floppy drive LED is on and the drive is 
sounding). The same behaviour takes place if I connect the drive with a floppy 
and then remove the floppy. It seems that the system accesses the drive 
permanently when there is no floppy. Under Windows XP it works normally - when 
there is no floppy, the LED and engine are switched off. I have tried Ubuntu 
14.10 (amd64) with upstart, LXQt and KDE 5; Ubuntu 15.04 with systemd, LXQt - 
the same behaviour.
If I boot using bash as init (init=/bin/bash) and connect the floppy drive 
after boot, the engine is off (the normal behaviour).
lsof /dev/sdb during engine running outputs nothing.

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: bot-comment floppy hardware usb
-- 
USB floppy drive is running without floppy
https://bugs.launchpad.net/bugs/1456338
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1495723] [NEW] Connecting USB devices failing

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

rob@DesktopUbuntu:~$ lsb_release -rd
Description:Ubuntu 14.04.3 LTS
Release:14.04

Ubuntu Software Center 13.10  (XUbuntu)

I have had a problem with connecting my phone as a memory/disk device on
Ubuntu 14.04 and found the same with a live install of 15.04. I recently
bought an expensive 3-D Robox-CEL printer and was also experiencing no
joy at all with extremely flaky connections.  Fortunately one of the
engineers at Robox-CEL published a patch to the udev .rules files and
this cured the 3-D Printer connections and when I applied the same to
the mobile phone .rules file it has been reliable as well.  His
assertion was the later Linux's (I am not sure how wide he sees this
problem here) have some sort of 'improvement' that interrogates the USB
devices and in my case these two devices don't work with this new
'feature' and are extremely flaky.

Here are the two new .rules I have added, that work for me

# Samsung
ATTRS{idVendor}=="04e8", ATTRS{idProduct}=="685b", ENV{ID_MM_DEVICE_IGNORE}="1"
SUBSYSTEM=="usb", ATTR{idVendor}=="04e8", ATTR{idProduct}=="685b", 
GROUP="plugdev", NAME="GalaxySII", MODE="0666", OWNER=""

#Robox Rules to stop the Linux sending disruptive commands to the 3D-Printer
ATTRS{idVendor}=="16d0", ATTRS{idProduct}=="081b", ENV{ID_MM_DEVICE_IGNORE}="1"
#Establish a standard name for the Robox tty interface
SUBSYSTEM=="tty", ATTRS{idVendor}=="16d0", ATTRS{idProduct}=="081b", 
SYMLINK="robox%n", MODE="0666"

The first line in the .rules is the really critical one.

This has been a huge problem for me, and I registering it as a 'bug' as
I believe the OS should be a bit more clever with these devices and
should not require this sort of user work-around.  Over the last two
years my phone went from super reliable to unusable, wasting huge
amounts of my time, and recently made my 14 day old 3-D Printer from a
quality manufacturer useless.

Thank you for your time and patience. I can send you a log of the
transactions of the Robox machine's interactions with the USB port if
you need them.  However the above two files should give a good lead on
where I feel the problems lie.

Cheers, Rob Ward

PS The Robox people also altered the shell script in their software to
look for the newly named 'robox0' connection.

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: bot-comment
-- 
Connecting USB devices failing
https://bugs.launchpad.net/bugs/1495723
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1526111] [NEW] RAID1 + LVM in 14.04.3 causes intermittent boot failure

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

This problem seems to be related to a timing bug within `udev`, and has been 
experienced by other users as seen here;
http://serverfault.com/questions/567579/boot-failure-with-root-on-md-raid1-lvm-udev-event-timing

Changing `/dev/md/0` to `/dev/md0` inside `/etc/mdadm/mdadm.conf` seems
to resolve the problem. However unless you apply this patch, the system
will intermittently fail to boot correctly, getting stuck here;

kernel: [3.003506] md: bind
kernel: [3.007705] md/raid1:md0: active with 1 out of 1 mirrors
kernel: [3.007768] md0: detected capacity change from 0 to 499972440064
kernel: [3.047284]  md0: unknown partition table
kernel: [3.124709] device-mapper: table: 252:0: linear: dm-linear: Device 
lookup failed
kernel: [3.124759] device-mapper: ioctl: error adding target to table
kernel: [3.125156] device-mapper: table: 252:1: linear: dm-linear: Device 
lookup failed
kernel: [3.125196] device-mapper: ioctl: error adding target to table

There is also an example `/lib/udev/rules.d/` patch inside the thread I
posted above, which proposes to add a `sleep` statement into LVM udev
rules.

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: lvm mdadm raid
-- 
RAID1 + LVM in 14.04.3 causes intermittent boot failure
https://bugs.launchpad.net/bugs/1526111
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1562589] [NEW] USB DVDRW's No Longer Function Correctly in 15.10 or 16.04

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

After upgrading several systems from 15.04 to 15.10, none of the systems
were able to recognize the DVDRW in userland. This was tested with two
different USB DVDRW's

*-cdrom
   description: DVD-RAM writer
   product: SuperMultiPA3761
   vendor: Toshiba
   physical id: 0.0.0
   bus info: scsi@4:0.0.0
   logical name: /dev/cdrom
   logical name: /dev/cdrw
   logical name: /dev/dvd
   logical name: /dev/dvdrw
   logical name: /dev/sr0
   version: TO01
   capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
   configuration: status=ready
 *-medium
  physical id: 0
  logical name: /dev/cdrom


And

  *-cdrom
   description: DVD-RAM writer
   product: DVD RW DRU-830A
   vendor: SONY
   physical id: 0.0.0
   bus info: scsi@5:0.0.0
   logical name: /dev/cdrom
   logical name: /dev/cdrw
   logical name: /dev/dvd
   logical name: /dev/dvdrw
   logical name: /dev/sr0
   version: SS15
   capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
   configuration: status=ready
 *-medium
  physical id: 0
  logical name: /dev/cdrom

This was also tested on 4 different systems. Three with Ubuntu and one
with Kubuntu. I upgraded Kubuntu to 16.04. The difference in 16.04 is
peculiar. The DVD player does not appear in any file manager. However, I
could access the DVD via VLC. Attempting to play the DVD failed however.
There was no sound and any option  chosen on the DVD menu resulted in a
blank/black screen.

This bug seems to afflict other users:

http://askubuntu.com/questions/692934/after-upgrade-to-ubuntu-15-10-can-
no-longer-access-video-files-on-cd-dvd

I've also included this report here:

https://bugs.launchpad.net/ubuntu/+source/udev/+bug/646293?comments=all

But am filing a new bug since the other seems to be dead and/or
outdated.

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New

-- 
USB DVDRW's No Longer Function Correctly in 15.10 or 16.04
https://bugs.launchpad.net/bugs/1562589
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1559643] [NEW] kswapd0 high cpu

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

kswapd0 high cpu load.
System doesn't have swap partition / swap file.

Using AWS t2.nano

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: linux-image-4.2.0-34-generic 4.2.0-34.39
ProcVersionSignature: User Name 4.2.0-34.39-generic 4.2.8-ckt4
Uname: Linux 4.2.0-34-generic x86_64
AlsaDevices:
 total 0
 crw-rw 1 root audio 116,  1 Mar 20 07:35 seq
 crw-rw 1 root audio 116, 33 Mar 20 07:35 timer
AplayDevices: Error: [Errno 2] No such file or directory: 'aplay'
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord'
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', 
'/dev/snd/timer'] failed with exit code 1:
Date: Sun Mar 20 07:57:52 2016
Ec2AMI: ami-b7443fc0
Ec2AMIManifest: (unknown)
Ec2AvailabilityZone: eu-west-1a
Ec2InstanceType: t2.nano
Ec2Kernel: unavailable
Ec2Ramdisk: unavailable
IwConfig: Error: [Errno 2] No such file or directory: 'iwconfig'
Lsusb: Error: command ['lsusb'] failed with exit code 1: unable to initialize 
libusb: -99
MachineType: Xen HVM domU
PciMultimedia:
 
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB:
 0 cirrusdrmfb
 1 xen
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-34-generic 
root=UUID=b079c5f1-8fc8-4bb0-aa26-31610f9c5615 ro console=tty1 console=ttyS0
RelatedPackageVersions:
 linux-restricted-modules-4.2.0-34-generic N/A
 linux-backports-modules-4.2.0-34-generic  N/A
 linux-firmware1.149.3
RfKill: Error: [Errno 2] No such file or directory: 'rfkill'
SourcePackage: linux
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: Upgraded to wily on 2015-11-13 (127 days ago)
dmi.bios.date: 12/07/2015
dmi.bios.vendor: Xen
dmi.bios.version: 4.2.amazon
dmi.chassis.type: 1
dmi.chassis.vendor: Xen
dmi.modalias: 
dmi:bvnXen:bvr4.2.amazon:bd12/07/2015:svnXen:pnHVMdomU:pvr4.2.amazon:cvnXen:ct1:cvr:
dmi.product.name: HVM domU
dmi.product.version: 4.2.amazon
dmi.sys.vendor: Xen

** Affects: linux (Ubuntu)
 Importance: Medium
 Status: Confirmed

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: Confirmed


** Tags: amd64 apport-bug ec2-images wily
-- 
kswapd0 high cpu
https://bugs.launchpad.net/bugs/1559643
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1635729] Re: bcache won't start on boot due to exotic block devices filtered in udev rules

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1635729

Title:
  bcache won't start on boot due to exotic block devices filtered in
  udev rules

Status in systemd package in Ubuntu:
  New

Bug description:
  If a bcache is created with a Curtis-Wright NVRAM card as caching
  device, the bcache device will not show up on boot without manual
  intervention.

  Tracking this down show this being due to the fact, that line 9 of
  /lib/udev/rules.d/60-persistent-storage.rules filters on a whitelist
  of devices
  
(loop*|mmcblk*[0-9]|msblk*[0-9]|mspblk*[0-9]|nvme*|sd*|sr*|vd*|xvd*|bcache*|cciss*|dasd*|ubd*),
  that doesn't include the NVRAM devices (umem*). A few steps later,
  this results in bcache_register() not being called.

  Trivially patching

  
-KERNEL!="loop*|mmcblk*[0-9]|msblk*[0-9]|mspblk*[0-9]|nvme*|sd*|sr*|vd*|xvd*|bcache*|cciss*|dasd*|ubd*",
 GOTO="persistent_storage_end"
  
+KERNEL!="loop*|mmcblk*[0-9]|msblk*[0-9]|mspblk*[0-9]|nvme*|sd*|sr*|vd*|xvd*|bcache*|cciss*|dasd*|ubd*|umem*",
 GOTO="persistent_storage_end"

  resolves the issue.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1635729/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1638518] Re: USB port gets rarely disabled until the next reboot

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1638518

Title:
  USB port gets rarely disabled until the next reboot

Status in systemd package in Ubuntu:
  New

Bug description:
  I'm using Ubuntu 17.04 dev with udev 231-10 and rarely (happened now
  the second time within 1-2 months) I'm noticing that the USB port of
  my mouse disables. This happens randomly on the current boot instance
  and replugging the mouse into the same USB port does not solve the
  issue. But plugging the mouse into another port causes it to work
  again but trying to plugging it back to the old port causes it to not
  work anymore. The only way to get the USB port working again is to
  reboot the system.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1638518/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1634714] Re: ASUS T300 CHI Keyboard Fn Mappings

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1634714

Title:
  ASUS T300 CHI Keyboard Fn Mappings

Status in systemd package in Ubuntu:
  New

Bug description:
  I believe that this is in the incorrect queue, but Launchpad would not
  allow me to move it to udev.

  I am submitting this bug report following the directions at
  https://wiki.ubuntu.com/Hotkeys/Troubleshooting

  1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> 
About Ubuntu
  Ubuntu 16.10

  2) The version of the package you are using, via 'apt-cache policy pkgname' 
or by checking in Software Center
    Installed: 231-9git1

  The Fn+F5,F6,F7, and F9 combinations do not produce the desired
  behavior of changing screen brightness or toggling the touchpad on the
  ASUS T300 Chi bluetooth keyboard. They do not produce any response
  whatsoever.

  They key events (as according to evtest) and their functions are
  listed below.

  type 2 (EV_REL), code 9 (REL_MISC), value 16 : Brightness Down (Fn + F5)
  type 2 (EV_REL), code 9 (REL_MISC), value 32 : Brightness Up (Fn + F6)
  type 2 (EV_REL), code 9 (REL_MISC), value 53 : Disable LCD Backlight (Fn + F7)
  type 2 (EV_REL), code 9 (REL_MISC), value 107 : Disable Touchpad (Fn + F9)

  Please let me know if I missed anything, this is my first bug report.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: udev 231-9git1
  ProcVersionSignature: Ubuntu 4.8.0-22.24-generic 4.8.0
  Uname: Linux 4.8.0-22-generic x86_64
  ApportVersion: 2.20.3-0ubuntu8
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Tue Oct 18 20:04:07 2016
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2016-10-18 (0 days ago)
  InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.2)
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 004: ID 06cb:11f0 Synaptics, Inc.
   Bus 001 Device 003: ID 0bda:57d2 Realtek Semiconductor Corp.
   Bus 001 Device 012: ID 8087:0a2a Intel Corp.
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: ASUSTeK COMPUTER INC. T300CHI
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.8.0-22-generic.efi.signed 
root=UUID=33082bfc-d5e7-4dd9-869c-01e06d67bb28 ro quiet splash vt.handoff=7
  SourcePackage: systemd
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/06/2015
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: T300CHI.207
  dmi.board.asset.tag: ATN12345678901234567
  dmi.board.name: T300CHI
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: 1.0
  dmi.chassis.asset.tag: ATN12345678901234567
  dmi.chassis.type: 10
  dmi.chassis.vendor: ASUSTeK COMPUTER INC.
  dmi.chassis.version: 1.0
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrT300CHI.207:bd08/06/2015:svnASUSTeKCOMPUTERINC.:pnT300CHI:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnT300CHI:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
  dmi.product.name: T300CHI
  dmi.product.version: 1.0
  dmi.sys.vendor: ASUSTeK COMPUTER INC.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1634714/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1646557] Re: /bin/udevadm should be exit 0 instead of exit 1

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1646557

Title:
  /bin/udevadm should be exit 0 instead of exit 1

Status in systemd package in Ubuntu:
  New

Bug description:
  if [ "$1" = "trigger" ]; then
  echo "some text halt was sinnvolle oder unsinniges zum Abruch
exit 1
  fi

  apt-get install rfkill 
  for example fails to configure 

  why not in /bin/udevadm end with exit 0 in case of trigger
  or settle? 

  then apt-get install rfkill and 28 other packages can configure

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1646557/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1564159] [NEW] vbox guest rules should be included by default

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

Since vivid, Ubuntu ships the VirtualBox drivers as part of the main
kernel package, by incorporating the virtualbox-guest-dkms package
directly. See
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1418743 . However,
the udev rules (/lib/udev/rules.d/60-virtualbox-guest-dkms.rules) from
the same DKMS package are not beind shipped with the main udev
installation. This leads to incorrect permissions of the /dev/vboxuser
device. Since Ubuntu ships the kernel modules "by default" it should do
the same for the udev rules. This is broken in vivid, wily and xenial.

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New

-- 
vbox guest rules should be included by default
https://bugs.launchpad.net/bugs/1564159
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1583372] [NEW] 73-special-net-names.rules is renaming manually created wifi interface

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

The 73-special-net-names.rules file from 229-4ubuntu5 is renaming USB
wifi network interfaces that I create manually with "iw phy phy0
interface add wifi0 type managed":

# Use MAC based names for network interfaces which are directly or indirectly
# on USB and have an universally administered (stable) MAC address (second bit
# is 0).
ACTION=="add", SUBSYSTEM=="net", SUBSYSTEMS=="usb", NAME=="", 
ATTR{address}=="?[014589cd]:*", IMPORT{builtin}="net_id", 
NAME="$env{ID_NET_NAME_MAC}"


The device is being renamed by udev as soon as it is created:
KERNEL[3299.499637] add  
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wifi0 (net)
KERNEL[3299.500180] add  
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wifi0/queues/rx-0 (queues)
KERNEL[3299.500388] add  
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wifi0/queues/tx-0 (queues)
KERNEL[3299.500548] add  
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wifi0/queues/tx-1 (queues)
KERNEL[3299.500680] add  
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wifi0/queues/tx-2 (queues)
KERNEL[3299.500811] add  
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wifi0/queues/tx-3 (queues)
KERNEL[3299.502911] move 
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wlxc83a35c1 (net)
UDEV  [3299.546165] add  
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wlxc83a35c1 (net)
UDEV  [3299.547977] add  
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wifi0/queues/rx-0 (queues)
UDEV  [3299.549123] add  
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wifi0/queues/tx-0 (queues)
UDEV  [3299.550082] add  
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wifi0/queues/tx-1 (queues)
UDEV  [3299.550353] add  
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wifi0/queues/tx-2 (queues)
UDEV  [3299.550495] add  
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wifi0/queues/tx-3 (queues)
UDEV  [3299.552404] move 
/devices/pci:00/:00:14.0/usb1/1-5/1-5:1.0/net/wlxc83a35c1 (net)

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New

-- 
73-special-net-names.rules is renaming manually created wifi interface
https://bugs.launchpad.net/bugs/1583372
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1618471] [NEW] udev: init script unconditionally writes to /sys/kernel/uevent_helper

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

The udev initramfs-tools script from trusty lts:

/usr/share/initramfs-tools/scripts/init-top/udev

does not check if uevent_helper does exist and fails to boot if it is
missing - which it is in recent kernels (e.g. 4.7.2 from the mainline
ppa or modern self build kernels where it is disabled per default
afaik).

See e.g.: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=756312

Its fixed in xenials version (latest LTS) but fails in current supported LTS 
trusty to boot.
Please backport those simple fix:

if [ -w /sys/kernel/uevent_helper ]; then
echo > /sys/kernel/uevent_helper
fi

and maybe add

udevadm settle || true

at the end to support kernels without uevent_helper enabled.

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: Fix Released

** Affects: systemd (Debian)
 Importance: Unknown
 Status: Fix Released


** Tags: trusty
-- 
udev: init script unconditionally writes to /sys/kernel/uevent_helper
https://bugs.launchpad.net/bugs/1618471
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1634714] [NEW] ASUS T300 CHI Keyboard Fn Mappings

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

I believe that this is in the incorrect queue, but Launchpad would not
allow me to move it to udev.

I am submitting this bug report following the directions at
https://wiki.ubuntu.com/Hotkeys/Troubleshooting

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> 
About Ubuntu
Ubuntu 16.10

2) The version of the package you are using, via 'apt-cache policy pkgname' or 
by checking in Software Center
  Installed: 231-9git1

The Fn+F5,F6,F7, and F9 combinations do not produce the desired behavior
of changing screen brightness or toggling the touchpad on the ASUS T300
Chi bluetooth keyboard. They do not produce any response whatsoever.

They key events (as according to evtest) and their functions are listed
below.

type 2 (EV_REL), code 9 (REL_MISC), value 16 : Brightness Down (Fn + F5)
type 2 (EV_REL), code 9 (REL_MISC), value 32 : Brightness Up (Fn + F6)
type 2 (EV_REL), code 9 (REL_MISC), value 53 : Disable LCD Backlight (Fn + F7)
type 2 (EV_REL), code 9 (REL_MISC), value 107 : Disable Touchpad (Fn + F9)

Please let me know if I missed anything, this is my first bug report.

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: udev 231-9git1
ProcVersionSignature: Ubuntu 4.8.0-22.24-generic 4.8.0
Uname: Linux 4.8.0-22-generic x86_64
ApportVersion: 2.20.3-0ubuntu8
Architecture: amd64
CurrentDesktop: Unity
Date: Tue Oct 18 20:04:07 2016
EcryptfsInUse: Yes
InstallationDate: Installed on 2016-10-18 (0 days ago)
InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.2)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 004: ID 06cb:11f0 Synaptics, Inc.
 Bus 001 Device 003: ID 0bda:57d2 Realtek Semiconductor Corp.
 Bus 001 Device 012: ID 8087:0a2a Intel Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: ASUSTeK COMPUTER INC. T300CHI
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.8.0-22-generic.efi.signed 
root=UUID=33082bfc-d5e7-4dd9-869c-01e06d67bb28 ro quiet splash vt.handoff=7
SourcePackage: systemd
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/06/2015
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: T300CHI.207
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: T300CHI
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrT300CHI.207:bd08/06/2015:svnASUSTeKCOMPUTERINC.:pnT300CHI:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnT300CHI:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: T300CHI
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug yakkety
-- 
ASUS T300 CHI Keyboard Fn Mappings
https://bugs.launchpad.net/bugs/1634714
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1635729] [NEW] bcache won't start on boot due to exotic block devices filtered in udev rules

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

If a bcache is created with a Curtis-Wright NVRAM card as caching
device, the bcache device will not show up on boot without manual
intervention.

Tracking this down show this being due to the fact, that line 9 of
/lib/udev/rules.d/60-persistent-storage.rules filters on a whitelist of
devices
(loop*|mmcblk*[0-9]|msblk*[0-9]|mspblk*[0-9]|nvme*|sd*|sr*|vd*|xvd*|bcache*|cciss*|dasd*|ubd*),
that doesn't include the NVRAM devices (umem*). A few steps later, this
results in bcache_register() not being called.

Trivially patching

-KERNEL!="loop*|mmcblk*[0-9]|msblk*[0-9]|mspblk*[0-9]|nvme*|sd*|sr*|vd*|xvd*|bcache*|cciss*|dasd*|ubd*",
 GOTO="persistent_storage_end"
+KERNEL!="loop*|mmcblk*[0-9]|msblk*[0-9]|mspblk*[0-9]|nvme*|sd*|sr*|vd*|xvd*|bcache*|cciss*|dasd*|ubd*|umem*",
 GOTO="persistent_storage_end"

resolves the issue.

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: bot-comment
-- 
bcache won't start on boot due to exotic block devices filtered in udev rules
https://bugs.launchpad.net/bugs/1635729
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1647067] Re: Dangling UDEV links after removing FC LUNs

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1647067

Title:
  Dangling UDEV links after removing FC LUNs

Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  We're using Q-Logic QLE2562 Fibre Channel adapters (qla2xxx driver)
  against a HPE 3PAR 7400c storage array in an OpenStack environment.
  The OpenStack 3PAR driver manages volume attachments from the array to
  the servers. There is 4 path multipath to every volume.

  As the LUNs are removed, sometimes udev does not remove all links,
  particularly in /run/udev/links and /dev/disk/by-path. The symptoms
  are multiple records in one by-path directory under /run/udev/links,
  broken links to no longer attached luns in dev/disk/by-path and links
  between wrong LUNs and scsi devices there.

  OpenStack relies on these links. When another volume is attached using
  a LUN that has these leftover links and it happens that it is the
  first of the 4 paths, OpenStack incorrectly identifies the volume and
  attaches the same volume to multiple instances, leading to data loss.

  What could be causing this behavior?

  Ubuntu version 14.04 
  Linux version Ubuntu 4.4.0-47.68~14.04.1-generic 4.4.24
  udev 204-5ubuntu20.19
  --- 
  ApportVersion: 2.14.1-0ubuntu3.21
  Architecture: amd64
  CustomUdevRuleFiles: 20-3par-unmap.rulez
  DistroRelease: Ubuntu 14.04
  InstallationDate: Installed on 2015-10-01 (429 days ago)
  InstallationMedia: Ubuntu-Server 14.04.3 LTS "Trusty Tahr" - Beta amd64 
(20150805)
  MachineType: HP ProLiant DL380 Gen9
  Package: udev 204-5ubuntu20.19
  PackageArchitecture: amd64
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.4.0-47-generic 
root=/dev/mapper/hostname--vg-root ro
  ProcVersionSignature: Ubuntu 4.4.0-47.68~14.04.1-generic 4.4.24
  Tags:  trusty
  UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
  Uname: Linux 4.4.0-47-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups:
   
  _MarkForUpload: True
  dmi.bios.date: 11/03/2014
  dmi.bios.vendor: HP
  dmi.bios.version: P89
  dmi.chassis.type: 23
  dmi.chassis.vendor: HP
  dmi.modalias: 
dmi:bvnHP:bvrP89:bd11/03/2014:svnHP:pnProLiantDL380Gen9:pvr:cvnHP:ct23:cvr:
  dmi.product.name: ProLiant DL380 Gen9
  dmi.sys.vendor: HP

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1647067/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1647078] Re: udevadm trigger (falsely?) reports udev is not configured

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1647078

Title:
  udevadm trigger (falsely?) reports udev is not configured

Status in systemd package in Ubuntu:
  New

Bug description:
  Eigentlich wollte ich nur ubuntu oder gnome als Desktop verwenden, da
  beide nicht starteten nahm ich dann Meta das läuft wenigstens und
  bekam die Fehlermeldung präsentiert. udisk2 ist wohl ein
  Abhängigkeitspaket für ubuntu-Desktop oder gnome-desktop beide wollen
  nicht laufen, warum auch immer.

  ProblemType: Package
  DistroRelease: Ubuntu 16.04
  Package: udisks2 2.1.7-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-51.72-generic 4.4.30
  Uname: Linux 4.4.0-51-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.2
  Architecture: amd64
  CustomUdevRuleFiles: 51-android.rules 69-usbmoto.rules 69-libmtp.rules 
60-raw1394.rules z60_hdaps-games.rules README.dpkg-new 51-hdaps.rules 
69-phicomm.rules
  Date: Thu Dec  1 12:10:32 2016
  ErrorMessage: Unterprozess installiertes post-installation-Skript gab den 
Fehlerwert 1 zurück
  MachineType: LENOVO 3093BU3
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-51-generic 
root=UUID=7aead086-5ba6-492c-921a-17a5656dba11 ro locale=de_DE bootkbd=de 
console-setup/layoutcode=de quiet splash selinux=0 enforcing=0 acpi_osi=Linux 
loglevel=0 vt.handoff=7
  RelatedPackageVersions:
   dpkg 1.18.4ubuntu1.1
   apt  1.2.15
  SourcePackage: udisks2
  Title: package udisks2 2.1.7-1ubuntu1 failed to install/upgrade: Unterprozess 
installiertes post-installation-Skript gab den Fehlerwert 1 zurück
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 10/11/2012
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 6QET70WW (1.40 )
  dmi.board.name: 3093BU3
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Available
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: 
dmi:bvnLENOVO:bvr6QET70WW(1.40):bd10/11/2012:svnLENOVO:pn3093BU3:pvrThinkPadX201Tablet:rvnLENOVO:rn3093BU3:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.name: 3093BU3
  dmi.product.version: ThinkPad X201 Tablet
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1647078/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1652019] Re: udev does not read LINK files dynamically

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1652019

Title:
  udev does not read LINK files dynamically

Status in systemd package in Ubuntu:
  New

Bug description:
  Hello all,

  To comply to SystemD's way of thinking, NIC names can be changed
  assuming my MAC addresses.

  I have then changed /etc/systemd/10-net.link assuming the nomenclature
  in https://www.freedesktop.org/software/systemd/man/systemd.link.html.

  Expected behavior: When restart, changes can be taken into account and
  NIC names changed, just like udev udev raw rules in /etc/udev/rules.d.

  Got: NIC names not changed. However: whane re-updating initramfs ( #
  update-initramfs -u ), it works.

  Question: why is udev not reading SystemD link files directly in the
  root FS, but is able to read udev rules.d files ?

  Distro : Ubuntu 16.04.4

  Thanks,

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1652019/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1638518] [NEW] USB port gets rarely disabled until the next reboot

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

I'm using Ubuntu 17.04 dev with udev 231-10 and rarely (happened now the
second time within 1-2 months) I'm noticing that the USB port of my
mouse disables. This happens randomly on the current boot instance and
replugging the mouse into the same USB port does not solve the issue.
But plugging the mouse into another port causes it to work again but
trying to plugging it back to the old port causes it to not work
anymore. The only way to get the USB port working again is to reboot the
system.

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New

-- 
USB port gets rarely disabled until the next reboot
https://bugs.launchpad.net/bugs/1638518
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1888572] Re: motd-news: use wget instead of curl

2020-08-06 Thread Launchpad Bug Tracker
** Merge proposal linked:
   
https://code.launchpad.net/~ahasenack/ubuntu/+source/base-files/+git/base-files/+merge/388848

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to base-files in Ubuntu.
https://bugs.launchpad.net/bugs/1888572

Title:
  motd-news: use wget instead of curl

Status in base-files package in Ubuntu:
  Fix Released
Status in base-files source package in Xenial:
  In Progress
Status in base-files source package in Bionic:
  In Progress
Status in base-files source package in Focal:
  In Progress

Bug description:
  The motd-news script is using curl, but since that is an optional
  package, there is no guarantee that it will be installed. The script
  correctly checks for its presence before trying to use it, though, so
  it won't fail. As we don't want to add such a dependency to the base-
  files package, we should switch to wget, which is standard.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/base-files/+bug/1888572/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1888575] Re: Split motd-news config into a new package

2020-08-06 Thread Launchpad Bug Tracker
** Merge proposal linked:
   
https://code.launchpad.net/~ahasenack/ubuntu/+source/base-files/+git/base-files/+merge/388848

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to base-files in Ubuntu.
https://bugs.launchpad.net/bugs/1888575

Title:
  Split motd-news config into a new package

Status in base-files package in Ubuntu:
  In Progress
Status in ubuntu-meta package in Ubuntu:
  In Progress
Status in base-files source package in Xenial:
  In Progress
Status in ubuntu-meta source package in Xenial:
  In Progress
Status in base-files source package in Bionic:
  In Progress
Status in ubuntu-meta source package in Bionic:
  In Progress
Status in base-files source package in Focal:
  In Progress
Status in ubuntu-meta source package in Focal:
  In Progress
Status in base-files source package in Groovy:
  In Progress
Status in ubuntu-meta source package in Groovy:
  In Progress

Bug description:
  The motd-news script is largely useless for desktop users, as they
  rarely login via a text console. It makes more sense for server users.

  We can use package dependencies to have the motd-news script enabled on 
servers, but disabled on desktops, and still handle upgrades. This is the plan:
  - move /etc/default/motd-news from base-files into a NEW package 
(motd-news-config)
  - have ubuntu-server depend on motd-news-config (or recommends)
  - have base-files break current ubuntu-server, so that if base-files if 
upgraded and ubuntu-server is installed, ubuntu-server will also be upgraded to 
the new version which has the depends (or recommends) on motd-news-config

  Care must be taken to preserve a changed /etc/default/motd-news when
  the upgrade installs the new motd-news-config package. For example, on
  a server that has set ENABLED=0 in /etc/default/motd-news and upgrades
  to the new base-files and ubuntu-server, and gets the new motd-config-
  news package, ENABLED=0 must remain set.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/base-files/+bug/1888575/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1646557] [NEW] /bin/udevadm should be exit 0 instead of exit 1

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

if [ "$1" = "trigger" ]; then
echo "some text halt was sinnvolle oder unsinniges zum Abruch
  exit 1
fi

apt-get install rfkill 
for example fails to configure 

why not in /bin/udevadm end with exit 0 in case of trigger
or settle? 

then apt-get install rfkill and 28 other packages can configure

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New

-- 
/bin/udevadm should be exit 0 instead of exit 1
https://bugs.launchpad.net/bugs/1646557
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1647067] [NEW] Dangling UDEV links after removing FC LUNs

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

We're using Q-Logic QLE2562 Fibre Channel adapters (qla2xxx driver)
against a HPE 3PAR 7400c storage array in an OpenStack environment. The
OpenStack 3PAR driver manages volume attachments from the array to the
servers. There is 4 path multipath to every volume.

As the LUNs are removed, sometimes udev does not remove all links,
particularly in /run/udev/links and /dev/disk/by-path. The symptoms are
multiple records in one by-path directory under /run/udev/links, broken
links to no longer attached luns in dev/disk/by-path and links between
wrong LUNs and scsi devices there.

OpenStack relies on these links. When another volume is attached using a
LUN that has these leftover links and it happens that it is the first of
the 4 paths, OpenStack incorrectly identifies the volume and attaches
the same volume to multiple instances, leading to data loss.

What could be causing this behavior?

Ubuntu version 14.04 
Linux version Ubuntu 4.4.0-47.68~14.04.1-generic 4.4.24
udev 204-5ubuntu20.19
--- 
ApportVersion: 2.14.1-0ubuntu3.21
Architecture: amd64
CustomUdevRuleFiles: 20-3par-unmap.rulez
DistroRelease: Ubuntu 14.04
InstallationDate: Installed on 2015-10-01 (429 days ago)
InstallationMedia: Ubuntu-Server 14.04.3 LTS "Trusty Tahr" - Beta amd64 
(20150805)
MachineType: HP ProLiant DL380 Gen9
Package: udev 204-5ubuntu20.19
PackageArchitecture: amd64
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.4.0-47-generic 
root=/dev/mapper/hostname--vg-root ro
ProcVersionSignature: Ubuntu 4.4.0-47.68~14.04.1-generic 4.4.24
Tags:  trusty
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
Uname: Linux 4.4.0-47-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:
 
_MarkForUpload: True
dmi.bios.date: 11/03/2014
dmi.bios.vendor: HP
dmi.bios.version: P89
dmi.chassis.type: 23
dmi.chassis.vendor: HP
dmi.modalias: 
dmi:bvnHP:bvrP89:bd11/03/2014:svnHP:pnProLiantDL380Gen9:pvr:cvnHP:ct23:cvr:
dmi.product.name: ProLiant DL380 Gen9
dmi.sys.vendor: HP

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: Confirmed


** Tags: apport-collected kernel-da-key trusty
-- 
Dangling UDEV links after removing FC LUNs
https://bugs.launchpad.net/bugs/1647067
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1702320] Re: CUPS serial backend don't initialize correctly USB to serial converters

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1702320

Title:
  CUPS serial backend don't initialize correctly USB to serial
  converters

Status in systemd package in Ubuntu:
  New

Bug description:
  CUPS serial backend don't initialize correctly USB to serial
  converters

  See here for more details:

  https://bugs.linuxfoundation.org/show_bug.cgi?id=1397

  ProblemType: Bug
  DistroRelease: Ubuntu 17.04
  Package: cups-filters 1.13.4-1ubuntu1
  ProcVersionSignature: Ubuntu 4.10.0-28.32-generic 4.10.17
  Uname: Linux 4.10.0-28-generic x86_64
  ApportVersion: 2.20.4-0ubuntu4.4
  Architecture: amd64
  CurrentDesktop: Unity:Unity7
  Date: Tue Jul  4 16:57:25 2017
  InstallationDate: Installed on 2010-02-19 (2691 days ago)
  InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
  Lpstat: device for PRN-ttyS0: 
serial:/dev/ttyUSB0?baud=38400+bits=8+parity=none+flow=dtrdsr
  MachineType: System manufacturer System Product Name
  Papersize: a4
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.10.0-28-generic 
root=UUID=6c704848-ff2d-4ef5-ba14-bbbe8a620cd0 ro quiet splash vt.handoff=7
  SourcePackage: cups-filters
  UpgradeStatus: Upgraded to zesty on 2017-07-03 (0 days ago)
  dmi.bios.date: 08/23/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 1003
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5KPL-VM
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: x.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr1003:bd08/23/2010:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5KPL-VM:rvrx.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: System Product Name
  dmi.product.version: System Version
  dmi.sys.vendor: System manufacturer

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1702320/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1712575] Re: Upgrade from Ubuntu 12.04 LTS to 14.04 LTS Server. Can't bring up eth0. RTNETLINK answers: no such process [61709.025401] bnx2: can't load firmware file bnx2/bnx2-mi

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1712575

Title:
  Upgrade from Ubuntu 12.04 LTS to 14.04 LTS Server. Can't bring up
  eth0. RTNETLINK answers: no such process [61709.025401] bnx2: can't
  load firmware file bnx2/bnx2-mips-06-6.2.3.fw

Status in systemd package in Ubuntu:
  New

Bug description:
  Hi. I just did a do-release-upgrade from Ubuntu Server 12.04 to 14.04
  LTS. After the upgrade eth0 does not exist. Networking fails on boot.
  Its on a Dell PowerEdge 2950 with one network connection and one
  static address on eth0 only (dual nics, 2nd is not being used).

  Here is the error I'm getting when trying to ifup eth0.

  RTNETLINK answers: no such process
  [61709.025401] bnx2: Can't load firmware file "bnx2/bnx2-mips-06-6.2.3.fw"
  RTNETLINK answers: No such file or directory
  Failed to bring up eth0.

  If I check dmesg, I can see the same error that it can't load the
  firmware file. I checked in /lib/firmware and the file is indeed
  there.

  
  This could be a dupe of this bug. However, I was told to file a new one as it 
is still an issue.
  https://bugs.launchpad.net/ubuntu/+source/udev/+bug/842560

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1712575/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1669420] Re: udevadm unconfigured script leaks into initrd causing boot failure

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1669420

Title:
  udevadm unconfigured script leaks into initrd causing boot failure

Status in systemd package in Ubuntu:
  New

Bug description:
  If update-initramfs is run while udevadm is "unconfigured", then the
  system is rendered unbootable.  Instead of containing a working
  version of udevadm, the "initrd" is built with the wrapper script that
  reports an error, and proceeds no further (as per code below).

  Please incorporate the check for 'unconfigured' into the code for
  udevadm, so that the udevadm binary can work correctly whether it is
  on an unconfigured system, or an initrd.

  This was a sticky problem, because no amount of 'dpkg-reconfigure
  udev' did the required 'mv udevadm.upgrade udevadm'

  #!/bin/sh

  if [ "$1" = "trigger" ]; then
  echo "udevadm trigger is not permitted while udev is unconfigured." 1>&2
  exit 1
  fi
  # ... snip ...
  exec /bin/bash -c "exec -a \"\$0\" /bin/udevadm.upgrade \"\$@\"" "$0" "$@"

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1669420/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1720621] Re: Systemd does not start UDEV after remounting root

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1720621

Title:
  Systemd does not start UDEV after remounting root

Status in systemd package in Ubuntu:
  New

Bug description:
  Systemd under zesty starts udev before the root file system has been
  made writeable.

  This means that every insertion script (from /lib/udev/rules.d) that
  is subsequently run, even long after system boot, is unable to change
  anything in the world (for example can't create locks in /run/lock,
  device files in /dev etc etc) can't even write to /tmp;

  In my case scripts run at device insertion (including an attempt to
  log data to /tmp) fail:

  Oct  1 21:45:02 rata systemd-udevd[21055]: '/sbin/onerng.sh ttyACM0'(err) 
'/sbin/onerng.sh: 2: /sbin/onerng.sh: cannot create /tmp/yy: Read-only file 
system'
  Oct  1 21:45:02 rata systemd-udevd[21055]: '/sbin/onerng.sh ttyACM0'(err) 
'warning: commands will be executed using /bin/sh'
  Oct  1 21:45:02 rata systemd-udevd[21055]: '/sbin/onerng.sh ttyACM0'(err) 
'Cannot open lockfile /var/spool/cron/atjobs/.SEQ: Read-only file system'

  This breaks add-on products already in the field that worked with
  previous versions of Ubuntu

  One can use "/etc/init.d/udev restart" to restart udev  and everything
  works great after that - but devices that were discovered since udev
  was originally started will already have had their startup scripts run
  and fail - works great for devices that are only inserted after system
  boot, fails for devices that were already present at boot time

  The solution is to make sure that udev is started after the system
  directories are remoutned RW

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1720621/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1665143] Re: Commission scripts select the wrong nvme device link, then fails to report any storage

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1665143

Title:
  Commission scripts select the wrong nvme device link, then fails to
  report any storage

Status in MAAS:
  Fix Released
Status in MAAS 2.1 series:
  Fix Released
Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  The udev package provides /lib/udev/rules.d/60-persistent-
  storage.rules which creates two symlinks for nvme devices, under
  /dev/disk/by-id/. The first link name includes the device wwid and the
  second includes the device model/serial. The commission script selects
  the first link discovered and subsequently attempts to store it in a
  FilePath field, which allows for 100 characters. Since the wwid link
  is greater than 100 characters an exception is thrown, causing not
  only the nvme device not to be registered but all other storage
  devices as well. Although commissioning completes there is no storage
  assigned, which makes deployment of the node impossible.

  This issue has blocked all test runs performed by the CDO-QA test
  infrastructure, since every run installs MAAS on a fresh machine and
  commissions new nodes. The failure is seen when installing from either
  ppa:maas/next (2.2.0~beta2) or ppa:maas/stable (2.1.3+bzr5573).

  ubuntu@meowth:~$ dpkg -l '*maas*'|cat
  Desired=Unknown/Install/Remove/Purge/Hold
  | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
  |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
  ||/ NameVersion  
Architecture Description
  
+++-===---=
  ii  maas2.2.0~beta2+bzr5717-0ubuntu1~16.04.1 all  
"Metal as a Service" is a physical cloud and IPAM
  ii  maas-cli2.2.0~beta2+bzr5717-0ubuntu1~16.04.1 all  
MAAS client and command-line interface
  un  maas-cluster-controller
   (no description available)
  ii  maas-common 2.2.0~beta2+bzr5717-0ubuntu1~16.04.1 all  
MAAS server common files
  ii  maas-dhcp   2.2.0~beta2+bzr5717-0ubuntu1~16.04.1 all  
MAAS DHCP server
  ii  maas-dns2.2.0~beta2+bzr5717-0ubuntu1~16.04.1 all  
MAAS DNS server
  ii  maas-proxy  2.2.0~beta2+bzr5717-0ubuntu1~16.04.1 all  
MAAS Caching Proxy
  ii  maas-rack-controller2.2.0~beta2+bzr5717-0ubuntu1~16.04.1 all  
Rack Controller for MAAS
  ii  maas-region-api 2.2.0~beta2+bzr5717-0ubuntu1~16.04.1 all  
Region controller API service for MAAS
  ii  maas-region-controller  2.2.0~beta2+bzr5717-0ubuntu1~16.04.1 all  
Region Controller for MAAS
  un  maas-region-controller-min 
   (no description available)
  un  python-django-maas 
   (no description available)
  un  python-maas-client 
   (no description available)
  un  python-maas-provisioningserver 
   (no description available)
  ii  python3-django-maas 2.2.0~beta2+bzr5717-0ubuntu1~16.04.1 all  
MAAS server Django web framework (Python 3)
  ii  python3-maas-client 2.2.0~beta2+bzr5717-0ubuntu1~16.04.1 all  
MAAS python API client (Python 3)
  ii  python3-maas-provisioningserver 2.2.0~beta2+bzr5717-0ubuntu1~16.04.1 all  
MAAS server provisioning libraries (Python 3)

  After re-commissioning one of the servers with ssh enabled the
  attached log files were collected. Please note that from the shell it
  can be seen that block devices are discovered and even the
  commissioning output found in /tmp/user_data.sh.IK9yVp/out/00-maas-07
  -block-devices lists devices (see attached), where-as this file is
  shown as a 0 byte file from the GUI (see screen shot).

  There are 'HTTP Error 500: INTERNAL SERVER ERROR' errors in cloud-
  init-output.log

  ubuntu@azurill:~$ uname -a
  Linux azurill 4.8.0-34-generic #36~16.04.1-Ubuntu SMP Wed Dec 21 18:55:08 UTC 
2016 x86_64 x86_64 x86_64 GNU/Linux

  ubuntu@azurill:~$ sudo lsblk  --exclude 1,2,7 -d -P -o NAME,RO,RM,MODEL,ROTA
  NAME="sdb" RO="0" RM="0" MODEL="LOGICAL VOLUME  " ROTA="1"
  NAME="sdc" RO="1" RM="0" MODEL="VIRTUAL-DISK" ROTA="1"
  NAME="sda" RO="0" RM="0" MODEL="LOGICAL VOLUME  " ROTA="1"
  NAME="nvme0n1" RO="0" RM="0" MODEL="INTEL SSDPEDME400G4

To manage notifications about this bug go to:
https://bugs.launchpad.net/maas/+bug/1665143/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to

[Touch-packages] [Bug 1647078] [NEW] udevadm trigger (falsely?) reports udev is not configured

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

Eigentlich wollte ich nur ubuntu oder gnome als Desktop verwenden, da
beide nicht starteten nahm ich dann Meta das läuft wenigstens und bekam
die Fehlermeldung präsentiert. udisk2 ist wohl ein Abhängigkeitspaket
für ubuntu-Desktop oder gnome-desktop beide wollen nicht laufen, warum
auch immer.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: udisks2 2.1.7-1ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-51.72-generic 4.4.30
Uname: Linux 4.4.0-51-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.2
Architecture: amd64
CustomUdevRuleFiles: 51-android.rules 69-usbmoto.rules 69-libmtp.rules 
60-raw1394.rules z60_hdaps-games.rules README.dpkg-new 51-hdaps.rules 
69-phicomm.rules
Date: Thu Dec  1 12:10:32 2016
ErrorMessage: Unterprozess installiertes post-installation-Skript gab den 
Fehlerwert 1 zurück
MachineType: LENOVO 3093BU3
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-51-generic 
root=UUID=7aead086-5ba6-492c-921a-17a5656dba11 ro locale=de_DE bootkbd=de 
console-setup/layoutcode=de quiet splash selinux=0 enforcing=0 acpi_osi=Linux 
loglevel=0 vt.handoff=7
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.1
 apt  1.2.15
SourcePackage: udisks2
Title: package udisks2 2.1.7-1ubuntu1 failed to install/upgrade: Unterprozess 
installiertes post-installation-Skript gab den Fehlerwert 1 zurück
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/11/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: 6QET70WW (1.40 )
dmi.board.name: 3093BU3
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: 
dmi:bvnLENOVO:bvr6QET70WW(1.40):bd10/11/2012:svnLENOVO:pn3093BU3:pvrThinkPadX201Tablet:rvnLENOVO:rn3093BU3:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 3093BU3
dmi.product.version: ThinkPad X201 Tablet
dmi.sys.vendor: LENOVO

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package xenial
-- 
udevadm trigger (falsely?) reports udev is not configured
https://bugs.launchpad.net/bugs/1647078
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1652019] [NEW] udev does not read LINK files dynamically

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

Hello all,

To comply to SystemD's way of thinking, NIC names can be changed
assuming my MAC addresses.

I have then changed /etc/systemd/10-net.link assuming the nomenclature
in https://www.freedesktop.org/software/systemd/man/systemd.link.html.

Expected behavior: When restart, changes can be taken into account and
NIC names changed, just like udev udev raw rules in /etc/udev/rules.d.

Got: NIC names not changed. However: whane re-updating initramfs ( #
update-initramfs -u ), it works.

Question: why is udev not reading SystemD link files directly in the
root FS, but is able to read udev rules.d files ?

Distro : Ubuntu 16.04.4

Thanks,

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: bot-comment
-- 
udev does not read LINK files dynamically
https://bugs.launchpad.net/bugs/1652019
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1665143] [NEW] Commission scripts select the wrong nvme device link, then fails to report any storage

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

The udev package provides /lib/udev/rules.d/60-persistent-storage.rules
which creates two symlinks for nvme devices, under /dev/disk/by-id/. The
first link name includes the device wwid and the second includes the
device model/serial. The commission script selects the first link
discovered and subsequently attempts to store it in a FilePath field,
which allows for 100 characters. Since the wwid link is greater than 100
characters an exception is thrown, causing not only the nvme device not
to be registered but all other storage devices as well. Although
commissioning completes there is no storage assigned, which makes
deployment of the node impossible.

This issue has blocked all test runs performed by the CDO-QA test
infrastructure, since every run installs MAAS on a fresh machine and
commissions new nodes. The failure is seen when installing from either
ppa:maas/next (2.2.0~beta2) or ppa:maas/stable (2.1.3+bzr5573).

ubuntu@meowth:~$ dpkg -l '*maas*'|cat
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ NameVersion  
Architecture Description
+++-===---=
ii  maas2.2.0~beta2+bzr5717-0ubuntu1~16.04.1 all
  "Metal as a Service" is a physical cloud and IPAM
ii  maas-cli2.2.0~beta2+bzr5717-0ubuntu1~16.04.1 all
  MAAS client and command-line interface
un  maas-cluster-controller 
  (no description available)
ii  maas-common 2.2.0~beta2+bzr5717-0ubuntu1~16.04.1 all
  MAAS server common files
ii  maas-dhcp   2.2.0~beta2+bzr5717-0ubuntu1~16.04.1 all
  MAAS DHCP server
ii  maas-dns2.2.0~beta2+bzr5717-0ubuntu1~16.04.1 all
  MAAS DNS server
ii  maas-proxy  2.2.0~beta2+bzr5717-0ubuntu1~16.04.1 all
  MAAS Caching Proxy
ii  maas-rack-controller2.2.0~beta2+bzr5717-0ubuntu1~16.04.1 all
  Rack Controller for MAAS
ii  maas-region-api 2.2.0~beta2+bzr5717-0ubuntu1~16.04.1 all
  Region controller API service for MAAS
ii  maas-region-controller  2.2.0~beta2+bzr5717-0ubuntu1~16.04.1 all
  Region Controller for MAAS
un  maas-region-controller-min  
  (no description available)
un  python-django-maas  
  (no description available)
un  python-maas-client  
  (no description available)
un  python-maas-provisioningserver  
  (no description available)
ii  python3-django-maas 2.2.0~beta2+bzr5717-0ubuntu1~16.04.1 all
  MAAS server Django web framework (Python 3)
ii  python3-maas-client 2.2.0~beta2+bzr5717-0ubuntu1~16.04.1 all
  MAAS python API client (Python 3)
ii  python3-maas-provisioningserver 2.2.0~beta2+bzr5717-0ubuntu1~16.04.1 all
  MAAS server provisioning libraries (Python 3)

After re-commissioning one of the servers with ssh enabled the attached
log files were collected. Please note that from the shell it can be seen
that block devices are discovered and even the commissioning output
found in /tmp/user_data.sh.IK9yVp/out/00-maas-07-block-devices lists
devices (see attached), where-as this file is shown as a 0 byte file
from the GUI (see screen shot).

There are 'HTTP Error 500: INTERNAL SERVER ERROR' errors in cloud-init-
output.log

ubuntu@azurill:~$ uname -a
Linux azurill 4.8.0-34-generic #36~16.04.1-Ubuntu SMP Wed Dec 21 18:55:08 UTC 
2016 x86_64 x86_64 x86_64 GNU/Linux

ubuntu@azurill:~$ sudo lsblk  --exclude 1,2,7 -d -P -o NAME,RO,RM,MODEL,ROTA
NAME="sdb" RO="0" RM="0" MODEL="LOGICAL VOLUME  " ROTA="1"
NAME="sdc" RO="1" RM="0" MODEL="VIRTUAL-DISK" ROTA="1"
NAME="sda" RO="0" RM="0" MODEL="LOGICAL VOLUME  " ROTA="1"
NAME="nvme0n1" RO="0" RM="0" MODEL="INTEL SSDPEDME400G4

** Affects: maas
 Importance: High
 Status: Fix Released

** Affects: maas/2.1
 Importance: High
 Assignee: Andres Rodriguez (andreserl)
 Status: Fix Released

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: Confirmed


** Tags: cdo-qa sts
-- 
Commission scripts select the wrong nvme device link, then fails to report any 
storage
https://bugs.launchpad.net/bugs/1665143
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : 

[Touch-packages] [Bug 1744928] Re: udev doesn't include a rule for security keys (including Yubico)

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1744928

Title:
  udev doesn't include a rule for security keys (including Yubico)

Status in systemd package in Ubuntu:
  New

Bug description:
  https://bugs.chromium.org/p/chromium/issues/detail?id=427966#c19

  I can confirm that the following solves the problem on bionic:

  sudo bash -c 'cat > /lib/udev/rules.d/50-securitykey.rules << EOF
  SUBSYSTEMS=="usb", ATTRS{idVendor}=="1050", MODE="0644", GROUP="plugdev"
  EOF'
  service udev restart

  We might wish to flesh this out with a list of vendor IDs, but even
  just Yubico (1050) will likely cover the vast majority of use cases
  due to their market share.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1744928/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1748698] Re: udevadm trigger kills X server

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1748698

Title:
  udevadm trigger kills X server

Status in systemd package in Ubuntu:
  New

Bug description:
  Running Xubuntu 16.04.3, with udev version 229-4ubuntu21.1.

  Every time I install the plexmediaserver package, no matter with what
  mechanism, my X server crashes out completely, taking all my running
  applications with it.

  I traced it to a postinst script call to `udevadm trigger`.  Running
  that one command manually will instantly kill the X server every time.

  In looking at the logs, there's a segfault in radeon_drv.o that's
  clearly the end of the X server.  syslog contains a set of messages
  about Ethernet interfaces "changed", then a cluster of messages about
  how various disk devices (/dev/sdX) appear twice with different sysfs
  paths, and then suddenly xfce4 is logging about how the X server just
  vanished.

  A mess of UPower[d] messages show up in the log as well, but shutting
  down upowerd before running another test yields no change, so it's not
  responsible for this.

  Whatever udev is doing to the X server is giving it a very bad day.
  This makes it impractical for me to upgrade plex very frequently at
  all, since my machine runs 24/7.  However, I'm having so many problems
  with Plex right now that I'll be investigating other solutions
  anyway...

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1748698/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1778900] Re: udev mounts MTP devices in read-only mode.

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1778900

Title:
  udev mounts MTP devices in read-only mode.

Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  In Ubuntu 18.04 udev mounts MTP devices (mine is Google Pixel C
  tablet) in read-only mode by default, so that files cannot be copied
  over to the device.

  One has to manually create a udev rule to mount the device in read-
  write mode. This is rather user-unfriendly.

  Make udev mount MTP devices in read-write mode by default.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1778900/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1778833] Re: tty symlink incorrect after disconnect/reconnect, fixed by manual udevadm trigger

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1778833

Title:
  tty symlink incorrect after disconnect/reconnect, fixed by manual
  udevadm trigger

Status in systemd package in Ubuntu:
  New

Bug description:
  I recently upgraded from Ubuntu 17.10 to 18.04 and encountered what appears 
to be a regression in udev. On 17.10 (and previous), the following udev rule to 
rename a USB serial device worked perfectly:
  SUBSYSTEMS=="usb", ATTRS{product}=="IOTool", 
ATTRS{manufacturer}=="zplab.wustl.edu", ATTRS{serial}=="0x", 
SYMLINK+="ttyIOTool"

  This would yield symlinks as expected:
  > ls -l /dev/ttyIOTool
  lrwxrwxrwx 1 root root 7 Jun 26 21:34 /dev/ttyIOTool -> ttyACM1

  On 18.04, the same symlinks are made correctly at boot time. However,
  if the device is unplugged and then re-plugged, the symlink instead
  goes to /dev/bus/usb:

  > ls -l /dev/ttyIOTool 
  lrwxrwxrwx 1 root root 15 Jun 26 21:33 /dev/ttyIOTool -> bus/usb/003/013

  This is a problem, because /dev/bus/usb devices can't be opened as
  serial ports in the way that /dev/tty devices can.

  However, manually triggering udev via `udevadm trigger` returns the
  symlinks to the expected state. I am fairly certain that this behavior
  represents a bug, because there shouldn't be any difference in
  behavior between an auto-triggered event with a disconnect /
  reconnect, and one manually triggered via udevadm trigger, right?

  Version information: udevadm --version gives 237 on the 18.04 system
  (with this broken behavior) and 234 on an identical 17.10 system with
  the correct behavior. On a similar 16.10 system with udevadm version
  231, such symlinks also work fine.

  Note also that there are several reports of similar udev behavior around the 
web, which have left the users fairly perplexed; e.g.:
  https://github.com/psi46/elComandante/issues/14
  https://github.com/oskarpearson/mmeowlink/issues/52

  Please let me know if there's anything further I can do to help debug
  this problem. I can probably work around this by using /dev/serial/by-
  id, but if anyone has other workarounds to try (different udev rules,
  perhaps?), I would be grateful as well.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1778833/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1669420] [NEW] udevadm unconfigured script leaks into initrd causing boot failure

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

If update-initramfs is run while udevadm is "unconfigured", then the
system is rendered unbootable.  Instead of containing a working version
of udevadm, the "initrd" is built with the wrapper script that reports
an error, and proceeds no further (as per code below).

Please incorporate the check for 'unconfigured' into the code for
udevadm, so that the udevadm binary can work correctly whether it is on
an unconfigured system, or an initrd.

This was a sticky problem, because no amount of 'dpkg-reconfigure udev'
did the required 'mv udevadm.upgrade udevadm'

#!/bin/sh

if [ "$1" = "trigger" ]; then
echo "udevadm trigger is not permitted while udev is unconfigured." 1>&2
exit 1
fi
# ... snip ...
exec /bin/bash -c "exec -a \"\$0\" /bin/udevadm.upgrade \"\$@\"" "$0" "$@"

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New

-- 
udevadm unconfigured script leaks into initrd causing boot failure
https://bugs.launchpad.net/bugs/1669420
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1702320] [NEW] CUPS serial backend don't initialize correctly USB to serial converters

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

CUPS serial backend don't initialize correctly USB to serial converters

See here for more details:

https://bugs.linuxfoundation.org/show_bug.cgi?id=1397

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: cups-filters 1.13.4-1ubuntu1
ProcVersionSignature: Ubuntu 4.10.0-28.32-generic 4.10.17
Uname: Linux 4.10.0-28-generic x86_64
ApportVersion: 2.20.4-0ubuntu4.4
Architecture: amd64
CurrentDesktop: Unity:Unity7
Date: Tue Jul  4 16:57:25 2017
InstallationDate: Installed on 2010-02-19 (2691 days ago)
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
Lpstat: device for PRN-ttyS0: 
serial:/dev/ttyUSB0?baud=38400+bits=8+parity=none+flow=dtrdsr
MachineType: System manufacturer System Product Name
Papersize: a4
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.10.0-28-generic 
root=UUID=6c704848-ff2d-4ef5-ba14-bbbe8a620cd0 ro quiet splash vt.handoff=7
SourcePackage: cups-filters
UpgradeStatus: Upgraded to zesty on 2017-07-03 (0 days ago)
dmi.bios.date: 08/23/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1003
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5KPL-VM
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr1003:bd08/23/2010:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5KPL-VM:rvrx.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug zesty
-- 
CUPS serial backend don't initialize correctly USB to serial converters
https://bugs.launchpad.net/bugs/1702320
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1712575] [NEW] Upgrade from Ubuntu 12.04 LTS to 14.04 LTS Server. Can't bring up eth0. RTNETLINK answers: no such process [61709.025401] bnx2: can't load firmware file bnx2/bnx2-

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

Hi. I just did a do-release-upgrade from Ubuntu Server 12.04 to 14.04
LTS. After the upgrade eth0 does not exist. Networking fails on boot.
Its on a Dell PowerEdge 2950 with one network connection and one static
address on eth0 only (dual nics, 2nd is not being used).

Here is the error I'm getting when trying to ifup eth0.

RTNETLINK answers: no such process
[61709.025401] bnx2: Can't load firmware file "bnx2/bnx2-mips-06-6.2.3.fw"
RTNETLINK answers: No such file or directory
Failed to bring up eth0.

If I check dmesg, I can see the same error that it can't load the
firmware file. I checked in /lib/firmware and the file is indeed there.


This could be a dupe of this bug. However, I was told to file a new one as it 
is still an issue.
https://bugs.launchpad.net/ubuntu/+source/udev/+bug/842560

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New

-- 
Upgrade from Ubuntu 12.04 LTS to 14.04 LTS Server. Can't bring up eth0. 
RTNETLINK answers: no such process [61709.025401] bnx2: can't load firmware 
file bnx2/bnx2-mips-06-6.2.3.fw
https://bugs.launchpad.net/bugs/1712575
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1720621] [NEW] Systemd does not start UDEV after remounting root

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

Systemd under zesty starts udev before the root file system has been
made writeable.

This means that every insertion script (from /lib/udev/rules.d) that is
subsequently run, even long after system boot, is unable to change
anything in the world (for example can't create locks in /run/lock,
device files in /dev etc etc) can't even write to /tmp;

In my case scripts run at device insertion (including an attempt to log
data to /tmp) fail:

Oct  1 21:45:02 rata systemd-udevd[21055]: '/sbin/onerng.sh ttyACM0'(err) 
'/sbin/onerng.sh: 2: /sbin/onerng.sh: cannot create /tmp/yy: Read-only file 
system'
Oct  1 21:45:02 rata systemd-udevd[21055]: '/sbin/onerng.sh ttyACM0'(err) 
'warning: commands will be executed using /bin/sh'
Oct  1 21:45:02 rata systemd-udevd[21055]: '/sbin/onerng.sh ttyACM0'(err) 
'Cannot open lockfile /var/spool/cron/atjobs/.SEQ: Read-only file system'

This breaks add-on products already in the field that worked with
previous versions of Ubuntu

One can use "/etc/init.d/udev restart" to restart udev  and everything
works great after that - but devices that were discovered since udev was
originally started will already have had their startup scripts run and
fail - works great for devices that are only inserted after system boot,
fails for devices that were already present at boot time

The solution is to make sure that udev is started after the system
directories are remoutned RW

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New

-- 
Systemd does not start UDEV after remounting root
https://bugs.launchpad.net/bugs/1720621
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1822451] Re: high cpu load

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1822451

Title:
  high cpu load

Status in systemd package in Ubuntu:
  New

Bug description:
  Testing  Kubuntu 19.04 Disco Dingo
  Same bug #1767968 on Dell Latitude E6400

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1822451/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1767968] Re: systemd-udev cause high cpu load after upgrade to bionic

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

** Project changed: udev => linux

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1767968

Title:
  systemd-udev cause high cpu load after upgrade to bionic

Status in Linux:
  Confirmed
Status in systemd package in Ubuntu:
  Confirmed
Status in bluez package in Debian:
  New

Bug description:
  After upgraded from xenial to bionic (kernel 4.15.0-20) systemd-udevd
  runs with high cpu load in 2 instances (50%, 15%) on Dell Precision
  M6500 when wlan switch will be enabled.

  With xenial this problem did't happen and Dell bluetooth & wifi (b43)
  are working.

  After some research I found that /var/log/syslog gets filled with a
  lot of messages (see log sample below).

  If I modify /lib/udev/rules.d/97-hid2hci.rules (disable rule for
  413c:8154, 413c:8158, 413c:8162), restart udev, turn wifi off/on by
  hardware switch, the messages go away but the bluetooth adapter will
  be not enabled anymore. It seems that udev is running in a loop.

  My modification for the rule just was (just as proof):

  --- before ---
  ATTR{bInterfaceClass}=="03", ATTR{bInterfaceSubClass}=="01", 
ATTR{bInterfaceProtocol}=="02", \
ATTRS{bDeviceClass}=="00", ATTRS{idVendor}=="413c", 
ATTRS{bmAttributes}=="e0", \
RUN+="hid2hci --method=dell --devpath=%p", ENV{HID2HCI_SWITCH}="1"
  --- end before ---

  --- after ---
  ATTR{bInterfaceClass}=="03", ATTR{bInterfaceSubClass}=="01", 
ATTR{bInterfaceProtocol}=="02", \
ATTRS{bDeviceClass}=="00", ATTRS{idVendor}=="413c", 
ATTRS{bmAttributes}=="e0", \
RUN+="/bin/sh", ENV{HID2HCI_SWITCH}="1"
  --- end after ---

  If you need some experiment or testing I can do (compiling software is
  not a problem, I'm a developer).

  lsusb:
  Bus 002 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
  Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
  Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
  Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  Bus 001 Device 058: ID 413c:8162 Dell Computer Corp. Integrated Touchpad 
[Synaptics]
  Bus 001 Device 057: ID 413c:8161 Dell Computer Corp. Integrated Keyboard
  Bus 001 Device 056: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part 
of BCM2046 Bluetooth)
  Bus 001 Device 004: ID 0a5c:5800 Broadcom Corp. BCM5880 Secure Applications 
Processor
  Bus 001 Device 003: ID 05ca:1815 Ricoh Co., Ltd 
  Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
  Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

  lspci:
  Bus 002 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
  Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
  Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
  Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  Bus 001 Device 058: ID 413c:8162 Dell Computer Corp. Integrated Touchpad 
[Synaptics]
  Bus 001 Device 057: ID 413c:8161 Dell Computer Corp. Integrated Keyboard
  Bus 001 Device 056: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part 
of BCM2046 Bluetooth)
  Bus 001 Device 004: ID 0a5c:5800 Broadcom Corp. BCM5880 Secure Applications 
Processor
  Bus 001 Device 003: ID 05ca:1815 Ricoh Co., Ltd 
  Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
  Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  root@precision:~# lspci
  00:00.0 Host bridge: Intel Corporation Core Processor DMI (rev 11)
  00:03.0 PCI bridge: Intel Corporation Core Processor PCI Express Root Port 1 
(rev 11)
  00:08.0 System peripheral: Intel Corporation Core Processor System Management 
Registers (rev 11)
  00:08.1 System peripheral: Intel Corporation Core Processor Semaphore and 
Scratchpad Registers (rev 11)
  00:08.2 System peripheral: Intel Corporation Core Processor System Control 
and Status Registers (rev 11)
  00:08.3 System peripheral: Intel Corporation Core Processor Miscellaneous 
Registers (rev 11)
  00:10.0 System peripheral: Intel Corporation Core Processor QPI Link (rev 11)
  00:10.1 System peripheral: Intel Corporation Core Processor QPI Routing and 
Protocol Registers (rev 11)
  00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 
Enhanced Host Controller (rev 05)
  00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High 
Definition Audio (rev 05)
  00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI 
Express Root Port 1 (rev 05)
  00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI 
Express Root Port 2 (rev 05)
  00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI 
Express Root Port 3 (rev 05)
  00:1c.3 PCI bridge: Intel Corporation 5 

[Touch-packages] [Bug 1744928] [NEW] udev doesn't include a rule for security keys (including Yubico)

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

https://bugs.chromium.org/p/chromium/issues/detail?id=427966#c19

I can confirm that the following solves the problem on bionic:

sudo bash -c 'cat > /lib/udev/rules.d/50-securitykey.rules << EOF
SUBSYSTEMS=="usb", ATTRS{idVendor}=="1050", MODE="0644", GROUP="plugdev"
EOF'
service udev restart

We might wish to flesh this out with a list of vendor IDs, but even just
Yubico (1050) will likely cover the vast majority of use cases due to
their market share.

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New

-- 
udev doesn't include a rule for security keys (including Yubico)
https://bugs.launchpad.net/bugs/1744928
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1748698] [NEW] udevadm trigger kills X server

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

Running Xubuntu 16.04.3, with udev version 229-4ubuntu21.1.

Every time I install the plexmediaserver package, no matter with what
mechanism, my X server crashes out completely, taking all my running
applications with it.

I traced it to a postinst script call to `udevadm trigger`.  Running
that one command manually will instantly kill the X server every time.

In looking at the logs, there's a segfault in radeon_drv.o that's
clearly the end of the X server.  syslog contains a set of messages
about Ethernet interfaces "changed", then a cluster of messages about
how various disk devices (/dev/sdX) appear twice with different sysfs
paths, and then suddenly xfce4 is logging about how the X server just
vanished.

A mess of UPower[d] messages show up in the log as well, but shutting
down upowerd before running another test yields no change, so it's not
responsible for this.

Whatever udev is doing to the X server is giving it a very bad day.
This makes it impractical for me to upgrade plex very frequently at all,
since my machine runs 24/7.  However, I'm having so many problems with
Plex right now that I'll be investigating other solutions anyway...

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New

-- 
udevadm trigger kills X server
https://bugs.launchpad.net/bugs/1748698
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1778833] [NEW] tty symlink incorrect after disconnect/reconnect, fixed by manual udevadm trigger

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

I recently upgraded from Ubuntu 17.10 to 18.04 and encountered what appears to 
be a regression in udev. On 17.10 (and previous), the following udev rule to 
rename a USB serial device worked perfectly:
SUBSYSTEMS=="usb", ATTRS{product}=="IOTool", 
ATTRS{manufacturer}=="zplab.wustl.edu", ATTRS{serial}=="0x", 
SYMLINK+="ttyIOTool"

This would yield symlinks as expected:
> ls -l /dev/ttyIOTool
lrwxrwxrwx 1 root root 7 Jun 26 21:34 /dev/ttyIOTool -> ttyACM1

On 18.04, the same symlinks are made correctly at boot time. However, if
the device is unplugged and then re-plugged, the symlink instead goes to
/dev/bus/usb:

> ls -l /dev/ttyIOTool 
lrwxrwxrwx 1 root root 15 Jun 26 21:33 /dev/ttyIOTool -> bus/usb/003/013

This is a problem, because /dev/bus/usb devices can't be opened as
serial ports in the way that /dev/tty devices can.

However, manually triggering udev via `udevadm trigger` returns the
symlinks to the expected state. I am fairly certain that this behavior
represents a bug, because there shouldn't be any difference in behavior
between an auto-triggered event with a disconnect / reconnect, and one
manually triggered via udevadm trigger, right?

Version information: udevadm --version gives 237 on the 18.04 system
(with this broken behavior) and 234 on an identical 17.10 system with
the correct behavior. On a similar 16.10 system with udevadm version
231, such symlinks also work fine.

Note also that there are several reports of similar udev behavior around the 
web, which have left the users fairly perplexed; e.g.:
https://github.com/psi46/elComandante/issues/14
https://github.com/oskarpearson/mmeowlink/issues/52

Please let me know if there's anything further I can do to help debug
this problem. I can probably work around this by using /dev/serial/by-
id, but if anyone has other workarounds to try (different udev rules,
perhaps?), I would be grateful as well.

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New

-- 
tty symlink incorrect after disconnect/reconnect, fixed by manual udevadm 
trigger
https://bugs.launchpad.net/bugs/1778833
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1778900] [NEW] udev mounts MTP devices in read-only mode.

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

In Ubuntu 18.04 udev mounts MTP devices (mine is Google Pixel C tablet)
in read-only mode by default, so that files cannot be copied over to the
device.

One has to manually create a udev rule to mount the device in read-write
mode. This is rather user-unfriendly.

Make udev mount MTP devices in read-write mode by default.

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: Confirmed


** Tags: mtp udev
-- 
udev mounts MTP devices in read-only mode.
https://bugs.launchpad.net/bugs/1778900
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1838992] Re: udev doesn't pick up volumes properly

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1838992

Title:
  udev doesn't pick up volumes properly

Status in systemd package in Ubuntu:
  New

Bug description:
  [Only happens on Ubuntu, not other OS's, like Debian]

  When we are attaching a volume to a running Ubuntu server (using
  kvm/libvirt), most of the time the udev rules are not properly
  triggered. In the end the volume will most of the time not be
  available in `/dev/disk/by-id/virtio-`. Sometimes it works
  though (10%/20%?).

  The reason for this is that udev somehow doesn't pick it up when the
  volume is attached. It looks like a timing issue. Just looking at
  `/sys/devices/pci:00/:00:05.0/virtio2/block/vdb/serial` makes
  it clear that it's there. However `udevadm info /dev/vdb` returns
  without the `ID_SERIAL` key. Only a `udevadm trigger` leads to a
  correct entry of `ID_SERIAL` and also fixes `/dev/disk/by-id`.

  We are a small cloud provider (cloudscale.ch). We have tested this on
  Ubuntu (16.04/18.04), Debian 9, CentOS, CoreOS. We haven't tested this
  extensively, but it sure looks like it's only happening on Ubuntu. .
  We never had any issues reported on other OS's about this.

  I tried looking at the differences of Debian and Ubuntu udev packages,
  but couldn't figure out what might be responsible for this behavior.

  If someone needs an account for our control panel to reproduce this,
  please contact me, I'm happy to give you the resources to debug this.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1838992/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1846367] Re: udev /dev/null incorrect permissions after package auto upgrades

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1846367

Title:
  udev /dev/null incorrect permissions after package auto upgrades

Status in systemd package in Ubuntu:
  New

Bug description:
  I've been attempting to determine root cause of this problem for
  months.

  Symptom is group/other permissions being dropped from all /dev/*
  files.

  This only occurs on some machines, so some machine udev updates work,
  some machines quietly fail.

  Looks like the problem relates to...

  1) APT /etc/apt/apt.conf.d/10periodic APT::Periodic::Update-Package-
  Lists == 1, which triggers auto upgrades for critical packages.

  2) This triggers the udev package run as an unattended/automatic
  upgrade.

  3) When udev package updates, /var/log/dpkg.log shows no errors.

  4) /dev/* files have group/other permissions stripped.

  5) LXD containers become unstable, as containers /dev points to
  machine /dev.

  Temp fix is change /etc/apt/apt.conf.d/10periodic - APT::Periodic
  ::Update-Package-Lists == 0 to disable all unattended upgrades.

  Someone let me know where I can find APT/DPKG logs detailing exactly
  what post install hook scripts run for udev, so I can look for errors.

  Or if log verbosity has to be increased for this level of logging, let
  me know how to increase verbosity, so next time udev updates, I can
  provide logging detail sufficient to generate a fix for this problem.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1846367/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1840772] Re: Script cannot access network when triggered by udev rule

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1840772

Title:
  Script cannot access network when triggered by udev rule

Status in systemd package in Ubuntu:
  New

Bug description:
  I have a script that is triggered by a udev rule, and that needs to
  connect to a remote host.

  The example below works fine in 16.04, but fails in 18.04. It seems
  that the process executing the script is somehow limited wrt. network
  access. The script works fine when started from a shell prompt.

  To reproduce:

  
  - create /tmp/myscript:

  #/bin/sh
  wget -o /tmp/wget.log -O /tmp/index.html http://www.google.com

  
  - create /etc/udev/rules.d/52-netaccess.rules

  ACTION=="add", ATTRS{idVendor}=="cafe", MODE="0660", GROUP="root",
  SUBSYSTEM=="usbmisc", RUN+="/tmp/myscript"

  
  - Plugin a USB device with vendor ID 0xcafe, and check the wget output in 
/tmp/wget.log. 

  On ubuntu 18.04 wget fails with this output:

  --2019-08-19 14:49:43--  http://www.google.com/
  Resolving www.google.com (www.google.com)... failed: Name or service not 
known.
  wget: unable to resolve host address 'www.google.com'

  
  If I use an IP address in the URL there is no resolve error, but then wget 
blocks in the socket connect() syscall (according to strace). At some point the 
script is killed.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1840772/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1833443] Re: Calculator button does nothing (Calculator not launched)

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1833443

Title:
  Calculator button does nothing (Calculator not launched)

Status in systemd package in Ubuntu:
  New

Bug description:
  Troubleshoot steps followed:
  https://wiki.ubuntu.com/Hotkeys/Troubleshooting.

  Step-by-step Troubleshooting
  1. Is latest I think
  2. gnome-settings-daemon not running
  3. No keypress event
  4. Skip (see 3)
  5. a. 

  evtest output:
  Event: time 1560959333.892425, -- SYN_REPORT 
  Event: time 1560959337.916913, type 4 (EV_MSC), code 4 (MSC_SCAN), value a1
  Event: time 1560959337.916913, type 1 (EV_KEY), code 140 (KEY_CALC), value 1
  Event: time 1560959337.916913, -- SYN_REPORT 
  Event: time 1560959338.121844, type 4 (EV_MSC), code 4 (MSC_SCAN), value a1
  Event: time 1560959338.121844, type 1 (EV_KEY), code 140 (KEY_CALC), value 0
  Event: time 1560959338.121844, -- SYN_REPORT 

 b. 140 (0x08c) not found in /usr/include/linux/input.h
  7. N/A (see 4)

  I can try provide info from
  https://wiki.ubuntu.com/DebuggingProcedures if wanted.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: udev 237-3ubuntu10.22
  ProcVersionSignature: Ubuntu 4.15.0-51.55-generic 4.15.18
  Uname: Linux 4.15.0-51-generic x86_64
  NonfreeKernelModules: lkp_Ubuntu_4_15_0_51_55_generic_52
  ApportVersion: 2.20.9-0ubuntu7.6
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  CustomUdevRuleFiles: 70-snap.warzone2100.rules 70-snap.core.rules 
70-snap.opendungeons.rules 56-hpmud.rules S99-2000S1.rules 
70-snap.minetest.rules 40-libsane.rules 70-snap.canonical-livepatch.rules 
70-snap.chromium.rules
  Date: Wed Jun 19 17:58:19 2019
  InstallationDate: Installed on 2019-05-14 (36 days ago)
  InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 
(20180725)
  ProcEnviron:
   LANGUAGE=en_ZA:en
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_ZA.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-51-generic 
root=UUID=9b9d08ae-0424-4d09-87e0-5db4115b3a2b ro quiet splash vt.handoff=1
  SourcePackage: systemd
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 03/12/2015
  dmi.bios.vendor: Hewlett-Packard
  dmi.bios.version: 68SVD Ver. F.60
  dmi.board.name: 1631
  dmi.board.vendor: Hewlett-Packard
  dmi.board.version: KBC Version 01.3F
  dmi.chassis.type: 10
  dmi.chassis.vendor: Hewlett-Packard
  dmi.modalias: 
dmi:bvnHewlett-Packard:bvr68SVDVer.F.60:bd03/12/2015:svnHewlett-Packard:pn:pvrA0001C02:rvnHewlett-Packard:rn1631:rvrKBCVersion01.3F:cvnHewlett-Packard:ct10:cvr:
  dmi.product.family: 103C_5336AN
  dmi.product.version: A0001C02
  dmi.sys.vendor: Hewlett-Packard

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1833443/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1856871] Re: i/o error if next unused loop device is queried

2020-08-06 Thread Kai Kasurinen
** Changed in: udev (Ubuntu)
   Status: New => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1856871

Title:
  i/o error if next unused loop device is queried

Status in linux package in Ubuntu:
  Incomplete
Status in parted package in Ubuntu:
  New
Status in snapd package in Ubuntu:
  Invalid
Status in systemd package in Ubuntu:
  Invalid
Status in udev package in Ubuntu:
  Invalid

Bug description:
  This is reproducible in Bionic and late.

  Here's an example running 'focal':

  $ lsb_release -cs
  focal

  $ uname -r
  5.3.0-24-generic

  The error is:
  blk_update_request: I/O error, dev loop2, sector 0

  and on more recent kernel:

  kernel: [18135.185709] blk_update_request: I/O error, dev loop18,
  sector 0 op 0x1:(WRITE) flags 0x800 phys_seg 0 prio class 0

  
  How to trigger it:
  $ sosreport -o block

  or more precisely the cmd causing the situation inside the block plugin:
  $ parted -s $(losetup -f) unit s print

  https://github.com/sosreport/sos/blob/master/sos/plugins/block.py#L52

  but if I run it on the next next unused loop device, in this case
  /dev/loop3 (which is also unused), no errors.

  While I agree that sosreport shouldn't query unused loop devices,
  there is definitely something going on with the next unused loop
  device.

  What is differentiate loop2 and loop3 and any other unused ones ?

  3 things so far I have noticed:
  * loop2 is the next unused loop device (losetup -f)
  * A reboot is needed (if some loop modification (snap install, mount loop, 
...) has been made at runtime
  * I have also noticed that loop2 (or whatever the next unused one is) have 
some stat as oppose to other unused loop devices. The stat exist already right 
after the system boot for the next unused loop device.

  /sys/block/loop2/stat
  ::
  2 0 10 0 1 0 0 0 0 0 0

  2  = number of read I/Os processed
  10 = number of sectors read
  1  = number of write I/Os processed

  Explanation of each column:
  https://www.kernel.org/doc/html/latest/block/stat.html

  while /dev/loop3 doesn't

  /sys/block/loop3/stat
  ::
  0 0 0 0 0 0 0 0 0 0 0

  Which tells me that something during the boot process most likely
  acquired (on purpose or not) the next unused loop and possibly didn't
  released it well enough.

  If loop2 is generating errors, and I install a snap, the snap squashfs
  will take loop2, making loop3 the next unused loop device.

  If I query loop3 with 'parted' right after, no errors.

  If I reboot, and query loop3 again, then no I'll have an error.

  To triggers the errors it need to be after a reboot and it only impact
  the first unused loop device available (losetup -f).

  This was tested with focal/systemd whic his very close to latest
  upstream code.

  This has been test with latest v5.5 mainline kernel as well.

  For now, I don't think it's a kernel problem, I'm more thinking of a
  userspace misbehaviour dealing with loop device (or block device) at
  boot.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1856871/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1873648] Re: After suspend, ttyusb0 is moved to ttyusb1

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1873648

Title:
  After suspend, ttyusb0 is moved to ttyusb1

Status in systemd package in Ubuntu:
  New

Bug description:
  I have an old Core2 Duo running Ubuntu 20.04.
  As it was sluggish with gnome, I installed the xfce environment (only xfce, 
not xubuntu)

  Yesterday, I was using minicom then I suspended my laptop.
  When I restarted minicom reported it could not open ttyusb0

  After a few checks, I noticed that my usb to serial adapter was now
  ttyusb1. I did not try to replicate.

  This is quite annoying if you intend to rely a lot on suspend.

  This behavior used to be in Windows in the past, but I believe they
  use the UUID to always assign the same port to a USB device, as under
  Windows, wherever I plug my US?B device, it always identifies as the
  same "COM" port (used not to be the case before).

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1873648/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1839156] Re: TCP/IP connection stuck when called from UDEV rule

2020-08-06 Thread Kai Kasurinen
** Package changed: udev (Ubuntu) => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1839156

Title:
  TCP/IP connection stuck when called from UDEV rule

Status in systemd package in Ubuntu:
  New

Bug description:
  It seems that in Eoan there is a lock/any other issue preventing
  particular system calls to be executed by the triggered action
  handler. I have an action executing wget when USB-serial adapter is
  plugged:

  SUBSYSTEM=="tty", ACTION=="add", ATTRS{idVendor}=="1a86", 
ATTRS{idProduct}=="7523", MODE="0666", RUN+="/usr/bin/wget -v --method=POST 
http://127.0.0.1:4000/udev_trigger/add;
  This action works perfectly in a prior versions - but in Eoan Ermine it hangs 
for ~30s and fails on a timeout. Analysis with strace shows that execution is 
stuck on connect() syscall - until it returns with ETIMEDOUT.

  Same Wget command, being run from a command line, works perfectly.

  The issue doesn't seem to be related to a particular IP
  (localhost/remote) and/or the status of a listener process - execution
  hangs also when listener is not running and port is free.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1839156/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1822451] [NEW] high cpu load

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

Testing  Kubuntu 19.04 Disco Dingo
Same bug #1767968 on Dell Latitude E6400

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New

-- 
high cpu load 
https://bugs.launchpad.net/bugs/1822451
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1767968] [NEW] systemd-udev cause high cpu load after upgrade to bionic

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

After upgraded from xenial to bionic (kernel 4.15.0-20) systemd-udevd
runs with high cpu load in 2 instances (50%, 15%) on Dell Precision
M6500 when wlan switch will be enabled.

With xenial this problem did't happen and Dell bluetooth & wifi (b43)
are working.

After some research I found that /var/log/syslog gets filled with a lot
of messages (see log sample below).

If I modify /lib/udev/rules.d/97-hid2hci.rules (disable rule for
413c:8154, 413c:8158, 413c:8162), restart udev, turn wifi off/on by
hardware switch, the messages go away but the bluetooth adapter will be
not enabled anymore. It seems that udev is running in a loop.

My modification for the rule just was (just as proof):

--- before ---
ATTR{bInterfaceClass}=="03", ATTR{bInterfaceSubClass}=="01", 
ATTR{bInterfaceProtocol}=="02", \
  ATTRS{bDeviceClass}=="00", ATTRS{idVendor}=="413c", 
ATTRS{bmAttributes}=="e0", \
  RUN+="hid2hci --method=dell --devpath=%p", ENV{HID2HCI_SWITCH}="1"
--- end before ---

--- after ---
ATTR{bInterfaceClass}=="03", ATTR{bInterfaceSubClass}=="01", 
ATTR{bInterfaceProtocol}=="02", \
  ATTRS{bDeviceClass}=="00", ATTRS{idVendor}=="413c", 
ATTRS{bmAttributes}=="e0", \
  RUN+="/bin/sh", ENV{HID2HCI_SWITCH}="1"
--- end after ---

If you need some experiment or testing I can do (compiling software is
not a problem, I'm a developer).

lsusb:
Bus 002 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 058: ID 413c:8162 Dell Computer Corp. Integrated Touchpad 
[Synaptics]
Bus 001 Device 057: ID 413c:8161 Dell Computer Corp. Integrated Keyboard
Bus 001 Device 056: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of 
BCM2046 Bluetooth)
Bus 001 Device 004: ID 0a5c:5800 Broadcom Corp. BCM5880 Secure Applications 
Processor
Bus 001 Device 003: ID 05ca:1815 Ricoh Co., Ltd 
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lspci:
Bus 002 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 058: ID 413c:8162 Dell Computer Corp. Integrated Touchpad 
[Synaptics]
Bus 001 Device 057: ID 413c:8161 Dell Computer Corp. Integrated Keyboard
Bus 001 Device 056: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of 
BCM2046 Bluetooth)
Bus 001 Device 004: ID 0a5c:5800 Broadcom Corp. BCM5880 Secure Applications 
Processor
Bus 001 Device 003: ID 05ca:1815 Ricoh Co., Ltd 
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
root@precision:~# lspci
00:00.0 Host bridge: Intel Corporation Core Processor DMI (rev 11)
00:03.0 PCI bridge: Intel Corporation Core Processor PCI Express Root Port 1 
(rev 11)
00:08.0 System peripheral: Intel Corporation Core Processor System Management 
Registers (rev 11)
00:08.1 System peripheral: Intel Corporation Core Processor Semaphore and 
Scratchpad Registers (rev 11)
00:08.2 System peripheral: Intel Corporation Core Processor System Control and 
Status Registers (rev 11)
00:08.3 System peripheral: Intel Corporation Core Processor Miscellaneous 
Registers (rev 11)
00:10.0 System peripheral: Intel Corporation Core Processor QPI Link (rev 11)
00:10.1 System peripheral: Intel Corporation Core Processor QPI Routing and 
Protocol Registers (rev 11)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 
Enhanced Host Controller (rev 05)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High 
Definition Audio (rev 05)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express 
Root Port 1 (rev 05)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express 
Root Port 2 (rev 05)
00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express 
Root Port 3 (rev 05)
00:1c.3 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express 
Root Port 4 (rev 05)
00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express 
Root Port 5 (rev 05)
00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express 
Root Port 6 (rev 05)
00:1c.6 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express 
Root Port 7 (rev 05)
00:1c.7 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express 
Root Port 8 (rev 05)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 
Enhanced Host 

[Touch-packages] [Bug 1833443] [NEW] Calculator button does nothing (Calculator not launched)

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

Troubleshoot steps followed:
https://wiki.ubuntu.com/Hotkeys/Troubleshooting.

Step-by-step Troubleshooting
1. Is latest I think
2. gnome-settings-daemon not running
3. No keypress event
4. Skip (see 3)
5. a. 

evtest output:
Event: time 1560959333.892425, -- SYN_REPORT 
Event: time 1560959337.916913, type 4 (EV_MSC), code 4 (MSC_SCAN), value a1
Event: time 1560959337.916913, type 1 (EV_KEY), code 140 (KEY_CALC), value 1
Event: time 1560959337.916913, -- SYN_REPORT 
Event: time 1560959338.121844, type 4 (EV_MSC), code 4 (MSC_SCAN), value a1
Event: time 1560959338.121844, type 1 (EV_KEY), code 140 (KEY_CALC), value 0
Event: time 1560959338.121844, -- SYN_REPORT 

   b. 140 (0x08c) not found in /usr/include/linux/input.h
7. N/A (see 4)

I can try provide info from https://wiki.ubuntu.com/DebuggingProcedures
if wanted.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: udev 237-3ubuntu10.22
ProcVersionSignature: Ubuntu 4.15.0-51.55-generic 4.15.18
Uname: Linux 4.15.0-51-generic x86_64
NonfreeKernelModules: lkp_Ubuntu_4_15_0_51_55_generic_52
ApportVersion: 2.20.9-0ubuntu7.6
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
CustomUdevRuleFiles: 70-snap.warzone2100.rules 70-snap.core.rules 
70-snap.opendungeons.rules 56-hpmud.rules S99-2000S1.rules 
70-snap.minetest.rules 40-libsane.rules 70-snap.canonical-livepatch.rules 
70-snap.chromium.rules
Date: Wed Jun 19 17:58:19 2019
InstallationDate: Installed on 2019-05-14 (36 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
ProcEnviron:
 LANGUAGE=en_ZA:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=
 LANG=en_ZA.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-51-generic 
root=UUID=9b9d08ae-0424-4d09-87e0-5db4115b3a2b ro quiet splash vt.handoff=1
SourcePackage: systemd
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/12/2015
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68SVD Ver. F.60
dmi.board.name: 1631
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 01.3F
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: 
dmi:bvnHewlett-Packard:bvr68SVDVer.F.60:bd03/12/2015:svnHewlett-Packard:pn:pvrA0001C02:rvnHewlett-Packard:rn1631:rvrKBCVersion01.3F:cvnHewlett-Packard:ct10:cvr:
dmi.product.family: 103C_5336AN
dmi.product.version: A0001C02
dmi.sys.vendor: Hewlett-Packard

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug bionic
-- 
Calculator button does nothing (Calculator not launched)
https://bugs.launchpad.net/bugs/1833443
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1838992] [NEW] udev doesn't pick up volumes properly

2020-08-06 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

[Only happens on Ubuntu, not other OS's, like Debian]

When we are attaching a volume to a running Ubuntu server (using
kvm/libvirt), most of the time the udev rules are not properly
triggered. In the end the volume will most of the time not be available
in `/dev/disk/by-id/virtio-`. Sometimes it works though
(10%/20%?).

The reason for this is that udev somehow doesn't pick it up when the
volume is attached. It looks like a timing issue. Just looking at
`/sys/devices/pci:00/:00:05.0/virtio2/block/vdb/serial` makes it
clear that it's there. However `udevadm info /dev/vdb` returns without
the `ID_SERIAL` key. Only a `udevadm trigger` leads to a correct entry
of `ID_SERIAL` and also fixes `/dev/disk/by-id`.

We are a small cloud provider (cloudscale.ch). We have tested this on
Ubuntu (16.04/18.04), Debian 9, CentOS, CoreOS. We haven't tested this
extensively, but it sure looks like it's only happening on Ubuntu. . We
never had any issues reported on other OS's about this.

I tried looking at the differences of Debian and Ubuntu udev packages,
but couldn't figure out what might be responsible for this behavior.

If someone needs an account for our control panel to reproduce this,
please contact me, I'm happy to give you the resources to debug this.

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New

-- 
udev doesn't pick up volumes properly
https://bugs.launchpad.net/bugs/1838992
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to systemd in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


  1   2   >