[Touch-packages] [Bug 1904192] Re: ebtables can not rename just created chain

2020-11-15 Thread Christian Ehrhardt 
FYI
Since I started on this with libvirt and the libvirt people were helpful as 
always in debugging this I also pinged the ML since this issue should affect 
libvirt in any place where it runs with the new ebtables.
https://www.redhat.com/archives/libvir-list/2020-November/msg00790.html


@Oibaf - thanks for reporting this upstream. Does it affect you in another 
use-case/context than libvirt?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to iptables in Ubuntu.
https://bugs.launchpad.net/bugs/1904192

Title:
  ebtables can not rename just created chain

Status in iptables:
  Unknown
Status in iptables package in Ubuntu:
  Confirmed

Bug description:
  Hi,
  I have an issue with ebtables that affects libvirt.
  While initially found in hirsute I had to realize this is broken in
  Groovy and even Bionic (might be a different reason back then) as well right 
now.
  But working in Focal (witch matches my memory of it being good before [1]).

  I was isolating the commands that libvirt runs (identical between Focal
  and Hirsute) to find a simplified trigger. Gladly I found one that leaves
  libvirt and other components out of the equation.
  The following works on focal, but fails on the other releases.

  Note: I checked which tool is in use and in both cases it is 
xtables-nft-multi.
  /usr/sbin/ebtables -> /etc/alternatives/ebtables*
  /etc/alternatives/ebtables -> /usr/sbin/ebtables-nft*
  /usr/sbin/ebtables-nft -> xtables-nft-multi*
  So I converted the libvirt issued commands into xtables-nft-multi just to be
  sure in case a system to compare has other alternatives set.

  Focal (Good):
  /usr/sbin/xtables-nft-multi ebtables --concurrent -t nat -N testrule3
  /usr/sbin/xtables-nft-multi ebtables --concurrent -t nat -E testrule3 
testrule3-renamed
  

  Groovy/Hirsute (Fail):
  /usr/sbin/xtables-nft-multi ebtables --concurrent -t nat -N testrule3
  /usr/sbin/xtables-nft-multi ebtables --concurrent -t nat -E testrule3 
testrule3-renamed
  ebtables v1.8.5 (nf_tables): Chain 'testrule3' doesn't exists
  Try `ebtables -h' or 'ebtables --help' for more information.

  What might be the root cause for this?


  -- Old test instructions --

  As I said I was tracking a fail in libvirt so the test instructions initially
  were around that:

  
  # the following us done as 2nd level guest (to not mess with the host,
  # but works on bare metal jst as much)
  uvt-kvm create --host-passthrough --memory 2048 --cpu 4 --disk 16 
--password=ubuntu hirsute-kvm release=hirsute arch=amd64 label=daily
  # On guest then

  sudo apt update
  sudo apt install uvtool uvtool-libvirt
  uvt-simplestreams-libvirt --verbose sync --source 
http://cloud-images.ubuntu.com/daily arch=amd64 label=daily release=hirsute
  uvt-kvm create --disk 5 --machine-type ubuntu --password=ubuntu 
hirsute-2nd-lvm release=hirsute arch=amd64 label=daily
  uvt-kvm wait hirsute-2nd-lvm
  virsh shutdown hirsute-2nd-lvm
  virsh edit hirsute-2nd-lvm
  # add this to the network

  

  virsh start hirsute-2nd-lvm
error: Failed to start domain hirsute-2nd-nwfilter
error: internal error: applyDHCPOnlyRules failed - spoofing not protected!

  FYI: Get helpful log details with these in /etc/libvirt/libvirtd.conf
  log_filters="1:util.firewall"
  log_outputs="1:syslog:libvirtd"

  -- --

  [1]: https://bugs.launchpad.net/ubuntu/+source/libvirt/+bug/1758037

To manage notifications about this bug go to:
https://bugs.launchpad.net/iptables/+bug/1904192/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1733002] Re: Google Online Account Two Factor with hardware key fails immediately

2020-11-15 Thread Steven Jay Cohen
Confirming, it affects me at well (20.04).

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gnome-online-accounts in
Ubuntu.
https://bugs.launchpad.net/bugs/1733002

Title:
  Google Online Account Two Factor with hardware key fails immediately

Status in gnome-online-accounts:
  Unknown
Status in Webkit:
  Fix Released
Status in gnome-online-accounts package in Ubuntu:
  Triaged

Bug description:
  The hardware key authentication two factor fails immediately with a
  web based retry dialogue when connecting a Google account to the
  online accounts in settings using a hardware key second factor.

  Steps to reproduce:
  1. Set Google Account to default to a hardware security key like a Yubikey or 
other FIDO standard key after having two factor authentication enabled on your 
Google Account.
  2. Open Online accounts
  3. Add a Google Account
  4. Enter google email address
  5. Enter google password
  6. (this is the login flow of two factor, if default is the hardware key the 
error should appear).

  Work around:
  Choose use another method to authenticate: enter the authentication code and 
you will proceed.

  Expectations were:
  The ability to use the hardware key to authenticate as the second factor.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: gnome-control-center 1:3.26.1-0ubuntu5
  ProcVersionSignature: Ubuntu 4.13.0-16.19-lowlatency 4.13.4
  Uname: Linux 4.13.0-16-lowlatency x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
  ApportVersion: 2.20.7-0ubuntu3.4
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Fri Nov 17 16:01:11 2017
  EcryptfsInUse: Yes
  ExecutablePath: /usr/bin/gnome-control-center
  ProcEnviron:
   XDG_RUNTIME_DIR=
   SHELL=/bin/bash
   PATH=(custom, user)
   LANG=en_US.UTF-8
  SourcePackage: gnome-control-center
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/gnome-online-accounts/+bug/1733002/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1904369] [NEW] systemd 100% CPU; constantly reading service for socket activation

2020-11-15 Thread Haw Loeung
Public bug reported:

Hi,

We recently switched to using systemd's socket activation for per-client
limits. The configs are as follows:

| $ ls -la /etc/systemd/system/sockets.target.wants/rsyncd.socket
| lrwxrwxrwx 1 root root 33 Aug 25 00:09 
/etc/systemd/system/sockets.target.wants/rsyncd.socket -> 
/etc/systemd/system/rsyncd.socket

| $ cat /etc/systemd/system/sockets.target.wants/rsyncd.socket
| [Unit]
| Description=rsync daemon (socket)
| Conflicts=rsyncd.service
|
| [Socket]
| ListenStream=873
| Accept=yes
| MaxConnections=85
| MaxConnectionsPerSource=5
| KeepAlive=true
|
| [Install]
| WantedBy=sockets.target

| $ cat /etc/systemd/system/rsyncd@.service
| [Unit]
| Description=rsync daemon
| ConditionPathExists=/etc/rsyncd.conf
|
| [Service]
| ExecStart=/usr/bin/rsync --daemon
| StandardInput=socket
|
| [Install]
| WantedBy=multi-user.target

After a while, systemd runs hot consuming a whole CPU core:

| $ top -p 1
|   PID USER  PR  NIVIRTRESSHR S  %CPU %MEM TIME+ COMMAND
| 1 root  20   0 2057476 251560   6264 R  99.7  0.1  17903:32 systemd

strace shows it constantly doing this:

| $ sudo strace -p 1
| ...
| openat(AT_FDCWD, "/etc/systemd/system/rsyncd@.service", 
O_RDONLY|O_NOCTTY|O_NOFOLLOW|O_CLOEXEC) = 14
| fcntl(14, F_GETFL)  = 0x28000 (flags 
O_RDONLY|O_LARGEFILE|O_NOFOLLOW)
| fstat(14, {st_mode=S_IFREG|0644, st_size=173, ...}) = 0
| fstat(14, {st_mode=S_IFREG|0644, st_size=173, ...}) = 0
| fstat(14, {st_mode=S_IFREG|0644, st_size=173, ...}) = 0
| read(14, "[Unit]\nDescription=rsync daemon\n"..., 4096) = 173
| read(14, "", 4096)  = 0
| close(14)   = 0
| openat(AT_FDCWD, "/etc/systemd/system/rsyncd@.service", 
O_RDONLY|O_NOCTTY|O_NOFOLLOW|O_CLOEXEC) = 14
| fcntl(14, F_GETFL)  = 0x28000 (flags 
O_RDONLY|O_LARGEFILE|O_NOFOLLOW)
| fstat(14, {st_mode=S_IFREG|0644, st_size=173, ...}) = 0
| fstat(14, {st_mode=S_IFREG|0644, st_size=173, ...}) = 0
| fstat(14, {st_mode=S_IFREG|0644, st_size=173, ...}) = 0
| read(14, "[Unit]\nDescription=rsync daemon\n"..., 4096) = 173
| read(14, "", 4096)  = 0
| close(14)   = 0
| ^Cstrace: Process 1 detached

This is with 237-3ubuntu10.43 on a host running Bionic.

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: systemd (Ubuntu Bionic)
 Importance: Undecided
 Status: New

** Also affects: systemd (Ubuntu Bionic)
   Importance: Undecided
   Status: New

** Description changed:

  Hi,
  
  We recently switched to using systemd's socket activation for per-client
  limits. The configs are as follows:
  
  | $ ls -la /etc/systemd/system/sockets.target.wants/rsyncd.socket
  | lrwxrwxrwx 1 root root 33 Aug 25 00:09 
/etc/systemd/system/sockets.target.wants/rsyncd.socket -> 
/etc/systemd/system/rsyncd.socket
  
  | $ cat /etc/systemd/system/sockets.target.wants/rsyncd.socket
  | [Unit]
  | Description=rsync daemon (socket)
  | Conflicts=rsyncd.service
  |
  | [Socket]
  | ListenStream=873
  | Accept=yes
  | MaxConnections=85
  | MaxConnectionsPerSource=5
  | KeepAlive=true
  |
  | [Install]
  | WantedBy=sockets.target
+ 
+ | $ cat /etc/systemd/system/rsyncd@.service
+ | [Unit]
+ | Description=rsync daemon
+ | ConditionPathExists=/etc/rsyncd.conf
+ |
+ | [Service]
+ | ExecStart=/usr/bin/rsync --daemon
+ | StandardInput=socket
+ |
+ | [Install]
+ | WantedBy=multi-user.target
  
  After a while, systemd runs hot consuming a whole CPU core:
  
  |   PID USER  PR  NIVIRTRESSHR S  %CPU %MEM TIME+ COMMAND
  | 1 root  20   0 2057476 251560   6264 R  99.7  0.1  17903:32 systemd
  
  strace shows it constantly doing this:
  
  | $ sudo strace -p 1
  | ...
  | openat(AT_FDCWD, "/etc/systemd/system/rsyncd@.service", 
O_RDONLY|O_NOCTTY|O_NOFOLLOW|O_CLOEXEC) = 14
  | fcntl(14, F_GETFL)  = 0x28000 (flags 
O_RDONLY|O_LARGEFILE|O_NOFOLLOW)
  | fstat(14, {st_mode=S_IFREG|0644, st_size=173, ...}) = 0
  | fstat(14, {st_mode=S_IFREG|0644, st_size=173, ...}) = 0
  | fstat(14, {st_mode=S_IFREG|0644, st_size=173, ...}) = 0
  | read(14, "[Unit]\nDescription=rsync daemon\n"..., 4096) = 173
  | read(14, "", 4096)  = 0
  | close(14)   = 0
  | openat(AT_FDCWD, "/etc/systemd/system/rsyncd@.service", 
O_RDONLY|O_NOCTTY|O_NOFOLLOW|O_CLOEXEC) = 14
  | fcntl(14, F_GETFL)  = 0x28000 (flags 
O_RDONLY|O_LARGEFILE|O_NOFOLLOW)
  | fstat(14, {st_mode=S_IFREG|0644, st_size=173, ...}) = 0
  | fstat(14, {st_mode=S_IFREG|0644, st_size=173, ...}) = 0
  | fstat(14, {st_mode=S_IFREG|0644, st_size=173, ...}) = 0
  | read(14, "[Unit]\nDescription=rsync daemon\n"..., 4096) = 173
  | read(14, "", 4096)  = 0
  | close(14)   = 0
  | ^Cstrace: Process 1 detached
  
  This is with 237-3ubuntu10.43 on a host running Bionic.

** Description changed:

  

[Touch-packages] [Bug 1871794] Re: [Bluetooth] No audio output/input in HSP/HFP mode

2020-11-15 Thread Hui Wang
@smurf,

I heard this wifi+bt module needs to install a dkms. I will ask my
colleague about it.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1871794

Title:
  [Bluetooth] No audio output/input in HSP/HFP mode

Status in bluez package in Ubuntu:
  Confirmed
Status in pulseaudio package in Ubuntu:
  Confirmed

Bug description:
  I'm testing with Sony bluetooth headset SBH20, works fine in A2DP
  profile, but I can't get audio input and output work in HSP/HFP
  profile.

  [Reproduce steps]
  1. Scan and pair BT headset in Bluetooth setting
  2. Switch to HSP/HFP profile in Sound setting
  3. Test sound output/input

  [Machine information]
  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: pulseaudio 1:13.99.1-1ubuntu1
  ProcVersionSignature: Ubuntu 5.4.0-21.25-generic 5.4.27
  Uname: Linux 5.4.0-21-generic x86_64
  ApportVersion: 2.20.11-0ubuntu25
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  ubuntu 1359 F pulseaudio
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Apr  9 16:26:52 2020
  InstallationDate: Installed on 2020-04-09 (0 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Beta amd64 (20200402)
  SourcePackage: pulseaudio
  Symptom: audio
  Symptom_Card: SBH20
  Symptom_DevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  ubuntu 1359 F pulseaudio
  Symptom_Type: No sound at all
  Title: [SBH20, recording] No sound at all
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 09/17/2019
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.0.13
  dmi.board.name: 0188D1
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 31
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvr1.0.13:bd09/17/2019:svnDellInc.:pnXPS1373902-in-1:pvr:rvnDellInc.:rn0188D1:rvrA00:cvnDellInc.:ct31:cvr:
  dmi.product.family: XPS
  dmi.product.name: XPS 13 7390 2-in-1
  dmi.product.sku: 08B0
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1871794/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1880282] Re: [HP Spectre x360 Convertible 15-df0xxx, Realtek ALC285, Speaker, Internal] No sound at all

2020-11-15 Thread Daniel van Vugt
*** This bug is a duplicate of bug 1876484 ***
https://bugs.launchpad.net/bugs/1876484

** This bug has been marked a duplicate of bug 1876484
   [HP Spectre x360 Convertible 15-df0xxx, Realtek ALC285, Speaker, Internal] 
No sound at all

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1880282

Title:
  [HP Spectre x360 Convertible 15-df0xxx, Realtek ALC285, Speaker,
  Internal] No sound at all

Status in alsa-driver package in Ubuntu:
  New

Bug description:
  Hi, I did try to upgrade kernel 5.6 and also 5.7. 
  So it did fix the problem with Nvidia driver and now Xorg driver is working. 
  But my computer doesn't give any sound. 
  It recognizes the device and also even shows sound works, but I don't get any 
sound. 
  If I use Nvidia drivers, the sound does work, but on Xorg driver it isn't - 
https://i.imgur.com/LmmXRad.png

  I did also check alsamixer and pulse control, did set up the sound, but any 
changes
  https://i.imgur.com/EHRsxj6.png

  If I add any headphones or others speakers, sound work.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: alsa-base 1.0.25+dfsg-0ubuntu5
  Uname: Linux 5.7.0-050700rc6-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  iron-mike   2519 F pulseaudio
iron-mike   6505 F alsamixer
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Sat May 23 10:24:44 2020
  InstallationDate: Installed on 2020-05-22 (0 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  PackageArchitecture: all
  SourcePackage: alsa-driver
  Symptom: audio
  Symptom_AlsaPlaybackTest: ALSA playback test through plughw:PCH failed
  Symptom_Card: Built-in Audio - HDA Intel PCH
  Symptom_DevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  iron-mike   2519 F pulseaudio
iron-mike   6505 F alsamixer
  Symptom_Jack: Speaker, Internal
  Symptom_Type: No sound at all
  Title: [HP Spectre x360 Convertible 15-df0xxx, Realtek ALC285, Speaker, 
Internal] No sound at all
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 11/27/2019
  dmi.bios.vendor: AMI
  dmi.bios.version: F.40
  dmi.board.asset.tag: Base Board Asset Tag
  dmi.board.name: 8519
  dmi.board.vendor: HP
  dmi.board.version: 11.72
  dmi.chassis.type: 31
  dmi.chassis.vendor: HP
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAMI:bvrF.40:bd11/27/2019:svnHP:pnHPSpectrex360Convertible15-df0xxx:pvr:rvnHP:rn8519:rvr11.72:cvnHP:ct31:cvrChassisVersion:
  dmi.product.family: 103C_5335KV HP Spectre
  dmi.product.name: HP Spectre x360 Convertible 15-df0xxx
  dmi.product.sku: 4UU78EA#ABD
  dmi.sys.vendor: HP
  mtime.conffile..etc.modprobe.d.alsa-base.conf: 2020-05-22T23:09:17.197956

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1880282/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1904332] Re: [HP Pavilion x360 Convertible 14-dh1xxx] No sound

2020-11-15 Thread Daniel van Vugt
** Summary changed:

- no sound issue
+ [HP Pavilion x360 Convertible 14-dh1xxx] No sound

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1904332

Title:
  [HP Pavilion x360 Convertible 14-dh1xxx] No sound

Status in pulseaudio package in Ubuntu:
  New

Bug description:
  I have a ubuntu budgie environment. Though the speakers (hardware) are
  detected, no sound is audible despite the volume levels being maximum.
  I performed tests in the sound settings window, so the issue does not
  seem to be specific to a particular application

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: pulseaudio 1:13.99.1-1ubuntu3.5
  ProcVersionSignature: Ubuntu 5.4.0-53.59-generic 5.4.65
  Uname: Linux 5.4.0-53-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.4
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  berry  1239 F pulseaudio
  CasperMD5CheckResult: skip
  CurrentDesktop: Budgie:GNOME
  Date: Sun Nov 15 21:07:24 2020
  InstallationDate: Installed on 2020-11-15 (0 days ago)
  InstallationMedia: Ubuntu-Budgie 20.04.1 LTS "Focal Fossa" - Release amd64 
(20200731)
  SourcePackage: pulseaudio
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 06/11/2020
  dmi.bios.vendor: Insyde
  dmi.bios.version: F.08
  dmi.board.asset.tag: Type2 - Board Asset Tag
  dmi.board.name: 866E
  dmi.board.vendor: HP
  dmi.board.version: 90.08
  dmi.chassis.asset.tag: Chassis Asset Tag
  dmi.chassis.type: 31
  dmi.chassis.vendor: HP
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnInsyde:bvrF.08:bd06/11/2020:svnHP:pnHPPavilionx360Convertible14-dh1xxx:pvrType1ProductConfigId:rvnHP:rn866E:rvr90.08:cvnHP:ct31:cvrChassisVersion:
  dmi.product.family: 103C_5335KV HP Pavilion
  dmi.product.name: HP Pavilion x360 Convertible 14-dh1xxx
  dmi.product.sku: 231T1PA#ACJ
  dmi.product.version: Type1ProductConfigId
  dmi.sys.vendor: HP

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1904332/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1904230] Re: System freeze after logging onto desktop session

2020-11-15 Thread Daniel van Vugt
Thank you for taking the time to report this bug and helping to make
Ubuntu better. It sounds like some part of the system has crashed. To
help us find the cause of the crash please follow these steps:

1. Look in /var/crash for crash files and if found run:
ubuntu-bug YOURFILE.crash
Then tell us the ID of the newly-created bug.

2. If step 1 failed then look at https://errors.ubuntu.com/user/ID where
ID is the content of file /var/lib/whoopsie/whoopsie-id on the machine.
Do you find any links to recent problems on that page? If so then please
send the links to us.

3. If step 2 also failed then apply the workaround from bug 994921,
reboot, reproduce the crash, and retry step 1.

Please take care to avoid attaching .crash files to bugs as we are
unable to process them as file attachments. It would also be a security
risk for yourself.


** Package changed: xorg (Ubuntu) => ubuntu

** Changed in: ubuntu
   Status: New => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1904230

Title:
  System freeze after logging onto desktop session

Status in Ubuntu:
  Incomplete

Bug description:
  After performing a recent update, I am encountering a complete system
  freeze shortly after logging on to a graphical session but only for a
  single user (which may suggest a corrupted configuration file
  somewhere). This is repeatable - happens every time I attempt to
  login. The desktop is LXDE however it also occurs with Openbox as
  well. Furthermore, it also happens when launching a desktop with
  vncserver which suggests it is not a graphics driver issue.

  I've tried deleting (renaming) the .config and .cache folders in the
  account, neither of these have had any effect.

  Am fairly sure I have seen this once or twice in the past but it was a
  pretty rare event.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: xorg (not installed)
  ProcVersionSignature: Ubuntu 4.15.0-122.124~16.04.1-generic 4.15.18
  Uname: Linux 4.15.0-122-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.25
  Architecture: amd64
  Date: Fri Nov 13 17:44:30 2020
  InstallationDate: Installed on 2013-07-25 (2668 days ago)
  InstallationMedia: Ubuntu-Server 12.04.2 LTS "Precise Pangolin" - Release 
amd64 (20130214)
  SourcePackage: xorg
  Symptom: display
  Title: Xorg freeze
  UpgradeStatus: Upgraded to xenial on 2018-12-28 (686 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+bug/1904230/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1904325] Re: half the steam games won't launch.

2020-11-15 Thread Daniel van Vugt
Please try launching one/some from a Terminal window so we can see any
errors being printed.

** Package changed: xorg (Ubuntu) => ubuntu

** Changed in: ubuntu
   Status: New => Incomplete

** Summary changed:

- half the steam games won't launch. 
+ Half the Steam games won't launch on Intel Atom N455

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1904325

Title:
  Half the Steam games won't launch on Intel Atom N455

Status in Ubuntu:
  Incomplete

Bug description:
  games launch only by using LIBGL_ALWAYS_SOFTWARE=1 %command% in game
  launch options. These games used to run fine on an older linux mint
  version, but now they won't launch no matter if i use lubuntu or lxde.
  only LIBGL_ALWAYS_SOFTWARE=1 %command% helps, but it significantly
  slows down the game. All the graphics drivers should be up to date. i
  am using Ubuntu 18.04.5 LTS

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: xorg 1:7.7+19ubuntu7.1
  ProcVersionSignature: Ubuntu 4.15.0-123.126-generic 4.15.18
  Uname: Linux 4.15.0-123-generic i686
  NonfreeKernelModules: wl
  ApportVersion: 2.20.9-0ubuntu7.20
  Architecture: i386
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: LXDE
  Date: Sun Nov 15 16:18:40 2020
  DistroCodename: bionic
  DistroVariant: ubuntu
  DkmsStatus:
   bcmwl, 6.30.223.271+bdcom, 4.15.0-122-generic, i686: installed
   bcmwl, 6.30.223.271+bdcom, 4.15.0-123-generic, i686: installed
   bcmwl, 6.30.223.271+bdcom, 4.15.0-60-generic, i686: installed
  ExtraDebuggingInterest: Yes, if not too technical
  GraphicsCard:
   Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics 
Controller [8086:a011] (prog-if 00 [VGA controller])
 Subsystem: Hewlett-Packard Company Atom Processor D4xx/D5xx/N4xx/N5xx 
Integrated Graphics Controller [103c:1584]
 Subsystem: Hewlett-Packard Company Atom Processor D4xx/D5xx/N4xx/N5xx 
Integrated Graphics Controller [103c:1584]
  InstallationDate: Installed on 2020-11-07 (8 days ago)
  InstallationMedia: LXLE 18.04 - Release i386
  MachineType: Hewlett-Packard HP Mini 210-2000
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-123-generic 
root=/dev/mapper/qwerty--vg-root ro quiet splash
  SourcePackage: xorg
  UpgradeStatus: Upgraded to bionic on 2019-09-08 (434 days ago)
  dmi.bios.date: 03/14/2012
  dmi.bios.vendor: Hewlett-Packard
  dmi.bios.version: F.25
  dmi.board.asset.tag: Base Board Asset Tag
  dmi.board.name: 1584
  dmi.board.vendor: Hewlett-Packard
  dmi.board.version: 85.37
  dmi.chassis.asset.tag: Chassis Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: Hewlett-Packard
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnHewlett-Packard:bvrF.25:bd03/14/2012:svnHewlett-Packard:pnHPMini210-2000:pvr059010202B0300100:rvnHewlett-Packard:rn1584:rvr85.37:cvnHewlett-Packard:ct10:cvrChassisVersion:
  dmi.product.family: 103C_5335KV
  dmi.product.name: HP Mini 210-2000
  dmi.product.version: 059010202B0300100
  dmi.sys.vendor: Hewlett-Packard
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2~18.04.1
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~18.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.8-0ubuntu1~18.04.1
  version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4.7
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.5-1ubuntu1
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.0.1-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20171229-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+bug/1904325/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1901115] Re: package bluez 5.55-0ubuntu1 failed to install/upgrade: installed bluez package post-installation script subprocess returned error exit status 1 [Failed to start Blue

2020-11-15 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: bluez (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to bluez in Ubuntu.
https://bugs.launchpad.net/bugs/1901115

Title:
  package bluez 5.55-0ubuntu1 failed to install/upgrade: installed bluez
  package post-installation script subprocess returned error exit status
  1 [Failed to start Bluetooth service.]

Status in bluez package in Ubuntu:
  Confirmed

Bug description:
  package bluez 5.55-0ubuntu1 failed to install/upgrade: installed bluez
  package post-installation script subprocess returned error exit status
  1

  ProblemType: Package
  DistroRelease: Ubuntu 20.10
  Package: bluez 5.55-0ubuntu1
  ProcVersionSignature: Ubuntu 5.8.0-25.26-generic 5.8.14
  Uname: Linux 5.8.0-25-generic x86_64
  ApportVersion: 2.20.11-0ubuntu50
  Architecture: amd64
  CasperMD5CheckResult: skip
  Date: Fri Oct 23 07:08:46 2020
  ErrorMessage: installed bluez package post-installation script subprocess 
returned error exit status 1
  InterestingModules: rfcomm bnep btusb bluetooth
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 8087:0a2a Intel Corp. Bluetooth wireless interface
   Bus 001 Device 002: ID 0bda:5689 Realtek Semiconductor Corp. Integrated 
Webcam
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: Dell Inc. Latitude 3180
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.8.0-25-generic 
root=UUID=8e6f60a5-d013-4d5d-83ed-df27737e1381 ro quiet splash vt.handoff=7
  Python3Details: /usr/bin/python3.8, Python 3.8.6, python3-minimal, 
3.8.6-0ubuntu1
  PythonDetails: N/A
  RelatedPackageVersions:
   dpkg 1.20.5ubuntu2
   apt  2.1.10
  SourcePackage: bluez
  Title: package bluez 5.55-0ubuntu1 failed to install/upgrade: installed bluez 
package post-installation script subprocess returned error exit status 1
  UpgradeStatus: Upgraded to groovy on 2020-10-23 (0 days ago)
  dmi.bios.date: 10/03/2019
  dmi.bios.release: 1.10
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.10.0
  dmi.board.name: 05YMV0
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 10
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvr1.10.0:bd10/03/2019:br1.10:svnDellInc.:pnLatitude3180:pvr:rvnDellInc.:rn05YMV0:rvrA00:cvnDellInc.:ct10:cvr:
  dmi.product.family: Latitude
  dmi.product.name: Latitude 3180
  dmi.product.sku: 07B2
  dmi.sys.vendor: Dell Inc.
  hciconfig:
   hci0:Type: Primary  Bus: USB
BD Address: 74:70:FD:58:F6:73  ACL MTU: 1021:4  SCO MTU: 96:6
UP RUNNING PSCAN 
RX bytes:2712 acl:0 sco:0 events:305 errors:0
TX bytes:50942 acl:0 sco:0 commands:305 errors:0

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1901115/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1901115] Re: package bluez 5.55-0ubuntu1 failed to install/upgrade: installed bluez package post-installation script subprocess returned error exit status 1 [Failed to start Blue

2020-11-15 Thread Daniel van Vugt
** Changed in: bluez (Ubuntu)
   Importance: Undecided => Medium

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to bluez in Ubuntu.
https://bugs.launchpad.net/bugs/1901115

Title:
  package bluez 5.55-0ubuntu1 failed to install/upgrade: installed bluez
  package post-installation script subprocess returned error exit status
  1 [Failed to start Bluetooth service.]

Status in bluez package in Ubuntu:
  Confirmed

Bug description:
  package bluez 5.55-0ubuntu1 failed to install/upgrade: installed bluez
  package post-installation script subprocess returned error exit status
  1

  ProblemType: Package
  DistroRelease: Ubuntu 20.10
  Package: bluez 5.55-0ubuntu1
  ProcVersionSignature: Ubuntu 5.8.0-25.26-generic 5.8.14
  Uname: Linux 5.8.0-25-generic x86_64
  ApportVersion: 2.20.11-0ubuntu50
  Architecture: amd64
  CasperMD5CheckResult: skip
  Date: Fri Oct 23 07:08:46 2020
  ErrorMessage: installed bluez package post-installation script subprocess 
returned error exit status 1
  InterestingModules: rfcomm bnep btusb bluetooth
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 8087:0a2a Intel Corp. Bluetooth wireless interface
   Bus 001 Device 002: ID 0bda:5689 Realtek Semiconductor Corp. Integrated 
Webcam
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: Dell Inc. Latitude 3180
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.8.0-25-generic 
root=UUID=8e6f60a5-d013-4d5d-83ed-df27737e1381 ro quiet splash vt.handoff=7
  Python3Details: /usr/bin/python3.8, Python 3.8.6, python3-minimal, 
3.8.6-0ubuntu1
  PythonDetails: N/A
  RelatedPackageVersions:
   dpkg 1.20.5ubuntu2
   apt  2.1.10
  SourcePackage: bluez
  Title: package bluez 5.55-0ubuntu1 failed to install/upgrade: installed bluez 
package post-installation script subprocess returned error exit status 1
  UpgradeStatus: Upgraded to groovy on 2020-10-23 (0 days ago)
  dmi.bios.date: 10/03/2019
  dmi.bios.release: 1.10
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.10.0
  dmi.board.name: 05YMV0
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 10
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvr1.10.0:bd10/03/2019:br1.10:svnDellInc.:pnLatitude3180:pvr:rvnDellInc.:rn05YMV0:rvrA00:cvnDellInc.:ct10:cvr:
  dmi.product.family: Latitude
  dmi.product.name: Latitude 3180
  dmi.product.sku: 07B2
  dmi.sys.vendor: Dell Inc.
  hciconfig:
   hci0:Type: Primary  Bus: USB
BD Address: 74:70:FD:58:F6:73  ACL MTU: 1021:4  SCO MTU: 96:6
UP RUNNING PSCAN 
RX bytes:2712 acl:0 sco:0 events:305 errors:0
TX bytes:50942 acl:0 sco:0 commands:305 errors:0

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1901115/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1901115] Re: package bluez 5.55-0ubuntu1 failed to install/upgrade: installed bluez package post-installation script subprocess returned error exit status 1 [Failed to start Blue

2020-11-15 Thread Daniel van Vugt
** Tags added: focal

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to bluez in Ubuntu.
https://bugs.launchpad.net/bugs/1901115

Title:
  package bluez 5.55-0ubuntu1 failed to install/upgrade: installed bluez
  package post-installation script subprocess returned error exit status
  1 [Failed to start Bluetooth service.]

Status in bluez package in Ubuntu:
  Confirmed

Bug description:
  package bluez 5.55-0ubuntu1 failed to install/upgrade: installed bluez
  package post-installation script subprocess returned error exit status
  1

  ProblemType: Package
  DistroRelease: Ubuntu 20.10
  Package: bluez 5.55-0ubuntu1
  ProcVersionSignature: Ubuntu 5.8.0-25.26-generic 5.8.14
  Uname: Linux 5.8.0-25-generic x86_64
  ApportVersion: 2.20.11-0ubuntu50
  Architecture: amd64
  CasperMD5CheckResult: skip
  Date: Fri Oct 23 07:08:46 2020
  ErrorMessage: installed bluez package post-installation script subprocess 
returned error exit status 1
  InterestingModules: rfcomm bnep btusb bluetooth
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 8087:0a2a Intel Corp. Bluetooth wireless interface
   Bus 001 Device 002: ID 0bda:5689 Realtek Semiconductor Corp. Integrated 
Webcam
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: Dell Inc. Latitude 3180
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.8.0-25-generic 
root=UUID=8e6f60a5-d013-4d5d-83ed-df27737e1381 ro quiet splash vt.handoff=7
  Python3Details: /usr/bin/python3.8, Python 3.8.6, python3-minimal, 
3.8.6-0ubuntu1
  PythonDetails: N/A
  RelatedPackageVersions:
   dpkg 1.20.5ubuntu2
   apt  2.1.10
  SourcePackage: bluez
  Title: package bluez 5.55-0ubuntu1 failed to install/upgrade: installed bluez 
package post-installation script subprocess returned error exit status 1
  UpgradeStatus: Upgraded to groovy on 2020-10-23 (0 days ago)
  dmi.bios.date: 10/03/2019
  dmi.bios.release: 1.10
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.10.0
  dmi.board.name: 05YMV0
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 10
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvr1.10.0:bd10/03/2019:br1.10:svnDellInc.:pnLatitude3180:pvr:rvnDellInc.:rn05YMV0:rvrA00:cvnDellInc.:ct10:cvr:
  dmi.product.family: Latitude
  dmi.product.name: Latitude 3180
  dmi.product.sku: 07B2
  dmi.sys.vendor: Dell Inc.
  hciconfig:
   hci0:Type: Primary  Bus: USB
BD Address: 74:70:FD:58:F6:73  ACL MTU: 1021:4  SCO MTU: 96:6
UP RUNNING PSCAN 
RX bytes:2712 acl:0 sco:0 events:305 errors:0
TX bytes:50942 acl:0 sco:0 commands:305 errors:0

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1901115/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1904288] Re: package bluez 5.53-0ubuntu3 failed to install/upgrade: il sottoprocesso installato pacchetto bluez script post-installation ha restituito lo stato di errore 1

2020-11-15 Thread Daniel van Vugt
*** This bug is a duplicate of bug 1901115 ***
https://bugs.launchpad.net/bugs/1901115

Thank you for taking the time to report this bug and helping to make
Ubuntu better. This particular bug has already been reported and is a
duplicate of bug 1901115, so it is being marked as such. Please look at
the other bug report to see if there is any missing information that you
can provide, or to see if there is a workaround for the bug.
Additionally, any further discussion regarding the bug should occur in
the other report. Feel free to continue to report any other bugs you may
find.


** This bug has been marked a duplicate of bug 1901115
   package bluez 5.55-0ubuntu1 failed to install/upgrade: installed bluez 
package post-installation script subprocess returned error exit status 1 
[Failed to start Bluetooth service.]

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to bluez in Ubuntu.
https://bugs.launchpad.net/bugs/1904288

Title:
  package bluez 5.53-0ubuntu3 failed to install/upgrade: il
  sottoprocesso installato pacchetto bluez script post-installation ha
  restituito lo stato di errore 1

Status in bluez package in Ubuntu:
  New

Bug description:
  I seguenti pacchetti sono stati installati automaticamente e non sono più 
richiesti:
libbluetooth3-dbg libfprint-2-tod1 libsbc1 linux-headers-5.4.0-47
linux-headers-5.4.0-47-generic linux-image-5.4.0-47-generic
linux-modules-5.4.0-47-generic linux-modules-extra-5.4.0-47-generic
  Usare "sudo apt autoremove" per rimuoverli.
  I seguenti pacchetti saranno RIMOSSI:
bluez* bluez-btsco* bluez-dbg* gnome-bluetooth* pulseaudio-module-bluetooth*
  0 aggiornati, 0 installati, 5 da rimuovere e 93 non aggiornati.
  Dopo quest'operazione, verranno liberati 14,9 MB di spazio su disco.
  Continuare? [S/n] s
  (Lettura del database... 226489 file e directory attualmente installati.)
  Rimozione di pulseaudio-module-bluetooth (1:13.99.1-1ubuntu3.7)...
  Rimozione di gnome-bluetooth (3.34.1-1)...
  Rimozione di bluez-btsco (1:0.50-0ubuntu7)...
  Rimozione di bluez-dbg (5.53-0ubuntu3)...
  Rimozione di bluez (5.53-0ubuntu3)...
  Elaborazione dei trigger per mime-support (3.64ubuntu1)...
  Elaborazione dei trigger per hicolor-icon-theme (0.17-2)...
  Elaborazione dei trigger per gnome-menus (3.36.0-1ubuntu1)...
  Elaborazione dei trigger per man-db (2.9.1-1)...
  Elaborazione dei trigger per dbus (1.12.16-2ubuntu2.1)...
  Elaborazione dei trigger per desktop-file-utils (0.24-1ubuntu3)...
  (Lettura del database... 226307 file e directory attualmente installati.)
  Eliminazione dei file di configurazione di bluez (5.53-0ubuntu3)...
  dpkg: attenzione: nel rimuovere bluez, la directory "/var/lib/bluetooth" è 
risul
  tata non vuota e non viene rimossa
  Elaborazione dei trigger per dbus (1.12.16-2ubuntu2.1)...
  Elaborazione dei trigger per systemd (245.4-4ubuntu3.2)...
  Lettura elenco dei pacchetti... Fatto
  Generazione albero delle dipendenze   
  Lettura informazioni sullo stato... Fatto
  I seguenti pacchetti sono stati installati automaticamente e non sono più 
richiesti:
libbluetooth3-dbg libfprint-2-tod1 libsbc1 linux-headers-5.4.0-47
linux-headers-5.4.0-47-generic linux-image-5.4.0-47-generic
linux-modules-5.4.0-47-generic linux-modules-extra-5.4.0-47-generic
  Usare "sudo apt autoremove" per rimuoverli.
  I seguenti pacchetti NUOVI saranno installati:
bluez
  0 aggiornati, 1 installati, 0 da rimuovere e 93 non aggiornati.
  È necessario scaricare 981 kB di archivi.
  Dopo quest'operazione, verranno occupati 4.910 kB di spazio su disco.
  Scaricamento di:1 http://it.archive.ubuntu.com/ubuntu focal/main amd64 bluez 
amd64 5.53-0ubuntu3 [981 kB]
  Recuperati 981 kB in 1s (985 kB/s)
  Selezionato il pacchetto bluez non precedentemente selezionato.
  (Lettura del database... 226300 file e directory attualmente installati.)
  Preparativi per estrarre .../bluez_5.53-0ubuntu3_amd64.deb...
  Estrazione di bluez (5.53-0ubuntu3)...
  Configurazione di bluez (5.53-0ubuntu3)...
  Created symlink /etc/systemd/system/dbus-org.bluez.service → 
/lib/systemd/system
  /bluetooth.service.
  Created symlink /etc/systemd/system/bluetooth.target.wants/bluetooth.service 
→ /
  lib/systemd/system/bluetooth.service.
  Job for bluetooth.service failed because the control process exited with 
error c
  ode.
  See "systemctl status bluetooth.service" and "journalctl -xe" for details.
  invoke-rc.d: initscript bluetooth, action "start" failed.
  ● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor 
pres
  et: enabled)
  Drop-In: /etc/systemd/system/bluetooth.service.d
   └─override.conf
   Active: activating (auto-restart) (Result: exit-code) since Sat 
2020-11-14 
  16:59:04 CET; 21ms ago
 Docs: man:bluetoothd(8)
  Process: 14788 ExecStart=/usr/lib/bluetooth/bluetoothd --debug -n 
(code=exit
  

[Touch-packages] [Bug 1904288] Re: package bluez 5.53-0ubuntu3 failed to install/upgrade: il sottoprocesso installato pacchetto bluez script post-installation ha restituito lo stato di errore 1

2020-11-15 Thread Alex Murray
Thanks for taking the time to report this bug and helping to make Ubuntu
better. We appreciate the difficulties you are facing, but this appears
to be a "regular" (non-security) bug.  I have unmarked it as a security
issue since this bug does not show evidence of allowing attackers to
cross privilege boundaries nor directly cause loss of data/privacy.
Please feel free to report any other bugs you may find.

** Information type changed from Private Security to Public

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to bluez in Ubuntu.
https://bugs.launchpad.net/bugs/1904288

Title:
  package bluez 5.53-0ubuntu3 failed to install/upgrade: il
  sottoprocesso installato pacchetto bluez script post-installation ha
  restituito lo stato di errore 1

Status in bluez package in Ubuntu:
  New

Bug description:
  I seguenti pacchetti sono stati installati automaticamente e non sono più 
richiesti:
libbluetooth3-dbg libfprint-2-tod1 libsbc1 linux-headers-5.4.0-47
linux-headers-5.4.0-47-generic linux-image-5.4.0-47-generic
linux-modules-5.4.0-47-generic linux-modules-extra-5.4.0-47-generic
  Usare "sudo apt autoremove" per rimuoverli.
  I seguenti pacchetti saranno RIMOSSI:
bluez* bluez-btsco* bluez-dbg* gnome-bluetooth* pulseaudio-module-bluetooth*
  0 aggiornati, 0 installati, 5 da rimuovere e 93 non aggiornati.
  Dopo quest'operazione, verranno liberati 14,9 MB di spazio su disco.
  Continuare? [S/n] s
  (Lettura del database... 226489 file e directory attualmente installati.)
  Rimozione di pulseaudio-module-bluetooth (1:13.99.1-1ubuntu3.7)...
  Rimozione di gnome-bluetooth (3.34.1-1)...
  Rimozione di bluez-btsco (1:0.50-0ubuntu7)...
  Rimozione di bluez-dbg (5.53-0ubuntu3)...
  Rimozione di bluez (5.53-0ubuntu3)...
  Elaborazione dei trigger per mime-support (3.64ubuntu1)...
  Elaborazione dei trigger per hicolor-icon-theme (0.17-2)...
  Elaborazione dei trigger per gnome-menus (3.36.0-1ubuntu1)...
  Elaborazione dei trigger per man-db (2.9.1-1)...
  Elaborazione dei trigger per dbus (1.12.16-2ubuntu2.1)...
  Elaborazione dei trigger per desktop-file-utils (0.24-1ubuntu3)...
  (Lettura del database... 226307 file e directory attualmente installati.)
  Eliminazione dei file di configurazione di bluez (5.53-0ubuntu3)...
  dpkg: attenzione: nel rimuovere bluez, la directory "/var/lib/bluetooth" è 
risul
  tata non vuota e non viene rimossa
  Elaborazione dei trigger per dbus (1.12.16-2ubuntu2.1)...
  Elaborazione dei trigger per systemd (245.4-4ubuntu3.2)...
  Lettura elenco dei pacchetti... Fatto
  Generazione albero delle dipendenze   
  Lettura informazioni sullo stato... Fatto
  I seguenti pacchetti sono stati installati automaticamente e non sono più 
richiesti:
libbluetooth3-dbg libfprint-2-tod1 libsbc1 linux-headers-5.4.0-47
linux-headers-5.4.0-47-generic linux-image-5.4.0-47-generic
linux-modules-5.4.0-47-generic linux-modules-extra-5.4.0-47-generic
  Usare "sudo apt autoremove" per rimuoverli.
  I seguenti pacchetti NUOVI saranno installati:
bluez
  0 aggiornati, 1 installati, 0 da rimuovere e 93 non aggiornati.
  È necessario scaricare 981 kB di archivi.
  Dopo quest'operazione, verranno occupati 4.910 kB di spazio su disco.
  Scaricamento di:1 http://it.archive.ubuntu.com/ubuntu focal/main amd64 bluez 
amd64 5.53-0ubuntu3 [981 kB]
  Recuperati 981 kB in 1s (985 kB/s)
  Selezionato il pacchetto bluez non precedentemente selezionato.
  (Lettura del database... 226300 file e directory attualmente installati.)
  Preparativi per estrarre .../bluez_5.53-0ubuntu3_amd64.deb...
  Estrazione di bluez (5.53-0ubuntu3)...
  Configurazione di bluez (5.53-0ubuntu3)...
  Created symlink /etc/systemd/system/dbus-org.bluez.service → 
/lib/systemd/system
  /bluetooth.service.
  Created symlink /etc/systemd/system/bluetooth.target.wants/bluetooth.service 
→ /
  lib/systemd/system/bluetooth.service.
  Job for bluetooth.service failed because the control process exited with 
error c
  ode.
  See "systemctl status bluetooth.service" and "journalctl -xe" for details.
  invoke-rc.d: initscript bluetooth, action "start" failed.
  ● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor 
pres
  et: enabled)
  Drop-In: /etc/systemd/system/bluetooth.service.d
   └─override.conf
   Active: activating (auto-restart) (Result: exit-code) since Sat 
2020-11-14 
  16:59:04 CET; 21ms ago
 Docs: man:bluetoothd(8)
  Process: 14788 ExecStart=/usr/lib/bluetooth/bluetoothd --debug -n 
(code=exit
  ed, status=1/FAILURE)
 Main PID: 14788 (code=exited, status=1/FAILURE)
   Status: "Starting up"
  dpkg: errore nell'elaborare il pacchetto bluez (--configure):
   il sottoprocesso installato pacchetto bluez script post-installation ha 
restitu
  ito lo stato di errore 1
  Elaborazione dei trigger per systemd (245.4-4ubuntu3.2)...
  Elaborazione dei 

[Touch-packages] [Bug 1901285] Re: After upgrade Wine app can't access internet

2020-11-15 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: dash (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to dash in Ubuntu.
https://bugs.launchpad.net/bugs/1901285

Title:
  After upgrade Wine app can't access internet

Status in dash package in Ubuntu:
  Confirmed

Bug description:
  Software Updater prompted upgrade from 20.04 to 20.10 completed.
  Existing kindle for pc application running via wine launches normally
  but does not connect to internet. Message from application is "Unable
  to Connect" uninstalled and re-installed wine no change.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.10
  Package: dash 0.5.10.2-7
  ProcVersionSignature: Ubuntu 5.8.0-25.26-generic 5.8.14
  Uname: Linux 5.8.0-25-generic x86_64
  ApportVersion: 2.20.11-0ubuntu50
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Sat Oct 24 01:59:42 2020
  InstallationDate: Installed on 2020-04-26 (180 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  SourcePackage: dash
  UpgradeStatus: Upgraded to groovy on 2020-10-24 (0 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dash/+bug/1901285/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1796501] Re: systemd-resolved tries to mitigate DVE-2018-0001 even if DNSSEC=yes

2020-11-15 Thread Ron Johnson
i fixed the issue simply but changing the link from the stub resolver to
just point at resolv.conf with just nameserver lines...

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1796501

Title:
  systemd-resolved tries to mitigate DVE-2018-0001 even if DNSSEC=yes

Status in systemd package in Ubuntu:
  Fix Released
Status in systemd source package in Bionic:
  Fix Released
Status in systemd source package in Cosmic:
  Won't Fix
Status in systemd source package in Disco:
  Fix Released

Bug description:
  [impact]

  an NXDOMAIN response from a dns server when systemd-resolved is
  configured as DNSSEC=yes breaks dns resolution as it downgrades from
  DNSSEC.

  [test case]

  see comment 9

  [regression potential]

  as with the original patch that introduced this problem, this has the
  potential to break dns resolution.

  [other info]

  original description:

  
  I ask systemd-resolved through dig to resolve the SOA of test.asdf. (doesn't 
exist) but it returns SERVFAIL instead of NXDOMAIN. It seems to do the 
following steps:
  1. Ask upstream for SOA of test.asdf. with EDNS0, DO-bit and 4k size.
  2. Ask upstream for SOA of test.asdf. with EDNS0 and DO-bit.
  3. Ask upstream for SOA of test.asdf. with EDNS0.
  4. Ask upstream for SOA of test.asdf. without EDNS0.
  5. Repeat 1-4 for DS of test.asdf.
  6. Repeat 1-5 for asdf.
  7. Ask upstream for SOA of . with EDNS0, DO-bit and 4k size.
  8. Ask upstream for DNSKEY of . with EDNS0, DO-bit and 4k size.

  The upstream returns an unfragmented NXDOMAIN response for steps 1-6,
  an unfragmented NOERROR response for step 7 and a fragmented NOERROR
  response for step 8 which is the correct behaviour. DNSSEC records are
  included in the response if the DO-bit in the request was set.

  systemd-resolved should take the response from step 1 and start with
  validation instead of starting useless retries with reduced feture
  set. Step 3 and 4 are completely useless and probably lead to the
  SERVFAIL because I have configured it with DNSSEC=yes to prevent
  downgrade attacks.

  This regression seems to be caused by the patch resolved-Mitigate-
  DVE-2018-0001-by-retrying-NXDOMAIN-with.patch. The downgrade logic
  should only be executed if it is configured as DNSSEC=allow-downgrade
  or DNSSEC=no. See also
  https://github.com/systemd/systemd/pull/8608#issuecomment-396927885.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1796501/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1818918] Re: gdb doesn't search in debug-file-directory for .gnu_debugaltlink

2020-11-15 Thread Tiago Stürmer Daitx
@sergiodj many thanks for the help here

It was a dwz man page somewhere that made me think we might be misusing
.gnu_debugaltlink somehow (didn't even know about dh_dwz), but on a
quick search I couldn't understand how the path was supposed to look
like so I could test that idea with my replace-altlink-section-hack.

And if GDB can support looking for .dwz on the debug-file-drectory even
with hardcoded paths, all the better.

Many, many thanks for taking the time to look at this and come up with
these 2 solutions. We really appreciate it.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apport in Ubuntu.
https://bugs.launchpad.net/bugs/1818918

Title:
  gdb doesn't search in debug-file-directory for .gnu_debugaltlink

Status in Apport:
  Fix Released
Status in apport package in Ubuntu:
  New
Status in gdb package in Ubuntu:
  Confirmed

Bug description:
  As far as I can tell gdb version 8.2.90 isn't searching the debug-
  file-directory, which I set, for the '.gnu_debugaltlink' which is in
  the debug symbols. Here's the error I'm seeing:

  Type "apropos word" to search for commands related to "word".
  Reading symbols from /srv/vms/apport-sandbox-dir/Ubuntu 
19.04/amd64/report-sandbox//usr/bin/gnome-calculator...
  Reading symbols from /srv/vms/apport-sandbox-dir/Ubuntu 
19.04/amd64/report-sandbox/usr/lib/debug/.build-id/95/59c4c5ee30eb66d47bb9bd64784a69c9a6de6b.debug...
  could not find '.gnu_debugaltlink' file for 
/srv/vms/apport-sandbox-dir/Ubuntu 
19.04/amd64/report-sandbox/usr/lib/debug/.build-id/95/59c4c5ee30eb66d47bb9bd64784a69c9a6de6b.debug
  (No debugging symbols found in /srv/vms/apport-sandbox-dir/Ubuntu 
19.04/amd64/report-sandbox/usr/lib/debug/.build-id/95/59c4c5ee30eb66d47bb9bd64784a69c9a6de6b.debug)

  Here's part of an strace of what's going on behind the scenes:

  lstat("/srv/vms/apport-sandbox-dir/Ubuntu 
19.04/amd64/report-sandbox/usr/lib/debug/.build-id/95/59c4c5ee30eb66d47bb9bd64784a69c9a6de6b.debug",
 {st_mode=S_IFREG|0644, st_size=839744, ...}) = 0 
  openat(AT_FDCWD, 
"/usr/lib/debug/.dwz/x86_64-linux-gnu/gnome-calculator.debug", 
O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)

  This is the only time "/usr/lib/debug" is searched, generally
  "/srv/vms/apport-sandbox-dir/Ubuntu 19.04/amd64/report-
  sandbox/usr/lib/debug/" is used. I'll attach the full strace though.

  For completeness here's the gdb command I'm using:

  Calling gdb command: '/srv/vms/apport-sandbox-dir/Ubuntu 19.04/amd64
  /report-sandbox/lib/x86_64-linux-gnu/ld-linux-x86-64.so.2' '/srv/vms
  /apport-sandbox-dir/Ubuntu 19.04/amd64/report-sandbox/usr/bin/gdb'
  --ex 'set debug-file-directory /srv/vms/apport-sandbox-dir/Ubuntu
  19.04/amd64/report-sandbox/usr/lib/debug' --ex 'set solib-absolute-
  prefix /srv/vms/apport-sandbox-dir/Ubuntu 19.04/amd64/report-sandbox'
  --ex 'add-auto-load-safe-path /srv/vms/apport-sandbox-dir/Ubuntu
  19.04/amd64/report-sandbox' --ex 'set solib-search-path /srv/vms
  /apport-sandbox-dir/Ubuntu 19.04/amd64/report-sandbox/lib/x86_64
  -linux-gnu' --ex 'set data-directory /srv/vms/apport-sandbox-
  dir/Ubuntu 19.04/amd64/report-sandbox/usr/share/gdb' --ex 'file
  "/srv/vms/apport-sandbox-dir/Ubuntu 19.04/amd64/report-
  sandbox//usr/bin/gnome-calculator"' --ex 'core-file
  /tmp/apport_core_1b6dn6np'

To manage notifications about this bug go to:
https://bugs.launchpad.net/apport/+bug/1818918/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1901922] Re: [SRU][Lenovo ThinkPad T14 Gen 1] No sound output device on startup

2020-11-15 Thread Launchpad Bug Tracker
This bug was fixed in the package alsa-lib - 1.2.3.2-1ubuntu4

---
alsa-lib (1.2.3.2-1ubuntu4) hirsute; urgency=medium

  * d/p/0001-ucm-handle-correctly-Linked-configuration.patch
- If the sound card is Linked in the ucm, don't return error
  in the check_empty_configuration(). So far the AMD Ryzen
  machines with acp sound card need this fix, otherwise the
  pulseaudio will fail to load ucm on those machines and the whole
  audio can't work. (LP: #1901922)

 -- Hui Wang   Mon, 09 Nov 2020 06:26:27 +

** Changed in: alsa-lib (Ubuntu Hirsute)
   Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-lib in Ubuntu.
https://bugs.launchpad.net/bugs/1901922

Title:
  [SRU][Lenovo ThinkPad T14 Gen 1] No sound output device on startup

Status in PulseAudio:
  Unknown
Status in alsa-lib package in Ubuntu:
  Fix Released
Status in alsa-ucm-conf package in Ubuntu:
  Fix Released
Status in alsa-lib source package in Focal:
  Fix Committed
Status in alsa-ucm-conf source package in Focal:
  Fix Committed
Status in alsa-lib source package in Groovy:
  Fix Committed
Status in alsa-ucm-conf source package in Groovy:
  Fix Committed
Status in alsa-lib source package in Hirsute:
  Fix Released
Status in alsa-ucm-conf source package in Hirsute:
  Fix Released

Bug description:
  [Impact]
  On the machines with AMD Ryzen acp audio design, the audio can't work
  anymore after upgrading the libasound2 to ubuntu3(groovy)/ubuntu2.1(
  focal), this is a regression on libasound2 for those machines. the AMD
  Ryzen acp audio card needs to load ucm to work with pulseaudio, but
  this audio card doesn't have an independant ucm for it, it needs to
  link to an existing HDA-Intel ucm, the check_empty_configuration() needs
  to cover the situation that Linked is true, otherwise it will fail
  to load the ucm for the audio card. Even the audio card could load the
  ucm, the output is muted and the init output volume is too low if
  freshly install the OS on these machines.

  [Fix]
  Backport 1 alsa-lib patch to fix the failure of loading ucm on AMD
  Ryzen acp audio machines. Backport 4 alsa-ucm-conf patches to fix
  init mute and init output volume problem.

  [Test Case]
  Install the updated libasuond2, rm ~/.config/pulse/*; sudo rm -rf
  /var/lib/alsa/*; sudo sh -c 'echo b > /proc/sysrq-trigger' and run pacmd
  list-cards, we could see the pulseaudio load the ucm successfully and we 
could see
  the sound card is generated and all output and input devices are listed
  under sound card, but the init output is muted and the volume is very low
  if we manually unumte it. Now install the updated alsa-ucm-conf, rm 
~/.config/pulse/*; sudo rm -rf
  /var/lib/alsa/*; sudo sh -c 'echo b > /proc/sysrq-trigger', the output is
  not muted anymore and the output volume is OK to most users.

  [Regression Risk]
  This could make the machines with sof audio driver fail to load ucm
  , then all audio function can't work as before, like the speaker can't
  output sound or the internal mic can't be found or can't record sound.
  But this possibility is very low, I tested this SRU on some machines with or
  without sof audio driver, all worked as well as before.

  
  After logging in, only a dummy device is available for audio playback 
(resulting in no audible playback). When running "pactl load-module 
module-detect" the sound card shows up, and playback works as expected.

  If pulseaudio is restarted with "pulseaudio -k" the playback device
  disappears again. Running the above command get things working again.

  If I change the following section in /etc/pulse/default.pa from:

  ### Automatically load driver modules depending on the hardware available
  .ifexists module-udev-detect.so
  load-module module-udev-detect
  .else
  ### Use the static hardware detection module (for systems that lack udev 
support)
  load-module module-detect
  .endif

  To:

  ### Automatically load driver modules depending on the hardware available
  #.ifexists module-udev-detect.so
  #load-module module-udev-detect
  #.else
  ### Use the static hardware detection module (for systems that lack udev 
support)
  load-module module-detect
  #.endif

  Things start working as they should after running "pulseaudio -k".

  ProblemType: Bug
  DistroRelease: Ubuntu 20.10
  Package: pulseaudio 1:13.99.2-1ubuntu1
  ProcVersionSignature: Ubuntu 5.8.0-26.27-generic 5.8.14
  Uname: Linux 5.8.0-26-generic x86_64
  ApportVersion: 2.20.11-0ubuntu50
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: KDE
  Date: Wed Oct 28 17:21:02 2020
  InstallationDate: Installed on 2020-10-23 (4 days ago)
  InstallationMedia: Kubuntu 20.10 "Groovy Gorilla" - Release amd64 (20201022)
  SourcePackage: pulseaudio
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/07/2020
  dmi.bios.release: 1.9
  

[Touch-packages] [Bug 1904343] [NEW] WiFi Working, Wired connection not.

2020-11-15 Thread John McLovin
Public bug reported:

Yesterday I wanted to move from Windows 10 to Linux (again) but I had
bad luck I guess with the network-manager and its current version.

My WiFi is working without any problems but the Ethernet (wired
connection) is not working. Tried (installed and fully updated) Pop OS
20.10, Kubuntu 20.10, KDE Neon based on 20.04 same problem on all of
them. Not working from Live USB too. Went back to Windows 10 -
everything works without any problems.

Tried some debugging: taking out the cable and plugging it back. No luck.
Restarting the laptop - not working.

Laptop model Acer ES1-512 if it matters. 
acer.com/ac/en/US/content/support-product/5611;-;Aspire%20ES1-512

On network, I have Broadcom and Atheros - not sure which one is for the
ethernet.

P.S: Whine Kubuntu was loading (the text window) I saw with red Failed -
network manager online or something like that, can't really remember the
whole thing.

** Affects: network-manager (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: connection ethernet network network-manager wired

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1904343

Title:
  WiFi Working, Wired connection not.

Status in network-manager package in Ubuntu:
  New

Bug description:
  Yesterday I wanted to move from Windows 10 to Linux (again) but I had
  bad luck I guess with the network-manager and its current version.

  My WiFi is working without any problems but the Ethernet (wired
  connection) is not working. Tried (installed and fully updated) Pop OS
  20.10, Kubuntu 20.10, KDE Neon based on 20.04 same problem on all of
  them. Not working from Live USB too. Went back to Windows 10 -
  everything works without any problems.

  Tried some debugging: taking out the cable and plugging it back. No luck.
  Restarting the laptop - not working.

  Laptop model Acer ES1-512 if it matters. 
  acer.com/ac/en/US/content/support-product/5611;-;Aspire%20ES1-512

  On network, I have Broadcom and Atheros - not sure which one is for
  the ethernet.

  P.S: Whine Kubuntu was loading (the text window) I saw with red Failed
  - network manager online or something like that, can't really remember
  the whole thing.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1904343/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1904321] Re: does not work as it should " systemctl edit service"

2020-11-15 Thread Dan Streetman
without your manually-created dropin file (with only the override.conf
file), check output of

$ systemctl cat elasticsearch

** Changed in: systemd (Ubuntu)
   Status: New => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1904321

Title:
  does not work as it should " systemctl edit service"

Status in systemd package in Ubuntu:
  Incomplete

Bug description:
  1. `systemctl edit service(elasticsearch)`
  That creates file `/etc/systemd/system/elasticsearch.service.d/override.conf`

  And I've added following section there:

  [Service]
  LimitMEMLOCK=infinity
  LimitNPROC=32768
  LimitNOFILE=25

  
  3. I've executed `systemctl daemon-reload; systemctl stop elasticsearch; 
systemctl start elasticsearch`

  However those parameters were not applied to a newly started service
  and I got an error "memory locking requested for elasticsearch process
  but memory is not locked".

  To workaround I've created a file
  `/etc/systemd/system/elasticsearch.service.d/elasticsearch.conf` with
  the same content and that fixed the problem.

  
  ubuntu 18.04, all updates are installed

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1904321/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1901922] Re: [SRU][Lenovo ThinkPad T14 Gen 1] No sound output device on startup

2020-11-15 Thread Nick Price
** Tags removed: verification-needed-focal
** Tags added: verification-done-focal

** Tags removed: verification-needed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-lib in Ubuntu.
https://bugs.launchpad.net/bugs/1901922

Title:
  [SRU][Lenovo ThinkPad T14 Gen 1] No sound output device on startup

Status in PulseAudio:
  Unknown
Status in alsa-lib package in Ubuntu:
  Fix Committed
Status in alsa-ucm-conf package in Ubuntu:
  Fix Released
Status in alsa-lib source package in Focal:
  Fix Committed
Status in alsa-ucm-conf source package in Focal:
  Fix Committed
Status in alsa-lib source package in Groovy:
  Fix Committed
Status in alsa-ucm-conf source package in Groovy:
  Fix Committed
Status in alsa-lib source package in Hirsute:
  Fix Committed
Status in alsa-ucm-conf source package in Hirsute:
  Fix Released

Bug description:
  [Impact]
  On the machines with AMD Ryzen acp audio design, the audio can't work
  anymore after upgrading the libasound2 to ubuntu3(groovy)/ubuntu2.1(
  focal), this is a regression on libasound2 for those machines. the AMD
  Ryzen acp audio card needs to load ucm to work with pulseaudio, but
  this audio card doesn't have an independant ucm for it, it needs to
  link to an existing HDA-Intel ucm, the check_empty_configuration() needs
  to cover the situation that Linked is true, otherwise it will fail
  to load the ucm for the audio card. Even the audio card could load the
  ucm, the output is muted and the init output volume is too low if
  freshly install the OS on these machines.

  [Fix]
  Backport 1 alsa-lib patch to fix the failure of loading ucm on AMD
  Ryzen acp audio machines. Backport 4 alsa-ucm-conf patches to fix
  init mute and init output volume problem.

  [Test Case]
  Install the updated libasuond2, rm ~/.config/pulse/*; sudo rm -rf
  /var/lib/alsa/*; sudo sh -c 'echo b > /proc/sysrq-trigger' and run pacmd
  list-cards, we could see the pulseaudio load the ucm successfully and we 
could see
  the sound card is generated and all output and input devices are listed
  under sound card, but the init output is muted and the volume is very low
  if we manually unumte it. Now install the updated alsa-ucm-conf, rm 
~/.config/pulse/*; sudo rm -rf
  /var/lib/alsa/*; sudo sh -c 'echo b > /proc/sysrq-trigger', the output is
  not muted anymore and the output volume is OK to most users.

  [Regression Risk]
  This could make the machines with sof audio driver fail to load ucm
  , then all audio function can't work as before, like the speaker can't
  output sound or the internal mic can't be found or can't record sound.
  But this possibility is very low, I tested this SRU on some machines with or
  without sof audio driver, all worked as well as before.

  
  After logging in, only a dummy device is available for audio playback 
(resulting in no audible playback). When running "pactl load-module 
module-detect" the sound card shows up, and playback works as expected.

  If pulseaudio is restarted with "pulseaudio -k" the playback device
  disappears again. Running the above command get things working again.

  If I change the following section in /etc/pulse/default.pa from:

  ### Automatically load driver modules depending on the hardware available
  .ifexists module-udev-detect.so
  load-module module-udev-detect
  .else
  ### Use the static hardware detection module (for systems that lack udev 
support)
  load-module module-detect
  .endif

  To:

  ### Automatically load driver modules depending on the hardware available
  #.ifexists module-udev-detect.so
  #load-module module-udev-detect
  #.else
  ### Use the static hardware detection module (for systems that lack udev 
support)
  load-module module-detect
  #.endif

  Things start working as they should after running "pulseaudio -k".

  ProblemType: Bug
  DistroRelease: Ubuntu 20.10
  Package: pulseaudio 1:13.99.2-1ubuntu1
  ProcVersionSignature: Ubuntu 5.8.0-26.27-generic 5.8.14
  Uname: Linux 5.8.0-26-generic x86_64
  ApportVersion: 2.20.11-0ubuntu50
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: KDE
  Date: Wed Oct 28 17:21:02 2020
  InstallationDate: Installed on 2020-10-23 (4 days ago)
  InstallationMedia: Kubuntu 20.10 "Groovy Gorilla" - Release amd64 (20201022)
  SourcePackage: pulseaudio
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/07/2020
  dmi.bios.release: 1.9
  dmi.bios.vendor: LENOVO
  dmi.bios.version: R1BET40W(1.09 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20UDCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Defined
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.ec.firmware.release: 1.9
  dmi.modalias: 

[Touch-packages] [Bug 1871794] Re: [Bluetooth] No audio output/input in HSP/HFP mode

2020-11-15 Thread smurf
Ok, I upgraded to 20.10, but in my case there are no changes, I see exactly the 
same behavior than in 20.04 .
I would appreciate a lot a bit of help.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1871794

Title:
  [Bluetooth] No audio output/input in HSP/HFP mode

Status in bluez package in Ubuntu:
  Confirmed
Status in pulseaudio package in Ubuntu:
  Confirmed

Bug description:
  I'm testing with Sony bluetooth headset SBH20, works fine in A2DP
  profile, but I can't get audio input and output work in HSP/HFP
  profile.

  [Reproduce steps]
  1. Scan and pair BT headset in Bluetooth setting
  2. Switch to HSP/HFP profile in Sound setting
  3. Test sound output/input

  [Machine information]
  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: pulseaudio 1:13.99.1-1ubuntu1
  ProcVersionSignature: Ubuntu 5.4.0-21.25-generic 5.4.27
  Uname: Linux 5.4.0-21-generic x86_64
  ApportVersion: 2.20.11-0ubuntu25
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  ubuntu 1359 F pulseaudio
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Apr  9 16:26:52 2020
  InstallationDate: Installed on 2020-04-09 (0 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Beta amd64 (20200402)
  SourcePackage: pulseaudio
  Symptom: audio
  Symptom_Card: SBH20
  Symptom_DevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  ubuntu 1359 F pulseaudio
  Symptom_Type: No sound at all
  Title: [SBH20, recording] No sound at all
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 09/17/2019
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.0.13
  dmi.board.name: 0188D1
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 31
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvr1.0.13:bd09/17/2019:svnDellInc.:pnXPS1373902-in-1:pvr:rvnDellInc.:rn0188D1:rvrA00:cvnDellInc.:ct31:cvr:
  dmi.product.family: XPS
  dmi.product.name: XPS 13 7390 2-in-1
  dmi.product.sku: 08B0
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1871794/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1904334] [NEW] [Audigy2 - SB Audigy 5/Rx [SB1550], playback] No sound at all

2020-11-15 Thread jayanarayanan
Public bug reported:

no sound at all. i am using creative soundblaster sound card

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: alsa-base 1.0.25+dfsg-0ubuntu5
ProcVersionSignature: Ubuntu 5.4.0-53.59-generic 5.4.65
Uname: Linux 5.4.0-53-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.11-0ubuntu27.12
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Sun Nov 15 21:52:15 2020
InstallationDate: Installed on 2020-11-14 (1 days ago)
InstallationMedia: Ubuntu 20.04.1 LTS "Focal Fossa" - Release amd64 (20200731)
PackageArchitecture: all
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:Audigy2 successful
Symptom_Card: GK208 HDMI/DP Audio Controller - HDA NVidia
Symptom_PulsePlaybackTest: PulseAudio playback test successful
Symptom_SpeakerTestPulseStderr:
 W r i t e   e r r o r :   - 3 2 , B r o k e n   p i p e 
  W r i t e   e r r o r :   - 3 2 , B r o k e n   p i p e 
  W r i t e   e r r o r :   - 3 2 , B r o k e n   p i p e
Symptom_Type: No sound at all
Title: [Audigy2 - SB Audigy 5/Rx [SB1550], playback] No sound at all
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/24/2011
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F7 DL
dmi.board.name: G41MT-S2
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: 
dmi:bvnAwardSoftwareInternational,Inc.:bvrF7DL:bd10/24/2011:svnGigabyteTechnologyCo.,Ltd.:pnG41MT-S2:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnG41MT-S2:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: G41MT-S2
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

** Affects: alsa-driver (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug focal

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1904334

Title:
  [Audigy2 - SB Audigy 5/Rx [SB1550], playback] No sound at all

Status in alsa-driver package in Ubuntu:
  New

Bug description:
  no sound at all. i am using creative soundblaster sound card

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: alsa-base 1.0.25+dfsg-0ubuntu5
  ProcVersionSignature: Ubuntu 5.4.0-53.59-generic 5.4.65
  Uname: Linux 5.4.0-53-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  ApportVersion: 2.20.11-0ubuntu27.12
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Sun Nov 15 21:52:15 2020
  InstallationDate: Installed on 2020-11-14 (1 days ago)
  InstallationMedia: Ubuntu 20.04.1 LTS "Focal Fossa" - Release amd64 (20200731)
  PackageArchitecture: all
  SourcePackage: alsa-driver
  Symptom: audio
  Symptom_AlsaPlaybackTest: ALSA playback test through plughw:Audigy2 successful
  Symptom_Card: GK208 HDMI/DP Audio Controller - HDA NVidia
  Symptom_PulsePlaybackTest: PulseAudio playback test successful
  Symptom_SpeakerTestPulseStderr:
   W r i t e   e r r o r :   - 3 2 , B r o k e n   p i p e 
W r i t e   e r r o r :   - 3 2 , B r o k e n   p i p e 
W r i t e   e r r o r :   - 3 2 , B r o k e n   p i p e
  Symptom_Type: No sound at all
  Title: [Audigy2 - SB Audigy 5/Rx [SB1550], playback] No sound at all
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 10/24/2011
  dmi.bios.vendor: Award Software International, Inc.
  dmi.bios.version: F7 DL
  dmi.board.name: G41MT-S2
  dmi.board.vendor: Gigabyte Technology Co., Ltd.
  dmi.board.version: x.x
  dmi.chassis.type: 3
  dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
  dmi.modalias: 
dmi:bvnAwardSoftwareInternational,Inc.:bvrF7DL:bd10/24/2011:svnGigabyteTechnologyCo.,Ltd.:pnG41MT-S2:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnG41MT-S2:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
  dmi.product.name: G41MT-S2
  dmi.sys.vendor: Gigabyte Technology Co., Ltd.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1904334/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1808421] Re: gparted produces unusual results when ZFS partitios exist

2020-11-15 Thread Peter Passchier
It seems gparted is interpreting data from blkid. In this case, when
PTTYPE is 'gpt', that should just take precedence over TYPE being
'zfs_member'.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to util-linux in Ubuntu.
https://bugs.launchpad.net/bugs/1808421

Title:
  gparted produces unusual results when ZFS partitios exist

Status in GParted:
  New
Status in gparted package in Ubuntu:
  Confirmed
Status in util-linux package in Ubuntu:
  Confirmed

Bug description:
  Run gparted on a disk that has ZFS partitions. It shows one entire
  partition. Parted seems to display correctly. gparted image attached.

  hbarta@saugage:~$ sudo parted /dev/sda
  GNU Parted 3.2
  Using /dev/sda
  Welcome to GNU Parted! Type 'help' to view a list of commands.
  (parted) p
  Model: ATA Samsung SSD 850 (scsi)
  Disk /dev/sda: 1000GB
  Sector size (logical/physical): 512B/512B
  Partition Table: gpt
  Disk Flags: 

  Number  Start   EndSizeFile system  Name  
Flags
   1  1049kB  538MB  537MB   fat32  
boot, esp
   2  538MB   555MB  16.8MB  zfs  Microsoft reserved partition  
msftres
   3  555MB   105GB  105GB   ntfs Basic data partition  
msftdata
   4  105GB   420GB  315GB   zfs  rpool

  (parted) q
  hbarta@saugage:~$ 

  hbarta@saugage:~$ sudo sgdisk -p /dev/sda
  Disk /dev/sda: 1953525168 sectors, 931.5 GiB
  Model: Samsung SSD 850 
  Sector size (logical/physical): 512/512 bytes
  Disk identifier (GUID): EBA09D2E-0F70-4D11-8E37-C1C170CFD9DD
  Partition table holds up to 128 entries
  Main partition table begins at sector 2 and ends at sector 33
  First usable sector is 34, last usable sector is 1953525134
  Partitions will be aligned on 2048-sector boundaries
  Total free space is 1133243757 sectors (540.4 GiB)

  Number  Start (sector)End (sector)  Size   Code  Name
 12048 1050623   512.0 MiB   EF00  
 2 1050624 1083391   16.0 MiB0C01  Microsoft reserved 
...
 3 1083392   205883391   97.7 GiB0700  Basic data partition
 4   205883392   820283391   293.0 GiB   8300  rpool
  hbarta@saugage:~$

  hbarta@saugage:~$ lsb_release -rd
  Description:  Ubuntu 18.10
  Release:  18.10
  hbarta@saugage:~$ 

  Reproduce: 
  1) Configure (perhaps install) Ubuntu on a drive with a ZFS partition.
  2) Open gparted.

  Note: Same issue happens with gparted on the 18.04.1 desktop install
  USB.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.10
  Package: gparted 0.32.0-1ubuntu1
  ProcVersionSignature: Ubuntu 4.18.0-12.13-generic 4.18.17
  Uname: Linux 4.18.0-12-generic x86_64
  NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
  ApportVersion: 2.20.10-0ubuntu13.1
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Dec 13 15:05:13 2018
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US
   SHELL=/bin/bash
  SourcePackage: gparted
  UpgradeStatus: Upgraded to cosmic on 2018-12-13 (0 days ago)
  mtime.conffile..etc.logrotate.d.apport: 2018-12-12T13:31:49.347693

To manage notifications about this bug go to:
https://bugs.launchpad.net/gparted/+bug/1808421/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1904332] Re: no sound issue

2020-11-15 Thread Ubuntu Foundations Team Bug Bot
** Package changed: ubuntu => pulseaudio (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1904332

Title:
  no sound issue

Status in pulseaudio package in Ubuntu:
  New

Bug description:
  I have a ubuntu budgie environment. Though the speakers (hardware) are
  detected, no sound is audible despite the volume levels being maximum.
  I performed tests in the sound settings window, so the issue does not
  seem to be specific to a particular application

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: pulseaudio 1:13.99.1-1ubuntu3.5
  ProcVersionSignature: Ubuntu 5.4.0-53.59-generic 5.4.65
  Uname: Linux 5.4.0-53-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.4
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  berry  1239 F pulseaudio
  CasperMD5CheckResult: skip
  CurrentDesktop: Budgie:GNOME
  Date: Sun Nov 15 21:07:24 2020
  InstallationDate: Installed on 2020-11-15 (0 days ago)
  InstallationMedia: Ubuntu-Budgie 20.04.1 LTS "Focal Fossa" - Release amd64 
(20200731)
  SourcePackage: pulseaudio
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 06/11/2020
  dmi.bios.vendor: Insyde
  dmi.bios.version: F.08
  dmi.board.asset.tag: Type2 - Board Asset Tag
  dmi.board.name: 866E
  dmi.board.vendor: HP
  dmi.board.version: 90.08
  dmi.chassis.asset.tag: Chassis Asset Tag
  dmi.chassis.type: 31
  dmi.chassis.vendor: HP
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnInsyde:bvrF.08:bd06/11/2020:svnHP:pnHPPavilionx360Convertible14-dh1xxx:pvrType1ProductConfigId:rvnHP:rn866E:rvr90.08:cvnHP:ct31:cvrChassisVersion:
  dmi.product.family: 103C_5335KV HP Pavilion
  dmi.product.name: HP Pavilion x360 Convertible 14-dh1xxx
  dmi.product.sku: 231T1PA#ACJ
  dmi.product.version: Type1ProductConfigId
  dmi.sys.vendor: HP

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1904332/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1904332] [NEW] no sound issue

2020-11-15 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

I have a ubuntu budgie environment. Though the speakers (hardware) are
detected, no sound is audible despite the volume levels being maximum. I
performed tests in the sound settings window, so the issue does not seem
to be specific to a particular application

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: pulseaudio 1:13.99.1-1ubuntu3.5
ProcVersionSignature: Ubuntu 5.4.0-53.59-generic 5.4.65
Uname: Linux 5.4.0-53-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.4
Architecture: amd64
AudioDevicesInUse:
 USERPID ACCESS COMMAND
 /dev/snd/controlC0:  berry  1239 F pulseaudio
CasperMD5CheckResult: skip
CurrentDesktop: Budgie:GNOME
Date: Sun Nov 15 21:07:24 2020
InstallationDate: Installed on 2020-11-15 (0 days ago)
InstallationMedia: Ubuntu-Budgie 20.04.1 LTS "Focal Fossa" - Release amd64 
(20200731)
SourcePackage: pulseaudio
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/11/2020
dmi.bios.vendor: Insyde
dmi.bios.version: F.08
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: 866E
dmi.board.vendor: HP
dmi.board.version: 90.08
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 31
dmi.chassis.vendor: HP
dmi.chassis.version: Chassis Version
dmi.modalias: 
dmi:bvnInsyde:bvrF.08:bd06/11/2020:svnHP:pnHPPavilionx360Convertible14-dh1xxx:pvrType1ProductConfigId:rvnHP:rn866E:rvr90.08:cvnHP:ct31:cvrChassisVersion:
dmi.product.family: 103C_5335KV HP Pavilion
dmi.product.name: HP Pavilion x360 Convertible 14-dh1xxx
dmi.product.sku: 231T1PA#ACJ
dmi.product.version: Type1ProductConfigId
dmi.sys.vendor: HP

** Affects: pulseaudio (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug focal
-- 
no sound issue
https://bugs.launchpad.net/bugs/1904332
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to pulseaudio in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1904330] [NEW] package linux-firmware 1.187.4 failed to install/upgrade: installed linux-firmware package post-installation script subprocess returned error exit status 1

2020-11-15 Thread edwardparker
Public bug reported:

soon after reboot and apt upgrade

ProblemType: Package
DistroRelease: Ubuntu 20.04
Package: linux-firmware 1.187.4
ProcVersionSignature: Ubuntu 5.4.0-53.59-generic 5.4.65
Uname: Linux 5.4.0-53-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.12
Architecture: amd64
AudioDevicesInUse:
 USERPID ACCESS COMMAND
 /dev/snd/controlC0:  edward 1603 F pulseaudio
CasperMD5CheckResult: skip
Date: Sun Nov 15 15:07:04 2020
Dependencies:
 
ErrorMessage: installed linux-firmware package post-installation script 
subprocess returned error exit status 1
InstallationDate: Installed on 2020-04-24 (205 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
MachineType: LENOVO 252282G
PackageArchitecture: all
ProcFB: 0 i915drmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-5.4.0-53-generic 
root=UUID=b89589af-856e-46c0-a52b-718dac23f4af ro quiet splash vt.handoff=7
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
Python3Details: /usr/bin/python3.8, Python 3.8.5, python3-minimal, 
3.8.2-0ubuntu2
PythonDetails: N/A
RelatedPackageVersions: grub-pc 2.04-1ubuntu26.6
SourcePackage: initramfs-tools
Title: package linux-firmware 1.187.4 failed to install/upgrade: installed 
linux-firmware package post-installation script subprocess returned error exit 
status 1
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/25/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6IET74WW (1.34 )
dmi.board.name: 252282G
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: 
dmi:bvnLENOVO:bvr6IET74WW(1.34):bd10/25/2010:svnLENOVO:pn252282G:pvrThinkPadT410:rvnLENOVO:rn252282G:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.family: ThinkPad T410
dmi.product.name: 252282G
dmi.product.version: ThinkPad T410
dmi.sys.vendor: LENOVO

** Affects: initramfs-tools (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package focal

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1904330

Title:
  package linux-firmware 1.187.4 failed to install/upgrade: installed
  linux-firmware package post-installation script subprocess returned
  error exit status 1

Status in initramfs-tools package in Ubuntu:
  New

Bug description:
  soon after reboot and apt upgrade

  ProblemType: Package
  DistroRelease: Ubuntu 20.04
  Package: linux-firmware 1.187.4
  ProcVersionSignature: Ubuntu 5.4.0-53.59-generic 5.4.65
  Uname: Linux 5.4.0-53-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.12
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  edward 1603 F pulseaudio
  CasperMD5CheckResult: skip
  Date: Sun Nov 15 15:07:04 2020
  Dependencies:
   
  ErrorMessage: installed linux-firmware package post-installation script 
subprocess returned error exit status 1
  InstallationDate: Installed on 2020-04-24 (205 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  MachineType: LENOVO 252282G
  PackageArchitecture: all
  ProcFB: 0 i915drmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-5.4.0-53-generic 
root=UUID=b89589af-856e-46c0-a52b-718dac23f4af ro quiet splash vt.handoff=7
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
  Python3Details: /usr/bin/python3.8, Python 3.8.5, python3-minimal, 
3.8.2-0ubuntu2
  PythonDetails: N/A
  RelatedPackageVersions: grub-pc 2.04-1ubuntu26.6
  SourcePackage: initramfs-tools
  Title: package linux-firmware 1.187.4 failed to install/upgrade: installed 
linux-firmware package post-installation script subprocess returned error exit 
status 1
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 10/25/2010
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 6IET74WW (1.34 )
  dmi.board.name: 252282G
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Available
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: 
dmi:bvnLENOVO:bvr6IET74WW(1.34):bd10/25/2010:svnLENOVO:pn252282G:pvrThinkPadT410:rvnLENOVO:rn252282G:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.family: ThinkPad T410
  dmi.product.name: 252282G
  dmi.product.version: ThinkPad T410
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1904330/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help 

[Touch-packages] [Bug 1901922] Re: [SRU][Lenovo ThinkPad T14 Gen 1] No sound output device on startup

2020-11-15 Thread cgampert
Hello, the focal-proposed 1.2.2-2.1ubuntu2.2 package solved the issue as
far I could test; indeed, the audio output device was present after the
multiple reboots or boot-ups I did.

System: yoga slim 7 4800u / ubuntu 20.04

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-lib in Ubuntu.
https://bugs.launchpad.net/bugs/1901922

Title:
  [SRU][Lenovo ThinkPad T14 Gen 1] No sound output device on startup

Status in PulseAudio:
  Unknown
Status in alsa-lib package in Ubuntu:
  Fix Committed
Status in alsa-ucm-conf package in Ubuntu:
  Fix Released
Status in alsa-lib source package in Focal:
  Fix Committed
Status in alsa-ucm-conf source package in Focal:
  Fix Committed
Status in alsa-lib source package in Groovy:
  Fix Committed
Status in alsa-ucm-conf source package in Groovy:
  Fix Committed
Status in alsa-lib source package in Hirsute:
  Fix Committed
Status in alsa-ucm-conf source package in Hirsute:
  Fix Released

Bug description:
  [Impact]
  On the machines with AMD Ryzen acp audio design, the audio can't work
  anymore after upgrading the libasound2 to ubuntu3(groovy)/ubuntu2.1(
  focal), this is a regression on libasound2 for those machines. the AMD
  Ryzen acp audio card needs to load ucm to work with pulseaudio, but
  this audio card doesn't have an independant ucm for it, it needs to
  link to an existing HDA-Intel ucm, the check_empty_configuration() needs
  to cover the situation that Linked is true, otherwise it will fail
  to load the ucm for the audio card. Even the audio card could load the
  ucm, the output is muted and the init output volume is too low if
  freshly install the OS on these machines.

  [Fix]
  Backport 1 alsa-lib patch to fix the failure of loading ucm on AMD
  Ryzen acp audio machines. Backport 4 alsa-ucm-conf patches to fix
  init mute and init output volume problem.

  [Test Case]
  Install the updated libasuond2, rm ~/.config/pulse/*; sudo rm -rf
  /var/lib/alsa/*; sudo sh -c 'echo b > /proc/sysrq-trigger' and run pacmd
  list-cards, we could see the pulseaudio load the ucm successfully and we 
could see
  the sound card is generated and all output and input devices are listed
  under sound card, but the init output is muted and the volume is very low
  if we manually unumte it. Now install the updated alsa-ucm-conf, rm 
~/.config/pulse/*; sudo rm -rf
  /var/lib/alsa/*; sudo sh -c 'echo b > /proc/sysrq-trigger', the output is
  not muted anymore and the output volume is OK to most users.

  [Regression Risk]
  This could make the machines with sof audio driver fail to load ucm
  , then all audio function can't work as before, like the speaker can't
  output sound or the internal mic can't be found or can't record sound.
  But this possibility is very low, I tested this SRU on some machines with or
  without sof audio driver, all worked as well as before.

  
  After logging in, only a dummy device is available for audio playback 
(resulting in no audible playback). When running "pactl load-module 
module-detect" the sound card shows up, and playback works as expected.

  If pulseaudio is restarted with "pulseaudio -k" the playback device
  disappears again. Running the above command get things working again.

  If I change the following section in /etc/pulse/default.pa from:

  ### Automatically load driver modules depending on the hardware available
  .ifexists module-udev-detect.so
  load-module module-udev-detect
  .else
  ### Use the static hardware detection module (for systems that lack udev 
support)
  load-module module-detect
  .endif

  To:

  ### Automatically load driver modules depending on the hardware available
  #.ifexists module-udev-detect.so
  #load-module module-udev-detect
  #.else
  ### Use the static hardware detection module (for systems that lack udev 
support)
  load-module module-detect
  #.endif

  Things start working as they should after running "pulseaudio -k".

  ProblemType: Bug
  DistroRelease: Ubuntu 20.10
  Package: pulseaudio 1:13.99.2-1ubuntu1
  ProcVersionSignature: Ubuntu 5.8.0-26.27-generic 5.8.14
  Uname: Linux 5.8.0-26-generic x86_64
  ApportVersion: 2.20.11-0ubuntu50
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: KDE
  Date: Wed Oct 28 17:21:02 2020
  InstallationDate: Installed on 2020-10-23 (4 days ago)
  InstallationMedia: Kubuntu 20.10 "Groovy Gorilla" - Release amd64 (20201022)
  SourcePackage: pulseaudio
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/07/2020
  dmi.bios.release: 1.9
  dmi.bios.vendor: LENOVO
  dmi.bios.version: R1BET40W(1.09 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20UDCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Defined
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.ec.firmware.release: 1.9
  dmi.modalias: 

[Touch-packages] [Bug 1904325] [NEW] half the steam games won't launch.

2020-11-15 Thread Hans-Josoep Hanson
Public bug reported:

games launch only by using LIBGL_ALWAYS_SOFTWARE=1 %command% in game
launch options. These games used to run fine on an older linux mint
version, but now they won't launch no matter if i use lubuntu or lxde.
only LIBGL_ALWAYS_SOFTWARE=1 %command% helps, but it significantly slows
down the game. All the graphics drivers should be up to date. i am using
Ubuntu 18.04.5 LTS

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xorg 1:7.7+19ubuntu7.1
ProcVersionSignature: Ubuntu 4.15.0-123.126-generic 4.15.18
Uname: Linux 4.15.0-123-generic i686
NonfreeKernelModules: wl
ApportVersion: 2.20.9-0ubuntu7.20
Architecture: i386
CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CurrentDesktop: LXDE
Date: Sun Nov 15 16:18:40 2020
DistroCodename: bionic
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 6.30.223.271+bdcom, 4.15.0-122-generic, i686: installed
 bcmwl, 6.30.223.271+bdcom, 4.15.0-123-generic, i686: installed
 bcmwl, 6.30.223.271+bdcom, 4.15.0-60-generic, i686: installed
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics 
Controller [8086:a011] (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Atom Processor D4xx/D5xx/N4xx/N5xx 
Integrated Graphics Controller [103c:1584]
   Subsystem: Hewlett-Packard Company Atom Processor D4xx/D5xx/N4xx/N5xx 
Integrated Graphics Controller [103c:1584]
InstallationDate: Installed on 2020-11-07 (8 days ago)
InstallationMedia: LXLE 18.04 - Release i386
MachineType: Hewlett-Packard HP Mini 210-2000
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-123-generic 
root=/dev/mapper/qwerty--vg-root ro quiet splash
SourcePackage: xorg
UpgradeStatus: Upgraded to bionic on 2019-09-08 (434 days ago)
dmi.bios.date: 03/14/2012
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.25
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 1584
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 85.37
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: 
dmi:bvnHewlett-Packard:bvrF.25:bd03/14/2012:svnHewlett-Packard:pnHPMini210-2000:pvr059010202B0300100:rvnHewlett-Packard:rn1584:rvr85.37:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.family: 103C_5335KV
dmi.product.name: HP Mini 210-2000
dmi.product.version: 059010202B0300100
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.101-2~18.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~18.04.1
version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.8-0ubuntu1~18.04.1
version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4.7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.5-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.0.1-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20171229-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: apport-bug bionic i386 ubuntu

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1904325

Title:
  half the steam games won't launch.

Status in xorg package in Ubuntu:
  New

Bug description:
  games launch only by using LIBGL_ALWAYS_SOFTWARE=1 %command% in game
  launch options. These games used to run fine on an older linux mint
  version, but now they won't launch no matter if i use lubuntu or lxde.
  only LIBGL_ALWAYS_SOFTWARE=1 %command% helps, but it significantly
  slows down the game. All the graphics drivers should be up to date. i
  am using Ubuntu 18.04.5 LTS

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: xorg 1:7.7+19ubuntu7.1
  ProcVersionSignature: Ubuntu 4.15.0-123.126-generic 4.15.18
  Uname: Linux 4.15.0-123-generic i686
  NonfreeKernelModules: wl
  ApportVersion: 2.20.9-0ubuntu7.20
  Architecture: i386
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: LXDE
  Date: Sun Nov 15 16:18:40 2020
  DistroCodename: bionic
  DistroVariant: ubuntu
  DkmsStatus:
   bcmwl, 6.30.223.271+bdcom, 4.15.0-122-generic, i686: installed
   bcmwl, 6.30.223.271+bdcom, 4.15.0-123-generic, i686: installed
   bcmwl, 6.30.223.271+bdcom, 4.15.0-60-generic, i686: installed
  ExtraDebuggingInterest: Yes, if not too technical
  GraphicsCard:
   Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics 
Controller [8086:a011] (prog-if 00 [VGA controller])
 Subsystem: Hewlett-Packard Company Atom Processor D4xx/D5xx/N4xx/N5xx 
Integrated Graphics Controller [103c:1584]
 Subsystem: Hewlett-Packard Company Atom Processor D4xx/D5xx/N4xx/N5xx 
Integrated Graphics Controller 

[Touch-packages] [Bug 1777070] Re: firefox plugin libwidevinecdm.so crashes due to apparmor denial

2020-11-15 Thread Christian Boltz
> The second rule allows firefox to load and run code from that location.
> But doesn't allow firefox to write to it. So if there is malware [...]

That's correct for the added rule, but the profile also has

owner @{HOME}/.{firefox,mozilla}/** rw,

which means firefox _can_ write to that location.

However, this doesn't make the new rule for @{HOME}/.mozilla/firefox
/*/gmp-widevinecdm/*/lib*so m, too bad because the profile also allows m
for plugins already.

owner @{HOME}/.{firefox,mozilla}/plugins/** rm,
owner @{HOME}/.{firefox,mozilla}/**/plugins/** rm,

which already allows to run code from more writeable locations.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apparmor in Ubuntu.
https://bugs.launchpad.net/bugs/1777070

Title:
  firefox plugin libwidevinecdm.so crashes due to apparmor denial

Status in apparmor package in Ubuntu:
  Confirmed
Status in firefox package in Ubuntu:
  Confirmed

Bug description:
  Ubuntu 18.04, Firefox 60.0.1+build2-0ubuntu0.18.04.1

  Running firefix, then going to netflix.com and attempting to play a
  movie.  The widevinecdm plugin crashes, the following is found in
  syslog:

  
  Jun 15 19:13:22 xplt kernel: [301351.553043] audit: type=1400 
audit(1529046802.585:246): apparmor="DENIED" operation="file_mmap" 
profile="/usr/lib/firefox/firefox{,*[^s][^h]}" 
name="/home/xav/.mozilla/firefox/wiavokxk.default-1510977878171/gmp-widevinecdm/1.4.8.1008/libwidevinecdm.so"
 pid=16118 comm="plugin-containe" requested_mask="m" denied_mask="m" fsuid=1000 
ouid=1000
  Jun 15 19:13:22 xplt kernel: [301351.553236] audit: type=1400 
audit(1529046802.585:247): apparmor="DENIED" operation="ptrace" 
profile="/usr/lib/firefox/firefox{,*[^s][^h]}" pid=24714 comm="firefox" 
requested_mask="trace" denied_mask="trace" 
peer="/usr/lib/firefox/firefox{,*[^s][^h]}"
  Jun 15 19:13:22 xplt kernel: [301351.553259] plugin-containe[16118]: segfault 
at 0 ip 7fcdfdaa76af sp 7ffc1ff03e28 error 6 in 
libxul.so[7fcdfb77a000+6111000]
  Jun 15 19:13:22 xplt snmpd[2334]: error on subcontainer 'ia_addr' insert (-1)
  Jun 15 19:13:22 xplt /usr/lib/gdm3/gdm-x-session[6549]: ###!!! 
[Parent][MessageChannel::Call] Error: Channel error: cannot send/recv
  Jun 15 19:13:24 xplt kernel: [301353.960182] audit: type=1400 
audit(1529046804.994:248): apparmor="DENIED" operation="file_mmap" 
profile="/usr/lib/firefox/firefox{,*[^s][^h]}" 
name="/home/xav/.mozilla/firefox/wiavokxk.default-1510977878171/gmp-widevinecdm/1.4.8.1008/libwidevinecdm.so"
 pid=16135 comm="plugin-containe" requested_mask="m" denied_mask="m" fsuid=1000 
ouid=1000
  Jun 15 19:13:24 xplt kernel: [301353.960373] audit: type=1400 
audit(1529046804.994:249): apparmor="DENIED" operation="ptrace" 
profile="/usr/lib/firefox/firefox{,*[^s][^h]}" pid=24714 comm="firefox" 
requested_mask="trace" denied_mask="trace" 
peer="/usr/lib/firefox/firefox{,*[^s][^h]}"
  Jun 15 19:13:24 xplt kernel: [301353.960398] plugin-containe[16135]: segfault 
at 0 ip 7fe3b57f46af sp 7ffe6dc0b488 error 6 in 
libxul.so[7fe3b34c7000+6111000]
  Jun 15 19:13:28 xplt kernel: [301357.859177] audit: type=1400 
audit(1529046808.895:250): apparmor="DENIED" operation="file_mmap" 
profile="/usr/lib/firefox/firefox{,*[^s][^h]}" 
name="/home/xav/.mozilla/firefox/wiavokxk.default-1510977878171/gmp-widevinecdm/1.4.8.1008/libwidevinecdm.so"
 pid=16139 comm="plugin-containe" requested_mask="m" denied_mask="m" fsuid=1000 
ouid=1000
  Jun 15 19:13:28 xplt kernel: [301357.859328] audit: type=1400 
audit(1529046808.895:251): apparmor="DENIED" operation="ptrace" 
profile="/usr/lib/firefox/firefox{,*[^s][^h]}" pid=24714 comm="firefox" 
requested_mask="trace" denied_mask="trace" 
peer="/usr/lib/firefox/firefox{,*[^s][^h]}"
  Jun 15 19:13:28 xplt kernel: [301357.859349] plugin-containe[16139]: segfault 
at 0 ip 7fcf32ae06af sp 7ffeb8a136c8 error 6 in 
libxul.so[7fcf307b3000+6111000]
  Jun 15 19:13:25 xplt /usr/lib/gdm3/gdm-x-session[6549]: ###!!! 
[Parent][MessageChannel::Call] Error: Channel error: cannot send/recv
  Jun 15 19:13:29 xplt /usr/lib/gdm3/gdm-x-session[6549]: ERROR block_reap:328: 
[hamster] bad exit code 1
  Jun 15 19:13:29 xplt /usr/lib/gdm3/gdm-x-session[6549]: ###!!! 
[Parent][MessageChannel::Call] Error: Channel error: cannot send/recv
  Jun 15 19:13:29 xplt kernel: [301358.227635] audit: type=1400 
audit(1529046809.263:252): apparmor="DENIED" operation="file_mmap" 
profile="/usr/lib/firefox/firefox{,*[^s][^h]}" 
name="/home/xav/.mozilla/firefox/wiavokxk.default-1510977878171/gmp-widevinecdm/1.4.8.1008/libwidevinecdm.so"
 pid=16188 comm="plugin-containe" requested_mask="m" denied_mask="m" fsuid=1000 
ouid=1000
  Jun 15 19:13:29 xplt kernel: [301358.227811] audit: type=1400 
audit(1529046809.263:253): apparmor="DENIED" operation="ptrace" 
profile="/usr/lib/firefox/firefox{,*[^s][^h]}" pid=24714 comm="firefox" 
requested_mask="trace" denied_mask="trace" 

[Touch-packages] [Bug 1904321] [NEW] does not work as it should " systemctl edit service"

2020-11-15 Thread erzent
Public bug reported:

1. `systemctl edit service(elasticsearch)`
That creates file `/etc/systemd/system/elasticsearch.service.d/override.conf`

And I've added following section there:

[Service]
LimitMEMLOCK=infinity
LimitNPROC=32768
LimitNOFILE=25


3. I've executed `systemctl daemon-reload; systemctl stop elasticsearch; 
systemctl start elasticsearch`

However those parameters were not applied to a newly started service and
I got an error "memory locking requested for elasticsearch process but
memory is not locked".

To workaround I've created a file
`/etc/systemd/system/elasticsearch.service.d/elasticsearch.conf` with
the same content and that fixed the problem.


ubuntu 18.04, all updates are installed

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1904321

Title:
  does not work as it should " systemctl edit service"

Status in systemd package in Ubuntu:
  New

Bug description:
  1. `systemctl edit service(elasticsearch)`
  That creates file `/etc/systemd/system/elasticsearch.service.d/override.conf`

  And I've added following section there:

  [Service]
  LimitMEMLOCK=infinity
  LimitNPROC=32768
  LimitNOFILE=25

  
  3. I've executed `systemctl daemon-reload; systemctl stop elasticsearch; 
systemctl start elasticsearch`

  However those parameters were not applied to a newly started service
  and I got an error "memory locking requested for elasticsearch process
  but memory is not locked".

  To workaround I've created a file
  `/etc/systemd/system/elasticsearch.service.d/elasticsearch.conf` with
  the same content and that fixed the problem.

  
  ubuntu 18.04, all updates are installed

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1904321/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


Re: [Touch-packages] [apparmor] [Bug 1777070] Re: firefox plugin libwidevinecdm.so crashes due to apparmor denial

2020-11-15 Thread John Johansen
On 10/25/20 5:15 AM, baptx wrote:
> I got it working by adding the 2 lines at the end of the
> /etc/apparmor.d/usr.bin.firefox just before the closing brack "}".
> Without these lines, I had to use another workaround by disabling
> Apparmor completely on Firefox with a command like "sudo aa-complain
> /usr/lib/firefox/firefox" or using the official Firefox binary from
> Mozilla instead of the Ubuntu package.
> 
> I saw Daniel wrote "this is not a great way of working (malware could
> write to that location and then load in code)" but do you have an idea
> how to make it more secure?
> 
I assume by the 2 lines you mean

ptrace (trace) peer=@{profile_name},
@{HOME}/.mozilla/firefox/*/gmp-widevinecdm/*/lib*so m,

from the bug report. Neither of these lines would allow malware to
write to that location. However they do provide some danger.

The first rule allow firefox to ptrace it self, this could potentially
be exploited by injected shell code to further take control of firefox
if say the code gains control of the render process. It won't however
allow removing confinement or attacking other processes the user might
be running.

The second rule allows firefox to load and run code from that location.
But doesn't allow firefox to write to it. So if there is malware on the
system that can write to that location it could have firefox run it.
But if something manages to hack/inject code into firefox it won't be
able to put code there. Dealing with this in apparmor comes down to
making sure the rest of the system confinement is correct, preventing
said malware from writing to that location. Or you could potentially
use IMA to further restrict and only allow signed files from this
location.

The reason this is more dangerous than allowing /lib/*.so or other
system locations is the users home directory can be written by other
processes run by the user. And on most systems, most user processes
are running unconfined hence malware that exists on the system and
isn't confined could write to it.

Again this isn't some much a problem with having the rule in the
apparmor profile but have sufficient policy on the system.

> When will the fix be added officially to the Firefox Apparmor profile?
> 
these can be added fairly soon.
https://gitlab.com/apparmor/apparmor/-/merge_requests/684

though that is just landing it upstream and I am not sure when the
next ubuntu upload will be

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apparmor in Ubuntu.
https://bugs.launchpad.net/bugs/1777070

Title:
  firefox plugin libwidevinecdm.so crashes due to apparmor denial

Status in apparmor package in Ubuntu:
  Confirmed
Status in firefox package in Ubuntu:
  Confirmed

Bug description:
  Ubuntu 18.04, Firefox 60.0.1+build2-0ubuntu0.18.04.1

  Running firefix, then going to netflix.com and attempting to play a
  movie.  The widevinecdm plugin crashes, the following is found in
  syslog:

  
  Jun 15 19:13:22 xplt kernel: [301351.553043] audit: type=1400 
audit(1529046802.585:246): apparmor="DENIED" operation="file_mmap" 
profile="/usr/lib/firefox/firefox{,*[^s][^h]}" 
name="/home/xav/.mozilla/firefox/wiavokxk.default-1510977878171/gmp-widevinecdm/1.4.8.1008/libwidevinecdm.so"
 pid=16118 comm="plugin-containe" requested_mask="m" denied_mask="m" fsuid=1000 
ouid=1000
  Jun 15 19:13:22 xplt kernel: [301351.553236] audit: type=1400 
audit(1529046802.585:247): apparmor="DENIED" operation="ptrace" 
profile="/usr/lib/firefox/firefox{,*[^s][^h]}" pid=24714 comm="firefox" 
requested_mask="trace" denied_mask="trace" 
peer="/usr/lib/firefox/firefox{,*[^s][^h]}"
  Jun 15 19:13:22 xplt kernel: [301351.553259] plugin-containe[16118]: segfault 
at 0 ip 7fcdfdaa76af sp 7ffc1ff03e28 error 6 in 
libxul.so[7fcdfb77a000+6111000]
  Jun 15 19:13:22 xplt snmpd[2334]: error on subcontainer 'ia_addr' insert (-1)
  Jun 15 19:13:22 xplt /usr/lib/gdm3/gdm-x-session[6549]: ###!!! 
[Parent][MessageChannel::Call] Error: Channel error: cannot send/recv
  Jun 15 19:13:24 xplt kernel: [301353.960182] audit: type=1400 
audit(1529046804.994:248): apparmor="DENIED" operation="file_mmap" 
profile="/usr/lib/firefox/firefox{,*[^s][^h]}" 
name="/home/xav/.mozilla/firefox/wiavokxk.default-1510977878171/gmp-widevinecdm/1.4.8.1008/libwidevinecdm.so"
 pid=16135 comm="plugin-containe" requested_mask="m" denied_mask="m" fsuid=1000 
ouid=1000
  Jun 15 19:13:24 xplt kernel: [301353.960373] audit: type=1400 
audit(1529046804.994:249): apparmor="DENIED" operation="ptrace" 
profile="/usr/lib/firefox/firefox{,*[^s][^h]}" pid=24714 comm="firefox" 
requested_mask="trace" denied_mask="trace" 
peer="/usr/lib/firefox/firefox{,*[^s][^h]}"
  Jun 15 19:13:24 xplt kernel: [301353.960398] plugin-containe[16135]: segfault 
at 0 ip 7fe3b57f46af sp 7ffe6dc0b488 error 6 in 
libxul.so[7fe3b34c7000+6111000]
  Jun 15 19:13:28 xplt kernel: [301357.859177] audit: type=1400 
audit(1529046808.895:250): apparmor="DENIED" 

[Touch-packages] [Bug 1897307] Re: [X470 AORUS GAMING 7 WIFI, Nvidia GPU 82 HDMI/DP, Digital Out, HDMI] Playback problem

2020-11-15 Thread Víctor
Same again,when I updated my Ubuntu 20.04.1 LTS, sometimes when I switch
on my PC, I lose one of my outputs of audio. For example, I switch on
the PC and the HDMI DisplayPort2 GP102 Audio Contoller doesn't appear in
the settings > Sound.

I need to reboot the PC and sometings if you have good luck it appears
again, if not, you need to reboot again and again and again.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1897307

Title:
  [X470 AORUS GAMING 7 WIFI, Nvidia GPU 82 HDMI/DP, Digital Out, HDMI]
  Playback problem

Status in alsa-driver package in Ubuntu:
  New

Bug description:
  After last update, I have lost the sound of my Asus Monitor which has
  got speakers.

  It is a problem with ALSA Audio because, the last update installed
  some patch of ALSA.

  Now, when I use for example VLC and try to change to my HDMI Audio
  Controller, it works well, but If I do the same thing with a videogame
  of Steam, like DOTA 2, I can't obtain the sound of the game in my Asus
  Monitor.

  I installed Pulse Audio to select the sound card which I want to use,
  and when I try to change the sound card of the application DOTA 2, it
  is impossible, I can't. I change it in the menu, but the option comes
  back to USB Speakers.

  Please solve it, I have lost my speakers with this update.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: alsa-base 1.0.25+dfsg-0ubuntu5
  ProcVersionSignature: Ubuntu 5.4.0-48.52-generic 5.4.60
  Uname: Linux 5.4.0-48-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  ApportVersion: 2.20.11-0ubuntu27.9
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Fri Sep 25 17:32:21 2020
  InstallationDate: Installed on 2020-04-24 (153 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  PackageArchitecture: all
  ProcEnviron:
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=es_ES.UTF-8
   SHELL=/bin/bash
  SourcePackage: alsa-driver
  Symptom: audio
  Symptom_AlsaPlaybackTest: ALSA playback test through plughw:NVidia failed
  Symptom_Card: GP102 HDMI Audio Controller - HDA NVidia
  Symptom_Jack: Digital Out, HDMI
  Symptom_Type: None of the above
  Title: [X470 AORUS GAMING 7 WIFI, Nvidia GPU 82 HDMI/DP, Digital Out, HDMI] 
Playback problem
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 11/27/2019
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: F50
  dmi.board.asset.tag: Default string
  dmi.board.name: X470 AORUS GAMING 7 WIFI-CF
  dmi.board.vendor: Gigabyte Technology Co., Ltd.
  dmi.board.version: x.x
  dmi.chassis.asset.tag: Default string
  dmi.chassis.type: 3
  dmi.chassis.vendor: Default string
  dmi.chassis.version: Default string
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrF50:bd11/27/2019:svnGigabyteTechnologyCo.,Ltd.:pnX470AORUSGAMING7WIFI:pvrDefaultstring:rvnGigabyteTechnologyCo.,Ltd.:rnX470AORUSGAMING7WIFI-CF:rvrx.x:cvnDefaultstring:ct3:cvrDefaultstring:
  dmi.product.family: Default string
  dmi.product.name: X470 AORUS GAMING 7 WIFI
  dmi.product.sku: Default string
  dmi.product.version: Default string
  dmi.sys.vendor: Gigabyte Technology Co., Ltd.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1897307/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1754671] Re: Full-tunnel VPN DNS leakage regression

2020-11-15 Thread Mathew Hodson
** Changed in: network-manager (Ubuntu Xenial)
   Status: Confirmed => Won't Fix

** Changed in: systemd (Ubuntu Xenial)
   Status: Invalid => Won't Fix

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1754671

Title:
  Full-tunnel VPN DNS leakage regression

Status in NetworkManager:
  Expired
Status in network-manager package in Ubuntu:
  Fix Released
Status in systemd package in Ubuntu:
  Fix Released
Status in network-manager source package in Xenial:
  Won't Fix
Status in systemd source package in Xenial:
  Won't Fix
Status in network-manager source package in Bionic:
  Fix Released
Status in systemd source package in Bionic:
  Fix Released
Status in network-manager source package in Cosmic:
  Fix Released
Status in systemd source package in Cosmic:
  Fix Released

Bug description:
  [Impact]
  When using a VPN the DNS requests might still be sent to a DNS server outside 
the VPN when they should not

  [Test case]
  1) Set up a VPN with split tunneling:
a) Configure VPN normally (set up remote host, any ports and options needed 
for the VPN to work)
b) Under the IPv4 tab: enable "Use this connection only for the resources 
on its network".
c) Under the IPv6 tab: enable "Use this connection only for the resources 
on its network".

  2) Connect to the VPN.

  3) Run 'systemd-resolve --status'; note the DNS servers configured:
a) For the VPN; under a separate link (probably tun0), note down the IP of 
the DNS server(s). Also note the name of the interface (link).
b) For the "main" connection; under the link for your ethernet or wireless 
devices (wl*, en*, whatever it may be), note down the IP of the DNS server(s). 
Also note the name of the interface (link).

  4) In a separate terminal, run 'sudo tcpdump -ni 
  port 53'; let it run.

  5) In a separate terminal, run 'sudo tcpdump -ni 
  port 53'; let it run.

  6) In yet another terminal, issue name resolution requests using dig:
a) For a name known to be reachable via the public network:
   'dig www.yahoo.com'
b) For a name known to be reachable only via the VPN:
   'dig '

  7) Check the output of each terminal running tcpdump. When requesting
  the public name, traffic can go through either. When requesting the
  "private" name (behind the VPN), traffic should only be going through
  the interface for the VPN. Additionally, ensure the IP receiving the
  requests for the VPN name is indeed the IP address noted above for the
  VPN's DNS server.

  If you see no traffic showing in tcpdump output when requesting a
  name, it may be because it is cached by systemd-resolved. Use a
  different name you have not tried before.

  
  [Regression potential]
  The code change the handling of DNS servers when using a VPN, we should check 
that name resolution still work whne using a VPN in different configurations

  -

  In 16.04 the NetworkManager package used to carry this patch:
  
http://bazaar.launchpad.net/~network-manager/network-manager/ubuntu/view/head:/debian/patches/Filter-DNS-servers-to-add-to-dnsmasq-based-on-availa.patch

  It fixed the DNS setup so that when I'm on the VPN, I am not sending
  unencrypted DNS queries to the (potentially hostile) local
  nameservers.

  This patch disappeared in an update. I think it was present in
  1.2.2-0ubuntu0.16.04.4 but was dropped some time later.

  This security bug exists upstream too: 
https://bugzilla.gnome.org/show_bug.cgi?id=746422
  It's not a *regression* there though, as they didn't fix it yet 
(unfortunately!)

To manage notifications about this bug go to:
https://bugs.launchpad.net/network-manager/+bug/1754671/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp