[Touch-packages] [Bug 1921562] Re: Intermittent hangs during ldap_search_ext when TLS enabled

2021-03-26 Thread Ubuntu Foundations Team Bug Bot
The attachment "retry-tls-connect-on-eintr-eagain.patch" seems to be a
patch.  If it isn't, please remove the "patch" flag from the attachment,
remove the "patch" tag, and if you are a member of the ~ubuntu-
reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by
~brian-murray, for any issues please contact him.]

** Tags added: patch

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openldap in Ubuntu.
https://bugs.launchpad.net/bugs/1921562

Title:
  Intermittent hangs during ldap_search_ext when TLS enabled

Status in openldap:
  Fix Released
Status in openldap package in Ubuntu:
  Confirmed

Bug description:
  When connecting to an LDAP server with TLS, ldap_search_ext can hang
  if during the initial TLS handshake a signal is received by the
  process. The cause of this bug is the same as
  https://bugs.openldap.org/show_bug.cgi?id=8650 which was fixed in
  https://git.openldap.org/openldap/openldap/-/commit/735e1ab and was
  released as part of version 2.4.50. This bug effects Ubuntu 20.04 LTS
  and potentially earlier Ubuntu releases. Later Ubuntu releases use an
  openldap version that is at least 2.4.50 and are therefore not
  affected.

  In our case this bug cause failures in the SSSD LDAP backend at least
  once per day, resulting in authentication errors followed by a sssd_be
  restart after a timeout has been hit:

  Mar 19 19:05:31 mail auth[867454]: pam_sss(dovecot:auth): received for user 
redacted: 4 (System error)
  Mar 19 19:05:32 mail sssd_be[867455]: Starting up

  A reduced version of the patch linked above can be found attached to
  this bug report. This patch has been applied to version 2.4.49+dfsg-
  2ubuntu1.7 and has been running in production for approximately a week
  and the issue has no longer occurred. No other issues have appeared
  during this period.

  As this bug affects all systems using LDAP with TLS, I suggest that
  the fix for this bug is ported to Ubuntu 20.04 LTS and potentially
  earlier versions.

To manage notifications about this bug go to:
https://bugs.launchpad.net/openldap/+bug/1921562/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1741365] Re: i don't know

2021-03-26 Thread Launchpad Bug Tracker
[Expired for xorg (Ubuntu) because there has been no activity for 60
days.]

** Changed in: xorg (Ubuntu)
   Status: Incomplete => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1741365

Title:
  i don't know

Status in xorg package in Ubuntu:
  Expired

Bug description:
  not sure

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: xorg 1:7.7+13ubuntu3
  ProcVersionSignature: Ubuntu 4.10.0-42.46~16.04.1-generic 4.10.17
  Uname: Linux 4.10.0-42-generic x86_64
  .tmp.unity_support_test.0:
   
  ApportVersion: 2.20.1-0ubuntu2.15
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  Date: Thu Jan  4 15:04:52 2018
  DistUpgraded: Fresh install
  DistroCodename: xenial
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes, including running git bisection searches
  GraphicsCard:
   NVIDIA Corporation GK107 [GeForce GT 630 OEM] [10de:0fc2] (rev a1) (prog-if 
00 [VGA controller])
 Subsystem: ASUSTeK Computer Inc. GK107 [GeForce GT 630 OEM] [1043:83e2]
  InstallationDate: Installed on 2017-12-26 (9 days ago)
  InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64 
(20170801)
  MachineType: ASUSTeK COMPUTER INC. CM6870
  ProcEnviron:
   LANGUAGE=en_CA:en
   PATH=(custom, no user)
   LANG=en_CA.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.10.0-42-generic.efi.signed 
root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
  SourcePackage: xorg
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 02/24/2012
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 0408
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: CM6870
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: Rev X.0x
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr0408:bd02/24/2012:svnASUSTeKCOMPUTERINC.:pnCM6870:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnCM6870:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: CM6870
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTeK COMPUTER INC.
  version.compiz: compiz 1:0.9.12.2+16.04.20160823-0ubuntu1
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.83-1~16.04.1
  version.libgl1-mesa-dri: libgl1-mesa-dri 17.2.4-0ubuntu1~16.04.2
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 17.2.4-0ubuntu1~16.04.2
  version.xserver-xorg-core: xserver-xorg-core N/A
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
  version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A
  xserver.bootTime: Thu Jan  4 01:51:57 2018
  xserver.configfile: default
  xserver.errors:
   Failed to load module "nvidia" (module does not exist, 0)
   Failed to load module "nvidia" (module does not exist, 0)
  xserver.logfile: /var/log/Xorg.0.log
  xserver.version: 2:1.19.5-0ubuntu2~16.04.1
  xserver.video_driver: nouveau

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1741365/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


Re: [Touch-packages] [Bug 1921562] [NEW] Intermittent hangs during ldap_search_ext when TLS enabled

2021-03-26 Thread Ryan Tandy
On Sat, Mar 27, 2021 at 01:06:42AM -, Vincent Vanlaer wrote:
>https://git.openldap.org/openldap/openldap/-/commit/735e1ab

Note that this commit is for OpenLDAP 2.5 and needs adjustment for the 
2.4 branch. The commit ids for 2.4 are:

https://git.openldap.org/openldap/openldap/-/commit/7cf7aa3141
https://git.openldap.org/openldap/openldap/-/commit/85fc8974f5

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openldap in Ubuntu.
https://bugs.launchpad.net/bugs/1921562

Title:
  Intermittent hangs during ldap_search_ext when TLS enabled

Status in openldap:
  Fix Released
Status in openldap package in Ubuntu:
  Confirmed

Bug description:
  When connecting to an LDAP server with TLS, ldap_search_ext can hang
  if during the initial TLS handshake a signal is received by the
  process. The cause of this bug is the same as
  https://bugs.openldap.org/show_bug.cgi?id=8650 which was fixed in
  https://git.openldap.org/openldap/openldap/-/commit/735e1ab and was
  released as part of version 2.4.50. This bug effects Ubuntu 20.04 LTS
  and potentially earlier Ubuntu releases. Later Ubuntu releases use an
  openldap version that is at least 2.4.50 and are therefore not
  affected.

  In our case this bug cause failures in the SSSD LDAP backend at least
  once per day, resulting in authentication errors followed by a sssd_be
  restart after a timeout has been hit:

  Mar 19 19:05:31 mail auth[867454]: pam_sss(dovecot:auth): received for user 
redacted: 4 (System error)
  Mar 19 19:05:32 mail sssd_be[867455]: Starting up

  A reduced version of the patch linked above can be found attached to
  this bug report. This patch has been applied to version 2.4.49+dfsg-
  2ubuntu1.7 and has been running in production for approximately a week
  and the issue has no longer occurred. No other issues have appeared
  during this period.

  As this bug affects all systems using LDAP with TLS, I suggest that
  the fix for this bug is ported to Ubuntu 20.04 LTS and potentially
  earlier versions.

To manage notifications about this bug go to:
https://bugs.launchpad.net/openldap/+bug/1921562/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921562] Re: Intermittent hangs during ldap_search_ext when TLS enabled

2021-03-26 Thread Bug Watch Updater
Launchpad has imported 19 comments from the remote bug at
https://bugs.openldap.org/show_bug.cgi?id=8650.

If you reply to an imported comment from within Launchpad, your comment
will be sent to the remote bug automatically. Read more about
Launchpad's inter-bugtracker facilities at
https://help.launchpad.net/InterBugTracking.


On 2017-05-06T22:32:26+00:00 Ryan Tandy wrote:

Full_Name: Ryan Tandy
Version: RE24
OS: Debian
URL: 
Submission from: (NULL) (24.68.41.160)
Submitted by: ryan


https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=861838

That bug's submitter seems to have unintentionally configured their slapd with
the entire list of system CAs. They're fixing it, but we have a bug here too.

When the ServerHello is larger than 16kb, gnutls_handshake can return
GNUTLS_E_AGAIN. In theory this was always possible, but I'm only seeing it
happen with gnutls 3.x and haven't the exact change responsible.

We need to loop gnutls_handshake until it completes, like we do already in the
re-handshake case.

Reply at:
https://bugs.launchpad.net/ubuntu/+source/openldap/+bug/1921562/comments/0


On 2017-05-06T22:52:25+00:00 Ryan Tandy wrote:

changed notes
changed state Open to Test
moved from Incoming to Software Bugs

Reply at:
https://bugs.launchpad.net/ubuntu/+source/openldap/+bug/1921562/comments/1


On 2017-05-06T22:58:54+00:00 Ryan Tandy wrote:

Committed the fix, and pinged the submitter to test it.


Reply at:
https://bugs.launchpad.net/ubuntu/+source/openldap/+bug/1921562/comments/2


On 2018-02-09T17:22:50+00:00 Quanah-x wrote:

changed notes
changed state Test to Release

Reply at:
https://bugs.launchpad.net/ubuntu/+source/openldap/+bug/1921562/comments/3


On 2018-03-22T19:25:42+00:00 Quanah-x wrote:

changed notes
changed state Release to Closed

Reply at:
https://bugs.launchpad.net/ubuntu/+source/openldap/+bug/1921562/comments/4


On 2018-08-03T15:19:06+00:00 Kartik Subbarao wrote:

Hi Ryan,

I'm running into a problem with slapd 2.4.46 hanging on Ubuntu 18.04, 
which seems to be a side effect of the ITS#8650 patch:

https://github.com/openldap/openldap/commit/7b5181da8cdd47a13041f9ee36fa9590a0fa6e48

slapd will run fine for a while, but during some periods of 
high-traffic, it'll hang. It'll peg the CPU at 100% and won't respond to 
any new LDAP connections. After some time, it'll resume working again, 
but overall it's fairly unreliable.

strace on slapd during the hang shows that it's constantly making read() 
calls that return EAGAIN. After doing a gdb stack trace on slapd, I 
realized that these read() calls are happening as part of the busywait 
for loop in tlsg_session_accept() that repeatedly calls 
gnutls_handshake() when it gets EAGAIN. When slapd recovers from this 
hang state, the first message it prints is a TLS negotiation failure 
error on the culprit file descriptor.

If I back out the ITS#8650 patch, the problem goes away. If I insert 
sleep(1) in the for loop, slapd no longer pegs the CPU at 100%, but it 
still becomes unresponsive during these high-traffic periods.

I don't know what's happening during these high-traffic periods that 
causes the TLS negotiation to go astray. Unfortunately it's not easy to 
reproduce this problem outside of this production environment, given the 
diversity of clients running different OSes with various versions of SSL 
libraries.

I'm wondering if there is a better way to handle EAGAIN returned from 
gnutls_handshake(), instead of doing a busywait as in ITS#8650, or my 
simplistic attempt at inserting a sleep() call which doesn't really seem 
to help. I'm wondering how the GnuTLS developers intend for people to 
use gnutls_handshake() properly, so as to gracefully handle sessions 
that involve long packets on the one hand, without opening up a 
vulnerability to chew up lots of system resources on the other hand.

Regards,

     -Kartik



Reply at: 
https://bugs.launchpad.net/ubuntu/+source/openldap/+bug/1921562/comments/5


On 2018-08-03T16:09:47+00:00 Ryan Tandy wrote:

Hi Kartik,

On Fri, Aug 03, 2018 at 11:19:06AM -0400, Kartik Subbarao wrote:
>I'm running into a problem with slapd 2.4.46 hanging on Ubuntu 18.04, 
>which seems to be a side effect of the ITS#8650 patch:
>
>https://github.com/openldap/openldap/commit/7b5181da8cdd47a13041f9ee36fa9590a0fa6e48
>
>slapd will run fine for a while, but during some periods of 
>high-traffic, it'll hang. It'll peg the CPU at 100% and won't respond 
>to any new LDAP connections. After some time, it'll resume 

[Touch-packages] [Bug 1921562] Re: Intermittent hangs during ldap_search_ext when TLS enabled

2021-03-26 Thread Bert Van de Poel
** Bug watch added: bugs.openldap.org/ #8650
   https://bugs.openldap.org/show_bug.cgi?id=8650

** Also affects: openldap via
   https://bugs.openldap.org/show_bug.cgi?id=8650
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openldap in Ubuntu.
https://bugs.launchpad.net/bugs/1921562

Title:
  Intermittent hangs during ldap_search_ext when TLS enabled

Status in openldap:
  Unknown
Status in openldap package in Ubuntu:
  Confirmed

Bug description:
  When connecting to an LDAP server with TLS, ldap_search_ext can hang
  if during the initial TLS handshake a signal is received by the
  process. The cause of this bug is the same as
  https://bugs.openldap.org/show_bug.cgi?id=8650 which was fixed in
  https://git.openldap.org/openldap/openldap/-/commit/735e1ab and was
  released as part of version 2.4.50. This bug effects Ubuntu 20.04 LTS
  and potentially earlier Ubuntu releases. Later Ubuntu releases use an
  openldap version that is at least 2.4.50 and are therefore not
  affected.

  In our case this bug cause failures in the SSSD LDAP backend at least
  once per day, resulting in authentication errors followed by a sssd_be
  restart after a timeout has been hit:

  Mar 19 19:05:31 mail auth[867454]: pam_sss(dovecot:auth): received for user 
redacted: 4 (System error)
  Mar 19 19:05:32 mail sssd_be[867455]: Starting up

  A reduced version of the patch linked above can be found attached to
  this bug report. This patch has been applied to version 2.4.49+dfsg-
  2ubuntu1.7 and has been running in production for approximately a week
  and the issue has no longer occurred. No other issues have appeared
  during this period.

  As this bug affects all systems using LDAP with TLS, I suggest that
  the fix for this bug is ported to Ubuntu 20.04 LTS and potentially
  earlier versions.

To manage notifications about this bug go to:
https://bugs.launchpad.net/openldap/+bug/1921562/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921562] Re: Intermittent hangs during ldap_search_ext when TLS enabled

2021-03-26 Thread Vincent Vanlaer
** Description changed:

  When connecting to an LDAP server with TLS, ldap_search_ext can hang if
  during the initial TLS handshake a signal is received by the process.
  The cause of this bug is the same as
  https://bugs.openldap.org/show_bug.cgi?id=8650 which was fixed in
  https://git.openldap.org/openldap/openldap/-/commit/735e1ab and was
  released as part of version 2.4.50. This bug effects Ubuntu 20.04 LTS
  and potentially earlier Ubuntu releases. Later Ubuntu releases use an
  openldap version that is at least 2.4.50 and are therefore not affected.
  
  In our case this bug cause failures in the SSSD LDAP backend at least
  once per day, resulting in authentication errors followed by a sssd_be
  restart after a timeout has been hit:
  
  Mar 19 19:05:31 mail auth[867454]: pam_sss(dovecot:auth): received for user 
redacted: 4 (System error)
  Mar 19 19:05:32 mail sssd_be[867455]: Starting up
  
  A reduced version of the patch linked above can be found attached to
  this bug report. This patch has been applied to version 2.4.49+dfsg-
  2ubuntu1.7 and has been running in production for approximately a week
  and the issue has no longer occurred. No other issues have appeared
  during this period.
  
- As this bug affects al systems using LDAP with TLS , I suggest that the
+ As this bug affects all systems using LDAP with TLS, I suggest that the
  fix for this bug is ported to Ubuntu 20.04 LTS and potentially earlier
  versions.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openldap in Ubuntu.
https://bugs.launchpad.net/bugs/1921562

Title:
  Intermittent hangs during ldap_search_ext when TLS enabled

Status in openldap:
  Unknown
Status in openldap package in Ubuntu:
  Confirmed

Bug description:
  When connecting to an LDAP server with TLS, ldap_search_ext can hang
  if during the initial TLS handshake a signal is received by the
  process. The cause of this bug is the same as
  https://bugs.openldap.org/show_bug.cgi?id=8650 which was fixed in
  https://git.openldap.org/openldap/openldap/-/commit/735e1ab and was
  released as part of version 2.4.50. This bug effects Ubuntu 20.04 LTS
  and potentially earlier Ubuntu releases. Later Ubuntu releases use an
  openldap version that is at least 2.4.50 and are therefore not
  affected.

  In our case this bug cause failures in the SSSD LDAP backend at least
  once per day, resulting in authentication errors followed by a sssd_be
  restart after a timeout has been hit:

  Mar 19 19:05:31 mail auth[867454]: pam_sss(dovecot:auth): received for user 
redacted: 4 (System error)
  Mar 19 19:05:32 mail sssd_be[867455]: Starting up

  A reduced version of the patch linked above can be found attached to
  this bug report. This patch has been applied to version 2.4.49+dfsg-
  2ubuntu1.7 and has been running in production for approximately a week
  and the issue has no longer occurred. No other issues have appeared
  during this period.

  As this bug affects all systems using LDAP with TLS, I suggest that
  the fix for this bug is ported to Ubuntu 20.04 LTS and potentially
  earlier versions.

To manage notifications about this bug go to:
https://bugs.launchpad.net/openldap/+bug/1921562/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921562] [NEW] Intermittent hangs during ldap_search_ext when TLS enabled

2021-03-26 Thread Vincent Vanlaer
Public bug reported:

When connecting to an LDAP server with TLS, ldap_search_ext can hang if
during the initial TLS handshake a signal is received by the process.
The cause of this bug is the same as
https://bugs.openldap.org/show_bug.cgi?id=8650 which was fixed in
https://git.openldap.org/openldap/openldap/-/commit/735e1ab and was
released as part of version 2.4.50. This bug effects Ubuntu 20.04 LTS
and potentially earlier Ubuntu releases. Later Ubuntu releases use an
openldap version that is at least 2.4.50 and are therefore not affected.

In our case this bug cause failures in the SSSD LDAP backend at least
once per day, resulting in authentication errors followed by a sssd_be
restart after a timeout has been hit:

Mar 19 19:05:31 mail auth[867454]: pam_sss(dovecot:auth): received for user 
redacted: 4 (System error)
Mar 19 19:05:32 mail sssd_be[867455]: Starting up

A reduced version of the patch linked above can be found attached to
this bug report. This patch has been applied to version 2.4.49+dfsg-
2ubuntu1.7 and has been running in production for approximately a week
and the issue has no longer occurred. No other issues have appeared
during this period.

As this bug affects all systems using LDAP with TLS, I suggest that the
fix for this bug is ported to Ubuntu 20.04 LTS and potentially earlier
versions.

** Affects: openldap
 Importance: Unknown
 Status: Unknown

** Affects: openldap (Ubuntu)
 Importance: Undecided
 Status: Confirmed


** Tags: focal

** Patch added: "retry-tls-connect-on-eintr-eagain.patch"
   
https://bugs.launchpad.net/bugs/1921562/+attachment/5481337/+files/retry-tls-connect-on-eintr-eagain.patch

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openldap in Ubuntu.
https://bugs.launchpad.net/bugs/1921562

Title:
  Intermittent hangs during ldap_search_ext when TLS enabled

Status in openldap:
  Unknown
Status in openldap package in Ubuntu:
  Confirmed

Bug description:
  When connecting to an LDAP server with TLS, ldap_search_ext can hang
  if during the initial TLS handshake a signal is received by the
  process. The cause of this bug is the same as
  https://bugs.openldap.org/show_bug.cgi?id=8650 which was fixed in
  https://git.openldap.org/openldap/openldap/-/commit/735e1ab and was
  released as part of version 2.4.50. This bug effects Ubuntu 20.04 LTS
  and potentially earlier Ubuntu releases. Later Ubuntu releases use an
  openldap version that is at least 2.4.50 and are therefore not
  affected.

  In our case this bug cause failures in the SSSD LDAP backend at least
  once per day, resulting in authentication errors followed by a sssd_be
  restart after a timeout has been hit:

  Mar 19 19:05:31 mail auth[867454]: pam_sss(dovecot:auth): received for user 
redacted: 4 (System error)
  Mar 19 19:05:32 mail sssd_be[867455]: Starting up

  A reduced version of the patch linked above can be found attached to
  this bug report. This patch has been applied to version 2.4.49+dfsg-
  2ubuntu1.7 and has been running in production for approximately a week
  and the issue has no longer occurred. No other issues have appeared
  during this period.

  As this bug affects all systems using LDAP with TLS, I suggest that
  the fix for this bug is ported to Ubuntu 20.04 LTS and potentially
  earlier versions.

To manage notifications about this bug go to:
https://bugs.launchpad.net/openldap/+bug/1921562/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921562] Re: Intermittent hangs during ldap_search_ext when TLS enabled

2021-03-26 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: openldap (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openldap in Ubuntu.
https://bugs.launchpad.net/bugs/1921562

Title:
  Intermittent hangs during ldap_search_ext when TLS enabled

Status in openldap:
  Unknown
Status in openldap package in Ubuntu:
  Confirmed

Bug description:
  When connecting to an LDAP server with TLS, ldap_search_ext can hang
  if during the initial TLS handshake a signal is received by the
  process. The cause of this bug is the same as
  https://bugs.openldap.org/show_bug.cgi?id=8650 which was fixed in
  https://git.openldap.org/openldap/openldap/-/commit/735e1ab and was
  released as part of version 2.4.50. This bug effects Ubuntu 20.04 LTS
  and potentially earlier Ubuntu releases. Later Ubuntu releases use an
  openldap version that is at least 2.4.50 and are therefore not
  affected.

  In our case this bug cause failures in the SSSD LDAP backend at least
  once per day, resulting in authentication errors followed by a sssd_be
  restart after a timeout has been hit:

  Mar 19 19:05:31 mail auth[867454]: pam_sss(dovecot:auth): received for user 
redacted: 4 (System error)
  Mar 19 19:05:32 mail sssd_be[867455]: Starting up

  A reduced version of the patch linked above can be found attached to
  this bug report. This patch has been applied to version 2.4.49+dfsg-
  2ubuntu1.7 and has been running in production for approximately a week
  and the issue has no longer occurred. No other issues have appeared
  during this period.

  As this bug affects all systems using LDAP with TLS, I suggest that
  the fix for this bug is ported to Ubuntu 20.04 LTS and potentially
  earlier versions.

To manage notifications about this bug go to:
https://bugs.launchpad.net/openldap/+bug/1921562/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921009] Re: Failure applying dump from m.5 drive to SCSI drive

2021-03-26 Thread Kevin O'Gorman
Color me embarassed.  I just tried this again on a different system,
still with the same software, and it worked perfectly, using the same
source and destination drives as when I first had a problem.

Mark this "worksforme" I guess.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to util-linux in Ubuntu.
https://bugs.launchpad.net/bugs/1921009

Title:
  Failure applying dump from m.5 drive to SCSI drive

Status in util-linux package in Ubuntu:
  New

Bug description:
  I have a dump from an M.5 drive named "/dev/nvme0n1" that I wanted to
  apply to a regular SCSI drive /dev/sdc.  This got the GPT built but
  when it tried to work on partitions, it failed, giving the error
  message sfdisk: failed to parse partition number: '/dev/sdc'

  This is probably due to the oddity of drive names for M.5 drives --
  they end in a digit, so a "p" is inserted before the actual partition
  numbers.  So the first partition may appear to be "p1" instead of "1".
  I know, I ran into it working on some software of my own.

  Anyway, the dump is attached.  Try applying it to a regular "/dev/sd?"
  drive and you will prpbably see the same thing.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: fdisk 2.34-0.1ubuntu9.1
  ProcVersionSignature: Ubuntu 5.4.0-66.74-generic 5.4.86
  Uname: Linux 5.4.0-66-generic x86_64
  NonfreeKernelModules: wl
  ApportVersion: 2.20.11-0ubuntu27.16
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: XFCE
  Date: Tue Mar 23 14:39:53 2021
  SourcePackage: util-linux
  UpgradeStatus: Upgraded to focal on 2021-02-19 (32 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/util-linux/+bug/1921009/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921556] Re: computer crash

2021-03-26 Thread Ubuntu Foundations Team Bug Bot
** Package changed: ubuntu => xorg (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1921556

Title:
  computer crash

Status in xorg package in Ubuntu:
  New

Bug description:
  after looking at a couple sites my computer stops responding

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: xorg 1:7.7+19ubuntu7.1
  ProcVersionSignature: Ubuntu 4.15.0-136.140-generic 4.15.18
  Uname: Linux 4.15.0-136-generic i686
  .tmp.unity_support_test.0:
   
  ApportVersion: 2.20.9-0ubuntu7.23
  Architecture: i386
  BootLog:
   
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  Date: Fri Mar 26 16:32:35 2021
  DistUpgraded: 2020-12-23 16:47:59,374 DEBUG /openCache(), new cache size 63671
  DistroCodename: bionic
  DistroVariant: ubuntu
  GraphicsCard:
   Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller 
(primary) [8086:2a02] (rev 0c) (prog-if 00 [VGA controller])
 Subsystem: Lenovo GM965 [X3100] on ThinkPad T61/R61 [17aa:20b5]
 Subsystem: Lenovo GM965 [X3100] on ThinkPad T61/R61 [17aa:20b5]
  InstallationDate: Installed on 2015-04-03 (2183 days ago)
  InstallationMedia: Edubuntu 12.04.2 LTS "Precise Pangolin" - Release i386 
(20130214)
  MachineType: LENOVO 765818U
  PccardctlIdent:
   Socket 0:
 no product info available
  PccardctlStatus:
   Socket 0:
 no card
  ProcEnviron:
   LANGUAGE=en_US
   PATH=(custom, no user)
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-136-generic 
root=UUID=e7e9746b-52c2-49ae-ab18-189b8d46be33 ro drm.debug=0xe nopat 
vesafb.invalid=1 plymouth:debug
  SourcePackage: xorg
  UpgradeStatus: Upgraded to bionic on 2020-12-23 (92 days ago)
  dmi.bios.date: 12/27/2007
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 7LETA9WW (2.09 )
  dmi.board.name: 765818U
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Available
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: 
dmi:bvnLENOVO:bvr7LETA9WW(2.09):bd12/27/2007:svnLENOVO:pn765818U:pvrThinkPadT61:rvnLENOVO:rn765818U:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.family: ThinkPad T61
  dmi.product.name: 765818U
  dmi.product.version: ThinkPad T61
  dmi.sys.vendor: LENOVO
  version.compiz: compiz 1:0.9.13.1+18.04.20180302-0ubuntu1
  version.libdrm2: libdrm2 2.4.101-2~18.04.1
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~18.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.8-0ubuntu1~18.04.1
  version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4.8
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.5-1ubuntu1
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.0.1-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20171229-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2
  xserver.bootTime: Fri Mar 26 14:45:08 2021
  xserver.configfile: default
  xserver.logfile: /var/log/Xorg.0.log
  xserver.version: 2:1.19.6-1ubuntu4.8
  xserver.video_driver: modeset

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1921556/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921556] [NEW] computer crash

2021-03-26 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

after looking at a couple sites my computer stops responding

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xorg 1:7.7+19ubuntu7.1
ProcVersionSignature: Ubuntu 4.15.0-136.140-generic 4.15.18
Uname: Linux 4.15.0-136-generic i686
.tmp.unity_support_test.0:
 
ApportVersion: 2.20.9-0ubuntu7.23
Architecture: i386
BootLog:
 
CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Fri Mar 26 16:32:35 2021
DistUpgraded: 2020-12-23 16:47:59,374 DEBUG /openCache(), new cache size 63671
DistroCodename: bionic
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) 
[8086:2a02] (rev 0c) (prog-if 00 [VGA controller])
   Subsystem: Lenovo GM965 [X3100] on ThinkPad T61/R61 [17aa:20b5]
   Subsystem: Lenovo GM965 [X3100] on ThinkPad T61/R61 [17aa:20b5]
InstallationDate: Installed on 2015-04-03 (2183 days ago)
InstallationMedia: Edubuntu 12.04.2 LTS "Precise Pangolin" - Release i386 
(20130214)
MachineType: LENOVO 765818U
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-136-generic 
root=UUID=e7e9746b-52c2-49ae-ab18-189b8d46be33 ro drm.debug=0xe nopat 
vesafb.invalid=1 plymouth:debug
SourcePackage: xorg
UpgradeStatus: Upgraded to bionic on 2020-12-23 (92 days ago)
dmi.bios.date: 12/27/2007
dmi.bios.vendor: LENOVO
dmi.bios.version: 7LETA9WW (2.09 )
dmi.board.name: 765818U
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: 
dmi:bvnLENOVO:bvr7LETA9WW(2.09):bd12/27/2007:svnLENOVO:pn765818U:pvrThinkPadT61:rvnLENOVO:rn765818U:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.family: ThinkPad T61
dmi.product.name: 765818U
dmi.product.version: ThinkPad T61
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.13.1+18.04.20180302-0ubuntu1
version.libdrm2: libdrm2 2.4.101-2~18.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~18.04.1
version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.8-0ubuntu1~18.04.1
version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4.8
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.5-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.0.1-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20171229-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2
xserver.bootTime: Fri Mar 26 14:45:08 2021
xserver.configfile: default
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.19.6-1ubuntu4.8
xserver.video_driver: modeset

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: apport-bug bionic i386 ubuntu
-- 
computer crash
https://bugs.launchpad.net/bugs/1921556
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to xorg in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1852911] Re: CriticalPowerAction=Suspend should be supported

2021-03-26 Thread Pedro Côrte-Real
I've once again lost my open session because upower has decided a
shutdown is a sensible thing to do instead of just suspending and
allowing me to just find a charger. Please consider this an actual bug
and not just a "Wishlist" item. It's something that deeply frustrates
users continuously. Orderly shutdowns are a relic of the past. Suspend
or just dieing from lack of battery are both much better options for a
laptop. That upstream has decided to force this behavior is unfortunate
but the patches are simple enough.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to upower in Ubuntu.
https://bugs.launchpad.net/bugs/1852911

Title:
  CriticalPowerAction=Suspend should be supported

Status in Upower:
  New
Status in upower package in Ubuntu:
  Triaged

Bug description:
  The action to take when the battery is critical can only be one of the
  following:

  # Possible values are:
  # PowerOff
  # Hibernate
  # HybridSleep

  Adding Suspend to that list makes perfect sense. My laptop is
  currently powering off on low power which is useless as I'll be losing
  my work anyway. Might as well suspend and allow me to notice that and
  connect a charger. If the thinking is that suspend uses power I can
  set a high enough threshold to give me some margin.

  The failovers are:

  # If HybridSleep isn't available, Hibernate will be used
  # If Hibernate isn't available, PowerOff will be used

  I'd argue Suspend should actually come before PowerOff in that list.
  For most laptop users having their computer suspend because they
  didn't notice the battery was running out is very easy to fix and
  takes no time. They'll just connect the charger. If however the
  computer needs to be completely rebooted, not only does that take a
  lot more time it will very likely cause lost work.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.04
  Package: upower 0.99.10-1
  ProcVersionSignature: Ubuntu 5.0.0-32.34-generic 5.0.21
  Uname: Linux 5.0.0-32-generic x86_64
  ApportVersion: 2.20.10-0ubuntu27.3
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Sun Nov 17 14:32:13 2019
  InstallationDate: Installed on 2019-05-09 (191 days ago)
  InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
  SourcePackage: upower
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/upower/+bug/1852911/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1920640] Re: EXPKEYSIG C8CAB6595FDFF622 Ubuntu Debug Symbol Archive Automatic Signing Key (2016)

2021-03-26 Thread Dimitri John Ledkov
** Changed in: ubuntu-keyring (Ubuntu Hirsute)
   Status: Fix Released => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-keyring in Ubuntu.
https://bugs.launchpad.net/bugs/1920640

Title:
  EXPKEYSIG C8CAB6595FDFF622 Ubuntu Debug Symbol Archive Automatic
  Signing Key (2016) 

Status in ubuntu-keyring package in Ubuntu:
  Fix Committed
Status in ubuntu-keyring source package in Bionic:
  Fix Committed
Status in ubuntu-keyring source package in Focal:
  Fix Committed
Status in ubuntu-keyring source package in Groovy:
  Fix Committed
Status in ubuntu-keyring source package in Hirsute:
  Fix Committed

Bug description:
  [Impact]

   * Cannot update apt metadata from ddebs.ubuntu.com whilst using
  ubuntu-dbgsym-keyring package

  [Test Plan]

   * Install ubuntu-dbgsym-keyring package
   * Add ddebs.ubuntu.com repository for your release
   * sudo apt update must be successful

  [Where problems could occur]

   * At the moment the signature was bumped by one year
   * Meaning this issue will occur again in 2022
   * Instead the key must be set to not expire & new round of SRUs issued

  [Other Info]
   
   * Original bug report

  The public key used by the debugging symbols repository
  /usr/share/keyrings/ubuntu-dbgsym-keyring.gpg from the package ubuntu-
  dbgsym-keyring expired.

  $ apt policy ubuntu-dbgsym-keyring
  ubuntu-dbgsym-keyring:
    Installed: 2020.02.11.2
    Candidate: 2020.02.11.2
    Version table:
   *** 2020.02.11.2 500
  500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages
  500 http://archive.ubuntu.com/ubuntu focal/main i386 Packages
  100 /var/lib/dpkg/status
  $ gpg --no-default-keyring --keyring 
/usr/share/keyrings/ubuntu-dbgsym-keyring.gpg --list-keys
  /usr/share/keyrings/ubuntu-dbgsym-keyring.gpg
  -
  pub   rsa4096 2016-03-21 [SC] [expired: 2021-03-20]
    F2EDC64DC5AEE1F6B9C621F0C8CAB6595FDFF622
  uid   [ expired] Ubuntu Debug Symbol Archive Automatic Signing Key 
(2016) 

  Error message on "apt update":

  E: The repository 'http://ddebs.ubuntu.com bionic-updates Release' is not 
signed.
  N: Updating from such a repository can't be done securely, and is therefore 
disabled by default.
  N: See apt-secure(8) manpage for repository creation and user configuration 
details.
  W: GPG error: http://ddebs.ubuntu.com bionic Release: The following 
signatures were invalid: EXPKEYSIG C8CAB6595FDFF622 Ubuntu Debug Symbol Archive 
Automatic Signing Key (2016) 
  E: The repository 'http://ddebs.ubuntu.com bionic Release' is not signed.
  N: Updating from such a repository can't be done securely, and is therefore 
disabled by default.
  N: See apt-secure(8) manpage for repository creation and user configuration 
details.
  W: GPG error: http://ddebs.ubuntu.com bionic-proposed Release: The following 
signatures were invalid: EXPKEYSIG C8CAB6595FDFF622 Ubuntu Debug Symbol Archive 
Automatic Signing Key (2016) 
  E: The repository 'http://ddebs.ubuntu.com bionic-proposed Release' is not 
signed.
  N: Updating from such a repository can't be done securely, and is therefore 
disabled by default.
  N: See apt-secure(8) manpage for repository creation and user configuration 
details.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-keyring/+bug/1920640/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921546] Re: [FFe] ubuntu-server to recommend needrestart

2021-03-26 Thread Launchpad Bug Tracker
This bug was fixed in the package ubuntu-meta - 1.466

---
ubuntu-meta (1.466) hirsute; urgency=medium

  * Refreshed dependencies
  * Added needrestart to server-raspi-recommends, server-recommends LP: #1921546
  * Moved usrmerge to minimal-recommends

 -- Dimitri John Ledkov   Fri, 26 Mar 2021 19:09:40
+

** Changed in: ubuntu-meta (Ubuntu)
   Status: Triaged => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu.
https://bugs.launchpad.net/bugs/1921546

Title:
  [FFe] ubuntu-server to recommend needrestart

Status in ubuntu-meta package in Ubuntu:
  Fix Released

Bug description:
  needrestart MIR has been completed.
  https://bugs.launchpad.net/ubuntu/+source/needrestart/+bug/1907422

  We are post FF, thus I am asking FFe to include needrestart as
  recommends in the ubuntu-server package.

  This change will results in needrestart being installed by default in
  the Ubuntu Server product. As it will change the default CLI
  experience. I'm writting a post to discourse about this too.

  This can be discussed on https://discourse.ubuntu.com/t/needrestart-
  for-servers/21552 too

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-meta/+bug/1921546/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1918855] Re: Xorg xserver got signal 6 to abort

2021-03-26 Thread Mathew Hodson
** Changed in: mesa (Ubuntu)
   Importance: Undecided => Medium

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1918855

Title:
  Xorg xserver got signal 6 to abort

Status in Mesa:
  Unknown
Status in OEM Priority Project:
  New
Status in mesa package in Ubuntu:
  New

Bug description:
  I run checkbox job
  com.canonical.certification::memory/memory_stress_ng on focal, and the
  xserver stops unexpectedly with the following stacktrace:

  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 0: /usr/lib/xorg/Xorg 
(OsLookupColor+0x13c) [0x5619f3a4d59c]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 1: 
/lib/x86_64-linux-gnu/libpthread.so.0 (funlockfile+0x60) [0x7fae4786741f]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 2: /lib/x86_64-linux-gnu/libc.so.6 
(gsignal+0xcb) [0x7fae476a418b]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 3: /lib/x86_64-linux-gnu/libc.so.6 
(abort+0x12b) [0x7fae47683859]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) unw_get_proc_name failed: no unwind 
info found [-10]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 4: 
/usr/lib/x86_64-linux-gnu/dri/iris_dri.so (?+0x0) [0x7fae457d7aec]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 5: 
/usr/lib/x86_64-linux-gnu/dri/iris_dri.so (nouveau_drm_screen_create+0x25c8ec) 
[0x7fae46529c9c]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 6: 
/usr/lib/x86_64-linux-gnu/dri/iris_dri.so 
(__driDriverGetExtensions_zink+0x2561d) [0x7fae4582c74d]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 7: 
/usr/lib/xorg/modules/libglamoregl.so (glamor_destroy_pixmap+0x150) 
[0x7fae47007480]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) unw_get_proc_name failed: no unwind 
info found [-10]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 8: 
/usr/lib/xorg/modules/drivers/modesetting_drv.so (?+0x0) [0x7fae47040a30]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 9: /usr/lib/xorg/Xorg 
(BlockHandler+0xa5) [0x5619f38f0995]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 10: /usr/lib/xorg/Xorg 
(WaitForSomething+0x122) [0x5619f3a46c12]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 11: /usr/lib/xorg/Xorg 
(SendErrorToClient+0x117) [0x5619f38ebcf7]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 12: /usr/lib/xorg/Xorg 
(InitFonts+0x3b4) [0x5619f38effc4]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 13: /lib/x86_64-linux-gnu/libc.so.6 
(__libc_start_main+0xf3) [0x7fae476850b3]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 14: /usr/lib/xorg/Xorg (_start+0x2e) 
[0x5619f38d9a2e]

  More info:
  I searched the Internet and got a bug with the same stacktrace:
  https://gitlab.freedesktop.org/mesa/mesa/-/issues/3468

To manage notifications about this bug go to:
https://bugs.launchpad.net/mesa/+bug/1918855/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890572] Re: USB backend never ends if the printer is not connected

2021-03-26 Thread Mathew Hodson
** No longer affects: cups

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to cups in Ubuntu.
https://bugs.launchpad.net/bugs/1890572

Title:
  USB backend never ends if the printer is not connected

Status in cups package in Ubuntu:
  New

Bug description:
  USB backend never ends if the printer is not connected. We have been
  able to identify a infinity loop in print_device function in usb-
  libusb.c file:

  ```
    fprintf(stderr, "DEBUG: Printing on printer with URI: %s\n", uri);
    while ((g.printer = find_device(print_cb, uri)) == NULL)
    {
  _cupsLangPrintFilter(stderr, "INFO",
  _("Waiting for printer to become available."));
  sleep(5);
    }
  ```

  It's also easy to test by invoking the backend by hand:

  ```
  # export DEVICE_URI='usb://Printer/Model?serial=?'
  # /usr/lib/cups/backend/usb 0 root title 1 '' data.file

  DEBUG: Loading USB quirks from "/usr/share/cups/usb".
  DEBUG: Loaded 159 quirks.
  DEBUG: Printing on printer with URI: usb://Printer/Model?serial=?
  DEBUG: libusb_get_device_list=6
  INFO: Waiting for printer to become available.
  DEBUG: libusb_get_device_list=6
  INFO: Waiting for printer to become available.
  DEBUG: libusb_get_device_list=6
  INFO: Waiting for printer to become available.
  DEBUG: libusb_get_device_list=6
  INFO: Waiting for printer to become available.
  DEBUG: libusb_get_device_list=6
  INFO: Waiting for printer to become available.
  ...

  ```

  Setting a job timeout policy or manually stopping work are not options
  for us. We may have jobs that take hours to complete.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1890572/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1918410] Re: isc-dhcp-client denied by apparmor

2021-03-26 Thread Sean Ford
I have been doing Xenial -> Bionic -> Focal release upgrades and started
running into this apparmor issue with dhclient after reaching Focal.

I don't know the root issue, and it doesn't appear to impact
functionality (at least as far as I can tell on my hosts). However, I am
currently dealing with this by adding the following to
/etc/apparmor.d/local/sbin.dhclient:

@{PROC}/[0-9]*/task/[0-9]*/comm rw,

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to isc-dhcp in Ubuntu.
https://bugs.launchpad.net/bugs/1918410

Title:
  isc-dhcp-client denied by apparmor

Status in isc-dhcp package in Ubuntu:
  Confirmed

Bug description:
  Hi, I get weird errors in the audit log, seeing dhclient is being
  denied reading its comm or the comm of one of its tasks:

  
  [1383307.827378] audit: type=1400 audit(1615367094.054:162): 
apparmor="DENIED" operation="open" profile="/{,usr/}sbin/dhclient" 
name="/proc/1095210/task/1095213/comm" pid=1095210 comm="dhclient" 
requested_mask="wr" denied_mask="wr" fsuid=0 ouid=0

  This might or might not be linked with the fact that I can't get an
  IPv4 on this interface. Note that it happened to other, see this
  comment:

  https://bugs.launchpad.net/ubuntu/+source/apparmor/+bug/1413232/comments/8

  Or even an article recommending disabling apparmor for dhclient(!):
  
https://blog.anthony-jacob.com/perte-dip-v4-sous-ubuntu-20-04-apparmor-et-dhclient/

  
  As I said, I'm not sure this is the root cause of the lack of IPv4 renewal, 
because running it manually *does* succeed in getting an IP. And running it in 
strace shows the EACCES failure:

  [pid 1095210] openat(AT_FDCWD, "/proc/self/task/1095211/comm", O_RDWRstrace: 
Process 1095211 attached
  ) = -1 EACCES (Permission non accordée)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/isc-dhcp/+bug/1918410/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921452] Re: [SRU] alsa-lib: conf: USB - add "Cmedia Audio" to USB-Audio.pcm.iec958_device

2021-03-26 Thread Mathew Hodson
** Changed in: alsa-lib (Ubuntu Focal)
   Importance: Undecided => Low

** Changed in: alsa-lib (Ubuntu Groovy)
   Importance: Undecided => Low

** Changed in: alsa-lib (Ubuntu Hirsute)
   Importance: Undecided => Low

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-lib in Ubuntu.
https://bugs.launchpad.net/bugs/1921452

Title:
  [SRU] alsa-lib: conf: USB - add "Cmedia Audio" to USB-
  Audio.pcm.iec958_device

Status in OEM Priority Project:
  In Progress
Status in alsa-lib package in Ubuntu:
  In Progress
Status in alsa-lib source package in Focal:
  In Progress
Status in alsa-lib source package in Groovy:
  In Progress
Status in alsa-lib source package in Hirsute:
  In Progress

Bug description:
  [Impact]
  On Cmedia Audio, unusable SPDIF can be selected as output from PulseAudio.

  [Fix]
  Disable IEC958 (SPDIF) through ALSA UCM.

  [Test]
  With the UCM applied, `pactl` and audio panel in gnome-control-center no 
longer have SPDIF option.

  [Where problems will occur]
  This fix limits to the Cmedia Audio only, other devices are unaffected.

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1921452/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1918410] Re: isc-dhcp-client denied by apparmor

2021-03-26 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: isc-dhcp (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to isc-dhcp in Ubuntu.
https://bugs.launchpad.net/bugs/1918410

Title:
  isc-dhcp-client denied by apparmor

Status in isc-dhcp package in Ubuntu:
  Confirmed

Bug description:
  Hi, I get weird errors in the audit log, seeing dhclient is being
  denied reading its comm or the comm of one of its tasks:

  
  [1383307.827378] audit: type=1400 audit(1615367094.054:162): 
apparmor="DENIED" operation="open" profile="/{,usr/}sbin/dhclient" 
name="/proc/1095210/task/1095213/comm" pid=1095210 comm="dhclient" 
requested_mask="wr" denied_mask="wr" fsuid=0 ouid=0

  This might or might not be linked with the fact that I can't get an
  IPv4 on this interface. Note that it happened to other, see this
  comment:

  https://bugs.launchpad.net/ubuntu/+source/apparmor/+bug/1413232/comments/8

  Or even an article recommending disabling apparmor for dhclient(!):
  
https://blog.anthony-jacob.com/perte-dip-v4-sous-ubuntu-20-04-apparmor-et-dhclient/

  
  As I said, I'm not sure this is the root cause of the lack of IPv4 renewal, 
because running it manually *does* succeed in getting an IP. And running it in 
strace shows the EACCES failure:

  [pid 1095210] openat(AT_FDCWD, "/proc/self/task/1095211/comm", O_RDWRstrace: 
Process 1095211 attached
  ) = -1 EACCES (Permission non accordée)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/isc-dhcp/+bug/1918410/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1234887] Re: [FFE] Update NetworkManager to 0.9.8.4

2021-03-26 Thread christopher wayne hess
** Changed in: network-manager (Ubuntu)
 Assignee: (unassigned) => christopher wayne hess (hess8519)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1234887

Title:
  [FFE] Update NetworkManager to 0.9.8.4

Status in network-manager package in Ubuntu:
  Fix Released
Status in network-manager source package in Saucy:
  Invalid
Status in network-manager source package in Trusty:
  Fix Released

Bug description:
  Let's update NetworkManager to 0.9.8.4; which is a bugfix release;
  minor version number change. Most specifically, multiple fixes for
  use-after-free and memory leaks, along with fixes for other possible
  crashes.

  Full list of commits is below.

  a450929 release: bump version to 0.9.8.4
  578b7c1 release: update NEWS
  4a4d58a libnm-glib: bump soname for added functions
  a00701d libnm-glib: fix annotations again: 0.9.8.4, not 0.9.8.6
  46345e0 libnm-glib: change the "Since: 0.9.10" annotations to "Since: 0.9.8.6"
  1d6947a ifcfg-rh: fix tests
  90c957c build: fix builddir != srcdir when building D-Bus API spec HTML
  72e3dd7 core: fix handling of ActiveConnections on Policy dispose()
  65590de libnm-util: accept old-style UUIDs as valid
  a10dea3 agents: don't make method calls with a destroyed proxy
  52b3810 core: fix NMPolicy/NMManager refcounting
  59c165a build: don't use g_clear_pointer()
  636387f trivial: nm_connectivity_check_async() returns void -> use 
g_return_if_fail()
  226b9b1 core: fix warning about unused variable
  299081e libnm-glib: Add NMClient:primary-connection and 
:activating-connection 
  61a81d1 core: add NMManager:primary-connection and :activating-connection 
 
  2489018 core: make NMPolicy a GObject
  693112f libnm-glib: support new connectivity property/methods 
 
  d34e77c core: provide additional network connectivity information 
 
  a5eeeb7 core: improve NMManager:state transitions with connectivity checking  
 
  0d2ccfd core: add LOGD_CONCHECK, log unexpected concheck responses at 
LOGL_INFO
  68356b5 core: build NMConnectivity unconditionally, possibly as a no-op
  a040f0b core: clean up connectivity code a bit
  62e59ed ifcfg-rh: do not write IPV6_DEFAULTGW=:: for missing gateway
  ee58f2a policy: prevent double-deactivation of an NMActiveConnection after 
it's removed
  49f8da5 wifi: change bgscan threshold parameter  (fixes bug 1071942)
  82be4aa ifcfg-rh: fix handling of VLAN parent PHYSDEV key
  f595624 systemd: fix up dispatcher unit install (rh #948433)
  8dc646e core: don't log warnings when devices are removed
  4f1e7e9 dhcp: kill dhclient on fatal errors
  94f5d09 dnsmasq: does handle more than one nameserver per domain
  886ee9a keyfile: ignore Emacs interlocking link named .# (rh 
#987629)
  764f0e2 core: fix flushing of routes and updating legacy IPv4 address property
  5628350 main: Set umask earlier
  1a7e606 main: setenv(GIO_USE_VFS=local) *very* early
  dc70b48 libnm-glib: fix device description with newer udev versions
  b73b963 dhcp: don't crash checking lease config if no DHCP client is usable
  89cb9e5 build: allow dhcpcd versions higher than 5
  dad3e1c nm-online: describe '--timeout' option more exactly (rh #969363)
  c068709 dispatcher: fix tests after 42577c5269fdf4e9bea442eb96fcba7f8403bda5
  42577c5 dispatcher: expose domains in IP4/6 config (bgo #701820)
  65edeb9 dispatcher: publish vpn_ip6_config
  b0f23d2 libnm-util: fix possible crash when IP method is NULL
  d4d9d36 core: set GError on failure in nm_manager_deactivate_connection() (rh 
#976627)
  c38e901 keyfile: do not set GError over the top of a previous GError
  3172ff1 dbus: fix dbus_connection_changed_cb() definition to take 
DBusConnection
  f324bfb keyfile: fix reading bonding options (bgo #701527)
  8e9e392 libnm-util: remove 'downdelay' and 'updelay' when setting 
'arp_interval'
  261db76 libnm-util: verify() - can't set both IPv4 'disabled' and IPv6 
'ignore' method
  77b24af libnm-glib: fix the object creation warning for remote connections
  665f42f wifi: fix checking AP mode and EAP-FAST support
  050c979 agents: don't require root agents to be part of a login session
  1c4f777 core: assume root always has a session for connection visibility
  9b82977 release: bump version to 0.9.8.2
  8d6828a libnm-util: fix 93c1041b9b3f48b42e35401b0dd756538935e870 for handling 
disabled
  62bb5ec release: update NEWS
  55ce7fe build: fix reporting of modemmanager-1 compilation status
  cca0bc9 wired: ignore carrier state for manual/static bridge and bond 
connections
  9c57277 wifi: fix possible crash when IP configuration times out (rh #854073)
  93c1041 libnm-util: recognize "disabled" as an IPv6 config method
  c126d97 modem-manager: read 'SupportedCapabilities' instead of 
'ModemCapabilities' (bgo #701668)
  0ff869e modem-manager: don't request allowed modes when talking to 

[Touch-packages] [Bug 1921531] Re: with breeze dark theme, buttons in thunderbird become indistinguishable

2021-03-26 Thread Ubuntu Foundations Team Bug Bot
** Package changed: ubuntu => xorg (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1921531

Title:
  with breeze dark theme, buttons in thunderbird become
  indistinguishable

Status in xorg package in Ubuntu:
  New

Bug description:
  In Thunderbird, when I select a dark GTK3 theme in the system
  settings, the "quick filter" buttons that are pressed are not
  distinguishable anymore from the ones that are not selected (there is
  a difference, but it is so slight that I don't see it unless the
  displays brightness is really high).

  Attached are two screenshots, one with the default and one with the
  breeze-dark theme. Note that "Sender" is selected, but "Recipients" is
  not, but this is almost invisible in the dark theme.

  I also tried other dark themes in addition to Breeze, and none of them
  work in this respect.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: xorg 1:7.7+19ubuntu14
  ProcVersionSignature: Ubuntu 5.4.0-70.78-generic 5.4.94
  Uname: Linux 5.4.0-70-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.16
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: KDE
  Date: Fri Mar 26 17:34:33 2021
  DistUpgraded: 2020-07-17 08:50:24,821 DEBUG Running PostInstallScript: 
'./xorg_fix_proprietary.py'
  DistroCodename: focal
  DistroVariant: ubuntu
  DkmsStatus:
   v4l2loopback, 0.12.5, 5.4.0-67-generic, x86_64: installed
   v4l2loopback, 0.12.5, 5.4.0-70-generic, x86_64: installed
  ExtraDebuggingInterest: No
  GraphicsCard:
   Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics 
Controller [8086:0412] (rev 06) (prog-if 00 [VGA controller])
 Subsystem: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor 
Integrated Graphics Controller [8086:204a]
  InstallationDate: Installed on 2018-06-01 (1029 days ago)
  InstallationMedia: Kubuntu 18.04 LTS "Bionic Beaver" - Release amd64 
(20180426)
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-70-generic 
root=UUID=b01a81fc-c0a2-4316-817e-edd0c3c6b622 ro quiet splash vt.handoff=7
  SourcePackage: xorg
  Symptom: display
  UpgradeStatus: Upgraded to focal on 2020-07-17 (252 days ago)
  dmi.bios.date: 04/17/2014
  dmi.bios.vendor: Intel Corp.
  dmi.bios.version: RLH8710H.86A.0325.2014.0417.1800
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: DH87RL
  dmi.board.vendor: Intel Corporation
  dmi.board.version: AAG74240-403
  dmi.chassis.type: 3
  dmi.modalias: 
dmi:bvnIntelCorp.:bvrRLH8710H.86A.0325.2014.0417.1800:bd04/17/2014:svn:pn:pvr:rvnIntelCorporation:rnDH87RL:rvrAAG74240-403:cvn:ct3:cvr:
  dmi.product.family: To be filled by O.E.M.
  dmi.product.sku: To be filled by O.E.M.
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.102-1ubuntu1~20.04.1
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.2.6-0ubuntu0.20.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.2.6-0ubuntu0.20.04.1
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.9-2ubuntu1.2~20.04.1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1921531/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921531] [NEW] with breeze dark theme, buttons in thunderbird become indistinguishable

2021-03-26 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

In Thunderbird, when I select a dark GTK3 theme in the system settings,
the "quick filter" buttons that are pressed are not distinguishable
anymore from the ones that are not selected (there is a difference, but
it is so slight that I don't see it unless the displays brightness is
really high).

Attached are two screenshots, one with the default and one with the
breeze-dark theme. Note that "Sender" is selected, but "Recipients" is
not, but this is almost invisible in the dark theme.

I also tried other dark themes in addition to Breeze, and none of them
work in this respect.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: xorg 1:7.7+19ubuntu14
ProcVersionSignature: Ubuntu 5.4.0-70.78-generic 5.4.94
Uname: Linux 5.4.0-70-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.16
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CasperMD5CheckResult: skip
CompositorRunning: None
CurrentDesktop: KDE
Date: Fri Mar 26 17:34:33 2021
DistUpgraded: 2020-07-17 08:50:24,821 DEBUG Running PostInstallScript: 
'./xorg_fix_proprietary.py'
DistroCodename: focal
DistroVariant: ubuntu
DkmsStatus:
 v4l2loopback, 0.12.5, 5.4.0-67-generic, x86_64: installed
 v4l2loopback, 0.12.5, 5.4.0-70-generic, x86_64: installed
ExtraDebuggingInterest: No
GraphicsCard:
 Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics 
Controller [8086:0412] (rev 06) (prog-if 00 [VGA controller])
   Subsystem: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor 
Integrated Graphics Controller [8086:204a]
InstallationDate: Installed on 2018-06-01 (1029 days ago)
InstallationMedia: Kubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-70-generic 
root=UUID=b01a81fc-c0a2-4316-817e-edd0c3c6b622 ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: Upgraded to focal on 2020-07-17 (252 days ago)
dmi.bios.date: 04/17/2014
dmi.bios.vendor: Intel Corp.
dmi.bios.version: RLH8710H.86A.0325.2014.0417.1800
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: DH87RL
dmi.board.vendor: Intel Corporation
dmi.board.version: AAG74240-403
dmi.chassis.type: 3
dmi.modalias: 
dmi:bvnIntelCorp.:bvrRLH8710H.86A.0325.2014.0417.1800:bd04/17/2014:svn:pn:pvr:rvnIntelCorporation:rnDH87RL:rvrAAG74240-403:cvn:ct3:cvr:
dmi.product.family: To be filled by O.E.M.
dmi.product.sku: To be filled by O.E.M.
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.102-1ubuntu1~20.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 20.2.6-0ubuntu0.20.04.1
version.libgl1-mesa-glx: libgl1-mesa-glx 20.2.6-0ubuntu0.20.04.1
version.xserver-xorg-core: xserver-xorg-core 2:1.20.9-2ubuntu1.2~20.04.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug focal kubuntu ubuntu
-- 
with breeze dark theme, buttons in thunderbird become indistinguishable
https://bugs.launchpad.net/bugs/1921531
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to xorg in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921546] Re: [FFe] ubuntu-server to recommend needrestart

2021-03-26 Thread Dimitri John Ledkov
** Description changed:

  needrestart MIR has been completed.
  https://bugs.launchpad.net/ubuntu/+source/needrestart/+bug/1907422
  
  We are post FF, thus I am asking FFe to include needrestart as
  recommends in the ubuntu-server package.
  
  This change will results in needrestart being installed by default in
  the Ubuntu Server product. As it will change the default CLI experience.
  I'm writting a post to discourse about this too.
+ 
+ This can be discussed on https://discourse.ubuntu.com/t/needrestart-for-
+ servers/21552 too

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu.
https://bugs.launchpad.net/bugs/1921546

Title:
  [FFe] ubuntu-server to recommend needrestart

Status in ubuntu-meta package in Ubuntu:
  Triaged

Bug description:
  needrestart MIR has been completed.
  https://bugs.launchpad.net/ubuntu/+source/needrestart/+bug/1907422

  We are post FF, thus I am asking FFe to include needrestart as
  recommends in the ubuntu-server package.

  This change will results in needrestart being installed by default in
  the Ubuntu Server product. As it will change the default CLI
  experience. I'm writting a post to discourse about this too.

  This can be discussed on https://discourse.ubuntu.com/t/needrestart-
  for-servers/21552 too

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-meta/+bug/1921546/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1920836] Re: Show Extended Security Maintenence status

2021-03-26 Thread Chad Smith
Another thing to note/expect: ua client in release in xenial and bionic
at the moment is a completed incompatible commandine (which we are
planning on SRUing prior to Xenial ESM, so `ua status --format=json`
will not work on something <  version 20. I'm fairly certain you
shouldn't care to support this old version of ua-tools, but you might
want to just do a pre-flight check on Xenial and bionic 'ua version' >=
20 and return (False, False) in that case notiing that those
environments should update their versionn of ubuntu-advantage-tools.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to software-properties in
Ubuntu.
https://bugs.launchpad.net/bugs/1920836

Title:
  Show Extended Security Maintenence status

Status in software-properties package in Ubuntu:
  New
Status in software-properties source package in Xenial:
  New
Status in software-properties source package in Bionic:
  New
Status in software-properties source package in Focal:
  New
Status in software-properties source package in Hirsute:
  New

Bug description:
  [Impact]
  There is not currently a graphical method of determining if a system is 
subscribed to [Extended Security Maintenance](https://ubuntu.com/security/esm) 
updates. This is resolved by adding some [new 
UI](https://wiki.ubuntu.com/SoftwareUpdates#Extended_Security_Maintenance) to 
the software properties application.

  [Test Case]
  1. Install latest version of Ubuntu advantage:
  $ sudo add-apt-repository ppa:ua-client/stable
  $ sudo apt update
  $ sudo apt upgrade
  2. Open Software Properties
  3. Go to Updates tab.

  Expected result:
  Information is shown that indicates if this system is using Extended Security 
Maintenance updates, when updates will supported until, and a link to upgrade 
to ESM.

  Observed result:
  No ESM information currently shown.

  [Where problems could occur]
  - Software properties could hit a bug getting a response from the ua app. The 
current code carefully checks if and what is returned, falling back to a safe 
default behavior.
  - Launching software properties could trigger a bug in the ua app.
  - Software properties could show incorrect information, causing confusion for 
the user. The solution uses information from distro-info and the ua app which 
means software-properties contains no data about ESM, and instead relies on 
these apps that can be updated if things change.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/1920836/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921546] Re: [FFe] ubuntu-server to recommend needrestart

2021-03-26 Thread Steve Langasek
FFe approved.  This has been discussed extensively and has only been
blocked by the MIR completion.

** Changed in: ubuntu-meta (Ubuntu)
   Status: New => Triaged

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu.
https://bugs.launchpad.net/bugs/1921546

Title:
  [FFe] ubuntu-server to recommend needrestart

Status in ubuntu-meta package in Ubuntu:
  Triaged

Bug description:
  needrestart MIR has been completed.
  https://bugs.launchpad.net/ubuntu/+source/needrestart/+bug/1907422

  We are post FF, thus I am asking FFe to include needrestart as
  recommends in the ubuntu-server package.

  This change will results in needrestart being installed by default in
  the Ubuntu Server product. As it will change the default CLI
  experience. I'm writting a post to discourse about this too.

  This can be discussed on https://discourse.ubuntu.com/t/needrestart-
  for-servers/21552 too

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-meta/+bug/1921546/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1878194] Re: [Sennheiser HD 4.50 BTNC] Bluetooth headset not working when selecting HSP/HFP audio profile in Focal Fossa

2021-03-26 Thread Michael Davis
*** This bug is a duplicate of bug 1871794 ***
https://bugs.launchpad.net/bugs/1871794

I'm experiencing this issue as well. On the HSP/HFP profile, the audio
output comes through crystal clear, but the microphone is lost. On the
A2DP profile, I get the microphone back, but the sound quality on the
headphones becomes terrible... sounds like I'm on a copper phone line or
bad cell signal.

- Kernel: 5.8.0-48-generic
- OS: Ubuntu 20.04.2 LTS
- Machine: Lenovo ThinkPad T-490
- Headset: Bose QuietComfort 35 II

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1878194

Title:
  [Sennheiser HD 4.50 BTNC] Bluetooth headset not working when selecting
  HSP/HFP audio profile in Focal Fossa

Status in bluez package in Ubuntu:
  Confirmed
Status in pulseaudio package in Ubuntu:
  Confirmed

Bug description:
  After updating the release from Ubuntu 19.10 to 20.04, the bluetooth
  headset doesn't work anymore when HSP/HFP profile is selected.

  With Ubuntu 19.10 the headset was working, there was audio and the mic
  was perfect for video conferencing.

  [Steps to reproduce]
  1. Connect headset (used blueman to setup and connect)
  1.1. When connected the system automatically selects A2DP profile
  2. Start playing audio (browser or other)
  3. Change profile to HSP/HFP with pavucontrol (or blueman)
  4. The audio disappears and microphone is not working (no input)
  5. Optionally switch back to A2DP and the audio comes back

  [Expected]
  When switching to HSP/HFP the audio should keep playing and the microphone 
should start working

  [Notes]
  I tried with pavucontrol to switch between profiles while playing audio from 
a browser.
  As side note there's a led in the headset that still blinks when switching 
profile.

  I tried deleting the pulse folder under user's profile .config without
  success, also reinstalled packages and did a `sudo alsa force-reload`
  and rebooting several times.

  Note: not sure this is a duplicate of [Bug #1576559], it looks quite
  different since the profile changes but the headset stops working.

  [System info]
  Ubuntu: 20.04 - Linux 5.4.0-29-generic x86_64
  pulseaudio: 1:13.99.1-1ubuntu3
  bluez: 5.53-0ubuntu3

  Headset: Sennheiser HD 4.50 BTNC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1878194/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921546] [NEW] [FFe] ubuntu-server to recommend needrestart

2021-03-26 Thread Dimitri John Ledkov
Public bug reported:

needrestart MIR has been completed.
https://bugs.launchpad.net/ubuntu/+source/needrestart/+bug/1907422

We are post FF, thus I am asking FFe to include needrestart as
recommends in the ubuntu-server package.

This change will results in needrestart being installed by default in
the Ubuntu Server product. As it will change the default CLI experience.
I'm writting a post to discourse about this too.

** Affects: ubuntu-meta (Ubuntu)
 Importance: Undecided
 Status: Triaged

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu.
https://bugs.launchpad.net/bugs/1921546

Title:
  [FFe] ubuntu-server to recommend needrestart

Status in ubuntu-meta package in Ubuntu:
  Triaged

Bug description:
  needrestart MIR has been completed.
  https://bugs.launchpad.net/ubuntu/+source/needrestart/+bug/1907422

  We are post FF, thus I am asking FFe to include needrestart as
  recommends in the ubuntu-server package.

  This change will results in needrestart being installed by default in
  the Ubuntu Server product. As it will change the default CLI
  experience. I'm writting a post to discourse about this too.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-meta/+bug/1921546/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1920836] Re: Show Extended Security Maintenence status

2021-03-26 Thread Chad Smith
Thanks @robert-ancell for setting up the PPA.

I tested on Xenial Ubuntu Desktop LiveCD and would like to report
Failure on this implementation.

Your use of subprocess is passing capture_output on xenial and that is
raising an error in python before calling ua client.


On a system attached to esm-apps:


python3 -c 'import gi; gi.require_version("Gtk", "3.0"); from 
softwareproperties.gtk.utils import get_esm_apps_status; 
print(get_esm_apps_status())'
Failed to call ubuntu advantage client:
__init__() got an unexpected keyword argument 'capture_output'
(False, False)


Note that run(capture_output) param is not available on python3.5 (it was 
introduced only in 3.7).

Also just dropping that capture_output param you've got some other logic
relying on result.stdout which is None in this case.

while you iterate on this work, you could substitute esm-infra  in your 
get_esm_apps_status function as it'll behave the same way as app, and all 
contracts are entitled to esm-infra at the moment so it will be easier to test 
enabled, available etc.
 
If you'd like review on the iterations of these SRU branches related to this 
just assign lamoura or chad.smith too and we can take a look.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to software-properties in
Ubuntu.
https://bugs.launchpad.net/bugs/1920836

Title:
  Show Extended Security Maintenence status

Status in software-properties package in Ubuntu:
  New
Status in software-properties source package in Xenial:
  New
Status in software-properties source package in Bionic:
  New
Status in software-properties source package in Focal:
  New
Status in software-properties source package in Hirsute:
  New

Bug description:
  [Impact]
  There is not currently a graphical method of determining if a system is 
subscribed to [Extended Security Maintenance](https://ubuntu.com/security/esm) 
updates. This is resolved by adding some [new 
UI](https://wiki.ubuntu.com/SoftwareUpdates#Extended_Security_Maintenance) to 
the software properties application.

  [Test Case]
  1. Install latest version of Ubuntu advantage:
  $ sudo add-apt-repository ppa:ua-client/stable
  $ sudo apt update
  $ sudo apt upgrade
  2. Open Software Properties
  3. Go to Updates tab.

  Expected result:
  Information is shown that indicates if this system is using Extended Security 
Maintenance updates, when updates will supported until, and a link to upgrade 
to ESM.

  Observed result:
  No ESM information currently shown.

  [Where problems could occur]
  - Software properties could hit a bug getting a response from the ua app. The 
current code carefully checks if and what is returned, falling back to a safe 
default behavior.
  - Launching software properties could trigger a bug in the ua app.
  - Software properties could show incorrect information, causing confusion for 
the user. The solution uses information from distro-info and the ua app which 
means software-properties contains no data about ESM, and instead relies on 
these apps that can be updated if things change.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/1920836/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1916485] Re: test -x fails inside shell scripts in containers

2021-03-26 Thread Stiverton
Will this be fixed in the 21.04 tag docker image as well?  I am having
the problem there also.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1916485

Title:
  test -x fails inside shell scripts in containers

Status in docker.io package in Ubuntu:
  New
Status in glibc package in Ubuntu:
  Opinion
Status in libseccomp package in Ubuntu:
  Fix Committed
Status in runc package in Ubuntu:
  Fix Released
Status in systemd package in Ubuntu:
  Fix Released
Status in docker.io source package in Xenial:
  New
Status in libseccomp source package in Xenial:
  New
Status in runc source package in Xenial:
  New
Status in systemd source package in Xenial:
  New
Status in docker.io source package in Bionic:
  New
Status in libseccomp source package in Bionic:
  New
Status in runc source package in Bionic:
  Fix Committed
Status in systemd source package in Bionic:
  New
Status in docker.io source package in Focal:
  New
Status in libseccomp source package in Focal:
  New
Status in runc source package in Focal:
  Fix Committed
Status in systemd source package in Focal:
  New
Status in docker.io source package in Groovy:
  New
Status in libseccomp source package in Groovy:
  New
Status in runc source package in Groovy:
  Fix Committed
Status in systemd source package in Groovy:
  Fix Released
Status in docker.io source package in Hirsute:
  New
Status in libseccomp source package in Hirsute:
  Fix Committed
Status in runc source package in Hirsute:
  Fix Released
Status in systemd source package in Hirsute:
  Fix Released

Bug description:
  (SRU template for systemd)

  [impact]

  bash (and some other shells) builtin test command -x operation fails

  [test case]

  on any affected host system, start nspawn container, e.g.:

  $ sudo apt install systemd-container
  $ wget 
https://cloud-images.ubuntu.com/hirsute/current/hirsute-server-cloudimg-amd64-root.tar.xz
  $ mkdir h
  $ cd h
  $ tar xvf ../hirsute-server-cloudimg-amd64-root.tar.xz
  $ sudo systemd-nspawn

  Then from a bash shell, verify if test -x works:

  root@h:~# ls -l /usr/bin/gpg
  -rwxr-xr-x 1 1000 1000 1083472 Jan 16 09:53 /usr/bin/gpg
  root@h:~# test -x /usr/bin/gpg || echo "fail"
  fail

  [regression potential]

  any regression would likely occur during a syscall, most likely
  faccessat2(), or during other syscalls.

  [scope]

  this is needed for b/f

  this is fixed upstream by commit
  bcf08acbffdee0d6360d3c31d268e73d0623e5dc which is in 247 and later, so
  this is fixed in h

  this was pulled into Debian at version 246.2 in commit
  e80c5e5371ab77792bae94e0f8c5e85a4237e6eb, so this is fixed in g

  in x, the entire systemd seccomp code is completely different and the
  patch doesn't apply, nor does it appear to be needed, as the problem
  doesn't reproduce in a h container under x.

  [other info]

  this needs fixing in libseccomp as well

  [original description]

  glibc regression causes test -x to fail inside scripts inside
  docker/podman, dash and bash are broken, mksh and zsh are fine:

  root@0df2ce5d7a46:/# test -x /usr/bin/gpg || echo Fail
  root@0df2ce5d7a46:/# dash -c "test -x /usr/bin/gpg || echo Fail"
  Fail
  root@0df2ce5d7a46:/# bash -c "test -x /usr/bin/gpg || echo Fail"
  Fail
  root@0df2ce5d7a46:/# mksh -c "test -x /usr/bin/gpg || echo Fail"
  root@0df2ce5d7a46:/# zsh -c "test -x /usr/bin/gpg || echo Fail"
  root@0df2ce5d7a46:/#

  root@0df2ce5d7a46:/# zsh -c "[ -x /usr/bin/gpg ] || echo Fail"
  root@0df2ce5d7a46:/# mksh -c "[ -x /usr/bin/gpg ] || echo Fail"
  root@0df2ce5d7a46:/# dash -c "[ -x /usr/bin/gpg ] || echo Fail"
  Fail
  root@0df2ce5d7a46:/# bash -c "[ -x /usr/bin/gpg ] || echo Fail"
  Fail

  The -f flag works, as does /usr/bin/test:
  # bash -c "test -f /usr/bin/gpg  || echo Fail"
  # bash -c "/usr/bin/test -x /usr/bin/gpg  || echo Fail"
  #

  [Original bug report]
  root@84b750e443f8:/# lsb_release -rd
  Description:  Ubuntu Hirsute Hippo (development branch)
  Release:  21.04
  root@84b750e443f8:/# dpkg -l gnupg apt
  Desired=Unknown/Install/Remove/Purge/Hold
  | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
  |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
  ||/ Name   Version Architecture Description
  
+++-==-===--==
  ii  apt2.1.20  amd64commandline package manager
  ii  gnupg  2.2.20-1ubuntu2 all  GNU privacy guard - a free 
PGP replacement

  Hi,
  for 3 days our CI pipelines to recreate Docker images fails for the Hirsute 
images. From comparison this seems to be caused by apt 2.1.20.

  The build fails with:

  0E: gnupg, gnupg2 and unupg1 do not seem to be installed, but one of
  them is required for this operation

  The simple Dockerfile to reproduce the error - "docker build -t foo ."

  

[Touch-packages] [Bug 1795278] Re: software-properties-{qt, kde} attempts to use KUrl but it doesn't exist

2021-03-26 Thread Leó Kolbeinsson
@wxl

This is still occuring on Lubuntu Hirsute  daily ISO 2021-03-26.

Tested also Ubuntu Mate and Xubuntu same date and no error.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to software-properties in
Ubuntu.
https://bugs.launchpad.net/bugs/1795278

Title:
  software-properties-{qt,kde} attempts to use KUrl but it doesn't exist

Status in software-properties package in Ubuntu:
  Triaged

Bug description:
  Release: Kubuntu 18.04
  Version: 0.96.24.32.1

  When clicking the "Import Key" button in the "Authentication" section
  of the panel it throws this error:

  Traceback (most recent call last):
File 
"/usr/lib/python3/dist-packages/softwareproperties/kde/SoftwarePropertiesKDE.py",
 line 667, in add_key_clicked
  url = KUrl.fromPath(home)
  NameError: name 'KUrl' is not defined

  While this doesn't crash the program it causes nothing to happen when
  clicking the button. Running the program in a terminal reveals the
  error being printed to stderr.

  After debugging it appears KUrl doesn't exist anywhere and I'm not
  sure if's a python module that has changed.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/1795278/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1920640] Re: EXPKEYSIG C8CAB6595FDFF622 Ubuntu Debug Symbol Archive Automatic Signing Key (2016)

2021-03-26 Thread Brian Murray
I tested this on Bionic (albeit using Ubuntu Error Tracker retracing
systems) and updating the ubuntu-dbgsym-kerying from -proposed allowed
them to retrace crashes again so setting to verification-done.

2021-03-26 
17:15:33,167:19962:140010884187968:INFO:root:6d1acc70-8e56-11eb-8af4-fa163e9b80e2:swift:Processing.
2021-03-26 
17:15:33,219:19962:140010884187968:INFO:root:6d1acc70-8e56-11eb-8af4-fa163e9b80e2:swift:Decompressing
 to /tmp/tmprCylMh-swift.6d1
acc70-8e56-11eb-8af4-fa163e9b80e2.oopsid.core
2021-03-26 
17:15:33,314:19962:140010884187968:INFO:root:6d1acc70-8e56-11eb-8af4-fa163e9b80e2:swift:Retracing
 6d1acc70-8e56-11eb-8af4-fa163e9
b80e2:swift with sandbox-dir /srv/daisy.staging.ubuntu.com/devel/cache/Ubuntu 
21.04/cache-uUsGBd/sandbox with cache /srv/daisy.staging.ubunt
u.com/devel/cache/Ubuntu 21.04/cache-uUsGBd/cache
2021-03-26 
17:15:36,471:19962:140010884187968:INFO:root:6d1acc70-8e56-11eb-8af4-fa163e9b80e2:swift:Apport's
 return code was 1.
2021-03-26 
17:15:36,471:19962:140010884187968:INFO:root:6d1acc70-8e56-11eb-8af4-fa163e9b80e2:swift:ERROR:
 W:Download is performed unsandboxe
d as root as file '/srv/daisy.staging.ubuntu.com/devel/cache/Ubuntu 
21.04/cache-uUsGBd/cache/Ubuntu 21.04/apt/var/lib/apt/lists/partial/arch
ive.ubuntu.com_ubuntu_dists_hirsute_InRelease' couldn't be accessed by user 
'_apt'. - pkgAcquire::Run (13: Permission denied), W:GPG error: 
http://ddebs.ubuntu.com hirsute Release: The following signatures were invalid: 
EXPKEYSIG C8CAB6595FDFF622 Ubuntu Debug Symbol Archive Autom
atic Signing Key (2016) , E:The repository 
'http://ddebs.ubuntu.com hirsute Release' is not signed., W:Upda
ting from such a repository can't be done securely, and is therefore disabled 
by default., W:See apt-secure(8) manpage for repository creati
on and user configuration details., W:GPG error: http://ddebs.ubuntu.com 
hirsute-updates Release: The following signatures were invalid: EXP
KEYSIG C8CAB6595FDFF622 Ubuntu Debug Symbol Archive Automatic Signing Key 
(2016) , E:The repository 'http:/
/ddebs.ubuntu.com hirsute-updates Release' is not signed.
2021-03-26 
17:15:36,471:19962:140010884187968:INFO:root:6d1acc70-8e56-11eb-8af4-fa163e9b80e2:swift:Will
 retry (6d1acc70-8e56-11eb-8af4-fa163
e9b80e2) due to a transient error.
2021-03-26 
17:15:36,473:19962:140010884187968:INFO:root:6d1acc70-8e56-11eb-8af4-fa163e9b80e2:swift:Processing.
2021-03-26 
17:15:36,657:19962:140010884187968:INFO:root:6d1acc70-8e56-11eb-8af4-fa163e9b80e2:swift:Decompressing
 to /tmp/tmpaSBRUl-swift.6d1
acc70-8e56-11eb-8af4-fa163e9b80e2.oopsid.core
2021-03-26 
17:15:36,751:19962:140010884187968:INFO:root:6d1acc70-8e56-11eb-8af4-fa163e9b80e2:swift:Retracing
 6d1acc70-8e56-11eb-8af4-fa163e9
b80e2:swift with sandbox-dir /srv/daisy.staging.ubuntu.com/devel/cache/Ubuntu 
21.04/cache-uUsGBd/sandbox with cache /srv/daisy.staging.ubunt
u.com/devel/cache/Ubuntu 21.04/cache-uUsGBd/cache
2021-03-26 
17:16:35,063:19962:140010884187968:INFO:root:6d1acc70-8e56-11eb-8af4-fa163e9b80e2:swift:Writing
 back to Cassandra
2021-03-26 
17:16:35,150:19962:140010884187968:INFO:root:6d1acc70-8e56-11eb-8af4-fa163e9b80e2:swift:Successfully
 retraced.

ubuntu@juju-1124ad-devel-error-tracker-9:/srv/daisy.staging.ubuntu.com/devel-logs$
 apt-cache policy ubuntu-dbgsym-keyring
ubuntu-dbgsym-keyring:
  Installed: 2018.09.18.1~18.04.1
  Candidate: 2018.09.18.1~18.04.1
  Version table:
 *** 2018.09.18.1~18.04.1 500
500 http://archive.ubuntu.com/ubuntu bionic-proposed/universe amd64 
Packages
100 /var/lib/dpkg/status
 2018.09.18.1~18.04.0 500
500 http://prodstack-zone-2.clouds.archive.ubuntu.com/ubuntu 
bionic-updates/universe amd64 Packages
 2018.02.28 500
500 http://prodstack-zone-2.clouds.archive.ubuntu.com/ubuntu 
bionic/universe amd64 Packages


** Tags removed: verification-needed-bionic
** Tags added: verification-done-bionic

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-keyring in Ubuntu.
https://bugs.launchpad.net/bugs/1920640

Title:
  EXPKEYSIG C8CAB6595FDFF622 Ubuntu Debug Symbol Archive Automatic
  Signing Key (2016) 

Status in ubuntu-keyring package in Ubuntu:
  Fix Released
Status in ubuntu-keyring source package in Bionic:
  Fix Committed
Status in ubuntu-keyring source package in Focal:
  Fix Committed
Status in ubuntu-keyring source package in Groovy:
  Fix Committed
Status in ubuntu-keyring source package in Hirsute:
  Fix Released

Bug description:
  [Impact]

   * Cannot update apt metadata from ddebs.ubuntu.com whilst using
  ubuntu-dbgsym-keyring package

  [Test Plan]

   * Install ubuntu-dbgsym-keyring package
   * Add ddebs.ubuntu.com repository for your release
   * sudo apt update must be successful

  [Where problems could occur]

   * At the moment the signature was bumped by one year
   * Meaning this issue will occur again in 2022
   * Instead the key must be set to not expire & new round of SRUs issued

  

[Touch-packages] [Bug 1903057] Re: vim confused by \~/

2021-03-26 Thread gregrwm
see https://github.com/vim/vim/issues/8015

** Bug watch added: github.com/vim/vim/issues #8015
   https://github.com/vim/vim/issues/8015

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to vim in Ubuntu.
https://bugs.launchpad.net/bugs/1903057

Title:
  vim confused by \~/

Status in vim package in Ubuntu:
  New

Bug description:
   $ cd
   $ mkdir \~
   $ echo content a>\~/a
   $ echo content b>b
   $ less \~/a b
  :n
  :e#
  :q
   $ vim \~/a b
  :n
  :e#

  less is not confused, but vim has forgotten where the first file was.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: vim 2:8.0.1453-1ubuntu1.3
  ProcVersionSignature: Ubuntu 5.3.0-51.44~18.04.2-generic 5.3.18
  Uname: Linux 5.3.0-51-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.14
  Architecture: amd64
  Date: Thu Nov  5 08:50:54 2020
  InstallationDate: Installed on 2019-11-16 (354 days ago)
  InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 
(20190210)
  ProcEnviron:
   LC_TIME=en_DK.utf8
   TERM=screen
   PATH=(custom, no user)
   LANG=en_US.utf8
   SHELL=/bin/bash
  SourcePackage: vim
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/vim/+bug/1903057/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1918855] Re: Xorg xserver got signal 6 to abort

2021-03-26 Thread Ubuntu Foundations Team Bug Bot
The attachment "mesa_20.2.6-0ubuntu0.20.04.2.debdiff" seems to be a
debdiff.  The ubuntu-sponsors team has been subscribed to the bug report
so that they can review and hopefully sponsor the debdiff.  If the
attachment isn't a patch, please remove the "patch" flag from the
attachment, remove the "patch" tag, and if you are member of the
~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by
~brian-murray, for any issue please contact him.]

** Tags added: patch

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1918855

Title:
  Xorg xserver got signal 6 to abort

Status in Mesa:
  Unknown
Status in OEM Priority Project:
  New
Status in mesa package in Ubuntu:
  New

Bug description:
  I run checkbox job
  com.canonical.certification::memory/memory_stress_ng on focal, and the
  xserver stops unexpectedly with the following stacktrace:

  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 0: /usr/lib/xorg/Xorg 
(OsLookupColor+0x13c) [0x5619f3a4d59c]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 1: 
/lib/x86_64-linux-gnu/libpthread.so.0 (funlockfile+0x60) [0x7fae4786741f]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 2: /lib/x86_64-linux-gnu/libc.so.6 
(gsignal+0xcb) [0x7fae476a418b]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 3: /lib/x86_64-linux-gnu/libc.so.6 
(abort+0x12b) [0x7fae47683859]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) unw_get_proc_name failed: no unwind 
info found [-10]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 4: 
/usr/lib/x86_64-linux-gnu/dri/iris_dri.so (?+0x0) [0x7fae457d7aec]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 5: 
/usr/lib/x86_64-linux-gnu/dri/iris_dri.so (nouveau_drm_screen_create+0x25c8ec) 
[0x7fae46529c9c]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 6: 
/usr/lib/x86_64-linux-gnu/dri/iris_dri.so 
(__driDriverGetExtensions_zink+0x2561d) [0x7fae4582c74d]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 7: 
/usr/lib/xorg/modules/libglamoregl.so (glamor_destroy_pixmap+0x150) 
[0x7fae47007480]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) unw_get_proc_name failed: no unwind 
info found [-10]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 8: 
/usr/lib/xorg/modules/drivers/modesetting_drv.so (?+0x0) [0x7fae47040a30]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 9: /usr/lib/xorg/Xorg 
(BlockHandler+0xa5) [0x5619f38f0995]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 10: /usr/lib/xorg/Xorg 
(WaitForSomething+0x122) [0x5619f3a46c12]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 11: /usr/lib/xorg/Xorg 
(SendErrorToClient+0x117) [0x5619f38ebcf7]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 12: /usr/lib/xorg/Xorg 
(InitFonts+0x3b4) [0x5619f38effc4]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 13: /lib/x86_64-linux-gnu/libc.so.6 
(__libc_start_main+0xf3) [0x7fae476850b3]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 14: /usr/lib/xorg/Xorg (_start+0x2e) 
[0x5619f38d9a2e]

  More info:
  I searched the Internet and got a bug with the same stacktrace:
  https://gitlab.freedesktop.org/mesa/mesa/-/issues/3468

To manage notifications about this bug go to:
https://bugs.launchpad.net/mesa/+bug/1918855/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921527] [NEW] Call to cupsGetDestMediaDefault always returns Letter

2021-03-26 Thread Jim Orcheson
Public bug reported:

The following always returns size of Letter regardless of what the
default is set to at localhost:631. This is the case for multiple
printers and printer manufacturers.

cups_size_t size;
int count = cupsGetDestMediaDefault(CUPS_HTTP_DEFAULT, m_dest, m_info, 0, 
);

Ubuntu 20.04
CUPS 2.3.1-9ubuntu1.1
gcc 9.3.0

For driverless printers, the PPD file shows the correct default.

** Affects: cups (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to cups in Ubuntu.
https://bugs.launchpad.net/bugs/1921527

Title:
  Call to cupsGetDestMediaDefault always returns Letter

Status in cups package in Ubuntu:
  New

Bug description:
  The following always returns size of Letter regardless of what the
  default is set to at localhost:631. This is the case for multiple
  printers and printer manufacturers.

  cups_size_t size;
  int count = cupsGetDestMediaDefault(CUPS_HTTP_DEFAULT, m_dest, m_info, 0, 
);

  Ubuntu 20.04
  CUPS 2.3.1-9ubuntu1.1
  gcc 9.3.0

  For driverless printers, the PPD file shows the correct default.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1921527/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921317] Re: [Lenovo ThinkBook 14s G2 ITL, Realtek ALC287, Speaker, Internal] Playback problem

2021-03-26 Thread Daniel Letzeisen
** Summary changed:

- [20VA, Realtek ALC287, Speaker, Internal] Playback problem
+ [Lenovo ThinkBook 14s G2 ITL, Realtek ALC287, Speaker, Internal] Playback 
problem

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1921317

Title:
  [Lenovo ThinkBook 14s G2 ITL, Realtek ALC287, Speaker, Internal]
  Playback problem

Status in alsa-driver package in Ubuntu:
  New

Bug description:
  Lenovo ThinkBook 14s G2
  1. Boot to windows (ah yes, I'm still using windows for something that's not 
fully supported by Ubuntu).
  2. Restart, boot to Ubuntu.
  3. Got no sound, except just a cool "hreck" sound when it has to be a 
sound, only a short sound although I'm about to play a long audio. Probably 
each time playback is activated the short "hreck" sound is produced.
  4. Restart, boot to Ubuntu again.
  5. It is not fixed yet.

  However the playback works if I fully turn the computer off and then
  turn it on again, instead of restarting.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: alsa-base 1.0.25+dfsg-0ubuntu5
  ProcVersionSignature: Ubuntu 5.8.0-48.54~20.04.1-generic 5.8.18
  Uname: Linux 5.8.0-48-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.16
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  fikr4n 1519 F pulseaudio
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Mar 25 11:34:59 2021
  InstallationDate: Installed on 2021-03-17 (7 days ago)
  InstallationMedia: Ubuntu 20.04.2.0 LTS "Focal Fossa" - Release amd64 
(20210209.1)
  PackageArchitecture: all
  SourcePackage: alsa-driver
  Symptom: audio
  Symptom_AlsaPlaybackTest: ALSA playback test through plughw:sofhdadsp failed
  Symptom_Card: sof-hda-dsp - sof-hda-dsp
  Symptom_Jack: Speaker, Internal
  Symptom_Type: None of the above
  Title: [20VA, Realtek ALC287, Speaker, Internal] Playback problem
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 03/03/2021
  dmi.bios.release: 1.38
  dmi.bios.vendor: LENOVO
  dmi.bios.version: F9CN38WW
  dmi.board.asset.tag: No Asset Tag
  dmi.board.name: LNVNB161216
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0Q55726 WIN
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: ThinkBook 14s G2 ITL
  dmi.ec.firmware.release: 1.37
  dmi.modalias: 
dmi:bvnLENOVO:bvrF9CN38WW:bd03/03/2021:br1.38:efr1.37:svnLENOVO:pn20VA:pvrThinkBook14sG2ITL:rvnLENOVO:rnLNVNB161216:rvrSDK0Q55726WIN:cvnLENOVO:ct10:cvrThinkBook14sG2ITL:
  dmi.product.family: ThinkBook 14s G2 ITL
  dmi.product.name: 20VA
  dmi.product.sku: LENOVO_MT_20VA_BU_idea_FM_ThinkBook 14s G2 ITL
  dmi.product.version: ThinkBook 14s G2 ITL
  dmi.sys.vendor: LENOVO
  mtime.conffile..etc.modprobe.d.alsa-base.conf: 2021-03-19T21:35:47.990357

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1921317/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1918855] Re: Xorg xserver got signal 6 to abort

2021-03-26 Thread Kai-Chuan Hsieh
@tjaalton

Thanks for your comment.

I build a test build in my ppa 
https://launchpad.net/~kchsieh/+archive/ubuntu/verification
The debdiff is attached. I'll try to verify it with the hardware in lp:1917692.

I don't know if I apply the patch correctly if you see anything wrong,
please correct me.

Thanks,

** Patch added: "mesa_20.2.6-0ubuntu0.20.04.2.debdiff"
   
https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1918855/+attachment/5481175/+files/mesa_20.2.6-0ubuntu0.20.04.2.debdiff

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1918855

Title:
  Xorg xserver got signal 6 to abort

Status in Mesa:
  Unknown
Status in OEM Priority Project:
  New
Status in mesa package in Ubuntu:
  New

Bug description:
  I run checkbox job
  com.canonical.certification::memory/memory_stress_ng on focal, and the
  xserver stops unexpectedly with the following stacktrace:

  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 0: /usr/lib/xorg/Xorg 
(OsLookupColor+0x13c) [0x5619f3a4d59c]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 1: 
/lib/x86_64-linux-gnu/libpthread.so.0 (funlockfile+0x60) [0x7fae4786741f]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 2: /lib/x86_64-linux-gnu/libc.so.6 
(gsignal+0xcb) [0x7fae476a418b]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 3: /lib/x86_64-linux-gnu/libc.so.6 
(abort+0x12b) [0x7fae47683859]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) unw_get_proc_name failed: no unwind 
info found [-10]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 4: 
/usr/lib/x86_64-linux-gnu/dri/iris_dri.so (?+0x0) [0x7fae457d7aec]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 5: 
/usr/lib/x86_64-linux-gnu/dri/iris_dri.so (nouveau_drm_screen_create+0x25c8ec) 
[0x7fae46529c9c]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 6: 
/usr/lib/x86_64-linux-gnu/dri/iris_dri.so 
(__driDriverGetExtensions_zink+0x2561d) [0x7fae4582c74d]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 7: 
/usr/lib/xorg/modules/libglamoregl.so (glamor_destroy_pixmap+0x150) 
[0x7fae47007480]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) unw_get_proc_name failed: no unwind 
info found [-10]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 8: 
/usr/lib/xorg/modules/drivers/modesetting_drv.so (?+0x0) [0x7fae47040a30]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 9: /usr/lib/xorg/Xorg 
(BlockHandler+0xa5) [0x5619f38f0995]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 10: /usr/lib/xorg/Xorg 
(WaitForSomething+0x122) [0x5619f3a46c12]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 11: /usr/lib/xorg/Xorg 
(SendErrorToClient+0x117) [0x5619f38ebcf7]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 12: /usr/lib/xorg/Xorg 
(InitFonts+0x3b4) [0x5619f38effc4]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 13: /lib/x86_64-linux-gnu/libc.so.6 
(__libc_start_main+0xf3) [0x7fae476850b3]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 14: /usr/lib/xorg/Xorg (_start+0x2e) 
[0x5619f38d9a2e]

  More info:
  I searched the Internet and got a bug with the same stacktrace:
  https://gitlab.freedesktop.org/mesa/mesa/-/issues/3468

To manage notifications about this bug go to:
https://bugs.launchpad.net/mesa/+bug/1918855/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1920665] Re: Ubiquity KDE crash on try/install and from live session with "malloc(): unaligned tcache chunk detected"

2021-03-26 Thread Brian Murray
** Changed in: ubiquity (Ubuntu Hirsute)
Milestone: None => ubuntu-21.04

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1920665

Title:
  Ubiquity KDE crash on try/install and from live session with
  "malloc(): unaligned tcache chunk detected"

Status in mesa package in Ubuntu:
  Confirmed
Status in ubiquity package in Ubuntu:
  Confirmed
Status in mesa source package in Hirsute:
  Confirmed
Status in ubiquity source package in Hirsute:
  Confirmed

Bug description:
  ProblemType: Bug
  DistroRelease: Ubuntu 21.04
  Package: ubiquity 21.04.11
  ProcVersionSignature: Ubuntu 5.11.0-11.12-generic 5.11.0
  Uname: Linux 5.11.0-11-generic x86_64
  ApportVersion: 2.20.11-0ubuntu60
  Architecture: amd64
  CasperMD5CheckResult: pass
  CasperVersion: 1.460
  CurrentDesktop: KDE
  Date: Sun Mar 21 11:53:44 2021
  InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/kubuntu.seed 
maybe-ubiquity quiet splash ---
  LiveMediaBuild: Kubuntu 21.04 "Hirsute Hippo" - Alpha amd64 (20210321)
  SourcePackage: ubiquity
  UpgradeStatus: No upgrade log present (probably fresh install)

  Since approximately 16/03/2021 ubiquity from maybe-ubiquity (try
  install screen) and from the live session is crashing on launch or
  shortly after.

  Try/Install crash:

   Screen fails to start, or starts then crashes on any user action. The
  user is presented with:

  "Installation failed - The installer encountered an unrecoverable error.
  A desktop session will now be run so that you may investigate the problem or 
try installing again"

  Live session crash:

  The installer does not start from the desktop icon. Starting ubiquity
  from the terminal results in an "Aborted (core dumped)" message and
  nothing else.

  An example /var/log/installer/debug log from a session where both
  crashes were triggered is below.

   /var/log/installer/debug 

  Ubiquity 21.04.11
  TEXT If more than one person will use this computer, you can set up 
multiple accounts after installation.
  TEXT Enter the same password twice, so that it can be checked for 
typing errors.
  TEXT The name it uses when it talks to other computers.
  TEXT Enter the same password twice, so that it can be checked for 
typing errors.
  TEXT Enter the same password twice, so that it can be checked for 
typing errors.
  TEXT If more than one person will use this computer, you can set up 
multiple accounts after installation.
  TEXT Enter the same password twice, so that it can be checked for 
typing errors.
  TEXT The name it uses when it talks to other computers.
  QSocketNotifier: Invalid socket 17 and type 'Read', disabling...
  QSocketNotifier: Invalid socket 17 and type 'Write', disabling...
  QSocketNotifier: Invalid socket 17 and type 'Exception', disabling...
  Your console font configuration will be updated the next time your system
  boots. If you want to update it now, run 'setupcon' from a virtual console.
  update-initramfs is disabled since running on read-only media
  debconf: DbDriver "passwords" warning: could not open 
/var/cache/debconf/passwords.dat: Permission denied
  munmap_chunk(): invalid pointer
  Ubiquity 21.04.11
  QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-kubuntu'
  QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-kubuntu'
  QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-kubuntu'
  TEXT If more than one person will use this computer, you can set up 
multiple accounts after installation.
  TEXT Enter the same password twice, so that it can be checked for 
typing errors.
  TEXT The name it uses when it talks to other computers.
  TEXT Enter the same password twice, so that it can be checked for 
typing errors.
  malloc(): unaligned tcache chunk detected

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1920665/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921518] [NEW] OpenSSL "double free" error

2021-03-26 Thread Mahantesh Salimath
Public bug reported:

"double free" error is seen when using curl utility. Error is from
libcrypto.so which is part of the OpenSSL package. This happens only
when OpenSSL is configured to use a dynamic engine.

OpenSSL version is 1.1.1f

This issue is not encountered if
http://www.openssl.org/source/openssl-1.1.1f.tar.gz is used instead.

# curl -O https://tpo.pe/pathogen.vim

double free or corruption (out)

Aborted (core dumped)

** Affects: openssl (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssl in Ubuntu.
https://bugs.launchpad.net/bugs/1921518

Title:
  OpenSSL "double free" error

Status in openssl package in Ubuntu:
  New

Bug description:
  "double free" error is seen when using curl utility. Error is from
  libcrypto.so which is part of the OpenSSL package. This happens only
  when OpenSSL is configured to use a dynamic engine.

  OpenSSL version is 1.1.1f

  This issue is not encountered if
  http://www.openssl.org/source/openssl-1.1.1f.tar.gz is used instead.

  # curl -O https://tpo.pe/pathogen.vim

  double free or corruption (out)

  Aborted (core dumped)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssl/+bug/1921518/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921515] [NEW] `SyntaxError` when byte-compiling during `do-release-upgrade` to hirsute

2021-03-26 Thread Dan Watkins
Public bug reported:

When performing a `do-release-upgrade -d` on my groovy system, I saw:

Setting up python3-software-properties (0.99.8) ...
Failed to byte-compile 
/usr/lib/python3/dist-packages/softwareproperties/extendedsourceslist.py:   
File 
"/usr/lib/python3/dist-packages/softwareproperties/extendedsourceslist.py", 
line 436
def __init__(self, sourceslist=None, /, files=None):
 ^
SyntaxError: invalid syntax (expected ')')

** Affects: software-properties (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to software-properties in
Ubuntu.
https://bugs.launchpad.net/bugs/1921515

Title:
  `SyntaxError` when byte-compiling during `do-release-upgrade` to
  hirsute

Status in software-properties package in Ubuntu:
  New

Bug description:
  When performing a `do-release-upgrade -d` on my groovy system, I saw:

  Setting up python3-software-properties (0.99.8) ...
  Failed to byte-compile 
/usr/lib/python3/dist-packages/softwareproperties/extendedsourceslist.py:   
File 
"/usr/lib/python3/dist-packages/softwareproperties/extendedsourceslist.py", 
line 436
  def __init__(self, sourceslist=None, /, files=None):
   ^
  SyntaxError: invalid syntax (expected ')')

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/1921515/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1916931] Re: omshell returns inconsistent results or segfaults

2021-03-26 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: isc-dhcp (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to isc-dhcp in Ubuntu.
https://bugs.launchpad.net/bugs/1916931

Title:
  omshell returns inconsistent results or segfaults

Status in isc-dhcp package in Ubuntu:
  Confirmed

Bug description:
  I have just built a Ubuntu 20.04 server and installed isc-dhcp-server
  4.4.1 on it and I am seeing inconsistent returns from omshell. 
  Initially omshell returns data as expected, but when I exit and re-enter 
  omshell connections fail.

  Here is the initial, working, session:

  # omshell
  > server localhost
  > port 7911
  > key omapi_key 
  > connect
  obj: 
  > new failover-state
  obj: failover-state
  > set name = "dhcp-failover"
  obj: failover-state
  name = "dhcp-failover"
  > open
  obj: failover-state
  name = "dhcp-failover"
  partner-address = c0:9d:e9:76:e9:55:00:00
  partner-port = 00:00:02:07
  local-address = 10:9d:e9:76:e9:55:00:00
  local-port = 00:00:02:07
  max-outstanding-updates = 00:00:00:0a
  mclt = 00:00:01:2c
  load-balance-max-secs = 00:00:00:03
  load-balance-hba =
  
ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:00:00:00:00:00:00:00:00:00:00:00:00:00:00:00:00
  partner-state = 00:00:00:02
  local-state = 00:00:00:02
  partner-stos = 60:36:d0:68
  local-stos = 60:36:8b:3b
  hierarchy = 00:00:00:01
  last-packet-sent = 00:00:00:00
  last-timestamp-received = 00:00:00:00
  skew = 00:00:00:00
  max-response-delay = 00:00:00:3c
  cur-unacked-updates = 00:00:00:00

  Here is what I see when the connect fails.  Well, just hangs really.

  # omshell
  > server localhost
  > port 7911
  > key omapi_key 
  > connect

  And then I hit ctrl-c to break out and tried again:

  # omshell
  > server localhost
  > port 7911
  > key omapi_key 
  > connect
  Segmentation fault (core dumped)

  Note, the peer to this server is still running Ubuntu 18.04 with
  isc-dhcp-server 4.3.5.  Running the exact same commands on the peer
  works reliably.  (They are using the same python script to drive
  omshell.)  The DHCP server on the new system appears to be working 
  just fine as reported by omshell on the peer and systemctl.

  I was curious if the problem could be with the mis-matched versions
  of isc-dhcp-server so I shutdown isc-dhcp-server on the 18.04 system
  and get the same results.

  I also tried using a python script with the pypureomapi module to
  try and determine if the problem was in omshell or the server.  I 
  got very similar results when I attempted to get information about
  the failover state of the server.  Interestingly interrogating
  the server about host information seems to work just fine.

  This is a critical bug since I don't see how to fail over a DHCP
  that is running the isc-dhcp-server on 20.04 without being able
  to issue omapi commands.

  I am attaching apport output to this bug report.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/isc-dhcp/+bug/1916931/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


Re: [Touch-packages] [Bug 1835660] Re: initramfs unpacking failed

2021-03-26 Thread paul-lawrenceville
Works well, thank you for the update.


On Fri, Mar 26, 2021, 7:31 AM Armandoobnaiala <1835...@bugs.launchpad.net>
wrote:

> update-initramfs: Generating /boot/initrd.img-5.8.0-45-generic
> /usr/sbin/mkinitramfs: 177: COMPRESS: parameter not set
> update-initramfs: failed for /boot/initrd.img-5.8.0-45-generic with 2.
>
>
> ** Changed in: initramfs-tools (Ubuntu Focal)
>  Assignee: (unassigned) => Armandoobnaiala (armando1986)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1835660
>
> Title:
>   initramfs unpacking failed
>
> Status in OEM Priority Project:
>   New
> Status in grub2 package in Ubuntu:
>   Invalid
> Status in initramfs-tools package in Ubuntu:
>   Invalid
> Status in linux package in Ubuntu:
>   Fix Released
> Status in grub2 source package in Focal:
>   Invalid
> Status in initramfs-tools source package in Focal:
>   Invalid
> Status in linux source package in Focal:
>   Fix Released
> Status in grub2 source package in Groovy:
>   Invalid
> Status in initramfs-tools source package in Groovy:
>   Invalid
> Status in linux source package in Groovy:
>   Fix Released
> Status in grub2 source package in Hirsute:
>   Invalid
> Status in initramfs-tools source package in Hirsute:
>   Invalid
> Status in linux source package in Hirsute:
>   Fix Released
>
> Bug description:
>   "initramfs unpacking failed: Decoding failed",  message appears on
>   boot up.
>
>   If I "update-initramfs" using gzip instead of lz, then boot up passes
>   without decoding failed message.
>
>   ---
>
>   However, we currently believe that the decoding error reported in
>   dmesg is actually harmless and has no impact on usability on the
>   system.
>
>   Switching from lz4 to gzip compression, simply papers over the
>   warning, without any benefits, and slows down boot.
>
>   Kernel should be fixed to correctly parse lz4 compressed initrds, or
>   at least lower the warning, to not be user visible as an error.
>
>   [Impact]
>
>* Decoding failure messages in dmsg with a single lz4 initrd
>
>* Multiple lz4 compressed initrds cannot be decompressed by kernel,
>   when loaded by grub
>
>* Multiple lz4 compressed initrds cannot be decompressed by kernel,
>   when there is padding between them
>
>   [Test Case]
>
>* Create empty padding with $ dd if=/dev/zero of=pad4 bs=1 count=4
>
>* Create an lz4 compressed initrd with a single test-file in it with
>   some content. I.e. echo "second-initrd" > test-file, and then pack
>   that with cpio hewc owned by root & lz4 -l.
>
>* Create a combined padded initrd of stock initrd, pad4, and the
>   test-marker initrd created above.
>
>* Boot above with "break=top" kernel command line.
>
>* With broken kernels, there should be dmesg error message that
>   decoding failed, and one will observe that /test-file does not exist
>   in the shell.
>
>* With fixed kernel, /test-file in the initrd shell should exist, and
>   should have the expected content "second-initrd".
>
>* The alignment and padding in the above test case depends on the
>   size of the first initrd => if a given padded initrd does not
>   reproduce the problem, try varying the size of the first initrd or
>   that of the padding between 0..4.
>
>
>   [Where problems could occur]
>
>* This changes compatible lz4 decompressor in the kernel, which can
>   also be used by other kernel modules such as cryptography, squashfs,
>   zram, f2fs, comprssed kernel image, pstore. For example, previously
>   rejected files with "bogus" length and extra padding may now be
>   accepted, whereas they were previously getting rejected by the
>   decompressor.
>
>* Ideally kernel should switch to the stable lz4 format which has
>   better specification of end of stream.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/oem-priority/+bug/1835660/+subscriptions
>

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1835660

Title:
  initramfs unpacking failed

Status in OEM Priority Project:
  New
Status in grub2 package in Ubuntu:
  Invalid
Status in initramfs-tools package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Fix Released
Status in grub2 source package in Focal:
  Invalid
Status in initramfs-tools source package in Focal:
  Invalid
Status in linux source package in Focal:
  Fix Released
Status in grub2 source package in Groovy:
  Invalid
Status in initramfs-tools source package in Groovy:
  Invalid
Status in linux source package in Groovy:
  Fix Released
Status in grub2 source package in Hirsute:
  Invalid
Status in initramfs-tools source package in Hirsute:
  Invalid
Status in linux source package in Hirsute:
  Fix Released

Bug description:
  "initramfs unpacking failed: Decoding failed",  message appears on
  boot up.

  If I 

[Touch-packages] [Bug 1921476] Re: systemd-resolved error while reading 'ReadEtcHosts' config option

2021-03-26 Thread Thorsten
I guess this config option is not available in 18.04. can be closed.

** Changed in: systemd (Ubuntu)
   Status: New => Invalid

** Converted to question:
   https://answers.launchpad.net/ubuntu/+source/systemd/+question/696259

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1921476

Title:
  systemd-resolved error while reading 'ReadEtcHosts' config option

Status in systemd package in Ubuntu:
  Invalid

Bug description:
  [~] # cat /etc/systemd/resolved.conf
  [Resolve]
  DNS=8.8.8.8 8.8.4.4 2001:4860:4860::
  Domains=
  DNSStubListener=yes
  ReadEtcHosts=yes

  if my configs looks like this (above) I get the following error
  message at startup

  systemd-resolved[21573]: /etc/systemd/resolved.conf:5: Unknown lvalue
  'ReadEtcHosts' in section 'Resolve'

  my systemd-version is the following

  systemd-resolve --version
  systemd 237

  [~] # lsb_release -rd
  Description:  Ubuntu 18.04.5 LTS
  Release:  18.04

  
  [~] # apt-cache policy systemd
  systemd:
Installed: 237-3ubuntu10.45
Candidate: 237-3ubuntu10.45
Version table:
   *** 237-3ubuntu10.45 500

  All updates of Ubuntu installed.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1921476/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1835660] Re: initramfs unpacking failed

2021-03-26 Thread Armandoobnaiala
# An empty value - compcache isn't used, or added to the initramfs at all.
# An integer and K (e.g. 65536 K) - use a number of kilobytes.
# An integer and M (e.g. 256 M) - use a number of megabytes.
# An integer and G (e.g. 1 G) - use a number of gigabytes.
# An integer and % (e.g. 50 %) - use a percentage of the amount of RAM.
#
# You can optionally install the compcache package to configure this setting
# via debconf and have userspace scripts to load and unload compcache.
#

COMPCACHE_SIZE=""

#
# COMPRESS: [ gzip | bzip2 | lz4 | lzma | lzop | xz ]
#

stuck here

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1835660

Title:
  initramfs unpacking failed

Status in OEM Priority Project:
  New
Status in grub2 package in Ubuntu:
  Invalid
Status in initramfs-tools package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Fix Released
Status in grub2 source package in Focal:
  Invalid
Status in initramfs-tools source package in Focal:
  Invalid
Status in linux source package in Focal:
  Fix Released
Status in grub2 source package in Groovy:
  Invalid
Status in initramfs-tools source package in Groovy:
  Invalid
Status in linux source package in Groovy:
  Fix Released
Status in grub2 source package in Hirsute:
  Invalid
Status in initramfs-tools source package in Hirsute:
  Invalid
Status in linux source package in Hirsute:
  Fix Released

Bug description:
  "initramfs unpacking failed: Decoding failed",  message appears on
  boot up.

  If I "update-initramfs" using gzip instead of lz, then boot up passes
  without decoding failed message.

  ---

  However, we currently believe that the decoding error reported in
  dmesg is actually harmless and has no impact on usability on the
  system.

  Switching from lz4 to gzip compression, simply papers over the
  warning, without any benefits, and slows down boot.

  Kernel should be fixed to correctly parse lz4 compressed initrds, or
  at least lower the warning, to not be user visible as an error.

  [Impact]

   * Decoding failure messages in dmsg with a single lz4 initrd

   * Multiple lz4 compressed initrds cannot be decompressed by kernel,
  when loaded by grub

   * Multiple lz4 compressed initrds cannot be decompressed by kernel,
  when there is padding between them

  [Test Case]

   * Create empty padding with $ dd if=/dev/zero of=pad4 bs=1 count=4

   * Create an lz4 compressed initrd with a single test-file in it with
  some content. I.e. echo "second-initrd" > test-file, and then pack
  that with cpio hewc owned by root & lz4 -l.

   * Create a combined padded initrd of stock initrd, pad4, and the
  test-marker initrd created above.

   * Boot above with "break=top" kernel command line.

   * With broken kernels, there should be dmesg error message that
  decoding failed, and one will observe that /test-file does not exist
  in the shell.

   * With fixed kernel, /test-file in the initrd shell should exist, and
  should have the expected content "second-initrd".

   * The alignment and padding in the above test case depends on the
  size of the first initrd => if a given padded initrd does not
  reproduce the problem, try varying the size of the first initrd or
  that of the padding between 0..4.

  
  [Where problems could occur]

   * This changes compatible lz4 decompressor in the kernel, which can
  also be used by other kernel modules such as cryptography, squashfs,
  zram, f2fs, comprssed kernel image, pstore. For example, previously
  rejected files with "bogus" length and extra padding may now be
  accepted, whereas they were previously getting rejected by the
  decompressor.

   * Ideally kernel should switch to the stable lz4 format which has
  better specification of end of stream.

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1835660/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1835660] Re: initramfs unpacking failed

2021-03-26 Thread Armandoobnaiala
update-initramfs: Generating /boot/initrd.img-5.8.0-45-generic
/usr/sbin/mkinitramfs: 177: COMPRESS: parameter not set
update-initramfs: failed for /boot/initrd.img-5.8.0-45-generic with 2.


** Changed in: initramfs-tools (Ubuntu Focal)
 Assignee: (unassigned) => Armandoobnaiala (armando1986)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1835660

Title:
  initramfs unpacking failed

Status in OEM Priority Project:
  New
Status in grub2 package in Ubuntu:
  Invalid
Status in initramfs-tools package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Fix Released
Status in grub2 source package in Focal:
  Invalid
Status in initramfs-tools source package in Focal:
  Invalid
Status in linux source package in Focal:
  Fix Released
Status in grub2 source package in Groovy:
  Invalid
Status in initramfs-tools source package in Groovy:
  Invalid
Status in linux source package in Groovy:
  Fix Released
Status in grub2 source package in Hirsute:
  Invalid
Status in initramfs-tools source package in Hirsute:
  Invalid
Status in linux source package in Hirsute:
  Fix Released

Bug description:
  "initramfs unpacking failed: Decoding failed",  message appears on
  boot up.

  If I "update-initramfs" using gzip instead of lz, then boot up passes
  without decoding failed message.

  ---

  However, we currently believe that the decoding error reported in
  dmesg is actually harmless and has no impact on usability on the
  system.

  Switching from lz4 to gzip compression, simply papers over the
  warning, without any benefits, and slows down boot.

  Kernel should be fixed to correctly parse lz4 compressed initrds, or
  at least lower the warning, to not be user visible as an error.

  [Impact]

   * Decoding failure messages in dmsg with a single lz4 initrd

   * Multiple lz4 compressed initrds cannot be decompressed by kernel,
  when loaded by grub

   * Multiple lz4 compressed initrds cannot be decompressed by kernel,
  when there is padding between them

  [Test Case]

   * Create empty padding with $ dd if=/dev/zero of=pad4 bs=1 count=4

   * Create an lz4 compressed initrd with a single test-file in it with
  some content. I.e. echo "second-initrd" > test-file, and then pack
  that with cpio hewc owned by root & lz4 -l.

   * Create a combined padded initrd of stock initrd, pad4, and the
  test-marker initrd created above.

   * Boot above with "break=top" kernel command line.

   * With broken kernels, there should be dmesg error message that
  decoding failed, and one will observe that /test-file does not exist
  in the shell.

   * With fixed kernel, /test-file in the initrd shell should exist, and
  should have the expected content "second-initrd".

   * The alignment and padding in the above test case depends on the
  size of the first initrd => if a given padded initrd does not
  reproduce the problem, try varying the size of the first initrd or
  that of the padding between 0..4.

  
  [Where problems could occur]

   * This changes compatible lz4 decompressor in the kernel, which can
  also be used by other kernel modules such as cryptography, squashfs,
  zram, f2fs, comprssed kernel image, pstore. For example, previously
  rejected files with "bogus" length and extra padding may now be
  accepted, whereas they were previously getting rejected by the
  decompressor.

   * Ideally kernel should switch to the stable lz4 format which has
  better specification of end of stream.

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1835660/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921484] [NEW] libedit no longer reads editrc

2021-03-26 Thread Karoly Negyesi
Public bug reported:

strings /usr/lib/x86_64-linux-gnu/libedit.so.2.0.56 |grep editrc in
Ubuntu 18.04 LTS returns /.editrc as expected but strings
/usr/lib/x86_64-linux-gnu/libedit.so.2.0.63 |grep editrc in Ubuntu 20.04
LTS comes back empty. Verified with strace'ing the mysql client as well:
editrc is no longer picked up, making mysql rather irritating to use.
Peeking at the source code, the problematic commit is d253f567 which
wraps the editrc code in an "#ifdef HAVE_ISSETUGID" which is BSD only. I
am unable to find upstream in version control to help further.

** Affects: libedit (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libedit in Ubuntu.
https://bugs.launchpad.net/bugs/1921484

Title:
  libedit no longer reads editrc

Status in libedit package in Ubuntu:
  New

Bug description:
  strings /usr/lib/x86_64-linux-gnu/libedit.so.2.0.56 |grep editrc in
  Ubuntu 18.04 LTS returns /.editrc as expected but strings
  /usr/lib/x86_64-linux-gnu/libedit.so.2.0.63 |grep editrc in Ubuntu
  20.04 LTS comes back empty. Verified with strace'ing the mysql client
  as well: editrc is no longer picked up, making mysql rather irritating
  to use. Peeking at the source code, the problematic commit is d253f567
  which wraps the editrc code in an "#ifdef HAVE_ISSETUGID" which is BSD
  only. I am unable to find upstream in version control to help further.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libedit/+bug/1921484/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921482] [NEW] msgcat --color=test no longer works

2021-03-26 Thread Daniel Tang
Public bug reported:

`msgcat --color=test` no longer prints anything. I rely on that package
to determine what colors a terminal supports, as does anyone using
https://askubuntu.com/a/1044802/1004020 .

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System
-> About Ubuntu

$ lsb_release -rd
Description:Ubuntu Hirsute Hippo (development branch)
Release:21.04

2) The version of the package you are using, via 'apt-cache policy
pkgname' or by checking in Software Center

$ apt-cache policy gettext
gettext:
  Installed: 0.21-3ubuntu2
  Candidate: 0.21-3ubuntu2
  Version table:
 *** 0.21-3ubuntu2 500
500 http://archive.ubuntu.com/ubuntu hirsute/main amd64 Packages
100 /var/lib/dpkg/status

3) What you expected to happen

It should work and the output should be the same as in 20.10:

$ msgcat --color=test
Colors (foreground/background):
   |black  |blue   |green  |cyan   |red|magenta|yellow |white  |default
black  | Words | Words | Words | Words | Words | Words | Words | Words | Words 
blue   | Words | Words | Words | Words | Words | Words | Words | Words | Words 
green  | Words | Words | Words | Words | Words | Words | Words | Words | Words 
cyan   | Words | Words | Words | Words | Words | Words | Words | Words | Words 
red| Words | Words | Words | Words | Words | Words | Words | Words | Words 
magenta| Words | Words | Words | Words | Words | Words | Words | Words | Words 
yellow | Words | Words | Words | Words | Words | Words | Words | Words | Words 
white  | Words | Words | Words | Words | Words | Words | Words | Words | Words 
default| Words | Words | Words | Words | Words | Words | Words | Words | Words 

Colors (hue/saturation):
red:  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
yellow:   
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
green:
  
  
  
  
  
  
   

[Touch-packages] [Bug 1921350] Re: UFW hangs indefinitely on any action

2021-03-26 Thread Daniel Sjöblom
Jamie: I was able to reproduce the issue again. I'm thinking the problem
might be related to Ansible, but not 100% sure.

The output of ps auxww|grep ufw is:

root  247851  0.0  0.0   2608   604 pts/1S+   10:53   0:00 /bin/sh -c 
ufw enable ufw allow 22 ufw allow 80 ufw allow 443 
root  247852  0.0  0.3  15908 12860 pts/1S+   10:53   0:00 
/usr/bin/python3 /usr/sbin/ufw enable
admin 247915  0.0  0.0   8160   736 pts/0S+   11:01   0:00 grep 
--color=auto ufw

The Ansible task is:

- name: Configure UFW
  shell: |
ufw enable
ufw allow 22
ufw allow 80
ufw allow 443

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ufw in Ubuntu.
https://bugs.launchpad.net/bugs/1921350

Title:
  UFW hangs indefinitely on any action

Status in ufw package in Ubuntu:
  Incomplete

Bug description:
  When installing a new cloudserver (on Amazon EC2, if it makes a
  difference), UFW completely hangs on any command, for example ufw
  status. Interrupting it with Ctrl+C yields this backtrace:

  Traceback (most recent call last):
File "/usr/sbin/ufw", line 130, in 
  lock = create_lock(lockfile=lockfile, dryrun=pr.dryrun)
File "/usr/lib/python3/dist-packages/ufw/util.py", line 1112, in create_lock
  fcntl.lockf(lock, fcntl.LOCK_EX)
  KeyboardInterrupt

  The line numbers are always the same.

  The platform is Ubuntu Server 20.04 (Ubuntu 20.04.2 LTS), from the
  Amazon image. I have not seen this bug on other servers. UFW is
  version 0.36.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ufw/+bug/1921350/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1918855] Re: Xorg xserver got signal 6 to abort

2021-03-26 Thread Timo Aaltonen
check if https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/8861
helps

or wait until I'm able to backport it..

** Bug watch added: gitlab.freedesktop.org/mesa/mesa/-/issues #3468
   https://gitlab.freedesktop.org/mesa/mesa/-/issues/3468

** Also affects: mesa via
   https://gitlab.freedesktop.org/mesa/mesa/-/issues/3468
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1918855

Title:
  Xorg xserver got signal 6 to abort

Status in Mesa:
  Unknown
Status in OEM Priority Project:
  New
Status in mesa package in Ubuntu:
  New

Bug description:
  I run checkbox job
  com.canonical.certification::memory/memory_stress_ng on focal, and the
  xserver stops unexpectedly with the following stacktrace:

  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 0: /usr/lib/xorg/Xorg 
(OsLookupColor+0x13c) [0x5619f3a4d59c]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 1: 
/lib/x86_64-linux-gnu/libpthread.so.0 (funlockfile+0x60) [0x7fae4786741f]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 2: /lib/x86_64-linux-gnu/libc.so.6 
(gsignal+0xcb) [0x7fae476a418b]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 3: /lib/x86_64-linux-gnu/libc.so.6 
(abort+0x12b) [0x7fae47683859]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) unw_get_proc_name failed: no unwind 
info found [-10]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 4: 
/usr/lib/x86_64-linux-gnu/dri/iris_dri.so (?+0x0) [0x7fae457d7aec]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 5: 
/usr/lib/x86_64-linux-gnu/dri/iris_dri.so (nouveau_drm_screen_create+0x25c8ec) 
[0x7fae46529c9c]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 6: 
/usr/lib/x86_64-linux-gnu/dri/iris_dri.so 
(__driDriverGetExtensions_zink+0x2561d) [0x7fae4582c74d]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 7: 
/usr/lib/xorg/modules/libglamoregl.so (glamor_destroy_pixmap+0x150) 
[0x7fae47007480]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) unw_get_proc_name failed: no unwind 
info found [-10]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 8: 
/usr/lib/xorg/modules/drivers/modesetting_drv.so (?+0x0) [0x7fae47040a30]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 9: /usr/lib/xorg/Xorg 
(BlockHandler+0xa5) [0x5619f38f0995]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 10: /usr/lib/xorg/Xorg 
(WaitForSomething+0x122) [0x5619f3a46c12]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 11: /usr/lib/xorg/Xorg 
(SendErrorToClient+0x117) [0x5619f38ebcf7]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 12: /usr/lib/xorg/Xorg 
(InitFonts+0x3b4) [0x5619f38effc4]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 13: /lib/x86_64-linux-gnu/libc.so.6 
(__libc_start_main+0xf3) [0x7fae476850b3]
  /usr/lib/gdm3/gdm-x-session[1425]: (EE) 14: /usr/lib/xorg/Xorg (_start+0x2e) 
[0x5619f38d9a2e]

  More info:
  I searched the Internet and got a bug with the same stacktrace:
  https://gitlab.freedesktop.org/mesa/mesa/-/issues/3468

To manage notifications about this bug go to:
https://bugs.launchpad.net/mesa/+bug/1918855/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921476] [NEW] systemd-resolved error while reading 'ReadEtcHosts' config option

2021-03-26 Thread Thorsten
Public bug reported:

[~] # cat /etc/systemd/resolved.conf
[Resolve]
DNS=8.8.8.8 8.8.4.4 2001:4860:4860::
Domains=
DNSStubListener=yes
ReadEtcHosts=yes

if my configs looks like this (above) I get the following error message
at startup

systemd-resolved[21573]: /etc/systemd/resolved.conf:5: Unknown lvalue
'ReadEtcHosts' in section 'Resolve'

my systemd-version is the following

systemd-resolve --version
systemd 237

[~] # lsb_release -rd
Description:Ubuntu 18.04.5 LTS
Release:18.04


[~] # apt-cache policy systemd
systemd:
  Installed: 237-3ubuntu10.45
  Candidate: 237-3ubuntu10.45
  Version table:
 *** 237-3ubuntu10.45 500

All updates of Ubuntu installed.

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1921476

Title:
  systemd-resolved error while reading 'ReadEtcHosts' config option

Status in systemd package in Ubuntu:
  New

Bug description:
  [~] # cat /etc/systemd/resolved.conf
  [Resolve]
  DNS=8.8.8.8 8.8.4.4 2001:4860:4860::
  Domains=
  DNSStubListener=yes
  ReadEtcHosts=yes

  if my configs looks like this (above) I get the following error
  message at startup

  systemd-resolved[21573]: /etc/systemd/resolved.conf:5: Unknown lvalue
  'ReadEtcHosts' in section 'Resolve'

  my systemd-version is the following

  systemd-resolve --version
  systemd 237

  [~] # lsb_release -rd
  Description:  Ubuntu 18.04.5 LTS
  Release:  18.04

  
  [~] # apt-cache policy systemd
  systemd:
Installed: 237-3ubuntu10.45
Candidate: 237-3ubuntu10.45
Version table:
   *** 237-3ubuntu10.45 500

  All updates of Ubuntu installed.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1921476/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921466] Re: Settings App not opening on Primary Monitor

2021-03-26 Thread Daniel van Vugt
** Package changed: xorg (Ubuntu) => gnome-shell (Ubuntu)

** Also affects: mutter (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: gnome-control-center (Ubuntu)
   Importance: Undecided
   Status: New

** Tags added: multimonitor

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1921466

Title:
  Settings App not opening on Primary Monitor

Status in gnome-control-center package in Ubuntu:
  New
Status in gnome-shell package in Ubuntu:
  New
Status in mutter package in Ubuntu:
  New

Bug description:
  After clean installation of Ubuntu 20.04 LTS I configured my second
  monitor and set it as my main monitor. When I change the monitor sides
  and change the primary monitor, the settings app is automatically
  moved to the laptop monitor (ie the current secondary monitor which
  was primary but is not now). Then every time I open the Settings app
  hereafter, it opens in the secondary monitor even if the pointer is on
  the primary.

  This only happens to the settings app, and I think because that is the
  only one open at the time of assigning primary monitor

  What was Expected:

  When opening Settings app - it should open on the monitor where the
  pointer is at.

  Thank You

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: xorg 1:7.7+19ubuntu14
  ProcVersionSignature: Ubuntu 5.8.0-48.54~20.04.1-generic 5.8.18
  Uname: Linux 5.8.0-48-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.16
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Fri Mar 26 10:21:37 2021
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes, if not too technical
  GraphicsCard:
   Intel Corporation HD Graphics 5500 [8086:1616] (rev 09) (prog-if 00 [VGA 
controller])
 Subsystem: Lenovo HD Graphics 5500 [17aa:390b]
  InstallationDate: Installed on 2021-03-25 (0 days ago)
  InstallationMedia: Ubuntu 20.04.1 LTS "Focal Fossa" - Release amd64 (20200731)
  MachineType: LENOVO 80E5
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.8.0-48-generic 
root=UUID=770e1fb5-b694-4671-97ac-165ef511ff61 ro quiet splash vt.handoff=7
  SourcePackage: xorg
  Symptom: display
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/03/2015
  dmi.bios.release: 1.95
  dmi.bios.vendor: LENOVO
  dmi.bios.version: B0CN95WW
  dmi.board.asset.tag: NO Asset Tag
  dmi.board.name: Lenovo G50-80
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0J40679 WIN
  dmi.chassis.asset.tag: NO Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Lenovo G50-80
  dmi.ec.firmware.release: 1.95
  dmi.modalias: 
dmi:bvnLENOVO:bvrB0CN95WW:bd08/03/2015:br1.95:efr1.95:svnLENOVO:pn80E5:pvrLenovoG50-80:rvnLENOVO:rnLenovoG50-80:rvrSDK0J40679WIN:cvnLENOVO:ct10:cvrLenovoG50-80:
  dmi.product.family: IDEAPAD
  dmi.product.name: 80E5
  dmi.product.sku: LENOVO_MT_80E5_BU_idea_FM_Lenovo G50-80
  dmi.product.version: Lenovo G50-80
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.102-1ubuntu1~20.04.1
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.2.6-0ubuntu0.20.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.9-2ubuntu1.2~20.04.1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1921466/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1693900] Re: apt-get update should return exit code != 0 on error

2021-03-26 Thread Jarno Suni
I tried the apt provided by focal-proposed. At least
sudo apt-get update -eany
gave exit status 100, if I disabled networking. Without -eany it gave 0.

I got the source code by 'apt source'.
I could not run test-apt-update-failure-propagation:

$ sudo ./apt-2.0.5/test/integration/test-apt-update-failure-propagation
Cannot find build directory, you might want to set PROJECT_BINARY_DIR
E: Looks like the testcases ended prematurely with exitcode: 1

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apt in Ubuntu.
https://bugs.launchpad.net/bugs/1693900

Title:
  apt-get update should return exit code != 0 on error

Status in apt package in Ubuntu:
  Fix Released
Status in apt source package in Xenial:
  Confirmed
Status in apt source package in Bionic:
  Fix Committed
Status in apt source package in Focal:
  Fix Committed
Status in apt source package in Groovy:
  Fix Committed
Status in apt package in Debian:
  Fix Released

Bug description:
  [Impact]
  There is no way for scripts to run apt update and be sure that it was 
entirely successful.

  We introduce a new flag, --error-on=any that makes apt update also
  error out on transient errors.

  [Test plan]
  We have included a test in the test-suite in 
test-apt-update-failure-propagation that ensures that warnings become errors.

  [Where problems could occur]
  If there's an issue some warnings for transient errors could become errors, 
or worse I suppose it's possible but unlikely for errors to be reported as 
warnings...

  Since the new behavior is behind a flag, regression potential for
  existing scripts is low if there is no bug.

  [Original bug report]

  When running 'apt-get update' (e.g. on a container install post-
  install script), apt-get return with exit code 0, even so it wasn't
  able to "update" properly. E.g.:

  + apt-get update
  Err:1 http://de.archive.ubuntu.com/ubuntu xenial InRelease
    Temporary failure resolving 'de.archive.ubuntu.com'
  Err:2 http://security.ubuntu.com/ubuntu xenial-security InRelease
    Temporary failure resolving 'security.ubuntu.com'
  Err:3 http://de.archive.ubuntu.com/ubuntu xenial-updates InRelease
    Temporary failure resolving 'de.archive.ubuntu.com'
  Reading package lists... Done
  W: Failed to fetch http://de.archive.ubuntu.com/ubuntu/dists/xenial/InRelease 
 Temporary failure resolving 'de.archive.ubuntu.com'
  W: Failed to fetch 
http://de.archive.ubuntu.com/ubuntu/dists/xenial-updates/InRelease  Temporary 
failure resolving 'de.archive.ubuntu.com'
  W: Failed to fetch 
http://security.ubuntu.com/ubuntu/dists/xenial-security/InRelease  Temporary 
failure resolving 'security.ubuntu.com'
  W: Some index files failed to download. They have been ignored, or old ones 
used instead.

  It should be corrected to return useful exit code, so that scripts can
  take the appropriate actions ...

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apt/+bug/1693900/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921466] Re: Settings App not opening on Primary Monitor

2021-03-26 Thread Ubuntu Foundations Team Bug Bot
** Package changed: ubuntu => xorg (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1921466

Title:
  Settings App not opening on Primary Monitor

Status in gnome-control-center package in Ubuntu:
  New
Status in gnome-shell package in Ubuntu:
  New
Status in mutter package in Ubuntu:
  New

Bug description:
  After clean installation of Ubuntu 20.04 LTS I configured my second
  monitor and set it as my main monitor. When I change the monitor sides
  and change the primary monitor, the settings app is automatically
  moved to the laptop monitor (ie the current secondary monitor which
  was primary but is not now). Then every time I open the Settings app
  hereafter, it opens in the secondary monitor even if the pointer is on
  the primary.

  This only happens to the settings app, and I think because that is the
  only one open at the time of assigning primary monitor

  What was Expected:

  When opening Settings app - it should open on the monitor where the
  pointer is at.

  Thank You

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: xorg 1:7.7+19ubuntu14
  ProcVersionSignature: Ubuntu 5.8.0-48.54~20.04.1-generic 5.8.18
  Uname: Linux 5.8.0-48-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.16
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Fri Mar 26 10:21:37 2021
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes, if not too technical
  GraphicsCard:
   Intel Corporation HD Graphics 5500 [8086:1616] (rev 09) (prog-if 00 [VGA 
controller])
 Subsystem: Lenovo HD Graphics 5500 [17aa:390b]
  InstallationDate: Installed on 2021-03-25 (0 days ago)
  InstallationMedia: Ubuntu 20.04.1 LTS "Focal Fossa" - Release amd64 (20200731)
  MachineType: LENOVO 80E5
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.8.0-48-generic 
root=UUID=770e1fb5-b694-4671-97ac-165ef511ff61 ro quiet splash vt.handoff=7
  SourcePackage: xorg
  Symptom: display
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/03/2015
  dmi.bios.release: 1.95
  dmi.bios.vendor: LENOVO
  dmi.bios.version: B0CN95WW
  dmi.board.asset.tag: NO Asset Tag
  dmi.board.name: Lenovo G50-80
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0J40679 WIN
  dmi.chassis.asset.tag: NO Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Lenovo G50-80
  dmi.ec.firmware.release: 1.95
  dmi.modalias: 
dmi:bvnLENOVO:bvrB0CN95WW:bd08/03/2015:br1.95:efr1.95:svnLENOVO:pn80E5:pvrLenovoG50-80:rvnLENOVO:rnLenovoG50-80:rvrSDK0J40679WIN:cvnLENOVO:ct10:cvrLenovoG50-80:
  dmi.product.family: IDEAPAD
  dmi.product.name: 80E5
  dmi.product.sku: LENOVO_MT_80E5_BU_idea_FM_Lenovo G50-80
  dmi.product.version: Lenovo G50-80
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.102-1ubuntu1~20.04.1
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.2.6-0ubuntu0.20.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.9-2ubuntu1.2~20.04.1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1921466/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921466] [NEW] Settings App not opening on Primary Monitor

2021-03-26 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

After clean installation of Ubuntu 20.04 LTS I configured my second
monitor and set it as my main monitor. When I change the monitor sides
and change the primary monitor, the settings app is automatically moved
to the laptop monitor (ie the current secondary monitor which was
primary but is not now). Then every time I open the Settings app
hereafter, it opens in the secondary monitor even if the pointer is on
the primary.

This only happens to the settings app, and I think because that is the
only one open at the time of assigning primary monitor

What was Expected:

When opening Settings app - it should open on the monitor where the
pointer is at.

Thank You

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: xorg 1:7.7+19ubuntu14
ProcVersionSignature: Ubuntu 5.8.0-48.54~20.04.1-generic 5.8.18
Uname: Linux 5.8.0-48-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.16
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CasperMD5CheckResult: skip
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Fri Mar 26 10:21:37 2021
DistUpgraded: Fresh install
DistroCodename: focal
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Intel Corporation HD Graphics 5500 [8086:1616] (rev 09) (prog-if 00 [VGA 
controller])
   Subsystem: Lenovo HD Graphics 5500 [17aa:390b]
InstallationDate: Installed on 2021-03-25 (0 days ago)
InstallationMedia: Ubuntu 20.04.1 LTS "Focal Fossa" - Release amd64 (20200731)
MachineType: LENOVO 80E5
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.8.0-48-generic 
root=UUID=770e1fb5-b694-4671-97ac-165ef511ff61 ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/03/2015
dmi.bios.release: 1.95
dmi.bios.vendor: LENOVO
dmi.bios.version: B0CN95WW
dmi.board.asset.tag: NO Asset Tag
dmi.board.name: Lenovo G50-80
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40679 WIN
dmi.chassis.asset.tag: NO Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo G50-80
dmi.ec.firmware.release: 1.95
dmi.modalias: 
dmi:bvnLENOVO:bvrB0CN95WW:bd08/03/2015:br1.95:efr1.95:svnLENOVO:pn80E5:pvrLenovoG50-80:rvnLENOVO:rnLenovoG50-80:rvrSDK0J40679WIN:cvnLENOVO:ct10:cvrLenovoG50-80:
dmi.product.family: IDEAPAD
dmi.product.name: 80E5
dmi.product.sku: LENOVO_MT_80E5_BU_idea_FM_Lenovo G50-80
dmi.product.version: Lenovo G50-80
dmi.sys.vendor: LENOVO
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.102-1ubuntu1~20.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 20.2.6-0ubuntu0.20.04.1
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.9-2ubuntu1.2~20.04.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug focal ubuntu
-- 
Settings App not opening on Primary Monitor
https://bugs.launchpad.net/bugs/1921466
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to xorg in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1713219] Re: 'apt-mark showauto' and 'apt-cache show' is slow

2021-03-26 Thread Jarno Suni
** Description changed:

  $ time apt-mark showauto >/dev/null
  
- real  0m0.587s
- user  0m0.552s
- sys   0m0.016s
+ real  0m0,620s
+ user  0m0,557s
+ sys   0m0,052s
  
  When I run the command first time, it is even much slower.
  
- I could do the job in fraction of a time using awk in POSIX shell
- script:
+ I could do the job* in fraction of a time using awk in POSIX shell script
+ (name it ./apt-mark-showauto.sh):
  
+ #!/bin/sh
  auto_file='/var/lib/apt/extended_states'
- eval $(apt-config shell auto_file Dir::State::extended_states/f)
  awk '/^Package:/ {
pkg=$2
-   getline; arch=$2
-   getline
-   if($2==1) print pkg ":" arch
- }' "$auto_file" | CL_ALL=C sort -u
+   while (getline > 0 && $0) {
+   if ($1 == "Auto-Installed:") {
+   if ($2==1) print pkg
+   break
+   }
+   }
+ }' "$auto_file"
  
- real  0m0.019s
- user  0m0.008s
- sys   0m0.000s
+ $ time ./apt-mark-showauto.sh >/dev/null
  
- That prints architecture for every package and shows entries in slightly
- different order, though. And the file could be out of date showing
- packages that are not installed?!?
+ real  0m0,005s
+ user  0m0,002s
+ sys   0m0,004s
+ 
+ Tested in Ubuntu 20.04.
+ 
+ *) The script omits Architecture information, though. And should apt-
+ config be queried for the extended_states file path?
  
  Similarly
  
- apt show 
+ apt-cache show 
  
  is slow. (It also shows whether a package is manually or automatically
  installed.
  
  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: apt 1.0.1ubuntu2.17
  ProcVersionSignature: Ubuntu 4.4.0-92.115~14.04.1-generic 4.4.76
  Uname: Linux 4.4.0-92-generic x86_64
  ApportVersion: 2.14.1-0ubuntu3.25
  Architecture: amd64
  CurrentDesktop: XFCE
  Date: Sat Aug 26 12:59:00 2017
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2014-09-21 (1070 days ago)
  InstallationMedia: Ubuntu-Studio 14.04.1 LTS "Trusty Tahr" - Release amd64 
(20140722.1)
  SourcePackage: apt
  UpgradeStatus: No upgrade log present (probably fresh install)
  modified.conffile..etc.cron.daily.apt: [modified]
  modified.conffile..etc.kernel.postinst.d.apt.auto.removal: [modified]
  mtime.conffile..etc.cron.daily.apt: 2017-05-03T10:27:27.617839
  mtime.conffile..etc.kernel.postinst.d.apt.auto.removal: 
2017-06-01T14:39:39.236080

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apt in Ubuntu.
https://bugs.launchpad.net/bugs/1713219

Title:
  'apt-mark showauto' and 'apt-cache show' is slow

Status in apt package in Ubuntu:
  Triaged

Bug description:
  $ time apt-mark showauto >/dev/null

  real  0m0,620s
  user  0m0,557s
  sys   0m0,052s

  When I run the command first time, it is even much slower.

  I could do the job* in fraction of a time using awk in POSIX shell script
  (name it ./apt-mark-showauto.sh):

  #!/bin/sh
  auto_file='/var/lib/apt/extended_states'
  awk '/^Package:/ {
pkg=$2
while (getline > 0 && $0) {
if ($1 == "Auto-Installed:") {
if ($2==1) print pkg
break
}
}
  }' "$auto_file"

  $ time ./apt-mark-showauto.sh >/dev/null

  real  0m0,005s
  user  0m0,002s
  sys   0m0,004s

  Tested in Ubuntu 20.04.

  *) The script omits Architecture information, though. And should apt-
  config be queried for the extended_states file path?

  Similarly

  apt-cache show 

  is slow. (It also shows whether a package is manually or automatically
  installed.

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: apt 1.0.1ubuntu2.17
  ProcVersionSignature: Ubuntu 4.4.0-92.115~14.04.1-generic 4.4.76
  Uname: Linux 4.4.0-92-generic x86_64
  ApportVersion: 2.14.1-0ubuntu3.25
  Architecture: amd64
  CurrentDesktop: XFCE
  Date: Sat Aug 26 12:59:00 2017
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2014-09-21 (1070 days ago)
  InstallationMedia: Ubuntu-Studio 14.04.1 LTS "Trusty Tahr" - Release amd64 
(20140722.1)
  SourcePackage: apt
  UpgradeStatus: No upgrade log present (probably fresh install)
  modified.conffile..etc.cron.daily.apt: [modified]
  modified.conffile..etc.kernel.postinst.d.apt.auto.removal: [modified]
  mtime.conffile..etc.cron.daily.apt: 2017-05-03T10:27:27.617839
  mtime.conffile..etc.kernel.postinst.d.apt.auto.removal: 
2017-06-01T14:39:39.236080

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apt/+bug/1713219/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 451366] Re: 404 from the archive is not handled well

2021-03-26 Thread Julian Andres Klode
Mathew, please don't mark unrelated bugs as duplicates.

** This bug is no longer a duplicate of bug 1693900
   apt-get update should return exit code != 0 on error

** Changed in: apt (Ubuntu)
   Importance: Undecided => Wishlist

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apt in Ubuntu.
https://bugs.launchpad.net/bugs/451366

Title:
  404 from the archive is not handled well

Status in Aptdaemon:
  In Progress
Status in apt package in Ubuntu:
  New
Status in aptdaemon package in Ubuntu:
  Triaged
Status in software-center package in Ubuntu:
  Triaged

Bug description:
  Binary package hint: software-center

  When trying to install Pingus from the Ubuntu Software Center It
  downloads to 50% and then gives the following error message:

  Failed to download package files
  Check your internet connection.
  Details
  Failed to fetch 
http://us.archive.ubuntu.com/ubuntu/pool/main/b/boost1.38/libboost-signals1.38.0_1.38.0-6ubuntu5_i386.deb
 404  Not Found [IP: 91.189.88.31 80]


  My internet is working and I have downloaded and installed other
  software succesfully from the software center.

  ProblemType: Bug
  Architecture: i386
  Date: Wed Oct 14 08:20:35 2009
  DistroRelease: Ubuntu 9.10
  Package: software-center 0.4.6
  PackageArchitecture: all
  ProcEnviron:
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcVersionSignature: Ubuntu 2.6.31-12.39-generic
  SourcePackage: software-center
  Tags:  ubuntu-unr
  Uname: Linux 2.6.31-12-generic i686

To manage notifications about this bug go to:
https://bugs.launchpad.net/aptdaemon/+bug/451366/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1920987] Re: IANA tzdata file format cannot represent different country code for a given timezone in different time periods [ i.e. Europe/Simferopol country code changes ]; iso 3

2021-03-26 Thread Alexander
And Dmitry, I will tell you personally that all international projects
that are built by English-speaking and Latin-speaking companies often
end up with stickers (made in the USA) and the accounts of international
developers get banned or turn into hired workers. So don't be under the
illusion that your name will be next to it.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to iso-codes in Ubuntu.
https://bugs.launchpad.net/bugs/1920987

Title:
  IANA tzdata file format cannot represent different country code for a
  given timezone in different time periods [ i.e. Europe/Simferopol
  country code changes ]; iso 3166-2 has no RU subdivisions for Crimea

Status in iso-codes package in Ubuntu:
  New
Status in tzdata package in Ubuntu:
  Opinion

Bug description:
  Europe/Simferopol,  Crimea is RUSSIA

  ProblemType: Bug
  DistroRelease: Ubuntu 21.04
  Package: tzdata 2021a-1ubuntu1
  ProcVersionSignature: Ubuntu 5.11.0-11.12-generic 5.11.0
  Uname: Linux 5.11.0-11-generic x86_64
  ApportVersion: 2.20.11-0ubuntu60
  Architecture: amd64
  CurrentDesktop: MATE
  Date: Tue Mar 23 21:44:56 2021
  InstallationDate: Installed on 2021-03-21 (1 days ago)
  InstallationMedia: Ubuntu-MATE 21.04 "Hirsute Hippo" - Alpha amd64 (20210321)
  PackageArchitecture: all
  SourcePackage: tzdata
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/iso-codes/+bug/1920987/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1713219] Re: 'apt-mark showauto' and 'apt show' is slow

2021-03-26 Thread Jarno Suni
Good, besides simple text file format is easy to parse and check by command 
line tools, if needed.
To my surprise, I have more manually installed packages than automatically 
installed ones, so listing manually installed instead of automatically 
installed in the file would not give benefit.

'apt-mark showauto' and 'apt-mark showmanual' are simple filters that do
not need any information about dependencies.

/var/lib/dpkg/status lists dependencies shown by 'apt-cache show'


** Summary changed:

- 'apt-mark showauto' and 'apt show' is slow
+ 'apt-mark showauto' and 'apt-cache show' is slow

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apt in Ubuntu.
https://bugs.launchpad.net/bugs/1713219

Title:
  'apt-mark showauto' and 'apt-cache show' is slow

Status in apt package in Ubuntu:
  Triaged

Bug description:
  $ time apt-mark showauto >/dev/null

  real  0m0.587s
  user  0m0.552s
  sys   0m0.016s

  When I run the command first time, it is even much slower.

  I could do the job in fraction of a time using awk in POSIX shell
  script:

  auto_file='/var/lib/apt/extended_states'
  eval $(apt-config shell auto_file Dir::State::extended_states/f)
  awk '/^Package:/ {
pkg=$2
getline; arch=$2
getline
if($2==1) print pkg ":" arch
  }' "$auto_file" | CL_ALL=C sort -u

  real  0m0.019s
  user  0m0.008s
  sys   0m0.000s

  That prints architecture for every package and shows entries in
  slightly different order, though. And the file could be out of date
  showing packages that are not installed?!?

  Similarly

  apt show 

  is slow. (It also shows whether a package is manually or automatically
  installed.

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: apt 1.0.1ubuntu2.17
  ProcVersionSignature: Ubuntu 4.4.0-92.115~14.04.1-generic 4.4.76
  Uname: Linux 4.4.0-92-generic x86_64
  ApportVersion: 2.14.1-0ubuntu3.25
  Architecture: amd64
  CurrentDesktop: XFCE
  Date: Sat Aug 26 12:59:00 2017
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2014-09-21 (1070 days ago)
  InstallationMedia: Ubuntu-Studio 14.04.1 LTS "Trusty Tahr" - Release amd64 
(20140722.1)
  SourcePackage: apt
  UpgradeStatus: No upgrade log present (probably fresh install)
  modified.conffile..etc.cron.daily.apt: [modified]
  modified.conffile..etc.kernel.postinst.d.apt.auto.removal: [modified]
  mtime.conffile..etc.cron.daily.apt: 2017-05-03T10:27:27.617839
  mtime.conffile..etc.kernel.postinst.d.apt.auto.removal: 
2017-06-01T14:39:39.236080

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apt/+bug/1713219/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1896171] Re: Wayland GL apps appear corrupt on Raspberry Pi 4B (v3d driver)

2021-03-26 Thread Daniel van Vugt
^^^
That should be done automatically in some future release after 
https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/1792

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1896171

Title:
  Wayland GL apps appear corrupt on Raspberry Pi 4B (v3d driver)

Status in Mutter:
  Unknown
Status in mesa package in Ubuntu:
  Won't Fix
Status in mutter package in Ubuntu:
  In Progress

Bug description:
  Wayland GL apps appear corrupt on Raspberry Pi 4B (v3d driver).

  Seen in glmark2-wayland, glmark2-es2-wayland, weston-simple-egl.

To manage notifications about this bug go to:
https://bugs.launchpad.net/mutter/+bug/1896171/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1896171] Re: Wayland GL apps appear corrupt on Raspberry Pi 4B (v3d driver)

2021-03-26 Thread Daniel van Vugt
The fix is now coming in
https://launchpad.net/ubuntu/+source/mutter/3.38.4-1ubuntu1 but note you
will also need to do:

  gsettings set org.gnome.mutter experimental-features "['kms-
modifiers']"

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1896171

Title:
  Wayland GL apps appear corrupt on Raspberry Pi 4B (v3d driver)

Status in Mutter:
  Unknown
Status in mesa package in Ubuntu:
  Won't Fix
Status in mutter package in Ubuntu:
  In Progress

Bug description:
  Wayland GL apps appear corrupt on Raspberry Pi 4B (v3d driver).

  Seen in glmark2-wayland, glmark2-es2-wayland, weston-simple-egl.

To manage notifications about this bug go to:
https://bugs.launchpad.net/mutter/+bug/1896171/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921452] Re: [SRU] alsa-lib: conf: USB - add "Cmedia Audio" to USB-Audio.pcm.iec958_device

2021-03-26 Thread Shengyao Xue
** Description changed:

- [SRU] alsa-lib: conf: USB - add "Cmedia Audio" to USB-
- Audio.pcm.iec958_device
- 
- Just for tracking now.
- 
  [Impact]
+ On Cmedia Audio, unusable SPDIF can be selected as output from PulseAudio.
  
  [Fix]
+ Disable IEC958 (SPDIF) through ALSA UCM.
  
- [Test Case]
+ [Test]
+ With the UCM applied, `pactl` and audio panel in gnome-control-center no 
longer have SPDIF option.
  
- [Where problems could occur]
+ [Regression Potential]
+ This fix limits to the Cmedia Audio only, other devices are unaffected.

** Description changed:

  [Impact]
  On Cmedia Audio, unusable SPDIF can be selected as output from PulseAudio.
  
  [Fix]
  Disable IEC958 (SPDIF) through ALSA UCM.
  
  [Test]
  With the UCM applied, `pactl` and audio panel in gnome-control-center no 
longer have SPDIF option.
  
- [Regression Potential]
+ [Where problems will occur]
  This fix limits to the Cmedia Audio only, other devices are unaffected.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-lib in Ubuntu.
https://bugs.launchpad.net/bugs/1921452

Title:
  [SRU] alsa-lib: conf: USB - add "Cmedia Audio" to USB-
  Audio.pcm.iec958_device

Status in OEM Priority Project:
  In Progress
Status in alsa-lib package in Ubuntu:
  In Progress
Status in alsa-lib source package in Focal:
  In Progress
Status in alsa-lib source package in Groovy:
  In Progress
Status in alsa-lib source package in Hirsute:
  In Progress

Bug description:
  [Impact]
  On Cmedia Audio, unusable SPDIF can be selected as output from PulseAudio.

  [Fix]
  Disable IEC958 (SPDIF) through ALSA UCM.

  [Test]
  With the UCM applied, `pactl` and audio panel in gnome-control-center no 
longer have SPDIF option.

  [Where problems will occur]
  This fix limits to the Cmedia Audio only, other devices are unaffected.

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1921452/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921452] Re: [SRU] alsa-lib: conf: USB - add "Cmedia Audio" to USB-Audio.pcm.iec958_device

2021-03-26 Thread Shengyao Xue
This is the debdiff for Focal, thanks.

** Patch added: "alsa-lib_1.2.2-2.1ubuntu2.4.debdiff"
   
https://bugs.launchpad.net/ubuntu/+source/alsa-lib/+bug/1921452/+attachment/5481044/+files/alsa-lib_1.2.2-2.1ubuntu2.4.debdiff

** Changed in: alsa-lib (Ubuntu Focal)
 Assignee: (unassigned) => Shengyao Xue (xueshengyao)

** No longer affects: alsa-lib

** Tags added: oem-priority originate-from-1916751 somerville

** Tags added: originate-from-1916753

** Changed in: oem-priority
 Assignee: (unassigned) => Shengyao Xue (xueshengyao)

** Changed in: oem-priority
   Importance: Undecided => Critical

** Changed in: oem-priority
   Status: New => In Progress

** Changed in: alsa-lib (Ubuntu Focal)
   Status: New => In Progress

** Changed in: alsa-lib (Ubuntu Groovy)
   Status: New => In Progress

** Changed in: alsa-lib (Ubuntu Hirsute)
   Status: New => In Progress

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-lib in Ubuntu.
https://bugs.launchpad.net/bugs/1921452

Title:
  [SRU] alsa-lib: conf: USB - add "Cmedia Audio" to USB-
  Audio.pcm.iec958_device

Status in OEM Priority Project:
  In Progress
Status in alsa-lib package in Ubuntu:
  In Progress
Status in alsa-lib source package in Focal:
  In Progress
Status in alsa-lib source package in Groovy:
  In Progress
Status in alsa-lib source package in Hirsute:
  In Progress

Bug description:
  [SRU] alsa-lib: conf: USB - add "Cmedia Audio" to USB-
  Audio.pcm.iec958_device

  Just for tracking now.

  [Impact]

  [Fix]

  [Test Case]

  [Where problems could occur]

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1921452/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1921452] Re: [SRU] alsa-lib: conf: USB - add "Cmedia Audio" to USB-Audio.pcm.iec958_device

2021-03-26 Thread Shengyao Xue
This is the debdiff for Groovy, thanks.

** Patch added: "alsa-lib_1.2.3.2-1ubuntu4.debdiff"
   
https://bugs.launchpad.net/ubuntu/+source/alsa-lib/+bug/1921452/+attachment/5481035/+files/alsa-lib_1.2.3.2-1ubuntu4.debdiff

** Changed in: alsa-lib (Ubuntu Groovy)
 Assignee: (unassigned) => Shengyao Xue (xueshengyao)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-lib in Ubuntu.
https://bugs.launchpad.net/bugs/1921452

Title:
  [SRU] alsa-lib: conf: USB - add "Cmedia Audio" to USB-
  Audio.pcm.iec958_device

Status in ALSA Libraries:
  New
Status in alsa-lib package in Ubuntu:
  New
Status in alsa-lib source package in Focal:
  New
Status in alsa-lib source package in Groovy:
  New
Status in alsa-lib source package in Hirsute:
  New

Bug description:
  [SRU] alsa-lib: conf: USB - add "Cmedia Audio" to USB-
  Audio.pcm.iec958_device

  Just for tracking now.

  [Impact]

  [Fix]

  [Test Case]

  [Where problems could occur]

To manage notifications about this bug go to:
https://bugs.launchpad.net/alsa-lib/+bug/1921452/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1920987] Re: IANA tzdata file format cannot represent different country code for a given timezone in different time periods [ i.e. Europe/Simferopol country code changes ]; iso 3

2021-03-26 Thread Alexander
Ubuntu often talks about philosophy, but philosophy is primarily about finding 
the truth.
Don't talk about philosophy, it doesn't suit you.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to iso-codes in Ubuntu.
https://bugs.launchpad.net/bugs/1920987

Title:
  IANA tzdata file format cannot represent different country code for a
  given timezone in different time periods [ i.e. Europe/Simferopol
  country code changes ]; iso 3166-2 has no RU subdivisions for Crimea

Status in iso-codes package in Ubuntu:
  New
Status in tzdata package in Ubuntu:
  Opinion

Bug description:
  Europe/Simferopol,  Crimea is RUSSIA

  ProblemType: Bug
  DistroRelease: Ubuntu 21.04
  Package: tzdata 2021a-1ubuntu1
  ProcVersionSignature: Ubuntu 5.11.0-11.12-generic 5.11.0
  Uname: Linux 5.11.0-11-generic x86_64
  ApportVersion: 2.20.11-0ubuntu60
  Architecture: amd64
  CurrentDesktop: MATE
  Date: Tue Mar 23 21:44:56 2021
  InstallationDate: Installed on 2021-03-21 (1 days ago)
  InstallationMedia: Ubuntu-MATE 21.04 "Hirsute Hippo" - Alpha amd64 (20210321)
  PackageArchitecture: all
  SourcePackage: tzdata
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/iso-codes/+bug/1920987/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp