[Touch-packages] [Bug 1832407] Re: Ubuntu's gnome-shell extensions can't be uninstalled (safely)

2022-01-03 Thread Daniel van Vugt
I agree this should be fixed, but it's also not a priority. You can
disable them in the Extensions app (sudo apt install gnome-shell-
extension-prefs).

** Description changed:

  I like the Ubuntu themed GNOME desktop but I don't like dash-to-dock.
- As the preinstalled extensions, especially gnome-shell-extension-ubuntu-dock 
are not deactivable and not removable atomic (they are hard dependcies of 
ubuntu-desktop), the only way to remove them is to rename the extensions 
folder. This will also restore the dock with every update of the 
gnome-shell-extension-ubuntu-dock package, as it creates this folder.
+ As the pre-installed extensions, especially gnome-shell-extension-ubuntu-dock 
are not atomically removable (they are hard dependencies of ubuntu-desktop), 
the only way to remove them is to rename the extensions folder. This will also 
restore the dock with every update of the gnome-shell-extension-ubuntu-dock 
package, as it creates this folder.
  
- Therfore, we should remove the hard dependcies.
+ Therefore, we should remove the hard dependencies.

** Changed in: ubuntu-meta (Ubuntu)
   Importance: Medium => Low

** Changed in: ubuntu-meta (Ubuntu)
   Status: Confirmed => Triaged

** Tags added: jammy

** Tags removed: groovy

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu.
https://bugs.launchpad.net/bugs/1832407

Title:
  Ubuntu's gnome-shell extensions can't be uninstalled (safely)

Status in ubuntu-meta package in Ubuntu:
  Triaged

Bug description:
  I like the Ubuntu themed GNOME desktop but I don't like dash-to-dock.
  As the pre-installed extensions, especially gnome-shell-extension-ubuntu-dock 
are not atomically removable (they are hard dependencies of ubuntu-desktop), 
the only way to remove them is to rename the extensions folder. This will also 
restore the dock with every update of the gnome-shell-extension-ubuntu-dock 
package, as it creates this folder.

  Therefore, we should remove the hard dependencies.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-meta/+bug/1832407/+subscriptions


-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1956275] [NEW] apt autoremove uninstalls nvidia graphics card drivers

2022-01-03 Thread Matt S
Public bug reported:

Hardware information:
Razer Blade 15 mid 2019, RTX2060
OS Kubuntu 21.10

command ran: apt autoremove

What I expected to happen: Unnecessary packages are removed by autoremove
What happened: GPU drivers are removed, preventing graphical interfaces from 
being used


apt logs:
Start-Date: 2022-01-03  18:34:51
Commandline: apt autoremove
Requested-By: matt (1000)
Remove: libnvidia-common-470:amd64 (470.86-0ubuntu0.21.10.1), libxnvctrl0:amd64 
(470.57.01-0ubuntu3), libnvidia-fbc1-470:amd64 (470.86-0ubuntu0.21.10.1), 
libnvidia-fbc1-470:i386 (470.86-0ubuntu0.21.10.1), libnvidia-gl-470:amd64 
(470.86-0ubuntu0.21.10.1), libnvidia-gl-470:i386 (470.86-0ubuntu0.21.10.1), 
libnvidia-extra-470:amd64 (470.86-0ubuntu0.21.10.1), 
nvidia-compute-utils-470:amd64 (470.86-0ubuntu0.21.10.1), 
libnvidia-encode-470:amd64 (470.86-0ubuntu0.21.10.1), libnvidia-encode-470:i386 
(470.86-0ubuntu0.21.10.1), nvidia-utils-470:amd64 (470.86-0ubuntu0.21.10.1), 
xserver-xorg-video-nvidia-470:amd64 (470.86-0ubuntu0.21.10.1), 
libnvidia-ifr1-470:amd64 (470.86-0ubuntu0.21.10.1), libnvidia-ifr1-470:i386 
(470.86-0ubuntu0.21.10.1), libsdl-ttf2.0-0:amd64 (2.0.11-6), 
libnvidia-decode-470:amd64 (470.86-0ubuntu0.21.10.1), libnvidia-decode-470:i386 
(470.86-0ubuntu0.21.10.1), screen-resolution-extra:amd64 (0.18.1), 
nvidia-settings:amd64 (470.57.01-0ubuntu3), lynx-common:amd64 (2.9.0dev.6-3), 
libnvidia-cfg1-470:amd64 (470.86-0ubuntu0.21.10.1), 
nvidia-kernel-source-470:amd64 (470.86-0ubuntu0.21.10.1), 
libnvidia-compute-470:i386 (470.86-0ubuntu0.21.10.1)

ProblemType: Bug
DistroRelease: Ubuntu 21.10
Package: apt 2.3.9
ProcVersionSignature: Ubuntu 5.13.0-22.22-generic 5.13.19
Uname: Linux 5.13.0-22-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.11-0ubuntu71
Architecture: amd64
CasperMD5CheckResult: pass
CurrentDesktop: KDE
Date: Mon Jan  3 21:11:15 2022
InstallationDate: Installed on 2021-12-26 (9 days ago)
InstallationMedia: Kubuntu 21.10 "Impish Indri" - Release amd64 (20211012)
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
SourcePackage: apt
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: apt (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug impish

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apt in Ubuntu.
https://bugs.launchpad.net/bugs/1956275

Title:
  apt autoremove uninstalls nvidia graphics card drivers

Status in apt package in Ubuntu:
  New

Bug description:
  Hardware information:
  Razer Blade 15 mid 2019, RTX2060
  OS Kubuntu 21.10

  command ran: apt autoremove

  What I expected to happen: Unnecessary packages are removed by autoremove
  What happened: GPU drivers are removed, preventing graphical interfaces from 
being used


  apt logs:
  Start-Date: 2022-01-03  18:34:51
  Commandline: apt autoremove
  Requested-By: matt (1000)
  Remove: libnvidia-common-470:amd64 (470.86-0ubuntu0.21.10.1), 
libxnvctrl0:amd64 (470.57.01-0ubuntu3), libnvidia-fbc1-470:amd64 
(470.86-0ubuntu0.21.10.1), libnvidia-fbc1-470:i386 (470.86-0ubuntu0.21.10.1), 
libnvidia-gl-470:amd64 (470.86-0ubuntu0.21.10.1), libnvidia-gl-470:i386 
(470.86-0ubuntu0.21.10.1), libnvidia-extra-470:amd64 (470.86-0ubuntu0.21.10.1), 
nvidia-compute-utils-470:amd64 (470.86-0ubuntu0.21.10.1), 
libnvidia-encode-470:amd64 (470.86-0ubuntu0.21.10.1), libnvidia-encode-470:i386 
(470.86-0ubuntu0.21.10.1), nvidia-utils-470:amd64 (470.86-0ubuntu0.21.10.1), 
xserver-xorg-video-nvidia-470:amd64 (470.86-0ubuntu0.21.10.1), 
libnvidia-ifr1-470:amd64 (470.86-0ubuntu0.21.10.1), libnvidia-ifr1-470:i386 
(470.86-0ubuntu0.21.10.1), libsdl-ttf2.0-0:amd64 (2.0.11-6), 
libnvidia-decode-470:amd64 (470.86-0ubuntu0.21.10.1), libnvidia-decode-470:i386 
(470.86-0ubuntu0.21.10.1), screen-resolution-extra:amd64 (0.18.1), 
nvidia-settings:amd64 (470.57.01-0ubuntu3), lynx-common:amd64 (2.9.0dev.6-3), 
libnvidia-cfg1-470:amd64 (470.86-0ubuntu0.21.10.1), 
nvidia-kernel-source-470:amd64 (470.86-0ubuntu0.21.10.1), 
libnvidia-compute-470:i386 (470.86-0ubuntu0.21.10.1)

  ProblemType: Bug
  DistroRelease: Ubuntu 21.10
  Package: apt 2.3.9
  ProcVersionSignature: Ubuntu 5.13.0-22.22-generic 5.13.19
  Uname: Linux 5.13.0-22-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  ApportVersion: 2.20.11-0ubuntu71
  Architecture: amd64
  CasperMD5CheckResult: pass
  CurrentDesktop: KDE
  Date: Mon Jan  3 21:11:15 2022
  InstallationDate: Installed on 2021-12-26 (9 days ago)
  InstallationMedia: Kubuntu 21.10 "Impish Indri" - Release amd64 (20211012)
  ProcEnviron:
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/zsh
  SourcePackage: apt
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apt/+bug/1956275/+subscriptions


-- 
Mailing list: 

[Touch-packages] [Bug 1956263] Re: Situationm

2022-01-03 Thread Chris Guiver
Thank you for taking the time to report this bug and helping to make
Ubuntu better.

Unfortunately, we cannot work on this bug because your description
didn't include enough information. You may find it helpful to read "How
to report bugs effectively"
http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful
if you would then provide a more complete description of the problem.

We have instructions on debugging some types of problems at
http://wiki.ubuntu.com/DebuggingProcedures.

At a minimum, we need:

1. The specific steps or actions you took that caused you to encounter the 
problem.
2. The behavior you expected.
3. The behavior you actually encountered (in as much detail as possible).

Bug reporting is mostly about finding & fixing problems thus preventing
future users from hitting the same bug.

I suspect a Support site would be more appropriate, eg.
https://answers.launchpad.net/ubuntu. You can also find help with your
problem in the support forum of your local Ubuntu community
http://loco.ubuntu.com/ or asking at https://askubuntu.com or
https://ubuntuforums.org, or for more support options please look at
https://discourse.ubuntu.com/t/community-support/709

You mention `grub` which is a boot loader; thus it's a boot issue and
the OS doesn't start?  Screen blanking can occur during the boot process
(video hardware switches modes) for some hardware setups. Grub config
has documentation; eg. https://help.ubuntu.com/community/Grub2/Setup but
it's all geared at altering the boot process; or making the grub menu
more appealing.

You're also not using Ubuntu kernel, with various 3rd party packages,
such as what is found in a 3rd OS/source (eg. not
`21.0.3-0ubuntu0.3~20.04.5` but
`21.2.2-1ubuntu1pop0~1634226723~20.04~b715ae2~dev` so issues should be
addressed with the 3rd party packager (possibly system76) as you're not
using Ubuntu packages.


** Changed in: xorg (Ubuntu)
   Status: New => Incomplete

** Package changed: xorg (Ubuntu) => xorg-server (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1956263

Title:
  Situationm

Status in xorg-server package in Ubuntu:
  Incomplete

Bug description:
  I have been using ubuntu for nearly ten years, but have only recently
  started taking things seriously.  My particular issue is that every
  now and then I have a screen blinking problem. I have done a bunch of
  research, and it points to the grub configuration.  I have downloaded
  and installed grub customizer.  But I am not sure what all the options
  are and am afraid of messing anyting up.  Not sure that coming here
  will help, or how I can pay for any help.  Thanks for reading, and for
  any help you are able to provide.  PS  I am running Ubundu 20.03 on a
  System 76 Mini box.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: xorg 1:7.7+19ubuntu14
  Uname: Linux 5.15.5-76051505-generic x86_64
  .tmp.unity_support_test.0:
   
  ApportVersion: 2.20.11-0ubuntu27.21
  Architecture: amd64
  BootLog:
   
  CasperMD5CheckResult: skip
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  Date: Mon Jan  3 18:28:39 2022
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroVariant: ubuntu
  DpkgLog:
   
  ExtraDebuggingInterest: I just need to know a workaround
  GraphicsCard:
   Intel Corporation Iris Plus Graphics 655 [8086:3ea5] (rev 01) (prog-if 00 
[VGA controller])
 Subsystem: Intel Corporation Iris Plus Graphics 655 [8086:2074]
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 
802.11n WLAN Adapter
   Bus 001 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
   Bus 001 Device 004: ID 8087:0aaa Intel Corp. 
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: System76 Meerkat
  ProcEnviron:
   PATH=(custom, no user)
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.15.5-76051505-generic 
root=UUID=bcaa96a9-3ebb-4f61-8b4d-bf8382de31aa ro
  Renderer: Software
  SourcePackage: xorg
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 11/28/2018
  dmi.bios.release: 5.6
  dmi.bios.vendor: Intel Corp.
  dmi.bios.version: BECFL357.86A.0056.2018.1128.1717
  dmi.board.name: NUC8BEB
  dmi.board.vendor: Intel Corporation
  dmi.board.version: J72693-304
  dmi.chassis.type: 3
  dmi.chassis.vendor: System76
  dmi.chassis.version: meer4
  dmi.ec.firmware.release: 3.20
  dmi.modalias: 
dmi:bvnIntelCorp.:bvrBECFL357.86A.0056.2018.1128.1717:bd11/28/2018:br5.6:efr3.20:svnSystem76:pnMeerkat:pvrmeer4:rvnIntelCorporation:rnNUC8BEB:rvrJ72693-304:cvnSystem76:ct3:cvrmeer4:skuBOXNUC8i3BEK:
  dmi.product.family: Intel NUC
  dmi.product.name: Meerkat
  dmi.product.sku: BOXNUC8i3BEK
  

[Touch-packages] [Bug 1956263] [NEW] Situationm

2022-01-03 Thread Bruce Miller
Public bug reported:

I have been using ubuntu for nearly ten years, but have only recently
started taking things seriously.  My particular issue is that every now
and then I have a screen blinking problem. I have done a bunch of
research, and it points to the grub configuration.  I have downloaded
and installed grub customizer.  But I am not sure what all the options
are and am afraid of messing anyting up.  Not sure that coming here will
help, or how I can pay for any help.  Thanks for reading, and for any
help you are able to provide.  PS  I am running Ubundu 20.03 on a System
76 Mini box.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: xorg 1:7.7+19ubuntu14
Uname: Linux 5.15.5-76051505-generic x86_64
.tmp.unity_support_test.0:
 
ApportVersion: 2.20.11-0ubuntu27.21
Architecture: amd64
BootLog:
 
CasperMD5CheckResult: skip
CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Mon Jan  3 18:28:39 2022
DistUpgraded: Fresh install
DistroCodename: focal
DistroVariant: ubuntu
DpkgLog:
 
ExtraDebuggingInterest: I just need to know a workaround
GraphicsCard:
 Intel Corporation Iris Plus Graphics 655 [8086:3ea5] (rev 01) (prog-if 00 [VGA 
controller])
   Subsystem: Intel Corporation Iris Plus Graphics 655 [8086:2074]
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 
802.11n WLAN Adapter
 Bus 001 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
 Bus 001 Device 004: ID 8087:0aaa Intel Corp. 
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: System76 Meerkat
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.15.5-76051505-generic 
root=UUID=bcaa96a9-3ebb-4f61-8b4d-bf8382de31aa ro
Renderer: Software
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/28/2018
dmi.bios.release: 5.6
dmi.bios.vendor: Intel Corp.
dmi.bios.version: BECFL357.86A.0056.2018.1128.1717
dmi.board.name: NUC8BEB
dmi.board.vendor: Intel Corporation
dmi.board.version: J72693-304
dmi.chassis.type: 3
dmi.chassis.vendor: System76
dmi.chassis.version: meer4
dmi.ec.firmware.release: 3.20
dmi.modalias: 
dmi:bvnIntelCorp.:bvrBECFL357.86A.0056.2018.1128.1717:bd11/28/2018:br5.6:efr3.20:svnSystem76:pnMeerkat:pvrmeer4:rvnIntelCorporation:rnNUC8BEB:rvrJ72693-304:cvnSystem76:ct3:cvrmeer4:skuBOXNUC8i3BEK:
dmi.product.family: Intel NUC
dmi.product.name: Meerkat
dmi.product.sku: BOXNUC8i3BEK
dmi.product.version: meer4
dmi.sys.vendor: System76
version.compiz: compiz 1:0.9.14.1+20.04.20200211-0ubuntu1
version.libdrm2: libdrm2 2.4.107-8ubuntu1pop0~1634226451~20.04~d7878ab~dev
version.libgl1-mesa-dri: libgl1-mesa-dri 
21.2.2-1ubuntu1pop0~1634226723~20.04~b715ae2~dev
version.libgl1-mesa-glx: libgl1-mesa-glx 
21.2.2-1ubuntu1pop0~1634226723~20.04~b715ae2~dev
version.xserver-xorg-core: xserver-xorg-core 2:1.20.11-1ubuntu1~20.04.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.6-1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1
xserver.bootTime: Tue Dec 17 17:36:58 2019
xserver.configfile: default
xserver.devices:
 inputPower Button KEYBOARD, id 6
 inputPower Button KEYBOARD, id 7
 inputSleep Button KEYBOARD, id 8
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.19.6-1ubuntu4.3

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug focal third-party-packages ubuntu

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1956263

Title:
  Situationm

Status in xorg package in Ubuntu:
  New

Bug description:
  I have been using ubuntu for nearly ten years, but have only recently
  started taking things seriously.  My particular issue is that every
  now and then I have a screen blinking problem. I have done a bunch of
  research, and it points to the grub configuration.  I have downloaded
  and installed grub customizer.  But I am not sure what all the options
  are and am afraid of messing anyting up.  Not sure that coming here
  will help, or how I can pay for any help.  Thanks for reading, and for
  any help you are able to provide.  PS  I am running Ubundu 20.03 on a
  System 76 Mini box.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: xorg 1:7.7+19ubuntu14
  Uname: Linux 5.15.5-76051505-generic x86_64
  .tmp.unity_support_test.0:
   
  ApportVersion: 2.20.11-0ubuntu27.21
  Architecture: amd64
  BootLog:
   
  CasperMD5CheckResult: skip
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  

[Touch-packages] [Bug 1952083] Re: Add support for Beige Goby

2022-01-03 Thread Alex Hung
** Changed in: amd
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1952083

Title:
  Add support for Beige Goby

Status in amd:
  Fix Released
Status in OEM Priority Project:
  Fix Released
Status in mesa package in Ubuntu:
  Fix Released
Status in mesa source package in Focal:
  Fix Released

Bug description:
  Impact]

  New hardware support for AMD's Beige Goby needs a commit backported to
  mesa. This is only needed on focal, skipping hirsute (no kernel
  support there). Fixed in impish and up.

  [Test plan]

  Install updates, boot a BG machine and check that the desktop has full
  hardware acceleration.

  [Where problems could occur]

  Mesa adds a single commit for enabling BEIGE_GOBY, hard to see what
  could go wrong.

To manage notifications about this bug go to:
https://bugs.launchpad.net/amd/+bug/1952083/+subscriptions


-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1952421] Re: Issue on sshd finds correct private key for a certificate when using ssh-agent

2022-01-03 Thread Chloé Smith
Hey everyone,

I can confirm the fix has been tested by our friends at Google (Anthos) for 
Focal 20.04, using the same patch used in 1:8.2p1-4ubuntu0.4 but *not* by using 
the package from focal-proposed itself.
Hopefully this still suffices? Please let me know if not and I'll re-run the 
verification again using an instance pulling from focal-proposed.

[RATIONALE]

Need SSH to authenticate a ``HostCertificate`` and an SSH agent that
holds the corresponding host private key.

The sshd_config has the following directives:

-- HostCertificate the public host certificate whose public key matches
the private key stored in the ssh agent

-- HostKey the public key of the host keypair

-- HostKeyAgent the socket of the ssh agent that holds the host private
key

Before the patch, this combination didn't work - even though it
authenticated successfully the setup behaved as if ``HostCertificate``
was never configured (i.e. it authenticated using only the public key
and the private key in the ssh agent).

[VERIFICATION OF FIX]

sh-agent -a /path/agent-socket
SSH_AUTH_SOCK=/path/agent-socket ssh-add -k /path/hostkey


Then ran ``sshd`` with:


HostCertificate /path/hostkey-cert.pub
HostKey /path/hostkey.pub
HostKeyAgent /path/agent-socket


Then configured the CA trust anchor on the client's side. 
(localhost was used, but it would be the same if a second host is used as a 
client)


ssh -vv localhost


shows the host certificate was seen and used.

** Tags removed: verification-needed-focal
** Tags added: verification-done-focal

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssh in Ubuntu.
https://bugs.launchpad.net/bugs/1952421

Title:
  Issue on sshd finds correct private key for a certificate when using
  ssh-agent

Status in openssh package in Ubuntu:
  Fix Released
Status in openssh source package in Focal:
  Fix Committed
Status in openssh source package in Hirsute:
  Fix Committed
Status in openssh source package in Impish:
  Fix Committed

Bug description:
  Reported as https://bugzilla.mindrot.org/show_bug.cgi?id=3254 upstream

  [Impact]

   * HostCertificate and HostKeyAgent are not working together in sshd due 
 to a mismatched certificate's public key and private key. The function `  
`sshkey_equal_public()`` incorrectly compares the certificate's public 
key with a private key, never finding a match. The impact is that sshd 
cannot use said certificate *even though* its private key is indeed in 
ssh-agent.

  * What it should do is compare the certificate's public key with a
  public key in `sensitive_data`.

  * Having this SRU-ed is a direct ask from one of the major cloud partners. 
They are currently using a customised version of the package to work 
around this issue, and we would like them to use a package directly from 
our own archive.

   * Looping through sensitive_data.host_pubkeys[j] *instead* of 
 sensitive_data.host_keys[j] fixes the issue

  [https://github.com/openssh/openssh-portable/blob/V_8_4/sshd.c#L1936]

  /* Find matching private key */
   for (j = 0; j < options.num_host_key_files; j++) {
    if (sshkey_equal_public(key,
     sensitive_data.host_keys[j])) {
     sensitive_data.host_certificates[j] = key;
  break;
     }
   }

  vs.

  /* Find matching private key */
   for (j = 0; j < options.num_host_key_files; j++) {
    if (sshkey_equal_public(key,
     sensitive_data.host_pubkeys[j])) {
     sensitive_data.host_certificates[j] = key;
  break;
     }
   }
   

  [Test Plan]

   * Due to the empirical nature of this bug, the test is quite straight 
 forward. *Without* the fix, one cannot use certificates to authenticate 
 successfully (e.g. ``sshd -c /path/to/certificate.pem``)
 whereas with the fix (assuming the certificate matches a host key) you 
 can create a channel.
 
  [Where problems could occur]

   * This has already been fixed both upstream and in Jammy without issue. 
 However, if a regression where to happen it would probably be in one of 
 two ways:
   
   * A dependency/reverse-dependency issue stemming from the version 
 bump that will happen if this fix is ported. We mitigate this risk 
 by testing for these exact types of regression, 
 and by selecting carefully what to label this new version.
 
   * Accidentally breaking a set up that was made to work around this 
 bug in the first place. The risk of this is lower, as the most 
 likely fix is the one being implemented here anyway.  Though
 to mitigate this more we can describe exactly what is happening 
 with the fix in the changelog.

  
  This affects every version of openssh back until Focal, at least.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1952421/+subscriptions


-- 
Mailing list: 

[Touch-packages] [Bug 1845797]

2022-01-03 Thread sam.voss
Unfortunately I replicated those same failures. All five speakers work
just fine in Windows (using qemu) although the played back verbs will
only continue activating the same speakers. When I tested it I was able
to "break" and "restore" the speakers using different verb-sets, so
while it's definitely making some changes, it doesn't seem to be
impacting the bottom speakers in the slightest.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1845797

Title:
  Microphone not detected Lenovo Yoga S940

Status in Linux:
  Confirmed
Status in alsa-driver package in Ubuntu:
  Confirmed
Status in linux package in Ubuntu:
  Incomplete

Bug description:
  Ubuntu 19.10 as well as 19.04 do not detect the microphone in Lenovo
  Yoga S940

  Attached the screen of gnome sound control panel.

  Inxi output:

  System:Host:  Kernel: 5.3.0-13-generic x86_64 bits: 64 Desktop: 
Gnome 3.34.0 Distro: Ubuntu 19.10 (Eoan Ermine) 
  Machine:   Type: Laptop System: LENOVO product: 81Q7 v: Lenovo Yoga 
S940-14IWL serial:  
 Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN serial:  UEFI: LENOVO v: AKCN34WW date: 06/12/2019 
  CPU:   Topology: Quad Core model: Intel Core i7-8565U bits: 64 type: MT 
MCP L2 cache: 8192 KiB 
 Speed: 1161 MHz min/max: 400/4600 MHz Core speeds (MHz): 1: 1161 
2: 1195 3: 1848 4: 976 5: 1041 6: 1209 7: 1061 
 8: 2229 
  Audio: Device-1: Intel Cannon Point-LP High Definition Audio driver: 
snd_hda_intel 
 Sound Server: ALSA v: k5.3.0-13-generic
  --- 
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu7
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  daniele2239 F pulseaudio
  CurrentDesktop: ubuntu:GNOME
  DistroRelease: Ubuntu 19.10
  InstallationDate: Installed on 2019-09-12 (17 days ago)
  InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
  MachineType: LENOVO 81Q7
  Package: pulseaudio 1:13.0-1ubuntu1
  PackageArchitecture: amd64
  ProcFB: 0 i915drmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-5.3.0-13-generic 
root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.3.0-13.14-generic 5.3.0
  RelatedPackageVersions:
   linux-restricted-modules-5.3.0-13-generic N/A
   linux-backports-modules-5.3.0-13-generic  N/A
   linux-firmware1.182
  Tags:  eoan
  Uname: Linux 5.3.0-13-generic x86_64
  UpgradeStatus: Upgraded to eoan on 2019-09-21 (8 days ago)
  UserGroups: adm cdrom dip docker lpadmin microk8s plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 06/12/2019
  dmi.bios.vendor: LENOVO
  dmi.bios.version: AKCN34WW
  dmi.board.asset.tag: No Asset Tag
  dmi.board.name: LNVNB161216
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0J40709 WIN
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Lenovo Yoga S940-14IWL
  dmi.modalias: 
dmi:bvnLENOVO:bvrAKCN34WW:bd06/12/2019:svnLENOVO:pn81Q7:pvrLenovoYogaS940-14IWL:rvnLENOVO:rnLNVNB161216:rvrSDK0J40709WIN:cvnLENOVO:ct10:cvrLenovoYogaS940-14IWL:
  dmi.product.family: Yoga S940-14IWL
  dmi.product.name: 81Q7
  dmi.product.sku: LENOVO_MT_81Q7_BU_idea_FM_Yoga S940-14IWL
  dmi.product.version: Lenovo Yoga S940-14IWL
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/linux/+bug/1845797/+subscriptions


-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1956243] [NEW] Ping give socket error initially if IPv6 is disabled

2022-01-03 Thread Andrew Welham
Public bug reported:

With IpV6 enabled everything works well. However if you disable ipv6 by editing 
/etc/default/grub with the following entry
GRUB_CMDLINE_LINUX_DEFAULT="ipv6.disable=1"
 then when you ping there is an initial socket error 

ping localhost
ping: socket: Address family not supported by protocol
PING localhost (127.0.0.1) 56(84) bytes of data.
64 bytes from localhost (127.0.0.1): icmp_seq=1 ttl=64 time=0.046 ms
64 bytes from localhost (127.0.0.1): icmp_seq=2 ttl=64 time=0.038 ms
64 bytes from localhost (127.0.0.1): icmp_seq=3 ttl=64 time=0.028 ms
64 bytes from localhost (127.0.0.1): icmp_seq=4 ttl=64 time=0.028 ms


however ping -4 works

ping -4 localhost
PING localhost (127.0.0.1) 56(84) bytes of data.
64 bytes from localhost (127.0.0.1): icmp_seq=1 ttl=64 time=0.032 ms
64 bytes from localhost (127.0.0.1): icmp_seq=2 ttl=64 time=0.029 ms
64 bytes from localhost (127.0.0.1): icmp_seq=3 ttl=64 time=0.021 ms

so it looks like ping is trying ipv6 first and not detecting that its
disabled.

ProblemType: Bug
DistroRelease: Ubuntu 22.04
Package: iputils-ping 3:20210202-1build1
ProcVersionSignature: Ubuntu 5.13.0-19.19-generic 5.13.14
Uname: Linux 5.13.0-19-generic x86_64
ApportVersion: 2.20.11-0ubuntu74
Architecture: amd64
CasperMD5CheckResult: pass
Date: Mon Jan  3 17:42:07 2022
InstallationDate: Installed on 2022-01-03 (0 days ago)
InstallationMedia: Ubuntu-Server 22.04 LTS "Jammy Jellyfish" - Alpha amd64 
(20211029)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: iputils
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: iputils (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug jammy third-party-packages uec-images

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to iputils in Ubuntu.
https://bugs.launchpad.net/bugs/1956243

Title:
  Ping give socket  error initially if IPv6 is disabled

Status in iputils package in Ubuntu:
  New

Bug description:
  With IpV6 enabled everything works well. However if you disable ipv6 by 
editing /etc/default/grub with the following entry
  GRUB_CMDLINE_LINUX_DEFAULT="ipv6.disable=1"
   then when you ping there is an initial socket error 

  ping localhost
  ping: socket: Address family not supported by protocol
  PING localhost (127.0.0.1) 56(84) bytes of data.
  64 bytes from localhost (127.0.0.1): icmp_seq=1 ttl=64 time=0.046 ms
  64 bytes from localhost (127.0.0.1): icmp_seq=2 ttl=64 time=0.038 ms
  64 bytes from localhost (127.0.0.1): icmp_seq=3 ttl=64 time=0.028 ms
  64 bytes from localhost (127.0.0.1): icmp_seq=4 ttl=64 time=0.028 ms

  
  however ping -4 works

  ping -4 localhost
  PING localhost (127.0.0.1) 56(84) bytes of data.
  64 bytes from localhost (127.0.0.1): icmp_seq=1 ttl=64 time=0.032 ms
  64 bytes from localhost (127.0.0.1): icmp_seq=2 ttl=64 time=0.029 ms
  64 bytes from localhost (127.0.0.1): icmp_seq=3 ttl=64 time=0.021 ms

  so it looks like ping is trying ipv6 first and not detecting that its
  disabled.

  ProblemType: Bug
  DistroRelease: Ubuntu 22.04
  Package: iputils-ping 3:20210202-1build1
  ProcVersionSignature: Ubuntu 5.13.0-19.19-generic 5.13.14
  Uname: Linux 5.13.0-19-generic x86_64
  ApportVersion: 2.20.11-0ubuntu74
  Architecture: amd64
  CasperMD5CheckResult: pass
  Date: Mon Jan  3 17:42:07 2022
  InstallationDate: Installed on 2022-01-03 (0 days ago)
  InstallationMedia: Ubuntu-Server 22.04 LTS "Jammy Jellyfish" - Alpha amd64 
(20211029)
  ProcEnviron:
   TERM=xterm
   PATH=(custom, no user)
   LANG=en_GB.UTF-8
   SHELL=/bin/bash
  SourcePackage: iputils
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/iputils/+bug/1956243/+subscriptions


-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1955985] Re: installation crashes with error "Setting up openssh-client (1:8.7p1-3) ... update-alternatives: and can't be the same"

2022-01-03 Thread Bug Watch Updater
** Changed in: openssh (Debian)
   Status: Unknown => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssh in Ubuntu.
https://bugs.launchpad.net/bugs/1955985

Title:
  installation crashes with error "Setting up openssh-client (1:8.7p1-3)
  ... update-alternatives:  and  can't be the same"

Status in openssh package in Ubuntu:
  Fix Released
Status in openssh package in Debian:
  Fix Released

Bug description:
  Description:Ubuntu Jammy Jellyfish (development branch)
  Release:22.04
  openssh-client (1:8.7p1-3)
  I expected it to install normally.
  The installation crashed.
  E: Sub-process /usr/bin/dpkg returned an error code (1)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1955985/+subscriptions


-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1955347] Re: rsync works bad with encfs now

2022-01-03 Thread Christian Ehrhardt 
I'm marking this incomplete waiting for feedback on the suggested
options or a discussion why this really should be an error to be fixed
in the source (instead of configuration).

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to rsync in Ubuntu.
https://bugs.launchpad.net/bugs/1955347

Title:
  rsync works bad with encfs now

Status in rsync package in Ubuntu:
  Incomplete

Bug description:
  Hello,
  I think rsync works bad with encfs now.

  When root uses it, rsync cannot read a directory encrypted with encfs
  by a user. More precisely, it cannot read the mounted directory, the
  virtual one where the user can read the datas.

  Until now there was only a warning like this
  "rsync: readlink_stat("/home/claude/Documents_chiffres") failed:
  Permission denied (13)"
  and the software went on working (only ignoring the content of the mounted 
directory and of course without saving this content)

  But recently there is this more:
  "IO error encountered -- skipping file deletion"
  and because of this "skipping file deletion", the software can't work 
normally. The destination gets bigger more and more because the deleted files 
in the source are not deleted in the destination.

  Thanks for reading me.
  rsync 3.1.3-8ubuntu0.1
  Description:Ubuntu 20.04.3 LTS
  Release:20.04

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/rsync/+bug/1955347/+subscriptions


-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1955347] Re: rsync works bad with encfs now

2022-01-03 Thread Christian Ehrhardt 
Hi,
I'm not 100% sure but to me that is a setup and configuration issue with the 
new version being a bit more insisting that it can read/access paths it is 
supposed to back up.

The new behavior can be disabled with --ignore-errors, but I'm tempted
to consider this dangerous as you could have any other I/O error and it
would still delete things.

Did you try to use --exclude=PATTERN and if that matches your use case
--delete-excluded to make the new version behave as you were used from
the older one?

** Changed in: rsync (Ubuntu)
   Status: New => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to rsync in Ubuntu.
https://bugs.launchpad.net/bugs/1955347

Title:
  rsync works bad with encfs now

Status in rsync package in Ubuntu:
  Incomplete

Bug description:
  Hello,
  I think rsync works bad with encfs now.

  When root uses it, rsync cannot read a directory encrypted with encfs
  by a user. More precisely, it cannot read the mounted directory, the
  virtual one where the user can read the datas.

  Until now there was only a warning like this
  "rsync: readlink_stat("/home/claude/Documents_chiffres") failed:
  Permission denied (13)"
  and the software went on working (only ignoring the content of the mounted 
directory and of course without saving this content)

  But recently there is this more:
  "IO error encountered -- skipping file deletion"
  and because of this "skipping file deletion", the software can't work 
normally. The destination gets bigger more and more because the deleted files 
in the source are not deleted in the destination.

  Thanks for reading me.
  rsync 3.1.3-8ubuntu0.1
  Description:Ubuntu 20.04.3 LTS
  Release:20.04

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/rsync/+bug/1955347/+subscriptions


-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1954628] Re: [USB-Audio - ALC4080] Front panel: Headphone output not working

2022-01-03 Thread Gijs Peskens
** Summary changed:

- [USB-Audio - USB Audio, playback] Headphone output mapped incorrectly
+ [USB-Audio - ALC4080] Front panel: Headphone output not working

** Description changed:

  I have a MSI MAG X570s Torpedo MAX motherboard, which has an onboard
- 'Starship/Matisse HD Audio Controller' controller that has a weird
- mapping via USB audio (see bug:
+ 'Starship/Matisse HD Audio Controller' (-> ALC4080 USB based audio chip)
+ controller that has a weird mapping via USB audio (see bug:
  https://bugzilla.kernel.org/show_bug.cgi?id=206873 for a similar
  configuration).
  
  Sound via line-out works fine without any interventions.
  
  Headphone output however does not, while Ubuntu correctly detects the
  headphones as being plugged in when selected sound is still output via
  line-out, instead of via the front panel headphone jack-out.
  
- After some debugging I figured the headphones are connected to a seperate 
Alsa device on the same card as the line-out. 
- Running 'pacmd load-module module-alsa-sink device=hw:2,1' gives me a working 
audio output that plays just via the headphone out. 
+ After some debugging I figured the headphones are connected to a seperate 
Alsa device on the same card as the line-out.
+ Running 'pacmd load-module module-alsa-sink device=hw:2,1' gives me a working 
audio output that plays just via the headphone out.
  
  I guess a quirk needs to be written for the configuration.
  
  ProblemType: Bug
  DistroRelease: Ubuntu 21.10
  Package: alsa-base 1.0.25+dfsg-0ubuntu7
  ProcVersionSignature: Ubuntu 5.13.0-22.22-generic 5.13.19
  Uname: Linux 5.13.0-22-generic x86_64
  ApportVersion: 2.20.11-0ubuntu71
  Architecture: amd64
  AudioDevicesInUse:
-  USERPID ACCESS COMMAND
-  /dev/snd/controlC2:  gijs   2129 F pulseaudio
-  /dev/snd/pcmC2D1p:   gijs   2129 F...m pulseaudio
-  /dev/snd/controlC0:  gijs   2129 F pulseaudio
+  USERPID ACCESS COMMAND
+  /dev/snd/controlC2:  gijs   2129 F pulseaudio
+  /dev/snd/pcmC2D1p:   gijs   2129 F...m pulseaudio
+  /dev/snd/controlC0:  gijs   2129 F pulseaudio
  CasperMD5CheckResult: unknown
  CurrentDesktop: ubuntu:GNOME
  Date: Mon Dec 13 09:28:19 2021
  InstallationDate: Installed on 2020-12-06 (371 days ago)
  InstallationMedia: Ubuntu 20.10 "Groovy Gorilla" - Release amd64 (20201022)
  PackageArchitecture: all
  SourcePackage: alsa-driver
  Symptom: audio
  Symptom_AlsaPlaybackTest: ALSA playback test through plughw:Audio successful
  Symptom_Card: USB Audio - USB Audio
  Symptom_PulsePlaybackTest: PulseAudio playback test successful
  Symptom_Type: Only some of outputs are working
  Title: [USB-Audio - USB Audio, playback] Playback problem
  UpgradeStatus: Upgraded to impish on 2021-09-28 (75 days ago)
  dmi.bios.date: 07/09/2021
  dmi.bios.release: 5.17
  dmi.bios.vendor: American Megatrends International, LLC.
  dmi.bios.version: A.00
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: MAG X570S TORPEDO MAX (MS-7D54)
  dmi.board.vendor: Micro-Star International Co., Ltd.
  dmi.board.version: 1.0
  dmi.chassis.asset.tag: To be filled by O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: Micro-Star International Co., Ltd.
  dmi.chassis.version: 1.0
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInternational,LLC.:bvrA.00:bd07/09/2021:br5.17:svnMicro-StarInternationalCo.,Ltd.:pnMS-7D54:pvr1.0:rvnMicro-StarInternationalCo.,Ltd.:rnMAGX570STORPEDOMAX(MS-7D54):rvr1.0:cvnMicro-StarInternationalCo.,Ltd.:ct3:cvr1.0:skuTobefilledbyO.E.M.:
  dmi.product.family: To be filled by O.E.M.
  dmi.product.name: MS-7D54
  dmi.product.sku: To be filled by O.E.M.
  dmi.product.version: 1.0
  dmi.sys.vendor: Micro-Star International Co., Ltd.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1954628

Title:
  [USB-Audio - ALC4080] Front panel: Headphone output not working

Status in alsa-driver package in Ubuntu:
  New

Bug description:
  I have a MSI MAG X570s Torpedo MAX motherboard, which has an onboard
  'Starship/Matisse HD Audio Controller' (-> ALC4080 USB based audio
  chip) controller that has a weird mapping via USB audio (see bug:
  https://bugzilla.kernel.org/show_bug.cgi?id=206873 for a similar
  configuration).

  Sound via line-out works fine without any interventions.

  Headphone output however does not, while Ubuntu correctly detects the
  headphones as being plugged in when selected sound is still output via
  line-out, instead of via the front panel headphone jack-out.

  After some debugging I figured the headphones are connected to a seperate 
Alsa device on the same card as the line-out.
  Running 'pacmd load-module module-alsa-sink device=hw:2,1' gives me a working 
audio output that plays just via the headphone out.

  I guess a quirk needs to be written for the configuration.

  ProblemType: Bug
  DistroRelease: Ubuntu 21.10
  Package: alsa-base 

[Touch-packages] [Bug 1955985] Re: installation crashes with error "Setting up openssh-client (1:8.7p1-3) ... update-alternatives: and can't be the same"

2022-01-03 Thread Christian Ehrhardt 
Indeed fixed in the referred version
https://salsa.debian.org/ssh-team/openssh/-/blob/master/debian/changelog#L4

Debian Bug:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1002803

This is already in jammy-proposed
 openssh-client | 1:8.7p1-4   | jammy-proposed   | amd64, arm64, armhf, 
i386, ppc64el, riscv64, s390x


** Bug watch added: Debian Bug tracker #1002803
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1002803

** Also affects: openssh (Debian) via
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1002803
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssh in Ubuntu.
https://bugs.launchpad.net/bugs/1955985

Title:
  installation crashes with error "Setting up openssh-client (1:8.7p1-3)
  ... update-alternatives:  and  can't be the same"

Status in openssh package in Ubuntu:
  Fix Released
Status in openssh package in Debian:
  Unknown

Bug description:
  Description:Ubuntu Jammy Jellyfish (development branch)
  Release:22.04
  openssh-client (1:8.7p1-3)
  I expected it to install normally.
  The installation crashed.
  E: Sub-process /usr/bin/dpkg returned an error code (1)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1955985/+subscriptions


-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1915238] Re: warning: /var/spool/postfix/etc/ssl/certs/ca-certificates.crt and /etc/ssl/certs/ca-certificates.crt differ

2022-01-03 Thread Christian Ehrhardt 
Thank you Scott!

As reference, that mentioned change is [1] and not yet part of a Debian
upload to sync/merge.

[1]: https://salsa.debian.org/postfix-team/postfix-
dev/-/commit/01fb7f1b307fb9bbc025d90dd404c9bff89f76ff

** Tags added: server-todo

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ca-certificates in Ubuntu.
https://bugs.launchpad.net/bugs/1915238

Title:
  warning: /var/spool/postfix/etc/ssl/certs/ca-certificates.crt and
  /etc/ssl/certs/ca-certificates.crt differ

Status in ca-certificates package in Ubuntu:
  Invalid
Status in postfix package in Ubuntu:
  Triaged
Status in postfix package in Debian:
  Fix Committed

Bug description:
  Postfix package doesn't utilize update-ca-certificate's hooks
  mechanism. By simply copying certs from /etc/ssl/certs/ca-
  certificates.crt to /var/spool/postfix/etc/ssl/certs/ca-
  certificates.crt, this warning and potential security issues could be
  avoided.

  Something like this would be a start:

  $ cat /etc/ca-certificates/update.d/postfix 
  #!/bin/bash

  if [ -e /var/spool/postfix/etc/ssl/certs/ca-certificates.crt ]; then
  echo "Updating postfix chrooted certs"
  cp /etc/ssl/certs/ca-certificates.crt 
/var/spool/postfix/etc/ssl/certs/ca-certificates.crt
  systemctl reload postfix
  fi

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ca-certificates/+bug/1915238/+subscriptions


-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1953052] Re: In Jammy sound level reset after reboot

2022-01-03 Thread sg...@tds.net
This bug also affects me. I am using Ubuntu MATE (Jammy).

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-utils in Ubuntu.
https://bugs.launchpad.net/bugs/1953052

Title:
  In Jammy sound level reset after reboot

Status in alsa-utils package in Ubuntu:
  Confirmed

Bug description:
  After reboot sound level is reset ignoring the level set in previous
  session.

  I manually set the sound output level 
  at next boot the sound is set at a different level (about 70%)

  Expected: the sound level is persistent across power off/on

  What happens : sound level is set at a different level (about 70%)

  Note: this problem does not occur on different partitions of same PC
  running Ubuntu 20.04 or 21.10

  corrado@corrado-p3-jj-1130:~$ apt policy gnome-control-center
  gnome-control-center:
Installed: 1:41.1-1ubuntu1
Candidate: 1:41.1-1ubuntu1
Version table:
   *** 1:41.1-1ubuntu1 500
  500 http://archive.ubuntu.com/ubuntu jammy/main amd64 Packages
  100 /var/lib/dpkg/status
  corrado@corrado-p3-jj-1130:~$ inxi -Fx
  System:Host: corrado-p3-jj-1130 Kernel: 5.13.0-19-generic x86_64 bits: 64 
compiler: gcc v: 11.2.0
 Desktop: GNOME 40.5 Distro: Ubuntu 22.04 (Jammy Jellyfish)
  Machine:   Type: Laptop System: Dell product: Inspiron 3793 v: N/A serial: 

 Mobo: Dell model: 0C1PF2 v: A00 serial:  UEFI: 
Dell v: 1.5.0 date: 12/17/2019
  Battery:   ID-1: BAT0 charge: 13.9 Wh (42.1%) condition: 33.0/42.0 Wh (78.7%) 
volts: 11.3 min: 11.4
 model: SWD-ATL3.618 DELL WJPC403 status: Discharging
  CPU:   Info: Quad Core model: Intel Core i5-1035G1 bits: 64 type: MT MCP 
arch: Ice Lake rev: 5 cache:
 L2: 6 MiB
 flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
bogomips: 19046
 Speed: 968 MHz min/max: 400/1000 MHz Core speeds (MHz): 1: 968 2: 
710 3: 706 4: 714 5: 966 6: 712
 7: 724 8: 821
  Graphics:  Device-1: Intel Iris Plus Graphics G1 vendor: Dell driver: i915 v: 
kernel bus-ID: 00:02.0
 Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo 
bus-ID: 1-6:3
 Display: wayland server: X.Org 1.21.1.2 compositor: gnome-shell 
driver: loaded: i915
 note: n/a (using device driver) resolution: 1920x1080~60Hz
 OpenGL: renderer: Mesa Intel UHD Graphics (ICL GT1) v: 4.6 Mesa 
21.2.2 direct render: Yes
  Audio: Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Dell driver: 
snd_hda_intel v: kernel
 bus-ID: 00:1f.3
 Sound Server-1: ALSA v: k5.13.0-19-generic running: yes
 Sound Server-2: PulseAudio v: 15.0 running: yes
 Sound Server-3: PipeWire v: 0.3.40 running: yes
  Network:   Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell 
driver: r8169 v: kernel port: 3000
 bus-ID: 01:00.0
 IF: enp1s0 state: down mac: 98:e7:43:59:19:19
 Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network 
Adapter vendor: Dell driver: ath10k_pci
 v: kernel bus-ID: 02:00.0
 IF: wlp2s0 state: up mac: d8:12:65:b8:21:b9
  Bluetooth: Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 
1-10:4
 Report: hciconfig ID: hci0 rfk-id: 0 state: down bt-service: 
enabled,running rfk-block: hardware: no
 software: yes address: D8:12:65:B8:21:BA
  Drives:Local Storage: total: 942.7 GiB used: 11.77 GiB (1.2%)
 ID-1: /dev/nvme0n1 vendor: Toshiba model: KBG40ZNS512G NVMe KIOXIA 
512GB size: 476.94 GiB temp: 24.9 C
 ID-2: /dev/sda vendor: Crucial model: CT500MX500SSD1 size: 465.76 
GiB
  Partition: ID-1: / size: 46.95 GiB used: 11.73 GiB (25.0%) fs: ext4 dev: 
/dev/nvme0n1p3
 ID-2: /boot/efi size: 246 MiB used: 46.4 MiB (18.9%) fs: vfat dev: 
/dev/nvme0n1p1
  Swap:  Alert: No swap data was found.
  Sensors:   System Temperatures: cpu: 27.8 C mobo: N/A
 Fan Speeds (RPM): cpu: 0
  Info:  Processes: 263 Uptime: 31m Memory: 15.4 GiB used: 2.45 GiB (15.9%) 
Init: systemd runlevel: 5 Compilers:
 gcc: N/A Packages: 1785 Shell: Bash v: 5.1.12 inxi: 3.3.07
  corrado@corrado-p3-jj-1130:~$
  --- 
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu74
  Architecture: amd64
  CasperMD5CheckResult: pass
  CurrentDesktop: ubuntu:GNOME
  DistroRelease: Ubuntu 22.04
  InstallationDate: Installed on 2021-11-30 (2 days ago)
  InstallationMedia: Ubuntu 22.04 LTS "Jammy Jellyfish" - Alpha amd64 (20211130)
  Package: gnome-control-center 1:41.1-1ubuntu1
  PackageArchitecture: amd64
  ProcVersionSignature: Ubuntu 5.13.0-19.19-generic 5.13.14
  Tags:  wayland-session jammy
  Uname: Linux 5.13.0-19-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
  _MarkForUpload: True

To manage notifications 

[Touch-packages] [Bug 1780680] Re: Older version in bionic than in xenial

2022-01-03 Thread Gianfranco Costamagna
** Changed in: fuse-umfuse-ext2 (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1780680

Title:
  Older version in bionic than in xenial

Status in fuse-umfuse-ext2 package in Ubuntu:
  Fix Released
Status in libclc package in Ubuntu:
  Won't Fix
Status in libdrm package in Ubuntu:
  Won't Fix
Status in linux-meta-azure package in Ubuntu:
  Fix Released
Status in linux-meta-gcp package in Ubuntu:
  Fix Released
Status in mesa package in Ubuntu:
  Won't Fix
Status in patch package in Ubuntu:
  Invalid
Status in python-pyvmomi package in Ubuntu:
  Invalid
Status in snapcraft package in Ubuntu:
  Fix Released
Status in wireless-regdb package in Ubuntu:
  Fix Released

Bug description:
  These packages have an older version in artful than in xenial.

  fuse-umfuse-ext2 0.4-1.1ubuntu0.1 < 0.4-1.1ubuntu0.16.04.1
  libclc 0.2.0+git20170330-3 < 0.2.0+git20180312-1~16.04.1
  libdrm 2.4.83-1 < 2.4.91-2~16.04.1
  mesa 17.2.8-0ubuntu0~17.10.1 < 18.0.5-0ubuntu0~16.04.1
  patch 2.7.5-1ubuntu0.2 < 2.7.5-1ubuntu0.16.04.1
  python-pyvmomi 5.5.0-2014.1.1-3 < 6.5.0.2017.5-0ubuntu1~16.04.1
  snapcraft 2.42+17.10 < 2.42.1
  wireless-regdb 2016.06.10-0ubuntu1 < 2018.05.09-0ubuntu1~16.04.1

  Some of these are older in bionic than in xenial too.

  Shouldn’t there be an automated check for this?  (See also: bug
  1780679, bug 1780681.)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/fuse-umfuse-ext2/+bug/1780680/+subscriptions


-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1922047]

2022-01-03 Thread Artogahr-9
Firefox 96 on Gnome 41.2 is still affected. These settings seem to help
though. Also the other one should be multiplier_y.

> In Windows 10, with the Precision touchpad, unaccelerated scrolling deltas 
> are used directly. In Firefox and GTK, they are not used directly, it seems. 
> Also, the scrolling on X11 using XInput2 with touchpad is also unusable for 
> me, same with GTK. Haven't exactly tested Wayland though, but for me, it is 
> 1.5xish compared to X11. 
> 
> I could manage the situation for Firefox as changing 
> `mousewheel.default.delta_multiplier_x` and 
> `mousewheel.default.delta_multiplier_x` from 100 to 30, and 
> `mousewheel.min_line_scroll_amount` from 5 to 180. With deltas, I could 
> manage touchpad scrolling speed usable, and with `min_line_scroll_amount` 
> one, mouse doesn't be affected by the delta reduction command. These are my 
> findings.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gtk+3.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1922047

Title:
  Touchpad scrolling is too fast

Status in Mozilla Firefox:
  New
Status in GTK+:
  Unknown
Status in Mutter:
  Unknown
Status in firefox package in Ubuntu:
  Confirmed
Status in gtk+3.0 package in Ubuntu:
  Confirmed
Status in gtk4 package in Ubuntu:
  Confirmed
Status in mutter package in Ubuntu:
  Confirmed

Bug description:
  This is an issue which has troubled me for a while. Anecdotally,
  scrolling feels way too fast in GNOME on Wayland compared to on X11. I
  finally tested it semi-scientifically, and it seems like GNOME on
  Wayland scrolls almost exactly 1.5x faster than GNOME on X11.

  I tested this by testing how many lines are scrolled from a full two-
  finger touchpad swipe from the bottom of my touchpad to the top of my
  touchpad, and logged a few attempts in both X and Wayland. I kept
  track of the results in this spreadsheet:
  
https://docs.google.com/spreadsheets/d/17EaBM5Pgt7GdnnzcN2Vchk4kfT7IZ6i4qZ0zpVRGLhc/edit?usp=sharing

  I scrolled in one of my own GTK applications
  (https://github.com/mortie/lograt) because it lets me easily see how
  many lines I scrolled. Attach is a video of one full scroll on X11 and
  one full scroll on Wayland.

  This testing was performed on a Dell XPS 13 9343, but I've also used
  Ubuntu on a Dell XPS 9575 where GNOME Wayland scrolling also feels way
  too fast. I don't have other hardware to test on.

  This has been an issue on both Ubuntu 20.10 and Ubuntu 21.04.

  ProblemType: Bug
  DistroRelease: Ubuntu 21.04
  Package: gnome-shell 3.38.4-1ubuntu1
  ProcVersionSignature: Ubuntu 5.11.0-13.14-generic 5.11.7
  Uname: Linux 5.11.0-13-generic x86_64
  ApportVersion: 2.20.11-0ubuntu61
  Architecture: amd64
  CasperMD5CheckResult: unknown
  CurrentDesktop: ubuntu:GNOME
  Date: Wed Mar 31 11:44:04 2021
  DisplayManager: gdm3
  InstallationDate: Installed on 2019-11-21 (495 days ago)
  InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
  RelatedPackageVersions: mutter-common 3.38.4-1ubuntu1
  SourcePackage: gnome-shell
  UpgradeStatus: Upgraded to hirsute on 2021-03-16 (14 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/firefox/+bug/1922047/+subscriptions


-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1942385] Re: [SOF - sof-bytcht rt5640, playback] fails after a while

2022-01-03 Thread Артём Шакиров
In my case, it might play media for some minutes (1-5 minutes).

I tried 5.10.89-051089-generic (last 5.10) linux and I didn't found this
bug.

Ubuntu 21.10, audio card name: sof-bytcht rt5645.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1942385

Title:
  [SOF - sof-bytcht rt5640, playback] fails after a while

Status in alsa-driver package in Ubuntu:
  Confirmed

Bug description:
  I am experiencing beep sound and audio from zoom, firefox, or vlc. It might 
play media for some seconds then beep. This has something to do with pipewire 
and sof driver and S16_LE format.( I read online).
  If I switch the profile Play HiFi quality Music in pavucontrol it does 
correct the beep sound for some few seconds then it

  ProblemType: Bug
  DistroRelease: Ubuntu 21.10
  Package: alsa-base 1.0.25+dfsg-0ubuntu7
  ProcVersionSignature: Ubuntu 5.13.0-14.14-generic 5.13.1
  Uname: Linux 5.13.0-14-generic x86_64
  ApportVersion: 2.20.11-0ubuntu68
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  bret   1249 F pulseaudio
   /dev/snd/pcmC0D0c:   bret   1249 F...m pulseaudio
   /dev/snd/pcmC0D0p:   bret   1249 F...m pulseaudio
   /dev/snd/timer:  bret   1249 f pulseaudio
  CasperMD5CheckResult: pass
  CurrentDesktop: XFCE
  Date: Thu Sep  2 05:25:01 2021
  InstallationDate: Installed on 2021-08-29 (3 days ago)
  InstallationMedia: Xubuntu 21.10 "Impish Indri" - Alpha amd64 (20210612)
  PackageArchitecture: all
  SourcePackage: alsa-driver
  Symptom: audio
  Symptom_Card: Built-in Audio - sof-bytcht rt5640
  Symptom_PulseAudioLog:
   Sep 02 05:24:14 toshiba systemd[826]: pulseaudio.service: Deactivated 
successfully.
   Sep 02 05:24:25 toshiba systemd[826]: pulseaudio.socket: Deactivated 
successfully.
  Symptom_Type: Sound works for a while, then breaks
  Title: [SOF - sof-bytcht rt5640, playback] fails after a while
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 11/02/2015
  dmi.bios.release: 5.20
  dmi.bios.vendor: INSYDE Corp.
  dmi.bios.version: 5.20
  dmi.board.name: 0700
  dmi.board.vendor: FF50
  dmi.board.version: Type2 - Board Version
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: OEM Chassis ManuFacturer
  dmi.chassis.version: OEM Chassis Version
  dmi.ec.firmware.release: 5.20
  dmi.modalias: 
dmi:bvnINSYDECorp.:bvr5.20:bd11/02/2015:br5.20:efr5.20:svnTOSHIBA:pnSATELLITEClickMiniL9W-B:pvrPDW0FE-002005EN:skuINVALID:rvnFF50:rn0700:rvrType2-BoardVersion:cvnOEMChassisManuFacturer:ct10:cvrOEMChassisVersion:
  dmi.product.family: INVALID
  dmi.product.name: SATELLITE Click Mini L9W-B
  dmi.product.sku: INVALID
  dmi.product.version: PDW0FE-002005EN
  dmi.sys.vendor: TOSHIBA

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1942385/+subscriptions


-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp