[Touch-packages] [Bug 1918044] Re: (Update libgweather to 3.36.2) Weather forecast and info is not available anymore

2021-05-24 Thread Amr Ibrahim
** Description changed:

+ [Impact]
+ 
  The weather forecast is not available since one week now. Also, the
  weather info is gone from gnome-shell.
  
  The weather service provider retired their old API.
  
https://developer.yr.no/news/important-changes-to-locationforecast-and-nowcast/
- https://developer.yr.no/doc/guides/getting-started-from-forecast-xml/
+ 
+ https://gitlab.gnome.org/GNOME/libgweather/-/blob/gnome-3-36/NEWS
+ 
+ ==
+ Version 3.36.2
+ ==
+ 
+ This version switches the yr.no backend to use met.no instead. Please note
+ that this backport is only meant as a compatibility layer. Where at all
+ possible, the newer libgweather 40 should be used as applications cannot
+ fully comply with the met.no ToS otherwise.
+ 
+ 
+ [Test case]
+ 
+ - gnome-weather shows the weather forecast
+ - gnome-shell shows the weather forecast in the calendar menu
+ 
+ 
+ [Regression potential]
+ 
+ - Weather forecast is totally broken now and can't be more broken.
+ 
  
  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: libgweather-3-16 3.36.1-1~ubuntu20.04.1
  ProcVersionSignature: Ubuntu 5.8.0-44.50~20.04.1-generic 5.8.18
  Uname: Linux 5.8.0-44-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.16
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Sun Mar  7 09:54:52 2021
  InstallationDate: Installed on 2020-04-26 (314 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=de_DE.UTF-8
   SHELL=/bin/bash
  SourcePackage: libgweather
  UpgradeStatus: No upgrade log present (probably fresh install)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libgweather in Ubuntu.
https://bugs.launchpad.net/bugs/1918044

Title:
  (Update libgweather to 3.36.2) Weather forecast and info is not
  available anymore

Status in libgweather:
  Unknown
Status in gnome-weather package in Ubuntu:
  Confirmed
Status in libgweather package in Ubuntu:
  Confirmed
Status in gnome-weather package in Fedora:
  New

Bug description:
  [Impact]

  The weather forecast is not available since one week now. Also, the
  weather info is gone from gnome-shell.

  The weather service provider retired their old API.
  
https://developer.yr.no/news/important-changes-to-locationforecast-and-nowcast/

  https://gitlab.gnome.org/GNOME/libgweather/-/blob/gnome-3-36/NEWS

  ==
  Version 3.36.2
  ==

  This version switches the yr.no backend to use met.no instead. Please note
  that this backport is only meant as a compatibility layer. Where at all
  possible, the newer libgweather 40 should be used as applications cannot
  fully comply with the met.no ToS otherwise.

  
  [Test case]

  - gnome-weather shows the weather forecast
  - gnome-shell shows the weather forecast in the calendar menu

  
  [Regression potential]

  - Weather forecast is totally broken now and can't be more broken.

  
  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: libgweather-3-16 3.36.1-1~ubuntu20.04.1
  ProcVersionSignature: Ubuntu 5.8.0-44.50~20.04.1-generic 5.8.18
  Uname: Linux 5.8.0-44-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.16
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Sun Mar  7 09:54:52 2021
  InstallationDate: Installed on 2020-04-26 (314 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=de_DE.UTF-8
   SHELL=/bin/bash
  SourcePackage: libgweather
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/libgweather/+bug/1918044/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1918044] Re: (Update libgweather to 3.36.2) Weather forecast and info is not available anymore

2021-05-24 Thread Amr Ibrahim
** Summary changed:

- Weather forecast and info is not available any more
+ (Update libgweather to 3.36.2) Weather forecast and info is not available 
anymore

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libgweather in Ubuntu.
https://bugs.launchpad.net/bugs/1918044

Title:
  (Update libgweather to 3.36.2) Weather forecast and info is not
  available anymore

Status in libgweather:
  Unknown
Status in gnome-weather package in Ubuntu:
  Confirmed
Status in libgweather package in Ubuntu:
  Confirmed
Status in gnome-weather package in Fedora:
  New

Bug description:
  The weather forecast is not available since one week now. Also, the
  weather info is gone from gnome-shell.

  The weather service provider retired their old API.
  
https://developer.yr.no/news/important-changes-to-locationforecast-and-nowcast/
  https://developer.yr.no/doc/guides/getting-started-from-forecast-xml/

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: libgweather-3-16 3.36.1-1~ubuntu20.04.1
  ProcVersionSignature: Ubuntu 5.8.0-44.50~20.04.1-generic 5.8.18
  Uname: Linux 5.8.0-44-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.16
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Sun Mar  7 09:54:52 2021
  InstallationDate: Installed on 2020-04-26 (314 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=de_DE.UTF-8
   SHELL=/bin/bash
  SourcePackage: libgweather
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/libgweather/+bug/1918044/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1878617] Re: Apple pages file type should be added to MIME types

2021-04-05 Thread Amr Ibrahim
** Also affects: shared-mime-info via
   https://gitlab.freedesktop.org/xdg/shared-mime-info/-/issues/136
   Importance: Unknown
   Status: Unknown

** Also affects: shared-mime-info (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mime-support in Ubuntu.
https://bugs.launchpad.net/bugs/1878617

Title:
  Apple pages file type should be added to MIME types

Status in shared-mime-info:
  Unknown
Status in mime-support package in Ubuntu:
  New
Status in shared-mime-info package in Ubuntu:
  New

Bug description:
  LibreOffice can open .pages files (from Apple pages). However, the
  mime type for these files is incorrectly just application/zip:

  $ file --mime-type example.pages
  example.pages: application/zip

  Instead, it should be application/vnd.apple.pages .

  This would allow the user to associate LibreOffice Writer with these
  types of files, and use it to open this file. (LibreOffice Writer can
  open .pages files)

  Apple Keynote files should have this MIME type:
  application/vnd.apple.keynote

  Apple Numbers files should have this MIME type:
  application/vnd.apple.numbers

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: mime-support 3.64ubuntu1
  ProcVersionSignature: Ubuntu 5.4.0-29.33-generic 5.4.30
  Uname: Linux 5.4.0-29-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  ApportVersion: 2.20.11-0ubuntu27
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Thu May 14 14:46:40 2020
  InstallationDate: Installed on 2018-11-11 (550 days ago)
  InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 
(20180725)
  PackageArchitecture: all
  SourcePackage: mime-support
  UpgradeStatus: Upgraded to focal on 2020-04-18 (25 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/shared-mime-info/+bug/1878617/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1832019] Re: Error when going to 'Tools -> Preferences -> Keyboard shortcuts' in Spyder3 in Bionic

2021-03-27 Thread Amr Ibrahim
** Changed in: spyder (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to qtbase-opensource-src in
Ubuntu.
https://bugs.launchpad.net/bugs/1832019

Title:
  Error when going to 'Tools -> Preferences -> Keyboard shortcuts' in
  Spyder3 in Bionic

Status in spyderlib:
  Unknown
Status in pyqt5 package in Ubuntu:
  Invalid
Status in qtbase-opensource-src package in Ubuntu:
  Invalid
Status in qtstyleplugins-src package in Ubuntu:
  Invalid
Status in spyder package in Ubuntu:
  Fix Released

Bug description:
  In Ubuntu 18.04 LTS
  Steps:

  1. Install spyder3 and qt5-style-plugins (sudo apt install spyder3 
qt5-style-plugins)
  2. Run spyder3
  3. Go to Tools → Preferences → General → Appearance
  4. Change the Qt window style to cleanlooks, gtk2 or plastique
  5. Go to Tools → Preferences → Keyboard shortcuts
  6. Error (or crash in case of gtk2)

  Keyboard shortcuts are not accessible.

  Here is the error:

    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most 

[Touch-packages] [Bug 1841783] Re: Update to 1.2.0?

2021-03-24 Thread Amr Ibrahim
Upstream Speex moved to GitLab (links updated in the description). The
Debian maintainer probably abandoned this package. I suggest that the
package moves under the maintainership of the Debian Multimedia Team.

** Tags added: hirsute

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to speex in Ubuntu.
https://bugs.launchpad.net/bugs/1841783

Title:
  Update to 1.2.0?

Status in speex package in Ubuntu:
  Triaged
Status in speex package in Debian:
  New

Bug description:
  The source was split in rc2, Debian didn't follow the change, and we
  are in sync, do we want to update?

  Speex and SpeexDSP

  https://gitlab.xiph.org/xiph/speex

  https://gitlab.xiph.org/xiph/speexdsp

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/speex/+bug/1841783/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1841783] Re: Update to 1.2.0?

2021-03-24 Thread Amr Ibrahim
** Description changed:

  The source was split in rc2, Debian didn't follow the change, and we are
  in sync, do we want to update?
  
  Speex and SpeexDSP
  
- https://git.xiph.org/?p=speex.git;a=summary
+ https://gitlab.xiph.org/xiph/speex
  
- https://git.xiph.org/?p=speexdsp.git;a=summary
+ https://gitlab.xiph.org/xiph/speexdsp

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to speex in Ubuntu.
https://bugs.launchpad.net/bugs/1841783

Title:
  Update to 1.2.0?

Status in speex package in Ubuntu:
  Triaged
Status in speex package in Debian:
  New

Bug description:
  The source was split in rc2, Debian didn't follow the change, and we
  are in sync, do we want to update?

  Speex and SpeexDSP

  https://gitlab.xiph.org/xiph/speex

  https://gitlab.xiph.org/xiph/speexdsp

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/speex/+bug/1841783/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1918044] Re: Weather forecast and info is not available any more

2021-03-14 Thread Amr Ibrahim
** No longer affects: gnome-weather

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libgweather in Ubuntu.
https://bugs.launchpad.net/bugs/1918044

Title:
  Weather forecast and info is not available any more

Status in libgweather:
  Unknown
Status in gnome-weather package in Ubuntu:
  Confirmed
Status in libgweather package in Ubuntu:
  Confirmed
Status in gnome-weather package in Fedora:
  New

Bug description:
  The weather forecast is not available since one week now. Also, the
  weather info is gone from gnome-shell.

  The weather service provider retired their old API.
  
https://developer.yr.no/news/important-changes-to-locationforecast-and-nowcast/
  https://developer.yr.no/doc/guides/getting-started-from-forecast-xml/

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: libgweather-3-16 3.36.1-1~ubuntu20.04.1
  ProcVersionSignature: Ubuntu 5.8.0-44.50~20.04.1-generic 5.8.18
  Uname: Linux 5.8.0-44-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.16
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Sun Mar  7 09:54:52 2021
  InstallationDate: Installed on 2020-04-26 (314 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=de_DE.UTF-8
   SHELL=/bin/bash
  SourcePackage: libgweather
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/libgweather/+bug/1918044/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1918044] Re: Weather forecast and info is not available any more

2021-03-07 Thread Amr Ibrahim
** Description changed:

  The weather forecast is not available since one week now. Also, the
  weather info is gone from gnome-shell.
+ 
+ The weather service provider retired their old API.
+ 
https://developer.yr.no/news/important-changes-to-locationforecast-and-nowcast/
+ https://developer.yr.no/doc/guides/getting-started-from-forecast-xml/
  
  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: libgweather-3-16 3.36.1-1~ubuntu20.04.1
  ProcVersionSignature: Ubuntu 5.8.0-44.50~20.04.1-generic 5.8.18
  Uname: Linux 5.8.0-44-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.16
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Sun Mar  7 09:54:52 2021
  InstallationDate: Installed on 2020-04-26 (314 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  ProcEnviron:
-  TERM=xterm-256color
-  PATH=(custom, no user)
-  XDG_RUNTIME_DIR=
-  LANG=de_DE.UTF-8
-  SHELL=/bin/bash
+  TERM=xterm-256color
+  PATH=(custom, no user)
+  XDG_RUNTIME_DIR=
+  LANG=de_DE.UTF-8
+  SHELL=/bin/bash
  SourcePackage: libgweather
  UpgradeStatus: No upgrade log present (probably fresh install)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libgweather in Ubuntu.
https://bugs.launchpad.net/bugs/1918044

Title:
  Weather forecast and info is not available any more

Status in GNOME Weather:
  Unknown
Status in libgweather:
  Unknown
Status in gnome-weather package in Ubuntu:
  New
Status in libgweather package in Ubuntu:
  New

Bug description:
  The weather forecast is not available since one week now. Also, the
  weather info is gone from gnome-shell.

  The weather service provider retired their old API.
  
https://developer.yr.no/news/important-changes-to-locationforecast-and-nowcast/
  https://developer.yr.no/doc/guides/getting-started-from-forecast-xml/

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: libgweather-3-16 3.36.1-1~ubuntu20.04.1
  ProcVersionSignature: Ubuntu 5.8.0-44.50~20.04.1-generic 5.8.18
  Uname: Linux 5.8.0-44-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.16
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Sun Mar  7 09:54:52 2021
  InstallationDate: Installed on 2020-04-26 (314 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=de_DE.UTF-8
   SHELL=/bin/bash
  SourcePackage: libgweather
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/gnome-weather/+bug/1918044/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1918044] [NEW] Weather forecast and info is not available any more

2021-03-07 Thread Amr Ibrahim
Public bug reported:

The weather forecast is not available since one week now. Also, the
weather info is gone from gnome-shell.

The weather service provider retired their old API.
https://developer.yr.no/news/important-changes-to-locationforecast-and-nowcast/
https://developer.yr.no/doc/guides/getting-started-from-forecast-xml/

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: libgweather-3-16 3.36.1-1~ubuntu20.04.1
ProcVersionSignature: Ubuntu 5.8.0-44.50~20.04.1-generic 5.8.18
Uname: Linux 5.8.0-44-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.16
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Sun Mar  7 09:54:52 2021
InstallationDate: Installed on 2020-04-26 (314 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: libgweather
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: gnome-weather
 Importance: Unknown
 Status: Unknown

** Affects: libgweather
 Importance: Unknown
 Status: Unknown

** Affects: gnome-weather (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: libgweather (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug focal wayland-session

** Bug watch added: gitlab.gnome.org/GNOME/libgweather/-/issues #82
   https://gitlab.gnome.org/GNOME/libgweather/-/issues/82

** Also affects: libgweather via
   https://gitlab.gnome.org/GNOME/libgweather/-/issues/82
   Importance: Unknown
   Status: Unknown

** Also affects: gnome-weather (Ubuntu)
   Importance: Undecided
   Status: New

** Bug watch added: gitlab.gnome.org/GNOME/gnome-weather/-/issues #148
   https://gitlab.gnome.org/GNOME/gnome-weather/-/issues/148

** Also affects: gnome-weather via
   https://gitlab.gnome.org/GNOME/gnome-weather/-/issues/148
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libgweather in Ubuntu.
https://bugs.launchpad.net/bugs/1918044

Title:
  Weather forecast and info is not available any more

Status in GNOME Weather:
  Unknown
Status in libgweather:
  Unknown
Status in gnome-weather package in Ubuntu:
  New
Status in libgweather package in Ubuntu:
  New

Bug description:
  The weather forecast is not available since one week now. Also, the
  weather info is gone from gnome-shell.

  The weather service provider retired their old API.
  
https://developer.yr.no/news/important-changes-to-locationforecast-and-nowcast/
  https://developer.yr.no/doc/guides/getting-started-from-forecast-xml/

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: libgweather-3-16 3.36.1-1~ubuntu20.04.1
  ProcVersionSignature: Ubuntu 5.8.0-44.50~20.04.1-generic 5.8.18
  Uname: Linux 5.8.0-44-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.16
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Sun Mar  7 09:54:52 2021
  InstallationDate: Installed on 2020-04-26 (314 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=de_DE.UTF-8
   SHELL=/bin/bash
  SourcePackage: libgweather
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/gnome-weather/+bug/1918044/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1916570] Re: BlueZ 5.56 release

2021-02-23 Thread Amr Ibrahim
Just a comment on the packaging: the Ubuntu packaging is a bit old: it
still build-depends on debhelper (>= 9), autotools-dev and libdbus-
glib-1-dev (which is deprecated and the Debian package replaced it with
libdbus-1-dev (>= 1.6)), and it is at Standards-Version: 3.9.6, which is
ancient by now.

I suggest merging with Debian first then updating to 5.56 to benefit
from the up-to-date best practices in Debian packaging.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to bluez in Ubuntu.
https://bugs.launchpad.net/bugs/1916570

Title:
  BlueZ 5.56 release

Status in bluez package in Ubuntu:
  In Progress

Bug description:
  BlueZ 5.56 is now available:

  https://mirrors.edge.kernel.org/pub/linux/bluetooth/

  ver 5.56:
  Fix issue with setting AVDTP disconnect timer.
  Fix issue with AVDTP not sending GetCapabilities.
  Fix issue with AVDTP connecting using streaming mode.
  Fix issue with handling A2DP and remote SEP disappearing.
  Fix issue with handling session of A2DP channels.
  Fix issue with GATT and handling device removal.
  Fix issue with GATT not accepting multiple requests.
  Fix issue with HID report value callback registration.
  Add support for new advertising management command.
  Add support for battery D-Bus interface.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1916570/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1831039] Re: When using Wayland, the onscreen keyboard does not open in text inputs for non-GTK applications such as Firefox or Chrome

2021-02-02 Thread Amr Ibrahim
Firefox uses GTK, but in a Wayland session it runs on XWayland, the same
for Qt apps and Chrome, they run on XWayland in a Wayland session.
That's a common factor.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to qtbase-opensource-src in
Ubuntu.
https://bugs.launchpad.net/bugs/1831039

Title:
  When using Wayland, the onscreen keyboard does not open in text inputs
  for non-GTK applications such as Firefox or Chrome

Status in chromium-browser package in Ubuntu:
  Confirmed
Status in firefox package in Ubuntu:
  Confirmed
Status in gnome-shell package in Ubuntu:
  Confirmed
Status in qtbase-opensource-src package in Ubuntu:
  Confirmed

Bug description:
  When using wayland - onscreen keyboard not open in text inputs in many
  applications such as firefox or chrome.

  Ubuntu 18.04
  --- 
  ProblemType: Bug
  ApportVersion: 2.20.9-0ubuntu7.6
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  DisplayManager: gdm3
  DistroRelease: Ubuntu 18.04
  InstallationDate: Installed on 2015-06-09 (1455 days ago)
  InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 
(20150218.1)
  Package: gnome-shell 3.28.3+git20190124-0ubuntu18.04.2
  PackageArchitecture: amd64
  ProcEnviron:
   LANG=cs_CZ.UTF-8
   TERM=xterm-256color
   SHELL=/bin/bash
   XDG_RUNTIME_DIR=
   PATH=(custom, no user)
  ProcVersionSignature: Ubuntu 4.15.0-50.54-generic 4.15.18
  Tags: third-party-packages bionic
  Uname: Linux 4.15.0-50-generic x86_64
  UpgradeStatus: Upgraded to bionic on 2018-05-31 (368 days ago)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1831039/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1891761] Re: Add a way to change the application_id of a toplevel wayland GdkSurface (so LibreOffice can reuse toplevels and get the right task icons in Wayland)

2020-12-20 Thread Amr Ibrahim
I've tested and this is now fixed in Groovy.

Could this be SRUed to Focal?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gtk+3.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1891761

Title:
  Add a way to change the application_id of a toplevel wayland
  GdkSurface (so LibreOffice can reuse toplevels and get the right task
  icons in Wayland)

Status in gtk+3.0 package in Ubuntu:
  New

Bug description:
  This is already committed upstream in GTK 3.24.22:
  
https://gitlab.gnome.org/GNOME/gtk/-/commit/2b74662b2befebb988b63118c8d7ee8c9d90e736

  LibreOffice in a Wayland session uses the same generic icon for its
  different apps, so when I have Writer, Calc and Impress open, they all
  share the same generic LO icon, which is not a very good experience.
  The upstream GTK commit should fix that, however, I have not tested
  it.

  The reason why I'm using Wayland in Ubuntu 20.04 is that I have a
  second 4K UHD monitor and fractional scaling + 4K UHD resolution is
  unusable in X11, so I'm kind of forced to use Wayland for fractional
  scaling. See bug #1890802.

  So I hope this fix could be committed in Ubuntu 20.04 to improve the
  LibreOffice experience in Wayland.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: libgtk-3-0 3.24.20-0ubuntu1
  ProcVersionSignature: Ubuntu 5.4.0-42.46-generic 5.4.44
  Uname: Linux 5.4.0-42-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.6
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Sat Aug 15 17:14:07 2020
  InstallationDate: Installed on 2020-04-26 (111 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=de_DE.UTF-8
   SHELL=/bin/bash
  SourcePackage: gtk+3.0
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1891761/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1799974] Re: [MIR] gupnp

2020-12-13 Thread Amr Ibrahim
** Changed in: gupnp (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gupnp in Ubuntu.
https://bugs.launchpad.net/bugs/1799974

Title:
  [MIR] gupnp

Status in gupnp package in Ubuntu:
  Fix Released

Bug description:
  * Availability

  Builds on all supported architectures in Ubuntu and on sync from
  Debian, the package was in main in the past and needs to be re-
  promoted

  * Rationale

  We would like to enable dlna sharing of media files, which is a GNOME
  upstream feature and relying on rygel which depends on the gupnp
  libraries

  * Security

  There is an old CVE recorded/fixed
  https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2174

  * Quality assurance

  - the desktop-packages team is subscribed to the package
  - the bug lists in upstream, the Debian PTS and launchpad are empty
  - upstream has a testsuit which is used during build

  * Dependendies

  The package uses standard desktop libraries that are already in main

  * Standards compliance

  the package is using standard packaging (dh10), the standards-version
  is 4.2, the package is in sync from Debian

  * Maintainance

  Upstream is active and the desktop team is going to look after the
  package in ubuntu

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gupnp/+bug/1799974/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1870508] Re: ubiquity crashed with SIGSEGV in g_type_check_instance_is_a()

2020-12-07 Thread Amr Ibrahim
** Also affects: atk via
   https://gitlab.gnome.org/GNOME/atk/-/issues/18
   Importance: Unknown
   Status: Unknown

** Also affects: gtk+3.0 (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to atk1.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1870508

Title:
  ubiquity crashed with SIGSEGV in g_type_check_instance_is_a()

Status in ATK:
  Unknown
Status in atk1.0 package in Ubuntu:
  Fix Released
Status in gtk+3.0 package in Ubuntu:
  New

Bug description:
  == Test Case ==
  1. Boot to ubiquity-dm
  2. Enable the screenreader (Alt+Super+S)
  3. Select "Install Ubuntu"
  4. Proceed with all the steps of the installer

  = Actual Result = 
  During installation, when the slideshow is running, this crash occurs.

  
  ProblemType: Crash
  DistroRelease: Ubuntu 20.04
  Package: ubiquity 20.04.9
  ProcVersionSignature: Ubuntu 5.4.0-21.25-generic 5.4.27
  Uname: Linux 5.4.0-21-generic x86_64
  NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
  ApportVersion: 2.20.11-0ubuntu22
  Architecture: amd64
  CasperVersion: 1.442
  CurrentDesktop: ubuntu:GNOME
  Date: Fri Apr  3 10:55:58 2020
  ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
  ExecutableTimestamp: 1585729537
  InstallCmdLine: file=/cdrom/preseed/ubuntu.seed initrd=/casper/initrd quiet 
splash --- maybe-ubiquity
  InterpreterPath: /usr/bin/python3.8
  LiveMediaBuild: Ubuntu 20.04 LTS "Focal Fossa" - Beta amd64 (20200402)
  ProcCmdline: /usr/bin/python3 /usr/lib/ubiquity/bin/ubiquity --greeter --only
  ProcCwd: /
  ProcEnviron:
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=C.UTF-8
  Python3Details: /usr/bin/python3.8, Python 3.8.2, python3-minimal, 
3.8.2-0ubuntu1
  PythonDetails: N/A
  SegvAnalysis:
   Segfault happened at: 0x7fbd15f8f16a :   
mov%rax,-0x20(%rsp)
   PC (0x7fbd15f8f16a) ok
   source "%rax" ok
   destination "-0x20(%rsp)" (0x7ffe329d3ff0) not located in a known VMA region 
(needed writable region)!
  SegvReason: writing unknown VMA
  Signal: 11
  SourcePackage: ubiquity
  StacktraceTop:
   g_type_check_instance_is_a () from /lib/x86_64-linux-gnu/libgobject-2.0.so.0
   atk_component_get_extents () from /lib/x86_64-linux-gnu/libatk-1.0.so.0
   ?? () from /lib/x86_64-linux-gnu/libgtk-3.so.0
   atk_component_get_extents () from /lib/x86_64-linux-gnu/libatk-1.0.so.0
   atk_component_get_extents () from /lib/x86_64-linux-gnu/libatk-1.0.so.0
  Title: ubiquity crashed with SIGSEGV in g_type_check_instance_is_a()
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups:

  separator:

To manage notifications about this bug go to:
https://bugs.launchpad.net/atk/+bug/1870508/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1906688] [NEW] [SRU] Update evolution, evolution-data-server & evolution-ews to 3.36.5 in Focal

2020-12-03 Thread Amr Ibrahim
Public bug reported:

* Impact

That's the current GNOME 3.36 stable updates, including some fixes and
translation updates

https://gitlab.gnome.org/GNOME/evolution/-/blob/gnome-3-36/NEWS

Evolution 3.36.5 2020-08-07
---

Bug Fixes:
- "Time" portion of calendar entries not scaling with font (Stefan Paul Noack)
- ECompEditor: Error when save-only (all instances) of a recurring event (Milan 
Crha)
- Calendar: SEQUENCE not changed when modifying All Instances (Milan Crha)
- Calendar: Event non-libical time zone reset to UTC on edit (Milan Crha)

Miscellaneous:
- EContactEditor: Other mailing address has stored incorrect address label 
(Milan Crha)
- help: Mailing List filter criterion checks numerous mail headers (Andre 
Klapper)

Translations:
Jordi Mas (ca)
Jwtiyar Nariman (ckb)
Yuri Chornoivan (uk)

https://gitlab.gnome.org/GNOME/evolution-data-
server/-/blob/gnome-3-36/NEWS

Evolution-Data-Server 3.36.5 2020-08-07
---

Bug Fixes:
- Uses LC_ADDRESS unconditionally in libphonenumber code (Milan Crha)
- IMAPx: Disable move to real junk/trash in server-side virtual folders (Milan 
Crha)

Miscellaneous:
- Fix a memory leak in ebmb_gather_photos_local_filenames() (Milan Crha)
- ESoupSession: Provided SoupAuth might not be always used by libsoup (Milan 
Crha)


https://gitlab.gnome.org/GNOME/evolution-ews/-/blob/gnome-3-36/NEWS

Evolution-EWS 3.36.5 2020-08-07
---
Miscellaneous:
- Provided SoupAuth might not be always used by libsoup (Milan Crha)


* Test case

The update is part of GNOME stable updates
https://wiki.ubuntu.com/StableReleaseUpdates/GNOME

- Check that evolution works correctly with different emails server and with 
online calendars.
- Check that calendar events show in gnome-shell's calendar menu.
- Check that calendar events show in gnome-calendar (when installed).


* Regression potential

There is no specific change or feature to test in that update.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: evolution 3.36.4-0ubuntu1
ProcVersionSignature: Ubuntu 5.4.0-54.60-generic 5.4.65
Uname: Linux 5.4.0-54-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.13
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Thu Dec  3 17:08:35 2020
InstallationDate: Installed on 2020-04-26 (221 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: evolution
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: evolution (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: evolution-data-server (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: evolution-ews (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug focal wayland-session

** Also affects: evolution-data-server (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: evolution-ews (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to evolution-data-server in
Ubuntu.
https://bugs.launchpad.net/bugs/1906688

Title:
  [SRU] Update evolution, evolution-data-server & evolution-ews to
  3.36.5 in Focal

Status in evolution package in Ubuntu:
  New
Status in evolution-data-server package in Ubuntu:
  New
Status in evolution-ews package in Ubuntu:
  New

Bug description:
  * Impact

  That's the current GNOME 3.36 stable updates, including some fixes and
  translation updates

  https://gitlab.gnome.org/GNOME/evolution/-/blob/gnome-3-36/NEWS

  Evolution 3.36.5 2020-08-07
  ---

  Bug Fixes:
  - "Time" portion of calendar entries not scaling with font (Stefan Paul Noack)
  - ECompEditor: Error when save-only (all instances) of a recurring event 
(Milan Crha)
  - Calendar: SEQUENCE not changed when modifying All Instances (Milan Crha)
  - Calendar: Event non-libical time zone reset to UTC on edit (Milan Crha)

  Miscellaneous:
  - EContactEditor: Other mailing address has stored incorrect address label 
(Milan Crha)
  - help: Mailing List filter criterion checks numerous mail headers (Andre 
Klapper)

  Translations:
  Jordi Mas (ca)
  Jwtiyar Nariman (ckb)
  Yuri Chornoivan (uk)

  https://gitlab.gnome.org/GNOME/evolution-data-
  server/-/blob/gnome-3-36/NEWS

  Evolution-Data-Server 3.36.5 2020-08-07
  ---

  Bug Fixes:
  - Uses LC_ADDRESS unconditionally in libphonenumber code (Milan Crha)
  - IMAPx: Disable move to real junk/trash in server-side virtual folders 
(Milan Crha)

  Miscellaneous:
  - Fix a memory leak in ebmb_gather_photos_local_filenames() (Milan Crha)
  - ESoupSession: Provided SoupAuth might not be always used by libsoup (Milan 
Crha)

  
  

[Touch-packages] [Bug 1892643] Re: [SRU] Update libgweather to 3.36.1

2020-10-24 Thread Amr Ibrahim
I have libgweather 3.36.1-1~ubuntu20.04.1 installed for quite some time
now, the weather appears in gnome-shell without any problems, gnome-
weather shows the weather for four cities, three in Europe and one in
Africa, also without any problems.

** Tags removed: verification-needed verification-needed-focal
** Tags added: verification-done-focal

** Patch removed: "libgweather_3.36.0-1_3.36.1-1~ubuntu20.04.1.diff"
   
https://bugs.launchpad.net/ubuntu/focal/+source/libgweather/+bug/1892643/+attachment/5417986/+files/libgweather_3.36.0-1_3.36.1-1~ubuntu20.04.1.diff

** Attachment removed: "libgweather_3.36.0-1_3.36.1-1~ubuntu20.04.1.diff.gz"
   
https://bugs.launchpad.net/ubuntu/focal/+source/libgweather/+bug/1892643/+attachment/5417988/+files/libgweather_3.36.0-1_3.36.1-1~ubuntu20.04.1.diff.gz

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libgweather in Ubuntu.
https://bugs.launchpad.net/bugs/1892643

Title:
  [SRU] Update libgweather to 3.36.1

Status in libgweather:
  Unknown
Status in libgweather package in Ubuntu:
  Fix Released
Status in libgweather source package in Focal:
  Fix Committed
Status in libgweather package in Debian:
  Unknown

Bug description:
  [Impact]

  libgweather 3.36.1 is a bug-fix release as part of GNOME 3.36.

  https://gitlab.gnome.org/GNOME/libgweather/-/blob/gnome-3-36/NEWS

  This version works around the unavailability of the NOAA weather
  services by using very short-term forecasts as current weather
  conditions.

  Sometimes the current weather is not available because the NOAA
  weather servers aren't working correctly. Version 3.36.1 fixes the
  unavailability of current temperature in some locations.

  
  [Test case]

  Make sure that gnome-weather is still working properly and the weather
  in gnome-shell is shown when gnome-weather is installed.

  
  [Regression potential]

  The regression potential is low since the changes in version 3.36.1
  are small.

  
  [Other]

  libgweather 3.36.1 has been successfully built as a no-change backport
  from Groovy to Focal in my PPA and runs fine:

  
https://launchpad.net/~amribrahim1987/+archive/ubuntu/ppa/+packages?field.name_filter=libgweather_filter=published_filter=

  
  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: libgweather-3-16 3.36.0-1
  ProcVersionSignature: Ubuntu 5.4.0-42.46-generic 5.4.44
  Uname: Linux 5.4.0-42-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.8
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Sun Aug 23 19:05:21 2020
  InstallationDate: Installed on 2020-04-26 (119 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  SourcePackage: libgweather
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/libgweather/+bug/1892643/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1899889] Re: In "show applications" the applications are not sorted alphabetically and does not update when installing new application. New applications are just added at the end

2020-10-15 Thread Amr Ibrahim
** Package changed: dash (Ubuntu) => gnome-shell (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to dash in Ubuntu.
https://bugs.launchpad.net/bugs/1899889

Title:
  In "show applications" the applications are not sorted alphabetically
  and does not update when installing new application. New applications
  are just added at the end of the last page.

Status in gnome-shell package in Ubuntu:
  New

Bug description:
  Upon installing a new application the list in "show applications" is
  not updated and just added at the end (last page). The list is also
  not sorted. When first installing Ubuntu 20.10, I could get the list
  updated by logging in and out, but after installing about 10
  applications that stopped working.

  The Dash is version 0.5.10.2-7

  ProblemType: Bug
  DistroRelease: Ubuntu 20.10
  Package: dash 0.5.10.2-7
  ProcVersionSignature: Ubuntu 5.8.0-22.23-generic 5.8.14
  Uname: Linux 5.8.0-22-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  ApportVersion: 2.20.11-0ubuntu50
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Oct 15 09:29:12 2020
  InstallationDate: Installed on 2020-10-01 (13 days ago)
  InstallationMedia: Ubuntu 20.10 "Groovy Gorilla" - Alpha amd64 (20200923)
  RebootRequiredPkgs:
   linux-image-5.8.0-23-generic
   linux-base
  SourcePackage: dash
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1899889/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1892643] Re: [SRU] Update libgweather to 3.36.1

2020-10-11 Thread Amr Ibrahim
That .diff is actually auto-generated from the package in my PPA:
https://launchpad.net/~amribrahim1987/+archive/ubuntu/ppa/+packages?field.name_filter=libgweather_filter=published_filter=

The package is built fine for all architectures in Focal and installs
and runs OK. Maybe the .diff got corrupted from downloading and
uploading again!

Could you please try the package from the PPA?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libgweather in Ubuntu.
https://bugs.launchpad.net/bugs/1892643

Title:
  [SRU] Update libgweather to 3.36.1

Status in libgweather:
  Unknown
Status in libgweather package in Ubuntu:
  Fix Released
Status in libgweather source package in Focal:
  New
Status in libgweather package in Debian:
  Unknown

Bug description:
  [Impact]

  libgweather 3.36.1 is a bug-fix release as part of GNOME 3.36.

  https://gitlab.gnome.org/GNOME/libgweather/-/blob/gnome-3-36/NEWS

  This version works around the unavailability of the NOAA weather
  services by using very short-term forecasts as current weather
  conditions.

  Sometimes the current weather is not available because the NOAA
  weather servers aren't working correctly. Version 3.36.1 fixes the
  unavailability of current temperature in some locations.

  
  [Test case]

  Make sure that gnome-weather is still working properly and the weather
  in gnome-shell is shown when gnome-weather is installed.

  
  [Regression potential]

  The regression potential is low since the changes in version 3.36.1
  are small.

  
  [Other]

  libgweather 3.36.1 has been successfully built as a no-change backport
  from Groovy to Focal in my PPA and runs fine:

  
https://launchpad.net/~amribrahim1987/+archive/ubuntu/ppa/+packages?field.name_filter=libgweather_filter=published_filter=

  
  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: libgweather-3-16 3.36.0-1
  ProcVersionSignature: Ubuntu 5.4.0-42.46-generic 5.4.44
  Uname: Linux 5.4.0-42-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.8
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Sun Aug 23 19:05:21 2020
  InstallationDate: Installed on 2020-04-26 (119 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  SourcePackage: libgweather
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/libgweather/+bug/1892643/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1892643] Re: [SRU] Update libgweather to 3.36.1

2020-10-05 Thread Amr Ibrahim
** Attachment added: "libgweather_3.36.0-1_3.36.1-1~ubuntu20.04.1.diff.gz"
   
https://bugs.launchpad.net/ubuntu/+source/libgweather/+bug/1892643/+attachment/5417988/+files/libgweather_3.36.0-1_3.36.1-1~ubuntu20.04.1.diff.gz

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libgweather in Ubuntu.
https://bugs.launchpad.net/bugs/1892643

Title:
  [SRU] Update libgweather to 3.36.1

Status in libgweather:
  Unknown
Status in libgweather package in Ubuntu:
  Fix Released
Status in libgweather source package in Focal:
  New
Status in libgweather package in Debian:
  Unknown

Bug description:
  [Impact]

  libgweather 3.36.1 is a bug-fix release as part of GNOME 3.36.

  https://gitlab.gnome.org/GNOME/libgweather/-/blob/gnome-3-36/NEWS

  This version works around the unavailability of the NOAA weather
  services by using very short-term forecasts as current weather
  conditions.

  Sometimes the current weather is not available because the NOAA
  weather servers aren't working correctly. Version 3.36.1 fixes the
  unavailability of current temperature in some locations.

  
  [Test case]

  Make sure that gnome-weather is still working properly and the weather
  in gnome-shell is shown when gnome-weather is installed.

  
  [Regression potential]

  The regression potential is low since the changes in version 3.36.1
  are small.

  
  [Other]

  libgweather 3.36.1 has been successfully built as a no-change backport
  from Groovy to Focal in my PPA and runs fine:

  
https://launchpad.net/~amribrahim1987/+archive/ubuntu/ppa/+packages?field.name_filter=libgweather_filter=published_filter=

  
  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: libgweather-3-16 3.36.0-1
  ProcVersionSignature: Ubuntu 5.4.0-42.46-generic 5.4.44
  Uname: Linux 5.4.0-42-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.8
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Sun Aug 23 19:05:21 2020
  InstallationDate: Installed on 2020-04-26 (119 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  SourcePackage: libgweather
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/libgweather/+bug/1892643/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1892643] Re: [SRU] Update libgweather to 3.36.1

2020-10-05 Thread Amr Ibrahim
Please either sponsor the attached diff or from my PPA mentioned above.

** Patch added: "libgweather_3.36.0-1_3.36.1-1~ubuntu20.04.1.diff"
   
https://bugs.launchpad.net/ubuntu/+source/libgweather/+bug/1892643/+attachment/5417986/+files/libgweather_3.36.0-1_3.36.1-1~ubuntu20.04.1.diff

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libgweather in Ubuntu.
https://bugs.launchpad.net/bugs/1892643

Title:
  [SRU] Update libgweather to 3.36.1

Status in libgweather:
  Unknown
Status in libgweather package in Ubuntu:
  Fix Released
Status in libgweather source package in Focal:
  New
Status in libgweather package in Debian:
  Unknown

Bug description:
  [Impact]

  libgweather 3.36.1 is a bug-fix release as part of GNOME 3.36.

  https://gitlab.gnome.org/GNOME/libgweather/-/blob/gnome-3-36/NEWS

  This version works around the unavailability of the NOAA weather
  services by using very short-term forecasts as current weather
  conditions.

  Sometimes the current weather is not available because the NOAA
  weather servers aren't working correctly. Version 3.36.1 fixes the
  unavailability of current temperature in some locations.

  
  [Test case]

  Make sure that gnome-weather is still working properly and the weather
  in gnome-shell is shown when gnome-weather is installed.

  
  [Regression potential]

  The regression potential is low since the changes in version 3.36.1
  are small.

  
  [Other]

  libgweather 3.36.1 has been successfully built as a no-change backport
  from Groovy to Focal in my PPA and runs fine:

  
https://launchpad.net/~amribrahim1987/+archive/ubuntu/ppa/+packages?field.name_filter=libgweather_filter=published_filter=

  
  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: libgweather-3-16 3.36.0-1
  ProcVersionSignature: Ubuntu 5.4.0-42.46-generic 5.4.44
  Uname: Linux 5.4.0-42-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.8
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Sun Aug 23 19:05:21 2020
  InstallationDate: Installed on 2020-04-26 (119 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  SourcePackage: libgweather
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/libgweather/+bug/1892643/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1896372] [NEW] systemd (sbin/init/ splash) consumes 12% CPU and doesn't stop

2020-09-20 Thread Amr Ibrahim
Public bug reported:

Right after login, the process systemd (sbin/init/ splash), which is run
by root, consumes 12% CPU and doesn't stop. The CPU fan is always on for
that reason. That doesn't happen in Focal on the same laptop, which has
both Focal and Groovy, and they both share the same /home partition.

ProblemType: Bug
DistroRelease: Ubuntu 20.10
Package: systemd 246.4-1ubuntu1
ProcVersionSignature: Ubuntu 5.8.0-18.19-generic 5.8.4
Uname: Linux 5.8.0-18-generic x86_64
ApportVersion: 2.20.11-0ubuntu45
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
CurrentDmesg: Error: command ['dmesg'] failed with exit code 1: dmesg: read 
kernel buffer failed: Operation not permitted
Date: Sun Sep 20 10:50:27 2020
InstallationDate: Installed on 2020-09-16 (3 days ago)
InstallationMedia: Ubuntu 20.10 "Groovy Gorilla" - Alpha amd64 (20200910)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 004: ID 5986:2113 Acer, Inc SunplusIT Integrated Camera
 Bus 001 Device 005: ID 8087:0a2b Intel Corp. Bluetooth wireless interface
 Bus 001 Device 002: ID 0461:4e57 Primax Electronics, Ltd HID compliant device
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: LENOVO 20LTS01800
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.8.0-18-generic 
root=UUID=301ac90f-9a29-425d-9b75-b6b2a43bf00a ro quiet splash
SourcePackage: systemd
SystemdFailedUnits:
 Error: command ['systemctl', 'status', '--full', '●'] failed with exit code 4: 
Invalid unit name "●" escaped as "\xe2\x97\x8f" (maybe you should use 
systemd-escape?).
 Unit \xe2\x97\x8f.service could not be found.
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/18/2019
dmi.bios.release: 1.37
dmi.bios.vendor: LENOVO
dmi.bios.version: R0QET60W (1.37 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20LTS01800
dmi.board.vendor: LENOVO
dmi.board.version: Not Defined
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.ec.firmware.release: 1.37
dmi.modalias: 
dmi:bvnLENOVO:bvrR0QET60W(1.37):bd12/18/2019:br1.37:efr1.37:svnLENOVO:pn20LTS01800:pvrThinkPadL480:rvnLENOVO:rn20LTS01800:rvrNotDefined:cvnLENOVO:ct10:cvrNone:
dmi.product.family: ThinkPad L480
dmi.product.name: 20LTS01800
dmi.product.sku: LENOVO_MT_20LT_BU_Think_FM_ThinkPad L480
dmi.product.version: ThinkPad L480
dmi.sys.vendor: LENOVO

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug groovy wayland-session

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1896372

Title:
  systemd (sbin/init/ splash) consumes 12% CPU and doesn't stop

Status in systemd package in Ubuntu:
  New

Bug description:
  Right after login, the process systemd (sbin/init/ splash), which is
  run by root, consumes 12% CPU and doesn't stop. The CPU fan is always
  on for that reason. That doesn't happen in Focal on the same laptop,
  which has both Focal and Groovy, and they both share the same /home
  partition.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.10
  Package: systemd 246.4-1ubuntu1
  ProcVersionSignature: Ubuntu 5.8.0-18.19-generic 5.8.4
  Uname: Linux 5.8.0-18-generic x86_64
  ApportVersion: 2.20.11-0ubuntu45
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  CurrentDmesg: Error: command ['dmesg'] failed with exit code 1: dmesg: read 
kernel buffer failed: Operation not permitted
  Date: Sun Sep 20 10:50:27 2020
  InstallationDate: Installed on 2020-09-16 (3 days ago)
  InstallationMedia: Ubuntu 20.10 "Groovy Gorilla" - Alpha amd64 (20200910)
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 004: ID 5986:2113 Acer, Inc SunplusIT Integrated Camera
   Bus 001 Device 005: ID 8087:0a2b Intel Corp. Bluetooth wireless interface
   Bus 001 Device 002: ID 0461:4e57 Primax Electronics, Ltd HID compliant device
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: LENOVO 20LTS01800
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=de_DE.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.8.0-18-generic 
root=UUID=301ac90f-9a29-425d-9b75-b6b2a43bf00a ro quiet splash
  SourcePackage: systemd
  SystemdFailedUnits:
   Error: command ['systemctl', 'status', '--full', '●'] failed with exit code 
4: Invalid unit name "●" escaped as "\xe2\x97\x8f" (maybe you should use 
systemd-escape?).
   Unit \xe2\x97\x8f.service could not be found.
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 12/18/2019
  dmi.bios.release: 1.37
  dmi.bios.vendor: LENOVO
  dmi.bios.version: R0QET60W (1.37 )
  

[Touch-packages] [Bug 1892643] Re: [SRU] Update libgweather to 3.36.1

2020-09-16 Thread Amr Ibrahim
Please sponsor libgweather 3.36.1 in my PPA to Focal:

https://launchpad.net/~amribrahim1987/+archive/ubuntu/ppa/+packages?field.name_filter=libgweather_filter=published_filter=

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libgweather in Ubuntu.
https://bugs.launchpad.net/bugs/1892643

Title:
  [SRU] Update libgweather to 3.36.1

Status in libgweather:
  Unknown
Status in libgweather package in Ubuntu:
  New
Status in libgweather package in Debian:
  Unknown

Bug description:
  [Impact]

  libgweather 3.36.1 is a bug-fix release as part of GNOME 3.36.

  https://gitlab.gnome.org/GNOME/libgweather/-/blob/gnome-3-36/NEWS

  This version works around the unavailability of the NOAA weather
  services by using very short-term forecasts as current weather
  conditions.

  Sometimes the current weather is not available because the NOAA
  weather servers aren't working correctly. Version 3.36.1 fixes the
  unavailability of current temperature in some locations.

  
  [Test case]

  Make sure that gnome-weather is still working properly and the weather
  in gnome-shell is shown when gnome-weather is installed.

  
  [Regression potential]

  The regression potential is low since the changes in version 3.36.1
  are small.

  
  [Other]

  libgweather 3.36.1 has been successfully built as a no-change backport
  from Groovy to Focal in my PPA and runs fine:

  
https://launchpad.net/~amribrahim1987/+archive/ubuntu/ppa/+packages?field.name_filter=libgweather_filter=published_filter=

  
  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: libgweather-3-16 3.36.0-1
  ProcVersionSignature: Ubuntu 5.4.0-42.46-generic 5.4.44
  Uname: Linux 5.4.0-42-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.8
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Sun Aug 23 19:05:21 2020
  InstallationDate: Installed on 2020-04-26 (119 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  SourcePackage: libgweather
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/libgweather/+bug/1892643/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1892643] Re: [SRU] Update libgweather to 3.36.1

2020-09-16 Thread Amr Ibrahim
** Description changed:

- Please update libgweather to 3.36.1 to fix the unavailability of current
- temperature in some locations.
+ [Impact]
+ 
+ libgweather 3.36.1 is a bug-fix release as part of GNOME 3.36.
  
  https://gitlab.gnome.org/GNOME/libgweather/-/blob/gnome-3-36/NEWS
  
- ==
- Version 3.36.1
- ==
+ This version works around the unavailability of the NOAA weather
+ services by using very short-term forecasts as current weather
+ conditions.
  
- This version works around the unavailability of the NOAA weather services
- by using very short-term forecasts as current weather conditions.
+ Sometimes the current weather is not available because the NOAA weather
+ servers aren't working correctly. Version 3.36.1 fixes the
+ unavailability of current temperature in some locations.
+ 
+ 
+ [Test case]
+ 
+ Make sure that gnome-weather is still working properly and the weather
+ in gnome-shell is shown when gnome-weather is installed.
+ 
+ 
+ [Regression potential]
+ 
+ The regression potential is low since the changes in version 3.36.1 are
+ small.
+ 
+ 
+ [Other]
+ 
+ libgweather 3.36.1 has been successfully built as a no-change backport
+ from Groovy to Focal in my PPA and runs fine:
+ 
+ 
https://launchpad.net/~amribrahim1987/+archive/ubuntu/ppa/+packages?field.name_filter=libgweather_filter=published_filter=
+ 
  
  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: libgweather-3-16 3.36.0-1
  ProcVersionSignature: Ubuntu 5.4.0-42.46-generic 5.4.44
  Uname: Linux 5.4.0-42-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.8
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Sun Aug 23 19:05:21 2020
  InstallationDate: Installed on 2020-04-26 (119 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  SourcePackage: libgweather
  UpgradeStatus: No upgrade log present (probably fresh install)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libgweather in Ubuntu.
https://bugs.launchpad.net/bugs/1892643

Title:
  [SRU] Update libgweather to 3.36.1

Status in libgweather:
  Unknown
Status in libgweather package in Ubuntu:
  New
Status in libgweather package in Debian:
  Unknown

Bug description:
  [Impact]

  libgweather 3.36.1 is a bug-fix release as part of GNOME 3.36.

  https://gitlab.gnome.org/GNOME/libgweather/-/blob/gnome-3-36/NEWS

  This version works around the unavailability of the NOAA weather
  services by using very short-term forecasts as current weather
  conditions.

  Sometimes the current weather is not available because the NOAA
  weather servers aren't working correctly. Version 3.36.1 fixes the
  unavailability of current temperature in some locations.

  
  [Test case]

  Make sure that gnome-weather is still working properly and the weather
  in gnome-shell is shown when gnome-weather is installed.

  
  [Regression potential]

  The regression potential is low since the changes in version 3.36.1
  are small.

  
  [Other]

  libgweather 3.36.1 has been successfully built as a no-change backport
  from Groovy to Focal in my PPA and runs fine:

  
https://launchpad.net/~amribrahim1987/+archive/ubuntu/ppa/+packages?field.name_filter=libgweather_filter=published_filter=

  
  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: libgweather-3-16 3.36.0-1
  ProcVersionSignature: Ubuntu 5.4.0-42.46-generic 5.4.44
  Uname: Linux 5.4.0-42-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.8
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Sun Aug 23 19:05:21 2020
  InstallationDate: Installed on 2020-04-26 (119 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  SourcePackage: libgweather
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/libgweather/+bug/1892643/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1895349] [NEW] Sync libgweather 3.36.1-1 (main) from Debian unstable (main)

2020-09-11 Thread Amr Ibrahim
Public bug reported:

Please sync libgweather 3.36.1-1 (main) from Debian unstable (main)

It's a bug-fix release.

Changelog entries since current groovy version 3.36.0-1:

libgweather (3.36.1-1) unstable; urgency=medium

  * Team upload
  * New upstream release
- This version works around the unavailability of the NOAA weather
  services by using very short-term forecasts as current weather
  conditions. (Closes: #968909)

 -- Simon McVittie   Fri, 28 Aug 2020 23:36:23 +0100

** Affects: libgweather (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libgweather in Ubuntu.
https://bugs.launchpad.net/bugs/1895349

Title:
  Sync libgweather 3.36.1-1 (main) from Debian unstable (main)

Status in libgweather package in Ubuntu:
  New

Bug description:
  Please sync libgweather 3.36.1-1 (main) from Debian unstable (main)

  It's a bug-fix release.

  Changelog entries since current groovy version 3.36.0-1:

  libgweather (3.36.1-1) unstable; urgency=medium

* Team upload
* New upstream release
  - This version works around the unavailability of the NOAA weather
services by using very short-term forecasts as current weather
conditions. (Closes: #968909)

   -- Simon McVittie   Fri, 28 Aug 2020 23:36:23 +0100

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libgweather/+bug/1895349/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1894124] Re: Merge gtk 3.24.22 from Debian

2020-09-04 Thread Amr Ibrahim
Ah, sorry, I thought the update fell through the cracks as the 20.10
release approaches.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gtk+3.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1894124

Title:
  Merge gtk 3.24.22 from Debian

Status in gtk+3.0 package in Ubuntu:
  New

Bug description:
  Please merge gtk 3.24.22 from Debian. It supposedly fixes bug #1891761
  and improves frame clock smoothness and fixes frame clock
  monotonicity.

  https://gitlab.gnome.org/GNOME/gtk/-/blob/gtk-3-24/NEWS

  Overview of Changes in GTK+ 3.24.22
  ===

  * GtkTextView:
   - Fix some corner cases of pixelcache invalidation
   - Make select-all work on touch

  * Fix print portal support

  * Adwaita:
   - Tweak title style class
   - Add a public color for text view background

  * Windows:
   - Limit the size of the corner mask cache
   - Use native API for keycode conversion
   - Use GLES on arm64

  * Wayland: Add a way to change the application id (LP: #1891761)

  * Quartz: Add axes to master devices

  * Add --enable-tracker3 option to configure

  * Translation updates:
   Catalan
   German
   Indonesian
   Italian
   Kazakh
   Spanish
   Turkish

  
  Overview of Changes in GTK+ 3.24.21
  ===

  * Wayland:
   - Prevent crashes with offscreen windows
   - Handle disorderly tablet/pad disconnects

  * GtkFileChooser:
   - Translate the type column
   - Add a tracker3 search engine
   - Rate-limit trash monitoring
   - Make get_filter work for native chooser

  * GtkGLArea:
   - Fix a redraw problem

  * GtkScrolledWindow:
   - Fix kinetic scrolling

  * Add a gtk-cursor-aspect-ratio setting

  * GDK:
   - Improve frame clock smoothness
   - Fix frame clock monotonicity

  * OS X:
   - Support Pen / Eraser input
   - Support openfiles in GtkApplication

  * Adwaita:
   - Improve notebook tab legibility

  * Translation updates:
   Basque
   Brazilian Portuguese
   Catalan
   Chinese (Taiwan)
   German
   Indonesian
   Italian
   Japanese
   Kazakh
   Lithuanian
   Polish
   Romanian
   Slovak
   Slovenian
   Swedish
   Ukrainian

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1894124/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1894124] [NEW] Merge gtk 3.24.22 from Debian

2020-09-03 Thread Amr Ibrahim
Public bug reported:

Please merge gtk 3.24.22 from Debian. It supposedly fixes bug #1891761
and improves frame clock smoothness and fixes frame clock monotonicity.

https://gitlab.gnome.org/GNOME/gtk/-/blob/gtk-3-24/NEWS

Overview of Changes in GTK+ 3.24.22
===

* GtkTextView:
 - Fix some corner cases of pixelcache invalidation
 - Make select-all work on touch

* Fix print portal support

* Adwaita:
 - Tweak title style class
 - Add a public color for text view background

* Windows:
 - Limit the size of the corner mask cache
 - Use native API for keycode conversion
 - Use GLES on arm64

* Wayland: Add a way to change the application id (LP: #1891761)

* Quartz: Add axes to master devices

* Add --enable-tracker3 option to configure

* Translation updates:
 Catalan
 German
 Indonesian
 Italian
 Kazakh
 Spanish
 Turkish


Overview of Changes in GTK+ 3.24.21
===

* Wayland:
 - Prevent crashes with offscreen windows
 - Handle disorderly tablet/pad disconnects

* GtkFileChooser:
 - Translate the type column
 - Add a tracker3 search engine
 - Rate-limit trash monitoring
 - Make get_filter work for native chooser

* GtkGLArea:
 - Fix a redraw problem

* GtkScrolledWindow:
 - Fix kinetic scrolling

* Add a gtk-cursor-aspect-ratio setting

* GDK:
 - Improve frame clock smoothness
 - Fix frame clock monotonicity

* OS X:
 - Support Pen / Eraser input
 - Support openfiles in GtkApplication

* Adwaita:
 - Improve notebook tab legibility

* Translation updates:
 Basque
 Brazilian Portuguese
 Catalan
 Chinese (Taiwan)
 German
 Indonesian
 Italian
 Japanese
 Kazakh
 Lithuanian
 Polish
 Romanian
 Slovak
 Slovenian
 Swedish
 Ukrainian

** Affects: gtk+3.0 (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: groovy upgrade-software-version

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gtk+3.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1894124

Title:
  Merge gtk 3.24.22 from Debian

Status in gtk+3.0 package in Ubuntu:
  New

Bug description:
  Please merge gtk 3.24.22 from Debian. It supposedly fixes bug #1891761
  and improves frame clock smoothness and fixes frame clock
  monotonicity.

  https://gitlab.gnome.org/GNOME/gtk/-/blob/gtk-3-24/NEWS

  Overview of Changes in GTK+ 3.24.22
  ===

  * GtkTextView:
   - Fix some corner cases of pixelcache invalidation
   - Make select-all work on touch

  * Fix print portal support

  * Adwaita:
   - Tweak title style class
   - Add a public color for text view background

  * Windows:
   - Limit the size of the corner mask cache
   - Use native API for keycode conversion
   - Use GLES on arm64

  * Wayland: Add a way to change the application id (LP: #1891761)

  * Quartz: Add axes to master devices

  * Add --enable-tracker3 option to configure

  * Translation updates:
   Catalan
   German
   Indonesian
   Italian
   Kazakh
   Spanish
   Turkish

  
  Overview of Changes in GTK+ 3.24.21
  ===

  * Wayland:
   - Prevent crashes with offscreen windows
   - Handle disorderly tablet/pad disconnects

  * GtkFileChooser:
   - Translate the type column
   - Add a tracker3 search engine
   - Rate-limit trash monitoring
   - Make get_filter work for native chooser

  * GtkGLArea:
   - Fix a redraw problem

  * GtkScrolledWindow:
   - Fix kinetic scrolling

  * Add a gtk-cursor-aspect-ratio setting

  * GDK:
   - Improve frame clock smoothness
   - Fix frame clock monotonicity

  * OS X:
   - Support Pen / Eraser input
   - Support openfiles in GtkApplication

  * Adwaita:
   - Improve notebook tab legibility

  * Translation updates:
   Basque
   Brazilian Portuguese
   Catalan
   Chinese (Taiwan)
   German
   Indonesian
   Italian
   Japanese
   Kazakh
   Lithuanian
   Polish
   Romanian
   Slovak
   Slovenian
   Swedish
   Ukrainian

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1894124/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1892643] Re: [SRU] Update libgweather to 3.36.1

2020-08-23 Thread Amr Ibrahim
** Bug watch added: Debian Bug tracker #968909
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=968909

** Also affects: libgweather (Debian) via
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=968909
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libgweather in Ubuntu.
https://bugs.launchpad.net/bugs/1892643

Title:
  [SRU] Update libgweather to 3.36.1

Status in libgweather:
  Unknown
Status in libgweather package in Ubuntu:
  New
Status in libgweather package in Debian:
  Unknown

Bug description:
  Please update libgweather to 3.36.1 to fix the unavailability of
  current temperature in some locations.

  https://gitlab.gnome.org/GNOME/libgweather/-/blob/gnome-3-36/NEWS

  ==
  Version 3.36.1
  ==

  This version works around the unavailability of the NOAA weather services
  by using very short-term forecasts as current weather conditions.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: libgweather-3-16 3.36.0-1
  ProcVersionSignature: Ubuntu 5.4.0-42.46-generic 5.4.44
  Uname: Linux 5.4.0-42-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.8
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Sun Aug 23 19:05:21 2020
  InstallationDate: Installed on 2020-04-26 (119 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  SourcePackage: libgweather
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/libgweather/+bug/1892643/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1892643] [NEW] [SRU] Update libgweather to 3.36.1

2020-08-23 Thread Amr Ibrahim
Public bug reported:

Please update libgweather to 3.36.1 to fix the unavailability of current
temperature in some locations.

https://gitlab.gnome.org/GNOME/libgweather/-/blob/gnome-3-36/NEWS

==
Version 3.36.1
==

This version works around the unavailability of the NOAA weather services
by using very short-term forecasts as current weather conditions.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: libgweather-3-16 3.36.0-1
ProcVersionSignature: Ubuntu 5.4.0-42.46-generic 5.4.44
Uname: Linux 5.4.0-42-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.8
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Sun Aug 23 19:05:21 2020
InstallationDate: Installed on 2020-04-26 (119 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
SourcePackage: libgweather
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: libgweather
 Importance: Unknown
 Status: Unknown

** Affects: libgweather (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug focal wayland-session

** Bug watch added: gitlab.gnome.org/GNOME/libgweather/-/issues #44
   https://gitlab.gnome.org/GNOME/libgweather/-/issues/44

** Also affects: libgweather via
   https://gitlab.gnome.org/GNOME/libgweather/-/issues/44
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libgweather in Ubuntu.
https://bugs.launchpad.net/bugs/1892643

Title:
  [SRU] Update libgweather to 3.36.1

Status in libgweather:
  Unknown
Status in libgweather package in Ubuntu:
  New

Bug description:
  Please update libgweather to 3.36.1 to fix the unavailability of
  current temperature in some locations.

  https://gitlab.gnome.org/GNOME/libgweather/-/blob/gnome-3-36/NEWS

  ==
  Version 3.36.1
  ==

  This version works around the unavailability of the NOAA weather services
  by using very short-term forecasts as current weather conditions.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: libgweather-3-16 3.36.0-1
  ProcVersionSignature: Ubuntu 5.4.0-42.46-generic 5.4.44
  Uname: Linux 5.4.0-42-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.8
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Sun Aug 23 19:05:21 2020
  InstallationDate: Installed on 2020-04-26 (119 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  SourcePackage: libgweather
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/libgweather/+bug/1892643/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1891761] Re: Add a way to change the application_id of a toplevel wayland GdkSurface (so LibreOffice can reuse toplevels and get the right task icons in Wayland)

2020-08-18 Thread Amr Ibrahim
Thanks, I will test any potentials fixes.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gtk+3.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1891761

Title:
  Add a way to change the application_id of a toplevel wayland
  GdkSurface (so LibreOffice can reuse toplevels and get the right task
  icons in Wayland)

Status in gtk+3.0 package in Ubuntu:
  New

Bug description:
  This is already committed upstream in GTK 3.24.22:
  
https://gitlab.gnome.org/GNOME/gtk/-/commit/2b74662b2befebb988b63118c8d7ee8c9d90e736

  LibreOffice in a Wayland session uses the same generic icon for its
  different apps, so when I have Writer, Calc and Impress open, they all
  share the same generic LO icon, which is not a very good experience.
  The upstream GTK commit should fix that, however, I have not tested
  it.

  The reason why I'm using Wayland in Ubuntu 20.04 is that I have a
  second 4K UHD monitor and fractional scaling + 4K UHD resolution is
  unusable in X11, so I'm kind of forced to use Wayland for fractional
  scaling. See bug #1890802.

  So I hope this fix could be committed in Ubuntu 20.04 to improve the
  LibreOffice experience in Wayland.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: libgtk-3-0 3.24.20-0ubuntu1
  ProcVersionSignature: Ubuntu 5.4.0-42.46-generic 5.4.44
  Uname: Linux 5.4.0-42-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.6
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Sat Aug 15 17:14:07 2020
  InstallationDate: Installed on 2020-04-26 (111 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=de_DE.UTF-8
   SHELL=/bin/bash
  SourcePackage: gtk+3.0
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1891761/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1891761] [NEW] Add a way to change the application_id of a toplevel wayland GdkSurface (so LibreOffice can reuse toplevels and get the right task icons in Wayland)

2020-08-15 Thread Amr Ibrahim
Public bug reported:

This is already committed upstream in GTK 3.24.22:
https://gitlab.gnome.org/GNOME/gtk/-/commit/2b74662b2befebb988b63118c8d7ee8c9d90e736

LibreOffice in a Wayland session uses the same generic icon for its
different apps, so when I have Writer, Calc and Impress open, they all
share the same generic LO icon, which is not a very good experience. The
upstream GTK commit should fix that, however, I have not tested it.

The reason why I'm using Wayland in Ubuntu 20.04 is that I have a second
4K UHD monitor and fractional scaling + 4K UHD resolution is unusable in
X11, so I'm kind of forced to use Wayland for fractional scaling. See
bug #1890802.

So I hope this fix could be committed in Ubuntu 20.04 to improve the
LibreOffice experience in Wayland.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: libgtk-3-0 3.24.20-0ubuntu1
ProcVersionSignature: Ubuntu 5.4.0-42.46-generic 5.4.44
Uname: Linux 5.4.0-42-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.6
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Sat Aug 15 17:14:07 2020
InstallationDate: Installed on 2020-04-26 (111 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: gtk+3.0
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: gtk+3.0 (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug focal wayland-session

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gtk+3.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1891761

Title:
  Add a way to change the application_id of a toplevel wayland
  GdkSurface (so LibreOffice can reuse toplevels and get the right task
  icons in Wayland)

Status in gtk+3.0 package in Ubuntu:
  New

Bug description:
  This is already committed upstream in GTK 3.24.22:
  
https://gitlab.gnome.org/GNOME/gtk/-/commit/2b74662b2befebb988b63118c8d7ee8c9d90e736

  LibreOffice in a Wayland session uses the same generic icon for its
  different apps, so when I have Writer, Calc and Impress open, they all
  share the same generic LO icon, which is not a very good experience.
  The upstream GTK commit should fix that, however, I have not tested
  it.

  The reason why I'm using Wayland in Ubuntu 20.04 is that I have a
  second 4K UHD monitor and fractional scaling + 4K UHD resolution is
  unusable in X11, so I'm kind of forced to use Wayland for fractional
  scaling. See bug #1890802.

  So I hope this fix could be committed in Ubuntu 20.04 to improve the
  LibreOffice experience in Wayland.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: libgtk-3-0 3.24.20-0ubuntu1
  ProcVersionSignature: Ubuntu 5.4.0-42.46-generic 5.4.44
  Uname: Linux 5.4.0-42-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.6
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Sat Aug 15 17:14:07 2020
  InstallationDate: Installed on 2020-04-26 (111 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=de_DE.UTF-8
   SHELL=/bin/bash
  SourcePackage: gtk+3.0
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1891761/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1814109] Re: Nautilus corrupts 7z archive files when extracting via 'Extract here' context menu

2020-07-06 Thread Amr Ibrahim
Fix released in groovy.

** Changed in: libarchive (Ubuntu)
   Status: Triaged => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libarchive in Ubuntu.
https://bugs.launchpad.net/bugs/1814109

Title:
  Nautilus corrupts 7z archive files when extracting via 'Extract here'
  context menu

Status in libarchive package in Ubuntu:
  Fix Released
Status in libarchive source package in Disco:
  Won't Fix

Bug description:
  Nautilus corrupts 7z archive files when extracting via 'Extract here' context 
menu.
  Extractions completes without errors, but the files are corrupted (mangled 
bytes, wrong size).
  This does happen only when extracting with 'Extract here' context menu action.
  Using 7z or p7zip via command line or opening the archive via file-roller and 
then drag
  single files or directory to a folder works well.
  This only happens with this particular archive, others 7z archives are 
extracted correctly.

  Original 7z archive:
  https://drive.google.com/open?id=1eZJm1ST3P-52tFSvHXbUn9-WSe_B3Ag9

  Re-zipped corrupted archive here:
  https://drive.google.com/open?id=1N--99RuWdmg6oUGrAz7pLoRpuJOIBEE5

  ProblemType: Bug
  DistroRelease: Ubuntu 18.10
  Package: nautilus 1:3.26.4-0ubuntu7.1
  ProcVersionSignature: Ubuntu 4.18.0-13.14-generic 4.18.17
  Uname: Linux 4.18.0-13-generic x86_64
  ApportVersion: 2.20.10-0ubuntu13.1
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Jan 31 15:03:45 2019
  GsettingsChanges:
   b'org.gnome.nautilus.window-state' b'sidebar-width' b'222'
   b'org.gnome.nautilus.window-state' b'geometry' b"'1133x703+51+273'"
   b'org.gnome.nautilus.desktop' b'trash-icon-visible' b'false'
   b'org.gnome.nautilus.desktop' b'volumes-visible' b'false'
  InstallationDate: Installed on 2018-05-31 (245 days ago)
  InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
  SourcePackage: nautilus
  UpgradeStatus: Upgraded to cosmic on 2018-10-20 (103 days ago)
  usr_lib_nautilus:

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libarchive/+bug/1814109/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1676069] Re: soxr resampling library not supported by pulseaudio

2020-06-17 Thread Amr Ibrahim
** Changed in: pasystray (Ubuntu)
   Status: Confirmed => Fix Released

** Package changed: pasystray (Ubuntu) => pulseaudio (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1676069

Title:
  soxr resampling library not supported by pulseaudio

Status in pulseaudio package in Ubuntu:
  Fix Released

Bug description:
  AMD 64
  Ubuntu 17.04 Beta 2
  Pulseaudio 10.0
  sampling rate 96K /24b

  in daemon.conf , set resample-method to soxr-vhq

  resample-method = soxr-vhq
  ;soxr-mq,soxr-hq, soxr-vhq.
  ;resample-method = speex-float-10
  ;resample-method = copy

  
  restart pulseaudio, then launch VLC with MP3 file @ 44.1KHz

  Output of pulseaudio log :

  W: [pulseaudio] resampler.c: Support for resampler 'soxr-vhq' not compiled 
in, reverting to 'auto'.
  D: [pulseaudio] resampler.c: Resampler:
  D: [pulseaudio] resampler.c:   rate 44100 -> 96000 (method speex-float-1)
  D: [pulseaudio] resampler.c:   format float32le -> float32le (intermediate 
float32le)
  D: [pulseaudio] resampler.c:   channels 2 -> 2 (resampling 2)
  I: [pulseaudio] speex.c: Choosing speex quality setting 1.

  
  So why soxr library is not compiled in ?

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1676069/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1741045] Re: Change the default resample-method to speex-float-N (N > 1) in daemon.conf

2020-05-31 Thread Amr Ibrahim
I changed the resample-method to soxr-hq, and I'll be testing it for
some time. According to the manpage of pulse-daemon.conf "the Soxr
resamplers generally offer better quality at less CPU compared to other
resamplers, such  as  speex". So far I think it gives better sound
quality than speex-float-1 and auto.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1741045

Title:
  Change the default resample-method to speex-float-N (N > 1) in
  daemon.conf

Status in PulseAudio:
  Fix Released
Status in pulseaudio package in Ubuntu:
  Incomplete

Bug description:
  I suggest changing the default resample-method to speex-float-10,
  instead of speex-float-1, which is the current default now, in
  /etc/pulse/daemon.conf.

  It would look like this in daemon.conf:
  resample-method = speex-float-10

  I have always done that since at least 12.04 LTS. I was not satisfied
  with the sound quality in Ubuntu compared to Windows, so I changed the
  resample-method.

  In my day-to-day usage, it gives better sound quality without
  sacrificing CPU power.

  I have not tried other resample methods. Maybe there are better
  options I don't know about.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: pulseaudio 1:10.0-2ubuntu3
  ProcVersionSignature: Ubuntu 4.13.0-19.22-generic 4.13.13
  Uname: Linux 4.13.0-19-generic x86_64
  ApportVersion: 2.20.7-0ubuntu3.6
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  amr1696 F pulseaudio
  CurrentDesktop: ubuntu:GNOME
  Date: Wed Jan  3 14:37:25 2018
  InstallationDate: Installed on 2017-10-02 (92 days ago)
  InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Beta amd64 (20170930)
  SourcePackage: pulseaudio
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 04/08/2011
  dmi.bios.vendor: Award Software International, Inc.
  dmi.bios.version: F2
  dmi.board.name: GA-78LMT-S2P
  dmi.board.vendor: Gigabyte Technology Co., Ltd.
  dmi.chassis.type: 3
  dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
  dmi.modalias: 
dmi:bvnAwardSoftwareInternational,Inc.:bvrF2:bd04/08/2011:svnGigabyteTechnologyCo.,Ltd.:pnGA-78LMT-S2P:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-78LMT-S2P:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
  dmi.product.name: GA-78LMT-S2P
  dmi.sys.vendor: Gigabyte Technology Co., Ltd.
  modified.conffile..etc.pulse.daemon.conf: [modified]
  mtime.conffile..etc.pulse.daemon.conf: 2017-10-05T12:39:48.718018

To manage notifications about this bug go to:
https://bugs.launchpad.net/pulseaudio/+bug/1741045/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1879927] [NEW] Merge wpa 2:2.9.0-13 (main) from Debian unstable (main)

2020-05-21 Thread Amr Ibrahim
Public bug reported:

Please merge wpa 2:2.9.0-13 (main) from Debian unstable (main)

The Debian package carries some upstream cherry-picks that are nice to
have in Ubuntu, plus the packaging updates.

Sorry, I can't work on this merge myself.

These Ubuntu changes can be dropped because they are already in Debian:
   * debian/patches/git_realtek_macrand.patch:
- backport an upstream patch to fix issues with some realtek cards
  when MAC address randomization is enabled (lp: #1867908)
   * SECURITY UPDATE: Incorrect indication of disconnection in certain
 situations
 - debian/patches/CVE-2019-16275.patch: silently ignore management
   frame from unexpected source address in src/ap/drv_callbacks.c,
   src/ap/ieee882_11.c.
 - CVE-2019-16275

Remaining changes specific to Ubuntu:
   * debian/patches/wpa_service_ignore-on-isolate.patch: add
 IgnoreOnIsolate=yes so that when switching "runlevels" in oem-config
 will not kill off wpa and cause wireless to be unavailable on first
 boot.
   * debian/patches/session-ticket.patch: disable the TLS Session Ticket
 extension to fix auth with 802.1x PEAP on some hardware.

Changelog entries since current groovy version 2:2.9-1ubuntu7:

wpa (2:2.9.0-13) unstable; urgency=medium

  * Apply upstream patches:
- Avoid sending invalid mgmt frames at startup
- Increase introspection buffer size for D-Bus

 -- Andrej Shadura   Tue, 19 May 2020 14:29:29
+0200

wpa (2:2.9.0-12) unstable; urgency=medium

  * Add an upstream patch to fix the MAC randomisation issue with some cards
(LP: #1867908).

 -- Andrej Shadura   Tue, 24 Mar 2020 11:13:16
+0100

wpa (2:2.9.0-11) unstable; urgency=medium

  * Actually add autopkgtest for libwpa-client-dev and libwpa_test.c.

 -- Andrej Shadura   Sat, 07 Mar 2020 13:18:19
+0100

wpa (2:2.9.0-10) unstable; urgency=medium

  * Rename the package with the client library to libwpa-client-dev.

 -- Andrej Shadura   Tue, 25 Feb 2020 20:19:52
+0100

wpa (2:2.9.0-9) unstable; urgency=medium

  [ Terry Burton ]
  * Build and install eapol_test in eapoltest package (Closes: #700870)

  [ Didier Raboud ]
  * Backport upstream patch to fix build with Debian's VERSION_STR.

  [ Andrew Lee (李健秋) ]
  * Build libwpa-dev binary package which contains a static
libwpa_client library and the wpa_ctrl header with an example program.

  [ Andrej Shadura ]
  * Add a patch to provide the BIT() macro locally in wpa_ctrl.h.
  * Patch the example to use stddef.h and wpa_ctrl.h from the global location.
  * Add an autopkgtest for libwpa-dev and libwpa_test.c.

 -- Andrej Shadura   Tue, 25 Feb 2020 18:21:35
+0100

wpa (2:2.9.0-8) unstable; urgency=medium

  * Reupload as 2.9.0 to undo an accidental experimental upload to
unstable.

 -- Andrej Shadura   Sat, 22 Feb 2020 11:25:29
+0300

wpa (2:2.9-7) unstable; urgency=medium

  * Apply upstream patches:
- trace: handle binutils bfd.h breakage
- Check for FT support when selecting FT suites (Closes: #942164)

 -- Andrej Shadura   Sat, 15 Feb 2020 16:42:04
+0100

wpa (2:2.9-6) unstable; urgency=medium

  [ Debian Janitor ]
  * Use secure URI in Homepage field.
  * Move source package lintian overrides to debian/source.
  * Use canonical URL in Vcs-Browser.
  * Rely on pre-initialized dpkg-architecture variables.
  * Update standards version to 4.4.1, no changes needed.

  [ Andrej Shadura ]
  * Disable CONFIG_DRIVER_MACSEC_QCA on kfreebsd.

 -- Andrej Shadura   Mon, 13 Jan 2020 16:28:58
+0100

wpa (2:2.9-5) unstable; urgency=medium

  * Fix erroneously inverted logic in postinst.

 -- Andrej Shadura   Mon, 13 Jan 2020 10:48:26
+0100

wpa (2:2.9-4) unstable; urgency=medium

  [ Helmut Grohne ]
  * Fix FTCBFS: Don’t export CC=cc (Closes: #921998).

  [ Andrej Shadura ]
  * Don’t act in hostapd.postinst if we’re running in a chrootless root.
  * Apply an upstream patch:
- wpa_supplicant: Do not try to detect PSK mismatch during PTK rekeying.

 -- Andrej Shadura   Mon, 13 Jan 2020 10:37:10
+0100

wpa (2:2.9-3) unstable; urgency=medium

  * Add pkg.wpa.nogui and noudeb build profiles.

 -- Andrej Shadura   Fri, 04 Oct 2019 11:47:15
+0200

wpa (2:2.9-2) unstable; urgency=medium

  * SECURITY UPDATE:
- AP mode PMF disconnection protection bypass.
  More details:
   + https://w1.fi/security/2019-7/
  Closes: #940080 (CVE-2019-16275)

 -- Andrej Shadura   Fri, 04 Oct 2019 10:11:47
+0200

** Affects: wpa (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to wpa in Ubuntu.
https://bugs.launchpad.net/bugs/1879927

Title:
  Merge wpa 2:2.9.0-13 (main) from Debian unstable (main)

Status in wpa package in Ubuntu:
  New

Bug description:
  Please merge wpa 2:2.9.0-13 (main) from Debian unstable (main)

  The Debian package carries some upstream cherry-picks that are nice to
  have in Ubuntu, plus the packaging updates.

  Sorry, I 

[Touch-packages] [Bug 1879131] [NEW] Relax the dependency of gnome-shell-extension-desktop-icons from Depends to Recommends

2020-05-17 Thread Amr Ibrahim
Public bug reported:

I would like to be able to remove the gnome-shell-extension-desktop-
icons without removing ubuntu-desktop.

GNOME shell extensions are sometimes buggy, in this case desktop-icons,
and I consider the desktop-icons extension an enhancement to the
desktop, not a necessity, because no other functionality or packages
depend on its behaviour, and there is no loss of data or breakage of
another functionality after removing it.

So changing the dependency to a Recommends would allow the extension to
be installed by default and be removed without removing ubuntu-desktop.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: ubuntu-desktop 1.450
ProcVersionSignature: Ubuntu 5.4.0-29.33-generic 5.4.30
Uname: Linux 5.4.0-29-generic x86_64
ApportVersion: 2.20.11-0ubuntu27
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Sun May 17 09:48:49 2020
InstallationDate: Installed on 2020-04-26 (20 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntu-meta
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: ubuntu-meta (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug focal

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu.
https://bugs.launchpad.net/bugs/1879131

Title:
  Relax the dependency of gnome-shell-extension-desktop-icons from
  Depends to Recommends

Status in ubuntu-meta package in Ubuntu:
  New

Bug description:
  I would like to be able to remove the gnome-shell-extension-desktop-
  icons without removing ubuntu-desktop.

  GNOME shell extensions are sometimes buggy, in this case desktop-
  icons, and I consider the desktop-icons extension an enhancement to
  the desktop, not a necessity, because no other functionality or
  packages depend on its behaviour, and there is no loss of data or
  breakage of another functionality after removing it.

  So changing the dependency to a Recommends would allow the extension
  to be installed by default and be removed without removing ubuntu-
  desktop.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: ubuntu-desktop 1.450
  ProcVersionSignature: Ubuntu 5.4.0-29.33-generic 5.4.30
  Uname: Linux 5.4.0-29-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Sun May 17 09:48:49 2020
  InstallationDate: Installed on 2020-04-26 (20 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=de_DE.UTF-8
   SHELL=/bin/bash
  SourcePackage: ubuntu-meta
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-meta/+bug/1879131/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1741045] Re: Change the default resample-method to speex-float-N (N > 1) in daemon.conf

2020-05-12 Thread Amr Ibrahim
I had already changed the resample-method to soxr-mq, and am satisfied
with the result. I don't know how to judge which is better, auto or
soxr-mq?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1741045

Title:
  Change the default resample-method to speex-float-N (N > 1) in
  daemon.conf

Status in PulseAudio:
  Fix Released
Status in pulseaudio package in Ubuntu:
  Incomplete

Bug description:
  I suggest changing the default resample-method to speex-float-10,
  instead of speex-float-1, which is the current default now, in
  /etc/pulse/daemon.conf.

  It would look like this in daemon.conf:
  resample-method = speex-float-10

  I have always done that since at least 12.04 LTS. I was not satisfied
  with the sound quality in Ubuntu compared to Windows, so I changed the
  resample-method.

  In my day-to-day usage, it gives better sound quality without
  sacrificing CPU power.

  I have not tried other resample methods. Maybe there are better
  options I don't know about.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: pulseaudio 1:10.0-2ubuntu3
  ProcVersionSignature: Ubuntu 4.13.0-19.22-generic 4.13.13
  Uname: Linux 4.13.0-19-generic x86_64
  ApportVersion: 2.20.7-0ubuntu3.6
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  amr1696 F pulseaudio
  CurrentDesktop: ubuntu:GNOME
  Date: Wed Jan  3 14:37:25 2018
  InstallationDate: Installed on 2017-10-02 (92 days ago)
  InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Beta amd64 (20170930)
  SourcePackage: pulseaudio
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 04/08/2011
  dmi.bios.vendor: Award Software International, Inc.
  dmi.bios.version: F2
  dmi.board.name: GA-78LMT-S2P
  dmi.board.vendor: Gigabyte Technology Co., Ltd.
  dmi.chassis.type: 3
  dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
  dmi.modalias: 
dmi:bvnAwardSoftwareInternational,Inc.:bvrF2:bd04/08/2011:svnGigabyteTechnologyCo.,Ltd.:pnGA-78LMT-S2P:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-78LMT-S2P:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
  dmi.product.name: GA-78LMT-S2P
  dmi.sys.vendor: Gigabyte Technology Co., Ltd.
  modified.conffile..etc.pulse.daemon.conf: [modified]
  mtime.conffile..etc.pulse.daemon.conf: 2017-10-05T12:39:48.718018

To manage notifications about this bug go to:
https://bugs.launchpad.net/pulseaudio/+bug/1741045/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1710511] Re: nano crashed with SIGSEGV in get_sysdep_segment_value()

2020-05-11 Thread Amr Ibrahim
** Changed in: nano (Ubuntu)
   Status: New => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to nano in Ubuntu.
https://bugs.launchpad.net/bugs/1710511

Title:
  nano crashed with SIGSEGV in get_sysdep_segment_value()

Status in nano package in Ubuntu:
  Incomplete

Bug description:
  When update

  ProblemType: Crash
  DistroRelease: Ubuntu 17.10
  Package: nano 2.8.6-2
  ProcVersionSignature: Ubuntu 4.11.0-13.19-generic 4.11.12
  Uname: Linux 4.11.0-10-generic x86_64
  ApportVersion: 2.20.6-0ubuntu5
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Wed Aug  9 20:22:31 2017
  ExecutablePath: /bin/nano
  InstallationDate: Installed on 2017-08-09 (4 days ago)
  InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170806)
  ProcCmdline: nano /etc/defaults/grub
  SegvAnalysis:
   Segfault happened at: 0x7fdda72da0f5 <_nl_find_msg+725>: mov
(%r12),%rdi
   PC (0x7fdda72da0f5) ok
   source "(%r12)" (0x30b03019) not located in a known VMA region (needed 
readable region)!
   destination "%rdi" ok
  SegvReason: reading unknown VMA
  Signal: 11
  SourcePackage: nano
  StacktraceTop:
   get_sysdep_segment_value (name=0x7fdda7cd3364 ) at loadmsgcat.c:727
   _nl_load_domain (domain_file=0x55d7c83aafc0, 
domainbinding=domainbinding@entry=0x0) at loadmsgcat.c:1002
   _nl_find_domain (dirname=dirname@entry=0x7fdda743ca40 <_nl_default_dirname> 
"/usr/share/locale", locale=locale@entry=0x7ffcc307a400 "pt", 
domainname=domainname@entry=0x7ffcc307a420 "LC_MESSAGES/libc.mo", 
domainbinding=domainbinding@entry=0x0) at finddomain.c:173
   __dcigettext (domainname=0x7fdda7435a40 <_libc_intl_domainname> "libc", 
msgid1=0x7fdda7435dfd "No such file or directory", msgid2=msgid2@entry=0x0, 
plural=plural@entry=0, n=n@entry=0, category=category@entry=5) at 
dcigettext.c:722
   __GI___dcgettext (domainname=, msgid=, 
category=category@entry=5) at dcgettext.c:47
  Title: nano crashed with SIGSEGV in get_sysdep_segment_value()
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nano/+bug/1710511/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1853825] Re: ^W ^G ^X fails to redisplay the text being edited

2020-05-11 Thread Amr Ibrahim
** Changed in: nano (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to nano in Ubuntu.
https://bugs.launchpad.net/bugs/1853825

Title:
  ^W ^G ^X fails to redisplay the text being edited

Status in nano package in Ubuntu:
  Fix Released

Bug description:
  There is a silly display bug in nano-4.3
  (https://savannah.gnu.org/bugs/?57295): when opening some file (for
  example, 'nano README') and typing the sequence Ctrl+W Ctrl+G Ctrl+X,
  the Search help text stays on the screen whereas the text of the
  README file should be redisplayed.  Attached upstream patch fixes
  this.  Please apply to Eoan.

  (It could be applied to Focal too, but nano-4.6 will be out within a
  week, so it's probably not worth the effort.)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nano/+bug/1853825/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1874107] Re: qt theming issue: error 6 in libgdk-x11-2.0.so

2020-04-21 Thread Amr Ibrahim
** Changed in: gtk+2.0 (Ubuntu)
   Status: New => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gtk+2.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1874107

Title:
  qt theming issue: error 6 in libgdk-x11-2.0.so

Status in gtk+2.0 package in Ubuntu:
  Incomplete

Bug description:
  As for related bug 
https://bugs.launchpad.net/ubuntu/+source/qtstyleplugins-src/+bug/1874102 , 
  theming a qt application with the "gtk2" theme causes the app to crash with 
segfault:

  ```
  segfault at 114 ip 7f0439c6caa5 sp 7fff05b55770 error 6 in 
libgdk-x11-2.0.so.0.2400.32[7f0439c36000+5e000]
  ```

  Also the following code is available:

  ```
  Code: 64 24 10 4c 8d 6c 24 40 e8 d8 fe ff ff 31 f6 48 8d 5c 24 38 48 89 c7 31 
c0 e8 77 c9 fc ff 31 d2 48 8d 35 0e fe ff ff 48 89 ef  80 14 01 00 00 01 00 
00 00 49 89 c7 48 89 a8 d8 00 00 00 e8 12
  ```

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: libgtk2.0-0 2.24.32-4ubuntu4
  ProcVersionSignature: Ubuntu 5.4.0-24.28-generic 5.4.30
  Uname: Linux 5.4.0-24-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: GNOME
  Date: Tue Apr 21 18:08:47 2020
  InstallationDate: Installed on 2020-04-03 (17 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Beta amd64 (20200401)
  SourcePackage: gtk+2.0
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gtk+2.0/+bug/1874107/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1807759] Re: Can not type file path in file open dialog, also can not turn on always-use-location-entry

2020-04-15 Thread Amr Ibrahim
*** This bug is a duplicate of bug 1863157 ***
https://bugs.launchpad.net/bugs/1863157

** This bug has been marked a duplicate of bug 1863157
   Petition to bring back file name copy/paste functionality in GTK file chooser

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gtk+3.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1807759

Title:
  Can not type file path in file open dialog, also can not turn on
  always-use-location-entry

Status in gtk+3.0 package in Ubuntu:
  New

Bug description:
  after upgrading to 16.04 from 14.04, I found that all file open dialog
  lost the address bar (location entry). The only thing to navigate
  between folders is the breadcrumb bar. Every path change requires a
  dozen of clicking, while before I could just paste the path and done.
  This is a big inconvenience.

  after googling, I found tons of reports to restore the location entry
  using the below command

  gsettings set org.gnome.nautilus.preferences always-use-location-entry true
   or
  dconf write /org/gnome/nautilus/preferences/always-use-location-entry true

  however, this fails to work on my system, I got

  fangq@taote:~$ gsettings set org.gnome.nautilus.preferences always-
  use-location-entry true

  (process:11686): dconf-WARNING **: failed to commit changes to dconf:
  
GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._g_2dfile_2derror_2dquark.Code4:
  Failed to rename file '/home/users/fangq/.config/dconf/user.SO58SZ' to
  '/home/users/fangq/.config/dconf/user': g_rename() failed: No such
  file or directory

  I would like to get a workaround to revert to the previous setting
  (either location entry is displayed by default, or can be re-enabled
  by clicking a button on the dialog). Also, I would suggest the
  developers to consider adding this feature back. For people who use
  Linux a lot, clicking is just not fast enough!

  
  Links to similar complains:

  
https://unix.stackexchange.com/questions/154106/show-address-bar-w-full-path-in-nautilus-instead-of-breadcrumbs-bar
  
https://www.howtogeek.com/189777/how-to-show-the-location-entry-instead-of-the-breadcrumb-bar-in-nautilus-in-ubuntu-14.04/
  
https://askubuntu.com/questions/547688/default-to-showing-and-using-pathbar-in-ubuntu-file-dialogs
  https://community.linuxmint.com/tutorial/view/65
  https://blog.tersmitten.nl/restore-the-location-bar-in-nautilus.html
  
https://askubuntu.com/questions/324064/use-path-bar-and-address-bar-in-nautilus

  and many more

  https://www.google.com/search?q=nautilus+always_use_location_entry

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1807759/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1851128] Re: Stylus Use leads to Crash Application in Wayland Sessions

2020-04-15 Thread Amr Ibrahim
** Changed in: gtk+3.0 (Ubuntu)
   Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gtk+3.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1851128

Title:
  Stylus Use leads to Crash Application in Wayland Sessions

Status in gtk+3.0 package in Ubuntu:
  Fix Released

Bug description:
  There is an issue in gtk. In Wayland sessions the use of a stylus
  leads to crash of the application. It is apparently fixed in Gnome
  gtk.

  When asking what should I do I got the answer that I should ask the
  ubuntu gtk maintainers to  backport <
  https://gitlab.gnome.org/GNOME/gtk/merge_requests/1121> and
  , which I do
  here and now.

  Best regards

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1851128/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1873038] [NEW] Merge gtk+3.0 3.24.18-1 (main) from Debian unstable (main)

2020-04-15 Thread Amr Ibrahim
Public bug reported:

Please merge gtk+3.0 3.24.18-1 (main) from Debian unstable (main)

Sorry, I can't work on this merge myself. It fixes bugs in Wayland.

https://gitlab.gnome.org/GNOME/gtk/-/blob/gtk-3-24/NEWS

Overview of Changes in GTK+ 3.24.18
===

* Wayland:
 - Fix more sizing regressions in Epiphany and LibreOffice
   menus, and popups in general

* Build:
 - Make resource build reproducible

* Translation updates
 Basque
 Latvian

Explanation of the Ubuntu delta:
  * Update to the current stable version (based on Debian)

Changelog entries since current focal version 3.24.17-3ubuntu1:

gtk+3.0 (3.24.18-1) unstable; urgency=medium

  * Team upload
  * New upstream release
- Fix remaining XInclude failure in documentation (Closes: #672369)
  * d/copyright: Update
  * d/patches: Drop patches that came from upstream

 -- Simon McVittie   Fri, 10 Apr 2020 15:47:07 +0100

** Affects: gtk+3.0 (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gtk+3.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1873038

Title:
  Merge gtk+3.0 3.24.18-1 (main) from Debian unstable (main)

Status in gtk+3.0 package in Ubuntu:
  New

Bug description:
  Please merge gtk+3.0 3.24.18-1 (main) from Debian unstable (main)

  Sorry, I can't work on this merge myself. It fixes bugs in Wayland.

  https://gitlab.gnome.org/GNOME/gtk/-/blob/gtk-3-24/NEWS

  Overview of Changes in GTK+ 3.24.18
  ===

  * Wayland:
   - Fix more sizing regressions in Epiphany and LibreOffice
 menus, and popups in general

  * Build:
   - Make resource build reproducible

  * Translation updates
   Basque
   Latvian

  Explanation of the Ubuntu delta:
* Update to the current stable version (based on Debian)

  Changelog entries since current focal version 3.24.17-3ubuntu1:

  gtk+3.0 (3.24.18-1) unstable; urgency=medium

* Team upload
* New upstream release
  - Fix remaining XInclude failure in documentation (Closes: #672369)
* d/copyright: Update
* d/patches: Drop patches that came from upstream

   -- Simon McVittie   Fri, 10 Apr 2020 15:47:07 +0100

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1873038/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1870617] Re: Merge fontconfig 2.13.1-3 (main) from Debian unstable (main)

2020-04-04 Thread Amr Ibrahim
** Description changed:

  Please merge fontconfig 2.13.1-3 (main) from Debian unstable (main)
  
  Sorry, I can't work on this merge myself.
- It fixes Debian bugs, and they can be related to Ubuntu too.
+ 
+ It fixes Debian bugs, especially this one
+ https://bugs.debian.org/568686, which is related to performance, and
+ they can be related to Ubuntu too.
  
  Explanation of the Ubuntu delta:
    * Really include the symbols file update
    * debian/patches/04_ubuntu_monospace_lcd_filter_conf.patch:
  - updated the 53-monospace-lcd-filter.conf syntax to avoid warnings
    which make autopkgtests fail
    * Upload proposed patch from upstream bug #103652. If the fontconfig
- cache was built on a system that has nanosecond timestamps and then
- later transplanted to one that doesn't - for example by mksquashfs as
- part of a live CD build - we consider the cache invalid and rebuild it
- during the boot process. Depending on the fonts involved, this can
- take a significant amount of time and potentially cause knock-on
- timeouts. The approach in this patch is to ignore the nanosecond
- portion of the cache's value if we get 0 when stat()ing the referenced
- directory, meaning it is considered fresh if the rest of the timestamp
- matches. (LP: #1749546)
+ cache was built on a system that has nanosecond timestamps and then
+ later transplanted to one that doesn't - for example by mksquashfs as
+ part of a live CD build - we consider the cache invalid and rebuild it
+ during the boot process. Depending on the fonts involved, this can
+ take a significant amount of time and potentially cause knock-on
+ timeouts. The approach in this patch is to ignore the nanosecond
+ portion of the cache's value if we get 0 when stat()ing the referenced
+ directory, meaning it is considered fresh if the rest of the timestamp
+ matches. (LP: #1749546)
    * Merge with Debian (LP: #1638959, LP: #1702544). Remaining changes:
  - debian/source_fontconfig.py, debian/fontconfig.install:
    + Install apport hook
  - Add 03_prefer_dejavu.patch:
    + Prefer DejaVu to Bitstream Vera
  - Add 04_ubuntu_monospace_lcd_filter_conf.patch:
    + Use legacy lcdfilter with smaller monospace fonts
  - Add 05_ubuntu_add_antialiasing_confs.patch:
    + Add config file for antialiasing
  - Add 05_lcdfilterlegacy.patch: Recognize const value "lcdfilterlegacy",
    used in Ubuntu before upstream introduced "lcdlegacy"
  - Add 07_no_bitmaps.patch:
    + Install 70-no-bitmaps.conf
  - Drop debian/fontconfig.NEWS, debian/fontconfig-config.templates,
    debian/fontconfig-config.config, and associatedpo files.
    Modify debian/rules, debian/fontconfig-config.postinst,
    debian/fontconfig-config.postrm, and debian/README.Debian.
    + Don't provide debconf prompts
  - Modify debian/rules, debian/fontconfig-config.install,
    debian/fontconfig-config.links, debian/fontconfig-config.postrm,
    and debian/fontconfig-udeb.install:
    + Delay doing the transition from /etc to /usr
    * New upstream release
    * Refresh patches
    * Update Ubuntu patches to use mode="append" and target="pattern"
  (LP: #1192175)
    * Drop patches applied in new release:
  - 01_fonts_nanum.patch
  - 03_locale_c.utf8.patch
  - 06_cross.patch
  - CVE-2016-5384.patch
  
  Changelog entries since current focal version 2.13.1-2ubuntu2:
  
  fontconfig (2.13.1-3) unstable; urgency=medium
  
    [ Laurent Bigonville ]
    * debian/rules: Stop looking for fonts in /usr/X11R6/lib/X11/fonts, nothing 
is installing fonts there for years and it's causing gnome-settings-daemon to 
check the location every few seconds (Closes: #568686)
  
    [ Fabian Greffrath ]
    * fontconfig-config: extend, clean-up and order fontconfig-config's
  font dependencies (Closes: #879503)
  
    [ Emilio Pozuelo Monfort ]
    * Split documentation into a -doc package to avoid multi-arch problems in 
the -dev one (Closes: #935760, #844607)
    * Since we're going through NEW, rename libfontconfig1-dev to
  libfontconfig-dev and provide the former.
    * Switch to debhelper-compat.
  
   -- Emilio Pozuelo Monfort   Wed, 18 Mar 2020 00:56:46
  +0100

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to fontconfig in Ubuntu.
https://bugs.launchpad.net/bugs/1870617

Title:
  Merge fontconfig 2.13.1-3 (main) from Debian unstable (main)

Status in fontconfig package in Ubuntu:
  New

Bug description:
  Please merge fontconfig 2.13.1-3 (main) from Debian unstable (main)

  Sorry, I can't work on this merge myself.

  It fixes Debian bugs, especially this one
  https://bugs.debian.org/568686, which is related to performance, and
  they can be related to Ubuntu too.

  Explanation of the Ubuntu delta:
    * Really include the symbols file update
    * 

[Touch-packages] [Bug 1870617] Re: Merge fontconfig 2.13.1-3 (main) from Debian unstable (main)

2020-04-04 Thread Amr Ibrahim
** Description changed:

  Please merge fontconfig 2.13.1-3 (main) from Debian unstable (main)
  
  Sorry, I can't work on this merge myself.
  It fixes Debian bugs, and they can be related to Ubuntu too.
  
  Explanation of the Ubuntu delta:
-   * Really include the symbols file update
-   * debian/patches/04_ubuntu_monospace_lcd_filter_conf.patch:
- - updated the 53-monospace-lcd-filter.conf syntax to avoid warnings
-   which make autopkgtests fail
-   * Upload proposed patch from upstream bug #103652. If the fontconfig cache
- was built on a system that has nanosecond timestamps and then later
- transplanted to one that doesn't - for example by mksquashfs as part of a
- live CD build - we consider the cache invalid and rebuild it during the
- boot process. Depending on the fonts involved, this can take a significant
- amount of time and potentially cause knock-on timeouts. The approach in
- this patch is to ignore the nanosecond portion of the cache's value if we
- get 0 when stat()ing the referenced directory, meaning it is considered
- fresh if the rest of the timestamp matches. (LP: #1749546)
-   * Merge with Debian (LP: #1638959, LP: #1702544). Remaining changes:
- - debian/source_fontconfig.py, debian/fontconfig.install:
-   + Install apport hook
- - Add 03_prefer_dejavu.patch:
-   + Prefer DejaVu to Bitstream Vera
- - Add 04_ubuntu_monospace_lcd_filter_conf.patch:
-   + Use legacy lcdfilter with smaller monospace fonts
- - Add 05_ubuntu_add_antialiasing_confs.patch:
-   + Add config file for antialiasing
- - Add 05_lcdfilterlegacy.patch: Recognize const value "lcdfilterlegacy",
-   used in Ubuntu before upstream introduced "lcdlegacy"
- - Add 07_no_bitmaps.patch:
-   + Install 70-no-bitmaps.conf
- - Drop debian/fontconfig.NEWS, debian/fontconfig-config.templates,
-   debian/fontconfig-config.config, and associatedpo files.
-   Modify debian/rules, debian/fontconfig-config.postinst,
-   debian/fontconfig-config.postrm, and debian/README.Debian.
-   + Don't provide debconf prompts
- - Modify debian/rules, debian/fontconfig-config.install,
-   debian/fontconfig-config.links, debian/fontconfig-config.postrm,
-   and debian/fontconfig-udeb.install:
-   + Delay doing the transition from /etc to /usr
-   * New upstream release
-   * Refresh patches
-   * Update Ubuntu patches to use mode="append" and target="pattern"
- (LP: #1192175)
-   * Drop patches applied in new release:
- - 01_fonts_nanum.patch
- - 03_locale_c.utf8.patch
- - 06_cross.patch
- - CVE-2016-5384.patch
+   * Really include the symbols file update
+   * debian/patches/04_ubuntu_monospace_lcd_filter_conf.patch:
+ - updated the 53-monospace-lcd-filter.conf syntax to avoid warnings
+   which make autopkgtests fail
+   * Upload proposed patch from upstream bug #103652. If the fontconfig
+ cache was built on a system that has nanosecond timestamps and then
+ later transplanted to one that doesn't - for example by mksquashfs as
+ part of a live CD build - we consider the cache invalid and rebuild it
+ during the boot process. Depending on the fonts involved, this can
+ take a significant amount of time and potentially cause knock-on
+ timeouts. The approach in this patch is to ignore the nanosecond
+ portion of the cache's value if we get 0 when stat()ing the referenced
+ directory, meaning it is considered fresh if the rest of the timestamp
+ matches. (LP: #1749546)
+   * Merge with Debian (LP: #1638959, LP: #1702544). Remaining changes:
+ - debian/source_fontconfig.py, debian/fontconfig.install:
+   + Install apport hook
+ - Add 03_prefer_dejavu.patch:
+   + Prefer DejaVu to Bitstream Vera
+ - Add 04_ubuntu_monospace_lcd_filter_conf.patch:
+   + Use legacy lcdfilter with smaller monospace fonts
+ - Add 05_ubuntu_add_antialiasing_confs.patch:
+   + Add config file for antialiasing
+ - Add 05_lcdfilterlegacy.patch: Recognize const value "lcdfilterlegacy",
+   used in Ubuntu before upstream introduced "lcdlegacy"
+ - Add 07_no_bitmaps.patch:
+   + Install 70-no-bitmaps.conf
+ - Drop debian/fontconfig.NEWS, debian/fontconfig-config.templates,
+   debian/fontconfig-config.config, and associatedpo files.
+   Modify debian/rules, debian/fontconfig-config.postinst,
+   debian/fontconfig-config.postrm, and debian/README.Debian.
+   + Don't provide debconf prompts
+ - Modify debian/rules, debian/fontconfig-config.install,
+   debian/fontconfig-config.links, debian/fontconfig-config.postrm,
+   and debian/fontconfig-udeb.install:
+   + Delay doing the transition from /etc to /usr
+   * New upstream release
+   * Refresh patches
+   * Update Ubuntu patches to use mode="append" and target="pattern"
+ (LP: #1192175)
+   * Drop patches applied in new release:
+ - 

[Touch-packages] [Bug 1870617] [NEW] Merge fontconfig 2.13.1-3 (main) from Debian unstable (main)

2020-04-03 Thread Amr Ibrahim
Public bug reported:

Please merge fontconfig 2.13.1-3 (main) from Debian unstable (main)

Sorry, I can't work on this merge myself.
It fixes Debian bugs, and they can be related to Ubuntu too.

Explanation of the Ubuntu delta:
  * Really include the symbols file update
  * debian/patches/04_ubuntu_monospace_lcd_filter_conf.patch:
- updated the 53-monospace-lcd-filter.conf syntax to avoid warnings
  which make autopkgtests fail
  * Upload proposed patch from upstream bug #103652. If the fontconfig cache
was built on a system that has nanosecond timestamps and then later
transplanted to one that doesn't - for example by mksquashfs as part of a
live CD build - we consider the cache invalid and rebuild it during the
boot process. Depending on the fonts involved, this can take a significant
amount of time and potentially cause knock-on timeouts. The approach in
this patch is to ignore the nanosecond portion of the cache's value if we
get 0 when stat()ing the referenced directory, meaning it is considered
fresh if the rest of the timestamp matches. (LP: #1749546)
  * Merge with Debian (LP: #1638959, LP: #1702544). Remaining changes:
- debian/source_fontconfig.py, debian/fontconfig.install:
  + Install apport hook
- Add 03_prefer_dejavu.patch:
  + Prefer DejaVu to Bitstream Vera
- Add 04_ubuntu_monospace_lcd_filter_conf.patch:
  + Use legacy lcdfilter with smaller monospace fonts
- Add 05_ubuntu_add_antialiasing_confs.patch:
  + Add config file for antialiasing
- Add 05_lcdfilterlegacy.patch: Recognize const value "lcdfilterlegacy",
  used in Ubuntu before upstream introduced "lcdlegacy"
- Add 07_no_bitmaps.patch:
  + Install 70-no-bitmaps.conf
- Drop debian/fontconfig.NEWS, debian/fontconfig-config.templates,
  debian/fontconfig-config.config, and associatedpo files.
  Modify debian/rules, debian/fontconfig-config.postinst,
  debian/fontconfig-config.postrm, and debian/README.Debian.
  + Don't provide debconf prompts
- Modify debian/rules, debian/fontconfig-config.install,
  debian/fontconfig-config.links, debian/fontconfig-config.postrm,
  and debian/fontconfig-udeb.install:
  + Delay doing the transition from /etc to /usr
  * New upstream release
  * Refresh patches
  * Update Ubuntu patches to use mode="append" and target="pattern"
(LP: #1192175)
  * Drop patches applied in new release:
- 01_fonts_nanum.patch
- 03_locale_c.utf8.patch
- 06_cross.patch
- CVE-2016-5384.patch

Changelog entries since current focal version 2.13.1-2ubuntu2:

fontconfig (2.13.1-3) unstable; urgency=medium

  [ Laurent Bigonville ]
  * debian/rules: Stop looking for fonts in /usr/X11R6/lib/X11/fonts, nothing
is installing fonts there for years and it's causing gnome-settings-daemon
to check the location every few seconds (Closes: #568686)

  [ Fabian Greffrath ]
  * fontconfig-config: extend, clean-up and order fontconfig-config's
font dependencies (Closes: #879503)

  [ Emilio Pozuelo Monfort ]
  * Split documentation into a -doc package to avoid multi-arch problems in
the -dev one (Closes: #935760, #844607)
  * Since we're going through NEW, rename libfontconfig1-dev to
libfontconfig-dev and provide the former.
  * Switch to debhelper-compat.

 -- Emilio Pozuelo Monfort   Wed, 18 Mar 2020 00:56:46
+0100

** Affects: fontconfig (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to fontconfig in Ubuntu.
https://bugs.launchpad.net/bugs/1870617

Title:
  Merge fontconfig 2.13.1-3 (main) from Debian unstable (main)

Status in fontconfig package in Ubuntu:
  New

Bug description:
  Please merge fontconfig 2.13.1-3 (main) from Debian unstable (main)

  Sorry, I can't work on this merge myself.
  It fixes Debian bugs, and they can be related to Ubuntu too.

  Explanation of the Ubuntu delta:
* Really include the symbols file update
* debian/patches/04_ubuntu_monospace_lcd_filter_conf.patch:
  - updated the 53-monospace-lcd-filter.conf syntax to avoid warnings
which make autopkgtests fail
* Upload proposed patch from upstream bug #103652. If the fontconfig cache
  was built on a system that has nanosecond timestamps and then later
  transplanted to one that doesn't - for example by mksquashfs as part of a
  live CD build - we consider the cache invalid and rebuild it during the
  boot process. Depending on the fonts involved, this can take a significant
  amount of time and potentially cause knock-on timeouts. The approach in
  this patch is to ignore the nanosecond portion of the cache's value if we
  get 0 when stat()ing the referenced directory, meaning it is considered
  fresh if the rest of the timestamp matches. (LP: #1749546)
* Merge with Debian (LP: #1638959, LP: #1702544). Remaining 

[Touch-packages] [Bug 1868927] Re: FFe: Sync shared-mime-info 1.15-1 (main) from Debian unstable (main)

2020-03-26 Thread Amr Ibrahim
I wasn't sure whether the updated build dependences require an FFe or
not. But yes, the changes are mostly bug fixes and improvements.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to shared-mime-info in
Ubuntu.
https://bugs.launchpad.net/bugs/1868927

Title:
  FFe: Sync shared-mime-info 1.15-1 (main) from Debian unstable (main)

Status in shared-mime-info package in Ubuntu:
  New

Bug description:
  Please sync shared-mime-info 1.15-1 (main) from Debian unstable (main)

  NEWS:
  https://gitlab.freedesktop.org/xdg/shared-mime-info/-/blob/master/NEWS

  shared-mime-info 1.15 (2019-30-10)
  * Add Kindle 8 eBook format
  * Fix some HTML files being detected as XML

  shared-mime-info 1.14 (2019-20-09)
  * Add mime-type for QCOW images
  * Fix matching SVG files in some circumstances (again)

  shared-mime-info 1.13.1 (2019-11-09)
  * Fix matching SVG files in some circumstances

  shared-mime-info 1.13 (2019-11-09)
  * Add code of conduct document
  * Use itstool and gettext to generate translations
  * Add content-tree type for OSTree USB repositories
  * Add match for MPEG-4 v1 videos
  * Adjust a lot of user readable mime-type descriptions
  * Fix WOFF/WOFF2 mime-types
  * Prefer text/html to XHTML for *.html files
  * Better magic for text/html files
  * Fix SVG magic for files embedded in HTML
  * Add *.sgd as a glob for Mega Drive ROMs

  Specification:
  - Mention that sub-class-of can be aliases

  Tools:
  - Enable Large File Support in update-mime-database

  Test suite:
  - Make test suite failures fatal
  - Add test for duplicate mime-types
  - Fix WarpScript test
  - Generate the specification in the CI, to avoid it becoming syntactically 
invalid

  shared-mime-info 1.12 (2019-17-01)
  * Fix build from tarball

  shared-mime-info 1.11 (2019-17-01)
  * Add mime-type for reStructuredText
  * Add mime-type for Groovy scripting language
  * Add mime-type for Gradle build tool
  * Add mime-type for Maven
  * Add mime-type for WarpScript source code
  * Add mime-type for zstd and tar.zst archives
  * Change the preferred suffix for image/jpeg from .jpeg to .jpg
  * Assign *.html to XHTML pages
  * Better detection for *.key files (Apple Keynote vs. GPG keys)
  * Give weight to one of the appimage patterns

  Tools:
  - Link to GitLab for contributions and bug reports
  - Loads of memory and file descriptor leak fixes

  Spec:
  - Clarify the availability of C character escape support

  Explanation of FeatureFreeze exception:
  New mime-type's and improvements to the existing ones useful for the life of 
the new LTS.
  The current version 1.10 has not been updated since September 2018.

  Changelog entries since current focal version 1.10-1:

  shared-mime-info (1.15-1) unstable; urgency=medium

    * New upstream release. Closes: #954669.
    * Update watch file for gitlab.freedesktop.org.
    * Update build-dependencies.
    * Remove ancient patches changing the magic database. Those should be
  reported upstream if they're still present.
    * Switch to debhelper-compat and bump compat to 12.
    * Don't hardcode full command path in postinst.

   -- Emilio Pozuelo Monfort   Tue, 24 Mar 2020
  16:58:21 +0100

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/shared-mime-info/+bug/1868927/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1867425] Re: Update tracker to 2.3.4 and tracker-miners to 2.3.3

2020-03-25 Thread Amr Ibrahim
** Changed in: tracker (Ubuntu)
   Status: New => Fix Released

** Changed in: tracker-miners (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to tracker in Ubuntu.
https://bugs.launchpad.net/bugs/1867425

Title:
  Update tracker to 2.3.4 and tracker-miners to 2.3.3

Status in tracker package in Ubuntu:
  Fix Released
Status in tracker-miners package in Ubuntu:
  Fix Released

Bug description:
  The 2.3.x branch receives bug fixes only since big, new development
  now goes to the master branch.

  tracker
  https://gitlab.gnome.org/GNOME/tracker/-/blob/tracker-2.3/NEWS

  NEW in 2.3.4 - 2020-03-10
  =
  * Brown paper bag release, fix NULL check.

  NEW in 2.3.3 - 2020-03-09
  =
  * Fix race condition during tracker-store shutdown maybe leading to warnings 
and missed writeback events.
  * Made fts:offsets stronger against corrupt FTS tables

  Translations: ja

  tracker-miners
  https://gitlab.gnome.org/GNOME/tracker-miners/-/blob/tracker-miners-2.3/NEWS

  NEW in 2.3.3 - 2020-03-09
  =
  * The secure sandbox for tracker-extract now permits clock_nanosleep() calls, 
fixing crashes on some systems.
  * Miners now set nice/scheduler priorities in a way that placates glib. The 
sched_setscheduler syscall is as a side effect also allowed by the 
tracker-extract sandbox.

  Translations: ja

  NEW in 2.3.2 - 2020-02-18
  =
  * Blocked parsing of image/x-dds image files, which were previously being 
passed to GStreamer and triggering system lockups for some people
  * Fixed incorrect MIME type for .raw images, which were previously being 
passed to GStreamer and triggering system lockups for some people
  * Improved how the MP3 extractor calculates durations of variable bitrate 
MP3s, which fixes incorrect durations being shown in GNOME Music.
  * Fixed a bug in the GStreamer writeback module.
  * Fix race condition that might leave tracker-miner-fs paused after a 
writeback operation.

  Translations: ms

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/tracker/+bug/1867425/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1865278] Re: Update to tracker 2.3.2 in Focal

2020-03-25 Thread Amr Ibrahim
** Changed in: tracker (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to tracker in Ubuntu.
https://bugs.launchpad.net/bugs/1865278

Title:
  Update to tracker 2.3.2 in Focal

Status in tracker package in Ubuntu:
  Fix Released
Status in tracker package in Debian:
  Unknown

Bug description:
  2.3.2 is a small bug-fix release.

  https://gitlab.gnome.org/GNOME/tracker/-/blob/tracker-2.3/NEWS

  NEW in 2.3.2 - 2020-02-18
  =

* Location info for photos is now inserted into the DB. It didn't
  work before as we failed to process SPARQL "blank nodes" correctly.
* Fix for oversensitive FTS5 index corruption detection

  Translations: ms

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/tracker/+bug/1865278/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868927] Re: FFe: Sync shared-mime-info 1.15-1 (main) from Debian unstable (main)

2020-03-25 Thread Amr Ibrahim
** Description changed:

  Please sync shared-mime-info 1.15-1 (main) from Debian unstable (main)
  
  NEWS:
  https://gitlab.freedesktop.org/xdg/shared-mime-info/-/blob/master/NEWS
  
  shared-mime-info 1.15 (2019-30-10)
  * Add Kindle 8 eBook format
  * Fix some HTML files being detected as XML
  
  shared-mime-info 1.14 (2019-20-09)
  * Add mime-type for QCOW images
  * Fix matching SVG files in some circumstances (again)
  
  shared-mime-info 1.13.1 (2019-11-09)
  * Fix matching SVG files in some circumstances
  
  shared-mime-info 1.13 (2019-11-09)
  * Add code of conduct document
  * Use itstool and gettext to generate translations
  * Add content-tree type for OSTree USB repositories
  * Add match for MPEG-4 v1 videos
  * Adjust a lot of user readable mime-type descriptions
  * Fix WOFF/WOFF2 mime-types
  * Prefer text/html to XHTML for *.html files
  * Better magic for text/html files
  * Fix SVG magic for files embedded in HTML
  * Add *.sgd as a glob for Mega Drive ROMs
  
  Specification:
  - Mention that sub-class-of can be aliases
  
  Tools:
  - Enable Large File Support in update-mime-database
  
  Test suite:
  - Make test suite failures fatal
  - Add test for duplicate mime-types
  - Fix WarpScript test
  - Generate the specification in the CI, to avoid it becoming syntactically 
invalid
  
  shared-mime-info 1.12 (2019-17-01)
  * Fix build from tarball
  
  shared-mime-info 1.11 (2019-17-01)
  * Add mime-type for reStructuredText
  * Add mime-type for Groovy scripting language
  * Add mime-type for Gradle build tool
  * Add mime-type for Maven
  * Add mime-type for WarpScript source code
  * Add mime-type for zstd and tar.zst archives
  * Change the preferred suffix for image/jpeg from .jpeg to .jpg
  * Assign *.html to XHTML pages
  * Better detection for *.key files (Apple Keynote vs. GPG keys)
  * Give weight to one of the appimage patterns
  
  Tools:
  - Link to GitLab for contributions and bug reports
  - Loads of memory and file descriptor leak fixes
  
  Spec:
  - Clarify the availability of C character escape support
  
- 
  Explanation of FeatureFreeze exception:
- New mime-type's and improvements to the existing ones useful for the life of 
the life of the new LTS.
+ New mime-type's and improvements to the existing ones useful for the life of 
the new LTS.
  The current version 1.10 has not been updated since September 2018.
  
  Changelog entries since current focal version 1.10-1:
  
  shared-mime-info (1.15-1) unstable; urgency=medium
  
-   * New upstream release. Closes: #954669.
-   * Update watch file for gitlab.freedesktop.org.
-   * Update build-dependencies.
-   * Remove ancient patches changing the magic database. Those should be
- reported upstream if they're still present.
-   * Switch to debhelper-compat and bump compat to 12.
-   * Don't hardcode full command path in postinst.
+   * New upstream release. Closes: #954669.
+   * Update watch file for gitlab.freedesktop.org.
+   * Update build-dependencies.
+   * Remove ancient patches changing the magic database. Those should be
+ reported upstream if they're still present.
+   * Switch to debhelper-compat and bump compat to 12.
+   * Don't hardcode full command path in postinst.
  
-  -- Emilio Pozuelo Monfort   Tue, 24 Mar 2020 16:58:21
+  -- Emilio Pozuelo Monfort   Tue, 24 Mar 2020 16:58:21
  +0100

** Tags added: focal upgrade-software-version

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to shared-mime-info in
Ubuntu.
https://bugs.launchpad.net/bugs/1868927

Title:
  FFe: Sync shared-mime-info 1.15-1 (main) from Debian unstable (main)

Status in shared-mime-info package in Ubuntu:
  New

Bug description:
  Please sync shared-mime-info 1.15-1 (main) from Debian unstable (main)

  NEWS:
  https://gitlab.freedesktop.org/xdg/shared-mime-info/-/blob/master/NEWS

  shared-mime-info 1.15 (2019-30-10)
  * Add Kindle 8 eBook format
  * Fix some HTML files being detected as XML

  shared-mime-info 1.14 (2019-20-09)
  * Add mime-type for QCOW images
  * Fix matching SVG files in some circumstances (again)

  shared-mime-info 1.13.1 (2019-11-09)
  * Fix matching SVG files in some circumstances

  shared-mime-info 1.13 (2019-11-09)
  * Add code of conduct document
  * Use itstool and gettext to generate translations
  * Add content-tree type for OSTree USB repositories
  * Add match for MPEG-4 v1 videos
  * Adjust a lot of user readable mime-type descriptions
  * Fix WOFF/WOFF2 mime-types
  * Prefer text/html to XHTML for *.html files
  * Better magic for text/html files
  * Fix SVG magic for files embedded in HTML
  * Add *.sgd as a glob for Mega Drive ROMs

  Specification:
  - Mention that sub-class-of can be aliases

  Tools:
  - Enable Large File Support in update-mime-database

  Test suite:
  - Make test suite failures fatal
  - Add test for duplicate mime-types
  - Fix WarpScript test
  - Generate the specification in the CI, to avoid 

[Touch-packages] [Bug 1868927] [NEW] FFe: Sync shared-mime-info 1.15-1 (main) from Debian unstable (main)

2020-03-25 Thread Amr Ibrahim
Public bug reported:

Please sync shared-mime-info 1.15-1 (main) from Debian unstable (main)

NEWS:
https://gitlab.freedesktop.org/xdg/shared-mime-info/-/blob/master/NEWS

shared-mime-info 1.15 (2019-30-10)
* Add Kindle 8 eBook format
* Fix some HTML files being detected as XML

shared-mime-info 1.14 (2019-20-09)
* Add mime-type for QCOW images
* Fix matching SVG files in some circumstances (again)

shared-mime-info 1.13.1 (2019-11-09)
* Fix matching SVG files in some circumstances

shared-mime-info 1.13 (2019-11-09)
* Add code of conduct document
* Use itstool and gettext to generate translations
* Add content-tree type for OSTree USB repositories
* Add match for MPEG-4 v1 videos
* Adjust a lot of user readable mime-type descriptions
* Fix WOFF/WOFF2 mime-types
* Prefer text/html to XHTML for *.html files
* Better magic for text/html files
* Fix SVG magic for files embedded in HTML
* Add *.sgd as a glob for Mega Drive ROMs

Specification:
- Mention that sub-class-of can be aliases

Tools:
- Enable Large File Support in update-mime-database

Test suite:
- Make test suite failures fatal
- Add test for duplicate mime-types
- Fix WarpScript test
- Generate the specification in the CI, to avoid it becoming syntactically 
invalid

shared-mime-info 1.12 (2019-17-01)
* Fix build from tarball

shared-mime-info 1.11 (2019-17-01)
* Add mime-type for reStructuredText
* Add mime-type for Groovy scripting language
* Add mime-type for Gradle build tool
* Add mime-type for Maven
* Add mime-type for WarpScript source code
* Add mime-type for zstd and tar.zst archives
* Change the preferred suffix for image/jpeg from .jpeg to .jpg
* Assign *.html to XHTML pages
* Better detection for *.key files (Apple Keynote vs. GPG keys)
* Give weight to one of the appimage patterns

Tools:
- Link to GitLab for contributions and bug reports
- Loads of memory and file descriptor leak fixes

Spec:
- Clarify the availability of C character escape support


Explanation of FeatureFreeze exception:
New mime-type's and improvements to the existing ones useful for the life of 
the life of the new LTS.
The current version 1.10 has not been updated since September 2018.

Changelog entries since current focal version 1.10-1:

shared-mime-info (1.15-1) unstable; urgency=medium

  * New upstream release. Closes: #954669.
  * Update watch file for gitlab.freedesktop.org.
  * Update build-dependencies.
  * Remove ancient patches changing the magic database. Those should be
reported upstream if they're still present.
  * Switch to debhelper-compat and bump compat to 12.
  * Don't hardcode full command path in postinst.

 -- Emilio Pozuelo Monfort   Tue, 24 Mar 2020 16:58:21
+0100

** Affects: shared-mime-info (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to shared-mime-info in
Ubuntu.
https://bugs.launchpad.net/bugs/1868927

Title:
  FFe: Sync shared-mime-info 1.15-1 (main) from Debian unstable (main)

Status in shared-mime-info package in Ubuntu:
  New

Bug description:
  Please sync shared-mime-info 1.15-1 (main) from Debian unstable (main)

  NEWS:
  https://gitlab.freedesktop.org/xdg/shared-mime-info/-/blob/master/NEWS

  shared-mime-info 1.15 (2019-30-10)
  * Add Kindle 8 eBook format
  * Fix some HTML files being detected as XML

  shared-mime-info 1.14 (2019-20-09)
  * Add mime-type for QCOW images
  * Fix matching SVG files in some circumstances (again)

  shared-mime-info 1.13.1 (2019-11-09)
  * Fix matching SVG files in some circumstances

  shared-mime-info 1.13 (2019-11-09)
  * Add code of conduct document
  * Use itstool and gettext to generate translations
  * Add content-tree type for OSTree USB repositories
  * Add match for MPEG-4 v1 videos
  * Adjust a lot of user readable mime-type descriptions
  * Fix WOFF/WOFF2 mime-types
  * Prefer text/html to XHTML for *.html files
  * Better magic for text/html files
  * Fix SVG magic for files embedded in HTML
  * Add *.sgd as a glob for Mega Drive ROMs

  Specification:
  - Mention that sub-class-of can be aliases

  Tools:
  - Enable Large File Support in update-mime-database

  Test suite:
  - Make test suite failures fatal
  - Add test for duplicate mime-types
  - Fix WarpScript test
  - Generate the specification in the CI, to avoid it becoming syntactically 
invalid

  shared-mime-info 1.12 (2019-17-01)
  * Fix build from tarball

  shared-mime-info 1.11 (2019-17-01)
  * Add mime-type for reStructuredText
  * Add mime-type for Groovy scripting language
  * Add mime-type for Gradle build tool
  * Add mime-type for Maven
  * Add mime-type for WarpScript source code
  * Add mime-type for zstd and tar.zst archives
  * Change the preferred suffix for image/jpeg from .jpeg to .jpg
  * Assign *.html to XHTML pages
  * Better detection for *.key files (Apple Keynote vs. GPG keys)
  * Give weight to one of the appimage patterns

  Tools:
  - Link to GitLab for 

[Touch-packages] [Bug 1868335] Re: Sync colord 1.4.4-2 (main) from Debian unstable (main)

2020-03-22 Thread Amr Ibrahim
** Changed in: colord (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to colord in Ubuntu.
https://bugs.launchpad.net/bugs/1868335

Title:
  Sync colord 1.4.4-2 (main) from Debian unstable (main)

Status in colord package in Ubuntu:
  Fix Released

Bug description:
  Please sync colord 1.4.4-2 (main) from Debian unstable (main)

  Explanation of the Ubuntu delta and why it can be dropped:
* No-change rebuild with fixed binutils on arm64.
* Omit colord-sensor-argyll on i386.
  The change to omit colord-sensor-argyll on i386 was adopted in Debian.

  Changelog entries since current focal version 1.4.4-1ubuntu2:

  colord (1.4.4-2) unstable; urgency=medium

* Team upload.
* Bump debhelper to 12 and install the daemons in /usr/libexec
* debian/rules: Explicitly disable systemd and udev on non-linux 
architectures
* debian/control: Bump Standards-Version to 4.5.0 (no further changes)
* debian/control: Drop docbook-utils from build-dep, this doesn't seems
  necessary and add xsltproc instead
* debian/control: Mark the -dev and gir packages as Multi-arch: same
* Omit colord-sensor-argyll on Ubuntu/i386.
  Thanks to Steve Langasek  (Closes: #948540)
* debian/control: Set Rules-Requires-Root: no
* debian/watch: Use https:// instead of http://
* d/p/tests-Make-the-build-reproductible.patch: Make the build reproductible
* debian/gbp.conf: Set upstream-vcs-tag and make sure patches are not 
numbered

   -- Laurent Bigonville   Fri, 20 Mar 2020 15:50:36
  +0100

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/colord/+bug/1868335/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1867390] Re: Update libarchive to 3.4.2

2020-03-20 Thread Amr Ibrahim
** Information type changed from Public to Public Security

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libarchive in Ubuntu.
https://bugs.launchpad.net/bugs/1867390

Title:
  Update libarchive to 3.4.2

Status in libarchive package in Ubuntu:
  Triaged
Status in libarchive package in Debian:
  Unknown

Bug description:
  Please update libarchive to 3.4.2, also fixes LP: #1814109.

  The bug and security fixes outweighs the new features added in 3.4.1
  and 3.4.2.

  https://github.com/libarchive/libarchive/releases

  Libarchive 3.4.2 is a feature and security release.

  New features:

  support for atomic file extraction (bsdtar -x --safe-writes) (#1289)
  support for mbed TLS (PolarSSL) (#1301)

  Important bugfixes:

  security fixes in RAR5 reader (#1280 #1326)
  compression buffer fix in XAR writer (#1317)
  fix uname and gname longer than 32 characters in PAX writer (#1319)
  fix segfault when archiving hard links in ISO9660 and XAR writers (#1325)
  fix support for extracting 7z archive entries with Delta filter (fixes LP: 
#1814109) (#987)

  Libarchive 3.4.1 is a feature and security release.

  New features:

  Unicode filename support for reading lha/lzh archives
  New pax write option "xattrhdr"

  Important bugfixes:

  security fixes in wide string processing (#1276 #1298)
  security fixes in RAR5 reader (#1212 #1217 #1296)
  security fixes and optimizations to write filter logic (#351)
  security fix related to use of readlink(2) (1dae5a5)
  sparse file handling fixes (#1218 #1260)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libarchive/+bug/1867390/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1867390] Re: Update libarchive to 3.4.2

2020-03-16 Thread Amr Ibrahim
** Description changed:

- Please update libarchive to 3.4.2.
+ Please update libarchive to 3.4.2, also fixes LP: #1814109.
+ 
+ The bug and security fixes outweighs the new features added in 3.4.1 and
+ 3.4.2.
  
  https://github.com/libarchive/libarchive/releases
  
  Libarchive 3.4.2 is a feature and security release.
  
  New features:
  
  support for atomic file extraction (bsdtar -x --safe-writes) (#1289)
  support for mbed TLS (PolarSSL) (#1301)
  
  Important bugfixes:
  
  security fixes in RAR5 reader (#1280 #1326)
  compression buffer fix in XAR writer (#1317)
  fix uname and gname longer than 32 characters in PAX writer (#1319)
  fix segfault when archiving hard links in ISO9660 and XAR writers (#1325)
- fix support for extracting 7z archive entries with Delta filter (#987)
- 
+ fix support for extracting 7z archive entries with Delta filter (fixes LP: 
#1814109) (#987)
  
  Libarchive 3.4.1 is a feature and security release.
  
  New features:
  
  Unicode filename support for reading lha/lzh archives
  New pax write option "xattrhdr"
  
  Important bugfixes:
  
  security fixes in wide string processing (#1276 #1298)
  security fixes in RAR5 reader (#1212 #1217 #1296)
  security fixes and optimizations to write filter logic (#351)
  security fix related to use of readlink(2) (1dae5a5)
  sparse file handling fixes (#1218 #1260)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libarchive in Ubuntu.
https://bugs.launchpad.net/bugs/1867390

Title:
  Update libarchive to 3.4.2

Status in libarchive package in Ubuntu:
  Triaged
Status in libarchive package in Debian:
  Unknown

Bug description:
  Please update libarchive to 3.4.2, also fixes LP: #1814109.

  The bug and security fixes outweighs the new features added in 3.4.1
  and 3.4.2.

  https://github.com/libarchive/libarchive/releases

  Libarchive 3.4.2 is a feature and security release.

  New features:

  support for atomic file extraction (bsdtar -x --safe-writes) (#1289)
  support for mbed TLS (PolarSSL) (#1301)

  Important bugfixes:

  security fixes in RAR5 reader (#1280 #1326)
  compression buffer fix in XAR writer (#1317)
  fix uname and gname longer than 32 characters in PAX writer (#1319)
  fix segfault when archiving hard links in ISO9660 and XAR writers (#1325)
  fix support for extracting 7z archive entries with Delta filter (fixes LP: 
#1814109) (#987)

  Libarchive 3.4.1 is a feature and security release.

  New features:

  Unicode filename support for reading lha/lzh archives
  New pax write option "xattrhdr"

  Important bugfixes:

  security fixes in wide string processing (#1276 #1298)
  security fixes in RAR5 reader (#1212 #1217 #1296)
  security fixes and optimizations to write filter logic (#351)
  security fix related to use of readlink(2) (1dae5a5)
  sparse file handling fixes (#1218 #1260)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libarchive/+bug/1867390/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1814109] Re: Nautilus corrupts 7z archive files when extracting via 'Extract here' context menu

2020-03-16 Thread Amr Ibrahim
The fix is in 3.4.2 update request LP: #1867390.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libarchive in Ubuntu.
https://bugs.launchpad.net/bugs/1814109

Title:
  Nautilus corrupts 7z archive files when extracting via 'Extract here'
  context menu

Status in libarchive package in Ubuntu:
  Triaged
Status in libarchive source package in Disco:
  Triaged

Bug description:
  Nautilus corrupts 7z archive files when extracting via 'Extract here' context 
menu.
  Extractions completes without errors, but the files are corrupted (mangled 
bytes, wrong size).
  This does happen only when extracting with 'Extract here' context menu action.
  Using 7z or p7zip via command line or opening the archive via file-roller and 
then drag
  single files or directory to a folder works well.
  This only happens with this particular archive, others 7z archives are 
extracted correctly.

  Original 7z archive:
  https://drive.google.com/open?id=1eZJm1ST3P-52tFSvHXbUn9-WSe_B3Ag9

  Re-zipped corrupted archive here:
  https://drive.google.com/open?id=1N--99RuWdmg6oUGrAz7pLoRpuJOIBEE5

  ProblemType: Bug
  DistroRelease: Ubuntu 18.10
  Package: nautilus 1:3.26.4-0ubuntu7.1
  ProcVersionSignature: Ubuntu 4.18.0-13.14-generic 4.18.17
  Uname: Linux 4.18.0-13-generic x86_64
  ApportVersion: 2.20.10-0ubuntu13.1
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Jan 31 15:03:45 2019
  GsettingsChanges:
   b'org.gnome.nautilus.window-state' b'sidebar-width' b'222'
   b'org.gnome.nautilus.window-state' b'geometry' b"'1133x703+51+273'"
   b'org.gnome.nautilus.desktop' b'trash-icon-visible' b'false'
   b'org.gnome.nautilus.desktop' b'volumes-visible' b'false'
  InstallationDate: Installed on 2018-05-31 (245 days ago)
  InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
  SourcePackage: nautilus
  UpgradeStatus: Upgraded to cosmic on 2018-10-20 (103 days ago)
  usr_lib_nautilus:

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libarchive/+bug/1814109/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1841783] Re: Update to 1.2.0?

2020-03-15 Thread Amr Ibrahim
** Description changed:

- The source was split in rc2, Debian didn't follow the change and we are
+ The source was split in rc2, Debian didn't follow the change, and we are
  in sync, do we want to update?
+ 
+ Speex and SpeexDSP
+ 
+ https://git.xiph.org/?p=speex.git;a=summary
+ 
+ https://git.xiph.org/?p=speexdsp.git;a=summary

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to speex in Ubuntu.
https://bugs.launchpad.net/bugs/1841783

Title:
  Update to 1.2.0?

Status in speex package in Ubuntu:
  Triaged
Status in speex package in Debian:
  New

Bug description:
  The source was split in rc2, Debian didn't follow the change, and we
  are in sync, do we want to update?

  Speex and SpeexDSP

  https://git.xiph.org/?p=speex.git;a=summary

  https://git.xiph.org/?p=speexdsp.git;a=summary

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/speex/+bug/1841783/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1867425] [NEW] Update tracker to 2.3.4 and tracker-miners to 2.3.3

2020-03-14 Thread Amr Ibrahim
Public bug reported:

The 2.3.x branch receives bug fixes only since big, new development now
goes to the master branch.

tracker
https://gitlab.gnome.org/GNOME/tracker/-/blob/tracker-2.3/NEWS

NEW in 2.3.4 - 2020-03-10
=
* Brown paper bag release, fix NULL check.

NEW in 2.3.3 - 2020-03-09
=
* Fix race condition during tracker-store shutdown maybe leading to warnings 
and missed writeback events.
* Made fts:offsets stronger against corrupt FTS tables

Translations: ja

tracker-miners
https://gitlab.gnome.org/GNOME/tracker-miners/-/blob/tracker-miners-2.3/NEWS

NEW in 2.3.3 - 2020-03-09
=
* The secure sandbox for tracker-extract now permits clock_nanosleep() calls, 
fixing crashes on some systems.
* Miners now set nice/scheduler priorities in a way that placates glib. The 
sched_setscheduler syscall is as a side effect also allowed by the 
tracker-extract sandbox.

Translations: ja

NEW in 2.3.2 - 2020-02-18
=
* Blocked parsing of image/x-dds image files, which were previously being 
passed to GStreamer and triggering system lockups for some people
* Fixed incorrect MIME type for .raw images, which were previously being passed 
to GStreamer and triggering system lockups for some people
* Improved how the MP3 extractor calculates durations of variable bitrate MP3s, 
which fixes incorrect durations being shown in GNOME Music.
* Fixed a bug in the GStreamer writeback module.
* Fix race condition that might leave tracker-miner-fs paused after a writeback 
operation.

Translations: ms

** Affects: tracker (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: tracker-miners (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: focal upgrade-software-version

** Also affects: tracker-miners (Ubuntu)
   Importance: Undecided
   Status: New

** Description changed:

- The 2.3.x branch receives bug-fixes only since big, new development now
+ The 2.3.x branch receives bug fixes only since big, new development now
  goes to the master branch.
  
  tracker
  https://gitlab.gnome.org/GNOME/tracker/-/blob/tracker-2.3/NEWS
  
  NEW in 2.3.4 - 2020-03-10
  =
-   * Brown paper bag release, fix NULL check.
+ * Brown paper bag release, fix NULL check.
  
  NEW in 2.3.3 - 2020-03-09
  =
-   * Fix race condition during tracker-store shutdown maybe leading to
- warnings and missed writeback events.
-   * Made fts:offsets stronger against corrupt FTS tables
+ * Fix race condition during tracker-store shutdown maybe leading to warnings 
and missed writeback events.
+ * Made fts:offsets stronger against corrupt FTS tables
  
  Translations: ja
- 
  
  tracker-miners
  https://gitlab.gnome.org/GNOME/tracker-miners/-/blob/tracker-miners-2.3/NEWS
  
  NEW in 2.3.3 - 2020-03-09
  =
- 
-   * The secure sandbox for tracker-extract now permits clock_nanosleep() 
calls,
- fixing crashes on some systems.
-   * Miners now set nice/scheduler priorities in a way that placates glib. The
- sched_setscheduler syscall is as a side effect also allowed by the
- tracker-extract sandbox.
+ * The secure sandbox for tracker-extract now permits clock_nanosleep() calls, 
fixing crashes on some systems.
+ * Miners now set nice/scheduler priorities in a way that placates glib. The 
sched_setscheduler syscall is as a side effect also allowed by the 
tracker-extract sandbox.
  
  Translations: ja
  
  NEW in 2.3.2 - 2020-02-18
  =
- 
-   * Blocked parsing of image/x-dds image files, which were previously
- being passed to GStreamer and triggering system lockups for some people
-   * Fixed incorrect MIME type for .raw images, which were previously
- being passed to GStreamer and triggering system lockups for some people
-   * Improved how the MP3 extractor calculates durations of variable bitrate
- MP3s, which fixes incorrect durations being shown in GNOME Music.
-   * Fixed a bug in the GStreamer writeback module.
-   * Fix race condition that might leave tracker-miner-fs paused after a
- writeback operation.
+ * Blocked parsing of image/x-dds image files, which were previously being 
passed to GStreamer and triggering system lockups for some people
+ * Fixed incorrect MIME type for .raw images, which were previously being 
passed to GStreamer and triggering system lockups for some people
+ * Improved how the MP3 extractor calculates durations of variable bitrate 
MP3s, which fixes incorrect durations being shown in GNOME Music.
+ * Fixed a bug in the GStreamer writeback module.
+ * Fix race condition that might leave tracker-miner-fs paused after a 
writeback operation.
  
  Translations: ms

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to tracker in Ubuntu.
https://bugs.launchpad.net/bugs/1867425

Title:
  Update tracker to 2.3.4 

[Touch-packages] [Bug 1867390] [NEW] Update libarchive to 3.4.2

2020-03-13 Thread Amr Ibrahim
Public bug reported:

Please update libarchive to 3.4.2.

https://github.com/libarchive/libarchive/releases

Libarchive 3.4.2 is a feature and security release.

New features:

support for atomic file extraction (bsdtar -x --safe-writes) (#1289)
support for mbed TLS (PolarSSL) (#1301)

Important bugfixes:

security fixes in RAR5 reader (#1280 #1326)
compression buffer fix in XAR writer (#1317)
fix uname and gname longer than 32 characters in PAX writer (#1319)
fix segfault when archiving hard links in ISO9660 and XAR writers (#1325)
fix support for extracting 7z archive entries with Delta filter (#987)


Libarchive 3.4.1 is a feature and security release.

New features:

Unicode filename support for reading lha/lzh archives
New pax write option "xattrhdr"

Important bugfixes:

security fixes in wide string processing (#1276 #1298)
security fixes in RAR5 reader (#1212 #1217 #1296)
security fixes and optimizations to write filter logic (#351)
security fix related to use of readlink(2) (1dae5a5)
sparse file handling fixes (#1218 #1260)

** Affects: libarchive (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: focal upgrade-software-version

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libarchive in Ubuntu.
https://bugs.launchpad.net/bugs/1867390

Title:
  Update libarchive to 3.4.2

Status in libarchive package in Ubuntu:
  New

Bug description:
  Please update libarchive to 3.4.2.

  https://github.com/libarchive/libarchive/releases

  Libarchive 3.4.2 is a feature and security release.

  New features:

  support for atomic file extraction (bsdtar -x --safe-writes) (#1289)
  support for mbed TLS (PolarSSL) (#1301)

  Important bugfixes:

  security fixes in RAR5 reader (#1280 #1326)
  compression buffer fix in XAR writer (#1317)
  fix uname and gname longer than 32 characters in PAX writer (#1319)
  fix segfault when archiving hard links in ISO9660 and XAR writers (#1325)
  fix support for extracting 7z archive entries with Delta filter (#987)

  
  Libarchive 3.4.1 is a feature and security release.

  New features:

  Unicode filename support for reading lha/lzh archives
  New pax write option "xattrhdr"

  Important bugfixes:

  security fixes in wide string processing (#1276 #1298)
  security fixes in RAR5 reader (#1212 #1217 #1296)
  security fixes and optimizations to write filter logic (#351)
  security fix related to use of readlink(2) (1dae5a5)
  sparse file handling fixes (#1218 #1260)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libarchive/+bug/1867390/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1865351] Re: Update to poppler 0.86.1 in Focal

2020-03-04 Thread Amr Ibrahim
** Changed in: poppler (Ubuntu)
   Status: Incomplete => New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to poppler in Ubuntu.
https://bugs.launchpad.net/bugs/1865351

Title:
  Update to poppler 0.86.1 in Focal

Status in poppler package in Ubuntu:
  New

Bug description:
  Please update to poppler 0.86.1 in Focal

  https://gitlab.freedesktop.org/poppler/poppler/-/blob/master/NEWS

  Release 0.86.1:
  core:
  * Fix regression in Browse Link handling
  * Internal code improvements

  Release 0.86.0:
  core:
  * Fix link content exfiltration attack
  * Splash: Implement gouraudTriangleShadedFill for some non parametrized 
shadings
  * Fix case unsensitive search for Old Hungarian, Warang Citi, Medefaidrin and 
Adlam
  * Internal code improvements

  glib:
  * Automatic handle of page's cropbox on annots. Issue #129
  * Fix memory leak if poppler_document_new_from_file fails
  * Minor speed optimization on poppler_page_get_annot_mapping

  utils:
  * pdfdetach: add 'savefile' option
  * pdftoppm/pdftocairo: Fix more odd/even mismatch

  qt5:
  * Fix loading from iodevice

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/poppler/+bug/1865351/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1865351] Re: Update to poppler 0.86.0 in Focal

2020-03-02 Thread Amr Ibrahim
Poppler 0.86.1 has nice fixes in the glib backend, which is used by Evince, as 
it is has this MR
https://gitlab.freedesktop.org/poppler/poppler/-/merge_requests/377
which fixes this 3 year old bug
https://gitlab.freedesktop.org/poppler/poppler/issues/129
https://gitlab.gnome.org/GNOME/evince/issues/1280

And it fixes a leak in the glib backend (which is considered under-
maintained by upstream).

https://gitlab.freedesktop.org/poppler/poppler/-/blob/master/NEWS
Release 0.86.1:
core:
* Fix regression in Browse Link handling
* Internal code improvements


** Bug watch added: gitlab.freedesktop.org/poppler/poppler/issues #129
   https://gitlab.freedesktop.org/poppler/poppler/issues/129

** Bug watch added: gitlab.gnome.org/GNOME/evince/issues #1280
   https://gitlab.gnome.org/GNOME/evince/issues/1280

** Summary changed:

- Update to poppler 0.86.0 in Focal
+ Update to poppler 0.86.1 in Focal

** Description changed:

- Please update to poppler 0.86.0 in Focal
+ Please update to poppler 0.86.1 in Focal
+ 
+ https://gitlab.freedesktop.org/poppler/poppler/-/blob/master/NEWS
+ 
+ Release 0.86.1:
+ core:
+ * Fix regression in Browse Link handling
+ * Internal code improvements
  
  Release 0.86.0:
  core:
  * Fix link content exfiltration attack
  * Splash: Implement gouraudTriangleShadedFill for some non parametrized 
shadings
  * Fix case unsensitive search for Old Hungarian, Warang Citi, Medefaidrin and 
Adlam
  * Internal code improvements
  
  glib:
  * Automatic handle of page's cropbox on annots. Issue #129
  * Fix memory leak if poppler_document_new_from_file fails
  * Minor speed optimization on poppler_page_get_annot_mapping
  
  utils:
  * pdfdetach: add 'savefile' option
  * pdftoppm/pdftocairo: Fix more odd/even mismatch
  
  qt5:
  * Fix loading from iodevice

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to poppler in Ubuntu.
https://bugs.launchpad.net/bugs/1865351

Title:
  Update to poppler 0.86.1 in Focal

Status in poppler package in Ubuntu:
  Incomplete

Bug description:
  Please update to poppler 0.86.1 in Focal

  https://gitlab.freedesktop.org/poppler/poppler/-/blob/master/NEWS

  Release 0.86.1:
  core:
  * Fix regression in Browse Link handling
  * Internal code improvements

  Release 0.86.0:
  core:
  * Fix link content exfiltration attack
  * Splash: Implement gouraudTriangleShadedFill for some non parametrized 
shadings
  * Fix case unsensitive search for Old Hungarian, Warang Citi, Medefaidrin and 
Adlam
  * Internal code improvements

  glib:
  * Automatic handle of page's cropbox on annots. Issue #129
  * Fix memory leak if poppler_document_new_from_file fails
  * Minor speed optimization on poppler_page_get_annot_mapping

  utils:
  * pdfdetach: add 'savefile' option
  * pdftoppm/pdftocairo: Fix more odd/even mismatch

  qt5:
  * Fix loading from iodevice

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/poppler/+bug/1865351/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1865351] [NEW] Update to poppler 0.86.0 in Focal

2020-03-01 Thread Amr Ibrahim
Public bug reported:

Please update to poppler 0.86.0 in Focal

Release 0.86.0:
core:
* Fix link content exfiltration attack
* Splash: Implement gouraudTriangleShadedFill for some non parametrized shadings
* Fix case unsensitive search for Old Hungarian, Warang Citi, Medefaidrin and 
Adlam
* Internal code improvements

glib:
* Automatic handle of page's cropbox on annots. Issue #129
* Fix memory leak if poppler_document_new_from_file fails
* Minor speed optimization on poppler_page_get_annot_mapping

utils:
* pdfdetach: add 'savefile' option
* pdftoppm/pdftocairo: Fix more odd/even mismatch

qt5:
* Fix loading from iodevice

** Affects: poppler (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: focal upgrade-software-version

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to poppler in Ubuntu.
https://bugs.launchpad.net/bugs/1865351

Title:
  Update to poppler 0.86.0 in Focal

Status in poppler package in Ubuntu:
  New

Bug description:
  Please update to poppler 0.86.0 in Focal

  Release 0.86.0:
  core:
  * Fix link content exfiltration attack
  * Splash: Implement gouraudTriangleShadedFill for some non parametrized 
shadings
  * Fix case unsensitive search for Old Hungarian, Warang Citi, Medefaidrin and 
Adlam
  * Internal code improvements

  glib:
  * Automatic handle of page's cropbox on annots. Issue #129
  * Fix memory leak if poppler_document_new_from_file fails
  * Minor speed optimization on poppler_page_get_annot_mapping

  utils:
  * pdfdetach: add 'savefile' option
  * pdftoppm/pdftocairo: Fix more odd/even mismatch

  qt5:
  * Fix loading from iodevice

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/poppler/+bug/1865351/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1865278] Re: Update to tracker 2.3.2 in Focal

2020-02-29 Thread Amr Ibrahim
** Bug watch added: Debian Bug tracker #952789
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=952789

** Also affects: tracker (Debian) via
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=952789
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to tracker in Ubuntu.
https://bugs.launchpad.net/bugs/1865278

Title:
  Update to tracker 2.3.2 in Focal

Status in tracker package in Ubuntu:
  New
Status in tracker package in Debian:
  Unknown

Bug description:
  2.3.2 is a small bug-fix release.

  https://gitlab.gnome.org/GNOME/tracker/-/blob/tracker-2.3/NEWS

  NEW in 2.3.2 - 2020-02-18
  =

* Location info for photos is now inserted into the DB. It didn't
  work before as we failed to process SPARQL "blank nodes" correctly.
* Fix for oversensitive FTS5 index corruption detection

  Translations: ms

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/tracker/+bug/1865278/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1865278] [NEW] Update to tracker 2.3.2 in Focal

2020-02-29 Thread Amr Ibrahim
Public bug reported:

2.3.2 is a small bug-fix release.

https://gitlab.gnome.org/GNOME/tracker/-/blob/tracker-2.3/NEWS

NEW in 2.3.2 - 2020-02-18
=

  * Location info for photos is now inserted into the DB. It didn't
work before as we failed to process SPARQL "blank nodes" correctly.
  * Fix for oversensitive FTS5 index corruption detection

Translations: ms

** Affects: tracker (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: focal upgrade-software-version

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to tracker in Ubuntu.
https://bugs.launchpad.net/bugs/1865278

Title:
  Update to tracker 2.3.2 in Focal

Status in tracker package in Ubuntu:
  New

Bug description:
  2.3.2 is a small bug-fix release.

  https://gitlab.gnome.org/GNOME/tracker/-/blob/tracker-2.3/NEWS

  NEW in 2.3.2 - 2020-02-18
  =

* Location info for photos is now inserted into the DB. It didn't
  work before as we failed to process SPARQL "blank nodes" correctly.
* Fix for oversensitive FTS5 index corruption detection

  Translations: ms

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/tracker/+bug/1865278/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1760190] Re: Useless icon themes installed

2020-02-25 Thread Amr Ibrahim
Is this issue going anywhere?

** Tags added: focal

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-themes in Ubuntu.
https://bugs.launchpad.net/bugs/1760190

Title:
  Useless icon themes installed

Status in humanity-icon-theme package in Ubuntu:
  Confirmed
Status in ubuntu-themes package in Ubuntu:
  Confirmed

Bug description:
  Humanity-Dark
  LoginIcons
  Ubuntu-mono-dark
  Ubuntu-mono-light
  Hicolor

  if i switch icons from these icons nothing happening.
  I think these icons are no longer used in ubuntu.

  And DMZ-Black, DMZ-White listing in icons

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/humanity-icon-theme/+bug/1760190/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1841783] Re: Update to 1.2.0?

2020-02-14 Thread Amr Ibrahim
The Debian maintainer has not touched the package since 2014. Maybe
Ubuntu should go ahead and update.

** Tags added: focal

** Bug watch added: Debian Bug tracker #949717
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=949717

** Also affects: speex (Debian) via
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=949717
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to speex in Ubuntu.
https://bugs.launchpad.net/bugs/1841783

Title:
  Update to 1.2.0?

Status in speex package in Ubuntu:
  Triaged
Status in speex package in Debian:
  Unknown

Bug description:
  The source was split in rc2, Debian didn't follow the change and we
  are in sync, do we want to update?

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/speex/+bug/1841783/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1836444] Re: Merge qt4-x11 4:4.8.7+dfsg-18 (universe) from Debian unstable (main)

2020-01-28 Thread Amr Ibrahim
I know that Qt4 is practically dead, however, it would be nice to merge
with Debian to get the vulnerability fixes in 4:4.8.7+dfsg-18.

** Tags added: focal

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to qt4-x11 in Ubuntu.
https://bugs.launchpad.net/bugs/1836444

Title:
  Merge qt4-x11 4:4.8.7+dfsg-18 (universe) from Debian unstable (main)

Status in qt4-x11 package in Ubuntu:
  New

Bug description:
  Please merge qt4-x11 4:4.8.7+dfsg-18 (universe) from Debian unstable
  (main)

  I cannot work on this merge myself. I filed this bug as a reference.

  Explanation of the Ubuntu delta:
* Merge with Debian since qtchooser has versioned Breaks. (LP: #1584654)
* Add one more macro to qt4-x11 moc to fix failing to parse BOOST_JOIN.
* No-change rebuild for libpng soname change.
* Rebuild against libmysqlclient20.
* Merge with Debian; remaining changes:
  - Pass list-missing to dh_install instead of fail-missing, since we don't
install the QtWebkit headers
  - Make sure libqt4-opengl-dev depends on gles libs for armel and armhf
  - Do not package ibase/firebird and sqlite2 package
+ remove from debian/control
+ libqt4-sql doesn't recommend libqt4-sql-ibase and libqt4-sql-sqlite2
  - Also exclude webkit examples from dh_shlibdeps
  - Do not build libqt4-phonon, disable in debian/control
  - Add debian/Trolltech.conf and install it in libqtcore4.install
  - Build with -no-neon on armel and armhf
  - Build with -no-javascript-jit on arm64
  - Add patches:
+ kubuntu_10_ibus_input_method.diff
+ kubuntu_12_fix_stack_protector.diff
+ kubuntu_28_xi2.1.patch
+ kubuntu_30_translucent_drag_pixmap.diff
+ kubuntu_37_cups_settings.diff
+ kubuntu_39_fix_medium_font.diff
+ kubuntu_40_disable_neon.patch
+ kubuntu_43_no_meego_helper.patch
+ kubuntu_93_disable_overlay_scrollbars.diff
+ kubuntu_94_xinput_valuators_fix.diff
+ kubuntu_95_qt_disable_bounce.diff
+ kubuntu_97_a11y_qt_and_qml_backport.diff
+ kubuntu_98_a11y_fix_crash.diff
+ kubuntu_glib-honor-ExcludeSocketNotifiers-flag.diff
+ kubuntu_qclipboard_delay.diff
+ kubuntu_qclipboard_fix_recursive.diff
  - Drop powerpc_designer_gstabs.diff, it breaks powerpc
* Update symbols files.

  Changelog entries since current eoan version 4:4.8.7+dfsg-7ubuntu1:

  qt4-x11 (4:4.8.7+dfsg-18) unstable; urgency=medium

* Team upload.

[ Edward Betts ]
* debian/NEWS: Replace UNRELEASED with unstable.

[ Alexander Volkov ]
* Backport some vulnerability fixes from Qt 5 (closes: #923003).
  - CVE-2018-15518: double free or corruption in QXmlStreamReader.
  - CVE-2018-19869: Qt Svg crash when parsing malformed url reference.
  - CVE-2018-19870: NULL pointer dereference in QGifHandler.
  - CVE-2018-19871: QTgaFile CPU exhaustion.
  - CVE-2018-19872: crash when parsing a malformed PPM image.
  - CVE-2018-19873: QBmpHandler segfault on malformed BMP file.

   -- Dmitry Shachnev   Fri, 12 Apr 2019 23:10:28
  +0300

  qt4-x11 (4:4.8.7+dfsg-17) unstable; urgency=medium

* Add fix-build-icu59.patch from OpenSuse. Fixes build with icu59
 (Closes: #898542). Thanks John Paul Adrian Glaubitz for digging the
 patch!
* Put the source package in section oldlibs. We do not expect new
  developments with qt4-x11.
* Update Vcs-[Git Browser] to the new location in salsa.debian.org.

   -- Lisandro Damián Nicanor Pérez Meyer   Tue, 15
  May 2018 13:24:10 -0300

  qt4-x11 (4:4.8.7+dfsg-16) unstable; urgency=medium

* Update symbols files with buildds' logs.
* Add a patch by Manuel A. Fernandez Montecelo to provide riscv64 support
 (Closes: #897667).

   -- Lisandro Damián Nicanor Pérez Meyer   Fri, 04
  May 2018 22:53:17 -0300

  qt4-x11 (4:4.8.7+dfsg-15) unstable; urgency=medium

* Actually upload it to unstable.

   -- Lisandro Damián Nicanor Pérez Meyer   Wed, 18
  Apr 2018 17:45:31 -0300

  qt4-x11 (4:4.8.7+dfsg-14) experimental; urgency=medium

* Update symbols files with buildds' logs.
* Add NEWS.Debian to explicitely tell users of the OpenSSL 1.1 patch.

   -- Lisandro Damián Nicanor Pérez Meyer   Wed, 18
  Apr 2018 16:30:10 -0300

  qt4-x11 (4:4.8.7+dfsg-13) experimental; urgency=medium

* Add extra patch from Dmitry Eremin-Solenikov to make Qt4 work with
  OpenSSL 1.1 (Closes: #873275).
* Recommend default-libmysqlclient-dev instead of libmysqlclient-dev.

   -- Lisandro Damián Nicanor Pérez Meyer   Fri, 10
  Nov 2017 15:36:11 -0300

  qt4-x11 (4:4.8.7+dfsg-12) experimental; urgency=medium

* Add openssl_1.1.patch to let Qt4 use OpenSSL 1.1 (Closes: #828522).
  - Switch libssl-1.0-dev to libssl-dev to use OpenSSL 1.1.
* Update symbols files with current build log.

   -- Lisandro Damián Nicanor Pérez Meyer   

[Touch-packages] [Bug 1853768] Re: Qt apps, like kid3-qt, which uses legacy icons "document-*.png", show them as normal document icon under Yaru theme

2019-12-27 Thread Amr Ibrahim
Just a bit of context:
Symbolic action icons are the de-facto in a GNOME environment, full-colour 
icons are legacy, that's why Yaru theme didn't originally have any "legacy" 
full-colour action icons as its original author refused to do so.
The recent addition of the coloured document-*.png icons in Yaru is just a 
workaround for Qt apps in order not to appear broken under Yaru. And not all 
full-colour icons will be in Yaru, only the needed document-*.png ones.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to qtbase-opensource-src in
Ubuntu.
https://bugs.launchpad.net/bugs/1853768

Title:
  Qt apps, like kid3-qt, which uses legacy icons "document-*.png", show
  them as normal document icon under Yaru theme

Status in Yaru Theme:
  Fix Released
Status in qtbase-opensource-src package in Ubuntu:
  Confirmed
Status in yaru-theme package in Ubuntu:
  Confirmed

Bug description:
  Qt apps, like kid3-qt, which uses these legacy icons:

  document-open.png
  document-open-recent.png
  document-save.png
  document-save-as.png
  document-revert.png
  document-import.png
  document-export.png

  The icons are all shown as the same normal document icon under Yaru.

  Qt apps only have a problem with legacy icons starting with
  "document-*" and all other legacy icons are inherited from Humanity
  under Yaru.

  Is there a general solution to force Qt apps to choose the closest
  icon name from Yaru or Humanity?

  Should this bug be issued against upstream Qt?

To manage notifications about this bug go to:
https://bugs.launchpad.net/yaru/+bug/1853768/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1853768] Re: Qt apps, like kid3-qt, which uses legacy icons "document-*.png", show them as normal document icon under Yaru theme

2019-11-24 Thread Amr Ibrahim
** Bug watch added: github.com/ubuntu/yaru/issues #1621
   https://github.com/ubuntu/yaru/issues/1621

** Also affects: yaru via
   https://github.com/ubuntu/yaru/issues/1621
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to qtbase-opensource-src in
Ubuntu.
https://bugs.launchpad.net/bugs/1853768

Title:
  Qt apps, like kid3-qt, which uses legacy icons "document-*.png", show
  them as normal document icon under Yaru theme

Status in Yaru Theme:
  Unknown
Status in qtbase-opensource-src package in Ubuntu:
  Confirmed
Status in yaru-theme package in Ubuntu:
  Confirmed

Bug description:
  Qt apps, like kid3-qt, which uses these legacy icons:

  document-open.png
  document-open-recent.png
  document-save.png
  document-save-as.png
  document-revert.png
  document-import.png
  document-export.png

  The icons are all shown as the same normal document icon under Yaru.

  Qt apps only have a problem with legacy icons starting with
  "document-*" and all other legacy icons are inherited from Humanity
  under Yaru.

  Is there a general solution to force Qt apps to choose the closest
  icon name from Yaru or Humanity?

  Should this bug be issued against upstream Qt?

To manage notifications about this bug go to:
https://bugs.launchpad.net/yaru/+bug/1853768/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1853768] [NEW] Qt apps, like kid3-qt, which uses legacy icons "document-*.png", show them as normal document icon under Yaru theme

2019-11-24 Thread Amr Ibrahim
Public bug reported:

Qt apps, like kid3-qt, which uses these legacy icons:

document-open.png
document-open-recent.png
document-save.png
document-save-as.png
document-revert.png
document-import.png
document-export.png

The icons are all shown as the same normal document icon under Yaru.

Qt apps only have a problem with legacy icons starting with "document-*"
and all other legacy icons are inherited from Humanity under Yaru.

Is there a general solution to force Qt apps to choose the closest icon
name from Yaru or Humanity?

Should this bug be issued against upstream Qt?

** Affects: qtbase-opensource-src (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: yaru-theme (Ubuntu)
 Importance: Undecided
 Status: New

** Also affects: qtbase-opensource-src (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to qtbase-opensource-src in
Ubuntu.
https://bugs.launchpad.net/bugs/1853768

Title:
  Qt apps, like kid3-qt, which uses legacy icons "document-*.png", show
  them as normal document icon under Yaru theme

Status in qtbase-opensource-src package in Ubuntu:
  New
Status in yaru-theme package in Ubuntu:
  New

Bug description:
  Qt apps, like kid3-qt, which uses these legacy icons:

  document-open.png
  document-open-recent.png
  document-save.png
  document-save-as.png
  document-revert.png
  document-import.png
  document-export.png

  The icons are all shown as the same normal document icon under Yaru.

  Qt apps only have a problem with legacy icons starting with
  "document-*" and all other legacy icons are inherited from Humanity
  under Yaru.

  Is there a general solution to force Qt apps to choose the closest
  icon name from Yaru or Humanity?

  Should this bug be issued against upstream Qt?

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/qtbase-opensource-src/+bug/1853768/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1832019] Re: Error when going to 'Tools -> Preferences -> Keyboard shortcuts' in Spyder3 in Bionic

2019-09-01 Thread Amr Ibrahim
** Also affects: spyderlib via
   https://github.com/spyder-ide/spyder/issues/7008
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to qtbase-opensource-src in
Ubuntu.
https://bugs.launchpad.net/bugs/1832019

Title:
  Error when going to 'Tools -> Preferences -> Keyboard shortcuts' in
  Spyder3 in Bionic

Status in spyderlib:
  Unknown
Status in pyqt5 package in Ubuntu:
  Invalid
Status in qtbase-opensource-src package in Ubuntu:
  Invalid
Status in qtstyleplugins-src package in Ubuntu:
  Invalid
Status in spyder package in Ubuntu:
  New

Bug description:
  In Ubuntu 18.04 LTS
  Steps:

  1. Install spyder3 and qt5-style-plugins (sudo apt install spyder3 
qt5-style-plugins)
  2. Run spyder3
  3. Go to Tools → Preferences → General → Appearance
  4. Change the Qt window style to cleanlooks, gtk2 or plastique
  5. Go to Tools → Preferences → Keyboard shortcuts
  6. Error (or crash in case of gtk2)

  Keyboard shortcuts are not accessible.

  Here is the error:

    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, 

[Touch-packages] [Bug 1832019] Re: Error when going to 'Tools -> Preferences -> Keyboard shortcuts' in Spyder3 in Bionic

2019-08-21 Thread Amr Ibrahim
Upstream bugs:
https://github.com/spyder-ide/spyder/issues/9412
https://github.com/spyder-ide/spyder/issues/7008

** Bug watch added: github.com/spyder-ide/spyder/issues #9412
   https://github.com/spyder-ide/spyder/issues/9412

** Bug watch added: github.com/spyder-ide/spyder/issues #7008
   https://github.com/spyder-ide/spyder/issues/7008

** Description changed:

  In Ubuntu 18.04 LTS
  Steps:
  
- 1. Install spyder3 (sudo apt install spyder3)
+ 1. Install spyder3 and qt5-style-plugins (sudo apt install spyder3 
qt5-style-plugins)
  2. Run spyder3
- 3. Go to Tools -> Preferences -> Keyboard shortcuts
- 4. Error
+ 3. Go to Tools → Preferences → General → Appearance
+ 4. Change the Qt window style to cleanlooks, gtk2 or plastique
+ 5. Go to Tools → Preferences → Keyboard shortcuts
+ 6. Error (or crash in case of gtk2)
  
  Keyboard shortcuts are not accessible.
  
  Here is the error:
  
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = 

[Touch-packages] [Bug 1832019] Re: Error when going to 'Tools -> Preferences -> Keyboard shortcuts' in Spyder3 in Bionic

2019-08-21 Thread Amr Ibrahim
Thanks Dmitry for the screenshot, it gave me a hint on where the bug is.

To reproduce the bug:

1. Install spyder3 and qt5-style-plugins (sudo apt install spyder3 
qt5-style-plugins)
2. Run spyder3
3. Go to Tools → Preferences → General → Appearance
4. Change the Qt window style to cleanlooks, gtk2 or plastique
5. Go to Tools → Preferences → Keyboard shortcuts
6. Error (or crash in case of gtk2)

** Also affects: qtstyleplugins-src (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to qtbase-opensource-src in
Ubuntu.
https://bugs.launchpad.net/bugs/1832019

Title:
  Error when going to 'Tools -> Preferences -> Keyboard shortcuts' in
  Spyder3 in Bionic

Status in pyqt5 package in Ubuntu:
  Invalid
Status in qtbase-opensource-src package in Ubuntu:
  Invalid
Status in qtstyleplugins-src package in Ubuntu:
  New
Status in spyder package in Ubuntu:
  New

Bug description:
  In Ubuntu 18.04 LTS
  Steps:

  1. Install spyder3 (sudo apt install spyder3)
  2. Run spyder3
  3. Go to Tools -> Preferences -> Keyboard shortcuts
  4. Error

  Keyboard shortcuts are not accessible.

  Here is the error:

    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  

[Touch-packages] [Bug 1832019] Re: Error when going to 'Tools -> Preferences -> Keyboard shortcuts' in Spyder3 in Bionic

2019-08-21 Thread Amr Ibrahim
** Also affects: pyqt5 (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to qtbase-opensource-src in
Ubuntu.
https://bugs.launchpad.net/bugs/1832019

Title:
  Error when going to 'Tools -> Preferences -> Keyboard shortcuts' in
  Spyder3 in Bionic

Status in pyqt5 package in Ubuntu:
  New
Status in qtbase-opensource-src package in Ubuntu:
  New
Status in spyder package in Ubuntu:
  New

Bug description:
  In Ubuntu 18.04 LTS
  Steps:

  1. Install spyder3 (sudo apt install spyder3)
  2. Run spyder3
  3. Go to Tools -> Preferences -> Keyboard shortcuts
  4. Error

  Keyboard shortcuts are not accessible.

  Here is the error:

    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
  textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
  TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough 

[Touch-packages] [Bug 185165] Re: Ubuntu does not open MS Windows internet shortcuts with 'url' extension

2019-08-16 Thread Amr Ibrahim
** Tags added: bionic disco eoan

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mime-support in Ubuntu.
https://bugs.launchpad.net/bugs/185165

Title:
  Ubuntu does not open MS Windows internet shortcuts with 'url'
  extension

Status in Ayatana Design:
  Fix Committed
Status in Gnome Mime-Data:
  Fix Released
Status in One Hundred Papercuts:
  Invalid
Status in gnome-mime-data package in Ubuntu:
  Fix Released
Status in mime-support package in Ubuntu:
  Triaged
Status in shared-mime-info package in Ubuntu:
  Triaged

Bug description:
  Ubuntu will not open standard internet shortcuts created in Microsoft
  Windows.  This makes interoperability very poor, and will prevent many
  people from migrating to Ubuntu.

  Copy any 'filename.url' from a Microsoft Windows machine, or create a
  file with the following contents:

  [DEFAULT]
  BASEURL=http://www.ubuntu.com
  [InternetShortcut]
  URL=http://www.ubuntu.com

  and name it 'ubuntu.url'.

  Double click in Nautilus to launch.  Nothing happens.  It should
  launch in the same manner as a 'desktop' internet shortcut.

  Note: a workaround has been developed -
  http://ubuntuforums.org/showthread.php?p=3281092.  This should be
  provided by default Ubuntu installation.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ayatana-design/+bug/185165/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 555380] Re: cautious-launcher untranslated and untranslatable

2019-08-16 Thread Amr Ibrahim
** Tags added: bionic disco eoan

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mime-support in Ubuntu.
https://bugs.launchpad.net/bugs/555380

Title:
  cautious-launcher untranslated and untranslatable

Status in Ubuntu Translations:
  Triaged
Status in mime-support package in Ubuntu:
  Triaged

Bug description:
  Binary package hint: mime-support

  The dialog box displayed by cautious-launcher shows untranslated in my
  Spanish desktop, and can't be translated because mime-support doesn't
  have a template in Launchpad Translations:

https://translations.launchpad.net/ubuntu/lucid/+source/mime-support

  ProblemType: Bug
  DistroRelease: Ubuntu 10.04
  Package: mime-support 3.48-1ubuntu1
  ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
  Uname: Linux 2.6.32-19-generic i686
  NonfreeKernelModules: nvidia
  Architecture: i386
  Date: Mon Apr  5 00:04:20 2010
  Dependencies:
   
  PackageArchitecture: all
  ProcEnviron:
   LANGUAGE=es_ES:es:en_GB:en
   PATH=(custom, user)
   LANG=es_ES.utf8
   SHELL=/bin/bash
  SourcePackage: mime-support

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-translations/+bug/555380/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1832123] Re: [SRU] Bugfix release 1.14.5

2019-08-03 Thread Amr Ibrahim
I've been testing too, playing music in Rhythmbox and videos in Totem,
transcoding with Sound Converter and Transmageddon. All seems fine.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gst-plugins-bad1.0 in
Ubuntu.
https://bugs.launchpad.net/bugs/1832123

Title:
  [SRU] Bugfix release 1.14.5

Status in gst-libav1.0 package in Ubuntu:
  Fix Released
Status in gst-plugins-bad1.0 package in Ubuntu:
  Fix Released
Status in gst-plugins-base1.0 package in Ubuntu:
  Fix Released
Status in gst-plugins-good1.0 package in Ubuntu:
  Fix Released
Status in gst-plugins-ugly1.0 package in Ubuntu:
  Fix Released
Status in gst-python1.0 package in Ubuntu:
  Fix Released
Status in gst-rtsp-server1.0 package in Ubuntu:
  Fix Released
Status in gstreamer-editing-services1.0 package in Ubuntu:
  Fix Released
Status in gstreamer-vaapi package in Ubuntu:
  Fix Released
Status in gstreamer1.0 package in Ubuntu:
  Fix Released
Status in gst-libav1.0 source package in Bionic:
  Fix Committed
Status in gst-plugins-bad1.0 source package in Bionic:
  Fix Committed
Status in gst-plugins-base1.0 source package in Bionic:
  Fix Committed
Status in gst-plugins-good1.0 source package in Bionic:
  Fix Committed
Status in gst-plugins-ugly1.0 source package in Bionic:
  Fix Committed
Status in gst-python1.0 source package in Bionic:
  Fix Committed
Status in gst-rtsp-server1.0 source package in Bionic:
  Fix Committed
Status in gstreamer-editing-services1.0 source package in Bionic:
  Fix Committed
Status in gstreamer-vaapi source package in Bionic:
  Fix Committed
Status in gstreamer1.0 source package in Bionic:
  Fix Committed

Bug description:
  [ Description ]

  We should keep up with GStreamer's bugfix releases in the 1.14 series
  that 18.04 shipped with.

  [ QA and testing ]

  Play a range of videos in Totem. Play a range of audio tracks in
  Rhythmbox. Try to stream audio and/or video. Try to install a missing
  codec.

  In all cases, make sure that everything which worked before still
  works.

  [ Regression potential ]

  If one of the fixes is bad then it might break video or audio playback, or 
could crash any application that tries to use gstreamer.
  ---

  Highlighted bugfixes in 1.14.5

  GStreamer core

  -   aggregator: take the pad lock around queue gap event removal
  -   aggregator: don’t leak gap buffer when out of segment
  -   buffer: fix possible memory corruption in gst_buffer_foreach_meta() when 
removing metas
  -   bus: Make removing of signal/bus watches thread-safe
  -   bus: Don’t allow removing signal watches with gst_bus_remove_watch()
  -   controlbinding: Check if the weak pointer was cleared before explicitly 
removing it
  -   ptp clock: Wait for ANNOUNCE before selecting a master; increase 
tolerance for late follow-up and delay-resp
  -   segment: Allow stop == -1 in gst_segment_to_running_time() and negative 
rate
  -   g-i: annotations fixes

  gst-plugins-base

  -   audioconvert: fix endianness conversion for unpacked formats (e.g. 
S24_32BE)
  -   audioringbuffer: Fix wrong memcpy address when reordering channels
  -   decodebin2: Make sure to remove pad probes when freeing GstDecodeGroup
  -   glviewconvert: fix output when a transformation matrix is used
  -   glupload: prevent segfault when updating caps
  -   gl/egl: Determine correct format on dmabuf import
  -   glupload: dmabuf: be explicit about gl formats used
  -   id3tag: validate the year from v1 tags before passing to GstDateTime
  -   rtpbasepayload: fix sequence numbers when using buffer lists
  -   rtspconnection: fix security issue, potential heap overflow 
(CVE-2019-9928)
  -   rtspconnection: fix GError set over the top of a previous GError
  -   rtspconnection: do not duplicate authentication headers
  -   subparse: don’t assert when failing to parse subrip timestamp
  -   video: various convert sample frame fixes
  -   video-converter: fix conversion from I420_10LE/BE, I420_12LE/BE, 
A420_10LE/BE to BGRA/RGBA which created corrupted output
  -   video-format: Fix GBRA_10/12 alpha channel pixel strides

  gst-plugins-good

  -   flv: Use 8kHz sample rate for alaw/mulaw audio
  -   flvdemux: Do not error out if the first added and chained pad is not 
linked
  -   flvmux: try harder to make sure timestamps are always increasing
  -   gdkpixbufdec: output a TIME segment which is what’s expected for raw video
  -   matroskademux: fix handling of MS ACM audio
  -   matroska: fix handling of FlagInterlaced
  -   pulsesink: Deal with not being able to convert a format to caps
  -   rtph265depay, rtph264depay; aggregation packet marker handling fixes
  -   rtpmp4gdepay: detect broken senders who send AAC with ADTS frames
  -   rtprawdepay: keep buffer pool around when flushing/seeking
  -   rtpssrcdemux: Forward serialized events to all pads
  -   qmlglsink: Handle OPENGL header guard changes
  -   qtdemux: fix 

[Touch-packages] [Bug 1818812] Re: glib: Fix named destinations

2019-07-19 Thread Amr Ibrahim
I wrote a comment on the upstream fixing commit asking if there are
other commits that are required to apply the fix on Poppler 0.62.0, no
answer yet, and I don't think upstream is interested in 0.62.0 any more.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to poppler in Ubuntu.
https://bugs.launchpad.net/bugs/1818812

Title:
  glib: Fix named destinations

Status in poppler package in Ubuntu:
  Fix Released

Bug description:
  IMPACT
  ---
  Evince does not follow internal links in some PDF research articles (affects 
Evince 3.28.4 + Poppler 0.62.0 on Ubuntu 18.04)
  https://gitlab.gnome.org/GNOME/evince/issues/1070

  PDF's link annotation does not work in Evince 3.30.2
  https://gitlab.gnome.org/GNOME/evince/issues/1027

  Evince does not follow internal links in some PDF research articles. The 
internal links are used for easy and fast navigation to pages, figures, 
references and equations.
  qpdfview (poppler-qt5 viewer) can follow the internal links in those files 
just fine.

  DOI of one of the affected documents:
  http://dx.doi.org/10.1016/j.apenergy.2016.10.058

  Upstream fix:
  
https://gitlab.freedesktop.org/poppler/poppler/commit/44505cb397c46baa7dd4a0456f737f36e6d19ad0

  
  TEST CASE
  --
  Clicking on the following parts should work after the fix is committed:

  - Superscripts next to the authors names
  - Citations in page 17 (e.g. [1], [9,11-18], [25-30])
  - Figure and Table links in page 17 (Fig 1 and Table 1 at the beginning of 
section 2)
  - Equations in page 19 (they stay in the same page as the equations are very 
close to their links)

  
  REGRESSION POTENTIAL
  -
  This is quoted from the upstream commit:

  "Named destinations may be described by bytestrings, containing
  embedded NULs and not being NUL terminated. That means they cannot be
  exposed directly as char*.

  The alternatives are to escape the string from the internal representation 
when exposing it in the API (e.g. in PopplerDest.named_dest), or to add 
parallel API exposing it as GString, or GBytes. This patch chooses the first 
option, since the presence of these named destionations in the public, not 
sealed, PopplerDest struct means that the second option would need more API 
additions. The chosen option is simpler, and does not need the API users to 
adapt unless they create the named dest strings
  themselves, or consume them in ways other than calling poppler APIs.

  The escaping scheme chosen simply replaces embedded NUL with "\0" and
  escapes a literal backslash with "\\".  This is a minimal ABI change
  in that some strings that previously worked unchanged as destinations
  (those containing backslash) now don't work, but on the other hand,
  previously it was impossible to use any destinations containing
  embedded NULs.

  Add poppler_named_dest_{from,to}_bytestring() to perform that
  conversion, and clarify the documentation for when you need them."

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: libpoppler-glib8 0.62.0-2ubuntu2.7
  ProcVersionSignature: Ubuntu 4.18.0-15.16~18.04.1-generic 4.18.20
  Uname: Linux 4.18.0-15-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.5
  Architecture: amd64
  CurrentDesktop: communitheme:ubuntu:GNOME
  Date: Wed Mar  6 10:57:53 2019
  InstallationDate: Installed on 2018-11-29 (96 days ago)
  InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 
(20180725)
  SourcePackage: poppler
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/poppler/+bug/1818812/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1832123] Re: [SRU] Bugfix release 1.14.5

2019-07-17 Thread Amr Ibrahim
I'm testing now, and will report later.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gst-plugins-bad1.0 in
Ubuntu.
https://bugs.launchpad.net/bugs/1832123

Title:
  [SRU] Bugfix release 1.14.5

Status in gst-libav1.0 package in Ubuntu:
  Fix Released
Status in gst-plugins-bad1.0 package in Ubuntu:
  Fix Released
Status in gst-plugins-base1.0 package in Ubuntu:
  Fix Released
Status in gst-plugins-good1.0 package in Ubuntu:
  Fix Released
Status in gst-plugins-ugly1.0 package in Ubuntu:
  Fix Released
Status in gst-python1.0 package in Ubuntu:
  Fix Released
Status in gst-rtsp-server1.0 package in Ubuntu:
  Fix Released
Status in gstreamer-editing-services1.0 package in Ubuntu:
  Fix Released
Status in gstreamer-vaapi package in Ubuntu:
  Fix Released
Status in gstreamer1.0 package in Ubuntu:
  Fix Released
Status in gst-libav1.0 source package in Bionic:
  Fix Committed
Status in gst-plugins-bad1.0 source package in Bionic:
  Fix Committed
Status in gst-plugins-base1.0 source package in Bionic:
  Fix Committed
Status in gst-plugins-good1.0 source package in Bionic:
  Fix Committed
Status in gst-plugins-ugly1.0 source package in Bionic:
  Fix Committed
Status in gst-python1.0 source package in Bionic:
  Fix Committed
Status in gst-rtsp-server1.0 source package in Bionic:
  Fix Committed
Status in gstreamer-editing-services1.0 source package in Bionic:
  Fix Committed
Status in gstreamer-vaapi source package in Bionic:
  Fix Committed
Status in gstreamer1.0 source package in Bionic:
  Fix Committed

Bug description:
  [ Description ]

  We should keep up with GStreamer's bugfix releases in the 1.14 series
  that 18.04 shipped with.

  [ QA and testing ]

  Play a range of videos in Totem. Play a range of audio tracks in
  Rhythmbox. Try to stream audio and/or video. Try to install a missing
  codec.

  In all cases, make sure that everything which worked before still
  works.

  [ Regression potential ]

  If one of the fixes is bad then it might break video or audio playback, or 
could crash any application that tries to use gstreamer.
  ---

  Highlighted bugfixes in 1.14.5

  GStreamer core

  -   aggregator: take the pad lock around queue gap event removal
  -   aggregator: don’t leak gap buffer when out of segment
  -   buffer: fix possible memory corruption in gst_buffer_foreach_meta() when 
removing metas
  -   bus: Make removing of signal/bus watches thread-safe
  -   bus: Don’t allow removing signal watches with gst_bus_remove_watch()
  -   controlbinding: Check if the weak pointer was cleared before explicitly 
removing it
  -   ptp clock: Wait for ANNOUNCE before selecting a master; increase 
tolerance for late follow-up and delay-resp
  -   segment: Allow stop == -1 in gst_segment_to_running_time() and negative 
rate
  -   g-i: annotations fixes

  gst-plugins-base

  -   audioconvert: fix endianness conversion for unpacked formats (e.g. 
S24_32BE)
  -   audioringbuffer: Fix wrong memcpy address when reordering channels
  -   decodebin2: Make sure to remove pad probes when freeing GstDecodeGroup
  -   glviewconvert: fix output when a transformation matrix is used
  -   glupload: prevent segfault when updating caps
  -   gl/egl: Determine correct format on dmabuf import
  -   glupload: dmabuf: be explicit about gl formats used
  -   id3tag: validate the year from v1 tags before passing to GstDateTime
  -   rtpbasepayload: fix sequence numbers when using buffer lists
  -   rtspconnection: fix security issue, potential heap overflow 
(CVE-2019-9928)
  -   rtspconnection: fix GError set over the top of a previous GError
  -   rtspconnection: do not duplicate authentication headers
  -   subparse: don’t assert when failing to parse subrip timestamp
  -   video: various convert sample frame fixes
  -   video-converter: fix conversion from I420_10LE/BE, I420_12LE/BE, 
A420_10LE/BE to BGRA/RGBA which created corrupted output
  -   video-format: Fix GBRA_10/12 alpha channel pixel strides

  gst-plugins-good

  -   flv: Use 8kHz sample rate for alaw/mulaw audio
  -   flvdemux: Do not error out if the first added and chained pad is not 
linked
  -   flvmux: try harder to make sure timestamps are always increasing
  -   gdkpixbufdec: output a TIME segment which is what’s expected for raw video
  -   matroskademux: fix handling of MS ACM audio
  -   matroska: fix handling of FlagInterlaced
  -   pulsesink: Deal with not being able to convert a format to caps
  -   rtph265depay, rtph264depay; aggregation packet marker handling fixes
  -   rtpmp4gdepay: detect broken senders who send AAC with ADTS frames
  -   rtprawdepay: keep buffer pool around when flushing/seeking
  -   rtpssrcdemux: Forward serialized events to all pads
  -   qmlglsink: Handle OPENGL header guard changes
  -   qtdemux: fix track language code parsing; ignore corrupted CTTS box
  -   qtmux: Correctly set tkhd width/height to 

[Touch-packages] [Bug 1836444] [NEW] Merge qt4-x11 4:4.8.7+dfsg-18 (universe) from Debian unstable (main)

2019-07-13 Thread Amr Ibrahim
Public bug reported:

Please merge qt4-x11 4:4.8.7+dfsg-18 (universe) from Debian unstable
(main)

I cannot work on this merge myself. I filed this bug as a reference.

Explanation of the Ubuntu delta:
  * Merge with Debian since qtchooser has versioned Breaks. (LP: #1584654)
  * Add one more macro to qt4-x11 moc to fix failing to parse BOOST_JOIN.
  * No-change rebuild for libpng soname change.
  * Rebuild against libmysqlclient20.
  * Merge with Debian; remaining changes:
- Pass list-missing to dh_install instead of fail-missing, since we don't
  install the QtWebkit headers
- Make sure libqt4-opengl-dev depends on gles libs for armel and armhf
- Do not package ibase/firebird and sqlite2 package
  + remove from debian/control
  + libqt4-sql doesn't recommend libqt4-sql-ibase and libqt4-sql-sqlite2
- Also exclude webkit examples from dh_shlibdeps
- Do not build libqt4-phonon, disable in debian/control
- Add debian/Trolltech.conf and install it in libqtcore4.install
- Build with -no-neon on armel and armhf
- Build with -no-javascript-jit on arm64
- Add patches:
  + kubuntu_10_ibus_input_method.diff
  + kubuntu_12_fix_stack_protector.diff
  + kubuntu_28_xi2.1.patch
  + kubuntu_30_translucent_drag_pixmap.diff
  + kubuntu_37_cups_settings.diff
  + kubuntu_39_fix_medium_font.diff
  + kubuntu_40_disable_neon.patch
  + kubuntu_43_no_meego_helper.patch
  + kubuntu_93_disable_overlay_scrollbars.diff
  + kubuntu_94_xinput_valuators_fix.diff
  + kubuntu_95_qt_disable_bounce.diff
  + kubuntu_97_a11y_qt_and_qml_backport.diff
  + kubuntu_98_a11y_fix_crash.diff
  + kubuntu_glib-honor-ExcludeSocketNotifiers-flag.diff
  + kubuntu_qclipboard_delay.diff
  + kubuntu_qclipboard_fix_recursive.diff
- Drop powerpc_designer_gstabs.diff, it breaks powerpc
  * Update symbols files.

Changelog entries since current eoan version 4:4.8.7+dfsg-7ubuntu1:

qt4-x11 (4:4.8.7+dfsg-18) unstable; urgency=medium

  * Team upload.

  [ Edward Betts ]
  * debian/NEWS: Replace UNRELEASED with unstable.

  [ Alexander Volkov ]
  * Backport some vulnerability fixes from Qt 5 (closes: #923003).
- CVE-2018-15518: double free or corruption in QXmlStreamReader.
- CVE-2018-19869: Qt Svg crash when parsing malformed url reference.
- CVE-2018-19870: NULL pointer dereference in QGifHandler.
- CVE-2018-19871: QTgaFile CPU exhaustion.
- CVE-2018-19872: crash when parsing a malformed PPM image.
- CVE-2018-19873: QBmpHandler segfault on malformed BMP file.

 -- Dmitry Shachnev   Fri, 12 Apr 2019 23:10:28
+0300

qt4-x11 (4:4.8.7+dfsg-17) unstable; urgency=medium

  * Add fix-build-icu59.patch from OpenSuse. Fixes build with icu59
   (Closes: #898542). Thanks John Paul Adrian Glaubitz for digging the
   patch!
  * Put the source package in section oldlibs. We do not expect new
developments with qt4-x11.
  * Update Vcs-[Git Browser] to the new location in salsa.debian.org.

 -- Lisandro Damián Nicanor Pérez Meyer   Tue, 15
May 2018 13:24:10 -0300

qt4-x11 (4:4.8.7+dfsg-16) unstable; urgency=medium

  * Update symbols files with buildds' logs.
  * Add a patch by Manuel A. Fernandez Montecelo to provide riscv64 support
   (Closes: #897667).

 -- Lisandro Damián Nicanor Pérez Meyer   Fri, 04
May 2018 22:53:17 -0300

qt4-x11 (4:4.8.7+dfsg-15) unstable; urgency=medium

  * Actually upload it to unstable.

 -- Lisandro Damián Nicanor Pérez Meyer   Wed, 18
Apr 2018 17:45:31 -0300

qt4-x11 (4:4.8.7+dfsg-14) experimental; urgency=medium

  * Update symbols files with buildds' logs.
  * Add NEWS.Debian to explicitely tell users of the OpenSSL 1.1 patch.

 -- Lisandro Damián Nicanor Pérez Meyer   Wed, 18
Apr 2018 16:30:10 -0300

qt4-x11 (4:4.8.7+dfsg-13) experimental; urgency=medium

  * Add extra patch from Dmitry Eremin-Solenikov to make Qt4 work with
OpenSSL 1.1 (Closes: #873275).
  * Recommend default-libmysqlclient-dev instead of libmysqlclient-dev.

 -- Lisandro Damián Nicanor Pérez Meyer   Fri, 10
Nov 2017 15:36:11 -0300

qt4-x11 (4:4.8.7+dfsg-12) experimental; urgency=medium

  * Add openssl_1.1.patch to let Qt4 use OpenSSL 1.1 (Closes: #828522).
- Switch libssl-1.0-dev to libssl-dev to use OpenSSL 1.1.
  * Update symbols files with current build log.

 -- Lisandro Damián Nicanor Pérez Meyer   Tue, 15
Aug 2017 13:25:00 -0300

qt4-x11 (4:4.8.7+dfsg-11) unstable; urgency=medium

  * Switch libmysqlclient-dev to default-libmysqlclient-dev.

 -- Lisandro Damián Nicanor Pérez Meyer   Wed, 09
Nov 2016 13:50:49 -0300

qt4-x11 (4:4.8.7+dfsg-10) unstable; urgency=medium

  * Update symbols files with buildds' logs.
  * Update libqtcore4's libicu55 suggestion to libicu57 (Closes: #842955).
Thanks Dmitry Eremin-Solenikov for the bug report.
  * Switch the build dependency on libssl-dev to libssl1.0-dev. While a
patch has been proposed applying it just a few days before the transitions
freeze is not the right moment 

[Touch-packages] [Bug 1818812] Re: glib: Fix named destinations

2019-07-11 Thread Amr Ibrahim
I can't do it myself, I'll have to ask upstream to do it.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to poppler in Ubuntu.
https://bugs.launchpad.net/bugs/1818812

Title:
  glib: Fix named destinations

Status in poppler package in Ubuntu:
  Fix Released

Bug description:
  IMPACT
  ---
  Evince does not follow internal links in some PDF research articles (affects 
Evince 3.28.4 + Poppler 0.62.0 on Ubuntu 18.04)
  https://gitlab.gnome.org/GNOME/evince/issues/1070

  PDF's link annotation does not work in Evince 3.30.2
  https://gitlab.gnome.org/GNOME/evince/issues/1027

  Evince does not follow internal links in some PDF research articles. The 
internal links are used for easy and fast navigation to pages, figures, 
references and equations.
  qpdfview (poppler-qt5 viewer) can follow the internal links in those files 
just fine.

  DOI of one of the affected documents:
  http://dx.doi.org/10.1016/j.apenergy.2016.10.058

  Upstream fix:
  
https://gitlab.freedesktop.org/poppler/poppler/commit/44505cb397c46baa7dd4a0456f737f36e6d19ad0

  
  TEST CASE
  --
  Clicking on the following parts should work after the fix is committed:

  - Superscripts next to the authors names
  - Citations in page 17 (e.g. [1], [9,11-18], [25-30])
  - Figure and Table links in page 17 (Fig 1 and Table 1 at the beginning of 
section 2)
  - Equations in page 19 (they stay in the same page as the equations are very 
close to their links)

  
  REGRESSION POTENTIAL
  -
  This is quoted from the upstream commit:

  "Named destinations may be described by bytestrings, containing
  embedded NULs and not being NUL terminated. That means they cannot be
  exposed directly as char*.

  The alternatives are to escape the string from the internal representation 
when exposing it in the API (e.g. in PopplerDest.named_dest), or to add 
parallel API exposing it as GString, or GBytes. This patch chooses the first 
option, since the presence of these named destionations in the public, not 
sealed, PopplerDest struct means that the second option would need more API 
additions. The chosen option is simpler, and does not need the API users to 
adapt unless they create the named dest strings
  themselves, or consume them in ways other than calling poppler APIs.

  The escaping scheme chosen simply replaces embedded NUL with "\0" and
  escapes a literal backslash with "\\".  This is a minimal ABI change
  in that some strings that previously worked unchanged as destinations
  (those containing backslash) now don't work, but on the other hand,
  previously it was impossible to use any destinations containing
  embedded NULs.

  Add poppler_named_dest_{from,to}_bytestring() to perform that
  conversion, and clarify the documentation for when you need them."

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: libpoppler-glib8 0.62.0-2ubuntu2.7
  ProcVersionSignature: Ubuntu 4.18.0-15.16~18.04.1-generic 4.18.20
  Uname: Linux 4.18.0-15-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.5
  Architecture: amd64
  CurrentDesktop: communitheme:ubuntu:GNOME
  Date: Wed Mar  6 10:57:53 2019
  InstallationDate: Installed on 2018-11-29 (96 days ago)
  InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 
(20180725)
  SourcePackage: poppler
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/poppler/+bug/1818812/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1832123] Re: [SRU] Bugfix release 1.14.5

2019-06-27 Thread Amr Ibrahim
I'm not working on this. I filled it as a place-holder for anyone who is
willing to work on the update.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gst-plugins-bad1.0 in
Ubuntu.
https://bugs.launchpad.net/bugs/1832123

Title:
  [SRU] Bugfix release 1.14.5

Status in gst-libav1.0 package in Ubuntu:
  New
Status in gst-omx package in Ubuntu:
  New
Status in gst-plugins-bad1.0 package in Ubuntu:
  New
Status in gst-plugins-base1.0 package in Ubuntu:
  New
Status in gst-plugins-good1.0 package in Ubuntu:
  New
Status in gst-plugins-ugly1.0 package in Ubuntu:
  New
Status in gst-python1.0 package in Ubuntu:
  New
Status in gst-rtsp-server1.0 package in Ubuntu:
  New
Status in gstreamer-editing-services1.0 package in Ubuntu:
  New
Status in gstreamer-vaapi package in Ubuntu:
  New
Status in gstreamer1.0 package in Ubuntu:
  New

Bug description:
  [ Description ]

  We should keep up with GStreamer's bugfix releases in the 1.14 series
  that 18.04 shipped with.

  [ QA and testing ]

  Play a range of videos in Totem. Play a range of audio tracks in
  Rhythmbox. Try to stream audio and/or video. Try to install a missing
  codec.

  In all cases, make sure that everything which worked before still
  works.

  [ Regression potential ]

  If one of the fixes is bad then it might break video or audio playback, or 
could crash any application that tries to use gstreamer.
  ---

  Highlighted bugfixes in 1.14.5

  GStreamer core

  -   aggregator: take the pad lock around queue gap event removal
  -   aggregator: don’t leak gap buffer when out of segment
  -   buffer: fix possible memory corruption in gst_buffer_foreach_meta() when 
removing metas
  -   bus: Make removing of signal/bus watches thread-safe
  -   bus: Don’t allow removing signal watches with gst_bus_remove_watch()
  -   controlbinding: Check if the weak pointer was cleared before explicitly 
removing it
  -   ptp clock: Wait for ANNOUNCE before selecting a master; increase 
tolerance for late follow-up and delay-resp
  -   segment: Allow stop == -1 in gst_segment_to_running_time() and negative 
rate
  -   g-i: annotations fixes

  gst-plugins-base

  -   audioconvert: fix endianness conversion for unpacked formats (e.g. 
S24_32BE)
  -   audioringbuffer: Fix wrong memcpy address when reordering channels
  -   decodebin2: Make sure to remove pad probes when freeing GstDecodeGroup
  -   glviewconvert: fix output when a transformation matrix is used
  -   glupload: prevent segfault when updating caps
  -   gl/egl: Determine correct format on dmabuf import
  -   glupload: dmabuf: be explicit about gl formats used
  -   id3tag: validate the year from v1 tags before passing to GstDateTime
  -   rtpbasepayload: fix sequence numbers when using buffer lists
  -   rtspconnection: fix security issue, potential heap overflow 
(CVE-2019-9928)
  -   rtspconnection: fix GError set over the top of a previous GError
  -   rtspconnection: do not duplicate authentication headers
  -   subparse: don’t assert when failing to parse subrip timestamp
  -   video: various convert sample frame fixes
  -   video-converter: fix conversion from I420_10LE/BE, I420_12LE/BE, 
A420_10LE/BE to BGRA/RGBA which created corrupted output
  -   video-format: Fix GBRA_10/12 alpha channel pixel strides

  gst-plugins-good

  -   flv: Use 8kHz sample rate for alaw/mulaw audio
  -   flvdemux: Do not error out if the first added and chained pad is not 
linked
  -   flvmux: try harder to make sure timestamps are always increasing
  -   gdkpixbufdec: output a TIME segment which is what’s expected for raw video
  -   matroskademux: fix handling of MS ACM audio
  -   matroska: fix handling of FlagInterlaced
  -   pulsesink: Deal with not being able to convert a format to caps
  -   rtph265depay, rtph264depay; aggregation packet marker handling fixes
  -   rtpmp4gdepay: detect broken senders who send AAC with ADTS frames
  -   rtprawdepay: keep buffer pool around when flushing/seeking
  -   rtpssrcdemux: Forward serialized events to all pads
  -   qmlglsink: Handle OPENGL header guard changes
  -   qtdemux: fix track language code parsing; ignore corrupted CTTS box
  -   qtmux: Correctly set tkhd width/height to the display size
  -   splitmuxsink: various timecode meta handling fixes
  -   splitmuxsink: make work with audio-only encoders as muxers, e.g. wavenc
  -   v4l2sink: fix pool-less allocation query handling
  -   v4l2dec/enc: fix use after free when handling events
  -   vpx: Fix build against libvpx 1.8
  -   webmmux: allow resolutions above 4096

  gst-plugins-ugly

  -   sid: Fix cross-compilation by using AC_TRY_LINK instead of AC_TRY_RUN
  -   x264: Only enable dynamic loading code for x264 before v253

  gst-plugins-bad

  -   assrender: fix disappearing subtitles when seeking back in time
  -   decklinkvideosink: fix segfault when audiosink is closed before videosink
  - 

[Touch-packages] [Bug 1832123] Re: [SRU] Bugfix release 1.14.5

2019-06-27 Thread Amr Ibrahim
Yep, 1.14.4 has been released now.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gst-plugins-bad1.0 in
Ubuntu.
https://bugs.launchpad.net/bugs/1832123

Title:
  [SRU] Bugfix release 1.14.5

Status in gst-libav1.0 package in Ubuntu:
  New
Status in gst-omx package in Ubuntu:
  New
Status in gst-plugins-bad1.0 package in Ubuntu:
  New
Status in gst-plugins-base1.0 package in Ubuntu:
  New
Status in gst-plugins-good1.0 package in Ubuntu:
  New
Status in gst-plugins-ugly1.0 package in Ubuntu:
  New
Status in gst-python1.0 package in Ubuntu:
  New
Status in gst-rtsp-server1.0 package in Ubuntu:
  New
Status in gstreamer-editing-services1.0 package in Ubuntu:
  New
Status in gstreamer-vaapi package in Ubuntu:
  New
Status in gstreamer1.0 package in Ubuntu:
  New

Bug description:
  [ Description ]

  We should keep up with GStreamer's bugfix releases in the 1.14 series
  that 18.04 shipped with.

  [ QA and testing ]

  Play a range of videos in Totem. Play a range of audio tracks in
  Rhythmbox. Try to stream audio and/or video. Try to install a missing
  codec.

  In all cases, make sure that everything which worked before still
  works.

  [ Regression potential ]

  If one of the fixes is bad then it might break video or audio playback, or 
could crash any application that tries to use gstreamer.
  ---

  Highlighted bugfixes in 1.14.5

  GStreamer core

  -   aggregator: take the pad lock around queue gap event removal
  -   aggregator: don’t leak gap buffer when out of segment
  -   buffer: fix possible memory corruption in gst_buffer_foreach_meta() when 
removing metas
  -   bus: Make removing of signal/bus watches thread-safe
  -   bus: Don’t allow removing signal watches with gst_bus_remove_watch()
  -   controlbinding: Check if the weak pointer was cleared before explicitly 
removing it
  -   ptp clock: Wait for ANNOUNCE before selecting a master; increase 
tolerance for late follow-up and delay-resp
  -   segment: Allow stop == -1 in gst_segment_to_running_time() and negative 
rate
  -   g-i: annotations fixes

  gst-plugins-base

  -   audioconvert: fix endianness conversion for unpacked formats (e.g. 
S24_32BE)
  -   audioringbuffer: Fix wrong memcpy address when reordering channels
  -   decodebin2: Make sure to remove pad probes when freeing GstDecodeGroup
  -   glviewconvert: fix output when a transformation matrix is used
  -   glupload: prevent segfault when updating caps
  -   gl/egl: Determine correct format on dmabuf import
  -   glupload: dmabuf: be explicit about gl formats used
  -   id3tag: validate the year from v1 tags before passing to GstDateTime
  -   rtpbasepayload: fix sequence numbers when using buffer lists
  -   rtspconnection: fix security issue, potential heap overflow 
(CVE-2019-9928)
  -   rtspconnection: fix GError set over the top of a previous GError
  -   rtspconnection: do not duplicate authentication headers
  -   subparse: don’t assert when failing to parse subrip timestamp
  -   video: various convert sample frame fixes
  -   video-converter: fix conversion from I420_10LE/BE, I420_12LE/BE, 
A420_10LE/BE to BGRA/RGBA which created corrupted output
  -   video-format: Fix GBRA_10/12 alpha channel pixel strides

  gst-plugins-good

  -   flv: Use 8kHz sample rate for alaw/mulaw audio
  -   flvdemux: Do not error out if the first added and chained pad is not 
linked
  -   flvmux: try harder to make sure timestamps are always increasing
  -   gdkpixbufdec: output a TIME segment which is what’s expected for raw video
  -   matroskademux: fix handling of MS ACM audio
  -   matroska: fix handling of FlagInterlaced
  -   pulsesink: Deal with not being able to convert a format to caps
  -   rtph265depay, rtph264depay; aggregation packet marker handling fixes
  -   rtpmp4gdepay: detect broken senders who send AAC with ADTS frames
  -   rtprawdepay: keep buffer pool around when flushing/seeking
  -   rtpssrcdemux: Forward serialized events to all pads
  -   qmlglsink: Handle OPENGL header guard changes
  -   qtdemux: fix track language code parsing; ignore corrupted CTTS box
  -   qtmux: Correctly set tkhd width/height to the display size
  -   splitmuxsink: various timecode meta handling fixes
  -   splitmuxsink: make work with audio-only encoders as muxers, e.g. wavenc
  -   v4l2sink: fix pool-less allocation query handling
  -   v4l2dec/enc: fix use after free when handling events
  -   vpx: Fix build against libvpx 1.8
  -   webmmux: allow resolutions above 4096

  gst-plugins-ugly

  -   sid: Fix cross-compilation by using AC_TRY_LINK instead of AC_TRY_RUN
  -   x264: Only enable dynamic loading code for x264 before v253

  gst-plugins-bad

  -   assrender: fix disappearing subtitles when seeking back in time
  -   decklinkvideosink: fix segfault when audiosink is closed before videosink
  -   decklinkvideosrc: respect pixel format property even if mode is 

[Touch-packages] [Bug 1832123] Re: [SRU] Bugfix release 1.14.5

2019-06-26 Thread Amr Ibrahim
** Also affects: gstreamer-editing-services1.0 (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: gst-python1.0 (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gst-plugins-bad1.0 in
Ubuntu.
https://bugs.launchpad.net/bugs/1832123

Title:
  [SRU] Bugfix release 1.14.5

Status in gst-libav1.0 package in Ubuntu:
  New
Status in gst-omx package in Ubuntu:
  New
Status in gst-plugins-bad1.0 package in Ubuntu:
  New
Status in gst-plugins-base1.0 package in Ubuntu:
  New
Status in gst-plugins-good1.0 package in Ubuntu:
  New
Status in gst-plugins-ugly1.0 package in Ubuntu:
  New
Status in gst-python1.0 package in Ubuntu:
  New
Status in gst-rtsp-server1.0 package in Ubuntu:
  New
Status in gstreamer-editing-services1.0 package in Ubuntu:
  New
Status in gstreamer-vaapi package in Ubuntu:
  New
Status in gstreamer1.0 package in Ubuntu:
  New

Bug description:
  [ Description ]

  We should keep up with GStreamer's bugfix releases in the 1.14 series
  that 18.04 shipped with.

  [ QA and testing ]

  Play a range of videos in Totem. Play a range of audio tracks in
  Rhythmbox. Try to stream audio and/or video. Try to install a missing
  codec.

  In all cases, make sure that everything which worked before still
  works.

  [ Regression potential ]

  If one of the fixes is bad then it might break video or audio playback, or 
could crash any application that tries to use gstreamer.
  ---

  Highlighted bugfixes in 1.14.5

  GStreamer core

  -   aggregator: take the pad lock around queue gap event removal
  -   aggregator: don’t leak gap buffer when out of segment
  -   buffer: fix possible memory corruption in gst_buffer_foreach_meta() when 
removing metas
  -   bus: Make removing of signal/bus watches thread-safe
  -   bus: Don’t allow removing signal watches with gst_bus_remove_watch()
  -   controlbinding: Check if the weak pointer was cleared before explicitly 
removing it
  -   ptp clock: Wait for ANNOUNCE before selecting a master; increase 
tolerance for late follow-up and delay-resp
  -   segment: Allow stop == -1 in gst_segment_to_running_time() and negative 
rate
  -   g-i: annotations fixes

  gst-plugins-base

  -   audioconvert: fix endianness conversion for unpacked formats (e.g. 
S24_32BE)
  -   audioringbuffer: Fix wrong memcpy address when reordering channels
  -   decodebin2: Make sure to remove pad probes when freeing GstDecodeGroup
  -   glviewconvert: fix output when a transformation matrix is used
  -   glupload: prevent segfault when updating caps
  -   gl/egl: Determine correct format on dmabuf import
  -   glupload: dmabuf: be explicit about gl formats used
  -   id3tag: validate the year from v1 tags before passing to GstDateTime
  -   rtpbasepayload: fix sequence numbers when using buffer lists
  -   rtspconnection: fix security issue, potential heap overflow 
(CVE-2019-9928)
  -   rtspconnection: fix GError set over the top of a previous GError
  -   rtspconnection: do not duplicate authentication headers
  -   subparse: don’t assert when failing to parse subrip timestamp
  -   video: various convert sample frame fixes
  -   video-converter: fix conversion from I420_10LE/BE, I420_12LE/BE, 
A420_10LE/BE to BGRA/RGBA which created corrupted output
  -   video-format: Fix GBRA_10/12 alpha channel pixel strides

  gst-plugins-good

  -   flv: Use 8kHz sample rate for alaw/mulaw audio
  -   flvdemux: Do not error out if the first added and chained pad is not 
linked
  -   flvmux: try harder to make sure timestamps are always increasing
  -   gdkpixbufdec: output a TIME segment which is what’s expected for raw video
  -   matroskademux: fix handling of MS ACM audio
  -   matroska: fix handling of FlagInterlaced
  -   pulsesink: Deal with not being able to convert a format to caps
  -   rtph265depay, rtph264depay; aggregation packet marker handling fixes
  -   rtpmp4gdepay: detect broken senders who send AAC with ADTS frames
  -   rtprawdepay: keep buffer pool around when flushing/seeking
  -   rtpssrcdemux: Forward serialized events to all pads
  -   qmlglsink: Handle OPENGL header guard changes
  -   qtdemux: fix track language code parsing; ignore corrupted CTTS box
  -   qtmux: Correctly set tkhd width/height to the display size
  -   splitmuxsink: various timecode meta handling fixes
  -   splitmuxsink: make work with audio-only encoders as muxers, e.g. wavenc
  -   v4l2sink: fix pool-less allocation query handling
  -   v4l2dec/enc: fix use after free when handling events
  -   vpx: Fix build against libvpx 1.8
  -   webmmux: allow resolutions above 4096

  gst-plugins-ugly

  -   sid: Fix cross-compilation by using AC_TRY_LINK instead of AC_TRY_RUN
  -   x264: Only enable dynamic loading code for x264 before v253

  gst-plugins-bad

  -   assrender: fix disappearing subtitles when seeking back in time
  

[Touch-packages] [Bug 1832123] Re: [SRU] Bugfix release 1.14.5

2019-06-26 Thread Amr Ibrahim
** Also affects: gst-plugins-good1.0 (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: gst-plugins-base1.0 (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: gst-plugins-ugly1.0 (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: gst-plugins-bad1.0 (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: gst-libav1.0 (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: gst-rtsp-server1.0 (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: gstreamer-vaapi (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: gst-omx (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gst-plugins-good1.0 in
Ubuntu.
https://bugs.launchpad.net/bugs/1832123

Title:
  [SRU] Bugfix release 1.14.5

Status in gst-libav1.0 package in Ubuntu:
  New
Status in gst-omx package in Ubuntu:
  New
Status in gst-plugins-bad1.0 package in Ubuntu:
  New
Status in gst-plugins-base1.0 package in Ubuntu:
  New
Status in gst-plugins-good1.0 package in Ubuntu:
  New
Status in gst-plugins-ugly1.0 package in Ubuntu:
  New
Status in gst-python1.0 package in Ubuntu:
  New
Status in gst-rtsp-server1.0 package in Ubuntu:
  New
Status in gstreamer-editing-services1.0 package in Ubuntu:
  New
Status in gstreamer-vaapi package in Ubuntu:
  New
Status in gstreamer1.0 package in Ubuntu:
  New

Bug description:
  [ Description ]

  We should keep up with GStreamer's bugfix releases in the 1.14 series
  that 18.04 shipped with.

  [ QA and testing ]

  Play a range of videos in Totem. Play a range of audio tracks in
  Rhythmbox. Try to stream audio and/or video. Try to install a missing
  codec.

  In all cases, make sure that everything which worked before still
  works.

  [ Regression potential ]

  If one of the fixes is bad then it might break video or audio playback, or 
could crash any application that tries to use gstreamer.
  ---

  Highlighted bugfixes in 1.14.5

  GStreamer core

  -   aggregator: take the pad lock around queue gap event removal
  -   aggregator: don’t leak gap buffer when out of segment
  -   buffer: fix possible memory corruption in gst_buffer_foreach_meta() when 
removing metas
  -   bus: Make removing of signal/bus watches thread-safe
  -   bus: Don’t allow removing signal watches with gst_bus_remove_watch()
  -   controlbinding: Check if the weak pointer was cleared before explicitly 
removing it
  -   ptp clock: Wait for ANNOUNCE before selecting a master; increase 
tolerance for late follow-up and delay-resp
  -   segment: Allow stop == -1 in gst_segment_to_running_time() and negative 
rate
  -   g-i: annotations fixes

  gst-plugins-base

  -   audioconvert: fix endianness conversion for unpacked formats (e.g. 
S24_32BE)
  -   audioringbuffer: Fix wrong memcpy address when reordering channels
  -   decodebin2: Make sure to remove pad probes when freeing GstDecodeGroup
  -   glviewconvert: fix output when a transformation matrix is used
  -   glupload: prevent segfault when updating caps
  -   gl/egl: Determine correct format on dmabuf import
  -   glupload: dmabuf: be explicit about gl formats used
  -   id3tag: validate the year from v1 tags before passing to GstDateTime
  -   rtpbasepayload: fix sequence numbers when using buffer lists
  -   rtspconnection: fix security issue, potential heap overflow 
(CVE-2019-9928)
  -   rtspconnection: fix GError set over the top of a previous GError
  -   rtspconnection: do not duplicate authentication headers
  -   subparse: don’t assert when failing to parse subrip timestamp
  -   video: various convert sample frame fixes
  -   video-converter: fix conversion from I420_10LE/BE, I420_12LE/BE, 
A420_10LE/BE to BGRA/RGBA which created corrupted output
  -   video-format: Fix GBRA_10/12 alpha channel pixel strides

  gst-plugins-good

  -   flv: Use 8kHz sample rate for alaw/mulaw audio
  -   flvdemux: Do not error out if the first added and chained pad is not 
linked
  -   flvmux: try harder to make sure timestamps are always increasing
  -   gdkpixbufdec: output a TIME segment which is what’s expected for raw video
  -   matroskademux: fix handling of MS ACM audio
  -   matroska: fix handling of FlagInterlaced
  -   pulsesink: Deal with not being able to convert a format to caps
  -   rtph265depay, rtph264depay; aggregation packet marker handling fixes
  -   rtpmp4gdepay: detect broken senders who send AAC with ADTS frames
  -   rtprawdepay: keep buffer pool around when flushing/seeking
  -   rtpssrcdemux: Forward serialized events to all pads
  -   qmlglsink: Handle OPENGL header guard changes
  -   qtdemux: fix track language code parsing; ignore corrupted CTTS box
  -   qtmux: Correctly set tkhd width/height to the display size
  -   splitmuxsink: various timecode meta handling fixes
  -   

[Touch-packages] [Bug 1832123] [NEW] [SRU] Bugfix release 1.14.5

2019-06-09 Thread Amr Ibrahim
Public bug reported:

[ Description ]

We should keep up with GStreamer's bugfix releases in the 1.14 series
that 18.04 shipped with.

[ QA and testing ]

Play a range of videos in Totem. Play a range of audio tracks in
Rhythmbox. Try to stream audio and/or video. Try to install a missing
codec.

In all cases, make sure that everything which worked before still works.

[ Regression potential ]

If one of the fixes is bad then it might break video or audio playback, or 
could crash any application that tries to use gstreamer.
---

Highlighted bugfixes in 1.14.5

GStreamer core

-   aggregator: take the pad lock around queue gap event removal
-   aggregator: don’t leak gap buffer when out of segment
-   buffer: fix possible memory corruption in gst_buffer_foreach_meta() when 
removing metas
-   bus: Make removing of signal/bus watches thread-safe
-   bus: Don’t allow removing signal watches with gst_bus_remove_watch()
-   controlbinding: Check if the weak pointer was cleared before explicitly 
removing it
-   ptp clock: Wait for ANNOUNCE before selecting a master; increase tolerance 
for late follow-up and delay-resp
-   segment: Allow stop == -1 in gst_segment_to_running_time() and negative rate
-   g-i: annotations fixes

gst-plugins-base

-   audioconvert: fix endianness conversion for unpacked formats (e.g. S24_32BE)
-   audioringbuffer: Fix wrong memcpy address when reordering channels
-   decodebin2: Make sure to remove pad probes when freeing GstDecodeGroup
-   glviewconvert: fix output when a transformation matrix is used
-   glupload: prevent segfault when updating caps
-   gl/egl: Determine correct format on dmabuf import
-   glupload: dmabuf: be explicit about gl formats used
-   id3tag: validate the year from v1 tags before passing to GstDateTime
-   rtpbasepayload: fix sequence numbers when using buffer lists
-   rtspconnection: fix security issue, potential heap overflow (CVE-2019-9928)
-   rtspconnection: fix GError set over the top of a previous GError
-   rtspconnection: do not duplicate authentication headers
-   subparse: don’t assert when failing to parse subrip timestamp
-   video: various convert sample frame fixes
-   video-converter: fix conversion from I420_10LE/BE, I420_12LE/BE, 
A420_10LE/BE to BGRA/RGBA which created corrupted output
-   video-format: Fix GBRA_10/12 alpha channel pixel strides

gst-plugins-good

-   flv: Use 8kHz sample rate for alaw/mulaw audio
-   flvdemux: Do not error out if the first added and chained pad is not linked
-   flvmux: try harder to make sure timestamps are always increasing
-   gdkpixbufdec: output a TIME segment which is what’s expected for raw video
-   matroskademux: fix handling of MS ACM audio
-   matroska: fix handling of FlagInterlaced
-   pulsesink: Deal with not being able to convert a format to caps
-   rtph265depay, rtph264depay; aggregation packet marker handling fixes
-   rtpmp4gdepay: detect broken senders who send AAC with ADTS frames
-   rtprawdepay: keep buffer pool around when flushing/seeking
-   rtpssrcdemux: Forward serialized events to all pads
-   qmlglsink: Handle OPENGL header guard changes
-   qtdemux: fix track language code parsing; ignore corrupted CTTS box
-   qtmux: Correctly set tkhd width/height to the display size
-   splitmuxsink: various timecode meta handling fixes
-   splitmuxsink: make work with audio-only encoders as muxers, e.g. wavenc
-   v4l2sink: fix pool-less allocation query handling
-   v4l2dec/enc: fix use after free when handling events
-   vpx: Fix build against libvpx 1.8
-   webmmux: allow resolutions above 4096

gst-plugins-ugly

-   sid: Fix cross-compilation by using AC_TRY_LINK instead of AC_TRY_RUN
-   x264: Only enable dynamic loading code for x264 before v253

gst-plugins-bad

-   assrender: fix disappearing subtitles when seeking back in time
-   decklinkvideosink: fix segfault when audiosink is closed before videosink
-   decklinkvideosrc: respect pixel format property even if mode is set to auto
-   d3dvideosink: Fix calculating buffer size of packed format; don’t leak 
thread object
-   dtls: Don’t abort on non-fatal issues, make work with newer OpenSSL versions
-   msdk: more robust error handling; fix intel sdk libdir path
-   nvenc: Ensure drain all frames on finish; fix element reuse and clean up 
properly
-   openh264dec: Fix handling of errors when doing EOS
-   shmsrc: fixes a crash when is-live is true due a race condition
-   shmsink: fix possible (racy) deadlock on shutdown
-   siren: Fix invalid floating point operation
-   tsdemux: Skew correction improvements: use upstream DTS if set
-   wasapi: number of segments was always 2 (the absolute minimum) by accident
-   wasapi: Fix infinite loop when the device disappears

gst-libav

-   libav: Update internal snapshot to ffmpeg n3.4.6
-   avdemux: fix negative pts if start_time is bigger than the ts

gst-rtsp-server

-   rtsp-client: Fix crash in close handler and remove timeout 

[Touch-packages] [Bug 1832019] Re: Error when going to 'Keyboard shortcuts' in 'Preferences'

2019-06-07 Thread Amr Ibrahim
** Also affects: qtbase-opensource-src (Ubuntu)
   Importance: Undecided
   Status: New

** Summary changed:

- Error when going to 'Keyboard shortcuts' in 'Preferences'
+ Error when going to 'Tools -> Preferences -> Keyboard shortcuts' in Spyder3

** Description changed:

  Steps:
- 
- 1. Start spyder
- 2. Go to Tools -> Preferences -> Keyboard shortcuts
- 3. Error
- 
- Keyboards shortcuts are not accessible.
+ 1. Install spyder3 (sudo apt install spyder3)
+ 2. Run spyder3
+ 3. Go to Tools -> Preferences -> Keyboard shortcuts
+ 4. Error
+ 
+ Keyboard shortcuts are not accessible.
  
  Here is the error:
  
-   File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
- textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
- TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
- Traceback (most recent call last):
-   File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
- textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
- TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
- Traceback (most recent call last):
-   File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
- textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
- TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
- Traceback (most recent call last):
-   File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
- textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
- TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
- Traceback (most recent call last):
-   File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
- textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
- TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
- Traceback (most recent call last):
-   File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
- textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
- TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
- Traceback (most recent call last):
-   File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
- textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
- TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
- Traceback (most recent call last):
-   File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
- textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
- TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
- Traceback (most recent call last):
-   File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
- textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
- TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
- Traceback (most recent call last):
-   File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
- textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
- TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
- Traceback (most recent call last):
-   File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
- textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
- TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
- Traceback (most recent call last):
-   File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
- textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
- TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
- Traceback (most recent call last):
-   File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
- textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
- TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
- Traceback (most recent call last):
-   File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint
- textRect = style.subElementRect(QStyle.SE_ItemViewItemText, options)
- TypeError: subElementRect(self, QStyle.SubElement, QStyleOption, QWidget): 
not enough arguments
- Traceback (most recent call last):
-   File "/usr/lib/python3/dist-packages/spyder/widgets/helperwidgets.py", line 
127, in paint

[Touch-packages] [Bug 1830807] Re: Update to bug-fix release Qt 5.9.8 to fix security issues in qtwebengine in Bionic

2019-05-28 Thread Amr Ibrahim
** No longer affects: qtbase-opensource-src (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to qtbase-opensource-src in
Ubuntu.
https://bugs.launchpad.net/bugs/1830807

Title:
  Update to bug-fix release Qt 5.9.8 to fix security issues in
  qtwebengine in Bionic

Status in qtwebengine-opensource-src package in Ubuntu:
  New

Bug description:
  https://wiki.qt.io/Qt_5.9.6_Change_Files
  https://wiki.qt.io/Qt_5.9.7_Change_Files
  https://wiki.qt.io/Qt_5.9.8_Change_Files

  Upstream Qt 5.9 is a long-term support (LTS) release. Qt 5.9.8 is a
  bug-fix release. It maintains both forward and backward compatibility
  (source and binary) with Qt 5.9.0 through 5.9.7. It would be
  beneficial to have Qt 5.9.8 in Bionic.

  Qtwebengine 5.9.8 Changes
  https://code.qt.io/cgit/qt/qtwebengine.git/tree/dist/changes-5.9.8/?h=v5.9.8

  Chromium
  
   - Security fixes from Chromium up to version 72.0.3626.121
 * CVE-2018-17462
 * CVE-2018-17469
 * CVE-2018-17471
 * CVE-2018-17474
 * CVE-2018-17476
 * CVE-2018-17481
 * CVE-2018-18336
 * CVE-2018-18337
 * CVE-2018-18339
 * CVE-2018-18340
 * CVE-2018-18342
 * CVE-2018-18343
 * CVE-2018-18345
 * CVE-2018-18347
 * CVE-2018-18349
 * CVE-2018-18356
 * CVE-2019-5756
 * CVE-2019-5758
 * CVE-2019-5759
 * CVE-2019-5764
 * CVE-2019-5786
 * Security issue 872189
 * Security issue 877843
 * Security issue 880207
 * Security issue 899689
 * Security issue 900910
 * Security issue 911253
 * Security issue 922677

  The other Qt 5.8.9 components are also a bug-fix release.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/qtwebengine-opensource-src/+bug/1830807/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1830807] [NEW] Update to bug-fix release Qt 5.9.8 to fix security issues in qtwebengine in Bionic

2019-05-28 Thread Amr Ibrahim
Public bug reported:

https://wiki.qt.io/Qt_5.9.6_Change_Files
https://wiki.qt.io/Qt_5.9.7_Change_Files
https://wiki.qt.io/Qt_5.9.8_Change_Files

Upstream Qt 5.9 is a long-term support (LTS) release. Qt 5.9.8 is a bug-
fix release. It maintains both forward and backward compatibility
(source and binary) with Qt 5.9.0 through 5.9.7. It would be beneficial
to have Qt 5.9.8 in Bionic.

Qtwebengine 5.9.8 Changes
https://code.qt.io/cgit/qt/qtwebengine.git/tree/dist/changes-5.9.8/?h=v5.9.8

Chromium

 - Security fixes from Chromium up to version 72.0.3626.121
   * CVE-2018-17462
   * CVE-2018-17469
   * CVE-2018-17471
   * CVE-2018-17474
   * CVE-2018-17476
   * CVE-2018-17481
   * CVE-2018-18336
   * CVE-2018-18337
   * CVE-2018-18339
   * CVE-2018-18340
   * CVE-2018-18342
   * CVE-2018-18343
   * CVE-2018-18345
   * CVE-2018-18347
   * CVE-2018-18349
   * CVE-2018-18356
   * CVE-2019-5756
   * CVE-2019-5758
   * CVE-2019-5759
   * CVE-2019-5764
   * CVE-2019-5786
   * Security issue 872189
   * Security issue 877843
   * Security issue 880207
   * Security issue 899689
   * Security issue 900910
   * Security issue 911253
   * Security issue 922677

The other Qt 5.8.9 components are also a bug-fix release.

** Affects: qtwebengine-opensource-src (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: bionic

** Also affects: qtbase-opensource-src (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to qtbase-opensource-src in
Ubuntu.
https://bugs.launchpad.net/bugs/1830807

Title:
  Update to bug-fix release Qt 5.9.8 to fix security issues in
  qtwebengine in Bionic

Status in qtwebengine-opensource-src package in Ubuntu:
  New

Bug description:
  https://wiki.qt.io/Qt_5.9.6_Change_Files
  https://wiki.qt.io/Qt_5.9.7_Change_Files
  https://wiki.qt.io/Qt_5.9.8_Change_Files

  Upstream Qt 5.9 is a long-term support (LTS) release. Qt 5.9.8 is a
  bug-fix release. It maintains both forward and backward compatibility
  (source and binary) with Qt 5.9.0 through 5.9.7. It would be
  beneficial to have Qt 5.9.8 in Bionic.

  Qtwebengine 5.9.8 Changes
  https://code.qt.io/cgit/qt/qtwebengine.git/tree/dist/changes-5.9.8/?h=v5.9.8

  Chromium
  
   - Security fixes from Chromium up to version 72.0.3626.121
 * CVE-2018-17462
 * CVE-2018-17469
 * CVE-2018-17471
 * CVE-2018-17474
 * CVE-2018-17476
 * CVE-2018-17481
 * CVE-2018-18336
 * CVE-2018-18337
 * CVE-2018-18339
 * CVE-2018-18340
 * CVE-2018-18342
 * CVE-2018-18343
 * CVE-2018-18345
 * CVE-2018-18347
 * CVE-2018-18349
 * CVE-2018-18356
 * CVE-2019-5756
 * CVE-2019-5758
 * CVE-2019-5759
 * CVE-2019-5764
 * CVE-2019-5786
 * Security issue 872189
 * Security issue 877843
 * Security issue 880207
 * Security issue 899689
 * Security issue 900910
 * Security issue 911253
 * Security issue 922677

  The other Qt 5.8.9 components are also a bug-fix release.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/qtwebengine-opensource-src/+bug/1830807/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1829366] Re: [SRU] Bugfix release 1.14.4

2019-05-20 Thread Amr Ibrahim
There is some activity upstream on the 1.14 branches, so there might be a 
1.14.5, but I'm not sure:
https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/merge_requests/223
https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/merge_requests/198

Should this SRU wait for a 1.14.5 release?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gst-plugins-bad1.0 in
Ubuntu.
https://bugs.launchpad.net/bugs/1829366

Title:
  [SRU]  Bugfix release 1.14.4

Status in gst-libav1.0 package in Ubuntu:
  Fix Released
Status in gst-plugins-bad1.0 package in Ubuntu:
  Fix Released
Status in gst-plugins-base1.0 package in Ubuntu:
  Fix Released
Status in gst-plugins-good1.0 package in Ubuntu:
  Fix Released
Status in gst-plugins-ugly1.0 package in Ubuntu:
  Fix Released
Status in gst-python1.0 package in Ubuntu:
  Fix Released
Status in gst-rtsp-server1.0 package in Ubuntu:
  Fix Released
Status in gstreamer-editing-services1.0 package in Ubuntu:
  Fix Released
Status in gstreamer-vaapi package in Ubuntu:
  Fix Released
Status in gstreamer1.0 package in Ubuntu:
  Fix Released
Status in gst-libav1.0 source package in Bionic:
  In Progress
Status in gst-plugins-bad1.0 source package in Bionic:
  In Progress
Status in gst-plugins-base1.0 source package in Bionic:
  In Progress
Status in gst-plugins-good1.0 source package in Bionic:
  In Progress
Status in gst-plugins-ugly1.0 source package in Bionic:
  In Progress
Status in gst-python1.0 source package in Bionic:
  In Progress
Status in gst-rtsp-server1.0 source package in Bionic:
  In Progress
Status in gstreamer-editing-services1.0 source package in Bionic:
  In Progress
Status in gstreamer-vaapi source package in Bionic:
  In Progress
Status in gstreamer1.0 source package in Bionic:
  In Progress

Bug description:
  [ Description ]

  We should keep up with GStreamer's bugfix releases in the 1.14 series
  that 18.04 shipped with.

  [ QA and testing ]

  Play a range of videos in Totem. Play a range of audio tracks in
  Rhythmbox. Try to stream audio and/or video. Try to install a missing
  codec.

  In all cases, make sure that everything which worked before still
  works.

  [ Regression potential ]

  If one of the fixes is bad then it might break video or audio
  playback, or could crash any application that tries to use gstreamer.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gst-libav1.0/+bug/1829366/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1827764] Re: bug when you add a GMAIL account

2019-05-05 Thread Amr Ibrahim
** Package changed: ubuntu-release-upgrader (Ubuntu) => gnome-online-
accounts (Ubuntu)

** Summary changed:

- bug when you add a GMAIL account
+ GOA cannot add a Gmail account of a minor (young child who needs consent)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gnome-online-accounts in
Ubuntu.
https://bugs.launchpad.net/bugs/1827764

Title:
  GOA cannot add a Gmail account of a minor (young child who needs
  consent)

Status in gnome-online-accounts package in Ubuntu:
  New

Bug description:
  Hello
  I am user of ubuntu 18.04 with gnome version 3.28.2 and it seems that I have 
found a bug when a GMAIL account is added.
  I have a problem setting up my child's GMAIL account (minor). The normal 
thing in any web browser is that when entering the GMAIL website, enter the 
data of them and then have to enter mine to consent to their access. In the 
GNOME directly blocks access when entering from ONLINE ACCOUNTS. Is there a 
solution for you to access? 
  Thanks and best regards

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: ubuntu-release-upgrader-core 1:18.04.31
  ProcVersionSignature: Ubuntu 4.18.0-18.19~18.04.1-generic 4.18.20
  Uname: Linux 4.18.0-18-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.6
  Architecture: amd64
  CrashDB: ubuntu
  CurrentDesktop: ubuntu:GNOME
  Date: Sun May  5 07:43:54 2019
  InstallationDate: Installed on 2019-04-07 (27 days ago)
  InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 
(20190210)
  PackageArchitecture: all
  SourcePackage: ubuntu-release-upgrader
  Symptom: dist-upgrade
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-online-accounts/+bug/1827764/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1592177] Re: Focus drops from search input in GtkFileChooserDialog after first character, which stops searching (broken behaviour)

2019-04-30 Thread Amr Ibrahim
When you want to file a bug against a certain package, you type the name
of the source package, which is gtk+3.0 here. You can find the name of a
source package from its Launchpad page at the top under the Ubuntu title
(here for example https://launchpad.net/ubuntu/+source/gtk+3.0).

So you run:
ubuntu-bug gtk+3.0

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gtk+3.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1592177

Title:
  Focus drops from search input in GtkFileChooserDialog after first
  character, which stops searching (broken behaviour)

Status in GTK+:
  Expired
Status in Ubuntu GNOME:
  New
Status in gtk+3.0 package in Ubuntu:
  Fix Released
Status in gtk+3.0 source package in Bionic:
  Fix Committed
Status in gtk+3.0 source package in Cosmic:
  Fix Committed
Status in gtk+3.0 source package in Disco:
  Fix Released

Bug description:
  * Impact
  The focus gets removed from the search entry widget in the fileselector while 
typing which makes it difficult to use

  * Test case

  Steps:
  1. Open Gedit
  2. Choose Open -> Other Documents... to open a GtkFileChooserDialog
  3. Press on the search button next to Open
  4. Type what you are searching for

  Expected behaviour:
  Focus remains in the search input until I finish typing then results come up

  What happens instead:
  Searching stops after I enter the first characters because focus is lost from 
the search input

  * Regression potential

  The change is desactivating/reactivating typeahead in the gtk
  fileselector, check that this feature keeps working as it should
  (keyboard navigate by typing the first chars of a file/folder, that
  should move the focus to the first matching item and allows to
  navigate by hitting enter)

  

  I have noticed that after upgrading to GNOME 3.20 on Ubuntu GNOME
  16.04 that the built-in search functionality is almost impossible to
  use in the GTK file chooser (though it is the same one that allows you
  to save files as well as choose them).

  So if one types something into the search, after they have typed the
  first letter it will immediately select the top search result meaning
  one has to re-select the search box, this happens for every letter so
  searching for a long string becomes very annoying. If one carries on
  typing once it has selected the top result and unselected the search
  box it will start searching in the other search which only looks at
  results.

  Upstream bug:
  https://gitlab.gnome.org/GNOME/gtk/issues/1572


  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: libgtk-3-0 3.22.30-1ubuntu1

To manage notifications about this bug go to:
https://bugs.launchpad.net/gtk/+bug/1592177/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1592177] Re: Focus drops from search input in GtkFileChooserDialog after first character, which stops searching (broken behaviour)

2019-04-30 Thread Amr Ibrahim
** Tags removed: verification-needed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gtk+3.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1592177

Title:
  Focus drops from search input in GtkFileChooserDialog after first
  character, which stops searching (broken behaviour)

Status in GTK+:
  Expired
Status in Ubuntu GNOME:
  New
Status in gtk+3.0 package in Ubuntu:
  Fix Released
Status in gtk+3.0 source package in Bionic:
  Fix Committed
Status in gtk+3.0 source package in Cosmic:
  Fix Committed
Status in gtk+3.0 source package in Disco:
  Fix Released

Bug description:
  * Impact
  The focus gets removed from the search entry widget in the fileselector while 
typing which makes it difficult to use

  * Test case

  Steps:
  1. Open Gedit
  2. Choose Open -> Other Documents... to open a GtkFileChooserDialog
  3. Press on the search button next to Open
  4. Type what you are searching for

  Expected behaviour:
  Focus remains in the search input until I finish typing then results come up

  What happens instead:
  Searching stops after I enter the first characters because focus is lost from 
the search input

  * Regression potential

  The change is desactivating/reactivating typeahead in the gtk
  fileselector, check that this feature keeps working as it should
  (keyboard navigate by typing the first chars of a file/folder, that
  should move the focus to the first matching item and allows to
  navigate by hitting enter)

  

  I have noticed that after upgrading to GNOME 3.20 on Ubuntu GNOME
  16.04 that the built-in search functionality is almost impossible to
  use in the GTK file chooser (though it is the same one that allows you
  to save files as well as choose them).

  So if one types something into the search, after they have typed the
  first letter it will immediately select the top search result meaning
  one has to re-select the search box, this happens for every letter so
  searching for a long string becomes very annoying. If one carries on
  typing once it has selected the top result and unselected the search
  box it will start searching in the other search which only looks at
  results.

  Upstream bug:
  https://gitlab.gnome.org/GNOME/gtk/issues/1572


  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: libgtk-3-0 3.22.30-1ubuntu1

To manage notifications about this bug go to:
https://bugs.launchpad.net/gtk/+bug/1592177/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1821768] Re: Java-gtk3 theming has many artefacts after updating to openjdk-11 in bionic-proposed

2019-03-26 Thread Amr Ibrahim
Yes, the screenshots are similar.

** Package changed: ubuntu-themes (Ubuntu) => openjdk-lts (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-themes in Ubuntu.
https://bugs.launchpad.net/bugs/1821768

Title:
  Java-gtk3 theming has many artefacts after updating to openjdk-11 in
  bionic-proposed

Status in openjdk-lts package in Ubuntu:
  New

Bug description:
  Openjdk-11 is now in bionic-proposed, and apparently it has switched
  to gtk3. The gtk3-java theming in Ambiance theme is very incomplete in
  Bionic. I can see a lot of theming artefacts in scilab (default look)
  and jabref (after switching to gtk look) from bionic-proposed.

  Steps to compare between java-gtk2 and java-gtk3 theming in Ambiance
  on Bionic:

  A. For java-gtk2:
  1. Don't update to openjdk-11 in bionic-proposed
  2. Install jabref 3.8.2+ds-3
  3. Change the look in Preferences to Gtk
  4. Notice that the app is properly themed

  B. For java-gtk3:
  5. Install jabref 3.8.2+ds-12~18.04 from bionic-proposed
  6. Change the look in Preferences to Gtk
  5. Notice that the theming has many artefacts compared to the previous version

  The same steps can be followed to compare scilab before and after.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: light-themes 16.10+18.04.20181005-0ubuntu1
  ProcVersionSignature: Ubuntu 4.18.0-16.17~18.04.1-generic 4.18.20
  Uname: Linux 4.18.0-16-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.6
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Tue Mar 26 16:17:52 2019
  InstallationDate: Installed on 2018-11-29 (116 days ago)
  InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 
(20180725)
  PackageArchitecture: all
  SourcePackage: ubuntu-themes
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openjdk-lts/+bug/1821768/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1821768] [NEW] Java-gtk3 theming has many artefacts after updating to openjdk-11 in bionic-proposed

2019-03-26 Thread Amr Ibrahim
Public bug reported:

Openjdk-11 is now in bionic-proposed, and apparently it has switched to
gtk3. The gtk3-java theming in Ambiance theme is very incomplete in
Bionic. I can see a lot of theming artefacts in scilab (default look)
and jabref (after switching to gtk look) from bionic-proposed.

Steps to compare between java-gtk2 and java-gtk3 theming in Ambiance on
Bionic:

A. For java-gtk2:
1. Don't update to openjdk-11 in bionic-proposed
2. Install jabref 3.8.2+ds-3
3. Change the look in Preferences to Gtk
4. Notice that the app is properly themed

B. For java-gtk3:
5. Install jabref 3.8.2+ds-12~18.04 from bionic-proposed
6. Change the look in Preferences to Gtk
5. Notice that the theming has many artefacts compared to the previous version

The same steps can be followed to compare scilab before and after.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: light-themes 16.10+18.04.20181005-0ubuntu1
ProcVersionSignature: Ubuntu 4.18.0-16.17~18.04.1-generic 4.18.20
Uname: Linux 4.18.0-16-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.6
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Tue Mar 26 16:17:52 2019
InstallationDate: Installed on 2018-11-29 (116 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
PackageArchitecture: all
SourcePackage: ubuntu-themes
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: ubuntu-themes (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug bionic

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-themes in Ubuntu.
https://bugs.launchpad.net/bugs/1821768

Title:
  Java-gtk3 theming has many artefacts after updating to openjdk-11 in
  bionic-proposed

Status in ubuntu-themes package in Ubuntu:
  New

Bug description:
  Openjdk-11 is now in bionic-proposed, and apparently it has switched
  to gtk3. The gtk3-java theming in Ambiance theme is very incomplete in
  Bionic. I can see a lot of theming artefacts in scilab (default look)
  and jabref (after switching to gtk look) from bionic-proposed.

  Steps to compare between java-gtk2 and java-gtk3 theming in Ambiance
  on Bionic:

  A. For java-gtk2:
  1. Don't update to openjdk-11 in bionic-proposed
  2. Install jabref 3.8.2+ds-3
  3. Change the look in Preferences to Gtk
  4. Notice that the app is properly themed

  B. For java-gtk3:
  5. Install jabref 3.8.2+ds-12~18.04 from bionic-proposed
  6. Change the look in Preferences to Gtk
  5. Notice that the theming has many artefacts compared to the previous version

  The same steps can be followed to compare scilab before and after.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: light-themes 16.10+18.04.20181005-0ubuntu1
  ProcVersionSignature: Ubuntu 4.18.0-16.17~18.04.1-generic 4.18.20
  Uname: Linux 4.18.0-16-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.6
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Tue Mar 26 16:17:52 2019
  InstallationDate: Installed on 2018-11-29 (116 days ago)
  InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 
(20180725)
  PackageArchitecture: all
  SourcePackage: ubuntu-themes
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-themes/+bug/1821768/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1818812] [NEW] glib: Fix named destinations

2019-03-06 Thread Amr Ibrahim
Public bug reported:

IMPACT
---
Evince does not follow internal links in some PDF research articles (affects 
Evince 3.28.4 + Poppler 0.62.0 on Ubuntu 18.04)
https://gitlab.gnome.org/GNOME/evince/issues/1070

PDF's link annotation does not work in Evince 3.30.2
https://gitlab.gnome.org/GNOME/evince/issues/1027

Evince does not follow internal links in some PDF research articles. The 
internal links are used for easy and fast navigation to pages, figures, 
references and equations.
qpdfview (poppler-qt5 viewer) can follow the internal links in those files just 
fine.

DOI of one of the affected documents:
http://dx.doi.org/10.1016/j.apenergy.2016.10.058

Upstream fix:
https://gitlab.freedesktop.org/poppler/poppler/commit/44505cb397c46baa7dd4a0456f737f36e6d19ad0


TEST CASE
--
Clicking on the following parts should work after the fix is committed:

- Superscripts next to the authors names
- Citations in page 17 (e.g. [1], [9,11-18], [25-30])
- Figure and Table links in page 17 (Fig 1 and Table 1 at the beginning of 
section 2)
- Equations in page 19 (they stay in the same page as the equations are very 
close to their links)


REGRESSION POTENTIAL
-
This is quoted from the upstream commit:

"Named destinations may be described by bytestrings, containing embedded
NULs and not being NUL terminated. That means they cannot be exposed
directly as char*.

The alternatives are to escape the string from the internal representation when 
exposing it in the API (e.g. in PopplerDest.named_dest), or to add parallel API 
exposing it as GString, or GBytes. This patch chooses the first option, since 
the presence of these named destionations in the public, not sealed, 
PopplerDest struct means that the second option would need more API additions. 
The chosen option is simpler, and does not need the API users to adapt unless 
they create the named dest strings
themselves, or consume them in ways other than calling poppler APIs.

The escaping scheme chosen simply replaces embedded NUL with "\0" and
escapes a literal backslash with "\\".  This is a minimal ABI change in
that some strings that previously worked unchanged as destinations
(those containing backslash) now don't work, but on the other hand,
previously it was impossible to use any destinations containing embedded
NULs.

Add poppler_named_dest_{from,to}_bytestring() to perform that
conversion, and clarify the documentation for when you need them."

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: libpoppler-glib8 0.62.0-2ubuntu2.7
ProcVersionSignature: Ubuntu 4.18.0-15.16~18.04.1-generic 4.18.20
Uname: Linux 4.18.0-15-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.5
Architecture: amd64
CurrentDesktop: communitheme:ubuntu:GNOME
Date: Wed Mar  6 10:57:53 2019
InstallationDate: Installed on 2018-11-29 (96 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
SourcePackage: poppler
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: poppler (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug bionic wayland-session

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to poppler in Ubuntu.
https://bugs.launchpad.net/bugs/1818812

Title:
  glib: Fix named destinations

Status in poppler package in Ubuntu:
  New

Bug description:
  IMPACT
  ---
  Evince does not follow internal links in some PDF research articles (affects 
Evince 3.28.4 + Poppler 0.62.0 on Ubuntu 18.04)
  https://gitlab.gnome.org/GNOME/evince/issues/1070

  PDF's link annotation does not work in Evince 3.30.2
  https://gitlab.gnome.org/GNOME/evince/issues/1027

  Evince does not follow internal links in some PDF research articles. The 
internal links are used for easy and fast navigation to pages, figures, 
references and equations.
  qpdfview (poppler-qt5 viewer) can follow the internal links in those files 
just fine.

  DOI of one of the affected documents:
  http://dx.doi.org/10.1016/j.apenergy.2016.10.058

  Upstream fix:
  
https://gitlab.freedesktop.org/poppler/poppler/commit/44505cb397c46baa7dd4a0456f737f36e6d19ad0

  
  TEST CASE
  --
  Clicking on the following parts should work after the fix is committed:

  - Superscripts next to the authors names
  - Citations in page 17 (e.g. [1], [9,11-18], [25-30])
  - Figure and Table links in page 17 (Fig 1 and Table 1 at the beginning of 
section 2)
  - Equations in page 19 (they stay in the same page as the equations are very 
close to their links)

  
  REGRESSION POTENTIAL
  -
  This is quoted from the upstream commit:

  "Named destinations may be described by bytestrings, containing
  embedded NULs and not being NUL terminated. That means they cannot be
  exposed directly as char*.

  The alternatives are to escape the string from the internal representation 
when exposing it in the API (e.g. in PopplerDest.named_dest), or to 

[Touch-packages] [Bug 1818422] Re: Totem: DBus reports wrong .desktop file name

2019-03-03 Thread Amr Ibrahim
** Package changed: mesa (Ubuntu) => totem (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1818422

Title:
  Totem: DBus reports wrong .desktop file name

Status in totem package in Ubuntu:
  New

Bug description:
  
  Totem - MPRIS2 - DBus-interface: 
  My application is asking Totem (video player) various data via (MPRIS2) 
DBus-interface.

  When asking "DesktopEntry", totem return value "totem" (meaning 
totem.desktop).  
  That is probably wrong.

  Ubuntu 19.10 has no "totem.desktop" file.
  $ updatedb
  $ locate totem.desktop

  The right answer would be "org.gnome.Totem". That is 
  /usr/share/applications/org.gnome.Totem.desktop

  Please see:
  
https://specifications.freedesktop.org/mpris-spec/latest/Media_Player.html#Property:Identity

  Please fix it.

  Kindly
Moma Antero

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/totem/+bug/1818422/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1772898] Re: [SRU] New stable release 1.14.1

2019-02-28 Thread Amr Ibrahim
Hi, should I open a new bug to update to Gstreamer 1.14.4 in 18.04?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gst-plugins-base1.0 in
Ubuntu.
https://bugs.launchpad.net/bugs/1772898

Title:
  [SRU] New stable release 1.14.1

Status in gst-libav1.0 package in Ubuntu:
  Fix Released
Status in gst-plugins-bad1.0 package in Ubuntu:
  Fix Released
Status in gst-plugins-base1.0 package in Ubuntu:
  Fix Released
Status in gst-plugins-good1.0 package in Ubuntu:
  Fix Released
Status in gst-plugins-ugly1.0 package in Ubuntu:
  Fix Released
Status in gst-python1.0 package in Ubuntu:
  Fix Released
Status in gst-rtsp-server1.0 package in Ubuntu:
  Fix Released
Status in gstreamer-editing-services1.0 package in Ubuntu:
  Fix Released
Status in gstreamer-vaapi package in Ubuntu:
  Fix Released
Status in gstreamer1.0 package in Ubuntu:
  Fix Released
Status in gst-libav1.0 source package in Bionic:
  Fix Released
Status in gst-plugins-bad1.0 source package in Bionic:
  Fix Released
Status in gst-plugins-base1.0 source package in Bionic:
  Fix Released
Status in gst-plugins-good1.0 source package in Bionic:
  Fix Released
Status in gst-plugins-ugly1.0 source package in Bionic:
  Fix Released
Status in gst-python1.0 source package in Bionic:
  Fix Released
Status in gst-rtsp-server1.0 source package in Bionic:
  Fix Released
Status in gstreamer-editing-services1.0 source package in Bionic:
  Fix Released
Status in gstreamer-vaapi source package in Bionic:
  Fix Released
Status in gstreamer1.0 source package in Bionic:
  Fix Released

Bug description:
  [ Description ]

  We should keep up with GStreamer's bugfix releases in the 1.14 series
  that 18.04 shipped with.

  [ QA and testing ]

  Play a range of videos in Totem. Play a range of audio tracks in
  Rhythmbox. Try to stream audio and/or video. Try to install a missing
  codec.

  In all cases, make sure that everything which worked before still
  works.

  [ Regression potential ]

  One of the fixes could be bad. Watch out for it.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gst-libav1.0/+bug/1772898/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1814133] Re: update to openjdk 11 in 18.04 LTS

2019-02-22 Thread Amr Ibrahim
Thanks Tiago for the answer. Those four apps specifically are widely
used in the scientific and academic fields, as seen in my university for
example. And I'm ready for testing when needed.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gettext in Ubuntu.
https://bugs.launchpad.net/bugs/1814133

Title:
  update to openjdk 11 in 18.04 LTS

Status in ca-certificates-java package in Ubuntu:
  New
Status in gettext package in Ubuntu:
  New
Status in gradle package in Ubuntu:
  New
Status in groovy package in Ubuntu:
  New
Status in insubstantial package in Ubuntu:
  New
Status in jasperreports package in Ubuntu:
  New
Status in java-common package in Ubuntu:
  New
Status in javatools package in Ubuntu:
  New
Status in jaxws-api package in Ubuntu:
  New
Status in junit4 package in Ubuntu:
  New
Status in jws-api package in Ubuntu:
  New
Status in jython package in Ubuntu:
  New
Status in libgpars-groovy-java package in Ubuntu:
  New
Status in libhibernate-validator-java package in Ubuntu:
  New
Status in logback package in Ubuntu:
  New
Status in maven-bundle-plugin package in Ubuntu:
  New
Status in maven-enforcer package in Ubuntu:
  New
Status in maven-javadoc-plugin package in Ubuntu:
  New
Status in maven-jaxb2-plugin package in Ubuntu:
  New
Status in maven-plugin-tools package in Ubuntu:
  New
Status in metro-policy package in Ubuntu:
  New
Status in openjdk-11-jre-dcevm package in Ubuntu:
  New
Status in openjdk-lts package in Ubuntu:
  New
Status in openjfx package in Ubuntu:
  New
Status in saaj package in Ubuntu:
  New
Status in scala package in Ubuntu:
  New
Status in clojure1.8 source package in Bionic:
  Fix Committed
Status in dd-plist source package in Bionic:
  Fix Committed
Status in gradle source package in Bionic:
  Fix Committed
Status in gradle-debian-helper source package in Bionic:
  Fix Committed
Status in groovy source package in Bionic:
  Fix Committed
Status in jtreg source package in Bionic:
  Fix Committed
Status in libcommons-lang3-java source package in Bionic:
  Fix Committed
Status in maven-compiler-plugin source package in Bionic:
  Fix Committed
Status in maven-debian-helper source package in Bionic:
  Fix Committed
Status in plexus-languages source package in Bionic:
  Fix Committed
Status in surefire source package in Bionic:
  Fix Committed
Status in testng source package in Bionic:
  Fix Committed

Bug description:
  Transition OpenJDK 11 to 18.04 LTS.

  This transition is a security update of openjdk-lts from openjdk-10 to
  openjdk-11. This introduces runtime and FTBFS issues which requires
  backports of multiple packages into the security pocket as well.

  The packages are being build on PPAs under the
  https://launchpad.net/~openjdk-11-transition team. The PPAs depend
  solely on the security pocket and are separated in stages.

  The agreed process among foundations and the security team is that
  packages in the PPAs will be binary copied into bionic-proposed,
  checked for migration issues, and - no issues pending - copied into
  bionic-security.

  NOTE TO SRU MEMBERS: The packages are to be released into bionic-
  security ONLY. This will be done/decided by the security team.

  A few packages might also need to be updated in Cosmic, but as an
  exception that will be done after the Bionic transition is worked out.

  [2019-02-21]
  Packages in stage 1 and stage 2 have been verified by the security team and 
are ready to be copied into bionic-proposed.

  Notes:
   - jtreg and testng are new versions required as build dependencies of 
openjdk-11
   - all other packages are backports that must be build/bootstrapped with 
openjdk-10

  PPAs:
  https://launchpad.net/~openjdk-11-transition/+archive/ubuntu/stage1
  https://launchpad.net/~openjdk-11-transition/+archive/ubuntu/stage2

  Please copy them in the following order/grouping.

  Group 1:
  * maven-debian-helper 2.3.2~18.04.1 Tiago Stürmer Daitx (2019-02-05)

  Group 2:
  * dd-plist 1.20-1~18.04.1 Tiago Stürmer Daitx (2019-02-05)
  * libcommons-lang3-java 3.8-1~18.04.2 Tiago Stürmer Daitx (2019-02-05)
  * plexus-languages 0.9.10-1~18.04.1 Tiago Stürmer Daitx (2019-02-05)
  * testng 6.9.12-2ubuntu1 Tiago Stürmer Daitx (2019-02-05)

  Please upload libcommons-lang3-java from stage 2 (ignore the version
  in stage 1).

  Group 3:
  * clojure1.8 1.8.0-7ubuntu1~18.04.1 Tiago Stürmer Daitx (2019-02-06)
  * gradle 4.4.1-3~18.04.1 Tiago Stürmer Daitx (2019-02-05)
  * jtreg 4.2-b13-1ubuntu0.1~18.04.1 Tiago Stürmer Daitx (2019-02-05)
  * maven-compiler-plugin 3.8.0-1ubuntu1~18.04.1 Tiago Stürmer Daitx 
(2019-02-05)
  * surefire 2.22.0-1~18.04.1 Tiago Stürmer Daitx (2019-02-05)

  Group 4:
  * gradle-debian-helper 2.0.2~18.04.1 Tiago Stürmer Daitx (2019-02-05)

  Group 5:
  * groovy 2.4.16-1ubuntu1~18.04.1 Tiago Stürmer Daitx (2019-02-05)

  
  [2019-02-22]
  Packages in stage 3 that are waiting for security team review. Copy only 
after OK is 

[Touch-packages] [Bug 1814133] Re: update to openjdk 11 in 18.04 LTS

2019-02-21 Thread Amr Ibrahim
Just a question, is this update going to affect these packages:
jabref
scilab
octave
pdfsam
?

Also, I hope this update brings 18.04 LTS closer to Debian 10 regarding
OpenJdk-11 and its dependant packages to facilitate the maintenance
burden.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gettext in Ubuntu.
https://bugs.launchpad.net/bugs/1814133

Title:
  update to openjdk 11 in 18.04 LTS

Status in ca-certificates-java package in Ubuntu:
  New
Status in clojure1.8 package in Ubuntu:
  New
Status in dd-plist package in Ubuntu:
  New
Status in gettext package in Ubuntu:
  New
Status in gradle package in Ubuntu:
  New
Status in gradle-debian-helper package in Ubuntu:
  New
Status in groovy package in Ubuntu:
  New
Status in jaxws-api package in Ubuntu:
  New
Status in jtreg package in Ubuntu:
  New
Status in junit4 package in Ubuntu:
  New
Status in jws-api package in Ubuntu:
  New
Status in jython package in Ubuntu:
  New
Status in libcommons-lang3-java package in Ubuntu:
  New
Status in maven-compiler-plugin package in Ubuntu:
  New
Status in maven-debian-helper package in Ubuntu:
  New
Status in metro-policy package in Ubuntu:
  New
Status in openjdk-11-jre-dcevm package in Ubuntu:
  New
Status in openjdk-lts package in Ubuntu:
  New
Status in openjfx package in Ubuntu:
  New
Status in plexus-languages package in Ubuntu:
  New
Status in saaj package in Ubuntu:
  New
Status in saaj-ri package in Ubuntu:
  New
Status in scala package in Ubuntu:
  New
Status in surefire package in Ubuntu:
  New
Status in testng package in Ubuntu:
  New
Status in clojure1.8 source package in Bionic:
  Fix Committed
Status in dd-plist source package in Bionic:
  Fix Committed
Status in gradle source package in Bionic:
  Fix Committed
Status in gradle-debian-helper source package in Bionic:
  Fix Committed
Status in groovy source package in Bionic:
  Fix Committed
Status in jtreg source package in Bionic:
  Fix Committed
Status in libcommons-lang3-java source package in Bionic:
  Fix Committed
Status in maven-compiler-plugin source package in Bionic:
  Fix Committed
Status in maven-debian-helper source package in Bionic:
  Fix Committed
Status in plexus-languages source package in Bionic:
  Fix Committed
Status in surefire source package in Bionic:
  Fix Committed
Status in testng source package in Bionic:
  Fix Committed

Bug description:
  Transition OpenJDK 11 to 18.04 LTS.

  This transition is a security update of openjdk-lts from openjdk-10 to
  openjdk-11. This introduces runtime and FTBFS issues which requires
  backports of multiple packages into the security pocket as well.

  The packages are being build on PPAs under the
  https://launchpad.net/~openjdk-11-transition team. The PPAs depend
  solely on the security pocket and are separated in stages.

  The agreed process among foundations and the security team is that
  packages in the PPAs will be binary copied into bionic-proposed,
  checked for migration issues, and - no issues pending - copied into
  bionic-security.

  NOTE TO SRU MEMBERS: The packages are to be released into bionic-
  security ONLY. This will be done/decided by the security team.

  A few packages might also need to be updated in Cosmic, but as an
  exception that will be done after the Bionic transition is worked out.

  [2018-02-21]
  Packages in stage 1 and stage 2 have been verified by the security team and 
are ready to be copied into bionic-proposed.

  Notes:
   - jtreg and testng are new versions required as build dependencies of 
openjdk-11
   - all other packages are backports that must be build/bootstrapped with 
openjdk-10

  PPAs:
  https://launchpad.net/~openjdk-11-transition/+archive/ubuntu/stage1
  https://launchpad.net/~openjdk-11-transition/+archive/ubuntu/stage2

  Please copy them in the following order/grouping.

  Group 1:
  * maven-debian-helper 2.3.2~18.04.1 Tiago Stürmer Daitx (2019-02-05)

  Group 2:
  * dd-plist 1.20-1~18.04.1 Tiago Stürmer Daitx (2019-02-05)
  * libcommons-lang3-java 3.8-1~18.04.2 Tiago Stürmer Daitx (2019-02-05)
  * plexus-languages 0.9.10-1~18.04.1 Tiago Stürmer Daitx (2019-02-05)
  * testng 6.9.12-2ubuntu1 Tiago Stürmer Daitx (2019-02-05)

  Please upload libcommons-lang3-java from stage 2 (ignore the version
  in stage 1).

  Group 3:
  * clojure1.8 1.8.0-7ubuntu1~18.04.1 Tiago Stürmer Daitx (2019-02-06)
  * gradle 4.4.1-3~18.04.1 Tiago Stürmer Daitx (2019-02-05)
  * jtreg 4.2-b13-1ubuntu0.1~18.04.1 Tiago Stürmer Daitx (2019-02-05)
  * maven-compiler-plugin 3.8.0-1ubuntu1~18.04.1 Tiago Stürmer Daitx 
(2019-02-05)
  * surefire 2.22.0-1~18.04.1 Tiago Stürmer Daitx (2019-02-05)

  Group 4:
  * gradle-debian-helper 2.0.2~18.04.1 Tiago Stürmer Daitx (2019-02-05)

  Group 5:
  * groovy 2.4.16-1ubuntu1~18.04.1 Tiago Stürmer Daitx (2019-02-05)

  Packages from stage 3 and later are not yet reviewed and should not be
  uploaded.

To manage notifications about this bug go to:

[Touch-packages] [Bug 1814506] Re: Use nemo-desktop to draw desktop icons under Unity (Disco)

2019-02-14 Thread Amr Ibrahim
Yes, I understand that users will not see nemo, but the memory will :)
But I get why nautilus is hard to let go.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-themes in Ubuntu.
https://bugs.launchpad.net/bugs/1814506

Title:
  Use nemo-desktop to draw desktop icons under Unity (Disco)

Status in ubuntu-settings package in Ubuntu:
  New
Status in ubuntu-themes package in Ubuntu:
  Fix Released
Status in unity package in Ubuntu:
  Fix Released

Bug description:
  As nautilus > 3.30 is now uploaded in Ubuntu 19.10, it doesn't have
  the desktop any more. The alternate options are to use caja-desktop or
  nemo-desktop keeping nautilus default file manger for now. Since nemo-
  desktop does not require any extensive patching it is easy to use
  under unity.

  Nemo-desktop will only draw the icons, not the background. In absence of
  nautilus unity-settings-daemon draws the background, so nothing to do in 
u-s-d.

  There are few small patches (nemo action files) required from nemo. 
@fossfreedom (ubuntu-budgie-dev) suggested that it's better that we ship 
  these action files ourselves as recommended by upstream. Budgie is doing the 
same.
  
https://github.com/UbuntuBudgie/budgie-desktop-environment/tree/master/nemo-actions

  
  Since nautilus still be default file-manager we disable auto-mount with nemo 
and various other cinnamon/nemo option in ubuntu-settings.gsettings-override

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-settings/+bug/1814506/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1814506] Re: Use nemo-desktop to draw desktop icons under Unity (Disco)

2019-02-14 Thread Amr Ibrahim
Just a comment, does that mean that two file managers will always be run
in the background? If so, why not just use nemo and drop nautilus
completely?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-themes in Ubuntu.
https://bugs.launchpad.net/bugs/1814506

Title:
  Use nemo-desktop to draw desktop icons under Unity (Disco)

Status in ubuntu-settings package in Ubuntu:
  New
Status in ubuntu-themes package in Ubuntu:
  Fix Released
Status in unity package in Ubuntu:
  Fix Released

Bug description:
  As nautilus > 3.30 is now uploaded in Ubuntu 19.10, it doesn't have
  the desktop any more. The alternate options are to use caja-desktop or
  nemo-desktop keeping nautilus default file manger for now. Since nemo-
  desktop does not require any extensive patching it is easy to use
  under unity.

  Nemo-desktop will only draw the icons, not the background. In absence of
  nautilus unity-settings-daemon draws the background, so nothing to do in 
u-s-d.

  There are few small patches (nemo action files) required from nemo. 
@fossfreedom (ubuntu-budgie-dev) suggested that it's better that we ship 
  these action files ourselves as recommended by upstream. Budgie is doing the 
same.
  
https://github.com/UbuntuBudgie/budgie-desktop-environment/tree/master/nemo-actions

  
  Since nautilus still be default file-manager we disable auto-mount with nemo 
and various other cinnamon/nemo option in ubuntu-settings.gsettings-override

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-settings/+bug/1814506/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


  1   2   3   4   5   6   >