[Touch-packages] [Bug 1753572] Re: cpio in Busybox 1.27 ingnores "unsafe links"

2019-02-18 Thread Bryan Seitz
Yes, 1.27.2-2ubuntu3.1 looks to fix the issue with 1.27.2-2ubuntu3! Thanks! -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to busybox in Ubuntu. https://bugs.launchpad.net/bugs/1753572 Title: cpio in Busybox 1.27 ingnores

[Touch-packages] [Bug 1753572] Re: cpio in Busybox 1.27 ingnores "unsafe links"

2019-02-01 Thread Bryan Seitz
I have the image, how can I get it to you privately to test? (Or alternatively, I can test it with the new version if you have a link?) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to busybox in Ubuntu.

[Touch-packages] [Bug 1753572] Re: cpio in Busybox 1.27 ingnores "unsafe links"

2019-01-30 Thread Bryan Seitz
Creating image now. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to busybox in Ubuntu. https://bugs.launchpad.net/bugs/1753572 Title: cpio in Busybox 1.27 ingnores "unsafe links" Status in busybox package in Ubuntu: Fix

[Touch-packages] [Bug 1753572] Re: cpio in Busybox 1.27 ingnores "unsafe links"

2019-01-24 Thread Bryan Seitz
Yeah apologies, I have to allocate another U18 host and build one. Will aim for tomorrow. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to busybox in Ubuntu. https://bugs.launchpad.net/bugs/1753572 Title: cpio in Busybox

[Touch-packages] [Bug 1753572] Re: cpio in Busybox 1.27 ingnores "unsafe links"

2019-01-17 Thread Bryan Seitz
I was using it to build a U18 debirf image when I saw this issue. I can generate one in a bit for you. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to busybox in Ubuntu. https://bugs.launchpad.net/bugs/1753572 Title: cpio

[Touch-packages] [Bug 1753572] Re: cpio in Busybox 1.27 ingnores "unsafe links"

2018-07-06 Thread Bryan Seitz
This does look good now, thanks! -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to busybox in Ubuntu. https://bugs.launchpad.net/bugs/1753572 Title: cpio in Busybox 1.27 ingnores "unsafe links" Status in busybox package in

[Touch-packages] [Bug 1753572] Re: cpio in Busybox 1.27 ingnores "unsafe links"

2018-03-05 Thread Bryan Seitz
** Project changed: busybox => debirf (Ubuntu) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to busybox in Ubuntu. https://bugs.launchpad.net/bugs/1753572 Title: cpio in Busybox 1.27 ingnores "unsafe links" Status in

[Touch-packages] [Bug 1753572] Re: cpio in Busybox 1.27 ingnores "unsafe links"

2018-03-05 Thread Bryan Seitz
** Also affects: busybox Importance: Undecided Status: New -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to busybox in Ubuntu. https://bugs.launchpad.net/bugs/1753572 Title: cpio in Busybox 1.27 ingnores "unsafe

[Touch-packages] [Bug 1753572] Re: cpio in Busybox 1.27 ingnores "unsafe links"

2018-03-05 Thread Bryan Seitz
Proposed solution: back port the env var patch or upgrade to 1.28. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to busybox in Ubuntu. https://bugs.launchpad.net/bugs/1753572 Title: cpio in Busybox 1.27 ingnores "unsafe

[Touch-packages] [Bug 1753572] [NEW] cpio in Busybox 1.27 ingnores "unsafe links"

2018-03-05 Thread Bryan Seitz
Public bug reported: Description:Ubuntu Bionic Beaver (development branch) Release:18.04 busybox: Installed: 1:1.27.2-2ubuntu3 Candidate: 1:1.27.2-2ubuntu3 3) Expected my CPIO archive to be fully extracted with proper symlinks Command: unxz < /rootfs.cxz | cpio -i 4) 'Unsafe'

[Touch-packages] [Bug 1693941] [NEW] passing an absolute path for sources_list to cache.update does not work

2017-05-26 Thread Bryan Seitz
Public bug reported: Using python-apt 1.1.0~beta1build1. Calling cache like such: cache = apt.Cache(memonly=True, rootdir='/home/seitz/tmp/apt_root') cache.update(sources_list='/home/seitz/tmp/apt_root/etc/apt/sources-zesty.list') Would produce an empty cache :( If I copy the contents of

[Touch-packages] [Bug 1693930] [NEW] python-apt complains even if trusted=yes in sources.list

2017-05-26 Thread Bryan Seitz
Public bug reported: Any help would be appreciated. python-apt - 1.1.0~beta1build1 --- Python Code --- import apt import re import sys from distutils.version import LooseVersion cache = apt.Cache(memonly=True, rootdir='/home/seitz/tmp/apt_root') try:

[Touch-packages] [Bug 1693897] [NEW] It seems like sometimes 'archive' can't be found for a package

2017-05-26 Thread Bryan Seitz
Public bug reported: This is for: python-apt 1.4.0~beta2 I wrote a script to find the latest kernel available for each major.minor, per Ubuntu release (that I configure) and sometimes it spits out: Unknown distro for package: linux-image-3.2.0-23-generic - [] precise: 3.13: