[Touch-packages] [Bug 1925742] Re: Recent iCloud versions trigger an issue in IMAP x

2021-05-17 Thread Ivan D
Tested on: Ubuntu 21.04
Package: evolution-data-server 3.40.1-2 (from Impish-proposed)

There aren't packages for hursuit (21.04) but I just tried the impish
(21.10) package and works.

Thanks again

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to evolution-data-server in
Ubuntu.
https://bugs.launchpad.net/bugs/1925742

Title:
  Recent iCloud versions trigger an issue in IMAP x

Status in evolution-data-server package in Ubuntu:
  Fix Released
Status in evolution-data-server source package in Focal:
  Fix Committed

Bug description:
  * Impact

  The Icloud service introduced changes that are confusing evolution-
  data-server which means evolution is now failing to connect to the
  email server

  * Test case

  Set up an iCloud account and try to use it for emails in evolution

  * Regression potential

  The change is in the imapx connection code, it could create problems
  with other type of servers so we should try to test on different
  providers.

  
  -


  The bug has been fixed yesterday by Evolution's developer:
  https://gitlab.gnome.org/GNOME/evolution/-/issues/1468

  However, the package in Ubuntu (at least in Focal Fosa) still needs to
  be updated.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/evolution-data-server/+bug/1925742/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1925742] Re: Recent iCloud versions trigger an issue in IMAP x

2021-05-16 Thread Ivan D
Tested on: Ubuntu 20.04.2 LTS
Package: evolution-data-server 3.36.5-0ubuntu1 amd64

Personal iCloud account, now is solved.

Thanks

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to evolution-data-server in
Ubuntu.
https://bugs.launchpad.net/bugs/1925742

Title:
  Recent iCloud versions trigger an issue in IMAP x

Status in evolution-data-server package in Ubuntu:
  Fix Released
Status in evolution-data-server source package in Focal:
  Fix Committed

Bug description:
  * Impact

  The Icloud service introduced changes that are confusing evolution-
  data-server which means evolution is now failing to connect to the
  email server

  * Test case

  Set up an iCloud account and try to use it for emails in evolution

  * Regression potential

  The change is in the imapx connection code, it could create problems
  with other type of servers so we should try to test on different
  providers.

  
  -


  The bug has been fixed yesterday by Evolution's developer:
  https://gitlab.gnome.org/GNOME/evolution/-/issues/1468

  However, the package in Ubuntu (at least in Focal Fosa) still needs to
  be updated.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/evolution-data-server/+bug/1925742/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1915908] [NEW] package openssh-server 1:8.2p1-4ubuntu0.1 failed to install/upgrade: installed openssh-server package post-installation script subprocess returned error exit statu

2021-02-17 Thread Chetas D L
Public bug reported:

sh.service - OpenBSD Secure Shell server
 Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: 
enabled)
 Active: activating (auto-restart) (Result: exit-code) since Wed 2021-02-17 
15:42:28 IST; 11ms ago
   Docs: man:sshd(8)
 man:sshd_config(5)
Process: 24813 ExecStartPre=/usr/sbin/sshd -t (code=exited, 
status=255/EXCEPTION)
dpkg: error processing package openssh-server (--configure):
 installed openssh-server package post-installation script subprocess returned 
error exit status 1
Processing triggers for systemd (245.4-4ubuntu3.4) ...
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for ufw (0.36-6) ...
Errors were encountered while processing:
 openssh-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Package
DistroRelease: Ubuntu 20.04
Package: openssh-server 1:8.2p1-4ubuntu0.1
ProcVersionSignature: Ubuntu 5.4.0-65.73-generic 5.4.78
Uname: Linux 5.4.0-65-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.16
AptOrdering:
 openssh-server:amd64: Install
 NULL: ConfigurePending
Architecture: amd64
CasperMD5CheckResult: skip
Date: Wed Feb 17 15:42:28 2021
ErrorMessage: installed openssh-server package post-installation script 
subprocess returned error exit status 1
InstallationDate: Installed on 2021-01-05 (42 days ago)
InstallationMedia: Ubuntu 18.04.4 LTS "Bionic Beaver" - Release amd64 
(20200203.1)
Python3Details: /usr/bin/python3.8, Python 3.8.5, python3-minimal, 
3.8.2-0ubuntu2
PythonDetails: /usr/bin/python3.8, Python 3.8.5, python-is-python3, 3.8.2-4
RelatedPackageVersions:
 dpkg 1.19.7ubuntu3
 apt  2.0.4
SSHDConfig: Error: command ['/usr/sbin/sshd', '-T'] failed with exit code 255: 
/etc/ssh/sshd_config line 1: garbage at end of line; "to".
SourcePackage: openssh
Title: package openssh-server 1:8.2p1-4ubuntu0.1 failed to install/upgrade: 
installed openssh-server package post-installation script subprocess returned 
error exit status 1
UpgradeStatus: Upgraded to focal on 2021-02-04 (12 days ago)

** Affects: openssh (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package focal

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssh in Ubuntu.
https://bugs.launchpad.net/bugs/1915908

Title:
  package openssh-server 1:8.2p1-4ubuntu0.1 failed to install/upgrade:
  installed openssh-server package post-installation script subprocess
  returned error exit status 1

Status in openssh package in Ubuntu:
  New

Bug description:
  sh.service - OpenBSD Secure Shell server
   Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: 
enabled)
   Active: activating (auto-restart) (Result: exit-code) since Wed 
2021-02-17 15:42:28 IST; 11ms ago
 Docs: man:sshd(8)
   man:sshd_config(5)
  Process: 24813 ExecStartPre=/usr/sbin/sshd -t (code=exited, 
status=255/EXCEPTION)
  dpkg: error processing package openssh-server (--configure):
   installed openssh-server package post-installation script subprocess 
returned error exit status 1
  Processing triggers for systemd (245.4-4ubuntu3.4) ...
  Processing triggers for man-db (2.9.1-1) ...
  Processing triggers for ufw (0.36-6) ...
  Errors were encountered while processing:
   openssh-server
  E: Sub-process /usr/bin/dpkg returned an error code (1)

  ProblemType: Package
  DistroRelease: Ubuntu 20.04
  Package: openssh-server 1:8.2p1-4ubuntu0.1
  ProcVersionSignature: Ubuntu 5.4.0-65.73-generic 5.4.78
  Uname: Linux 5.4.0-65-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.16
  AptOrdering:
   openssh-server:amd64: Install
   NULL: ConfigurePending
  Architecture: amd64
  CasperMD5CheckResult: skip
  Date: Wed Feb 17 15:42:28 2021
  ErrorMessage: installed openssh-server package post-installation script 
subprocess returned error exit status 1
  InstallationDate: Installed on 2021-01-05 (42 days ago)
  InstallationMedia: Ubuntu 18.04.4 LTS "Bionic Beaver" - Release amd64 
(20200203.1)
  Python3Details: /usr/bin/python3.8, Python 3.8.5, python3-minimal, 
3.8.2-0ubuntu2
  PythonDetails: /usr/bin/python3.8, Python 3.8.5, python-is-python3, 3.8.2-4
  RelatedPackageVersions:
   dpkg 1.19.7ubuntu3
   apt  2.0.4
  SSHDConfig: Error: command ['/usr/sbin/sshd', '-T'] failed with exit code 
255: /etc/ssh/sshd_config line 1: garbage at end of line; "to".
  SourcePackage: openssh
  Title: package openssh-server 1:8.2p1-4ubuntu0.1 failed to install/upgrade: 
installed openssh-server package post-installation script subprocess returned 
error exit status 1
  UpgradeStatus: Upgraded to focal on 2021-02-04 (12 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1915908/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : 

[Touch-packages] [Bug 1915198] Re: "Dummy output" instead of the audio device ALC268

2021-02-10 Thread D
Hello Daniel,

Packages named 'timidity' or 'pipewire' are not installed. File
packages.txt in attachment.

Regards, Dmitriy.

** Attachment added: "packages.txt"
   
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1915198/+attachment/5462367/+files/packages.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1915198

Title:
  "Dummy output" instead of the audio device ALC268

Status in pulseaudio package in Ubuntu:
  Incomplete

Bug description:
  Hello Support,

  "Dummy output" in Sound settings. nothing works.

  $ aplay -l
   List of PLAYBACK Hardware Devices 

  $ alsa-info.sh link to http://alsa-
  project.org/db/?f=834b3fe04e2e1c74c7f2a84b6fb698e6e49db8fa.

  # dmidecode -t system
  # dmidecode 3.2
  Getting SMBIOS data from sysfs.
  SMBIOS 2.4 present.

  Handle 0x0001, DMI type 1, 27 bytes
  System Information
Manufacturer: TOSHIBA
Product Name: Satellite U300
Version: PSU30E-01M01DRU

  # lspci |grep Audio
  00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio 
Controller (rev 03)
  00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio 
Controller [8086:284b] (rev 03)
Subsystem: Toshiba Corporation 82801H (ICH8 Family) HD Audio Controller 
[1179:ff50]
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel
  Physical device is ALC268.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: pulseaudio 1:13.99.1-1ubuntu3.10
  ProcVersionSignature: Ubuntu 5.8.0-43.49~20.04.1-generic 5.8.18
  Uname: Linux 5.8.0-43-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.16
  Architecture: amd64
  AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/by-path', 
'/dev/snd/controlC0', '/dev/snd/hwC0D1', '/dev/snd/seq', '/dev/snd/timer'] 
failed with exit code 1:
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Tue Feb  9 22:37:35 2021
  InstallationDate: Installed on 2021-02-09 (0 days ago)
  InstallationMedia: Ubuntu 20.04.2 LTS "Focal Fossa" - Release amd64 (20210204)
  SourcePackage: pulseaudio
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 01/15/2009
  dmi.bios.vendor: TOSHIBA
  dmi.bios.version: V5.10
  dmi.board.name: Satellite U300
  dmi.board.vendor: TOSHIBA
  dmi.board.version: Not Applicable
  dmi.chassis.type: 10
  dmi.chassis.vendor: TOSHIBA
  dmi.chassis.version: N/A
  dmi.modalias: 
dmi:bvnTOSHIBA:bvrV5.10:bd01/15/2009:svnTOSHIBA:pnSatelliteU300:pvrPSU30E-01M01DRU:rvnTOSHIBA:rnSatelliteU300:rvrNotApplicable:cvnTOSHIBA:ct10:cvrN/A:
  dmi.product.name: Satellite U300
  dmi.product.version: PSU30E-01M01DRU
  dmi.sys.vendor: TOSHIBA

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1915198/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1914284] [NEW] package gzip 1.10-2ubuntu1 failed to install/upgrade: unable to make backup link of './bin/zless' before installing new version: Input/output error

2021-02-02 Thread John D Brown, MD
Public bug reported:

installing plocate before mlocate

ProblemType: Package
DistroRelease: Ubuntu 20.10
Package: gzip 1.10-2ubuntu1
ProcVersionSignature: Ubuntu 5.8.0-25.26-generic 5.8.14
Uname: Linux 5.8.0-25-generic x86_64
NonfreeKernelModules: wl zfs zunicode zavl icp zcommon znvpair
Architecture: amd64
Date: Tue Feb  2 19:00:41 2021
Df:
 
ErrorMessage: unable to make backup link of './bin/zless' before installing new 
version: Input/output error
PythonDetails: N/A
SourcePackage: gzip
Title: package gzip 1.10-2ubuntu1 failed to install/upgrade: unable to make 
backup link of './bin/zless' before installing new version: Input/output error
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: gzip (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package groovy

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gzip in Ubuntu.
https://bugs.launchpad.net/bugs/1914284

Title:
  package gzip 1.10-2ubuntu1 failed to install/upgrade: unable to make
  backup link of './bin/zless' before installing new version:
  Input/output error

Status in gzip package in Ubuntu:
  New

Bug description:
  installing plocate before mlocate

  ProblemType: Package
  DistroRelease: Ubuntu 20.10
  Package: gzip 1.10-2ubuntu1
  ProcVersionSignature: Ubuntu 5.8.0-25.26-generic 5.8.14
  Uname: Linux 5.8.0-25-generic x86_64
  NonfreeKernelModules: wl zfs zunicode zavl icp zcommon znvpair
  Architecture: amd64
  Date: Tue Feb  2 19:00:41 2021
  Df:
   
  ErrorMessage: unable to make backup link of './bin/zless' before installing 
new version: Input/output error
  PythonDetails: N/A
  SourcePackage: gzip
  Title: package gzip 1.10-2ubuntu1 failed to install/upgrade: unable to make 
backup link of './bin/zless' before installing new version: Input/output error
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gzip/+bug/1914284/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1481779] Re: apt-get autoremove crashes my system

2020-12-14 Thread Jahoner D
** Changed in: apt (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apt in Ubuntu.
https://bugs.launchpad.net/bugs/1481779

Title:
  apt-get autoremove crashes my system

Status in apt package in Ubuntu:
  Confirmed

Bug description:
  Ubuntu 15.04 Server Gnome - 3.19.0-25-generic #26-Ubuntu SMP Fri Jul 24 
21:17:31 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
  apt 1.0.9.7

  If I try to clean my system with "sudo apt-get autoremove":
  Reading package lists... Done
  Building dependency tree   
  Reading state information... Done
  The following packages will be REMOVED:
acpi-support app-install-data-partner apturl apturl-common argyll 
argyll-ref baobab bluez-alsa bluez-cups brltty cheese dc deja-dup
deja-dup-backend-cloudfiles deja-dup-backend-gvfs deja-dup-backend-s3 
duplicity folks-common fonts-cantarell fonts-guru fonts-guru-extra
fonts-kacst fonts-kacst-one fonts-khmeros-core fonts-lao 
fonts-lklug-sinhala fonts-lohit-guru fonts-sil-abyssinica fonts-sil-padauk
fonts-thai-tlwg fonts-tibetan-machine fonts-tlwg-garuda fonts-tlwg-kinnari 
fonts-tlwg-laksaman fonts-tlwg-loma fonts-tlwg-mono fonts-tlwg-norasi
fonts-tlwg-purisa fonts-tlwg-sawasdee fonts-tlwg-typewriter 
fonts-tlwg-typist fonts-tlwg-typo fonts-tlwg-umpush fonts-tlwg-waree gdm 
geoclue-2.0
gir1.2-accountsservice-1.0 gir1.2-champlain-0.12 gir1.2-gck-1 gir1.2-gcr-3 
gir1.2-gdata-0.0 gir1.2-gdm-1.0 gir1.2-geocodeglib-1.0 gir1.2-gkbd-3.0
gir1.2-goa-1.0 gir1.2-gtkchamplain-0.12 gir1.2-gweather-3.0 
gir1.2-mutter-3.0 gir1.2-rb-3.0 gir1.2-rest-0.7 gir1.2-telepathyglib-0.12
gir1.2-telepathylogger-0.2 gir1.2-tracker-1.0 gir1.2-udisks-2.0 
gir1.2-upowerglib-1.0 gir1.2-xkl-1.0 gir1.2-zpj-0.0 gjs gnome-backgrounds
gnome-calculator gnome-color-manager gnome-contacts gnome-dictionary 
gnome-disk-utility gnome-documents gnome-font-viewer gnome-maps
gnome-online-accounts gnome-online-miners gnome-orca gnome-screenshot 
gnome-session-canberra gnome-shell gnome-shell-common gnome-shell-extensions
gnome-system-log gnome-tweak-tool gnome-video-effects gnome-weather 
gstreamer0.10-alsa gstreamer0.10-nice gstreamer1.0-nice gucharmap gvfs-fuse
hamster-applet hamster-indicator ibus-pinyin ibus-table inputattach 
intel-gpu-tools itstool kerneloops-daemon libavahi-gobject0 libavahi-ui-gtk3-0
libbrlapi0.6 libcaribou-gtk-module libcaribou-gtk3-module 
libchamplain-0.12-0 libchamplain-gtk-0.12-0 libdiscid0 libdotconf0 
libfarstream-0.1-0
libfarstream-0.2-2 libfolks-eds25 libfolks-telepathy25 libfolks25 
libgdict-1.0-6 libgdict-common libgdm1 libgexiv2-2 libgfbgraph-0.2-0
libgpod-common libgpod4 libgsf-1-114 libgsf-1-common libgupnp-igd-1.0-4 
liblouis-data liblouis2 libmeanwhile1 libminiupnpc10
libmission-control-plugins0 libnatpmp1 libnice10 libnotify-bin 
libnss-myhostname libopencc1 libproxy1-plugin-gsettings
libproxy1-plugin-networkmanager libpurple-bin libpurple0 libpyzy-1.0-0 
libraw10 librhythmbox-core8 librsync1 librygel-core-2.4-2
librygel-renderer-2.4-2 librygel-renderer-gst-2.4-2 librygel-server-2.4-2 
libsofia-sip-ua-glib3 libsofia-sip-ua0 libspeechd2
libtelepathy-farstream3 libtelepathy-logger3 libtracker-control-1.0-0 
libtracker-miner-1.0-0 libunity-control-center1 libxp6 libzapojit-0.0-0
libzephyr4 mscompress nautilus-share oneconf oneconf-common pcmciautils 
policykit-desktop-privileges printer-driver-brlaser printer-driver-c2esp
printer-driver-foo2zjs printer-driver-foo2zjs-common 
printer-driver-min12xxw printer-driver-pnm2ppa printer-driver-ptouch 
printer-driver-pxljr
printer-driver-sag-gdi printer-driver-splix pulseaudio-module-bluetooth 
python-appindicator python-boto python-cloudfiles python-cups
python-debtagshw python-lockfile python-notify python-oneconf 
python-piston-mini-client python-wnck python3-brlapi python3-louis python3-mako
python3-oauthlib python3-oneconf python3-piston-mini-client python3-pyatspi 
python3-speechd realmd rfkill rhythmbox rhythmbox-data
rhythmbox-mozilla rhythmbox-plugin-cdrecorder rhythmbox-plugin-magnatune 
rhythmbox-plugin-zeitgeist rhythmbox-plugins rygel rygel-playbin
rygel-preferences seahorse shotwell shotwell-common 
signon-keyring-extension signon-plugin-oauth2 simple-scan software-center
software-center-aptdaemon-plugins sound-juicer speech-dispatcher 
speech-dispatcher-audio-plugins syslinux syslinux-common syslinux-legacy
telepathy-gabble telepathy-haze telepathy-idle telepathy-logger 
telepathy-mission-control-5 telepathy-rakia telepathy-salut toshset tracker
tracker-extract tracker-gui tracker-miner-fs tracker-utils 
transmission-common transmission-gtk ttf-ancient-fonts-symbola 
ttf-indic-fonts-core
ubuntu-gnome-default-settings unity-asset-pool usb-creator-common 
usb-creator-gtk vino whoopsie x11-apps x11-session-utils xbrlapi
xdg-user-dirs-gtk xdiagnose xinit xorg 

[Touch-packages] [Bug 1908025] [NEW] export var=~root does not expand ~root to /root

2020-12-13 Thread Ian! D. Allen
Public bug reported:

Shouldn't these give the same results in dash, i.e. "/root"?
They give the same output in bash.

$ dash
$ var=~root
$ echo "$var"
/root
$ export var=~root
$ echo "$var"
~root

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: dash 0.5.10.2-6
ProcVersionSignature: Ubuntu 5.4.0-56.62-generic 5.4.73
Uname: Linux 5.4.0-56-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.13
Architecture: amd64
CasperMD5CheckResult: skip
Date: Mon Dec 14 00:14:44 2020
EcryptfsInUse: Yes
InstallationDate: Installed on 2020-10-07 (67 days ago)
InstallationMedia: Lubuntu 20.04.1 LTS "Focal Fossa" - Release amd64 (20200731)
SourcePackage: dash
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: dash (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug focal

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to dash in Ubuntu.
https://bugs.launchpad.net/bugs/1908025

Title:
  export var=~root does not expand ~root to /root

Status in dash package in Ubuntu:
  New

Bug description:
  Shouldn't these give the same results in dash, i.e. "/root"?
  They give the same output in bash.

  $ dash
  $ var=~root
  $ echo "$var"
  /root
  $ export var=~root
  $ echo "$var"
  ~root

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: dash 0.5.10.2-6
  ProcVersionSignature: Ubuntu 5.4.0-56.62-generic 5.4.73
  Uname: Linux 5.4.0-56-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.13
  Architecture: amd64
  CasperMD5CheckResult: skip
  Date: Mon Dec 14 00:14:44 2020
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2020-10-07 (67 days ago)
  InstallationMedia: Lubuntu 20.04.1 LTS "Focal Fossa" - Release amd64 
(20200731)
  SourcePackage: dash
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dash/+bug/1908025/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1718927] Re: No HDMI sound after suspend/resume

2020-12-03 Thread Jonas D.
A workaround that worked for me was `pulseaudio -k`; having to do this
almost every time I need audio is a big PITA though.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1718927

Title:
  No HDMI sound after suspend/resume

Status in pulseaudio package in Ubuntu:
  Confirmed

Bug description:
  When plugging in a HDMI TV to Lenovo Carbon 3rd Edition, sound works
  perfectly, but when I suspend computer and resume it there is no sound
  via HDMI in TV. However sound via built in speakers works fine. The
  only thing I can do to restore sound is to reboot the machine. Similar
  problem was discussed in following thread
  https://ubuntuforums.org/showthread.php?t=2251651 with no solution. I
  tested it on several versions of kernel 4.4.0 and on 4.4.8. Still no
  solution.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1718927/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890716] Re: misidentifies .html file as Perl script when it contains JavaScript "use strict"

2020-09-25 Thread Alex A. D.
@Kai Kasurinen 
>probably fixed on shared-mime-info 2.0:
>https://gitlab.freedesktop.org/xdg/shared-mime-info/-/commit/18bb7cfc6c43d710ecf60339b5dd9bd19c297cdf
Yeah, well. It's if they only used the same database.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to shared-mime-info in
Ubuntu.
https://bugs.launchpad.net/bugs/1890716

Title:
  misidentifies .html file as Perl script when it contains JavaScript
  "use strict"

Status in shared-mime-info:
  Unknown
Status in kde-cli-tools package in Ubuntu:
  New
Status in shared-mime-info package in Ubuntu:
  Fix Committed
Status in shared-mime-info package in Debian:
  Confirmed

Bug description:
  For .html files `xdg-mime` reports wrong type. The culprit is the
  `"use strict"` phrase which is used in JavaScript. It should not
  mistake .html files for anything else except of text/html !

  STEPS TO REPRODUCE:
  Run the following step by step in any folder:
  1. $ echo "\"use strict\"" > index.html
  2. $ xdg-mime query filetype index.html # -> application/x-perl - this should 
be text/html!

  Platform:
  Ubuntu 20.04.1 LTS (Focal Fossa)"
  Linux version 5.4.0-42-generic (buildd@lgw01-amd64-038) (gcc version 9.3.0 
(Ubuntu 9.3.0-10ubuntu2))

  xdg-utils: 1.1.3-2ubuntu1

To manage notifications about this bug go to:
https://bugs.launchpad.net/shared-mime-info/+bug/1890716/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890716] Re: misidentifies .html file as Perl script when it contains JavaScript "use strict"

2020-09-25 Thread Alex A. D.
If you wrap string in the proper tags you will get the same result, but
with different offset (28 chars):

tee "index.html" <
`printf "x"%.0s {1..228}`
use strict

eol # -> text/html

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to shared-mime-info in
Ubuntu.
https://bugs.launchpad.net/bugs/1890716

Title:
  misidentifies .html file as Perl script when it contains JavaScript
  "use strict"

Status in shared-mime-info:
  Unknown
Status in kde-cli-tools package in Ubuntu:
  New
Status in shared-mime-info package in Ubuntu:
  Fix Committed
Status in shared-mime-info package in Debian:
  Confirmed

Bug description:
  For .html files `xdg-mime` reports wrong type. The culprit is the
  `"use strict"` phrase which is used in JavaScript. It should not
  mistake .html files for anything else except of text/html !

  STEPS TO REPRODUCE:
  Run the following step by step in any folder:
  1. $ echo "\"use strict\"" > index.html
  2. $ xdg-mime query filetype index.html # -> application/x-perl - this should 
be text/html!

  Platform:
  Ubuntu 20.04.1 LTS (Focal Fossa)"
  Linux version 5.4.0-42-generic (buildd@lgw01-amd64-038) (gcc version 9.3.0 
(Ubuntu 9.3.0-10ubuntu2))

  xdg-utils: 1.1.3-2ubuntu1

To manage notifications about this bug go to:
https://bugs.launchpad.net/shared-mime-info/+bug/1890716/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890716] Re: misidentifies .html file as Perl script when it contains JavaScript "use strict"

2020-09-25 Thread Alex A. D.
#INTRO
After digging up for a while I've found where the issue comes from for both 
`.html` and `.py` (bug #1857824) files.

#SHORT
The culprit responsible for misidentification resides in `.xml` database which 
specifies how to match mime-type against input data. It can be found here [2].

#LONG
The `kmimetypefinder.cpp` pulls up [0] `QMimeDatabase db` apis by 
`db.mimeTypeForFile(...)` which in turns bootstrup `QMimeDatabasePrivate ...` 
XML database from .xml file.[1] 

If we look carefully at the content of the `"text/x-perl"` entry we
would see the following:

```


  ...
   
  ...

```

Did you notice the offset attribute `"0:256"`? Now if we run the
following two cases we will see that files whose content contains
keywords `use strict` in the range of 1..256 will be identified as
`text/x-perl` script and as `text/html` if the `use trict` is located
outside of such range otherwise, checkout:

 tee "index.html"  index.html
  2. $ xdg-mime query filetype index.html # -> application/x-perl - this should 
be text/html!

  Platform:
  Ubuntu 20.04.1 LTS (Focal Fossa)"
  Linux version 5.4.0-42-generic (buildd@lgw01-amd64-038) (gcc version 9.3.0 
(Ubuntu 9.3.0-10ubuntu2))

  xdg-utils: 1.1.3-2ubuntu1

To manage notifications about this bug go to:
https://bugs.launchpad.net/shared-mime-info/+bug/1890716/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890716] Re: misidentifies .html file as Perl script when it contains JavaScript "use strict"

2020-09-24 Thread Alex A. D.
With the same setup I have the `mimetype` to output `text/html` for
`index.html`. It seems it workds correctly.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to shared-mime-info in
Ubuntu.
https://bugs.launchpad.net/bugs/1890716

Title:
  misidentifies .html file as Perl script when it contains JavaScript
  "use strict"

Status in shared-mime-info:
  Unknown
Status in kde-cli-tools package in Ubuntu:
  New
Status in shared-mime-info package in Ubuntu:
  Fix Committed
Status in shared-mime-info package in Debian:
  Confirmed

Bug description:
  For .html files `xdg-mime` reports wrong type. The culprit is the
  `"use strict"` phrase which is used in JavaScript. It should not
  mistake .html files for anything else except of text/html !

  STEPS TO REPRODUCE:
  Run the following step by step in any folder:
  1. $ echo "\"use strict\"" > index.html
  2. $ xdg-mime query filetype index.html # -> application/x-perl - this should 
be text/html!

  Platform:
  Ubuntu 20.04.1 LTS (Focal Fossa)"
  Linux version 5.4.0-42-generic (buildd@lgw01-amd64-038) (gcc version 9.3.0 
(Ubuntu 9.3.0-10ubuntu2))

  xdg-utils: 1.1.3-2ubuntu1

To manage notifications about this bug go to:
https://bugs.launchpad.net/shared-mime-info/+bug/1890716/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890716] Re: misidentifies .html file as Perl script when it contains JavaScript "use strict"

2020-09-22 Thread Alex A. D.
** Also affects: kde-cli-tools (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to shared-mime-info in
Ubuntu.
https://bugs.launchpad.net/bugs/1890716

Title:
  misidentifies .html file as Perl script when it contains JavaScript
  "use strict"

Status in shared-mime-info:
  Unknown
Status in kde-cli-tools package in Ubuntu:
  New
Status in shared-mime-info package in Ubuntu:
  New
Status in shared-mime-info package in Debian:
  Unknown

Bug description:
  For .html files `xdg-mime` reports wrong type. The culprit is the
  `"use strict"` phrase which is used in JavaScript. It should not
  mistake .html files for anything else except of text/html !

  STEPS TO REPRODUCE:
  Run the following step by step in any folder:
  1. $ echo "\"use strict\"" > index.html
  2. $ xdg-mime query filetype index.html # -> application/x-perl - this should 
be text/html!

  Platform:
  Ubuntu 20.04.1 LTS (Focal Fossa)"
  Linux version 5.4.0-42-generic (buildd@lgw01-amd64-038) (gcc version 9.3.0 
(Ubuntu 9.3.0-10ubuntu2))

  xdg-utils: 1.1.3-2ubuntu1

To manage notifications about this bug go to:
https://bugs.launchpad.net/shared-mime-info/+bug/1890716/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890716] Re: kmimetypefinder5 *.html reports wrong type

2020-09-22 Thread Alex A. D.
I've reported a new bug providing a complete and correct description:
https://bugs.launchpad.net/ubuntu/+source/kde-cli-tools/+bug/1896682

This one can be safely closed.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to shared-mime-info in
Ubuntu.
https://bugs.launchpad.net/bugs/1890716

Title:
  kmimetypefinder5 *.html reports wrong type

Status in shared-mime-info package in Ubuntu:
  Invalid

Bug description:
  For .html files `xdg-mime` reports wrong type. The culprit is the
  `"use strict"` phrase which is used in JavaScript. It should not
  mistake .html files for anything else except of text/html !

  STEPS TO REPRODUCE:
  Run the following step by step in any folder:
  1. $ echo "\"use strict\"" > index.html
  2. $ xdg-mime query filetype index.html # -> application/x-perl - this should 
be text/html!

  Platform:
  Ubuntu 20.04.1 LTS (Focal Fossa)"
  Linux version 5.4.0-42-generic (buildd@lgw01-amd64-038) (gcc version 9.3.0 
(Ubuntu 9.3.0-10ubuntu2))

  xdg-utils: 1.1.3-2ubuntu1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/shared-mime-info/+bug/1890716/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890716] Re: kmimetypefinder5 *.html reports wrong type

2020-09-22 Thread Alex A. D.
New bug reopened with complete and correct explanation: 
https://bugs.launchpad.net/ubuntu/+source/kde-cli-tools/+bug/1896682

** Changed in: shared-mime-info (Ubuntu)
   Status: Incomplete => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to shared-mime-info in
Ubuntu.
https://bugs.launchpad.net/bugs/1890716

Title:
  kmimetypefinder5 *.html reports wrong type

Status in shared-mime-info package in Ubuntu:
  Invalid

Bug description:
  For .html files `xdg-mime` reports wrong type. The culprit is the
  `"use strict"` phrase which is used in JavaScript. It should not
  mistake .html files for anything else except of text/html !

  STEPS TO REPRODUCE:
  Run the following step by step in any folder:
  1. $ echo "\"use strict\"" > index.html
  2. $ xdg-mime query filetype index.html # -> application/x-perl - this should 
be text/html!

  Platform:
  Ubuntu 20.04.1 LTS (Focal Fossa)"
  Linux version 5.4.0-42-generic (buildd@lgw01-amd64-038) (gcc version 9.3.0 
(Ubuntu 9.3.0-10ubuntu2))

  xdg-utils: 1.1.3-2ubuntu1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/shared-mime-info/+bug/1890716/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890716] Re: xdg-mime query filetype index.html reports wrong type

2020-09-22 Thread Alex A. D.
After running that commands I got the following output:

$ ...
Running kmimetypefinder5 "/home/alex/Desktop/index.html"
application/x-perl


It seems like that kmimetypefinder5 is major culprit here. I've found another 
unrelated bugreport here which was reported about a year ago: 
https://bugs.launchpad.net/ubuntu/+source/kde-cli-tools/+bug/1857824

In that case the program reports wrong type for *.py files with correct 
content. Weird!
I think it's wortht to rename this bugreport.

** Summary changed:

- xdg-mime query filetype index.html reports wrong type
+ kmimetypefinder5 *.html reports wrong type

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to shared-mime-info in
Ubuntu.
https://bugs.launchpad.net/bugs/1890716

Title:
  kmimetypefinder5 *.html reports wrong type

Status in shared-mime-info package in Ubuntu:
  Incomplete

Bug description:
  For .html files `xdg-mime` reports wrong type. The culprit is the
  `"use strict"` phrase which is used in JavaScript. It should not
  mistake .html files for anything else except of text/html !

  STEPS TO REPRODUCE:
  Run the following step by step in any folder:
  1. $ echo "\"use strict\"" > index.html
  2. $ xdg-mime query filetype index.html # -> application/x-perl - this should 
be text/html!

  Platform:
  Ubuntu 20.04.1 LTS (Focal Fossa)"
  Linux version 5.4.0-42-generic (buildd@lgw01-amd64-038) (gcc version 9.3.0 
(Ubuntu 9.3.0-10ubuntu2))

  xdg-utils: 1.1.3-2ubuntu1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/shared-mime-info/+bug/1890716/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890716] Re: xdg-mime query filetype index.html reports wrong type

2020-09-21 Thread Alex A. D.
I just have tried a fresh new user. The output is identical. See
attached screenshot.

** Attachment added: "xdg-mime query wrong result"
   
https://bugs.launchpad.net/ubuntu/+source/shared-mime-info/+bug/1890716/+attachment/5413048/+files/Screenshot_20200921_232318.png

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to shared-mime-info in
Ubuntu.
https://bugs.launchpad.net/bugs/1890716

Title:
  xdg-mime query filetype index.html reports wrong type

Status in shared-mime-info package in Ubuntu:
  Incomplete

Bug description:
  For .html files `xdg-mime` reports wrong type. The culprit is the
  `"use strict"` phrase which is used in JavaScript. It should not
  mistake .html files for anything else except of text/html !

  STEPS TO REPRODUCE:
  Run the following step by step in any folder:
  1. $ echo "\"use strict\"" > index.html
  2. $ xdg-mime query filetype index.html # -> application/x-perl - this should 
be text/html!

  Platform:
  Ubuntu 20.04.1 LTS (Focal Fossa)"
  Linux version 5.4.0-42-generic (buildd@lgw01-amd64-038) (gcc version 9.3.0 
(Ubuntu 9.3.0-10ubuntu2))

  xdg-utils: 1.1.3-2ubuntu1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/shared-mime-info/+bug/1890716/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890716] Re: xdg-mime query filetype index.html reports wrong type

2020-08-12 Thread Alex A. D.
why did you tag the report*

Bump.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to shared-mime-info in
Ubuntu.
https://bugs.launchpad.net/bugs/1890716

Title:
  xdg-mime query filetype index.html reports wrong type

Status in shared-mime-info package in Ubuntu:
  Invalid

Bug description:
  For .html files `xdg-mime` reports wrong type. The culprit is the
  `"use strict"` phrase which is used in JavaScript. It should not
  mistake .html files for anything else except of text/html !

  STEPS TO REPRODUCE:
  Run the following step by step in any folder:
  1. $ echo "\"use strict\"" > index.html
  2. $ xdg-mime query filetype index.html # -> application/x-perl - this should 
be text/html!

  Platform:
  Ubuntu 20.04.1 LTS (Focal Fossa)"
  Linux version 5.4.0-42-generic (buildd@lgw01-amd64-038) (gcc version 9.3.0 
(Ubuntu 9.3.0-10ubuntu2))

  xdg-utils: 1.1.3-2ubuntu1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/shared-mime-info/+bug/1890716/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890716] Re: xdg-mime query filetype index.html reports wrong type

2020-08-12 Thread Alex A. D.
Hi Sebastien. Thaks your for your reply.

I suggest you to do the following to see that even if file is starting
with proper tags it is recognized as `application/x-perl`:

$ tee "index.html" <
use strict
eol

$ xdg-mime query filetype index.html # -> application/x-perl - wrong
type

Why did you tagged report as invalid? 
I just got a file with minified JS code which has `use strict` burrowed deep 
somewhere inside correct html file but it's still recognized as perl script.

I can't use some tools to open the file in browser by using xdg-open and
forced to use browser-specific launcher.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to shared-mime-info in
Ubuntu.
https://bugs.launchpad.net/bugs/1890716

Title:
  xdg-mime query filetype index.html reports wrong type

Status in shared-mime-info package in Ubuntu:
  Invalid

Bug description:
  For .html files `xdg-mime` reports wrong type. The culprit is the
  `"use strict"` phrase which is used in JavaScript. It should not
  mistake .html files for anything else except of text/html !

  STEPS TO REPRODUCE:
  Run the following step by step in any folder:
  1. $ echo "\"use strict\"" > index.html
  2. $ xdg-mime query filetype index.html # -> application/x-perl - this should 
be text/html!

  Platform:
  Ubuntu 20.04.1 LTS (Focal Fossa)"
  Linux version 5.4.0-42-generic (buildd@lgw01-amd64-038) (gcc version 9.3.0 
(Ubuntu 9.3.0-10ubuntu2))

  xdg-utils: 1.1.3-2ubuntu1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/shared-mime-info/+bug/1890716/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1576559] Re: Refused to switch profile to headset_head_unit: Not connected

2020-08-10 Thread Brett D
Same issue here with Aukey EP-N5 bluetooth earbuds on 20.04.1.  This is
a top-selling set of earbuds on Amazon so I thought they'd work.

The microphone doesn't appear at all in the list of input devices under
system Sound Settings.

Attempting to change the profile within Blueman to HSP/HFP results in
"Failed to change profile to headset_head_unit".

Maddening.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1576559

Title:
  Refused to switch profile to headset_head_unit: Not connected

Status in PulseAudio:
  Unknown
Status in pulseaudio package in Ubuntu:
  Confirmed

Bug description:
  I'm trying to connect a bluetooth-speaker-with-microphone (Mi
  Bluetooth Speaker) to Ubuntu. It works well as an A2DP sync, but can't
  use it as a headset with microphone.

  The device doesn't list in the "Input Devices" by default, and using
  the sound settings to change the profile of the device to HSP/HFP
  results in this log message:

  W: [pulseaudio] module-bluez5-device.c: Refused to switch profile to
  headset_head_unit: Not connected

  
  I'm running Ubuntu 16.04 LTS. I did an upgrade from Ubuntu 15.10.

  pulseaudio:
Installed: 1:8.0-0ubuntu3

  bluez:
Installed: 5.37-0ubuntu5

To manage notifications about this bug go to:
https://bugs.launchpad.net/pulseaudio/+bug/1576559/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1885310] [NEW] Unable to add local printer. cups hanging

2020-06-26 Thread Peter D Knight
Public bug reported:

Initially added epson c60 stylus but it installed with filter error.
Deleted printer from cups , added new printer.
Added the epson printer , selected the .ppd file that worked in 1904 and 
clicked add printer.
Cups just sits and thinks.
Same happens if I use the applications/System/printers menu.
Thanks
Peter

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: cups-daemon 2.3.1-9ubuntu1.1
ProcVersionSignature: Ubuntu 5.4.0-37.41-generic 5.4.41
Uname: Linux 5.4.0-37-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.2
Architecture: amd64
CasperMD5CheckResult: skip
Date: Fri Jun 26 18:16:57 2020
ExecutablePath: /usr/sbin/cupsd
InstallationDate: Installed on 2020-06-01 (25 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
Lpstat: Error: command ['lpstat', '-v'] failed with exit code 1: lpstat: No 
destinations added.
MachineType: System manufacturer System Product Name
Papersize: a4
PpdFiles: EPSON-Stylus-C60: Epson Stylus C60 - CUPS+Gutenprint v5.3.1
ProcAttrCurrent: /usr/sbin/cupsd (enforce)
ProcEnviron:
 LANG=en_ZA.UTF-8
 LANGUAGE=en_ZA:en
 PATH=(custom, no user)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-37-generic 
root=UUID=b750d723-abc0-43bf-bfd0-945d09637362 ro quiet splash vt.handoff=7
SourcePackage: cups
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/16/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0402
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5G41T-M LX3
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr0402:bd05/16/2011:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5G41T-MLX3:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.family: To Be Filled By O.E.M.
dmi.product.name: System Product Name
dmi.product.sku: To Be Filled By O.E.M.
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

** Affects: cups (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug focal

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to cups in Ubuntu.
https://bugs.launchpad.net/bugs/1885310

Title:
  Unable to add local printer. cups hanging

Status in cups package in Ubuntu:
  New

Bug description:
  Initially added epson c60 stylus but it installed with filter error.
  Deleted printer from cups , added new printer.
  Added the epson printer , selected the .ppd file that worked in 1904 and 
clicked add printer.
  Cups just sits and thinks.
  Same happens if I use the applications/System/printers menu.
  Thanks
  Peter

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: cups-daemon 2.3.1-9ubuntu1.1
  ProcVersionSignature: Ubuntu 5.4.0-37.41-generic 5.4.41
  Uname: Linux 5.4.0-37-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.2
  Architecture: amd64
  CasperMD5CheckResult: skip
  Date: Fri Jun 26 18:16:57 2020
  ExecutablePath: /usr/sbin/cupsd
  InstallationDate: Installed on 2020-06-01 (25 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  Lpstat: Error: command ['lpstat', '-v'] failed with exit code 1: lpstat: No 
destinations added.
  MachineType: System manufacturer System Product Name
  Papersize: a4
  PpdFiles: EPSON-Stylus-C60: Epson Stylus C60 - CUPS+Gutenprint v5.3.1
  ProcAttrCurrent: /usr/sbin/cupsd (enforce)
  ProcEnviron:
   LANG=en_ZA.UTF-8
   LANGUAGE=en_ZA:en
   PATH=(custom, no user)
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-37-generic 
root=UUID=b750d723-abc0-43bf-bfd0-945d09637362 ro quiet splash vt.handoff=7
  SourcePackage: cups
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 05/16/2011
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 0402
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5G41T-M LX3
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev X.0x
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr0402:bd05/16/2011:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5G41T-MLX3:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.family: To Be Filled By O.E.M.
  dmi.product.name: System Product Name
  dmi.product.sku: To Be Filled By O.E.M.
  dmi.product.version: System Version
  dmi.sys.vendor: System manufacturer

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1885310/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : 

[Touch-packages] [Bug 1878617] Re: Apple pages file type should be added to MIME types

2020-05-18 Thread David D Lowe
As requested, here is an example of an Apple Pages document, taken from
an online templates website.

** Attachment added: "New Job Resignation Letter.pages"
   
https://bugs.launchpad.net/ubuntu/+source/mime-support/+bug/1878617/+attachment/5373328/+files/New%20Job%20Resignation%20Letter.pages

** Changed in: mime-support (Ubuntu)
   Status: Incomplete => New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mime-support in Ubuntu.
https://bugs.launchpad.net/bugs/1878617

Title:
  Apple pages file type should be added to MIME types

Status in mime-support package in Ubuntu:
  New

Bug description:
  LibreOffice can open .pages files (from Apple pages). However, the
  mime type for these files is incorrectly just application/zip:

  $ file --mime-type example.pages
  example.pages: application/zip

  Instead, it should be application/vnd.apple.pages .

  This would allow the user to associate LibreOffice Writer with these
  types of files, and use it to open this file. (LibreOffice Writer can
  open .pages files)

  Apple Keynote files should have this MIME type:
  application/vnd.apple.keynote

  Apple Numbers files should have this MIME type:
  application/vnd.apple.numbers

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: mime-support 3.64ubuntu1
  ProcVersionSignature: Ubuntu 5.4.0-29.33-generic 5.4.30
  Uname: Linux 5.4.0-29-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  ApportVersion: 2.20.11-0ubuntu27
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Thu May 14 14:46:40 2020
  InstallationDate: Installed on 2018-11-11 (550 days ago)
  InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 
(20180725)
  PackageArchitecture: all
  SourcePackage: mime-support
  UpgradeStatus: Upgraded to focal on 2020-04-18 (25 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/mime-support/+bug/1878617/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1878617] Re: Apple pages file type should be added to MIME types

2020-05-18 Thread David D Lowe
I created a bug report in shared-mime-info's issues tracker here:
https://gitlab.freedesktop.org/xdg/shared-mime-info/-/issues/136


** Bug watch added: gitlab.freedesktop.org/xdg/shared-mime-info/-/issues #136
   https://gitlab.freedesktop.org/xdg/shared-mime-info/-/issues/136

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mime-support in Ubuntu.
https://bugs.launchpad.net/bugs/1878617

Title:
  Apple pages file type should be added to MIME types

Status in mime-support package in Ubuntu:
  New

Bug description:
  LibreOffice can open .pages files (from Apple pages). However, the
  mime type for these files is incorrectly just application/zip:

  $ file --mime-type example.pages
  example.pages: application/zip

  Instead, it should be application/vnd.apple.pages .

  This would allow the user to associate LibreOffice Writer with these
  types of files, and use it to open this file. (LibreOffice Writer can
  open .pages files)

  Apple Keynote files should have this MIME type:
  application/vnd.apple.keynote

  Apple Numbers files should have this MIME type:
  application/vnd.apple.numbers

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: mime-support 3.64ubuntu1
  ProcVersionSignature: Ubuntu 5.4.0-29.33-generic 5.4.30
  Uname: Linux 5.4.0-29-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  ApportVersion: 2.20.11-0ubuntu27
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Thu May 14 14:46:40 2020
  InstallationDate: Installed on 2018-11-11 (550 days ago)
  InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 
(20180725)
  PackageArchitecture: all
  SourcePackage: mime-support
  UpgradeStatus: Upgraded to focal on 2020-04-18 (25 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/mime-support/+bug/1878617/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1878617] [NEW] Apple pages file type should be added to MIME types

2020-05-14 Thread David D Lowe
Public bug reported:

LibreOffice can open .pages files (from Apple pages). However, the mime
type for these files is incorrectly just application/zip:

$ file --mime-type example.pages
example.pages: application/zip

Instead, it should be application/vnd.apple.pages .

This would allow the user to associate LibreOffice Writer with these
types of files, and use it to open this file. (LibreOffice Writer can
open .pages files)

Apple Keynote files should have this MIME type:
application/vnd.apple.keynote

Apple Numbers files should have this MIME type:
application/vnd.apple.numbers

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: mime-support 3.64ubuntu1
ProcVersionSignature: Ubuntu 5.4.0-29.33-generic 5.4.30
Uname: Linux 5.4.0-29-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.11-0ubuntu27
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Thu May 14 14:46:40 2020
InstallationDate: Installed on 2018-11-11 (550 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
PackageArchitecture: all
SourcePackage: mime-support
UpgradeStatus: Upgraded to focal on 2020-04-18 (25 days ago)

** Affects: mime-support (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug focal third-party-packages

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mime-support in Ubuntu.
https://bugs.launchpad.net/bugs/1878617

Title:
  Apple pages file type should be added to MIME types

Status in mime-support package in Ubuntu:
  New

Bug description:
  LibreOffice can open .pages files (from Apple pages). However, the
  mime type for these files is incorrectly just application/zip:

  $ file --mime-type example.pages
  example.pages: application/zip

  Instead, it should be application/vnd.apple.pages .

  This would allow the user to associate LibreOffice Writer with these
  types of files, and use it to open this file. (LibreOffice Writer can
  open .pages files)

  Apple Keynote files should have this MIME type:
  application/vnd.apple.keynote

  Apple Numbers files should have this MIME type:
  application/vnd.apple.numbers

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: mime-support 3.64ubuntu1
  ProcVersionSignature: Ubuntu 5.4.0-29.33-generic 5.4.30
  Uname: Linux 5.4.0-29-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  ApportVersion: 2.20.11-0ubuntu27
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Thu May 14 14:46:40 2020
  InstallationDate: Installed on 2018-11-11 (550 days ago)
  InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 
(20180725)
  PackageArchitecture: all
  SourcePackage: mime-support
  UpgradeStatus: Upgraded to focal on 2020-04-18 (25 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/mime-support/+bug/1878617/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1866194] Re: External audio device shows up in the sound output options but the sound keeps being emitted from the internal laptop speaker, or none at all.

2020-05-12 Thread Josh D
This also happens on a Dell XPS 9570. My workaround after reboots, or
other events that disable the headphone audio, is to run this:

sudo alsactl restore

Then things are back to normal for a while.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1866194

Title:
  External audio device shows up in the sound output options but the
  sound keeps being emitted from the internal laptop speaker, or none at
  all.

Status in gnome-control-center:
  Unknown
Status in PulseAudio:
  New
Status in gnome-control-center package in Ubuntu:
  Invalid
Status in pulseaudio package in Ubuntu:
  In Progress
Status in gnome-control-center source package in Focal:
  Invalid
Status in pulseaudio source package in Focal:
  In Progress

Bug description:
  Ubuntu version: focal dev
  Kernel version: 5.4.0-14-generic #17-Ubuntu SMP Thu Feb 6 22:47:59 UTC 2020
  Pulseaudio: 1:13.99.1-1ubuntu1
  Device CID: 201704-25503

  Steps to reproduce:

  1. Connect an audio interface. I tried with BT headphones and speakers as 
well as a USB microphone/output.
  2. Make sure it's the one selected as "Output device"
  3. Click "Test"
  -> the test sound outputs from the internal laptop speakers (NOK)
  4. Select "Speakers - Built-in Audio" as Output device and click "Test"
  -> the test sound outputs from the internal laptop speakers (OK)
  5. Try to switch back to the BT device and click Test
  -> same result as in step 3

  Tested with 2 different BT devices (one headset and one speaker) as
  well as a USB audio interface (Zoom H2N microphone).

  Attached are btmon logs captured during the procedure described above,
  and pactl logs capture after step 7.

  I was previously using 19.04 and 19.10 on this device and never
  experienced this kind of issue.

  Up to this morning, it was harder to connect the BT device, but once
  connected, the sound would output on it as expected. Now, the BT
  connection seems to work better, but I can't output the sound to the
  BT device...

  I tried to reboot the device, and also to suspend/resume, but in each
  case, the BT device can connect back, but the sound is still output
  from the internal laptop speakers, even when the BT device is selected
  in the Sound settings.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: pulseaudio 1:13.99.1-1ubuntu1
  ProcVersionSignature: Ubuntu 5.4.0-14.17-generic 5.4.18
  Uname: Linux 5.4.0-14-generic x86_64
  ApportVersion: 2.20.11-0ubuntu18
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  pieq   1566 F pulseaudio
   /dev/snd/pcmC0D0c:   pieq   1566 F...m pulseaudio
   /dev/snd/pcmC0D0p:   pieq   1566 F...m pulseaudio
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Mar  5 22:15:50 2020
  InstallationDate: Installed on 2020-01-17 (48 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200116)
  SourcePackage: pulseaudio
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 04/23/2019
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.14.0
  dmi.board.vendor: Dell Inc.
  dmi.chassis.type: 10
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvr1.14.0:bd04/23/2019:svnDellInc.:pnInspiron7370:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct10:cvr:
  dmi.product.family: Inspiron
  dmi.product.name: Inspiron 7370
  dmi.product.sku: 07E9
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/gnome-control-center/+bug/1866194/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1876632] [NEW] Corrupted fonts in display output when using multiple users

2020-05-03 Thread Tom D.
Public bug reported:

I recently installed ubuntu 20.04 on my computer, and I am running into
an issue when I do the following:

* Login with a user on desktop
* Select switch user, and login as second user
* Switch user again, and return to original user

At this point, text and icons in the menubar / sidebar are corrupted.
Text and icons in normal windows appear correctly. I have attached a
screenshot of what this looks like.

Screenshots: https://imgur.com/a/3ZFDLMc

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: xorg 1:7.7+19ubuntu14
ProcVersionSignature: Ubuntu 5.4.0-28.32-generic 5.4.30
Uname: Linux 5.4.0-28-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
.proc.driver.nvidia.gpus..09.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:09:00.0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.suspend: suspend hibernate resume
.proc.driver.nvidia.suspend_depth: default modeset uvm
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
 GCC version:
ApportVersion: 2.20.11-0ubuntu27
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CasperMD5CheckResult: skip
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Sun May  3 18:12:45 2020
DistUpgraded: Fresh install
DistroCodename: focal
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 NVIDIA Corporation GP104 [GeForce GTX 1070] [10de:1b81] (rev a1) (prog-if 00 
[VGA controller])
   Subsystem: ASUSTeK Computer Inc. GP104 [GeForce GTX 1070] [1043:85a0]
InstallationDate: Installed on 2020-05-03 (0 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
MachineType: Gigabyte Technology Co., Ltd. AX370-Gaming
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-5.4.0-28-generic 
root=/dev/mapper/vgubuntu-root ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/19/2017
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: F3
dmi.board.asset.tag: Default string
dmi.board.name: AX370-Gaming-CF
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: se1
dmi.chassis.asset.tag: Default string
dmi.chassis.type: 3
dmi.chassis.vendor: Default string
dmi.chassis.version: Default string
dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrF3:bd06/19/2017:svnGigabyteTechnologyCo.,Ltd.:pnAX370-Gaming:pvrDefaultstring:rvnGigabyteTechnologyCo.,Ltd.:rnAX370-Gaming-CF:rvrse1:cvnDefaultstring:ct3:cvrDefaultstring:
dmi.product.family: Default string
dmi.product.name: AX370-Gaming
dmi.product.sku: Default string
dmi.product.version: Default string
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.101-2
version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.4-2ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.4-2ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug focal ubuntu

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1876632

Title:
  Corrupted fonts in display output when using multiple users

Status in xorg package in Ubuntu:
  New

Bug description:
  I recently installed ubuntu 20.04 on my computer, and I am running
  into an issue when I do the following:

  * Login with a user on desktop
  * Select switch user, and login as second user
  * Switch user again, and return to original user

  At this point, text and icons in the menubar / sidebar are corrupted.
  Text and icons in normal windows appear correctly. I have attached a
  screenshot of what this looks like.

  Screenshots: https://imgur.com/a/3ZFDLMc

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: xorg 1:7.7+19ubuntu14
  ProcVersionSignature: Ubuntu 5.4.0-28.32-generic 5.4.30
  Uname: Linux 5.4.0-28-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  .proc.driver.nvidia.gpus..09.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:09:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
   GCC version:
  

[Touch-packages] [Bug 1871960] Re: package libpam-modules 1.1.8-3.6ubuntu2.18.04.1 failed to install/upgrade: pre-dependency problem - not installing libpam-modules:amd64

2020-04-19 Thread David D Lowe
I also experienced this bug. I was running Ubuntu 18.04, and I upgraded
to Ubuntu 20.20 yesterday by running `update-manager -d` on the command-
line, which launched the GUI. During the upgrade itself, I was shown a
dialog displaying an error relating to pam.

I've attached apt-term.log (for me) to this comment. Here is the
relevant error, I think, I don't know how to find the core dump:

Preparing to unpack .../libpam0g_1.3.1-5ubuntu4_amd64.deb ...
Unpacking libpam0g:amd64 (1.3.1-5ubuntu4) over (1.1.8-3.6ubuntu2.18.04.1) ...
Setting up libpam0g:amd64 (1.3.1-5ubuntu4) ...
Fontconfig warning: "/etc/fonts/conf.avail/53-monospace-lcd-filter.conf", line 
10: Having multiple values in  isn't supported and may not work as 
expected
GLib-GObject-WARNING **: specified class size for type 'PangoCairoFcFont' is 
smaller than the parent type's 'PangoFcFont' class size at 
/usr/lib/x86_64-linux-gnu/perl5/5.30/Glib/Object/Introspection.pm line 67.
GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion 
'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed at 
/usr/lib/x86_64-linux-gnu/perl5/5.30/Glib/Object/Introspection.pm line 67.
GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed at 
/usr/lib/x86_64-linux-gnu/perl5/5.30/Glib/Object/Introspection.pm line 67.
GLib-GObject-CRITICAL **: g_object_new_valist: assertion 'G_TYPE_IS_OBJECT 
(object_type)' failed at 
/usr/lib/x86_64-linux-gnu/perl5/5.30/Glib/Object/Introspection.pm line 67.
dpkg: error processing package libpam0g:amd64 (--configure):
 installed libpam0g:amd64 package post-installation script subprocess was 
killed by signal (Segmentation fault), core dumped
Errors were encountered while processing:
 libpam0g:amd64
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 276143 files and directories currently installed.)
Preparing to unpack .../libpam-modules-bin_1.3.1-5ubuntu4_amd64.deb ...
Unpacking libpam-modules-bin (1.3.1-5ubuntu4) over (1.1.8-3.6ubuntu2.18.04.1) 
...
dpkg: dependency problems prevent configuration of libpam-modules-bin:
 libpam-modules-bin depends on libpam0g (>= 0.99.7.1); however:
  Package libpam0g:amd64 is not configured yet.

dpkg: error processing package libpam-modules-bin (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libpam-modules-bin
dpkg: regarding .../libpam-modules_1.3.1-5ubuntu4_amd64.deb containing 
libpam-modules:amd64, pre-dependency problem:
 libpam-modules:amd64 pre-depends on libpam0g (>= 1.3.1)
  libpam0g:amd64 latest configured version is 1.1.8-3.6ubuntu2.18.04.1.

dpkg: error processing archive 
/var/cache/apt/archives/libpam-modules_1.3.1-5ubuntu4_amd64.deb (--unpack):
 pre-dependency problem - not installing libpam-modules:amd64
Errors were encountered while processing:
 /var/cache/apt/archives/libpam-modules_1.3.1-5ubuntu4_amd64.deb
dpkg: error processing package libpam-modules:amd64 (--configure):
 package libpam-modules:amd64 is already installed and configured
Errors were encountered while processing:
 libpam-modules:amd64


** Attachment added: "from flimm's machine"
   
https://bugs.launchpad.net/ubuntu/+source/pam/+bug/1871960/+attachment/5356669/+files/apt-term.log

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pam in Ubuntu.
https://bugs.launchpad.net/bugs/1871960

Title:
  package libpam-modules 1.1.8-3.6ubuntu2.18.04.1 failed to
  install/upgrade: pre-dependency problem - not installing libpam-
  modules:amd64

Status in pam package in Ubuntu:
  Incomplete

Bug description:
  I was updating ubuntu to the 20.04 version. Not all packages were
  updated. I receive new errors every few seconds. what should I do?

  Thanks
  safi

  ProblemType: Package
  DistroRelease: Ubuntu 20.04
  Package: libpam-modules 1.1.8-3.6ubuntu2.18.04.1
  ProcVersionSignature: Ubuntu 5.4.0-21.25-generic 5.4.27
  Uname: Linux 5.4.0-21-generic x86_64
  ApportVersion: 2.20.11-0ubuntu25
  Architecture: amd64
  Date: Fri Apr 10 00:36:08 2020
  ErrorMessage: pre-dependency problem - not installing libpam-modules:amd64
  InstallationDate: Installed on 2019-12-28 (102 days ago)
  InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 
(20180725)
  Python3Details: /usr/bin/python3.8, Python 3.8.2, python3-minimal, 
3.8.2-0ubuntu2
  PythonDetails: N/A
  RelatedPackageVersions:
   dpkg 1.19.7ubuntu3
   apt  2.0.1ubuntu1
  SourcePackage:

[Touch-packages] [Bug 1868474] ProcModules.txt

2020-03-25 Thread D
apport information

** Attachment added: "ProcModules.txt"
   
https://bugs.launchpad.net/bugs/1868474/+attachment/5341479/+files/ProcModules.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1868474

Title:
  20.04 Xorg doesn't detect/load Elantech mouse driver on Lenovo P73

Status in xorg package in Ubuntu:
  Incomplete

Bug description:
  The installation scripts loads the correct drivers so the touch pad
  and pointer works during the install. However after the install
  neither work.

  I've worked around it by using a wireless USB from Vilros for mouse input 
while logging in. Then issuing (found on 
https://askubuntu.com/questions/1143663):
   sudo 'echo -n "elantech">/sys/bus/serio/devices/serio1/protocol'

  So it's a bug for me but one I can work around and should be fixed before 
20.04 goes live.
  --- 
  ProblemType: Bug
  .proc.driver.nvidia.gpus..01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:01:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
   GCC version:  gcc version 9.3.0 (Ubuntu 9.3.0-5ubuntu1)
  ApportVersion: 2.20.11-0ubuntu21
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus:
   nvidia, 440.64, 5.4.0-14-generic, x86_64: installed
   nvidia, 440.64, 5.4.0-18-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   NVIDIA Corporation TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [10de:1eb5] 
(rev a1) (prog-if 00 [VGA controller])
 Subsystem: Lenovo TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [17aa:229b]
  InstallationDate: Installed on 2020-03-21 (3 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200315)
  MachineType: LENOVO 20QRCTO1WW
  NonfreeKernelModules: nvidia_modeset nvidia
  Package: xorg 1:7.7+19ubuntu14
  PackageArchitecture: amd64
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-18-generic 
root=UUID=d38adcbd-2ba3-4d84-84b7-388b5f55daa7 ro psmouse.elantech_smbus=0 
quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
  Tags:  focal ubuntu reproducible has-workaround
  Uname: Linux 5.4.0-18-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 01/08/2020
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N2NET35W (1.20 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20QRCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0Q40104 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN2NET35W(1.20):bd01/08/2020:svnLENOVO:pn20QRCTO1WW:pvrThinkPadP73:rvnLENOVO:rn20QRCTO1WW:rvrSDK0Q40104WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad P73
  dmi.product.name: 20QRCTO1WW
  dmi.product.sku: LENOVO_MT_20QR_BU_Think_FM_ThinkPad P73
  dmi.product.version: ThinkPad P73
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.100-4
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.0-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.0-1ubuntu1
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.7-2ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1868474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868474] xdpyinfo.txt

2020-03-25 Thread D
apport information

** Attachment added: "xdpyinfo.txt"
   
https://bugs.launchpad.net/bugs/1868474/+attachment/5341485/+files/xdpyinfo.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1868474

Title:
  20.04 Xorg doesn't detect/load Elantech mouse driver on Lenovo P73

Status in xorg package in Ubuntu:
  Incomplete

Bug description:
  The installation scripts loads the correct drivers so the touch pad
  and pointer works during the install. However after the install
  neither work.

  I've worked around it by using a wireless USB from Vilros for mouse input 
while logging in. Then issuing (found on 
https://askubuntu.com/questions/1143663):
   sudo 'echo -n "elantech">/sys/bus/serio/devices/serio1/protocol'

  So it's a bug for me but one I can work around and should be fixed before 
20.04 goes live.
  --- 
  ProblemType: Bug
  .proc.driver.nvidia.gpus..01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:01:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
   GCC version:  gcc version 9.3.0 (Ubuntu 9.3.0-5ubuntu1)
  ApportVersion: 2.20.11-0ubuntu21
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus:
   nvidia, 440.64, 5.4.0-14-generic, x86_64: installed
   nvidia, 440.64, 5.4.0-18-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   NVIDIA Corporation TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [10de:1eb5] 
(rev a1) (prog-if 00 [VGA controller])
 Subsystem: Lenovo TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [17aa:229b]
  InstallationDate: Installed on 2020-03-21 (3 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200315)
  MachineType: LENOVO 20QRCTO1WW
  NonfreeKernelModules: nvidia_modeset nvidia
  Package: xorg 1:7.7+19ubuntu14
  PackageArchitecture: amd64
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-18-generic 
root=UUID=d38adcbd-2ba3-4d84-84b7-388b5f55daa7 ro psmouse.elantech_smbus=0 
quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
  Tags:  focal ubuntu reproducible has-workaround
  Uname: Linux 5.4.0-18-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 01/08/2020
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N2NET35W (1.20 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20QRCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0Q40104 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN2NET35W(1.20):bd01/08/2020:svnLENOVO:pn20QRCTO1WW:pvrThinkPadP73:rvnLENOVO:rn20QRCTO1WW:rvrSDK0Q40104WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad P73
  dmi.product.name: 20QRCTO1WW
  dmi.product.sku: LENOVO_MT_20QR_BU_Think_FM_ThinkPad P73
  dmi.product.version: ThinkPad P73
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.100-4
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.0-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.0-1ubuntu1
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.7-2ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1868474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868474] Xrandr.txt

2020-03-25 Thread D
apport information

** Attachment added: "Xrandr.txt"
   https://bugs.launchpad.net/bugs/1868474/+attachment/5341483/+files/Xrandr.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1868474

Title:
  20.04 Xorg doesn't detect/load Elantech mouse driver on Lenovo P73

Status in xorg package in Ubuntu:
  Incomplete

Bug description:
  The installation scripts loads the correct drivers so the touch pad
  and pointer works during the install. However after the install
  neither work.

  I've worked around it by using a wireless USB from Vilros for mouse input 
while logging in. Then issuing (found on 
https://askubuntu.com/questions/1143663):
   sudo 'echo -n "elantech">/sys/bus/serio/devices/serio1/protocol'

  So it's a bug for me but one I can work around and should be fixed before 
20.04 goes live.
  --- 
  ProblemType: Bug
  .proc.driver.nvidia.gpus..01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:01:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
   GCC version:  gcc version 9.3.0 (Ubuntu 9.3.0-5ubuntu1)
  ApportVersion: 2.20.11-0ubuntu21
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus:
   nvidia, 440.64, 5.4.0-14-generic, x86_64: installed
   nvidia, 440.64, 5.4.0-18-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   NVIDIA Corporation TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [10de:1eb5] 
(rev a1) (prog-if 00 [VGA controller])
 Subsystem: Lenovo TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [17aa:229b]
  InstallationDate: Installed on 2020-03-21 (3 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200315)
  MachineType: LENOVO 20QRCTO1WW
  NonfreeKernelModules: nvidia_modeset nvidia
  Package: xorg 1:7.7+19ubuntu14
  PackageArchitecture: amd64
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-18-generic 
root=UUID=d38adcbd-2ba3-4d84-84b7-388b5f55daa7 ro psmouse.elantech_smbus=0 
quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
  Tags:  focal ubuntu reproducible has-workaround
  Uname: Linux 5.4.0-18-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 01/08/2020
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N2NET35W (1.20 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20QRCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0Q40104 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN2NET35W(1.20):bd01/08/2020:svnLENOVO:pn20QRCTO1WW:pvrThinkPadP73:rvnLENOVO:rn20QRCTO1WW:rvrSDK0Q40104WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad P73
  dmi.product.name: 20QRCTO1WW
  dmi.product.sku: LENOVO_MT_20QR_BU_Think_FM_ThinkPad P73
  dmi.product.version: ThinkPad P73
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.100-4
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.0-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.0-1ubuntu1
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.7-2ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1868474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868474] UdevDb.txt

2020-03-25 Thread D
apport information

** Attachment added: "UdevDb.txt"
   https://bugs.launchpad.net/bugs/1868474/+attachment/5341480/+files/UdevDb.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1868474

Title:
  20.04 Xorg doesn't detect/load Elantech mouse driver on Lenovo P73

Status in xorg package in Ubuntu:
  Incomplete

Bug description:
  The installation scripts loads the correct drivers so the touch pad
  and pointer works during the install. However after the install
  neither work.

  I've worked around it by using a wireless USB from Vilros for mouse input 
while logging in. Then issuing (found on 
https://askubuntu.com/questions/1143663):
   sudo 'echo -n "elantech">/sys/bus/serio/devices/serio1/protocol'

  So it's a bug for me but one I can work around and should be fixed before 
20.04 goes live.
  --- 
  ProblemType: Bug
  .proc.driver.nvidia.gpus..01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:01:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
   GCC version:  gcc version 9.3.0 (Ubuntu 9.3.0-5ubuntu1)
  ApportVersion: 2.20.11-0ubuntu21
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus:
   nvidia, 440.64, 5.4.0-14-generic, x86_64: installed
   nvidia, 440.64, 5.4.0-18-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   NVIDIA Corporation TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [10de:1eb5] 
(rev a1) (prog-if 00 [VGA controller])
 Subsystem: Lenovo TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [17aa:229b]
  InstallationDate: Installed on 2020-03-21 (3 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200315)
  MachineType: LENOVO 20QRCTO1WW
  NonfreeKernelModules: nvidia_modeset nvidia
  Package: xorg 1:7.7+19ubuntu14
  PackageArchitecture: amd64
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-18-generic 
root=UUID=d38adcbd-2ba3-4d84-84b7-388b5f55daa7 ro psmouse.elantech_smbus=0 
quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
  Tags:  focal ubuntu reproducible has-workaround
  Uname: Linux 5.4.0-18-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 01/08/2020
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N2NET35W (1.20 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20QRCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0Q40104 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN2NET35W(1.20):bd01/08/2020:svnLENOVO:pn20QRCTO1WW:pvrThinkPadP73:rvnLENOVO:rn20QRCTO1WW:rvrSDK0Q40104WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad P73
  dmi.product.name: 20QRCTO1WW
  dmi.product.sku: LENOVO_MT_20QR_BU_Think_FM_ThinkPad P73
  dmi.product.version: ThinkPad P73
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.100-4
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.0-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.0-1ubuntu1
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.7-2ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1868474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868474] MonitorsUser.xml.txt

2020-03-25 Thread D
apport information

** Attachment added: "MonitorsUser.xml.txt"
   
https://bugs.launchpad.net/bugs/1868474/+attachment/5341474/+files/MonitorsUser.xml.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1868474

Title:
  20.04 Xorg doesn't detect/load Elantech mouse driver on Lenovo P73

Status in xorg package in Ubuntu:
  Incomplete

Bug description:
  The installation scripts loads the correct drivers so the touch pad
  and pointer works during the install. However after the install
  neither work.

  I've worked around it by using a wireless USB from Vilros for mouse input 
while logging in. Then issuing (found on 
https://askubuntu.com/questions/1143663):
   sudo 'echo -n "elantech">/sys/bus/serio/devices/serio1/protocol'

  So it's a bug for me but one I can work around and should be fixed before 
20.04 goes live.
  --- 
  ProblemType: Bug
  .proc.driver.nvidia.gpus..01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:01:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
   GCC version:  gcc version 9.3.0 (Ubuntu 9.3.0-5ubuntu1)
  ApportVersion: 2.20.11-0ubuntu21
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus:
   nvidia, 440.64, 5.4.0-14-generic, x86_64: installed
   nvidia, 440.64, 5.4.0-18-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   NVIDIA Corporation TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [10de:1eb5] 
(rev a1) (prog-if 00 [VGA controller])
 Subsystem: Lenovo TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [17aa:229b]
  InstallationDate: Installed on 2020-03-21 (3 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200315)
  MachineType: LENOVO 20QRCTO1WW
  NonfreeKernelModules: nvidia_modeset nvidia
  Package: xorg 1:7.7+19ubuntu14
  PackageArchitecture: amd64
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-18-generic 
root=UUID=d38adcbd-2ba3-4d84-84b7-388b5f55daa7 ro psmouse.elantech_smbus=0 
quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
  Tags:  focal ubuntu reproducible has-workaround
  Uname: Linux 5.4.0-18-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 01/08/2020
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N2NET35W (1.20 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20QRCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0Q40104 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN2NET35W(1.20):bd01/08/2020:svnLENOVO:pn20QRCTO1WW:pvrThinkPadP73:rvnLENOVO:rn20QRCTO1WW:rvrSDK0Q40104WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad P73
  dmi.product.name: 20QRCTO1WW
  dmi.product.sku: LENOVO_MT_20QR_BU_Think_FM_ThinkPad P73
  dmi.product.version: ThinkPad P73
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.100-4
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.0-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.0-1ubuntu1
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.7-2ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1868474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868474] NvidiaBugReportLog.txt

2020-03-25 Thread D
apport information

** Attachment added: "NvidiaBugReportLog.txt"
   
https://bugs.launchpad.net/bugs/1868474/+attachment/5341475/+files/NvidiaBugReportLog.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1868474

Title:
  20.04 Xorg doesn't detect/load Elantech mouse driver on Lenovo P73

Status in xorg package in Ubuntu:
  Incomplete

Bug description:
  The installation scripts loads the correct drivers so the touch pad
  and pointer works during the install. However after the install
  neither work.

  I've worked around it by using a wireless USB from Vilros for mouse input 
while logging in. Then issuing (found on 
https://askubuntu.com/questions/1143663):
   sudo 'echo -n "elantech">/sys/bus/serio/devices/serio1/protocol'

  So it's a bug for me but one I can work around and should be fixed before 
20.04 goes live.
  --- 
  ProblemType: Bug
  .proc.driver.nvidia.gpus..01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:01:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
   GCC version:  gcc version 9.3.0 (Ubuntu 9.3.0-5ubuntu1)
  ApportVersion: 2.20.11-0ubuntu21
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus:
   nvidia, 440.64, 5.4.0-14-generic, x86_64: installed
   nvidia, 440.64, 5.4.0-18-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   NVIDIA Corporation TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [10de:1eb5] 
(rev a1) (prog-if 00 [VGA controller])
 Subsystem: Lenovo TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [17aa:229b]
  InstallationDate: Installed on 2020-03-21 (3 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200315)
  MachineType: LENOVO 20QRCTO1WW
  NonfreeKernelModules: nvidia_modeset nvidia
  Package: xorg 1:7.7+19ubuntu14
  PackageArchitecture: amd64
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-18-generic 
root=UUID=d38adcbd-2ba3-4d84-84b7-388b5f55daa7 ro psmouse.elantech_smbus=0 
quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
  Tags:  focal ubuntu reproducible has-workaround
  Uname: Linux 5.4.0-18-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 01/08/2020
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N2NET35W (1.20 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20QRCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0Q40104 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN2NET35W(1.20):bd01/08/2020:svnLENOVO:pn20QRCTO1WW:pvrThinkPadP73:rvnLENOVO:rn20QRCTO1WW:rvrSDK0Q40104WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad P73
  dmi.product.name: 20QRCTO1WW
  dmi.product.sku: LENOVO_MT_20QR_BU_Think_FM_ThinkPad P73
  dmi.product.version: ThinkPad P73
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.100-4
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.0-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.0-1ubuntu1
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.7-2ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1868474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868474] nvidia-settings.txt

2020-03-25 Thread D
apport information

** Attachment added: "nvidia-settings.txt"
   
https://bugs.launchpad.net/bugs/1868474/+attachment/5341484/+files/nvidia-settings.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1868474

Title:
  20.04 Xorg doesn't detect/load Elantech mouse driver on Lenovo P73

Status in xorg package in Ubuntu:
  Incomplete

Bug description:
  The installation scripts loads the correct drivers so the touch pad
  and pointer works during the install. However after the install
  neither work.

  I've worked around it by using a wireless USB from Vilros for mouse input 
while logging in. Then issuing (found on 
https://askubuntu.com/questions/1143663):
   sudo 'echo -n "elantech">/sys/bus/serio/devices/serio1/protocol'

  So it's a bug for me but one I can work around and should be fixed before 
20.04 goes live.
  --- 
  ProblemType: Bug
  .proc.driver.nvidia.gpus..01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:01:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
   GCC version:  gcc version 9.3.0 (Ubuntu 9.3.0-5ubuntu1)
  ApportVersion: 2.20.11-0ubuntu21
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus:
   nvidia, 440.64, 5.4.0-14-generic, x86_64: installed
   nvidia, 440.64, 5.4.0-18-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   NVIDIA Corporation TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [10de:1eb5] 
(rev a1) (prog-if 00 [VGA controller])
 Subsystem: Lenovo TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [17aa:229b]
  InstallationDate: Installed on 2020-03-21 (3 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200315)
  MachineType: LENOVO 20QRCTO1WW
  NonfreeKernelModules: nvidia_modeset nvidia
  Package: xorg 1:7.7+19ubuntu14
  PackageArchitecture: amd64
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-18-generic 
root=UUID=d38adcbd-2ba3-4d84-84b7-388b5f55daa7 ro psmouse.elantech_smbus=0 
quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
  Tags:  focal ubuntu reproducible has-workaround
  Uname: Linux 5.4.0-18-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 01/08/2020
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N2NET35W (1.20 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20QRCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0Q40104 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN2NET35W(1.20):bd01/08/2020:svnLENOVO:pn20QRCTO1WW:pvrThinkPadP73:rvnLENOVO:rn20QRCTO1WW:rvrSDK0Q40104WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad P73
  dmi.product.name: 20QRCTO1WW
  dmi.product.sku: LENOVO_MT_20QR_BU_Think_FM_ThinkPad P73
  dmi.product.version: ThinkPad P73
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.100-4
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.0-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.0-1ubuntu1
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.7-2ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1868474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868474] XorgLogOld.txt

2020-03-25 Thread D
apport information

** Attachment added: "XorgLogOld.txt"
   
https://bugs.launchpad.net/bugs/1868474/+attachment/5341482/+files/XorgLogOld.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1868474

Title:
  20.04 Xorg doesn't detect/load Elantech mouse driver on Lenovo P73

Status in xorg package in Ubuntu:
  Incomplete

Bug description:
  The installation scripts loads the correct drivers so the touch pad
  and pointer works during the install. However after the install
  neither work.

  I've worked around it by using a wireless USB from Vilros for mouse input 
while logging in. Then issuing (found on 
https://askubuntu.com/questions/1143663):
   sudo 'echo -n "elantech">/sys/bus/serio/devices/serio1/protocol'

  So it's a bug for me but one I can work around and should be fixed before 
20.04 goes live.
  --- 
  ProblemType: Bug
  .proc.driver.nvidia.gpus..01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:01:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
   GCC version:  gcc version 9.3.0 (Ubuntu 9.3.0-5ubuntu1)
  ApportVersion: 2.20.11-0ubuntu21
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus:
   nvidia, 440.64, 5.4.0-14-generic, x86_64: installed
   nvidia, 440.64, 5.4.0-18-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   NVIDIA Corporation TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [10de:1eb5] 
(rev a1) (prog-if 00 [VGA controller])
 Subsystem: Lenovo TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [17aa:229b]
  InstallationDate: Installed on 2020-03-21 (3 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200315)
  MachineType: LENOVO 20QRCTO1WW
  NonfreeKernelModules: nvidia_modeset nvidia
  Package: xorg 1:7.7+19ubuntu14
  PackageArchitecture: amd64
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-18-generic 
root=UUID=d38adcbd-2ba3-4d84-84b7-388b5f55daa7 ro psmouse.elantech_smbus=0 
quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
  Tags:  focal ubuntu reproducible has-workaround
  Uname: Linux 5.4.0-18-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 01/08/2020
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N2NET35W (1.20 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20QRCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0Q40104 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN2NET35W(1.20):bd01/08/2020:svnLENOVO:pn20QRCTO1WW:pvrThinkPadP73:rvnLENOVO:rn20QRCTO1WW:rvrSDK0Q40104WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad P73
  dmi.product.name: 20QRCTO1WW
  dmi.product.sku: LENOVO_MT_20QR_BU_Think_FM_ThinkPad P73
  dmi.product.version: ThinkPad P73
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.100-4
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.0-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.0-1ubuntu1
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.7-2ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1868474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868474] ProcInterrupts.txt

2020-03-25 Thread D
apport information

** Attachment added: "ProcInterrupts.txt"
   
https://bugs.launchpad.net/bugs/1868474/+attachment/5341478/+files/ProcInterrupts.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1868474

Title:
  20.04 Xorg doesn't detect/load Elantech mouse driver on Lenovo P73

Status in xorg package in Ubuntu:
  Incomplete

Bug description:
  The installation scripts loads the correct drivers so the touch pad
  and pointer works during the install. However after the install
  neither work.

  I've worked around it by using a wireless USB from Vilros for mouse input 
while logging in. Then issuing (found on 
https://askubuntu.com/questions/1143663):
   sudo 'echo -n "elantech">/sys/bus/serio/devices/serio1/protocol'

  So it's a bug for me but one I can work around and should be fixed before 
20.04 goes live.
  --- 
  ProblemType: Bug
  .proc.driver.nvidia.gpus..01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:01:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
   GCC version:  gcc version 9.3.0 (Ubuntu 9.3.0-5ubuntu1)
  ApportVersion: 2.20.11-0ubuntu21
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus:
   nvidia, 440.64, 5.4.0-14-generic, x86_64: installed
   nvidia, 440.64, 5.4.0-18-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   NVIDIA Corporation TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [10de:1eb5] 
(rev a1) (prog-if 00 [VGA controller])
 Subsystem: Lenovo TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [17aa:229b]
  InstallationDate: Installed on 2020-03-21 (3 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200315)
  MachineType: LENOVO 20QRCTO1WW
  NonfreeKernelModules: nvidia_modeset nvidia
  Package: xorg 1:7.7+19ubuntu14
  PackageArchitecture: amd64
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-18-generic 
root=UUID=d38adcbd-2ba3-4d84-84b7-388b5f55daa7 ro psmouse.elantech_smbus=0 
quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
  Tags:  focal ubuntu reproducible has-workaround
  Uname: Linux 5.4.0-18-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 01/08/2020
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N2NET35W (1.20 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20QRCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0Q40104 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN2NET35W(1.20):bd01/08/2020:svnLENOVO:pn20QRCTO1WW:pvrThinkPadP73:rvnLENOVO:rn20QRCTO1WW:rvrSDK0Q40104WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad P73
  dmi.product.name: 20QRCTO1WW
  dmi.product.sku: LENOVO_MT_20QR_BU_Think_FM_ThinkPad P73
  dmi.product.version: ThinkPad P73
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.100-4
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.0-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.0-1ubuntu1
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.7-2ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1868474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868474] XorgLog.txt

2020-03-25 Thread D
apport information

** Attachment added: "XorgLog.txt"
   
https://bugs.launchpad.net/bugs/1868474/+attachment/5341481/+files/XorgLog.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1868474

Title:
  20.04 Xorg doesn't detect/load Elantech mouse driver on Lenovo P73

Status in xorg package in Ubuntu:
  Incomplete

Bug description:
  The installation scripts loads the correct drivers so the touch pad
  and pointer works during the install. However after the install
  neither work.

  I've worked around it by using a wireless USB from Vilros for mouse input 
while logging in. Then issuing (found on 
https://askubuntu.com/questions/1143663):
   sudo 'echo -n "elantech">/sys/bus/serio/devices/serio1/protocol'

  So it's a bug for me but one I can work around and should be fixed before 
20.04 goes live.
  --- 
  ProblemType: Bug
  .proc.driver.nvidia.gpus..01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:01:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
   GCC version:  gcc version 9.3.0 (Ubuntu 9.3.0-5ubuntu1)
  ApportVersion: 2.20.11-0ubuntu21
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus:
   nvidia, 440.64, 5.4.0-14-generic, x86_64: installed
   nvidia, 440.64, 5.4.0-18-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   NVIDIA Corporation TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [10de:1eb5] 
(rev a1) (prog-if 00 [VGA controller])
 Subsystem: Lenovo TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [17aa:229b]
  InstallationDate: Installed on 2020-03-21 (3 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200315)
  MachineType: LENOVO 20QRCTO1WW
  NonfreeKernelModules: nvidia_modeset nvidia
  Package: xorg 1:7.7+19ubuntu14
  PackageArchitecture: amd64
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-18-generic 
root=UUID=d38adcbd-2ba3-4d84-84b7-388b5f55daa7 ro psmouse.elantech_smbus=0 
quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
  Tags:  focal ubuntu reproducible has-workaround
  Uname: Linux 5.4.0-18-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 01/08/2020
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N2NET35W (1.20 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20QRCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0Q40104 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN2NET35W(1.20):bd01/08/2020:svnLENOVO:pn20QRCTO1WW:pvrThinkPadP73:rvnLENOVO:rn20QRCTO1WW:rvrSDK0Q40104WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad P73
  dmi.product.name: 20QRCTO1WW
  dmi.product.sku: LENOVO_MT_20QR_BU_Think_FM_ThinkPad P73
  dmi.product.version: ThinkPad P73
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.100-4
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.0-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.0-1ubuntu1
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.7-2ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1868474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868474] Lsusb.txt

2020-03-25 Thread D
apport information

** Attachment added: "Lsusb.txt"
   https://bugs.launchpad.net/bugs/1868474/+attachment/5341471/+files/Lsusb.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1868474

Title:
  20.04 Xorg doesn't detect/load Elantech mouse driver on Lenovo P73

Status in xorg package in Ubuntu:
  Incomplete

Bug description:
  The installation scripts loads the correct drivers so the touch pad
  and pointer works during the install. However after the install
  neither work.

  I've worked around it by using a wireless USB from Vilros for mouse input 
while logging in. Then issuing (found on 
https://askubuntu.com/questions/1143663):
   sudo 'echo -n "elantech">/sys/bus/serio/devices/serio1/protocol'

  So it's a bug for me but one I can work around and should be fixed before 
20.04 goes live.
  --- 
  ProblemType: Bug
  .proc.driver.nvidia.gpus..01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:01:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
   GCC version:  gcc version 9.3.0 (Ubuntu 9.3.0-5ubuntu1)
  ApportVersion: 2.20.11-0ubuntu21
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus:
   nvidia, 440.64, 5.4.0-14-generic, x86_64: installed
   nvidia, 440.64, 5.4.0-18-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   NVIDIA Corporation TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [10de:1eb5] 
(rev a1) (prog-if 00 [VGA controller])
 Subsystem: Lenovo TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [17aa:229b]
  InstallationDate: Installed on 2020-03-21 (3 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200315)
  MachineType: LENOVO 20QRCTO1WW
  NonfreeKernelModules: nvidia_modeset nvidia
  Package: xorg 1:7.7+19ubuntu14
  PackageArchitecture: amd64
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-18-generic 
root=UUID=d38adcbd-2ba3-4d84-84b7-388b5f55daa7 ro psmouse.elantech_smbus=0 
quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
  Tags:  focal ubuntu reproducible has-workaround
  Uname: Linux 5.4.0-18-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 01/08/2020
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N2NET35W (1.20 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20QRCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0Q40104 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN2NET35W(1.20):bd01/08/2020:svnLENOVO:pn20QRCTO1WW:pvrThinkPadP73:rvnLENOVO:rn20QRCTO1WW:rvrSDK0Q40104WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad P73
  dmi.product.name: 20QRCTO1WW
  dmi.product.sku: LENOVO_MT_20QR_BU_Think_FM_ThinkPad P73
  dmi.product.version: ThinkPad P73
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.100-4
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.0-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.0-1ubuntu1
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.7-2ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1868474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868474] Lspci.txt

2020-03-25 Thread D
apport information

** Attachment added: "Lspci.txt"
   https://bugs.launchpad.net/bugs/1868474/+attachment/5341470/+files/Lspci.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1868474

Title:
  20.04 Xorg doesn't detect/load Elantech mouse driver on Lenovo P73

Status in xorg package in Ubuntu:
  Incomplete

Bug description:
  The installation scripts loads the correct drivers so the touch pad
  and pointer works during the install. However after the install
  neither work.

  I've worked around it by using a wireless USB from Vilros for mouse input 
while logging in. Then issuing (found on 
https://askubuntu.com/questions/1143663):
   sudo 'echo -n "elantech">/sys/bus/serio/devices/serio1/protocol'

  So it's a bug for me but one I can work around and should be fixed before 
20.04 goes live.
  --- 
  ProblemType: Bug
  .proc.driver.nvidia.gpus..01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:01:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
   GCC version:  gcc version 9.3.0 (Ubuntu 9.3.0-5ubuntu1)
  ApportVersion: 2.20.11-0ubuntu21
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus:
   nvidia, 440.64, 5.4.0-14-generic, x86_64: installed
   nvidia, 440.64, 5.4.0-18-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   NVIDIA Corporation TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [10de:1eb5] 
(rev a1) (prog-if 00 [VGA controller])
 Subsystem: Lenovo TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [17aa:229b]
  InstallationDate: Installed on 2020-03-21 (3 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200315)
  MachineType: LENOVO 20QRCTO1WW
  NonfreeKernelModules: nvidia_modeset nvidia
  Package: xorg 1:7.7+19ubuntu14
  PackageArchitecture: amd64
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-18-generic 
root=UUID=d38adcbd-2ba3-4d84-84b7-388b5f55daa7 ro psmouse.elantech_smbus=0 
quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
  Tags:  focal ubuntu reproducible has-workaround
  Uname: Linux 5.4.0-18-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 01/08/2020
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N2NET35W (1.20 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20QRCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0Q40104 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN2NET35W(1.20):bd01/08/2020:svnLENOVO:pn20QRCTO1WW:pvrThinkPadP73:rvnLENOVO:rn20QRCTO1WW:rvrSDK0Q40104WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad P73
  dmi.product.name: 20QRCTO1WW
  dmi.product.sku: LENOVO_MT_20QR_BU_Think_FM_ThinkPad P73
  dmi.product.version: ThinkPad P73
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.100-4
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.0-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.0-1ubuntu1
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.7-2ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1868474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868474] ProcCpuinfoMinimal.txt

2020-03-25 Thread D
apport information

** Attachment added: "ProcCpuinfoMinimal.txt"
   
https://bugs.launchpad.net/bugs/1868474/+attachment/5341477/+files/ProcCpuinfoMinimal.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1868474

Title:
  20.04 Xorg doesn't detect/load Elantech mouse driver on Lenovo P73

Status in xorg package in Ubuntu:
  Incomplete

Bug description:
  The installation scripts loads the correct drivers so the touch pad
  and pointer works during the install. However after the install
  neither work.

  I've worked around it by using a wireless USB from Vilros for mouse input 
while logging in. Then issuing (found on 
https://askubuntu.com/questions/1143663):
   sudo 'echo -n "elantech">/sys/bus/serio/devices/serio1/protocol'

  So it's a bug for me but one I can work around and should be fixed before 
20.04 goes live.
  --- 
  ProblemType: Bug
  .proc.driver.nvidia.gpus..01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:01:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
   GCC version:  gcc version 9.3.0 (Ubuntu 9.3.0-5ubuntu1)
  ApportVersion: 2.20.11-0ubuntu21
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus:
   nvidia, 440.64, 5.4.0-14-generic, x86_64: installed
   nvidia, 440.64, 5.4.0-18-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   NVIDIA Corporation TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [10de:1eb5] 
(rev a1) (prog-if 00 [VGA controller])
 Subsystem: Lenovo TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [17aa:229b]
  InstallationDate: Installed on 2020-03-21 (3 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200315)
  MachineType: LENOVO 20QRCTO1WW
  NonfreeKernelModules: nvidia_modeset nvidia
  Package: xorg 1:7.7+19ubuntu14
  PackageArchitecture: amd64
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-18-generic 
root=UUID=d38adcbd-2ba3-4d84-84b7-388b5f55daa7 ro psmouse.elantech_smbus=0 
quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
  Tags:  focal ubuntu reproducible has-workaround
  Uname: Linux 5.4.0-18-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 01/08/2020
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N2NET35W (1.20 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20QRCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0Q40104 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN2NET35W(1.20):bd01/08/2020:svnLENOVO:pn20QRCTO1WW:pvrThinkPadP73:rvnLENOVO:rn20QRCTO1WW:rvrSDK0Q40104WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad P73
  dmi.product.name: 20QRCTO1WW
  dmi.product.sku: LENOVO_MT_20QR_BU_Think_FM_ThinkPad P73
  dmi.product.version: ThinkPad P73
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.100-4
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.0-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.0-1ubuntu1
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.7-2ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1868474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868474] ProcCpuinfo.txt

2020-03-25 Thread D
apport information

** Attachment added: "ProcCpuinfo.txt"
   
https://bugs.launchpad.net/bugs/1868474/+attachment/5341476/+files/ProcCpuinfo.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1868474

Title:
  20.04 Xorg doesn't detect/load Elantech mouse driver on Lenovo P73

Status in xorg package in Ubuntu:
  Incomplete

Bug description:
  The installation scripts loads the correct drivers so the touch pad
  and pointer works during the install. However after the install
  neither work.

  I've worked around it by using a wireless USB from Vilros for mouse input 
while logging in. Then issuing (found on 
https://askubuntu.com/questions/1143663):
   sudo 'echo -n "elantech">/sys/bus/serio/devices/serio1/protocol'

  So it's a bug for me but one I can work around and should be fixed before 
20.04 goes live.
  --- 
  ProblemType: Bug
  .proc.driver.nvidia.gpus..01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:01:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
   GCC version:  gcc version 9.3.0 (Ubuntu 9.3.0-5ubuntu1)
  ApportVersion: 2.20.11-0ubuntu21
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus:
   nvidia, 440.64, 5.4.0-14-generic, x86_64: installed
   nvidia, 440.64, 5.4.0-18-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   NVIDIA Corporation TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [10de:1eb5] 
(rev a1) (prog-if 00 [VGA controller])
 Subsystem: Lenovo TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [17aa:229b]
  InstallationDate: Installed on 2020-03-21 (3 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200315)
  MachineType: LENOVO 20QRCTO1WW
  NonfreeKernelModules: nvidia_modeset nvidia
  Package: xorg 1:7.7+19ubuntu14
  PackageArchitecture: amd64
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-18-generic 
root=UUID=d38adcbd-2ba3-4d84-84b7-388b5f55daa7 ro psmouse.elantech_smbus=0 
quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
  Tags:  focal ubuntu reproducible has-workaround
  Uname: Linux 5.4.0-18-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 01/08/2020
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N2NET35W (1.20 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20QRCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0Q40104 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN2NET35W(1.20):bd01/08/2020:svnLENOVO:pn20QRCTO1WW:pvrThinkPadP73:rvnLENOVO:rn20QRCTO1WW:rvrSDK0Q40104WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad P73
  dmi.product.name: 20QRCTO1WW
  dmi.product.sku: LENOVO_MT_20QR_BU_Think_FM_ThinkPad P73
  dmi.product.version: ThinkPad P73
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.100-4
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.0-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.0-1ubuntu1
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.7-2ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1868474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868474] Lsusb-v.txt

2020-03-25 Thread D
apport information

** Attachment added: "Lsusb-v.txt"
   
https://bugs.launchpad.net/bugs/1868474/+attachment/5341473/+files/Lsusb-v.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1868474

Title:
  20.04 Xorg doesn't detect/load Elantech mouse driver on Lenovo P73

Status in xorg package in Ubuntu:
  Incomplete

Bug description:
  The installation scripts loads the correct drivers so the touch pad
  and pointer works during the install. However after the install
  neither work.

  I've worked around it by using a wireless USB from Vilros for mouse input 
while logging in. Then issuing (found on 
https://askubuntu.com/questions/1143663):
   sudo 'echo -n "elantech">/sys/bus/serio/devices/serio1/protocol'

  So it's a bug for me but one I can work around and should be fixed before 
20.04 goes live.
  --- 
  ProblemType: Bug
  .proc.driver.nvidia.gpus..01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:01:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
   GCC version:  gcc version 9.3.0 (Ubuntu 9.3.0-5ubuntu1)
  ApportVersion: 2.20.11-0ubuntu21
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus:
   nvidia, 440.64, 5.4.0-14-generic, x86_64: installed
   nvidia, 440.64, 5.4.0-18-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   NVIDIA Corporation TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [10de:1eb5] 
(rev a1) (prog-if 00 [VGA controller])
 Subsystem: Lenovo TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [17aa:229b]
  InstallationDate: Installed on 2020-03-21 (3 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200315)
  MachineType: LENOVO 20QRCTO1WW
  NonfreeKernelModules: nvidia_modeset nvidia
  Package: xorg 1:7.7+19ubuntu14
  PackageArchitecture: amd64
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-18-generic 
root=UUID=d38adcbd-2ba3-4d84-84b7-388b5f55daa7 ro psmouse.elantech_smbus=0 
quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
  Tags:  focal ubuntu reproducible has-workaround
  Uname: Linux 5.4.0-18-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 01/08/2020
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N2NET35W (1.20 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20QRCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0Q40104 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN2NET35W(1.20):bd01/08/2020:svnLENOVO:pn20QRCTO1WW:pvrThinkPadP73:rvnLENOVO:rn20QRCTO1WW:rvrSDK0Q40104WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad P73
  dmi.product.name: 20QRCTO1WW
  dmi.product.sku: LENOVO_MT_20QR_BU_Think_FM_ThinkPad P73
  dmi.product.version: ThinkPad P73
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.100-4
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.0-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.0-1ubuntu1
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.7-2ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1868474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868474] DpkgLog.txt

2020-03-25 Thread D
apport information

** Attachment added: "DpkgLog.txt"
   
https://bugs.launchpad.net/bugs/1868474/+attachment/5341469/+files/DpkgLog.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1868474

Title:
  20.04 Xorg doesn't detect/load Elantech mouse driver on Lenovo P73

Status in xorg package in Ubuntu:
  Incomplete

Bug description:
  The installation scripts loads the correct drivers so the touch pad
  and pointer works during the install. However after the install
  neither work.

  I've worked around it by using a wireless USB from Vilros for mouse input 
while logging in. Then issuing (found on 
https://askubuntu.com/questions/1143663):
   sudo 'echo -n "elantech">/sys/bus/serio/devices/serio1/protocol'

  So it's a bug for me but one I can work around and should be fixed before 
20.04 goes live.
  --- 
  ProblemType: Bug
  .proc.driver.nvidia.gpus..01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:01:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
   GCC version:  gcc version 9.3.0 (Ubuntu 9.3.0-5ubuntu1)
  ApportVersion: 2.20.11-0ubuntu21
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus:
   nvidia, 440.64, 5.4.0-14-generic, x86_64: installed
   nvidia, 440.64, 5.4.0-18-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   NVIDIA Corporation TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [10de:1eb5] 
(rev a1) (prog-if 00 [VGA controller])
 Subsystem: Lenovo TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [17aa:229b]
  InstallationDate: Installed on 2020-03-21 (3 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200315)
  MachineType: LENOVO 20QRCTO1WW
  NonfreeKernelModules: nvidia_modeset nvidia
  Package: xorg 1:7.7+19ubuntu14
  PackageArchitecture: amd64
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-18-generic 
root=UUID=d38adcbd-2ba3-4d84-84b7-388b5f55daa7 ro psmouse.elantech_smbus=0 
quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
  Tags:  focal ubuntu reproducible has-workaround
  Uname: Linux 5.4.0-18-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 01/08/2020
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N2NET35W (1.20 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20QRCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0Q40104 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN2NET35W(1.20):bd01/08/2020:svnLENOVO:pn20QRCTO1WW:pvrThinkPadP73:rvnLENOVO:rn20QRCTO1WW:rvrSDK0Q40104WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad P73
  dmi.product.name: 20QRCTO1WW
  dmi.product.sku: LENOVO_MT_20QR_BU_Think_FM_ThinkPad P73
  dmi.product.version: ThinkPad P73
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.100-4
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.0-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.0-1ubuntu1
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.7-2ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1868474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868474] Lsusb-t.txt

2020-03-25 Thread D
apport information

** Attachment added: "Lsusb-t.txt"
   
https://bugs.launchpad.net/bugs/1868474/+attachment/5341472/+files/Lsusb-t.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1868474

Title:
  20.04 Xorg doesn't detect/load Elantech mouse driver on Lenovo P73

Status in xorg package in Ubuntu:
  Incomplete

Bug description:
  The installation scripts loads the correct drivers so the touch pad
  and pointer works during the install. However after the install
  neither work.

  I've worked around it by using a wireless USB from Vilros for mouse input 
while logging in. Then issuing (found on 
https://askubuntu.com/questions/1143663):
   sudo 'echo -n "elantech">/sys/bus/serio/devices/serio1/protocol'

  So it's a bug for me but one I can work around and should be fixed before 
20.04 goes live.
  --- 
  ProblemType: Bug
  .proc.driver.nvidia.gpus..01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:01:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
   GCC version:  gcc version 9.3.0 (Ubuntu 9.3.0-5ubuntu1)
  ApportVersion: 2.20.11-0ubuntu21
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus:
   nvidia, 440.64, 5.4.0-14-generic, x86_64: installed
   nvidia, 440.64, 5.4.0-18-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   NVIDIA Corporation TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [10de:1eb5] 
(rev a1) (prog-if 00 [VGA controller])
 Subsystem: Lenovo TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [17aa:229b]
  InstallationDate: Installed on 2020-03-21 (3 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200315)
  MachineType: LENOVO 20QRCTO1WW
  NonfreeKernelModules: nvidia_modeset nvidia
  Package: xorg 1:7.7+19ubuntu14
  PackageArchitecture: amd64
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-18-generic 
root=UUID=d38adcbd-2ba3-4d84-84b7-388b5f55daa7 ro psmouse.elantech_smbus=0 
quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
  Tags:  focal ubuntu reproducible has-workaround
  Uname: Linux 5.4.0-18-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 01/08/2020
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N2NET35W (1.20 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20QRCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0Q40104 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN2NET35W(1.20):bd01/08/2020:svnLENOVO:pn20QRCTO1WW:pvrThinkPadP73:rvnLENOVO:rn20QRCTO1WW:rvrSDK0Q40104WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad P73
  dmi.product.name: 20QRCTO1WW
  dmi.product.sku: LENOVO_MT_20QR_BU_Think_FM_ThinkPad P73
  dmi.product.version: ThinkPad P73
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.100-4
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.0-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.0-1ubuntu1
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.7-2ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1868474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868474] Dependencies.txt

2020-03-25 Thread D
apport information

** Attachment added: "Dependencies.txt"
   
https://bugs.launchpad.net/bugs/1868474/+attachment/5341468/+files/Dependencies.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1868474

Title:
  20.04 Xorg doesn't detect/load Elantech mouse driver on Lenovo P73

Status in xorg package in Ubuntu:
  Incomplete

Bug description:
  The installation scripts loads the correct drivers so the touch pad
  and pointer works during the install. However after the install
  neither work.

  I've worked around it by using a wireless USB from Vilros for mouse input 
while logging in. Then issuing (found on 
https://askubuntu.com/questions/1143663):
   sudo 'echo -n "elantech">/sys/bus/serio/devices/serio1/protocol'

  So it's a bug for me but one I can work around and should be fixed before 
20.04 goes live.
  --- 
  ProblemType: Bug
  .proc.driver.nvidia.gpus..01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:01:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
   GCC version:  gcc version 9.3.0 (Ubuntu 9.3.0-5ubuntu1)
  ApportVersion: 2.20.11-0ubuntu21
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus:
   nvidia, 440.64, 5.4.0-14-generic, x86_64: installed
   nvidia, 440.64, 5.4.0-18-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   NVIDIA Corporation TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [10de:1eb5] 
(rev a1) (prog-if 00 [VGA controller])
 Subsystem: Lenovo TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [17aa:229b]
  InstallationDate: Installed on 2020-03-21 (3 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200315)
  MachineType: LENOVO 20QRCTO1WW
  NonfreeKernelModules: nvidia_modeset nvidia
  Package: xorg 1:7.7+19ubuntu14
  PackageArchitecture: amd64
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-18-generic 
root=UUID=d38adcbd-2ba3-4d84-84b7-388b5f55daa7 ro psmouse.elantech_smbus=0 
quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
  Tags:  focal ubuntu reproducible has-workaround
  Uname: Linux 5.4.0-18-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 01/08/2020
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N2NET35W (1.20 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20QRCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0Q40104 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN2NET35W(1.20):bd01/08/2020:svnLENOVO:pn20QRCTO1WW:pvrThinkPadP73:rvnLENOVO:rn20QRCTO1WW:rvrSDK0Q40104WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad P73
  dmi.product.name: 20QRCTO1WW
  dmi.product.sku: LENOVO_MT_20QR_BU_Think_FM_ThinkPad P73
  dmi.product.version: ThinkPad P73
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.100-4
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.0-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.0-1ubuntu1
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.7-2ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1868474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868474] Re: 20.04 Xorg doesn't detect/load Elantech mouse driver on Lenovo P73

2020-03-25 Thread D
apport information

** Tags added: apport-collected has-workaround reproducible ubuntu

** Description changed:

  The installation scripts loads the correct drivers so the touch pad and
  pointer works during the install. However after the install neither
  work.
  
  I've worked around it by using a wireless USB from Vilros for mouse input 
while logging in. Then issuing (found on 
https://askubuntu.com/questions/1143663):
   sudo 'echo -n "elantech">/sys/bus/serio/devices/serio1/protocol'
  
- So it's a bug for me but one I can work around and should be fixed
- before 20.04 goes live.
+ So it's a bug for me but one I can work around and should be fixed before 
20.04 goes live.
+ --- 
+ ProblemType: Bug
+ .proc.driver.nvidia.gpus..01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:01:00.0'
+ .proc.driver.nvidia.registry: Binary: ""
+ .proc.driver.nvidia.suspend: suspend hibernate resume
+ .proc.driver.nvidia.suspend_depth: default modeset uvm
+ .proc.driver.nvidia.version:
+  NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
+  GCC version:  gcc version 9.3.0 (Ubuntu 9.3.0-5ubuntu1)
+ ApportVersion: 2.20.11-0ubuntu21
+ Architecture: amd64
+ BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
+ CompositorRunning: None
+ CurrentDesktop: ubuntu:GNOME
+ DistUpgraded: Fresh install
+ DistroCodename: focal
+ DistroRelease: Ubuntu 20.04
+ DistroVariant: ubuntu
+ DkmsStatus:
+  nvidia, 440.64, 5.4.0-14-generic, x86_64: installed
+  nvidia, 440.64, 5.4.0-18-generic, x86_64: installed
+ ExtraDebuggingInterest: Yes
+ GraphicsCard:
+  NVIDIA Corporation TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [10de:1eb5] 
(rev a1) (prog-if 00 [VGA controller])
+Subsystem: Lenovo TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [17aa:229b]
+ InstallationDate: Installed on 2020-03-21 (3 days ago)
+ InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200315)
+ MachineType: LENOVO 20QRCTO1WW
+ NonfreeKernelModules: nvidia_modeset nvidia
+ Package: xorg 1:7.7+19ubuntu14
+ PackageArchitecture: amd64
+ ProcEnviron:
+  TERM=xterm-256color
+  PATH=(custom, no user)
+  XDG_RUNTIME_DIR=
+  LANG=en_US.UTF-8
+  SHELL=/bin/bash
+ ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-18-generic 
root=UUID=d38adcbd-2ba3-4d84-84b7-388b5f55daa7 ro psmouse.elantech_smbus=0 
quiet splash vt.handoff=7
+ ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
+ Tags:  focal ubuntu reproducible has-workaround
+ Uname: Linux 5.4.0-18-generic x86_64
+ UpgradeStatus: No upgrade log present (probably fresh install)
+ UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
+ _MarkForUpload: True
+ dmi.bios.date: 01/08/2020
+ dmi.bios.vendor: LENOVO
+ dmi.bios.version: N2NET35W (1.20 )
+ dmi.board.asset.tag: Not Available
+ dmi.board.name: 20QRCTO1WW
+ dmi.board.vendor: LENOVO
+ dmi.board.version: SDK0Q40104 WIN
+ dmi.chassis.asset.tag: No Asset Information
+ dmi.chassis.type: 10
+ dmi.chassis.vendor: LENOVO
+ dmi.chassis.version: None
+ dmi.modalias: 
dmi:bvnLENOVO:bvrN2NET35W(1.20):bd01/08/2020:svnLENOVO:pn20QRCTO1WW:pvrThinkPadP73:rvnLENOVO:rn20QRCTO1WW:rvrSDK0Q40104WIN:cvnLENOVO:ct10:cvrNone:
+ dmi.product.family: ThinkPad P73
+ dmi.product.name: 20QRCTO1WW
+ dmi.product.sku: LENOVO_MT_20QR_BU_Think_FM_ThinkPad P73
+ dmi.product.version: ThinkPad P73
+ dmi.sys.vendor: LENOVO
+ version.compiz: compiz N/A
+ version.libdrm2: libdrm2 2.4.100-4
+ version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.0-1ubuntu1
+ version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.0-1ubuntu1
+ version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
+ version.xserver-xorg-core: xserver-xorg-core 2:1.20.7-2ubuntu2
+ version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
+ version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
+ version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
+ version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

** Attachment added: ".proc.driver.nvidia.params.txt"
   
https://bugs.launchpad.net/bugs/1868474/+attachment/5341466/+files/.proc.driver.nvidia.params.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1868474

Title:
  20.04 Xorg doesn't detect/load Elantech mouse driver on Lenovo P73

Status in xorg package in Ubuntu:
  Incomplete

Bug description:
  The installation scripts loads the correct drivers so the touch pad
  and pointer works during the install. However after the install
  neither work.

  I've worked around it by using a wireless USB from Vilros for mouse input 
while logging in. Then issuing (found on 
https://askubuntu.com/questions/1143663):
   sudo 'echo -n "elantech">/sys/bus/serio/devices/serio1/protocol'

  So it's a bug for me but one I can work around and should be fixed before 
20.04 goes live.
  --- 
  ProblemType: Bug
  

[Touch-packages] [Bug 1868474] CurrentDmesg.txt

2020-03-25 Thread D
apport information

** Attachment added: "CurrentDmesg.txt"
   
https://bugs.launchpad.net/bugs/1868474/+attachment/5341467/+files/CurrentDmesg.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1868474

Title:
  20.04 Xorg doesn't detect/load Elantech mouse driver on Lenovo P73

Status in xorg package in Ubuntu:
  Incomplete

Bug description:
  The installation scripts loads the correct drivers so the touch pad
  and pointer works during the install. However after the install
  neither work.

  I've worked around it by using a wireless USB from Vilros for mouse input 
while logging in. Then issuing (found on 
https://askubuntu.com/questions/1143663):
   sudo 'echo -n "elantech">/sys/bus/serio/devices/serio1/protocol'

  So it's a bug for me but one I can work around and should be fixed before 
20.04 goes live.
  --- 
  ProblemType: Bug
  .proc.driver.nvidia.gpus..01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:01:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
   GCC version:  gcc version 9.3.0 (Ubuntu 9.3.0-5ubuntu1)
  ApportVersion: 2.20.11-0ubuntu21
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroRelease: Ubuntu 20.04
  DistroVariant: ubuntu
  DkmsStatus:
   nvidia, 440.64, 5.4.0-14-generic, x86_64: installed
   nvidia, 440.64, 5.4.0-18-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   NVIDIA Corporation TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [10de:1eb5] 
(rev a1) (prog-if 00 [VGA controller])
 Subsystem: Lenovo TU104GLM [Quadro RTX 5000 Mobile / Max-Q] [17aa:229b]
  InstallationDate: Installed on 2020-03-21 (3 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200315)
  MachineType: LENOVO 20QRCTO1WW
  NonfreeKernelModules: nvidia_modeset nvidia
  Package: xorg 1:7.7+19ubuntu14
  PackageArchitecture: amd64
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-18-generic 
root=UUID=d38adcbd-2ba3-4d84-84b7-388b5f55daa7 ro psmouse.elantech_smbus=0 
quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
  Tags:  focal ubuntu reproducible has-workaround
  Uname: Linux 5.4.0-18-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 01/08/2020
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N2NET35W (1.20 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20QRCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0Q40104 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN2NET35W(1.20):bd01/08/2020:svnLENOVO:pn20QRCTO1WW:pvrThinkPadP73:rvnLENOVO:rn20QRCTO1WW:rvrSDK0Q40104WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad P73
  dmi.product.name: 20QRCTO1WW
  dmi.product.sku: LENOVO_MT_20QR_BU_Think_FM_ThinkPad P73
  dmi.product.version: ThinkPad P73
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.100-4
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.0-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.0-1ubuntu1
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.7-2ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1868474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868474] Re: 20.04 Xorg doesn't detect/load Elantech mouse driver on Lenovo P73

2020-03-24 Thread D
Paraide,

Thanks. If I can help let me know, I'm following this bug.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1868474

Title:
  20.04 Xorg doesn't detect/load Elantech mouse driver on Lenovo P73

Status in xorg package in Ubuntu:
  New

Bug description:
  The installation scripts loads the correct drivers so the touch pad
  and pointer works during the install. However after the install
  neither work.

  I've worked around it by using a wireless USB from Vilros for mouse input 
while logging in. Then issuing (found on 
https://askubuntu.com/questions/1143663):
   sudo 'echo -n "elantech">/sys/bus/serio/devices/serio1/protocol'

  So it's a bug for me but one I can work around and should be fixed
  before 20.04 goes live.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1868474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1840592] Re: systemd-backlight does not save and restore brightness for nvidia display

2020-03-23 Thread D
And it's an issue with 20.04 daily builds.
Hardware is Lenovo P73 with NVIDIA RTX-5000 Q-Max.

So how can the driver be made to register the backlight device?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1840592

Title:
  systemd-backlight does not save and restore brightness for nvidia
  display

Status in nvidia-graphics-drivers package in Ubuntu:
  Confirmed
Status in nvidia-graphics-drivers-418 package in Ubuntu:
  Confirmed
Status in nvidia-settings package in Ubuntu:
  Confirmed
Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  Running nvidia gtx 1080 graphics card, with proprietary nvidia drivers
  on ubuntu 19.04. I can change screen brightness from 0% to 100% in 5%
  steps. However, after a reboot or after a shutdown, brightness level
  reverts to 100%. Please fix to is "remembers" the current brightness
  value at shutdown time, like in does Windows.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/1840592/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868474] [NEW] 20.04 Xorg doesn't detect/load Elantech mouse driver on Lenovo P73

2020-03-22 Thread D
Public bug reported:

The installation scripts loads the correct drivers so the touch pad and
pointer works during the install. However after the install neither
work.

I've worked around it by using a wireless USB from Vilros for mouse input while 
logging in. Then issuing (found on https://askubuntu.com/questions/1143663):
 sudo 'echo -n "elantech">/sys/bus/serio/devices/serio1/protocol'

So it's a bug for me but one I can work around and should be fixed
before 20.04 goes live.

** Affects: init-system-helpers (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to init-system-helpers in
Ubuntu.
https://bugs.launchpad.net/bugs/1868474

Title:
  20.04 Xorg doesn't detect/load Elantech mouse driver on Lenovo P73

Status in init-system-helpers package in Ubuntu:
  New

Bug description:
  The installation scripts loads the correct drivers so the touch pad
  and pointer works during the install. However after the install
  neither work.

  I've worked around it by using a wireless USB from Vilros for mouse input 
while logging in. Then issuing (found on 
https://askubuntu.com/questions/1143663):
   sudo 'echo -n "elantech">/sys/bus/serio/devices/serio1/protocol'

  So it's a bug for me but one I can work around and should be fixed
  before 20.04 goes live.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/init-system-helpers/+bug/1868474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1868473] [NEW] 20.04 Install screen corrupt on Lenovo P73+NVIDEA RTX-5000

2020-03-22 Thread D
Public bug reported:

Hardware: Lenovo P73 with NVIDEA RTX-5000 QMax

20.04 Daily Build install.

On using the USB drive for a new install the screen is corrupt. This can be 
worked around by:
1. Waiting for Focal Fossa to give the sound showing the splash screen.
2. Closing the screen so it goes into sleep mode.
3. Open the screen and hit the power button to wake the system.
4. Wait a second or two and screen loads correctly and the rest of the install 
works beautifully.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: init 1.57
ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
Uname: Linux 5.4.0-18-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.11-0ubuntu21
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Sun Mar 22 08:27:04 2020
InstallationDate: Installed on 2020-03-21 (1 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200315)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: init-system-helpers
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: init-system-helpers (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug focal

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to init-system-helpers in
Ubuntu.
https://bugs.launchpad.net/bugs/1868473

Title:
  20.04 Install screen corrupt on Lenovo P73+NVIDEA RTX-5000

Status in init-system-helpers package in Ubuntu:
  New

Bug description:
  Hardware: Lenovo P73 with NVIDEA RTX-5000 QMax

  20.04 Daily Build install.

  On using the USB drive for a new install the screen is corrupt. This can be 
worked around by:
  1. Waiting for Focal Fossa to give the sound showing the splash screen.
  2. Closing the screen so it goes into sleep mode.
  3. Open the screen and hit the power button to wake the system.
  4. Wait a second or two and screen loads correctly and the rest of the 
install works beautifully.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: init 1.57
  ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
  Uname: Linux 5.4.0-18-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  ApportVersion: 2.20.11-0ubuntu21
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Sun Mar 22 08:27:04 2020
  InstallationDate: Installed on 2020-03-21 (1 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200315)
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: init-system-helpers
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/init-system-helpers/+bug/1868473/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1866365] [NEW] Missing /usr/lib/x86_64-linux-gnu/libfreetype.la file

2020-03-06 Thread Martin D. Weinberg
Public bug reported:

This file disappeared from 19.10 dev package.  Without the *.la file,
libtool fails to configure libraries with GTK dependencies.

My work around was to grab the file from 18.04 and change the metadata
for the current library versions.  That allowed me to successfully
compile my package with GTK dependencies.

Perhaps there is some libtool/autoconf magic that I do not understand
here?  Please do tell me how to address this this issue if I am
misunderstanding the need for the *.la file.  Thanks.

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: libfreetype6-dev 2.9.1-4
ProcVersionSignature: Ubuntu 5.3.0-40.32-generic 5.3.18
Uname: Linux 5.3.0-40-generic x86_64
ApportVersion: 2.20.11-0ubuntu8.5
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Fri Mar  6 10:18:10 2020
EcryptfsInUse: Yes
InstallationDate: Installed on 2018-03-12 (725 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180114)
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: freetype
UpgradeStatus: Upgraded to eoan on 2019-12-31 (65 days ago)

** Affects: freetype (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug eoan

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to freetype in Ubuntu.
https://bugs.launchpad.net/bugs/1866365

Title:
  Missing /usr/lib/x86_64-linux-gnu/libfreetype.la file

Status in freetype package in Ubuntu:
  New

Bug description:
  This file disappeared from 19.10 dev package.  Without the *.la file,
  libtool fails to configure libraries with GTK dependencies.

  My work around was to grab the file from 18.04 and change the metadata
  for the current library versions.  That allowed me to successfully
  compile my package with GTK dependencies.

  Perhaps there is some libtool/autoconf magic that I do not understand
  here?  Please do tell me how to address this this issue if I am
  misunderstanding the need for the *.la file.  Thanks.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: libfreetype6-dev 2.9.1-4
  ProcVersionSignature: Ubuntu 5.3.0-40.32-generic 5.3.18
  Uname: Linux 5.3.0-40-generic x86_64
  ApportVersion: 2.20.11-0ubuntu8.5
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Fri Mar  6 10:18:10 2020
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2018-03-12 (725 days ago)
  InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180114)
  ProcEnviron:
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: freetype
  UpgradeStatus: Upgraded to eoan on 2019-12-31 (65 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/freetype/+bug/1866365/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1843479]

2020-02-23 Thread D-i-j
Can be closed now.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to binutils in Ubuntu.
https://bugs.launchpad.net/bugs/1843479

Title:
  gzip in Ubuntu Eoan results in Exec format error on WSL1

Status in binutils:
  Fix Released
Status in binutils package in Ubuntu:
  Fix Released
Status in gzip package in Ubuntu:
  Fix Released
Status in binutils source package in Eoan:
  Fix Released
Status in gzip source package in Eoan:
  Fix Released

Bug description:
  [Impact]

   * Running gzip on WSL1 results in the following error:
     $ gzip
     -bash: /bin/gzip: cannot execute binary file: Exec format error
   * The error occurs frequently in package updates and makes gzip inoperable 
on WSL1
   * The problem is caused by PT_LOAD offset pointing past the end of file and 
the fix is fixing strip to not generate such ELF files and recompiling gzip 
with the fixed strip.

  [Test Case]

   * Check the gzip binary for wrong offset:
    $ FILE=/usr/bin/gzip; readelf -W --program-headers $FILE | awk -v 
size=$(stat -c %s $FILE) '/^  LOAD/ {if (strtonum($2) > size) {print "wrong 
offset ("$2" ("strtonum($2)") points past EOF:" size; exit 1;}}'

  [ Regression Potential ]

   * The binutils fix could cause binutils to generate invalid ELF files. The 
fix is very small and isolated and has been tested and accepted by upstream, 
which makes such problems unlikely.
   * Bugs in the toolchain in general can make the rebuilt gzip show new 
errors, but this generally applies to many SRUs and security updates. The 
testing period in proposed should mitigate this risk.

  [Other Info]

   * Binutils 2.33.1-6ubuntu1.1 was accidentally built in -proposed
  instead of in a PPA. I've rebuilt it in https://launchpad.net/~ci-
  train-ppa-service/+archive/ubuntu/3878 for the -security pocket as
  2.33-2ubuntu1.2.

  [Originial Bug Text]

  Summary:

  Running gzip on WSL1 results in the following error:

  $ gzip
  -bash: /bin/gzip: cannot execute binary file: Exec format error

  What I expect to happen:

  gzip executes correctly on WSL1.

  What happens instead:

  gzip fails with an Exec format error.

  Notes:

  I suspect a change in how gzip is being built for Eoan is causing
  issues with ELF parsing on the WSL1 translation layer. For example:

  On Disco with gzip 1.9-3:

  $ file /bin/gzip
  /bin/gzip: ELF 64-bit LSB pie executable, x86-64, version 1 (SYSV), 
dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 
3.2.0, BuildID[sha1]=efa859c26eaf8e035efe9a139361e2a60cd17b3e, stripped

  On Eoan with gzip 1.10-0ubuntu3:

  $ file /bin/gzip
  /bin/gzip: ELF 64-bit LSB pie executable, x86-64, version 1 (SYSV), 
dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, 
BuildID[sha1]=bc0f5994544c2a469d04c914bf4bf44b4ded6040, for GNU/Linux 3.2.0, 
stripped

  Eoan ships with gzip 1.10, while Disco ships with gzip 1.9, but I do
  not believe this is an issue in 1.10 because this error does not occur
  when building gzip from GNU project source on Ubuntu Eoan.

  Justifications:

  WSL1 will need to be patched in future Windows builds for this change
  in ELF. However that patch will likely not be backported to older
  builds of Windows, including Windows Enterprise/Server 2019.

  To ensure Eoan can run on current and older builds of Windows Ubuntu
  should consider looking at how it's building gzip and see if it can be
  made to 'play nice' until WSL1 can be updated.

  This was originally reported here:
  https://github.com/microsoft/WSL/issues/4461

  Details:

  Description:Ubuntu Eoan Ermine (development branch)
  Release:19.10

  gzip:
    Installed: 1.10-0ubuntu3
    Candidate: 1.10-0ubuntu3
    Version table:
   *** 1.10-0ubuntu3 500
  500 http://archive.ubuntu.com/ubuntu eoan/main amd64 Packages
  100 /var/lib/dpkg/status

To manage notifications about this bug go to:
https://bugs.launchpad.net/binutils/+bug/1843479/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1857176] [NEW] [PLT V8200 Series, playback] Playback problem

2019-12-20 Thread josh d
Public bug reported:

Hi, what happened was - I changed my input device to this device and
when I did I noticed the output (to same device) became degraded. I was
able to fix by setting it from high fidelity, back to headset, and back
to high fidelity again. So, it seems setting the input device did some
sort of 'configuration reset' that was not shown in the UI.

Thanks! Wonderful OS :)

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: alsa-base 1.0.25+dfsg-0ubuntu5
ProcVersionSignature: Ubuntu 5.3.0-24.26-generic 5.3.10
Uname: Linux 5.3.0-24-generic x86_64
ApportVersion: 2.20.11-0ubuntu8.2
Architecture: amd64
AudioDevicesInUse:
 USERPID ACCESS COMMAND
 /dev/snd/controlC1:  jdix   1978 F pulseaudio
 /dev/snd/controlC0:  jdix   1978 F pulseaudio
CurrentDesktop: ubuntu:GNOME
Date: Fri Dec 20 16:52:06 2019
InstallationDate: Installed on 2018-10-08 (438 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Symptom_Card: PLT V8200 Series
Symptom_Type: None of the above
Title: [PLT V8200 Series, playback] Playback problem
UpgradeStatus: Upgraded to eoan on 2019-10-31 (50 days ago)
dmi.bios.date: 06/04/2019
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: L3.24
dmi.board.name: X470 Master SLI/ac
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrL3.24:bd06/04/2019:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnX470MasterSLI/ac:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.family: To Be Filled By O.E.M.
dmi.product.name: To Be Filled By O.E.M.
dmi.product.sku: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.

** Affects: alsa-driver (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug eoan

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1857176

Title:
  [PLT V8200 Series, playback] Playback problem

Status in alsa-driver package in Ubuntu:
  New

Bug description:
  Hi, what happened was - I changed my input device to this device and
  when I did I noticed the output (to same device) became degraded. I
  was able to fix by setting it from high fidelity, back to headset, and
  back to high fidelity again. So, it seems setting the input device did
  some sort of 'configuration reset' that was not shown in the UI.

  Thanks! Wonderful OS :)

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: alsa-base 1.0.25+dfsg-0ubuntu5
  ProcVersionSignature: Ubuntu 5.3.0-24.26-generic 5.3.10
  Uname: Linux 5.3.0-24-generic x86_64
  ApportVersion: 2.20.11-0ubuntu8.2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  jdix   1978 F pulseaudio
   /dev/snd/controlC0:  jdix   1978 F pulseaudio
  CurrentDesktop: ubuntu:GNOME
  Date: Fri Dec 20 16:52:06 2019
  InstallationDate: Installed on 2018-10-08 (438 days ago)
  InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
  PackageArchitecture: all
  ProcEnviron:
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: alsa-driver
  Symptom: audio
  Symptom_Card: PLT V8200 Series
  Symptom_Type: None of the above
  Title: [PLT V8200 Series, playback] Playback problem
  UpgradeStatus: Upgraded to eoan on 2019-10-31 (50 days ago)
  dmi.bios.date: 06/04/2019
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: L3.24
  dmi.board.name: X470 Master SLI/ac
  dmi.board.vendor: ASRock
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: To Be Filled By O.E.M.
  dmi.chassis.version: To Be Filled By O.E.M.
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrL3.24:bd06/04/2019:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnX470MasterSLI/ac:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
  dmi.product.family: To Be Filled By O.E.M.
  dmi.product.name: To Be Filled By O.E.M.
  dmi.product.sku: To Be Filled By O.E.M.
  dmi.product.version: To Be Filled By O.E.M.
  dmi.sys.vendor: To Be Filled By O.E.M.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1857176/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1848900] [NEW] blank display with Eoan Ermine live DVD on Rysen 2200G

2019-10-19 Thread Peter D.
Public bug reported:

Regression with Ryzen 3 2200G, UEFI Asrock B450 Pro4 motherboard and
55-75 Hz monitor.

Booting Xubuntu 19.10 live iso with safe graphics options did give a
stable desktop display, but

xubuntu@xubuntu:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1920 x 1080, current 1920 x 1080, maximum 1920 x 1080
default connected 1920x1080+0+0 0mm x 0mm
   1920x1080 77.00* 
xubuntu@xubuntu:~$ 

The monitor is only supposed to have a maximum vertical refresh rate of
75 Hz. Xrandr reports 77 Hz as the only choice.  The monitor reports 60
Hz, not that I trust the monitor.

Swapping monitors and running many reboots the situation seems to be...

Old versions of Ubuntu (Bionic and Dingo) can handle the hardware.
Standard boot sometimes gives a blank screen.  
Standard boot sometimes gives a badly pixelated display 
(Ctl-Alt-F6, Ctl-Alt-F7 temporarily improves it).  
Connecting a 144 Hz monitor convinces something (the firmware?) 
that fast refreshes are OK on a slow monitor, or at least it fails to 
reread and abide by the slow monitor's limitations when swapping back.
Something, I don't know what, convinces the computer to run the display 
at 60 Hz, sometimes. 

The motherboard has three video ports; DP, HDMI and VGA (using an onboard 
DP? to VGA converter chip).  The fast monitor has DP, HDMI and VGA ports, 
but I only experimented with the DP connection.  The slow monitor has VGA and 
DVI-D ports.  I experimented with VGA to VGA and HDMI via a passive adapter 
to DVI.  When running in the badly pixelated mode xorg seems to think that 
the VGA port is "DP-1".

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: xorg 1:7.7+19ubuntu12
ProcVersionSignature: Ubuntu 5.3.0-18.19-generic 5.3.1
Uname: Linux 5.3.0-18-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu8
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CasperVersion: 1.427
CompositorRunning: None
CurrentDesktop: XFCE
Date: Sun Oct 20 00:17:34 2019
DistUpgraded: Fresh install
DistroCodename: eoan
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 Advanced Micro Devices, Inc. [AMD/ATI] Raven Ridge [Radeon Vega Series / 
Radeon Vega Mobile Series] [1002:15dd] (rev c8) (prog-if 00 [VGA controller])
   Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Raven Ridge [Radeon Vega 
Series / Radeon Vega Mobile Series] [1002:15dd]
LiveMediaBuild: Xubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/username.seed 
quiet splash nomodeset ---
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/02/2019
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P3.40
dmi.board.name: B450 Pro4
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrP3.40:bd07/02/2019:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnB450Pro4:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.family: To Be Filled By O.E.M.
dmi.product.name: To Be Filled By O.E.M.
dmi.product.sku: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.99-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 19.2.1-1ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.5+git20191008-0ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.0.1-1ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1
xserver.bootTime: Sat Oct 19 23:52:52 2019
xserver.configfile: default
xserver.errors:
 open /dev/dri/card0: No such file or directory
 open /dev/dri/card0: No such file or directory
 Screen 0 deleted because of no matching config section.
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 
xserver.version: 2:1.20.5+git20191008-0ubuntu1

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug eoan ubuntu

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1848900

Title:
  blank display with Eoan Ermine live DVD on Rysen 2200G

Status in xorg package in Ubuntu:
  New

Bug description:
  Regression with Ryzen 3 2200G, UEFI Asrock B450 Pro4 motherboard and
  55-75 Hz monitor.

  Booting Xubuntu 19.10 live iso with safe graphics options did give a
  st

[Touch-packages] [Bug 1838802] [NEW] ca-certificates missing trusted entry from linuxfoundation

2019-08-02 Thread Christopher D Schalk
Public bug reported:

source.codeaurora.org (linuxfoundation) changed their certificate on 30
JUL 2019. When cloning from codeaurora, you now get this error:

$ git clone https://source.codeaurora.org/external/imx/libdrm-imx.git/
Cloning into 'libdrm-imx'...
fatal: unable to access 
'https://source.codeaurora.org/external/imx/libdrm-imx.git/': server 
certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt 
CRLfile: none

I think this suggests that the issuing CA Authority is not trusted and
included in ca-certificates.crt. I've confirmed this certificate
validation issue on both ubuntu 16.04 and ubutnu 18.04. I've even
upgraded and reinstalled the ca-certificates package and still get the
same validation error.

I assumed it might be a problem with my clock out of sync, so I
synchronized my server time with chrony and the issue persists. I can
add the certificate manually to my installation of git and get around
the issue, but I suspect that this issue will impact anyone attempting
to clone from the linux foundation git servers.

I've attached the source.codeaurora.org certificate to this bug report.
The certificate shows that the issueing authority is "Sectigo RSA Domain
Validation Secure Server CA"

** Affects: ca-certificates (Ubuntu)
 Importance: Undecided
 Status: New

** Attachment added: "source.codeaurora.org.pem"
   
https://bugs.launchpad.net/bugs/1838802/+attachment/5280552/+files/source.codeaurora.org.pem

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ca-certificates in Ubuntu.
https://bugs.launchpad.net/bugs/1838802

Title:
  ca-certificates missing trusted entry from linuxfoundation

Status in ca-certificates package in Ubuntu:
  New

Bug description:
  source.codeaurora.org (linuxfoundation) changed their certificate on
  30 JUL 2019. When cloning from codeaurora, you now get this error:

  $ git clone https://source.codeaurora.org/external/imx/libdrm-imx.git/
  Cloning into 'libdrm-imx'...
  fatal: unable to access 
'https://source.codeaurora.org/external/imx/libdrm-imx.git/': server 
certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt 
CRLfile: none

  I think this suggests that the issuing CA Authority is not trusted and
  included in ca-certificates.crt. I've confirmed this certificate
  validation issue on both ubuntu 16.04 and ubutnu 18.04. I've even
  upgraded and reinstalled the ca-certificates package and still get the
  same validation error.

  I assumed it might be a problem with my clock out of sync, so I
  synchronized my server time with chrony and the issue persists. I can
  add the certificate manually to my installation of git and get around
  the issue, but I suspect that this issue will impact anyone attempting
  to clone from the linux foundation git servers.

  I've attached the source.codeaurora.org certificate to this bug
  report. The certificate shows that the issueing authority is "Sectigo
  RSA Domain Validation Secure Server CA"

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ca-certificates/+bug/1838802/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1831849] [NEW] [1066AJU, Realtek ALC272, Speaker, Internal] Underruns, dropouts or crackling sound

2019-06-06 Thread D
Public bug reported:

Tried modifying /etc/pulse/default.pa with load-module module-udev-
detect tsched=0, but it didn't help. Was working fine in 18.04.

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: alsa-base 1.0.25+dfsg-0ubuntu5
ProcVersionSignature: Ubuntu 5.0.0-16.17-generic 5.0.8
Uname: Linux 5.0.0-16-generic x86_64
ApportVersion: 2.20.10-0ubuntu27
Architecture: amd64
AudioDevicesInUse:
 USERPID ACCESS COMMAND
 /dev/snd/controlC0:  ubuntu10126 F pulseaudio
 /dev/snd/pcmC0D0c:   ubuntu10126 F...m pulseaudio
 /dev/snd/pcmC0D0p:   ubuntu10126 F...m pulseaudio
CurrentDesktop: ubuntu:GNOME
Date: Thu Jun  6 01:01:05 2019
InstallationDate: Installed on 2018-04-21 (410 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20180105.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:PCH successful
Symptom_Card: Built-in Audio - HDA Intel PCH
Symptom_Jack: Speaker, Internal
Symptom_PulsePlaybackTest: PulseAudio playback test successful
Symptom_Type: Underruns, dropouts, or "crackling" sound
Title: [1066AJU, Realtek ALC272, Speaker, Internal] Underruns, dropouts or 
crackling sound
UpgradeStatus: Upgraded to disco on 2019-04-30 (36 days ago)
dmi.bios.date: 10/27/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 44CN43WW
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Emerald Lake
dmi.board.vendor: LENOVO
dmi.board.version: FAB1
dmi.chassis.asset.tag: Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: 0.1
dmi.modalias: 
dmi:bvnLENOVO:bvr44CN43WW:bd10/27/2011:svnLENOVO:pn1066AJU:pvrLenovoV570:rvnLENOVO:rnEmeraldLake:rvrFAB1:cvnLENOVO:ct10:cvr0.1:
dmi.product.family: HuronRiver System
dmi.product.name: 1066AJU
dmi.product.sku: System SKUNumber
dmi.product.version: Lenovo V570
dmi.sys.vendor: LENOVO

** Affects: alsa-driver (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug disco

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1831849

Title:
  [1066AJU, Realtek ALC272, Speaker, Internal] Underruns, dropouts or
  crackling sound

Status in alsa-driver package in Ubuntu:
  New

Bug description:
  Tried modifying /etc/pulse/default.pa with load-module module-udev-
  detect tsched=0, but it didn't help. Was working fine in 18.04.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.04
  Package: alsa-base 1.0.25+dfsg-0ubuntu5
  ProcVersionSignature: Ubuntu 5.0.0-16.17-generic 5.0.8
  Uname: Linux 5.0.0-16-generic x86_64
  ApportVersion: 2.20.10-0ubuntu27
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  ubuntu10126 F pulseaudio
   /dev/snd/pcmC0D0c:   ubuntu10126 F...m pulseaudio
   /dev/snd/pcmC0D0p:   ubuntu10126 F...m pulseaudio
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Jun  6 01:01:05 2019
  InstallationDate: Installed on 2018-04-21 (410 days ago)
  InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20180105.1)
  PackageArchitecture: all
  ProcEnviron:
   LANGUAGE=en_CA:en
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_CA.UTF-8
   SHELL=/bin/bash
  SourcePackage: alsa-driver
  Symptom: audio
  Symptom_AlsaPlaybackTest: ALSA playback test through plughw:PCH successful
  Symptom_Card: Built-in Audio - HDA Intel PCH
  Symptom_Jack: Speaker, Internal
  Symptom_PulsePlaybackTest: PulseAudio playback test successful
  Symptom_Type: Underruns, dropouts, or "crackling" sound
  Title: [1066AJU, Realtek ALC272, Speaker, Internal] Underruns, dropouts or 
crackling sound
  UpgradeStatus: Upgraded to disco on 2019-04-30 (36 days ago)
  dmi.bios.date: 10/27/2011
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 44CN43WW
  dmi.board.asset.tag: Base Board Asset Tag
  dmi.board.name: Emerald Lake
  dmi.board.vendor: LENOVO
  dmi.board.version: FAB1
  dmi.chassis.asset.tag: Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: 0.1
  dmi.modalias: 
dmi:bvnLENOVO:bvr44CN43WW:bd10/27/2011:svnLENOVO:pn1066AJU:pvrLenovoV570:rvnLENOVO:rnEmeraldLake:rvrFAB1:cvnLENOVO:ct10:cvr0.1:
  dmi.product.family: HuronRiver System
  dmi.product.name: 1066AJU
  dmi.product.sku: System SKUNumber
  dmi.product.version: Lenovo V570
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1831849/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1577575] Re: NFS share does not mount on boot using fstab

2019-05-03 Thread Jason D. Kelleher
Sorry - those last two comments were meant for bug #1827286.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1577575

Title:
  NFS share does not mount on boot using fstab

Status in nfs-utils package in Ubuntu:
  New
Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  What I expected to happen?

  I want an NFS share to be mounted on startup using

  
  192.168.178.66:/media/captainplanet/7EF8B26FF8B22575/ 
/media/captainplanet/banane/ nfs rw 0 0

  What happened instead?

  It does not mount on startup. Systemd waits 91sec instead and finally
  starts after failing.

  I can successfully mount the NFS share with

  sudo mount 192.168.178.66:/media/captainplanet/7EF8B26FF8B22575
  /media/captainplanet/banane/

  When I try to shutdown Xubuntu it hangs forever. Unmounting the NFS
  share manually before shutdown fixes the second problem.

  
  Do you need more information?

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: systemd 229-4ubuntu4
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: XFCE
  Date: Mon May  2 23:10:50 2016
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2016-04-22 (10 days ago)
  InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Release amd64 
(20160420.1)
  MachineType: LENOVO 20DM003XUK
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=eece9973-0430-4a60-9291-9a994782bf86 ro quiet splash
  SourcePackage: systemd
  SystemdDelta:
   [EXTENDED]   /lib/systemd/system/systemd-timesyncd.service → 
/lib/systemd/system/systemd-timesyncd.service.d/disable-with-time-daemon.conf
   [EXTENDED]   /lib/systemd/system/rc-local.service → 
/lib/systemd/system/rc-local.service.d/debian.conf
   
   2 overridden configuration files found.
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/26/2015
  dmi.bios.vendor: LENOVO
  dmi.bios.version: JFET44WW(1.21)
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20DM003XUK
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0E50512 STD
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrJFET44WW(1.21):bd08/26/2015:svnLENOVO:pn20DM003XUK:pvrThinkPadS3Yoga14:rvnLENOVO:rn20DM003XUK:rvrSDK0E50512STD:cvnLENOVO:ct10:cvrNone:
  dmi.product.name: 20DM003XUK
  dmi.product.version: ThinkPad S3 Yoga 14
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nfs-utils/+bug/1577575/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1577575] Re: NFS share does not mount on boot using fstab

2019-05-03 Thread Jason D. Kelleher
I did a little more testing and this looks to be specific to /home.
Even mounting over /home (no linking) with autofs results in the same
issue.

All autofs files as well as the list of packages installed have been
attached.


As a side note, having /home as a link is an artifact of some very old build 
scripts and worked fine with an /etc/fstab NFS mount.  autofs was deployed as a 
workaround for bug #1577575.

The new workaround for both these bugs is to update all /etc/passwd
entries to /vol/home/.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1577575

Title:
  NFS share does not mount on boot using fstab

Status in nfs-utils package in Ubuntu:
  New
Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  What I expected to happen?

  I want an NFS share to be mounted on startup using

  
  192.168.178.66:/media/captainplanet/7EF8B26FF8B22575/ 
/media/captainplanet/banane/ nfs rw 0 0

  What happened instead?

  It does not mount on startup. Systemd waits 91sec instead and finally
  starts after failing.

  I can successfully mount the NFS share with

  sudo mount 192.168.178.66:/media/captainplanet/7EF8B26FF8B22575
  /media/captainplanet/banane/

  When I try to shutdown Xubuntu it hangs forever. Unmounting the NFS
  share manually before shutdown fixes the second problem.

  
  Do you need more information?

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: systemd 229-4ubuntu4
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: XFCE
  Date: Mon May  2 23:10:50 2016
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2016-04-22 (10 days ago)
  InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Release amd64 
(20160420.1)
  MachineType: LENOVO 20DM003XUK
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=eece9973-0430-4a60-9291-9a994782bf86 ro quiet splash
  SourcePackage: systemd
  SystemdDelta:
   [EXTENDED]   /lib/systemd/system/systemd-timesyncd.service → 
/lib/systemd/system/systemd-timesyncd.service.d/disable-with-time-daemon.conf
   [EXTENDED]   /lib/systemd/system/rc-local.service → 
/lib/systemd/system/rc-local.service.d/debian.conf
   
   2 overridden configuration files found.
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/26/2015
  dmi.bios.vendor: LENOVO
  dmi.bios.version: JFET44WW(1.21)
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20DM003XUK
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0E50512 STD
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrJFET44WW(1.21):bd08/26/2015:svnLENOVO:pn20DM003XUK:pvrThinkPadS3Yoga14:rvnLENOVO:rn20DM003XUK:rvrSDK0E50512STD:cvnLENOVO:ct10:cvrNone:
  dmi.product.name: 20DM003XUK
  dmi.product.version: ThinkPad S3 Yoga 14
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nfs-utils/+bug/1577575/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1577575] Re: NFS share does not mount on boot using fstab

2019-05-03 Thread Jason D. Kelleher
** Attachment added: "chi.packages"
   
https://bugs.launchpad.net/ubuntu/+source/nfs-utils/+bug/1577575/+attachment/5261278/+files/chi.packages

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1577575

Title:
  NFS share does not mount on boot using fstab

Status in nfs-utils package in Ubuntu:
  New
Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  What I expected to happen?

  I want an NFS share to be mounted on startup using

  
  192.168.178.66:/media/captainplanet/7EF8B26FF8B22575/ 
/media/captainplanet/banane/ nfs rw 0 0

  What happened instead?

  It does not mount on startup. Systemd waits 91sec instead and finally
  starts after failing.

  I can successfully mount the NFS share with

  sudo mount 192.168.178.66:/media/captainplanet/7EF8B26FF8B22575
  /media/captainplanet/banane/

  When I try to shutdown Xubuntu it hangs forever. Unmounting the NFS
  share manually before shutdown fixes the second problem.

  
  Do you need more information?

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: systemd 229-4ubuntu4
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: XFCE
  Date: Mon May  2 23:10:50 2016
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2016-04-22 (10 days ago)
  InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Release amd64 
(20160420.1)
  MachineType: LENOVO 20DM003XUK
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=eece9973-0430-4a60-9291-9a994782bf86 ro quiet splash
  SourcePackage: systemd
  SystemdDelta:
   [EXTENDED]   /lib/systemd/system/systemd-timesyncd.service → 
/lib/systemd/system/systemd-timesyncd.service.d/disable-with-time-daemon.conf
   [EXTENDED]   /lib/systemd/system/rc-local.service → 
/lib/systemd/system/rc-local.service.d/debian.conf
   
   2 overridden configuration files found.
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/26/2015
  dmi.bios.vendor: LENOVO
  dmi.bios.version: JFET44WW(1.21)
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20DM003XUK
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0E50512 STD
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrJFET44WW(1.21):bd08/26/2015:svnLENOVO:pn20DM003XUK:pvrThinkPadS3Yoga14:rvnLENOVO:rn20DM003XUK:rvrSDK0E50512STD:cvnLENOVO:ct10:cvrNone:
  dmi.product.name: 20DM003XUK
  dmi.product.version: ThinkPad S3 Yoga 14
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nfs-utils/+bug/1577575/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1827286] Re: autofs - "Too many levels of symbolic links" after apt upgrade

2019-05-02 Thread Jason D. Kelleher
Looks like the issue is symlinking to a director prior to autofs
mounting it.

Everything fine...

root@numbersix:/# ssh chi uname -a
Linux chi 4.4.0-146-generic #172-Ubuntu SMP Wed Apr 3 09:00:08 UTC 2019 x86_64 
x86_64 x86_64 GNU/Linux
root@chi:~# ls -la /home
ls: cannot access '/home': No such file or directory
root@chi:~#
root@numbersix:/# ssh chi 'ls -la /vol/*'
/vol/home:
total 8
drwxr-xr-x 1 root root  154 Apr 21 19:10 .
drwxr-xr-x 5 root root 4096 Jul  2  2018 ..
drwxr-xr-x 1 2005 2005 1070 Nov 17  2015 bethann
[trimmed]

/vol/media:
total 4
drwxr-xr-x 1 root root  128 Apr 13 18:29 .
drwxr-xr-x 5 root root 4096 Jul  2  2018 ..
[trimmed]

/vol/zhora-temp:
total 24
dr-xr-xr-x  6 root root 4096 Mar  3 08:21 .
drwxr-xr-x  5 root root 4096 Jul  2  2018 ..
[trimmed]
root@numbersix:/#


Everything works fine if the link is made after...

root@chi:/# ln -s /vol/home
root@chi:/# ls -la /home
lrwxrwxrwx 1 root root 9 May  2 12:11 /home -> /vol/home
root@chi:/#
root@chi:/# ls -la /vol/*
/vol/home:
total 8
drwxr-xr-x 1 root root  154 Apr 21 19:10 .
drwxr-xr-x 5 root root 4096 Jul  2  2018 ..
[trimmed]

/vol/media:
total 4
drwxr-xr-x 1 root root  128 Apr 13 18:29 .
drwxr-xr-x 5 root root 4096 Jul  2  2018 ..
[trimmed]

/vol/zhora-temp:
total 24
dr-xr-xr-x  6 root root 4096 Mar  3 08:21 .
drwxr-xr-x  5 root root 4096 Jul  2  2018 ..
[trimmed]
root@chi:/#

It breaks after the reboot...

root@chi:/# init 6
Connection to chi closed by remote host.
Connection to chi closed.
root@numbersix:~# root@chi:/# init 6
Connection to chi closed by remote host.
Connection to chi closed.
root@numbersix:~#

root@numbersix:~#
root@numbersix:~# ssh chi
Welcome to Ubuntu 16.04.6 LTS (GNU/Linux 4.4.0-146-generic x86_64)

 * Documentation:  https://help.ubuntu.com
 * Management: https://landscape.canonical.com
 * Support:https://ubuntu.com/advantage

21 packages can be updated.
15 updates are security updates.

New release '18.04.2 LTS' available.
Run 'do-release-upgrade' to upgrade to it.


root@chi:~# ls -la /vol/*
ls: cannot open directory '/vol/home': Too many levels of symbolic links
/vol/media:
total 4
drwxr-xr-x 1 root root  128 Apr 13 18:29 .
drwxr-xr-x 5 root root 4096 Jul  2  2018 ..
[trimmed]

/vol/zhora-temp:
total 24
dr-xr-xr-x  6 root root 4096 Mar  3 08:21 .
drwxr-xr-x  5 root root 4096 Jul  2  2018 ..
[trimmed]
root@chi:~#


At this point, the link needs to be deleted and the VM rebooted to get back to 
a normal state - just restarting autofs won't clear it.


** Package changed: systemd (Ubuntu) => autofs5 (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1827286

Title:
  autofs  - "Too many levels of symbolic links" after apt upgrade

Status in autofs5 package in Ubuntu:
  New

Bug description:
  Description:Ubuntu 16.04.6 LTS
  Release:16.04

  I moved to autofs this week as a workaround for Bug #1577575 failing
  to mount NFS entries at boot. This worked file until I ran 'apt
  upgrade' today.

  Now trying to access /vol/home mount results in the following error:

  root@chi:~# ls -la /vol/home/
  ls: cannot access '/vol/home/': Too many levels of symbolic links
  root@chi:~# 

  Oddly enough, the other two autofs entries work fine (output trimmed):
  root@chi:~# ls -la /vol/media
  total 4
  ...
  root@chi:~# 
  root@chi:~# ls -al /vol/temp/
  total 24
  ...
  root@chi:~# 

  
  I have a scratch VM I can break tonight by performing upgrades individually 
and testing after each.  Will provide that detail when available.

  
  Here is /var/log/apt/history.log

   Start-Date: 2019-05-01  17:37:00
  Commandline: apt upgrade
  Upgrade: libdns-export162:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), libisccfg140:amd64 
(1:9.10.3.dfsg.P4-8ubuntu1.12, 1:9.10.3.dfsg.P4-8ubuntu1.14), ureadahead:amd64 
(0.100.0-19, 0.100.0-19.1), libldap-2.4-2:amd64 (2.4.42+dfsg-2ubuntu3.4, 
2.4.42+dfsg-2ubuntu3.5), libirs141:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), bind9-host:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), dnsutils:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), libisc160:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), passwd:amd64 (1:4.2-3.1ubuntu5.3, 
1:4.2-3.1ubuntu5.4), bind9utils:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), libisc-export160:amd64 
(1:9.10.3.dfsg.P4-8ubuntu1.12, 1:9.10.3.dfsg.P4-8ubuntu1.14), liblwres141:amd64 
(1:9.10.3.dfsg.P4-8ubuntu1.12, 1:9.10.3.dfsg.P4-8ubuntu1.14), login:amd64 
(1:4.2-3.1ubuntu5.3, 1:4.2-3.1ubuntu5.4), iproute2:amd64 
(4.3.0-1ubuntu3.16.04.4, 4.3.0-1ubuntu3.16.04.5), bind9:amd64 
(1:9.10.3.dfsg.P4-8ubuntu1.12, 

[Touch-packages] [Bug 1827286] Re: autofs - "Too many levels of symbolic links" after apt upgrade

2019-05-01 Thread Jason D. Kelleher
** Tags added: autofs

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1827286

Title:
  autofs  - "Too many levels of symbolic links" after apt upgrade

Status in systemd package in Ubuntu:
  New

Bug description:
  Description:Ubuntu 16.04.6 LTS
  Release:16.04

  I moved to autofs this week as a workaround for Bug #1577575 failing
  to mount NFS entries at boot. This worked file until I ran 'apt
  upgrade' today.

  Now trying to access /vol/home mount results in the following error:

  root@chi:~# ls -la /vol/home/
  ls: cannot access '/vol/home/': Too many levels of symbolic links
  root@chi:~# 

  Oddly enough, the other two autofs entries work fine (output trimmed):
  root@chi:~# ls -la /vol/media
  total 4
  ...
  root@chi:~# 
  root@chi:~# ls -al /vol/temp/
  total 24
  ...
  root@chi:~# 

  
  I have a scratch VM I can break tonight by performing upgrades individually 
and testing after each.  Will provide that detail when available.

  
  Here is /var/log/apt/history.log

   Start-Date: 2019-05-01  17:37:00
  Commandline: apt upgrade
  Upgrade: libdns-export162:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), libisccfg140:amd64 
(1:9.10.3.dfsg.P4-8ubuntu1.12, 1:9.10.3.dfsg.P4-8ubuntu1.14), ureadahead:amd64 
(0.100.0-19, 0.100.0-19.1), libldap-2.4-2:amd64 (2.4.42+dfsg-2ubuntu3.4, 
2.4.42+dfsg-2ubuntu3.5), libirs141:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), bind9-host:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), dnsutils:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), libisc160:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), passwd:amd64 (1:4.2-3.1ubuntu5.3, 
1:4.2-3.1ubuntu5.4), bind9utils:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), libisc-export160:amd64 
(1:9.10.3.dfsg.P4-8ubuntu1.12, 1:9.10.3.dfsg.P4-8ubuntu1.14), liblwres141:amd64 
(1:9.10.3.dfsg.P4-8ubuntu1.12, 1:9.10.3.dfsg.P4-8ubuntu1.14), login:amd64 
(1:4.2-3.1ubuntu5.3, 1:4.2-3.1ubuntu5.4), iproute2:amd64 
(4.3.0-1ubuntu3.16.04.4, 4.3.0-1ubuntu3.16.04.5), bind9:amd64 
(1:9.10.3.dfsg.P4-8ubuntu1.12, 1:9.10.3.dfsg.P4-8ubuntu1.14), libdns162:amd64 
(1:9.10.3.dfsg.P4-8ubuntu1.12, 1:9.10.3.dfsg.P4-8ubuntu1.14), 
unattended-upgrades:amd64 (0.90ubuntu0.10, 1.1ubuntu1.18.04.7~16.04.2), 
libisccc140:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 1:9.10.3.dfsg.P4-8ubuntu1.14), 
libbind9-140:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), uidmap:amd64 (1:4.2-3.1ubuntu5.3, 
1:4.2-3.1ubuntu5.4), bind9-doc:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), tzdata:amd64 (2018i-0ubuntu0.16.04, 
2019a-0ubuntu0.16.04)
  End-Date: 2019-05-01  17:37:24

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1827286/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1827286] [NEW] autofs - "Too many levels of symbolic links" after apt upgrade

2019-05-01 Thread Jason D. Kelleher
Public bug reported:

Description:Ubuntu 16.04.6 LTS
Release:16.04

I moved to autofs this week as a workaround for Bug #1577575 failing to
mount NFS entries at boot. This worked file until I ran 'apt upgrade'
today.

Now trying to access /vol/home mount results in the following error:

root@chi:~# ls -la /vol/home/
ls: cannot access '/vol/home/': Too many levels of symbolic links
root@chi:~# 

Oddly enough, the other two autofs entries work fine (output trimmed):
root@chi:~# ls -la /vol/media
total 4
...
root@chi:~# 
root@chi:~# ls -al /vol/temp/
total 24
...
root@chi:~# 


I have a scratch VM I can break tonight by performing upgrades individually and 
testing after each.  Will provide that detail when available.


Here is /var/log/apt/history.log

 Start-Date: 2019-05-01  17:37:00
Commandline: apt upgrade
Upgrade: libdns-export162:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), libisccfg140:amd64 
(1:9.10.3.dfsg.P4-8ubuntu1.12, 1:9.10.3.dfsg.P4-8ubuntu1.14), ureadahead:amd64 
(0.100.0-19, 0.100.0-19.1), libldap-2.4-2:amd64 (2.4.42+dfsg-2ubuntu3.4, 
2.4.42+dfsg-2ubuntu3.5), libirs141:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), bind9-host:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), dnsutils:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), libisc160:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), passwd:amd64 (1:4.2-3.1ubuntu5.3, 
1:4.2-3.1ubuntu5.4), bind9utils:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), libisc-export160:amd64 
(1:9.10.3.dfsg.P4-8ubuntu1.12, 1:9.10.3.dfsg.P4-8ubuntu1.14), liblwres141:amd64 
(1:9.10.3.dfsg.P4-8ubuntu1.12, 1:9.10.3.dfsg.P4-8ubuntu1.14), login:amd64 
(1:4.2-3.1ubuntu5.3, 1:4.2-3.1ubuntu5.4), iproute2:amd64 
(4.3.0-1ubuntu3.16.04.4, 4.3.0-1ubuntu3.16.04.5), bind9:amd64 
(1:9.10.3.dfsg.P4-8ubuntu1.12, 1:9.10.3.dfsg.P4-8ubuntu1.14), libdns162:amd64 
(1:9.10.3.dfsg.P4-8ubuntu1.12, 1:9.10.3.dfsg.P4-8ubuntu1.14), 
unattended-upgrades:amd64 (0.90ubuntu0.10, 1.1ubuntu1.18.04.7~16.04.2), 
libisccc140:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 1:9.10.3.dfsg.P4-8ubuntu1.14), 
libbind9-140:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), uidmap:amd64 (1:4.2-3.1ubuntu5.3, 
1:4.2-3.1ubuntu5.4), bind9-doc:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), tzdata:amd64 (2018i-0ubuntu0.16.04, 
2019a-0ubuntu0.16.04)
End-Date: 2019-05-01  17:37:24

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1827286

Title:
  autofs  - "Too many levels of symbolic links" after apt upgrade

Status in systemd package in Ubuntu:
  New

Bug description:
  Description:Ubuntu 16.04.6 LTS
  Release:16.04

  I moved to autofs this week as a workaround for Bug #1577575 failing
  to mount NFS entries at boot. This worked file until I ran 'apt
  upgrade' today.

  Now trying to access /vol/home mount results in the following error:

  root@chi:~# ls -la /vol/home/
  ls: cannot access '/vol/home/': Too many levels of symbolic links
  root@chi:~# 

  Oddly enough, the other two autofs entries work fine (output trimmed):
  root@chi:~# ls -la /vol/media
  total 4
  ...
  root@chi:~# 
  root@chi:~# ls -al /vol/temp/
  total 24
  ...
  root@chi:~# 

  
  I have a scratch VM I can break tonight by performing upgrades individually 
and testing after each.  Will provide that detail when available.

  
  Here is /var/log/apt/history.log

   Start-Date: 2019-05-01  17:37:00
  Commandline: apt upgrade
  Upgrade: libdns-export162:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), libisccfg140:amd64 
(1:9.10.3.dfsg.P4-8ubuntu1.12, 1:9.10.3.dfsg.P4-8ubuntu1.14), ureadahead:amd64 
(0.100.0-19, 0.100.0-19.1), libldap-2.4-2:amd64 (2.4.42+dfsg-2ubuntu3.4, 
2.4.42+dfsg-2ubuntu3.5), libirs141:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), bind9-host:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), dnsutils:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), libisc160:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), passwd:amd64 (1:4.2-3.1ubuntu5.3, 
1:4.2-3.1ubuntu5.4), bind9utils:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.12, 
1:9.10.3.dfsg.P4-8ubuntu1.14), libisc-export160:amd64 
(1:9.10.3.dfsg.P4-8ubuntu1.12, 1:9.10.3.dfsg.P4-8ubuntu1.14), liblwres141:amd64 
(1:9.10.3.dfsg.P4-8ubuntu1.12, 1:9.10.3.dfsg.P4-8ubuntu1.14), login:amd64 
(1:4.2-3.1ubuntu5.3, 1:4.2-3.1ubuntu5.4), iproute2:amd64 
(4.3.0-1ubuntu3.16.04.4, 4.3.0-1ubuntu3.16.04.5), bind9:amd64 
(1:9.10.3.dfsg.P4-8ubuntu1.12, 1:9.10.3.dfsg.P4-8ubuntu1.14), libdns162:amd64 
(1:9.10.3.dfsg.P4-8ubuntu1.12, 1:9.10.3.dfsg.P4-8ubuntu1.14), 
unattended-upgrades:amd64 (0.90ubuntu0.10, 1.1ubuntu1.18.04.7~16.04.2), 

[Touch-packages] [Bug 1577575] Re: NFS share does not mount on boot using fstab

2019-05-01 Thread Jason D. Kelleher
Quick update - switched to autofs as a workaround for this 16.04 issue.

That was fine until I ran 'apt upgrade' today.  Now I get the following
error:

root@chi:~# ls -la /vol/home/
ls: cannot access '/vol/home/': Too many levels of symbolic links
root@chi:~# 

I'll be opening a new bug for autofs while considering a move back to
Debian or a jump to CentOS.

If anyone is using autofs as a workaround for the systemd issue, be very
careful with an apt upgrade.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1577575

Title:
  NFS share does not mount on boot using fstab

Status in nfs-utils package in Ubuntu:
  New
Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  What I expected to happen?

  I want an NFS share to be mounted on startup using

  
  192.168.178.66:/media/captainplanet/7EF8B26FF8B22575/ 
/media/captainplanet/banane/ nfs rw 0 0

  What happened instead?

  It does not mount on startup. Systemd waits 91sec instead and finally
  starts after failing.

  I can successfully mount the NFS share with

  sudo mount 192.168.178.66:/media/captainplanet/7EF8B26FF8B22575
  /media/captainplanet/banane/

  When I try to shutdown Xubuntu it hangs forever. Unmounting the NFS
  share manually before shutdown fixes the second problem.

  
  Do you need more information?

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: systemd 229-4ubuntu4
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: XFCE
  Date: Mon May  2 23:10:50 2016
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2016-04-22 (10 days ago)
  InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Release amd64 
(20160420.1)
  MachineType: LENOVO 20DM003XUK
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=eece9973-0430-4a60-9291-9a994782bf86 ro quiet splash
  SourcePackage: systemd
  SystemdDelta:
   [EXTENDED]   /lib/systemd/system/systemd-timesyncd.service → 
/lib/systemd/system/systemd-timesyncd.service.d/disable-with-time-daemon.conf
   [EXTENDED]   /lib/systemd/system/rc-local.service → 
/lib/systemd/system/rc-local.service.d/debian.conf
   
   2 overridden configuration files found.
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/26/2015
  dmi.bios.vendor: LENOVO
  dmi.bios.version: JFET44WW(1.21)
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20DM003XUK
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0E50512 STD
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrJFET44WW(1.21):bd08/26/2015:svnLENOVO:pn20DM003XUK:pvrThinkPadS3Yoga14:rvnLENOVO:rn20DM003XUK:rvrSDK0E50512STD:cvnLENOVO:ct10:cvrNone:
  dmi.product.name: 20DM003XUK
  dmi.product.version: ThinkPad S3 Yoga 14
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nfs-utils/+bug/1577575/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1577575] Re: NFS share does not mount on boot using fstab

2019-04-29 Thread Jason D. Kelleher
I should note this is impacting an image built from 16.04.4.  Another
image built from 16.04.1 is working fine.

Both have been pulled forward via apt dist-upgrade and their behaviors
differ - concerning in it's own right.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1577575

Title:
  NFS share does not mount on boot using fstab

Status in nfs-utils package in Ubuntu:
  New
Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  What I expected to happen?

  I want an NFS share to be mounted on startup using

  
  192.168.178.66:/media/captainplanet/7EF8B26FF8B22575/ 
/media/captainplanet/banane/ nfs rw 0 0

  What happened instead?

  It does not mount on startup. Systemd waits 91sec instead and finally
  starts after failing.

  I can successfully mount the NFS share with

  sudo mount 192.168.178.66:/media/captainplanet/7EF8B26FF8B22575
  /media/captainplanet/banane/

  When I try to shutdown Xubuntu it hangs forever. Unmounting the NFS
  share manually before shutdown fixes the second problem.

  
  Do you need more information?

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: systemd 229-4ubuntu4
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: XFCE
  Date: Mon May  2 23:10:50 2016
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2016-04-22 (10 days ago)
  InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Release amd64 
(20160420.1)
  MachineType: LENOVO 20DM003XUK
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=eece9973-0430-4a60-9291-9a994782bf86 ro quiet splash
  SourcePackage: systemd
  SystemdDelta:
   [EXTENDED]   /lib/systemd/system/systemd-timesyncd.service → 
/lib/systemd/system/systemd-timesyncd.service.d/disable-with-time-daemon.conf
   [EXTENDED]   /lib/systemd/system/rc-local.service → 
/lib/systemd/system/rc-local.service.d/debian.conf
   
   2 overridden configuration files found.
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/26/2015
  dmi.bios.vendor: LENOVO
  dmi.bios.version: JFET44WW(1.21)
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20DM003XUK
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0E50512 STD
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrJFET44WW(1.21):bd08/26/2015:svnLENOVO:pn20DM003XUK:pvrThinkPadS3Yoga14:rvnLENOVO:rn20DM003XUK:rvrSDK0E50512STD:cvnLENOVO:ct10:cvrNone:
  dmi.product.name: 20DM003XUK
  dmi.product.version: ThinkPad S3 Yoga 14
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nfs-utils/+bug/1577575/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1577575] Re: NFS share does not mount on boot using fstab

2019-04-29 Thread Jason D. Kelleher
Same issue here.  NFS fails to mount at boot, but logging in and issuing
a manual "mount -a" resolves until the next reboot.

It should also be noted that there's a significant delay on boot with
nfs entries in fstab - need to time it, but ~1 minute.

Why issues with something as old/stable/boring as NFS?



** Also affects: nfs-utils (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1577575

Title:
  NFS share does not mount on boot using fstab

Status in nfs-utils package in Ubuntu:
  New
Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  What I expected to happen?

  I want an NFS share to be mounted on startup using

  
  192.168.178.66:/media/captainplanet/7EF8B26FF8B22575/ 
/media/captainplanet/banane/ nfs rw 0 0

  What happened instead?

  It does not mount on startup. Systemd waits 91sec instead and finally
  starts after failing.

  I can successfully mount the NFS share with

  sudo mount 192.168.178.66:/media/captainplanet/7EF8B26FF8B22575
  /media/captainplanet/banane/

  When I try to shutdown Xubuntu it hangs forever. Unmounting the NFS
  share manually before shutdown fixes the second problem.

  
  Do you need more information?

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: systemd 229-4ubuntu4
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: XFCE
  Date: Mon May  2 23:10:50 2016
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2016-04-22 (10 days ago)
  InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Release amd64 
(20160420.1)
  MachineType: LENOVO 20DM003XUK
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=eece9973-0430-4a60-9291-9a994782bf86 ro quiet splash
  SourcePackage: systemd
  SystemdDelta:
   [EXTENDED]   /lib/systemd/system/systemd-timesyncd.service → 
/lib/systemd/system/systemd-timesyncd.service.d/disable-with-time-daemon.conf
   [EXTENDED]   /lib/systemd/system/rc-local.service → 
/lib/systemd/system/rc-local.service.d/debian.conf
   
   2 overridden configuration files found.
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/26/2015
  dmi.bios.vendor: LENOVO
  dmi.bios.version: JFET44WW(1.21)
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20DM003XUK
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0E50512 STD
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrJFET44WW(1.21):bd08/26/2015:svnLENOVO:pn20DM003XUK:pvrThinkPadS3Yoga14:rvnLENOVO:rn20DM003XUK:rvrSDK0E50512STD:cvnLENOVO:ct10:cvrNone:
  dmi.product.name: 20DM003XUK
  dmi.product.version: ThinkPad S3 Yoga 14
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nfs-utils/+bug/1577575/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1452239] Re: root escalation with fs.suid_dumpable=2

2019-01-22 Thread Carlos D. Gonzalez
  which has Apport package release 0.76/0.76.1.  Any system since Ubuntu
  7.04 that has had fs.suid_dumpable set to 2, even though it wasn't
  Ubuntu's default, has been exploitable.  Thus, the proof of concept
  attached will and should essentially work on any Ubuntu release starting
  with 7.04; it was in fact tested and found to be working on 7.04 itself,
  but later releases until 12.04 were not tested.

  VULNERABLE RELEASES
  ---

  The proof of concept attached should work out of the box on (and is in
  fact tested to work on most of them) all of the following releases:

  12.04   LTS
  12.04.1 LTS
  12.04.2 LTS
  12.04.3 LTS
  12.04.4 LTS
  12.04.5 LTS
  12.10   (EOL)
  13.04   (EOL)
  13.10   (EOL)
  14.04   LTS
  14.04.1 LTS
  14.04.2 LTS
  14.10
  15.04   (only with Upstart, not systemd)

  Of all of the above releases all of the Server, Desktop and, where
  available, Alternate editions are affected.

  In other words: anything Ubuntu from the past three years is vulnerable,
  out of the box.

  All releases older than 12.04, starting with 7.04, are vulnerable as well
  in the sense that they have installed Apport by default or otherwise
  provide it as an installable package, being an Apport package which
  creates user core dumps (in CWD, also with fs.suid_dumpable=2); however,
  those releases do not have the Apport service enabled by default, nor
  do they have fs.suid_dumpable set to "2" by default.

  OTHER OSes / DISTRIBUTIONS / UBUNTU VERSIONS / DERIVATIVES
  --

  Any OS / distribution with an Apport version creating a user core
  dump (meaning, the core dump created apart from the Apport report in
  /var/crash) in CWD is vulnerable.  If fs.suid_dumpable=2 is the default,
  the OS is exploitable by default.

  This may or may not include Ubuntu derivatives, forks and Ubuntu based
  distributions like Ubuntu GNOME, Kubuntu, Ubuntu MATE, Ubuntu Studio,
  Edubuntu, Lubuntu, Mythbuntu, Xubuntu, Linux Mint (the Ubuntu based
  version), Peppermint, elementary OS, Bodhi Linux, BackBox, et cetera[5].
  (As a quick test, at least BackBox 3.13 was found to be exploitable
  by default.)

  Further investigation will need to reveil what OSes / distributions /
  Ubuntu versions and derivatives are vulnerable, and which aren't.

  WORKAROUND
  --

  Disable the Apport service.

  PROPOSED IMMEDIATE, TEMPORARY FIX
  -

  Disable suid_dumpable=2 in _all_ Ubuntu Apport packages; let it stay 0,
  which is the kernel's default.

  Thus, revert the damage done almost two years ago, e.g., by removing
  the lines

  echo 2 > /proc/sys/fs/suid_dumpable

  and

  echo 0 > /proc/sys/fs/suid_dumpable

  from the debian/apport.upstart files.

  Additionally, do _not_ enable fs.suid_dumpable=2 in the Apport systemd
  scripts for Ubuntu until a proper solution is implemented.

  PROPOSED LONG TERM FIX
  --

  Apport should _never_ dump core to CWD with fs.suid_dumpable=2 for
  tainted/protected binaries (just like the kernel does not do this
  anymore[4]).  If creating a user core dump at all, Apport should dump
  it to a safe, dedicated directory.

  Apport should use the kernel's "%d" kernel.core_pattern template specifier
  (see core(5)), which will present the dumpable state of the crashed
  process ("0", "1" or "2").  Please note though that the "%d" template
  is only available in (upstream) kernels >=3.7.

  REFERENCES
  --

  [1] <http://bazaar.launchpad.net/~apport-hackers/apport/trunk/revision/602>
  [2] <https://wiki.ubuntu.com/Apport#How_to_enable_apport>
  [3] <https://bugs.launchpad.net/ubuntu/+source/apport/+bug/1194541>
  [4] 
<https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=9520628e8ceb69fa9a4aee6b57f22675d9e1b709>
  [5] 
<https://en.wikipedia.org/wiki/List_of_Ubuntu-based_distributions#Ubuntu-based>

  CREDITS
  ---

  The issue was found, analyzed, and reported to Ubuntu by Sander Bos,
  along with a detailed explanation of the problem, proposed workarounds
  and fixes, and an exploit proof of concept.

To manage notifications about this bug go to:
https://bugs.launchpad.net/apport/+bug/1452239/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1793555] Re: networkd tears down bridge ip address when the last device is pulled out from the bridge

2018-11-29 Thread Scati Labs I+D
This issue has been fixed upstream:
https://github.com/systemd/systemd/pull/10597

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1793555

Title:
  networkd tears down bridge ip address when the last device is pulled
  out from the bridge

Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  In Ubuntu 18.04.1 LTS (systemd 237) pulling out the last device out of
  the bridge removes the bridge ip address.

  given the following config:

  # cat /etc/systemd/network/vmbr0.netdev
  [NetDev]
  Name=vmbr0
  Kind=bridge

  [Bridge]
  HelloTimeSec=0
  ForwardDelaySec=0
  STP=no

  # cat /etc/systemd/network/vmbr0.network
  [Match]
  Name=vmbr0

  [Network]
  Address=10.10.0.1/16
  ConfigureWithoutCarrier=yes
  DHCP=no
  IPForward=yes
  IPv6AcceptRA=no
  LinkLocalAddressing=no

  networkd would bring up vmbr0 with 10.10.0.1/16 on system boot despite
  it not having any devices, allowing services to bind to 10.10.0.1.

  However, if you add a device and then remove it (e.g. by starting and
  then stopping a virtual machine connected to the bridge), networkd
  would tear down the interface:

  3: vmbr0:  mtu 1500 qdisc noqueue state 
DOWN group default qlen 1000
  link/ether 16:19:4c:7f:e8:c4 brd ff:ff:ff:ff:ff:ff

  thus making any service listening on 10.10.0.1 inaccessible.

  previously on Xenial the bridge would stay intact.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1793555/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1805543] Re: Packaged version of iptables doesn't provide --random-fully flag.

2018-11-27 Thread Paul D
First off, wow, thank you for the speedy response!  I am pretty
confident that the kernel we're running supports this feature.  Here's
why:

$ uname -a
Linux ip-172-18-45-20 4.15.0-1025-aws #25-Ubuntu SMP Wed Oct 10 14:23:49 UTC 
2018 x86_64 x86_64 x86_64 GNU/Linux

Subsequently I found the patch in the kernel tree which I think
introduces support for the feature I'm after:

https://github.com/torvalds/linux/commit/34ce324019e76f6d93768d68343a0e78f464d754
#diff-b0b059e2ea29367b52cec84db46f33a3R11

If I read the list of tags on that page correctly, this has been part of
kernels released since 3.14, which is quite a while ago now.  In
particular, I see that the kernel I'm running is in that list too.
Although for absolute transparency I'm using the Ubuntu released on AWS
EC2 instances, but I'm guessing this shouldn't make any difference.

Thank you again.

$ apt-cache policy linux-image-4.15.0-1025-aws
linux-image-4.15.0-1025-aws:
  Installed: 4.15.0-1025.25
  Candidate: 4.15.0-1025.25
  Version table:
 *** 4.15.0-1025.25 500
500 http://us-west-2.ec2.archive.ubuntu.com/ubuntu bionic-updates/main 
amd64 Packages
100 /var/lib/dpkg/status

$ apt-cache policy linux-base
linux-base:
  Installed: 4.5ubuntu1
  Candidate: 4.5ubuntu1
  Version table:
 *** 4.5ubuntu1 500
500 http://us-west-2.ec2.archive.ubuntu.com/ubuntu bionic/main amd64 
Packages
100 /var/lib/dpkg/status

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to iptables in Ubuntu.
https://bugs.launchpad.net/bugs/1805543

Title:
  Packaged version of iptables doesn't provide --random-fully flag.

Status in iptables package in Ubuntu:
  New

Bug description:
  Hello.  This isn't strictly a bug, but more of an upgrade-request on
  the iptables package.  Normally i wouldn't be inclined to submit such
  a bug report, but a user on the ubuntu-devel-discuss mailing list
  encouraged me to submit this anyway [1].  For our production systems,
  we're running into a kernel race condition bug, for which a workaround
  has been made available.  The fix boils down to iptables having a new
  flag which it passes down to the kernel, to enable the workaround.
  However, the version of iptables in Ubuntu (v1.6.1) doesn't support
  that kernel feature yet.  Specifically, it's introduced in this commit
  on the iptables codebase:
  
https://git.netfilter.org/iptables/commit/?id=8b0da2130b8af3890ef20afb2305f11224bb39ec.

  The feature we need from that commit is part of the v1.6.2 and newer
  iptables releases, but it looks like the Bionic, Cosmic, and Disco
  releases of Ubuntu all include v1.6.1 without that patch, so for now
  we're going to have to build iptables from source on our production
  machines.  That shouldn't pose any huge issues, but of course, we'd
  prefer to be able to use the package from package management, or
  perhaps a backported package from a newer Ubuntu release.

  So to summarise, this might be an invalid bug report, but consider it
  a vote to upgrade the packaged version of iptables.  If this bug
  report is entirely inappropriate, then I apologise.

  1. Link to thread on ubuntu-devel-discuss where I describe the problem
  and Nish suggests I file this bug report:
  https://lists.ubuntu.com/archives/ubuntu-devel-
  discuss/2018-November/018181.html

  Ubuntu version we're using: 
  Description:  Ubuntu 18.04.1 LTS
  Release:  18.04

  $ apt-cache policy iptables
  iptables:
Installed: 1.6.1-2ubuntu2
Candidate: 1.6.1-2ubuntu2
Version table:
   *** 1.6.1-2ubuntu2 500
  500 http://us-west-2.ec2.archive.ubuntu.com/ubuntu bionic/main amd64 
Packages
  100 /var/lib/dpkg/status

  Thanks for your time,

  Paul

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/iptables/+bug/1805543/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1805543] [NEW] Packaged version of iptables doesn't provide --random-fully flag.

2018-11-27 Thread Paul D
Public bug reported:

Hello.  This isn't strictly a bug, but more of an upgrade-request on the
iptables package.  Normally i wouldn't be inclined to submit such a bug
report, but a user on the ubuntu-devel-discuss mailing list encouraged
me to submit this anyway [1].  For our production systems, we're running
into a kernel race condition bug, for which a workaround has been made
available.  The fix boils down to iptables having a new flag which it
passes down to the kernel, to enable the workaround.  However, the
version of iptables in Ubuntu (v1.6.1) doesn't support that kernel
feature yet.  Specifically, it's introduced in this commit on the
iptables codebase:
https://git.netfilter.org/iptables/commit/?id=8b0da2130b8af3890ef20afb2305f11224bb39ec.

The feature we need from that commit is part of the v1.6.2 and newer
iptables releases, but it looks like the Bionic, Cosmic, and Disco
releases of Ubuntu all include v1.6.1 without that patch, so for now
we're going to have to build iptables from source on our production
machines.  That shouldn't pose any huge issues, but of course, we'd
prefer to be able to use the package from package management, or perhaps
a backported package from a newer Ubuntu release.

So to summarise, this might be an invalid bug report, but consider it a
vote to upgrade the packaged version of iptables.  If this bug report is
entirely inappropriate, then I apologise.

1. Link to thread on ubuntu-devel-discuss where I describe the problem
and Nish suggests I file this bug report:
https://lists.ubuntu.com/archives/ubuntu-devel-
discuss/2018-November/018181.html

Ubuntu version we're using: 
Description:Ubuntu 18.04.1 LTS
Release:18.04

$ apt-cache policy iptables
iptables:
  Installed: 1.6.1-2ubuntu2
  Candidate: 1.6.1-2ubuntu2
  Version table:
 *** 1.6.1-2ubuntu2 500
500 http://us-west-2.ec2.archive.ubuntu.com/ubuntu bionic/main amd64 
Packages
100 /var/lib/dpkg/status

Thanks for your time,

Paul

** Affects: iptables (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to iptables in Ubuntu.
https://bugs.launchpad.net/bugs/1805543

Title:
  Packaged version of iptables doesn't provide --random-fully flag.

Status in iptables package in Ubuntu:
  New

Bug description:
  Hello.  This isn't strictly a bug, but more of an upgrade-request on
  the iptables package.  Normally i wouldn't be inclined to submit such
  a bug report, but a user on the ubuntu-devel-discuss mailing list
  encouraged me to submit this anyway [1].  For our production systems,
  we're running into a kernel race condition bug, for which a workaround
  has been made available.  The fix boils down to iptables having a new
  flag which it passes down to the kernel, to enable the workaround.
  However, the version of iptables in Ubuntu (v1.6.1) doesn't support
  that kernel feature yet.  Specifically, it's introduced in this commit
  on the iptables codebase:
  
https://git.netfilter.org/iptables/commit/?id=8b0da2130b8af3890ef20afb2305f11224bb39ec.

  The feature we need from that commit is part of the v1.6.2 and newer
  iptables releases, but it looks like the Bionic, Cosmic, and Disco
  releases of Ubuntu all include v1.6.1 without that patch, so for now
  we're going to have to build iptables from source on our production
  machines.  That shouldn't pose any huge issues, but of course, we'd
  prefer to be able to use the package from package management, or
  perhaps a backported package from a newer Ubuntu release.

  So to summarise, this might be an invalid bug report, but consider it
  a vote to upgrade the packaged version of iptables.  If this bug
  report is entirely inappropriate, then I apologise.

  1. Link to thread on ubuntu-devel-discuss where I describe the problem
  and Nish suggests I file this bug report:
  https://lists.ubuntu.com/archives/ubuntu-devel-
  discuss/2018-November/018181.html

  Ubuntu version we're using: 
  Description:  Ubuntu 18.04.1 LTS
  Release:  18.04

  $ apt-cache policy iptables
  iptables:
Installed: 1.6.1-2ubuntu2
Candidate: 1.6.1-2ubuntu2
Version table:
   *** 1.6.1-2ubuntu2 500
  500 http://us-west-2.ec2.archive.ubuntu.com/ubuntu bionic/main amd64 
Packages
  100 /var/lib/dpkg/status

  Thanks for your time,

  Paul

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/iptables/+bug/1805543/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1803821] [NEW] trackpoint scrolling not working after update to Ubuntu 18.10

2018-11-17 Thread Amelie D
Public bug reported:

Scrolling by pressing the middle button + moving the trackpoint no
longer works on my Lenovo E560 after recently updating to Ubuntu 18.10.
Other functions of the middle button besides scrolling work fine.

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: xorg 1:7.7+19ubuntu8
ProcVersionSignature: Ubuntu 4.18.0-11.12-generic 4.18.12
Uname: Linux 4.18.0-11-generic x86_64
ApportVersion: 2.20.10-0ubuntu13
Architecture: amd64
CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CurrentDesktop: MATE
Date: Sat Nov 17 12:40:30 2018
DistUpgraded: 2018-11-06 01:04:28,107 DEBUG Running PostInstallScript: 
'./xorg_fix_proprietary.py'
DistroCodename: cosmic
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Intel Corporation Skylake GT2 [HD Graphics 520] [8086:1916] (rev 07) (prog-if 
00 [VGA controller])
   Subsystem: Lenovo Skylake GT2 [HD Graphics 520] [17aa:5049]
   Subsystem: Lenovo Mars [Radeon HD 8670A/8670M/8750M] [17aa:5049]
InstallationDate: Installed on 2016-05-12 (918 days ago)
InstallationMedia: Ubuntu-MATE 16.04 LTS "Xenial Xerus" - Release amd64 
(20160420.1)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 04f2:b541 Chicony Electronics Co., Ltd 
 Bus 001 Device 002: ID 8087:0a2b Intel Corp. 
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: LENOVO 20EVCTO1WW
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.18.0-11-generic 
root=UUID=fb8caa1e-e7e1-4c22-9a7e-fd410dd71da0 ro quiet splash vt.handoff=1
SourcePackage: xorg
UpgradeStatus: Upgraded to cosmic on 2018-11-06 (11 days ago)
dmi.bios.date: 04/20/2016
dmi.bios.vendor: LENOVO
dmi.bios.version: R00ET42W (1.17 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20EVCTO1WW
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40709 WIN
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.modalias: 
dmi:bvnLENOVO:bvrR00ET42W(1.17):bd04/20/2016:svnLENOVO:pn20EVCTO1WW:pvrThinkPadE560:rvnLENOVO:rn20EVCTO1WW:rvrSDK0J40709WIN:cvnLENOVO:ct10:cvrNone:
dmi.product.family: ThinkPad E560
dmi.product.name: 20EVCTO1WW
dmi.product.sku: LENOVO_MT_20EV_BU_Think_FM_ThinkPad E560
dmi.product.version: ThinkPad E560
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.13.1+18.10.20180930-0ubuntu1
version.libdrm2: libdrm2 2.4.95-1
version.libgl1-mesa-dri: libgl1-mesa-dri 18.2.2-0ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 18.2.2-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.20.1-3ubuntu2.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.6-1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.1.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20171229-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-3
xserver.bootTime: Thu Nov 15 15:55:41 2018
xserver.configfile: default
xserver.errors:
 
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.20.1-3ubuntu2.1
xserver.video_driver: modeset

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug cosmic ubuntu

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1803821

Title:
  trackpoint scrolling not working after update to Ubuntu 18.10

Status in xorg package in Ubuntu:
  New

Bug description:
  Scrolling by pressing the middle button + moving the trackpoint no
  longer works on my Lenovo E560 after recently updating to Ubuntu
  18.10. Other functions of the middle button besides scrolling work
  fine.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.10
  Package: xorg 1:7.7+19ubuntu8
  ProcVersionSignature: Ubuntu 4.18.0-11.12-generic 4.18.12
  Uname: Linux 4.18.0-11-generic x86_64
  ApportVersion: 2.20.10-0ubuntu13
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: MATE
  Date: Sat Nov 17 12:40:30 2018
  DistUpgraded: 2018-11-06 01:04:28,107 DEBUG Running PostInstallScript: 
'./xorg_fix_proprietary.py'
  DistroCodename: cosmic
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes, if not too technical
  GraphicsCard:
   Intel Corporation Skylake GT2 [HD Graphics 520] [8086:1916] (rev 07) 
(prog-if 00 [VGA controller])
 Subsystem: Lenovo Skylake GT2 [HD Graphics 520] [17aa:5049]
 Subsystem: Lenovo Mars [Radeon HD 8670A/8670M/8750M] [17aa:5049]
  InstallationDate: Installed on 2016-05-12 (918 days ago)
  InstallationMedia: Ubuntu-MATE 16.04 LTS "Xenial Xerus" - Release amd64 
(20160420.1)
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 04f2:b541 Chicony Electronics Co., Ltd 
   Bus 001 Device 002: ID 8087:0a2b Intel Corp. 
   Bus 001 Device 001: 

[Touch-packages] [Bug 1800382] [NEW] package linux-image-4.15.0-38-generic 4.15.0-38.41 failed to install/upgrade: run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1

2018-10-28 Thread Ethan D
Public bug reported:

Was using apt upgrade to update multiple components (I believe around
650mb) and towards the end of the installation, it was doing the headers
when the error occurred. The system running is a live-boot USB with a
4gb persistence file for storage/updates. I'm thinking this might
inherently be the issue, since further errors occurred with fstab
telling me that it was unable to determine the root device. I've never
had any issues updating headers before, but I've also never tried to
perform a header update on a USB system, so I decided to report, just in
case there is a larger issue.

ProblemType: Package
DistroRelease: Ubuntu 18.04
Package: linux-image-4.15.0-38-generic 4.15.0-38.41
ProcVersionSignature: Ubuntu 4.15.0-29.31-generic 4.15.18
Uname: Linux 4.15.0-29-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.4
Architecture: amd64
AudioDevicesInUse:
 USERPID ACCESS COMMAND
 /dev/snd/controlC0:  ubuntu 1846 F pulseaudio
Date: Sun Oct 28 19:58:12 2018
ErrorMessage: run-parts: /etc/kernel/postinst.d/initramfs-tools exited with 
return code 1
MachineType: Hewlett-Packard HP Pavilion 17 Notebook PC
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: 
BOOT_IMAGE=/multiboot/hostname-18.04.1-desktop-amd64/casper/vmlinuz 
file=/cdrom/multiboot/hostname-18.04.1-desktop-amd64/preseed/hostname.seed 
boot=casper cdrom-detect/try-usb=true persistent 
persistent-path=/multiboot/hostname-18.04.1-desktop-amd64 noprompt 
floppy.allowed_drive_mask=0 ignore_uuid 
live-media-path=/multiboot/hostname-18.04.1-desktop-amd64/casper/ 
initrd=/multiboot/hostname-18.04.1-desktop-amd64/casper/initrd.lz quiet splash 
---
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
Python3Details: /usr/bin/python3.6, Python 3.6.6, python3-minimal, 
3.6.5-3ubuntu1
PythonDetails: /usr/bin/python2.7, Python 2.7.15rc1, python-minimal, 
2.7.15~rc1-1
RelatedPackageVersions: grub-pc 2.02-2ubuntu8.7
RfKill:
 0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
SourcePackage: initramfs-tools
Title: package linux-image-4.15.0-38-generic 4.15.0-38.41 failed to 
install/upgrade: run-parts: /etc/kernel/postinst.d/initramfs-tools exited with 
return code 1
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/04/2014
dmi.bios.vendor: Insyde
dmi.bios.version: F.23
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: 1971
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 95.33
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: 
dmi:bvnInsyde:bvrF.23:bd06/04/2014:svnHewlett-Packard:pnHPPavilion17NotebookPC:pvr088310305B1620100:rvnHewlett-Packard:rn1971:rvr95.33:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.family: 103C_5335KV G=N L=CON B=HP S=PAV X=Null
dmi.product.name: HP Pavilion 17 Notebook PC
dmi.product.version: 088310305B1620100
dmi.sys.vendor: Hewlett-Packard

** Affects: initramfs-tools (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package bionic

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1800382

Title:
  package linux-image-4.15.0-38-generic 4.15.0-38.41 failed to
  install/upgrade: run-parts: /etc/kernel/postinst.d/initramfs-tools
  exited with return code 1

Status in initramfs-tools package in Ubuntu:
  New

Bug description:
  Was using apt upgrade to update multiple components (I believe around
  650mb) and towards the end of the installation, it was doing the
  headers when the error occurred. The system running is a live-boot USB
  with a 4gb persistence file for storage/updates. I'm thinking this
  might inherently be the issue, since further errors occurred with
  fstab telling me that it was unable to determine the root device. I've
  never had any issues updating headers before, but I've also never
  tried to perform a header update on a USB system, so I decided to
  report, just in case there is a larger issue.

  ProblemType: Package
  DistroRelease: Ubuntu 18.04
  Package: linux-image-4.15.0-38-generic 4.15.0-38.41
  ProcVersionSignature: Ubuntu 4.15.0-29.31-generic 4.15.18
  Uname: Linux 4.15.0-29-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.4
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  ubuntu 1846 F pulseaudio
  Date: Sun Oct 28 19:58:12 2018
  ErrorMessage: run-parts: /etc/kernel/postinst.d/initramfs-tools exited with 
return code 1
  MachineType: Hewlett-Packard HP Pavilion 17 Notebook PC
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: 
BOOT_IMAGE=/multiboot/hostname-18.04.1-desktop-amd64/casper/vmlinuz 
file=/cdrom/multiboot/hostname-18.04.1-desktop-amd64/preseed/hostname.seed 
boot=casper cdrom-detect/try-usb=true persistent 

[Touch-packages] [Bug 1767896] Re: Live images with broken seed causes snapd high CPU usage and periodic short GUI freezes

2018-10-25 Thread William D Waddington
So persistence is no longer possible?  That's very disappointing :(
Perhaps the option should be removed.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu.
https://bugs.launchpad.net/bugs/1767896

Title:
  Live images with broken seed causes snapd high CPU usage and periodic
  short GUI freezes

Status in OEM Priority Project:
  Fix Released
Status in snapd package in Ubuntu:
  New
Status in ubuntu-meta package in Ubuntu:
  Fix Released

Bug description:
  ThinkPad 25, UEFI mode, Ubuntu 18.04 installed as a _live_ distro in
  FAT32 partition on SATA SSD in WWAN slot.

  Grub options allow booting without persistence or with a 256MB
  persistence file.  Only thing "persisted" is TERM in favorites.

  Without persistence all is well. With persistence snapd uses up to 90%
  CPU - perhaps more - and cripples the system. Fan runs nearly full
  speed constantly.

  I can eliminate the problem by removing snapd - and that persists.
  Can't kill snapd.  PID is constantly changing.

  0% fan  and low CPU use at idle w/out snapd with persistence, or
  booted w/out persistence.

  WORKAROUND:
  sudo systemctl stop snapd

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1767896/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1767896] Re: Live images with broken seed causes snapd high CPU usage and periodic short GUI freezes

2018-10-25 Thread William D Waddington
Yes, this is with the 18.10 final release.

I'm unable to provide confirmation/diagnostics as the behavior is worse
than with 18.04/04.1.  With persistence enabled I can sometimes
initially get to a desktop which has a moving mouse pointer but is
unresponsive. It will at some point black-screen with a message about
the Snappy daemon - which I wasn't able to capture.

Subsequent attempts to boot will either hang on the Ubuntu splash
indefinitely, or eventually flash a desktop immediately followed by a
black screen with only a flashing cursor.

I can exit that and initiate a shutdown with the three-fingered-salute.
That brings a message about a stop job for the Snappy daemon, which also
hangs for a very long time.

Sorry I can't provide any further information.  I'm handcuffed ... and
frustrated as *bleep*.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu.
https://bugs.launchpad.net/bugs/1767896

Title:
  Live images with broken seed causes snapd high CPU usage and periodic
  short GUI freezes

Status in OEM Priority Project:
  Fix Released
Status in snapd package in Ubuntu:
  New
Status in ubuntu-meta package in Ubuntu:
  Fix Released

Bug description:
  ThinkPad 25, UEFI mode, Ubuntu 18.04 installed as a _live_ distro in
  FAT32 partition on SATA SSD in WWAN slot.

  Grub options allow booting without persistence or with a 256MB
  persistence file.  Only thing "persisted" is TERM in favorites.

  Without persistence all is well. With persistence snapd uses up to 90%
  CPU - perhaps more - and cripples the system. Fan runs nearly full
  speed constantly.

  I can eliminate the problem by removing snapd - and that persists.
  Can't kill snapd.  PID is constantly changing.

  0% fan  and low CPU use at idle w/out snapd with persistence, or
  booted w/out persistence.

  WORKAROUND:
  sudo systemctl stop snapd

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1767896/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1767896] Re: Live images with broken seed causes snapd high CPU usage and periodic short GUI freezes

2018-10-24 Thread William D Waddington
The above "confirmed fixed" link is broken.

If you'll pardon another ignorant question: when does this fix show up
in distro?

Just tried 18.10 and persistence renders live Ubuntu completely
unusable.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu.
https://bugs.launchpad.net/bugs/1767896

Title:
  Live images with broken seed causes snapd high CPU usage and periodic
  short GUI freezes

Status in OEM Priority Project:
  Fix Released
Status in snapd package in Ubuntu:
  Won't Fix
Status in ubuntu-meta package in Ubuntu:
  Fix Released

Bug description:
  ThinkPad 25, UEFI mode, Ubuntu 18.04 installed as a _live_ distro in
  FAT32 partition on SATA SSD in WWAN slot.

  Grub options allow booting without persistence or with a 256MB
  persistence file.  Only thing "persisted" is TERM in favorites.

  Without persistence all is well. With persistence snapd uses up to 90%
  CPU - perhaps more - and cripples the system. Fan runs nearly full
  speed constantly.

  I can eliminate the problem by removing snapd - and that persists.
  Can't kill snapd.  PID is constantly changing.

  0% fan  and low CPU use at idle w/out snapd with persistence, or
  booted w/out persistence.

  WORKAROUND:
  sudo systemctl stop snapd

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1767896/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1575078] Re: [XPS 15 9550, Realtek ALC3266] Headphone jack stops working after a while

2018-10-22 Thread D . Schäfer
Dell XPS 13 9630

Had the same problem as multiple times described above what helped in my
case


$ alsactl restore


weird but it helped

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1575078

Title:
  [XPS 15 9550, Realtek ALC3266] Headphone jack stops working after a
  while

Status in alsa-driver package in Ubuntu:
  Confirmed

Bug description:
  I'm experiencing a strange behavior with a headphone jack on my
  laptop.

  I have an external audio speaker connected to it. When I disconnect the 
speaker and reconnect it again it stops working.
  Even more, laptop audio stops working too. And after the reboot, I don't even 
see any of the audio devices.

  I've googled a lot and tried different fixes from forums with no luck.
  After a while, I've accidentally discovered that putting the laptop to
  the sleep mode and rebooting system after brings audio back to live.
  Even more, if speakers were attached during this sleep-reboot
  procedure, they are starting to work as well.

  However, after the next reboot speakers are not working again. And if
  I will plug them out and in - problem with completely missing audio
  returns.

  P.S. I'm using laptop-mode-tools package on my laptop. Recovery after
  hibernation made me believe that it's somehow related. But after
  uninstalling this package nothing really changed.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: alsa-base 1.0.25+dfsg-0ubuntu5
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/pcmC0D0p:   kop3224 F...m pulseaudio
   /dev/snd/controlC0:  kop3224 F pulseaudio
  CurrentDesktop: Unity
  Date: Tue Apr 26 12:17:03 2016
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2016-04-22 (3 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 
(20160420.1)
  PackageArchitecture: all
  SourcePackage: alsa-driver
  Symptom: audio
  Symptom_Card: Встроенное аудио - HDA Intel PCH
  Symptom_Jack: Black Headphone Out, Left
  Symptom_Type: Sound works for a while, then breaks
  Title: [XPS 15 9550, Realtek ALC3266, Black Headphone Out, Left] fails after 
a while
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 04/07/2016
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 01.02.00
  dmi.board.name: 0N7TVV
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 9
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvr01.02.00:bd04/07/2016:svnDellInc.:pnXPS159550:pvr:rvnDellInc.:rn0N7TVV:rvrA00:cvnDellInc.:ct9:cvr:
  dmi.product.name: XPS 15 9550
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1575078/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1579580] Re: ureadahead reports relative path errors in journalctl output

2018-09-10 Thread Angel D. Segarra
I would just remove ureadahead using apt. It's just another canonical
project that nobody has looked at in years and not a priority. I see no
difference whatsoever without it and maybe you won't either.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ureadahead in Ubuntu.
https://bugs.launchpad.net/bugs/1579580

Title:
  ureadahead reports relative path errors in journalctl output

Status in ureadahead package in Ubuntu:
  Confirmed

Bug description:
  ureadahead reports relative path errors in my journalctl output.

  This is currently 4368 lines of useless annoyances in my logs.

  To see if you have this problem, run: journalctl -b | grep ureadahead
  | grep relative | wc -l

  Thanks

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: ureadahead 0.100.0-19
  ProcVersionSignature: Ubuntu 4.4.0-22.39-generic 4.4.8
  Uname: Linux 4.4.0-22-generic x86_64
  NonfreeKernelModules: zfs zunicode zcommon znvpair zavl
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  Date: Sun May  8 15:55:18 2016
  InstallationDate: Installed on 2016-04-04 (34 days ago)
  InstallationMedia: Ubuntu-Server 16.04 LTS "Xenial Xerus" - Beta amd64 
(20160325)
  ProcEnviron:
   TERM=linux
   PATH=(custom, no user)
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: ureadahead
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ureadahead/+bug/1579580/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


Re: [Touch-packages] [Bug 775156] Re: Publish shared printers to the network does not work

2018-08-09 Thread James D. Ehmann
Sorry, I don't use Ubuntu anymore.
~
Jim (James D.) Ehmann
Cary, NC 27511
http://about.me/james.ehmann


On Thu, Aug 9, 2018 at 1:45 AM gf <775...@bugs.launchpad.net> wrote:

> Hello James,
> Thank you for submitting this bug and reporting a problem with cups and
> printing.  You made this bug report some time ago and Ubuntu has been
> updated since then.
>
> Could you confirm that this is no longer a problem and that we can close
> the ticket?
> If it is still a problem, are you still interested in finding a solution
> to this bug?
> If you are, could you let us know, and in the current version, run the
> following (only once):
> apport-collect BUGNUMBER
> and upload the updated logs and and any other logs that are relevant for
> this particular issue.
>
> Thank you again for helping make Ubuntu better.
> G
>
> ** Changed in: cups (Ubuntu)
>Status: New => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/775156
>
> Title:
>   Publish shared printers to the network does not work
>
> Status in cups package in Ubuntu:
>   Incomplete
>
> Bug description:
>   Page 1 (Scheduler not running?):
>   {'cups_connection_failure': False}
>   Page 2 (Choose printer):
>   {'cups_dest': ,
>'cups_instance': None,
>'cups_queue': 'Lexmark-7000',
>'cups_queue_listed': True}
>   Page 3 (Check printer sanity):
>   {'cups_device_uri_scheme': u'socket',
>'cups_printer_dict': {'device-uri': u'socket://10.0.1.9:9100',
>  'printer-info': u'Lexmark 7000',
>  'printer-is-shared': True,
>  'printer-location': u'10.0.1.9',
>  'printer-make-and-model': u'Lexmark 7000
> Foomatic/lex7000 (recommended)',
>  'printer-state': 3,
>  'printer-state-message': u'',
>  'printer-state-reasons': [u'none'],
>  'printer-type': 8531980,
>  'printer-uri-supported':
> u'ipp://localhost:631/printers/Lexmark-7000'},
>'cups_printer_remote': False,
>'is_cups_class': False,
>'local_cups_queue_attributes': {'auth-info-required': u'none',
>'charset-configured': u'utf-8',
>'charset-supported': [u'us-ascii',
> u'utf-8'],
>'color-supported': True,
>'compression-supported': [u'none',
> u'gzip'],
>'copies-default': 1,
>'copies-supported': (1, ),
>'cups-version': u'1.4.4',
>'device-uri': u'socket://10.0.1.9:9100
> ',
>'document-format-default':
> u'application/octet-stream',
>'document-format-supported':
> [u'application/octet-stream',
>
>  u'application/openofficeps',
>
>  u'application/pdf',
>
>  u'application/postscript',
>
>  u'application/vnd.cups-banner',
>
>  u'application/vnd.cups-command',
>
>  u'application/vnd.cups-pdf',
>
>  u'application/vnd.cups-postscript',
>
>  u'application/vnd.cups-raw',
>
>  u'application/vnd.hp-hpgl',
>
>  u'application/x-cshell',
>
>  u'application/x-csource',
>
>  u'application/x-perl',
>
>  u'application/x-shell',
>
>  u'image/gif',
>
>  u'image/jpeg',
>
>  u'image/png',
>
>  u'image/tiff',
>
>  u'image/x-bitmap',
>
>  u'image/x-photocd',
>
>  u'image/x-portable-anymap',
>
>  u'image/x-portable-bitmap',
>
>  u'image/x-portable-graymap',
>
>  u'image/x-portable-pixmap',
>
>  u'image/x-sgi-rgb',
>
>  u'image/x-sun-raster',
>
>  u'image/x-xbitmap',
>
>  u'image/x-xpixmap',
>
>  u'image/x-xwindowdump',
>
>  u'text/css',
>
>  u'text/html',
>
>  u'text/plain'],
>'finishings-default': 3,
>'finishings-supported': [3],
>'generated-natural-language-supported':
> [u'en-us'],
>'ipp-versions-supported': [u'1.0',
>   u'1.1',
>   u'2.0',
>   u'2.1'],
>'ippget-event-life': 15,
>'job-creation-attributes-supported':
> [u'c

[Touch-packages] [Bug 1762314] Re: Sound output too low

2018-06-10 Thread Vanja D
Identical symptoms, package version, distro version, also ALC298, also
tried windows, only difference is computer model (Lenovo T570).
Confirmed on two identical computers with identical setups. Sorry, don't
know how to generate a new report or add debug info.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1762314

Title:
  Sound output too low

Status in alsa-driver package in Ubuntu:
  Confirmed

Bug description:
  Sound output on lenovo p51s is too low. No option to go above 100% in volume 
settings. Download pulse audio volume control to raise application and output 
volume to 153%, which helps to some extent, but then leads to distortion. 
  Was running windows 10 on same system and audio was loud enough!
  Also after this morning
  s update, the volume keys no longer work, even after re-mapping them in 
shortcuts.3

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: alsa-base 1.0.25+dfsg-0ubuntu5
  ProcVersionSignature: Ubuntu 4.15.0-13.14-generic 4.15.10
  Uname: Linux 4.15.0-13-generic x86_64
  ApportVersion: 2.20.9-0ubuntu4
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  jatin  2098 F pulseaudio
  CurrentDesktop: Budgie:GNOME
  Date: Sun Apr  8 22:50:04 2018
  InstallationDate: Installed on 2018-03-23 (17 days ago)
  InstallationMedia: Ubuntu-Budgie 18.04 LTS "Bionic Beaver" - Alpha amd64 
(20180307.1)
  PackageArchitecture: all
  SourcePackage: alsa-driver
  Symptom: audio
  Symptom_AlsaPlaybackTest: ALSA playback test through plughw:PCH successful
  Symptom_Card: Built-in Audio - HDA Intel PCH
  Symptom_Jack: Speaker, Internal
  Symptom_PulsePlaybackTest: PulseAudio playback test successful
  Symptom_Type: High background noise, or volume is too low
  Title: [20HCS06601, Realtek ALC298, Speaker, Internal] Background noise or 
low volume
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 10/03/2017
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N1VET36W (1.26 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20HCS06601
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0J40697 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN1VET36W(1.26):bd10/03/2017:svnLENOVO:pn20HCS06601:pvrThinkPadP51s:rvnLENOVO:rn20HCS06601:rvrSDK0J40697WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad P51s
  dmi.product.name: 20HCS06601
  dmi.product.version: ThinkPad P51s
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1762314/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1768232] Re: [HP Compaq dx2080 Microtower PC] Stuck at Ubuntu 18.04 logo while booting after installing

2018-06-06 Thread d a i s y
** Changed in: xorg (Ubuntu)
   Status: Incomplete => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1768232

Title:
  [HP Compaq dx2080 Microtower PC] Stuck at Ubuntu 18.04 logo while
  booting after installing

Status in xorg package in Ubuntu:
  Fix Released

Bug description:
  My system stuck at ubuntu logo while booting. This issue occurred only
  after installing it, not when I choose 'Try without Installing'. This
  doesn't happen in 16.04.4.

  xrandr
  xrandr: Failed to get size of gamma for output default
  Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
  default connected primary 1024x768+0+0 0mm x 0mm
     1024x768  76.00*

  Output of sudo lshw -c display

  *-display UNCLAIMED
     description: VGA compatible controller
     product: 82945G/GZ Integrated Graphics Controller
     vendor: Intel Corporation
     physical id: 2
     bus info: pci@:00:02.0
     version: 02
     width: 32 bits
     clock: 33MHz
     capabilities: msi pm vga_controller bus_master cap_list
     configuration: latency=0
     resources: memory:e200-e207 ioport:c000(size=8) 
memory:d000-dfff memory:e208-e20b memory:c-d

  WORKAROUND: Using the following kernel boot parameter allows me to boot but 
the maximum resolution is limited to 1024x768:
  nomodeset

  WORKAROUND: Edit the file /etc/gdm3/custom.conf and change:
  #WaylandEnable=false

  to:
  WaylandEnable=false

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: xorg 1:7.7+19ubuntu7
  ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
  Uname: Linux 4.15.0-20-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Tue May  1 17:16:20 2018
  DistUpgraded: Fresh install
  DistroCodename: bionic
  DistroVariant: ubuntu
  ExtraDebuggingInterest: I just need to know a workaround
  GraphicsCard:
   Intel Corporation 82945G/GZ Integrated Graphics Controller [8086:2772] (rev 
02) (prog-if 00 [VGA controller])
     Subsystem: Hewlett-Packard Company 82945G/GZ Integrated Graphics 
Controller [103c:302a]
  InstallationDate: Installed on 2018-05-01 (0 days ago)
  InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
  MachineType: Hewlett-Packard HP dx2080 MT(KS826PA)
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_IN
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-20-generic 
root=UUID=7ec4f610-9b62-44f3-867d-01abd93de14d ro quiet splash nomodeset 
vt.handoff=1
  Renderer: Software
  SourcePackage: xorg
  UpgradeStatus: No upgrade log present (probably fresh install)
  XorgConf:
   Section "Device"
    Identifier "Intel Graphics"
    Driver "intel"
    Option "AccelMethod" "uxa"
   EndSection
  dmi.bios.date: 11/28/2007
  dmi.bios.vendor: Award Software International, Inc.
  dmi.bios.version: V1.03
  dmi.board.name: 0AD8h
  dmi.board.vendor: Board Manufacturer
  dmi.chassis.asset.tag: INA8100LFY
  dmi.chassis.type: 3
  dmi.chassis.vendor: Hewlett-Packard
  dmi.modalias: 
dmi:bvnAwardSoftwareInternational,Inc.:bvrV1.03:bd11/28/2007:svnHewlett-Packard:pnHPdx2080MT(KS826PA):pvr:rvnBoardManufacturer:rn0AD8h:rvr:cvnHewlett-Packard:ct3:cvr:
  dmi.product.name: HP dx2080 MT(KS826PA)
  dmi.sys.vendor: Hewlett-Packard
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.91+git1804271336.50426f~oibaf~b
  version.libgl1-mesa-dri: libgl1-mesa-dri 18.2~git1804301930.1c5f4f~oibaf~b
  version.libgl1-mesa-glx: libgl1-mesa-glx 18.2~git1804301930.1c5f4f~oibaf~b
  version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.0.1-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20171229-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1768232/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1768232] Re: [HP Compaq dx2080 Microtower PC] Stuck at Ubuntu 18.04 logo while booting after installing

2018-06-05 Thread d a i s y
Shane Semanek

I've tried disabling Wayland in GDM3.

sudo vi /etc/gdm3/custom.conf

Change #WaylandEnable=false to WaylandEnable=false and reboot

It worked !

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1768232

Title:
  [HP Compaq dx2080 Microtower PC] Stuck at Ubuntu 18.04 logo while
  booting after installing

Status in xorg package in Ubuntu:
  Incomplete

Bug description:
  My system stuck at ubuntu logo while booting. This issue occurred only
  after installing it, not when I choose 'Try without Installing'. This
  doesn't happen in 16.04.4.

  xrandr
  xrandr: Failed to get size of gamma for output default
  Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
  default connected primary 1024x768+0+0 0mm x 0mm
     1024x768  76.00*

  Output of sudo lshw -c display

  *-display UNCLAIMED
     description: VGA compatible controller
     product: 82945G/GZ Integrated Graphics Controller
     vendor: Intel Corporation
     physical id: 2
     bus info: pci@:00:02.0
     version: 02
     width: 32 bits
     clock: 33MHz
     capabilities: msi pm vga_controller bus_master cap_list
     configuration: latency=0
     resources: memory:e200-e207 ioport:c000(size=8) 
memory:d000-dfff memory:e208-e20b memory:c-d

  WORKAROUND: Using the following kernel boot parameter allows me to boot but 
the maximum resolution is limited to 1024x768:
  nomodeset

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: xorg 1:7.7+19ubuntu7
  ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
  Uname: Linux 4.15.0-20-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Tue May  1 17:16:20 2018
  DistUpgraded: Fresh install
  DistroCodename: bionic
  DistroVariant: ubuntu
  ExtraDebuggingInterest: I just need to know a workaround
  GraphicsCard:
   Intel Corporation 82945G/GZ Integrated Graphics Controller [8086:2772] (rev 
02) (prog-if 00 [VGA controller])
     Subsystem: Hewlett-Packard Company 82945G/GZ Integrated Graphics 
Controller [103c:302a]
  InstallationDate: Installed on 2018-05-01 (0 days ago)
  InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
  MachineType: Hewlett-Packard HP dx2080 MT(KS826PA)
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_IN
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-20-generic 
root=UUID=7ec4f610-9b62-44f3-867d-01abd93de14d ro quiet splash nomodeset 
vt.handoff=1
  Renderer: Software
  SourcePackage: xorg
  UpgradeStatus: No upgrade log present (probably fresh install)
  XorgConf:
   Section "Device"
    Identifier "Intel Graphics"
    Driver "intel"
    Option "AccelMethod" "uxa"
   EndSection
  dmi.bios.date: 11/28/2007
  dmi.bios.vendor: Award Software International, Inc.
  dmi.bios.version: V1.03
  dmi.board.name: 0AD8h
  dmi.board.vendor: Board Manufacturer
  dmi.chassis.asset.tag: INA8100LFY
  dmi.chassis.type: 3
  dmi.chassis.vendor: Hewlett-Packard
  dmi.modalias: 
dmi:bvnAwardSoftwareInternational,Inc.:bvrV1.03:bd11/28/2007:svnHewlett-Packard:pnHPdx2080MT(KS826PA):pvr:rvnBoardManufacturer:rn0AD8h:rvr:cvnHewlett-Packard:ct3:cvr:
  dmi.product.name: HP dx2080 MT(KS826PA)
  dmi.sys.vendor: Hewlett-Packard
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.91+git1804271336.50426f~oibaf~b
  version.libgl1-mesa-dri: libgl1-mesa-dri 18.2~git1804301930.1c5f4f~oibaf~b
  version.libgl1-mesa-glx: libgl1-mesa-glx 18.2~git1804301930.1c5f4f~oibaf~b
  version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.0.1-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20171229-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1768232/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1768232] Re: [HP Compaq dx2080 Microtower PC] Stuck at Ubuntu 18.04 logo while booting after installing

2018-06-05 Thread d a i s y
Christopher M. Penalver

1. I've tried debugging kernel boot option other than nomodeset but it did not 
work, it shows started all the services and then pause there, no process after 
then.
2. I've installed kernel 4.16 and 4.17 but it also didn't work and I have to 
boot up with nomodeset option.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1768232

Title:
  [HP Compaq dx2080 Microtower PC] Stuck at Ubuntu 18.04 logo while
  booting after installing

Status in xorg package in Ubuntu:
  Incomplete

Bug description:
  My system stuck at ubuntu logo while booting. This issue occurred only
  after installing it, not when I choose 'Try without Installing'. This
  doesn't happen in 16.04.4.

  xrandr
  xrandr: Failed to get size of gamma for output default
  Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
  default connected primary 1024x768+0+0 0mm x 0mm
     1024x768  76.00*

  Output of sudo lshw -c display

  *-display UNCLAIMED
     description: VGA compatible controller
     product: 82945G/GZ Integrated Graphics Controller
     vendor: Intel Corporation
     physical id: 2
     bus info: pci@:00:02.0
     version: 02
     width: 32 bits
     clock: 33MHz
     capabilities: msi pm vga_controller bus_master cap_list
     configuration: latency=0
     resources: memory:e200-e207 ioport:c000(size=8) 
memory:d000-dfff memory:e208-e20b memory:c-d

  WORKAROUND: Using the following kernel boot parameter allows me to boot but 
the maximum resolution is limited to 1024x768:
  nomodeset

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: xorg 1:7.7+19ubuntu7
  ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
  Uname: Linux 4.15.0-20-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Tue May  1 17:16:20 2018
  DistUpgraded: Fresh install
  DistroCodename: bionic
  DistroVariant: ubuntu
  ExtraDebuggingInterest: I just need to know a workaround
  GraphicsCard:
   Intel Corporation 82945G/GZ Integrated Graphics Controller [8086:2772] (rev 
02) (prog-if 00 [VGA controller])
     Subsystem: Hewlett-Packard Company 82945G/GZ Integrated Graphics 
Controller [103c:302a]
  InstallationDate: Installed on 2018-05-01 (0 days ago)
  InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
  MachineType: Hewlett-Packard HP dx2080 MT(KS826PA)
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_IN
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-20-generic 
root=UUID=7ec4f610-9b62-44f3-867d-01abd93de14d ro quiet splash nomodeset 
vt.handoff=1
  Renderer: Software
  SourcePackage: xorg
  UpgradeStatus: No upgrade log present (probably fresh install)
  XorgConf:
   Section "Device"
    Identifier "Intel Graphics"
    Driver "intel"
    Option "AccelMethod" "uxa"
   EndSection
  dmi.bios.date: 11/28/2007
  dmi.bios.vendor: Award Software International, Inc.
  dmi.bios.version: V1.03
  dmi.board.name: 0AD8h
  dmi.board.vendor: Board Manufacturer
  dmi.chassis.asset.tag: INA8100LFY
  dmi.chassis.type: 3
  dmi.chassis.vendor: Hewlett-Packard
  dmi.modalias: 
dmi:bvnAwardSoftwareInternational,Inc.:bvrV1.03:bd11/28/2007:svnHewlett-Packard:pnHPdx2080MT(KS826PA):pvr:rvnBoardManufacturer:rn0AD8h:rvr:cvnHewlett-Packard:ct3:cvr:
  dmi.product.name: HP dx2080 MT(KS826PA)
  dmi.sys.vendor: Hewlett-Packard
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.91+git1804271336.50426f~oibaf~b
  version.libgl1-mesa-dri: libgl1-mesa-dri 18.2~git1804301930.1c5f4f~oibaf~b
  version.libgl1-mesa-glx: libgl1-mesa-glx 18.2~git1804301930.1c5f4f~oibaf~b
  version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.0.1-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20171229-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1768232/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1768610] Re: leftover conffile forces GNOME is software rendering

2018-05-23 Thread Martin D. Weinberg
Sebastien: Yes, that is precisely the issue!  Took me an afternoon of
sleuthing to figure it out.

Emiliano: You might want to find out if any package is providing that
file (e.g. dpkg -S 20-intel-graphics.conf) and delete that file if it
turns out to be orphaned.  I do not that file, but I do have xserver-
xorg-video-intel installed.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to nux in Ubuntu.
https://bugs.launchpad.net/bugs/1768610

Title:
  leftover conffile forces GNOME is software rendering

Status in nux package in Ubuntu:
  Confirmed

Bug description:
  After an upgrade from 17.10 to 18.04, I noticed that all gnome windows
  animations were gone.  After some digging, it seems that gnome-session
  incorrectly assumes that my graphics has no acceleration, when in fact
  it does: it's a i5-2520M CPU @ 2.50GHz with Intel integrated graphics
  (i915 driver).

  I've tried this with and without the xserver-xorg-video-intel package
  (a.k.a. Intel driver) with the same behavior.

  The output of gnome-session-check-accelerated is: llvmpipe (LLVM 6.0,
  256 bits)  however the system should have DRM 2.0 capability.

  GL checks (e.g. glxinfo, glxgears produce the expected output from a
  working DRM system).

  mesa-utils and mesa-utils-extra are both installed.

  I can't find a work around.  Perhaps there is something wrong with my
  install/upgrade?

  Everything else works fine, although the graphical transitions are no
  longer smooth.  But it would be nice to restore the expected behavior.

  I have attached the log of 'journalctl -b0'

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: gnome-session 3.28.1-0ubuntu2
  ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
  Uname: Linux 4.15.0-20-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Wed May  2 13:06:00 2018
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2016-04-22 (739 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 
(20160420.1)
  ProcEnviron:
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: gnome-session
  UpgradeStatus: Upgraded to bionic on 2018-04-27 (5 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nux/+bug/1768610/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1768232] Re: Stuck at ubuntu logo while booting after installing Ubuntu 18.04 (i915 driver issue)

2018-05-08 Thread d a i s y
** Summary changed:

- i915 driver issue in Ubuntu 18.04
+ Stuck at ubuntu logo while booting after installing Ubuntu 18.04 (i915 driver 
issue)

** Summary changed:

- Stuck at ubuntu logo while booting after installing Ubuntu 18.04 (i915 driver 
issue)
+ Stuck at ubuntu logo while booting after installing Ubuntu 18.04 (Resolution 
1024x768 after nomodeset, i915 driver issue)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1768232

Title:
  Stuck at ubuntu logo while booting after installing Ubuntu 18.04
  (Resolution 1024x768 after nomodeset, i915 driver issue)

Status in xorg package in Ubuntu:
  Confirmed

Bug description:
  My system stuck at ubuntu logo while booting. To resolve it, I've set
  nomodeset.

  But now it occurs a resolution issue to 1024x768. Here are the
  necessary information:

  lspci -nnk | grep -iA2 vga
  00:02.0 VGA compatible controller [0300]: Intel Corporation 82945G/GZ 
Integrated Graphics Controller [8086:2772] (rev 02)
  Subsystem: Hewlett-Packard Company 82945G/GZ Integrated Graphics 
Controller [103c:302a]
  Kernel modules: i915, intelfb

  and

  xrandr
  xrandr: Failed to get size of gamma for output default
  Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
  default connected primary 1024x768+0+0 0mm x 0mm
     1024x768  76.00*

  Output of sudo lshw -c display

  *-display UNCLAIMED
     description: VGA compatible controller
     product: 82945G/GZ Integrated Graphics Controller
     vendor: Intel Corporation
     physical id: 2
     bus info: pci@:00:02.0
     version: 02
     width: 32 bits
     clock: 33MHz
     capabilities: msi pm vga_controller bus_master cap_list
     configuration: latency=0
     resources: memory:e200-e207 ioport:c000(size=8) 
memory:d000-dfff memory:e208-e20b memory:c-d

  This issue occurred only after installing it, not when I choose 'Try
  without Installing', I don't need to set nomodeset in that case.

  Intel Graphics Update Tool shows:

  Checking if Intel graphics card available...
    • checking for i915 module in /sys/module
    • i915 module found
  Checking if Intel graphics card available... OK
  Retrieving information from 01.org...
    • fetching https://download.01.org/gfx/ilg-config.cfg
    • saving to /home/test/.ilg-config
    • fetched 1626 bytes
    • fetched 9818 bytes
    • fetched 12301 bytes
    • looking up [Ubuntu bionic] configuration
  Retrieving information from 01.org... OK
  Checking distribution... Failed

  
  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: xorg 1:7.7+19ubuntu7
  ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
  Uname: Linux 4.15.0-20-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Tue May  1 17:16:20 2018
  DistUpgraded: Fresh install
  DistroCodename: bionic
  DistroVariant: ubuntu
  ExtraDebuggingInterest: I just need to know a workaround
  GraphicsCard:
   Intel Corporation 82945G/GZ Integrated Graphics Controller [8086:2772] (rev 
02) (prog-if 00 [VGA controller])
     Subsystem: Hewlett-Packard Company 82945G/GZ Integrated Graphics 
Controller [103c:302a]
  InstallationDate: Installed on 2018-05-01 (0 days ago)
  InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
  MachineType: Hewlett-Packard HP dx2080 MT(KS826PA)
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_IN
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-20-generic 
root=UUID=7ec4f610-9b62-44f3-867d-01abd93de14d ro quiet splash nomodeset 
vt.handoff=1
  Renderer: Software
  SourcePackage: xorg
  UpgradeStatus: No upgrade log present (probably fresh install)
  XorgConf:
   Section "Device"
    Identifier "Intel Graphics"
    Driver "intel"
    Option "AccelMethod" "uxa"
   EndSection
  dmi.bios.date: 11/28/2007
  dmi.bios.vendor: Award Software International, Inc.
  dmi.bios.version: V1.03
  dmi.board.name: 0AD8h
  dmi.board.vendor: Board Manufacturer
  dmi.chassis.asset.tag: INA8100LFY
  dmi.chassis.type: 3
  dmi.chassis.vendor: Hewlett-Packard
  dmi.modalias: 
dmi:bvnAwardSoftwareInternational,Inc.:bvrV1.03:bd11/28/2007:svnHewlett-Packard:pnHPdx2080MT(KS826PA):pvr:rvnBoardManufacturer:rn0AD8h:rvr:cvnHewlett-Packard:ct3:cvr:
  dmi.product.name: HP dx2080 MT(KS826PA)
  dmi.sys.vendor: Hewlett-Packard
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.91+git1804271336.50426f~oibaf~b
  version.libgl1-mesa-dri: libgl1-mesa-dri 18.2~git1804301930.1c5f4f~oibaf~b
  version.libgl1-mesa-glx: libgl1-mesa-glx 18.2~git1804301930.1c5f4f~oibaf~b
  version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4
  

[Touch-packages] [Bug 1762539] [NEW] package avahi-dnsconfd 0.6.32~rc+dfsg-1ubuntu2 failed to install/upgrade: subprocess new pre-removal script returned error exit status 1

2018-04-09 Thread Alan D. Jackson
*** This bug is a duplicate of bug 1760128 ***
https://bugs.launchpad.net/bugs/1760128

Public bug reported:

this problem occurred during a routine system and/or application package
update.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: avahi-dnsconfd 0.6.32~rc+dfsg-1ubuntu2
ProcVersionSignature: Ubuntu 4.13.0-38.43~16.04.1-generic 4.13.16
Uname: Linux 4.13.0-38-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
Date: Mon Apr  9 15:06:39 2018
ErrorMessage: subprocess new pre-removal script returned error exit status 1
InstallationDate: Installed on 2018-03-09 (30 days ago)
InstallationMedia: Ubuntu-MATE 16.04.3 LTS "Xenial Xerus" - Release amd64 
(20170801)
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.4
 apt  1.2.26
SourcePackage: avahi
Title: package avahi-dnsconfd 0.6.32~rc+dfsg-1ubuntu2 failed to 
install/upgrade: subprocess new pre-removal script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: avahi (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package xenial

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to avahi in Ubuntu.
https://bugs.launchpad.net/bugs/1762539

Title:
  package avahi-dnsconfd 0.6.32~rc+dfsg-1ubuntu2 failed to
  install/upgrade: subprocess new pre-removal script returned error exit
  status 1

Status in avahi package in Ubuntu:
  New

Bug description:
  this problem occurred during a routine system and/or application
  package update.

  ProblemType: Package
  DistroRelease: Ubuntu 16.04
  Package: avahi-dnsconfd 0.6.32~rc+dfsg-1ubuntu2
  ProcVersionSignature: Ubuntu 4.13.0-38.43~16.04.1-generic 4.13.16
  Uname: Linux 4.13.0-38-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.15
  Architecture: amd64
  Date: Mon Apr  9 15:06:39 2018
  ErrorMessage: subprocess new pre-removal script returned error exit status 1
  InstallationDate: Installed on 2018-03-09 (30 days ago)
  InstallationMedia: Ubuntu-MATE 16.04.3 LTS "Xenial Xerus" - Release amd64 
(20170801)
  RelatedPackageVersions:
   dpkg 1.18.4ubuntu1.4
   apt  1.2.26
  SourcePackage: avahi
  Title: package avahi-dnsconfd 0.6.32~rc+dfsg-1ubuntu2 failed to 
install/upgrade: subprocess new pre-removal script returned error exit status 1
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/avahi/+bug/1762539/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1660619] Re: kernel: [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe B

2017-11-28 Thread D-nl-k
Got this error, too. 2 year anniversary is near and nobody seems to
care. The best would be to move away from this Intel Graphics crap.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1660619

Title:
  kernel: [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update
  failure on pipe B

Status in xorg package in Ubuntu:
  Confirmed

Bug description:
  I've a dual monitor setup and I'm running latest version of kubuntu.

  After a few days of uptime the desktop becomes so slow that I've to
  reboot it.

  In the log I find those errors, I don't know if they are related:

  kernel: [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update
  failure on pipe B (start=150051 end=150052) time 110 us, min 1073, max
  1079, scanline start 1072, end 1080

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: xorg 1:7.7+13ubuntu4
  ProcVersionSignature: Ubuntu 4.8.0-34.36-generic 4.8.11
  Uname: Linux 4.8.0-34-generic x86_64
  ApportVersion: 2.20.3-0ubuntu8.2
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  Date: Tue Jan 31 14:06:17 2017
  DistUpgraded: 2016-10-16 19:45:53,200 DEBUG Running PostInstallScript: 
'./xorg_fix_proprietary.py'
  DistroCodename: yakkety
  DistroVariant: ubuntu
  DkmsStatus:
   bbswitch, 0.8, 4.8.0-30-generic, x86_64: installed
   bbswitch, 0.8, 4.8.0-32-generic, x86_64: installed
   bbswitch, 0.8, 4.8.0-34-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation HD Graphics 530 [8086:1912] (rev 06) (prog-if 00 [VGA 
controller])
 Subsystem: Micro-Star International Co., Ltd. [MSI] HD Graphics 530 
[1462:7978]
  InstallationDate: Installed on 2013-04-25 (1376 days ago)
  InstallationMedia: Kubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
  LightdmGreeterLogOld:
   QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such 
file or directory
   QFileSystemWatcher: failed to add paths: /var/lib/lightdm/.config/ibus/bus
   Bus::open: Can not get ibus-daemon's address. 
   IBusInputContext::createInputContext: no connection to ibus-daemon 
   file:///usr/share/kde4/apps/lightdm-kde-greeter/themes/userbar/main.qml:135: 
Unable to assign [undefined] to QString usersession
  MachineType: MSI MS-7978
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.8.0-34-generic 
root=UUID=f848f2e6-9d53-4c75-823a-fa97cfe10aa6 ro
  SourcePackage: xorg
  UpgradeStatus: Upgraded to yakkety on 2016-10-16 (106 days ago)
  dmi.bios.date: 05/16/2016
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: A.60
  dmi.board.asset.tag: Default string
  dmi.board.name: Z170A GAMING M3 (MS-7978)
  dmi.board.vendor: MSI
  dmi.board.version: 2.0
  dmi.chassis.asset.tag: Default string
  dmi.chassis.type: 3
  dmi.chassis.vendor: MSI
  dmi.chassis.version: 2.0
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrA.60:bd05/16/2016:svnMSI:pnMS-7978:pvr2.0:rvnMSI:rnZ170AGAMINGM3(MS-7978):rvr2.0:cvnMSI:ct3:cvr2.0:
  dmi.product.name: MS-7978
  dmi.product.version: 2.0
  dmi.sys.vendor: MSI
  version.compiz: compiz N/A
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.70-1
  version.libgl1-mesa-dri: libgl1-mesa-dri 12.0.3-1ubuntu2
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 12.0.3-1ubuntu2
  version.xserver-xorg-core: xserver-xorg-core 2:1.18.4-1ubuntu6.1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.2-1ubuntu1
  version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20160706-1ubuntu1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-2
  xserver.bootTime: Sat Jan 28 11:57:37 2017
  xserver.configfile: default
  xserver.errors:
   Failed to load module "fbdev" (module does not exist, 0)
   Failed to load module "vesa" (module does not exist, 0)
   Failed to load module "fbdev" (module does not exist, 0)
   Failed to load module "vesa" (module does not exist, 0)
  xserver.logfile: /var/log/Xorg.0.log
  xserver.version: 2:1.18.4-1ubuntu6.1
  xserver.video_driver: modeset

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1660619/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1727770] [NEW] wayland does not have logic for a Lenovo laptop on the dock

2017-10-26 Thread Martin D. Weinberg
Public bug reported:

I have a Lenovo T440s (haswell) and an ultradock with external monitor.

If I resume on the dock, wayland seems to recognize the lid as closed
and suspends. The work around is to (1) open the lid, bring up the
display control tab and switch to single monitor, choose the external
one (on the DP); and (3) apply.  Then I can close the lid.

The laptop will boot correctly on the dock with the lid closed.

I tried changing the dconf parameter org.gnome.settings-
daemon.plugins.power to 'nothing' but that doesn't seem to matter.

Obviously, this is not a critical issue, but it sure is annoying.  This
should "just work".

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: libwayland-server0 1.14.0-1
Uname: Linux 4.13.9-041309-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.1
Architecture: amd64
CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Thu Oct 26 10:59:35 2017
Dependencies:
 gcc-7-base 7.2.0-8ubuntu3
 libc6 2.26-0ubuntu2
 libffi6 3.2.1-6
 libgcc1 1:7.2.0-8ubuntu3
DistUpgraded: 2017-10-20 11:39:46,873 DEBUG Running PostInstallScript: 
'./xorg_fix_proprietary.py'
DistroCodename: artful
DistroVariant: ubuntu
DkmsStatus:
 acpi-call, 1.1.0, 4.13.0-16-generic, x86_64: installed
 acpi-call, 1.1.0, 4.13.9-041309-generic, x86_64: installed
EcryptfsInUse: Yes
GraphicsCard:
 Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 
0b) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Haswell-ULT Integrated Graphics Controller [17aa:220c]
InstallationDate: Installed on 2016-05-06 (537 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
MachineType: LENOVO 20ARA0S100
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.9-041309-generic 
root=UUID=0a196d38-a419-4a42-b659-7108068e6ce5 ro quiet splash vt.handoff=7
SourcePackage: wayland
UpgradeStatus: Upgraded to artful on 2017-10-20 (5 days ago)
dmi.bios.date: 03/19/2014
dmi.bios.vendor: LENOVO
dmi.bios.version: GJET74WW (2.24 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20ARA0S100
dmi.board.vendor: LENOVO
dmi.board.version: Not Defined
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: 
dmi:bvnLENOVO:bvrGJET74WW(2.24):bd03/19/2014:svnLENOVO:pn20ARA0S100:pvrThinkPadT440s:rvnLENOVO:rn20ARA0S100:rvrNotDefined:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.family: ThinkPad T440s
dmi.product.name: 20ARA0S100
dmi.product.version: ThinkPad T440s
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.13.1+17.10.20170901-0ubuntu1
version.libdrm2: libdrm2 2.4.83-1
version.libgl1-mesa-dri: libgl1-mesa-dri 17.2.2-0ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 17.2.2-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.19.5-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

** Affects: wayland (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug artful ubuntu wayland-session

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to wayland in Ubuntu.
https://bugs.launchpad.net/bugs/1727770

Title:
  wayland does not have logic for a Lenovo laptop on the dock

Status in wayland package in Ubuntu:
  New

Bug description:
  I have a Lenovo T440s (haswell) and an ultradock with external
  monitor.

  If I resume on the dock, wayland seems to recognize the lid as closed
  and suspends. The work around is to (1) open the lid, bring up the
  display control tab and switch to single monitor, choose the external
  one (on the DP); and (3) apply.  Then I can close the lid.

  The laptop will boot correctly on the dock with the lid closed.

  I tried changing the dconf parameter org.gnome.settings-
  daemon.plugins.power to 'nothing' but that doesn't seem to matter.

  Obviously, this is not a critical issue, but it sure is annoying.
  This should "just work".

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: libwayland-server0 1.14.0-1
  Uname: Linux 4.13.9-041309-generic x86_64
  ApportVersion: 2.20.7-0ubuntu3.1
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Oct 26 10:59:35 2017
  Dependencies:
   gcc-7-base 7.2.0-8ubuntu3
   libc6 2.26-0ubuntu2
   libffi6 3.2.1-6
   libgcc1 1:7.2.0-8ubuntu3
  DistUpgraded: 2017-10-20 11:39:46,873 DEBUG Running PostInstallScript: 
'./xorg_fix_proprietary.py'
  DistroCodename: artful
  DistroVariant: ubuntu
  DkmsStatus:
   acpi-call, 1.1.0, 

[Touch-packages] [Bug 1721138] Re: APT update fail when using HTTPS

2017-10-17 Thread Carlos D. Gonzalez
Thanks Julian, I work for a company with thousands so the process of
migration all the servers is a little slow but based on or security team
we need to move all our HTTP traffic to HTTPS. That's the reason why I
filed the bug.

Also why trusty cant also handle modern HTTPS connections? Its end of
line is until 2019

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gnutls26 in Ubuntu.
https://bugs.launchpad.net/bugs/1721138

Title:
  APT update fail when using HTTPS

Status in gnutls26 package in Ubuntu:
  New

Bug description:
  ### Ubuntu Release
  root@:~# lsb_release -rd 
  Description:    Ubuntu 14.04.5 LTS
  Release:        14.04
  root@:~#

  ### Expected Behaviors

  Trusty’s version of apt should be able to pull updates from an
  internal mirror using the HTTPS protocol and a SHA256 certificate
  (please check the 2nd link at the end of this description)

  Note: Using the same configuration on Ubuntu Xenial works.

  ### Actual Behavior

  Apt error out with the error: gnutls_handshake() failed: The signature
  algorithm is not supported.

  ### Package Information
  Im not sure if the problem is actually with apt of with a library (I’m 
including libgnutls26 info as well)
  root@:~# apt-cache policy apt
  apt:
    Installed: 1.0.1ubuntu2.17
    Candidate: 1.0.1ubuntu2.17
    Version table:
   *** 1.0.1ubuntu2.17 0
          100 /var/lib/dpkg/status
  root@:~# 

  root@:~# apt-cache policy libgnutls26
  libgnutls26:
    Installed: 2.12.23-12ubuntu2.8
    Candidate: 2.12.23-12ubuntu2.8
    Version table:
   *** 2.12.23-12ubuntu2.8 0
          100 /var/lib/dpkg/status
  root@:~#

  ### Active sources
  root@:~# egrep -R -v '^#|^$' --include=\*.list /etc/apt/
  /etc/apt/sources.list:deb https:///ubuntu/test trusty main 
restricted universe multiverse
  root@:~# 

  ### Apt Update output

  root@:~# apt update -qq
  W: Failed to fetch https:///ubuntu/test/dists/trusty/main/binary-amd64/Packages  gnutls_handshake() 
failed: The signature algorithm is not supported.

  W: Failed to fetch https:///ubuntu/test/dists/trusty/restricted/binary-amd64/Packages
  gnutls_handshake() failed: The signature algorithm is not supported.

  W: Failed to fetch https:///ubuntu/test/dists/trusty/universe/binary-amd64/Packages
  gnutls_handshake() failed: The signature algorithm is not supported.

  W: Failed to fetch https:///ubuntu/test/dists/trusty/multiverse/binary-amd64/Packages
  gnutls_handshake() failed: The signature algorithm is not supported.

  W: Failed to fetch https:///ubuntu/test/dists/trusty/main/binary-i386/Packages
  gnutls_handshake() failed: The signature algorithm is not supported.

  W: Failed to fetch https:///ubuntu/test/dists/trusty/restricted/binary-i386/Packages
  gnutls_handshake() failed: The signature algorithm is not supported.

  W: Failed to fetch https:///ubuntu/test/dists/trusty/universe/binary-i386/Packages
  gnutls_handshake() failed: The signature algorithm is not supported.

  W: Failed to fetch https:///ubuntu/test/dists/trusty/multiverse/binary-i386/Packages
  gnutls_handshake() failed: The signature algorithm is not supported.

  E: Some index files failed to download. They have been ignored, or old ones 
used instead.
  root@:~#

  # NMAP output of the current allowed ciphers
  root@:~# nmap --script ssl-enum-ciphers -p 443

   

  Starting Nmap 6.40 ( http://nmap.org ) at 2017-10-03 21:07 GMT
  Nmap scan report for  ()
  Host is up (0.0039s latency).
  PORTSTATE SERVICE
  443/tcp open  https
  | ssl-enum-ciphers: 
  |   SSLv3: No supported ciphers found
  |   TLSv1.0: 
  | ciphers: 
  |   TLS_DHE_RSA_WITH_3DES_EDE_CBC_SHA - strong
  |   TLS_DHE_RSA_WITH_AES_128_CBC_SHA - strong
  |   TLS_DHE_RSA_WITH_AES_256_CBC_SHA - strong
  |   TLS_DHE_RSA_WITH_CAMELLIA_128_CBC_SHA - strong
  |   TLS_DHE_RSA_WITH_CAMELLIA_256_CBC_SHA - strong
  |   TLS_DHE_RSA_WITH_SEED_CBC_SHA - strong
  |   TLS_ECDHE_RSA_WITH_3DES_EDE_CBC_SHA - strong
  |   TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA - strong
  |   TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA - strong
  |   TLS_ECDHE_RSA_WITH_RC4_128_SHA - strong
  |   TLS_RSA_WITH_3DES_EDE_CBC_SHA - strong
  |   TLS_RSA_WITH_AES_128_CBC_SHA - strong
  |   TLS_RSA_WITH_AES_256_CBC_SHA - strong
  |   TLS_RSA_WITH_CAMELLIA_128_CBC_SHA - strong
  |   TLS_RSA_WITH_CAMELLIA_256_CBC_SHA - strong
  |   TLS_RSA_WITH_RC4_128_MD5 - strong
  |   TLS_RSA_WITH_RC4_128_SHA - strong
  |   TLS_RSA_WITH_SEED_CBC_SHA - strong
  | compressors: 
  |   NULL
  |   TLSv1.1: 
  | ciphers: 
  |   TLS_DHE_RSA_WITH_3DES_EDE_CBC_SHA - strong
  |   TLS_DHE_RSA_WITH_AES_128_CBC_SHA - strong
  |   TLS_DHE_RSA_WITH_AES_256_CBC_SHA - strong
  |   TLS_DHE_RSA_WITH_CAMELLIA_128_CBC_SHA - strong
  |   

[Touch-packages] [Bug 1723552] [NEW] package libc-bin 2.19-0ubuntu6.13 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2

2017-10-13 Thread Eduardo D. Dequilla
Public bug reported:

After logging in to Ubuntu this error appear on the screen. System
program error.

ProblemType: Package
DistroRelease: Ubuntu 14.04
Package: libc-bin 2.19-0ubuntu6.13
ProcVersionSignature: Ubuntu 4.4.0-97.120~14.04.1-generic 4.4.87
Uname: Linux 4.4.0-97-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.25
Architecture: amd64
Date: Fri Oct 13 21:03:54 2017
Dependencies:
 gcc-4.9-base 4.9.3-0ubuntu4
 libc6 2.19-0ubuntu6.13
 libgcc1 1:4.9.3-0ubuntu4
 multiarch-support 2.19-0ubuntu6.13
DuplicateSignature: package:libc-bin:2.19-0ubuntu6.13:subprocess installed 
post-installation script returned error exit status 2
ErrorMessage: subprocess installed post-installation script returned error exit 
status 2
InstallationDate: Installed on 2017-10-13 (0 days ago)
InstallationMedia: Ubuntu 14.04.5 LTS "Trusty Tahr" - Release amd64 (20160803)
RelatedPackageVersions:
 dpkg 1.17.5ubuntu5.7
 apt  1.0.1ubuntu2.17
SourcePackage: eglibc
Title: package libc-bin 2.19-0ubuntu6.13 failed to install/upgrade: subprocess 
installed post-installation script returned error exit status 2
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: eglibc (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package trusty

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to eglibc in Ubuntu.
https://bugs.launchpad.net/bugs/1723552

Title:
  package libc-bin 2.19-0ubuntu6.13 failed to install/upgrade:
  subprocess installed post-installation script returned error exit
  status 2

Status in eglibc package in Ubuntu:
  New

Bug description:
  After logging in to Ubuntu this error appear on the screen. System
  program error.

  ProblemType: Package
  DistroRelease: Ubuntu 14.04
  Package: libc-bin 2.19-0ubuntu6.13
  ProcVersionSignature: Ubuntu 4.4.0-97.120~14.04.1-generic 4.4.87
  Uname: Linux 4.4.0-97-generic x86_64
  ApportVersion: 2.14.1-0ubuntu3.25
  Architecture: amd64
  Date: Fri Oct 13 21:03:54 2017
  Dependencies:
   gcc-4.9-base 4.9.3-0ubuntu4
   libc6 2.19-0ubuntu6.13
   libgcc1 1:4.9.3-0ubuntu4
   multiarch-support 2.19-0ubuntu6.13
  DuplicateSignature: package:libc-bin:2.19-0ubuntu6.13:subprocess installed 
post-installation script returned error exit status 2
  ErrorMessage: subprocess installed post-installation script returned error 
exit status 2
  InstallationDate: Installed on 2017-10-13 (0 days ago)
  InstallationMedia: Ubuntu 14.04.5 LTS "Trusty Tahr" - Release amd64 (20160803)
  RelatedPackageVersions:
   dpkg 1.17.5ubuntu5.7
   apt  1.0.1ubuntu2.17
  SourcePackage: eglibc
  Title: package libc-bin 2.19-0ubuntu6.13 failed to install/upgrade: 
subprocess installed post-installation script returned error exit status 2
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/eglibc/+bug/1723552/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1721138] [NEW] APT update fail when using HTTPS

2017-10-03 Thread Carlos D. Gonzalez
Public bug reported:

### Ubuntu Release
root@:~# lsb_release -rd 
Description:    Ubuntu 14.04.5 LTS
Release:        14.04
root@:~#

### Expected Behaviors

Trusty’s version of apt should be able to pull updates from an internal
mirror using the HTTPS protocol and a SHA256 certificate (please check
the 2nd link at the end of this description)

Note: Using the same configuration on Ubuntu Xenial works.

### Actual Behavior

Apt error out with the error: gnutls_handshake() failed: The signature
algorithm is not supported.

### Package Information
Im not sure if the problem is actually with apt of with a library (I’m 
including libgnutls26 info as well)
root@:~# apt-cache policy apt
apt:
  Installed: 1.0.1ubuntu2.17
  Candidate: 1.0.1ubuntu2.17
  Version table:
 *** 1.0.1ubuntu2.17 0
        100 /var/lib/dpkg/status
root@:~# 

root@:~# apt-cache policy libgnutls26
libgnutls26:
  Installed: 2.12.23-12ubuntu2.8
  Candidate: 2.12.23-12ubuntu2.8
  Version table:
 *** 2.12.23-12ubuntu2.8 0
        100 /var/lib/dpkg/status
root@:~#

### Active sources
root@:~# egrep -R -v '^#|^$' --include=\*.list /etc/apt/
/etc/apt/sources.list:deb https:///ubuntu/test trusty main 
restricted universe multiverse
root@:~# 

### Apt Update output

root@:~# apt update -qq
W: Failed to fetch https:///ubuntu/test/dists/trusty/main/binary-amd64/Packages  gnutls_handshake() 
failed: The signature algorithm is not supported.

W: Failed to fetch https:///ubuntu/test/dists/trusty/restricted/binary-amd64/Packages
gnutls_handshake() failed: The signature algorithm is not supported.

W: Failed to fetch https:///ubuntu/test/dists/trusty/universe/binary-amd64/Packages
gnutls_handshake() failed: The signature algorithm is not supported.

W: Failed to fetch https:///ubuntu/test/dists/trusty/multiverse/binary-amd64/Packages
gnutls_handshake() failed: The signature algorithm is not supported.

W: Failed to fetch https:///ubuntu/test/dists/trusty/main/binary-i386/Packages
gnutls_handshake() failed: The signature algorithm is not supported.

W: Failed to fetch https:///ubuntu/test/dists/trusty/restricted/binary-i386/Packages
gnutls_handshake() failed: The signature algorithm is not supported.

W: Failed to fetch https:///ubuntu/test/dists/trusty/universe/binary-i386/Packages
gnutls_handshake() failed: The signature algorithm is not supported.

W: Failed to fetch https:///ubuntu/test/dists/trusty/multiverse/binary-i386/Packages
gnutls_handshake() failed: The signature algorithm is not supported.

E: Some index files failed to download. They have been ignored, or old ones 
used instead.
root@:~#

# NMAP output of the current allowed ciphers
root@:~# nmap --script ssl-enum-ciphers -p 443  

 

Starting Nmap 6.40 ( http://nmap.org ) at 2017-10-03 21:07 GMT
Nmap scan report for  ()
Host is up (0.0039s latency).
PORTSTATE SERVICE
443/tcp open  https
| ssl-enum-ciphers: 
|   SSLv3: No supported ciphers found
|   TLSv1.0: 
| ciphers: 
|   TLS_DHE_RSA_WITH_3DES_EDE_CBC_SHA - strong
|   TLS_DHE_RSA_WITH_AES_128_CBC_SHA - strong
|   TLS_DHE_RSA_WITH_AES_256_CBC_SHA - strong
|   TLS_DHE_RSA_WITH_CAMELLIA_128_CBC_SHA - strong
|   TLS_DHE_RSA_WITH_CAMELLIA_256_CBC_SHA - strong
|   TLS_DHE_RSA_WITH_SEED_CBC_SHA - strong
|   TLS_ECDHE_RSA_WITH_3DES_EDE_CBC_SHA - strong
|   TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA - strong
|   TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA - strong
|   TLS_ECDHE_RSA_WITH_RC4_128_SHA - strong
|   TLS_RSA_WITH_3DES_EDE_CBC_SHA - strong
|   TLS_RSA_WITH_AES_128_CBC_SHA - strong
|   TLS_RSA_WITH_AES_256_CBC_SHA - strong
|   TLS_RSA_WITH_CAMELLIA_128_CBC_SHA - strong
|   TLS_RSA_WITH_CAMELLIA_256_CBC_SHA - strong
|   TLS_RSA_WITH_RC4_128_MD5 - strong
|   TLS_RSA_WITH_RC4_128_SHA - strong
|   TLS_RSA_WITH_SEED_CBC_SHA - strong
| compressors: 
|   NULL
|   TLSv1.1: 
| ciphers: 
|   TLS_DHE_RSA_WITH_3DES_EDE_CBC_SHA - strong
|   TLS_DHE_RSA_WITH_AES_128_CBC_SHA - strong
|   TLS_DHE_RSA_WITH_AES_256_CBC_SHA - strong
|   TLS_DHE_RSA_WITH_CAMELLIA_128_CBC_SHA - strong
|   TLS_DHE_RSA_WITH_CAMELLIA_256_CBC_SHA - strong
|   TLS_DHE_RSA_WITH_SEED_CBC_SHA - strong
|   TLS_ECDHE_RSA_WITH_3DES_EDE_CBC_SHA - strong
|   TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA - strong
|   TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA - strong
|   TLS_ECDHE_RSA_WITH_RC4_128_SHA - strong
|   TLS_RSA_WITH_3DES_EDE_CBC_SHA - strong
|   TLS_RSA_WITH_AES_128_CBC_SHA - strong
|   TLS_RSA_WITH_AES_256_CBC_SHA - strong
|   TLS_RSA_WITH_CAMELLIA_128_CBC_SHA - strong
|   TLS_RSA_WITH_CAMELLIA_256_CBC_SHA - strong
|   TLS_RSA_WITH_RC4_128_MD5 - strong
|   TLS_RSA_WITH_RC4_128_SHA - strong
|   TLS_RSA_WITH_SEED_CBC_SHA - strong
| compressors: 
|   NULL
|   TLSv1.2: 
| ciphers: 
|   

[Touch-packages] [Bug 1164016] Re: restore type-ahead find

2017-09-11 Thread Max D
This is up to date again in 17.10

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-settings in Ubuntu.
https://bugs.launchpad.net/bugs/1164016

Title:
  restore type-ahead find

Status in Nautilus:
  Expired
Status in nautilus package in Ubuntu:
  Fix Released
Status in ubuntu-settings package in Ubuntu:
  Fix Released

Bug description:
  GNOME removed type-ahead find in Nautilus 3.6, not without
  controversy:

  https://mail.gnome.org/archives/nautilus-
  list/2012-August/msg2.html

  Now when you type in a Nautilus window, Nautilus immediately performs
  a search in the current directory and all its subdirectories.  I
  personally find this annoying.  If I want to search, I'll click the
  search icon.  Often I'm looking at a long directory listing and simply
  want to jump to a certain point in it, and type-ahead find works great
  for that.

  Would Ubuntu consider patching type-ahead find back in?

To manage notifications about this bug go to:
https://bugs.launchpad.net/nautilus/+bug/1164016/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1278223] Re: Mouse Flickering after adding 3rd Monitor

2017-09-06 Thread D. Charles Pyle
I had the latest DisplayLink driver and it still did the same thing to
me.  And it gets worse than that.  No errors are generated but the speed
is so slow it is almost unbearable whenever the DisplayLink device is in
use.  I could click the icon for Files to launch Nautilus from the Unity
favorites bar, and it would not appear for almost two whole minutes!
Disconnect the device and reboot, and all was fine with the world--
except that it wasn't.  I could not use my third monitor to do editing
work.

Unfortunately, it became easier just to remove Ubuntu from my system and
move to another distribution that does work with DisplayLink devices.
There were serious problems with power saving, too.  Suspend would crash
the machine rather than suspend to memory, and this was on a system that
I purchased because it was certified for Ubuntu!

In Fedora, the distribution I now am using exclusively, I still see
flickering when the mouse is moved to the top of the screen but the
flickering is bearable compared to the ungodly slowness on the screen
with that flickering, in Ubuntu 16.04.2.  I do not know what the problem
is on Ubuntu with DisplayLink devices but it was too unbearable, and
that is unfortunate because I really liked working in Ubuntu, with Unity
being my chosen interface.  But I hear that even Unity will be going
away.

I hope that one day the display bugs involving DisplayLink displays will
be fixed.  Until then, if I want to get work done, and not have to spend
time waiting between mouse clicks and app launches, I have to go
elsewhere for at least the time being.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1278223

Title:
  Mouse Flickering after adding 3rd Monitor

Status in X.Org X server:
  New
Status in xorg package in Ubuntu:
  Incomplete
Status in xorg package in Fedora:
  Unknown

Bug description:
  My issues is, after adding a 3rd monitor to Ubuntu 14.04, the mouse
  flickers (or blinks) when the cursor is on monitors one or two, but
  not 3.

  Monitor 1: 1440 x 900 - Laptop's Native Monitor
  Monitor 2: 1920 x 1080 - Laptop's HDMI Port's External Monitor
  Monitor 3: 1024 x 768 - SIIG USB 2.0 to VGA Pro Monitor

  Here's the video card that feeds my laptop's native monitor, monitor 2
  (hdmi).

  lspci | grep 'VGA\|Display'
  00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset 
Integrated Graphics Controller (rev 07)
  00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset 
Integrated Graphics Controller (rev 07)

  The 3rd Monitor is powered through a Display Link certified SIIG USB
  2.0 to VGA Pro adapter (A2H1320X1374 - not sure what this number, but
  it is a sticker on back of the device):

  lsusb -tv
  /:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/6p, 480M
  |__ Port 6: Dev 2, If 0, Class=Video, Driver=uvcvideo, 480M
  |__ Port 6: Dev 2, If 1, Class=Video, Driver=uvcvideo, 480M

  dmesg
  [1.688343] usb 2-1: New USB device found, idVendor=17e9, idProduct=02ee
  [1.688348] usb 2-1: New USB device strings: Mfr=1, Product=2, 
SerialNumber=3
  [1.688351] usb 2-1: Product: VGA Display Adapter
  [1.688353] usb 2-1: Manufacturer: DisplayLink
  [1.688356] usb 2-1: SerialNumber: 119785

  Additionally, unity-control-center crashes sometimes after I "Restore
  previous settings", after selecting a resolution too high. This
  freezed my laptop, requiring a hard reboot.

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: unity-control-center 14.04.1-0ubuntu5
  ProcVersionSignature: Ubuntu 3.13.0-8.27-generic 3.13.2
  Uname: Linux 3.13.0-8-generic x86_64
  NonfreeKernelModules: wl
  ApportVersion: 2.13.2-0ubuntu2
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Sun Feb  9 18:43:13 2014
  InstallationDate: Installed on 2014-02-02 (7 days ago)
  InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140202)
  SourcePackage: unity-control-center
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/xorg-server/+bug/1278223/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1715118] [NEW] cannot install libperl-dev:i386 on x64 system with already installed native perl and libperl-dev

2017-09-05 Thread D
Public bug reported:

There seems two problems
1) libperl-dev:i386 just conflicts with native libperl-dev. So apt-get install 
libperl-dev:i386 automatically removes libperl-dev
2) Even after this it still won't install due to conflict of dependent 
libperl5.22 packages (that required for Perl itself):
Unpacking libperl5.22:i386 (5.22.1-9) ...
dpkg: error processing archive 
/var/cache/apt/archives/libperl5.22_5.22.1-9_i386.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libperl5.22/changelog.Debian.gz', 
which is different from other instances of package libperl5.22:i386

The problem reason:  I want to crosscompile some C code linked to
libperl but cannot do this due to error above. Temporary removing native
libperl-dev would be acceptable workaround, but removing whole Perl is
not acceptable.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: libperl-dev:i386 5.22.1-9
ProcVersionSignature: Ubuntu 4.4.0-93.116-generic 4.4.79
Uname: Linux 4.4.0-93-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.10
Architecture: amd64
Date: Tue Sep  5 12:57:34 2017
InstallationDate: Installed on 2016-08-10 (390 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
PackageArchitecture: i386
SourcePackage: perl
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: perl (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: apport-bug i386 package perl x64 xenial

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to perl in Ubuntu.
https://bugs.launchpad.net/bugs/1715118

Title:
  cannot install libperl-dev:i386 on x64 system with already installed
  native perl and libperl-dev

Status in perl package in Ubuntu:
  New

Bug description:
  There seems two problems
  1) libperl-dev:i386 just conflicts with native libperl-dev. So apt-get 
install libperl-dev:i386 automatically removes libperl-dev
  2) Even after this it still won't install due to conflict of dependent 
libperl5.22 packages (that required for Perl itself):
  Unpacking libperl5.22:i386 (5.22.1-9) ...
  dpkg: error processing archive 
/var/cache/apt/archives/libperl5.22_5.22.1-9_i386.deb (--unpack):
   trying to overwrite shared '/usr/share/doc/libperl5.22/changelog.Debian.gz', 
which is different from other instances of package libperl5.22:i386

  The problem reason:  I want to crosscompile some C code linked to
  libperl but cannot do this due to error above. Temporary removing
  native libperl-dev would be acceptable workaround, but removing whole
  Perl is not acceptable.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: libperl-dev:i386 5.22.1-9
  ProcVersionSignature: Ubuntu 4.4.0-93.116-generic 4.4.79
  Uname: Linux 4.4.0-93-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.10
  Architecture: amd64
  Date: Tue Sep  5 12:57:34 2017
  InstallationDate: Installed on 2016-08-10 (390 days ago)
  InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 
(20160719)
  PackageArchitecture: i386
  SourcePackage: perl
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/perl/+bug/1715118/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1704628] Re: CUPS keeps crashing 17.04

2017-07-18 Thread Luc D.
I used the command line ubuntu-bug cups. I confirm I get the systematic
internal error pop-up at start-up and I have just submitted again a
report "cups-browsed crashed with SIGSEGV in__strcasecmp_l_avx()" but it
does not help much... . Please let me know how I can get you the "stack
trace", I am not familiar with bug reporting.

Thanks.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to cups in Ubuntu.
https://bugs.launchpad.net/bugs/1704628

Title:
  CUPS keeps crashing 17.04

Status in cups package in Ubuntu:
  Incomplete

Bug description:
  cupsd or cups-browser are systematically crashing at start-up. I tried to 
purge and reinstall cups without success. systemctrl status cups shows:
  cups.service - CUPS Scheduler
 Loaded: loaded (/lib/systemd/system/cups.service; enabled; vendor preset: 
enabled)
 Active: failed (Result: core-dump) since Sun 2017-07-16 16:58:10 CST; 45s 
ago
   Docs: man:cupsd(8)
Process: 14474 ExecStart=/usr/sbin/cupsd -l (code=dumped, signal=SEGV)
   Main PID: 14474 (code=dumped, signal=SEGV)

  Jul 16 16:58:10 my-desktop systemd[1]: Started CUPS Scheduler.
  Jul 16 16:58:10 my-desktop systemd[1]: cups.service: Main process exited, 
code=dumped, status=11/SEGV
  Jul 16 16:58:10 my-desktop systemd[1]: cups.service: Unit entered failed 
state.
  Jul 16 16:58:10 my-desktop systemd[1]: cups.service: Failed with result 
'core-dump'.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.04
  Package: cups 2.2.2-1ubuntu1
  ProcVersionSignature: Ubuntu 4.10.0-26.30-generic 4.10.17
  Uname: Linux 4.10.0-26-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia
  ApportVersion: 2.20.4-0ubuntu4.4
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Sun Jul 16 17:06:10 2017
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2017-07-02 (14 days ago)
  InstallationMedia: Ubuntu-GNOME 17.04 "Zesty Zapus" - Release amd64 (20170412)
  Lpstat: Error: command ['lpstat', '-v'] failed with exit code 1: lpstat: Bad 
file descriptor
  MachineType: System manufacturer System Product Name
  Papersize: a4
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-26-generic 
root=UUID=bf399cdf-9a52-46c0-9d61-daa2bc83cf2f ro quiet splash
  SourcePackage: cups
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/13/2013
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 2104
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: P8Z77-V PRO
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr2104:bd08/13/2013:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnP8Z77-VPRO:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: System Product Name
  dmi.product.version: System Version
  dmi.sys.vendor: System manufacturer

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1704628/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1704628] [NEW] CUPS keeps crashing 17.04

2017-07-16 Thread Luc D.
Public bug reported:

cupsd or cups-browser are systematically crashing at start-up. I tried to purge 
and reinstall cups without success. systemctrl status cups shows:
cups.service - CUPS Scheduler
   Loaded: loaded (/lib/systemd/system/cups.service; enabled; vendor preset: 
enabled)
   Active: failed (Result: core-dump) since Sun 2017-07-16 16:58:10 CST; 45s ago
 Docs: man:cupsd(8)
  Process: 14474 ExecStart=/usr/sbin/cupsd -l (code=dumped, signal=SEGV)
 Main PID: 14474 (code=dumped, signal=SEGV)

Jul 16 16:58:10 my-desktop systemd[1]: Started CUPS Scheduler.
Jul 16 16:58:10 my-desktop systemd[1]: cups.service: Main process exited, 
code=dumped, status=11/SEGV
Jul 16 16:58:10 my-desktop systemd[1]: cups.service: Unit entered failed state.
Jul 16 16:58:10 my-desktop systemd[1]: cups.service: Failed with result 
'core-dump'.

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: cups 2.2.2-1ubuntu1
ProcVersionSignature: Ubuntu 4.10.0-26.30-generic 4.10.17
Uname: Linux 4.10.0-26-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia
ApportVersion: 2.20.4-0ubuntu4.4
Architecture: amd64
CurrentDesktop: GNOME
Date: Sun Jul 16 17:06:10 2017
EcryptfsInUse: Yes
InstallationDate: Installed on 2017-07-02 (14 days ago)
InstallationMedia: Ubuntu-GNOME 17.04 "Zesty Zapus" - Release amd64 (20170412)
Lpstat: Error: command ['lpstat', '-v'] failed with exit code 1: lpstat: Bad 
file descriptor
MachineType: System manufacturer System Product Name
Papersize: a4
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-26-generic 
root=UUID=bf399cdf-9a52-46c0-9d61-daa2bc83cf2f ro quiet splash
SourcePackage: cups
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/13/2013
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 2104
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: P8Z77-V PRO
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr2104:bd08/13/2013:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnP8Z77-VPRO:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

** Affects: cups (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apparmor apport-bug zesty

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to cups in Ubuntu.
https://bugs.launchpad.net/bugs/1704628

Title:
  CUPS keeps crashing 17.04

Status in cups package in Ubuntu:
  New

Bug description:
  cupsd or cups-browser are systematically crashing at start-up. I tried to 
purge and reinstall cups without success. systemctrl status cups shows:
  cups.service - CUPS Scheduler
 Loaded: loaded (/lib/systemd/system/cups.service; enabled; vendor preset: 
enabled)
 Active: failed (Result: core-dump) since Sun 2017-07-16 16:58:10 CST; 45s 
ago
   Docs: man:cupsd(8)
Process: 14474 ExecStart=/usr/sbin/cupsd -l (code=dumped, signal=SEGV)
   Main PID: 14474 (code=dumped, signal=SEGV)

  Jul 16 16:58:10 my-desktop systemd[1]: Started CUPS Scheduler.
  Jul 16 16:58:10 my-desktop systemd[1]: cups.service: Main process exited, 
code=dumped, status=11/SEGV
  Jul 16 16:58:10 my-desktop systemd[1]: cups.service: Unit entered failed 
state.
  Jul 16 16:58:10 my-desktop systemd[1]: cups.service: Failed with result 
'core-dump'.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.04
  Package: cups 2.2.2-1ubuntu1
  ProcVersionSignature: Ubuntu 4.10.0-26.30-generic 4.10.17
  Uname: Linux 4.10.0-26-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia
  ApportVersion: 2.20.4-0ubuntu4.4
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Sun Jul 16 17:06:10 2017
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2017-07-02 (14 days ago)
  InstallationMedia: Ubuntu-GNOME 17.04 "Zesty Zapus" - Release amd64 (20170412)
  Lpstat: Error: command ['lpstat', '-v'] failed with exit code 1: lpstat: Bad 
file descriptor
  MachineType: System manufacturer System Product Name
  Papersize: a4
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-26-generic 
root=UUID=bf399cdf-9a52-46c0-9d61-daa2bc83cf2f ro quiet splash
  SourcePackage: cups
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/13/2013
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 2104
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: P8Z77-V PRO
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 

[Touch-packages] [Bug 1694631] [NEW] Xorg

2017-05-31 Thread d
Public bug reported:

xorg.conf absent

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: xorg 1:7.7+16ubuntu3
ProcVersionSignature: Ubuntu 4.10.0-21.23-generic 4.10.11
Uname: Linux 4.10.0-21-generic x86_64
.tmp.unity_support_test.0:
 
ApportVersion: 2.20.4-0ubuntu4.1
Architecture: amd64
CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Wed May 31 10:26:51 2017
DistUpgraded: Fresh install
DistroCodename: zesty
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] 
(rev 02) (prog-if 00 [VGA controller])
   Subsystem: Dell Core Processor Integrated Graphics Controller [1028:0429]
MachineType: Dell Inc. Latitude E5410
ProcEnviron:
 LANGUAGE=fr_FR
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-21-generic 
root=UUID=c02f6267-09a0-4614-bbfc-a0f00e5bedfc ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/18/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A07
dmi.board.name: 05C67D
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: 
dmi:bvnDellInc.:bvrA07:bd11/18/2010:svnDellInc.:pnLatitudeE5410:pvr0001:rvnDellInc.:rn05C67D:rvrA00:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E5410
dmi.product.version: 0001
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.13.1+17.04.20170109-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.76-1
version.libgl1-mesa-dri: libgl1-mesa-dri 17.0.6-0ubuntu0.17.04.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 17.0.6-0ubuntu0.17.04.1
version.xserver-xorg-core: xserver-xorg-core 2:1.19.3-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.9.0-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20170309-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.14-0ubuntu1

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug compiz-0.9 ubuntu zesty

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1694631

Title:
  Xorg

Status in xorg package in Ubuntu:
  New

Bug description:
  xorg.conf absent

  ProblemType: Bug
  DistroRelease: Ubuntu 17.04
  Package: xorg 1:7.7+16ubuntu3
  ProcVersionSignature: Ubuntu 4.10.0-21.23-generic 4.10.11
  Uname: Linux 4.10.0-21-generic x86_64
  .tmp.unity_support_test.0:
   
  ApportVersion: 2.20.4-0ubuntu4.1
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  Date: Wed May 31 10:26:51 2017
  DistUpgraded: Fresh install
  DistroCodename: zesty
  DistroVariant: ubuntu
  GraphicsCard:
   Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] 
(rev 02) (prog-if 00 [VGA controller])
 Subsystem: Dell Core Processor Integrated Graphics Controller [1028:0429]
  MachineType: Dell Inc. Latitude E5410
  ProcEnviron:
   LANGUAGE=fr_FR
   PATH=(custom, no user)
   LANG=fr_FR.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-21-generic 
root=UUID=c02f6267-09a0-4614-bbfc-a0f00e5bedfc ro quiet splash vt.handoff=7
  SourcePackage: xorg
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 11/18/2010
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A07
  dmi.board.name: 05C67D
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 9
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvrA07:bd11/18/2010:svnDellInc.:pnLatitudeE5410:pvr0001:rvnDellInc.:rn05C67D:rvrA00:cvnDellInc.:ct9:cvr:
  dmi.product.name: Latitude E5410
  dmi.product.version: 0001
  dmi.sys.vendor: Dell Inc.
  version.compiz: compiz 1:0.9.13.1+17.04.20170109-0ubuntu1
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.76-1
  version.libgl1-mesa-dri: libgl1-mesa-dri 17.0.6-0ubuntu0.17.04.1
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 17.0.6-0ubuntu0.17.04.1
  version.xserver-xorg-core: xserver-xorg-core 2:1.19.3-1ubuntu1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.9.0-0ubuntu1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20170309-0ubuntu1
  version.xserver-xorg-video-nouveau: 

[Touch-packages] [Bug 1589487] Re: libicu52 not present

2017-04-28 Thread Om Prakash D
We experienced this issue while installing "Ubuntu 16.04.2 LTS Version".
Does this applies the same? I mean do we have any workaround to get this
or only option left with to replace with libicu55?

Thank you

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to icu in Ubuntu.
https://bugs.launchpad.net/bugs/1589487

Title:
  libicu52 not present

Status in icu package in Ubuntu:
  New

Bug description:
  Hi,
  libicu52 is not installable but some applications needs it.

  Command 1300 of 8 #apt-get install libicu52
  Reading package lists... Done
  Building dependency tree
  Reading state information... Done
  E: Unable to locate package libicu52

  Please can you add to Xenial standard repository the libicu52 library?

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/icu/+bug/1589487/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1683281] [NEW] package postgresql-common 179 failed to install/upgrade: Unterprozess installiertes post-installation-Skript gab den Fehlerwert 255 zurück

2017-04-17 Thread d-kick
Public bug reported:

upgrade from ubuntu 16.10 to 17.04

ProblemType: Package
DistroRelease: Ubuntu 17.04
Package: postgresql-common 179
ProcVersionSignature: Ubuntu 4.10.0-19.21-generic 4.10.8
Uname: Linux 4.10.0-19-generic x86_64
ApportVersion: 2.20.4-0ubuntu4
Architecture: amd64
Date: Sat Apr 15 11:47:14 2017
ErrorMessage: Unterprozess installiertes post-installation-Skript gab den 
Fehlerwert 255 zurück
InstallationDate: Installed on 2013-05-03 (1444 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
PackageArchitecture: all
RelatedPackageVersions:
 dpkg 1.18.10ubuntu2
 apt  1.4
SourcePackage: initramfs-tools
Title: package postgresql-common 179 failed to install/upgrade: Unterprozess 
installiertes post-installation-Skript gab den Fehlerwert 255 zurück
UpgradeStatus: Upgraded to zesty on 2017-04-15 (1 days ago)

** Affects: initramfs-tools (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package zesty

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1683281

Title:
  package postgresql-common 179 failed to install/upgrade: Unterprozess
  installiertes post-installation-Skript gab den Fehlerwert 255 zurück

Status in initramfs-tools package in Ubuntu:
  New

Bug description:
  upgrade from ubuntu 16.10 to 17.04

  ProblemType: Package
  DistroRelease: Ubuntu 17.04
  Package: postgresql-common 179
  ProcVersionSignature: Ubuntu 4.10.0-19.21-generic 4.10.8
  Uname: Linux 4.10.0-19-generic x86_64
  ApportVersion: 2.20.4-0ubuntu4
  Architecture: amd64
  Date: Sat Apr 15 11:47:14 2017
  ErrorMessage: Unterprozess installiertes post-installation-Skript gab den 
Fehlerwert 255 zurück
  InstallationDate: Installed on 2013-05-03 (1444 days ago)
  InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
  PackageArchitecture: all
  RelatedPackageVersions:
   dpkg 1.18.10ubuntu2
   apt  1.4
  SourcePackage: initramfs-tools
  Title: package postgresql-common 179 failed to install/upgrade: Unterprozess 
installiertes post-installation-Skript gab den Fehlerwert 255 zurück
  UpgradeStatus: Upgraded to zesty on 2017-04-15 (1 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1683281/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1683124] [NEW] package linux-firmware 1.164 failed to install/upgrade: Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück

2017-04-16 Thread d-kick
Public bug reported:

error message after upgrading from 16.10 to 17.04

ProblemType: Package
DistroRelease: Ubuntu 17.04
Package: linux-firmware 1.164
ProcVersionSignature: Ubuntu 4.10.0-19.21-generic 4.10.8
Uname: Linux 4.10.0-19-generic x86_64
ApportVersion: 2.20.4-0ubuntu4
Architecture: amd64
Date: Sat Apr 15 11:46:42 2017
Dependencies:
 
ErrorMessage: Unterprozess installiertes post-installation-Skript gab den 
Fehlerwert 1 zurück
InstallationDate: Installed on 2013-05-03 (1443 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
PackageArchitecture: all
RelatedPackageVersions:
 dpkg 1.18.10ubuntu2
 apt  1.4
SourcePackage: initramfs-tools
Title: package linux-firmware 1.164 failed to install/upgrade: Unterprozess 
installiertes post-installation-Skript gab den Fehlerwert 1 zurück
UpgradeStatus: Upgraded to zesty on 2017-04-15 (0 days ago)

** Affects: initramfs-tools (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package zesty

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1683124

Title:
  package linux-firmware 1.164 failed to install/upgrade: Unterprozess
  installiertes post-installation-Skript gab den Fehlerwert 1 zurück

Status in initramfs-tools package in Ubuntu:
  New

Bug description:
  error message after upgrading from 16.10 to 17.04

  ProblemType: Package
  DistroRelease: Ubuntu 17.04
  Package: linux-firmware 1.164
  ProcVersionSignature: Ubuntu 4.10.0-19.21-generic 4.10.8
  Uname: Linux 4.10.0-19-generic x86_64
  ApportVersion: 2.20.4-0ubuntu4
  Architecture: amd64
  Date: Sat Apr 15 11:46:42 2017
  Dependencies:
   
  ErrorMessage: Unterprozess installiertes post-installation-Skript gab den 
Fehlerwert 1 zurück
  InstallationDate: Installed on 2013-05-03 (1443 days ago)
  InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
  PackageArchitecture: all
  RelatedPackageVersions:
   dpkg 1.18.10ubuntu2
   apt  1.4
  SourcePackage: initramfs-tools
  Title: package linux-firmware 1.164 failed to install/upgrade: Unterprozess 
installiertes post-installation-Skript gab den Fehlerwert 1 zurück
  UpgradeStatus: Upgraded to zesty on 2017-04-15 (0 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1683124/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


Re: [Touch-packages] [Bug 1678385] Re: qt5 application wrong popup position on wayland native

2017-04-01 Thread Olivier R-D
I will. I see now that qt5 on Wayland also crashes, etc. I thought Wayland
was supported...

On Sat, Apr 1, 2017, 14:25 Dmitry Shachnev  wrote:

> Hi Olivier,
>
> Can you please file this bug upstream, for either GNOME Shell or Qt?
>
> I have experienced a similar issue a couple of years ago with X11
> (https://bugzilla.gnome.org/show_bug.cgi?id=736719), however yours seems
> to be a different one.
>
> ** Bug watch added: GNOME Bug Tracker #736719
>https://bugzilla.gnome.org/show_bug.cgi?id=736719
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1678385
>
> Title:
>   qt5 application wrong popup position on wayland native
>
> Status in qtbase-opensource-src package in Ubuntu:
>   New
>
> Bug description:
>   1- log in using gnome wayland session
>   2-set environment variable export QT_QPA_PLATFORM=wayland-egl
>   or use switch -platform wayland for qt app
>   3- start a qt application for ex: "qtcreator -platform wayland"
>   4- click on menu or make a contextual menu to appear.
>   => They appear on left edge of screen not where they should on the
> application
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/qtbase-opensource-src/+bug/1678385/+subscriptions
>

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to qtbase-opensource-src in
Ubuntu.
https://bugs.launchpad.net/bugs/1678385

Title:
  qt5 application wrong popup position on wayland native

Status in qtbase-opensource-src package in Ubuntu:
  New

Bug description:
  1- log in using gnome wayland session
  2-set environment variable export QT_QPA_PLATFORM=wayland-egl
  or use switch -platform wayland for qt app
  3- start a qt application for ex: "qtcreator -platform wayland"
  4- click on menu or make a contextual menu to appear. 
  => They appear on left edge of screen not where they should on the application

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/qtbase-opensource-src/+bug/1678385/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


  1   2   3   >