[Touch-packages] [Bug 1846821] Re: Qt print dialog has wrong default page size

2019-11-21 Thread Maciej Puzio
Ɓukasz, thank you very much for accepting the package into bionic- proposed. I confirm that the updated binary package libqt5printsupport5 fixes the problem. I also updated other libqt5* packages available in bionic-proposed, and did not notice any obvious regressions. However, I would like to

[Touch-packages] [Bug 1846821] Re: Qt print dialog has wrong default page size

2019-10-30 Thread Maciej Puzio
I can confirm that the patch fixes the problem, i.e. Qt print dialog now defaults to page size as set in System Settings Printers applet. To apply the fix, it was enough to add the PPA repository, upgrade libqt5printsupport5 package, and then close and reopen applications that were affected by

[Touch-packages] [Bug 1846821] [NEW] Qt print dialog has wrong default page size

2019-10-04 Thread Maciej Puzio
Public bug reported: Please backport Qt patch 213677 to qtbase-opensource-src https://codereview.qt-project.org/c/qt/qtbase/+/213677 In Qt5 applications, print dialog (Printer Properties) always defaults to A4 paper size, even when Letter is set as a default in all system and KDE preferences.

[Touch-packages] [Bug 1588915] Re: ifup does not block for interface to be up with static addresses

2016-08-16 Thread Maciej Puzio
I am also affected by this issue. In my case both network.target and network-online.target are reached too early, which results in sssd and autofs to start before network interfaces are up; autofs then fails to obtain mount maps and does not attempt to retry; it is necessary to restart autofs

[Touch-packages] [Bug 1585568] Re: slapd startup fails with "connections_destroy: nothing to destroy"

2016-05-25 Thread Maciej Puzio
It appears that GnuTLS initialization is failing with an error, perhaps because there is something in your slapd configuration that newer version of GnuTLS (in xenial) does not like. Can you post your slapd config? Please redact it so that it does not contain any host names, IP addresses, user

[Touch-packages] [Bug 1557248] Re: OpenLDAP: Backport a fix for use-after-free in GnuTLS-related code

2016-05-20 Thread Maciej Puzio
I can confirm that the following packages from xenial-proposed fix the bug: slapd 2.4.42+dfsg-2ubuntu3.1 libldap-2.4-2 2.4.42+dfsg-2ubuntu3.1 ldap-utils 2.4.42+dfsg-2ubuntu3.1 I did not test the packages in wily-proposed. Setting the test environment is not trivial, and I don't think it is

[Touch-packages] [Bug 1557248] Re: OpenLDAP: Backport a fix for use-after-free in GnuTLS-related code

2016-05-12 Thread Maciej Puzio
Chris, thank you very much for preparing the packages for -proposed repos. I started testing of xenial-proposed version, but tests are not progressing quickly, due to issues that I described above. In addition I have run into another problem, likely unrelated to this bug, which is further

[Touch-packages] [Bug 1557248] Re: OpenLDAP: Backport a fix for use-after-free in GnuTLS-related code

2016-05-10 Thread Maciej Puzio
Due to the nature of this bug (referencing previously freed memory leading to an undefined behavior), a reliable testing procedure is difficult to create. This bug was originally found by looking for a cause of syncrepl failures. The reproducibility of these failures was about 50%, enough to make

[Touch-packages] [Bug 1557248] Re: OpenLDAP: Backport a fix for use-after-free in GnuTLS-related code

2016-04-06 Thread Maciej Puzio
I reported the bug to Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=820244 ** Bug watch added: Debian Bug tracker #820244 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=820244 -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which

[Touch-packages] [Bug 1557248] Re: OpenLDAP: Backport a fix for use-after-free in GnuTLS-related code

2016-03-29 Thread Maciej Puzio
I created patched openldap packages for xenial, available on the same PPA as above. I tested amd64 packages on xenial beta 2. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to openldap in Ubuntu.

[Touch-packages] [Bug 1547927] Re: LDAP_OPT_X_TLS_REQUIRE_CERT handling differences between ldaps:// and STARTTLS

2016-03-29 Thread Maciej Puzio
I created a PPA with patched openldap packages for wily and xenial. If you would like to test them, there is more information in bug 1557248. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to openldap in Ubuntu.

[Touch-packages] [Bug 1557248] Re: OpenLDAP: Backport a fix for use-after-free in GnuTLS-related code

2016-03-24 Thread Maciej Puzio
I have just found that Howard Chu of OpenLDAP team had already uploaded this patch to Launchpad VCS: http://bazaar.launchpad.net/~vcs-imports/openldap/master/revision/20757 Hopefully we will have the package released soon. -- You received this bug notification because you are a member of Ubuntu

[Touch-packages] [Bug 1557248] Re: OpenLDAP: Backport a fix for use-after-free in GnuTLS-related code

2016-03-24 Thread Maciej Puzio
** Tags added: patch-accepted-upstream -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to openldap in Ubuntu. https://bugs.launchpad.net/bugs/1557248 Title: OpenLDAP: Backport a fix for use-after-free in GnuTLS-related code

[Touch-packages] [Bug 1557248] Re: OpenLDAP: Backport a fix for use-after-free in GnuTLS-related code

2016-03-23 Thread Maciej Puzio
I created a PPA with patched deb packages, available at: https://launchpad.net/~maciej-puzio/+archive/ubuntu/openldap Currently it contains openldap-2.4.41 source package with the above patch applied, as well as binary debs built from it, for amd64 and i386. These packages are for Ubuntu 15.10

[Touch-packages] [Bug 1557248] Re: OpenLDAP: Backport a fix for use-after-free in GnuTLS-related code

2016-03-21 Thread Maciej Puzio
Patch created by OpenLDAP team applies cleanly to openldap 2.4.41+dfsg- 1ubuntu2 (wily). ** Patch added: "tls_g.patch" https://bugs.launchpad.net/ubuntu/+source/openldap/+bug/1557248/+attachment/4607004/+files/tls_g.patch -- You received this bug notification because you are a member of

[Touch-packages] [Bug 1547927] Re: LDAP_OPT_X_TLS_REQUIRE_CERT handling differences between ldaps:// and STARTTLS

2016-03-19 Thread Maciej Puzio
A bug has been found in libldap code that interferes with the value of "require cert" option. It affects libldap built with GnuTLS, as is done in packages supplied by Ubuntu and Debian. The bug causes the value to be read from previously freed memory, often resulting in incorrect or random value

[Touch-packages] [Bug 1537762] Re: syncrepl does not work when using tls

2016-03-14 Thread Maciej Puzio
Perhaps the issue is that your certificates have too short RSA keys. In GnuTLS SECURE256 requires at least 3072-bit public key. Unfortunately, this is not clearly documented. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to

[Touch-packages] [Bug 1557248] [NEW] OpenLDAP: Backport a fix for use-after-free in GnuTLS-related code

2016-03-14 Thread Maciej Puzio
Public bug reported: May I ask that you backport an upstream patch that resolves the issue of use-after-free in libldap that interferes with syncrepl, causing failures and segfaults. OpenLDAP commit: 283f3ae1713df449cc170965b311b19157f7b7ea Link:

[Touch-packages] [Bug 831487] Re: Dependency on package unattended-upgrades on Ubuntu Server

2015-10-28 Thread Maciej Puzio
The same problem exists on Ubuntu 14.04 LTS (Trusty). In this case, add- apt-repository is in package software-properties-common, which depends on python3-software-properties, which depends (needlessly) on unattended-upgrades. -- You received this bug notification because you are a member of

[Touch-packages] [Bug 525154] Re: mountall for /var or other nfs mount races with rpc.statd

2015-06-02 Thread Maciej Puzio
For a similar bug affecting Ubuntu 14.04, please see bug #1371564 -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mountall in Ubuntu. https://bugs.launchpad.net/bugs/525154 Title: mountall for /var or other nfs mount races