[Touch-packages] [Bug 1922464] Re: GNOME 40: GTK3 apps crash with: Settings schema 'org.gnome.settings-daemon.plugins.xsettings' does not contain a key named 'antialiasing'

2021-10-06 Thread Mattia Rizzolo
@seb128: would you take care of uploading that patch, or should somebody else do it? I'm not a core-dev, so I would still need a sponsor for the actual upload (though I have them already), so if you have the tuits it might just be quicker/easier if you could do it ^^ -- You received this bug

[Touch-packages] [Bug 1922464] Re: GNOME 40: GTK3 apps crash with: Settings schema 'org.gnome.settings-daemon.plugins.xsettings' does not contain a key named 'antialiasing'

2021-10-05 Thread Mattia Rizzolo
@seb128: but is the patch that you uploaded with 3.24.25-1ubuntu4 (i.e. this http://launchpadlibrarian.net/532459482/gtk+3.0_3.24.25-1ubuntu3_3.24.25-1ubuntu4.diff.gz ) really that inappropriate for a SRU on top of the current version in focal-updates? -- You received this bug notification

[Touch-packages] [Bug 1922464] Re: GNOME 40: GTK3 apps crash with: Settings schema 'org.gnome.settings-daemon.plugins.xsettings' does not contain a key named 'antialiasing'

2021-10-05 Thread Mattia Rizzolo
** Also affects: gtk+3.0 (Ubuntu Focal) Importance: Undecided Status: New ** Also affects: gtk+3.0 (Ubuntu Hirsute) Importance: Undecided Status: New ** No longer affects: gtk+3.0 (Ubuntu Hirsute) ** Changed in: gtk+3.0 (Ubuntu Focal) Status: New => Confirmed -- You

Re: [Touch-packages] [Bug 1943984] Re: No archive files for static compilation are included in the -dev package

2021-09-29 Thread Mattia Rizzolo
As a member of the Debian LibreOffice Team, and also as an Ubuntu Developer, I'm likewise not convinced that starting to build and ship graphite2's static library is a really useful thing to do. I'm personally generically against static libraries, since I regularly see grief caused by poor

[Touch-packages] [Bug 1943125] Re: devscripts breaks apt

2021-09-10 Thread Mattia Rizzolo
from my (devscripts) side, no idea. also I have no clue how a command that has || in there can even "return an error code". I'm strongly convinced there is nothing special in devscripts that could cause this, so I'm not considering it a bug in there. ** Changed in: devscripts (Ubuntu)

[Touch-packages] [Bug 1943277] Re: libxml2 2.9.12+dfsg-3 causes regression

2021-09-10 Thread Mattia Rizzolo
** Changed in: libxml2 (Ubuntu) Assignee: (unassigned) => Mattia Rizzolo (mapreri) ** Changed in: libxml2 (Ubuntu) Status: Triaged => Fix Committed -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to l

[Touch-packages] [Bug 1923845] Re: Please compress packages with zstd by default

2021-06-25 Thread Mattia Rizzolo
** Changed in: diffoscope (Ubuntu) Status: New => Fix Committed ** Changed in: diffoscope (Ubuntu) Assignee: (unassigned) => Balint Reczey (rbalint) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to file in Ubuntu.

[Touch-packages] [Bug 1895839] Re: CVE-2020-24977

2021-02-25 Thread Mattia Rizzolo
** Also affects: libxml2 (Ubuntu Hirsute) Importance: High Status: Confirmed ** Changed in: libxml2 (Ubuntu Hirsute) Status: Confirmed => Fix Released -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to libxml2

[Touch-packages] [Bug 1908500] Re: libxslt.a missing from libxslt1-dev

2021-01-15 Thread Mattia Rizzolo
** Changed in: libxslt (Ubuntu) Status: Incomplete => Invalid -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to libxslt in Ubuntu. https://bugs.launchpad.net/bugs/1908500 Title: libxslt.a missing from libxslt1-dev

[Touch-packages] [Bug 1908500] Re: libxslt.a missing from libxslt1-dev

2020-12-17 Thread Mattia Rizzolo
** Changed in: libxslt (Ubuntu) Status: New => Incomplete -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to libxslt in Ubuntu. https://bugs.launchpad.net/bugs/1908500 Title: libxslt.a missing from libxslt1-dev Status

Re: [Touch-packages] [Bug 1908500] Re: libxslt.a missing from libxslt1-dev

2020-12-17 Thread Mattia Rizzolo
wrote: > It seems this was intentional, from debian/changelog: > > > libxslt (1.1.34-1) experimental; urgency=medium > > ... > * Stop building and installing the static library. > ... > > -- Mattia Rizzolo Mon, 25 Nov 2019 19:22:08 +0100 > > -- > Y

[Touch-packages] [Bug 1895839] Re: CVE-2020-24977

2020-09-17 Thread Mattia Rizzolo
** Bug watch added: Debian Bug tracker #969529 https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=969529 ** Also affects: libxml2 (Debian) via https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=969529 Importance: Unknown Status: Unknown -- You received this bug notification

[Touch-packages] [Bug 1865387] Re: Linux Biolinum O italic lowercase m not displayed by poppler

2020-07-02 Thread Mattia Rizzolo
the commit seb128 mentions for freetype is present in freetype 2.10.1-1 which is present in focal+. ** Changed in: freetype (Ubuntu) Status: Triaged => Fix Released -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to

[Touch-packages] [Bug 1536751] Re: Font/text rendering is irregular and not pixel-aligned on low DPI screens

2020-07-02 Thread Mattia Rizzolo
Is this issue still present after some years? I don't have any low-DPI system at hand (I really only have hi-DPI screens… :P) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to qtbase-opensource-src in Ubuntu.

[Touch-packages] [Bug 1876962] Re: package libxml2:amd64 2.9.4+dfsg1-6.1ubuntu1.3 failed to install/upgrade: package is in a very bad inconsistent state; you should reinstall it before attempting con

2020-05-10 Thread Mattia Rizzolo
Did you try to contact user support for this? That's clearly some kind of installation error, likely from some interrupted process. Try `sudo dpkg --configure -a` followed by `sudo apt -f install`, if that doesn't work then an `apt install --reinstall libxml2`. If you can't bring it to heel,

[Touch-packages] [Bug 1865555] Re: libxml2

2020-03-06 Thread Mattia Rizzolo
People made me notice that I stopped reading at the first section, before the `apt-get -f install` bit… That multiarch breakage is fixed in the version currently blocked in propsed, starting with 2.9.10+dfsg-4 ** Changed in: libxml2 (Ubuntu) Status: Invalid => Fix Released -- You

[Touch-packages] [Bug 1865555] Re: libxml2

2020-03-06 Thread Mattia Rizzolo
you: * shouldn't use a development version if you don't know what you are doing * never use the -proposed pocket of a development release unless you are very clear on what you are doing, since that pocket is supposed to be consumed only by programs. ** Changed in: libxml2 (Ubuntu)

[Touch-packages] [Bug 1774757] Re: package libgraphite2-3 1.3.11-2 failed to install/upgrade: trying to overwrite shared '/usr/share/doc/libgraphite2-3/changelog.Debian.gz', which is different from ot

2019-10-17 Thread Mattia Rizzolo
I can't quite imagine what could have happened here, but I'm totally unable to reproduce it. Also, you are the only one that reported this, so I'm totally at a loss. I'll be marking this bug as incompleted, and see if anybody can post new details, otherwise it'll expire. I also believe just

[Touch-packages] [Bug 1322024] Re: Make Hexchat the default IRC client instead of XChat in Ubuntu 14.10 and later versions

2019-05-26 Thread Mattia Rizzolo
xchat is back, and Gianfranco wants to keep it. Also, I see little value in a transitional package or similar when they can't be upgraded from one to the other seamlessly. I'm therefore closing both tasks. ** Changed in: hexchat (Ubuntu) Status: New => Invalid ** Changed in: xchat

[Touch-packages] [Bug 1755311] Re: "Warning: libpng warning: iCCP: known incorrect sRGB profile"

2019-03-27 Thread Mattia Rizzolo
So, I'm reassigning this bug to qt5webkit, thank you Gianfranco for investigating the issue. That was very obscure! I'll take care of closing this bug once somebody merges in the new qt5webkit version (which may be for disco+1) ** Package changed: sigil (Ubuntu) => qtwebkit-opensource-src

[Touch-packages] [Bug 1792835] Re: Bash completion for Inkscape does not work

2018-09-20 Thread Mattia Rizzolo
Fix committed in git: https://salsa.debian.org/pbuilder-team/cowdancer/commit/bbac66ca568e00ff6f54e0b38d77556f44b7b03d ** Changed in: cowdancer (Ubuntu) Status: New => Fix Committed -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is

[Touch-packages] [Bug 1792835] Re: Bash completion for Inkscape does not work

2018-09-20 Thread Mattia Rizzolo
Status: New ** Also affects: apt-xapian-index (Ubuntu) Importance: Undecided Status: New ** Changed in: inkscape (Ubuntu) Assignee: (unassigned) => Mattia Rizzolo (mapreri) ** Changed in: cowdancer (Ubuntu) Assignee: (unassigned) => Mattia Rizzolo (mapreri) -- You re

[Touch-packages] [Bug 1039599] Re: package libxslt1.1 1.1.26-8ubuntu1 [modified: usr/share/doc/libxslt1.1/changelog.Debian.gz] failed to install/upgrade: libxslt1.1:amd64 1.1.26-8ubuntu1 cannot be con

2018-05-26 Thread Mattia Rizzolo
There used to be some multiarch issues that have since been fixed, closing. ** Changed in: libxslt (Ubuntu) Status: Confirmed => Fix Released -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to libxslt in Ubuntu.

[Touch-packages] [Bug 661649] Re: package libxslt1.1 1.1.26-1ubuntu1 failed to install/upgrade: ErrorMessage: pakken libxslt1.1 er installert og satt opp fra før

2018-05-26 Thread Mattia Rizzolo
Sorry nobody had a chance at looking at this old bug. both 10.04 and 10.10 are out of support for a long time, and I'm positive the package installs/upgrades just fine on newer releases. closing ** Changed in: libxslt (Ubuntu) Status: New => Fix Released -- You received this bug

[Touch-packages] [Bug 1770667] Re: package python-libxml2 2.9.1+dfsg1-3ubuntu4.7 failed to install/upgrade: subprocess new pre-removal script returned error exit status 126

2018-05-11 Thread Mattia Rizzolo
/var/lib/dpkg/info/apport.prerm: 14: /var/lib/dpkg/info/apport.prerm: pyclean: Permission denied and then /var/lib/dpkg/tmp.ci/prerm: 14: /var/lib/dpkg/tmp.ci/prerm: pyclean: Permission denied and then /var/lib/dpkg/info/apport.postinst: 13: /var/lib/dpkg/info/apport.postinst: pycompile:

[Touch-packages] [Bug 1156807] Re: package libunistring0 0.9.3-5 failed to install/upgrade: package libunistring0 is already installed and configured

2018-02-03 Thread Mattia Rizzolo
I'm sorry it took so long to receive a reply about this bug report. However I am going to close it because there is nothing actionable here. That error you reported is incredibly unhelpful, and it' not caused by anything from this package. We'd need to know what is asking dpkg to explicitly

[Touch-packages] [Bug 1626248] Re: libunistring0 has not been updated since 2010

2018-02-03 Thread Mattia Rizzolo
I'm sorry it took so long to receive a reply about this bug report. However I am going to close it because there is nothing actionable here. That error you reported is incredibly unhelpful, and it' not caused by anything from this package. We'd need to know what is asking dpkg to explicitly

[Touch-packages] [Bug 1626248] Re: libunistring0 has not been updated since 2010

2018-02-03 Thread Mattia Rizzolo
ooops, managed to write this comment on the wrong bug report somehow -.-' ** Changed in: libunistring (Ubuntu) Status: Invalid => Triaged ** Changed in: libunistring (Ubuntu) Importance: Undecided => Low -- You received this bug notification because you are a member of Ubuntu Touch

[Touch-packages] [Bug 1745805] Re: package python-libxml2 2.9.3+dfsg1-1ubuntu0.5 failed to install/upgrade: subprocess installed post-installation script returned error exit status 127

2018-01-28 Thread Mattia Rizzolo
** Changed in: libxml2 (Ubuntu) Status: New => Incomplete -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to libxml2 in Ubuntu. https://bugs.launchpad.net/bugs/1745805 Title: package python-libxml2

[Touch-packages] [Bug 1742902] Re: package libxml2:amd64 2.9.3+dfsg1-1ubuntu0.5 failed to install/upgrade: package is in a very bad inconsistent state; you should reinstall it before attempting confi

2018-01-17 Thread Mattia Rizzolo
tl;dr: your system is in a mess. Please contact user support if you don't know how to handle it, but it's most likely due to some odd thing you did rather than a bug. ** Changed in: libxml2 (Ubuntu) Status: New => Invalid -- You received this bug notification because you are a member of

[Touch-packages] [Bug 1738784] Re: package libxml2 2.9.1+dfsg1-3ubuntu4.12 failed to install/upgrade: 64.1026:package libxml2:amd64 2.9.1+dfsg1-3ubuntu4.12 cannot be configured because libxml2:i386 is

2017-12-19 Thread Mattia Rizzolo
Plus, libxml2 is only one of the many packages that fails, the first error is this: package libpcre3:amd64 2:8.41-1.1+ubuntu14.04.1+deb.sury.org+4 cannot be configured because libpcre3:i386 is at a different version (2:8.41-1.1+ubuntu14.04.1+deb.sury.org+3) Anyway, it's as seth-arnold said,

[Touch-packages] [Bug 1737589] Re: package python-libxml2 2.9.3+dfsg1-1ubuntu0.3 failed to install/upgrade: subprocess new pre-removal script returned error exit status 1

2017-12-11 Thread Mattia Rizzolo
indeed, having the `python` in the path being a python3 is not supported. Don't do it. ** Changed in: libxml2 (Ubuntu) Status: New => Invalid -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to libxml2 in Ubuntu.

[Touch-packages] [Bug 1630623] Re: package python-pyside.qtcore 1.2.2-2build2 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

2017-12-11 Thread Mattia Rizzolo
** Package changed: pyside (Ubuntu) => python-defaults (Ubuntu) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to python-defaults in Ubuntu. https://bugs.launchpad.net/bugs/1630623 Title: package python-pyside.qtcore

[Touch-packages] [Bug 1737453] Re: package python-libxml2 2.9.3+dfsg1-1ubuntu0.4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

2017-12-11 Thread Mattia Rizzolo
** Package changed: libxml2 (Ubuntu) => python-defaults (Ubuntu) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to python-defaults in Ubuntu. https://bugs.launchpad.net/bugs/1737453 Title: package python-libxml2

[Touch-packages] [Bug 1736858] Re: package python-libxml2 2.9.4+dfsg1-2.2ubuntu0.1 failed to install/upgrade: subprocess new pre-removal script returned error exit status 127

2017-12-07 Thread Mattia Rizzolo
pyclean is part of python-minimal... Do you perhaps have some manual python installation that removed /usr/bin/pyclean? Or are you running with a PATH that doesn't include /usr/bin or something equivalently crazy? Or at the very least, please check if you have /usr/bin/pyclean and it works.

[Touch-packages] [Bug 1604638] Re: package python2.7-minimal 2.7.12-1~16.04 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2

2017-11-19 Thread Mattia Rizzolo
*** This bug is a duplicate of bug 1659002 *** https://bugs.launchpad.net/bugs/1659002 ** This bug has been marked a duplicate of bug 1659002 ImportError: No module named 'ConfigParser' when running pycompile -- You received this bug notification because you are a member of Ubuntu Touch

[Touch-packages] [Bug 1718095] Re: package python-libxml2 2.9.3+dfsg1-1ubuntu0.3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

2017-11-19 Thread Mattia Rizzolo
*** This bug is a duplicate of bug 1659002 *** https://bugs.launchpad.net/bugs/1659002 ** This bug has been marked a duplicate of bug 1659002 ImportError: No module named 'ConfigParser' when running pycompile -- You received this bug notification because you are a member of Ubuntu Touch

[Touch-packages] [Bug 1659002] Re: ImportError: No module named 'ConfigParser' when running pycompile

2017-11-10 Thread Mattia Rizzolo
** Summary changed: - package python-apt 1.1.0~beta1build1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1 + ImportError: No module named 'ConfigParser' when running pycompile -- You received this bug notification because you are a member

[Touch-packages] [Bug 1718869] Re: Migrate to hunspell-en-us in libreoffice-dictionaries

2017-11-09 Thread Mattia Rizzolo
scowl is not being autosynced because of the binary takeover that is a bit tricky, I asked for manual sync ** Changed in: libreoffice-dictionaries (Ubuntu) Status: New => Won't Fix -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is

[Touch-packages] [Bug 1715599] Re: 2.26-0ubuntu1 breaks compliation of several KDE sources

2017-10-28 Thread Mattia Rizzolo
** Bug watch added: Debian Bug tracker #880038 https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=880038 ** Also affects: libxslt (Debian) via https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=880038 Importance: Unknown Status: Unknown -- You received this bug notification

[Touch-packages] [Bug 1727975] Re: package python-libxml2 2.9.3+dfsg1-1ubuntu0.3 failed to install/upgrade: 子进程 已安装 post-installation 脚本 返回错误状态 1

2017-10-27 Thread Mattia Rizzolo
** Package changed: libxml2 (Ubuntu) => python2.7 (Ubuntu) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to python2.7 in Ubuntu. https://bugs.launchpad.net/bugs/1727975 Title: package python-libxml2 2.9.3+dfsg1-1ubuntu0.3

[Touch-packages] [Bug 1718869] Re: Migrate to hunspell-en-us in libreoffice-dictionaries

2017-10-20 Thread Mattia Rizzolo
See https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=879199 ** Bug watch added: Debian Bug tracker #879199 https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=879199 -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to

[Touch-packages] [Bug 1718869] Re: Migrate to hunspell-en-us in libreoffice-dictionaries

2017-10-16 Thread Mattia Rizzolo
I also disagree with Rene here, but I'd rather not go against his explicit wishes. It would be more interesting to try to update src:hunspell-en-us, to at least try to update it, at this point. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which

[Touch-packages] [Bug 1642447] Re: package libgraphite2-3:amd64 1.3.9-1 failed to install/upgrade: pacote libgraphite2-3:amd64 1.3.9-1 não pode ser configurado pois libgraphite2-3:i386 tem uma versão

2017-09-28 Thread Mattia Rizzolo
You'll need to install the same version of the i386 package together. I don't know what you were running, but please try to contact user support instead. ** Changed in: graphite2 (Ubuntu) Status: New => Invalid -- You received this bug notification because you are a member of Ubuntu

[Touch-packages] [Bug 1717737] Re: package libgraphite2-3:amd64 1.3.6-1ubuntu1 failed to install/upgrade: package libgraphite2-3:amd64 is not ready for configuration cannot configure (current status '

2017-09-28 Thread Mattia Rizzolo
We'll need more than just the final error message to even start to imagine what's happening here. ** Changed in: graphite2 (Ubuntu) Status: New => Incomplete -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to graphite2

[Touch-packages] [Bug 1718095] Re: package python-libxml2 2.9.3+dfsg1-1ubuntu0.3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

2017-09-19 Thread Mattia Rizzolo
Setting up python-libxml2 (2.9.3+dfsg1-1ubuntu0.3) ... Traceback (most recent call last): File "/usr/bin/pycompile", line 35, in from debpython.version import SUPPORTED, debsorted, vrepr, \ File "/usr/share/python/debpython/version.py", line 24, in from ConfigParser import

[Touch-packages] [Bug 1637239] Re: Please merge ncurses 6.0+20161126-1 (main) from Debian unstable (main)

2017-08-30 Thread Mattia Rizzolo
@tsimonq2 where/when? I still see 6.0+20160625-1ubuntu1 in artful. Subscribing ubuntu-sponsors again. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to ncurses in Ubuntu. https://bugs.launchpad.net/bugs/1637239 Title: Please

[Touch-packages] [Bug 1647809] Re: package inkscape 0.91-7ubuntu2 failed to install/upgrade: subprocess installed pre-removal script returned error exit status 1

2017-08-25 Thread Mattia Rizzolo
this was a issue in python-minimal, fixed in the meantime. ** Package changed: inkscape (Ubuntu) => python-defaults (Ubuntu) ** Changed in: python-defaults (Ubuntu) Status: New => Fix Released -- You received this bug notification because you are a member of Ubuntu Touch seeded

[Touch-packages] [Bug 1607921] Re: package libopencv-features2d2.4v5 2.4.9.1+dfsg-1.5ubuntu1 failed to install/upgrade: no package named 'libopencv-features2d2.4v5' is installed, cannot configure

2017-04-24 Thread Mattia Rizzolo
*** This bug is a duplicate of bug 1631983 *** https://bugs.launchpad.net/bugs/1631983 ** This bug has been marked a duplicate of bug 1631983 package libopencv-gpu2.4v5 (not installed) failed to install/upgrade: no package named 'libopencv-gpu2.4v5' is installed, cannot configure -- You

[Touch-packages] [Bug 1631983] Re: package libopencv-gpu2.4v5 (not installed) failed to install/upgrade: no package named 'libopencv-gpu2.4v5' is installed, cannot configure

2017-04-24 Thread Mattia Rizzolo
After peering with the APT maintainers, I'm reassigning this to them. ** Package changed: opencv (Ubuntu) => apt (Ubuntu) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to apt in Ubuntu. https://bugs.launchpad.net/bugs/1631983

[Touch-packages] [Bug 1680504] Re: package libopencv-objdetect2.4v5 (not installed) failed to install/upgrade: no package named 'libopencv-objdetect2.4v5' is installed, cannot configure

2017-04-24 Thread Mattia Rizzolo
*** This bug is a duplicate of bug 1631983 *** https://bugs.launchpad.net/bugs/1631983 ** This bug has been marked a duplicate of bug 1631983 package libopencv-gpu2.4v5 (not installed) failed to install/upgrade: no package named 'libopencv-gpu2.4v5' is installed, cannot configure -- You

[Touch-packages] [Bug 1439162] Re: libopencv-contrib2.4 libopencv-objdetect2.4 cannot be installed on 15.04

2017-04-23 Thread Mattia Rizzolo
It's clear from the snippet you pasted that you have PPA packages that are causing some kind of conflicts with packages from the main archive, so this is not a valid bug. Besides, I can install libopencv-contrib2.4 and libopencv-objdetect2.4 just fine in a vivid chroot. ** Changed in: opencv

[Touch-packages] [Bug 1514508] Re: cant install libopencv-objdetect-dev

2017-04-23 Thread Mattia Rizzolo
At the very least we would need the distribution version, and we kneed to know where you found that package version that is not present in any ubuntu release (vivid has 2.4.9+dfsg-1ubuntu4 and wily has 2.4.9.1+dfsg-1.5ubuntu1). ** Changed in: opencv (Ubuntu) Status: New => Incomplete --

[Touch-packages] [Bug 1315418] Re: cvconfig.h not found

2017-04-23 Thread Mattia Rizzolo
https://anonscm.debian.org/git/debian- science/packages/opencv.git/commit/?id=f7814e9 ** Changed in: opencv (Ubuntu) Importance: Undecided => Medium ** Changed in: opencv (Ubuntu) Status: New => Fix Committed ** Changed in: opencv (Ubuntu) Assignee: (unassigned) => Matti

[Touch-packages] [Bug 1515282] Re: The name of the wily's package break the search of apt-get

2017-04-23 Thread Mattia Rizzolo
Same as LP: #1683112 ** Changed in: opencv (Ubuntu) Status: New => Invalid -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to opencv in Ubuntu. https://bugs.launchpad.net/bugs/1515282 Title: The name of the wily's

[Touch-packages] [Bug 1680504] Re: package libopencv-objdetect2.4v5 (not installed) failed to install/upgrade: no package named 'libopencv-objdetect2.4v5' is installed, cannot configure

2017-04-23 Thread Mattia Rizzolo
For some reason the file DpkgTerminalLog.txt doesn't contain the actual error. And a test upgrade from trusty to zesty with libopencv-objdetect-dev installed doesn't fail. Please provide more details (like a log with an error). ** Changed in: opencv (Ubuntu) Status: New => Incomplete --

[Touch-packages] [Bug 1683112] Re: The name of the package break other packages

2017-04-23 Thread Mattia Rizzolo
You are doing it wrong. You should not manually list the dependency on libaries in debian/control, but instead use dpkg-shlibdeps and have it fill automatically through ${shlibs:Depends}. This way a simple rebuild would be enough to have an installable package. Library transitions happens

[Touch-packages] [Bug 1362285] Re: package libopencv-imgproc-dev 2.4.8+dfsg1-2ubuntu1 failed to install/upgrade: próba nadpisania "/usr/include/opencv2/imgproc/imgproc_c.h", który istnieje także w pak

2017-04-23 Thread Mattia Rizzolo
That error involves a package (libopencv4tegra-dev) that's not from the Ubuntu archive, so this bug is invalid. Anyway, please report error messages in English next time (export LC_ALL=C while reproducing). ** Changed in: opencv (Ubuntu) Status: New => Invalid -- You received this bug

[Touch-packages] [Bug 1516985] Re: Package update to 3.0

2017-04-23 Thread Mattia Rizzolo
** Changed in: opencv (Ubuntu) Status: Confirmed => Fix Committed ** Changed in: opencv (Ubuntu) Assignee: (unassigned) => Mattia Rizzolo (mapreri) ** Changed in: opencv (Ubuntu) Importance: Undecided => Wishlist -- You received this bug notification because you are

[Touch-packages] [Bug 1556156] Re: OpenCV lacks Python 3 bindings

2017-04-23 Thread Mattia Rizzolo
** Changed in: opencv (Ubuntu) Status: Confirmed => Fix Committed ** Changed in: opencv (Ubuntu) Assignee: (unassigned) => Mattia Rizzolo (mapreri) ** Changed in: opencv (Ubuntu) Importance: Undecided => Wishlist -- You received this bug notification because you are

[Touch-packages] [Bug 1167422] Re: Missing photo-lib

2017-04-23 Thread Mattia Rizzolo
libopencv-photo-dev is available in later releases. ** Changed in: opencv (Ubuntu) Status: New => Fix Released -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to opencv in Ubuntu. https://bugs.launchpad.net/bugs/1167422

[Touch-packages] [Bug 1251522] Re: OpenCV downgrades Intel Ivybridge Graphics Card drivers on Ubuntu 13.10

2017-04-23 Thread Mattia Rizzolo
*** This bug is a duplicate of bug 1245260 *** https://bugs.launchpad.net/bugs/1245260 ** This bug has been marked a duplicate of bug 1245260 Installing libopencv-dev breaks OpenGl for Intel based gpu -- You received this bug notification because you are a member of Ubuntu Touch seeded

[Touch-packages] [Bug 1168000] Re: gpu-dev missing in raring build

2017-04-23 Thread Mattia Rizzolo
present in later releases. ** Changed in: opencv (Ubuntu) Status: New => Fix Released -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to opencv in Ubuntu. https://bugs.launchpad.net/bugs/1168000 Title: gpu-dev missing

[Touch-packages] [Bug 1161485] Re: /usr/lib/pyshared/python2.7/cv2.so depends on missing libavcodec52?

2017-04-23 Thread Mattia Rizzolo
I confirm this happens in trusty amd64, but it's fixed in xenial and later, so I'm marking it as such. ** Changed in: opencv (Ubuntu) Status: Confirmed => Fix Released -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to

[Touch-packages] [Bug 886482] Re: opencv-doc c examples don't build

2017-04-23 Thread Mattia Rizzolo
this works in 3.x (which I'm going to upload in a few weeks), so this has been fixed at some point. ** Changed in: opencv (Ubuntu) Status: Confirmed => Fix Released -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to

[Touch-packages] [Bug 1079232] Re: OpenCV built without Qt support

2017-04-23 Thread Mattia Rizzolo
Yes, there is a reason, see this message on the relevant Debian bug for more info: https://bugs.debian.org/785477#10 ** Bug watch added: Debian Bug tracker #785477 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=785477 ** Also affects: opencv (Debian) via

[Touch-packages] [Bug 698016] Re: Opencv haarcascades should not be shipped as documentation

2017-04-23 Thread Mattia Rizzolo
it's in opencv-data these days. closing. ** Changed in: opencv (Ubuntu) Status: Confirmed => Fix Released -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to opencv in Ubuntu. https://bugs.launchpad.net/bugs/698016

[Touch-packages] [Bug 345891] Re: capture-cam.py crashed with IndentationError in unknown()

2017-04-23 Thread Mattia Rizzolo
pretty sure this has been fixed at some point. ps: making this bug private only cause it to be unseen for 8 years. ** Information type changed from Private to Public ** Changed in: opencv (Ubuntu) Status: New => Fix Released -- You received this bug notification because you are a

[Touch-packages] [Bug 500745] Re: Missing dependency: Numeric

2017-04-23 Thread Mattia Rizzolo
these days python-opencv depends on python-numpy. ** Changed in: opencv (Ubuntu) Status: New => Fix Released -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to opencv in Ubuntu. https://bugs.launchpad.net/bugs/500745

[Touch-packages] [Bug 532495] Re: OpenCV 2.0 packages in lucid doesn't contain the new python API

2017-04-23 Thread Mattia Rizzolo
can't be fixed in lucid anymore (and anyway, such changes wouldn't have make in it after the release). ** Changed in: opencv (Ubuntu) Status: New => Won't Fix -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to opencv in

[Touch-packages] [Bug 994114] Re: Missing link to libopencv_gpu.so.2.3

2017-04-23 Thread Mattia Rizzolo
besides, libopencv-dev does. anyway, closing this bug. ** Changed in: opencv (Ubuntu) Status: New => Won't Fix -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to opencv in Ubuntu. https://bugs.launchpad.net/bugs/994114

[Touch-packages] [Bug 188539] Re: cvCalibrateCamera2 broken in python-opencv

2017-04-23 Thread Mattia Rizzolo
closing this old bug... ** Changed in: opencv (Ubuntu) Status: Incomplete => Invalid -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to opencv in Ubuntu. https://bugs.launchpad.net/bugs/188539 Title:

[Touch-packages] [Bug 1272314] Re: opencv-doc missing the PDFs

2017-04-23 Thread Mattia Rizzolo
opencv 3.x doesn't seem to support building pdf docs anymore, so I am marking this bug as invalid. If I'm wrong, please reopen this bug (possibly, by showing how to do it. ** Changed in: opencv (Ubuntu) Status: New => Invalid -- You received this bug notification because you are a

[Touch-packages] [Bug 319463] Re: opencv-doc/examples/python/houghlines.py contains wrong path to image file

2017-04-23 Thread Mattia Rizzolo
This file was completely rewritten in the meantime, this bug can't exist anymore... ** Changed in: opencv (Ubuntu) Status: New => Fix Released -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to opencv in Ubuntu.

[Touch-packages] [Bug 1245260] Re: Installing libopencv-dev breaks OpenGl for Intel based gpu

2017-04-23 Thread Mattia Rizzolo
opencl support has been implemented a little differently in debian, using ocl-icd-libopencl1, which avoids this bug, which should not be present anymore now. ** Changed in: opencv (Ubuntu) Status: Confirmed => Fix Released -- You received this bug notification because you are a member of

[Touch-packages] [Bug 1251997] Re: blank screen after login in all sessions except lxde

2017-04-23 Thread Mattia Rizzolo
*** This bug is a duplicate of bug 1245260 *** https://bugs.launchpad.net/bugs/1245260 ** This bug has been marked a duplicate of bug 1245260 Installing libopencv-dev breaks OpenGl for Intel based gpu -- You received this bug notification because you are a member of Ubuntu Touch seeded

[Touch-packages] [Bug 588093] Re: cvMixChannels completely broken

2017-04-23 Thread Mattia Rizzolo
As Nobuhiro said, it's already applied, and affected ubuntu releases are now unsupported, so closing. ** Changed in: opencv (Ubuntu) Status: New => Fix Released -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to opencv

[Touch-packages] [Bug 709639] Re: package libgtkglext1 1.2.0-1ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2

2017-04-03 Thread Mattia Rizzolo
This is not a bug in gtkglext, not sure what it is, but I suggest you contact a support channel next time. Also, lucid is EOL now. ** Changed in: gtkglext (Ubuntu) Status: New => Invalid -- You received this bug notification because you are a member of Ubuntu Touch seeded packages,

[Touch-packages] [Bug 1508627] Re: Build with multiarch support

2017-04-03 Thread Mattia Rizzolo
** Bug watch added: Debian Bug tracker #777211 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=777211 ** Also affects: gtkglext (Debian) via http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=777211 Importance: Unknown Status: Unknown -- You received this bug notification because

[Touch-packages] [Bug 1528297] Re: libvpx FTBFS with gcc 5.3 on armhf

2017-04-03 Thread Mattia Rizzolo
libvpx just builds now, so this is fixed. ** Changed in: libvpx (Ubuntu) Status: New => Fix Released -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to libvpx in Ubuntu. https://bugs.launchpad.net/bugs/1528297 Title:

[Touch-packages] [Bug 600074] Re: opencv-doc does not contain actual documentation

2017-04-03 Thread Mattia Rizzolo
This has been fixed somewhen in the 3.x.y tree, that will be in ubuntu for zesty+1. ** Changed in: opencv (Ubuntu) Status: New => Fix Committed -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to opencv in Ubuntu.

[Touch-packages] [Bug 1272314] Re: opencv-doc missing the PDFs

2017-04-03 Thread Mattia Rizzolo
** Changed in: opencv (Ubuntu) Milestone: ubuntu-14.10 => None ** Changed in: opencv (Ubuntu) Importance: Medium => Low -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to opencv in Ubuntu.

[Touch-packages] [Bug 1540168] Re: Update OpenCV version for 16.04

2017-04-03 Thread Mattia Rizzolo
As several people explained, that's not going to happen. Libraries like this don't get updated in stable releases, much less when they are not even yet in the current development release... (it will be for zesty+1 though, I intend to make sure of it...) ** Changed in: opencv (Ubuntu)

[Touch-packages] [Bug 1031768] Re: python-opencv missing depend python-numpy

2017-04-03 Thread Mattia Rizzolo
This has been fixed at some point (for sure 2.4.1+dfsg-0exp1 had it). ** Changed in: opencv (Ubuntu) Status: New => Fix Released -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to opencv in Ubuntu.

[Touch-packages] [Bug 875382] Re: package libcv-dev (not installed) failed to install/upgrade: a tentar sobre-escrever '/usr/bin/opencv_haartraining', que também está no pacote libopencv2.3 2.3.1 svn6

2017-04-03 Thread Mattia Rizzolo
natty is not supported anymore, and right now all of opencv is installable. ** Changed in: opencv (Ubuntu) Status: Confirmed => Invalid -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to opencv in Ubuntu.

[Touch-packages] [Bug 600074] Re: opencv-doc does not contain actual documentation

2017-04-03 Thread Mattia Rizzolo
** Bug watch added: Debian Bug tracker #822483 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=822483 ** Also affects: opencv (Debian) via http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=822483 Importance: Unknown Status: Unknown -- You received this bug notification because

[Touch-packages] [Bug 1571338] Re: add python3+opencv

2017-04-03 Thread Mattia Rizzolo
*** This bug is a duplicate of bug 1556156 *** https://bugs.launchpad.net/bugs/1556156 ** This bug has been marked a duplicate of bug 1556156 OpenCV lacks Python 3 bindings -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed

[Touch-packages] [Bug 1675138] Re: Please transition to Boost 1.62

2017-03-27 Thread Mattia Rizzolo
FWIW, the fix for this bug in the -2 upload, waiting in the unapproved queue, until somebody from the release team approves it… (and it's been there for nearly 3 days already…). ** Changed in: mir (Ubuntu) Status: Triaged => Fix Committed -- You received this bug notification because you

[Touch-packages] [Bug 1675138] Re: Please transition to Boost 1.62

2017-03-23 Thread Mattia Rizzolo
I'd really appreciate if it could be scheduled for 0.26.2, actually. It's a packaging-only change, making progress on a transition. I'm not involved in this boost transition myself, but I know I hate any kind of delay. Besides, to me it looks like mir is the last actionable package on the list

[Touch-packages] [Bug 1675138] Re: Please transition to Boost 1.62

2017-03-23 Thread Mattia Rizzolo
Thank you for merging! What is the expected time frame for the next upload to the archive, containing this change? -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mir in Ubuntu. https://bugs.launchpad.net/bugs/1675138

[Touch-packages] [Bug 1675138] Re: Please transition to Boost 1.62

2017-03-22 Thread Mattia Rizzolo
ntu) Assignee: (unassigned) => Mattia Rizzolo (mapreri) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mir in Ubuntu. https://bugs.launchpad.net/bugs/1675138 Title: Please transition to Boost 1.62 Status in mir package in

[Touch-packages] [Bug 1675138] Re: Please transition to Boost 1.62

2017-03-22 Thread Mattia Rizzolo
why can't mir depend on unversioned boost? -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mir in Ubuntu. https://bugs.launchpad.net/bugs/1675138 Title: Please transition to Boost 1.62 Status in mir package in Ubuntu:

[Touch-packages] [Bug 1672941] Re: FTBFS with older versions of OpenSSL

2017-03-15 Thread Mattia Rizzolo
** Description changed: - cyrus-sasl2 currently FTBFS in Yakkety because we have an older version - of OpenSSL than in Debian (1.0.2 vs 1.1.0). There was a patch upstream - to fix this: https://github.com/cyrusimap/cyrus- + cyrus-sasl2 currently FTBFS in Zesty because we have an older version of

[Touch-packages] [Bug 1187448] Re: package libharfbuzz-dev 0.9.18-3 failed to install/upgrade: error writing to '': No such file or directory

2017-01-23 Thread Mattia Rizzolo
Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been

[Touch-packages] [Bug 1647204] Re: 1.8.0-2 FTBFS in zesty 17.04

2016-12-27 Thread Mattia Rizzolo
No, that's not really acceptable. firstly +pic is not an hardening option AFAIK, what you effectively did was disabling pie. Then I don't particularly like disabling tests just because they hang; please somebody investigate why they hang and actually fix them. Unsubscribing sponsors for now.

[Touch-packages] [Bug 1575255] [NEW] RM: hunspell-sv -- obsolete; replaced by hunspell-sv from libreoffice-dictionaries

2016-04-26 Thread Mattia Rizzolo
Public bug reported: Currently this package builds only a transitional package (myspell-sv-se) which in turns depends on another transitional package (hunspell-sv-se, which has been hijacked by src:libreoffice-dictionaries) which depends on hunspell-sv. Time to remove it. According to my

[Touch-packages] [Bug 1510198] Re: [FFe] Sync (almost) with libreoffice-dictionaries in Debian sid

2016-03-08 Thread Mattia Rizzolo
\o/ Thanks you all! -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to hunspell-en-us in Ubuntu. https://bugs.launchpad.net/bugs/1510198 Title: [FFe] Sync (almost) with libreoffice-dictionaries in Debian sid Status in

Re: [Touch-packages] [Bug 1510198] Re: [FFe] Sync (almost) with libreoffice-dictionaries in Debian sid

2016-03-03 Thread Mattia Rizzolo
To ease this, I just uploaded to debian a -2 including some of those changes, so maybe rebase. > Basically the Ubuntu/Debian delta in lo-dicts consists of two [...] > Would appreciate your comments before I ask for upload sponsoring. I think it makes a lot of sense, please try going ahead. As

[Touch-packages] [Bug 1203496] Re: micompilation of autoconf stack growth test at -O > 0 on ARM

2016-01-13 Thread Mattia Rizzolo
librep workarounded it in 0.90.2-1.4ubuntu1. ** Changed in: librep (Ubuntu) Status: New => Fix Released -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to gcc-4.8 in Ubuntu. https://bugs.launchpad.net/bugs/1203496

[Touch-packages] [Bug 268953] Re: [needs-packaging] provide all dictionaries available for hunspell

2015-10-16 Thread Mattia Rizzolo
Exactly. I strongly believe the bundle made by libreoffice-dictionaries is quite a good one, and I'm not the only one thinking that. Now, if there are two dictionaries for the same language we'll probably going to just pick the one in LO-dicts, since that's way easier to handle from a

  1   2   >