[Touch-packages] [Bug 1925211] Re: Hot-unplug of disks leaves broken block devices around in Hirsute on s390x

2021-04-21 Thread Seth Forshee
** Description changed:

+ SRU Justification
+ 
+ [Impact]
+ 
+ Hot removal of disks under kvm on s390 does not result in the kernel
+ removing the block device, which can lead to hung tasks and other
+ issues.
+ 
+ [Test Plan]
+ 
+ See steps to reproduce the bug in the original description below. To
+ test, execute these steps and confirm that the block device gets removed
+ as expected.
+ 
+ [Where problems could occur]
+ 
+ The fix is a revert of the changes which introduced this regression. The
+ original commit was a removal of supposedly unused code, but it seems a
+ mistake was made in the logic around unregistering of disks. Reverting
+ the changes could have potential to introduce bugs related to other virt
+ devices, especially if it interacts badly with subsequent driver
+ changes. However, the patch reverted cleanly, and reverting restores the
+ code to the state which has been working well in previous kernels and
+ seems like the lowest risk option until a proper fix is available
+ upstream.
+ 
+ ---
+ 
  Repro:
  #1 Get a guest
  $ uvt-kvm create --disk 5  --password=ubuntu h release=hirsute arch=s390x 
label=daily
  $ uvt-kvm wait h release=hirsute arch=s390x label=daily
  
  #2 Attach and Detach disk
  $ sudo qemu-img create -f qcow2 /var/lib/libvirt/images/test.qcow2 10M
  $ virsh attach-disk h /var/lib/libvirt/images/test.qcow2 vdc
  $ virsh detach-disk h vdc
- 
  
  From libvirts POV it is gone at this point
  $ virsh domblklist h
   Target   Source
  --
   vda  /var/lib/uvtool/libvirt/images/hirsute-2nd-zfs.qcow
   vdb  /var/lib/uvtool/libvirt/images/hirsute-2nd-zfs-ds.qcow
  
  But the guest thinks still it is present
  $ uvt-kvm ssh --insecure hirsute-2nd-zfs lsblk
    ...
    vdc252:32   0   20M  0 disk
  
  This even remains a while after (not a race).
  
  Any access to it in the guest will hang (as you'd expect of a non-existing 
blockdev)
  4 017581739  20   0  12140  4800 -  S+   pts/0  0:00  |   
\_ sudo mkfs.ext4 /dev/vdc
  4 017591758  20   0   6924  1044 -  D+   pts/0  0:00  |   
\_ mkfs.ext4 /dev/vdc
  
  The result above was originally found with hirsute-guest@hirsute-host on
  s390x
  
  I do NOT see the same with  groovy-guest@hirsute-host on s390x
  I DO see the same with hirsute-guest@groovy-host on s390x
    => Guest version dependent not Host/Hipervisor dependent
  I DO see the same with ZFS disks AND LVM disks being added
    => not type dependent
  I do NOT see the same on x86.
    => Arch dependent ??
  
  ... the evidence slowly points towards an issue in the guest, damn we are so
  close to release - but non-fully detaching disks are critical in my POV :-/
  
  Filing this as-is for awareness, but certainly this will need more debugging.
  Unsure where this is going to eventually I'll now file it for 
kernel/udev/systemd.
  If there are any known issues/components that are related let me know please!
- --- 
+ ---
  ProblemType: Bug
  AlsaDevices: Error: command ['ls', '-l', '/dev/snd/'] failed with exit code 
2: ls: cannot access '/dev/snd/': No such file or directory
  AplayDevices: Error: [Errno 2] No such file or directory: 'aplay'
  ApportVersion: 2.20.11-0ubuntu65
  Architecture: s390x
  ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord'
  CRDA: N/A
  CasperMD5CheckResult: unknown
  DistroRelease: Ubuntu 21.04
  IwConfig: Error: [Errno 2] No such file or directory: 'iwconfig'
  Lspci:
-  
+ 
  Lspci-vt: -[:00]-
  Lsusb: Error: command ['lsusb'] failed with exit code 1:
  Lsusb-t: Error: command ['lsusb', '-t'] failed with exit code 1: 
/sys/bus/usb/devices: No such file or directory
  Lsusb-v: Error: command ['lsusb', '-v'] failed with exit code 1:
  Package: udev
  PackageArchitecture: s390x
  PciMultimedia:
-  
+ 
  ProcFB:
-  
+ 
  ProcKernelCmdLine: root=LABEL=cloudimg-rootfs
  ProcVersionSignature: User Name 5.11.0-14.15-generic 5.11.12
  RelatedPackageVersions:
-  linux-restricted-modules-5.11.0-14-generic N/A
-  linux-backports-modules-5.11.0-14-generic  N/A
-  linux-firmware N/A
+  linux-restricted-modules-5.11.0-14-generic N/A
+  linux-backports-modules-5.11.0-14-generic  N/A
+  linux-firmware N/A
  RfKill: Error: [Errno 2] No such file or directory: 'rfkill'
  Tags:  hirsute uec-images
  Uname: Linux 5.11.0-14-generic s390x
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm audio cdrom dialout dip floppy lxd netdev plugdev sudo video
  _MarkForUpload: True
  acpidump:

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1925211

Title:
  Hot-unplug of disks leaves broken block devices around in Hirsute on
  s390x

Status in Ubuntu on IBM z Systems:
  Triaged
Status in linux package in 

[Touch-packages] [Bug 1925211] Re: Hot-unplug of disks leaves broken block devices around in Hirsute on s390x

2021-04-21 Thread Seth Forshee
The condition for css_sch_device_unregister(sch) also caught my eye,
calling it unconditionally is probably closer to right because it was
called in the !cdev case before, and in the attached patch it would no
longer be called in this case. However I think in the short term the
revert is the safest option, since the code will match what we already
know was working in the groovy kernel. Once a fix is committed upstream,
we can trade out the revert for that patch.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1925211

Title:
  Hot-unplug of disks leaves broken block devices around in Hirsute on
  s390x

Status in Ubuntu on IBM z Systems:
  Triaged
Status in linux package in Ubuntu:
  Triaged
Status in systemd package in Ubuntu:
  Invalid
Status in udev package in Ubuntu:
  Invalid
Status in linux source package in Hirsute:
  Triaged
Status in systemd source package in Hirsute:
  Invalid
Status in udev source package in Hirsute:
  Invalid

Bug description:
  Repro:
  #1 Get a guest
  $ uvt-kvm create --disk 5  --password=ubuntu h release=hirsute arch=s390x 
label=daily
  $ uvt-kvm wait h release=hirsute arch=s390x label=daily

  #2 Attach and Detach disk
  $ sudo qemu-img create -f qcow2 /var/lib/libvirt/images/test.qcow2 10M
  $ virsh attach-disk h /var/lib/libvirt/images/test.qcow2 vdc
  $ virsh detach-disk h vdc

  
  From libvirts POV it is gone at this point
  $ virsh domblklist h
   Target   Source
  --
   vda  /var/lib/uvtool/libvirt/images/hirsute-2nd-zfs.qcow
   vdb  /var/lib/uvtool/libvirt/images/hirsute-2nd-zfs-ds.qcow

  But the guest thinks still it is present
  $ uvt-kvm ssh --insecure hirsute-2nd-zfs lsblk
    ...
    vdc252:32   0   20M  0 disk

  This even remains a while after (not a race).

  Any access to it in the guest will hang (as you'd expect of a non-existing 
blockdev)
  4 017581739  20   0  12140  4800 -  S+   pts/0  0:00  |   
\_ sudo mkfs.ext4 /dev/vdc
  4 017591758  20   0   6924  1044 -  D+   pts/0  0:00  |   
\_ mkfs.ext4 /dev/vdc

  The result above was originally found with hirsute-guest@hirsute-host
  on s390x

  I do NOT see the same with  groovy-guest@hirsute-host on s390x
  I DO see the same with hirsute-guest@groovy-host on s390x
    => Guest version dependent not Host/Hipervisor dependent
  I DO see the same with ZFS disks AND LVM disks being added
    => not type dependent
  I do NOT see the same on x86.
    => Arch dependent ??

  ... the evidence slowly points towards an issue in the guest, damn we are so
  close to release - but non-fully detaching disks are critical in my POV :-/

  Filing this as-is for awareness, but certainly this will need more debugging.
  Unsure where this is going to eventually I'll now file it for 
kernel/udev/systemd.
  If there are any known issues/components that are related let me know please!
  --- 
  ProblemType: Bug
  AlsaDevices: Error: command ['ls', '-l', '/dev/snd/'] failed with exit code 
2: ls: cannot access '/dev/snd/': No such file or directory
  AplayDevices: Error: [Errno 2] No such file or directory: 'aplay'
  ApportVersion: 2.20.11-0ubuntu65
  Architecture: s390x
  ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord'
  CRDA: N/A
  CasperMD5CheckResult: unknown
  DistroRelease: Ubuntu 21.04
  IwConfig: Error: [Errno 2] No such file or directory: 'iwconfig'
  Lspci:
   
  Lspci-vt: -[:00]-
  Lsusb: Error: command ['lsusb'] failed with exit code 1:
  Lsusb-t: Error: command ['lsusb', '-t'] failed with exit code 1: 
/sys/bus/usb/devices: No such file or directory
  Lsusb-v: Error: command ['lsusb', '-v'] failed with exit code 1:
  Package: udev
  PackageArchitecture: s390x
  PciMultimedia:
   
  ProcFB:
   
  ProcKernelCmdLine: root=LABEL=cloudimg-rootfs
  ProcVersionSignature: User Name 5.11.0-14.15-generic 5.11.12
  RelatedPackageVersions:
   linux-restricted-modules-5.11.0-14-generic N/A
   linux-backports-modules-5.11.0-14-generic  N/A
   linux-firmware N/A
  RfKill: Error: [Errno 2] No such file or directory: 'rfkill'
  Tags:  hirsute uec-images
  Uname: Linux 5.11.0-14-generic s390x
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm audio cdrom dialout dip floppy lxd netdev plugdev sudo video
  _MarkForUpload: True
  acpidump:

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-z-systems/+bug/1925211/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1925211] Re: Hot-unplug of disks leaves broken block devices around in Hirsute

2021-04-20 Thread Seth Forshee
The commit reverts cleanly. We need to confirm that reverting the commit
does fix the issue. I put a test build here, please test.

https://people.canonical.com/~sforshee/lp1925211/

I doubt we can get a new kernel into the release. If it's extremely
urgent we can consider a day 0 SRU kernel for hirsute, otherwise we can
make sure it gets into the first normal SRU kernel.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1925211

Title:
  Hot-unplug of disks leaves broken block devices around in Hirsute

Status in linux package in Ubuntu:
  Confirmed
Status in systemd package in Ubuntu:
  New
Status in udev package in Ubuntu:
  New
Status in linux source package in Hirsute:
  Confirmed
Status in systemd source package in Hirsute:
  New
Status in udev source package in Hirsute:
  New

Bug description:
  Repro:
  #1 Get a guest
  $ uvt-kvm create --disk 5  --password=ubuntu h release=hirsute arch=s390x 
label=daily
  $ uvt-kvm wait h release=hirsute arch=s390x label=daily

  #2 Attach and Detach disk
  $ sudo qemu-img create -f qcow2 /var/lib/libvirt/images/test.qcow2 10M
  $ virsh attach-disk h /var/lib/libvirt/images/test.qcow2 vdc
  $ virsh detach-disk h vdc

  
  From libvirts POV it is gone at this point
  $ virsh domblklist h
   Target   Source
  --
   vda  /var/lib/uvtool/libvirt/images/hirsute-2nd-zfs.qcow
   vdb  /var/lib/uvtool/libvirt/images/hirsute-2nd-zfs-ds.qcow

  But the guest thinks still it is present
  $ uvt-kvm ssh --insecure hirsute-2nd-zfs lsblk
    ...
    vdc252:32   0   20M  0 disk

  This even remains a while after (not a race).

  Any access to it in the guest will hang (as you'd expect of a non-existing 
blockdev)
  4 017581739  20   0  12140  4800 -  S+   pts/0  0:00  |   
\_ sudo mkfs.ext4 /dev/vdc
  4 017591758  20   0   6924  1044 -  D+   pts/0  0:00  |   
\_ mkfs.ext4 /dev/vdc

  The result above was originally found with hirsute-guest@hirsute-host
  on s390x

  I do NOT see the same with  groovy-guest@hirsute-host on s390x
  I DO see the same with hirsute-guest@groovy-host on s390x
    => Guest version dependent not Host/Hipervisor dependent
  I DO see the same with ZFS disks AND LVM disks being added
    => not type dependent
  I do NOT see the same on x86.
    => Arch dependent ??

  ... the evidence slowly points towards an issue in the guest, damn we are so
  close to release - but non-fully detaching disks are critical in my POV :-/

  Filing this as-is for awareness, but certainly this will need more debugging.
  Unsure where this is going to eventually I'll now file it for 
kernel/udev/systemd.
  If there are any known issues/components that are related let me know please!
  --- 
  ProblemType: Bug
  AlsaDevices: Error: command ['ls', '-l', '/dev/snd/'] failed with exit code 
2: ls: cannot access '/dev/snd/': No such file or directory
  AplayDevices: Error: [Errno 2] No such file or directory: 'aplay'
  ApportVersion: 2.20.11-0ubuntu65
  Architecture: s390x
  ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord'
  CRDA: N/A
  CasperMD5CheckResult: unknown
  DistroRelease: Ubuntu 21.04
  IwConfig: Error: [Errno 2] No such file or directory: 'iwconfig'
  Lspci:
   
  Lspci-vt: -[:00]-
  Lsusb: Error: command ['lsusb'] failed with exit code 1:
  Lsusb-t: Error: command ['lsusb', '-t'] failed with exit code 1: 
/sys/bus/usb/devices: No such file or directory
  Lsusb-v: Error: command ['lsusb', '-v'] failed with exit code 1:
  Package: udev
  PackageArchitecture: s390x
  PciMultimedia:
   
  ProcFB:
   
  ProcKernelCmdLine: root=LABEL=cloudimg-rootfs
  ProcVersionSignature: User Name 5.11.0-14.15-generic 5.11.12
  RelatedPackageVersions:
   linux-restricted-modules-5.11.0-14-generic N/A
   linux-backports-modules-5.11.0-14-generic  N/A
   linux-firmware N/A
  RfKill: Error: [Errno 2] No such file or directory: 'rfkill'
  Tags:  hirsute uec-images
  Uname: Linux 5.11.0-14-generic s390x
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm audio cdrom dialout dip floppy lxd netdev plugdev sudo video
  _MarkForUpload: True
  acpidump:

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1925211/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1907307] Re: lxc 1:4.0.4-0ubuntu3 ADT test failure with linux 5.10.0-7.8

2020-12-08 Thread Seth Forshee
lxc-test-api-reboot fails. The container fails to start, I see lots of
errors in the logs related to mounting things.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lxc in Ubuntu.
https://bugs.launchpad.net/bugs/1907307

Title:
  lxc 1:4.0.4-0ubuntu3 ADT test failure with linux 5.10.0-7.8

Status in lxc package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-hirsute-canonical-kernel-team-bootstrap/hirsute/amd64/l/lxc/20201208_183047_03358@/log.gz
  arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-hirsute-canonical-kernel-team-bootstrap/hirsute/arm64/l/lxc/20201208_193132_88a43@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-hirsute-canonical-kernel-team-bootstrap/hirsute/ppc64el/l/lxc/20201208_194831_12ffc@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-hirsute-canonical-kernel-team-bootstrap/hirsute/s390x/l/lxc/20201208_175951_b132c@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/1907307/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1907307] [NEW] lxc 1:4.0.4-0ubuntu3 ADT test failure with linux 5.10.0-7.8

2020-12-08 Thread Seth Forshee
Public bug reported:

Testing failed on:
amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-hirsute-canonical-kernel-team-bootstrap/hirsute/amd64/l/lxc/20201208_183047_03358@/log.gz
arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-hirsute-canonical-kernel-team-bootstrap/hirsute/arm64/l/lxc/20201208_193132_88a43@/log.gz
ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-hirsute-canonical-kernel-team-bootstrap/hirsute/ppc64el/l/lxc/20201208_194831_12ffc@/log.gz
s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-hirsute-canonical-kernel-team-bootstrap/hirsute/s390x/l/lxc/20201208_175951_b132c@/log.gz

** Affects: lxc (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: kernel-adt-failure

** Tags added: kernel-adt-failure

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lxc in Ubuntu.
https://bugs.launchpad.net/bugs/1907307

Title:
  lxc 1:4.0.4-0ubuntu3 ADT test failure with linux 5.10.0-7.8

Status in lxc package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-hirsute-canonical-kernel-team-bootstrap/hirsute/amd64/l/lxc/20201208_183047_03358@/log.gz
  arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-hirsute-canonical-kernel-team-bootstrap/hirsute/arm64/l/lxc/20201208_193132_88a43@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-hirsute-canonical-kernel-team-bootstrap/hirsute/ppc64el/l/lxc/20201208_194831_12ffc@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-hirsute-canonical-kernel-team-bootstrap/hirsute/s390x/l/lxc/20201208_175951_b132c@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/1907307/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1895426] Re: package linux-firmware 1.187.3 failed to install/upgrade: installed linux-firmware package post-installation script subprocess returned error exit status 1

2020-09-14 Thread Seth Forshee
Looks like a problem generating a new initramfs:

update-initramfs: Generating /boot/initrd.img-5.4.0-47-generic
mv: cannot stat '/boot/initrd.img-5.4.0-47-generic.new': No such file or 
directory

I don't see any information about what went wrong though. The disk isn't
full, so that's not the problem.

Adding initramfs-tools. I don't see any reason to think this is a linux-
firmware problem right now, so setting that to invalid.

** Also affects: initramfs-tools (Ubuntu)
   Importance: Undecided
   Status: New

** Changed in: linux-firmware (Ubuntu)
   Status: New => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1895426

Title:
  package linux-firmware 1.187.3 failed to install/upgrade: installed
  linux-firmware package post-installation script subprocess returned
  error exit status 1

Status in initramfs-tools package in Ubuntu:
  New
Status in linux-firmware package in Ubuntu:
  Invalid

Bug description:
  linux-firmware bug

  ProblemType: Package
  DistroRelease: Ubuntu 20.04
  Package: linux-firmware 1.187.3
  ProcVersionSignature: Ubuntu 5.4.0-47.51-generic 5.4.55
  Uname: Linux 5.4.0-47-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.8
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  tirtha 1397 F pulseaudio
  CasperMD5CheckResult: skip
  Date: Sun Sep 13 11:45:12 2020
  Dependencies:
   
  ErrorMessage: installed linux-firmware package post-installation script 
subprocess returned error exit status 1
  InstallationDate: Installed on 2020-09-13 (0 days ago)
  InstallationMedia: Ubuntu 20.04.1 LTS "Focal Fossa" - Release amd64 (20200731)
  IwConfig:
   lono wireless extensions.
   
   enp0s3no wireless extensions.
  Lsusb:
   Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
   Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  Lsusb-t:
   /:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ohci-pci/12p, 12M
   |__ Port 1: Dev 2, If 0, Class=Human Interface Device, Driver=usbhid, 12M
  MachineType: innotek GmbH VirtualBox
  PackageArchitecture: all
  ProcFB: 0 svgadrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-47-generic 
root=UUID=a24d343d-9753-4460-ac8f-43882d4197c7 ro quiet splash
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
  Python3Details: /usr/bin/python3.8, Python 3.8.2, python3-minimal, 
3.8.2-0ubuntu2
  PythonDetails: N/A
  RelatedPackageVersions: grub-pc 2.04-1ubuntu26.3
  RfKill:
   
  SourcePackage: linux-firmware
  Title: package linux-firmware 1.187.3 failed to install/upgrade: installed 
linux-firmware package post-installation script subprocess returned error exit 
status 1
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 12/01/2006
  dmi.bios.vendor: innotek GmbH
  dmi.bios.version: VirtualBox
  dmi.board.name: VirtualBox
  dmi.board.vendor: Oracle Corporation
  dmi.board.version: 1.2
  dmi.chassis.type: 1
  dmi.chassis.vendor: Oracle Corporation
  dmi.modalias: 
dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:rvnOracleCorporation:rnVirtualBox:rvr1.2:cvnOracleCorporation:ct1:cvr:
  dmi.product.family: Virtual Machine
  dmi.product.name: VirtualBox
  dmi.product.version: 1.2
  dmi.sys.vendor: innotek GmbH

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1895426/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890913] Re: init is using 100% of processor

2020-08-19 Thread Seth Forshee
These messages show up repeatedly in the journal:

Aug 19 21:33:11 ubuntu-x1 systemd[1]: Failed to start Process error reports 
when automatic reporting is enabled.
Aug 19 21:33:11 ubuntu-x1 systemd[1]: apport-autoreport.service: Start request 
repeated too quickly.
Aug 19 21:33:11 ubuntu-x1 systemd[1]: apport-autoreport.service: Failed with 
result 'start-limit-hit'.

They stop when I mask the service.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1890913

Title:
  init is using 100% of processor

Status in apport package in Ubuntu:
  New
Status in linux package in Ubuntu:
  Incomplete
Status in systemd package in Ubuntu:
  New

Bug description:
  the `sbin/init splash` process is using more than 100% of processor
  after boot.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.10
  Package: systemd 246-2ubuntu1
  ProcVersionSignature: Ubuntu 5.8.0-12.13-generic 5.8.0-rc7
  Uname: Linux 5.8.0-12-generic x86_64
  ApportVersion: 2.20.11-0ubuntu44
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  CurrentDmesg: Error: command ['dmesg'] failed with exit code 1: dmesg: read 
kernel buffer failed: Operation not permitted
  Date: Sat Aug  8 22:14:37 2020
  InstallationDate: Installed on 2019-11-01 (280 days ago)
  InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
  MachineType: LENOVO 2349KEG
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.8.0-12-generic 
root=/dev/mapper/vgubuntu-root ro i915.fastboot=1 quiet splash vt.handoff=7
  SourcePackage: systemd
  SystemdDelta:
   [EXTENDED]   /usr/lib/systemd/system/rc-local.service → 
/usr/lib/systemd/system/rc-local.service.d/debian.conf
   [EXTENDED]   /usr/lib/systemd/system/user@.service → 
/usr/lib/systemd/system/user@.service.d/timeout.conf
   
   2 overridden configuration files found.
  SystemdFailedUnits:
   Error: command ['systemctl', 'status', '--full', '●'] failed with exit code 
4: Invalid unit name "●" escaped as "\xe2\x97\x8f" (maybe you should use 
systemd-escape?).
   Unit \xe2\x97\x8f.service could not be found.
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/07/2019
  dmi.bios.release: 2.82
  dmi.bios.vendor: LENOVO
  dmi.bios.version: G1ETC2WW (2.82 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 2349KEG
  dmi.board.vendor: LENOVO
  dmi.board.version: Win8 Pro DPK TPG
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.ec.firmware.release: 1.14
  dmi.modalias: 
dmi:bvnLENOVO:bvrG1ETC2WW(2.82):bd08/07/2019:br2.82:efr1.14:svnLENOVO:pn2349KEG:pvrThinkPadT430:rvnLENOVO:rn2349KEG:rvrWin8ProDPKTPG:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.family: ThinkPad T430
  dmi.product.name: 2349KEG
  dmi.product.sku: LENOVO_MT_2349
  dmi.product.version: ThinkPad T430
  dmi.sys.vendor: LENOVO
  modified.conffile..etc.default.apport:
   # set this to 0 to disable apport, or to 1 to enable it
   # you can temporarily override this with
   # sudo service apport start force_start=1
   enabled=0
  mtime.conffile..etc.default.apport: 2020-08-08T22:11:41.151132

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apport/+bug/1890913/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890913] Re: init is using 100% of processor

2020-08-19 Thread Seth Forshee
I should note, I did not update systemd in isolation. I can provide a
complete list of packages installed/upgrade at the same time if that is
helpful.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1890913

Title:
  init is using 100% of processor

Status in apport package in Ubuntu:
  New
Status in linux package in Ubuntu:
  Incomplete
Status in systemd package in Ubuntu:
  New

Bug description:
  the `sbin/init splash` process is using more than 100% of processor
  after boot.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.10
  Package: systemd 246-2ubuntu1
  ProcVersionSignature: Ubuntu 5.8.0-12.13-generic 5.8.0-rc7
  Uname: Linux 5.8.0-12-generic x86_64
  ApportVersion: 2.20.11-0ubuntu44
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  CurrentDmesg: Error: command ['dmesg'] failed with exit code 1: dmesg: read 
kernel buffer failed: Operation not permitted
  Date: Sat Aug  8 22:14:37 2020
  InstallationDate: Installed on 2019-11-01 (280 days ago)
  InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
  MachineType: LENOVO 2349KEG
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.8.0-12-generic 
root=/dev/mapper/vgubuntu-root ro i915.fastboot=1 quiet splash vt.handoff=7
  SourcePackage: systemd
  SystemdDelta:
   [EXTENDED]   /usr/lib/systemd/system/rc-local.service → 
/usr/lib/systemd/system/rc-local.service.d/debian.conf
   [EXTENDED]   /usr/lib/systemd/system/user@.service → 
/usr/lib/systemd/system/user@.service.d/timeout.conf
   
   2 overridden configuration files found.
  SystemdFailedUnits:
   Error: command ['systemctl', 'status', '--full', '●'] failed with exit code 
4: Invalid unit name "●" escaped as "\xe2\x97\x8f" (maybe you should use 
systemd-escape?).
   Unit \xe2\x97\x8f.service could not be found.
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/07/2019
  dmi.bios.release: 2.82
  dmi.bios.vendor: LENOVO
  dmi.bios.version: G1ETC2WW (2.82 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 2349KEG
  dmi.board.vendor: LENOVO
  dmi.board.version: Win8 Pro DPK TPG
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.ec.firmware.release: 1.14
  dmi.modalias: 
dmi:bvnLENOVO:bvrG1ETC2WW(2.82):bd08/07/2019:br2.82:efr1.14:svnLENOVO:pn2349KEG:pvrThinkPadT430:rvnLENOVO:rn2349KEG:rvrWin8ProDPKTPG:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.family: ThinkPad T430
  dmi.product.name: 2349KEG
  dmi.product.sku: LENOVO_MT_2349
  dmi.product.version: ThinkPad T430
  dmi.sys.vendor: LENOVO
  modified.conffile..etc.default.apport:
   # set this to 0 to disable apport, or to 1 to enable it
   # you can temporarily override this with
   # sudo service apport start force_start=1
   enabled=0
  mtime.conffile..etc.default.apport: 2020-08-08T22:11:41.151132

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apport/+bug/1890913/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890913] Re: init is using 100% of processor

2020-08-19 Thread Seth Forshee
I hadn't seen this bug before today when I noticed that it's blocking my
kernel in groovy-proposed. I upgraded systemd, and I am seeing this
issue. But when I boot back to 5.4.0-37 the problem persists, so it
doesn't seem to have anything to do with the 5.8 kernel.

It seems like a problem with apport-autoreport.service. I'm not an
expert on debugging system units, but I get the impression it was
constantly restarting -- it always seemed to be in the activating state,
but with a different pid each time I checked. 'systemd list-jobs' also
showed this service with a different job id each time I ran the command.
I was finally able to get out of this state by running 'systemctl mask
--runtime apport-autoreport.service'.

This clearly doesn't look like an issue with the 5.8 kernel since I also
see it with 5.4, so I'm removing the block-proposed tag.

** Tags removed: block-proposed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1890913

Title:
  init is using 100% of processor

Status in apport package in Ubuntu:
  New
Status in linux package in Ubuntu:
  Incomplete
Status in systemd package in Ubuntu:
  New

Bug description:
  the `sbin/init splash` process is using more than 100% of processor
  after boot.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.10
  Package: systemd 246-2ubuntu1
  ProcVersionSignature: Ubuntu 5.8.0-12.13-generic 5.8.0-rc7
  Uname: Linux 5.8.0-12-generic x86_64
  ApportVersion: 2.20.11-0ubuntu44
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  CurrentDmesg: Error: command ['dmesg'] failed with exit code 1: dmesg: read 
kernel buffer failed: Operation not permitted
  Date: Sat Aug  8 22:14:37 2020
  InstallationDate: Installed on 2019-11-01 (280 days ago)
  InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
  MachineType: LENOVO 2349KEG
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.8.0-12-generic 
root=/dev/mapper/vgubuntu-root ro i915.fastboot=1 quiet splash vt.handoff=7
  SourcePackage: systemd
  SystemdDelta:
   [EXTENDED]   /usr/lib/systemd/system/rc-local.service → 
/usr/lib/systemd/system/rc-local.service.d/debian.conf
   [EXTENDED]   /usr/lib/systemd/system/user@.service → 
/usr/lib/systemd/system/user@.service.d/timeout.conf
   
   2 overridden configuration files found.
  SystemdFailedUnits:
   Error: command ['systemctl', 'status', '--full', '●'] failed with exit code 
4: Invalid unit name "●" escaped as "\xe2\x97\x8f" (maybe you should use 
systemd-escape?).
   Unit \xe2\x97\x8f.service could not be found.
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/07/2019
  dmi.bios.release: 2.82
  dmi.bios.vendor: LENOVO
  dmi.bios.version: G1ETC2WW (2.82 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 2349KEG
  dmi.board.vendor: LENOVO
  dmi.board.version: Win8 Pro DPK TPG
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.ec.firmware.release: 1.14
  dmi.modalias: 
dmi:bvnLENOVO:bvrG1ETC2WW(2.82):bd08/07/2019:br2.82:efr1.14:svnLENOVO:pn2349KEG:pvrThinkPadT430:rvnLENOVO:rn2349KEG:rvrWin8ProDPKTPG:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.family: ThinkPad T430
  dmi.product.name: 2349KEG
  dmi.product.sku: LENOVO_MT_2349
  dmi.product.version: ThinkPad T430
  dmi.sys.vendor: LENOVO
  modified.conffile..etc.default.apport:
   # set this to 0 to disable apport, or to 1 to enable it
   # you can temporarily override this with
   # sudo service apport start force_start=1
   enabled=0
  mtime.conffile..etc.default.apport: 2020-08-08T22:11:41.151132

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apport/+bug/1890913/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1890913] Re: init is using 100% of processor

2020-08-19 Thread Seth Forshee
** Also affects: systemd (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: apport (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1890913

Title:
  init is using 100% of processor

Status in apport package in Ubuntu:
  New
Status in linux package in Ubuntu:
  Incomplete
Status in systemd package in Ubuntu:
  New

Bug description:
  the `sbin/init splash` process is using more than 100% of processor
  after boot.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.10
  Package: systemd 246-2ubuntu1
  ProcVersionSignature: Ubuntu 5.8.0-12.13-generic 5.8.0-rc7
  Uname: Linux 5.8.0-12-generic x86_64
  ApportVersion: 2.20.11-0ubuntu44
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  CurrentDmesg: Error: command ['dmesg'] failed with exit code 1: dmesg: read 
kernel buffer failed: Operation not permitted
  Date: Sat Aug  8 22:14:37 2020
  InstallationDate: Installed on 2019-11-01 (280 days ago)
  InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
  MachineType: LENOVO 2349KEG
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.8.0-12-generic 
root=/dev/mapper/vgubuntu-root ro i915.fastboot=1 quiet splash vt.handoff=7
  SourcePackage: systemd
  SystemdDelta:
   [EXTENDED]   /usr/lib/systemd/system/rc-local.service → 
/usr/lib/systemd/system/rc-local.service.d/debian.conf
   [EXTENDED]   /usr/lib/systemd/system/user@.service → 
/usr/lib/systemd/system/user@.service.d/timeout.conf
   
   2 overridden configuration files found.
  SystemdFailedUnits:
   Error: command ['systemctl', 'status', '--full', '●'] failed with exit code 
4: Invalid unit name "●" escaped as "\xe2\x97\x8f" (maybe you should use 
systemd-escape?).
   Unit \xe2\x97\x8f.service could not be found.
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/07/2019
  dmi.bios.release: 2.82
  dmi.bios.vendor: LENOVO
  dmi.bios.version: G1ETC2WW (2.82 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 2349KEG
  dmi.board.vendor: LENOVO
  dmi.board.version: Win8 Pro DPK TPG
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.ec.firmware.release: 1.14
  dmi.modalias: 
dmi:bvnLENOVO:bvrG1ETC2WW(2.82):bd08/07/2019:br2.82:efr1.14:svnLENOVO:pn2349KEG:pvrThinkPadT430:rvnLENOVO:rn2349KEG:rvrWin8ProDPKTPG:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.family: ThinkPad T430
  dmi.product.name: 2349KEG
  dmi.product.sku: LENOVO_MT_2349
  dmi.product.version: ThinkPad T430
  dmi.sys.vendor: LENOVO
  modified.conffile..etc.default.apport:
   # set this to 0 to disable apport, or to 1 to enable it
   # you can temporarily override this with
   # sudo service apport start force_start=1
   enabled=0
  mtime.conffile..etc.default.apport: 2020-08-08T22:11:41.151132

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apport/+bug/1890913/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1891527] Re: systemd unit tests need updates for Linux 5.8 and later

2020-08-17 Thread Seth Forshee
Upstream fix:

https://github.com/systemd/systemd/pull/16734

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1891527

Title:
  systemd unit tests need updates for Linux 5.8 and later

Status in systemd:
  New
Status in systemd package in Ubuntu:
  New

Bug description:
  Linux 5.8 allows unprivileged creation of whiteout devices, causing a
  couple of test failures in systemd:

  == test-fs-util ===
  /* test_chase_symlinks */
  /* test_unlink_noerrno */
  /* test_readlink_and_make_absolute */
  /* test_var_tmp */
  /* test_dot_or_dot_dot */
  /* test_access_fd */
  /* test_touch_file */
  Assertion 'mknod(a, 0775 | S_IFBLK, makedev(0, 0)) >= 0' failed at 
src/test/test-fs-util.c:637, function test_touch_file(). Aborting.
  FAIL: test-fs-util (code: 134)
  ...
  == test-stat-util ===
  Assertion 'stat(path, ) >= 0' failed at src/test/test-stat-util.c:126, 
function test_device_path_make_canonical_one(). Aborting.
  FAIL: test-stat-util (code: 134)

  test-fs-util succeeds in making a character device with major/minor
  0,0, and thus assumes it will be able to create other devices, but it
  cannot.

  test-stat-util assumes that because /run/systemd/inaccessible/chr
  exists /run/systemd/inaccessible/blk should also exist, but it does
  not for the same reason.

To manage notifications about this bug go to:
https://bugs.launchpad.net/systemd/+bug/1891527/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1886050] Re: initramfs-tools 0.137ubuntu10 ADT test failure with linux-5.8 5.8.0-3.4

2020-08-13 Thread Seth Forshee
I'm getting an oops from launchpad trying to attach a debdiff to update
the package to fix the problem, so supplying a link instead:

https://people.canonical.com/~sforshee/initramfs-
tools_0.137ubuntu11.debdiff

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1886050

Title:
  initramfs-tools 0.137ubuntu10 ADT test failure with linux-5.8
  5.8.0-3.4

Status in initramfs-tools package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/amd64/i/initramfs-tools/20200702_083751_cff4d@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1886050/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1891527] [NEW] systemd unit tests need updates for Linux 5.8 and later

2020-08-13 Thread Seth Forshee
Public bug reported:

Linux 5.8 allows unprivileged creation of whiteout devices, causing a
couple of test failures in systemd:

== test-fs-util ===
/* test_chase_symlinks */
/* test_unlink_noerrno */
/* test_readlink_and_make_absolute */
/* test_var_tmp */
/* test_dot_or_dot_dot */
/* test_access_fd */
/* test_touch_file */
Assertion 'mknod(a, 0775 | S_IFBLK, makedev(0, 0)) >= 0' failed at 
src/test/test-fs-util.c:637, function test_touch_file(). Aborting.
FAIL: test-fs-util (code: 134)
...
== test-stat-util ===
Assertion 'stat(path, ) >= 0' failed at src/test/test-stat-util.c:126, 
function test_device_path_make_canonical_one(). Aborting.
FAIL: test-stat-util (code: 134)

test-fs-util succeeds in making a character device with major/minor 0,0,
and thus assumes it will be able to create other devices, but it cannot.

test-stat-util assumes that because /run/systemd/inaccessible/chr exists
/run/systemd/inaccessible/blk should also exist, but it does not for the
same reason.

** Affects: systemd
 Importance: Unknown
 Status: Unknown

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New

** Bug watch added: github.com/systemd/systemd/issues #16721
   https://github.com/systemd/systemd/issues/16721

** Also affects: systemd via
   https://github.com/systemd/systemd/issues/16721
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1891527

Title:
  systemd unit tests need updates for Linux 5.8 and later

Status in systemd:
  Unknown
Status in systemd package in Ubuntu:
  New

Bug description:
  Linux 5.8 allows unprivileged creation of whiteout devices, causing a
  couple of test failures in systemd:

  == test-fs-util ===
  /* test_chase_symlinks */
  /* test_unlink_noerrno */
  /* test_readlink_and_make_absolute */
  /* test_var_tmp */
  /* test_dot_or_dot_dot */
  /* test_access_fd */
  /* test_touch_file */
  Assertion 'mknod(a, 0775 | S_IFBLK, makedev(0, 0)) >= 0' failed at 
src/test/test-fs-util.c:637, function test_touch_file(). Aborting.
  FAIL: test-fs-util (code: 134)
  ...
  == test-stat-util ===
  Assertion 'stat(path, ) >= 0' failed at src/test/test-stat-util.c:126, 
function test_device_path_make_canonical_one(). Aborting.
  FAIL: test-stat-util (code: 134)

  test-fs-util succeeds in making a character device with major/minor
  0,0, and thus assumes it will be able to create other devices, but it
  cannot.

  test-stat-util assumes that because /run/systemd/inaccessible/chr
  exists /run/systemd/inaccessible/blk should also exist, but it does
  not for the same reason.

To manage notifications about this bug go to:
https://bugs.launchpad.net/systemd/+bug/1891527/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1891527] Re: systemd unit tests need updates for Linux 5.8 and later

2020-08-13 Thread Seth Forshee
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac
/autopkgtest-groovy/groovy/amd64/s/systemd/20200812_210502_aa555@/log.gz

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1891527

Title:
  systemd unit tests need updates for Linux 5.8 and later

Status in systemd:
  Unknown
Status in systemd package in Ubuntu:
  New

Bug description:
  Linux 5.8 allows unprivileged creation of whiteout devices, causing a
  couple of test failures in systemd:

  == test-fs-util ===
  /* test_chase_symlinks */
  /* test_unlink_noerrno */
  /* test_readlink_and_make_absolute */
  /* test_var_tmp */
  /* test_dot_or_dot_dot */
  /* test_access_fd */
  /* test_touch_file */
  Assertion 'mknod(a, 0775 | S_IFBLK, makedev(0, 0)) >= 0' failed at 
src/test/test-fs-util.c:637, function test_touch_file(). Aborting.
  FAIL: test-fs-util (code: 134)
  ...
  == test-stat-util ===
  Assertion 'stat(path, ) >= 0' failed at src/test/test-stat-util.c:126, 
function test_device_path_make_canonical_one(). Aborting.
  FAIL: test-stat-util (code: 134)

  test-fs-util succeeds in making a character device with major/minor
  0,0, and thus assumes it will be able to create other devices, but it
  cannot.

  test-stat-util assumes that because /run/systemd/inaccessible/chr
  exists /run/systemd/inaccessible/blk should also exist, but it does
  not for the same reason.

To manage notifications about this bug go to:
https://bugs.launchpad.net/systemd/+bug/1891527/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1861941] Re: bcache by-uuid links disappear after mounting bcache0

2020-08-12 Thread Seth Forshee
** Also affects: linux (Ubuntu)
   Importance: Undecided
   Status: New

** Changed in: linux (Ubuntu)
   Status: New => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1861941

Title:
  bcache by-uuid links disappear after mounting bcache0

Status in bcache-tools package in Ubuntu:
  Fix Released
Status in linux package in Ubuntu:
  Fix Committed
Status in systemd package in Ubuntu:
  Fix Released
Status in bcache-tools source package in Bionic:
  Fix Committed
Status in systemd source package in Bionic:
  Won't Fix
Status in bcache-tools source package in Focal:
  Fix Released
Status in systemd source package in Focal:
  In Progress

Bug description:
  SRU TEAM: The last 2 commits show a summary for the merges/changes
  I added some specific (to Bionic) notes in the template.
  Thanks!

  [Impact]

   * bcache-tools udev created symlinks might disappear when other udev
  events are processed for the same devices.

   * after mkfs.XXX in /dev/bcacheY you might face a condition where
  /dev/bcache/by-{uuid,label}/zzz symlinks are gone.

   * /dev/bcache/by-{uuid,label}/ symlinks are important so bcache
  devices can be addressed by their UUIDs and not the ordering they were
  assembled (MAAS depends on this feature, for example).

   * it was also discussed in this bug that systemd-udev should *not*
  populate /dev/disk/by-uuid/ with symlinks of disks that were bcache
  backing devices. this was turned into a discussion whether blkid
  should report those or not, and this discussion "died" after sometime.
  This last item is what the systemd update is all about: to disallow
  /dev/disk/by-XXX/ creation for bcache backing devices (a simple
  change that will reduce end users confusion).

  [Test Case]

   * The reproducer script is here:

     https://paste.ubuntu.com/p/37KGy2Smnp/

   * Bionic can't reproduce the issue with the 18.04 kernel, nor with
  the HWE kernel. Nevertheless, it is preferable that Bionic also do the
  same thing: to read bcache superblock and feed environment for
  /dev/bcache/by-{uuid,label} symlinks creation.

  [Regression Potential]

   * We are not depending on bcache device udev events any more when
  creating the /dev/bcache/by-{uuid,label}/ symlinks. Instead, we are
  depending on a wrapper script that heads bcache device superblock. If
  there is a bug in this wrapper the symlinks wouldn't work.

   * Previously we were thinking in asking the kernel team to remove the
  bcache udev event delta script they've done for previous case (LP:
  #1729145). It creates the udev events that were being read and filling
  the symlinks. We decided not to remove those (just from Groovy and on)
  so we don't need to worry on Breaks/Conflicts in between the kernel
  package and bcache-tools (and udev)).

   * Long story short: kernel will continue to emit bcache udev events
  as it did previously but now those events won't be used by anything -
  after installing this SRU - because udev wrapper script is doing this
  job (and doing it properly)

  [Other Info]

  - Original Description:

  1.
  root@ubuntu:~# lsb_release -rd
  Description:  Ubuntu Focal Fossa (development branch)
  Release:  20.04

  2.
  root@ubuntu:~# lsb_release -rd
  Description:  Ubuntu Focal Fossa (development branch)
  Release:  20.04
  root@ubuntu:~# apt-cache policy linux-image-virtual
  linux-image-virtual:
    Installed: 5.4.0.12.15
    Candidate: 5.4.0.12.15
    Version table:
   *** 5.4.0.12.15 500
  500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages
  100 /var/lib/dpkg/status
  root@ubuntu:~# apt-cache policy linux-image-5.4.0-12-generic
  linux-image-5.4.0-12-generic:
    Installed: 5.4.0-12.15
    Candidate: 5.4.0-12.15
    Version table:
   *** 5.4.0-12.15 500
  500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages
  100 /var/lib/dpkg/status

  3. mount /dev/bcache0 && ls -al /dev/bcache/by-uuid/
  + ls -al /dev/bcache/by-uuid/
  total 0
  drwxr-xr-x 2 root root 60 Feb  4 23:31 .
  drwxr-xr-x 3 root root 60 Feb  4 23:31 ..
  lrwxrwxrwx 1 root root 13 Feb  4 23:31 abdfd1f6-44ce-4266-91db-24667b9ae51a 
-> ../../bcache0

  4.
  root@ubuntu:~# ls -al /dev/bcache/by-uuid
  ls: cannot access '/dev/bcache/by-uuid': No such file or directory

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: linux-image-5.4.0-12-generic 5.4.0-12.15
  ProcVersionSignature: Ubuntu 5.4.0-12.15-generic 5.4.8
  Uname: Linux 5.4.0-12-generic x86_64
  ApportVersion: 2.20.11-0ubuntu16
  Architecture: amd64
  Date: Tue Feb  4 23:31:52 2020
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   LANG=C.UTF-8
   SHELL=/bin/bash
  SourcePackage: linux-signed-5.4
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:

[Touch-packages] [Bug 1887577] Re: DEP8: Invalid capability setuid

2020-07-27 Thread Seth Forshee
I think the problem might be an unnecessary backslash in
common/Make.rules:

CAPABILITIES=$(shell echo "\#include " | cpp -dM |
LC_ALL=C sed -n -e '/CAP_EMPTY_SET/d' -e 's/^\#define[
\t]\+CAP_\([A-Z0-9_]\+\)[ \t]\+\([0-9xa-f]\+\)\(.*\)$$/CAP_\1/p' |
LC_ALL=C sort)

I wrote a dummy makefile to test this and $(CAPABILITIES) was empty.
Changing to this:

CAPABILITIES=$(shell echo "#include " | cpp -dM |
LC_ALL=C sed -n -e '/CAP_EMPTY_SET/d' -e 's/^\#define[
\t]\+CAP_\([A-Z0-9_]\+\)[ \t]\+\([0-9xa-f]\+\)\(.*\)$$/CAP_\1/p' |
LC_ALL=C sort)

gives what I think is the expected output.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apparmor in Ubuntu.
https://bugs.launchpad.net/bugs/1887577

Title:
  DEP8: Invalid capability setuid

Status in apparmor package in Ubuntu:
  New

Bug description:
  
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac
  /autopkgtest-
  groovy/groovy/amd64/a/apparmor/20200713_202347_dd214@/log.gz

  Excuses is showing apparmor failing dep8 tests when they are triggered
  by another package.

  last time apparmor was uploaded was on May 14th, and this is the
  package under test:

  https://launchpad.net/ubuntu/+source/apparmor/2.13.3-7ubuntu6

  
  The errors are like this:
  FAIL: test_profile_newer_rewrites_cache (__main__.AAParserAltCacheTests)
  --
  Traceback (most recent call last):
File "/tmp/tmp.40nJ4LqRYT/parser/tst/testlib.py", line 50, in 
new_unittest_func
  return unittest_func(self)
File "./caching.py", line 448, in test_profile_newer_rewrites_cache
  self._generate_cache_file()
File "./caching.py", line 257, in _generate_cache_file
  self.run_cmd_check(cmd)
File "/tmp/tmp.40nJ4LqRYT/parser/tst/testlib.py", line 73, in run_cmd_check
  self.assertEqual(rc, expected_rc, "Got return code %d, expected 
%d\nCommand run: %s\nOutput: %s" % (rc, expected_rc, (' '.join(command)), 
report))
  AssertionError: 1 != 0 : Got return code 1, expected 0
  Command run: ../apparmor_parser --config-file=./parser.conf --base 
/tmp/aa-caching-s3l9wndt --skip-kernel-load --cache-loc 
/tmp/aa-caching-s3l9wndt/cache --cache-loc 
/tmp/aa-caching-s3l9wndt/aa-alt-cachezi43qt78 -q --write-cache -r 
/tmp/aa-caching-s3l9wndt/sbin.pingy
  Output: AppArmor parser error for /tmp/aa-caching-s3l9wndt/sbin.pingy in 
/tmp/aa-caching-s3l9wndt/suid-abstraction at line 3: Invalid capability setuid.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apparmor/+bug/1887577/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1885755] Re: test-cap-list fails with Linux 5.8 due to new capabilities

2020-07-22 Thread Seth Forshee
The test still fails with systemd 245.6-3ubuntu3.

https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac
/autopkgtest-groovy-canonical-kernel-team-
bootstrap/groovy/amd64/s/systemd/20200721_162550_a22c1@/log.gz

** Changed in: systemd (Ubuntu)
   Status: Fix Released => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1885755

Title:
  test-cap-list fails with Linux 5.8 due to new capabilities

Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  == test-cap-list ===
  Assertion 'capability_set_to_string_alloc(c, ) == 0' failed at 
src/test/test-cap-list.c:60, function test_capability_set_one(). Aborting.
  FAIL: test-cap-list (code: 134)

  This seems to be a result of new capabilities added in 5.8. systemd
  builds an array to convert capability numbers to strings, and these
  new capabilities are not in its array, so the test bombs out when
  trying to look up the string for a capability it doesn't know about.
  Rebuilding systemd using headers from Linux 5.8 should fix this issue.

  
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/amd64/s/systemd/20200630_154532_b7979@/log.gz
  arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/arm64/s/systemd/20200630_155538_0c63d@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/ppc64el/s/systemd/20200630_162720_b3e1b@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/s390x/s/systemd/20200630_140417_c5bdb@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1885755/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1887542] Re: apparmor 2.13.3-7ubuntu6 ADT test failure with linux-5.8 5.8.0-6.7

2020-07-16 Thread Seth Forshee
This is a new failure, an autopkgtest run on July 7 did not have these
failures whereas a run on July 14 did, so something happened between
those dates. As noted I also seen tests with 5.4 and 5.7 kernels showing
the same errors:

http://autopkgtest.ubuntu.com/packages/a/apparmor

There the first failures appear on July 9, though there are tests
triggered by pam which pass after the first failures appears, which is
kind of odd. Both these pam-triggered tests and some later tests
triggered by tor which failed are using the 5.4.0-26 kernel though.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apparmor in Ubuntu.
https://bugs.launchpad.net/bugs/1887542

Title:
  apparmor 2.13.3-7ubuntu6 ADT test failure with linux-5.8 5.8.0-6.7

Status in apparmor package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/amd64/a/apparmor/20200714_133743_4383d@/log.gz
  arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/arm64/a/apparmor/20200714_14_bc148@/log.gz
  armhf: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/armhf/a/apparmor/20200714_141429_e2c2b@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/ppc64el/a/apparmor/20200714_121607_23fa9@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/s390x/a/apparmor/20200714_120404_d5ecf@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apparmor/+bug/1887542/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1885755] Re: systemd 245.6-1ubuntu1 ADT test failure with linux-5.8 5.8.0-3.4

2020-07-14 Thread Seth Forshee
** Description changed:

+ == test-cap-list ===
+ Assertion 'capability_set_to_string_alloc(c, ) == 0' failed at 
src/test/test-cap-list.c:60, function test_capability_set_one(). Aborting.
+ FAIL: test-cap-list (code: 134)
+ 
+ This seems to be a result of new capabilities added in 5.8. systemd
+ builds an array to convert capability numbers to strings, and these new
+ capabilities are not in its array, so the test bombs out when trying to
+ look up the string for a capability it doesn't know about. Rebuilding
+ systemd using headers from Linux 5.8 should fix this issue.
+ 
+ 
  Testing failed on:
- amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/amd64/s/systemd/20200630_154532_b7979@/log.gz
- arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/arm64/s/systemd/20200630_155538_0c63d@/log.gz
- ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/ppc64el/s/systemd/20200630_162720_b3e1b@/log.gz
- s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/s390x/s/systemd/20200630_140417_c5bdb@/log.gz
+ amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/amd64/s/systemd/20200630_154532_b7979@/log.gz
+ arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/arm64/s/systemd/20200630_155538_0c63d@/log.gz
+ ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/ppc64el/s/systemd/20200630_162720_b3e1b@/log.gz
+ s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/s390x/s/systemd/20200630_140417_c5bdb@/log.gz

** Summary changed:

- systemd 245.6-1ubuntu1 ADT test failure with linux-5.8 5.8.0-3.4
+ test-cap-list fails with Linux 5.8 due to new capabilities

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1885755

Title:
  test-cap-list fails with Linux 5.8 due to new capabilities

Status in systemd package in Ubuntu:
  New

Bug description:
  == test-cap-list ===
  Assertion 'capability_set_to_string_alloc(c, ) == 0' failed at 
src/test/test-cap-list.c:60, function test_capability_set_one(). Aborting.
  FAIL: test-cap-list (code: 134)

  This seems to be a result of new capabilities added in 5.8. systemd
  builds an array to convert capability numbers to strings, and these
  new capabilities are not in its array, so the test bombs out when
  trying to look up the string for a capability it doesn't know about.
  Rebuilding systemd using headers from Linux 5.8 should fix this issue.

  
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/amd64/s/systemd/20200630_154532_b7979@/log.gz
  arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/arm64/s/systemd/20200630_155538_0c63d@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/ppc64el/s/systemd/20200630_162720_b3e1b@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/s390x/s/systemd/20200630_140417_c5bdb@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1885755/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1887542] [NEW] apparmor 2.13.3-7ubuntu6 ADT test failure with linux-5.8 5.8.0-6.7

2020-07-14 Thread Seth Forshee
Public bug reported:

Testing failed on:
amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/amd64/a/apparmor/20200714_133743_4383d@/log.gz
arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/arm64/a/apparmor/20200714_14_bc148@/log.gz
armhf: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/armhf/a/apparmor/20200714_141429_e2c2b@/log.gz
ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/ppc64el/a/apparmor/20200714_121607_23fa9@/log.gz
s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/s390x/a/apparmor/20200714_120404_d5ecf@/log.gz

** Affects: apparmor (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: kernel-adt-failure

** Tags added: kernel-adt-failure

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apparmor in Ubuntu.
https://bugs.launchpad.net/bugs/1887542

Title:
  apparmor 2.13.3-7ubuntu6 ADT test failure with linux-5.8 5.8.0-6.7

Status in apparmor package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/amd64/a/apparmor/20200714_133743_4383d@/log.gz
  arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/arm64/a/apparmor/20200714_14_bc148@/log.gz
  armhf: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/armhf/a/apparmor/20200714_141429_e2c2b@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/ppc64el/a/apparmor/20200714_121607_23fa9@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/s390x/a/apparmor/20200714_120404_d5ecf@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apparmor/+bug/1887542/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1887542] Re: apparmor 2.13.3-7ubuntu6 ADT test failure with linux-5.8 5.8.0-6.7

2020-07-14 Thread Seth Forshee
Seeing these failures with 5.4, 5.7, and 5.8 kernels.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apparmor in Ubuntu.
https://bugs.launchpad.net/bugs/1887542

Title:
  apparmor 2.13.3-7ubuntu6 ADT test failure with linux-5.8 5.8.0-6.7

Status in apparmor package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/amd64/a/apparmor/20200714_133743_4383d@/log.gz
  arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/arm64/a/apparmor/20200714_14_bc148@/log.gz
  armhf: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/armhf/a/apparmor/20200714_141429_e2c2b@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/ppc64el/a/apparmor/20200714_121607_23fa9@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/s390x/a/apparmor/20200714_120404_d5ecf@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apparmor/+bug/1887542/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1886050] Re: initramfs-tools 0.137ubuntu10 ADT test failure with linux-5.8 5.8.0-3.4

2020-07-02 Thread Seth Forshee
This appears to be a race in debian/tests/run-image:

 dev=$(losetup -Pf --show "$IMAGE")
 mount "${dev}p1" mnt

It appears that loop0p1 is not ready before the mount command. I
reproduced the issue locally, and adding a 'sleep 1' between these lines
caused the test to pass.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1886050

Title:
  initramfs-tools 0.137ubuntu10 ADT test failure with linux-5.8
  5.8.0-3.4

Status in initramfs-tools package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/amd64/i/initramfs-tools/20200702_083751_cff4d@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1886050/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1886050] [NEW] initramfs-tools 0.137ubuntu10 ADT test failure with linux-5.8 5.8.0-3.4

2020-07-02 Thread Seth Forshee
Public bug reported:

Testing failed on:
amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/amd64/i/initramfs-tools/20200702_083751_cff4d@/log.gz

** Affects: initramfs-tools (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: kernel-adt-failure

** Tags added: kernel-adt-failure

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1886050

Title:
  initramfs-tools 0.137ubuntu10 ADT test failure with linux-5.8
  5.8.0-3.4

Status in initramfs-tools package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/amd64/i/initramfs-tools/20200702_083751_cff4d@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1886050/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1885755] [NEW] systemd 245.6-1ubuntu1 ADT test failure with linux-5.8 5.8.0-3.4

2020-06-30 Thread Seth Forshee
Public bug reported:

Testing failed on:
amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/amd64/s/systemd/20200630_154532_b7979@/log.gz
arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/arm64/s/systemd/20200630_155538_0c63d@/log.gz
ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/ppc64el/s/systemd/20200630_162720_b3e1b@/log.gz
s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/s390x/s/systemd/20200630_140417_c5bdb@/log.gz

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: kernel-adt-failure

** Tags added: kernel-adt-failure

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1885755

Title:
  systemd 245.6-1ubuntu1 ADT test failure with linux-5.8 5.8.0-3.4

Status in systemd package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/amd64/s/systemd/20200630_154532_b7979@/log.gz
  arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/arm64/s/systemd/20200630_155538_0c63d@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/ppc64el/s/systemd/20200630_162720_b3e1b@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/s390x/s/systemd/20200630_140417_c5bdb@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1885755/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884636] [NEW] systemd 245.5-3ubuntu1 ADT test failure with linux-5.8 5.8.0-1.2

2020-06-22 Thread Seth Forshee
Public bug reported:

Testing failed on:
amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/amd64/s/systemd/20200619_224023_f687b@/log.gz
arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/arm64/s/systemd/20200620_002130_9921a@/log.gz
ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/ppc64el/s/systemd/20200620_002108_b4135@/log.gz
s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/s390x/s/systemd/20200619_214658_5b596@/log.gz

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: kernel-adt-failure

** Tags added: kernel-adt-failure

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1884636

Title:
  systemd 245.5-3ubuntu1 ADT test failure with linux-5.8 5.8.0-1.2

Status in systemd package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/amd64/s/systemd/20200619_224023_f687b@/log.gz
  arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/arm64/s/systemd/20200620_002130_9921a@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/ppc64el/s/systemd/20200620_002108_b4135@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/s390x/s/systemd/20200619_214658_5b596@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1884636/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1884635] [NEW] lxc 1:4.0.2-0ubuntu1 ADT test failure with linux-5.8 5.8.0-1.2

2020-06-22 Thread Seth Forshee
Public bug reported:

Testing failed on:
amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/amd64/l/lxc/20200619_210334_814e1@/log.gz
arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/arm64/l/lxc/20200619_213805_39c53@/log.gz
ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/ppc64el/l/lxc/20200619_210431_b275f@/log.gz
s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/s390x/l/lxc/20200619_210417_54a16@/log.gz

** Affects: lxc (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: kernel-adt-failure

** Tags added: kernel-adt-failure

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lxc in Ubuntu.
https://bugs.launchpad.net/bugs/1884635

Title:
  lxc 1:4.0.2-0ubuntu1 ADT test failure with linux-5.8 5.8.0-1.2

Status in lxc package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/amd64/l/lxc/20200619_210334_814e1@/log.gz
  arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/arm64/l/lxc/20200619_213805_39c53@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/ppc64el/l/lxc/20200619_210431_b275f@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-groovy-canonical-kernel-team-bootstrap/groovy/s390x/l/lxc/20200619_210417_54a16@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/1884635/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1875665] Re: rtkit-daemon[*]: Failed to make ourselves RT: Operation not permitted after upgrade to 20.04

2020-05-13 Thread Seth Forshee
** Also affects: linux-azure (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: linux-gcp (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: linux-kvm (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: linux-oracle (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: linux-riscv (Ubuntu)
   Importance: Undecided
   Status: New

** Changed in: linux (Ubuntu)
   Status: Confirmed => Fix Committed

** Changed in: linux-azure (Ubuntu)
   Status: New => Invalid

** Changed in: linux-gcp (Ubuntu)
   Status: New => Invalid

** Changed in: linux-kvm (Ubuntu)
   Status: New => Invalid

** Changed in: linux-oracle (Ubuntu)
   Status: New => Invalid

** Changed in: linux-riscv (Ubuntu)
   Status: New => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to rtkit in Ubuntu.
https://bugs.launchpad.net/bugs/1875665

Title:
  rtkit-daemon[*]: Failed to make ourselves RT: Operation not permitted
  after upgrade to 20.04

Status in linux package in Ubuntu:
  Fix Committed
Status in linux-azure package in Ubuntu:
  Invalid
Status in linux-gcp package in Ubuntu:
  Invalid
Status in linux-kvm package in Ubuntu:
  Invalid
Status in linux-oracle package in Ubuntu:
  Invalid
Status in linux-riscv package in Ubuntu:
  Invalid
Status in rtkit package in Ubuntu:
  Confirmed
Status in linux source package in Focal:
  Confirmed
Status in linux-azure source package in Focal:
  New
Status in linux-gcp source package in Focal:
  New
Status in linux-kvm source package in Focal:
  New
Status in linux-oracle source package in Focal:
  New
Status in linux-riscv source package in Focal:
  New
Status in rtkit source package in Focal:
  Confirmed

Bug description:
  SRU Justification

  Impact: CONFIG_RT_GROUP_SCHED was enabled in focal, except for the
  lowlatency kernel since we expected most RT users to use that kernel.
  However we are getting RT regressions with the generic kernel. Digging
  deeper into this option, it seems to be pretty specialized and to
  require quite a bit of workload-specific configuration/tuning to be
  useful, so it doesn't really seem to make sense for a general-purpose
  kernel.

  Fix: Turn this option back off.

  Test Case: See comment #4.

  Regression Potential: This was turned on to support some docker
  functionality, so this functionality will no longer be available.
  We've had this option off for all releases prior to focal, so this
  seems acceptable.

  ---

  These errors started right after upgrading to 20.04.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: rtkit 0.12-4
  ProcVersionSignature: Ubuntu 5.4.0-26.30-generic 5.4.30
  Uname: Linux 5.4.0-26-generic x86_64
  NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
  ApportVersion: 2.20.11-0ubuntu27
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Tue Apr 28 10:31:43 2020
  InstallationDate: Installed on 2019-06-18 (315 days ago)
  InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
  ProcEnviron:
   TERM=tmux-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: rtkit
  UpgradeStatus: Upgraded to focal on 2020-04-21 (6 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1875665/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1875665] Re: rtkit-daemon[*]: Failed to make ourselves RT: Operation not permitted after upgrade to 20.04

2020-05-07 Thread Seth Forshee
** Description changed:

+ SRU Justification
+ 
+ Impact: CONFIG_RT_GROUP_SCHED was enabled in focal, except for the
+ lowlatency kernel since we expected most RT users to use that kernel.
+ However we are getting RT regressions with the generic kernel. Digging
+ deeper into this option, it seems to be pretty specialized and to
+ require quite a bit of workload-specific configuration/tuning to be
+ useful, so it doesn't really seem to make sense for a general-purpose
+ kernel.
+ 
+ Fix: Turn this option back off.
+ 
+ Test Case: See comment #4.
+ 
+ Regression Potential: This was turned on to support some docker
+ functionality, so this functionality will no longer be available. We've
+ had this option off for all releases prior to focal, so this seems
+ acceptable.
+ 
+ ---
+ 
  These errors started right after upgrading to 20.04.
  
  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: rtkit 0.12-4
  ProcVersionSignature: Ubuntu 5.4.0-26.30-generic 5.4.30
  Uname: Linux 5.4.0-26-generic x86_64
  NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
  ApportVersion: 2.20.11-0ubuntu27
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Tue Apr 28 10:31:43 2020
  InstallationDate: Installed on 2019-06-18 (315 days ago)
  InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
  ProcEnviron:
-  TERM=tmux-256color
-  PATH=(custom, no user)
-  XDG_RUNTIME_DIR=
-  LANG=en_US.UTF-8
-  SHELL=/bin/bash
+  TERM=tmux-256color
+  PATH=(custom, no user)
+  XDG_RUNTIME_DIR=
+  LANG=en_US.UTF-8
+  SHELL=/bin/bash
  SourcePackage: rtkit
  UpgradeStatus: Upgraded to focal on 2020-04-21 (6 days ago)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to rtkit in Ubuntu.
https://bugs.launchpad.net/bugs/1875665

Title:
  rtkit-daemon[*]: Failed to make ourselves RT: Operation not permitted
  after upgrade to 20.04

Status in linux package in Ubuntu:
  Confirmed
Status in rtkit package in Ubuntu:
  Confirmed
Status in linux source package in Focal:
  Confirmed
Status in rtkit source package in Focal:
  New

Bug description:
  SRU Justification

  Impact: CONFIG_RT_GROUP_SCHED was enabled in focal, except for the
  lowlatency kernel since we expected most RT users to use that kernel.
  However we are getting RT regressions with the generic kernel. Digging
  deeper into this option, it seems to be pretty specialized and to
  require quite a bit of workload-specific configuration/tuning to be
  useful, so it doesn't really seem to make sense for a general-purpose
  kernel.

  Fix: Turn this option back off.

  Test Case: See comment #4.

  Regression Potential: This was turned on to support some docker
  functionality, so this functionality will no longer be available.
  We've had this option off for all releases prior to focal, so this
  seems acceptable.

  ---

  These errors started right after upgrading to 20.04.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: rtkit 0.12-4
  ProcVersionSignature: Ubuntu 5.4.0-26.30-generic 5.4.30
  Uname: Linux 5.4.0-26-generic x86_64
  NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
  ApportVersion: 2.20.11-0ubuntu27
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Tue Apr 28 10:31:43 2020
  InstallationDate: Installed on 2019-06-18 (315 days ago)
  InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
  ProcEnviron:
   TERM=tmux-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: rtkit
  UpgradeStatus: Upgraded to focal on 2020-04-21 (6 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1875665/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1875665] Re: rtkit-daemon[*]: Failed to make ourselves RT: Operation not permitted after upgrade to 20.04

2020-05-07 Thread Seth Forshee
Seems like this kernel config change should be reverted for now. We can
consider turning it back on later if rtkit receives changes to work
better with this option.

** Also affects: linux (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Focal)
   Importance: Undecided
   Status: New

** Also affects: rtkit (Ubuntu Focal)
   Importance: Undecided
   Status: New

** Changed in: linux (Ubuntu)
   Importance: Undecided => Medium

** Changed in: linux (Ubuntu)
   Status: New => Confirmed

** Changed in: linux (Ubuntu)
 Assignee: (unassigned) => Seth Forshee (sforshee)

** Changed in: linux (Ubuntu Focal)
   Importance: Undecided => Medium

** Changed in: linux (Ubuntu Focal)
   Status: New => Confirmed

** Changed in: linux (Ubuntu Focal)
 Assignee: (unassigned) => Seth Forshee (sforshee)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to rtkit in Ubuntu.
https://bugs.launchpad.net/bugs/1875665

Title:
  rtkit-daemon[*]: Failed to make ourselves RT: Operation not permitted
  after upgrade to 20.04

Status in linux package in Ubuntu:
  Confirmed
Status in rtkit package in Ubuntu:
  Confirmed
Status in linux source package in Focal:
  Confirmed
Status in rtkit source package in Focal:
  New

Bug description:
  These errors started right after upgrading to 20.04.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: rtkit 0.12-4
  ProcVersionSignature: Ubuntu 5.4.0-26.30-generic 5.4.30
  Uname: Linux 5.4.0-26-generic x86_64
  NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
  ApportVersion: 2.20.11-0ubuntu27
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: ubuntu:GNOME
  Date: Tue Apr 28 10:31:43 2020
  InstallationDate: Installed on 2019-06-18 (315 days ago)
  InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
  ProcEnviron:
   TERM=tmux-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: rtkit
  UpgradeStatus: Upgraded to focal on 2020-04-21 (6 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1875665/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1866012] Re: depmod ERROR during Setting up linux-modules-5.4.0-17-generic

2020-03-04 Thread Seth Forshee
Sorry, I was getting that confused with another file,
modules.builtin.modinfo. That was the one we just added to linux-
modules.

modules.builtin.bin is generated by depmod, and if I remove the file for
a given kernel and run depmod I get these messages. So this looks like
something fully from depmod and not a result of anything wrong in our
kernel packages.

** Changed in: linux (Ubuntu)
   Status: Confirmed => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to kmod in Ubuntu.
https://bugs.launchpad.net/bugs/1866012

Title:
  depmod ERROR during Setting up linux-modules-5.4.0-17-generic

Status in kmod package in Ubuntu:
  New
Status in linux package in Ubuntu:
  Invalid

Bug description:
  Steps to reproduce:
  1. Deploy Focal on a KVM ndoe, enable proposed
  2. Run sudo apt dist-upgrade

  The console will be flushed with:
  Setting up libisc1105:amd64 (1:9.11.16+dfsg-3~build1) ...
  Setting up linux-modules-5.4.0-17-generic (5.4.0-17.21) ...
  depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open 
builtin file '/lib/modules/5.4.0-17-generic/modules.builtin.bin'
  depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open 
builtin file '/lib/modules/5.4.0-17-generic/modules.builtin.bin'
  depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open 
builtin file '/lib/modules/5.4.0-17-generic/modules.builtin.bin'
  depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open 
builtin file '/lib/modules/5.4.0-17-generic/modules.builtin.bin'
  depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open 
builtin file '/lib/modules/5.4.0-17-generic/modules.builtin.bin'
  
  Setting up apt-utils (1.9.12) ...
  Setting up libselinux1-dev:amd64 (3.0-1build2) ...
  Setting up libglib2.0-0:amd64 (2.64.0-1) ...

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: linux-image-5.4.0-14-generic 5.4.0-14.17
  ProcVersionSignature: User Name 5.4.0-14.17-generic 5.4.18
  Uname: Linux 5.4.0-14-generic x86_64
  AlsaDevices:
   total 0
   crw-rw 1 root audio 116,  1 Mar  4 08:29 seq
   crw-rw 1 root audio 116, 33 Mar  4 08:29 timer
  AplayDevices: Error: [Errno 2] No such file or directory: 'aplay'
  ApportVersion: 2.20.11-0ubuntu18
  Architecture: amd64
  ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord'
  AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', 
'/dev/snd/timer'] failed with exit code 1:
  Date: Wed Mar  4 09:06:42 2020
  IwConfig: Error: [Errno 2] No such file or directory: 'iwconfig'
  Lsusb: Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  Lsusb-t: /:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
  MachineType: QEMU Standard PC (i440FX + PIIX, 1996)
  PciMultimedia:
   
  ProcFB: 0 cirrusdrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-14-generic 
root=UUID=36e162f3-41b5-4487-a6dc-09ba4e37d3bf ro console=tty1 console=ttyS0
  RelatedPackageVersions:
   linux-restricted-modules-5.4.0-14-generic N/A
   linux-backports-modules-5.4.0-14-generic  N/A
   linux-firmware1.186
  RfKill: Error: [Errno 2] No such file or directory: 'rfkill'
  SourcePackage: linux-5.4
  StagingDrivers: exfat
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 04/01/2014
  dmi.bios.vendor: SeaBIOS
  dmi.bios.version: 1.10.2-1ubuntu1
  dmi.chassis.type: 1
  dmi.chassis.vendor: QEMU
  dmi.chassis.version: pc-i440fx-bionic
  dmi.modalias: 
dmi:bvnSeaBIOS:bvr1.10.2-1ubuntu1:bd04/01/2014:svnQEMU:pnStandardPC(i440FX+PIIX,1996):pvrpc-i440fx-bionic:cvnQEMU:ct1:cvrpc-i440fx-bionic:
  dmi.product.name: Standard PC (i440FX + PIIX, 1996)
  dmi.product.version: pc-i440fx-bionic
  dmi.sys.vendor: QEMU

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/kmod/+bug/1866012/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1866012] Re: depmod ERROR during Setting up linux-modules-5.4.0-17-generic

2020-03-04 Thread Seth Forshee
Adding kmod, since the error comes from depmod.

The file it's complaining about is relatively new (added in 5.2
timeframe iirc), and we haven't been shipping it. However as of 5.4.0-17
we are shipping it in linux-modules. I've confirmed that
/lib/modules/5.4.0-17-generic/modules.builtin.bin is there after the
installation, so I don't yet know why it wouldn't be there when depmod
runs.

** Also affects: kmod (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to kmod in Ubuntu.
https://bugs.launchpad.net/bugs/1866012

Title:
  depmod ERROR during Setting up linux-modules-5.4.0-17-generic

Status in kmod package in Ubuntu:
  New
Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Steps to reproduce:
  1. Deploy Focal on a KVM ndoe, enable proposed
  2. Run sudo apt dist-upgrade

  The console will be flushed with:
  Setting up libisc1105:amd64 (1:9.11.16+dfsg-3~build1) ...
  Setting up linux-modules-5.4.0-17-generic (5.4.0-17.21) ...
  depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open 
builtin file '/lib/modules/5.4.0-17-generic/modules.builtin.bin'
  depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open 
builtin file '/lib/modules/5.4.0-17-generic/modules.builtin.bin'
  depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open 
builtin file '/lib/modules/5.4.0-17-generic/modules.builtin.bin'
  depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open 
builtin file '/lib/modules/5.4.0-17-generic/modules.builtin.bin'
  depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open 
builtin file '/lib/modules/5.4.0-17-generic/modules.builtin.bin'
  
  Setting up apt-utils (1.9.12) ...
  Setting up libselinux1-dev:amd64 (3.0-1build2) ...
  Setting up libglib2.0-0:amd64 (2.64.0-1) ...

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: linux-image-5.4.0-14-generic 5.4.0-14.17
  ProcVersionSignature: User Name 5.4.0-14.17-generic 5.4.18
  Uname: Linux 5.4.0-14-generic x86_64
  AlsaDevices:
   total 0
   crw-rw 1 root audio 116,  1 Mar  4 08:29 seq
   crw-rw 1 root audio 116, 33 Mar  4 08:29 timer
  AplayDevices: Error: [Errno 2] No such file or directory: 'aplay'
  ApportVersion: 2.20.11-0ubuntu18
  Architecture: amd64
  ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord'
  AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', 
'/dev/snd/timer'] failed with exit code 1:
  Date: Wed Mar  4 09:06:42 2020
  IwConfig: Error: [Errno 2] No such file or directory: 'iwconfig'
  Lsusb: Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  Lsusb-t: /:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
  MachineType: QEMU Standard PC (i440FX + PIIX, 1996)
  PciMultimedia:
   
  ProcFB: 0 cirrusdrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-14-generic 
root=UUID=36e162f3-41b5-4487-a6dc-09ba4e37d3bf ro console=tty1 console=ttyS0
  RelatedPackageVersions:
   linux-restricted-modules-5.4.0-14-generic N/A
   linux-backports-modules-5.4.0-14-generic  N/A
   linux-firmware1.186
  RfKill: Error: [Errno 2] No such file or directory: 'rfkill'
  SourcePackage: linux-5.4
  StagingDrivers: exfat
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 04/01/2014
  dmi.bios.vendor: SeaBIOS
  dmi.bios.version: 1.10.2-1ubuntu1
  dmi.chassis.type: 1
  dmi.chassis.vendor: QEMU
  dmi.chassis.version: pc-i440fx-bionic
  dmi.modalias: 
dmi:bvnSeaBIOS:bvr1.10.2-1ubuntu1:bd04/01/2014:svnQEMU:pnStandardPC(i440FX+PIIX,1996):pvrpc-i440fx-bionic:cvnQEMU:ct1:cvrpc-i440fx-bionic:
  dmi.product.name: Standard PC (i440FX + PIIX, 1996)
  dmi.product.version: pc-i440fx-bionic
  dmi.sys.vendor: QEMU

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/kmod/+bug/1866012/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1861446] Re: on focal 'ubuntu-bug linux' doesn't automatically collect kernel artifacts

2020-02-11 Thread Seth Forshee
This should be point at linux-5.4 and not linux-signed-5.4.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apport in Ubuntu.
https://bugs.launchpad.net/bugs/1861446

Title:
  on focal 'ubuntu-bug linux' doesn't automatically collect kernel
  artifacts

Status in apport package in Ubuntu:
  In Progress
Status in linux package in Ubuntu:
  Invalid
Status in apport source package in Focal:
  In Progress
Status in linux source package in Focal:
  Invalid

Bug description:
  Hello, on focal I ran 'ubuntu-bug linux' to report a kernel issue. The
  issue was filed against linux-signed-5.4 (Ubuntu) rather than linux
  (Ubuntu), and none of the logs usually included with kernel bug
  reports were included.

  After the bug was changed from linux-signed-5.4 to linux, I was
  prompted to run apport-collect by the kernel team's triagebot and that
  worked successfully:

  https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1861359/+activity

  My guess is that apport needs to be updated to understand a change in
  kernel packaging.

  Thanks

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: apport 2.20.11-0ubuntu16
  ProcVersionSignature: Ubuntu 5.4.0-12.15-generic 5.4.8
  Uname: Linux 5.4.0-12-generic x86_64
  NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
  ApportLog:
   
  ApportVersion: 2.20.11-0ubuntu16
  Architecture: amd64
  CrashReports:
   640:1000:1000:40192:2020-01-30 03:32:41.717296496 +:2020-01-30 
03:32:41.717296496 +:/var/crash/_usr_bin_apport-bug.1000.crash
   600:0:0:467987:2020-01-24 20:40:35.855434497 +:2020-01-24 
20:40:35.819434494 +:/var/crash/zfsutils-linux.0.crash
   640:0:0:386063:2020-01-24 20:42:09.391725398 +:2020-01-24 
20:42:08.887728256 +:/var/crash/_usr_sbin_zfs.0.crash
  Date: Thu Jan 30 18:44:47 2020
  PackageArchitecture: all
  ProcEnviron:
   TERM=rxvt-unicode-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: apport
  UpgradeStatus: Upgraded to focal on 2020-01-24 (5 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apport/+bug/1861446/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1857046] [NEW] lxc 3.0.4-0ubuntu2 ADT test failure with linux 5.5.0-2.3

2019-12-19 Thread Seth Forshee
Public bug reported:

Testing failed on:
amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-focal-canonical-kernel-team-bootstrap/focal/amd64/l/lxc/20191218_145013_76e0c@/log.gz
arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-focal-canonical-kernel-team-bootstrap/focal/arm64/l/lxc/20191218_165648_a3f34@/log.gz
ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-focal-canonical-kernel-team-bootstrap/focal/ppc64el/l/lxc/20191218_151902_0998c@/log.gz
s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-focal-canonical-kernel-team-bootstrap/focal/s390x/l/lxc/20191218_152251_9101b@/log.gz

** Affects: lxc (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: kernel-adt-failure

** Tags added: kernel-adt-failure

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lxc in Ubuntu.
https://bugs.launchpad.net/bugs/1857046

Title:
  lxc 3.0.4-0ubuntu2 ADT test failure with linux 5.5.0-2.3

Status in lxc package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-focal-canonical-kernel-team-bootstrap/focal/amd64/l/lxc/20191218_145013_76e0c@/log.gz
  arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-focal-canonical-kernel-team-bootstrap/focal/arm64/l/lxc/20191218_165648_a3f34@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-focal-canonical-kernel-team-bootstrap/focal/ppc64el/l/lxc/20191218_151902_0998c@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-focal-canonical-kernel-team-bootstrap/focal/s390x/l/lxc/20191218_152251_9101b@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/1857046/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1848587] Re: lxc 3.0.4-0ubuntu1 ADT test failure with linux 5.4.0-1.2

2019-11-26 Thread Seth Forshee
Do you have an ETA on when you'll do an lxc upload with the fix?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lxc in Ubuntu.
https://bugs.launchpad.net/bugs/1848587

Title:
  lxc 3.0.4-0ubuntu1 ADT test failure with linux 5.4.0-1.2

Status in lxc package in Ubuntu:
  Fix Committed

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-unstable/eoan/amd64/l/lxc/20191016_150939_0f81d@/log.gz
  arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-unstable/eoan/arm64/l/lxc/20191016_152027_0f81d@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-unstable/eoan/ppc64el/l/lxc/20191016_150251_0f81d@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-unstable/eoan/s390x/l/lxc/20191016_150201_0f81d@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/1848587/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1848587] Re: lxc 3.0.4-0ubuntu1 ADT test failure with linux 5.4.0-1.2

2019-11-18 Thread Seth Forshee
Christian: Discussed this bug with stgraber last week. Sounds like
/dev/network_latency is just an arbitrary device picked for a test case,
and since it's been removed upstream a different device should be used.
He said you could get this fixed.

** Changed in: lxc (Ubuntu)
   Importance: Undecided => Medium

** Changed in: lxc (Ubuntu)
   Status: New => Confirmed

** Changed in: lxc (Ubuntu)
 Assignee: (unassigned) => Christian Brauner (cbrauner)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lxc in Ubuntu.
https://bugs.launchpad.net/bugs/1848587

Title:
  lxc 3.0.4-0ubuntu1 ADT test failure with linux 5.4.0-1.2

Status in lxc package in Ubuntu:
  Confirmed

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-unstable/eoan/amd64/l/lxc/20191016_150939_0f81d@/log.gz
  arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-unstable/eoan/arm64/l/lxc/20191016_152027_0f81d@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-unstable/eoan/ppc64el/l/lxc/20191016_150251_0f81d@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-unstable/eoan/s390x/l/lxc/20191016_150201_0f81d@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/1848587/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1848587] Re: lxc 3.0.4-0ubuntu1 ADT test failure with linux 5.4.0-1.2

2019-10-24 Thread Seth Forshee
Seems /dev/network_latency was removed upstream.

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=c3082a674f46fe49383b157882c41dfabaa37113

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lxc in Ubuntu.
https://bugs.launchpad.net/bugs/1848587

Title:
  lxc 3.0.4-0ubuntu1 ADT test failure with linux 5.4.0-1.2

Status in lxc package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-unstable/eoan/amd64/l/lxc/20191016_150939_0f81d@/log.gz
  arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-unstable/eoan/arm64/l/lxc/20191016_152027_0f81d@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-unstable/eoan/ppc64el/l/lxc/20191016_150251_0f81d@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-unstable/eoan/s390x/l/lxc/20191016_150201_0f81d@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/1848587/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


Re: [Touch-packages] [Bug 1848587] [NEW] lxc 3.0.4-0ubuntu1 ADT test failure with linux 5.4.0-1.2

2019-10-21 Thread Seth Forshee
On Fri, Oct 18, 2019 at 03:03:43PM -, Christian Brauner wrote:
> Is this a flake or consistently reproducible?

It's reproducible.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lxc in Ubuntu.
https://bugs.launchpad.net/bugs/1848587

Title:
  lxc 3.0.4-0ubuntu1 ADT test failure with linux 5.4.0-1.2

Status in lxc package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-unstable/eoan/amd64/l/lxc/20191016_150939_0f81d@/log.gz
  arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-unstable/eoan/arm64/l/lxc/20191016_152027_0f81d@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-unstable/eoan/ppc64el/l/lxc/20191016_150251_0f81d@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-unstable/eoan/s390x/l/lxc/20191016_150201_0f81d@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/1848587/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1848587] [NEW] lxc 3.0.4-0ubuntu1 ADT test failure with linux 5.4.0-1.2

2019-10-17 Thread Seth Forshee
Public bug reported:

Testing failed on:
amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-unstable/eoan/amd64/l/lxc/20191016_150939_0f81d@/log.gz
arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-unstable/eoan/arm64/l/lxc/20191016_152027_0f81d@/log.gz
ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-unstable/eoan/ppc64el/l/lxc/20191016_150251_0f81d@/log.gz
s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-unstable/eoan/s390x/l/lxc/20191016_150201_0f81d@/log.gz

** Affects: lxc (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: kernel-adt-failure

** Tags added: kernel-adt-failure

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lxc in Ubuntu.
https://bugs.launchpad.net/bugs/1848587

Title:
  lxc 3.0.4-0ubuntu1 ADT test failure with linux 5.4.0-1.2

Status in lxc package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-unstable/eoan/amd64/l/lxc/20191016_150939_0f81d@/log.gz
  arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-unstable/eoan/arm64/l/lxc/20191016_152027_0f81d@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-unstable/eoan/ppc64el/l/lxc/20191016_150251_0f81d@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-unstable/eoan/s390x/l/lxc/20191016_150201_0f81d@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/1848587/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1845317] Re: Add new pci-id's for CML-S, ICL

2019-09-27 Thread Seth Forshee
** Changed in: linux (Ubuntu)
   Status: Confirmed => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libdrm in Ubuntu.
https://bugs.launchpad.net/bugs/1845317

Title:
  Add new pci-id's for CML-S, ICL

Status in libdrm package in Ubuntu:
  Fix Released
Status in linux package in Ubuntu:
  Fix Committed
Status in linux-oem-osp1 package in Ubuntu:
  New
Status in mesa package in Ubuntu:
  New
Status in libdrm source package in Bionic:
  New
Status in linux source package in Bionic:
  Won't Fix
Status in linux-oem-osp1 source package in Bionic:
  New
Status in mesa source package in Bionic:
  New

Bug description:
  [Impact]
  Comet Lake (CML) is basically same gen9 GPU as Sky Lake (SKL) (as is KBL, 
CFL, WHL). There are new CML-S desktop cpu's on the way, and they add three new 
pci-id's that need to be added across the stack in order to use the GPU 
properly.

  There's also one ICL pci-id which was added recently (not in 5.3).

  [Test case]
  The proper way to test is to have an actual machine and boot it up with the 
updated stack, but since these are just pci-id's with no regression potential 
on older hw, it should be fine to just accept them.

  [Regression potential]
  None, just adds new pci-id's to allow the new GPUs to load the proper drivers.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libdrm/+bug/1845317/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1837894] Re: systemd 240-6ubuntu9 ADT test failure with linux 5.3.0-0.1

2019-08-21 Thread Seth Forshee
To clarify, this was an upstream *kernel* regression.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1837894

Title:
  systemd 240-6ubuntu9 ADT test failure with linux 5.3.0-0.1

Status in systemd package in Ubuntu:
  Invalid

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/amd64/s/systemd/20190724_134818_5c46d@/log.gz
  arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/arm64/s/systemd/20190724_154200_5c46d@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/ppc64el/s/systemd/20190724_143708_5c46d@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/s390x/s/systemd/20190724_135803_5c46d@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1837894/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1837894] Re: systemd 240-6ubuntu9 ADT test failure with linux 5.3.0-0.1

2019-08-21 Thread Seth Forshee
This was an upstream regression with mounting within user namespaces. It
has been fixed, closing the systemd bug as invalid.

** Changed in: systemd (Ubuntu)
   Status: New => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1837894

Title:
  systemd 240-6ubuntu9 ADT test failure with linux 5.3.0-0.1

Status in systemd package in Ubuntu:
  Invalid

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/amd64/s/systemd/20190724_134818_5c46d@/log.gz
  arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/arm64/s/systemd/20190724_154200_5c46d@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/ppc64el/s/systemd/20190724_143708_5c46d@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/s390x/s/systemd/20190724_135803_5c46d@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1837894/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1837937] Re: CRASH

2019-07-26 Thread Seth Forshee
He means that you are running a kernel from eoan-proposed, despite your
saying that you do not have updates from the -proposed pocket enabled.

This report contains no useful information about the crash you are
seeing. I see no indication of a kernel panic or anything like that in
the logs, despite your reporting this against the kernel. The one thing
I do notice is a bunch of messages about apparmor denying gnome-system-
monitor access to /run/systemd/sessions/2.

Please provide more information about the crash you are seeing,
otherwise it will be difficult to provide help.

** Changed in: linux (Ubuntu)
   Status: Confirmed => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1837937

Title:
  CRASH

Status in linux package in Ubuntu:
  Confirmed
Status in systemd package in Ubuntu:
  New

Bug description:
  Description:  Ubuntu Eoan Ermine (development branch)
  Release:  19.10
  gnome:
Installed: (none)
Candidate: 1:3.30+1ubuntu1
Version table:
   1:3.30+1ubuntu1 500
  500 http://archive.ubuntu.com/ubuntu devel/universe amd64 Packages
  The screen froze but the mouse was still moving then it all froze and said 
systemd-journal not able to write entry. I had to press the power button.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: linux-image-5.2.0-9-generic 5.2.0-9.10
  ProcVersionSignature: Ubuntu 5.2.0-9.10-generic 5.2.1
  Uname: Linux 5.2.0-9-generic x86_64
  ApportVersion: 2.20.11-0ubuntu7
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  administrator   2068 F pulseaudio
   /dev/snd/controlC0:  administrator   2068 F pulseaudio
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Jul 25 15:11:47 2019
  InstallationDate: Installed on 2019-06-05 (50 days ago)
  InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Alpha amd64 (20190605)
  MachineType: HP HP Notebook
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcFB: 0 radeondrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.2.0-9-generic 
root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
  RelatedPackageVersions:
   linux-restricted-modules-5.2.0-9-generic N/A
   linux-backports-modules-5.2.0-9-generic  N/A
   linux-firmware   1.181
  RfKill:
   0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 06/15/2017
  dmi.bios.vendor: Insyde
  dmi.bios.version: F.24
  dmi.board.asset.tag: Type2 - Board Asset Tag
  dmi.board.name: 82F6
  dmi.board.vendor: HP
  dmi.board.version: 40.41
  dmi.chassis.type: 10
  dmi.chassis.vendor: HP
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnInsyde:bvrF.24:bd06/15/2017:svnHP:pnHPNotebook:pvrType1ProductConfigId:rvnHP:rn82F6:rvr40.41:cvnHP:ct10:cvrChassisVersion:
  dmi.product.family: 103C_5335KV G=N L=CON B=HP
  dmi.product.name: HP Notebook
  dmi.product.sku: X7T78UA#ABA
  dmi.product.version: Type1ProductConfigId
  dmi.sys.vendor: HP

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1837937/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1837937] Re: CRASH

2019-07-26 Thread Seth Forshee
Ok, sorry, I see the description of your problem now. It was mixed in
with the automatically collected information, so I missed it initially.

However I still don't really see anything in the logs to explain the
symptoms you're reporting. Could you check the /var/log/kern.log* files
and see if you find anything about an oops, panic, or OOM killer?
Thanks.

** Changed in: linux (Ubuntu)
   Status: Incomplete => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1837937

Title:
  CRASH

Status in linux package in Ubuntu:
  Confirmed
Status in systemd package in Ubuntu:
  New

Bug description:
  Description:  Ubuntu Eoan Ermine (development branch)
  Release:  19.10
  gnome:
Installed: (none)
Candidate: 1:3.30+1ubuntu1
Version table:
   1:3.30+1ubuntu1 500
  500 http://archive.ubuntu.com/ubuntu devel/universe amd64 Packages
  The screen froze but the mouse was still moving then it all froze and said 
systemd-journal not able to write entry. I had to press the power button.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: linux-image-5.2.0-9-generic 5.2.0-9.10
  ProcVersionSignature: Ubuntu 5.2.0-9.10-generic 5.2.1
  Uname: Linux 5.2.0-9-generic x86_64
  ApportVersion: 2.20.11-0ubuntu7
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  administrator   2068 F pulseaudio
   /dev/snd/controlC0:  administrator   2068 F pulseaudio
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Jul 25 15:11:47 2019
  InstallationDate: Installed on 2019-06-05 (50 days ago)
  InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Alpha amd64 (20190605)
  MachineType: HP HP Notebook
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcFB: 0 radeondrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.2.0-9-generic 
root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
  RelatedPackageVersions:
   linux-restricted-modules-5.2.0-9-generic N/A
   linux-backports-modules-5.2.0-9-generic  N/A
   linux-firmware   1.181
  RfKill:
   0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 06/15/2017
  dmi.bios.vendor: Insyde
  dmi.bios.version: F.24
  dmi.board.asset.tag: Type2 - Board Asset Tag
  dmi.board.name: 82F6
  dmi.board.vendor: HP
  dmi.board.version: 40.41
  dmi.chassis.type: 10
  dmi.chassis.vendor: HP
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnInsyde:bvrF.24:bd06/15/2017:svnHP:pnHPNotebook:pvrType1ProductConfigId:rvnHP:rn82F6:rvr40.41:cvnHP:ct10:cvrChassisVersion:
  dmi.product.family: 103C_5335KV G=N L=CON B=HP
  dmi.product.name: HP Notebook
  dmi.product.sku: X7T78UA#ABA
  dmi.product.version: Type1ProductConfigId
  dmi.sys.vendor: HP

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1837937/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1837894] Re: systemd 240-6ubuntu9 ADT test failure with linux 5.3.0-0.1

2019-07-25 Thread Seth Forshee
We've also seen regressions with lxc which atm appear to be related to a
regression in mounting sysfs in containers which use user namespaces
(bug 1837888 for reference, though there's no activity on the bug as of
yet, just some irc discussion about the regression).

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1837894

Title:
  systemd 240-6ubuntu9 ADT test failure with linux 5.3.0-0.1

Status in systemd package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/amd64/s/systemd/20190724_134818_5c46d@/log.gz
  arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/arm64/s/systemd/20190724_154200_5c46d@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/ppc64el/s/systemd/20190724_143708_5c46d@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/s390x/s/systemd/20190724_135803_5c46d@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1837894/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1837888] [NEW] lxc 3.0.3-0ubuntu1 ADT test failure with linux 5.3.0-0.1

2019-07-25 Thread Seth Forshee
Public bug reported:

Testing failed on:
amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/amd64/l/lxc/20190724_132232_e90e9@/log.gz
arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/arm64/l/lxc/20190724_134725_e90e9@/log.gz
ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/ppc64el/l/lxc/20190724_130343_e90e9@/log.gz
s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/s390x/l/lxc/20190724_131610_e90e9@/log.gz

** Affects: lxc (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: kernel-adt-failure

** Tags added: kernel-adt-failure

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lxc in Ubuntu.
https://bugs.launchpad.net/bugs/1837888

Title:
  lxc 3.0.3-0ubuntu1 ADT test failure with linux 5.3.0-0.1

Status in lxc package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/amd64/l/lxc/20190724_132232_e90e9@/log.gz
  arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/arm64/l/lxc/20190724_134725_e90e9@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/ppc64el/l/lxc/20190724_130343_e90e9@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/s390x/l/lxc/20190724_131610_e90e9@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/1837888/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1837894] [NEW] systemd 240-6ubuntu9 ADT test failure with linux 5.3.0-0.1

2019-07-25 Thread Seth Forshee
Public bug reported:

Testing failed on:
amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/amd64/s/systemd/20190724_134818_5c46d@/log.gz
arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/arm64/s/systemd/20190724_154200_5c46d@/log.gz
ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/ppc64el/s/systemd/20190724_143708_5c46d@/log.gz
s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/s390x/s/systemd/20190724_135803_5c46d@/log.gz

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: kernel-adt-failure

** Tags added: kernel-adt-failure

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1837894

Title:
  systemd 240-6ubuntu9 ADT test failure with linux 5.3.0-0.1

Status in systemd package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/amd64/s/systemd/20190724_134818_5c46d@/log.gz
  arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/arm64/s/systemd/20190724_154200_5c46d@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/ppc64el/s/systemd/20190724_143708_5c46d@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan-canonical-kernel-team-bootstrap/eoan/s390x/s/systemd/20190724_135803_5c46d@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1837894/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1836209] Re: network-manager 1.18.0-1ubuntu5 ADT test failure with linux 5.2.0-8.9

2019-07-15 Thread Seth Forshee
Seems to possibly be something going slightly slower with this kernel.
With 5.2 a fw IPv6 address assignment tests (DHCP and RA) fail sometimes
and pass other times, and usually at least one of them fails.  The same
failures would happen in the past, but less frequency. I suspect that
something is taking slightly longer with 5.2 such that the tests
frequently time out before the interface becomes activated.

Since the tests do pass I'm setting this to low and not blocking kernel
promotion on it.

** Changed in: network-manager (Ubuntu)
   Importance: Undecided => Low

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1836209

Title:
  network-manager 1.18.0-1ubuntu5 ADT test failure with linux 5.2.0-8.9

Status in network-manager package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan/eoan/amd64/n/network-manager/20190710_160945_9116e@/log.gz
  i386: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan/eoan/i386/n/network-manager/20190710_110735_e5ce3@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1836209/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1836209] [NEW] network-manager 1.18.0-1ubuntu5 ADT test failure with linux 5.2.0-8.9

2019-07-11 Thread Seth Forshee
Public bug reported:

Testing failed on:
amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan/eoan/amd64/n/network-manager/20190710_160945_9116e@/log.gz
i386: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan/eoan/i386/n/network-manager/20190710_110735_e5ce3@/log.gz

** Affects: network-manager (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: kernel-adt-failure

** Tags added: kernel-adt-failure

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1836209

Title:
  network-manager 1.18.0-1ubuntu5 ADT test failure with linux 5.2.0-8.9

Status in network-manager package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan/eoan/amd64/n/network-manager/20190710_160945_9116e@/log.gz
  i386: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan/eoan/i386/n/network-manager/20190710_110735_e5ce3@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1836209/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1834192] [NEW] apparmor mult_mount regression test fails in eoan

2019-06-25 Thread Seth Forshee
Public bug reported:

In running adt testing on 5.2-based kernels for eoan, I'm seeing
failures from the apparmor mult_mount regression test. Running the test
case manually with -x yields:

 + dd if=/dev/zero of=/tmp/sdtest.2210-22387-i6UxxQ/image.ext3 bs=4096 count=20
 + mkfs.ext2 -F -m 0 -N 10 /tmp/sdtest.2210-22387-i6UxxQ/image.ext3
 ++ error_handler
 ++ fatalerror 'Unexpected shell error. Run with -x to debug'

Running the following manually in a shell also fails in eoan with the
5.0 kernel copied forward from disco, while it passes in disco:

 $ uname -a
 Linux ee-apparmor 5.0.0-17-generic #18-Ubuntu SMP Tue Jun 4 15:34:08 UTC 2019 
x86_64 x86_64 x86_64 GNU/Linux
 $ dd if=/dev/zero of=test.img bs=4096 count=20
 20+0 records in
 20+0 records out
 81920 bytes (82 kB, 80 KiB) copied, 0.000406443 s, 202 MB/s
 $ mkfs.ext2 -F -m 0 -N 10 test.img
 mke2fs 1.45.2 (27-May-2019)
 test.img: Not enough space to build proposed filesystem while setting up 
superblock

So this seems likely to be due to some change with mke2fs; not sure if
this is a regression there or if the test was getting away with doing
something invalid.

** Affects: apparmor (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apparmor in Ubuntu.
https://bugs.launchpad.net/bugs/1834192

Title:
  apparmor mult_mount regression test fails in eoan

Status in apparmor package in Ubuntu:
  New

Bug description:
  In running adt testing on 5.2-based kernels for eoan, I'm seeing
  failures from the apparmor mult_mount regression test. Running the
  test case manually with -x yields:

   + dd if=/dev/zero of=/tmp/sdtest.2210-22387-i6UxxQ/image.ext3 bs=4096 
count=20
   + mkfs.ext2 -F -m 0 -N 10 /tmp/sdtest.2210-22387-i6UxxQ/image.ext3
   ++ error_handler
   ++ fatalerror 'Unexpected shell error. Run with -x to debug'

  Running the following manually in a shell also fails in eoan with the
  5.0 kernel copied forward from disco, while it passes in disco:

   $ uname -a
   Linux ee-apparmor 5.0.0-17-generic #18-Ubuntu SMP Tue Jun 4 15:34:08 UTC 
2019 x86_64 x86_64 x86_64 GNU/Linux
   $ dd if=/dev/zero of=test.img bs=4096 count=20
   20+0 records in
   20+0 records out
   81920 bytes (82 kB, 80 KiB) copied, 0.000406443 s, 202 MB/s
   $ mkfs.ext2 -F -m 0 -N 10 test.img
   mke2fs 1.45.2 (27-May-2019)
   test.img: Not enough space to build proposed filesystem while setting up 
superblock

  So this seems likely to be due to some change with mke2fs; not sure if
  this is a regression there or if the test was getting away with doing
  something invalid.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apparmor/+bug/1834192/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1823862] Re: disco: unable to use iptables/enable ufw under -virtual kernel

2019-04-11 Thread Seth Forshee
** Changed in: linux (Ubuntu)
   Status: In Progress => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ufw in Ubuntu.
https://bugs.launchpad.net/bugs/1823862

Title:
  disco: unable to use iptables/enable ufw under -virtual kernel

Status in linux package in Ubuntu:
  Fix Committed
Status in ufw package in Ubuntu:
  Invalid

Bug description:
  SRU Justification

  Impact: iptables does not work in disco with linux-virtual.

  Fix: Add bpfilter to the generic inclusion list.

  Regression Potential: There are no code changes and thus minimal
  potential for regressions.

  Test Case: Verify that bpffilter.ko is shipped in linux-modues instead
  of linux-module-extra and that iptables commands work in disco with
  the linux-virtual kernel installed.

  ---

  Fresh install of disco:

  $ sudo ufw enable
  Command may disrupt existing ssh connections. Proceed with operation (y|n)? y
  ERROR: problem running ufw-init
  iptables-restore v1.6.1: Can't set policy `DROP' on `INPUT' line 3: Bad 
built-in chain name

  iptables-restore: line 22 failed
  iptables-restore: line 2 failed
  iptables-restore v1.6.1: Couldn't load target `ufw-logging-deny':No such file 
or directory

  Error occurred at line: 30
  Try `iptables-restore -h' or 'iptables-restore --help' for more information.
  iptables-restore v1.6.1: Couldn't load target `ufw-skip-to-policy-input':No 
such file or directory

  Error occurred at line: 19
  Try `iptables-restore -h' or 'iptables-restore --help' for more information.
  iptables-restore v1.6.1: Couldn't load target `ufw-user-input':No such file 
or directory

  Error occurred at line: 2
  Try `iptables-restore -h' or 'iptables-restore --help' for more information.

  Problem running '/etc/ufw/before.rules'
  Problem running '/etc/ufw/after.rules'

  ProblemType: Bug
  DistroRelease: Ubuntu 19.04
  Package: ufw 0.36-1ubuntu1
  ProcVersionSignature: Ubuntu 5.0.0-8.9-generic 5.0.1
  Uname: Linux 5.0.0-8-generic x86_64
  ApportVersion: 2.20.10-0ubuntu26
  Architecture: amd64
  Date: Tue Apr  9 08:49:59 2019
  Ec2AMI: ami-04cf
  Ec2AMIManifest: FIXME
  Ec2AvailabilityZone: nova
  Ec2InstanceType: m1.blue
  Ec2Kernel: unavailable
  Ec2Ramdisk: unavailable
  PackageArchitecture: all
  ProcEnviron:
   TERM=screen-256color
   PATH=(custom, no user)
   LANG=C.UTF-8
   SHELL=/bin/bash
  SourcePackage: ufw
  UpgradeStatus: No upgrade log present (probably fresh install)
  mtime.conffile..etc.default.ufw: 2019-04-09T08:48:31.371301

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1823862/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1823862] Re: disco: unable to use iptables/enable ufw under -virtual kernel

2019-04-10 Thread Seth Forshee
** Changed in: linux (Ubuntu)
   Status: Incomplete => In Progress

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ufw in Ubuntu.
https://bugs.launchpad.net/bugs/1823862

Title:
  disco: unable to use iptables/enable ufw under -virtual kernel

Status in linux package in Ubuntu:
  In Progress
Status in ufw package in Ubuntu:
  Invalid

Bug description:
  SRU Justification

  Impact: iptables does not work in disco with linux-virtual.

  Fix: Add bpfilter to the generic inclusion list.

  Regression Potential: There are no code changes and thus minimal
  potential for regressions.

  Test Case: Verify that bpffilter.ko is shipped in linux-modues instead
  of linux-module-extra and that iptables commands work in disco with
  the linux-virtual kernel installed.

  ---

  Fresh install of disco:

  $ sudo ufw enable
  Command may disrupt existing ssh connections. Proceed with operation (y|n)? y
  ERROR: problem running ufw-init
  iptables-restore v1.6.1: Can't set policy `DROP' on `INPUT' line 3: Bad 
built-in chain name

  iptables-restore: line 22 failed
  iptables-restore: line 2 failed
  iptables-restore v1.6.1: Couldn't load target `ufw-logging-deny':No such file 
or directory

  Error occurred at line: 30
  Try `iptables-restore -h' or 'iptables-restore --help' for more information.
  iptables-restore v1.6.1: Couldn't load target `ufw-skip-to-policy-input':No 
such file or directory

  Error occurred at line: 19
  Try `iptables-restore -h' or 'iptables-restore --help' for more information.
  iptables-restore v1.6.1: Couldn't load target `ufw-user-input':No such file 
or directory

  Error occurred at line: 2
  Try `iptables-restore -h' or 'iptables-restore --help' for more information.

  Problem running '/etc/ufw/before.rules'
  Problem running '/etc/ufw/after.rules'

  ProblemType: Bug
  DistroRelease: Ubuntu 19.04
  Package: ufw 0.36-1ubuntu1
  ProcVersionSignature: Ubuntu 5.0.0-8.9-generic 5.0.1
  Uname: Linux 5.0.0-8-generic x86_64
  ApportVersion: 2.20.10-0ubuntu26
  Architecture: amd64
  Date: Tue Apr  9 08:49:59 2019
  Ec2AMI: ami-04cf
  Ec2AMIManifest: FIXME
  Ec2AvailabilityZone: nova
  Ec2InstanceType: m1.blue
  Ec2Kernel: unavailable
  Ec2Ramdisk: unavailable
  PackageArchitecture: all
  ProcEnviron:
   TERM=screen-256color
   PATH=(custom, no user)
   LANG=C.UTF-8
   SHELL=/bin/bash
  SourcePackage: ufw
  UpgradeStatus: No upgrade log present (probably fresh install)
  mtime.conffile..etc.default.ufw: 2019-04-09T08:48:31.371301

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1823862/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1823862] Re: disco: unable to use iptables/enable ufw under -virtual kernel

2019-04-10 Thread Seth Forshee
** Description changed:

+ SRU Justification
+ 
+ Impact: iptables does not work in disco with linux-virtual.
+ 
+ Fix: Add bpfilter to the generic inclusion list.
+ 
+ Regression Potential: There are no code changes and thus minimal
+ potential for regressions.
+ 
+ Test Case: Verify that bpffilter.ko is shipped in linux-modues instead
+ of linux-module-extra and that iptables commands work in disco with the
+ linux-virtual kernel installed.
+ 
+ ---
+ 
  Fresh install of disco:
  
  $ sudo ufw enable
  Command may disrupt existing ssh connections. Proceed with operation (y|n)? y
  ERROR: problem running ufw-init
  iptables-restore v1.6.1: Can't set policy `DROP' on `INPUT' line 3: Bad 
built-in chain name
  
  iptables-restore: line 22 failed
  iptables-restore: line 2 failed
  iptables-restore v1.6.1: Couldn't load target `ufw-logging-deny':No such file 
or directory
  
  Error occurred at line: 30
  Try `iptables-restore -h' or 'iptables-restore --help' for more information.
  iptables-restore v1.6.1: Couldn't load target `ufw-skip-to-policy-input':No 
such file or directory
  
  Error occurred at line: 19
  Try `iptables-restore -h' or 'iptables-restore --help' for more information.
  iptables-restore v1.6.1: Couldn't load target `ufw-user-input':No such file 
or directory
  
  Error occurred at line: 2
  Try `iptables-restore -h' or 'iptables-restore --help' for more information.
  
  Problem running '/etc/ufw/before.rules'
  Problem running '/etc/ufw/after.rules'
  
  ProblemType: Bug
  DistroRelease: Ubuntu 19.04
  Package: ufw 0.36-1ubuntu1
  ProcVersionSignature: Ubuntu 5.0.0-8.9-generic 5.0.1
  Uname: Linux 5.0.0-8-generic x86_64
  ApportVersion: 2.20.10-0ubuntu26
  Architecture: amd64
  Date: Tue Apr  9 08:49:59 2019
  Ec2AMI: ami-04cf
  Ec2AMIManifest: FIXME
  Ec2AvailabilityZone: nova
  Ec2InstanceType: m1.blue
  Ec2Kernel: unavailable
  Ec2Ramdisk: unavailable
  PackageArchitecture: all
  ProcEnviron:
-  TERM=screen-256color
-  PATH=(custom, no user)
-  LANG=C.UTF-8
-  SHELL=/bin/bash
+  TERM=screen-256color
+  PATH=(custom, no user)
+  LANG=C.UTF-8
+  SHELL=/bin/bash
  SourcePackage: ufw
  UpgradeStatus: No upgrade log present (probably fresh install)
  mtime.conffile..etc.default.ufw: 2019-04-09T08:48:31.371301

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ufw in Ubuntu.
https://bugs.launchpad.net/bugs/1823862

Title:
  disco: unable to use iptables/enable ufw under -virtual kernel

Status in linux package in Ubuntu:
  Incomplete
Status in ufw package in Ubuntu:
  Invalid

Bug description:
  SRU Justification

  Impact: iptables does not work in disco with linux-virtual.

  Fix: Add bpfilter to the generic inclusion list.

  Regression Potential: There are no code changes and thus minimal
  potential for regressions.

  Test Case: Verify that bpffilter.ko is shipped in linux-modues instead
  of linux-module-extra and that iptables commands work in disco with
  the linux-virtual kernel installed.

  ---

  Fresh install of disco:

  $ sudo ufw enable
  Command may disrupt existing ssh connections. Proceed with operation (y|n)? y
  ERROR: problem running ufw-init
  iptables-restore v1.6.1: Can't set policy `DROP' on `INPUT' line 3: Bad 
built-in chain name

  iptables-restore: line 22 failed
  iptables-restore: line 2 failed
  iptables-restore v1.6.1: Couldn't load target `ufw-logging-deny':No such file 
or directory

  Error occurred at line: 30
  Try `iptables-restore -h' or 'iptables-restore --help' for more information.
  iptables-restore v1.6.1: Couldn't load target `ufw-skip-to-policy-input':No 
such file or directory

  Error occurred at line: 19
  Try `iptables-restore -h' or 'iptables-restore --help' for more information.
  iptables-restore v1.6.1: Couldn't load target `ufw-user-input':No such file 
or directory

  Error occurred at line: 2
  Try `iptables-restore -h' or 'iptables-restore --help' for more information.

  Problem running '/etc/ufw/before.rules'
  Problem running '/etc/ufw/after.rules'

  ProblemType: Bug
  DistroRelease: Ubuntu 19.04
  Package: ufw 0.36-1ubuntu1
  ProcVersionSignature: Ubuntu 5.0.0-8.9-generic 5.0.1
  Uname: Linux 5.0.0-8-generic x86_64
  ApportVersion: 2.20.10-0ubuntu26
  Architecture: amd64
  Date: Tue Apr  9 08:49:59 2019
  Ec2AMI: ami-04cf
  Ec2AMIManifest: FIXME
  Ec2AvailabilityZone: nova
  Ec2InstanceType: m1.blue
  Ec2Kernel: unavailable
  Ec2Ramdisk: unavailable
  PackageArchitecture: all
  ProcEnviron:
   TERM=screen-256color
   PATH=(custom, no user)
   LANG=C.UTF-8
   SHELL=/bin/bash
  SourcePackage: ufw
  UpgradeStatus: No upgrade log present (probably fresh install)
  mtime.conffile..etc.default.ufw: 2019-04-09T08:48:31.371301

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1823862/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net

[Touch-packages] [Bug 1820114] Re: iptables v1.6.1: can't initialize iptables table `filter': Memory allocation problem

2019-04-10 Thread Seth Forshee
*** This bug is a duplicate of bug 1823862 ***
https://bugs.launchpad.net/bugs/1823862

** This bug has been marked a duplicate of bug 1823862
   disco: unable to use iptables/enable ufw under -virtual kernel

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to iptables in Ubuntu.
https://bugs.launchpad.net/bugs/1820114

Title:
  iptables v1.6.1: can't initialize iptables table `filter': Memory
  allocation problem

Status in iptables package in Ubuntu:
  Confirmed
Status in linux package in Ubuntu:
  Confirmed

Bug description:
  I hit this error on disco:

  ```
  $ free -h
totalusedfree  shared  buff/cache   
available
  Mem:  478Mi98Mi   311Mi   0.0Ki68Mi   
366Mi
  Swap:0B  0B  0B

  $ sudo iptables -S
  iptables v1.6.1: can't initialize iptables table `filter': Memory allocation 
problem
  Perhaps iptables or your kernel needs to be upgraded.
  ```

  ProblemType: Bug
  DistroRelease: Ubuntu 19.04
  Package: iptables 1.6.1-2ubuntu3
  ProcVersionSignature: User Name 5.0.0-7.8-generic 5.0.0
  Uname: Linux 5.0.0-7-generic x86_64
  ApportVersion: 2.20.10-0ubuntu23
  Architecture: amd64
  Date: Thu Mar 14 19:16:15 2019
  SourcePackage: iptables
  UpgradeStatus: No upgrade log present (probably fresh install)
  --- 
  ProblemType: Bug
  ApportVersion: 2.20.10-0ubuntu23
  Architecture: amd64
  DistroRelease: Ubuntu 19.04
  Package: linux
  PackageArchitecture: amd64
  ProcVersionSignature: User Name 5.0.0-7.8-generic 5.0.0
  Tags:  disco uec-images
  Uname: Linux 5.0.0-7-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm audio cdrom dialout dip floppy netdev plugdev sudo video
  _MarkForUpload: True

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/iptables/+bug/1820114/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1823862] Re: disco: unable to use iptables/enable ufw under -virtual kernel

2019-04-10 Thread Seth Forshee
All that seems to be missing is bpffilter. I've made a test build with
this moved to linux-modules. It appears to be working for check-
requirements. Can you test and make sure everything is working as
expected? Thanks!

http://people.canonical.com/~sforshee/lp1823862/

** Changed in: linux (Ubuntu)
   Importance: Undecided => High

** Changed in: linux (Ubuntu)
   Status: Confirmed => Incomplete

** Changed in: linux (Ubuntu)
 Assignee: (unassigned) => Seth Forshee (sforshee)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ufw in Ubuntu.
https://bugs.launchpad.net/bugs/1823862

Title:
  disco: unable to use iptables/enable ufw under -virtual kernel

Status in linux package in Ubuntu:
  Incomplete
Status in ufw package in Ubuntu:
  Invalid

Bug description:
  Fresh install of disco:

  $ sudo ufw enable
  Command may disrupt existing ssh connections. Proceed with operation (y|n)? y
  ERROR: problem running ufw-init
  iptables-restore v1.6.1: Can't set policy `DROP' on `INPUT' line 3: Bad 
built-in chain name

  iptables-restore: line 22 failed
  iptables-restore: line 2 failed
  iptables-restore v1.6.1: Couldn't load target `ufw-logging-deny':No such file 
or directory

  Error occurred at line: 30
  Try `iptables-restore -h' or 'iptables-restore --help' for more information.
  iptables-restore v1.6.1: Couldn't load target `ufw-skip-to-policy-input':No 
such file or directory

  Error occurred at line: 19
  Try `iptables-restore -h' or 'iptables-restore --help' for more information.
  iptables-restore v1.6.1: Couldn't load target `ufw-user-input':No such file 
or directory

  Error occurred at line: 2
  Try `iptables-restore -h' or 'iptables-restore --help' for more information.

  Problem running '/etc/ufw/before.rules'
  Problem running '/etc/ufw/after.rules'

  ProblemType: Bug
  DistroRelease: Ubuntu 19.04
  Package: ufw 0.36-1ubuntu1
  ProcVersionSignature: Ubuntu 5.0.0-8.9-generic 5.0.1
  Uname: Linux 5.0.0-8-generic x86_64
  ApportVersion: 2.20.10-0ubuntu26
  Architecture: amd64
  Date: Tue Apr  9 08:49:59 2019
  Ec2AMI: ami-04cf
  Ec2AMIManifest: FIXME
  Ec2AvailabilityZone: nova
  Ec2InstanceType: m1.blue
  Ec2Kernel: unavailable
  Ec2Ramdisk: unavailable
  PackageArchitecture: all
  ProcEnviron:
   TERM=screen-256color
   PATH=(custom, no user)
   LANG=C.UTF-8
   SHELL=/bin/bash
  SourcePackage: ufw
  UpgradeStatus: No upgrade log present (probably fresh install)
  mtime.conffile..etc.default.ufw: 2019-04-09T08:48:31.371301

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1823862/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1818204] Re: Qualcomm Atheros QCA9377 wireless does not work

2019-03-27 Thread Seth Forshee
** Changed in: linux (Ubuntu)
   Status: Incomplete => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1818204

Title:
  Qualcomm Atheros QCA9377 wireless does not work

Status in linux package in Ubuntu:
  Fix Committed
Status in network-manager package in Ubuntu:
  Invalid

Bug description:
  === SRU Justification ===
  [Impact] 
  Lenovo ideapad 530S-14ARR Wifi rfkill hard blocked

  [Fix]
  The platform in question doesn't have hardware RF switch, so quirk it
  off.
   
  [Test]
  User confirm it fixes the issue.

  [Regression Potential]
  Minimal. This fix is limited to one specific platform.

  === Original Bug Report ===
  I have Lenovo 530s laptop with Qualcomm Atheros QCA9377 802.11ac Wireless 
Network Adapter (rev 31).

  The menu shows that wireless is off. Turning on the wireless from the
  menu does not do anything.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: network-manager 1.10.6-2ubuntu1.1
  ProcVersionSignature: Ubuntu 4.18.0-15.16~18.04.1-generic 4.18.20
  Uname: Linux 4.18.0-15-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.5
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Fri Mar  1 11:42:34 2019
  IfupdownConfig:
   # interfaces(5) file used by ifup(8) and ifdown(8)
   auto lo
   iface lo inet loopback
  InstallationDate: Installed on 2019-02-20 (8 days ago)
  InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 
(20190210)
  IpRoute:
   default via 130.232.69.254 dev enx00e04c704f68 proto dhcp metric 100
   130.232.69.0/24 dev enx00e04c704f68 proto kernel scope link src 
130.232.69.176 metric 100
   169.254.0.0/16 dev virbr0 scope link metric 1000 linkdown
   192.168.122.0/24 dev virbr0 proto kernel scope link src 192.168.122.1 
linkdown
  NetworkManager.state:
   [main]
   NetworkingEnabled=true
   WirelessEnabled=true
   WWANEnabled=true
  SourcePackage: network-manager
  UpgradeStatus: No upgrade log present (probably fresh install)
  nmcli-con:
   NAMEUUID  TYPE  
TIMESTAMP   TIMESTAMP-REALAUTOCONNECT  AUTOCONNECT-PRIORITY 
 READONLY  DBUS-PATH   ACTIVE  DEVICE   
STATE  ACTIVE-PATH  SLAVE
   Wired connection 1  ada277fe-966d-33ff-aba2-8ba32d6ce5a9  ethernet  
155143  pe  1. maaliskuuta 2019 11.42.13  yes  4294966297   
 no/org/freedesktop/NetworkManager/Settings/1  yes enx00e04c704f68  
activated  /org/freedesktop/NetworkManager/ActiveConnection/11  --
   virbr0  dc46fe89-5b22-438a-85d5-37be48a077ea  bridge
155143  pe  1. maaliskuuta 2019 11.42.13  no   0
 no/org/freedesktop/NetworkManager/Settings/2  yes virbr0   
activated  /org/freedesktop/NetworkManager/ActiveConnection/1   --
  nmcli-nm:
   RUNNING  VERSION  STATE  STARTUP  CONNECTIVITY  NETWORKING  WIFI-HW  
WIFI  WWAN-HW  WWAN
   running  1.10.6   connected  started  full  enabled enabled  
disabled  enabled  enabled
  ---
  ProblemType: Bug
  ApportVersion: 2.20.9-0ubuntu7.5
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  sami   1315 F pulseaudio
   /dev/snd/controlC0:  sami   1315 F pulseaudio
  CurrentDesktop: ubuntu:GNOME
  DistroRelease: Ubuntu 18.04
  IfupdownConfig:
   # interfaces(5) file used by ifup(8) and ifdown(8)
   auto lo
   iface lo inet loopback
  InstallationDate: Installed on 2019-02-20 (11 days ago)
  InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 
(20190210)
  IpRoute:
   default via 130.232.69.254 dev enx00e04c704f68 proto dhcp metric 100
   130.232.69.0/24 dev enx00e04c704f68 proto kernel scope link src 
130.232.69.176 metric 100
   169.254.0.0/16 dev virbr0 scope link metric 1000 linkdown
   192.168.122.0/24 dev virbr0 proto kernel scope link src 192.168.122.1 
linkdown
  MachineType: LENOVO 81H1
  NetworkManager.state:
   [main]
   NetworkingEnabled=true
   WirelessEnabled=true
   WWANEnabled=true
  Package: network-manager 1.10.6-2ubuntu1.1
  PackageArchitecture: amd64
  ProcFB: 0 amdgpudrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.18.0-15-generic 
root=UUID=a6aaac69-de44-4491-bfb7-0e57c9ff25cf ro rootflags=subvol=@ quiet 
splash vt.handoff=1
  ProcVersionSignature: Ubuntu 4.18.0-15.16~18.04.1-generic 4.18.20
  RelatedPackageVersions:
   linux-restricted-modules-4.18.0-15-generic N/A
   linux-backports-modules-4.18.0-15-generic  N/A
   linux-firmware 1.173.3
  Tags:  bionic wayland-session wayland-session
  Uname: Linux 4.18.0-15-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip libvirt lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  

[Touch-packages] [Bug 1789924] Re: Missing Intel GPU pci-id's

2018-09-06 Thread Seth Forshee
** Changed in: linux (Ubuntu)
   Status: Confirmed => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libdrm in Ubuntu.
https://bugs.launchpad.net/bugs/1789924

Title:
  Missing Intel GPU pci-id's

Status in libdrm package in Ubuntu:
  New
Status in linux package in Ubuntu:
  Fix Committed
Status in mesa package in Ubuntu:
  New
Status in xorg-server package in Ubuntu:
  Fix Released
Status in libdrm source package in Bionic:
  New
Status in linux source package in Bionic:
  Fix Committed
Status in mesa source package in Bionic:
  New
Status in xorg-server source package in Bionic:
  New

Bug description:
  [Impact]
  There are some new Intel GPU pci-id's that need to be added to several places:

  0x3E98
  0x87C0

  and to make future additions easier, add platform definitions for
  Whiskey Lake and Amber Lake too.

  [Test case]
  Check that the user session uses the proper driver on these systems.

  [Regression potential]
  none, these just add pci-id's and platform definitions

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libdrm/+bug/1789924/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1762385] Re: dell_wmi: Unknown key codes

2018-08-30 Thread Seth Forshee
** Changed in: linux (Ubuntu Cosmic)
   Status: Confirmed => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1762385

Title:
  dell_wmi: Unknown key codes

Status in OEM Priority Project:
  Triaged
Status in linux package in Ubuntu:
  Fix Committed
Status in systemd package in Ubuntu:
  Fix Released
Status in systemd source package in Xenial:
  New
Status in linux source package in Bionic:
  In Progress
Status in systemd source package in Bionic:
  Fix Released
Status in linux source package in Cosmic:
  Fix Committed
Status in systemd source package in Cosmic:
  Fix Released

Bug description:
  [Impact]

   * Bogus keycode messages produced by the kernel / user annoyance
   * rfkill keyboard shortcuts not working as intended on some Dell machines

  [Test Case]

   * check that there are no spurious kernel messages about unknown keys
  in journalctl upon RFKill key presses

   * check that RFKill key presses work correctly and kill/restore RF
  capabilities

  [Regression Potential]

   * The change is scoped to particular SKUs and thus should only affect them
   * It is related to matching gsd support, which is in-place on xenial and up

  [Solution]
  Cherrypick upstream commit 
https://github.com/systemd/systemd/commit/cab01e9ecf1c69656785e64f5fc94cd4ed09e57f

  [Original Bug report]

  RFKill key produces these messages in kernel log:

  dell_wmi: Unknown key with type 0x0010 and code 0xe008 pressed

  This key code is a notification and should be added as KEY_IGNORE
  here:
  https://github.com/torvalds/linux/blob/master/drivers/platform/x86
  /dell-wmi.c#L263

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: linux-image-4.15.0-15-generic 4.15.0-15.16
  ProcVersionSignature: Ubuntu 4.15.0-15.16-generic 4.15.15
  Uname: Linux 4.15.0-15-generic x86_64
  ApportVersion: 2.20.9-0ubuntu4
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  dmig   2737 F pulseaudio
  CurrentDesktop: ubuntu:GNOME
  Date: Mon Apr  9 18:09:03 2018
  InstallationDate: Installed on 2018-03-27 (12 days ago)
  InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180327)
  MachineType: Dell Inc. Inspiron 5379
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/@/boot/vmlinuz-4.15.0-15-generic 
root=UUID=9745e22b-0b19-4a7d-98a0-1a4bc5b19d99 ro rootflags=subvol=@ quiet 
splash vt.handoff=1
  RelatedPackageVersions:
   linux-restricted-modules-4.15.0-15-generic N/A
   linux-backports-modules-4.15.0-15-generic  N/A
   linux-firmware 1.173
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 01/31/2018
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.6.0
  dmi.board.name: 0C6J64
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 10
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvr1.6.0:bd01/31/2018:svnDellInc.:pnInspiron5379:pvr:rvnDellInc.:rn0C6J64:rvrA00:cvnDellInc.:ct10:cvr:
  dmi.product.family: Inspiron
  dmi.product.name: Inspiron 5379
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1762385/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1787440] [NEW] systemd 237-3ubuntu10 ADT test failure with linux 4.18.0-5.6

2018-08-16 Thread Seth Forshee
Public bug reported:

Testing failed on:
i386: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic-canonical-kernel-team-unstable/cosmic/i386/s/systemd/20180816_145803_9e627@/log.gz
s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic-canonical-kernel-team-unstable/cosmic/s390x/s/systemd/20180816_140152_9e627@/log.gz

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: kernel-adt-failure

** Tags added: kernel-adt-failure

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1787440

Title:
  systemd 237-3ubuntu10 ADT test failure with linux 4.18.0-5.6

Status in systemd package in Ubuntu:
  New

Bug description:
  Testing failed on:
  i386: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic-canonical-kernel-team-unstable/cosmic/i386/s/systemd/20180816_145803_9e627@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic-canonical-kernel-team-unstable/cosmic/s390x/s/systemd/20180816_140152_9e627@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1787440/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1787436] [NEW] lxc 3.0.1-0ubuntu2 ADT test failure with linux 4.18.0-5.6

2018-08-16 Thread Seth Forshee
Public bug reported:

Testing failed on:
amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic-canonical-kernel-team-unstable/cosmic/amd64/l/lxc/20180816_134239_340a6@/log.gz
arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic-canonical-kernel-team-unstable/cosmic/arm64/l/lxc/20180816_135423_340a6@/log.gz
i386: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic-canonical-kernel-team-unstable/cosmic/i386/l/lxc/20180816_134641_340a6@/log.gz
ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic-canonical-kernel-team-unstable/cosmic/ppc64el/l/lxc/20180816_134231_340a6@/log.gz
s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic-canonical-kernel-team-unstable/cosmic/s390x/l/lxc/20180816_134140_340a6@/log.gz

** Affects: lxc (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: kernel-adt-failure

** Tags added: kernel-adt-failure

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lxc in Ubuntu.
https://bugs.launchpad.net/bugs/1787436

Title:
  lxc 3.0.1-0ubuntu2 ADT test failure with linux 4.18.0-5.6

Status in lxc package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic-canonical-kernel-team-unstable/cosmic/amd64/l/lxc/20180816_134239_340a6@/log.gz
  arm64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic-canonical-kernel-team-unstable/cosmic/arm64/l/lxc/20180816_135423_340a6@/log.gz
  i386: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic-canonical-kernel-team-unstable/cosmic/i386/l/lxc/20180816_134641_340a6@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic-canonical-kernel-team-unstable/cosmic/ppc64el/l/lxc/20180816_134231_340a6@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic-canonical-kernel-team-unstable/cosmic/s390x/l/lxc/20180816_134140_340a6@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/1787436/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1783138] Re: hinic interfaces aren't getting predictable names

2018-08-01 Thread Seth Forshee
** Changed in: linux (Ubuntu)
   Status: In Progress => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1783138

Title:
  hinic interfaces aren't getting predictable names

Status in linux package in Ubuntu:
  Fix Committed
Status in systemd package in Ubuntu:
  Invalid
Status in linux source package in Bionic:
  In Progress
Status in systemd source package in Bionic:
  Invalid

Bug description:
  [Impact]
  Interfaces associated with Huawei "hinic" PCI adapters will not be assigned 
predictable names[*] and instead remain using the kernel names (e.g. eth0). 
This can lead to races where the interface names are not the same on every 
boot. For example, in a system with both 2-port hinic and 2-port igb devices, 
the hinic interfaces would be eth0 & eth1 if the kernel finished probing hinic 
before igb loaded. But if igb completes loading first, the hinic interfaces 
would be eth2 & eth3.

  [*]
  
https://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames/

  [Test Case]
  grep ^eth /proc/net/dev

  [Fix]
  There's an upstream fix that properly associates the hinic interfaces with 
their PCI devices, providing udev with the info it needs to generate a 
predictable name.

  [Regression Risk]
  The big regression risk here is with existing bionic installs w/ hinic 
devices. They will be currently using "eth" names by default, and this change 
will cause those names to change to "enP" names after upgrade. However, in only 
certain configs are those "eth" names reliable (e.g. only NIC in the system is 
a hinic plug-in card). It sucks to introduce such a change in a stable release 
- but users will be bitten by this when they upgrade or transition to the HWE 
kernel anyway if we don't.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1783138/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1780227] Re: locking sockets broken due to missing AppArmor socket mediation patches

2018-08-01 Thread Seth Forshee
** Changed in: linux (Ubuntu)
   Status: Triaged => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apparmor in Ubuntu.
https://bugs.launchpad.net/bugs/1780227

Title:
  locking sockets broken due to missing AppArmor socket mediation
  patches

Status in apparmor package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Fix Committed
Status in apparmor source package in Xenial:
  Invalid
Status in linux source package in Xenial:
  Fix Committed
Status in apparmor source package in Bionic:
  Invalid
Status in linux source package in Bionic:
  Fix Committed

Bug description:
  Hey,

  Newer systemd makes use of locks placed on AF_UNIX sockets created
  with the socketpair() syscall to synchronize various bits and pieces
  when isolating services. On kernels prior to 4.18 that do not have
  backported the AppArmor socket mediation patchset this will cause the
  locks to be denied with EACCESS. This causes systemd to be broken in
  LXC and LXD containers that do not run unconfined which is a pretty
  big deal. We have seen various bug reports related to this. See for
  example [1] and [2].

  If feasible it would be excellent if we could backport the socket
  mediation patchset to all LTS kernels. Afaict, this should be 4.4 and
  4.15. This will unbreak a whole range of use-cases.

  The socket mediation patchset is available here:
  
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=80a17a5f501ea048d86f81d629c94062b76610d4

  
  [1]: https://bugs.launchpad.net/ubuntu/+source/apparmor/+bug/1575779
  [2]: https://github.com/systemd/systemd/issues/9493

  Thanks!
  Christian

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apparmor/+bug/1780227/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1778551] Re: Add linux-modules* packages to VersionedKernelPackages

2018-06-25 Thread Seth Forshee
Other than simply checking the patterns in the file, I can't think of an
easier way to test. If you know of one please let me know. I do
currently have a vm set up to let me test it.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apt in Ubuntu.
https://bugs.launchpad.net/bugs/1778551

Title:
  Add linux-modules* packages to VersionedKernelPackages

Status in apt package in Ubuntu:
  Fix Released
Status in apt source package in Xenial:
  Triaged

Bug description:
  == SRU Justification ==

  Impact: The 4.15 hwe kernel includes some package shuffling, so the
  VersionedKernelPackages list in /etc/apt/apt.conf.d/01autoremove needs
  to be updated to include linux-modules* packages.

  Fix: Backport the conf file changes from bionic.

  Test Case: Confirm that linux-modules* packages are autoremoved
  according to the same rules used for linux-image* packages.

  Regression Potential: Minimal. Probably the worst case is that some
  packages that should be autoremoved are not, but since these changes
  have been in use in bionic for a while now no regressions are
  expected.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apt/+bug/1778551/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1778551] Re: Add linux-modules* packages to VersionedKernelPackages

2018-06-25 Thread Seth Forshee
Hmm, now that I actually look at how the file is used, I guess we could
verify the list generated by /etc/kernel/postinst.d/apt-auto-removal,
couldn't we?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apt in Ubuntu.
https://bugs.launchpad.net/bugs/1778551

Title:
  Add linux-modules* packages to VersionedKernelPackages

Status in apt package in Ubuntu:
  Fix Released
Status in apt source package in Xenial:
  Triaged

Bug description:
  == SRU Justification ==

  Impact: The 4.15 hwe kernel includes some package shuffling, so the
  VersionedKernelPackages list in /etc/apt/apt.conf.d/01autoremove needs
  to be updated to include linux-modules* packages.

  Fix: Backport the conf file changes from bionic.

  Test Case: Confirm that linux-modules* packages are autoremoved
  according to the same rules used for linux-image* packages.

  Regression Potential: Minimal. Probably the worst case is that some
  packages that should be autoremoved are not, but since these changes
  have been in use in bionic for a while now no regressions are
  expected.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apt/+bug/1778551/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1778551] [NEW] Add linux-modules* packages to VersionedKernelPackages

2018-06-25 Thread Seth Forshee
Public bug reported:

== SRU Justification ==

Impact: The 4.15 hwe kernel includes some package shuffling, so the
VersionedKernelPackages list in /etc/apt/apt.conf.d/01autoremove needs
to be updated to include linux-modules* packages.

Fix: Backport the conf file changes from bionic.

Test Case: Confirm that linux-modules* packages are autoremoved
according to the same rules used for linux-image* packages.

Regression Potential: Minimal. Probably the worst case is that some
packages that should be autoremoved are not, but since these changes
have been in use in bionic for a while now no regressions are expected.

** Affects: apt (Ubuntu)
 Importance: Undecided
 Status: Fix Released

** Changed in: apt (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apt in Ubuntu.
https://bugs.launchpad.net/bugs/1778551

Title:
  Add linux-modules* packages to VersionedKernelPackages

Status in apt package in Ubuntu:
  Fix Released

Bug description:
  == SRU Justification ==

  Impact: The 4.15 hwe kernel includes some package shuffling, so the
  VersionedKernelPackages list in /etc/apt/apt.conf.d/01autoremove needs
  to be updated to include linux-modules* packages.

  Fix: Backport the conf file changes from bionic.

  Test Case: Confirm that linux-modules* packages are autoremoved
  according to the same rules used for linux-image* packages.

  Regression Potential: Minimal. Probably the worst case is that some
  packages that should be autoremoved are not, but since these changes
  have been in use in bionic for a while now no regressions are
  expected.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apt/+bug/1778551/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1776669] [NEW] network-manager 1.10.6-2ubuntu1 ADT test failure with linux 4.17.0-2.3

2018-06-13 Thread Seth Forshee
Public bug reported:

Testing failed on:
s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic-canonical-kernel-team-bootstrap/cosmic/s390x/n/network-manager/20180613_112923_bf26d@/log.gz

** Affects: network-manager (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: kernel-adt-failure

** Tags added: kernel-adt-failure

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1776669

Title:
  network-manager 1.10.6-2ubuntu1 ADT test failure with linux 4.17.0-2.3

Status in network-manager package in Ubuntu:
  New

Bug description:
  Testing failed on:
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic-canonical-kernel-team-bootstrap/cosmic/s390x/n/network-manager/20180613_112923_bf26d@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1776669/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1776670] [NEW] systemd 237-3ubuntu10 ADT test failure with linux 4.17.0-2.3

2018-06-13 Thread Seth Forshee
Public bug reported:

Testing failed on:
amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic-canonical-kernel-team-bootstrap/cosmic/amd64/s/systemd/20180613_003352_38c07@/log.gz
i386: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic-canonical-kernel-team-bootstrap/cosmic/i386/s/systemd/20180613_003420_38c07@/log.gz

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: kernel-adt-failure

** Tags added: kernel-adt-failure

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1776670

Title:
  systemd 237-3ubuntu10 ADT test failure with linux 4.17.0-2.3

Status in systemd package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic-canonical-kernel-team-bootstrap/cosmic/amd64/s/systemd/20180613_003352_38c07@/log.gz
  i386: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic-canonical-kernel-team-bootstrap/cosmic/i386/s/systemd/20180613_003420_38c07@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1776670/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1773476] Re: linux-firmware 1.157.19 attempts to generate /boot/initrd.img-4.8.0-56, /boot/initrd.img-4.8.0 when no corresponding vmlinuz present

2018-05-29 Thread Seth Forshee
This is not a problem with linux-firmware itself, it does is trigger a
rebuild of the initrd for all installed kernels but it's initramfs-tools
which does this. It will try to generate an initrd for all kernels with
a file in /var/lib/initramfs-tools, so it sounds like you have a file
there for that kernel but no corresponding directory for that kernel in
/lib/modules.

Changing this bug report to be against initramfs-tools.

** Package changed: linux-firmware (Ubuntu) => initramfs-tools (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1773476

Title:
  linux-firmware 1.157.19 attempts to generate
  /boot/initrd.img-4.8.0-56, /boot/initrd.img-4.8.0 when no
  corresponding vmlinuz present

Status in initramfs-tools package in Ubuntu:
  Confirmed

Bug description:
  With LinUX Images/-Extras 4.15.0-22-generic, 4.13.0-43-generic,
  4.8.0-58-generic, 4.8.0-56-generic, and 4.4.0-127-generic installed,
  sudo dpkg-reconfigure linux-firmware returns the following to Console:

  update-initramfs: Generating /boot/initrd.img-4.15.0-22-generic
  update-initramfs: Generating /boot/initrd.img-4.13.0-43-generic
  update-initramfs: Generating /boot/initrd.img-4.8.0-58-generic
  update-initramfs: Generating /boot/initrd.img-4.8.0-56-generic
  update-initramfs: Generating /boot/initrd.img-4.8.0-56
  WARNING: missing /lib/modules/4.8.0-56
  Ensure all necessary drivers are built into the linux image!
  depmod: ERROR: could not open directory /lib/modules/4.8.0-56: No such file 
or directory
  depmod: FATAL: could not search modules: No such file or directory
  depmod: WARNING: could not open 
/var/tmp/mkinitramfs_AlVft4/lib/modules/4.8.0-56/modules.order: No such file or 
directory
  depmod: WARNING: could not open 
/var/tmp/mkinitramfs_AlVft4/lib/modules/4.8.0-56/modules.builtin: No such file 
or directory
  update-initramfs: Generating /boot/initrd.img-4.8.0
  WARNING: missing /lib/modules/4.8.0
  Ensure all necessary drivers are built into the linux image!
  depmod: ERROR: could not open directory /lib/modules/4.8.0: No such file or 
directory
  depmod: FATAL: could not search modules: No such file or directory
  depmod: WARNING: could not open 
/var/tmp/mkinitramfs_OwnjIb/lib/modules/4.8.0/modules.order: No such file or 
directory
  depmod: WARNING: could not open 
/var/tmp/mkinitramfs_OwnjIb/lib/modules/4.8.0/modules.builtin: No such file or 
directory
  update-initramfs: Generating /boot/initrd.img-4.4.0-127-generic

  Same configuration report for "Setting up linux-firmware..." with sudo
  apt(-get) install (--reinstall) linux-firmware and sudo apt-get
  upgrade linux-firmware.  Therefore:

  Reproducible: Always
  Steps to reproduce: sudo apt install (--reinstall) linux-firmware or sudo 
dpkg-reconfigure linux-firmware.
  Actual results, excepting actually installed Kernel Image packages:

  update-initramfs: Generating /boot/initrd.img-4.8.0-56
  WARNING: missing /lib/modules/4.8.0-56
  Ensure all necessary drivers are built into the linux image!
  depmod: ERROR: could not open directory /lib/modules/4.8.0-56: No such file 
or directory
  depmod: FATAL: could not search modules: No such file or directory
  depmod: WARNING: could not open 
/var/tmp/mkinitramfs_AlVft4/lib/modules/4.8.0-56/modules.order: No such file or 
directory
  depmod: WARNING: could not open 
/var/tmp/mkinitramfs_AlVft4/lib/modules/4.8.0-56/modules.builtin: No such file 
or directory
  update-initramfs: Generating /boot/initrd.img-4.8.0
  WARNING: missing /lib/modules/4.8.0
  Ensure all necessary drivers are built into the linux image!
  depmod: ERROR: could not open directory /lib/modules/4.8.0: No such file or 
directory
  depmod: FATAL: could not search modules: No such file or directory
  depmod: WARNING: could not open 
/var/tmp/mkinitramfs_OwnjIb/lib/modules/4.8.0/modules.order: No such file or 
directory
  depmod: WARNING: could not open 
/var/tmp/mkinitramfs_OwnjIb/lib/modules/4.8.0/modules.builtin: No such file or 
directory

  Expected results, excepting actually installed Kernel Image packages:

  No attempt to generate /boot/initrd.img for missing kernels, thus no
  warnings, errors or fatals.

  ---
  ApportVersion: 2.20.1-0ubuntu2.17
  Architecture: amd64
  CurrentDesktop: Unity
  Dependencies:

  DistroRelease: Ubuntu 16.04
  InstallationDate: Installed on 2017-05-17 (373 days ago)
  InstallationMedia: Ubuntu 16.04.2 LTS "Xenial Xerus" - Release amd64 
(20170215.2)
  Package: linux-firmware 1.157.19 [origin: unknown]
  PackageArchitecture: all
  ProcVersionSignature: Ubuntu 4.15.0-22.24~16.04.1-generic 4.15.17
  Tags: xenial third-party-packages
  Uname: Linux 4.15.0-22-generic x86_64
  UnreportableReason: This is not an official Ubuntu package. Please remove any 
third party package and try again.
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip 

[Touch-packages] [Bug 1768001] Re: En Thinkpad T430 con controlador BCM20702A0

2018-05-01 Thread Seth Forshee
I'm afraid that the firmware files just look to be pulled out of Windows
drivers downloaded from arbitrary download sites. I'd be hesitant to
stick those into our linux-firmware package in any case, and without a
license which allows us to redistribute the files we simply cannot
distribute them in Ubuntu.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to bluez in Ubuntu.
https://bugs.launchpad.net/bugs/1768001

Title:
  En Thinkpad T430 con controlador BCM20702A0

Status in bluez package in Ubuntu:
  Invalid
Status in linux-firmware package in Ubuntu:
  Triaged

Bug description:
  loa dispositivos se intentan conectar y se conectan/desconectan
  continuamente. Se hace inutilizable el bluetooth.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: bluez 5.48-0ubuntu3
  ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
  Uname: Linux 4.15.0-20-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Mon Apr 30 13:26:49 2018
  InstallationDate: Installed on 2018-04-27 (2 days ago)
  InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
  InterestingModules: rfcomm bnep btusb bluetooth
  MachineType: LENOVO 2349I62
  ProcEnviron:
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=es_ES.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-20-generic 
root=UUID=b9f1f5f8-77c7-404e-92e8-a58f7bd5fa9e ro quiet splash vt.handoff=1
  SourcePackage: bluez
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 09/25/2017
  dmi.bios.vendor: LENOVO
  dmi.bios.version: G1ETB4WW (2.74 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 2349I62
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Defined
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: 
dmi:bvnLENOVO:bvrG1ETB4WW(2.74):bd09/25/2017:svnLENOVO:pn2349I62:pvrThinkPadT430:rvnLENOVO:rn2349I62:rvrNotDefined:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.family: ThinkPad T430
  dmi.product.name: 2349I62
  dmi.product.version: ThinkPad T430
  dmi.sys.vendor: LENOVO
  hciconfig:
   hci0:Type: Primary  Bus: USB
BD Address: 74:E5:43:C5:85:87  ACL MTU: 1021:8  SCO MTU: 64:1
UP RUNNING PSCAN ISCAN 
RX bytes:1196 acl:0 sco:0 events:88 errors:0
TX bytes:4095 acl:0 sco:0 commands:86 errors:0

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1768001/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1760106] Re: FFe: Enable configuring resume offset via sysfs

2018-04-03 Thread Seth Forshee
** Changed in: linux (Ubuntu Bionic)
   Status: Triaged => Fix Committed

** Changed in: linux (Ubuntu Bionic)
 Assignee: (unassigned) => Seth Forshee (sforshee)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1760106

Title:
  FFe: Enable configuring resume offset via sysfs

Status in klibc package in Ubuntu:
  New
Status in linux package in Ubuntu:
  Fix Committed
Status in systemd package in Ubuntu:
  New
Status in klibc source package in Bionic:
  New
Status in linux source package in Bionic:
  Fix Committed
Status in systemd source package in Bionic:
  New

Bug description:
  In 4.17 a new attribute is introduced to configure the hibernation
  resume offset. Since Ubuntu enables a swapfile by default this
  attribute is important to be able to make hibernation work "out of the
  box".

  The patch in the kernel is here:
  
https://git.kernel.org/pub/scm/linux/kernel/git/rafael/linux-pm.git/commit/?h=linux-next=355064675f1c997cea017ea64c8f2c216e5425d9

  Systemd support for adopting this change is available here:
  https://github.com/systemd/systemd/pull/8406
  As of 3/30/18 it's not yet been merged however.

  Klibc support for adopting this change is available here:
  https://www.zytor.com/pipermail/klibc/2018-March/003986.html

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/klibc/+bug/1760106/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1717224] Re: virsh start of virtual guest domain fails with internal error due to low default aio-max-nr sysctl value

2018-02-26 Thread Seth Forshee
** Changed in: linux (Ubuntu)
   Status: In Progress => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to procps in Ubuntu.
https://bugs.launchpad.net/bugs/1717224

Title:
  virsh start of virtual guest domain fails with internal error due to
  low default aio-max-nr sysctl value

Status in Ubuntu on IBM z Systems:
  In Progress
Status in kvm package in Ubuntu:
  Won't Fix
Status in linux package in Ubuntu:
  Fix Released
Status in procps package in Ubuntu:
  New
Status in linux source package in Xenial:
  In Progress
Status in procps source package in Xenial:
  New
Status in linux source package in Zesty:
  Won't Fix
Status in procps source package in Zesty:
  Won't Fix
Status in linux source package in Artful:
  In Progress
Status in procps source package in Artful:
  New

Bug description:
  Starting virtual guests via on Ubuntu 16.04.2 LTS installed with its
  KVM hypervisor on an IBM Z14 system LPAR fails on the 18th guest with
  the following error:

  root@zm93k8:/rawimages/ubu1604qcow2# virsh start zs93kag70038
  error: Failed to start domain zs93kag70038
  error: internal error: process exited while connecting to monitor: 
2017-07-26T01:48:26.352534Z qemu-kvm: -drive 
file=/guestimages/data1/zs93kag70038.qcow2,format=qcow2,if=none,id=drive-virtio-disk0,cache=none,aio=native:
 Could not open backing file: Could not set AIO state: Inappropriate ioctl for 
device

  The previous 17 guests started fine:

  root@zm93k8# virsh start zs93kag70020
  Domain zs93kag70020 started

  root@zm93k8# virsh start zs93kag70021
  Domain zs93kag70021 started

  .
  .

  root@zm93k8:/rawimages/ubu1604qcow2# virsh start zs93kag70036
  Domain zs93kag70036 started

  
  We ended up fixing the issue by adding the following line to /etc/sysctl.conf 
: 

  fs.aio-max-nr = 4194304

  ... then, reload the sysctl config file:

  root@zm93k8:/etc# sysctl -p /etc/sysctl.conf
  fs.aio-max-nr = 4194304

  
  Now, we're able to start more guests...

  root@zm93k8:/etc# virsh start zs93kag70036
  Domain zs93kag70036 started

  
  The default value was originally set to 65535: 

  root@zm93k8:/rawimages/ubu1604qcow2# cat /proc/sys/fs/aio-max-nr
  65536

  
  Note, we chose the 4194304 value, because this is what our KVM on System Z 
hypervisor ships as its default value.  Eg.  on our zKVM system: 

  [root@zs93ka ~]# cat /proc/sys/fs/aio-max-nr
  4194304

  ubuntu@zm93k8:/etc$ lsb_release -a
  No LSB modules are available.
  Distributor ID: Ubuntu
  Description:Ubuntu 16.04.2 LTS
  Release:16.04
  Codename:   xenial
  ubuntu@zm93k8:/etc$

  ubuntu@zm93k8:/etc$ dpkg -s qemu-kvm |grep Version
  Version: 1:2.5+dfsg-5ubuntu10.8

  Is something already documented for Ubuntu KVM users warning them about the 
low default value, and some guidance as to
  how to select an appropriate value?   Also, would you consider increasing the 
default aio-max-nr value to something much
  higher, to accommodate significantly more virtual guests?  

  Thanks!

  ---uname output---
  ubuntu@zm93k8:/etc$ uname -a Linux zm93k8 4.4.0-62-generic #83-Ubuntu SMP Wed 
Jan 18 14:12:54 UTC 2017 s390x s390x s390x GNU/Linux
   
  Machine Type = z14 
   
  ---Debugger---
  A debugger is not configured
   
  ---Steps to Reproduce---
   See Problem Description.

  The problem was happening a week ago, so this may not reflect that
  activity.

  This file was collected on Aug 7, one week after we were hitting the
  problem.  If I need to reproduce the problem and get fresh data,
  please let me know.

  /var/log/messages doesn't exist on this system, so I provided syslog
  output instead.

  All data have been collected too late after the problem was observed
  over a week ago.  If you need me to reproduce the problem and get new
  data, please let me know.  That's not a problem.

  Also, we would have to make special arrangements for login access to
  these systems.  I'm happy to run traces and data collection for you as
  needed.  If that's not sufficient, then we'll explore log in access
  for you.

  Thanks...   - Scott G.

  
  I was able to successfully recreate the problem and captured / attached new 
debug docs. 

  Recreate procedure:

  #  Started out with no virtual guests running.

  ubuntu@zm93k8:/home/scottg$ virsh list
   IdName   State
  

  
  # Set fs.aio-max-nr back to original Ubuntu "out of the box" value in 
/etc/sysctl.conf

  ubuntu@zm93k8:~$ tail -1 /etc/sysctl.conf
  fs.aio-max-nr = 65536

  
  ## sysctl -a shows: 

  fs.aio-max-nr = 4194304

  
  ##  Reload sysctl.

  ubuntu@zm93k8:~$ sudo sysctl -p /etc/sysctl.conf
  fs.aio-max-nr = 65536
  ubuntu@zm93k8:~$

  ubuntu@zm93k8:~$ sudo sysctl -a |grep fs.aio-max-nr
  fs.aio-max-nr = 65536

  ubuntu@zm93k8:~$  cat /proc/sys/fs/aio-max-nr
  65536


  # Attempt to start more than 17 qcow2 virtual guests on the Ubuntu
  

[Touch-packages] [Bug 1733328] Re: systemd 235-2ubuntu3 ADT test failure with linux 4.14.0-7.9

2017-12-07 Thread Seth Forshee
** Changed in: systemd (Ubuntu)
   Status: New => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1733328

Title:
  systemd 235-2ubuntu3 ADT test failure with linux 4.14.0-7.9

Status in systemd package in Ubuntu:
  Invalid

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic-canonical-kernel-team-bootstrap/bionic/amd64/s/systemd/20171120_141956_c23d7@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic-canonical-kernel-team-bootstrap/bionic/s390x/s/systemd/20171120_131930_c23d7@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1733328/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1733328] Re: systemd 235-2ubuntu3 ADT test failure with linux 4.14.0-7.9

2017-11-20 Thread Seth Forshee
amd64 also passed on retry. s390x failure is present with 4.13 kernel
too, so not a regression in 4.14.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1733328

Title:
  systemd 235-2ubuntu3 ADT test failure with linux 4.14.0-7.9

Status in systemd package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic-canonical-kernel-team-bootstrap/bionic/amd64/s/systemd/20171120_141956_c23d7@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic-canonical-kernel-team-bootstrap/bionic/s390x/s/systemd/20171120_131930_c23d7@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1733328/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1733328] Re: systemd 235-2ubuntu3 ADT test failure with linux 4.14.0-7.9

2017-11-20 Thread Seth Forshee
** Description changed:

  Testing failed on:
- i386: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic-canonical-kernel-team-bootstrap/bionic/i386/s/systemd/20171118_221900_c23d7@/log.gz
- s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic-canonical-kernel-team-bootstrap/bionic/s390x/s/systemd/20171120_131930_c23d7@/log.gz
+ amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic-canonical-kernel-team-bootstrap/bionic/amd64/s/systemd/20171120_141956_c23d7@/log.gz
+ s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic-canonical-kernel-team-bootstrap/bionic/s390x/s/systemd/20171120_131930_c23d7@/log.gz

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1733328

Title:
  systemd 235-2ubuntu3 ADT test failure with linux 4.14.0-7.9

Status in systemd package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic-canonical-kernel-team-bootstrap/bionic/amd64/s/systemd/20171120_141956_c23d7@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic-canonical-kernel-team-bootstrap/bionic/s390x/s/systemd/20171120_131930_c23d7@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1733328/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1733328] Re: systemd 235-2ubuntu3 ADT test failure with linux 4.14.0-7.9

2017-11-20 Thread Seth Forshee
Oops, didn't mean to file this yet as tests haven't completed. However
there are failures already.

On s390x, the test history leads me to believe that the tests started
failing when we switch to running tests in VMs.

Traceback (most recent call last):
  File "/tmp/autopkgtest.EztoIW/build.0Oh/src/debian/tests/systemd-fsckd", line 
267, in 
boot_with_systemd_distro()
  File "/tmp/autopkgtest.EztoIW/build.0Oh/src/debian/tests/systemd-fsckd", line 
243, in boot_with_systemd_distro
enable_plymouth()
  File "/tmp/autopkgtest.EztoIW/build.0Oh/src/debian/tests/systemd-fsckd", line 
224, in enable_plymouth
plymouth_enabled = 'splash' in open('/boot/grub/grub.cfg').read()
FileNotFoundError: [Errno 2] No such file or directory: '/boot/grub/grub.cfg'

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1733328

Title:
  systemd 235-2ubuntu3 ADT test failure with linux 4.14.0-7.9

Status in systemd package in Ubuntu:
  New

Bug description:
  Testing failed on:
  i386: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic-canonical-kernel-team-bootstrap/bionic/i386/s/systemd/20171118_221900_c23d7@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic-canonical-kernel-team-bootstrap/bionic/s390x/s/systemd/20171120_131930_c23d7@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1733328/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1733328] [NEW] systemd 235-2ubuntu3 ADT test failure with linux 4.14.0-7.9

2017-11-20 Thread Seth Forshee
Public bug reported:

Testing failed on:
i386: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic-canonical-kernel-team-bootstrap/bionic/i386/s/systemd/20171118_221900_c23d7@/log.gz
s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic-canonical-kernel-team-bootstrap/bionic/s390x/s/systemd/20171120_131930_c23d7@/log.gz

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: kernel-adt-failure

** Tags added: kernel-adt-failure

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1733328

Title:
  systemd 235-2ubuntu3 ADT test failure with linux 4.14.0-7.9

Status in systemd package in Ubuntu:
  New

Bug description:
  Testing failed on:
  i386: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic-canonical-kernel-team-bootstrap/bionic/i386/s/systemd/20171118_221900_c23d7@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic-canonical-kernel-team-bootstrap/bionic/s390x/s/systemd/20171120_131930_c23d7@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1733328/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1731283] Re: network-manager 1.8.4-1ubuntu3 ADT test failure with linux 4.14.0-6.8

2017-11-17 Thread Seth Forshee
Seems that s390x ADT does now run in VMs, which explains the change.

Since we don't have wireless support in our s390x kernels, these
failures are expected. Seems the tests will need to be changed to skip
these tests or make them expected failures.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1731283

Title:
  network-manager 1.8.4-1ubuntu3 ADT test failure with linux 4.14.0-6.8

Status in network-manager package in Ubuntu:
  New

Bug description:
  Testing failed on:
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic-canonical-kernel-team-bootstrap/bionic/s390x/n/network-manager/20171107_135937_02323@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1731283/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1731283] Re: network-manager 1.8.4-1ubuntu3 ADT test failure with linux 4.14.0-6.8

2017-11-17 Thread Seth Forshee
Tests were previously getting skipped for s390, due to "Restrictions:
... isolation-machine" in the test control file. Possibly some sort of
infrastructure problem detecting that the tests are running in a
container.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1731283

Title:
  network-manager 1.8.4-1ubuntu3 ADT test failure with linux 4.14.0-6.8

Status in network-manager package in Ubuntu:
  New

Bug description:
  Testing failed on:
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic-canonical-kernel-team-bootstrap/bionic/s390x/n/network-manager/20171107_135937_02323@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1731283/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1716009] Re: problem with the sound since the latest update

2017-11-13 Thread Seth Forshee
I'm not sure why this was reported against alsa-drivers, you didn't
report any alsa packages in those that were upgraded when the problem
started. To get the bug noticed it's helpful to report the bug against
the appropriate package. If you believe the issue is related to a linux-
firmware update then please report the bug against that package.
Changing the bug to affect linux-firmware.

Do you know what version of linux-firmware you were using before the
update which broke your audio?

Please capture dmesg on your machine and attach it to this bug; let me
know if you need instructions for how to do this. Thanks!

** Package changed: alsa-driver (Ubuntu) => linux-firmware (Ubuntu)

** Changed in: linux-firmware (Ubuntu)
   Status: New => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1716009

Title:
  problem with the sound since the latest update

Status in linux-firmware package in Ubuntu:
  Incomplete

Bug description:
  i am with an old intel chipset motherboard having an integrated
  realtek alc888 sound, and Ubuntu 16.04 Desktop (64-bit); since the
  latest update there has had no effect when adjusting sound volume from
  the sound menu on the menu bar and sound settings, and no sound in
  counter strike 1.6 linux version, also, there has appeared an effect
  of a sound interruption/break (for less than a second) when switching
  between applications, however, i can still adjust the sound volume
  from gnome alsa mixer

  the latest update includes:

  snapd-login-service:amd64
  libsnapd-glib1:amd64
  linux-firmware:amd64
  libgd3:amd64

  the previous ——:

  libpackagekit-glib2-16:amd64
  gir1.2-packagekitglib-1.0:amd64

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/1716009/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1731283] Re: network-manager 1.8.4-1ubuntu3 ADT test failure with linux 4.14.0-6.8

2017-11-09 Thread Seth Forshee
This and other errors are related to lacking the cfg80211 module, which
we do not build for s390. However we did not build it in artful either,
and we currently have the same version of network-manager in artful and
bionic, so it's odd that the tests are failing in bionic and not in
artful.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1731283

Title:
  network-manager 1.8.4-1ubuntu3 ADT test failure with linux 4.14.0-6.8

Status in network-manager package in Ubuntu:
  New

Bug description:
  Testing failed on:
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic-canonical-kernel-team-bootstrap/bionic/s390x/n/network-manager/20171107_135937_02323@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1731283/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1731283] [NEW] network-manager 1.8.4-1ubuntu3 ADT test failure with linux 4.14.0-6.8

2017-11-09 Thread Seth Forshee
Public bug reported:

Testing failed on:
s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic-canonical-kernel-team-bootstrap/bionic/s390x/n/network-manager/20171107_135937_02323@/log.gz

** Affects: network-manager (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: kernel-adt-failure

** Tags added: kernel-adt-failure

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1731283

Title:
  network-manager 1.8.4-1ubuntu3 ADT test failure with linux 4.14.0-6.8

Status in network-manager package in Ubuntu:
  New

Bug description:
  Testing failed on:
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic-canonical-kernel-team-bootstrap/bionic/s390x/n/network-manager/20171107_135937_02323@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1731283/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1731283] Re: network-manager 1.8.4-1ubuntu3 ADT test failure with linux 4.14.0-6.8

2017-11-09 Thread Seth Forshee
autopkgtest [13:37:31]: test wpa-dhclient: [---
modprobe: FATAL: Module cfg80211 not found in directory 
/lib/modules/4.14.0-6-generic
ERROR

==
ERROR: setUpClass (__main__.T)
--
Traceback (most recent call last):
  File 
"/tmp/autopkgtest.J2UcbH/build.Dbb/network-manager-1.8.4/debian/tests/network_test_base.py",
 line 47, in setUpClass
subprocess.check_call(['modprobe', 'cfg80211'])
  File "/usr/lib/python3.6/subprocess.py", line 291, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['modprobe', 'cfg80211']' returned 
non-zero exit status 1.

--
Ran 0 tests in 0.002s

FAILED (errors=1)
autopkgtest [13:37:32]: test wpa-dhclient: ---]

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1731283

Title:
  network-manager 1.8.4-1ubuntu3 ADT test failure with linux 4.14.0-6.8

Status in network-manager package in Ubuntu:
  New

Bug description:
  Testing failed on:
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic-canonical-kernel-team-bootstrap/bionic/s390x/n/network-manager/20171107_135937_02323@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1731283/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1727850] Re: systemd 229-4ubuntu20 ADT test failure with linux-hwe-edge 4.13.0-16.19~16.04.3

2017-10-26 Thread Seth Forshee
>From journal.txt in the adt artifacts:


Oct 25 13:55:35 autopkgtest systemd[1]: lightdm.service: Main process exited, 
code=exited, status=1/FAILURE
Oct 25 13:55:35 autopkgtest systemd[1]: lightdm.service: Unit entered failed 
state.
Oct 25 13:55:35 autopkgtest systemd[1]: lightdm.service: Failed with result 
'exit-code'.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1727850

Title:
  systemd 229-4ubuntu20 ADT test failure with linux-hwe-edge
  4.13.0-16.19~16.04.3

Status in systemd package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/amd64/s/systemd/20171025_152041_0db62@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1727850/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1727850] Re: systemd 229-4ubuntu20 ADT test failure with linux-hwe-edge 4.13.0-16.19~16.04.3

2017-10-26 Thread Seth Forshee
When I run the systemd tests locally using autopkgtest I cannot
reproduce this failure.

** Tags removed: kernel-adt-failure
** Tags added: kernel-adt-failure-hwe-edge-4.13

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1727850

Title:
  systemd 229-4ubuntu20 ADT test failure with linux-hwe-edge
  4.13.0-16.19~16.04.3

Status in systemd package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/amd64/s/systemd/20171025_152041_0db62@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1727850/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1727850] Re: systemd 229-4ubuntu20 ADT test failure with linux-hwe-edge 4.13.0-16.19~16.04.3

2017-10-26 Thread Seth Forshee
boot-smoke test fails:

checking that there are no running jobs
FAIL: expected: '' actual: '550 lightdm.service start running'

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1727850

Title:
  systemd 229-4ubuntu20 ADT test failure with linux-hwe-edge
  4.13.0-16.19~16.04.3

Status in systemd package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/amd64/s/systemd/20171025_152041_0db62@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1727850/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1727850] [NEW] systemd 229-4ubuntu20 ADT test failure with linux-hwe-edge 4.13.0-16.19~16.04.3

2017-10-26 Thread Seth Forshee
Public bug reported:

Testing failed on:
amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/amd64/s/systemd/20171025_152041_0db62@/log.gz

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: kernel-adt-failure-hwe-edge-4.13

** Tags added: kernel-adt-failure

** Description changed:

  Testing failed on:
- amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/amd64/s/systemd/20171025_152041_0db62@/log.gz
- s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/s390x/s/systemd/20171025_134325_0db62@/log.gz
+ amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/amd64/s/systemd/20171025_152041_0db62@/log.gz

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1727850

Title:
  systemd 229-4ubuntu20 ADT test failure with linux-hwe-edge
  4.13.0-16.19~16.04.3

Status in systemd package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/amd64/s/systemd/20171025_152041_0db62@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1727850/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1703339] Re: Unable to install Ubuntu on the NVMe disk under VMD PCI domain

2017-10-23 Thread Seth Forshee
Added xenial nomination for initramfs-tools to add vmd.ko to initrd for
16.04.4.

** Also affects: initramfs-tools (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Changed in: linux (Ubuntu Xenial)
   Status: New => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1703339

Title:
  Unable to install Ubuntu on the NVMe disk under VMD PCI domain

Status in initramfs-tools package in Ubuntu:
  Fix Released
Status in linux package in Ubuntu:
  Fix Released
Status in initramfs-tools source package in Xenial:
  New
Status in linux source package in Xenial:
  Invalid
Status in initramfs-tools source package in Artful:
  Fix Released
Status in linux source package in Artful:
  Fix Released

Bug description:
  It is not possible to install Ubuntu on the NVMe disk under VMD
  (Volume Management Device) PCI domain. The disk is not visible in the
  installer because VMD module is not available at this stage.

  I'm raising it against kernel package as I have impression VMD module
  must be included in linux-image dpkg package, not linux-image-extra.

  Please also assure VMD module gets included in initramfs by installer
  (if necessary).

  For more information about VMD please see bug 1591806.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: linux-image-generic 4.10.0.26.28
  ProcVersionSignature: Ubuntu 4.10.0-26.30-generic 4.10.17
  Uname: Linux 4.10.0-26-generic x86_64
  ApportVersion: 2.20.5-0ubuntu5
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/pcmC0D0p:   tomasz 1659 F...m pulseaudio
   /dev/snd/controlC0:  tomasz 1659 F pulseaudio
   /dev/snd/timer:  tomasz 1659 f pulseaudio
  CurrentDesktop: GNOME
  Date: Mon Jul 10 10:40:20 2017
  HibernationDevice: RESUME=/dev/mapper/ubuntu--vg-swap_1
  InstallationDate: Installed on 2017-07-06 (3 days ago)
  InstallationMedia: Ubuntu-Server 17.10 "Artful Aardvark" - Alpha amd64 
(20170702)
  IwConfig:
   lono wireless extensions.
   
   enp0s3no wireless extensions.
  Lsusb:
   Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
   Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: innotek GmbH VirtualBox
  ProcFB: 0 vboxdrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-26-generic 
root=/dev/mapper/hostname--vg-root ro
  RelatedPackageVersions:
   linux-restricted-modules-4.10.0-26-generic N/A
   linux-backports-modules-4.10.0-26-generic  N/A
   linux-firmware 1.167
  RfKill:
   
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 12/01/2006
  dmi.bios.vendor: innotek GmbH
  dmi.bios.version: VirtualBox
  dmi.board.name: VirtualBox
  dmi.board.vendor: Oracle Corporation
  dmi.board.version: 1.2
  dmi.chassis.type: 1
  dmi.chassis.vendor: Oracle Corporation
  dmi.modalias: 
dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:rvnOracleCorporation:rnVirtualBox:rvr1.2:cvnOracleCorporation:ct1:cvr:
  dmi.product.name: VirtualBox
  dmi.product.version: 1.2
  dmi.sys.vendor: innotek GmbH

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1703339/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1703339] Re: Unable to install Ubuntu on the NVMe disk under VMD PCI domain

2017-10-13 Thread Seth Forshee
** Also affects: initramfs-tools (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1703339

Title:
  Unable to install Ubuntu on the NVMe disk under VMD PCI domain

Status in initramfs-tools package in Ubuntu:
  New
Status in linux package in Ubuntu:
  Fix Released
Status in initramfs-tools source package in Artful:
  New
Status in linux source package in Artful:
  Fix Released

Bug description:
  It is not possible to install Ubuntu on the NVMe disk under VMD
  (Volume Management Device) PCI domain. The disk is not visible in the
  installer because VMD module is not available at this stage.

  I'm raising it against kernel package as I have impression VMD module
  must be included in linux-image dpkg package, not linux-image-extra.

  Please also assure VMD module gets included in initramfs by installer
  (if necessary).

  For more information about VMD please see bug 1591806.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: linux-image-generic 4.10.0.26.28
  ProcVersionSignature: Ubuntu 4.10.0-26.30-generic 4.10.17
  Uname: Linux 4.10.0-26-generic x86_64
  ApportVersion: 2.20.5-0ubuntu5
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/pcmC0D0p:   tomasz 1659 F...m pulseaudio
   /dev/snd/controlC0:  tomasz 1659 F pulseaudio
   /dev/snd/timer:  tomasz 1659 f pulseaudio
  CurrentDesktop: GNOME
  Date: Mon Jul 10 10:40:20 2017
  HibernationDevice: RESUME=/dev/mapper/ubuntu--vg-swap_1
  InstallationDate: Installed on 2017-07-06 (3 days ago)
  InstallationMedia: Ubuntu-Server 17.10 "Artful Aardvark" - Alpha amd64 
(20170702)
  IwConfig:
   lono wireless extensions.
   
   enp0s3no wireless extensions.
  Lsusb:
   Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
   Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: innotek GmbH VirtualBox
  ProcFB: 0 vboxdrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-26-generic 
root=/dev/mapper/hostname--vg-root ro
  RelatedPackageVersions:
   linux-restricted-modules-4.10.0-26-generic N/A
   linux-backports-modules-4.10.0-26-generic  N/A
   linux-firmware 1.167
  RfKill:
   
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 12/01/2006
  dmi.bios.vendor: innotek GmbH
  dmi.bios.version: VirtualBox
  dmi.board.name: VirtualBox
  dmi.board.vendor: Oracle Corporation
  dmi.board.version: 1.2
  dmi.chassis.type: 1
  dmi.chassis.vendor: Oracle Corporation
  dmi.modalias: 
dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:rvnOracleCorporation:rnVirtualBox:rvr1.2:cvnOracleCorporation:ct1:cvr:
  dmi.product.name: VirtualBox
  dmi.product.version: 1.2
  dmi.sys.vendor: innotek GmbH

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1703339/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1715397] Re: systemd 234-2ubuntu9 ADT test failure with linux 4.13.0-9.10

2017-09-06 Thread Seth Forshee
I see adt failures with 4.12 as well, looks like a regression in
ppc64-diag. Changing affected package.

** Package changed: systemd (Ubuntu) => ppc64-diag (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1715397

Title:
  systemd 234-2ubuntu9 ADT test failure with linux 4.13.0-9.10

Status in ppc64-diag package in Ubuntu:
  New

Bug description:
  Testing failed on:
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful-canonical-kernel-team-unstable/artful/ppc64el/s/systemd/20170906_131209_2a96a@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ppc64-diag/+bug/1715397/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1715397] Re: systemd 234-2ubuntu9 ADT test failure with linux 4.13.0-9.10

2017-09-06 Thread Seth Forshee
ep 06 12:23:41 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: 
Starting ppc64-diag rtas_errd (platform error handling) Service...
Sep 06 12:23:41 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: 
Started ppc64-diag rtas_errd (platform error handling) Service.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: 
rtas_errd.service: Service hold-off time over, scheduling restart.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: 
Stopped ppc64-diag rtas_errd (platform error handling) Service.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: 
Starting ppc64-diag rtas_errd (platform error handling) Service...
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: 
Started ppc64-diag rtas_errd (platform error handling) Service.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: 
rtas_errd.service: Service hold-off time over, scheduling restart.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: 
Stopped ppc64-diag rtas_errd (platform error handling) Service.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: 
Starting ppc64-diag rtas_errd (platform error handling) Service...
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: 
Started ppc64-diag rtas_errd (platform error handling) Service.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: 
rtas_errd.service: Service hold-off time over, scheduling restart.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: 
Stopped ppc64-diag rtas_errd (platform error handling) Service.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: 
Starting ppc64-diag rtas_errd (platform error handling) Service...
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: 
Started ppc64-diag rtas_errd (platform error handling) Service.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: 
rtas_errd.service: Service hold-off time over, scheduling restart.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: 
Stopped ppc64-diag rtas_errd (platform error handling) Service.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: 
Starting ppc64-diag rtas_errd (platform error handling) Service...
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: 
Started ppc64-diag rtas_errd (platform error handling) Service.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: 
rtas_errd.service: Service hold-off time over, scheduling restart.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: 
Stopped ppc64-diag rtas_errd (platform error handling) Service.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: 
rtas_errd.service: Start request repeated too quickly.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: 
Failed to start ppc64-diag rtas_errd (platform error handling) Service.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: 
rtas_errd.service: Unit entered failed state.
Sep 06 12:23:42 6963eeea-263f-4ad0-8fdf-549bd646f5dc-adt-prepare systemd[1]: 
rtas_errd.service: Failed with result 'start-limit-hit'.
FAIL

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1715397

Title:
  systemd 234-2ubuntu9 ADT test failure with linux 4.13.0-9.10

Status in ppc64-diag package in Ubuntu:
  New

Bug description:
  Testing failed on:
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful-canonical-kernel-team-unstable/artful/ppc64el/s/systemd/20170906_131209_2a96a@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ppc64-diag/+bug/1715397/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1713726] Re: lxc 2.0.8-0ubuntu6 ADT test failure with linux 4.13.0-7.8

2017-09-06 Thread Seth Forshee
With the latest upload tests still fail, but it seems to get slightly
farther. Is this a different issue?

https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac
/autopkgtest-artful-canonical-kernel-team-
unstable/artful/amd64/l/lxc/20170906_003748_d668f@/log.gz

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lxc in Ubuntu.
https://bugs.launchpad.net/bugs/1713726

Title:
  lxc 2.0.8-0ubuntu6 ADT test failure with linux 4.13.0-7.8

Status in lxc package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful-canonical-kernel-team-unstable/artful/amd64/l/lxc/20170829_024349_c4b5f@/log.gz
  i386: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful-canonical-kernel-team-unstable/artful/i386/l/lxc/20170829_025427_c4b5f@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful-canonical-kernel-team-unstable/artful/ppc64el/l/lxc/20170829_024824_c4b5f@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/1713726/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1715397] [NEW] systemd 234-2ubuntu9 ADT test failure with linux 4.13.0-9.10

2017-09-06 Thread Seth Forshee
Public bug reported:

Testing failed on:
ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful-canonical-kernel-team-unstable/artful/ppc64el/s/systemd/20170906_131209_2a96a@/log.gz

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: kernel-adt-failure

** Tags added: kernel-adt-failure

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1715397

Title:
  systemd 234-2ubuntu9 ADT test failure with linux 4.13.0-9.10

Status in systemd package in Ubuntu:
  New

Bug description:
  Testing failed on:
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful-canonical-kernel-team-unstable/artful/ppc64el/s/systemd/20170906_131209_2a96a@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1715397/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1713726] [NEW] lxc 2.0.8-0ubuntu6 ADT test failure with linux 4.13.0-7.8

2017-08-29 Thread Seth Forshee
Public bug reported:

Testing failed on:
amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful-canonical-kernel-team-unstable/artful/amd64/l/lxc/20170829_024349_c4b5f@/log.gz
i386: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful-canonical-kernel-team-unstable/artful/i386/l/lxc/20170829_025427_c4b5f@/log.gz
ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful-canonical-kernel-team-unstable/artful/ppc64el/l/lxc/20170829_024824_c4b5f@/log.gz

** Affects: lxc (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: kernel-adt-failure

** Tags added: kernel-adt-failure

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lxc in Ubuntu.
https://bugs.launchpad.net/bugs/1713726

Title:
  lxc 2.0.8-0ubuntu6 ADT test failure with linux 4.13.0-7.8

Status in lxc package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful-canonical-kernel-team-unstable/artful/amd64/l/lxc/20170829_024349_c4b5f@/log.gz
  i386: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful-canonical-kernel-team-unstable/artful/i386/l/lxc/20170829_025427_c4b5f@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful-canonical-kernel-team-unstable/artful/ppc64el/l/lxc/20170829_024824_c4b5f@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/1713726/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1713075] [NEW] lxc 2.0.8-0ubuntu6 ADT test failure with linux 4.13.0-6.7

2017-08-25 Thread Seth Forshee
Public bug reported:

Testing failed on:
amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful-canonical-kernel-team-unstable/artful/amd64/l/lxc/20170825_140357_85137@/log.gz
i386: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful-canonical-kernel-team-unstable/artful/i386/l/lxc/20170825_135445_85137@/log.gz
ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful-canonical-kernel-team-unstable/artful/ppc64el/l/lxc/20170825_133209_85137@/log.gz

** Affects: lxc (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: kernel-adt-failure

** Tags added: kernel-adt-failure

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lxc in Ubuntu.
https://bugs.launchpad.net/bugs/1713075

Title:
  lxc 2.0.8-0ubuntu6 ADT test failure with linux 4.13.0-6.7

Status in lxc package in Ubuntu:
  New

Bug description:
  Testing failed on:
  amd64: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful-canonical-kernel-team-unstable/artful/amd64/l/lxc/20170825_140357_85137@/log.gz
  i386: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful-canonical-kernel-team-unstable/artful/i386/l/lxc/20170825_135445_85137@/log.gz
  ppc64el: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful-canonical-kernel-team-unstable/artful/ppc64el/l/lxc/20170825_133209_85137@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/1713075/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1712865] Re: systemd 234-2ubuntu6 ADT test failure with linux 4.12.0-12.13

2017-08-24 Thread Seth Forshee
armhf passed after re-running, so I guess we can ignore it. Since the
s390x failure is fixed in -proposed I'll close the bug as invalid, I can
hint away the kernel test failure since it's clearly not a kernel issue.

** Changed in: systemd (Ubuntu)
   Status: New => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1712865

Title:
  systemd 234-2ubuntu6 ADT test failure with linux 4.12.0-12.13

Status in systemd package in Ubuntu:
  Invalid

Bug description:
  Testing failed on:
  armhf: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful/artful/armhf/s/systemd/20170823_191459_e2f1d@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful/artful/s390x/s/systemd/20170824_125405_e2f1d@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1712865/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1712865] Re: systemd 234-2ubuntu6 ADT test failure with linux 4.12.0-12.13

2017-08-24 Thread Seth Forshee
s390x failure:

autopkgtest: WARNING: Test dependencies are unsatisfiable with using apt 
pinning. Retrying with using all packages from proposed
Reading package lists...
Building dependency tree...
Reading state information...
Correcting dependencies...Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) autopkgtest-satdep:s390x < 0 @iU mK Nb Ib >
Broken autopkgtest-satdep:s390x Depends on gdm3:s390x < none @un H >
  Removing autopkgtest-satdep:s390x because I can't find gdm3:s390x
...
blame: systemd
badpkg: Test dependencies are unsatisfiable. A common reason is that your 
testbed is out of date with respect to the archive, and you need to use a 
current testbed or run apt-get update or use -U.
autopkgtest [12:54:05]: ERROR: erroneous package: Test dependencies are 
unsatisfiable. A common reason is that your testbed is out of date with respect 
to the archive, and you need to use a current testbed or run apt-get update or 
use -U.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1712865

Title:
  systemd 234-2ubuntu6 ADT test failure with linux 4.12.0-12.13

Status in systemd package in Ubuntu:
  New

Bug description:
  Testing failed on:
  armhf: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful/artful/armhf/s/systemd/20170823_191459_e2f1d@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful/artful/s390x/s/systemd/20170824_125405_e2f1d@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1712865/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1712865] Re: systemd 234-2ubuntu6 ADT test failure with linux 4.12.0-12.13

2017-08-24 Thread Seth Forshee
armhf failure:

==
FAIL: test_search_domains_too_long (__main__.NetworkdClientTest)
--
Traceback (most recent call last):
  File "/tmp/autopkgtest.WNuNXs/build.mwP/systemd-234/test/networkd-test.py", 
line 855, in test_search_domains_too_long
self.assertRegex(contents, 'search .*{p}0 {p}1 {p}2'.format(p=name_prefix))
AssertionError: Regex didn't match: 'search 
.*0 
1 
2' not found in '# 
This file is managed by man:systemd-resolved(8). Do not edit.\n#\n# This is a 
dynamic resolv.conf file for connecting local clients directly to\n# all known 
DNS servers.\n#\n# Third party programs must not access this file directly, but 
only through the\n# symlink at /etc/resolv.conf. To manage man:resolv.conf(5) 
in a different way,\n# replace this symlink by a static file or a different 
symlink.\n#\n# See man:systemd-resolved.service(8) for details about the 
supported modes of\n# operation for /etc/resolv.conf.\n\nnameserver 
10.0.4.1\nnameserver 192.168.42.1\nsearch lxd one two three four five\n# Too 
many search domains configured, remaining ones ignored.\n'

--

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1712865

Title:
  systemd 234-2ubuntu6 ADT test failure with linux 4.12.0-12.13

Status in systemd package in Ubuntu:
  New

Bug description:
  Testing failed on:
  armhf: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful/artful/armhf/s/systemd/20170823_191459_e2f1d@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful/artful/s390x/s/systemd/20170824_125405_e2f1d@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1712865/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1712865] [NEW] systemd 234-2ubuntu6 ADT test failure with linux 4.12.0-12.13

2017-08-24 Thread Seth Forshee
Public bug reported:

Testing failed on:
armhf: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful/artful/armhf/s/systemd/20170823_191459_e2f1d@/log.gz
s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful/artful/s390x/s/systemd/20170824_125405_e2f1d@/log.gz

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: kernel-adt-failure

** Tags added: kernel-adt-failure

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1712865

Title:
  systemd 234-2ubuntu6 ADT test failure with linux 4.12.0-12.13

Status in systemd package in Ubuntu:
  New

Bug description:
  Testing failed on:
  armhf: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful/artful/armhf/s/systemd/20170823_191459_e2f1d@/log.gz
  s390x: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful/artful/s390x/s/systemd/20170824_125405_e2f1d@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1712865/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1710654] Re: systemd 233-8ubuntu3 ADT test failure with linux 4.12.0-11.12

2017-08-14 Thread Seth Forshee
There are quite a few messages like these that lead me to believe where
running out of inotify watches.

Failed to acquire watch file descriptor: Too many open files
path-exists.path: Failed to enter waiting state: Too many open files

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1710654

Title:
  systemd 233-8ubuntu3 ADT test failure with linux 4.12.0-11.12

Status in systemd package in Ubuntu:
  New

Bug description:
  Testing failed on:
  armhf: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful/artful/armhf/s/systemd/20170814_062054_7f9b9@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1710654/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1710654] Re: systemd 233-8ubuntu3 ADT test failure with linux 4.12.0-11.12

2017-08-14 Thread Seth Forshee
networkd-test.py FAIL non-zero exit status 1
root-unittests   FAIL non-zero exit status 1


networkd-test:

==
FAIL: test_catchall_config (__main__.UnmanagedClientTest)
Verify link states with a catch-all config, hot-plug.
--
Traceback (most recent call last):
  File "/tmp/autopkgtest.0R9oTG/build.WC8/systemd-233/test/networkd-test.py", 
line 1009, in test_catchall_config
m0unm='managed')
  File "/tmp/autopkgtest.0R9oTG/build.WC8/systemd-233/test/networkd-test.py", 
line 145, in assert_link_states
(iface, expected, actual))
AssertionError: Link m1man expects state managed, found unmanaged


root-unittests:

== test-path ===
path-exists.service: state = dead; result = success 
path-exists.service: state = dead; result = success 
path-exists.service: state = dead; result = success 
path-exists.service: state = dead; result = success 
path-exists.service: state = dead; result = success 
path-exists.service: state = dead; result = success 
path-exists.service: state = dead; result = success 
path-exists.service: state = dead; result = success 
path-exists.service: state = dead; result = success 
path-exists.service: state = dead; result = success 
path-exists.service: state = dead; result = success 
path-exists.service: state = dead; result = success 
path-exists.service: state = dead; result = success 
path-exists.service: state = dead; result = success 
path-exists.service: state = dead; result = success 
path-exists.service: state = dead; result = success 
path-exists.service: state = dead; result = success 
path-exists.service: state = dead; result = success 
path-exists.service: state = dead; result = success 
path-exists.service: state = dead; result = success 
FAIL: test-path (code: 1)
Test timeout when testing path-exists.path

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1710654

Title:
  systemd 233-8ubuntu3 ADT test failure with linux 4.12.0-11.12

Status in systemd package in Ubuntu:
  New

Bug description:
  Testing failed on:
  armhf: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful/artful/armhf/s/systemd/20170814_062054_7f9b9@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1710654/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1710654] [NEW] systemd 233-8ubuntu3 ADT test failure with linux 4.12.0-11.12

2017-08-14 Thread Seth Forshee
Public bug reported:

Testing failed on:
armhf: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful/artful/armhf/s/systemd/20170814_062054_7f9b9@/log.gz

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: kernel-adt-failure

** Tags added: kernel-adt-failure

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1710654

Title:
  systemd 233-8ubuntu3 ADT test failure with linux 4.12.0-11.12

Status in systemd package in Ubuntu:
  New

Bug description:
  Testing failed on:
  armhf: 
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful/artful/armhf/s/systemd/20170814_062054_7f9b9@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1710654/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


  1   2   >