[Touch-packages] [Bug 1976258] Re: icu ftbfs in the jammy release pocket

2022-06-10 Thread Steve Langasek
Hello Matthias, or anyone else affected, Accepted icu into jammy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/icu/70.1-2ubuntu1 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1969375] Please test proposed package

2022-06-10 Thread Steve Langasek
Hello Dean, or anyone else affected, Accepted systemd into jammy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/systemd/249.11-0ubuntu3.3 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1969375] Re: systemd-cryptenroll does not support TPM2 devices

2022-06-10 Thread Steve Langasek
> "libssl3", but fortunately that one is already installed by default, > so should still be fine. For changes to so fundamental of a package, I think we want to be careful to have a higher standard than just "installed by default". In fact it is not possible to remove libssl3 from a jammy system

[Touch-packages] [Bug 1964494] Re: Setting DuplicateAddressDetection=none doesn't disable DAD for link-local IPs

2022-06-10 Thread Steve Langasek
Hello Alejandro, or anyone else affected, Accepted systemd into jammy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/systemd/249.11-0ubuntu3.3 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1967576] Re: systemd: autopkgtest: tests-in-lxd fails because of remaining snap .mount units

2022-06-10 Thread Steve Langasek
Hello Nick, or anyone else affected, Accepted systemd into jammy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/systemd/249.11-0ubuntu3.3 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1976607] Re: tests-in-lxd autopkgtest is skipped, due to missing 'lxd' deb

2022-06-10 Thread Steve Langasek
Hello Lukas, or anyone else affected, Accepted systemd into jammy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/systemd/249.11-0ubuntu3.3 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1976371] Re: SRU for evolution-data-server 3.44.2

2022-06-10 Thread Steve Langasek
** Also affects: evolution (Ubuntu) Importance: Undecided Status: New ** Changed in: evolution (Ubuntu) Status: New => Fix Released ** Changed in: evolution (Ubuntu Jammy) Status: New => Incomplete -- You received this bug notification because you are a member of Ubuntu

[Touch-packages] [Bug 1976371] Re: SRU for evolution-data-server 3.44.2

2022-06-10 Thread Steve Langasek
> As a component of GNOME core, How do I confirm that this is the case? https://wiki.ubuntu.com/StableReleaseUpdates/GNOME points to https://gitlab.gnome.org/GNOME/gnome-build- meta/-/tree/master/elements/core which does not list it. It does not appear in the discourse discussion at

[Touch-packages] [Bug 1966562] Re: ubuntu-minimal should not depend on isc-dhcp-client

2022-06-09 Thread Steve Langasek
The isc-dhcp-client dependency exists to ensure support for network configuration from within an initramfs, for which systemd-networkd is not currently a replacement since we don't run systemd in the initramfs. See also https://lists.ubuntu.com/archives/ubuntu- devel/2022-May/042080.html ff

[Touch-packages] [Bug 1970442] Re: ubuntu-standard shouldn't depend on transitional mime-support package

2022-06-09 Thread Steve Langasek
ubuntu-meta (1.468) hirsute; urgency=medium * Refreshed dependencies * Added media-types to standard * Removed mime-support from standard -- Steve Langasek Fri, 16 Apr 2021 21:52:27 + This dependency was removed a year before this bug report was filed? ** Changed in: ubuntu-meta

[Touch-packages] [Bug 1969375] Re: systemd-cryptenroll does not support TPM2 devices

2022-06-08 Thread Steve Langasek
Please include as part of the test plan a check that: - there are no new binary dependencies introduced in the package - systemd-cryptenroll doesn't have any undefined symbols that prevent it from running (a simple 'systemd-cryptenroll --help' suffices for this) - non-TPM use cases of

[Touch-packages] [Bug 1977493] Re: Upgrade from Ubuntu 21.10 to 22.04 fails - unmet dependencies: libpam-modules

2022-06-03 Thread Steve Langasek
If there's any bug in Ubuntu here, it's that the release upgrader didn't try harder to get the system into a consistent state before offering a reboot. No bug in pam, which is simply one of the packages to be upgraded. libpam-modules refused to be upgraded because there were references to

[Touch-packages] [Bug 1971650] Re: wrong check for "server" in libssl3.postinst

2022-05-23 Thread Steve Langasek
Certainly if Debian is dropping the per-package code in favor of needrestart we should head in the same direction, but we need to sort out getting needrestart included in the desktop-common seed first. -- You received this bug notification because you are a member of Ubuntu Touch seeded

Re: [Touch-packages] [Bug 1972115] Re: ubuntu-bug exits after dialog instead of sending data

2022-05-19 Thread Steve Langasek
On Thu, May 19, 2022 at 12:25:22PM -, Ralf Sternberg wrote: > This bug seems to prevent me from providing a crash log in > https://bugs.launchpad.net/bugs/1973802. > Is there any alternative way of attaching a crash log to a bug report? > Attachment doesn't work, apparently because of the

[Touch-packages] [Bug 1877194] Re: switch-on-connect mistakes startup for USB hotplug, so seemingly ignores the old default device on reboot

2022-05-17 Thread Steve Langasek
This behavior particularly affects Raspberry Pis, where USB is the only bus available for a lot of devices and treating this as "hotplug" gives wrong results. That doesn't mean the default should change for pulseaudio on the desktop in general, but should somehow be treated in a hardware-specific

[Touch-packages] [Bug 1972115] Re: ubuntu-bug exits after dialog instead of sending data

2022-05-09 Thread Steve Langasek
I don't think it's by design that if you explicitly run 'ubuntu-bug', it exits without giving you the opportunity to file a bug report or explaining why. Yes, it's intentional that we don't by default open bug reports on crashes, but the above seems like an accidental outcome. -- You received

[Touch-packages] [Bug 1972115] [NEW] ubuntu-bug exits after dialog instead of sending data

2022-05-08 Thread Steve Langasek
Public bug reported: After a gnome-shell crash, I am trying to manually submit it by running 'ubuntu-bug /var/crash/_usr_bin_gnome-shell.1000.crash'. This results in an apport-gtk prompt asking me "Send problem report to the developers?" When I click 'send', the dialog disappears and ubuntu-bug

[Touch-packages] [Bug 1971669] Re: Can't even launch `ubuntu-bug` console application to report any other bug!

2022-05-05 Thread Steve Langasek
Your log shows: May 05 14:44:00 khteh-p17-2i update-notifier.desktop[15164]: File "/home/khteh/.local/lib/python3.10/site-packages/httplib2/__init__.py", line 52, in May 05 14:44:00 khteh-p17-2i update-notifier.desktop[15164]: from . import auth May 05 14:44:00 khteh-p17-2i

[Touch-packages] [Bug 1965636] Re: libfuse2 no longer included in jammy, required for AppImages

2022-05-05 Thread Steve Langasek
fuse has been demoted from Ubuntu main in favor of fuse3; it would not be appropriate to re-promote it to main and expand the security surface of a default Ubuntu install (fuse is a very security-relevant facility), and Ubuntu images build only from main. So this is a wontfix for the Ubuntu

[Touch-packages] [Bug 1971650] [NEW] wrong check for "server" in libssl3.postinst

2022-05-04 Thread Steve Langasek
Public bug reported: A security update has just been applied to my system for openssl, and the 'reboot required' message just popped on my desktop. I looked to see why this was, and found the following code in the libssl3 postinst: # Here we issue the reboot notification for upgrades

[Touch-packages] [Bug 1969396] Re: Can't use Right Alt as compose key with English (Dvorak, alt. intl.) layout

2022-04-25 Thread Steve Langasek
On Wed, Apr 20, 2022 at 03:58:40AM -, Gunnar Hjalmarsson wrote: > Alternate Charters Key to None + Compose key to Right Alt > - > $ gsettings get org.gnome.desktop.input-sources xkb-options > ['lv3:ralt_alt', 'compose:ralt'] > Right Alt

[Touch-packages] [Bug 1969960] Re: Jammy's /etc/os-release missing LTS string in VERSION

2022-04-22 Thread Steve Langasek
Hello Paride, or anyone else affected, Accepted base-files into jammy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/base- files/12ubuntu4.1 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1969396] Re: Can't use Right Alt as compose key with English (Dvorak, alt. intl.) layout

2022-04-19 Thread Steve Langasek
> And AFAICT gnome-control-center sets the expected XKB options, > so it's not a g-c-c bug. Maybe an xkeyboard-config bug. >From my initial bug report: Setting Alternate Characters Key to None, and moving the Compose Key setting around between different options (and then back to Right Alt), the

[Touch-packages] [Bug 1969386] [NEW] software-properties-gtk Livepatch toggle is grayed out

2022-04-18 Thread Steve Langasek
Public bug reported: After an upgrade from impish to jammy, update-manager rightly notifies me that livepatch should be available: The software on this computer is up to date. Tip: You can use Livepatch to keep your computer more secure between restarts. However, when I click on the

[Touch-packages] [Bug 1896772] Re: systemd-resolved configures no Current Scopes on start

2022-04-18 Thread Steve Langasek
** Tags added: rls-jj-incoming -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to ifupdown in Ubuntu. https://bugs.launchpad.net/bugs/1896772 Title: systemd-resolved configures no Current Scopes on start Status in ifupdown

[Touch-packages] [Bug 1968997] Re: openssl has catastrophic issues when locale set to TR_UTF8

2022-04-15 Thread Steve Langasek
Note that because these locale objects are declared 'static', they don't go out of scope until the library is unloaded. So the only way this results in a memory leak is if a process is opening libssl via dlopen, then unloading it, then loading it again. -- You received this bug notification

[Touch-packages] [Bug 1968997] Re: openssl has catastrophic issues when locale set to TR_UTF8

2022-04-14 Thread Steve Langasek
I've uploaded a fix to the jammy unapproved queue, but it's a rather large patch and I think it should be reviewed by another member of the release team. ** Changed in: openssl (Ubuntu) Status: In Progress => Fix Committed -- You received this bug notification because you are a member of

[Touch-packages] [Bug 1968997] Re: openssl has catastrophic issues when locale set to TR_UTF8

2022-04-14 Thread Steve Langasek
** Changed in: openssl (Ubuntu) Importance: High => Critical ** Changed in: openssl (Ubuntu) Status: Confirmed => In Progress ** Changed in: openssl (Ubuntu) Assignee: (unassigned) => Steve Langasek (vorlon) -- You received this bug notification because you are

[Touch-packages] [Bug 1892825] Please test proposed package

2022-04-13 Thread Steve Langasek
Hello bs, or anyone else affected, Accepted glibc into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/glibc/2.31-0ubuntu9.9 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1927192] Please test proposed package

2022-04-13 Thread Steve Langasek
Hello Matthias, or anyone else affected, Accepted glibc into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/glibc/2.31-0ubuntu9.9 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1966800] Re: systemd locks up due to incorrect handling of time zone changes

2022-04-07 Thread Steve Langasek
This is fixed in the systemd present in Ubuntu 21.10 and later ** Changed in: systemd (Ubuntu) Status: Confirmed => Fix Released ** Also affects: systemd (Ubuntu Focal) Importance: Undecided Status: New -- You received this bug notification because you are a member of Ubuntu

[Touch-packages] [Bug 1967127] Re: [FFe] update libarchive to 3.6.0

2022-04-06 Thread Steve Langasek
> https://github.com/libarchive/libarchive/releases/tag/v3.6.0 This looks fine. > https://github.com/libarchive/libarchive/compare/v3.5.2...v3.6.0 I'm not reading this. An FFe request should include a human-readable *summary* of upstream feature-freeze-breaking that may introduce risk of

[Touch-packages] [Bug 1962332] Re: xenial systemd fails to start if cgroup2 is mounted

2022-03-18 Thread Steve Langasek
It's the SRU team's purview to make exceptions here. The rationale that this only benefits images is and therefore needs to be in the main archive is sound. So for the SRU team, I'm +1 on going ahead with this. But someone still needs to prepare the SRU, which I think falls to Foundations. --

Re: [Touch-packages] [Bug 1964561] Re: package libpam-runtime 1.3.1-5ubuntu4.3 failed to install/upgrade: installed libpam-runtime package post-installation script subprocess returned error exit statu

2022-03-11 Thread Steve Langasek
On Fri, Mar 11, 2022 at 05:53:33PM -, Seth Arnold wrote: > These lines from the logs look most relevant: > > Unpacking libpam-runtime (1.3.1-5ubuntu4.3) over (1.3.1-5ubuntu4.1) ... > Setting up libpam-runtime (1.3.1-5ubuntu4.3) ... > Can't locate object method "new" via package >

[Touch-packages] [Bug 1962038] Re: wrong sysrq value in /usr/lib/sysctl.d/50-default.conf

2022-03-10 Thread Steve Langasek
oh correction, it does because of the added autopkgtest :) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to systemd in Ubuntu. https://bugs.launchpad.net/bugs/1962038 Title: wrong sysrq value in

[Touch-packages] [Bug 1962038] Re: wrong sysrq value in /usr/lib/sysctl.d/50-default.conf

2022-03-10 Thread Steve Langasek
dropping the update-excuse tag, since this bug has nothing to do with why the packages are or aren't migrating out of -proposed AFAIK -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to systemd in Ubuntu.

Re: [Touch-packages] [Bug 1962038] Re: wrong sysrq value in /usr/lib/sysctl.d/50-default.conf

2022-03-08 Thread Steve Langasek
On Tue, Mar 08, 2022 at 04:11:45PM -, Lukas Märdian wrote: > >> systemd should drop its setting to defer to the file that we have been > >> carrying in procps for a very long time. > > at some point it would be a better idea to drop the procps files and > > adjust the systemd defaults

[Touch-packages] [Bug 1956115] Re: ubuntu-advantage-tools ' MOTD is incompatible with Ubuntu Legal's MOTD opt-out directions.

2022-03-06 Thread Steve Langasek
You did respond to the questions so this should not have expired out. However, your answers beget more questions so I will be setting this back to incomplete. > /etc/default/motd-news as outlined in the link > "/etc/default/motd-news has an ENABLED=1 setting that if set to 0 will turn > off this

[Touch-packages] [Bug 1962332] Re: xenial systemd fails to start if cgroup2 is mounted

2022-02-28 Thread Steve Langasek
(not reassigning because I'm not sure of a public team that can be used for ESM bug assignments, but I've contacted the engineering team internally.) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to systemd in Ubuntu.

[Touch-packages] [Bug 1962332] Re: xenial systemd fails to start if cgroup2 is mounted

2022-02-28 Thread Steve Langasek
NB this has been assigned to Canonical Foundations, but as Ubuntu 16.04 is in Extended Security Maintenance now, this is actually a decision for our ESM Team to make regarding the path forward on whether xenial containers will be supported on jammy hosts, and if so, to update systemd for it. --

[Touch-packages] [Bug 1961517] Re: package base-files 11ubuntu5.5 failed to install/upgrade: end of file on stdin at conffile prompt

2022-02-24 Thread Steve Langasek
If your IS department is changing /etc/issue, and then you have not handled the conffile prompt on upgrade, that isn't something we can fix for you. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to base-files in Ubuntu.

[Touch-packages] [Bug 1961517] Re: package base-files 11ubuntu5.5 failed to install/upgrade: end of file on stdin at conffile prompt

2022-02-24 Thread Steve Langasek
> I've read & consent to terms in IS user agreem't. \n So where does your modified /etc/issue come from? ** Changed in: base-files (Ubuntu) Status: New => Incomplete -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to

[Touch-packages] [Bug 1962038] [NEW] wrong sysrq value in /usr/lib/sysctl.d/50-default.conf

2022-02-23 Thread Steve Langasek
Public bug reported: I've just learned that systemd is setting kernel.sysrq to 16 in /usr/lib/sysctl.d/50-default.conf. This is inconsistent with /etc/sysctl.d/10-magic-sysrq.conf which intentionally sets it to 176 by default. systemd should drop its setting to defer to the file that we have

[Touch-packages] [Bug 1962038] Re: wrong sysrq value in /usr/lib/sysctl.d/50-default.conf

2022-02-23 Thread Steve Langasek
we may want to audit /usr/lib/sysctl.d vs /etc/sysctl.d to verify if there are any other settings that are being shadowed. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to systemd in Ubuntu.

[Touch-packages] [Bug 1961610] Re: i386: seed inclusion for libfakechroot

2022-02-23 Thread Steve Langasek
fakechroot is now building on i386. https://launchpad.net/ubuntu/+source/fakechroot/2.20.1+ds-2/+build/23194235 ** Changed in: ubuntu-meta (Ubuntu) Status: New => Fix Released -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is

[Touch-packages] [Bug 1959085] Re: Ubuntu 21.10 boot stuck in initramfs

2022-02-10 Thread Steve Langasek
Dimitri, can you take a look at this? ** Also affects: zfs-linux (Ubuntu) Importance: Undecided Status: New ** Changed in: zfs-linux (Ubuntu) Assignee: (unassigned) => Dimitri John Ledkov (xnox) -- You received this bug notification because you are a member of Ubuntu Touch

[Touch-packages] [Bug 1959343] Re: deprecation of the Canonical partner archive

2022-01-31 Thread Steve Langasek
** Tags added: fr-2016 -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to python-apt in Ubuntu. https://bugs.launchpad.net/bugs/1959343 Title: deprecation of the Canonical partner archive Status in subiquity: Invalid

[Touch-packages] [Bug 1959343] Re: deprecation of the Canonical partner archive

2022-01-30 Thread Steve Langasek
** Changed in: ubuntu-unity-meta (Ubuntu) Status: Fix Committed => Fix Released -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to python-apt in Ubuntu. https://bugs.launchpad.net/bugs/1959343 Title: deprecation of the

[Touch-packages] [Bug 1959343] Re: deprecation of the Canonical partner archive

2022-01-30 Thread Steve Langasek
Thanks, @khurshid-alam. I have pushed a new bzr branch to lp:~unity7maintainers/ubuntu-seeds/ubuntu-unity.jammy/ that includes the change to drop app-install-data-partner, and am regenerating the ubuntu- unity-meta package via update. Note that in general since the metapackages are automatically

[Touch-packages] [Bug 1959343] Re: deprecation of the Canonical partner archive

2022-01-29 Thread Steve Langasek
I've removed app-install-data-partner, but unfortunately ubuntu-unity- desktop in the archive still recommends it and I cannot commit to the master branch for the seeds that this metapackage is built from. There was an invitation for ubuntu-core-dev to be added to ~unity7maintainers but it was

[Touch-packages] [Bug 1959343] Re: deprecation of the Canonical partner archive

2022-01-29 Thread Steve Langasek
Removing packages from jammy: app-install-data-partner 21.10 in jammy app-install-data-partner 21.10 in jammy amd64 app-install-data-partner 21.10 in jammy arm64 app-install-data-partner 21.10 in jammy armhf

[Touch-packages] [Bug 1959343] Re: deprecation of the Canonical partner archive

2022-01-28 Thread Steve Langasek
Yes, looks like this can be removed. ** Also affects: app-install-data-partner (Ubuntu) Importance: Undecided Status: New -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to python-apt in Ubuntu.

[Touch-packages] [Bug 1959343] Re: deprecation of the Canonical partner archive

2022-01-27 Thread Steve Langasek
** Changed in: ubuntu-release-upgrader (Ubuntu) Status: New => In Progress ** Changed in: ubuntu-release-upgrader (Ubuntu) Assignee: (unassigned) => Steve Langasek (vorlon) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages,

[Touch-packages] [Bug 1959343] Re: deprecation of the Canonical partner archive

2022-01-27 Thread Steve Langasek
No references to archive.canonical.com in the subiquity source. ** Changed in: cloud-init (Ubuntu) Status: New => In Progress ** Changed in: subiquity Status: New => Invalid -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is

[Touch-packages] [Bug 1959343] Re: deprecation of the Canonical partner archive

2022-01-27 Thread Steve Langasek
It was thought that curtin would need an update for this, but I can find no references to archive.canonical.com in the current curtin source. ** Changed in: curtin (Ubuntu) Status: New => Invalid -- You received this bug notification because you are a member of Ubuntu Touch seeded

[Touch-packages] [Bug 1959343] Re: deprecation of the Canonical partner archive

2022-01-27 Thread Steve Langasek
** Changed in: ubiquity (Ubuntu) Assignee: (unassigned) => Steve Langasek (vorlon) ** Changed in: ubiquity (Ubuntu) Status: New => In Progress -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to python-apt in

[Touch-packages] [Bug 1959343] Re: deprecation of the Canonical partner archive

2022-01-27 Thread Steve Langasek
** Changed in: python-apt (Ubuntu) Status: New => Fix Committed ** Changed in: python-apt (Ubuntu) Assignee: (unassigned) => Steve Langasek (vorlon) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to pyth

[Touch-packages] [Bug 1959343] Re: deprecation of the Canonical partner archive

2022-01-27 Thread Steve Langasek
** Also affects: ubuntu-release-upgrader (Ubuntu) Importance: Undecided Status: New -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to python-apt in Ubuntu. https://bugs.launchpad.net/bugs/1959343 Title: deprecation

[Touch-packages] [Bug 1959343] [NEW] deprecation of the Canonical partner archive

2022-01-27 Thread Steve Langasek
Status: New ** Affects: cloud-init (Ubuntu) Importance: Undecided Status: New ** Affects: curtin (Ubuntu) Importance: Undecided Status: New ** Affects: livecd-rootfs (Ubuntu) Importance: Undecided Assignee: Steve Langasek (vorlon) Status: Fix

[Touch-packages] [Bug 1958904] Re: autopkgtest is failing on jammy with "no space left on device"

2022-01-27 Thread Steve Langasek
Historically, we have sought to avoid publishing to -updates of SRUs that only fix autopkgtests because fixing the autopkgtests does not change the behavior of the package in a way that benefits the end user and justifies the download cost. However, between the fact that this is initramfs-tools,

[Touch-packages] [Bug 1956350] Re: xdg-desktop-portal-gnome missing in Jammy ISO

2022-01-04 Thread Steve Langasek
** Project changed: ubuntu-cdimage => ubuntu-meta (Ubuntu) ** Changed in: ubuntu-meta (Ubuntu) Assignee: (unassigned) => Ubuntu Desktop Bugs (desktop-bugs) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to ubuntu-meta in

[Touch-packages] [Bug 1947452] Re: Please remove maliit from Ubuntu

2021-12-16 Thread Steve Langasek
> The project doesn’t look dead to me… Nevertheless, it's clear it is no longer being maintained as a package in Ubuntu, with only distro maintenance uploads (rebuilds for ABI changes, etc) since at least 2017 and no one pulling new upstream versions into Ubuntu since 2015. If someone is

[Touch-packages] [Bug 1947452] Re: Please remove maliit from Ubuntu

2021-12-16 Thread Steve Langasek
Removing packages from jammy: maliit-inputcontext-gtk 0.99.1-0ubuntu2 in jammy maliit-inputcontext-gtk2 0.99.1-0ubuntu2 in jammy amd64 maliit-inputcontext-gtk2 0.99.1-0ubuntu2 in jammy arm64 maliit-inputcontext-gtk2 0.99.1-0ubuntu2 in jammy

[Touch-packages] [Bug 1955084] [NEW] systemd unit leaves a process running for the system lifetime but it only does anything at shutdown

2021-12-16 Thread Steve Langasek
Public bug reported: The /lib/systemd/system/unattended-upgrades.service unit leaves a process, /usr/share/unattended-upgrades/unattended-upgrade-shutdown --wait-for-signal, running from system start until shutdown. This increases the minimum memory footprint of every host, VM, or container

[Touch-packages] [Bug 1954649] Re: autopkgtest regressions with python3.10 as supported

2021-12-13 Thread Steve Langasek
skimage on s390x is also regressed. ** Also affects: skimage (Ubuntu) Importance: Undecided Status: New -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to python3-defaults in Ubuntu.

[Touch-packages] [Bug 1892825] Re: update-locale not perform correctly sanity checks

2021-12-12 Thread Steve Langasek
Hello bs, or anyone else affected, Accepted glibc into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/glibc/2.31-0ubuntu9.4 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1927192] Re: gdb ftbfs on armhf, testsuite timeouts

2021-12-12 Thread Steve Langasek
Hello Matthias, or anyone else affected, Accepted glibc into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/glibc/2.31-0ubuntu9.4 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1927192] Re: gdb ftbfs on armhf, testsuite timeouts

2021-12-12 Thread Steve Langasek
Sorry, I see this is explained in another changelog entry / bug. ** Changed in: glibc (Ubuntu Focal) Status: Incomplete => In Progress -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to gdb in Ubuntu.

[Touch-packages] [Bug 1927192] Re: gdb ftbfs on armhf, testsuite timeouts

2021-12-12 Thread Steve Langasek
Why was dh_strip previously being called with an override of DH_COMPAT=8, and why is this safe to drop in SRU as part of this change? ** Changed in: glibc (Ubuntu Focal) Status: Opinion => Incomplete -- You received this bug notification because you are a member of Ubuntu Touch seeded

[Touch-packages] [Bug 1952918] Re: Please temporarely pull fluidsynth 2.2.4-2 from jammy-proposed

2021-12-06 Thread Steve Langasek
since all packages are now rebuild against liburing2 that need to be, without the fluidsynth dependency, I've re-copied fluidsynth to jammy- proposed now. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to fluidsynth in Ubuntu.

[Touch-packages] [Bug 1953258] [NEW] opencv regressed on armhf

2021-12-05 Thread Steve Langasek
Public bug reported: autopkgtests of reverse-dependencies of opencv are failing on armhf with opencv 4.5.4+dfsg-1ubuntu1. A git bisect points to https://github.com/opencv/opencv/commit/eab2b9dc09570b141adeba3814f196a4efd8adb2 as the commit that has introduced the regression. ** Affects: opencv

[Touch-packages] [Bug 1953201] Re: pam_env doesn't accept /etc/environment files that don't end with newline anymore (PAM 1.4.x behaviour change/regression)

2021-12-03 Thread Steve Langasek
FWIW I'm going to mark this bug 'low' instead of high, on the basis that Debian has shipped pam 1.4.0 in a stable release and there hasn't even been a single bug report about this issue, it was only caught because of a bug in the Ubuntu autopkgtest-cloud implementation that was writing entries to

[Touch-packages] [Bug 1952895] Re: Some mistakes in /etc/profile

2021-12-01 Thread Steve Langasek
These appear to be reasonable suggestions for style improvements, but these nits have been here for literally decades without causing practical problems. They are not worth Ubuntu carrying a delta against Debian for. Please see about getting your changes upstreamed to Debian first.

[Touch-packages] [Bug 1951653] [NEW] can't use NM for ethernet device on 20.04 LTS because it is 'strictly unmanaged'

2021-11-19 Thread Steve Langasek
Public bug reported: I have tried to tell netplan to let my ethernet device be managed by NetworkManager, so that I can then configure a pppoe connection on top of this device. This fails with: # nmcli c up netplan-wan Error: Connection activation failed: No suitable device found for this

[Touch-packages] [Bug 1949205] Re: Prints message that 'Volume group "vgubuntu" not found' when partition encrypted in LUKS

2021-11-18 Thread Steve Langasek
** Summary changed: - Volume group "vgubuntu" not found when parition encrypted in LUKS + Prints message that 'Volume group "vgubuntu" not found' when partition encrypted in LUKS ** Changed in: initramfs-tools (Ubuntu) Importance: Undecided => Low ** Tags removed: rls-ff-incoming ** Tags

[Touch-packages] [Bug 1950872] Re: package libpam0g:amd64 1.3.1-5ubuntu4.3 failed to install/upgrade: installed libpam0g:amd64 package post-installation script subprocess was killed by signal (Trace/b

2021-11-13 Thread Steve Langasek
> libpam0g:amd64 (--configure): > installed libpam0g:amd64 package post-installation script subprocess was > killed by signal (Trace/breakpoint trap), core dumped This is not something that happens during normal operation. Do you have some idea why this signal was generated? Did you also get

[Touch-packages] [Bug 1921518] Re: OpenSSL "double free" error

2021-11-12 Thread Steve Langasek
How will you test that the change does not regress any wget behavior? ** Changed in: wget (Ubuntu Focal) Status: In Progress => Incomplete -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to wget in Ubuntu.

[Touch-packages] [Bug 1939973] Re: make 4.3-4.1 triggers build failures

2021-11-07 Thread Steve Langasek
Removing block-proposed tag because this is now blocking the unrelated 4.3-4ubuntu2 upload. ** Tags removed: block-proposed -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to make-dfsg in Ubuntu.

[Touch-packages] [Bug 1896251] Please test proposed package

2021-11-05 Thread Steve Langasek
Hello Mikko, or anyone else affected, Accepted rsync into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/rsync/3.1.2-2.1ubuntu1.2 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1896251] Re: rsync --delete-missing-args fails with "error: protocol incompatibility"

2021-11-05 Thread Steve Langasek
Hello Mikko, or anyone else affected, Accepted rsync into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/rsync/3.1.3-8ubuntu0.1 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1917920] Re: magic-proxy broke with iptables 1.8.7-1ubuntu2

2021-11-05 Thread Steve Langasek
Hello Dimitri, or anyone else affected, Accepted livecd-rootfs into hirsute-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd- rootfs/2.719.3 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1949970] Please test proposed package

2021-11-05 Thread Steve Langasek
Hello Dan, or anyone else affected, Accepted lightdm into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lightdm/1.30.0-0ubuntu4~20.04.2 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1949970] Please test proposed package

2021-11-05 Thread Steve Langasek
Hello Dan, or anyone else affected, Accepted lightdm into hirsute-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lightdm/1.30.0-0ubuntu4.21.04.1 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1949970] Re: attempt to dlopen nonexistent pam_kwallet.so spams log

2021-11-05 Thread Steve Langasek
Hello Dan, or anyone else affected, Accepted lightdm into impish-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lightdm/1.30.0-0ubuntu4.21.10.1 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1948698] Update Released

2021-10-28 Thread Steve Langasek
The verification of the Stable Release Update for tzdata has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a

[Touch-packages] [Bug 772121] Re: typo in pam_tally manpage

2021-10-26 Thread Steve Langasek
1.4.0-10ubuntu1 has been uploaded to jammy, which fixes this bug, but a wrong upload option prevents this bug from being autoclosed. Related changelog entry: pam (1.4.0-1) unstable; urgency=medium * New upstream release. Closes: #948188. - Stop using obsoleted selinux headers. Closes:

[Touch-packages] [Bug 1946096] Re: Support manual firmware upgrading for Foxconn and Quectel modems.

2021-10-22 Thread Steve Langasek
Is there a risk that applying these changes will regress the behavior of these modems on systems which have NOT applied the firmware updates? Can the testcase include a check for this? ** Changed in: modemmanager (Ubuntu) Status: Fix Committed => Incomplete -- You received this bug

[Touch-packages] [Bug 1947475] Re: PAM: pam_chroot.so not accessible after upgrade 21.04 > 21.10

2021-10-18 Thread Steve Langasek
This is a regression in the libpam-chroot package, which is installing the module to the wrong path, not where libpam looks for it. libpam-chroot is a separate source package in universe; reassigning. ** Package changed: pam (Ubuntu) => libpam-chroot (Ubuntu) ** Changed in: libpam-chroot

[Touch-packages] [Bug 1947429] [NEW] linux-object-* not autoremoved on upgrade

2021-10-15 Thread Steve Langasek
Public bug reported: After upgrading my kernel, directories are left behind in /lib/modules for previous kernel because with the kernel packaging layout, not all binary packages are autoremoved: $ dpkg -S /lib/modules/5.11.0-34-generic linux-objects-nvidia-460-5.11.0-34-generic:

[Touch-packages] [Bug 1916250] Re: gir1.2-signon-2.0 needs to declare replace on older releases (Groovy2Hirsute)

2021-10-15 Thread Steve Langasek
Please provide an SRU template for this bug per https://wiki.ubuntu.com/StableReleaseUpdates#Procedure ** Changed in: libsignon-glib (Ubuntu) Status: In Progress => Incomplete -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is

[Touch-packages] [Bug 1944741] Re: HiFive Unmatched partitions are named "Unleashed"

2021-10-15 Thread Steve Langasek
Hello Alexandre, or anyone else affected, Accepted util-linux into impish-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/util- linux/2.36.1-8ubuntu2 in a few hours, and then in the -proposed repository. Please help us by testing this new package.

[Touch-packages] [Bug 982436] Re: can not import pycurl: librtmp.so.0: cannot open shared object file: No such file or directory

2021-10-14 Thread Steve Langasek
The Precise Pangolin has reached end of life, so this bug will not be fixed for that release ** Changed in: pycurl (Ubuntu Precise) Status: Confirmed => Won't Fix -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to pycurl

[Touch-packages] [Bug 1348150] Re: Memory corruption (using memory after freeing) in GNU Make

2021-10-14 Thread Steve Langasek
The Precise Pangolin has reached end of life, so this bug will not be fixed for that release ** Changed in: make-dfsg (Ubuntu Precise) Status: Confirmed => Won't Fix -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to

[Touch-packages] [Bug 828356] Re: Support X-GNOME-Keywords

2021-10-14 Thread Steve Langasek
The Precise Pangolin has reached end of life, so this bug will not be fixed for that release ** Changed in: unity (Ubuntu Precise) Status: New => Won't Fix -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to libunity in

[Touch-packages] [Bug 385882] Re: if fsck exits with error code 4 no way for non-experts to recover

2021-10-14 Thread Steve Langasek
The Precise Pangolin has reached end of life, so this bug will not be fixed for that release ** Changed in: mountall (Ubuntu Precise) Status: Confirmed => Won't Fix -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to

[Touch-packages] [Bug 1209292] Re: Support for HTTPS is broken

2021-10-14 Thread Steve Langasek
The Precise Pangolin has reached end of life, so this bug will not be fixed for that release ** Changed in: apt (Ubuntu Precise) Status: Confirmed => Won't Fix -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to apt in

[Touch-packages] [Bug 1639372] Re: CVE-2016-9082: DOS attack in converting SVG to PNG

2021-10-14 Thread Steve Langasek
The Precise Pangolin has reached end of life, so this bug will not be fixed for that release ** Changed in: cairo (Ubuntu Precise) Status: Confirmed => Won't Fix -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to cairo

[Touch-packages] [Bug 1089013] Re: clvm startup script requires cman

2021-10-14 Thread Steve Langasek
The Precise Pangolin has reached end of life, so this bug will not be fixed for that release ** Changed in: lvm2 (Ubuntu Precise) Status: Triaged => Won't Fix -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to lvm2 in

[Touch-packages] [Bug 1481561] Re: Connect to XDMCP clients on address requests come from if available

2021-10-14 Thread Steve Langasek
The Precise Pangolin has reached end of life, so this bug will not be fixed for that release ** Changed in: lightdm (Ubuntu Precise) Status: New => Won't Fix -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to lightdm in

[Touch-packages] [Bug 1517685] Re: XDMCP server starts without authentication if configured key does not exist

2021-10-14 Thread Steve Langasek
The Precise Pangolin has reached end of life, so this bug will not be fixed for that release ** Changed in: lightdm (Ubuntu Precise) Status: Confirmed => Won't Fix -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to

  1   2   3   4   5   6   7   8   9   10   >