[Touch-packages] [Bug 1980386] Re: `radeonsi_dri.so` driver missing on riscv64

2022-08-16 Thread Timo Aaltonen
oh right, 22.0.5 hasn't been backported yet anyway, if llvm is enabled, it'll essentially break swrast for riscv64.. if that's a tradeoff you can live with, then okay -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in

[Touch-packages] [Bug 1980386] Re: `radeonsi_dri.so` driver missing on riscv64

2022-08-15 Thread Timo Aaltonen
Which version of mesa on focal is that? The current backport version is from jammy and doesn't enable gallium for riscv64. Radeonsi requires llvm. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu.

[Touch-packages] [Bug 1980386] Re: `radeonsi_dri.so` driver missing on riscv64

2022-08-14 Thread Timo Aaltonen
not going to get fixed before llvm supports JIT on riscv64 ** Also affects: llvm-toolchain-14 (Ubuntu) Importance: Undecided Status: New -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu.

[Touch-packages] [Bug 1980804] Re: New bugfix release 22.0.5

2022-07-28 Thread Timo Aaltonen
tested on Intel Kaby Lake (gen9) and AMD Radeon 520 Mobile, no issues found -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu. https://bugs.launchpad.net/bugs/1980804 Title: New bugfix release 22.0.5 Status

[Touch-packages] [Bug 1980804] Re: New bugfix release 22.0.5

2022-07-28 Thread Timo Aaltonen
** Tags removed: verification-needed verification-needed-jammy ** Tags added: verification-done verification-done-jammy -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu. https://bugs.launchpad.net/bugs/1980804

[Touch-packages] [Bug 1972977] Re: gnome-shell crashed with SIGSEGV in crocus_begin_query() from crocus_begin_query() from crocus_end_query() from crocus_end_query() from tc_call_end_query()

2022-07-28 Thread Timo Aaltonen
I find it confusing to move a bug 'fix committed' when it's only in upstream master. Kinetic will get 22.2.x, and it'll have this (hasn't branched yet). -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu.

[Touch-packages] [Bug 1958267] Re: wpa can't connect to servers using TLS 1.1 or older

2022-06-10 Thread Timo Aaltonen
Hello Alexander, or anyone else affected, Accepted wpa into jammy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/wpa/2:2.10-6ubuntu2 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1971712] Re: Add support for Intel DG2

2022-06-01 Thread Timo Aaltonen
works fine on Dell hybrid with ADL iGPU and DG2 dGPU -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu. https://bugs.launchpad.net/bugs/1971712 Title: Add support for Intel DG2 Status in linux-oem-5.17

[Touch-packages] [Bug 1971712] Re: Add support for Intel DG2

2022-06-01 Thread Timo Aaltonen
** Tags removed: verification-needed verification-needed-jammy ** Tags added: verification-done verification-done-jammy -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu. https://bugs.launchpad.net/bugs/1971712

[Touch-packages] [Bug 1975566] Re: radeon / amdgpu bad performance or panics

2022-05-25 Thread Timo Aaltonen
aiui the radv vulkan driver requires amdgpu kernel driver, so I don't know how you could have it working before the upgrade. the default driver for SI cards is radeon, that won't change so essentially we don't support vulkan on those -- You received this bug notification because you are a

[Touch-packages] [Bug 1974428] Re: Update to the current 1.36 stable version

2022-05-20 Thread Timo Aaltonen
Hello Sebastien, or anyone else affected, Accepted network-manager into jammy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network- manager/1.36.6-0ubuntu1 in a few hours, and then in the -proposed repository. Please help us by testing this new

[Touch-packages] [Bug 1973477] Re: unable to upgrade to xubuntu

2022-05-16 Thread Timo Aaltonen
the missing firmware warning is not the reason, it's erroring because of klibc-utils ** Package changed: linux-firmware (Ubuntu) => klibc (Ubuntu) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to klibc in Ubuntu.

[Touch-packages] [Bug 1971712] Re: Add support for Intel DG2

2022-05-13 Thread Timo Aaltonen
** Changed in: linux-oem-5.17 (Ubuntu Jammy) Status: New => Fix Committed -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu. https://bugs.launchpad.net/bugs/1971712 Title: Add support for Intel DG2

[Touch-packages] [Bug 1972721] Re: Include gtk3 changes needed for mutter 42.1

2022-05-13 Thread Timo Aaltonen
Hello Jeremy, or anyone else affected, Accepted gtk+3.0 into jammy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gtk+3.0/3.24.33-1ubuntu2 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1973270] Re: json-c please mark package as multiarch

2022-05-13 Thread Timo Aaltonen
Hello Gianfranco, or anyone else affected, Accepted json-c into jammy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/json-c/0.15-3~ubuntu1.22.04.1 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1971712] Re: Add support for Intel DG2

2022-05-11 Thread Timo Aaltonen
** Description changed: [Impact] Ubuntu 22.04 does not support Intel DG2-based hw which is released later this year. - [Fix] Mesa: needs a bunch of patches backported to 22.0.x, will be upstream in 22.1 or 22.2 kernel: use a dkms provided by Intel and integrated in the OEM

[Touch-packages] [Bug 1959345] Re: vulkaninfo reports error

2022-05-10 Thread Timo Aaltonen
see, remnants of amdgpu-pro ;) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu. https://bugs.launchpad.net/bugs/1959345 Title: vulkaninfo reports error Status in mesa package in Ubuntu: Invalid Bug

[Touch-packages] [Bug 1615381] Please test proposed package

2022-05-06 Thread Timo Aaltonen
Hello Jarno, or anyone else affected, Accepted apt into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/apt/1.6.15 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1968154] Please test proposed package

2022-05-06 Thread Timo Aaltonen
Hello Julian, or anyone else affected, Accepted apt into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/apt/2.0.8 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1615381] Re: apt-get autoremove may remove current kernel

2022-05-06 Thread Timo Aaltonen
Hello Jarno, or anyone else affected, Accepted apt into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/apt/2.0.8 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1968154] Please test proposed package

2022-05-06 Thread Timo Aaltonen
Hello Julian, or anyone else affected, Accepted apt into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/apt/1.6.15 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1968154] Re: Only keep 2 kernels

2022-05-06 Thread Timo Aaltonen
Hello Julian, or anyone else affected, Accepted apt into impish-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/apt/2.3.9ubuntu0.1 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1968997] Re: openssl has catastrophic issues when locale set to TR_UTF8

2022-05-06 Thread Timo Aaltonen
Hello Ilgaz, or anyone else affected, Accepted openssl into jammy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/openssl/3.0.2-0ubuntu1.2 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1962541] Re: PEAP wifi can't connect (ubuntu live/installer is also not working

2022-05-06 Thread Timo Aaltonen
Hello leonpano, or anyone else affected, Accepted wpa into jammy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/wpa/2:2.10-6ubuntu1 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1971712] [NEW] Add support for Intel DG2

2022-05-05 Thread Timo Aaltonen
Public bug reported: [Impact] Ubuntu 22.04 does not support Intel DG2-based hw which is released later this year. [Fix] Mesa: needs a bunch of patches backported to 22.0.x, will be upstream in 22.1 or 22.2 kernel: use a dkms provided by Intel and integrated in the OEM kernel source, the

[Touch-packages] [Bug 1959345] Re: vulkaninfo reports error

2022-05-04 Thread Timo Aaltonen
I've been trying to tell that it's some remnant of amdgpu-pro, and not something ever shipped by Ubuntu, and that's why the bug is marked as 'invalid'. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu.

[Touch-packages] [Bug 1959345] Re: vulkaninfo reports error

2022-05-04 Thread Timo Aaltonen
the package is mesa-vulkan-drivers, and it ships the correct file for radeon: /usr/share/vulkan/icd.d/radeon_icd.x86_64.json -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu.

[Touch-packages] [Bug 1959345] Re: vulkaninfo reports error

2022-05-02 Thread Timo Aaltonen
well I think some parts still remain on your system.. in any case, it should all work just fine at least on more current releases -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu.

[Touch-packages] [Bug 1959345] Re: vulkaninfo reports error

2022-04-29 Thread Timo Aaltonen
it's looking for amd_icd64.json, and if you google that most hits seem to suggest amdgpu-pro/amdvlk so do you have amdvlk installed? -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu.

[Touch-packages] [Bug 1959345] Re: vulkaninfo reports error

2022-04-28 Thread Timo Aaltonen
we as in 'ubuntu' -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu. https://bugs.launchpad.net/bugs/1959345 Title: vulkaninfo reports error Status in mesa package in Ubuntu: Invalid Bug description:

[Touch-packages] [Bug 1959345] Re: vulkaninfo reports error

2022-04-28 Thread Timo Aaltonen
you have the amdgpu-pro driver installed, if it's vulkan driver does not install it's icd file in the correct place, there's nothing we can do about that ** Changed in: mesa (Ubuntu) Status: Confirmed => Invalid -- You received this bug notification because you are a member of Ubuntu

[Touch-packages] [Bug 1926860] Re: XP Pen Star 03 graphic tablet not running on Ubuntu later than 18.04

2022-04-06 Thread Timo Aaltonen
udev is built by src:systemd -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to systemd in Ubuntu. https://bugs.launchpad.net/bugs/1926860 Title: XP Pen Star 03 graphic tablet not running on Ubuntu later than 18.04 Status in

[Touch-packages] [Bug 1926860] Re: XP Pen Star 03 graphic tablet not running on Ubuntu later than 18.04

2022-04-06 Thread Timo Aaltonen
Well, I can reassign to see if the maintainer of systemd/udev could backport the patch for this. ** Package changed: xf86-input-wacom (Ubuntu) => systemd (Ubuntu) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to systemd in

[Touch-packages] [Bug 1895486] Re: [media-keys] Fn media keys with lag slow/delay on Gnome with "Scroll Lock" keyboards

2022-04-05 Thread Timo Aaltonen
** Changed in: xkeyboard-config (Ubuntu) Status: Fix Committed => Fix Released -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to xkeyboard-config in Ubuntu. https://bugs.launchpad.net/bugs/1895486 Title: [media-keys]

[Touch-packages] [Bug 1782984] Re: Assertion `!xcb_xlib_threads_sequence_lost' failed with multiple applications

2022-03-31 Thread Timo Aaltonen
That'll install all updates from proposed? Don't do that. Just use a clean image and then install the required updates as mentioned in #106 -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to libx11 in Ubuntu.

[Touch-packages] [Bug 1966221] Re: gnome-extensions-app crashes with "Segmentation fault (core dumped)"

2022-03-30 Thread Timo Aaltonen
the gnome-chess crash does -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu. https://bugs.launchpad.net/bugs/1966221 Title: gnome-extensions-app crashes with "Segmentation fault (core dumped)" Status in

[Touch-packages] [Bug 1782984] Re: Assertion `!xcb_xlib_threads_sequence_lost' failed with multiple applications

2022-03-29 Thread Timo Aaltonen
or do as advised in comment #106 -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to libx11 in Ubuntu. https://bugs.launchpad.net/bugs/1782984 Title: Assertion `!xcb_xlib_threads_sequence_lost' failed with multiple

[Touch-packages] [Bug 1782984] Re: Assertion `!xcb_xlib_threads_sequence_lost' failed with multiple applications

2022-03-29 Thread Timo Aaltonen
echo 'deb http://archive.ubuntu.com/ubuntu/ focal-proposed main restricted' >> /etc/apt/sources.list apt update apt install libx11-6 verify with 'apt-cache policy libx11-6' that you have the correct version (from proposed), and run your tests. -- You received this bug notification because you

[Touch-packages] [Bug 1966221] Re: gnome-extensions-app crashes with "Segmentation fault (core dumped)"

2022-03-29 Thread Timo Aaltonen
gnome-chess fails to start as well, but it's crashing also on newer gen chips (tested on Alder Lake) with the iris driver. What's common is that it is also fine on wayland. upstream had a look at the backtrace, but said that there's nothing that would explain why it fails on xorg -- You

[Touch-packages] [Bug 1965563] Re: gnome-extensions-app fails to start (Protocol error)

2022-03-28 Thread Timo Aaltonen
** Package changed: gnome-shell (Ubuntu) => mesa (Ubuntu) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu. https://bugs.launchpad.net/bugs/1965563 Title: gnome-extensions-app fails to start (Protocol error)

[Touch-packages] [Bug 1902464] Re: The rear panel of Lenovo P620 doesn't support more than one audio device at the same time

2022-03-25 Thread Timo Aaltonen
Hello jeremyszu, or anyone else affected, Accepted alsa-ucm-conf into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/alsa-ucm- conf/1.2.2-1ubuntu0.13 in a few hours, and then in the -proposed repository. Please help us by testing this new

[Touch-packages] [Bug 1782984] Re: Assertion `!xcb_xlib_threads_sequence_lost' failed with multiple applications

2022-03-24 Thread Timo Aaltonen
did you enable focal-proposed? -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to libx11 in Ubuntu. https://bugs.launchpad.net/bugs/1782984 Title: Assertion `!xcb_xlib_threads_sequence_lost' failed with multiple

[Touch-packages] [Bug 1960669] Re: the display doesn't appear after suspend, i915

2022-02-12 Thread Timo Aaltonen
install 'linux-generic-hwe-20.04' and then you'll get a newer kernel does it fix this? ** Package changed: libdrm (Ubuntu) => linux (Ubuntu) ** Changed in: linux (Ubuntu) Status: New => Incomplete -- You received this bug notification because you are a member of Ubuntu Touch seeded

[Touch-packages] [Bug 1960544] Re: External Monitors Not Detected Anymore

2022-02-10 Thread Timo Aaltonen
you need to update again and run 'apport-collect 1960544' also, test 21.10 live image to see if it works there -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu. https://bugs.launchpad.net/bugs/1960544 Title:

[Touch-packages] [Bug 1960544] Re: External Monitors Not Detected Anymore

2022-02-10 Thread Timo Aaltonen
that's unlikely, mesa has little to do with driving displays, the kernel does -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu. https://bugs.launchpad.net/bugs/1960544 Title: External Monitors Not Detected

[Touch-packages] [Bug 1956915] Re: New bugfix release 21.2.6

2022-02-09 Thread Timo Aaltonen
this bug is "fix committed" for both focal and impish, meaning the update is in the respective -proposed pocket. see comment #5 -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu.

[Touch-packages] [Bug 1960372] Re: DPMS ignores attempts to DISABLE IT

2022-02-09 Thread Timo Aaltonen
** Package changed: libxcb (Ubuntu) => ubuntu -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to libxcb in Ubuntu. https://bugs.launchpad.net/bugs/1960372 Title: DPMS ignores attempts to DISABLE IT Status in Ubuntu: New

[Touch-packages] [Bug 1956915] Re: New bugfix release 21.2.6

2022-02-09 Thread Timo Aaltonen
the jammy queue has had 21.3.x for weeks now -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu. https://bugs.launchpad.net/bugs/1956915 Title: New bugfix release 21.2.6 Status in mesa package in Ubuntu: Fix

[Touch-packages] [Bug 1949553] Re: Backport packages for 20.04.4 HWE stack

2022-02-08 Thread Timo Aaltonen
tested on intel TGL-U, WHL, and AMD Radeon 520 Mobile, everything looks good ** Description changed: [Impact] These are needed for 20.04.4 images. [Test case] Boot a daily image, see that it still has the necessary stack installed and working. [What could go wrong]

[Touch-packages] [Bug 1956915] Re: New bugfix release 21.2.6

2022-02-08 Thread Timo Aaltonen
** Tags removed: verification-needed verification-needed-focal verification-needed-impish ** Tags added: verification-done verification-done-focal verification-done-impish -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to

[Touch-packages] [Bug 1958242] Re: mesa update freeze/crash screen before login

2022-02-08 Thread Timo Aaltonen
please try the latest stable release from https://launchpad.net/~kisak/+archive/ubuntu/kisak-mesa then at least we'd know if it's fixed in 21.3.x ** Changed in: mesa (Ubuntu) Status: New => Incomplete -- You received this bug notification because you are a member of Ubuntu Touch seeded

[Touch-packages] [Bug 1958904] Please test proposed package

2022-01-28 Thread Timo Aaltonen
Hello Andrea, or anyone else affected, Accepted initramfs-tools into impish-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/initramfs- tools/0.140ubuntu6.1 in a few hours, and then in the -proposed repository. Please help us by testing this new

[Touch-packages] [Bug 1958904] Re: autopkgtest is failing on jammy with "no space left on device"

2022-01-28 Thread Timo Aaltonen
Hello Andrea, or anyone else affected, Accepted initramfs-tools into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/initramfs- tools/0.136ubuntu6.7 in a few hours, and then in the -proposed repository. Please help us by testing this new

[Touch-packages] [Bug 1952970] Re: mesa GLX change leads to wine showing GLXBadFBConfig

2022-01-27 Thread Timo Aaltonen
looks like it's still unresolved upstream ** Changed in: mesa (Ubuntu) Importance: Undecided => Medium ** Changed in: mesa (Ubuntu) Status: New => Confirmed -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in

[Touch-packages] [Bug 1574354] Re: playing .mp4 in VLC freezes machine

2022-01-27 Thread Timo Aaltonen
vlc works just fine on several machines here, closing if you have further issues, open a new bug ** Changed in: mesa (Ubuntu) Status: Confirmed => Invalid -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in

[Touch-packages] [Bug 1958554] Re: package libdrm-intel1:amd64 2.4.91-2 failed to install/upgrade: Paket ist in einem sehr schlechten inkonsistenten Zustand - Sie sollten es nochmal installieren, bevo

2022-01-21 Thread Timo Aaltonen
some transient issue on your system, not a bug in the package ** Changed in: libdrm (Ubuntu) Status: New => Invalid -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to libdrm in Ubuntu.

[Touch-packages] [Bug 1939455] Re: Upgrading from 20.0.4-2ubuntu1 to 21.0.3-0ubuntu0.2~20.04.1 breaks vlc video output

2022-01-17 Thread Timo Aaltonen
thanks for testing focal-proposed (and impish) has 21.2.6, so once it lands in updates, it's also fixed for focal ** Changed in: mesa (Ubuntu) Status: New => Fix Released -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed

[Touch-packages] [Bug 1956915] Re: New bugfix release 21.2.6

2022-01-12 Thread Timo Aaltonen
** Changed in: mesa (Ubuntu) Status: Confirmed => Fix Released -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu. https://bugs.launchpad.net/bugs/1956915 Title: New bugfix release 21.2.6 Status in mesa

[Touch-packages] [Bug 1955566] Re: iris driver doesn't load correctly on intel pci_id 0x4688

2022-01-10 Thread Timo Aaltonen
*** This bug is a duplicate of bug 1949553 *** https://bugs.launchpad.net/bugs/1949553 focal will get this via impish backport ** This bug has been marked a duplicate of bug 1956915 New bugfix release 21.2.6 ** This bug is no longer a duplicate of bug 1956915 New bugfix release 21.2.6

[Touch-packages] [Bug 1946621] Re: Crash in libegl-mesa0 (eglReleaseThread)

2022-01-10 Thread Timo Aaltonen
*** This bug is a duplicate of bug 1956915 *** https://bugs.launchpad.net/bugs/1956915 ** This bug has been marked a duplicate of bug 1956915 New bugfix release 21.2.6 -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to

[Touch-packages] [Bug 1939455] Re: Upgrading from 20.0.4-2ubuntu1 to 21.0.3-0ubuntu0.2~20.04.1 breaks vlc video output

2022-01-10 Thread Timo Aaltonen
So what about impish? Focal will soon get 21.2.x from impish. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu. https://bugs.launchpad.net/bugs/1939455 Title: Upgrading from 20.0.4-2ubuntu1 to

[Touch-packages] [Bug 1940545] Re: Update Mesa to mesa-21.1.7 on Ubuntu 20.04

2022-01-10 Thread Timo Aaltonen
*** This bug is a duplicate of bug 1956915 *** https://bugs.launchpad.net/bugs/1956915 ** This bug has been marked a duplicate of bug 1956915 New bugfix release 21.2.6 -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to

[Touch-packages] [Bug 1950044] Re: REGRESSION with version 21.0.3, please backport 21.2.x to Focal

2022-01-10 Thread Timo Aaltonen
*** This bug is a duplicate of bug 1956915 *** https://bugs.launchpad.net/bugs/1956915 ** This bug has been marked a duplicate of bug 1956915 New bugfix release 21.2.6 -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to

[Touch-packages] [Bug 1956915] Re: New bugfix release 21.2.6

2022-01-10 Thread Timo Aaltonen
** Changed in: mesa (Ubuntu Focal) Assignee: (unassigned) => Timo Aaltonen (tjaalton) ** Changed in: mesa (Ubuntu Impish) Assignee: (unassigned) => Timo Aaltonen (tjaalton) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages,

[Touch-packages] [Bug 1956915] [NEW] New bugfix release 21.2.6

2022-01-10 Thread Timo Aaltonen
Public bug reported: [Impact] This is the last point-release of the 21.2.x-series, we should put it in impish so latest bugfixes would get there, and in focal for 20.04.4 image. [Test case] Install the updates, test desktop use and some basic games etc on at least AMD and Intel hw. [Where

[Touch-packages] [Bug 1952083] Re: Add support for Beige Goby

2021-12-02 Thread Timo Aaltonen
sounds like your mirror is not uptodate -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu. https://bugs.launchpad.net/bugs/1952083 Title: Add support for Beige Goby Status in amd: New Status in OEM Priority

[Touch-packages] [Bug 1952083] Update Released

2021-12-01 Thread Timo Aaltonen
The verification of the Stable Release Update for mesa has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a

[Touch-packages] [Bug 1949553] Re: Backport packages for 20.04.4 HWE stack

2021-11-24 Thread Timo Aaltonen
see Debian bugs https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=994873 https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=994955 we can't keep valgrind enabled, or libdrm.pc would be broken ** Bug watch added: Debian Bug tracker #994873

[Touch-packages] [Bug 1952083] [NEW] Add support for Beige Goby

2021-11-24 Thread Timo Aaltonen
Public bug reported: Impact] New hardware support for AMD's Beige Goby needs a commit backported to mesa. This is only needed on focal, skipping hirsute (no kernel support there). Fixed in impish and up. [Test plan] Install updates, boot a BG machine and check that the desktop has full

[Touch-packages] [Bug 1871959] Re: Xorg crashed with SIGABRT in _iris_batch_flush from iris_fence_flush()

2021-11-23 Thread Timo Aaltonen
Bug 1918855 is fixed in focal and up, so if you still have crashes then that was not your bug/fix. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu. https://bugs.launchpad.net/bugs/1871959 Title: Xorg crashed

[Touch-packages] [Bug 1950174] Update Released

2021-11-18 Thread Timo Aaltonen
The verification of the Stable Release Update for mesa has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a

[Touch-packages] [Bug 1940656] Update Released

2021-11-15 Thread Timo Aaltonen
The verification of the Stable Release Update for openssl has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a

[Touch-packages] [Bug 1946621] Re: Crash in libegl-mesa0 (eglReleaseThread)

2021-11-10 Thread Timo Aaltonen
fixed in 21.2.5-1 which is in jammy-proposed ** Also affects: mesa (Ubuntu Focal) Importance: Undecided Status: New ** Also affects: mesa (Ubuntu Impish) Importance: Undecided Status: New ** Changed in: mesa (Ubuntu) Status: Confirmed => Fix Released -- You received

[Touch-packages] [Bug 1950174] Re: [SRU] focal: gallium: Reset {d, r}Priv in dri_unbind_context

2021-11-10 Thread Timo Aaltonen
** Description changed: [Description] This is a request to backport this fix from mesa 21.1 to focal-updates which is affecting users of WSL: https://gitlab.freedesktop.org/mesa/mesa/-/commit/7ff30a0499bd872d77b0f377414bbc03463b9f87 This cached stale pointer is causing various

[Touch-packages] [Bug 1949116] Re: libgl1-mesa-dri depends on libllvm12 from universe

2021-11-03 Thread Timo Aaltonen
** Also affects: mesa (Ubuntu Hirsute) Importance: Undecided Status: New ** Changed in: mesa (Ubuntu Hirsute) Importance: Undecided => Critical ** Changed in: mesa (Ubuntu) Status: New => Invalid -- You received this bug notification because you are a member of Ubuntu Touch

[Touch-packages] [Bug 1949553] Re: Backport packages for 20.04.4 HWE stack

2021-11-03 Thread Timo Aaltonen
ess ** Changed in: xorg-server (Ubuntu Focal) Status: New => In Progress ** Changed in: mesa (Ubuntu Focal) Assignee: (unassigned) => Timo Aaltonen (tjaalton) ** Changed in: libdrm (Ubuntu Focal) Assignee: (unassigned) => Timo Aaltonen (tjaalton) ** Changed in: x

[Touch-packages] [Bug 1949553] [NEW] Backport packages for 20.04.4 HWE stack

2021-11-03 Thread Timo Aaltonen
Public bug reported: [Impact] These are needed for 20.04.4 images. [Test case] Boot a daily image, see that it still has the necessary stack installed and working. [What could go wrong] libdrm: adds some new api, no changes to old stuff llvm-13: a new package, no regression potential on

[Touch-packages] [Bug 1949116] Re: libgl1-mesa-dri depends on libllvm12 from universe

2021-11-03 Thread Timo Aaltonen
yes it should, promotion is fine -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu. https://bugs.launchpad.net/bugs/1949116 Title: libgl1-mesa-dri depends on libllvm12 from universe Status in mesa package in

[Touch-packages] [Bug 1940504] Re: Support Alder Lake P graphics

2021-10-25 Thread Timo Aaltonen
** Changed in: linux-oem-5.14 (Ubuntu Focal) Status: Fix Committed => Fix Released -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu. https://bugs.launchpad.net/bugs/1940504 Title: Support Alder Lake P

[Touch-packages] [Bug 1930188] Please test proposed package

2021-10-08 Thread Timo Aaltonen
Hello Bijay, or anyone else affected, Accepted pulseaudio into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/pulseaudio/1:13.99.1-1ubuntu3.12 in a few hours, and then in the -proposed repository. Please help us by testing this new package.

[Touch-packages] [Bug 1930188] Please test proposed package

2021-10-08 Thread Timo Aaltonen
Hello Bijay, or anyone else affected, Accepted alsa-ucm-conf into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/alsa-ucm- conf/1.2.2-1ubuntu0.11 in a few hours, and then in the -proposed repository. Please help us by testing this new package.

[Touch-packages] [Bug 1930188] Please test proposed package

2021-10-08 Thread Timo Aaltonen
Hello Bijay, or anyone else affected, Accepted pulseaudio into hirsute-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/pulseaudio/1:14.2-1ubuntu1.2 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1930188] Re: Acer Aspire 5 sound driver issues

2021-10-08 Thread Timo Aaltonen
Hello Bijay, or anyone else affected, Accepted alsa-ucm-conf into hirsute-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/alsa-ucm- conf/1.2.4-2ubuntu1.4 in a few hours, and then in the -proposed repository. Please help us by testing this new

[Touch-packages] [Bug 1944107] Re: No archive files for static compilation are included in the -dev package

2021-10-05 Thread Timo Aaltonen
this broke flutter classic snap, and I had to revert the change ** Changed in: libdrm (Ubuntu) Status: Fix Released => Triaged -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to libdrm in Ubuntu.

[Touch-packages] [Bug 1942764] Re: Enable riscv64 build of mesa-opencl-icd

2021-10-04 Thread Timo Aaltonen
Note that this will be dropped from the next upload, as LLVM JIT is not available on riscv64 which means apps crash, see Debian bug #995618. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu.

[Touch-packages] [Bug 1945227] Re: drm/amdgpu: Add support for Yellow Carp

2021-09-29 Thread Timo Aaltonen
** Description changed: [Impact] New hardware support for AMD's Yellow Carp need five commits backported - to mesa and new firmware. This is only needed on focal, skipping - hirsute/impish (no kernel support there). + to mesa and new firmware. This is only needed on focal, skipping hirsute

[Touch-packages] [Bug 1776499] Re: Crash in libegl-mesa0 due to out of bound array access

2021-09-28 Thread Timo Aaltonen
huh, focal-updates has a much newer mesa which has that commit.. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu. https://bugs.launchpad.net/bugs/1776499 Title: Crash in libegl-mesa0 due to out of bound

[Touch-packages] [Bug 1945227] [NEW] drm/amdgpu: Add support for Yellow Carp

2021-09-27 Thread Timo Aaltonen
Public bug reported: [Impact] New hardware support for AMD's Yellow Carp need five commits backported to mesa and new firmware. This is only needed on focal, skipping hirsute/impish (no kernel support there). [Test plan] Install updates, boot a YC machine and check that the desktop has full

[Touch-packages] [Bug 1940504] Update Released

2021-09-27 Thread Timo Aaltonen
The verification of the Stable Release Update for libdrm has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a

[Touch-packages] [Bug 1782984] Re: Assertion `!xcb_xlib_threads_sequence_lost' failed with multiple applications

2021-09-27 Thread Timo Aaltonen
comment #113 still holds, focal needs to be verified first -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to libx11 in Ubuntu. https://bugs.launchpad.net/bugs/1782984 Title: Assertion `!xcb_xlib_threads_sequence_lost' failed

[Touch-packages] [Bug 1940504] Re: Support Alder Lake P graphics

2021-09-23 Thread Timo Aaltonen
oh, oem-5.14 was part of this bug :) ** Tags removed: verification-needed verification-needed-focal ** Tags added: verification-done verification-done-focal -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu.

[Touch-packages] [Bug 1940504] Re: Support Alder Lake P graphics

2021-09-23 Thread Timo Aaltonen
ADL-P works with the updated stack, plus linux-oem-5.14 from proposed -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu. https://bugs.launchpad.net/bugs/1940504 Title: Support Alder Lake P graphics Status in

[Touch-packages] [Bug 1944107] Re: No archive files for static compilation are included in the -dev package

2021-09-21 Thread Timo Aaltonen
enabled again in 2.4.107-3 -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to libdrm in Ubuntu. https://bugs.launchpad.net/bugs/1944107 Title: No archive files for static compilation are included in the -dev package

[Touch-packages] [Bug 1940504] Re: Support Alder Lake P graphics

2021-09-17 Thread Timo Aaltonen
** Changed in: linux-oem-5.14 (Ubuntu Focal) Status: New => Fix Committed -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu. https://bugs.launchpad.net/bugs/1940504 Title: Support Alder Lake P graphics

[Touch-packages] [Bug 1943906] [NEW] warning about missing firmware is mostly just noise

2021-09-17 Thread Timo Aaltonen
Public bug reported: Every time an LTS release gets a new backport kernel, we see reports from concerned users when they see something like this: W: Possible missing firmware /lib/firmware/i915/skl_guc_49.0.1.bin for module i915 W: Possible missing firmware /lib/firmware/i915/bxt_guc_49.0.1.bin

[Touch-packages] [Bug 1943818] Re: mesa built with -O3 on ppc64el has broken EGL

2021-09-16 Thread Timo Aaltonen
** Description changed: If mesa is built with -O3 then EGL will fail with: libEGL warning: DRI2: failed to create any config this can be easily reproduced by building libepoxy which then runs a series of tests. + + The same is fine on amd64, and also ppc64el is fine with gcc-10 and

[Touch-packages] [Bug 1943818] [NEW] mesa built with -O3 on ppc64el has broken EGL

2021-09-16 Thread Timo Aaltonen
Public bug reported: If mesa is built with -O3 then EGL will fail with: libEGL warning: DRI2: failed to create any config this can be easily reproduced by building libepoxy which then runs a series of tests. The same is fine on amd64, and also ppc64el is fine with gcc-10 and -O3. ** Affects:

[Touch-packages] [Bug 1942764] Re: Enable riscv64 build of mesa-opencl-icd

2021-09-08 Thread Timo Aaltonen
the packaging is basically synced from Debian, committed there ** Changed in: mesa (Ubuntu) Status: New => In Progress -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu.

[Touch-packages] [Bug 1940504] Re: Support Alder Lake P graphics

2021-09-07 Thread Timo Aaltonen
** Package changed: linux-oem-5.13 (Ubuntu Focal) => linux-oem-5.14 (Ubuntu Focal) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mesa in Ubuntu. https://bugs.launchpad.net/bugs/1940504 Title: Support Alder Lake P

[Touch-packages] [Bug 1940504] Re: Support Alder Lake P graphics

2021-08-25 Thread Timo Aaltonen
** Description changed: NOTE: this is for focal only, hirsute/impish do not and will not have kernel support for this. [Impact] ADL-P machines need to use the native driver. [Fix] Backport support from upstream. libdrm: a single patch from 2.4.107 mesa: three

  1   2   3   4   5   6   7   8   9   10   >