[Touch-packages] [Bug 1835738] Re: SRU: Update Python interpreter to 3.6.9 and 3.7.5

2019-11-25 Thread Mathew Hodson
** No longer affects: python3-defaults (Ubuntu Eoan) ** No longer affects: python3-defaults (Ubuntu Disco) ** No longer affects: python3-defaults (Ubuntu Bionic) ** No longer affects: python3-defaults (Ubuntu) -- You received this bug notification because you are a member of Ubuntu Touch

[Touch-packages] [Bug 1835738] Re: SRU: Update Python interpreter to 3.6.9 and 3.7.5

2019-11-25 Thread Launchpad Bug Tracker
This bug was fixed in the package python3.6 - 3.6.9-1~18.04 --- python3.6 (3.6.9-1~18.04) bionic-proposed; urgency=medium * SRU: LP: #1835738, backport 3.6.9 to 18.04. * Python 3.6.9 release. * Remove patches applied upstream: - CVE-2018-20852.patch -

[Touch-packages] [Bug 1835738] Re: SRU: Update Python interpreter to 3.6.9 and 3.7.5

2019-11-25 Thread Launchpad Bug Tracker
This bug was fixed in the package python3.7 - 3.7.5-2~19.10 --- python3.7 (3.7.5-2~19.10) eoan-proposed; urgency=medium * SRU: LP: #1835738, backport 3.7.5 to 19.10. -- Matthias Klose Wed, 20 Nov 2019 10:21:52 +0100 ** Changed in: python3.7 (Ubuntu Eoan) Status: Fix

[Touch-packages] [Bug 1835738] Re: SRU: Update Python interpreter to 3.6.9 and 3.7.5

2019-11-25 Thread Launchpad Bug Tracker
This bug was fixed in the package python3.7 - 3.7.5-2~18.04 --- python3.7 (3.7.5-2~18.04) bionic-proposed; urgency=medium * SRU: LP: #1835738, backport 3.7.5 to 18.04. python3.7 (3.7.5-2) unstable; urgency=medium * python3.7-dev: Depend on zlib1g-dev, needed to link as an

[Touch-packages] [Bug 1835738] Re: SRU: Update Python interpreter to 3.6.9 and 3.7.5

2019-11-25 Thread Łukasz Zemczak
Thanks! I have hinted virtualbox and will no proceed with releasing those to -updates. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to python3-defaults in Ubuntu. https://bugs.launchpad.net/bugs/1835738 Title: SRU: Update

[Touch-packages] [Bug 1835738] Re: SRU: Update Python interpreter to 3.6.9 and 3.7.5

2019-11-22 Thread Matthias Klose
** Tags removed: verification-needed verification-needed-eoan ** Tags added: verification-done verification-done-eoan -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to python3-defaults in Ubuntu.

[Touch-packages] [Bug 1835738] Re: SRU: Update Python interpreter to 3.6.9 and 3.7.5

2019-11-21 Thread Matthias Klose
given back tests, the one remaining failing test virtualbox/6.0.14-dfsg-1 (amd64) doesn't look like it is Python specific. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to python3-defaults in Ubuntu.

[Touch-packages] [Bug 1835738] Re: SRU: Update Python interpreter to 3.6.9 and 3.7.5

2019-11-20 Thread Łukasz Zemczak
Hello Matthias, or anyone else affected, Accepted python3.7 into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/python3.7/3.7.5-2~19.10 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1835738] Re: SRU: Update Python interpreter to 3.6.9 and 3.7.5

2019-11-11 Thread Matthias Klose
packages successfully built, no autopkg test regressions. And the test rebuild of main was already done before the upload to -proposed. ** Tags removed: verification-needed verification-needed-bionic verification-needed-disco verification-needed-eoan ** Tags added: verification-done

[Touch-packages] [Bug 1835738] Re: SRU: Update Python interpreter to 3.6.9 and 3.7.5

2019-11-09 Thread Matthias Klose
python3-stdlib-extensions for bionic was updated as part of the python3.8 SRU. ** Changed in: python3-stdlib-extensions (Ubuntu Bionic) Status: New => Fix Released -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to

[Touch-packages] [Bug 1835738] Re: SRU: Update Python interpreter to 3.6.9 and 3.7.5

2019-11-07 Thread Łukasz Zemczak
Hello Matthias, or anyone else affected, Accepted python3.7 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/python3.7/3.7.5-2~18.04 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1835738] Re: SRU: Update Python interpreter to 3.6.9 and 3.7.5

2019-11-07 Thread Launchpad Bug Tracker
This bug was fixed in the package python3-stdlib-extensions - 3.7.5-1~19.04 --- python3-stdlib-extensions (3.7.5-1~19.04) disco-proposed; urgency=medium * SRU: LP: #1835737. Backport the final Python 3.8.0 release. * Also update the 3.7 modules to 3.7.5.

[Touch-packages] [Bug 1835738] Re: SRU: Update Python interpreter to 3.6.9 and 3.7.5

2019-11-07 Thread Launchpad Bug Tracker
This bug was fixed in the package python3-stdlib-extensions - 3.7.5-1build1 --- python3-stdlib-extensions (3.7.5-1build1) eoan; urgency=medium * SRU: LP: #1835738. python3-stdlib-extensions (3.7.5-1) unstable; urgency=medium * Update 3.7 extensions and modules to 3.7.5 release.

[Touch-packages] [Bug 1835738] Re: SRU: Update Python interpreter to 3.6.9 and 3.7.5

2019-11-06 Thread Matthias Klose
** Description changed: Update Python interpreter to 3.6.9 and 3.7.5. As done with earlier subminor upstream releases (LP: #1822993). SRU: update Python 3.7 to the 3.7.5 release, update Python 3.6 to the 3.6.9 release. python3-stdlib-extensions also updates the modules to the

[Touch-packages] [Bug 1835738] Re: SRU: Update Python interpreter to 3.6.9 and 3.7.5

2019-11-06 Thread Matthias Klose
** Description changed: Update Python interpreter to 3.6.9 and 3.7.5. As done with earlier subminor upstream releases (LP: #1822993). SRU: update Python 3.7 to the 3.7.5 release, update Python 3.6 to the 3.6.9 release. python3-stdlib-extensions also updates the modules to the

[Touch-packages] [Bug 1835738] Re: SRU: Update Python interpreter to 3.6.9 and 3.7.5

2019-11-06 Thread Matthias Klose
** Description changed: Update Python interpreter to 3.6.9 and 3.7.5. As done with earlier subminor upstream releases (LP: #1822993). SRU: update Python 3.7 to the 3.7.5 release, update Python 3.6 to the 3.6.9 release. python3-stdlib-extensions also updates the modules to the

[Touch-packages] [Bug 1835738] Re: SRU: Update Python interpreter to 3.6.9 and 3.7.5

2019-10-21 Thread Łukasz Zemczak
Hello Matthias, or anyone else affected, Accepted python3-stdlib-extensions into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/python3-stdlib- extensions/3.7.5-1~19.04 in a few hours, and then in the -proposed repository. Please help us by

[Touch-packages] [Bug 1835738] Re: SRU: Update Python interpreter to 3.6.9 and 3.7.5

2019-10-18 Thread Launchpad Bug Tracker
This bug was fixed in the package python3-stdlib-extensions - 3.7.5-1build1 --- python3-stdlib-extensions (3.7.5-1build1) eoan; urgency=medium * SRU: LP: #1835738. python3-stdlib-extensions (3.7.5-1) unstable; urgency=medium * Update 3.7 extensions and modules to 3.7.5 release.

[Touch-packages] [Bug 1835738] Re: SRU: Update Python interpreter to 3.6.9 and 3.7.5

2019-10-18 Thread Launchpad Bug Tracker
This bug was fixed in the package python3.7 - 3.7.5-1ubuntu1 --- python3.7 (3.7.5-1ubuntu1) eoan; urgency=medium * SRU: LP: #1835738, to build the final 3.7.5 release for eoan, just introducing a delta for the SRU process. python3.7 (3.7.5-1) unstable; urgency=medium *

[Touch-packages] [Bug 1835738] Re: SRU: Update Python interpreter to 3.6.9 and 3.7.5

2019-10-17 Thread Mathew Hodson
** No longer affects: python3.6 (Ubuntu) ** No longer affects: python3.6 (Ubuntu Disco) ** No longer affects: python3.6 (Ubuntu Eoan) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to python3-defaults in Ubuntu.

[Touch-packages] [Bug 1835738] Re: SRU: Update Python interpreter to 3.6.9 and 3.7.5

2019-10-16 Thread Steve Langasek
Hello Matthias, or anyone else affected, Accepted python3-stdlib-extensions into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/python3-stdlib- extensions/3.7.5-1build1 in a few hours, and then in the -proposed repository. Please help us by

[Touch-packages] [Bug 1835738] Re: SRU: Update Python interpreter to 3.6.9 and 3.7.5

2019-10-16 Thread Steve Langasek
Hello Matthias, or anyone else affected, Accepted python3.7 into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/python3.7/3.7.5-1ubuntu1 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Touch-packages] [Bug 1835738] Re: SRU: Update Python interpreter to 3.6.9 and 3.7.5

2019-10-15 Thread Matthias Klose
** Summary changed: - SRU: Update Python interpreter to 3.6.9 and 3.7.4 + SRU: Update Python interpreter to 3.6.9 and 3.7.5 ** Description changed: - Update Python interpreter to 3.6.9 and 3.7.4. As done with earlier + Update Python interpreter to 3.6.9 and 3.7.5. As done with earlier