[Touch-packages] [Bug 1841654] Re: Consider replacing mawk with gawk in main

2020-02-12 Thread amano
With mawk 1.3.4.20200120-1 being uploaded to Debian testing now I suggest to mark this bug here as invalid and just sync the new mawk version to Focal. There is a separate bug for just updating mawk https://bugs.launchpad.net/ubuntu/+source/mawk/+bug/1332114 Let's follow up there... ** Changed

[Touch-packages] [Bug 1841654] Re: Consider replacing mawk with gawk in main

2019-11-20 Thread Erik Auerswald
I would prefer to have a current mawk in Ubuntu, but if that does not happen, replacing mawk with gawk would be appreciated. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mawk in Ubuntu.

[Touch-packages] [Bug 1841654] Re: Consider replacing mawk with gawk in main

2019-10-12 Thread Norbert
** Also affects: ubuntu-mate-meta (Ubuntu) Importance: Undecided Status: New ** Changed in: ubuntu-mate-meta (Ubuntu) Status: New => Confirmed ** Tags added: eoan ** Tags removed: amd64 indeed wayland-session -- You received this bug notification because you are a member of

[Touch-packages] [Bug 1841654] Re: Consider replacing mawk with gawk in main

2019-09-16 Thread Dave Chiluk
We (Indeed) were recently hit by mawk posix non-compliance as well. For all the reasons stated above, I would also like to see mawk replaced with gawk in main. I'd also like to see the mawk dependencies in the ubuntu-meta packages replaced with gawk. For that reason I'm opening a separate

[Touch-packages] [Bug 1841654] Re: Consider replacing mawk with gawk in main

2019-09-16 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users. ** Changed in: mawk (Ubuntu) Status: New => Confirmed -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to mawk in Ubuntu.

[Touch-packages] [Bug 1841654] Re: Consider replacing mawk with gawk in main

2019-09-05 Thread Thomas Dickey
NetBSD pkgsrc has a more recent version of mawk than stated in this report: http://pkgsrc.se/lang/mawk 2019-02-15) Updated to version: mawk-1.3.4.20171017 MacPorts has the 2019-02-03 version: https://github.com/macports/macports- ports/blob/master/lang/mawk/Portfile The report as worded

[Touch-packages] [Bug 1841654] Re: Consider replacing mawk with gawk in main

2019-09-02 Thread amano
Updated the description to include links to your current snapshots. Sorry for not finding them in the first place. ** Description changed: For POSIX compatibility reasons Ubuntu ships with mawk ("Mike's awk" = mawk) in main. There is an awk-symlink to mawk, thus mawk is the official awk

[Touch-packages] [Bug 1841654] Re: Consider replacing mawk with gawk in main

2019-09-01 Thread Thomas Dickey
I updated the webpage last week, to reduce confusion: https://invisible-island.net/mawk/mawk.html However, back to the stated issue: if the packager follows the same guidelines as previously stated (100% compatibility with the existing scripts, no effort whatsoever required of the packager),