Re: [Touch-packages] [Bug 1059872] Re: Error formatting disk using disk utility

2014-07-28 Thread Dimitri John Ledkov
On 27 July 2014 03:16, Phillip Susi ps...@ubuntu.com wrote: Dimitri, are you going to revert that patch? I was going to revert it locally to verify that installing the new util-linux 2.24 from debian experimental fixed it, but it seems that the bzr branch is significantly out of date for some

Re: [Touch-packages] [Bug 1238244] Re: pyconfig.h is missing HAVE_MEMMOVE

2014-07-28 Thread Dimitri John Ledkov
On 24 June 2014 23:23, Matt Black 1238...@bugs.launchpad.net wrote: I can confirm the bug exists installing PyXML 0.8.4 (latest at time of writing) from pypi on Ubuntu trusty 14.04. Please report a bug to PyXML upstream, with a note that HAVE_MEMMOVE detection is wrong upstream and instead

[Touch-packages] [Bug 1238244] Re: pyconfig.h is missing HAVE_MEMMOVE

2014-07-28 Thread Dimitri John Ledkov
Also please stop using PyXML, it's last release was in 2004 10 years ago. I daubt it will be fixed. Instead use import xml from python2.7 standard library, which is available out of the box. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which

[Touch-packages] [Bug 1331555] Re: Trusty's libsepol1 causes issues with Precise's Upstart during dist-upgrade

2014-07-28 Thread Dimitri John Ledkov
** Also affects: libsepol (Ubuntu Trusty) Importance: Undecided Status: New ** Also affects: libsepol (Ubuntu Utopic) Importance: Undecided Status: Confirmed ** Changed in: libsepol (Ubuntu Trusty) Status: New = Confirmed ** Changed in: libsepol (Ubuntu Utopic)

Re: [Touch-packages] [Bug 430224] Re: init: support chroots

2014-07-28 Thread Dimitri John Ledkov
On 19 June 2014 14:15, Dashamir Hoxha 430...@bugs.launchpad.net wrote: Just for the record, when I install Ubuntu Trusty (14.04) as a chroot inside Ubuntu Trusty (14.04) this problem does not happen. The problem here is with starting mysql inside the chroot: `service mysql start`. It tries to

[Touch-packages] [Bug 1331707] Re: db5.3-util package contains the wrong version of the manual pages

2014-07-28 Thread Dimitri John Ledkov
** Also affects: db5.3 (Ubuntu Utopic) Importance: Undecided Status: New ** Also affects: db5.3 (Ubuntu Trusty) Importance: Undecided Status: New -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to db5.3 in

Re: [Touch-packages] [Bug 1059872] Re: Error formatting disk using disk utility

2014-07-28 Thread Dimitri John Ledkov
On 28 July 2014 14:35, Phillip Susi ps...@ubuntu.com wrote: I was going to say that adding an option would break the ABI wouldn't it? And it sounds like you are saying that it did, and so the disk utility now is completely broken. If so, then yes, this certainly does need reverted; we can't

[Touch-packages] [Bug 1349813] Re: [org.freedesktop.Accounts.Error.PermissionDenied: Not authorized] While trying to change a ringtone

2014-07-30 Thread Dimitri John Ledkov
Pitti, looks like upstream has relaxed policy a bit in the current trunk. Would you review this proposed backport? Regards, Dimitri. ** Changed in: accountsservice (Ubuntu) Assignee: (unassigned) = Martin Pitt (pitti) -- You received this bug notification because you are a member of

[Touch-packages] [Bug 1320534] Re: sbuild fails under systemd-boot with /dev/shm tmpfs mount

2014-07-30 Thread Dimitri John Ledkov
On fresh Utopic host (VM, server install): $ sudo apt-get update; sudo apt-get install ubuntu-dev-tools systemd haveged $ mk-sbuild utopic relogin $ mk-sbuild utopic $ sbuild-update --keygen $ pull-lp-source hello $ sbuild -Ad utopic *.dsc # boot with init=/lib/systmed/systemd $ sbuild -Ad

[Touch-packages] [Bug 1320534] Re: systemd does not honor Ubuntu default mountpoints (as listed in /lib/init/fstab by upstart/mountall)

2014-07-30 Thread Dimitri John Ledkov
http://paste.ubuntu.com/7905336/ Diff between upstart+cgmanager mountpoints vs systemd from utopic- proposed (208) ** Summary changed: - systemd does not honor Ubuntu default mountpoints (as listed in /lib/init/fstab by upstart/mountall) + systemd does not honor Ubuntu default mountpoints (as

[Touch-packages] [Bug 1320534] Re: systemd does not honor Ubuntu default mountpoints (as listed in /lib/init/fstab by upstart/mountall) ... well just /run/shm is missing

2014-07-30 Thread Dimitri John Ledkov
: New = Confirmed ** Changed in: ubuntu-dev-tools (Ubuntu) Assignee: (unassigned) = Dimitri John Ledkov (xnox) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to systemd in Ubuntu. https://bugs.launchpad.net/bugs/1320534

[Touch-packages] [Bug 1320534] Re: missing /run/shm backwards compat symlink

2014-07-30 Thread Dimitri John Ledkov
/shm. ** Changed in: sysvinit (Ubuntu) Assignee: Dimitri John Ledkov (xnox) = Martin Pitt (pitti) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to sysvinit in Ubuntu. https://bugs.launchpad.net/bugs/1320534 Title

[Touch-packages] [Bug 1350770] [NEW] FTBFS with llvm 3.5

2014-07-31 Thread Dimitri John Ledkov
Public bug reported: FTBFS with llvm 3.5, git master has a few commits to resolve build failures. ** Affects: mesa (Ubuntu) Importance: Undecided Status: Confirmed ** Tags: ftbfs llvm-3.5 ** Tags added: ftbfs llvm-3.5 ** Changed in: mesa (Ubuntu) Status: New = Confirmed

[Touch-packages] [Bug 1351295] Re: Boot fails if /sbin/init (or init= arg) is an absolute symlink

2014-08-01 Thread Dimitri John Ledkov
I would prefer that /sbin/init is shipped as a real file by systemd- sysv, instead of a symlink of any kind. (E.g. a copy of /lib/systemd/systemd). -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.

[Touch-packages] [Bug 1351295] Re: Boot fails if /sbin/init (or init= arg) is an absolute symlink

2014-08-01 Thread Dimitri John Ledkov
At the moment we'd want to support for people to install systemd-sysv, and easily revert back to upstart. Ideally, systemd-sysv would not conflict with upstart, instead it would dpkg divert /sbin/init to /sbin/init.upstart and install /sbin/init which is systemd. That way people can still boot

[Touch-packages] [Bug 1351306] Re: Cannot uninstall upstart and install systemd-sysv

2014-08-01 Thread Dimitri John Ledkov
At the moment we'd want to support for people to install systemd-sysv, and easily revert back to upstart. Ideally, systemd-sysv would not conflict with upstart, instead it would dpkg divert /sbin/init to /sbin/init.upstart and install /sbin/init which is systemd. That way people can still boot

[Touch-packages] [Bug 1351306] Re: Cannot uninstall upstart and install systemd-sysv

2014-08-01 Thread Dimitri John Ledkov
Wrt. runlevel, telinit, shutdown, poweroff, halt: i think we want upstart equivalent to be aware of systemd. Such that, if system was booted with systemd, one can use invoke upstart commands which will send the request off to e.g. systemctl, Similarly, we probably want to continue to provide

[Touch-packages] [Bug 1351295] Re: Boot fails if /sbin/init (or init= arg) is an absolute symlink

2014-08-01 Thread Dimitri John Ledkov
Actually, i take that back. To support running upstart user sessions under systemd-sysv, we'd need to split upstart package. In that case upstart will ship /sbin/init which would be a symlink as well. Similar to how systemd-sysv is packaged. -- You received this bug notification because you are

[Touch-packages] [Bug 1351295] Re: Boot fails if /sbin/init (or init= arg) is an absolute symlink

2014-08-01 Thread Dimitri John Ledkov
** Changed in: initramfs-tools (Ubuntu) Assignee: Martin Pitt (pitti) = Dimitri John Ledkov (xnox) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu. https://bugs.launchpad.net/bugs/1351295 Title: Boot

[Touch-packages] [Bug 1351519] [NEW] /sys/class/dmi/id/product_uuid is not world readable

2014-08-01 Thread Dimitri John Ledkov
Public bug reported: As part of (un)stable whoopsie persistent machine identifier generation /sys/class/dmi/id/product_uuid is used. However: $ ls /sys/class/dmi/id/product_uuid -r 1 root root 4096 Aug 2 01:23 /sys/class/dmi/id/product_uuid It's not world-readable. Hence API calls to

[Touch-packages] [Bug 1350536] Re: url-dispatcher report_recoverable_problem() handler triggers reports filed against upstart

2014-08-01 Thread Dimitri John Ledkov
** Also affects: url-dispatcher Importance: Undecided Status: New ** Changed in: url-dispatcher Importance: Undecided = High ** Changed in: url-dispatcher Assignee: (unassigned) = Dimitri John Ledkov (xnox) -- You received this bug notification because you are a member

[Touch-packages] [Bug 1351543] [NEW] whoopsie-preferences does not honor CRASH_DB_IDENTIFIER

2014-08-01 Thread Dimitri John Ledkov
Public bug reported: whoopsie is running with CRASH_DB_IDENTIFIER set in the environment. whoopsie-preferences is ignorant of that, and calculates a fresh instead. ** Affects: whoopsie-preferences (Ubuntu) Importance: Undecided Status: New -- You received this bug notification

[Touch-packages] [Bug 1351544] [NEW] whoopsie should support andorid.serialno

2014-08-01 Thread Dimitri John Ledkov
Public bug reported: whoopsie should support andorid.serialno, which is an approx equivalent to product_uuid on i386/amd64 systems. ** Affects: whoopsie (Ubuntu) Importance: Undecided Status: New -- You received this bug notification because you are a member of Ubuntu Touch

[Touch-packages] [Bug 1351544] Re: whoopsie should support andorid.serialno

2014-08-01 Thread Dimitri John Ledkov
Aka /sys/class/android_usb/android0/iSerial -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to whoopsie in Ubuntu. https://bugs.launchpad.net/bugs/1351544 Title: whoopsie should support andorid.serialno Status in “whoopsie”

[Touch-packages] [Bug 1351306] Re: Cannot uninstall upstart and install systemd-sysv

2014-08-04 Thread Dimitri John Ledkov
** Changed in: upstart (Ubuntu) Assignee: (unassigned) = Dimitri John Ledkov (xnox) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to sysvinit in Ubuntu. https://bugs.launchpad.net/bugs/1351306 Title: Cannot uninstall

[Touch-packages] [Bug 1352334] [NEW] systemd boot hangs

2014-08-04 Thread Dimitri John Ledkov
Public bug reported: systemd boot hangs for me with [ *** ] A start job is running for LSB: Raise network interfaces message in plymouth with stars bouncing left to right. I only have a wifi card on this machine, which is usually brought up just by network-manager with WPA2 authentication.

[Touch-packages] [Bug 1352334] Re: systemd boot hangs

2014-08-04 Thread Dimitri John Ledkov
On 4 August 2014 14:22, Martin Pitt martin.p...@ubuntu.com wrote: Can you please attach your /etc/network/interfaces? At the time when it hangs, can you switch VTs and log in there already? Or ssh in? If you get access to the machine in that state, can you please get the output of sudo

[Touch-packages] [Bug 1351544] Re: whoopsie should support andorid.serialno

2014-08-05 Thread Dimitri John Ledkov
** Branch linked: lp:~xnox/whoopsie/android-serial -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to whoopsie in Ubuntu. https://bugs.launchpad.net/bugs/1351544 Title: whoopsie should support andorid.serialno Status in

[Touch-packages] [Bug 1351306] Re: Cannot uninstall upstart and install systemd-sysv

2014-08-06 Thread Dimitri John Ledkov
Upstart uploaded, will need to go through NEW. ** Changed in: upstart (Ubuntu) Status: Triaged = Fix Committed -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to sysvinit in Ubuntu.

Re: [Touch-packages] [Bug 1351295] Re: Boot fails if /sbin/init (or init= arg) is an absolute symlink

2014-08-07 Thread Dimitri John Ledkov
On 7 August 2014 03:03, A. Eibach 1351...@bugs.launchpad.net wrote: Strange. I still got the line 307: readlink: not found error on bootup although I do have initramfs-tools 0.103ubuntu8. It's not just initramfs-tools package, one also needs to regenerate initramfs with that tools package

[Touch-packages] [Bug 1245105] Re: [please sync lucene++ from debian] Mysteriously FTBFS on the distro builders

2014-10-17 Thread Dimitri John Ledkov
Ok, thanks for this. This is too late for Utopic, but i'll do that for Victorious Vicuna. ** Changed in: lucene++ (Ubuntu) Assignee: (unassigned) = Dimitri John Ledkov (xnox) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed

[Touch-packages] [Bug 1385817] Re: initscripts package fails to upgrade if there are local init scripts on the system with no LSB headers

2014-10-28 Thread Dimitri John Ledkov
** Description changed: - ? + = Release Notes = + + The dependency-based boot sequencing originally introduced upstream with + Debian 6.0 is now always enabled in Ubuntu 14.10. + + For optimal sequencing, all init.d scripts should declare their + dependencies in an LSB header. This is already

[Touch-packages] [Bug 1386257] Re: intel-microcode should be installed by default, when the CPU is GenuineIntel

2014-10-29 Thread Dimitri John Ledkov
** Changed in: ubuntu-seeds Assignee: (unassigned) = Dimitri John Ledkov (xnox) ** Project changed: ubuntu-seeds = ubuntu-meta (Ubuntu) ** Changed in: ubuntu-meta (Ubuntu) Status: New = In Progress -- You received this bug notification because you are a member of Ubuntu Touch

[Touch-packages] [Bug 1387908] [NEW] FIDO u2f security keys should be supported out of the box

2014-10-30 Thread Dimitri John Ledkov
Public bug reported: FIDO u2f is an emerging standard for public-private cryptography based 2nd factor authentication, which improves on OTP by mitigating phishing, man-in-the-middle attacks and reply attacks. Google Chrome supports u2f devices which are now widely available from Yubico (new

[Touch-packages] [Bug 1386206] Re: python-tz: Russia reintroduces daylight saving time

2014-10-30 Thread Dimitri John Ledkov
In ubuntu python-tz is patched to use system-wide tzdata, which is up to date (2014i) across the board. What specific error are you hitting? What version of tzdata package do you have installed? ** Changed in: python-tz (Ubuntu) Status: Confirmed = Incomplete -- You received this bug

[Touch-packages] [Bug 1373422] [NEW] gnutls fails to connect to https://01.org in trusty

2014-09-24 Thread Dimitri John Ledkov
Public bug reported: gnutls fails to connect to https://01.org in trusty In the certificate chain the top level certficate is trusted and is in /etc/ssl/certs/ca-certificates.crt, and gnutls-cli (3.x based) in utopic and openssl connect to 01.org just fine. gnutls-cli (2.6 based) in trusty does

[Touch-packages] [Bug 1373422] Re: gnutls fails to connect to https://01.org in trusty

2014-09-24 Thread Dimitri John Ledkov
In utopic gnutsl28 is the default implementation and thus does not have this problem. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to gnutls26 in Ubuntu. https://bugs.launchpad.net/bugs/1373422 Title: gnutls fails to

[Touch-packages] [Bug 1373422] Re: gnutls fails to connect to https://01.org in trusty

2014-09-24 Thread Dimitri John Ledkov
looks like certificates on 01.org are out of order. ** Changed in: gnutls26 (Ubuntu) Status: New = Invalid -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to gnutls26 in Ubuntu. https://bugs.launchpad.net/bugs/1373422

[Touch-packages] [Bug 1373422] Re: gnutls26 does not accept out of order certificate chains, whilst gnutls28 openssl do

2014-09-24 Thread Dimitri John Ledkov
mdeslaur I haven't looked at it yet, but it's probably an out of order cert, and you're hitting the well known gnutls issue with out-of-order certs mdeslaur xnox: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=573736 , http://lists.gnutls.org/pipermail/gnutls-devel/2013-July/006389.html ubot5

[Touch-packages] [Bug 1373422] Re: gnutls fails to connect to https://01.org in trusty

2014-09-24 Thread Dimitri John Ledkov
related bug #1043376 ** Changed in: gnutls26 (Ubuntu) Status: Invalid = Confirmed ** Summary changed: - gnutls fails to connect to https://01.org in trusty + gnutls26 does not accept out of order certificate chains, whilst gnutls28 openssl do ** Bug watch added: Debian Bug tracker

[Touch-packages] [Bug 1374648] [NEW] libuuid1 postinst fails on upgrade - calls usermod, without stopping the daemon first

2014-09-26 Thread Dimitri John Ledkov
Public bug reported: $ sudo dpkg --configure libuuid1 Setting up libuuid1:amd64 (2.25.1-1ubuntu1) ... usermod: user libuuid is currently used by process 2043 dpkg: error processing package libuuid1:amd64 (--configure): subprocess installed post-installation script returned error exit status 8

[Touch-packages] [Bug 1374652] [NEW] unity-schemas fail to install, missinng declaration replaces libunity-core

2014-09-26 Thread Dimitri John Ledkov
Public bug reported: dpkg: error processing archive /var/cache/apt/archives/unity-schemas_7.3.1+14.10.20140915-0ubuntu1_all.deb (--unpack): trying to overwrite '/usr/share/glib-2.0/schemas/com.canonical.Unity.gschema.xml', which is also in package libunity-core-6.0-9

[Touch-packages] [Bug 1377624] [NEW] udev requires hotplug support, thus upgrades fail

2014-10-05 Thread Dimitri John Ledkov
Public bug reported: I'm running 14.04 LTS in an OpenVZ container. Upgrades failed today, due to failure to configure udev: $ sudo apt-get dist-upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done 0 upgraded, 0 newly

[Touch-packages] [Bug 25700] Re: sudo does not read /etc/environment on interactive logins (directly, not through pam_env)

2014-10-08 Thread Dimitri John Ledkov
I wonder if this regressed and/or if my configuration is different from default, because sudo -i does not appear to be reading /etc/environment any more. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to sudo in Ubuntu.

[Touch-packages] [Bug 155794] Re: pam_env can't open /etc/default/locale

2014-10-08 Thread Dimitri John Ledkov
I believe it's a bug in sudo's PAM configuration. Specifically, /etc/pam.d/sudo should use session for pam_env module, rather than auth. ** Package changed: pam (Ubuntu) = sudo (Ubuntu) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is

[Touch-packages] [Bug 1386257] Re: intel-microcode should be installed by default, when the CPU is GenuineIntel

2014-11-03 Thread Dimitri John Ledkov
MIR filed in https://bugs.launchpad.net/ubuntu/+source/iucode- tool/+bug/139 -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu. https://bugs.launchpad.net/bugs/1386257 Title: intel-microcode should

[Touch-packages] [Bug 1377624] Re: udev requires hotplug support, thus upgrades fail

2014-11-15 Thread Dimitri John Ledkov
** Changed in: systemd (Ubuntu) Assignee: (unassigned) = Martin Pitt (pitti) ** Also affects: systemd (Ubuntu Trusty) Importance: Undecided Status: New ** Changed in: systemd (Ubuntu Trusty) Status: New = Confirmed ** Changed in: systemd (Ubuntu Trusty) Importance:

[Touch-packages] [Bug 1386257] Re: intel-microcode should be installed by default, when the CPU is GenuineIntel

2014-12-05 Thread Dimitri John Ledkov
MIR has been approved and intel-microcode has been seeded on to the images, thus whenever next images are build intel-microcode will be available from the package pool with the archive overrides done, but not yet automatically installed until after ubuntu-drivers-common change also lands on the

[Touch-packages] [Bug 1331555] Re: Trusty's libsepol1 causes issues with Precise's Upstart during dist-upgrade

2014-12-06 Thread Dimitri John Ledkov
Confirmed in an lxc container, job status from initctl list and processes preserved across upgrade from precise to (trusty + trusty- updates + trusty-proposed) which pulled the new libsepol ** Tags removed: verification-needed ** Tags added: verification-done -- You received this bug

[Touch-packages] [Bug 1385817] Re: initscripts package fails to upgrade if there are local init scripts on the system with no LSB headers

2014-12-19 Thread Dimitri John Ledkov
All systems are affected, and the scope of this bug report is minimal. If there are no LSB headers, defaults are used, unless there are other _other_ scripts which do have lsb headers and reference that one (e.g. override scripts of the stock init script). In those cases an upgrade may fail and

[Touch-packages] [Bug 1361886] [NEW] Proxy Auto-Configuration files should be supported better

2014-08-26 Thread Dimitri John Ledkov
: Undecided Assignee: Dimitri John Ledkov (xnox) Status: Confirmed ** Affects: libproxy (Ubuntu) Importance: Undecided Assignee: Dimitri John Ledkov (xnox) Status: Confirmed ** Affects: ubuntu-system-service (Ubuntu) Importance: Undecided Assignee: Dimitri

[Touch-packages] [Bug 1331555] Re: Trusty's libsepol1 causes issues with Precise's Upstart during dist-upgrade

2014-08-31 Thread Dimitri John Ledkov
** Changed in: libsepol (Ubuntu Trusty) Assignee: (unassigned) = Dimitri John Ledkov (xnox) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to libsepol in Ubuntu. https://bugs.launchpad.net/bugs/1331555 Title: Trusty's

[Touch-packages] [Bug 1361886] Re: Proxy Auto-Configuration files should be supported better

2014-09-02 Thread Dimitri John Ledkov
mvo wrote apt patch \o/ removing ubuntu apt task ** Bug watch added: Debian Bug tracker #759264 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=759264 ** Also affects: apt (Debian) via http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=759264 Importance: Unknown Status: Unknown

[Touch-packages] [Bug 1361886] Re: Proxy Auto-Configuration files should be supported better

2014-09-02 Thread Dimitri John Ledkov
libproxy needs to gain a plugin to talk to ubuntu-system-service. ubuntu-system-service should store / expose proxy-autoconfiguration URL. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to apt in Ubuntu.

Re: [Touch-packages] [Bug 1039887] Re: fstab does not honor /proc mount options

2014-07-15 Thread Dimitri John Ledkov
On 25 March 2014 19:50, Simon Déziel 1039...@bugs.launchpad.net wrote: Dimitri, any chance to see this implemented in Trusty? So I took a stab at implementing this. To figure out whether or not a remount is required, I had to start parsing all options specified in the right order, which turned

[Touch-packages] [Bug 1338788] Re: startpar-bridge: does not notice, if upstart jobs are skipped

2014-07-15 Thread Dimitri John Ledkov
** Changed in: sysvinit (Ubuntu) Assignee: (unassigned) = Dimitri John Ledkov (xnox) ** Changed in: sysvinit (Ubuntu) Status: New = In Progress ** Changed in: sysvinit (Ubuntu) Status: In Progress = Triaged -- You received this bug notification because you are a member

[Touch-packages] [Bug 1339758] Re: package libboost1.54-dev (not installed) failed to install/upgrade: trying to overwrite '/usr/include/boost/multi_index/safe_mode_errors.hpp', which is also in packa

2014-07-15 Thread Dimitri John Ledkov
Where did you get libboost-dev 1.33.1-2ubuntu0.1 from? Please remove libboost-dev, and attempt upgrade again. That version number is from pre-lucid it seems, and direct upgrades to boost1.54 are not supported from pre-lucid machines. ** Changed in: boost1.54 (Ubuntu) Status: New =

[Touch-packages] [Bug 1174272] Re: 'reboot now' reverting to maintenance mode, instead of rebooting

2014-07-18 Thread Dimitri John Ledkov
`$ sudo reboot please` now correctly reboots machine, instead of erroneously dropping to runlevel 1. ** Tags removed: verification-needed ** Tags added: verification-done -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to

[Touch-packages] [Bug 1174272] Re: 'reboot now' reverting to maintenance mode, instead of rebooting

2014-07-20 Thread Dimitri John Ledkov
** Changed in: upstart Status: In Progress = Fix Released -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to upstart in Ubuntu. https://bugs.launchpad.net/bugs/1174272 Title: 'reboot now' reverting to maintenance mode,

[Touch-packages] [Bug 1304363] Re: [UIFe] enable borderless windows under metacity (e.g. for ubiquity)

2014-07-20 Thread Dimitri John Ledkov
** Changed in: ubuntu-themes (Ubuntu) Status: Confirmed = Won't Fix ** Summary changed: - [UIFe] enable borderless windows under metacity (e.g. for ubiquity) + enable borderless windows under metacity (e.g. for ubiquity) -- You received this bug notification because you are a member of

[Touch-packages] [Bug 1347553] Re: Ubuntu GNOME: reboot dialog in live image shows 6 versions of the live user logged in on the console

2014-07-23 Thread Dimitri John Ledkov
** Also affects: gnome-shell (Ubuntu) Importance: Undecided Status: New -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to systemd in Ubuntu. https://bugs.launchpad.net/bugs/1347553 Title: Ubuntu GNOME: reboot

[Touch-packages] [Bug 1059872] Re: Error formatting disk using disk utility

2014-07-23 Thread Dimitri John Ledkov
Whilst the bug maybe elsewhere, udisks2 will need an action to revert the patch i uploaded, thus keeping the task againt udisks2 assigned to myself. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to util-linux in Ubuntu.

[Touch-packages] [Bug 1235649] Re: uevent spam causes libdbus client code in session upstart to consume massive amounts of memory on Ubuntu Touch

2014-07-24 Thread Dimitri John Ledkov
** Changed in: upstart Status: Fix Committed = Fix Released ** Changed in: upstart Status: Fix Released = Confirmed -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to unity in Ubuntu.

[Touch-packages] [Bug 1348150] Re: Memory corruption (using memory after freeing) in GNU Make

2014-07-25 Thread Dimitri John Ledkov
** Also affects: make-dfsg (Ubuntu Precise) Importance: Undecided Status: New ** Also affects: make-dfsg (Ubuntu Trusty) Importance: Undecided Status: New ** Also affects: make-dfsg (Ubuntu Utopic) Importance: Undecided Status: New ** Changed in: make-dfsg (Ubuntu

[Touch-packages] [Bug 1377624] Re: udev fails without devtmpfs and sysvinit

2014-11-21 Thread Dimitri John Ledkov
I am running such a container (it's OpenVZ based) It is running upstart as pid 1 (in the container) and it is unmodified binary from trusty. (double verified with $ initctl version, which confirms running init is in-fact upstart) udev upgrade fails in trusty in that container here is the mount:

[Touch-packages] [Bug 1350536] Re: url-dispatcher report_recoverable_problem() handler triggers reports filed against upstart

2014-11-25 Thread Dimitri John Ledkov
** Changed in: url-dispatcher Assignee: Dimitri John Ledkov (xnox) = (unassigned) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to url-dispatcher in Ubuntu. https://bugs.launchpad.net/bugs/1350536 Title: url-dispatcher

[Touch-packages] [Bug 1331555] Re: Trusty's libsepol1 causes issues with Precise's Upstart during dist-upgrade

2014-11-25 Thread Dimitri John Ledkov
libsepol (2.3-2) unstable; urgency=medium * Drop debian/libsepol1.postinst: Reloading systemd during an upgrade in an uncontroled way might endup with unwanted side effects (Closes: #753727) -- Laurent Bigonville bi...@debian.org Sun, 31 Aug 2014 20:02:14 +0200 ** Changed in: libsepol

[Touch-packages] [Bug 1324257] Re: utopic lubuntu insserv error

2014-11-25 Thread Dimitri John Ledkov
** Changed in: dbus (Ubuntu) Assignee: Dimitri John Ledkov (xnox) = (unassigned) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to dbus in Ubuntu. https://bugs.launchpad.net/bugs/1324257 Title: utopic lubuntu insserv

[Touch-packages] [Bug 1331555] Re: Trusty's libsepol1 causes issues with Precise's Upstart during dist-upgrade

2014-11-25 Thread Dimitri John Ledkov
** Changed in: libsepol (Ubuntu Trusty) Status: Confirmed = In Progress -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to libsepol in Ubuntu. https://bugs.launchpad.net/bugs/1331555 Title: Trusty's libsepol1 causes

[Touch-packages] [Bug 1315464] Re: Cannot login if ~/.cache is dead symlink

2014-11-25 Thread Dimitri John Ledkov
(Ubuntu Trusty) Assignee: Dimitri John Ledkov (xnox) = (unassigned) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to dbus in Ubuntu. https://bugs.launchpad.net/bugs/1315464 Title: Cannot login if ~/.cache is dead symlink

[Touch-packages] [Bug 1330410] Re: All keyboard types in Keyboard layout are not localized during installation

2014-11-29 Thread Dimitri John Ledkov
Can you please elaborate? I'm downloading console-setup from https://launchpad.net/ubuntu/+source /console-setup/1.70ubuntu9/+build/6047796 which is the current version published in the archive, and DEBIAN/templates appear to be translated to me correctly. Rebuilding the package locally here

[Touch-packages] [Bug 1397685] Re: git gnutls_handshake() failed: A TLS packet with unexpected length was received.

2014-11-30 Thread Dimitri John Ledkov
This will need further investigations / tests as to what is the problem in the TLS protocol. It's most likely not git specific but rather TLS implementation specific - that is one can recompile curl utility against (openssl, gnutls, nss) to verify with each one that lts access works. We cannot

[Touch-packages] [Bug 1397685] Re: git gnutls_handshake() failed: A TLS packet with unexpected length was received.

2014-11-30 Thread Dimitri John Ledkov
Performing https configuration verfication on git.fedorahosted.org: On Trusty 14.04 LTS, the default gnutls implementation is old 2.6 based: $ gnutls-cli -V --print-cert -p 443 git.fedorahosted.org /dev/zero | certtool --verify-chain Certificate[0]: C=US,ST=North Carolina,L=Raleigh,O=Red Hat

[Touch-packages] [Bug 1397685] Re: git gnutls_handshake() failed: A TLS packet with unexpected length was received.

2014-11-30 Thread Dimitri John Ledkov
@Erez Hadad can you please try to reproduce this problem in 14.10 Utopic as well? This will then rule-out whether gnutls 3.x is affected as well or not. This can be done from a Trusty 14.04 host like so: $ mk-sbuild utopic $ schroot -u root -c utopic-ppc64el $ apt-get install git $ cd /tmp; git

[Touch-packages] [Bug 1330410] Re: All keyboard types in Keyboard layout are not localized during installation

2014-11-30 Thread Dimitri John Ledkov
Translated keyboard names appear to have been explicitely disabled in ubiquity: http://bazaar.launchpad.net/~ubuntu-installer/ubiquity/trunk/revision/6210 Due to https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1182784 Which appears to have regressed the installer

Re: [Touch-packages] [Bug 1330410] Re: All keyboard types in Keyboard layout are not localized during installation

2014-12-02 Thread Dimitri John Ledkov
Heya, On 1 December 2014 at 04:23, Anthony Wong anthony.w...@ubuntu.com wrote: xnox, the problem is the translation of keyboard model names, not debconf templates. I checked by extracting the debian package with ar and then untar control.tar.gz. These are snippets of diff'ing the config

[Touch-packages] [Bug 1386257] Re: intel-microcode should be installed by default, when the CPU is GenuineIntel

2014-12-02 Thread Dimitri John Ledkov
@debfx this is precisely why intel microcode package should be consistently installed and this is done in response to the TSX problem described before. microcode update is the last resort that vendor has to correct firmware bugs in the field. microcode update removed TSX instruction because the

[Touch-packages] [Bug 1409555] Re: drop extras.ubuntu.com

2015-02-07 Thread Dimitri John Ledkov
** Tags added: block-proposed -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu. https://bugs.launchpad.net/bugs/1409555 Title: drop extras.ubuntu.com Status in Ubuntu Software Center: New Status in

[Touch-packages] [Bug 1417637] Re: Kdeinit4 is leaking memory on every ssh login due to known bug on policykit-1

2015-02-03 Thread Dimitri John Ledkov
This appears to be the fix, unreleased upstream yet, thus probably affects all current series. http://cgit.freedesktop.org/polkit/commit/?id=f4d71e0de885010494b8b0b8d62ca910011d7544 ** Bug watch added: freedesktop.org Bugzilla #88288 https://bugs.freedesktop.org/show_bug.cgi?id=88288 ** Also

[Touch-packages] [Bug 1417637] Re: Kdeinit4 is leaking memory on every ssh login due to known bug on policykit-1

2015-02-03 Thread Dimitri John Ledkov
By large the above debdiff should be (with correct version number and target) should be applied and uploaded into vivid, utopic and trusty. Series targets opened ubuntu-sponsors subscribed to the bug report. Test case description for SRUs is in

Re: [Touch-packages] [Bug 1409555] Re: drop extras.ubuntu.com

2015-02-08 Thread Dimitri John Ledkov
On 7 February 2015 at 19:25, Dave Stroud bigdav...@suddenlink.net wrote: it shows fix released for ubuntu gnome but upgrade still fails. because no vivid extras cant be found This problem needs to be fixed in _all_ affected packages. Which is still in progress. This is not indication that

[Touch-packages] [Bug 1409555] Re: drop extras.ubuntu.com

2015-02-08 Thread Dimitri John Ledkov
** Tags removed: block-proposed -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu. https://bugs.launchpad.net/bugs/1409555 Title: drop extras.ubuntu.com Status in Ubuntu Software Center: New Status

[Touch-packages] [Bug 821000] Re: setuptools and distribute don't prepend PYTHONPATH to sys.path

2015-01-21 Thread Dimitri John Ledkov
** Also affects: python-setuptools (Ubuntu) Importance: Undecided Status: New ** Changed in: python-setuptools (Ubuntu) Assignee: (unassigned) = Barry Warsaw (barry) -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is

[Touch-packages] [Bug 1421058] [NEW] invoke-rc.d $foo stop prints degraded

2015-02-11 Thread Dimitri John Ledkov
Public bug reported: During dist-upgrade I see a lot of degraded Lines. It seems like systemd is leaking those through invoke-rc.d calls. E.g. $ invoke-rc.d apport stop Prints degraded, note that my machine is systemd-booted and is currently in degraded state. ProblemType: Bug

[Touch-packages] [Bug 1414229] Re: python apt reporting Mint as generic distro, not as Ubuntu type distro

2015-01-27 Thread Dimitri John Ledkov
Could you please copy into here results off: $ cat /etc/dpkg/origins/default $ dpkg-vendor --derives-from Ubuntu echo $? $ dpkg-vendor --derives-from Debian echo $? -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to

[Touch-packages] [Bug 1109029] Re: Depend on linux-initramfs-tools

2015-01-24 Thread Dimitri John Ledkov
why is dracut conflicting with initramfs-tools? shouldn't that conflict be solved in Debian? note there is no intention to support alternative initramfs implementations in Ubuntu main. ** Changed in: ubuntu-meta (Ubuntu) Status: Confirmed = Invalid -- You received this bug notification

[Touch-packages] [Bug 1413699] Re: pkill|pgrep are buggy

2015-01-23 Thread Dimitri John Ledkov
use $ status upstart-udev-bridge ? After all said process is managed by upstart, why pgrep for it? -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to procps in Ubuntu. https://bugs.launchpad.net/bugs/1413699 Title:

Re: [Touch-packages] [Bug 1385817] Re: initscripts package fails to upgrade if there are local init scripts on the system with no LSB headers

2015-01-31 Thread Dimitri John Ledkov
On 29 January 2015 at 16:10, Christopher 1385...@bugs.launchpad.net wrote: insserv: Starting .depend.boot depends on rc.local and therefore on system facility `$all' which can not be true! Do you have anything in /etc/rc.local ? apart from exit 0? What are the headers of /etc/init.d/rc.local?

[Touch-packages] [Bug 1409356] Re: drop usage of :sys:started/stopped/starting/stopping events

2015-01-10 Thread Dimitri John Ledkov
** Also affects: location-service (Ubuntu) Importance: Undecided Status: New -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to location-service in Ubuntu. https://bugs.launchpad.net/bugs/1409356 Title: drop usage

[Touch-packages] [Bug 1409555] Re: drop extras.ubuntu.com

2015-01-11 Thread Dimitri John Ledkov
** Changed in: kubuntu-meta (Ubuntu) Status: New = In Progress ** Changed in: ubuntu-gnome-meta (Ubuntu) Status: New = In Progress ** Changed in: ubuntu-meta (Ubuntu) Status: New = In Progress ** Changed in: ubuntukylin-meta (Ubuntu) Status: New = In Progress **

[Touch-packages] [Bug 1409555] Re: drop extras.ubuntu.com

2015-01-11 Thread Dimitri John Ledkov
** Also affects: software-center Importance: Undecided Status: New -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu. https://bugs.launchpad.net/bugs/1409555 Title: drop extras.ubuntu.com

[Touch-packages] [Bug 1409555] Re: drop extras.ubuntu.com

2015-01-11 Thread Dimitri John Ledkov
** Also affects: ubuntu-meta (Ubuntu) Importance: Undecided Status: New ** Also affects: ubuntu-gnome-meta (Ubuntu) Importance: Undecided Status: New ** Also affects: kubuntu-meta (Ubuntu) Importance: Undecided Status: New ** Also affects: ubuntukylin-meta (Ubuntu)

[Touch-packages] [Bug 1409555] Re: drop extras.ubuntu.com

2015-01-11 Thread Dimitri John Ledkov
** Also affects: ubuntu-release-upgrader (Ubuntu) Importance: Undecided Status: New -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu. https://bugs.launchpad.net/bugs/1409555 Title: drop

[Touch-packages] [Bug 1409129] [NEW] Drop usage of udev-bridge via events-bridge

2015-01-09 Thread Dimitri John Ledkov
Public bug reported: Currently there is udev-bridge that connects to system upstart and emits *-device-changed events and related. User session init has an events bridge that connects to system upstart and listen on event, and re-emits them to session upstart. udev socket - udev-bridge - system

[Touch-packages] [Bug 1409555] Re: drop extras.ubuntu.com

2015-01-12 Thread Dimitri John Ledkov
** Changed in: ubuntu-release-upgrader (Ubuntu) Status: New = In Progress -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu. https://bugs.launchpad.net/bugs/1409555 Title: drop extras.ubuntu.com

[Touch-packages] [Bug 1409555] Re: drop extras.ubuntu.com

2015-01-12 Thread Dimitri John Ledkov
** Also affects: lubuntu-meta (Ubuntu) Importance: Undecided Status: New -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu. https://bugs.launchpad.net/bugs/1409555 Title: drop

[Touch-packages] [Bug 1345296] Re: Unable to load entry point in libxpathselect

2015-01-09 Thread Dimitri John Ledkov
Will this be included in trusty? -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to unity in Ubuntu. https://bugs.launchpad.net/bugs/1345296 Title: Unable to load entry point in libxpathselect Status in Unity: Fix

[Touch-packages] [Bug 1190344] Re: lightdm is leaking FDs -fix

2015-02-13 Thread Dimitri John Ledkov
Even thought this does not address the bug completely, can the lightdm update be released none-the-less? as it does not degrade beyond what's in current release/updates pockets? -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to

[Touch-packages] [Bug 1377624] Re: udev fails in trusty OpenVZ containers, when /etc/init/udev is missing (OVH misconfig?!)

2015-02-15 Thread Dimitri John Ledkov
@ Pitti thanks for the hint: I've added -x to the udev postinst $ sudo dpkg --configure udev Setting up udev (204-5ubuntu20.9) ... + set -e + update_hwdb + udevadm hwdb --update + invoke-rc.d udev restart * udev requires hotplug support, not started ...fail! invoke-rc.d: initscript udev,

[Touch-packages] [Bug 1238410] Re: Inconsistent cursor visibility with cursor plugin enabled

2015-03-18 Thread Dimitri John Ledkov
I think this is hardware dependant as well. Since on my Ideapad Yoga i never have mouse pointer appearing. Can we please disable the cursor plugin and release it as SRU? -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to unity

  1   2   3   4   5   6   7   8   9   10   >