[Touch-packages] [Bug 1252121] Re: missing PrepareForSleep signal after resuming, causing networking to stay disabled

2014-08-24 Thread Vincas Dargis
Same problem for laptop upgraded from 12.04 into 14.04. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to systemd-shim in Ubuntu. https://bugs.launchpad.net/bugs/1252121 Title: missing PrepareForSleep signal after resuming,

[Touch-packages] [Bug 1349704] Re: location service should create logging directories

2016-06-06 Thread Vincas Dargis
I'm still missing this directory on E5. I bought it, I believe, with OTA-8, but noticed that it is missing at OTA-10.1 (because only at that time I started to debug issues). OTA-11 updated and there is still no /var/log/ubuntu-location-service . I have created it manually, but it is not filled.

[Touch-packages] [Bug 1588459] Re: OTA-11: missing GPS swtich in battery setings, GPS seems not working

2016-06-06 Thread Vincas Dargis
I can see something interesting in logcat output: E/gps_mt3326( 4545): gps_state_thread: line = 1943error while reading from gps daemon socket: Success: 0xb4fcd294 -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to

[Touch-packages] [Bug 1440111] Re: [calendar] Reminder notifications are not integrated into system notifications

2016-06-07 Thread Vincas Dargis
>Sound will be an option once the extended notification settings work gets done Is there a task I could follow? Integration is much better now, but without noisy alarm, I still missed my task... -- You received this bug notification because you are a member of Ubuntu Touch seeded packages,

[Touch-packages] [Bug 1588459] Re: OTA-11: missing GPS swtich in battery setings, GPS seems not working

2016-06-07 Thread Vincas Dargis
I've left Location enabled for two days now, and visible_space_vehicles is not empty actually, but it's full of zeroes ** Attachment added: "visible_space_vehicles" https://bugs.launchpad.net/ubuntu/+source/location-service/+bug/1588459/+attachment/4679064/+files/visible_space_vehicles

[Touch-packages] [Bug 1588459] Re: OTA-11: missing GPS swtich in battery setings, GPS seems not working

2016-06-03 Thread Vincas Dargis
** Summary changed: - OTA-11: missing GPS slider in battery setings, GPS seems not working + OTA-11: missing GPS swtich in battery setings, GPS seems not working -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to

[Touch-packages] [Bug 1391863] Re: horizontal accuracy meters keeps getting higher

2016-05-30 Thread Vincas Dargis
Forgot to mention - I'm on E5 with OTA-10.1. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to location-service in Ubuntu. https://bugs.launchpad.net/bugs/1391863 Title: horizontal accuracy meters keeps getting higher

[Touch-packages] [Bug 1391863] Re: horizontal accuracy meters keeps getting higher

2016-05-30 Thread Vincas Dargis
I too noticed in SensorStatus app that horizontal accuracy keeps increasing. Also in OpenStreetMap and HERE as stated. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to location-service in Ubuntu.

[Touch-packages] [Bug 1588459] [NEW] OTA-11: missing GPS slider in battery setings, GPS seems not working

2016-06-02 Thread Vincas Dargis
Public bug reported: Just updated Aquaris E5 to OTA-11 (using settings app, no flashing), and noticed that slider to enable GPS device is missing. I am not sure if it was designed so, but GPS does seems like not working. Location service is enabled (at least it seems so). There are Wireless

[Touch-packages] [Bug 1596586] [NEW] Enter Sim Pin dialog briefly show as white round cornered rectangle artefact after reboot

2016-06-27 Thread Vincas Dargis
Public bug reported: When phone boots, just before Enter Sim Pin Ubuntu-styled dialog is shown, I see white round cornered rectangle with "Enter Sim Pin" text inside of it on to of the screen. It imagine it as QML style not yet loaded or something like that. It happens always, but just for a

[Touch-packages] [Bug 1542644] Re: Cannot exit Messaging app tutorial while in landscape

2016-02-06 Thread Vincas Dargis
** Attachment added: "messaging_ok.png" https://bugs.launchpad.net/ubuntu/+source/messaging-app/+bug/1542644/+attachment/4565202/+files/messaging_ok.png -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to messaging-app in

[Touch-packages] [Bug 1542644] [NEW] Cannot exit Messaging app tutorial while in landscape

2016-02-06 Thread Vincas Dargis
Public bug reported: When I have launched Messaging app in Aquaris E5 OTA-9 I've been introduced with tutorial about how to deal with messages. I have screenshot attached showing that "Got it" button is NOT visible while in landscape (gets hidden?), but it's OK in portrait mode. ** Affects:

[Touch-packages] [Bug 1596586] Re: SIM PIN dialog displayed before it rendered completely

2016-07-28 Thread Vincas Dargis
Same on OTA-12. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to unity8 in Ubuntu. https://bugs.launchpad.net/bugs/1596586 Title: SIM PIN dialog displayed before it rendered completely Status in unity8 package in Ubuntu:

[Touch-packages] [Bug 1588459] Re: OTA-11: missing GPS swtich in battery setings, GPS seems not working

2016-07-29 Thread Vincas Dargis
Same issue with OTA-12. Attaching logcat output. There are some interesting lines, such as: D/gps_mt3326( 3334): nmea_reader_parse: line = 1247GPS get accuracy failed, fix mode:1 D/mnl_linux(10399): mtk_gps_sys_gps_mnl_callback: MTK_GPS_MSG_FIX_READY,GET_RTC_FAIL D/gps_mt3326( 3334):

[Touch-packages] [Bug 1588459] Re: OTA-11: missing GPS swtich in battery setings, GPS seems not working

2016-07-29 Thread Vincas Dargis
I am thinking about reflashing, but maybe it would be actually better to try to find actual issue and fix it... -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to location-service in Ubuntu.

[Touch-packages] [Bug 1588459] Re: OTA-11: GPS seems not working

2016-07-31 Thread Vincas Dargis
Well, I've been on some trip with my car, and... it worked. Maybe sometimes it just has hard time acquiring satellites, harder when we (users) assumes it should have. ** Summary changed: - OTA-11: missing GPS swtich in battery setings, GPS seems not working + OTA-11: GPS seems not working --

[Touch-packages] [Bug 1585886] Re: WiFi indicator icon disappears in Ubuntu 16.04

2016-08-04 Thread Vincas Dargis
I did another experiment. I've remove ehternet cable, connected WiFi to my home router. Now I could reboot as much as I want, WiFi worked, checkbox is visible and is ON inside network manager widget. BUT, later I disabled WiFi connection, attached etherne cable, rebooted and that's it - wlan0

[Touch-packages] [Bug 1585886] Re: WiFi indicator icon disappears in Ubuntu 16.04

2016-08-04 Thread Vincas Dargis
** Attachment added: "lspci" https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1585886/+attachment/4713881/+files/lspci -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to network-manager in Ubuntu.

[Touch-packages] [Bug 1585886] Re: WiFi indicator icon disappears in Ubuntu 16.04

2016-08-04 Thread Vincas Dargis
Yeah, it looks like I lose WiFi connectivity on ever third reboot!. Have to "rfkill unblock 0" to make it work again, for two reboots... -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to network-manager in Ubuntu.

[Touch-packages] [Bug 1585886] Re: WiFi indicator icon disappears in Ubuntu 16.04

2016-08-04 Thread Vincas Dargis
** Attachment added: "syslog-2-reboot-with-wifi-disabled" https://bugs.launchpad.net/ubuntu/+source/indicator-applet/+bug/1585886/+attachment/4713868/+files/syslog-2-reboot-with-wifi-disabled ** Also affects: network-manager (Ubuntu) Importance: Undecided Status: New -- You

[Touch-packages] [Bug 1588459] Re: OTA-11: GPS seems not working

2016-08-14 Thread Vincas Dargis
I am not sure about other 6 people who confirmed this bug, but it looks like GPS is actually working for me. One simply has to have app (SensorStatus or uNav) in the foreground for some time to actually acquire GPS fix. Having Location on for few days does nothing, if you check Sensors app just

[Touch-packages] [Bug 1544477] Re: No sound notification for new SMS (Ubuntu Touch)

2016-08-14 Thread Vincas Dargis
I have same problem on OTA-12, BQ E5. Attaching tailed unity8 and syslog. Note that there are lot's of these lines: """ Failed to get current playback position: org.freedesktop.DBus.Error.UnknownMethod: Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't

[Touch-packages] [Bug 1516696] Re: SMS notifications are received only when the phone is unlocked

2016-08-14 Thread Vincas Dargis
Yep, thanks Anupam! -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to unity8 in Ubuntu. https://bugs.launchpad.net/bugs/1516696 Title: SMS notifications are received only when the phone is unlocked Status in Canonical

[Touch-packages] [Bug 1516696] Re: SMS notifications are received only when the phone is unlocked

2016-08-14 Thread Vincas Dargis
I am not sure if it's the same bug, but for me (E5, OTA-12), I do not get sound notification at all (sometimes I do though), even if device is unlocked. I do hear vibrator, see green blinking light, but no sound. I am quite sure that Sound options are set OK. I've attached tailed syslog.log and

[Touch-packages] [Bug 1613056] [NEW] unity8.log spammed with Failed to get current playback position messages

2016-08-14 Thread Vincas Dargis
Public bug reported: BQ E5, OTA-12. I've noticed that my ~/.cache/upstart/unity8.log contains lot's of these messages, filled every second (file is around 6 Megs at time of writing): [2016-35-10:11:35:07.388] Failed to get current playback position: org.freedesktop.DBus.Error.UnknownMethod:

[Touch-packages] [Bug 1578176] Re: Cannot place or recieve calls when using in-car bluetooth system

2016-07-18 Thread Vincas Dargis
Looks like I have created a duplicate: https://bugs.launchpad.net/ubuntu-rtm/+source/bluez/+bug/1584362 There are some logs attached. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to bluez in Ubuntu.

[Touch-packages] [Bug 1603627] [NEW] Missing Lithuanian keyboard support.

2016-07-16 Thread Vincas Dargis
Public bug reported: Hi, I've noticed that our neighbours Latvians just got keyboard support [1]. I thought it would be cool to have keyboard for Lithuanian language also. It's also QWERTY, with special characters: Ą, ą Č, č Ę, ę Ė, ė Į, į Š, š Ų, ų Ū, ū Ž, ž [1]

[Touch-packages] [Bug 1585886] Re: WiFi indicator icon disappears in Ubuntu 16.04

2016-08-05 Thread Vincas Dargis
No, not do do with Etherenr, but with the fact that WiFi is not used. In other words, WiFi wlan0 interface goes missing after third reboot if it is not used (because I use ethernet instead). Try to disable automatic connection to your home WiFi, disable WiFi in indicator, and then reboot

[Touch-packages] [Bug 1613056] Re: unity8.log spammed: Failed to get current playback position: org.freedesktop.DBus.Error.UnknownMethod: Method "Get" with signature "ss" on interface "org.freedesktop

2016-08-16 Thread Vincas Dargis
Thanks for info, I'll try. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to unity8 in Ubuntu. https://bugs.launchpad.net/bugs/1613056 Title: unity8.log spammed: Failed to get current playback position:

[Touch-packages] [Bug 1435040] Re: Ubuntu Phone does not connect to car-bluetooth

2016-10-06 Thread Vincas Dargis
With OTA13 I cannot even pair with Parrot CK3100. Tried to forget pairing on both sides but it did not help. My BQ E5 shows "unknown" device instead of "Parrot..". pre-OTA13 I could pair, sync contacts, but there was no sound. -- You received this bug notification because you are a member of

[Touch-packages] [Bug 1613056] Re: unity8.log spammed: Failed to get current playback position: org.freedesktop.DBus.Error.UnknownMethod: Method "Get" with signature "ss" on interface "org.freedesktop

2016-08-28 Thread Vincas Dargis
There is one .crash file, though log was not spammed. ** Attachment added: "_usr_bin_media-hub-server.32011.crash" https://bugs.launchpad.net/ubuntu/+source/media-hub/+bug/1613056/+attachment/4729335/+files/_usr_bin_media-hub-server.32011.crash -- You received this bug notification because

[Touch-packages] [Bug 1612367] Re: [Touch] Incoming call gets silent randomly

2016-09-25 Thread Vincas Dargis
I've noticed same issue on BQ E5 on OTA-12 and OTA-13. Sometimes incomming call gets silent after a split second (I can hear a blip of sound). Attaching syslog and unity8.log of that exact minute it happened. There are no lines in media-hub log. ** Attachment added: "syslog"

[Touch-packages] [Bug 1612367] Re: [Touch] Incoming call gets silent randomly

2016-09-25 Thread Vincas Dargis
** Attachment added: "unity8.log" https://bugs.launchpad.net/ubuntu/+source/media-hub/+bug/1612367/+attachment/4748324/+files/unity8.log -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.

[Touch-packages] [Bug 1628956] Re: From v49.0, Firefox needs read access to @{PROC}/net/arp

2016-10-17 Thread Vincas Dargis
Maybe we should ask Firefox devs what they mean by that? net/arp contains rather sensitive info... -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to apparmor in Ubuntu. https://bugs.launchpad.net/bugs/1628956 Title: From

[Touch-packages] [Bug 1435040] Re: Ubuntu Phone does not connect to car-bluetooth

2016-12-10 Thread Vincas Dargis
With OTA-14 I can now pair with Parrot CK3100 again, but there is still no sound (crossed note symbol). -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to bluez in Ubuntu. https://bugs.launchpad.net/bugs/1435040 Title: Ubuntu

[Touch-packages] [Bug 1612367] Re: [Touch] Incoming call gets silent randomly

2016-12-10 Thread Vincas Dargis
With OTA-14 it's still the same - sometimes I can hear ring tone only for split a second (~200ms maybe). I can answer the call and talk normally. Attached yet another syslog (received call at 21:19). ** Attachment added: "syslog"

[Touch-packages] [Bug 1451808] Re: apport-collect error: No module named PyQt5.QtCore

2016-12-17 Thread Vincas Dargis
Any ideas to workaround it? Same problem on Kubuntu 16.04. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to apport in Ubuntu. https://bugs.launchpad.net/bugs/1451808 Title: apport-collect error: No module named PyQt5.QtCore

[Touch-packages] [Bug 1650947] Re: module-equalizer-sink produces cracking at the beginning of playback

2016-12-18 Thread Vincas Dargis
Attached syslog with verbose pulseaudio logs. I was clicking "Make a test sound" on Skype, skipped audio file on SMPlayer etc, so that short sound cracking is produced. ** Attachment added: "syslog"

[Touch-packages] [Bug 1650947] [NEW] module-equalizer-sink produces cracking at the beginning of playback

2016-12-18 Thread Vincas Dargis
Public bug reported: After upgrade from Kubuntu 14.04 to Kubuntu 16.04 (amd64), audio playback contains cracking, especially noticeable when sound/video file is seeked (on SMplayer, Youtube on Firefox), or new notification sound plays in IM clients (in Skype, qTox, ...). Usually cracking stops

[Touch-packages] [Bug 1703649] Re: Traceroute needs net_admin capability for unknown reason

2017-07-12 Thread Vincas Dargis
Added systemd because: # apt-cache show libnss-resolve | fgrep Source Source: systemd -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to systemd in Ubuntu. https://bugs.launchpad.net/bugs/1703649 Title: Traceroute needs

[Touch-packages] [Bug 1703649] Re: Traceroute needs net_admin capability for unknown reason

2017-07-12 Thread Vincas Dargis
Looks like culprit is libnss_resonve.so. First of all, to reproduce, I have to use hostname like google.com. If I give traceroute an IP address, there are no setsockopt calls that needs net_admin cap. Here's gdb log, breakpointed on setsockopt, dumped registers (you can see rdx set to "33" so

[Touch-packages] [Bug 1703649] Re: Traceroute needs net_admin capability for unknown reason

2017-08-09 Thread Vincas Dargis
How could I get comment from Systemd maintainers..? -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to systemd in Ubuntu. https://bugs.launchpad.net/bugs/1703649 Title: Traceroute needs net_admin capability for unknown reason

[Touch-packages] [Bug 1628956] Re: From v49.0, Firefox needs read access to @{PROC}/net/arp

2017-05-15 Thread Vincas Dargis
I've tried patched version from 1659988, it works fine. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to apparmor in Ubuntu. https://bugs.launchpad.net/bugs/1628956 Title: From v49.0, Firefox needs read access to

[Touch-packages] [Bug 1505220] Re: multiple apps crashing at launch

2017-05-20 Thread Vincas Dargis
For me, removing /home/phablet/.cache/QML/Apps/webbrowser-app helped. If I return backup contents, browser crashes again. I could send webbrowser-app.tar.gz for investigation. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to

[Touch-packages] [Bug 1505220] Re: multiple apps crashing at launch

2017-05-20 Thread Vincas Dargis
In my case it's E5 with OTA-15. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to webbrowser-app in Ubuntu. https://bugs.launchpad.net/bugs/1505220 Title: multiple apps crashing at launch Status in Canonical System Image:

[Touch-packages] [Bug 1117804] Re: ausearch doesn't show AppArmor denial messages

2017-06-06 Thread Vincas Dargis
I have asked about it in audit mailing list [0], and Audit developer said that AppArmor should use assigned event numbers in right way, or something like that.. [0] https://www.redhat.com/archives/linux-audit/2016-April/msg00129.html -- You received this bug notification because you are a

[Touch-packages] [Bug 1045985] Re: support environment filtering

2017-09-11 Thread Vincas Dargis
This bug is rather old. Is there a progress in this? Is it relevant on latest AppArmor? -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to apparmor in Ubuntu. https://bugs.launchpad.net/bugs/1045985 Title: support environment

[Touch-packages] [Bug 1717714] Re: @{pid} variable broken on systems with pid_max more than 6 digits

2017-09-25 Thread Vincas Dargis
I can provide merge request, and I would like to suggest simplifying that ever-growing expression. Couldn't it be just [0-9]*? Are there possibility that `/proc` will have some item, starting with digit, *not* being a pid? -- You received this bug notification because you are a member of Ubuntu

[Touch-packages] [Bug 1717714] Re: @{pid} variable broken on systems with pid_max more than 6 digits

2017-09-30 Thread Vincas Dargis
OK, so if http://man7.org/linux/man-pages/man5/proc.5.html says: ``` On 64-bit systems, pid_max can be set to any value up to 2^22 (PID_MAX_LIMIT, approximately 4 million). `` Its 4194304, so I will propose adding one more bulk of expressions for seven-digit PID, stating with [1-4]. -- You

[Touch-packages] [Bug 1717714] Re: @{pid} variable broken on systems with pid_max more than 6 digits

2017-09-30 Thread Vincas Dargis
** Branch linked: lp:~talkless/apparmor/seven_digit_pid -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to apparmor in Ubuntu. https://bugs.launchpad.net/bugs/1717714 Title: @{pid} variable broken on systems with pid_max more

[Touch-packages] [Bug 1117804] Re: ausearch doesn't show AppArmor denial messages

2017-09-03 Thread Vincas Dargis
IMHO we have to ask John Johansen about this, he's working on kernel side. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to audit in Ubuntu. https://bugs.launchpad.net/bugs/1117804 Title: ausearch doesn't show AppArmor

[Touch-packages] [Bug 1331856] Re: apparmor-utils don't work when defining a variable on

2017-12-05 Thread Vincas Dargis
I believe I got similar issue while experimenting with Thunderbird profile patch [0] to use `local/tunables/usr.bin.thunderbird` as extension point. aa-* tools does now like that: ``` vincas@debian-sid:~$ sudo aa-enforce /etc/apparmor.d/* ERROR: Values added to a non-existing variable

[Touch-packages] [Bug 1042771] Re: sanitized_helper prevents proper transition to other profiles

2017-10-31 Thread Vincas Dargis
Or simply PCx -> sanitized_helper ? It would be a little better if thunderbird/firefox used xdg-open, instead opening directly: xdg-open Cxr -> sanitized_helper, Although it does not control what xdg-open itself can launch. For example, Dragon player launches browser (for http://) or email

Re: [Touch-packages] [Bug 1331856] Re: apparmor-utils don't work when defining a variable on

2018-01-07 Thread Vincas Dargis
On 2018-01-07 17:33, intrigeri wrote: > Vincas, do you want to test the proposed patch? Yeah, I could try that within next week. -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to apparmor in Ubuntu.

[Touch-packages] [Bug 1331856] Re: apparmor-utils don't work when defining a variable on

2018-01-10 Thread Vincas Dargis
Hm, Ubuntu 18.04 Daily has only apparmor 2.11.0-2ubuntu8 (I was expecting it would already have 2.12 for some reason). Should I try (somehow) to build apparmor-utils package using 2.12 source? Not sure what's the best way to test latest against latest AppArmor. -- You received this bug

[Touch-packages] [Bug 1331856] Re: apparmor-utils don't work when defining a variable on

2018-01-16 Thread Vincas Dargis
Seems that this patch is quite outdated: vincas@debian-sid:/tmp/apparmor-2.12$ patch -p1 < /home/vincas/Downloads/python-utils-var-append-in-include-support.patch patching file utils/apparmor/aa.py Hunk #1 FAILED at 2636. Hunk #2 FAILED at 2836. Hunk #3 FAILED at 2979. Hunk #4 FAILED at 2987.

[Touch-packages] [Bug 1331856] Re: apparmor-utils don't work when defining a variable on

2019-04-13 Thread Vincas Dargis
Uhm I get same error even if variable is introduced in /etc/apparmor.d/tunables/: ``` $ cat /etc/apparmor.d/tunables/usr.bin.qtox | head -n1 @{qtox_prefix} = /usr /usr/local ``` Adding local customisation: ``` $ cat /etc/apparmor.d/tunables/usr.bin.qtox.d/local @{qtox_prefix} += /tmp/qtox ```

[Touch-packages] [Bug 1331856] Re: apparmor-utils don't work when defining a variable on

2020-06-02 Thread Vincas Dargis
Thank you Christian! -- You received this bug notification because you are a member of Ubuntu Touch seeded packages, which is subscribed to apparmor in Ubuntu. https://bugs.launchpad.net/bugs/1331856 Title: apparmor-utils don't work when defining a variable on Status in AppArmor: Fix