[Touch-packages] [Bug 2060615] Re: [noble] two versions of perl-modules are published, breaking debootstrap

2024-04-08 Thread Martin Pitt
Aside from curl this can be reproduced most quickly with

  sudo /usr/sbin/debootstrap --include=build-essential noble /tmp/n
http://archive.ubuntu.com/ubuntu

Errors were encountered while processing:
 perl
 libdpkg-perl
 libperl5.38t64:amd64
 dpkg-dev
 build-essential

These are all ultimately due to

dpkg: dependency problems prevent configuration of perl:
 perl depends on perl-modules-5.38 (>= 5.38.2-3.2build2); however:
  Version of perl-modules-5.38 on system is 5.38.2-3.

dpkg: error processing package perl (--configure):
 dependency problems - leaving unconfigured


** Tags added: debootstrap noble

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to perl in Ubuntu.
https://bugs.launchpad.net/bugs/2060615

Title:
  [noble] two versions of perl-modules are published, breaking
  pbuilder/debootstrap

Status in perl package in Ubuntu:
  New
Status in perl source package in Noble:
  New

Bug description:
  For the last two weeks, building noble VM images for our CI has been
  broken. Most of it was uninstallability due to the xz reset, but for
  the last three days, `pbuilder --create` has failed [2] because it
  gets perl and perl-modules-5.38 in two different versions:

  2024-04-08 08:47:08 
URL:http://archive.ubuntu.com/ubuntu/pool/main/p/perl/perl-base_5.38.2-3.2build2_amd64.deb
 [1822564/1822564] -> 
"/var/cache/pbuilder/aptcache//perl-base_5.38.2-3.2build2_amd64.deb" [1]
  2024-04-08 08:47:09 
URL:http://archive.ubuntu.com/ubuntu/pool/main/p/perl/perl-modules-5.38_5.38.2-3_all.deb
 [3110080/3110080] -> 
"/var/cache/pbuilder/aptcache//perl-modules-5.38_5.38.2-3_all.deb" [1]

  and then trying to configure the packages blows up. The root cause is
  that perl-modules has *two* versions published:


  # curl -s 
http://archive.ubuntu.com/ubuntu/dists/noble/main/binary-amd64/Packages.xz|xzgrep
 -A5 'Package: perl-modules-'
  Package: perl-modules-5.38
  Architecture: all
  Version: 5.38.2-3.2build2
  Multi-Arch: foreign
  Priority: optional
  Build-Essential: yes
  --
  Package: perl-modules-5.38
  Architecture: all
  Version: 5.38.2-3
  Multi-Arch: foreign
  Priority: optional
  Build-Essential: yes

  While apt is clever enough to pick the right one, debootstrap isn't.
  Can you please remove the old perl-modules-5.38 5.38.2-3 from noble?

  Thanks!

  
  [1] https://github.com/cockpit-project/bots/issues/6147
  [2] 
https://cockpit-logs.us-east-1.linodeobjects.com/image-refresh-ubuntu-stable-02cafde3-20240407-074108/log.html

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/perl/+bug/2060615/+subscriptions


-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 2060615] Re: [noble] two versions of perl-modules are published, breaking debootstrap

2024-04-08 Thread Martin Pitt
I wonder where that comes from --
https://launchpad.net/ubuntu/+source/perl/+publishinghistory says that
5.38.2-3 was deleted, but only from noble-updates. In noble proper it is
merely "superseded". https://launchpad.net/ubuntu/+source/perl/5.38.2-3
doesn't show it being published anyway, and it's not in https://ubuntu-
archive-team.ubuntu.com/nbs.html either.

** Summary changed:

- [noble] two versions of perl-modules are published, breaking debootstrap
+ [noble] two versions of perl-modules are published, breaking 
pbuilder/debootstrap

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to perl in Ubuntu.
https://bugs.launchpad.net/bugs/2060615

Title:
  [noble] two versions of perl-modules are published, breaking
  pbuilder/debootstrap

Status in perl package in Ubuntu:
  New
Status in perl source package in Noble:
  New

Bug description:
  For the last two weeks, building noble VM images for our CI has been
  broken. Most of it was uninstallability due to the xz reset, but for
  the last three days, `pbuilder --create` has failed [2] because it
  gets perl and perl-modules-5.38 in two different versions:

  2024-04-08 08:47:08 
URL:http://archive.ubuntu.com/ubuntu/pool/main/p/perl/perl-base_5.38.2-3.2build2_amd64.deb
 [1822564/1822564] -> 
"/var/cache/pbuilder/aptcache//perl-base_5.38.2-3.2build2_amd64.deb" [1]
  2024-04-08 08:47:09 
URL:http://archive.ubuntu.com/ubuntu/pool/main/p/perl/perl-modules-5.38_5.38.2-3_all.deb
 [3110080/3110080] -> 
"/var/cache/pbuilder/aptcache//perl-modules-5.38_5.38.2-3_all.deb" [1]

  and then trying to configure the packages blows up. The root cause is
  that perl-modules has *two* versions published:


  # curl -s 
http://archive.ubuntu.com/ubuntu/dists/noble/main/binary-amd64/Packages.xz|xzgrep
 -A5 'Package: perl-modules-'
  Package: perl-modules-5.38
  Architecture: all
  Version: 5.38.2-3.2build2
  Multi-Arch: foreign
  Priority: optional
  Build-Essential: yes
  --
  Package: perl-modules-5.38
  Architecture: all
  Version: 5.38.2-3
  Multi-Arch: foreign
  Priority: optional
  Build-Essential: yes

  While apt is clever enough to pick the right one, debootstrap isn't.
  Can you please remove the old perl-modules-5.38 5.38.2-3 from noble?

  Thanks!

  
  [1] https://github.com/cockpit-project/bots/issues/6147
  [2] 
https://cockpit-logs.us-east-1.linodeobjects.com/image-refresh-ubuntu-stable-02cafde3-20240407-074108/log.html

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/perl/+bug/2060615/+subscriptions


-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp