Re: [RDB DAS] Consistent use of Parameters in Config

2007-09-03 Thread Amita Vadhavkar
I agree, it is the right time to remove this backward compatibility, as in future , it can add to more confusion. I am chaning the patch for this. ( i.e. removing List and any related methods). Please give any other review comments. Regards, Amita On 9/3/07, Adriano Crestani [EMAIL PROTECTED]

Re: [RDB DAS] Consistent use of Parameters in Config

2007-09-02 Thread Adriano Crestani
Hi everyone, I wonder if it is really necessary to keep the back compatibility keeping the List attribute, once the Tuscany DAS Java is still in beta phase of develpment. What do you think? Regards, Adriano Crestani On 8/30/07, Amita Vadhavkar [EMAIL PROTECTED] wrote: Thanks Kevin, for

Re: [RDB DAS] Consistent use of Parameters in Config

2007-08-30 Thread Amita Vadhavkar
Thanks Kevin, for correcting the example, I actually meant what you have assumed :) Also, another question in JDK5 context, the code will be very precise and type checking/assumptions about types can be avoided in many places in DAS using JDK5 generics. Other features from JDK5 can be used too.

Re: [RDB DAS] Consistent use of Parameters in Config

2007-08-29 Thread Amita Vadhavkar
Below is one of the use cases where user will get some benefit:- USE CASE: bigtable{col1, col2,col50} SIMPLEST CLIENT CODE: WITH NAMED PARAM SUPPORT Command insertAdhoc = das.createCommand(insert into bigtable values (?, ?, ?...50 times)); insertAdhoc.setParameter(ID, new Integer(6));

Re: [RDB DAS] Consistent use of Parameters in Config

2007-08-03 Thread Adriano Crestani
I agree with Amita that for clarity is better to let the user set the parameter name, for all those reasons she has argued on this thread so far. But, I don't I agree with to use the [1] instead of [2], because it's not a good practice to define the parameter names on only one string separated by

Re: [RDB DAS] Consistent use of Parameters in Config

2007-08-02 Thread Amita Vadhavkar
JPQL, Hibernate ,... have support for named parameters. Why is RDB DAS going in the other way? If there is a reason for switching off named parameters, please elaborate, else is it OK to go for JIRA-1462? Regards, Amita On 7/13/07, Amita Vadhavkar [EMAIL PROTECTED] wrote: I went through [1]

Re: [RDB DAS] Consistent use of Parameters in Config

2007-07-13 Thread Amita Vadhavkar
I went through [1] and [2], it talks about removing name attribute from Parameter and about generatedKeys. Also saw JIRA-528 on the way. But I could not get the exact rational behind removing Name from Parameter (It is definitely not required by JDBC for sure, but can have some aid in usage

[RDB DAS] Consistent use of Parameters in Config

2007-07-12 Thread Amita Vadhavkar
Hi, A few days ago there was a user question about passing name in Parameter:- http://www.mail-archive.com/tuscany-dev@ws.apache.org/msg19339.html When checking how Parameters are used in Config, came across the following points. There is a difference in Config (SDO) generated Parameter and

Re: [RDB DAS] Consistent use of Parameters in Config

2007-07-12 Thread Luciano Resende
The named parameter support was removed from earlier versions of DAS, here is some previous discussion around the subject [1] See also tuscany-658. We might need to do further cleanup on the impl, if I understood correctly. As for your second suggestion (parameter column types), could you expose