Re: [U-Boot] [PATCH v2] MPC8260: fixup device tree by property instead of path

2009-05-13 Thread Heiko Schocher
Hello Wolfgang, Wolfgang Denk wrote: cpu/mpc8260/cpu.c used to use do_fixup_by_path_u32() to update the clock frequencies in the device tree, using a CPU path /cpus/OF_CPU, with OF_CPU beind defined in the board config file. However, this does not work when one board config file (here:

Re: [U-Boot] [PATCHv2 3/4] omap3: replace all instances of gpmc config struct by one global

2009-05-13 Thread Jean-Christophe PLAGNIOL-VILLARD
On 07:26 Wed 13 May , Wolfgang Denk wrote: Dear Jean-Christophe PLAGNIOL-VILLARD, In message 20090512230224.gl...@game.jcrosoft.org you wrote: diff --git a/cpu/arm_cortexa8/omap3/mem.c b/cpu/arm_cortexa8/omap3/mem.c index aa15f94..079c848 100644 --- a/cpu/arm_cortexa8/omap3/mem.c

Re: [U-Boot] [PATCHv2 1/4] omap3: embedd gpmc_cs into gpmc config struct

2009-05-13 Thread Matthias Ludwig
Dear Jean-Christophe, Attention: this also fixes a missnaming in board/omap3/evm/evm.c which told to use CS6 but used CS5 in reallity. More info on http://lists.denx.de/pipermail/u-boot/2009-May/052157.html it will be better to split this in 2 patch to bisect it but how to split? I do

Re: [U-Boot] [PATCHv2 2/4] omap3: remove typedefs for configuration structs

2009-05-13 Thread Matthias Ludwig
} sdrc_cs_t; please remove too } sdrc_actim_t; please remove too this like i'm missen those :( will be fixed #ifndef __ASSEMBLY__ -typedef enum { +enum { STACKED = 0, IP_DDR = 1, COMBO_DDR = 2, IP_SDR = 3, -} mem_t; +}; it will be better to use the

Re: [U-Boot] [PATCH] arm/imx31_phycore: Fix bi_arch_number

2009-05-13 Thread Jean-Christophe PLAGNIOL-VILLARD
On 07:28 Wed 13 May , Wolfgang Denk wrote: Dear Jean-Christophe PLAGNIOL-VILLARD, In message 20090512231236.gn...@game.jcrosoft.org you wrote: Sascha ping? What are you waiting for? Isn't the patch obvious? the ack from the board Maintainer which is Sascha For such

Re: [U-Boot] [PATCHv2 4/4] omap3: use only fixed-size types inside ctrl_structs

2009-05-13 Thread Matthias Ludwig
replace variable types in ctrl_structs for omap3 by those with fixed size (u8, u16, u32). Additional ifndef-protection is needed by examples which do not compile when including asm/types.h could explain why and in which case we need it? Explain why transfor to fixed-size-types or explain

Re: [U-Boot] [PATCHv2 1/4] omap3: embedd gpmc_cs into gpmc config struct

2009-05-13 Thread Jean-Christophe PLAGNIOL-VILLARD
On 09:16 Wed 13 May , Matthias Ludwig wrote: Dear Jean-Christophe, Attention: this also fixes a missnaming in board/omap3/evm/evm.c which told to use CS6 but used CS5 in reallity. More info on http://lists.denx.de/pipermail/u-boot/2009-May/052157.html it will be better to split

[U-Boot] Congratulations

2009-05-13 Thread giseles
Confirm receipt by contacting the process unit officer Herald claim your £1,000,000GBP E-mail:phun...@btinternet.com Fill the details:Name,Add,Tel.Yours Ms.Caroline ___ U-Boot mailing list U-Boot@lists.denx.de

Re: [U-Boot] [PATCH 1/4] net: extend the netdev to have a common way to set the hw mac address

2009-05-13 Thread Detlev Zundel
Hi Scott, On Tue, May 12, 2009 at 10:48:28AM +0200, Detlev Zundel wrote: Can you please explain to me, why you think it to be reasonable to demand providing an initramfs in the order of 100s of k to set an attribute of a hardware device which has its own driver? Kind of defeats any

Re: [U-Boot] [PATCH 1/4] net: extend the netdev to have a common way to set the hw mac address

2009-05-13 Thread Detlev Zundel
Hi Mike, I never ran across this outside of linux arm where people seriously repeat the statement over and over that a whole initramfs with an initial userspace and a pivot_root is plausible for nfs root whilst patches of a few lines float around doing the same in the kernel. i never said

Re: [U-Boot] [PATCH] lib_arch/board.c: Move malloc initialization before flash_init()

2009-05-13 Thread Detlev Zundel
Hi Stefan, On Tuesday 12 May 2009 22:09:11 Kim Phillips wrote: Signed-off-by: Stefan Roese s...@denx.de Cc: Wolfgang Denk w...@denx.de Cc: Mike Frysinger vap...@gentoo.org Cc: Scott McNutt smcn...@psyent.com Cc: Shinya Kuribayashi shinya.kuribaya...@necel.com Cc: Nobuhiro Iwamatsu

Re: [U-Boot] [PATCH v2] MPC8260: fixup device tree by property instead of path

2009-05-13 Thread Detlev Zundel
Hi Heiko, Acked-by: Heiko Schocherh...@denx.de Apart from fixing the inverse whitespace problemn, am I correct that strictly speaking we should now also add the following? Tested-by: Heiko Schocher h...@denx.de Cheers Detlev -- To summarize: It is a well known and lamented fact that

Re: [U-Boot] [PATCH] powerpc/inka4x0: Remove left-over ide reset code.

2009-05-13 Thread Detlev Zundel
Hi Grant, realizing that I forgot to CC you on the original mail[1], I now formally ask you to pull the patch into your repo as it fixes a real bug. Thanks Detlev [1] http://article.gmane.org/gmane.comp.boot-loaders.u-boot/59148 The pin which was used in preliminary versions of the board

Re: [U-Boot] onenand bad block handling

2009-05-13 Thread Geiger Ho
Hi Sharma-san, If I use u-boot to write kernel image to onenand that the kernel image across bad blocks, will u-boot able to skip blocks during read and successfully boot up the kernel? Also, same case for rootfs, if I write JFFS2 format rootfs to onenand using u-boot, how does the kernel

Re: [U-Boot] Timeout in tftp.c

2009-05-13 Thread Achim Ehrlich
Jens Gehrlein schrieb: Wolfgang Denk schrieb: Dear Achim Ehrlich, In message 4a0969fc.2060...@taskit.de you wrote: The timeout for lost packages in tftp.c is defined to 5000 msecs. But when setting the timeout get_timer(0) is called in NetSetTimeout in net.c. But on AT91 the timer code

Re: [U-Boot] Timeout in tftp.c

2009-05-13 Thread Jean-Christophe PLAGNIOL-VILLARD
On 13:37 Wed 13 May , Achim Ehrlich wrote: Jens Gehrlein schrieb: Wolfgang Denk schrieb: Dear Achim Ehrlich, In message 4a0969fc.2060...@taskit.de you wrote: The timeout for lost packages in tftp.c is defined to 5000 msecs. But when setting the timeout get_timer(0) is called in

[U-Boot] LCD issue

2009-05-13 Thread yanfeng qin
Hi guys, I try to add LCD driver in U-boot. LCD displays many vertical lines in different colors. Is it anyone has experience in LCD? Yan Feng ___ U-Boot mailing list U-Boot@lists.denx.de http://lists.denx.de/mailman/listinfo/u-boot

Re: [U-Boot] [PATCH] powerpc/inka4x0: Remove left-over ide reset code.

2009-05-13 Thread Grant Likely
On Wed, May 13, 2009 at 3:30 AM, Detlev Zundel d...@denx.de wrote: Hi Grant, realizing that I forgot to CC you on the original mail[1], I now formally ask you to pull the patch into your repo as it fixes a real bug. Hi Detlev, I'm not the u-boot mpc5xxx maintainer anymore. I didn't have

Re: [U-Boot] [PATCH] common/cmd_ide.c: Coding style cleanup (Lindent)

2009-05-13 Thread Stefan Roese
Hi Wolfgang, On Wednesday 13 May 2009 13:32:08 Wolfgang Denk wrote: Not sure if this patch will be accepted. It's probably not so easy to understand the history of changes in this file with this coding style cleanup. But the current condition is so bad that I think it's worth the change.

Re: [U-Boot] [PATCH] common/cmd_ide.c: Coding style cleanup (Lindent)

2009-05-13 Thread Wolfgang Denk
Dear Stefan Roese, In message 200905131620.39726...@denx.de you wrote: -static void ide_ident (block_dev_desc_t *dev_desc); -static uchar ide_wait (int dev, ulong t); +static void ide_ident(block_dev_desc_t * dev_desc); And I really hate the space after the '*' in lines like

[U-Boot] [PATCH] ARM DaVinci Leopard Board Support

2009-05-13 Thread s-paulraj
The patch applies to arm/next. It was tested on a leopard board. After testing had to change the MACH TYPE as this board is not present in the list of mach types at the moment. So the patch itself is going to give a compilation failure. Further details on this board can be found at

Re: [U-Boot] [PATCH] powerpc/inka4x0: Remove left-over ide reset code.

2009-05-13 Thread Detlev Zundel
Hi Grant, I'm not the u-boot mpc5xxx maintainer anymore. I didn't have time to keep up with it. John Rigby is the current maintainer. Argh, my fault, I should have known better. Sorry for the noise. Cheers Detlev -- #define KSAMTIB_CIGAM_2SFFJ 0x8519 /* For detecting wrong-endian fs */

Re: [U-Boot] [PATCH] lib_arch/board.c: Move malloc initialization before flash_init()

2009-05-13 Thread Kim Phillips
On Wed, 13 May 2009 00:58:06 -0400 Mike Frysinger vap...@gentoo.org wrote: On Wednesday 13 May 2009 00:20:52 Stefan Roese wrote: On Tuesday 12 May 2009 22:09:11 Kim Phillips wrote: Signed-off-by: Stefan Roese s...@denx.de Cc: Wolfgang Denk w...@denx.de Cc: Mike Frysinger

Re: [U-Boot] [PATCH v2] MPC8260: fixup device tree by property instead of path

2009-05-13 Thread Heiko Schocher
Hello Detlev, Detlev Zundel wrote: Acked-by: Heiko Schocherh...@denx.de Apart from fixing the inverse whitespace problemn, am I correct that strictly speaking we should now also add the following? Tested-by: Heiko Schocher h...@denx.de Ah, you are right. bye Heiko -- DENX Software

Re: [U-Boot] [PATCH 1/4] net: extend the netdev to have a common way to set the hw mac address

2009-05-13 Thread Mike Frysinger
On Wednesday 13 May 2009 04:41:29 Detlev Zundel wrote: I never ran across this outside of linux arm where people seriously repeat the statement over and over that a whole initramfs with an initial userspace and a pivot_root is plausible for nfs root whilst patches of a few lines float

[U-Boot] [PATCH V3] arm: timer and interrupt init rework

2009-05-13 Thread Jean-Christophe PLAGNIOL-VILLARD
actually the timer init use the interrupt_init as init callback which make the interrupt and timer implementation difficult to follow so now rename it as int timer_init(void) and use interrupt_init for interrupt btw also remane the corresponding file to the functionnality implemented as ixp

[U-Boot] [PATCH 1/1] api: remove un-needed ifdef CONFIG_API already handle by the Makefile

2009-05-13 Thread Jean-Christophe PLAGNIOL-VILLARD
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD plagn...@jcrosoft.com --- api/api.c |5 - api/api_net.c |5 - api/api_platform-arm.c |3 --- api/api_platform-ppc.c |5 - api/api_storage.c |5 - 5 files changed, 0 insertions(+), 23

[U-Boot] [PATCH 1/4 v4] console.h: remove unused prototype 'console_realloc'

2009-05-13 Thread Jean-Christophe PLAGNIOL-VILLARD
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD plagn...@jcrosoft.com --- V4 update commit message as ask by Wolfgang include/console.h |2 -- 1 files changed, 0 insertions(+), 2 deletions(-) diff --git a/include/console.h b/include/console.h index 06ec32a..bc8b139 100644 ---

[U-Boot] [PATCH 3/4 v4] console: unify printing current devices

2009-05-13 Thread Jean-Christophe PLAGNIOL-VILLARD
create stdio_print_current_devices() for this purpose Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD plagn...@jcrosoft.com --- V4 split in 2 commits and remove an other duplicate block as ask by Wolfgang common/console.c| 75 +++---

[U-Boot] [PATCH 2/4 v4] stdio/device: rework function naming convention

2009-05-13 Thread Jean-Christophe PLAGNIOL-VILLARD
actually the console API use the following naming convention ==Extract== typedef struct device_t; int device_register (device_t * dev); int devices_init (void); int device_deregister(char *devname); struct list_head* device_get_list(void); device_t* device_get_by_name(char*

[U-Boot] [PATCH 4/4 v4] mpl: printing current stdio devices cleanup

2009-05-13 Thread Jean-Christophe PLAGNIOL-VILLARD
curently the mpl's boards duplicate the printing current devices from common/console.c use stdio_print_current_devices() instead Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD plagn...@jcrosoft.com --- V4 split in 2 commits as ask by Wolfgang board/mpl/common/common_util.c | 30

Re: [U-Boot] [PATCH 05/10] mxc-mmc: sdhc host driver for MX2 and MX3 proccessor

2009-05-13 Thread alfred steele
On Wed, May 6, 2009 at 1:30 PM, Ilya Yanok ya...@emcraft.com wrote: This is a port of Linux driver for SDHC host controller hardware found on Freescale's MX2 and MX3 processors. Would this work asis on the MX31 uboot. I tried making the code work on the MX31 with minor mods ( on some registers).

[U-Boot] [PATCH] at91: regroup IP hw init in one cpu file per soc

2009-05-13 Thread Jean-Christophe PLAGNIOL-VILLARD
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD plagn...@jcrosoft.com --- cpu/arm926ejs/at91/Makefile| 35 +--- cpu/arm926ejs/at91/at91cap9_devices.c | 176 +++ cpu/arm926ejs/at91/at91cap9_macb.c | 54 --

Re: [U-Boot] [PATCH 01/10] mx27: basic cpu support

2009-05-13 Thread Ilya Yanok
Hi Wolfgang, Wolfgang Denk wrote: +static ulong clk_in_26m(void) +{ +if (CSCR CSCR_OSC26M_DIV1P5) { +/* divide by 1.5 */ +return 2600 / 1.5; We definitely do not allow any FP use in U-Boot. This will be actually converted to an integer at the

[U-Boot] [RFC PATCH 1/2] sh: make lds more generic

2009-05-13 Thread Jean-Christophe PLAGNIOL-VILLARD
currently the sh lds need to sync the lds enty and TEXT_BASE manualy and the reloc_dst is based on it instead provide it now from the ldflags tested on r2dplus Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD plagn...@jcrosoft.com Cc: Nobuhiro Iwamatsu iwamatsu.nobuh...@renesas.com ---

[U-Boot] [RFC PATCH 2/2] sh: unify lds

2009-05-13 Thread Jean-Christophe PLAGNIOL-VILLARD
all sh boards use the same cpu lds so move it to cpu/$(CPU) that could be overwrite in following order SOC BOARD via the corresponding config.mk tested on r2dplus Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD plagn...@jcrosoft.com Cc: Nobuhiro Iwamatsu iwamatsu.nobuh...@renesas.com ---

[U-Boot] [PATCH v5] mtd: nand: new base driver for memory mapped nand devices

2009-05-13 Thread Mike Frysinger
The BF537-STAMP Blackfin board had a driver for working with NAND devices that are simply memory mapped. Since there is nothing Blackfin specific about this, generalize the driver a bit so that everyone can leverage it. Signed-off-by: Mike Frysinger vap...@gentoo.org Signed-off-by: Scott Wood

[U-Boot] map mtd partitions address for TWO NOR flash

2009-05-13 Thread H. Johnny
Hi guys: I have a mpc8313erbd (powerpc arch) demo board. There are one NOR flash and one NAND flash on board. The drivers/mtd/map/mpc8313erbd.c do address map for NOR flash. I want to add another NOR flash and take off the NAND flash. So there are two NOR flash on board. I am trying to do

[U-Boot] [PATCH] cmd_ide: Fix detection problem with missing devices

2009-05-13 Thread Stefan Roese
Currently only IDE busses are probed and all possible available devices are listed in the IDE bootup log. Even when devices on the bus are not available. This leads to the following output on the CPCI750: IDE: Bus 0: OK Bus 1: OK Device 0: Model: HITACHI_DK23FA-20J Firm: 00M7A0A0 Ser#: 42D182

[U-Boot] [PATCH] 74xx_7xx: Fix rounding problem in CPU frequency calculation

2009-05-13 Thread Stefan Roese
This patch fixes a problem in the CPU frequency calculation. Without it a 798MHz CPU is displayed as 368.503 MHz. And with it it's 798 MHz. Signed-off-by: Stefan Roese s...@denx.de --- cpu/74xx_7xx/speed.c |4 ++-- 1 files changed, 2 insertions(+), 2 deletions(-) diff --git

[U-Boot] [PATCH] video: ct6900: Add an option to skip video initialization

2009-05-13 Thread Stefan Roese
This patch adds an option to skip the video initialization on the ct6900. This is needed for the CPCI750 which can be built as CPCI host and adapter/target board. And the adapter board can't access the video cards. Signed-off-by: Stefan Roese s...@denx.de Cc: Anatolij Gustschin ag...@denx.de ---

[U-Boot] [PATCH] 74xx_7xx: Add CPCI adapter/target support for the CPCI750

2009-05-13 Thread Stefan Roese
The CPCI750 can be built as CPCI host or adapter/target board. This patch adds support for runtime detection of those variants. Signed-off-by: Stefan Roese s...@denx.de Cc: Reinhard Arlt reinhard.a...@esd-electronics.com --- board/esd/cpci750/cpci750.c | 108