[U-Boot] drivers/net/enc28j60.c - generalisation, how?

2010-07-24 Thread Reinhard Meyer
Hello, I would like to generalize that driver and make it also CONFIG_NET_MULTI-able. Currently it contains hard coded functionality for the LPC2292 Cpu and is used by only two boards: lpc2292sodimm and SMN42. Since the driver could be clearly generic, using just SPI and two I/O Pins for

[U-Boot] [PATCH 3/4] Blackfin: jtag-console: add debug markers

2010-07-24 Thread Mike Frysinger
While we're in here, add some useful debug points. We need custom debug statements because we need the output to only go to the serial port. If we used the standard debug helpers, the output would also go to the stdout (which would be the jtag console) and make it hard to figure out what is

[U-Boot] [PATCH 1/4] Blackfin: jtagconsole: disable output processing

2010-07-24 Thread Mike Frysinger
Avoid extra carriage returns in the output by disabling output processing. Otherwise, whenever the remote sends a \r\n, we end up with \r\r\n. Reported-by: Vivi Li vivi...@analog.com Signed-off-by: Mike Frysinger vap...@gentoo.org --- tools/jtagconsole |4 ++-- 1 files changed, 2

[U-Boot] [PATCH 4/4] Blackfin: jtag-console: handle newline stuffing

2010-07-24 Thread Mike Frysinger
Serial devices currently have to manually stuff \r after every \n found, but this is a bit more difficult with the jtag console since we process everything in chunks of 4 bit. So we have to scan stuff the whole string rather than what most serial drivers do which is output on a byte per byte

[U-Boot] [PATCH 2/4] Blackfin: jtag-console: robustify against missing peer

2010-07-24 Thread Mike Frysinger
If the other side isn't listening, we should reset the state to ignore the whole message and not just the part we missed. This makes it easier to connect at any time to the jtag console without worrying about the two sides getting out of sync and thus sending garbage back and forth.

Re: [U-Boot] drivers/net/enc28j60.c - generalisation, how?

2010-07-24 Thread Wolfgang Denk
Dear Reinhard Meyer, In message 4c4a8404.6030...@emk-elektronik.de you wrote: I would like to generalize that driver and make it also CONFIG_NET_MULTI-able. ... When I do that, clearly I cannot test the two above boards for continued functionality. Messing up the driver with #ifdefs to

Re: [U-Boot] Please pull u-boot-mpc85xx.git

2010-07-24 Thread Wolfgang Denk
Dear Kumar Gala, In message pine.lnx.4.64.1007210044340.19...@localhost.localdomain you wrote: The following changes since commit 1f82ff4777f360e92aa37bbbed647f7b9d9d2044: Wolfgang Denk (1): Merge branch 'master' of git://git.denx.de/u-boot-video are available in the git

Re: [U-Boot] Please pull u-boot-ppc4xx/master

2010-07-24 Thread Wolfgang Denk
Dear Stefan Roese, In message 201007231026.53803...@denx.de you wrote: The following changes since commit 1f82ff4777f360e92aa37bbbed647f7b9d9d2044: Merge branch 'master' of git://git.denx.de/u-boot-video (2010-07-17 20:49:59 +0200) are available in the git repository at:

Re: [U-Boot] Pull request: u-boot-i2c

2010-07-24 Thread Wolfgang Denk
Dear Heiko Schocher, In message 4c4a7fc9.6030...@denx.de you wrote: please pull from u-boot-i2c The following changes since commit 1f82ff4777f360e92aa37bbbed647f7b9d9d2044: Wolfgang Denk (1): Merge branch 'master' of git://git.denx.de/u-boot-video are available in the git

Re: [U-Boot] [PATCH] cmd_usage(): simplify return code handling

2010-07-24 Thread Wolfgang Denk
Dear Wolfgang Denk, In message 1279321564-19845-1-git-send-email...@denx.de you wrote: Lots of code use this construct: cmd_usage(cmdtp); return 1; Change cmd_usage() let it return 1 - then we can replace all these ocurrances by return cmd_usage(cmdtp); This fixes

Re: [U-Boot] [PATCH 1/5] usb_storage.c: initialize device type

2010-07-24 Thread Wolfgang Denk
Dear Wolfgang Denk, In message 1279532220-5848-2-git-send-email...@denx.de you wrote: The device type was left uninitialized which caused later tests against DEV_TYPE_UNKNOWN to fail. In the result, usb part would attempt to print information about non-existent devices like this: =

Re: [U-Boot] [PATCH 2/5] FAT32: fix support for superfloppy-format (PBR)

2010-07-24 Thread Wolfgang Denk
Dear Wolfgang Denk, In message 1279532220-5848-3-git-send-email...@denx.de you wrote: Superfloppy format (in U-Boot called PBR) did not work for FAT32 as the file system type string is at a different location. Add support for FAT32. Signed-off-by: Wolfgang Denk w...@denx.de ---

Re: [U-Boot] [PATCH 3/5] FAT32: fix broken root directory handling.

2010-07-24 Thread Wolfgang Denk
Dear Wolfgang Denk, In message 1279532220-5848-4-git-send-email...@denx.de you wrote: On FAT32, instead of fetching the cluster numbers from the FAT, the code assumed (incorrectly) that the clusters for the root directory were allocated contiguously. In the result, only the first cluster

Re: [U-Boot] [PATCH 4/5] usb_storage.c: change progress output in debug() message

2010-07-24 Thread Wolfgang Denk
Dear Wolfgang Denk, In message 1279532220-5848-5-git-send-email...@denx.de you wrote: The dots printed by common/usb_storage.c as progress meter corrupt the output for example of fatls usb commands like this: = fatls usb 0 . here 29 file.001 29

Re: [U-Boot] [PATCH 5/5] fs/fat: Big code cleanup.

2010-07-24 Thread Wolfgang Denk
Dear Wolfgang Denk, In message 1279532220-5848-6-git-send-email...@denx.de you wrote: - reformat - throw out macros like FAT_DPRINT and FAT_DPRINT - remove dead code Signed-off-by: Wolfgang Denk w...@denx.de --- common/cmd_fat.c | 210 ++ fs/fat/fat.c | 1167

Re: [U-Boot] [PATCH v4] Support for devices with FAT32 PBR

2010-07-24 Thread Wolfgang Denk
Dear Igor Luri, In message 1273586575-27317-1-git-send-email-il...@aotek.es you wrote: Signed-off-by: Igor Luri il...@aotek.es --- disk/part_dos.c |3 ++- disk/part_dos.h |1 + fs/fat/fat.c|7 +-- 3 files changed, 8 insertions(+), 3 deletions(-) I applied commit

[U-Boot] [PATCH] Rename getenv_r() into getenv_f()

2010-07-24 Thread Wolfgang Denk
While running from flash, i. e. before relocation, we have only a limited C runtime environment without writable data segment. In this phase, some configurations (for example with environment in EEPROM) must not use the normal getenv(), but a special function. This function had been called

[U-Boot] [PATCH] getenv_f(): fix handling of too short buffers

2010-07-24 Thread Wolfgang Denk
Fix error handling in getenv_f() when the user provided buffer is too short to hold the variable name; make sure to truncate and NUL-terminate without overwriting the buffer limits. Signed-off-by: Wolfgang Denk w...@denx.de --- common/cmd_nvedit.c | 18 -- 1 files changed, 12