Re: [U-Boot] [PATCH v3 7/8] imximage: Add MX53 boot image support

2010-12-31 Thread Wolfgang Denk
Dear Stefano Babic, In message 4d1c7f08.1010...@denx.de you wrote: The name is not consistent with the other commands, as they do not use the IMXIMAGE_ prefix (we do not have such as IMXIMAGE_BOOT_FROM). Please replace with VERSION. No, plain VERSION is way too generic. We need some prefix

Re: [U-Boot] [PATCH v3 7/8] imximage: Add MX53 boot image support

2010-12-31 Thread Wolfgang Denk
Dear Jason Liu, In message aanlktimchbovnntw9enqafrp3wvw3epgb7s7cvtks...@mail.gmail.com you wrote: Not change the mx51evk file. The code should take VERSION=1 as default, and we do not need to change the actual boards. Do you mean that if can't find the VERSION command in the cfg file,

Re: [U-Boot] [PATCH v3 7/8] imximage: Add MX53 boot image support

2010-12-31 Thread Wolfgang Denk
Dear Jason Liu, In message aanlktinnfxd26yrciwfnbt5lx9ay5kxihbolsc8jg...@mail.gmail.com you wrote: But, I did think again about your comments. If we store the version into the header which will make the version check more easier, the side-effect is that we store some boot ROM useless

Re: [U-Boot] [PATCH v3 7/8] imximage: Add MX53 boot image support

2010-12-31 Thread Jason Liu
Hi, Wolfgang, 2010/12/31 Wolfgang Denk w...@denx.de: Dear Jason Liu, In message aanlktinnfxd26yrciwfnbt5lx9ay5kxihbolsc8jg...@mail.gmail.com you wrote: But, I did think again about your comments. If we store the version into the header which will make the version check more easier, the

Re: [U-Boot] [PATCH] common/dlmalloc: support reinit bin for fast reset

2010-12-31 Thread Wolfgang Denk
Dear Macpaul Lin, In message 1293779628-9804-1-git-send-email-macp...@andestech.com you wrote: There are several way to reset the u-boot. To avoid confusion, we should try and agree on certain terms. Reset means (at least in U-Boot context) to bring a system to an initial state, similar to

Re: [U-Boot] [PATCH v3 7/8] imximage: Add MX53 boot image support

2010-12-31 Thread Wolfgang Denk
Dear Jason Liu, In message aanlktik1uxzk+7ll6chtq465z4x+pm-kfqeali=d7...@mail.gmail.com you wrote: This looks as if you added something to the standard 64 byte image header. You must not modify this. It is fixed for all architectures and cannot be extended. This change is specific for

Re: [U-Boot] [PATCH v3 7/8] imximage: Add MX53 boot image support

2010-12-31 Thread Jason Liu
Hi, Wolfgang, 2010/12/31 Wolfgang Denk w...@denx.de: Dear Jason Liu, In message aanlktik1uxzk+7ll6chtq465z4x+pm-kfqeali=d7...@mail.gmail.com you wrote: This looks as if you added something to the standard 64 byte image header. You must not modify this. It is fixed for all architectures

Re: [U-Boot] [PATCH v3 7/8] imximage: Add MX53 boot image support

2010-12-31 Thread Stefano Babic
On 12/31/2010 09:10 AM, Wolfgang Denk wrote: Dear Stefano Babic, In message 4d1c7f08.1010...@denx.de you wrote: The name is not consistent with the other commands, as they do not use the IMXIMAGE_ prefix (we do not have such as IMXIMAGE_BOOT_FROM). Please replace with VERSION. No, plain

Re: [U-Boot] [PATCH v3 7/8] imximage: Add MX53 boot image support

2010-12-31 Thread Stefano Babic
On 12/31/2010 07:06 AM, Jason Liu wrote: But, I did think again about your comments. If we store the version into the header which will make the version check more easier, the side-effect is that we store some boot ROM useless information into the header, but which should not bring some

Re: [U-Boot] [PATCH v3 7/8] imximage: Add MX53 boot image support

2010-12-31 Thread Stefano Babic
On 12/31/2010 09:12 AM, Wolfgang Denk wrote: Dear Jason Liu, In message aanlktimchbovnntw9enqafrp3wvw3epgb7s7cvtks...@mail.gmail.com you wrote: Not change the mx51evk file. The code should take VERSION=1 as default, and we do not need to change the actual boards. Do you mean that if

Re: [U-Boot] [PATCH v3 7/8] imximage: Add MX53 boot image support

2010-12-31 Thread Stefano Babic
On 12/31/2010 10:25 AM, Jason Liu wrote: Hi, Wolfgang, 2010/12/31 Wolfgang Denk w...@denx.de: Dear Jason Liu, In message aanlktik1uxzk+7ll6chtq465z4x+pm-kfqeali=d7...@mail.gmail.com you wrote: This looks as if you added something to the standard 64 byte image header. You must not

[U-Boot] Recent changes break our update scripts, because of getenv_yesno()

2010-12-31 Thread Reinhard Meyer
Hello, in common/image.c: int getenv_yesno (char *var) { char *s = getenv (var); return (s (*s == 'n')) ? 0 : 1; } Is that supposed to return TRUE when the env variable does NOT exist? Because each TFTP/USB/whatever load of an image will automatically start it! (and why is

Re: [U-Boot] Recent changes break our update scripts, because of getenv_yesno()

2010-12-31 Thread Reinhard Meyer
On 31.12.2010 11:33, Reinhard Meyer wrote: Hello, in common/image.c: int getenv_yesno (char *var) { char *s = getenv (var); return (s (*s == 'n')) ? 0 : 1; } Is that supposed to return TRUE when the env variable does NOT exist? Because each TFTP/USB/whatever load of an

Re: [U-Boot] Recent changes break our update scripts, because of getenv_yesno()

2010-12-31 Thread Stefano Babic
On 12/31/2010 11:33 AM, Reinhard Meyer wrote: Hello, in common/image.c: int getenv_yesno (char *var) { char *s = getenv (var); return (s (*s == 'n')) ? 0 : 1; } Is that supposed to return TRUE when the env variable does NOT exist? Because each TFTP/USB/whatever load

Re: [U-Boot] Recent changes break our update scripts, because of getenv_yesno()

2010-12-31 Thread Stefano Babic
On 12/31/2010 11:41 AM, Reinhard Meyer wrote: /* Loading ok, check if we should attempt an auto-start */ - if (((s = getenv(autostart)) != NULL) (strcmp(s,yes) == 0)) { + if (getenv_yesno(autostart)) { char *local_args[2]; local_args[0]

Re: [U-Boot] [PATCH v3 7/8] imximage: Add MX53 boot image support

2010-12-31 Thread Wolfgang Denk
Dear Jason Liu, In message aanlktimuduwb8ktcpzw1rnjhazbnilcdr8-9vheee...@mail.gmail.com you wrote: So, I don't think it will affect other architectures. I haven't seen your code yet, but your description does not convince me. Please keep in mind that not only mkimage -l, but also the U-Boot

Re: [U-Boot] [PATCH v3 7/8] imximage: Add MX53 boot image support

2010-12-31 Thread Wolfgang Denk
Dear Stefano Babic, In message 4d1da3ea.4060...@denx.de you wrote: No, plain VERSION is way too generic. We need some prefix here. As the setting is only inside the imximage configuration file, I supposed that it is redundant to remember we are talking about IMX images and VERSION is

Re: [U-Boot] Recent changes break our update scripts, because of getenv_yesno()

2010-12-31 Thread Wolfgang Denk
Dear Reinhard Meyer, In message 4d1db35a.3090...@emk-elektronik.de you wrote: OK, digging deeper, the culprit actually is: 2010-11-28 Mike Frysinger boot cmds: convert to getenv_yesno() with autostart There has been agreement to revert that commit. Best regards, Wolfgang

Re: [U-Boot] Recent changes break our update scripts, because of getenv_yesno()

2010-12-31 Thread Reinhard Meyer
Dear Wolfgang Denk, Dear Reinhard Meyer, In message4d1db35a.3090...@emk-elektronik.de you wrote: OK, digging deeper, the culprit actually is: 2010-11-28 Mike Frysinger boot cmds: convert to getenv_yesno() with autostart There has been agreement to revert that commit. OK, I

Re: [U-Boot] [PATCH v3 7/8] imximage: Add MX53 boot image support

2010-12-31 Thread Stefano Babic
On 12/31/2010 12:39 PM, Wolfgang Denk wrote: This seems the other extreme. How about a comprimize like IMG_VERSION or IMAGE_VERSION or the like, so it's clear what sort of version we are talking about, while at the same time allowing to reuse this on other architectures if that should be

[U-Boot] Work Smarter

2010-12-31 Thread michela Beck
HeyheyHellohellogreetings!Hey!hey!Hello!hello!Yo!yo!Hola!Good dayGood-day!Good Day!Attention!AttentionWhat's happening?What's Happening??Howdy!howdyHowdy Do you sometimes wish for more in life? I discovered this internet news article that you you may end up being more than interested to view.