Re: [U-Boot] Booting kernel from NAND flash on AT91SAM9 custom board using fsload

2011-03-30 Thread Joakim Tjernlund
Dear Nicholas Kinar, In message 4d92428e.6030...@usask.ca you wrote: (1) Does replacing jffs2_1pass.c with jffs2_nand_1pass.c in the fs/jffs2 directory influence the robustness of the fsload code? JFFS2 is more or less deprecated these days. FOr new projects, we recommend to use UBI/

Re: [U-Boot] CFI flash broken for 8-bit bus

2011-03-30 Thread Rogan Dawes
On 2011/03/26 8:32 AM, Aaron Williams wrote: I am still doing some testing and just added a fix today so that if a flash chip that supports both 8 and 16-bits is on an 8-bit bus the interface is set to 8-bits. I'll try and get patches out next week. So far it's working fairly well on all

[U-Boot] using ${var} with env import

2011-03-30 Thread Holger Brunck
Hi all, I am using env import -t to import environment variables from a textfile. My simple textfile is: fdt_file=${hostname}/${hostname}.dtb I import the file with: = tftp 20 scripts/my_environ.txt = env import -t 20 ${filesize} Now when I print the variable I get: = print fdt_file

Re: [U-Boot] Booting kernel from NAND flash on AT91SAM9 custom board using fsload

2011-03-30 Thread Wolfgang Denk
Dear Joakim Tjernlund, In message ofa7deb7be.7d093c64-onc1257863.0027befd-c1257863.00281...@transmode.se you wrote: JFFS2 deprecated? It is very stable and works well for NOR based filesystems. Yes, we consider it deprecated, and we do not use it in any new projects / products. Do you use

Re: [U-Boot] [PATCH] Kirkwood: SATA supports only one device per bus

2011-03-30 Thread Albert ARIBAUD
Hi Gray, Le 29/03/2011 21:42, Gray Remlin a écrit : Change CONFIG_SYS_IDE_MAXDEVICE from 2 to 1 Signed-off-by: Gray Remlingryr...@gmail.com --- arch/arm/include/asm/arch-kirkwood/config.h |3 ++- 1 files changed, 2 insertions(+), 1 deletions(-) diff --git

Re: [U-Boot] [PATCH 2/7] tsec: arrange the code to avoid useless function declaration

2011-03-30 Thread Detlev Zundel
Hi Andy, From: Mingkai Hu mingkai...@freescale.com Signed-off-by: Mingkai Hu mingkai...@freescale.com Acked-by: Andy Fleming aflem...@freescale.com Signed-off-by: Kumar Gala ga...@kernel.crashing.org --- drivers/net/tsec.c | 857 +--- 1

Re: [U-Boot] [PATCH 3/7] Remove instances of phy_read/write

2011-03-30 Thread Detlev Zundel
Hi Andy, There were a few files which were already using phy_read and phy_write for their PHY function names. It's only a few places, and the name seems most appropriate for the high-level abstraction, so let's rename the other versions to something more specific. Also, uec_phy.c had a

Re: [U-Boot] CFI flash broken for 8-bit bus

2011-03-30 Thread Albert ARIBAUD
Le 30/03/2011 10:01, Rogan Dawes a écrit : On 2011/03/26 8:32 AM, Aaron Williams wrote: I am still doing some testing and just added a fix today so that if a flash chip that supports both 8 and 16-bits is on an 8-bit bus the interface is set to 8-bits. I'll try and get patches out next week.

Re: [U-Boot] [PATCH] Kirkwood: SATA supports only one device per bus

2011-03-30 Thread Prafulla Wadaskar
-Original Message- From: Gray Remlin [mailto:gryr...@gmail.com] Sent: Wednesday, March 30, 2011 1:12 AM To: Prafulla Wadaskar Cc: u-boot@lists.denx.de; Gray Remlin Subject: [PATCH] Kirkwood: SATA supports only one device per bus Change CONFIG_SYS_IDE_MAXDEVICE from 2 to 1

Re: [U-Boot] [PATCH] Kirkwood: SATA supports only one device per bus

2011-03-30 Thread Prafulla Wadaskar
-Original Message- From: Prafulla Wadaskar Sent: Wednesday, March 30, 2011 4:48 PM To: 'Gray Remlin' Cc: u-boot@lists.denx.de; Prabhanjan Sarnaik; Ashish Karkare Subject: RE: [PATCH] Kirkwood: SATA supports only one device per bus -Original Message- From: Gray

Re: [U-Boot] [PATCH] ARM: Add support for displaying second ethaddr in 'bdinfo' command

2011-03-30 Thread Albert ARIBAUD
Le 30/03/2011 00:36, Gray Remlin a écrit : On 03/29/2011 10:49 PM, Wolfgang Denk wrote: Dear Gray Remlin, In message1301433395-25203-1-git-send-email-gryr...@gmail.com you wrote: Signed-off-by: Gray Remlingryr...@gmail.com --- common/cmd_bdinfo.c |3 +++ 1 files changed, 3

Re: [U-Boot] [PATCH 4/7] Create PHY Lib for U-Boot

2011-03-30 Thread Detlev Zundel
Hi Andy, Extends the mii_dev structure to participate in a full-blown MDIO and PHY driver scheme. The mii_dev structure and miiphy calls are modified in such a way to allow the original mii command and miiphy infrastructure to work as before, but also to support a new set of APIs which

Re: [U-Boot] [PATCH 5/7] Add mdio command for new PHY infrastructure

2011-03-30 Thread Detlev Zundel
Hi Andy, The new mdio command doesn't have all of the features of the mii command, but it provides the necessary read/write primitives, and allows users to interact with 10G PHYs, and other PHYs which use Clause 45 of 802.3. This means that the mdio command requires a Device Address

Re: [U-Boot] [RFC 0/7] Universal PHY Infrastructure

2011-03-30 Thread Detlev Zundel
Hi Andy, Or PHY Lib for U-Boot. This sequence of patches adds infrastructure for universally-available PHY drivers (and MDIO drivers). It piggy-backs on the existing miiphy code, for backwards compatibility, but it also creates a new set of APIs. This was necessary partly to provide

Re: [U-Boot] [PATCH 6/7] phylib: Add a bunch of PHY drivers from tsec

2011-03-30 Thread Detlev Zundel
Hi Andy, The tsec driver had a bunch of PHY drivers already written. This converts them all into PHY Lib drivers, and serves as the first set of PHY drivers for PHY Lib. Signed-off-by: Andy Fleming aflem...@freescale.com [...] diff --git a/drivers/net/phy/atheros.c

Re: [U-Boot] [PATCH 7/7] tsec: Convert tsec to use PHY Lib

2011-03-30 Thread Detlev Zundel
Hi Andy, This converts tsec to use the new PHY Lib. All of the old PHY support is ripped out. The old MDIO driver is split off, and placed in fsl_mdio.c. The initialization is modified to initialize the MDIO driver as well. The powerpc config file is modified to configure PHYLIB if

Re: [U-Boot] [PATCH] ARM: Add support for displaying second ethaddr in 'bdinfo' command

2011-03-30 Thread Detlev Zundel
Hi Gray, On 03/29/2011 10:49 PM, Wolfgang Denk wrote: Dear Gray Remlin, In message1301433395-25203-1-git-send-email-gryr...@gmail.com you wrote: Signed-off-by: Gray Remlingryr...@gmail.com --- common/cmd_bdinfo.c |3 +++ 1 files changed, 3 insertions(+), 0 deletions(-) Why limit

Re: [U-Boot] [PATCH] Kirkwood: SATA supports only one device per bus

2011-03-30 Thread Gray Remlin
On 03/30/2011 11:51 AM, Albert ARIBAUD wrote: Hi Gray, Le 29/03/2011 21:42, Gray Remlin a écrit : Change CONFIG_SYS_IDE_MAXDEVICE from 2 to 1 Signed-off-by: Gray Remlingryr...@gmail.com --- arch/arm/include/asm/arch-kirkwood/config.h |3 ++- 1 files changed, 2 insertions(+), 1

Re: [U-Boot] using ${var} with env import

2011-03-30 Thread Wolfgang Denk
Dear Holger Brunck, In message 4d92e7b4.9010...@keymile.com you wrote: I am using env import -t to import environment variables from a textfile. My simple textfile is: fdt_file=${hostname}/${hostname}.dtb I import the file with: = tftp 20 scripts/my_environ.txt = env import -t

Re: [U-Boot] [PATCH] ARM: Add support for displaying second ethaddr in 'bdinfo' command

2011-03-30 Thread Gray Remlin
On 03/30/2011 12:34 PM, Albert ARIBAUD wrote: Le 30/03/2011 00:36, Gray Remlin a écrit : On 03/29/2011 10:49 PM, Wolfgang Denk wrote: Dear Gray Remlin, In message1301433395-25203-1-git-send-email-gryr...@gmail.comyou wrote: Signed-off-by: Gray Remlingryr...@gmail.com ---

Re: [U-Boot] [PATCH] Kirkwood: SATA supports only one device per bus

2011-03-30 Thread Gray Remlin
On 03/30/2011 12:21 PM, Prafulla Wadaskar wrote: -Original Message- From: Prafulla Wadaskar Sent: Wednesday, March 30, 2011 4:48 PM To: 'Gray Remlin' Cc: u-boot@lists.denx.de; Prabhanjan Sarnaik; Ashish Karkare Subject: RE: [PATCH] Kirkwood: SATA supports only one device per bus

Re: [U-Boot] [PATCH V5 4/6] I2C: add i2c support for Pantheon platform

2011-03-30 Thread Lei Wen
Hi Prafulla, On Tue, Mar 29, 2011 at 9:07 PM, Prafulla Wadaskar prafu...@marvell.com wrote: -Original Message- From: Lei Wen [mailto:lei...@marvell.com] Sent: Monday, March 28, 2011 12:24 PM To: Heiko Schocher; Prafulla Wadaskar; Wolfgang Denk; u- b...@lists.denx.de; Marek Vasut;

Re: [U-Boot] [PATCH V4 1/6] io: add and* and or* operation api to set and clear bit

2011-03-30 Thread Lei Wen
Hi Scott, On Wed, Mar 30, 2011 at 12:03 AM, Scott Wood scottw...@freescale.com wrote: On Tue, 29 Mar 2011 10:47:04 +0800 Lei Wen adrian.w...@gmail.com wrote: Hi Scott, On Tue, Mar 29, 2011 at 12:05 AM, Scott Wood scottw...@freescale.com wrote: What does this do that setbits*/clrbits*

Re: [U-Boot] [PATCH V5 3/6] mv_i2c: use structure to replace the direclty define

2011-03-30 Thread Lei Wen
Hi Prafulla, On Tue, Mar 29, 2011 at 9:27 PM, Prafulla Wadaskar prafu...@marvell.com wrote: -Original Message- From: Lei Wen [mailto:lei...@marvell.com] Sent: Monday, March 28, 2011 12:24 PM To: Heiko Schocher; Prafulla Wadaskar; Wolfgang Denk; u- b...@lists.denx.de; Marek Vasut;

[U-Boot] MIPS: tb0229 build error caused by asm/ppc4xx.h reference

2011-03-30 Thread Shinya Kuribayashi
Hi Komiya-san, Since the commit below, tb0229 target has been broken for months because ppc4xx.h and ppc405.h can not be easily included as used to by MIPS ports any more. commit b36df561154bdd0a41bb77e09c5575ca2cf48013 Author: Stefan Roese s...@denx.de Date: Thu Sep 9 19:18:00 2010 +0200

Re: [U-Boot] using ${var} with env import

2011-03-30 Thread Holger Brunck
Hello, Wolfgang Denk wrote: Dear Holger Brunck, In message 4d92e7b4.9010...@keymile.com you wrote: I am using env import -t to import environment variables from a textfile. My simple textfile is: fdt_file=${hostname}/${hostname}.dtb I import the file with: = tftp 20

[U-Boot] [PATCH] BeagleBoard: add xM rev C to ID table

2011-03-30 Thread Jason Kridner
A simple addition to the revision IDs. This patch depends upon http://patchwork.ozlabs.org/patch/85303/. Signed-off-by: Jason Kridner jkrid...@beagleboard.org --- board/ti/beagle/beagle.c | 12 board/ti/beagle/beagle.h |1 + 2 files changed, 13 insertions(+), 0 deletions(-)

Re: [U-Boot] [PATCH v3 0/5] MIPS: Refactoring and cleanup of CPU and SoC code

2011-03-30 Thread Shinya Kuribayashi
On 03/29/2011 01:33 AM, daniel.schwierz...@googlemail.com wrote: This patch series refactors the Mips CPU directory and put all current code into an own mips32 subdirectory. Furthermore the SoC specific code of IncaIP and Au1x00 is moved to separate SoC subdirectories. The support for Purple

[U-Boot] [U-Boot, 2/7] IDE: Don't assume there are always two devices per bus

2011-03-30 Thread Gray Remlin
Excuse the noob question. Is it intentional to replace '(dev 1) with '(dev 0)' ? ___ U-Boot mailing list U-Boot@lists.denx.de http://lists.denx.de/mailman/listinfo/u-boot

Re: [U-Boot] [U-Boot, 2/7] IDE: Don't assume there are always two devices per bus

2011-03-30 Thread Gray Remlin
On 03/30/2011 07:27 PM, Gray Remlin wrote: Excuse the noob question. Is it intentional to replace '(dev 1) with '(dev 0)' ? Ignore me, I get it. Divide by two, or not, as required. ___ U-Boot mailing list U-Boot@lists.denx.de

Re: [U-Boot] [PATCH V5 3/6] mv_i2c: use structure to replace the direclty define

2011-03-30 Thread Prafulla Wadaskar
-Original Message- From: Lei Wen [mailto:adrian.w...@gmail.com] Sent: Wednesday, March 30, 2011 7:42 PM To: Prafulla Wadaskar Cc: Lei Wen; Heiko Schocher; Wolfgang Denk; u-boot@lists.denx.de; Marek Vasut; Ashish Karkare; Prabhanjan Sarnaik; Yu Tang Subject: Re: [PATCH V5 3/6]

Re: [U-Boot] [PATCH V5 4/6] I2C: add i2c support for Pantheon platform

2011-03-30 Thread Prafulla Wadaskar
-Original Message- From: Lei Wen [mailto:adrian.w...@gmail.com] Sent: Wednesday, March 30, 2011 7:36 PM To: Prafulla Wadaskar Cc: Lei Wen; Heiko Schocher; Wolfgang Denk; u-boot@lists.denx.de; Marek Vasut; Ashish Karkare; Prabhanjan Sarnaik; Yu Tang Subject: Re: [PATCH V5 4/6] I2C:

Re: [U-Boot] [PATCH] Kirkwood: SATA supports only one device per bus

2011-03-30 Thread Prafulla Wadaskar
-Original Message- From: Gray Remlin [mailto:gryr...@gmail.com] Sent: Wednesday, March 30, 2011 7:21 PM To: Prafulla Wadaskar Cc: u-boot@lists.denx.de Subject: Re: [PATCH] Kirkwood: SATA supports only one device per bus On 03/30/2011 12:21 PM, Prafulla Wadaskar wrote:

Re: [U-Boot] [U-Boot, 2/7] IDE: Don't assume there are always two devices per bus

2011-03-30 Thread Rogan Dawes
On 2011/03/30 8:49 PM, Gray Remlin wrote: On 03/30/2011 07:27 PM, Gray Remlin wrote: Excuse the noob question. Is it intentional to replace '(dev 1) with '(dev 0)' ? Ignore me, I get it. Divide by two, or not, as required. Hi Gray, Please also see the thread that starts at:

Re: [U-Boot] [U-Boot, 2/7] IDE: Don't assume there are always two devices per bus

2011-03-30 Thread Albert ARIBAUD
Le 30/03/2011 21:45, Rogan Dawes a écrit : On 2011/03/30 8:49 PM, Gray Remlin wrote: On 03/30/2011 07:27 PM, Gray Remlin wrote: Excuse the noob question. Is it intentional to replace '(dev 1) with '(dev 0)' ? Ignore me, I get it. Divide by two, or not, as required. Hi Gray, Please also

Re: [U-Boot] [PATCH] Kirkwood: SATA supports only one device per bus

2011-03-30 Thread Albert ARIBAUD
Le 30/03/2011 20:59, Prafulla Wadaskar a écrit : to the best of my knowledge, no one has yet implemented a board using both busses (I am not that familiar with OpenRD, I may have to eat my words). OpenRD-Base board has two, one e-sata for external hdd and one sata for onboard hdd

Re: [U-Boot] [PATCH 5/7] Add mdio command for new PHY infrastructure

2011-03-30 Thread Andy Fleming
On Mar 30, 2011, at 6:55 AM, Detlev Zundel wrote: Hi Andy, +static int extract_range(char *input, int *plo, int *phi) +{ +char * end; +*plo = simple_strtol(input, end, 0); +if (end == input) +return -1; + +if (*end == '-') { What about the case of

Re: [U-Boot] [PATCH 5/7] Add mdio command for new PHY infrastructure

2011-03-30 Thread Mike Frysinger
On Tue, Mar 29, 2011 at 3:30 PM, Andy Fleming wrote: +        busname  addr\n +        busname:addr\n why bother ? pick one and go with it [busname:]addr -mike ___ U-Boot mailing list U-Boot@lists.denx.de

Re: [U-Boot] [PATCH v3 01/23] powerpc, mpc83xx: add missing functions to mpc83xx.h

2011-03-30 Thread Kim Phillips
On Mon, 21 Mar 2011 08:01:57 +0100 Heiko Schocher h...@denx.de wrote: Signed-off-by: Heiko Schocher h...@denx.de cc: Kim Phillips kim.phill...@freescale.com cc: Holger Brunck holger.bru...@keymile.com cc: Wolfgang Denk w...@denx.de cc: Detlev Zundel d...@denx.de cc: Valentin Longchamp

Re: [U-Boot] [PATCH v3 06/23] mpc832x: add support for the mpc8321 based suvd3 board

2011-03-30 Thread Kim Phillips
On Mon, 21 Mar 2011 08:02:02 +0100 Heiko Schocher h...@denx.de wrote: +++ b/arch/powerpc/cpu/mpc83xx/fdt.c @@ -32,7 +32,8 @@ extern void ft_qe_setup(void *blob); DECLARE_GLOBAL_DATA_PTR; -#if defined(CONFIG_BOOTCOUNT_LIMIT) defined(CONFIG_MPC8360) +#if defined(CONFIG_BOOTCOUNT_LIMIT)

Re: [U-Boot] [PATCH 6/7] phylib: Add a bunch of PHY drivers from tsec

2011-03-30 Thread Andy Fleming
On Mar 30, 2011, at 7:26 AM, Detlev Zundel wrote: Hi Andy, The tsec driver had a bunch of PHY drivers already written. This converts them all into PHY Lib drivers, and serves as the first set of PHY drivers for PHY Lib. Signed-off-by: Andy Fleming aflem...@freescale.com [...] diff

Re: [U-Boot] [PATCH] [MPC837x v2] Make it work again with USB.

2011-03-30 Thread Kim Phillips
On Mon, 28 Feb 2011 17:18:38 +0100 Andre Schwarz andre.schw...@matrix-vision.de wrote: sorry to bother you again, but I again stumbled over the discussed USB init issue : nack, 837x has a usb controller at IMMR+0x23000. yes - but offset 0x00-0xff is explicitly reserved regarding to the

Re: [U-Boot] [PATCH] ftsmc020: enhance for features and asm support.

2011-03-30 Thread Macpaul Lin
Hi Wolfgang, 2011/3/25 Wolfgang Denk w...@denx.de: Dear macp...@andestech.com, There is no (known) problem with it, but you have to be careful about the context you are running in - the script as is is supposed to be run in make context, which means different $ expansion rules then when

Re: [U-Boot] [PATCH RFC v2] Fix build problems caused by _end - __bss_end__ rename

2011-03-30 Thread Kumar Gala
On Mar 29, 2011, at 8:38 PM, Po-Yu Chuang wrote: Hi Wolfgang, On Wed, Mar 30, 2011 at 3:51 AM, Wolfgang Denk w...@denx.de wrote: Dear Po-Yu Chuang, In message 1301402371-8697-1-git-send-email...@denx.de I wrote: Commit 44c6e65 rename _end to __bss_end__ broke building of a large number

Re: [U-Boot] [PATCH v3 01/23] powerpc, mpc83xx: add missing functions to mpc83xx.h

2011-03-30 Thread Heiko Schocher
Hello Kim, Kim Phillips wrote: On Mon, 21 Mar 2011 08:01:57 +0100 Heiko Schocher h...@denx.de wrote: Signed-off-by: Heiko Schocher h...@denx.de cc: Kim Phillips kim.phill...@freescale.com cc: Holger Brunck holger.bru...@keymile.com cc: Wolfgang Denk w...@denx.de cc: Detlev Zundel