Re: [U-Boot] [PATCH v2 3/4] mmc: zynq: Determine base clock frequency via clock framework

2017-01-01 Thread Michal Simek
Hi, On 27.12.2016 11:10, Stefan Herbrechtsmeier wrote: > Hi Michal, > > Am 28.11.2016 um 08:42 schrieb Michal Simek: >> Hi, +Siva, > > >> Moving current zynq clk driver to driver model shouldn't be that hard >> because all should be in place. and then you can keep just that >> if defined(CONFIG

Re: [U-Boot] [RESEND PATCH v3 1/2] mmc: rockchip_sdhci: add clock init for mmc

2017-01-01 Thread Jaehoon Chung
Hi Stefan, On 12/31/2016 12:07 AM, Stefan Herbrechtsmeier wrote: > Hi, [snip] In Conclusion, host's maximum value is used. ("max_frequency" property is used to QUIRK_BROKEN_CAP_CLOCK_BASE in Linux kernel.) >>> The conclusion is wrong. The host->max_clk isn't influenced by th

Re: [U-Boot] [PATCH v2 2/2] test/py: Create tests for ext4 and fat testing on sandbox

2017-01-01 Thread Stefan Bruens
On Montag, 12. Dezember 2016 11:04:34 CET you wrote: > On 12/04/2016 05:52 PM, Stefan Brüns wrote: > > From: Stefan Brüns > > > > The following checks are currently implemented: > > 1. listing a directory > > 2. verifying size of a file > > 3. veryfying md5sum for a file region > > 4. reading th

Re: [U-Boot] [PATCH 00/10] i.MX6: engicam: Add nandboot env and FIT support

2017-01-01 Thread Jagan Teki
Hi Stefano, On Thu, Dec 29, 2016 at 2:37 PM, Jagan Teki wrote: > Hi Stefano, > > On Wed, Dec 21, 2016 at 12:00 PM, Jagan Teki wrote: >> From: Jagan Teki >> >> This patchset, add support for >> - legacy image boot, with bootm >> - NAND boot env support, with UBIFS as rootfs >> - FIT image boot s

Re: [U-Boot] [PATCH v3 00/26] sunxi: Allwinner A64: SPL support

2017-01-01 Thread Jagan Teki
On Mon, Dec 19, 2016 at 2:49 AM, Andre Przywara wrote: > Hi, > > another reworked version of the SPL support series for the Allwinner A64 > SoC. Again many thanks to the diligent reviewers, I hope I didn't miss any > comments. > As the previous versions this one includes support for both AArch64 a

[U-Boot] [PATCH 0/7] mmc: more Kconfig conversion, MMC related clean-up

2017-01-01 Thread Masahiro Yamada
This series is based on commit 3d3a74cc8c. Each git-log describes how to re-generate it. Buildman test passed. Masahiro Yamada (7): socfpga: remove unused CONFIG option and cleanup README.socfpga mmc: rename CONFIG_ROCKCHIP_DWMMC to CONFIG_MMC_DW_ROCKCHIP mmc: move CONFIG_DWMMC to Kconfig,

[U-Boot] [PATCH 6/7] mmc: move more driver config options to Kconfig

2017-01-01 Thread Masahiro Yamada
Move (and rename) the following CONFIG options to Kconfig: CONFIG_DAVINCI_MMC (renamed to CONFIG_MMC_DAVINCI) CONFIG_OMAP_HSMMC (renamed to CONFIG_MMC_OMAP_HS) CONFIG_MXC_MMC (renamed to CONFIG_MMC_MXC) CONFIG_MXS_MMC (renamed to CONFIG_MMC_MXS) CONFIG_TEGRA_MMC(renamed

[U-Boot] [PATCH 3/7] mmc: move CONFIG_DWMMC to Kconfig, renaming to CONFIG_MMC_DW

2017-01-01 Thread Masahiro Yamada
This commit was created as follows: [1] Rename the option with the following command: find . -name .git -prune -o ! -path ./scripts/config_whitelist.txt \ -type f -print | xargs sed -i -e 's/CONFIG_DWMMC/CONFIG_MMC_DW/g' [2] create the entry for MMC_DW in drivers/mmc/Kconfig (the prompt and h

[U-Boot] [PATCH 4/7] mmc: move DesignWare-based drivers to Kconfig

2017-01-01 Thread Masahiro Yamada
Move (and rename) the following CONFIG options to Kconfig: CONFIG_EXYNOS_DWMMC (renamed to CONFIG_MMC_DW_EXYNOS) CONFIG_HIKEY_DWMMC (renamed to CONFIG_MMC_DW_K3) CONFIG_SOCFPGA_DWMMC (renamed to CONFIG_MMC_DW_SOCFPGA) The "HIKEY" is a board name, so it is not suitable for the MMC control

[U-Boot] [PATCH 5/7] ARM: davinci: remove unused CONFIG_DAVINCI_MMC_SD1

2017-01-01 Thread Masahiro Yamada
This CONFIG is not referenced from anywhere. Signed-off-by: Masahiro Yamada --- include/configs/da850evm.h | 1 - include/configs/legoev3.h | 1 - 2 files changed, 2 deletions(-) diff --git a/include/configs/da850evm.h b/include/configs/da850evm.h index ceb9cea..2eabc00 100644 --- a/include/c

[U-Boot] [PATCH 1/7] socfpga: remove unused CONFIG option and cleanup README.socfpga

2017-01-01 Thread Masahiro Yamada
CONFIG_SOCFPGA_DWMMC_FIFO_DEPTH is defined in the socfpga_common.h, but not referenced at all. Remove. Also, clean-up the README.socfpga. CONFIG_MMC should not be defined in the header since it was moved to Kconfig by commit c27269953b94 ("mmc: complete unfinished move of CONFIG_MMC"). I see no

[U-Boot] [PATCH 2/7] mmc: rename CONFIG_ROCKCHIP_DWMMC to CONFIG_MMC_DW_ROCKCHIP

2017-01-01 Thread Masahiro Yamada
I am trying to make all DesignWare-based driver options prefixed with CONFIG_MMC_DW_. This commit was generated as follows: find . -name .git -prune -o -type f -print | \ xargs sed -i -e 's/ROCKCHIP_DWMMC/MMC_DW_ROCKCHIP/g' Signed-off-by: Masahiro Yamada --- configs/chromebit_mickey_defconfig

[U-Boot] [PATCH 7/7] sunxi: remove bare default for CONFIG_MMC

2017-01-01 Thread Masahiro Yamada
The bare default entry is wrong. Just remove it since the (real) entry in drivers/mmc/Kconfig has "default ARM || PPC || SANDBOX". Signed-off-by: Masahiro Yamada --- board/sunxi/Kconfig | 4 1 file changed, 4 deletions(-) diff --git a/board/sunxi/Kconfig b/board/sunxi/Kconfig index e1d4a