[U-Boot] [RESEND PATCH 8/8] sf: add driver for Atmel QSPI controller

2017-07-16 Thread Wenyou Yang
From: Cyrille Pitchen This patch adds support to the Atmel Quad SPI controller. Signed-off-by: Cyrille Pitchen Signed-off-by: Wenyou Yang --- drivers/spi/Kconfig | 7 + drivers/spi/Makefile | 1 + drivers/spi/atmel_qspi.c | 404 +++ dr

[U-Boot] [RESEND PATCH 6/8] sf: add new option to support SPI flash above 16MiB

2017-07-16 Thread Wenyou Yang
From: Cyrille Pitchen The patch provides an alternative method to support SPI flash size greater than 16MiB (128Mib). Indeed using the Base Address Register (BAR) is stateful. Hence, once the BAR has been modified, if a spurious CPU reset occurs with no reset/power off at the SPI flash side, ear

[U-Boot] [RESEND PATCH 5/8] sf: add 'addr_len' member to 'struct spi_flash'

2017-07-16 Thread Wenyou Yang
From: Cyrille Pitchen This is a transitional patch to prepare the SPI FLASH sub-system to support the 4-byte address instruction set later. For now, flash->addr_len is always set to SPI_FLASH_3B_ADDR_LEN. Signed-off-by: Cyrille Pitchen Signed-off-by: Wenyou Yang --- drivers/mtd/spi/spi_flash

[U-Boot] [RESEND PATCH 7/8] sf: add support to Microchip SST26 QSPI memories

2017-07-16 Thread Wenyou Yang
From: Cyrille Pitchen This patch adds support to Microchip SST26 QSPI memories. Erase blocks are protected at power up and must be unlocked first before being erased then programmed. Also, the erase block sizes are not uniform. The memory layout is uniform only for the 4K sector blocks. The 64K

[U-Boot] [RESEND PATCH 3/8] sf: select the relevant SPI flash protocol for read and write commands

2017-07-16 Thread Wenyou Yang
From: Cyrille Pitchen SPI controller drivers should not check the instruction op code byte to guess which SPI x-y-z protocol is to be used for Fast Read or Page Program operations. Indeed, the op code values are not so reliable. For instance, the 32h op code is generally used for Page Program 1-

[U-Boot] [RESEND PATCH 4/8] sf: differentiate Page Program 1-1-4 and 1-4-4

2017-07-16 Thread Wenyou Yang
From: Cyrille Pitchen This patch simply renames the ambiguous CMD_QUAD_PAGE_PROGRAM macro into the more explicit CMD_PAGE_PROGRAM_1_1_4. Also it defines the CMD_PAGE_PROGRAM_1_4_4 macro to the standard 38h op code. Signed-off-by: Cyrille Pitchen Signed-off-by: Wenyou Yang --- drivers/mtd/spi

[U-Boot] [RESEND PATCH 2/8] sf: describe all SPI flash commands with 'struct spi_flash_command'

2017-07-16 Thread Wenyou Yang
From: Cyrille Pitchen Now that the SPI sub-system API has been extended with 'struct spi_flash_command' and spi_is_flash_command_supported() / spi_exec_flash_command() functions, we update the SPI FLASH sub-system to use this new API. Signed-off-by: Cyrille Pitchen Signed-off-by: Wenyou Yang -

[U-Boot] [RESEND PATCH 1/8] spi: add support of SPI flash commands

2017-07-16 Thread Wenyou Yang
From: Cyrille Pitchen This patch introduces 'struct spi_flash_command' and functions spi_is_flash_command_supported() / spi_exec_flash_command(). The 'struct spi_flash_command' describes all the relevant parameters to execute any SPI flash command: - the instruction op code - the number of bytes

[U-Boot] [RESEND PATCH 0/8] sf: improve support of (Q)SPI flash memories

2017-07-16 Thread Wenyou Yang
This series of patches has been tested on u-boot-2017.03-at91 then ported to the 'master' branch of the u-boot-spi.git tree. Tests were passed with a sama5d2 xplained board which embeds both SPI and QSPI controllers. The following tests have been passed: - QSPI0 + Macronix MX25L25673G: + prob

[U-Boot] [PATCH 2/2] console: simplify puts()

2017-07-16 Thread Masahiro Yamada
Current puts() and putc() have similar #ifdef / if() conditionals. Make puts() iterate over putc() to avoid code duplication. Signed-off-by: Masahiro Yamada --- common/console.c | 44 ++-- 1 file changed, 2 insertions(+), 42 deletions(-) diff --git a/com

[U-Boot] [PATCH 1/2] sandbox: remove os_putc() and os_puts()

2017-07-16 Thread Masahiro Yamada
They are unused since commit d8c6fb8cedbc ("sandbox: Drop special case console code for sandbox"). Signed-off-by: Masahiro Yamada --- arch/sandbox/cpu/os.c | 11 --- include/os.h | 20 2 files changed, 31 deletions(-) diff --git a/arch/sandbox/cpu/os.c b/a

Re: [U-Boot] [PATCH 4/5] dm: ofnode: rename dev_read_prop() to dev_get_property()

2017-07-16 Thread Masahiro Yamada
Hi Simon, 2017-07-14 23:20 GMT+09:00 Simon Glass : > Hi Masahiro, > > On 13 July 2017 at 20:38, Masahiro Yamada > wrote: >> Hi Simon, >> >> >> 2017-07-07 12:57 GMT+09:00 Simon Glass : >>> Hi Masahiro, >>> >>> On 5 July 2017 at 22:49, Simon Glass wrote: On 22 June 2017 at 01:54, Masahiro Ya

[U-Boot] [PATCH] dm: ofnode: change return type of dev_read_prop() to opaque pointer

2017-07-16 Thread Masahiro Yamada
DT property values can be strings as well as integers. This is why of_get_property/fdt_getprop returns an opaque pointer. Signed-off-by: Masahiro Yamada --- drivers/core/read.c | 2 +- include/dm/read.h | 6 +++--- 2 files changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/core/r

Re: [U-Boot] [PATCH v2] serial: ns16550: Add RX interrupt buffer support

2017-07-16 Thread Bin Meng
Hi Stefan, On Fri, Jul 14, 2017 at 11:25 PM, Stefan Roese wrote: > Pasting longer lines into the U-Boot console prompt sometimes leads to > characters missing. One problem here is the small 16-byte FIFO of the > legacy NS16550 UART, e.g. on x86 platforms. > > This patch now introduces a Kconfig o

[U-Boot] [PATCH 1/2] board: ti: am57xx: Fix detection of board version

2017-07-16 Thread Lokesh Vutla
board_is*("rev", board_ti_get_rev()) uses strncmp() for revison detection and assumes it is success if return value is <= 0. This will fail in case of multiple versions, as revb will be true for board_is_*revb() and board_is_*reva(). Fix it by looking for exact match of the string. Signed-off-by:

[U-Boot] [PATCH 2/2] board: ti: x15: Add support for beagle_X15 revC

2017-07-16 Thread Lokesh Vutla
BeagleBoard X15 revC board is similar to X15 revB1 except with a SR2.0 where revB1 uses a SR1.1. Add board detection support for revC. Signed-off-by: Lokesh Vutla --- board/ti/am57xx/board.c | 7 ++- 1 file changed, 6 insertions(+), 1 deletion(-) diff --git a/board/ti/am57xx/board.c b/board

Re: [U-Boot] [PATCH] spl: dm: Make it possible for the SPL to pick its own DTB from a FIT

2017-07-16 Thread Lokesh Vutla
On 7/7/2017 8:30 PM, Jean-Jacques Hiblot wrote: > > > On 07/07/2017 16:30, Tom Rini wrote: >> On Fri, Jul 07, 2017 at 01:44:39PM +0200, Jean-Jacques Hiblot wrote: >> >>> u-boot can be embedded within a FIT image with multiple DTBs. It then >>> selects at run-time which one is best suited for t

Re: [U-Boot] [PATCH v3] watchdog: Introduce watchdog driver for Intel Tangier

2017-07-16 Thread Andy Shevchenko
On Fri, 2017-07-07 at 12:51 +0800, Bin Meng wrote: > On Thu, Jul 6, 2017 at 1:33 AM, Andy Shevchenko > wrote: > > From: Felipe Balbi > > > > Add watchdog driver for Intel Tangier based platforms. Can we get it applied? > > > > Signed-off-by: Vincent Tinelli > > Signed-off-by: Felipe Balbi >

Re: [U-Boot] [PATCH 1/3] efi_loader: implement multiple event support

2017-07-16 Thread Alexander Graf
On 15.07.17 13:43, Heinrich Schuchardt wrote: On 07/12/2017 12:55 PM, Alexander Graf wrote: On 05.07.17 19:47, Heinrich Schuchardt wrote: Up to now the boot time supported only a single event. This patch now allows four events. Signed-off-by: Heinrich Schuchardt --- include/efi_api.h