Re: [PATCH v2 4/7] clk: Add Microchip PolarFire SoC clock driver

2020-10-24 Thread Anup Patel
On Thu, Oct 22, 2020 at 1:11 PM Padmarao Begari wrote: > > Add clock driver code for the Microchip PolarFire SoC. This driver > handles reset and clock control of the Microchip PolarFire SoC device. > > Signed-off-by: Padmarao Begari > --- > drivers/clk/Kconfig | 1 +

Re: [PATCH v2 5/7] riscv: dts: Add device tree for Microchip Icicle Kit

2020-10-24 Thread Anup Patel
On Thu, Oct 22, 2020 at 12:53 PM Padmarao Begari wrote: > > Add device tree for Microchip PolarFire SoC Icicle Kit. > > Signed-off-by: Padmarao Begari > --- > arch/riscv/dts/Makefile | 1 + > arch/riscv/dts/microchip-icicle-kit-a000.dts | 426 +++ > 2

Re: [PATCH v2 1/7] riscv: Add DMA 64-bit address support

2020-10-24 Thread Anup Patel
On Thu, Oct 22, 2020 at 1:23 PM Padmarao Begari wrote: > > dma_addr_t holds any valid DMA address. If the DMA API only uses 32/64-bit > addresses, dma_addr_t need only be 32/64 bits wide. > > Signed-off-by: Padmarao Begari > --- > arch/riscv/Kconfig | 5 + >

Re: [PATCH 2/2] rockchip: gru: Allow setting up clocks in U-Boot proper

2020-10-24 Thread Alper Nebi Yasak
On 24/10/2020 03:05, Simon Glass wrote: > Hi Alper, > > On Thu, 22 Oct 2020 at 14:38, Alper Nebi Yasak > wrote: >> >> Commit fe974716326c ("rockchip: rk3288: Allow setting up clocks in >> U-Boot proper") fixes some clock issues when chainloading U-Boot on >> rk3288 chromebooks. Part of that

Re: [PATCH 1/2] rockchip: rk3399: Re-init clocks in U-Boot proper

2020-10-24 Thread Alper Nebi Yasak
On 24/10/2020 03:05, Simon Glass wrote: > Hi Alper, > > On Thu, 22 Oct 2020 at 14:37, Alper Nebi Yasak > wrote: >> >> It's possible to chainload U-Boot proper from the vendor firmware in >> rk3399 chromebooks, but the way the vendor firmware sets up clocks is >> somehow different than what

Re: [PATCH 0/8] PinePhone automatic device tree selection

2020-10-24 Thread Peter Robinson
On Mon, Sep 7, 2020 at 1:01 AM André Przywara wrote: > > On 03/09/2020 06:07, Samuel Holland wrote: > > Hi Samuel, > > > This patch series implements a feature to automatically choose the > > right PinePhone device tree by probing the hardware. It then extends > > the functionality to pass the

[PATCH] rockchip: mkimage: Remove host endianness dependency

2020-10-24 Thread Samuel Holland
The Rockchip boot ROM expects little-endian values in the image header. When running mkimage on a big-endian machine, these values need to be byteswapped before writing or verifying the header. This change fixes cross-compiling U-Boot SPL for the RK3399 SoC from a big-endian ppc64 host machine.

[PATCH v2 7/8] sunxi: DT: A64: update device tree files

2020-10-24 Thread Samuel Holland
Import updated device trees from Linux tag v5.9. This picks up new hardware (PinePhone, PineTab); and it drops the U-Boot specific DTSI files for the Pinebook and the Teres-I, since the ANX6345 bridge is now supported upstream. A couple of headers needed updates for recently-added hardware

Re: [PATCH v2 7/7] doc: board: Add Microchip MPFS Icicle Kit doc

2020-10-24 Thread Jagan Teki
On Thu, Oct 22, 2020 at 1:22 PM Padmarao Begari wrote: > > This doc describes the procedure to build, flash and > boot Linux using U-boot on Microchip MPFS Icicle Kit. > > Signed-off-by: Padmarao Begari > --- > doc/board/index.rst | 1 + > doc/board/microchip/index.rst |

Re: [PATCH v10 1/2] spi: ca_sflash: Add CAxxxx SPI Flash Controller

2020-10-24 Thread Jagan Teki
On Fri, Jul 31, 2020 at 1:23 AM Alex Nemirovsky wrote: > > From: Pengpeng Chen > > Add SPI Flash controller driver for Cortina Access > CA SoCs > > Signed-off-by: Pengpeng Chen > Signed-off-by: Alex Nemirovsky > CC: Jagan Teki > CC: Vignesh R Applied to u-boot-spi/master

[PATCH v2 4/8] sunxi: board: Add PinePhone DT selection logic

2020-10-24 Thread Samuel Holland
There are two different publicly-released revisions of the PinePhone hardware, versions 1.1 and 1.2; and they need different device trees. Since some GPIO pins were rerouted, we can use that to distinguish between them. Acked-by: Maxime Ripard Reviewed-by: Andre Przywara Signed-off-by: Samuel

[PATCH v2 6/8] sunxi: board: Set fdtfile to match the DT chosen by SPL

2020-10-24 Thread Samuel Holland
Previously, fdtfile was always the value in CONFIG_DEFAULT_DEVICE_TREE. This meant that, regardless of the DT chosen by SPL (either by changing the header in the image or by the selection code at runtime), Linux always used the default DT. By using the name from the SPL header (which, because of

[PATCH v2 2/8] sunxi: board: Add a helper to get the SPL DT name

2020-10-24 Thread Samuel Holland
This moves the validity checking and typecasts all to one place away from the string comparison logic, and it detangles the compile-time and runtime control flow. The new helper will also be used by U-Boot proper in a future commit. Acked-by: Maxime Ripard Reviewed-by: Andre Przywara

[PATCH v2 0/8] PinePhone automatic device tree selection

2020-10-24 Thread Samuel Holland
This patch series implements a feature to automatically choose the right PinePhone device tree by probing the hardware. It then extends the functionality to pass the chosen DTB name to the boot command. Finally, I add device trees and a defconfig for the PinePhone. Changes from v1 to v2: -

[PATCH v2 5/8] sunxi: board: Save the chosen DT name in the SPL header

2020-10-24 Thread Samuel Holland
This overwrites the name loaded from the SPL image. It will be different if there was previously no name provided, or if a more accurate name was determined by the board variant selection logic. This means that the DT name in the SPL header now always matches the DT appended to U-Boot. Acked-by:

[PATCH v2 8/8] sunxi: a64: Add a defconfig for the PinePhone

2020-10-24 Thread Samuel Holland
The PinePhone is a smartphone produced by Pine64, with an A64 SoC, 2 or 3 GiB LPDDR3 RAM, 16 or 32 GiB eMMC, 720x1440 MIPI-DSI panel, and Quectel EG25-G modem. There are two main board revisions: 1.1 for early adopters, and 1.2 for mass production. Since there is code to detect the board revision

[PATCH v2 1/8] sunxi: board: Use a more descriptive variable name

2020-10-24 Thread Samuel Holland
The variable "cmp_str" always leaves me wondering if it is the DT name of the current board (yes) or DT name in the FIT config entry (no). In preparation for expanding the functionality here, rename it to something that obviously means "this is the DT name we are looking for". Acked-by: Maxime

[PATCH v2 3/8] sunxi: board: Simplify Pine A64 DT selection logic

2020-10-24 Thread Samuel Holland
Instead of using an entirely separate matching algorithm, simply update the name of the DT we want to match. Enabling this logic does not depend on the FIT config name, only on the initial guess of the board name. Importantly, the initial guess must be "sun50i-a64-pine64-plus", because otherwise

Re: [PATCH v10 2/2] board: presidio-asic: Add SPI NOR support

2020-10-24 Thread Jagan Teki
On Fri, Jul 31, 2020 at 1:23 AM Alex Nemirovsky wrote: > > Add SPI NOR support for Cortina Access > Presidio Engineering Board > > Signed-off-by: Alex Nemirovsky > CC: Jagan Teki > CC: Vignesh R > CC: Tom Rini > > Add err processing while probe sf device > > --- > > Changes in v10: > - Change

Re: [PATCH v4 00/13] riscv: Add SPI support for Kendryte K210

2020-10-24 Thread Jagan Teki
On Sat, Oct 24, 2020 at 12:14 AM Jagan Teki wrote: > > On Sat, Oct 17, 2020 at 4:28 AM Sean Anderson wrote: > > > > This series adds support for SPI on the Kendryte K210. This covers the MMC > > slot and SPI flash on the Sipeed Maix Bit. > > > > This series makes significant changes to the

Re: [PATCH 2/2] test: unit tests for print_freq(), print_size()

2020-10-24 Thread Tom Rini
On Thu, Oct 22, 2020 at 09:45:28PM +0200, Heinrich Schuchardt wrote: > Provide unit tests for functions print_freq() and print_size(). > > Signed-off-by: Heinrich Schuchardt Applied to u-boot/master, thanks! -- Tom signature.asc Description: PGP signature

Re: [PATCH v2] cmd: fat: Use do_save() for fatwrite

2020-10-24 Thread Tom Rini
On Tue, Oct 20, 2020 at 08:45:46AM +0100, Lad Prabhakar wrote: > do_save() function defined in fs.c also supports FAT file system > re-use the same for fatwrite command. > > Also fix the FAT test script to match the expected output. > > Signed-off-by: Lad Prabhakar > Reviewed-by: Biju Das

Re: [PATCH] bootm: fix wrong conditions about images overlap

2020-10-24 Thread Tom Rini
On Wed, Oct 21, 2020 at 02:17:03PM +0900, Jaehoon Chung wrote: > It doesn't need to consider start byte address. > If ramdisk size is 0x80 and start address is 0x270, then it's > used until 0x02ef, not 0x02f0. But it's detected to overlapt RD > image, when kernel start address is

Re: [PATCH] phy: nop-phy: add clk bulk

2020-10-24 Thread Tom Rini
On Thu, Oct 15, 2020 at 06:05:58PM +0800, Peng Fan wrote: > Add clk bulk for nop-phy driver. > > Signed-off-by: Peng Fan Applied to u-boot/master, thanks! -- Tom signature.asc Description: PGP signature

Re: [PATCH v2 2/2] cmd: Split out timer command from the sleep command

2020-10-24 Thread Tom Rini
On Tue, Oct 13, 2020 at 06:45:06PM +0800, Bin Meng wrote: > From: Bin Meng > > CONFIG_CMD_TIMER merits a single file instead of co-exist in the > sleep command file. > > Signed-off-by: Bin Meng Applied to u-boot/master, thanks! -- Tom signature.asc Description: PGP signature

Re: [PATCH] cmd: Add a 'misc' command to access miscellaneous devices

2020-10-24 Thread Tom Rini
On Wed, Oct 14, 2020 at 02:34:52PM +0800, Bin Meng wrote: > From: Bin Meng > > Enable the command "misc" for accessing miscellaneous devices with > a MISC uclass driver. The command provides listing all MISC devices > as well as read and write functionalities via their drivers. > >

Re: [PATCH] Makefile: Fix u-boot-nodtb.bin target

2020-10-24 Thread Tom Rini
On Wed, Oct 07, 2020 at 03:39:40PM +0200, Pali Rohár wrote: > This change fixes two issues when building u-boot-nodtb.bin target: > > * Remove intermediate binary u-boot-nodtb.bin from disk when static_rela > call (which modifies u-boot-nodtb.bin binary) failed. It is required > because

Re: [PATCH v2 1/2] cmd: Rename CMD_MISC to CMD_SLEEP

2020-10-24 Thread Tom Rini
On Tue, Oct 13, 2020 at 06:45:05PM +0800, Bin Meng wrote: > From: Bin Meng > > The "cmd/Kconfig" has a TODO description for CMD_MISC that it should > really be named as CMD_SLEEP. Change it in the whole source tree. > > Signed-off-by: Bin Meng Applied to u-boot/master, thanks! -- Tom

Re: [PATCH] i2c: i2c-gpio: Convert to use APIs which support live DT

2020-10-24 Thread Tom Rini
On Thu, Sep 10, 2020 at 06:25:09PM +0200, Patrick Delaunay wrote: > Use ofnode_ or dev_ APIs instead of fdt_ and fdtdec_ APIs so that the > driver can support live DT. > > Signed-off-by: Patrick Delaunay > Reviewed-by: Heiko Schocher Applied to u-boot/master, thanks! -- Tom signature.asc

Re: [PATCH 1/2] power: regulator: gpio-regulator: protect count value

2020-10-24 Thread Tom Rini
On Thu, Sep 10, 2020 at 06:18:16PM +0200, Patrick Delaunay wrote: > Update the size of states_array to avoid overflow for > dev_pdata->voltages[j] and dev_pdata->states[j]. > > As the size of array is GPIO_REGULATOR_MAX_STATES, the size of > states_array is limited by GPIO_REGULATOR_MAX_STATES *

Re: [PATCH 1/1] post: remove redundant condition

2020-10-24 Thread Tom Rini
On Mon, Aug 03, 2020 at 10:12:13PM +0200, Heinrich Schuchardt wrote: > (A && A == 0x20) is only true for (A == 0x20). > > Signed-off-by: Heinrich Schuchardt > Reviewed-by: Simon Glass Applied to u-boot/master, thanks! -- Tom signature.asc Description: PGP signature

Re: [PATCH 2/2] power: regulator: gpio-regulator: Convert to use APIs which support live DT

2020-10-24 Thread Tom Rini
On Thu, Sep 10, 2020 at 06:18:17PM +0200, Patrick Delaunay wrote: > Use ofnode_ or dev_ APIs instead of fdt_ and fdtdec_ APIs so that the > driver can support live DT. > > Signed-off-by: Patrick Delaunay > Reviewed-by: Simon Glass Applied to u-boot/master, thanks! -- Tom signature.asc

Re: [PATCH 0/8] PinePhone automatic device tree selection

2020-10-24 Thread Jagan Teki
On Thu, Sep 3, 2020 at 10:37 AM Samuel Holland wrote: > > All, > > This patch series implements a feature to automatically choose the > right PinePhone device tree by probing the hardware. It then extends > the functionality to pass the chosen DTB name to the boot command. > Finally, I add device

Re: [maemo-leste] [PATCH] nokia_rx51: disable obsolete VIDEO config

2020-10-24 Thread Tom Rini
On Sat, Oct 24, 2020 at 12:46:45PM +0200, Merlijn Wajer wrote: > Hi, > > On 24/10/2020 12:06, Pali Rohár wrote: > > On Wednesday 21 October 2020 08:47:02 Tom Rini wrote: > >> On Wed, Oct 21, 2020 at 11:08:37AM +0200, Pali Rohár wrote: > >>> On Tuesday 20 October 2020 10:17:07 Tom Rini wrote: >

Re: [PATCH] nokia_rx51: disable obsolete VIDEO config

2020-10-24 Thread Pali Rohár
On Wednesday 21 October 2020 08:47:02 Tom Rini wrote: > On Wed, Oct 21, 2020 at 11:08:37AM +0200, Pali Rohár wrote: > > On Tuesday 20 October 2020 10:17:07 Tom Rini wrote: > > > On Tue, Oct 20, 2020 at 11:30:51AM +0200, Pali Rohár wrote: > > > > Hello! > > > > > > > > On Sunday 18 October 2020