The definitons of the variable services are adjusted:
- use efi_uintn_t instead of unsigned long
- use u16 * instead of s16 * for Unicode strings
- correct definition of QueryVariableInfo
- rename efi_get_next_variable to efi_get_next_variable_name

A unit test for the variable services is supplied.

Heinrich Schuchardt (2):
  efi_loader: adjust definitions of variable services
  efi_selftest: unit test for variable services

 include/efi_api.h             | 20 ++++++++++----------
 include/efi_loader.h          | 14 +++++++-------
 lib/efi_loader/efi_bootmgr.c  | 10 +++++-----
 lib/efi_loader/efi_runtime.c  | 10 +++++-----
 lib/efi_loader/efi_variable.c | 18 +++++++++---------
 lib/efi_selftest/Makefile     |  1 +
 6 files changed, 37 insertions(+), 36 deletions(-)

-- 
2.17.0

_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
https://lists.denx.de/listinfo/u-boot

Reply via email to