Re: [U-Boot] [PATCH 01/11 v2] drivers/net/vsc9953: Cleanup patch

2015-07-07 Thread Joe Hershberger
Hi Codrin, On Thu, Jul 2, 2015 at 9:32 AM, Codrin Constantin Ciubotariu codrin.ciubota...@freescale.com wrote: Hi Joe, -#define CONFIG_VSC9953_PORT_ENA0x3a00 Why is this value changing? Was it just wrong before? Sorry, I missed this comment. Yes, the correct value that

Re: [U-Boot] [PATCH 01/11 v2] drivers/net/vsc9953: Cleanup patch

2015-07-02 Thread Codrin Constantin Ciubotariu
Hi Joe, -#define CONFIG_VSC9953_PORT_ENA0x3a00 Why is this value changing? Was it just wrong before? Sorry, I missed this comment. Yes, the correct value that only enables the port is 0x2000. The rest of the bits are set to 1 because they are reserved and default

Re: [U-Boot] [PATCH 01/11 v2] drivers/net/vsc9953: Cleanup patch

2015-06-25 Thread Joe Hershberger
Hi Codrin, On Thu, Jun 25, 2015 at 11:35 AM, Codrin Constantin Ciubotariu codrin.ciubota...@freescale.com wrote: Hi Joe, /* alloc eth device */ dev = (struct eth_device *)calloc(1, sizeof(struct eth_device)); if (!dev) - return 1; +

Re: [U-Boot] [PATCH 01/11 v2] drivers/net/vsc9953: Cleanup patch

2015-06-25 Thread Codrin Constantin Ciubotariu
Hi Joe, /* alloc eth device */ dev = (struct eth_device *)calloc(1, sizeof(struct eth_device)); if (!dev) - return 1; + return -1; Is it reasonable to use values from asm/errno.h here and elsewhere in the driver? This seems like

Re: [U-Boot] [PATCH 01/11 v2] drivers/net/vsc9953: Cleanup patch

2015-06-25 Thread Joe Hershberger
Hi Codrin, On Tue, Jun 23, 2015 at 11:48 AM, Codrin Ciubotariu codrin.ciubota...@freescale.com wrote: This patch groups some macros defined for registers and replaces some magic numbers from vsc9953 with macros. Also, port and port_nr keywords are replaced with port_no. Also, in some places,

[U-Boot] [PATCH 01/11 v2] drivers/net/vsc9953: Cleanup patch

2015-06-23 Thread Codrin Ciubotariu
This patch groups some macros defined for registers and replaces some magic numbers from vsc9953 with macros. Also, port and port_nr keywords are replaced with port_no. Also, in some places, this patch replaces in_le32 and out_le32 with clrbits_le32 and setbits_le32 to reduce the number of code