Re: [U-Boot] [PATCH] Makefile: Include vendor common library in include search path

2015-11-07 Thread Tom Rini
On Fri, Nov 06, 2015 at 03:58:17PM -0800, Simon Glass wrote: > Hi, > > On 6 November 2015 at 10:23, Nishanth Menon wrote: > > On 11:10-20151106, Nishanth Menon wrote: > >> On 11/05/2015 10:50 PM, Masahiro Yamada wrote: > >> > 2015-11-06 12:30 GMT+09:00 Nishanth Menon : > >> >> On Thu, Nov 5, 2015

[U-Boot] [PATCH] arm: mxs: add support for I2SE's Duckbill boards

2015-11-07 Thread Michael Heimpold
Signed-off-by: Michael Heimpold --- arch/arm/Kconfig | 8 ++ arch/arm/include/asm/mach-types.h | 13 +++ board/i2se/duckbill/Kconfig | 15 +++ board/i2se/duckbill/MAINTAINERS | 6 ++ board/i2se/duckbill/Makefile | 12 +++ board/i2se/duckbill/duckbill.c| 18

[U-Boot] [PATCH v6 22/23] sf: Drop SPI_FLASH_MTD driver

2015-11-07 Thread Jagan Teki
Now MTD core has been added as part of spi-flash layer, so there is no need for explicit driver for handling mtd stuff, hence removed all neccessary code regarding SPI_FLASH_MTD driver. Signed-off-by: Jagan Teki --- drivers/mtd/spi/Kconfig | 12 - drivers/mtd/spi/Makefile | 1 -

[U-Boot] [PATCH v6 23/23] configs: Remove CONFIG_SPI_FLASH_MTD

2015-11-07 Thread Jagan Teki
No explict spi-flash mtd handling driver, it's been part of spi-flash layer iteself, hence removed it from board configs. Signed-off-by: Jagan Teki --- include/configs/aristainetos-common.h | 1 - include/configs/gw_ventana.h | 1 - include/configs/socfpga_common.h | 1 - 3 files c

[U-Boot] [PATCH v6 21/23] sf: probe: Minor cleanup

2015-11-07 Thread Jagan Teki
- Use static for file-scope function - Remove unneeded header file - Use spi instead of slave notation for spi_slave {} Reviewed-by: Heiko Schocher Signed-off-by: Jagan Teki --- drivers/mtd/spi/sf_probe.c | 14 +++--- 1 file changed, 7 insertions(+), 7 deletions(-) diff --git a/drivers

[U-Boot] [PATCH v6 20/23] sf: Add MTD support for non-dm spi_flash interface

2015-11-07 Thread Jagan Teki
This patch adds MTD support to non-dm spi_flash interface code. Reviewed-by: Heiko Schocher Signed-off-by: Jagan Teki --- drivers/mtd/spi/sf_probe.c | 26 ++ 1 file changed, 14 insertions(+), 12 deletions(-) diff --git a/drivers/mtd/spi/sf_probe.c b/drivers/mtd/spi/sf_p

[U-Boot] [PATCH v6 19/23] sf: Use MTD lock operations

2015-11-07 Thread Jagan Teki
Since the spi-flash framework itself is using core MTD functionalities this patch uses lock operation from mtd. Fabio Estevam Signed-off-by: Jagan Teki --- drivers/mtd/spi/sf_internal.h | 9 - drivers/mtd/spi/sf_ops.c | 383 ++ include/spi_flash.h

[U-Boot] [PATCH v6 18/23] dm-sf: use mtd_ops, drop dm_spi_flash_ops

2015-11-07 Thread Jagan Teki
Since mtd_info ops got introduced, just drop the unneeded dm_spi_flash operations. Reviewed-by: Heiko Schocher Signed-off-by: Jagan Teki --- drivers/mtd/spi/sf-uclass.c | 16 drivers/mtd/spi/sf_probe.c | 30 --- include/spi_flash.h | 90 +++-

[U-Boot] [PATCH v6 17/23] cmd_sf: Use mtd->size instead of flash->size

2015-11-07 Thread Jagan Teki
Since mtd got added, replace flash->size with mtd->size. Reviewed-by: Heiko Schocher Signed-off-by: Jagan Teki --- common/cmd_sf.c | 16 1 file changed, 8 insertions(+), 8 deletions(-) diff --git a/common/cmd_sf.c b/common/cmd_sf.c index 42862d9..d9f1bd1 100644 --- a/common/cm

[U-Boot] [PATCH v6 14/23] dm-sf: Re-factorize spi_flash_std_probe code

2015-11-07 Thread Jagan Teki
spi_flash_probe_tail code looks not in proper shape to add more functionalities. hence refactorized so-that it's more readable and hence we may extend more functionalies to it. Cc: Bin Meng Cc: Troy Kisky Signed-off-by: Jagan Teki --- drivers/mtd/spi/sf_probe.c | 20 +--- 1 fil

[U-Boot] [PATCH v6 16/23] sf: Use mtd_info ops instead of spi_flash ops

2015-11-07 Thread Jagan Teki
Since MTD support is added in spi_flash layer, this patch uses mtd_info operations instead of legacy spi_flash operations. Reviewed-by: Heiko Schocher Signed-off-by: Jagan Teki --- drivers/mtd/spi/sf_ops.c | 66 include/spi_flash.h | 23

[U-Boot] [PATCH v6 15/23] sf: Add MTD support to spi_flash

2015-11-07 Thread Jagan Teki
This patch adds mtd_info support to spi_flash layer, MTD has proven core for flash operations so adding MTD to spi_flash will extends more functionality. Reviewed-by: Heiko Schocher Signed-off-by: Jagan Teki --- drivers/mtd/spi/sf_ops.c | 45 + driv

[U-Boot] [PATCH v6 09/23] sf: Flash power up read-only based on idcode0

2015-11-07 Thread Jagan Teki
Using macro's for flash power up read-only access code leads wrong behaviour hence use idcode0 for runtime detection, hence the flash which require this functionality gets detected at runtime. Signed-off-by: Jagan Teki --- drivers/mtd/spi/sf_internal.h | 2 ++ drivers/mtd/spi/sf_ops.c | 7 +

[U-Boot] [PATCH v6 13/23] sf: Re-factorize spi_flash_probe_tail code

2015-11-07 Thread Jagan Teki
spi_flash_probe_tail code looks not in proper shape to add more functionalities. hence refactorized so-that it's more readable and hence we may extend more functionalies to it. Cc: Bin Meng Cc: Troy Kisky Signed-off-by: Jagan Teki --- drivers/mtd/spi/sf_internal.h | 3 +- drivers/mtd/spi/sf_o

[U-Boot] [PATCH v6 11/23] sf: Remove unneeded header includes

2015-11-07 Thread Jagan Teki
Removed unneeded header includes in sf_ops and sf_probe Signed-off-by: Jagan Teki --- drivers/mtd/spi/sf_ops.c | 2 -- drivers/mtd/spi/sf_probe.c | 3 --- 2 files changed, 5 deletions(-) diff --git a/drivers/mtd/spi/sf_ops.c b/drivers/mtd/spi/sf_ops.c index 7638cb1..e4f841b 100644 --- a/drive

[U-Boot] [PATCH v6 12/23] sf: probe: Use spi_flash_scan in dm-spi-flash

2015-11-07 Thread Jagan Teki
This patch add support to use spi_flash_scan in dm-spi-flash probe, so-that it can access the spi_flash functionalities same as non-dm sf probe. Signed-off-by: Jagan Teki --- drivers/mtd/spi/sf_probe.c | 28 +--- 1 file changed, 25 insertions(+), 3 deletions(-) diff --gi

[U-Boot] [PATCH v6 10/23] sf: Use static for file-scope functions

2015-11-07 Thread Jagan Teki
Use static for file-scope functions and removed them from header files. Signed-off-by: Jagan Teki --- drivers/mtd/spi/sf_internal.h | 21 - drivers/mtd/spi/sf_ops.c | 11 ++- 2 files changed, 6 insertions(+), 26 deletions(-) diff --git a/drivers/mtd/spi/sf_inter

[U-Boot] [PATCH v6 07/23] sf: Use simple name for register access functions

2015-11-07 Thread Jagan Teki
Most of the register access function are static, so used simple name to represent each. Signed-off-by: Jagan Teki --- drivers/mtd/spi/sf_ops.c | 42 +- 1 file changed, 21 insertions(+), 21 deletions(-) diff --git a/drivers/mtd/spi/sf_ops.c b/drivers/mtd/s

[U-Boot] [PATCH v6 06/23] sf: Fix Makefile

2015-11-07 Thread Jagan Teki
This patch removes unneeded ifdef and fixed accordingly. Signed-off-by: Jagan Teki --- drivers/mtd/spi/Makefile | 6 +- 1 file changed, 1 insertion(+), 5 deletions(-) diff --git a/drivers/mtd/spi/Makefile b/drivers/mtd/spi/Makefile index ff48b25..66c4424 100644 --- a/drivers/mtd/spi/Makefil

[U-Boot] [PATCH v6 08/23] sf: Use flash function pointers in dm_spi_flash_ops

2015-11-07 Thread Jagan Teki
flash operations are defined as static and reuse them with function-pointers so call them with generic function pounters instead of calling like normal functions. Signed-off-by: Jagan Teki --- drivers/mtd/spi/sf_ops.c | 2 -- drivers/mtd/spi/sf_probe.c | 15 +++ include/spi_flash.

[U-Boot] [PATCH v6 05/23] sf: Use static for file-scope functions

2015-11-07 Thread Jagan Teki
Use static for file-scope functions and removed them from header files. Signed-off-by: Jagan Teki --- drivers/mtd/spi/sf_internal.h | 18 -- drivers/mtd/spi/sf_ops.c | 11 ++- 2 files changed, 6 insertions(+), 23 deletions(-) diff --git a/drivers/mtd/spi/sf_internal

[U-Boot] [PATCH v6 04/23] sf: probe: Code cleanup

2015-11-07 Thread Jagan Teki
- Move bar read code below the bar write hance both at once place, hence it easy for #ifdef macro only once and readable. - Move read_cmd_array at top Signed-off-by: Jagan Teki --- drivers/mtd/spi/sf_ops.c | 80 +++- 1 file changed, 39 insertions(+

[U-Boot] [PATCH v6 03/23] sf: Move read_id code to sf_ops

2015-11-07 Thread Jagan Teki
read_id code is related to spi_flash stuff hence moved to sf_ops. Signed-off-by: Jagan Teki --- drivers/mtd/spi/sf_internal.h | 3 +-- drivers/mtd/spi/sf_ops.c | 21 ++--- drivers/mtd/spi/sf_probe.c| 15 +-- 3 files changed, 20 insertions(+), 19 deletions(-)

[U-Boot] [PATCH v6 00/23] sf: MTD support

2015-11-07 Thread Jagan Teki
This series is combination of mtd and sf tunning stuff in previous version patches. This is whole patch series for add mtd support to spi-flash framework and related stuff. The idea is to introduce the spi-nor flash framework which similar to Linux with driver-model support. spi-nor looks:

[U-Boot] [PATCH v6 02/23] sf: Move spi_flash_scan code to sf_ops

2015-11-07 Thread Jagan Teki
Intension is that sf_ops should deals all spi_flash related stuff and sf_probe (which should renamed future) should be an interface layer for spi_flash versus spi drivers. sf_ops => spi_flash interface sf_probe => interface layer vs spi_flash(sf_probe) to spi drivers Signed-off-by: Jagan Teki --

[U-Boot] [PATCH v6 01/23] sf: spi_flash_validate_params => spi_flash_scan

2015-11-07 Thread Jagan Teki
Rename spi_flash_validate_params to spi_flash_scan as this code not only deals with params setup but also configure all spi_flash attributes. And also moved all flash related code into spi_flash_scan for future functionality addition. Signed-off-by: Jagan Teki --- drivers/mtd/spi/sf_probe.c | 1

Re: [U-Boot] [PATCH v4 1/3] dm: implement a MTD uclass

2015-11-07 Thread Thomas Chou
HI Jagan, On 2015年11月07日 20:35, Jagan Teki wrote: It seems we are working toward the same direction. :) Sorry, I couldn't understand this looks we're in different direction. Let me explain what I thought about mtd_info usage. udevice should be part of underlying flash structure's like cfi, na

Re: [U-Boot] Pull request: u-boot-nios/master

2015-11-07 Thread Tom Rini
On Fri, Nov 06, 2015 at 01:38:04PM +0800, Thomas Chou wrote: > Hi Tom, > > Please pull, > > The following changes since commit ed02c532be690b3d0c3e15c81531785a788fd949: > > Merge branch 'master' of git://git.denx.de/u-boot-video (2015-11-05 > 07:47:21 -0500) > > are available in the git rep

Re: [U-Boot] [GIT PULL] u-boot-mips/master

2015-11-07 Thread Tom Rini
On Fri, Nov 06, 2015 at 02:10:06PM +0100, Daniel Schwierzeck wrote: > Hi Tom, > > please pull the MIPS bootm fixes, thanks. > > > The following changes since commit ed02c532be690b3d0c3e15c81531785a788fd949: > > Merge branch 'master' of git://git.denx.de/u-boot-video (2015-11-05 > 07:47:21 -

[U-Boot] [PATCH] ARM: omap3_logic: Fix pin muxing

2015-11-07 Thread Adam Ford
>From 83fc9aee5fa80a3f671966e0ca9569eeb372b160 Mon Sep 17 00:00:00 2001 From: Adam Ford Date: Sat, 7 Nov 2015 05:52:10 -0600 Subject: [PATCH 41/41] ARM: omap3_logic: Fix pin muxing Enhance pin muxing to enable more board features and reduce power based on Tony's device tree work. Signed-off-by:

[U-Boot] [PATCH v3] mtd: add altera quadspi driver

2015-11-07 Thread Thomas Chou
Add Altera Generic Quad SPI Controller support. The controller converts SPI NOR flash to parallel flash interface. So it is not like other SPI flash, but rather like CFI flash. Signed-off-by: Thomas Chou --- v2 use memcpy_toio() for mtd_write() as suggested by Chin Liang and Marek. v3 use a