Re: [U-Boot] [RFC V1] arm: config: enforce -fno-pic for gcc

2015-12-30 Thread Peng Fan
Hi Albert, Gentle ping! Sorry for missing to mail you when I sent out the patch. Thanks, Peng. On Mon, Dec 14, 2015 at 03:28:56PM +0800, Peng Fan wrote: >Hi Albert, > >Do you have any comments on this patch? > >Regards, >Peng. > >On Sat, Dec 05, 2015 at 03:53:46PM +0800, Peng Fan wrote:

[U-Boot] [PATCH V3] usb:ci_udc: Remove ULPI setting for i.MX OTG controller

2015-12-30 Thread Peng Fan
From: "Ye.Li" All the i.MX6, i.MX23 and i.MX28 OTG controllers only support UTMI interface. Set to ULPI is not correct, even the controller will reject this setting in PORTSC register. Signed-off-by: Ye.Li Signed-off-by: Peng Fan

[U-Boot] [PATCH v4 1/8] x86: qemu: add fw_cfg support

2015-12-30 Thread Miao Yan
The QEMU fw_cfg interface allows the guest to retrieve various data information from QEMU. For example, APCI/SMBios tables, number of online cpus, kernel data and command line, etc. This patch adds support for QEMU fw_cfg interface. Signed-off-by: Miao Yan --- Changes in

[U-Boot] [PATCH v4 5/8] x86: qemu: add qemu_fwcfg_fdt_fixup()

2015-12-30 Thread Miao Yan
Add a function to fix up 'cpus' node in dts files for qemu target. Signed-off-by: Miao Yan --- Changes in v4: - fix a typo in commit log arch/x86/cpu/qemu/fw_cfg.c | 65 ++ arch/x86/cpu/qemu/fw_cfg.h | 11 2 files

[U-Boot] [PATCH v4 4/8] x86: use actual CPU number for allocating memory

2015-12-30 Thread Miao Yan
Use actual CPU number, instead of maximum cpu configured, to allocate stack memory in 'load_sipi_vector' Signed-off-by: Miao Yan --- arch/x86/cpu/mp_init.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/arch/x86/cpu/mp_init.c

[U-Boot] [PATCH v4 6/8] x86: qemu: fix up cpu node in device tree

2015-12-30 Thread Miao Yan
Remove 'cpus' node in dts files for QEMU targets, retrieve cpu number through 'fw_cfg' interface and fix up device tree blob at runtime. Signed-off-by: Miao Yan --- arch/x86/cpu/qemu/qemu.c | 4 arch/x86/dts/qemu-x86_i440fx.dts | 19 +--

[U-Boot] [PATCH v4 7/8] x86: qemu: adjust ramdisk load address

2015-12-30 Thread Miao Yan
By default, ramdisk load address is defined to 0200 in env string. When loading bzImage to 10 (default address), there's a chance that the ramdisk header would be overwritten by the kernel. Thus increase the gap and make ramdisk load at 0400 by default. Signed-off-by: Miao Yan

[U-Boot] [PATCH v4 3/8] x86: fix a typo in function name

2015-12-30 Thread Miao Yan
Rename 'find_cpu_by_apid_id' to 'find_cpu_by_apic_id'. This should be a typo. Signed-off-by: Miao Yan --- arch/x86/cpu/mp_init.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/arch/x86/cpu/mp_init.c b/arch/x86/cpu/mp_init.c index

[U-Boot] [PATCH v4 8/8] x86: qemu: add documentaion for the fw_cfg interface

2015-12-30 Thread Miao Yan
Document the usage of 'fw' command Signed-off-by: Miao Yan --- Changes in v4: - limit maximum supported cpu number to 32 doc/README.x86 | 35 --- 1 file changed, 32 insertions(+), 3 deletions(-) diff --git a/doc/README.x86

Re: [U-Boot] [PATCH v4 5/8] x86: qemu: add qemu_fwcfg_fdt_fixup()

2015-12-30 Thread Simon Glass
Hi Maio, On 30 December 2015 at 19:55, Miao Yan wrote: > Add a function to fix up 'cpus' node in dts files for qemu target. > > Signed-off-by: Miao Yan > --- > Changes in v4: > - fix a typo in commit log > > arch/x86/cpu/qemu/fw_cfg.c | 65 >

Re: [U-Boot] [PATCH v4 4/8] x86: use actual CPU number for allocating memory

2015-12-30 Thread Simon Glass
On 30 December 2015 at 19:55, Miao Yan wrote: > Use actual CPU number, instead of maximum cpu configured, > to allocate stack memory in 'load_sipi_vector' > > Signed-off-by: Miao Yan > --- > arch/x86/cpu/mp_init.c | 6 +++--- > 1 file changed, 3

Re: [U-Boot] [PATCH v4 7/8] x86: qemu: adjust ramdisk load address

2015-12-30 Thread Simon Glass
Hi Miao, On 30 December 2015 at 19:55, Miao Yan wrote: > By default, ramdisk load address is defined to 0200 in > env string. When loading bzImage to 10 (default address), there's > a chance that the ramdisk header would be overwritten by > the kernel. Thus

Re: [U-Boot] [PATCH v4 8/8] x86: qemu: add documentaion for the fw_cfg interface

2015-12-30 Thread Simon Glass
Hi Miao, On 30 December 2015 at 19:55, Miao Yan wrote: > Document the usage of 'fw' command > > Signed-off-by: Miao Yan > --- > Changes in v4: > - limit maximum supported cpu number to 32 > > doc/README.x86 | 35

Re: [U-Boot] [PATCH v4 1/8] x86: qemu: add fw_cfg support

2015-12-30 Thread Simon Glass
Hi Miao, On 30 December 2015 at 19:55, Miao Yan wrote: > The QEMU fw_cfg interface allows the guest to retrieve various > data information from QEMU. For example, APCI/SMBios tables, number > of online cpus, kernel data and command line, etc. > > This patch adds support

Re: [U-Boot] [PATCH v4 3/8] x86: fix a typo in function name

2015-12-30 Thread Simon Glass
On 30 December 2015 at 19:55, Miao Yan wrote: > Rename 'find_cpu_by_apid_id' to 'find_cpu_by_apic_id'. This > should be a typo. > > Signed-off-by: Miao Yan > --- > arch/x86/cpu/mp_init.c | 6 +++--- > 1 file changed, 3 insertions(+), 3 deletions(-)

Re: [U-Boot] [PATCH v4 2/8] x86: qemu: add a cpu uclass driver for qemu target

2015-12-30 Thread Simon Glass
On 30 December 2015 at 19:55, Miao Yan wrote: > Add a cpu uclass driver for qemu. Previously, the qemu > target gets cpu number from board dts files, which are > manually created at compile time. This does not scale > when more cpus are assigned to guest as the dts files >

[U-Boot] sf: About sandbox flash driver

2015-12-30 Thread Jagan Teki
Hi Simon, Few question wrt sandbox flash driver - drivers/mtd/spi/sandbox.c 1) Does this driver used for creating flash emulation environment? or something else? 2) Can't it use spi_flash.c core for all spi flash operations, how different is this? Please let me know your inputs. thanks! --

Re: [U-Boot] [PATCH] igep00x0: Do not include config_distro_defaults.h directly

2015-12-30 Thread Enric Balletbo Serra
Hi Ladislav, Thanks for the patch, some comments below 2015-12-30 2:50 GMT+01:00 Ladislav Michl : > File is already included: > omap3_igep00x0.h -> ti_omap3_common.h -> ti_armv7_omap.h -> > ti_armv7_common.h -> config_distro_defaults.h > > Signed-off-by: Ladislav Michl

Re: [U-Boot] [PATCH 1/2] arm: Replace test for CONFIG_ARMV7 with CONFIG_CPU_V7

2015-12-30 Thread Albert ARIBAUD
Hello Marek, On Tue, 29 Dec 2015 19:44:01 +0100, Marek Vasut wrote: > The arch/arm/lib/cache-cp15.c checks for CONFIG_ARMV7 and if this macro is > set, it configures TTBR0 register. This register must be configured for the > cache on ARMv7 to operate correctly. > > The problem is

Re: [U-Boot] [PATCH] nios2: set up the debug UART early

2015-12-30 Thread Chin Liang See
On Wed, 2015-12-30 at 20:32 +0800, Thomas Chou wrote: > Set up the debug UART early if enabled, so that it is ready to use. > > Signed-off-by: Thomas Chou > --- > arch/nios2/cpu/start.S | 7 +++ > 1 file changed, 7 insertions(+) > > Acked-by: Chin Liang See

[U-Boot] [PATCH v4 2/8] x86: qemu: add a cpu uclass driver for qemu target

2015-12-30 Thread Miao Yan
Add a cpu uclass driver for qemu. Previously, the qemu target gets cpu number from board dts files, which are manually created at compile time. This does not scale when more cpus are assigned to guest as the dts files must be modified as well. This patch adds a cpu uclass driver for qemu targets

[U-Boot] [PATCH v4 0/8] x86: qemu: add fw_cfg interface support for qemu-x86 targets

2015-12-30 Thread Miao Yan
The fw_cfg interface provided by QEMU allow guests to retrieve various information about the system, e.g. cpu number, variaous firmware data, kernel setup, etc. The fw_cfg interface can be accessed through 3 IO ports (on x86), using x86 in/out instructions. - 0x510: select configuration items

Re: [U-Boot] [PATCH v2 0/8] sf: Add flash_ids inside Core

2015-12-30 Thread Jagan Teki
Hi Bin, On 30 December 2015 at 10:15, Bin Meng wrote: > Hi Jagan, > > On Tue, Dec 29, 2015 at 5:49 PM, Jagan Teki wrote: >> This series handle flash_ids stuff inside spi_flash core. >> >> Changes for v2: >> - Remove SECT_4K flag for s25fl128s >>

Re: [U-Boot] [PATCH v5 4/5] mips: ath79: add spi driver

2015-12-30 Thread Antony Pavlov
On Wed, 30 Dec 2015 01:51:47 +0100 Marek Vasut wrote: > On Wednesday, December 30, 2015 at 12:46:23 AM, Thomas Chou wrote: > > Hi Marek, > > > > On 2015年12月29日 21:25, Marek Vasut wrote: > > > On Tuesday, December 29, 2015 at 02:00:27 PM, Thomas Chou wrote: > > >> Hi Wills, > > >>

Re: [U-Boot] [PATCH v3 7/8] x86: reserve more spaces for dtb

2015-12-30 Thread Miao Yan
Hi Bin, 2015-12-30 12:04 GMT+08:00 Bin Meng : > Hi Miao, > > On Tue, Dec 29, 2015 at 6:35 PM, Miao Yan wrote: >> Reserve more spaces for x86 dtb files. Otherwise when booting >> on qemu targets, fixing 'cpu' node may fail due to lack >> of space left in

Re: [U-Boot] [PATCH v3 8/8] x86: qemu: add documentaion for the fw_cfg interface

2015-12-30 Thread Miao Yan
Hi Bin, 2015-12-30 12:04 GMT+08:00 Bin Meng : > Hi Miao, > > On Tue, Dec 29, 2015 at 6:35 PM, Miao Yan wrote: >> Document the usage of 'fw' command >> >> Signed-off-by: Miao Yan >> --- >> Changes in v2: >> - various cleanup >>

Re: [U-Boot] [Patch V3] i2c: mxc: add a condition in case the parameter is NULL

2015-12-30 Thread Qianyu Gong
Hi Stefano, Could you please help to merge this patch? Thanks very much. Regards, Qianyu > -Original Message- > From: Qianyu Gong > Sent: Monday, December 21, 2015 1:42 PM > To: h...@denx.de; Gong Qianyu-B52263 > Cc: u-boot@lists.denx.de; Stefano Babic

Re: [U-Boot] [PATCH 0/3] This series adds support for fastboot related to USB.

2015-12-30 Thread Lukasz Majewski
Hi Frank > [PATCH 1/3] Modified the check condition for max packet size of > ep_in in high speed > > [PATCH 2/3] Fixed the error that the last packet transmission could > not be terminated > > [PATCH 3/3] Add usb phy control to support fastboot for rk3036 > > Tested on RK3036 SDK board, it

Re: [U-Boot] [PATCH v2 0/8] sf: Add flash_ids inside Core

2015-12-30 Thread Mugunthan V N
On Tuesday 29 December 2015 03:19 PM, Jagan Teki wrote: > This series handle flash_ids stuff inside spi_flash core. > > Changes for v2: > - Remove SECT_4K flag for s25fl128s > > Jagan Teki (8): > sf: Add spi_flash_ids local to core > sf: Rename SST_WR to SST_WRITE > sf: Remove

[U-Boot] Pull request: u-boot-spi/next

2015-12-30 Thread Jagan Teki
Hi Tom, Please pull this PR. thanks! Jagan. The following changes since commit 312db9f75f50b339310474d72c8524cef2bd7931: armv7: omap-common: Rework SPL board_mmc_init() (2015-12-14 13:42:54 -0500) are available in the git repository at: git://git.denx.de/u-boot-spi.git master for you to

Re: [U-Boot] [PATCH v3 1/8] x86: qemu: add fw_cfg support

2015-12-30 Thread Miao Yan
Hi Bin, 2015-12-30 12:04 GMT+08:00 Bin Meng : > Hi Miao, > > On Tue, Dec 29, 2015 at 6:35 PM, Miao Yan wrote: >> The QEMU fw_cfg interface allows the guest to retrieve various >> data information from QEMU. For example, APCI/SMBios tables, number >> of

Re: [U-Boot] [PATCH v5 4/5] mips: ath79: add spi driver

2015-12-30 Thread Marek Vasut
On Wednesday, December 30, 2015 at 09:32:52 AM, Antony Pavlov wrote: > On Wed, 30 Dec 2015 01:51:47 +0100 > > Marek Vasut wrote: > > On Wednesday, December 30, 2015 at 12:46:23 AM, Thomas Chou wrote: > > > Hi Marek, > > > > > > On 2015年12月29日 21:25, Marek Vasut wrote: > > > > On

Re: [U-Boot] [PATCH 1/2] spl: dm: Add SPL_DM_SEQ_ALIAS config option

2015-12-30 Thread Marek Vasut
On Wednesday, December 30, 2015 at 06:52:24 AM, Nathan Rossi wrote: [...] > > TBH I don't think this is the best solution. We should select things > > which are required all the time. For zynq case this selection is > > necessary just for qspi boot mode. There are other boot modes which > >

Re: [U-Boot] Pull request: u-boot-spi/next

2015-12-30 Thread Jagan Teki
Tom, Please note that subject shows u-boot-spi/next but it actually u-boot-spi/master and of course PR shows the repo as master (not next). On 30 December 2015 at 16:01, Jagan Teki wrote: > Hi Tom, > > Please pull this PR. > > thanks! > Jagan. > > The following changes since

Re: [U-Boot] [PATCH v2 8/8] sf: Fix few naming convension for read modes

2015-12-30 Thread Mugunthan V N
On Tuesday 29 December 2015 03:19 PM, Jagan Teki wrote: > spi_read_cmds => read_mode > e_rd_cmd => flash_read > spi_read_cmds_array => flash_read_cmd > > All these are flash specific notation used in spi_flash > core hence renamed to proper naming convensions related > to flash. $sub and

[U-Boot] [PATCH v2] Fix GCC format-security errors and convert sprintfs.

2015-12-30 Thread ben . whitten
From: Ben Whitten With format-security errors turned on, GCC picks up the use of sprintf with a format parameter not being a string literal. Simple uses of sprintf are also converted to use strcpy. Signed-off-by: Ben Whitten --- Changes for v2:

[U-Boot] [PATCH] nios2: set up the debug UART early

2015-12-30 Thread Thomas Chou
Set up the debug UART early if enabled, so that it is ready to use. Signed-off-by: Thomas Chou --- arch/nios2/cpu/start.S | 7 +++ 1 file changed, 7 insertions(+) diff --git a/arch/nios2/cpu/start.S b/arch/nios2/cpu/start.S index 54787c5..1caee0c 100644 ---