Re: [U-Boot] [PATCH v4 5/8] x86: qemu: add qemu_fwcfg_fdt_fixup()

2015-12-31 Thread Miao Yan
Hi Simon, 2015-12-31 13:08 GMT+08:00 Simon Glass : > Hi Maio, > > On 30 December 2015 at 19:55, Miao Yan wrote: >> Add a function to fix up 'cpus' node in dts files for qemu target. >> >> Signed-off-by: Miao Yan >> --- >> Changes

[U-Boot] [PATCH 0/8] arm: ls1021atwr: Convert to driver model and enable serial support

2015-12-31 Thread Bin Meng
This series converts Freescale LS1021A-TWR board to driver model. - Enable ns16550 serial driver on ls1021atwr_nor configuration - Convert LPUART serial driver to driver model - Enable LPUART serial driver on ls1021atwr_nor_lpuart configuration Bin Meng (8): fdt: Fix up stdout correctly

[U-Boot] [PATCH 2/8] arm: ls1021atwr: Convert to driver model and enable serial support

2015-12-31 Thread Bin Meng
Convert ls1021atwr_nor to driver model support. As a start, enable ns16550 serial port driver. Signed-off-by: Bin Meng --- arch/arm/dts/ls1021a-twr.dts | 4 arch/arm/dts/ls1021a.dtsi| 4 configs/ls1021atwr_nor_defconfig | 4

[U-Boot] [PATCH 4/8] serial: lpuart: Fix several cosmetic issues

2015-12-31 Thread Bin Meng
Clean up the driver codes a little bit, by: - Use tab instead of space in the macro defines - Use single line comment whenever possible - Fix insertion of blank lines Signed-off-by: Bin Meng --- drivers/serial/serial_lpuart.c | 35 +++ 1 file

Re: [U-Boot] [PATCH V3] usb:ci_udc: Remove ULPI setting for i.MX OTG controller

2015-12-31 Thread Marek Vasut
On Thursday, December 31, 2015 at 08:24:45 AM, Peng Fan wrote: > From: "Ye.Li" > > All the i.MX6, i.MX23 and i.MX28 OTG controllers only support UTMI > interface. Set to ULPI is not correct, even the controller will > reject this setting in PORTSC register. > >

Re: [U-Boot] [PATCH] cmd_pci: Check for VendorID earlier

2015-12-31 Thread Bin Meng
+Alison, York, Hi, On Fri, Oct 9, 2015 at 9:44 PM, Simon Glass wrote: > Hi Fabio, > > On 9 October 2015 at 14:36, Fabio Estevam wrote: >> On Fri, Oct 9, 2015 at 10:31 AM, Simon Glass wrote: >> >>> If you look down one more level, these

Re: [U-Boot] [PATCH v4 1/8] x86: qemu: add fw_cfg support

2015-12-31 Thread Miao Yan
Hi Simon, 2015-12-31 13:07 GMT+08:00 Simon Glass : > Hi Miao, > > On 30 December 2015 at 19:55, Miao Yan wrote: >> The QEMU fw_cfg interface allows the guest to retrieve various >> data information from QEMU. For example, APCI/SMBios tables, number >> of

[U-Boot] [PULL] u-boot-usb/master

2015-12-31 Thread Marek Vasut
The following changes since commit 78680314c53a95c0bb25e942662979843b60d7b9: Merge branch 'master' of http://git.denx.de/u-boot-sunxi (2015-12-27 09:15:57 -0500) are available in the git repository at: git://git.denx.de/u-boot-usb.git master for you to fetch changes up to

[U-Boot] [PATCH v3 10/10] sf: Drop sf_params.c

2015-12-31 Thread Jagan Teki
sf_params.c is not used anywhere in the code, hence removed the same. Cc: Simon Glass Cc: Bin Meng Cc: Mugunthan V N Tested-by: Jagan Teki Signed-off-by: Jagan Teki ---

[U-Boot] [PATCH v3 01/10] sf: Add spi_flash_ids local to core

2015-12-31 Thread Jagan Teki
This patch add's spi_flash_ids handling into core, instead of maintaining it into separate file like sf_params.c Code taken from the Linux spi-nor core and added missing part id's and also added extra flash_info member as e_rd_cmd for computing fastest read command. Cc: Simon Glass

[U-Boot] [PATCH v3 00/10] sf: Add flash_ids inside Core

2015-12-31 Thread Jagan Teki
This series handle flash_ids stuff inside spi_flash core. Changes for v3: - Updated SNOR_F_SST_WRITE at sf_probe.c - two patches, wrt sanbox newly added Changes for v2: - Remove SECT_4K flag for s25fl128s Jagan Teki (10): sf: Add spi_flash_ids local to core

[U-Boot] [PATCH 5/8] serial: lpuart: Call local version of setbrg and putc directly

2015-12-31 Thread Bin Meng
There is no need to go through serial driver subsystem, instead call the driver's setbrg and putc routines directly. Signed-off-by: Bin Meng --- drivers/serial/serial_lpuart.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git

[U-Boot] [PATCH 6/8] serial: lpuart: Prepare the driver for DM conversion

2015-12-31 Thread Bin Meng
Create internal routines which take lpuart's register base as a parameter, in preparation for driver model conversion. Signed-off-by: Bin Meng --- drivers/serial/serial_lpuart.c | 146 +++-- 1 file changed, 95 insertions(+), 51

[U-Boot] [PATCH 8/8] arm: ls1021atwr: Enable driver model lpuart serial driver

2015-12-31 Thread Bin Meng
Convert ls1021atwr_nor_lpuart to driver model support. As a start, enable lpuart serial port driver. Signed-off-by: Bin Meng --- arch/arm/dts/ls1021a-twr.dts| 4 configs/ls1021atwr_nor_lpuart_defconfig | 4 2 files changed, 8 insertions(+) diff --git

[U-Boot] [PATCH 3/8] serial: lpuart: Move CONFIG_FSL_LPUART to Kconfig

2015-12-31 Thread Bin Meng
LPUART is seen on Freescale VF610 and QorIQ Layerscape devices. Create a Kconfig option and move it to defconfig for all boards that have this serial driver. Signed-off-by: Bin Meng --- configs/colibri_vf_defconfig | 1 + configs/colibri_vf_dtb_defconfig

[U-Boot] [PATCH 7/8] serial: lpuart: Add driver model serial support

2015-12-31 Thread Bin Meng
This adds driver model support to lpuart serial driver. Signed-off-by: Bin Meng --- doc/driver-model/serial-howto.txt | 1 - drivers/serial/serial_lpuart.c| 157 ++ 2 files changed, 157 insertions(+), 1 deletion(-) diff --git

[U-Boot] [PATCH 1/8] fdt: Fix up stdout correctly in fdt_fixup_stdout()

2015-12-31 Thread Bin Meng
When CONFIG_OF_STDOUT_VIA_ALIAS is on, always fix up kernel's stdout string with hardcoded CONFIG_CONS_INDEX. This actually reverts commit 3e303f748cf57fb23e8ec95ab7eac0074be50e2b "fdt_support: Add multi-serial support for stdout fixup", as the fix up in the /aliases node did not work under the

[U-Boot] [PATCH v3 09/10] sf: sandbox: Move spi_flash_params_table

2015-12-31 Thread Jagan Teki
Since spi_flash_params_table data is only used by sandbox, so this patch moves the spi_flash_params_table data from sf_params.c to sandbox. Cc: Simon Glass Cc: Bin Meng Cc: Mugunthan V N Tested-by: Jagan Teki

[U-Boot] [PATCH v3 02/10] sf: Rename SST_WR to SST_WRITE

2015-12-31 Thread Jagan Teki
SST_WR => SST_WRITE Cc: Simon Glass Cc: Bin Meng Cc: Michal Simek Cc: Siva Durga Prasad Paladugu Tested-by: Mugunthan V N Tested-by: Jagan Teki Signed-off-by: Jagan

[U-Boot] [PATCH v3 06/10] sf: Add SECT_4K_PMC

2015-12-31 Thread Jagan Teki
Add SECT_4K_PMC for erase 4KiB block on PMC chips. Cc: Simon Glass Cc: Bin Meng Cc: Michal Simek Cc: Siva Durga Prasad Paladugu Tested-by: Mugunthan V N Tested-by: Jagan Teki

[U-Boot] [PATCH v3 03/10] sf: Remove SPI_NOR_DUAL|QUAD_READ

2015-12-31 Thread Jagan Teki
Since flash_info hadle all read modes through e_rd_cmd there is no explicit flags for these, hence removed the same. Cc: Simon Glass Cc: Bin Meng Cc: Michal Simek Cc: Siva Durga Prasad Paladugu Tested-by:

[U-Boot] [PATCH v3 05/10] sf: Remove SECT_32K

2015-12-31 Thread Jagan Teki
None of the flash part is using SECT_32K in spi_flash_ids hence removed the same. Cc: Simon Glass Cc: Bin Meng Cc: Michal Simek Cc: Siva Durga Prasad Paladugu Tested-by: Mugunthan V N

[U-Boot] [PATCH v3 04/10] sf: Use sf_params in sandbox

2015-12-31 Thread Jagan Teki
sandbox.c is using sf_params, so move sf_params.o to sandbox build. Cc: Simon Glass Cc: Bin Meng Tested-by: Mugunthan V N Tested-by: Jagan Teki Signed-off-by: Jagan Teki ---

[U-Boot] [PATCH v3 07/10] sf: Use CONFIG_SPI_FLASH_USE_4K_SECTORS

2015-12-31 Thread Jagan Teki
Used CONFIG_SPI_FLASH_USE_4K_SECTORS core itself for usage of 4K_SECTORS. Cc: Simon Glass Cc: Bin Meng Cc: Michal Simek Cc: Siva Durga Prasad Paladugu Tested-by: Mugunthan V N Tested-by:

[U-Boot] [PATCH v3 08/10] sf: Fix few naming convention for read modes

2015-12-31 Thread Jagan Teki
spi_read_cmds => read_mode e_rd_cmd => flash_read spi_read_cmds_array => flash_read_cmd All these are flash specific notation used in spi_flash core hence renamed to proper naming conventions related to flash. Cc: Simon Glass Cc: Bin Meng Cc: Michal

Re: [U-Boot] [PATCH v3 1/5] lib: Add wait_for_bit

2015-12-31 Thread Mateusz Kulikowski
@Tom: I forgot to add you on CC :( I think this patch goes to you. On Sun, Dec 27, 2015 at 06:28:08PM +0100, Mateusz Kulikowski wrote: > Add function to poll register waiting for specific bit(s). > Similar functions are implemented in few drivers - they are almost > identical and can be

[U-Boot] [Patch V2 3/3] armv8/ls1043aqds: enable qixis_reset command to boot from NAND/SD

2015-12-31 Thread Gong Qianyu
From: Gong Qianyu Signed-off-by: Gong Qianyu --- V2: - No change. include/configs/ls1043aqds.h | 4 1 file changed, 4 insertions(+) diff --git a/include/configs/ls1043aqds.h b/include/configs/ls1043aqds.h index bfbfcb6..43107b0

[U-Boot] [Patch V2 0/3] QIXIS related patches

2015-12-31 Thread Gong Qianyu
Hi all, The version 2 patchset fixed to: - use qixis_write_i2c() instead of QIXIS_WRITE once QSPI is enabled. [Patch V2 1/3] freescale/qixis: Add support for booting from SD/QSPI [Patch V2 2/3] armv8/ls1043aqds: fix qixis_reset command issue [Patch V2 3/3] armv8/ls1043aqds: enable qixis_reset

[U-Boot] [Patch V2 2/3] armv8/ls1043aqds: fix qixis_reset command issue

2015-12-31 Thread Gong Qianyu
From: Gong Qianyu Signed-off-by: Gong Qianyu --- V2: - No change. include/configs/ls1043aqds.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/include/configs/ls1043aqds.h b/include/configs/ls1043aqds.h index

[U-Boot] [Patch V2 1/3] freescale/qixis: Add support for booting from SD/QSPI

2015-12-31 Thread Gong Qianyu
From: Gong Qianyu 1.Use "qixis_reset sd" to boot from SD 2.Use "qixis_reset sd_qspi" to boot from SD with QSPI support 3.Use "qixis_reset qspi" to boot from QSPI flash On some SoCs such as LS1021A and LS1043A, IFC and QSPI could be pin-multiplexed. So the switches are

Re: [U-Boot] [PATCH v3 2/5] usb: dwc2: Use shared wait_for_bit

2015-12-31 Thread Mateusz Kulikowski
Hi Stefan, On Sun, Dec 27, 2015 at 11:17:55PM +0100, Stefan Bruens wrote: > On Sonntag, 27. Dezember 2015 18:28:09 CET Mateusz Kulikowski wrote: > > Use existing library function to poll bit(s). > > > > Signed-off-by: Mateusz Kulikowski > > It might be useful to

[U-Boot] [PATCH] trats2: Move include of power/max77686_pmic.h

2015-12-31 Thread Tom Rini
We only need this include file in board/samsung/common/misc.c, so move it there. Signed-off-by: Tom Rini --- board/samsung/common/misc.c |1 + include/configs/trats2.h|2 -- 2 files changed, 1 insertion(+), 2 deletions(-) diff --git a/board/samsung/common/misc.c

Re: [U-Boot] [PATCH v2] Fix GCC format-security errors and convert sprintfs.

2015-12-31 Thread Wolfgang Denk
Dear ben.whit...@gmail.com, In message <1451480758-8871-1-git-send-email-ben.whit...@gmail.com> you wrote: > From: Ben Whitten > > With format-security errors turned on, GCC picks up the use of sprintf with > a format parameter not being a string literal. > > Simple uses

Re: [U-Boot] [PULL] u-boot-usb/master

2015-12-31 Thread Marek Vasut
On Thursday, December 31, 2015 at 02:41:21 PM, Tom Rini wrote: > On Thu, Dec 31, 2015 at 10:30:02AM +0100, Marek Vasut wrote: > > The following changes since commit 78680314c53a95c0bb25e942662979843b60d7b9: > > Merge branch 'master' of http://git.denx.de/u-boot-sunxi (2015-12-27 > > 09:15:57 >

Re: [U-Boot] [PATCH v4 1/2] usb: Move determination of TT hub address/port into separate function

2015-12-31 Thread Marek Vasut
On Tuesday, December 22, 2015 at 01:21:03 AM, Stefan BrĂ¼ns wrote: > Start split and complete split tokens need the hub address and the > downstream port of the first HS hub (device view). > > The core of the function was duplicated in both host/ehci_hcd and > musb-new/usb-compat.h. > >

Re: [U-Boot] [PATCH v4 5/8] x86: qemu: add qemu_fwcfg_fdt_fixup()

2015-12-31 Thread Simon Glass
Hi Miao, On 31 December 2015 at 02:02, Miao Yan wrote: > Hi Simon, > > 2015-12-31 13:08 GMT+08:00 Simon Glass : >> Hi Maio, >> >> On 30 December 2015 at 19:55, Miao Yan wrote: >>> Add a function to fix up 'cpus' node in dts files

Re: [U-Boot] [PATCH v4 1/8] x86: qemu: add fw_cfg support

2015-12-31 Thread Simon Glass
Hi Miao, On 31 December 2015 at 01:42, Miao Yan wrote: > Hi Simon, > > 2015-12-31 13:07 GMT+08:00 Simon Glass : >> Hi Miao, >> >> On 30 December 2015 at 19:55, Miao Yan wrote: >>> The QEMU fw_cfg interface allows the guest to

Re: [U-Boot] [PATCH V3] usb:ci_udc: Remove ULPI setting for i.MX OTG controller

2015-12-31 Thread Li Ye-B37916
On 12/31/2015 5:07 PM, Marek Vasut wrote: > On Thursday, December 31, 2015 at 08:24:45 AM, Peng Fan wrote: >> From: "Ye.Li" >> >> All the i.MX6, i.MX23 and i.MX28 OTG controllers only support UTMI >> interface. Set to ULPI is not correct, even the controller will >> reject

Re: [U-Boot] [PULL] u-boot-usb/master

2015-12-31 Thread Tom Rini
On Thu, Dec 31, 2015 at 10:30:02AM +0100, Marek Vasut wrote: > The following changes since commit 78680314c53a95c0bb25e942662979843b60d7b9: > > Merge branch 'master' of http://git.denx.de/u-boot-sunxi (2015-12-27 > 09:15:57 > -0500) > > are available in the git repository at: > >

Re: [U-Boot] Pull request: u-boot-spi/next

2015-12-31 Thread Jagan Teki
On 30 December 2015 at 16:04, Jagan Teki wrote: > Tom, Please pull this asap, in case if you miss. > > Please note that subject shows u-boot-spi/next but it actually > u-boot-spi/master and of course PR shows the repo as master (not > next). > > On 30 December 2015 at 16:01,

Re: [U-Boot] [PATCH] cmd_pci: Check for VendorID earlier

2015-12-31 Thread Fabio Estevam
Hi Bin, On Thu, Dec 31, 2015 at 7:32 AM, Bin Meng wrote: > I also see this behavior on ls1021atwr board. I agree with Simon, the > correct fix should fix the PCIe driver to return 0 instead of -EINVAL. Do you mean like this for imx? --- a/drivers/pci/pcie_imx.c +++

Re: [U-Boot] [PATCH] trats2: Move include of power/max77686_pmic.h

2015-12-31 Thread Tom Rini
On Thu, Dec 31, 2015 at 08:52:18AM -0500, Tom Rini wrote: > We only need this include file in board/samsung/common/misc.c, so move > it there. > > Signed-off-by: Tom Rini This in turn breaks trats and s5pc210_universal, so it's not quite there. I'll take another run at