Re: [U-Boot] [PATCH v2 4/4] dm: usb: Rename usb_find_child to usb_find_emul_child

2015-07-07 Thread Simon Glass
On 3 July 2015 at 17:06, Simon Glass s...@chromium.org wrote:
 On 1 July 2015 at 12:53, Hans de Goede hdego...@redhat.com wrote:
 Now that we unbind usb devices from usb_stop() usb_find_child() is
 only necessary to deal with emulated usb devices.

 Rename it to make this clear and add a #ifdef to make it a nop in
 other cases.

 Note the #ifdef turns usb_find_emul_child() into a nop, rather then not
 building it and adding another #ifdef to the caller, this is done this way
 because adding a #ifdef to the caller is somewhat hairy.

 Signed-off-by: Hans de Goede hdego...@redhat.com
 ---
  drivers/usb/host/usb-uclass.c | 19 +--
  1 file changed, 9 insertions(+), 10 deletions(-)

 Acked-by: Simon Glass s...@chromium.org

Applied to u-boot-dm/next, thanks!
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


Re: [U-Boot] [PATCH v2 4/4] dm: usb: Rename usb_find_child to usb_find_emul_child

2015-07-03 Thread Simon Glass
On 1 July 2015 at 12:53, Hans de Goede hdego...@redhat.com wrote:
 Now that we unbind usb devices from usb_stop() usb_find_child() is
 only necessary to deal with emulated usb devices.

 Rename it to make this clear and add a #ifdef to make it a nop in
 other cases.

 Note the #ifdef turns usb_find_emul_child() into a nop, rather then not
 building it and adding another #ifdef to the caller, this is done this way
 because adding a #ifdef to the caller is somewhat hairy.

 Signed-off-by: Hans de Goede hdego...@redhat.com
 ---
  drivers/usb/host/usb-uclass.c | 19 +--
  1 file changed, 9 insertions(+), 10 deletions(-)

Acked-by: Simon Glass s...@chromium.org
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


[U-Boot] [PATCH v2 4/4] dm: usb: Rename usb_find_child to usb_find_emul_child

2015-07-01 Thread Hans de Goede
Now that we unbind usb devices from usb_stop() usb_find_child() is
only necessary to deal with emulated usb devices.

Rename it to make this clear and add a #ifdef to make it a nop in
other cases.

Note the #ifdef turns usb_find_emul_child() into a nop, rather then not
building it and adding another #ifdef to the caller, this is done this way
because adding a #ifdef to the caller is somewhat hairy.

Signed-off-by: Hans de Goede hdego...@redhat.com
---
 drivers/usb/host/usb-uclass.c | 19 +--
 1 file changed, 9 insertions(+), 10 deletions(-)

diff --git a/drivers/usb/host/usb-uclass.c b/drivers/usb/host/usb-uclass.c
index 2df6740..fd11cc6 100644
--- a/drivers/usb/host/usb-uclass.c
+++ b/drivers/usb/host/usb-uclass.c
@@ -485,15 +485,14 @@ error:
 }
 
 /**
- * usb_find_child() - Find an existing device which matches our needs
- *
- *
+ * usb_find_emul_child() - Find an existing device for emulated devices
  */
-static int usb_find_child(struct udevice *parent,
- struct usb_device_descriptor *desc,
- struct usb_interface_descriptor *iface,
- struct udevice **devp)
+static int usb_find_emul_child(struct udevice *parent,
+  struct usb_device_descriptor *desc,
+  struct usb_interface_descriptor *iface,
+  struct udevice **devp)
 {
+#ifdef CONFIG_SANDBOX
struct udevice *dev;
 
*devp = NULL;
@@ -512,7 +511,7 @@ static int usb_find_child(struct udevice *parent,
return 0;
}
}
-
+#endif
return -ENOENT;
 }
 
@@ -572,8 +571,8 @@ int usb_scan_device(struct udevice *parent, int port,
debug(read_descriptor for '%s': ret=%d\n, parent-name, ret);
if (ret)
return ret;
-   ret = usb_find_child(parent, udev-descriptor, iface, dev);
-   debug(** usb_find_child returns %d\n, ret);
+   ret = usb_find_emul_child(parent, udev-descriptor, iface, dev);
+   debug(** usb_find_emul_child returns %d\n, ret);
if (ret) {
if (ret != -ENOENT)
return ret;
-- 
2.4.3

___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot