Re: [PATCH 2/3] Convert CONFIG_FIXED_SDHCI_ALIGNED_BUFFER to Kconfig

2022-05-29 Thread Marek BehĂșn
On Sun, 29 May 2022 11:13:17 +1200 Chris Packham wrote: > CONFIG_FIXED_SDHCI_ALIGNED_BUFFER is needed on some Marvell SoCs when > booting from MMC. All existing usages of this have the same value so > make this the default and have the Kconfig option depend on SPL && > MVEBU_SPL_BOOT_DEVICE_MMC.

Re: [PATCH v2 1/2] bootmenu: use utf-8 for menu title

2022-05-29 Thread Pali Rohar
On Sunday 29 May 2022 10:37:23 Masahisa Kojima wrote: > On Sat, 28 May 2022 at 17:37, Heinrich Schuchardt wrote: > > On 5/26/22 12:09, Masahisa Kojima wrote: > > > @@ -183,13 +183,13 @@ static int prepare_bootmenu_entry(struct > > > bootmenu_data *menu, > > > return

Re: [PATCH 3/3] arm: mvebu: Remove CONFIG_SPL_BOOT_DEVICE

2022-05-29 Thread Marek BehĂșn
On Sun, 29 May 2022 11:13:18 +1200 Chris Packham wrote: > CONFIG_SPL_BOOT_DEVICE was made obsolete by > CONFIG_MVEBU_SPL_BOOT_DEVICE_{SPI,MMC,SATA,UART}. > CONFIG_MVEBU_SPL_BOOT_DEVICE_SPI is the default so existing users of > CONFIG_SPL_BOOT_DEVICE can simply have the option removed. > >

[PATCH 05/20] Convert CONFIG_SPL_RELOC_TEXT_BASE et al to Kconfig

2022-05-29 Thread Tom Rini
This converts the following to Kconfig: CONFIG_SPL_RELOC_TEXT_BASE CONFIG_SPL_RELOC_STACK CONFIG_SPL_RELOC_MALLOC_ADDR CONFIG_SPL_RELOC_MALLOC_SIZE Signed-off-by: Tom Rini --- README | 13 - board/freescale/p1010rdb/spl.c | 6

[PATCH 10/20] Convert CONFIG_SPL_GD_ADDR to Kconfig

2022-05-29 Thread Tom Rini
This converts the following to Kconfig: CONFIG_SPL_GD_ADDR Signed-off-by: Tom Rini --- board/freescale/p1010rdb/spl.c | 4 ++-- board/freescale/p1_p2_rdb_pc/spl.c | 4 ++-- common/spl/Kconfig | 8

[PATCH 11/20] Drop CONFIG_SPL_SPI_FLASH_MINIMAL

2022-05-29 Thread Tom Rini
There are no users of CONFIG_SPL_SPI_FLASH_MINIMAL only platforms defining it, drop it. Signed-off-by: Tom Rini --- include/configs/P1010RDB.h | 1 - include/configs/T102xRDB.h | 1 - include/configs/T104xRDB.h | 1 - include/configs/T208xQDS.h | 1 - include/configs/T208xRDB.h

[PATCH 04/20] Convert CONFIG_TPL_NAND_INIT to Kconfig

2022-05-29 Thread Tom Rini
This converts the following to Kconfig: CONFIG_TPL_NAND_INIT Signed-off-by: Tom Rini --- drivers/mtd/nand/raw/Kconfig | 4 drivers/mtd/nand/raw/Makefile | 2 +- drivers/mtd/nand/raw/fsl_ifc_spl.c | 2 +- include/configs/P1010RDB.h | 1 - include/configs/p1_p2_rdb_pc.h

[PATCH 08/20] Remove CONFIG_SYS_SPL_LEN largely

2022-05-29 Thread Tom Rini
This is mostly unused. In the case where it is currently used, it means the same as CONFIG_SPL_PAD_TO, which is already set for the platform. Signed-off-by: Tom Rini --- include/configs/corvus.h| 2 -- include/configs/gardena-smart-gateway-at91sam.h | 2 --

[PATCH 09/20] etamin: Remove CONFIG_SPL_CMT defines

2022-05-29 Thread Tom Rini
These are presumably private to non-upstream code, remove. Signed-off-by: Tom Rini --- include/configs/etamin.h | 6 -- 1 file changed, 6 deletions(-) diff --git a/include/configs/etamin.h b/include/configs/etamin.h index 9cf93924df93..383beee17aec 100644 --- a/include/configs/etamin.h +++

[PATCH 12/20] Remove CONFIG_SPL_STACK_SIZE

2022-05-29 Thread Tom Rini
This is not used anywhere, drop it. Signed-off-by: Tom Rini --- include/configs/microblaze-generic.h | 3 --- 1 file changed, 3 deletions(-) diff --git a/include/configs/microblaze-generic.h b/include/configs/microblaze-generic.h index e9c9bf9281ce..389da112b939 100644 ---

Re: [PATCH 01/12] env: Complete generic support for writable list

2022-05-29 Thread Jan Kiszka
On 29.05.22 03:46, Marek Vasut wrote: > On 5/28/22 15:02, Jan Kiszka wrote: >> From: Jan Kiszka >> >> This completes what 890feecaab72 started by selecting ENV_APPEND and >> ENV_IS_NOWHERE and by moving this driver to top if the list. This > > s@if the list@of the list@ > >> ensures that load

Re: [PATCH] mach-rockchip: make_fit_atf.py: support OP-TEE tee.bin v1 format

2022-05-29 Thread Alper Nebi Yasak
On 28/05/2022 01:08, Jerome Forissier wrote: > On 5/27/22 21:24, Alper Nebi Yasak wrote: >> On 11/05/2022 18:35, Jerome Forissier wrote: >>> +if paged_sz != 0: >>> +raise ValueError("OP-TEE paged mode not supported") >> >> Is this not feasible/necessary to do, or just not

Pull request for efi-2022-07-rc4-2

2022-05-29 Thread Heinrich Schuchardt
Dear Tom, this replaces pull request for efi-2022-07-rc4. The following changes since commit 4fe629d2e8bbda5f265e870d771b92be26e885f6: Merge https://source.denx.de/u-boot/custodians/u-boot-riscv (2022-05-27 08:50:42 -0400) are available in the Git repository at:

[PATCH 02/20] imx6: Update CONFIG_SPL_STACK defaults in Kconfig

2022-05-29 Thread Tom Rini
Update the Kconfig entry to have the correct defaults for i.MX6 platforms, and move the existing large comment from imx6_spl.h to doc/imx/common/imx6.txt so that it's not lost. Signed-off-by: Tom Rini --- common/spl/Kconfig | 4 ++- configs/apalis_imx6_defconfig| 2

[PATCH 03/20] imx7: Update CONFIG_SPL_STACK defaults in Kconfig

2022-05-29 Thread Tom Rini
Update the Kconfig entry to have the correct defaults for i.MX7 platforms, and move the existing large comment from imx7_spl.h to doc/imx/common/imx7.txt so that it's not lost. Signed-off-by: Tom Rini --- common/spl/Kconfig | 3 ++- configs/cl-som-imx7_defconfig | 2 --

[PATCH 19/20] Convert CONFIG_SYS_MMCSD_RAW_MODE_ARGS_SECTOR et al to Kconfig

2022-05-29 Thread Tom Rini
This converts the following to Kconfig: CONFIG_SYS_MMCSD_RAW_MODE_ARGS_SECTOR CONFIG_SYS_MMCSD_RAW_MODE_ARGS_SECTORS Signed-off-by: Tom Rini --- README| 6 -- common/spl/Kconfig| 14 ++ common/spl/spl_mmc.c

[PATCH 18/20] Convert CONFIG_SYS_NAND_SPL_KERNEL_OFFS to Kconfig

2022-05-29 Thread Tom Rini
This converts the following to Kconfig: CONFIG_SYS_NAND_SPL_KERNEL_OFFS Signed-off-by: Tom Rini --- common/spl/Kconfig| 4 configs/am335x_evm_defconfig | 1 + configs/am335x_igep003x_defconfig | 1 + configs/am3517_evm_defconfig

Re: [PATCH] doc: sandbox: Add additional valgrind documentation

2022-05-29 Thread Sean Anderson
On 5/28/22 4:20 AM, Heinrich Schuchardt wrote: On 5/27/22 15:25, Sean Anderson wrote: On 5/27/22 3:14 AM, Heinrich Schuchardt wrote: On 5/27/22 05:36, Sean Anderson wrote: This document some additional options which can be used with valgrind, as Thanks for enhancing this document nits

Re: [RFC PATCH v2 2/8] rockchip: Add binman definitions for final images

2022-05-29 Thread Alper Nebi Yasak
On 22/05/2022 03:55, Andrew Abbott wrote: > On Thu May 19, 2022 at 9:36 PM AEST, Alper Nebi Yasak wrote: >> Do we need the 'idbloader.img' as a build output, assuming we have a >> working 'u-boot-rockchip.bin'? I'm asking because Simon was trying to >> drop it in a similar patch [1]. > > I was

[PATCH 14/20] Convert CONFIG_SYS_SPL_ARGS_ADDR to Kconfig

2022-05-29 Thread Tom Rini
This converts the following to Kconfig: CONFIG_SYS_SPL_ARGS_ADDR In doing so, we also consistently use this variable for SPL_OS_BOOT and not CONFIG_SYS_FDT_BASE in some cases. Signed-off-by: Tom Rini --- common/spl/Kconfig| 8

[PATCH 13/20] Convert CONFIG_SPL_TARGET to Kconfig

2022-05-29 Thread Tom Rini
This converts the following to Kconfig: CONFIG_SPL_TARGET Signed-off-by: Tom Rini --- README | 5 - common/spl/Kconfig | 9 + configs/P1010RDB-PA_36BIT_NAND_defconfig | 1 +

[PATCH 16/20] Drop CONFIG_SPL_SIZE

2022-05-29 Thread Tom Rini
We do not reference CONFIG_SPL_SIZE in the code, remove it. Signed-off-by: Tom Rini --- include/configs/clearfog.h| 3 --- include/configs/controlcenterdc.h | 3 --- include/configs/db-88f6820-amc.h | 3 --- include/configs/db-88f6820-gp.h | 3 --- include/configs/helios4.h |

[PATCH 17/20] spl: Remove CONFIG_SPL_START_S_PATH and rework the logic behind it

2022-05-29 Thread Tom Rini
In some cases, when we don't use CONFIG_SPL_FRAMEWORK nor are we on PowerPC using their specific SPL/TPL framework, we need to specify the start.S file to use for these typically very constrained systems. Do this within the Makefile logic, rather than introducing a string-based CONFIG option, as

[PATCH 15/20] ax25-ae350: Move CONFIG_SYS_FDT_BASE to Kconfig

2022-05-29 Thread Tom Rini
The address where the device tree will be passed in to U-Boot at is now moved to the Kconfig file. If this is user configurable, it needs to be exposed rather than hidden, and should probably be renamed as well. Cc: Rick Chen Signed-off-by: Tom Rini --- board/AndesTech/ax25-ae350/Kconfig | 4

[PATCH 20/20] riotboard, syzygy_hub: Disable SPL_FALCON_BOOT_MMCSD

2022-05-29 Thread Tom Rini
Looking at the git history and values used for the raw kernel/args location, it's clear these platforms only ever did Falcon Mode via filesystem images and not raw MMC/SD locations. Disable CONFIG_SPL_FALCON_BOOT_MMCSD. Signed-off-by: Tom Rini --- configs/riotboard_defconfig | 2 --

Re: Pull request for efi-2022-07-rc4-2

2022-05-29 Thread Masahisa Kojima
Hi Heinrich, On Mon, 30 May 2022 at 01:16, Heinrich Schuchardt wrote: > > Dear Tom, > > this replaces pull request for efi-2022-07-rc4. > > The following changes since commit 4fe629d2e8bbda5f265e870d771b92be26e885f6: > >Merge https://source.denx.de/u-boot/custodians/u-boot-riscv >