Re: [U-Boot] [PATCH v5 7/9] bootm: use new common function lmb_init_and_reserve

2018-12-10 Thread Simon Glass
On Sun, 9 Dec 2018 at 13:46, Simon Goldschmidt
 wrote:
>
> This reduces duplicate code only.
>
> Signed-off-by: Simon Goldschmidt 
> ---
>
> Changes in v5: None
> Changes in v4: None
> Changes in v2: None
>
>  common/bootm.c | 8 ++--
>  1 file changed, 2 insertions(+), 6 deletions(-)
>

Reviewed-by: Simon Glass 
___
U-Boot mailing list
U-Boot@lists.denx.de
https://lists.denx.de/listinfo/u-boot


[U-Boot] [PATCH v5 7/9] bootm: use new common function lmb_init_and_reserve

2018-12-09 Thread Simon Goldschmidt
This reduces duplicate code only.

Signed-off-by: Simon Goldschmidt 
---

Changes in v5: None
Changes in v4: None
Changes in v2: None

 common/bootm.c | 8 ++--
 1 file changed, 2 insertions(+), 6 deletions(-)

diff --git a/common/bootm.c b/common/bootm.c
index 8bf84ebcb7..31e4f0f794 100644
--- a/common/bootm.c
+++ b/common/bootm.c
@@ -56,15 +56,11 @@ static void boot_start_lmb(bootm_headers_t *images)
ulong   mem_start;
phys_size_t mem_size;
 
-   lmb_init(>lmb);
-
mem_start = env_get_bootm_low();
mem_size = env_get_bootm_size();
 
-   lmb_add(>lmb, (phys_addr_t)mem_start, mem_size);
-
-   arch_lmb_reserve(>lmb);
-   board_lmb_reserve(>lmb);
+   lmb_init_and_reserve(>lmb, (phys_addr_t)mem_start, mem_size,
+NULL);
 }
 #else
 #define lmb_reserve(lmb, base, size)
-- 
2.17.1

___
U-Boot mailing list
U-Boot@lists.denx.de
https://lists.denx.de/listinfo/u-boot