Re: [U-Boot] instruction "xchgb" for x86_64

2019-08-16 Thread James Wang
> > Hi, > > (James please can you use plain-text email for the mailing list?) OK. Thanks Simon for pointing out this. I am using outlook, so most likely will have "newline" difference. Hope can find a way out for this. > > For chromebook_link64 I get: > > output:

Re: [U-Boot] instruction "xchgb" for x86_64

2019-08-14 Thread Simon Glass
Hi, (James please can you use plain-text email for the mailing list?) On Wed, 14 Aug 2019 at 01:35, Bin Meng wrote: > > Hi James, > > On Wed, Aug 14, 2019 at 1:08 PM James Wang > wrote: >> >> Hi Simon, >> >> >> >> This is James and am working on u-boot to bring back MinGW tool chain for >>

Re: [U-Boot] instruction "xchgb" for x86_64

2019-08-14 Thread James Wang
Hi Bin   >> This is James and am working on u-boot to bring back MinGW tool chain for >> cross compiling host tools for Windows on Linux. After complete the code, I >> plan to generate a patch for community review. >Do you mean cross compiling U-Boot's mkimage tool for Windows on Linux using

[U-Boot] instruction "xchgb" for x86_64

2019-08-14 Thread James Wang
Hi Simon, This is James and am working on u-boot to bring back MinGW tool chain for cross compiling host tools for Windows on Linux. After complete the code, I plan to generate a patch for community review. During work, I face an compiling error in file with macro CONFIG_IS_ENABLED. After

Re: [U-Boot] instruction "xchgb" for x86_64

2019-08-14 Thread Bin Meng
Hi James, On Wed, Aug 14, 2019 at 1:08 PM James Wang wrote: > Hi Simon, > > > > This is James and am working on u-boot to bring back MinGW tool chain for > cross compiling host tools for Windows on Linux. After complete the code, I > plan to generate a patch for community review. > Do you mean