[Bug 997269] Re: dovecot imap broken by apparmor policy

2012-05-15 Thread Robie Basak
** Changed in: dovecot (Ubuntu)
   Importance: Undecided = High

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to dovecot in Ubuntu.
https://bugs.launchpad.net/bugs/997269

Title:
  dovecot imap broken by apparmor policy

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apparmor/+bug/997269/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


Re: [Bug 999082] Re: package puppetmaster 0.25.4-2ubuntu6.7 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

2012-05-15 Thread Luis Lavina
Hi Robie,

Thanks for the info. I already remove and purged the package installation
for the ubuntu and also remove the package for the manual and restarted the
system. then I try to reinstall the puppet using apt-get install then error
appears(sorry I already deleted the logs and error messages), I will try to
reproduce the error and will send you the info once  the error is related
to the Ubuntu (not related to the app)

Thanks for the response regarding to this issue

Luis



On Tue, May 15, 2012 at 1:33 PM, Robie Basak
999...@bugs.launchpad.netwrote:

 Thanks for taking the time to report this bug and helping to make Ubuntu
 better.

 It looks like the error you have experienced is related to a conflict
 between the packaged installation of puppet and a custom manual
 installation of puppet you have in /usr/local/lib/site_ruby/1.8/puppet.

 Thus this problem appears to be on your system and not a bug in Ubuntu.
 Accordingly I am marking this bug as Invalid in Ubuntu.

 If I am mistaken, please do explain and change the status back to New.

 ** Changed in: puppet (Ubuntu)
   Status: New = Invalid

 --
 You received this bug notification because you are subscribed to the bug
 report.
 https://bugs.launchpad.net/bugs/999082

 Title:
  package puppetmaster 0.25.4-2ubuntu6.7 failed to install/upgrade:
  subprocess installed post-installation script returned error exit
  status 1

 Status in “puppet” package in Ubuntu:
  Invalid

 Bug description:
  failed when purge the installed puppet and reinstall it again and
  produce some error

  ProblemType: Package
  DistroRelease: Ubuntu 10.04
  Package: puppetmaster 0.25.4-2ubuntu6.7
  ProcVersionSignature: Ubuntu 2.6.32-41.88-generic 2.6.32.59+drm33.24
  Uname: Linux 2.6.32-41-generic x86_64
  AptOrdering:
   libaugeas-ruby1.8: Remove
   libaugeas0: Remove
   augeas-lenses: Remove
   puppet: Purge
   puppetmaster: Configure
  Architecture: amd64
  Date: Mon May 14 19:03:15 2012
  ErrorMessage: subprocess installed post-installation script returned
 error exit status 1
  InstallationMedia: Ubuntu 10.04.4 LTS Lucid Lynx - Release amd64
 (20120214.2)
  PackageArchitecture: all
  SourcePackage: puppet
  Title: package puppetmaster 0.25.4-2ubuntu6.7 failed to install/upgrade:
 subprocess installed post-installation script returned error exit status 1

 To manage notifications about this bug go to:
 https://bugs.launchpad.net/ubuntu/+source/puppet/+bug/999082/+subscriptions


-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to puppet in Ubuntu.
https://bugs.launchpad.net/bugs/999082

Title:
  package puppetmaster 0.25.4-2ubuntu6.7 failed to install/upgrade:
  subprocess installed post-installation script returned error exit
  status 1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/puppet/+bug/999082/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 998918] Re: openvpn openssl.cnf file missing

2012-05-15 Thread Fabio Marconi
** Changed in: openvpn (Ubuntu)
   Status: Incomplete = New

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to openvpn in Ubuntu.
https://bugs.launchpad.net/bugs/998918

Title:
  openvpn  openssl.cnf file missing

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openvpn/+bug/998918/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 989355] Re: Unable to create Node: timed out

2012-05-15 Thread Julian Edwards
I thought of something you can try - if you change the cobbler settings
to not manage dhcp and set your external dhcp up manually, it might
work.  Please let me know.

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to maas in Ubuntu.
https://bugs.launchpad.net/bugs/989355

Title:
  Unable to create Node: timed out

To manage notifications about this bug go to:
https://bugs.launchpad.net/maas/+bug/989355/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999485] [NEW] package slapd 2.4.25-1.1ubuntu4.1 failed to install/upgrade: ErrorMessage: подпроцесс новый сценарий pre-installation возвратил код ошибки 1

2012-05-15 Thread Nikolay
Public bug reported:

Errors

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: slapd 2.4.25-1.1ubuntu4.1
ProcVersionSignature: Ubuntu 3.0.0-19.33-generic-pae 3.0.27
Uname: Linux 3.0.0-19-generic-pae i686
ApportVersion: 1.23-0ubuntu4
Architecture: i386
CNConfig: Error: [Errno 2] Нет такого файла или каталога
Date: Tue May 15 10:26:05 2012
ErrorMessage: ErrorMessage: подпроцесс новый сценарий pre-installation 
возвратил код ошибки 1
InstallationMedia: Ubuntu-Server 11.10 Oneiric Ocelot - Release i386 
(20111011)
SourcePackage: openldap
Title: package slapd 2.4.25-1.1ubuntu4.1 failed to install/upgrade: 
ErrorMessage: подпроцесс новый сценарий pre-installation возвратил код ошибки 1
UpgradeStatus: Upgraded to precise on 2012-05-15 (0 days ago)

** Affects: openldap (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: apport-package i386 precise

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to openldap in Ubuntu.
https://bugs.launchpad.net/bugs/999485

Title:
  package slapd 2.4.25-1.1ubuntu4.1 failed to install/upgrade:
  ErrorMessage: подпроцесс новый сценарий pre-installation возвратил код
  ошибки 1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openldap/+bug/999485/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999485] Re: package slapd 2.4.25-1.1ubuntu4.1 failed to install/upgrade: ErrorMessage: подпроцесс новый сценарий pre-installation возвратил код ошибки 1

2012-05-15 Thread Nikolay
-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to openldap in Ubuntu.
https://bugs.launchpad.net/bugs/999485

Title:
  package slapd 2.4.25-1.1ubuntu4.1 failed to install/upgrade:
  ErrorMessage: подпроцесс новый сценарий pre-installation возвратил код
  ошибки 1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openldap/+bug/999485/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 998137] Re: Keystone user tenant membership not always removed

2012-05-15 Thread Joseph Heck
** Tags added: essex-backport-potential

** Changed in: keystone
Milestone: None = folsom-1

** Changed in: keystone
   Importance: Undecided = High

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to keystone in Ubuntu.
https://bugs.launchpad.net/bugs/998137

Title:
  Keystone user tenant membership not always removed

To manage notifications about this bug go to:
https://bugs.launchpad.net/keystone/+bug/998137/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 998137] Re: Keystone user tenant membership not always removed

2012-05-15 Thread OpenStack Hudson
Reviewed:  https://review.openstack.org/7353
Committed: 
http://github.com/openstack/keystone/commit/2e912f4b91b57c060c2363c067125276a92457d2
Submitter: Jenkins
Branch:master

commit 2e912f4b91b57c060c2363c067125276a92457d2
Author: Adam Gandelman adam.gandel...@canonical.com
Date:   Fri May 11 09:49:39 2012 -0700

Flush tenant membership deletion before user

Ensure user tenant membership is *actually* removed before deleting
user.

Fixes bug 998137.  This should be proposed to stable/essex as well.

Change-Id: I097456e603177646d62ebf08ca71af1fd7f787bf


** Changed in: keystone
   Status: In Progress = Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to keystone in Ubuntu.
https://bugs.launchpad.net/bugs/998137

Title:
  Keystone user tenant membership not always removed

To manage notifications about this bug go to:
https://bugs.launchpad.net/keystone/+bug/998137/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 978356] Re: squid3 gets killed at startup with dnsmasq and no networkmanager

2012-05-15 Thread Daniel Hahler
For what it's worth, this does not happen with the squid-deb-proxy
package (which uses squid with an optimized config) - at least after
several boot processes.

The init/start script is different, for example, it uses
start on (local-filesystems and net-device-up IFACE!=lo)
instead of
start on runlevel [2345].

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to squid3 in Ubuntu.
https://bugs.launchpad.net/bugs/978356

Title:
  squid3 gets killed at startup with dnsmasq and no networkmanager

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dnsmasq/+bug/978356/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 651049] Re: php5: FILTER_VALIDATE_URL will invalidate a hostname that includes '-'

2012-05-15 Thread Guy Van Sanden
Won't this be fixed for Lucid?  It's pretty annoying and there's no
other fix than upgrading to 12.04?

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to php5 in Ubuntu.
https://bugs.launchpad.net/bugs/651049

Title:
  php5: FILTER_VALIDATE_URL will invalidate a hostname that includes '-'

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/php5/+bug/651049/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 651049] Re: php5: FILTER_VALIDATE_URL will invalidate a hostname that includes '-'

2012-05-15 Thread Olivier Dobberkau
I maintain a private ppa with this fix..

https://launchpad.net/~olivier-dobberkau/+archive/php5-usn-1437-1

i try to stay uptodate with the current security patches in lucid php5.

the patch it self is a no brainer!

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to php5 in Ubuntu.
https://bugs.launchpad.net/bugs/651049

Title:
  php5: FILTER_VALIDATE_URL will invalidate a hostname that includes '-'

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/php5/+bug/651049/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999614] [NEW] new SoapClient() with connection_timeout = NULL breaks multi-dimensional arrays

2012-05-15 Thread Markus Birth
Public bug reported:

EXAMPLE CODE:
?php

$header = array();
$header[header_general][order_type] = SHOP;
print_r( $header );

#$timeout = 1;
$client = new SoapClient( null, array( 'location' = 'www.silversolutions.de', 
'uri' = 'www.silversolutions.de', 'connection_timeout' = $timeout ) );

$header = array();
$header[header_general][order_type] = SHOP;
print_r( $header );

?

COMMAND:
php -n test.php
(NO CONFIG IS USED!!)


ACTUAL OUTPUT:
Array
(
[header_general] = Array
(
[order_type] = SHOP
)

)

Warning: Cannot use a scalar value as an array in /home/mab/test.php on line 11
Array
(
[header_general] = 0
)


EXPECTED OUTPUT:
Array
(
[header_general] = Array
(
[order_type] = SHOP
)

)

Warning: Cannot use a scalar value as an array in /home/mab/test.php on line 11
Array
(
[header_general] = Array
(
[order_type] = SHOP
)

)


This is on
Linux johndoe 3.2.0-24-virtual #37-Ubuntu SMP Wed Apr 25 10:17:19 UTC 2012 
x86_64 x86_64 x86_64 GNU/Linux.

On a desktop machine with
Linux johndoe 3.2.0-24-generic #38-Ubuntu SMP Tue May 1 16:18:50 UTC 2012 
x86_64 x86_64 x86_64 GNU/Linux
it works as expected.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: php5 5.3.10-1ubuntu3.1
ProcVersionSignature: Ubuntu 3.2.0-24.37-virtual 3.2.14
Uname: Linux 3.2.0-24-virtual x86_64
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Tue May 15 12:55:50 2012
PackageArchitecture: all
SourcePackage: php5
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: php5 (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug php5 precise

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to php5 in Ubuntu.
https://bugs.launchpad.net/bugs/999614

Title:
  new SoapClient() with connection_timeout = NULL breaks multi-
  dimensional arrays

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/php5/+bug/999614/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999614] Re: new SoapClient() with connection_timeout = NULL breaks multi-dimensional arrays

2012-05-15 Thread Markus Birth
-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to php5 in Ubuntu.
https://bugs.launchpad.net/bugs/999614

Title:
  new SoapClient() with connection_timeout = NULL breaks multi-
  dimensional arrays

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/php5/+bug/999614/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 994169] Re: quagga security update tracking bug

2012-05-15 Thread Launchpad Bug Tracker
This bug was fixed in the package quagga - 0.99.20.1-0ubuntu0.12.04.2

---
quagga (0.99.20.1-0ubuntu0.12.04.2) precise-security; urgency=low

  * SECURITY UPDATE: Update to 0.99.20.1 to fix multiple security issues
(LP: #994169)
- Denial of service via short Link State Update packet
- Denial of service via short network-LSA link-state advertisement
- Denial of service via malformed Four-octet AS Number Capability
- CVE-2012-0249
- CVE-2012-0250
- CVE-2012-0255
  * debian/patches/99_bgpd-fix-memory-leak-for-extra-attributes.diff:
added fix for a bgpd memory leak related to extra attributes. Thanks to
Debian for the regression fix.
 -- Marc Deslauriers marc.deslauri...@ubuntu.com   Sat, 05 May 2012 17:00:30 
-0400

** Changed in: quagga (Ubuntu Precise)
   Status: Confirmed = Fix Released

** Changed in: quagga (Ubuntu Lucid)
   Status: Confirmed = Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to quagga in Ubuntu.
https://bugs.launchpad.net/bugs/994169

Title:
  quagga security update tracking bug

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/quagga/+bug/994169/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 994169] Re: quagga security update tracking bug

2012-05-15 Thread Launchpad Bug Tracker
This bug was fixed in the package quagga - 0.99.20.1-0ubuntu0.11.04.2

---
quagga (0.99.20.1-0ubuntu0.11.04.2) natty-security; urgency=low

  * SECURITY UPDATE: Update to 0.99.20.1 to fix multiple security issues.
(LP: #994169)
- Denial of service via short Link State Update packet
- Denial of service via short network-LSA link-state advertisement
- Denial of service via malformed Four-octet AS Number Capability
- CVE-2012-0249
- CVE-2012-0250
- CVE-2012-0255
  * debian/control, debian/rules: Remove quagga-dbg package for Natty.
  * debian/patches/99_bgpd-fix-memory-leak-for-extra-attributes.diff:
added fix for a bgpd memory leak related to extra attributes. Thanks to
Debian for the regression fix.
 -- Marc Deslauriers marc.deslauri...@ubuntu.com   Sat, 05 May 2012 18:41:01 
-0400

** Changed in: quagga (Ubuntu Oneiric)
   Status: Confirmed = Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to quagga in Ubuntu.
https://bugs.launchpad.net/bugs/994169

Title:
  quagga security update tracking bug

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/quagga/+bug/994169/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 994169] Re: quagga security update tracking bug

2012-05-15 Thread Launchpad Bug Tracker
This bug was fixed in the package quagga - 0.99.20.1-0ubuntu0.11.10.2

---
quagga (0.99.20.1-0ubuntu0.11.10.2) oneiric-security; urgency=low

  * SECURITY UPDATE: Update to 0.99.20.1 to fix multiple security issues.
(LP: #994169)
- Denial of service via short Link State Update packet
- Denial of service via short network-LSA link-state advertisement
- Denial of service via malformed Four-octet AS Number Capability
- CVE-2012-0249
- CVE-2012-0250
- CVE-2012-0255
  * debian/control, debian/rules: Remove quagga-dbg package for Oneiric.
  * debian/patches/99_bgpd-fix-memory-leak-for-extra-attributes.diff:
added fix for a bgpd memory leak related to extra attributes. Thanks to
Debian for the regression fix.
 -- Marc Deslauriers marc.deslauri...@ubuntu.com   Sat, 05 May 2012 17:03:18 
-0400

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to quagga in Ubuntu.
https://bugs.launchpad.net/bugs/994169

Title:
  quagga security update tracking bug

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/quagga/+bug/994169/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-bug-triage-review] Review of Server Bug Triage Process

2012-05-15 Thread James Page
Blueprint changed by James Page:

Work items set to:
Work items:
[ursinha] Check with brian-murray his tools to mark duplicates and see how this 
applies to get rid of the installation/upgrade bugs: TODO
[ursinha] Check how to isolate installation/upgrade failures and start doing 
something with apport to filter invalid ones out: TODO
[ursinha] Use bryce script to expire bugs targeted to non supported releases: 
TODO
[james-page] Document triage process and circulate for RFP and then refine: TODO

-- 
Review of Server Bug Triage Process
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-bug-triage-review

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-bug-triage-review] Review of Server Bug Triage Process

2012-05-15 Thread James Page
Blueprint changed by James Page:

Whiteboard changed:
  UDS Discussion Points:
  
  Review of current process
-  - http://reports.qa.ubuntu.com/reports/ubuntu-server/triage-report.html
+  - http://reports.qa.ubuntu.com/reports/ubuntu-server/triage-report.html
  How is the New/Undecided - New process working? are we losing focus during 
this step?
  We have a backlog - we need to have a blitz on pushing stuff through.
  Additional tagging to help with triage.
   - unreproducable?
+ 
+ Session Notes: http://pad.ubuntu.com/uds-q-servercloud-q-bug-triage-
+ review

-- 
Review of Server Bug Triage Process
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-bug-triage-review

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-server-iso-tests-review] Server ISO Tests Review

2012-05-15 Thread James Page
Blueprint changed by James Page:

Work items set to:
Work items:
[jibel] Add a profile to auto upgrade testing  to support VM upgrade testing 
(nested VMs): TODO
[serge-hallyn] Provide a test to check the status of the VM after upgrade: TODO
[ivoks] Expand existing test cases to support different configuration options 
for mail-server: TODO
Add missing test cases to test case system: TODO
Improve MAAS test cases: TODO
[james-page] Plug the iSCSI tests into UATH: TODO
Migrate existing automated tests to UATH and document how to add new test cases 
in the new environment: TODO
[zulcss] Upgrade testing for openstack - work with jibel to setup new upgrade 
testing: TODO
[james-page] Work out better more focussed upgrade testing for server tasks: 
TODO
[james-page] Call for improvement of test cases and coordination with migration 
to new harness - write some documents on how todo this for the current 
framework: TODO
[hggdh2] Quick hack to make USB install in the VM's work in ISO testing 
framework: TODO
Ensure UATH can support USB installation as well: TODO
Ensure multi-nic testing can be supported: TODO
[hggdh2] Quick hack to make multi-nic work in current ISO testing framework: 
TODO
[james-page] Call for testing on ubuntu-server at key milestones: TODO

-- 
Server ISO Tests Review
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-server-iso-tests-review

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-server-iso-tests-review] Server ISO Tests Review

2012-05-15 Thread James Page
Blueprint changed by James Page:

Whiteboard changed:
  Summary of Discussion at UDS:
  
  Current test cases are OK - but all need to be migrated to UTAH early during 
the Q cycle.
  Some gaps in upgrade testing - members of the server team to identify 
suitable test cases so that the QA team can setup more regular upgrade testing.
  More requirements identified for UTAH - specifically multi-nic and USB 
install support.
  Still need to ensure that we get good manual testing coverage at key 
milestones - ubuntu-server list will be used to call for testing.
- MAAS test cases need some improvement and automation/
+ MAAS test cases need some improvement and automation.

-- 
Server ISO Tests Review
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-server-iso-tests-review

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-server-iso-tests-review] Server ISO Tests Review

2012-05-15 Thread James Page
Blueprint changed by James Page:

Whiteboard changed:
  Summary of Discussion at UDS:
  
  Current test cases are OK - but all need to be migrated to UTAH early during 
the Q cycle.
  Some gaps in upgrade testing - members of the server team to identify 
suitable test cases so that the QA team can setup more regular upgrade testing.
  More requirements identified for UTAH - specifically multi-nic and USB 
install support.
  Still need to ensure that we get good manual testing coverage at key 
milestones - ubuntu-server list will be used to call for testing.
  MAAS test cases need some improvement and automation.
+ 
+ Session notes: http://pad.ubuntu.com/uds-q-servercloud-q-server-iso-
+ tests-review

-- 
Server ISO Tests Review
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-server-iso-tests-review

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-server-iso-tests-review] Server ISO Tests Review

2012-05-15 Thread James Page
Blueprint changed by James Page:

Work items changed:
  Work items:
  [jibel] Add a profile to auto upgrade testing  to support VM upgrade testing 
(nested VMs): TODO
  [serge-hallyn] Provide a test to check the status of the VM after upgrade: 
TODO
  [ivoks] Expand existing test cases to support different configuration options 
for mail-server: TODO
  Add missing test cases to test case system: TODO
  Improve MAAS test cases: TODO
- [james-page] Plug the iSCSI tests into UATH: TODO
- Migrate existing automated tests to UATH and document how to add new test 
cases in the new environment: TODO
+ [james-page] Plug the iSCSI tests into UTAH: TODO
+ Migrate existing automated tests to UTAH and document how to add new test 
cases in the new environment: TODO
  [zulcss] Upgrade testing for openstack - work with jibel to setup new upgrade 
testing: TODO
  [james-page] Work out better more focussed upgrade testing for server tasks: 
TODO
  [james-page] Call for improvement of test cases and coordination with 
migration to new harness - write some documents on how todo this for the 
current framework: TODO
  [hggdh2] Quick hack to make USB install in the VM's work in ISO testing 
framework: TODO
  Ensure UATH can support USB installation as well: TODO
  Ensure multi-nic testing can be supported: TODO
  [hggdh2] Quick hack to make multi-nic work in current ISO testing framework: 
TODO
  [james-page] Call for testing on ubuntu-server at key milestones: TODO

-- 
Server ISO Tests Review
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-server-iso-tests-review

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-server-iso-tests-review] Server ISO Tests Review

2012-05-15 Thread James Page
Blueprint changed by James Page:

Work items changed:
  Work items:
  [jibel] Add a profile to auto upgrade testing  to support VM upgrade testing 
(nested VMs): TODO
  [serge-hallyn] Provide a test to check the status of the VM after upgrade: 
TODO
  [ivoks] Expand existing test cases to support different configuration options 
for mail-server: TODO
  Add missing test cases to test case system: TODO
  Improve MAAS test cases: TODO
  [james-page] Plug the iSCSI tests into UTAH: TODO
  Migrate existing automated tests to UTAH and document how to add new test 
cases in the new environment: TODO
  [zulcss] Upgrade testing for openstack - work with jibel to setup new upgrade 
testing: TODO
  [james-page] Work out better more focussed upgrade testing for server tasks: 
TODO
- [james-page] Call for improvement of test cases and coordination with 
migration to new harness - write some documents on how todo this for the 
current framework: TODO
- [hggdh2] Quick hack to make USB install in the VM's work in ISO testing 
framework: TODO
+ [james-page] Call for improvement of test cases and coordination with 
migration to new harness: TODO
  Ensure UATH can support USB installation as well: TODO
  Ensure multi-nic testing can be supported: TODO
  [hggdh2] Quick hack to make multi-nic work in current ISO testing framework: 
TODO
- [james-page] Call for testing on ubuntu-server at key milestones: TODO
+ [hggdh2] Quick hack to make USB install in the VM's work in ISO testing 
framework: TODO[james-page] Call for testing on ubuntu-server at key 
milestones: TODO

-- 
Server ISO Tests Review
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-server-iso-tests-review

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-server-iso-tests-review] Server ISO Tests Review

2012-05-15 Thread James Page
Blueprint changed by James Page:

Work items changed:
  Work items:
  [jibel] Add a profile to auto upgrade testing  to support VM upgrade testing 
(nested VMs): TODO
  [serge-hallyn] Provide a test to check the status of the VM after upgrade: 
TODO
  [ivoks] Expand existing test cases to support different configuration options 
for mail-server: TODO
  Add missing test cases to test case system: TODO
  Improve MAAS test cases: TODO
  [james-page] Plug the iSCSI tests into UTAH: TODO
  Migrate existing automated tests to UTAH and document how to add new test 
cases in the new environment: TODO
  [zulcss] Upgrade testing for openstack - work with jibel to setup new upgrade 
testing: TODO
  [james-page] Work out better more focussed upgrade testing for server tasks: 
TODO
  [james-page] Call for improvement of test cases and coordination with 
migration to new harness: TODO
  Ensure UATH can support USB installation as well: TODO
  Ensure multi-nic testing can be supported: TODO
  [hggdh2] Quick hack to make multi-nic work in current ISO testing framework: 
TODO
- [hggdh2] Quick hack to make USB install in the VM's work in ISO testing 
framework: TODO[james-page] Call for testing on ubuntu-server at key 
milestones: TODO
+ [hggdh2] Quick hack to make USB install in the VM's work in ISO testing 
framework: TODO
+ [james-page] Call for testing on ubuntu-server at key milestones: TODO

-- 
Server ISO Tests Review
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-server-iso-tests-review

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 997641] Re: Could not run Puppet configuration client: Could not retrieve local facts: bad URI

2012-05-15 Thread Robie Basak
Thank you for taking the time to report this bug and helping to make
Ubuntu better.

This looks like a version of the regression introduced in bug 732953 and
fixed in bug 885998. However, others reported the regression fixed in
bug 885998.

** Changed in: facter (Ubuntu)
   Importance: Undecided = High

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to facter in Ubuntu.
https://bugs.launchpad.net/bugs/997641

Title:
  Could not run Puppet configuration client: Could not retrieve local
  facts: bad URI

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/facter/+bug/997641/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-server-iso-tests-review] Server ISO Tests Review

2012-05-15 Thread James Page
Blueprint changed by James Page:

Whiteboard changed:
  Summary of Discussion at UDS:
  
  Current test cases are OK - but all need to be migrated to UTAH early during 
the Q cycle.
  Some gaps in upgrade testing - members of the server team to identify 
suitable test cases so that the QA team can setup more regular upgrade testing.
  More requirements identified for UTAH - specifically multi-nic and USB 
install support.
  Still need to ensure that we get good manual testing coverage at key 
milestones - ubuntu-server list will be used to call for testing.
  MAAS test cases need some improvement and automation.
  
  Session notes: http://pad.ubuntu.com/uds-q-servercloud-q-server-iso-
  tests-review
+ 
+ Assumptions:
+ 
+ - No new tests will be automated using the existing Ubuntu Server ISO Testing 
Framework.
+ - All existing tests will be migrated by the Platform QA team as UTAH comes 
online.
+ - The existing upgrade testing framework can support the requirements of the 
server team.
+ - OpenStack testing is not covered under the scope of this blueprint.
+ - Preseed based install testing is still sufficient to prove installer 
testing.
+ - Manual testing still has its place a key points in the development cycle.
+ 
+ User Stories:  N/A
+ Test Plan: N/A
+ Release Note: N/A

-- 
Server ISO Tests Review
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-server-iso-tests-review

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-server-iso-tests-review] Server ISO Tests Review

2012-05-15 Thread James Page
Blueprint changed by James Page:

Whiteboard changed:
  Summary of Discussion at UDS:
  
  Current test cases are OK - but all need to be migrated to UTAH early during 
the Q cycle.
  Some gaps in upgrade testing - members of the server team to identify 
suitable test cases so that the QA team can setup more regular upgrade testing.
  More requirements identified for UTAH - specifically multi-nic and USB 
install support.
  Still need to ensure that we get good manual testing coverage at key 
milestones - ubuntu-server list will be used to call for testing.
  MAAS test cases need some improvement and automation.
  
  Session notes: http://pad.ubuntu.com/uds-q-servercloud-q-server-iso-
  tests-review
  
  Assumptions:
  
  - No new tests will be automated using the existing Ubuntu Server ISO Testing 
Framework.
  - All existing tests will be migrated by the Platform QA team as UTAH comes 
online.
+ - Existing test format is still valid for UTAH and existing tests can be 
extended in place.
  - The existing upgrade testing framework can support the requirements of the 
server team.
  - OpenStack testing is not covered under the scope of this blueprint.
  - Preseed based install testing is still sufficient to prove installer 
testing.
  - Manual testing still has its place a key points in the development cycle.
  
  User Stories:  N/A
  Test Plan: N/A
  Release Note: N/A

-- 
Server ISO Tests Review
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-server-iso-tests-review

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999614] Re: new SoapClient() with connection_timeout = NULL breaks multi-dimensional arrays

2012-05-15 Thread Robie Basak
Thank you for taking the time to report this bug and helping to make
Ubuntu better.

Are you saying that this bug depends on the kernel version installed?!

Please could you clarify which versions of the php5 you have on both the
machine affected and the machine not affected? Do you think that this is
a bug in php5 packaging or in php5 itself?

** Changed in: php5 (Ubuntu)
   Status: New = Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to php5 in Ubuntu.
https://bugs.launchpad.net/bugs/999614

Title:
  new SoapClient() with connection_timeout = NULL breaks multi-
  dimensional arrays

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/php5/+bug/999614/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-server-iso-tests-review] Server ISO Tests Review

2012-05-15 Thread James Page
Blueprint changed by James Page:

Whiteboard changed:
  Summary of Discussion at UDS:
  
  Current test cases are OK - but all need to be migrated to UTAH early during 
the Q cycle.
  Some gaps in upgrade testing - members of the server team to identify 
suitable test cases so that the QA team can setup more regular upgrade testing.
  More requirements identified for UTAH - specifically multi-nic and USB 
install support.
  Still need to ensure that we get good manual testing coverage at key 
milestones - ubuntu-server list will be used to call for testing.
  MAAS test cases need some improvement and automation.
  
  Session notes: http://pad.ubuntu.com/uds-q-servercloud-q-server-iso-
  tests-review
  
  Assumptions:
  
  - No new tests will be automated using the existing Ubuntu Server ISO Testing 
Framework.
  - All existing tests will be migrated by the Platform QA team as UTAH comes 
online.
  - Existing test format is still valid for UTAH and existing tests can be 
extended in place.
  - The existing upgrade testing framework can support the requirements of the 
server team.
  - OpenStack testing is not covered under the scope of this blueprint.
- - Preseed based install testing is still sufficient to prove installer 
testing.
+ - Preseed based install testing is still sufficient to prove the ISO install 
experience.
  - Manual testing still has its place a key points in the development cycle.
  
  User Stories:  N/A
  Test Plan: N/A
  Release Note: N/A

-- 
Server ISO Tests Review
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-server-iso-tests-review

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 994237] Re: ip_sec

2012-05-15 Thread Robie Basak
Thank you for taking the time to report this bug and helping to make
Ubuntu better.

Ubuntu ships packages which have dealt with source builds already for
you. To install ipsec-tools, type apt-get update and then apt-get
install ipsec-tools. For version 0.8, you'll need Ubuntu release 11.10
or 12.04. Older Ubuntu releases have older versions of ipsec-tools.

As this is not a bug in Ubuntu, I'm marking the bug status as Invalid.

** Changed in: ipsec-tools (Ubuntu)
   Status: New = Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to ipsec-tools in Ubuntu.
https://bugs.launchpad.net/bugs/994237

Title:
  ip_sec

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ipsec-tools/+bug/994237/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999614] Re: new SoapClient() with connection_timeout = NULL breaks multi-dimensional arrays

2012-05-15 Thread Markus Birth
php5, php5-cli, etc. on both machines are 5.3.10-1ubuntu3.1 (x86_64)
from the precise-updates repository.

So the only real difference is the kernel version.

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to php5 in Ubuntu.
https://bugs.launchpad.net/bugs/999614

Title:
  new SoapClient() with connection_timeout = NULL breaks multi-
  dimensional arrays

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/php5/+bug/999614/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-juju-charm-best-practices] Juju Charm Best practices

2012-05-15 Thread Jorge O. Castro
Blueprint changed by Jorge O. Castro:

Whiteboard changed:
  * charm-tools -- charm proof should do everything it can to statically 
analyze and guide users
-   * man pages are needed sorely
+   * man pages are needed sorely
  * charm-helpers -- Gather tools which are useful for sharing between many 
charms
-   * python helpers have been proposed, but blocked up on needing to package 
some extra python deps
+   * python helpers have been proposed, but blocked up on needing to package 
some extra python deps
  * Policy -- Policy is somewhat loose, just listed on 
https://juju.ubuntu.com/Charms
-   * Should be useful information for writing charms, not just rules
-   * Perhaps this should be moved into a versioned RST inside charm-tools?
+   * Should be useful information for writing charms, not just rules
+   * Perhaps this should be moved into a versioned RST inside charm-tools?
+ 
+ charm best practices:
+ 
+ aka. Charm tools all the things!
+ 
+ time to be opinionated? 
+ alternatively point to more example charms?
+ 
+ also juju best practices:
+   this is really a charm best-practice for now... flag-bearing charms should 
include a _good_ readme.
+   (see lp:charms/hadoop for an example)
+ 
+ BEST PRACTICES
+ ==
+ 
+ * run charm proof before submitting *
+ use charm helpers
+ 
+ 
+ WORK ITEMS
+ ===
+ [jorge] Pick better example charms, flagbearer charms.
+ [jorge] Choose a single place for presenting flagbearer charms (charm 
browser?)
+ [mark-mims] (and individual maintainers!) clean up existing charms wrt best 
practices
+ [clint-fewbar] Comment and add links to docs in 'charm create' templates
+ [hazmat] incorporate output of charm proof into charm browser
+ [jorge] Move rules and charm best practices into docs.
+ [jorge] Add Maintainer field information to documents.
+ [clint-fewbar] determine most likely maintainers based on bzr logs
+ [jorge] Reach out to maintainers to get their maintainer firled filled out.
+ [imbrandon] Reach out to maintainers to get their maintainer filled out.
+ [marcoceppi] tag:juju review on AU and SE network
+ [clint-fewbar] fix doc repos wrt (trunk, go, docs)
+ [imbrandon] Put Doc instructions in the docs: http://askubuntu.com/q/52063
+ [jcastro] pull file bug or join the doc team from other projects
+ [hazmat] clear out trunk docs for juju
+ [hazmat] make juju report on initial lxc image downloads ?
+ [hazmat] make juju lxc use lxc networking instead of libvirt networking ?
+ [jorge] Clarify documentention on what to expect when your using LXC and EC2. 
Cost, wait time, what you see, logs, downloading. You should expect this to 
download 300 megs, etc. Here's a table of look here troubleshooting your LXC 
thing.
+ [imbrandon] Clarify documentention on what to expect when your using LXC and 
EC2. Cost, wait time, what you see, logs, downloading. You should expect this 
to download 300 megs, etc. Here's a table of look here troubleshooting your 
LXC thing. 
+ [clint-fewbar] juju in Debian! NOW!
+ [jorge] Add docs work to patch pilot!! (AW YEAA!)

-- 
Juju Charm Best practices
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-juju-charm-best-practices

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-juju-charm-best-practices] Juju Charm Best practices

2012-05-15 Thread Jorge O. Castro
Blueprint changed by Jorge O. Castro:

Work items set to:
Work items:
[jorge] Pick better example charms, flagbearer charms.: TODO
[jorge] Choose a single place for presenting flagbearer charms (charm 
browser?): TODO
[mark-mims] (and individual maintainers!) clean up existing charms wrt best 
practices: TODO
[clint-fewbar] Comment and add links to docs in 'charm create' templates: TODO
[hazmat] incorporate output of charm proof into charm browser: TODO
[jorge] Move rules and charm best practices into docs.: TODO
[jorge] Add Maintainer field information to documents.: TODO
[clint-fewbar] determine most likely maintainers based on bzr logs: TODO
[jorge] Reach out to maintainers to get their maintainer firled filled out.: 
TODO
[imbrandon] Reach out to maintainers to get their maintainer filled out.: TODO
[marcoceppi] tag:juju review on AU and SE network: TODO
[clint-fewbar] fix doc repos wrt (trunk, go, docs): TODO
[imbrandon] Put Doc instructions in the docs: http://askubuntu.com/q/52063 : 
TODO
[jcastro] pull file bug or join the doc team from other projects: TODO
[hazmat] clear out trunk docs for juju: TODO
[hazmat] make juju report on initial lxc image downloads ?: TODO
[hazmat] make juju lxc use lxc networking instead of libvirt networking ?: TODO
[jorge] Clarify documentention on what to expect when your using LXC and EC2. 
Cost, wait time, what you see, logs, downloading. You should expect this to 
download 300 megs, etc. Here's a table of look here troubleshooting your LXC 
thing.: TODO
[imbrandon] Clarify documentention on what to expect when your using LXC and 
EC2. Cost, wait time, what you see, logs, downloading. You should expect this 
to download 300 megs, etc. Here's a table of look here troubleshooting your 
LXC thing.: TODO
[clint-fewbar] juju in Debian! NOW!: TODO
[jorge] Add docs work to patch pilot!! (AW YEAA!): TODO

-- 
Juju Charm Best practices
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-juju-charm-best-practices

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-juju-charm-best-practices] Juju Charm Best practices

2012-05-15 Thread Jorge O. Castro
Blueprint changed by Jorge O. Castro:

Whiteboard changed:
  * charm-tools -- charm proof should do everything it can to statically 
analyze and guide users
    * man pages are needed sorely
  * charm-helpers -- Gather tools which are useful for sharing between many 
charms
    * python helpers have been proposed, but blocked up on needing to package 
some extra python deps
  * Policy -- Policy is somewhat loose, just listed on 
https://juju.ubuntu.com/Charms
    * Should be useful information for writing charms, not just rules
    * Perhaps this should be moved into a versioned RST inside charm-tools?
  
  charm best practices:
  
  aka. Charm tools all the things!
  
- time to be opinionated? 
+ time to be opinionated?
  alternatively point to more example charms?
  
  also juju best practices:
-   this is really a charm best-practice for now... flag-bearing charms should 
include a _good_ readme.
-   (see lp:charms/hadoop for an example)
+   this is really a charm best-practice for now... flag-bearing charms should 
include a _good_ readme.
+   (see lp:charms/hadoop for an example)
  
  BEST PRACTICES
  ==
  
  * run charm proof before submitting *
  use charm helpers
- 
- 
- WORK ITEMS
- ===
- [jorge] Pick better example charms, flagbearer charms.
- [jorge] Choose a single place for presenting flagbearer charms (charm 
browser?)
- [mark-mims] (and individual maintainers!) clean up existing charms wrt best 
practices
- [clint-fewbar] Comment and add links to docs in 'charm create' templates
- [hazmat] incorporate output of charm proof into charm browser
- [jorge] Move rules and charm best practices into docs.
- [jorge] Add Maintainer field information to documents.
- [clint-fewbar] determine most likely maintainers based on bzr logs
- [jorge] Reach out to maintainers to get their maintainer firled filled out.
- [imbrandon] Reach out to maintainers to get their maintainer filled out.
- [marcoceppi] tag:juju review on AU and SE network
- [clint-fewbar] fix doc repos wrt (trunk, go, docs)
- [imbrandon] Put Doc instructions in the docs: http://askubuntu.com/q/52063
- [jcastro] pull file bug or join the doc team from other projects
- [hazmat] clear out trunk docs for juju
- [hazmat] make juju report on initial lxc image downloads ?
- [hazmat] make juju lxc use lxc networking instead of libvirt networking ?
- [jorge] Clarify documentention on what to expect when your using LXC and EC2. 
Cost, wait time, what you see, logs, downloading. You should expect this to 
download 300 megs, etc. Here's a table of look here troubleshooting your LXC 
thing.
- [imbrandon] Clarify documentention on what to expect when your using LXC and 
EC2. Cost, wait time, what you see, logs, downloading. You should expect this 
to download 300 megs, etc. Here's a table of look here troubleshooting your 
LXC thing. 
- [clint-fewbar] juju in Debian! NOW!
- [jorge] Add docs work to patch pilot!! (AW YEAA!)

-- 
Juju Charm Best practices
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-juju-charm-best-practices

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-juju-charm-unit-tests] Juju Charm Unit Tests

2012-05-15 Thread Jorge O. Castro
Blueprint changed by Jorge O. Castro:

Whiteboard set to:

charm unit tests

recap... we automatically run:
  - installation
  - graph test
we'd like to additionally run
  - charm tests

read the spec lp:juju in the docs dir... look for something like 
charmtests.rst
http://bazaar.launchpad.net/~clint-fewbar/juju/charm-tests-spec/view/head:/source/charm-tests.rst

policy stuff?
tests required?  just encouraged for now

additional testing plugins possible:
  - nessus, etc against the running service
  - app-armor complain against running service
  - lint-type 'charm proof'
  - upgrade-charm tests
  - testing spread with add-unit
  - coverage ???
  - watching relation settings??

please put all projects in one of:
charm-tools
juju-jitsu
charms
juju

environments - include all of them, including MAAS

support MAAS, other distro needs

enable manual kicks from ~charmers (charmbot, but we prob wanna do that
through openid over the web) - parameterized jenkins tests, both
official and against specific distro needs

charmtester is a *charm* in the charm store - test my custom stack of
services is readily doable (contributions are welcome as always)

jenkins file bugs when charms fail (close them when they pass again?)
try for maintainer notification through launchpad

how do long-failing tests relate to series freeze???

coverage tools possible?  check out next cycle

load testing for individual charms?  for example, siege all charms with
http interface

scale testing?  weekly large runs?  really a _juju_ test and less a
_charm_ test


ACTIONS:
[] documentation for unit tests
[] write examples of unit tests on flag-bearing charms
[] make 'jitsu run-tests' aware of error codes
[hazmat] charm proof testing
[] keep everything green
[mark-mims] make charmtester easier to use one-off by anyone
[mark-mims] make charmtester whitelist
[] extend charm tools to help generate tests
run charmtester against maas environment


#uds-q #servercloud #juju

-- 
Juju Charm Unit Tests
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-juju-charm-unit-tests

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-juju-charms-release-policy] Clarifying Charm Store policy around Ubuntu Releases

2012-05-15 Thread Jorge O. Castro
Blueprint changed by Jorge O. Castro:

Whiteboard set to:

Charm Store Policy

- This is a living policy, we will not try to get it perfect, so trying to get 
it perfect is not useful, we need to be agile and revisit our policies on a 
regular basis.
- Charm Store doesn't freeze
- I want stability. I want a single place to collaborate around.

backports?
charm store submissions?
When to open the next release series?

Where we've been doing:

- Default series is LTS with juju deploy foo


Where do we want to go with it:

- Default series should be LTS with juju deploy foo
- Search should default to the best possible solution first.

what do we mean by:
 - open - able to push to this series
 - development focus - default series to build against?

dev focus with release (at beta?)
but insure lts gets as much focus as we can


one approach
- commit to latest dev focus
- try to test on previous release
- try to test further back
two things to do this:
- blacklisting for tests
- better automated testing

also start forward testing as soon as alpha1 is available

perhaps charm browser can show test status for each charm... _per
release_

security is an aspect of this when considering preventing, allowing, or 
automating back-ports
maybe don't auto-backport...
put on the maintainer's shoulders?
what about use tags?... auto-backport only tagged appropriately?
(kinda like pockets security, etc etc)

Tags for charms to denote default behavior

perhaps the only valid tags we can use are ones that can be
automatically tested?

we digress...

we branched too late for precise release
next time... ?
  - q the dev focus on beta1 day?
  - what to do with backports?

hard problem, we don't have solid answers...
maybe we just need to make a decision and run with it

follow the distro model, but lag by three months
adjust on demand

Dev focus to stay on LTS (precise) and push promulgated charms forward
and test forward

WORK ITEMS?

-- 
Clarifying Charm Store policy around Ubuntu Releases
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-juju-charms-release-policy

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 958704] Re: ubuntu 12.04 boot with nis(ypbind) autofs (nfs) not working.

2012-05-15 Thread Steve Plummer
I just wanted to comment that I find it troubling that this bug is closed and 
has low urgency.  I am not a developer, just a user. 
My company runs a small computer lab for our clients, it is used by 150+ users. 
 It uses NIS for it's logins and NFS for the user's home directories.  Any time 
that a user restarts or shuts down a computer, I have to log into the one local 
account and run a sudo restart ypbind (which I learned from this thread, 
thank you) and log out...as you can guess users restart or shutdown frequently, 
completely disabling the computer.  Prior to upgrading to 12.04, this lab ran 
flawlessly and took almost none of my attention, now it takes up a solid hour 
of every work day.
Please reconsider this bug as a higher priority.  How many schools, libraries, 
and companies like mine are being affected?

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to autofs5 in Ubuntu.
https://bugs.launchpad.net/bugs/958704

Title:
  ubuntu 12.04 boot with nis(ypbind) autofs (nfs) not working.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/autofs5/+bug/958704/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-juju-integration] Juju Integration

2012-05-15 Thread Jorge O. Castro
Blueprint changed by Jorge O. Castro:

Whiteboard changed:
  Juju will not live in isolation
  https://launchpad.net/juju-jitsu exists to enable these use cases
  
  Potential integration points:
  
  - Existing Puppet Deployments
-  - Existing puppet subordinate charm promulgated yesterday
+  - Existing puppet subordinate charm promulgated yesterday
  - Existing Puppet Manifests
  - External Node Classifier
  - Capistrano / Fabric
-   - jitsu capfile - emits a capfile
-   - capistrano subordinate?
+   - jitsu capfile - emits a capfile
+   - capistrano subordinate?
  - Chef
  - SaltStack
-  
+ 
  Solutions
  - REST API (lp:jrapi)
  
  other ways to integrate
  puppetforge
  cookbooks on github
  how do you make a charm out of any of these?
- 
- 
- Work Items:
- [mark-mims] charm to deploy chef-server (maybe w sub like clint's puppet sub)
- [mark-mims] charms that call chef solo recipes
- jujustrano
- [negronjl] go to town on clint's puppet sub ( puppetforge? ) ( add charm 
create option for puppet recipes )
- define ways that capistrano would need to call Capistrano
- [negronjl] jrapi as juju-jitsu subcommand... 'jitsu api'
- [hazmat] export/import environment into juju-jitsu
- use-cases for integration
- how to make charms out of puppetforge modules / github cookbooks
- plugin for chef-search to interface with juju (possibly just chef sub)
- testing against euca and cloudstack
- jenkins plugins for juju (anything other than charm-runner?)
- vagrant integration to support local development story on osx
- [mike-mcclurg] cloudstack integration
- [imbrandon] investigate enstratus integration
- 
- related
- best practices for juju at scale

-- 
Juju Integration
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-juju-integration

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


Re: [Bug 978356] Re: squid3 gets killed at startup with dnsmasq and no networkmanager

2012-05-15 Thread Clint Byrum
Excerpts from Daniel Hahler's message of Tue May 15 08:53:06 UTC 2012:
 For what it's worth, this does not happen with the squid-deb-proxy
 package (which uses squid with an optimized config) - at least after
 several boot processes.
 
 The init/start script is different, for example, it uses
 start on (local-filesystems and net-device-up IFACE!=lo)

This is basically wrong. A system may have more than one interface and
there is no guarantee that one of them is the right one.

That said, this makes perfect sense, because with NM, this will delay the
start until *after* the first interface comes up, whereas with runlevel 2,
that event will actually come before the first interface is up, so that
starts the window where squid is starting up, polling for DNS entries
and failing, and then it gets HUP just as the interface comes up.

My patch to ignore HUP early on should solve this issue, but I haven't
pushed it back upstream yet.

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to squid3 in Ubuntu.
https://bugs.launchpad.net/bugs/978356

Title:
  squid3 gets killed at startup with dnsmasq and no networkmanager

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dnsmasq/+bug/978356/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999710] [NEW] package libsensors4 1:3.3.1-2ubuntu1 failed to install/upgrade: conffile './etc/sensors.d/.placeholder' is not in sync with other instances of the same package

2012-05-15 Thread stu green
Public bug reported:

Release - 12.04
lm-sensors 1:3.3.1-2ubuntu1
expected it to install
it did not

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: libsensors4 1:3.3.1-2ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Tue May 15 01:04:59 2012
DuplicateSignature:
 Unpacking libsensors4:i386 (from .../libsensors4_1%3a3.3.1-2ubuntu1_i386.deb) 
...
 dpkg: error processing 
/var/cache/apt/archives/libsensors4_1%3a3.3.1-2ubuntu1_i386.deb (--unpack):
  conffile './etc/sensors.d/.placeholder' is not in sync with other instances 
of the same package
ErrorMessage: conffile './etc/sensors.d/.placeholder' is not in sync with other 
instances of the same package
InstallationMedia: Ubuntu 12.04 LTS Precise Pangolin - Release amd64 
(20120425)
SourcePackage: lm-sensors
Title: package libsensors4 1:3.3.1-2ubuntu1 failed to install/upgrade: conffile 
'./etc/sensors.d/.placeholder' is not in sync with other instances of the same 
package
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: lm-sensors (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package need-duplicate-check precise

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to lm-sensors in Ubuntu.
https://bugs.launchpad.net/bugs/999710

Title:
  package libsensors4 1:3.3.1-2ubuntu1 failed to install/upgrade:
  conffile './etc/sensors.d/.placeholder' is not in sync with other
  instances of the same package

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lm-sensors/+bug/999710/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999710] Re: package libsensors4 1:3.3.1-2ubuntu1 failed to install/upgrade: conffile './etc/sensors.d/.placeholder' is not in sync with other instances of the same package

2012-05-15 Thread stu green
-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to lm-sensors in Ubuntu.
https://bugs.launchpad.net/bugs/999710

Title:
  package libsensors4 1:3.3.1-2ubuntu1 failed to install/upgrade:
  conffile './etc/sensors.d/.placeholder' is not in sync with other
  instances of the same package

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lm-sensors/+bug/999710/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 958312] Re: Change zk logging configuration

2012-05-15 Thread Clint Byrum
** Description changed:

+ == SRU Justifcation ==
+ 
+ === Impact ===
+ This bug can cause juju's local provider to fill up the local disk very 
rapidly after a reboot.
+ 
+ === Test Case ===
+ 1. Create a local environment in ~/.juju/environments.yaml, something like 
this:
+ 
+ environments:
+   local:
+ type: local
+ data-dir: /home/myuser/.juju/data
+ default-series: precise
+ 
+ 2. juju bootstrap
+ 3. reboot the machine
+ 4. check /home/myuser/.juju/data/myuser-local/machine-agent.log .. if it is 
streaming errors, the system is affected.
+ 5. juju destroy-environment
+ 6. update the package
+ 7. repeat steps 1 - 4. If the logs are no longer streaming, the bug is fixed.
+ 
+ === Dev Fix ===
+ 
+ This is fixed in upstream commit 533 by suppressing the logs from
+ libzookeeper.
+ 
+ === Regression Potential ===
+ Very low, this simply suppresses the logs that come streaming out of 
libzookeeper, and they are not useful in most cases. This does mean that in the 
rare cases where client error logs would be useful, they are suppressed.
+ 
+ == Original Bug Description ==
+ 
  The verbosity and frequency of the zookeeper log is considerable, use a
  pipe and filter on level and rate. Lacking this its possible for the log
- to fill up the disks on the machine for a disconnected agent, happened
+ to fill up the disks on the machine for a disconnected agent, happeneRd
  to me on local provider, ugh. Just to be clear this on the client
  connection logging, not the server.

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to juju in Ubuntu.
https://bugs.launchpad.net/bugs/958312

Title:
  Change zk logging configuration

To manage notifications about this bug go to:
https://bugs.launchpad.net/juju/+bug/958312/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 998732] Re: vmbuilder debootstrap crash

2012-05-15 Thread Serge Hallyn
Thanks for reporting this bug.

I suspect you'll have to change your configuration to allow things like
mounting inside a chroot, etc.  If you feel this is a bug in debootstrap
you could file a bug against it, but I think privileged operation is
assumed, and so this is not a valid bug.

** Changed in: vm-builder (Ubuntu)
   Status: New = Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to vm-builder in Ubuntu.
https://bugs.launchpad.net/bugs/998732

Title:
  vmbuilder debootstrap crash

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/vm-builder/+bug/998732/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999725] [NEW] broken start-up dependencies for ntp

2012-05-15 Thread Paul Crawford
Public bug reported:

We recently installed 12.04 LTS (32-bit) with NIS authentication and found two 
bugs with ntp, the first was ntp was not installed (even though the clock 
manager allowed, and defaulted to, internet time) and the second more serious 
bug reported here is we discovered that ntp is being started before the system 
is capable of resolving DNS, so only time servers given by IP address are found.
Those given by name (ntp0.dundee.ac.uk and similar) are not found and, as ntp 
never performs DNS lookup after initially starting, they remain unavailable 
until you manually issue the command /etc/init.d/ntp restart.
This was not a problem with 10.04 LTS, and I also though upstart was supposed 
to handle such starting sequence dependencies?

$lsb_release -rd
Description:Ubuntu 12.04 LTS
Release:12.04

$ apt-cache policy ntp
ntp:
  Installed: 1:4.2.6.p3+dfsg-1ubuntu3
  Candidate: 1:4.2.6.p3+dfsg-1ubuntu3
  Version table:
 *** 1:4.2.6.p3+dfsg-1ubuntu3 0
500 http://gb.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
100 /var/lib/dpkg/status

We expected ntp to be started after the network interfaces were up and
DNS look-up possible.

** Affects: ntp (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to ntp in Ubuntu.
https://bugs.launchpad.net/bugs/999725

Title:
  broken start-up dependencies for ntp

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ntp/+bug/999725/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999187] Re: lxc-create for armhf fails with error failed to execute template 'ubuntu'

2012-05-15 Thread Serge Hallyn
Thanks.

Sounds like /etc/apt/sources.list is not being set right.

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to lxc in Ubuntu.
https://bugs.launchpad.net/bugs/999187

Title:
  lxc-create for armhf fails with error failed to execute template
  'ubuntu'

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/999187/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999187] Re: lxc-create for armhf fails with error failed to execute template 'ubuntu'

2012-05-15 Thread Serge Hallyn
James,

I assume this is on precise?

** Also affects: lxc (Ubuntu Precise)
   Importance: Undecided
   Status: New

** Also affects: lxc (Ubuntu Quantal)
   Importance: High
   Status: New

** Changed in: lxc (Ubuntu Precise)
   Status: New = Fix Released

** Changed in: lxc (Ubuntu Quantal)
   Status: New = Confirmed

** Changed in: lxc (Ubuntu Precise)
 Assignee: (unassigned) = Stéphane Graber (stgraber)

** Changed in: lxc (Ubuntu Precise)
   Importance: Undecided = High

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to lxc in Ubuntu.
https://bugs.launchpad.net/bugs/999187

Title:
  lxc-create for armhf fails with error failed to execute template
  'ubuntu'

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/999187/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999764] [NEW] no ufw profile or apport hook is included in the 12.04 packages

2012-05-15 Thread James Page
Public bug reported:

The samba packages in 11.10 ship both a ufw profile and an apport hook:

   samba: /etc/ufw/applications.d/samba
   samba-common-bin: /usr/share/apport/package-hooks/source_samba.py

Neither of these is included in the 12.04 packages - looks like they got
dropped from the .install files during merging.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: samba 2:3.6.3-2ubuntu2.1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Tue May 15 16:47:40 2012
SourcePackage: samba
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: samba (Ubuntu)
 Importance: High
 Assignee: James Page (james-page)
 Status: In Progress

** Affects: samba (Ubuntu Precise)
 Importance: High
 Status: New

** Affects: samba (Ubuntu Quantal)
 Importance: High
 Assignee: James Page (james-page)
 Status: In Progress


** Tags: amd64 apport-bug precise

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to samba in Ubuntu.
https://bugs.launchpad.net/bugs/999764

Title:
  no ufw profile or apport hook is included in the 12.04 packages

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/samba/+bug/999764/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999764] Re: no ufw profile or apport hook is included in the 12.04 packages

2012-05-15 Thread James Page
** Also affects: samba (Ubuntu Precise)
   Importance: Undecided
   Status: New

** Also affects: samba (Ubuntu Quantal)
   Importance: Undecided
   Status: New

** Changed in: samba (Ubuntu Quantal)
   Status: New = In Progress

** Changed in: samba (Ubuntu Precise)
   Importance: Undecided = High

** Changed in: samba (Ubuntu Quantal)
   Importance: Undecided = High

** Changed in: samba (Ubuntu Quantal)
 Assignee: (unassigned) = James Page (james-page)

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to samba in Ubuntu.
https://bugs.launchpad.net/bugs/999764

Title:
  no ufw profile or apport hook is included in the 12.04 packages

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/samba/+bug/999764/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999187] Re: lxc-create for armhf fails with error failed to execute template 'ubuntu'

2012-05-15 Thread Stéphane Graber
** Changed in: lxc (Ubuntu)
   Status: Confirmed = Fix Released

** Changed in: lxc (Ubuntu Precise)
   Status: Fix Released = Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to lxc in Ubuntu.
https://bugs.launchpad.net/bugs/999187

Title:
  lxc-create for armhf fails with error failed to execute template
  'ubuntu'

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/999187/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999787] Re: package kpartx-boot 0.4.9-3ubuntu5 failed to install/upgrade: ErrorMessage: dependency problems - leaving unconfigured

2012-05-15 Thread Marco Normac
*** This bug is a duplicate of bug 999782 ***
https://bugs.launchpad.net/bugs/999782

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to multipath-tools in Ubuntu.
https://bugs.launchpad.net/bugs/999787

Title:
  package kpartx-boot 0.4.9-3ubuntu5 failed to install/upgrade:
  ErrorMessage: dependency problems - leaving unconfigured

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/multipath-tools/+bug/999787/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999785] Re: package libsensors4 1:3.3.1-2ubuntu1 failed to install/upgrade: conffile './etc/sensors.d/.placeholder' is not in sync with other instances of the same package

2012-05-15 Thread Victor
-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to lm-sensors in Ubuntu.
https://bugs.launchpad.net/bugs/999785

Title:
  package libsensors4 1:3.3.1-2ubuntu1 failed to install/upgrade:
  conffile './etc/sensors.d/.placeholder' is not in sync with other
  instances of the same package

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lm-sensors/+bug/999785/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999787] [NEW] package kpartx-boot 0.4.9-3ubuntu5 failed to install/upgrade: ErrorMessage: dependency problems - leaving unconfigured

2012-05-15 Thread Marco Normac
*** This bug is a duplicate of bug 999782 ***
https://bugs.launchpad.net/bugs/999782

Private bug reported:

After Upgrading 10.04 LTS to 12.04 LTS codename:pargolin

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: kpartx-boot
ProcVersionSignature: Ubuntu 3.2.0-24.38-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Tue May 15 17:06:56 2012
ErrorMessage: ErrorMessage: dependency problems - leaving unconfigured
InstallationMedia: Zorin OS 3 Core - Release amd64
PackageArchitecture: all
SourcePackage: multipath-tools
Title: package kpartx-boot 0.4.9-3ubuntu5 failed to install/upgrade: 
ErrorMessage: dependency problems - leaving unconfigured
UpgradeStatus: Upgraded to precise on 2012-05-15 (0 days ago)

** Affects: multipath-tools (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package precise

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to multipath-tools in Ubuntu.
https://bugs.launchpad.net/bugs/999787

Title:
  package kpartx-boot 0.4.9-3ubuntu5 failed to install/upgrade:
  ErrorMessage: dependency problems - leaving unconfigured

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/multipath-tools/+bug/999787/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999785] [NEW] package libsensors4 1:3.3.1-2ubuntu1 failed to install/upgrade: conffile './etc/sensors.d/.placeholder' is not in sync with other instances of the same package

2012-05-15 Thread Victor
Public bug reported:


after running

sudo dpkg --set-selections packlist.txt
sudo apt-get dselect-upgrade

The processes ran, before ending some error was produced which lead mt
to this page

The process ended. Th last few lines show:

Errors were encountered while processing:
 /var/cache/apt/archives/libsensors4_1%3a3.3.1-2ubuntu1_i386.deb
 /var/cache/apt/archives/gcc-4.4-base_4.4.7-1ubuntu2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

That's it.

Thanks

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: libsensors4 1:3.3.1-2ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
NonfreeKernelModules: nvidia bnep rfcomm bluetooth ext2 lp snd_hda_codec_analog 
snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_seq_midi dell_wmi nouveau 
snd_rawmidi ttm drm_kms_helper drm i2c_algo_bit sparse_keymap psmouse mxm_wmi 
snd_seq_midi_event snd_seq wmi mei mac_hid snd_timer snd_seq_device serio_raw 
dcdbas ppdev parport_pc parport video snd soundcore snd_page_alloc usbhid hid 
e1000e
ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
Date: Tue May 15 12:06:24 2012
DuplicateSignature:
 Unpacking libsensors4:i386 (from .../libsensors4_1%3a3.3.1-2ubuntu1_i386.deb) 
...
 dpkg: error processing 
/var/cache/apt/archives/libsensors4_1%3a3.3.1-2ubuntu1_i386.deb (--unpack):
  conffile './etc/sensors.d/.placeholder' is not in sync with other instances 
of the same package
ErrorMessage: conffile './etc/sensors.d/.placeholder' is not in sync with other 
instances of the same package
InstallationMedia: Ubuntu 12.04 LTS Precise Pangolin - Release amd64 
(20120425)
SourcePackage: lm-sensors
Title: package libsensors4 1:3.3.1-2ubuntu1 failed to install/upgrade: conffile 
'./etc/sensors.d/.placeholder' is not in sync with other instances of the same 
package
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: lm-sensors (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package need-duplicate-check precise

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to lm-sensors in Ubuntu.
https://bugs.launchpad.net/bugs/999785

Title:
  package libsensors4 1:3.3.1-2ubuntu1 failed to install/upgrade:
  conffile './etc/sensors.d/.placeholder' is not in sync with other
  instances of the same package

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lm-sensors/+bug/999785/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999801] [NEW] package kpartx-boot 0.4.9-3ubuntu5 failed to install/upgrade: ErrorMessage: dependency problems - leaving unconfigured

2012-05-15 Thread Marco Normac
Private bug reported:

After Upgrading 10.04 LTS to 12.04 LTS codename:pargolin

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: kpartx-boot
ProcVersionSignature: Ubuntu 3.2.0-24.38-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Tue May 15 17:06:56 2012
ErrorMessage: ErrorMessage: dependency problems - leaving unconfigured
InstallationMedia: Zorin OS 3 Core - Release amd64
PackageArchitecture: all
SourcePackage: multipath-tools
Title: package kpartx-boot 0.4.9-3ubuntu5 failed to install/upgrade: 
ErrorMessage: dependency problems - leaving unconfigured
UpgradeStatus: Upgraded to precise on 2012-05-15 (0 days ago)

** Affects: multipath-tools (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package precise

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to multipath-tools in Ubuntu.
https://bugs.launchpad.net/bugs/999801

Title:
  package kpartx-boot 0.4.9-3ubuntu5 failed to install/upgrade:
  ErrorMessage: dependency problems - leaving unconfigured

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/multipath-tools/+bug/999801/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999801] Re: package kpartx-boot 0.4.9-3ubuntu5 failed to install/upgrade: ErrorMessage: dependency problems - leaving unconfigured

2012-05-15 Thread Marco Normac
-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to multipath-tools in Ubuntu.
https://bugs.launchpad.net/bugs/999801

Title:
  package kpartx-boot 0.4.9-3ubuntu5 failed to install/upgrade:
  ErrorMessage: dependency problems - leaving unconfigured

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/multipath-tools/+bug/999801/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999187] Re: lxc-create for armhf fails with error failed to execute template 'ubuntu'

2012-05-15 Thread Colin Watson
Hello James, or anyone else affected,

Accepted lxc into precise-proposed. The package will build now and be
available in a few hours. Please test and give feedback here. See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
enable and use -proposed. Thank you in advance!

** Tags added: verification-needed

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to lxc in Ubuntu.
https://bugs.launchpad.net/bugs/999187

Title:
  lxc-create for armhf fails with error failed to execute template
  'ubuntu'

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/999187/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999187] Re: lxc-create for armhf fails with error failed to execute template 'ubuntu'

2012-05-15 Thread Launchpad Bug Tracker
** Branch linked: lp:ubuntu/precise-proposed/lxc

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to lxc in Ubuntu.
https://bugs.launchpad.net/bugs/999187

Title:
  lxc-create for armhf fails with error failed to execute template
  'ubuntu'

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/999187/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


Re: [Bug 998732] Re: vmbuilder debootstrap crash

2012-05-15 Thread Alix Mougenot
It was indeed because of a secure the kernel.
Thx.

 Dr. Alix Mougenot  | Head of Technology (Directeur Technique), Loodies |
www.loodies.com | S: alix_loodies | a...@loodies.com | 20 rue Jean Batiste
Pigalle, 75009  Paris.


2012/5/15 Serge Hallyn 998...@bugs.launchpad.net

 Thanks for reporting this bug.

 I suspect you'll have to change your configuration to allow things like
 mounting inside a chroot, etc.  If you feel this is a bug in debootstrap
 you could file a bug against it, but I think privileged operation is
 assumed, and so this is not a valid bug.

 ** Changed in: vm-builder (Ubuntu)
   Status: New = Invalid

 --
 You received this bug notification because you are subscribed to the bug
 report.
 https://bugs.launchpad.net/bugs/998732

 Title:
  vmbuilder debootstrap crash

 Status in “vm-builder” package in Ubuntu:
  Invalid

 Bug description:
  package:
  ubuntu-vm-builder_0.12.4+bzr477

  real package:
  python-vm-builder_0.12.4+bzr477

  running on:
  Ubuntu 12.04 LTS

  by running the following command (just a test):
  $ sudo vmbuilder kvm ubuntu --suite precise --flavour server --libvirt
 qemu:///system

  is triggered the following exception:
  W: Failure trying to run: chroot /tmp/tmprLI6UB mount -t proc proc /proc
  Traceback (most recent call last):
File /usr/bin/vmbuilder, line 24, in module
  cli.main()
File /usr/lib/python2.7/dist-packages/VMBuilder/contrib/cli.py, line
 216, in main
  distro.build_chroot()
File /usr/lib/python2.7/dist-packages/VMBuilder/distro.py, line 83,
 in build_chroot
  self.call_hooks('bootstrap')
File /usr/lib/python2.7/dist-packages/VMBuilder/distro.py, line 67,
 in call_hooks
  call_hooks(self, *args, **kwargs)
File /usr/lib/python2.7/dist-packages/VMBuilder/util.py, line 165, in
 call_hooks
  getattr(context, func, log_no_such_method)(*args, **kwargs)
File
 /usr/lib/python2.7/dist-packages/VMBuilder/plugins/ubuntu/distro.py, line
 136, in bootstrap
  self.suite.debootstrap()
File
 /usr/lib/python2.7/dist-packages/VMBuilder/plugins/ubuntu/dapper.py, line
 269, in debootstrap
  run_cmd(*cmd, **kwargs)
File /usr/lib/python2.7/dist-packages/VMBuilder/util.py, line 120, in
 run_cmd
  raise VMBuilderException, Process (%s) returned %d. stdout: %s,
 stderr: %s % (args.__repr__(), status, mystdout.buf, mystderr.buf)
  VMBuilder.exception.VMBuilderException: Process
 (['/usr/sbin/debootstrap', '--arch=amd64', 'precise', '/tmp/tmprLI6UB', '
 http://archive.ubuntu.com/ubuntu']) returned 1

  - debootstrap may be the culprit its version is 1.0.39ubuntu0.1
  - the targeted folder is a correct root folder
  - /proc is a correct proc folder

  complete output:
  2012-05-13 13:56:04,184 INFO: Calling hook: preflight_check
  2012-05-13 13:56:04,186 INFO: Calling hook: set_defaults
  2012-05-13 13:56:04,186 INFO: Calling hook: bootstrap
  2012-05-13 13:57:12,195 INFO: Cleaning up
  2012-05-13 13:57:12,195 ERROR   : Process (['/usr/sbin/debootstrap',
 '--arch=amd64', 'precise', '/tmp/tmprLI6UB', '
 http://archive.ubuntu.com/ubuntu']) returned 1. stdout: I: Retrieving
 Release
  I: Retrieving Release.gpg
  I: Checking Release signature
  I: Valid Release signature (key id
 630239CC130E1A7FD81A27B140976EAF437D05B5)
  I: Retrieving Packages
  I: Validating Packages
  I: Resolving dependencies of required packages...
  I: Resolving dependencies of base packages...
  I: Checking component main on http://archive.ubuntu.com/ubuntu...
  I: Retrieving adduser
  I: Validating adduser
  I: Retrieving apt
  I: Validating apt
  I: Retrieving apt-utils
  I: Validating apt-utils
  I: Retrieving base-files
  I: Validating base-files
  I: Retrieving base-passwd
  I: Validating base-passwd
  I: Retrieving bash
  I: Validating bash
  I: Retrieving bsdutils
  I: Validating bsdutils
  I: Retrieving busybox-initramfs
  I: Validating busybox-initramfs
  I: Retrieving bzip2
  I: Validating bzip2
  I: Retrieving console-setup
  I: Validating console-setup
  I: Retrieving coreutils
  I: Validating coreutils
  I: Retrieving cpio
  I: Validating cpio
  I: Retrieving cron
  I: Validating cron
  I: Retrieving dash
  I: Validating dash
  I: Retrieving debconf
  I: Validating debconf
  I: Retrieving debconf-i18n
  I: Validating debconf-i18n
  I: Retrieving debianutils
  I: Validating debianutils
  I: Retrieving diffutils
  I: Validating diffutils
  I: Retrieving dmsetup
  I: Validating dmsetup
  I: Retrieving dpkg
  I: Validating dpkg
  I: Retrieving e2fslibs
  I: Validating e2fslibs
  I: Retrieving e2fsprogs
  I: Validating e2fsprogs
  I: Retrieving eject
  I: Validating eject
  I: Retrieving file
  I: Validating file
  I: Retrieving findutils
  I: Validating findutils
  I: Retrieving gcc-4.6-base
  I: Validating gcc-4.6-base
  I: Retrieving gnupg
  I: Validating gnupg
  I: Retrieving gpgv
  I: Validating gpgv
  I: Retrieving grep
  I: Validating grep
  I: Retrieving gzip
  I: Validating gzip
  I: Retrieving hostname
  

[Bug 999764] Re: no ufw profile or apport hook is included in the 12.04 packages

2012-05-15 Thread Launchpad Bug Tracker
This bug was fixed in the package samba - 2:3.6.5-2ubuntu1

---
samba (2:3.6.5-2ubuntu1) quantal; urgency=low

  * Merge from Debian unstable, remaining changes:
+ debian/patches/VERSION.patch:
  - set SAMBA_VERSION_SUFFIX to Ubuntu.
+ debian/smb.conf:
  - add (Samba, Ubuntu) to server string.
  - comment out the default [homes] share, and add a comment about
valid users = %S to show users how to restrict access to
\\server\username to only username.
  - Other changes now in Debian packaging.
+ debian/samba-common.config:
  - Do not change priority to high if dhclient3 is installed.
  - Use priority medium instead of high for the workgroup question.
+ debian/control:
  - Don't build against or suggest ctdb.
  - Add dependency on samba-common-bin to samba.
+ Add ufw integration:
  - Created debian/samba.ufw.profile
  - debian/rules, debian/samba.install: install profile.
  - debian/control: have samba suggest ufw.
+ Add apport hook:
  - Created debian/source_samba.py.
  - debian/rules, debian/samba-common-bin.install: install hook.
+ Switch to upstart:
  - Added debian/samba.{nmbd,smbd}.upstart.
  - debian/samba.logrotate, debian/samba-common.dhcp, debian/samba.if-up:
Make upstart compatible.
  * d/samba.install, d/samba-common-bin.install: Restore apport hook and ufw
profile (LP: #999764).
  * Dropped:
+ debian/patches/CVE-2012-1182-*.patch: fixed in upstream release 3.6.4.
+ debian/patches/CVE-2012-2111.patch: fixed in upstream release 3.6.5.
+ debian/patches/fix-debuglevel-name-conflict.patch: fixed upstream -
  debug_level is no longer used as a global variable name.
+ debian/patches/error-trans.fix-276472: fixed upstream.

samba (2:3.6.5-2) unstable; urgency=low

  * The yearly SambaXP bug cleaning party release. 11 years
SambaXP, 20 years Samba and counting...
  * Make samba-common Multi-Arch: foreign
  * Adapt patch in upstream #7499 and stop nss_wins clobbering other
daemon's logfiles. Closes: #598313
  * Add some mention about some use for the user information in Kerberos
environments in the smbspool manpage. Closes: #387266
  * Drop link to no longer provided Using Samba documentation in
HTML documentation summary file. Closes: #604768
  * Provide WHATSNEW.txt in samba-doc too as it is linked from the
documentation summary file. Do not compress that file.
  * Fix link to WHATSNEW.txt in HTML documentation summary file. This
is the second part of the fix for #604768
  * Use lp_state_dir() instead of get_dyn_STATEDIR() in
fhs-filespaths.patch as the latter does indeed hardcode the
location for passdb.tdb and secrets.tdb to /var/lib/samba
(the compile-time option for state directory and NOT the configurable
value). This is left to state directory instead of private dir
at least as of now, because if doesn't change anything to the
current behaviour, but allows the files' location to be configurable
through state directory (and not private dir).
Closes: #249873
  * Disable useless smbtorture4 build. Thanks to Ivo De Decker for the patch.
Closes: #670561
  * Add upstream commit that adds waf source to the buildtools/
directory. As upstream will, one day or another, merge this, I
prefer this over removing the waf binary and repack upstream
tarball.
Closes: #654499
  * Build-Conflict with python-ldb and python-ldb-dev to avoid build
failures when some versions of these packages are locally installed.
Closes: #657314
  * Rename fix-samba.ldip-syntax.patch to fix-samba.ldif-syntax.patch
  * Split NSS modules into a new libnss-winbind binary package.
Closes: #646292
  * Add a NEWS.Debian entry about the libnss-winbind split and, while at
it, add an entry for libpam-winbind too (as it will affect upgrades
from squeeze).
  * Drop code that was moving files around in samba.postinst and
winbind.postinst for pre-squeeze versions of the package.
  * Drop code that was modifying a deprecated passdb backend setting
in smb.conf for pre-squeeze versions of the package (in
samba-common.config).
  * Add Should-Start dependency to winbind init script to guarantee
that the samba init script is started before winbind if present.
Closes: #638066
  * Provide a (basic) manpage to smbtorture(1). Closes: #528735
  * Turkish debconf translation update (Atila KOÇ).  Closes: #672447
  * Drop the code that generates an smbpasswd file from the system's
user list. This adds very long delays on systems with many users,
including those with external user backends. It also makes much
less sense nowadays and the use of libpam-smbpass can easily
fill most of the needs. Closes: #671926
  * Merged from Ubuntu:
- Set 'usershare allow guests', so that usershare admins are
  allowed to create public shares in addition to authenticated
  ones.
- add map 

[Bug 999764] Re: no ufw profile or apport hook is included in the 12.04 packages

2012-05-15 Thread James Page
** Changed in: samba (Ubuntu Precise)
 Assignee: (unassigned) = James Page (james-page)

** Changed in: samba (Ubuntu Precise)
   Status: New = In Progress

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to samba in Ubuntu.
https://bugs.launchpad.net/bugs/999764

Title:
  no ufw profile or apport hook is included in the 12.04 packages

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/samba/+bug/999764/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 423252] Re: NSS using LDAP+SSL breaks setuid applications like su, sudo, apache2 suexec, and atd

2012-05-15 Thread Adam Stokes
** Description changed:

- On Karmic (alpha 4 plus updates), changing the nsswitch.conf 'passwd'
- field to anything with 'ldap' as the first item breaks the ability to
- become root using 'su' and 'sudo' as anyone but root.
+ SRU Request:
+ 
+ [Impact]
+ As heavily outlined in the amount of comments in this bug the impact is 
detrimental to both community and enterprise users alike.
+ 
+ [Development Fix]
+ Howard Chu released a patch in #73 which was later confirmed in #106  #108 
as a resolution. The patch has since then made its way into the latest 
development tree.
+ 
+ [Stable Fix]
+ Patch from #73 can be applied cleanly to Lucid and new distributions.
+ 
+ [Test Case]
+ On Karmic (alpha 4 plus updates), changing the nsswitch.conf 'passwd' field 
to anything with 'ldap' as the first item breaks the ability to become root 
using 'su' and 'sudo' as anyone but root.
  
  Default nsswitch.conf:
  
  passwd: compat
  group:  compat
  shadow: compat
  
  matt@box:~$ sudo uname -a
  [sudo] password for matt:
  Linux box 2.6.31-9-server #29-Ubuntu SMP Sun Aug 30 18:37:42 UTC 2009 x86_64 
GNU/Linux
  
  matt@box:~$ su -
  Password:
  root@box:~#
  
  Modified nsswitch.conf with 'ldap' before 'compat':
  
  passwd: ldap compat
  group:  ldap compat
  shadow: ldap compat
  
  matt@box:~$ sudo uname -a
  sudo: setreuid(ROOT_UID, user_uid): Operation not permitted
  
  matt@box:~$ su -
  Password:
  setgid: Operation not permitted
  
  Modified nsswitch.conf with 'ldap' after 'compat':
  
  passwd: compat ldap
  group:  compat ldap
  shadow: compat ldap
  
  matt@box:~$ sudo uname -a
  [sudo] password for matt:
  Linux box 2.6.31-9-server #29-Ubuntu SMP Sun Aug 30 18:37:42 UTC 2009 x86_64 
GNU/Linux
  
  matt@box:~$ su -
  Password:
  root@box:~#
  
  The same arrangements in nsswitch.conf work as expected in Jaunty and
  earlier releases.
  
+ [Regression Potential]
+ This should be minimal as the code change only addresses the duplicating 
global_init during thread callbacks.
+ 
+ 
  Lucid Release Note:
  
  == NSS via LDAP+SSL breaks setuid applications like sudo ==
  
  Upgrading systems configured to use ldap over ssl as the first service
  in the nss stack (in nsswitch.conf) leads to a broken nss resolution for
  setuid applications after the upgrade to Lucid (for example sudo would
  stop working). There isn't any simple workaround for now. One option is
  to switch to libnss-ldapd in place of libnss-ldap before the upgrade.
  Another one consists in using nscd before the upgrade.

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to libnss-ldap in Ubuntu.
https://bugs.launchpad.net/bugs/423252

Title:
  NSS using LDAP+SSL breaks setuid applications like su, sudo, apache2
  suexec, and atd

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-release-notes/+bug/423252/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 988520] Re: After failed auth, subsequent auths in same context fail

2012-05-15 Thread Ubuntu Foundation's Bug Bot
The attachment krb5.debdiff of this bug report has been identified as
being a patch in the form of a debdiff.  The ubuntu-sponsors team has
been subscribed to the bug report so that they can review and hopefully
sponsor the debdiff.  In the event that this is in fact not a patch you
can resolve this situation by removing the tag 'patch' from the bug
report and editing the attachment so that it is not flagged as a patch.
Additionally, if you are member of the ubuntu-sponsors team please also
unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by
Brian Murray.  Please contact him regarding any issues with the action
taken in this bug report.]

** Tags added: patch

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to krb5 in Ubuntu.
https://bugs.launchpad.net/bugs/988520

Title:
  After failed auth, subsequent auths in same context fail

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/krb5/+bug/988520/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 958312] Re: Change zk logging configuration

2012-05-15 Thread Clint Byrum
** Changed in: juju (Ubuntu)
   Status: Triaged = Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to juju in Ubuntu.
https://bugs.launchpad.net/bugs/958312

Title:
  Change zk logging configuration

To manage notifications about this bug go to:
https://bugs.launchpad.net/juju/+bug/958312/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999764] Re: no ufw profile or apport hook is included in the 12.04 packages

2012-05-15 Thread Launchpad Bug Tracker
** Branch linked: lp:ubuntu/samba

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to samba in Ubuntu.
https://bugs.launchpad.net/bugs/999764

Title:
  no ufw profile or apport hook is included in the 12.04 packages

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/samba/+bug/999764/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 988065] Re: Support smart formatting for relation-ids command

2012-05-15 Thread Clint Byrum
** Changed in: juju
   Importance: Undecided = High

** Also affects: juju (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: juju (Ubuntu Precise)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to juju in Ubuntu.
https://bugs.launchpad.net/bugs/988065

Title:
  Support smart formatting for relation-ids command

To manage notifications about this bug go to:
https://bugs.launchpad.net/juju/+bug/988065/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 423252] Re: NSS using LDAP+SSL breaks setuid applications like su, sudo, apache2 suexec, and atd

2012-05-15 Thread Adam Stokes
** Description changed:

  SRU Request:
  
  [Impact]
  As heavily outlined in the amount of comments in this bug the impact is 
detrimental to both community and enterprise users alike.
  
  [Development Fix]
- Howard Chu released a patch in #73 which was later confirmed in #106  #108 
as a resolution. The patch has since then made its way into the latest 
development tree.
+ Howard Chu released a patch in #73 which was later confirmed in #106  #108 
as a resolution.
  
  [Stable Fix]
  Patch from #73 can be applied cleanly to Lucid and new distributions.
  
  [Test Case]
  On Karmic (alpha 4 plus updates), changing the nsswitch.conf 'passwd' field 
to anything with 'ldap' as the first item breaks the ability to become root 
using 'su' and 'sudo' as anyone but root.
  
  Default nsswitch.conf:
  
  passwd: compat
  group:  compat
  shadow: compat
  
  matt@box:~$ sudo uname -a
  [sudo] password for matt:
  Linux box 2.6.31-9-server #29-Ubuntu SMP Sun Aug 30 18:37:42 UTC 2009 x86_64 
GNU/Linux
  
  matt@box:~$ su -
  Password:
  root@box:~#
  
  Modified nsswitch.conf with 'ldap' before 'compat':
  
  passwd: ldap compat
  group:  ldap compat
  shadow: ldap compat
  
  matt@box:~$ sudo uname -a
  sudo: setreuid(ROOT_UID, user_uid): Operation not permitted
  
  matt@box:~$ su -
  Password:
  setgid: Operation not permitted
  
  Modified nsswitch.conf with 'ldap' after 'compat':
  
  passwd: compat ldap
  group:  compat ldap
  shadow: compat ldap
  
  matt@box:~$ sudo uname -a
  [sudo] password for matt:
  Linux box 2.6.31-9-server #29-Ubuntu SMP Sun Aug 30 18:37:42 UTC 2009 x86_64 
GNU/Linux
  
  matt@box:~$ su -
  Password:
  root@box:~#
  
  The same arrangements in nsswitch.conf work as expected in Jaunty and
  earlier releases.
  
  [Regression Potential]
  This should be minimal as the code change only addresses the duplicating 
global_init during thread callbacks.
  
- 
  Lucid Release Note:
  
  == NSS via LDAP+SSL breaks setuid applications like sudo ==
  
  Upgrading systems configured to use ldap over ssl as the first service
  in the nss stack (in nsswitch.conf) leads to a broken nss resolution for
  setuid applications after the upgrade to Lucid (for example sudo would
  stop working). There isn't any simple workaround for now. One option is
  to switch to libnss-ldapd in place of libnss-ldap before the upgrade.
  Another one consists in using nscd before the upgrade.

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to libnss-ldap in Ubuntu.
https://bugs.launchpad.net/bugs/423252

Title:
  NSS using LDAP+SSL breaks setuid applications like su, sudo, apache2
  suexec, and atd

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-release-notes/+bug/423252/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 988065] Re: Support smart formatting for relation-ids command

2012-05-15 Thread Clint Byrum
** Description changed:

+ == SRU Justification ==
+ 
+ === Impact ===
+ Charms written in shell, which is the bulk of charms, cannot make use of the 
output of this command. Also charms written using the documentation as a guide 
will not work because the docs say it works this way.
+ 
+ === Test Case ===
+ 1. juju bootstrap
+ 2. juju deploy --repository /usr/share/docs/juju/examples local:mysql
+ 3. juju deploy --repository /usr/share/docs/juju/examples local:wordpress
+ 4. juju debug-hooks wordpress/0 db
+ 5. juju add-relation mysql wordpress
+ 6. When the db-relation-joined hook window opens up run 'relation-ids'. 
Affected versions will print out json, while fixed versions will print out a 
list, something like db:0\n
+ 
+ === Dev fix ===
+ 
+ Fixed in upstream commit 532
+ 
+ === Regression Potential ===
+ 
+ Medium. Charms may have already been written that are using the broken
+ behavior. They will have to add --format=json but other than that will
+ work fine. This is mitigated by the fact that the official PPA version
+ is already fixed, and many users, including the charm store automated
+ testing suite use that version.
+ 
+ == Original Bug Description ==
+ 
  Adds format_smart method for RelationIdsCli, which outputs whitespace
  separated (to be precise, per line) relation idents.

** Changed in: juju (Ubuntu)
   Status: New = Fix Released

** Changed in: juju (Ubuntu Precise)
   Status: New = Triaged

** Changed in: juju (Ubuntu)
   Importance: Undecided = High

** Changed in: juju (Ubuntu Precise)
   Importance: Undecided = High

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to juju in Ubuntu.
https://bugs.launchpad.net/bugs/988065

Title:
  Support smart formatting for relation-ids command

To manage notifications about this bug go to:
https://bugs.launchpad.net/juju/+bug/988065/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 915506] Re: juju-log and relation-set outputs {}

2012-05-15 Thread Clint Byrum
** Description changed:

+ == SRU Justification ==
+ 
+ === Impact ===
+ 
+ This causes some charms to have to add complex output control logic for
+ calling juju-log.
+ 
+ === Test Case ===
+ 
+ 1. juju bootstrap
+ 2. juju deploy --repository /usr/share/doc/juju/examples local:mysql
+ 3. juju debug-hooks mysql/0
+ 4. upon seeing the install window open, type 'juju-log foo'. Affected 
versions will show '{}', unaffected versions will return without printing 
anything.
+ 
+ === Dev Fix ===
+ 
+ This was fixed in upstream commit 534
+ 
+ === Regression Potential ===
+ 
+ Low. Charms *MIGHT* have been written in a way where not printing {}
+ would cause issues, but this is very unlikely and is easy to work
+ around.
+ 
+ == Original Bug Description ==
+ 
  using juju with lxc provider on oneiric.
  
  Enter debugging session on a unit with 'juju debug-hooks' and catch an event.
  At the console type 'juju-log test'
  The standard output receives a {}
  
  This is really anoying if you called juju-log within a function which
  standard output is important to you...

** Also affects: juju (Ubuntu)
   Importance: Undecided
   Status: New

** Changed in: juju (Ubuntu)
   Status: New = Fix Released

** Also affects: juju (Ubuntu Precise)
   Importance: Undecided
   Status: New

** Changed in: juju (Ubuntu Precise)
   Status: New = Triaged

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to juju in Ubuntu.
https://bugs.launchpad.net/bugs/915506

Title:
  juju-log and relation-set outputs {}

To manage notifications about this bug go to:
https://bugs.launchpad.net/juju/+bug/915506/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 423252] Re: NSS using LDAP+SSL breaks setuid applications like su, sudo, apache2 suexec, and atd

2012-05-15 Thread Adam Stokes
** Branch linked: lp:~adam-stokes/ubuntu/quantal/libgcrypt11/libgcrypt-
fix-423252

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to libnss-ldap in Ubuntu.
https://bugs.launchpad.net/bugs/423252

Title:
  NSS using LDAP+SSL breaks setuid applications like su, sudo, apache2
  suexec, and atd

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-release-notes/+bug/423252/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999869] Re: vsftpd allows local users to log in even if local_enable in not set

2012-05-15 Thread AC
-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to vsftpd in Ubuntu.
https://bugs.launchpad.net/bugs/999869

Title:
  vsftpd allows local users to log in even if local_enable in not set

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/vsftpd/+bug/999869/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999869] [NEW] vsftpd allows local users to log in even if local_enable in not set

2012-05-15 Thread AC
Public bug reported:

I use almost vanilla /etc/vsftpd.conf file. I am not able to log-in with
a system user tuser from Debian Squeeze as expected. But if I use
psftp from Putty in Windows, vsftpd will allow me to log-in, even if
local_enable is commented out.

From Debian Squeeze:

$ ftp 106.187.*.*
Connected to 106.187.*.*.
220 (vsFTPd 2.3.5)
Name (106.187.*.*:root): tuser
530 Please login with USER and PASS.
530 Please login with USER and PASS.
SSL not available
530 This FTP server is anonymous only.
Login failed.
ftp

From Windows7+Putty:

Puttypsftp 106.187.*.*
login as: tuser
tuser@106.187.*.*'s password:
Remote working directory is /home/tuser
psftp ls
Listing directory /home/tuser
drwxr-xr-x3 tusertuser4096 May 15 18:32 .
drwxr-xr-x4 root root 4096 May 15 17:59 ..
-rw-r--r--1 tusertuser 220 May 15 17:59 .bash_logout
-rw-r--r--1 tusertuser3486 May 15 17:59 .bashrc
drwx--2 tusertuser4096 May 15 18:32 .cache
-rw-r--r--1 tusertuser 675 May 15 17:59 .profile
psftp

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: vsftpd 2.3.5-1ubuntu2
Uname: Linux 3.0.18-linode43 i686
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
Date: Tue May 15 18:34:10 2012
InstallationMedia:
 
ProcEnviron:
 TERM=xterm
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: vsftpd
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.vsftpd.conf: 2012-05-15T18:30:38

** Affects: vsftpd (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: apport-bug i386 precise

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to vsftpd in Ubuntu.
https://bugs.launchpad.net/bugs/999869

Title:
  vsftpd allows local users to log in even if local_enable in not set

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/vsftpd/+bug/999869/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-lxc] Lxc work for Q

2012-05-15 Thread Serge Hallyn
Blueprint changed by Serge Hallyn:

Work items set to:
Work items:
[stgraber] Review list of extra packages in lxc-ubuntu and have it contain the 
right list for each release: TODO
[stefan-bader-canonical] check that all new cgroups are enabled in quantal 
kernel: TODO
[serge-hallyn] pre-mount cgroups during container startup: TODO
[serge-hallyn] send attach patch sets to kernel-team ASAP: TODO
[serge-hallyn] convert lxc-apparmor patchset to generic lsm set: TODO
[serge-hallyn] send generic lsm patchset upstream: TODO
[kees] package libsecomp to aid bpf creation 
http://sourceforge.net/projects/libseccomp/: TODO
[serge-hallyn] exploit libseccomp in lxc-start: TODO
[serge-hallyn] come up with default secomp containers profile: TODO
[apw] expect SECCOMP to drop in v3.5 replacing our patches: TODO
[ebiederm] fix lxc-attach upstream to use the new setns syntax: DONE
[serge-hallyn] write a patch for lxc to use user namespaces: TODO
[ebiederm] patch adduser: TODO
[ebiederm] get user namespaces upstream: INPROGRESS
[ebiederm] get setns(mnt) upstream: DONE
[ebiederm] get setns(pid) upstream: TODO
[serge-hallyn] extend lxc-attach to support attaching only to specific 
namespaces: TODO
[stgraber] add the lxc-nesting apparmor profile to the package in quantal: TODO
[serge-hallyn] send usernamespace patchset ASAP to kernel team (link to git 
repo for review): DONE
[stgraber] write the hookpoints and send to the lxc-devel list for review: TODO
[serge-hallyn] implement configuration file #includes (stretch goal): TODO
[serge-hallyn] example for encrypted root in the example guide: TODO
[serge-hallyn] investigate post commit hook to email out changes: TODO
[serge-hallyn] get lxc to do a pivot root into a per-container tree visible to 
the host: TODO
[serge-hallyn] apport hook for lxc bugs: TODO
[stgraber] where do crashes in the container go: TODO
[james-page] hook testing up to jenkins: TODO
[serge-hallyn] convert the test suite to jenkins: TODO
[serge-hallyn] fedora 16 and 17 and open-suse templates need to be made to work 
(stretch goal): TODO
[stgraber] make an liblxc API definition and publicise (+ serge-hallyn): TODO
[stgraber] Create python module using the API: TODO
[serge-hallyn] arrange devices namespace discussion with the right people after 
userns patchset: TODO

-- 
Lxc work for Q
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-lxc

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-libvirt] Libvirt work for Q

2012-05-15 Thread Serge Hallyn
Blueprint changed by Serge Hallyn:

Whiteboard set to:
Email with proposed fix to console growth problem:
https://review.openstack.org/#/c/5873/

-- 
Libvirt work for Q
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-libvirt

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-libvirt] Libvirt work for Q

2012-05-15 Thread Serge Hallyn
Blueprint changed by Serge Hallyn:

Work items set to:
Work items:
[zulcss] merge latest upstream libvirt: INPROGRESS
[serge-hallyn] finish MIR of netcf: TODO
[serge-hallyn] link libvirt against netc: TODO
[stefan-bader-canonical] look into transition from xend to libxl: TODO
[stefan-bader-canonical] look into automated tests for libvirt-xen: TODO
[serge-hallyn] automated tests for libvirt-lxc 
(start,stop,define,undefine,console): TODO
[adam-g] Ping Daniel Berrange (upstream libvirt) about proposed fix to console 
growth problem: TODO

-- 
Libvirt work for Q
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-libvirt

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-kvm] Kvm work for Q

2012-05-15 Thread Serge Hallyn
Blueprint changed by Serge Hallyn:

Work items set to:
Work items:
[smoser] jump for joy: DONE
[rbasak] follow up on console log size limit implementation (ringbuffer): TODO
[stefan-bader-canonical] confirm the xen and qemu prom naming is correct after 
the debian merge back: TODO
[serge-hallyn] follow up on spice upstream (stretch goal): POSTPONED
[serge-hallyn] sync qemu-kvm from debian: TODO
[serge-hallyn] push qemu-kvm delta back to debian: TODO
[serge-hallyn] move qemu-utils package into qemu-linaro: TODO
[serge-hallyn] sync seabios from debian: TODO
[serge-hallyn] sync ipxe from debian: TODO

-- 
Kvm work for Q
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-kvm

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999869] Re: vsftpd allows local users to log in even if local_enable in not set

2012-05-15 Thread AC
** Changed in: vsftpd (Ubuntu)
   Status: New = Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to vsftpd in Ubuntu.
https://bugs.launchpad.net/bugs/999869

Title:
  vsftpd allows local users to log in even if local_enable in not set

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/vsftpd/+bug/999869/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 997978] Re: KVM images lose connectivity with bridged network

2012-05-15 Thread Jonathan Tullett
It took a few days, but we've finally had a failure of VM instance 2.
It died 2.5 hours ago. Logging into the dom0 host shows the arp table
dead for that host:

mailer02..com   (incomplete)
br0

Logging into the machine itself via console:

root:~# ifconfig
eth0  Link encap:Ethernet  HWaddr 52:54:00:d3:8f:91  
  inet addr:212.XX.239.101  Bcast:212.XX.239.111  Mask:255.255.255.240
  inet6 addr: fe80::5054:ff:fed3:8f91/64 Scope:Link
  UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
  RX packets:6893246 errors:0 dropped:0 overruns:0 frame:0
  TX packets:8242152 errors:0 dropped:0 overruns:0 carrier:0
  collisions:0 txqueuelen:1000 
  RX bytes:2290922658 (2.2 GB)  TX bytes:3314395798 (3.3 GB)

root:~# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric RefUse Iface
0.0.0.0 212.XX.239.97   0.0.0.0 UG10000 eth0
212.XX.239.96   0.0.0.0 255.255.255.240 U 0  00 eth0

Restarting the network on the vm (/etc/init.d/networking restart) does
nothing. Rebooting the VM brings it back to life.

I'm happy to try with the container again, but using the instructions
provided (even with some additional research online), I can't get it
running.  Please advise.

Thanks.

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to bridge-utils in Ubuntu.
https://bugs.launchpad.net/bugs/997978

Title:
  KVM images lose connectivity with bridged network

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bridge-utils/+bug/997978/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 997978] Re: KVM images lose connectivity with bridged network

2012-05-15 Thread Serge Hallyn
Sorry, I didn't see your update on the 12th.

The configuration file as you showed it may also work, but it should be simpler
to use the one I posted.

Can you do 
sudo lxc-start -n lxc1 -l DEBUG -o debugout

and attach the file debugout here?

Do you have cgroups mounted?  (what does 'grep cgroup /proc/self/mounts'
show?)

Does the dhcp server for that network answer all requests, or only for
certain mac addresses?  (Lack of dhcp response shouldn't prevent the
container from starting anyway, so shouldn't explain the problem)

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to bridge-utils in Ubuntu.
https://bugs.launchpad.net/bugs/997978

Title:
  KVM images lose connectivity with bridged network

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bridge-utils/+bug/997978/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 82853] Re: Add support for the smbk5pwd overlay

2012-05-15 Thread Georg Rath
Attached you will find a patch that builds the smbk5pwd overlay.
The patch was done against the openldap 2.4.28-1.1ubuntu4 package.
I basically copied over the missing parts from the debian version of the 
package.

In my opinion the point raised by Mathias Gug is moot. If people want to
use heimdal in combination with smbk5pwd, they should be able to do so.
Especially since there are no downsides to including the smbk5pwd
overlay in the package.

As long as this patch not accepted feel free to use the openldap package
from my PPA (https://launchpad.net/~georg-rath/+archive/ppa-mrce). I
will try to keep up with the official Ubuntu releases.

** Patch added: Build the smbk5pwd overlay in the precise package.
   
https://bugs.launchpad.net/ubuntu/+source/openldap/+bug/82853/+attachment/3148153/+files/openldap_smbk5pwd_precise.patch

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to openldap in Ubuntu.
https://bugs.launchpad.net/bugs/82853

Title:
  Add support for the smbk5pwd overlay

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openldap/+bug/82853/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999896] [NEW] package postfix 2.9.1-4 failed to install/upgrade: le sous-processus script post-installation installé a retourné une erreur de sortie d'état 75

2012-05-15 Thread Odomat
Public bug reported:

Problème existant à chaque passage par synaptic...

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: postfix 2.9.1-4
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic i686
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
Date: Tue May 15 21:32:39 2012
ErrorMessage: le sous-processus script post-installation installé a retourné 
une erreur de sortie d'état 75
InstallationMedia: Ubuntu 11.10 Oneiric - Build i386 LIVE Binary 
20111013-11:02
SourcePackage: postfix
Title: package postfix 2.9.1-4 failed to install/upgrade: le sous-processus 
script post-installation installé a retourné une erreur de sortie d'état 75
UpgradeStatus: Upgraded to precise on 2012-04-28 (17 days ago)

** Affects: postfix (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: apport-package i386 precise

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to postfix in Ubuntu.
https://bugs.launchpad.net/bugs/999896

Title:
  package postfix 2.9.1-4 failed to install/upgrade: le sous-processus
  script post-installation installé a retourné une erreur de sortie
  d'état 75

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/postfix/+bug/999896/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999896] Re: package postfix 2.9.1-4 failed to install/upgrade: le sous-processus script post-installation installé a retourné une erreur de sortie d'état 75

2012-05-15 Thread Odomat
-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to postfix in Ubuntu.
https://bugs.launchpad.net/bugs/999896

Title:
  package postfix 2.9.1-4 failed to install/upgrade: le sous-processus
  script post-installation installé a retourné une erreur de sortie
  d'état 75

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/postfix/+bug/999896/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 997978] Re: KVM images lose connectivity with bridged network

2012-05-15 Thread Jonathan Tullett
Hey,

There is no DHCP server for that network, which is why I set up the
static IPs.

The cgroup-bin package wasn't installed, I installed that and then grep
showed some output:

root:~# grep cgroup /proc/self/mounts
cgroups /sys/fs/cgroup tmpfs rw,relatime,mode=755 0 0
cgroup /sys/fs/cgroup/cpu cgroup rw,relatime,cpu 0 0
cgroup /sys/fs/cgroup/cpuacct cgroup rw,relatime,cpuacct 0 0
cgroup /sys/fs/cgroup/devices cgroup rw,relatime,devices 0 0
cgroup /sys/fs/cgroup/memory cgroup rw,relatime,memory 0 0
cgroup /sys/fs/cgroup/freezer cgroup rw,relatime,freezer 0 0

The container has now started.

I'll configure it so it's running the same software as the other VMs and
let's see what happens over the coming days.

Thanks for your help so far.

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to bridge-utils in Ubuntu.
https://bugs.launchpad.net/bugs/997978

Title:
  KVM images lose connectivity with bridged network

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bridge-utils/+bug/997978/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-juju-charmstore-maintenance] Juju Charm Store Maintenance

2012-05-15 Thread Jorge O. Castro
Blueprint changed by Jorge O. Castro:

Whiteboard changed:
  ==
  Everything has been copied to the Blueprint
  
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-juju-charmstore-maintenance
  -Juan ( negronjl )
  ==
  
  Welcome to Ubuntu Developer Summit!
  
  Avoiding charm store bitrot...
  
  automated testing
  
  - Assign maintainers to charms (metadata.yaml)
  - Failing tests for period of time.
-   - autofiles bug (puts in the Big List to be unpromulgated)
+   - autofiles bug (puts in the Big List to be unpromulgated)
  
  Policy would be to not promote charm series until it's all green (i.e.,
  no critical bugs)
  
  Simplify writing tests:
  
  make it easy for users to run their own tests... merge 'charm test' in
  charm tools
- 
- WORK ITEMS:
- 
- [clint-fewbar] Maintainer idea was almost universally accepted: TODO
- [negronjl] Promulgate should run charm proof: TODO
- [clint-fewbar] update charm tools to support maintainer
- [clint-fewbar] assign maintainers to existing charms, everyone who committed 
to the charm pinged to see who will maintain it.
- [clint-fewbar] Document orphan process.

-- 
Juju Charm Store Maintenance
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-juju-charmstore-maintenance

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-awstools] Package (more) AWS tools for Ubuntu

2012-05-15 Thread Ben Howard
Blueprint changed by Ben Howard:

Work items set to:
Work items:
[jbrowne] Package ELB: TODO
[jbrowne] AWS Import/Export: TODO
[jbrowne] RDS: TODO
[jbrowne] Check IAM for latest version: TODO
[utlemming] Package Autoscaling: TODO
[utlemming] Package Cloudwatch: TODO
[utlemming] MIRs for packages: TODO
[smoser] Re-sync python-boto to 2.3.0 from debian: TODO
[smoser] Debian packaging: TODO
[kamal] Debian packaging: TODO
[utlemming] Setup daily build PPA: TODO
[esh] Promotion of packaging work on Alestic.com: TODO

-- 
Package (more) AWS tools for Ubuntu
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-awstools

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-cloud-images] Ubuntu Cloud Images Roundtable

2012-05-15 Thread Ben Howard
Blueprint changed by Ben Howard:

Work items set to:
Work items:
[utlemming] Build Rescue EBS Snapshots: TODO
[utlemming] Disable 5 second boot time out on images: TODO
[utlemming] Work with IS to show only the latest images on 
cloud.ubuntu.com/ami: TODO
[utlemming] Add links to cloud-images.ubuntu.com: TODO
[utlemming] Create full disk images for Lucid: TODO

-- 
Ubuntu Cloud Images Roundtable
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-cloud-images

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-push-to-the-clouds] Push to the Clouds

2012-05-15 Thread Ben Howard
Blueprint changed by Ben Howard:

Work items set to:
Work items:
[utlemming] Create public glance servers: TODO
[utlemming] Process improvements to publish glance IDs on 
cloud-images.ubuntu.com: TODO

-- 
Push to the Clouds
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-push-to-the-clouds

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 994752] Re: lxc-start-ephemeral's use of dhcp lease table is fragile

2012-05-15 Thread Serge Hallyn
Thanks, the patch looks good.  A new package was pushed to precise-
proposed today, so it should sit for 6 days.  I'll test this one over
the next few days and upload it soon.

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to lxc in Ubuntu.
https://bugs.launchpad.net/bugs/994752

Title:
  lxc-start-ephemeral's use of dhcp lease table is fragile

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/994752/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 994752] Re: lxc-start-ephemeral's use of dhcp lease table is fragile

2012-05-15 Thread Serge Hallyn
Sorry - I forgot this affects quantal as well (though lxc-attach may
arrive in tie for that).  I'll push to there by tomorrow (assuming no
testing hiccoughs).  Thanks again.

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to lxc in Ubuntu.
https://bugs.launchpad.net/bugs/994752

Title:
  lxc-start-ephemeral's use of dhcp lease table is fragile

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/994752/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999969] [NEW] PHP5 doesn't send errors or warnings to fastcgi clients

2012-05-15 Thread Morgan Jones
Public bug reported:

Upstream: https://bugs.php.net/bug.php?id=61045

I've not been able to receive any warning or error output from PHP5.
Apparently, this is a known (and patched) bug with PHP5. Could you take
a look at this? Thanks!

Description:Ubuntu 12.04 LTS
Release:12.04

** Affects: php
 Importance: Unknown
 Status: Unknown

** Affects: php5 (Ubuntu)
 Importance: Undecided
 Status: Confirmed

** Description changed:

  Upstream: https://bugs.php.net/bug.php?id=61045
  
  I've not been able to receive any warning or error output from PHP5.
  Apparently, this is a known (and patched) bug with PHP5. Could you take
  a look at this? Thanks!
+ 
+ Description:  Ubuntu 12.04 LTS
+ Release:  12.04

** Bug watch added: bugs.php.net/ #61045
   http://bugs.php.net/bug.php?id=61045

** Also affects: php via
   http://bugs.php.net/bug.php?id=61045
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to php5 in Ubuntu.
https://bugs.launchpad.net/bugs/69

Title:
  PHP5 doesn't send errors or warnings to fastcgi clients

To manage notifications about this bug go to:
https://bugs.launchpad.net/php/+bug/69/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999969] Re: PHP5 doesn't send errors or warnings to fastcgi clients

2012-05-15 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: php5 (Ubuntu)
   Status: New = Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to php5 in Ubuntu.
https://bugs.launchpad.net/bugs/69

Title:
  PHP5 doesn't send errors or warnings to fastcgi clients

To manage notifications about this bug go to:
https://bugs.launchpad.net/php/+bug/69/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Blueprint servercloud-q-awstools] Package (more) AWS tools for Ubuntu

2012-05-15 Thread Scott Moser
Blueprint changed by Scott Moser:

Work items changed:
  Work items:
  [jbrowne] Package ELB: TODO
  [jbrowne] AWS Import/Export: TODO
  [jbrowne] RDS: TODO
  [jbrowne] Check IAM for latest version: TODO
  [utlemming] Package Autoscaling: TODO
  [utlemming] Package Cloudwatch: TODO
  [utlemming] MIRs for packages: TODO
- [smoser] Re-sync python-boto to 2.3.0 from debian: TODO
- [smoser] Debian packaging: TODO
+ [smoser] Re-sync python-boto to 2.3.0 from debian: DONE
+ [kamal] Debian packaging: TODO
  [kamal] Debian packaging: TODO
  [utlemming] Setup daily build PPA: TODO
  [esh] Promotion of packaging work on Alestic.com: TODO

-- 
Package (more) AWS tools for Ubuntu
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-awstools

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 978999] Re: command injection on the host via the xmlrpc api

2012-05-15 Thread Steve Beattie
I believe upstream attempted to address this in
https://github.com/cobbler/cobbler/commit/6d9167e5da44eca56bdf42b5776097a6779aaadf

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to cobbler in Ubuntu.
https://bugs.launchpad.net/bugs/978999

Title:
  command injection on the host via the xmlrpc api

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cobbler/+bug/978999/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999996] Re: package mcollective 1.2.1+dfsg-2ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

2012-05-15 Thread martin suc
-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to mcollective in Ubuntu.
https://bugs.launchpad.net/bugs/96

Title:
  package mcollective 1.2.1+dfsg-2ubuntu1 failed to install/upgrade:
  subprocess installed post-installation script returned error exit
  status 1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/mcollective/+bug/96/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999996] [NEW] package mcollective 1.2.1+dfsg-2ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

2012-05-15 Thread martin suc
Public bug reported:

just nistallation


lsb_release -rd
Description:Ubuntu 12.04 LTS
Release:12.04


apt-cache policy mcollective
mcollective:
  Installed: 1.2.1+dfsg-2ubuntu1
  Candidate: 1.2.1+dfsg-2ubuntu1
  Version table:
 *** 1.2.1+dfsg-2ubuntu1 0
500 http://archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
100 /var/lib/dpkg/status

expecting properly installation.

happened:

Processing triggers for mcollective ...
postinst called with unknown argument `triggered'
dpkg: error processing mcollective (--unpack):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 mcollective

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: mcollective 1.2.1+dfsg-2ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.38-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Wed May 16 00:40:54 2012
ErrorMessage: subprocess installed post-installation script returned error exit 
status 1
InstallationMedia: Ubuntu 11.04 Natty Narwhal - Release amd64 (20110427.1)
PackageArchitecture: all
SourcePackage: mcollective
Title: package mcollective 1.2.1+dfsg-2ubuntu1 failed to install/upgrade: 
subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to precise on 2011-10-15 (213 days ago)

** Affects: mcollective (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package need-duplicate-check precise

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to mcollective in Ubuntu.
https://bugs.launchpad.net/bugs/96

Title:
  package mcollective 1.2.1+dfsg-2ubuntu1 failed to install/upgrade:
  subprocess installed post-installation script returned error exit
  status 1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/mcollective/+bug/96/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 956421] Re: error in /var/log/syslog: ssh[12586]: segfault at 0 ip 001c60e0 sp bfbf2508 error 4 in libc-2.13.so

2012-05-15 Thread Launchpad Bug Tracker
[Expired for openssh (Ubuntu) because there has been no activity for 60
days.]

** Changed in: openssh (Ubuntu)
   Status: Incomplete = Expired

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to openssh in Ubuntu.
https://bugs.launchpad.net/bugs/956421

Title:
  error in /var/log/syslog: ssh[12586]: segfault at 0 ip 001c60e0 sp
  bfbf2508 error 4 in libc-2.13.so

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/956421/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 950589] Re: unmet dependencies on installing mysql-server-5.1

2012-05-15 Thread Launchpad Bug Tracker
[Expired for mysql-5.1 (Ubuntu) because there has been no activity for
60 days.]

** Changed in: mysql-5.1 (Ubuntu)
   Status: Incomplete = Expired

-- 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to mysql-5.1 in Ubuntu.
https://bugs.launchpad.net/bugs/950589

Title:
  unmet dependencies on installing mysql-server-5.1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/mysql-5.1/+bug/950589/+subscriptions

-- 
Ubuntu-server-bugs mailing list
Ubuntu-server-bugs@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-server-bugs


[Bug 999482] [NEW] package mumble-server-web 1.2.2-1ubuntu1.2 failed to install/upgrade: el subproceso instalado el script post-installation devolvió el código de salida de error 1

2012-05-15 Thread Maximiliano Alameddin
Public bug reported:

No lo se

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: mumble-server-web 1.2.2-1ubuntu1.2
ProcVersionSignature: Ubuntu 2.6.32-41.88-generic 2.6.32.59+drm33.24
Uname: Linux 2.6.32-41-generic i686
NonfreeKernelModules: nvidia wl
Architecture: i386
Date: Tue May 15 02:18:14 2012
ErrorMessage: el subproceso instalado el script post-installation devolvió el 
código de salida de error 1
InstallationMedia: Ubuntu 10.04 LTS Lucid Lynx - Release i386 (20100429)
PackageArchitecture: all
SourcePackage: mumble
Title: package mumble-server-web 1.2.2-1ubuntu1.2 failed to install/upgrade: el 
subproceso instalado el script post-installation devolvió el código de salida 
de error 1

** Affects: ubuntu
 Importance: Undecided
 Status: New


** Tags: apport-package i386 lucid

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/999482

Title:
  package mumble-server-web 1.2.2-1ubuntu1.2 failed to install/upgrade:
  el subproceso instalado el script post-installation devolvió el código
  de salida de error 1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+bug/999482/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 999482] Re: package mumble-server-web 1.2.2-1ubuntu1.2 failed to install/upgrade: el subproceso instalado el script post-installation devolvió el código de salida de error 1

2012-05-15 Thread Maximiliano Alameddin
-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/999482

Title:
  package mumble-server-web 1.2.2-1ubuntu1.2 failed to install/upgrade:
  el subproceso instalado el script post-installation devolvió el código
  de salida de error 1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+bug/999482/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 999481] [NEW] package mumble-server-web 1.2.2-1ubuntu1.2 failed to install/upgrade: el subproceso instalado el script post-installation devolvió el código de salida de error 1

2012-05-15 Thread Maximiliano Alameddin
Public bug reported:

No lo se

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: mumble-server-web 1.2.2-1ubuntu1.2
ProcVersionSignature: Ubuntu 2.6.32-41.88-generic 2.6.32.59+drm33.24
Uname: Linux 2.6.32-41-generic i686
NonfreeKernelModules: nvidia wl
Architecture: i386
Date: Tue May 15 02:18:14 2012
ErrorMessage: el subproceso instalado el script post-installation devolvió el 
código de salida de error 1
InstallationMedia: Ubuntu 10.04 LTS Lucid Lynx - Release i386 (20100429)
PackageArchitecture: all
SourcePackage: mumble
Title: package mumble-server-web 1.2.2-1ubuntu1.2 failed to install/upgrade: el 
subproceso instalado el script post-installation devolvió el código de salida 
de error 1

** Affects: ubuntu
 Importance: Undecided
 Status: New


** Tags: apport-package i386 lucid

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/999481

Title:
  package mumble-server-web 1.2.2-1ubuntu1.2 failed to install/upgrade:
  el subproceso instalado el script post-installation devolvió el código
  de salida de error 1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+bug/999481/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 999481] Re: package mumble-server-web 1.2.2-1ubuntu1.2 failed to install/upgrade: el subproceso instalado el script post-installation devolvió el código de salida de error 1

2012-05-15 Thread Maximiliano Alameddin
-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/999481

Title:
  package mumble-server-web 1.2.2-1ubuntu1.2 failed to install/upgrade:
  el subproceso instalado el script post-installation devolvió el código
  de salida de error 1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+bug/999481/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

  1   2   3   4   5   6   7   8   9   10   >