[Bug 1873272] Re: Error in livepatch is not translated

2020-06-12 Thread Adolfo Jayme
** Changed in: ubuntu-translations
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1873272

Title:
  Error in livepatch is not translated

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-translations/+bug/1873272/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1874698] Re: [OMEN by HP Laptop 15-dh0xxx, Realtek ALC285, Black Mic, Left] Recording problem

2020-06-12 Thread hugh chao
Verified this issue with two combinations 
1. linux-oem-20.04(5.6.0-1011-oem) + alsa-ucm-conf 1.2.2-1ubuntu0.1
2. linux-generic (5.4.0.38.41)(still in proposed channel) + alsa-ucm-conf 
1.2.2-1ubuntu0.1

didn't find any potential regression.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1874698

Title:
  [OMEN by HP Laptop 15-dh0xxx, Realtek ALC285, Black Mic, Left]
  Recording problem

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/1874698/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1874698] Re: [OMEN by HP Laptop 15-dh0xxx, Realtek ALC285, Black Mic, Left] Recording problem

2020-06-12 Thread hugh chao
Verified this issue with two combinations
1. linux-oem-20.04(5.6.0-1011-oem) + alsa-ucm-conf 1.2.2-1ubuntu0.1
2. linux-generic (5.4.0.38.41)(still in proposed channel) + alsa-ucm-conf 
1.2.2-1ubuntu0.1

can actually fix this issue, and I didn't find any regression.

** Tags removed: verification-needed verification-needed-focal
** Tags added: verification-done-focal

** Changed in: oem-priority
   Status: Confirmed => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1874698

Title:
  [OMEN by HP Laptop 15-dh0xxx, Realtek ALC285, Black Mic, Left]
  Recording problem

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/1874698/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1874698] Re: [OMEN by HP Laptop 15-dh0xxx, Realtek ALC285, Black Mic, Left] Recording problem

2020-06-12 Thread hugh chao
@Welly,

please enable proposed channel first [0], then run below command,

# sudo apt install linux-generic alsa-ucm-conf

reboot and give it a try

[0] https://wiki.ubuntu.com/Testing/EnableProposed

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1874698

Title:
  [OMEN by HP Laptop 15-dh0xxx, Realtek ALC285, Black Mic, Left]
  Recording problem

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/1874698/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1882415] Re: artifact in top-right corner

2020-06-12 Thread vasdi
** Attachment added: "settings.txt"
   
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1882415/+attachment/5383419/+files/settings.txt

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1882415

Title:
  artifact in top-right corner

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1882415/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1874698] Re: [OMEN by HP Laptop 15-dh0xxx, Realtek ALC285, Black Mic, Left] Recording problem

2020-06-12 Thread Welly Wu
If I download the alsa-ucm-conf 1.2.2-1 debdiff patch, then how do I
apply it within Pop_OS! 20.04.0 64 bit LTS GNU/Linux and make it work
with a future Linux kernel version? How do I download and install a
newer Linux kernel version on Pop_OS!?

I apologize for becoming more of a nuisance and for my beginner
questions. I would appreciate it if someone takes the time to tell me
what I need to know and to do. Thanks.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1874698

Title:
  [OMEN by HP Laptop 15-dh0xxx, Realtek ALC285, Black Mic, Left]
  Recording problem

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/1874698/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1874698] Re: [OMEN by HP Laptop 15-dh0xxx, Realtek ALC285, Black Mic, Left] Recording problem

2020-06-12 Thread Welly Wu
Hugh Chao:

Please keep us informed with your results. I assume that I am correct to
remove the specific hacks to my alsa-base.conf and default.pa
configuration files while patiently waiting for Linux kernel 5.4.0.38-41
AMD64 and I may need to download and install alsa-ucm-conf 1.2.2-1 as
well? This is a long Ubuntu Launchpad bug report so what exactly is it
supposed to fix? Will my ALC285 sound card and digital microphone just
work after installation of these newer software packages based on you
sharing your results on your HP Omen 15 gaming notebook PC?

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1874698

Title:
  [OMEN by HP Laptop 15-dh0xxx, Realtek ALC285, Black Mic, Left]
  Recording problem

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/1874698/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1874698] Re: [OMEN by HP Laptop 15-dh0xxx, Realtek ALC285, Black Mic, Left] Recording problem

2020-06-12 Thread Welly Wu
Upon closer investigation, Pop Shop is System76's replacement for their
software center and there is an unchecked option to choose to download
and install software packages from Ubuntu-Proposed (Focal Fossa). So, I
expect that I may need to click this button, update Pop Shop and hope
that the newer Linux kernel version will become available as a software
update in the near future, correct?

Back to my question, how do I apply the alsa-ucm-conf 1.2.2-1 debdiff
patch safely and will it work with Ubuntu kernel version 5.4.0.38-41
AMD64 or not?

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1874698

Title:
  [OMEN by HP Laptop 15-dh0xxx, Realtek ALC285, Black Mic, Left]
  Recording problem

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/1874698/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1874646] Comment bridged from LTC Bugzilla

2020-06-12 Thread bugproxy
--- Comment From hegdevas...@in.ibm.com 2020-06-13 00:37 EDT---
(In reply to comment #19)
> Created attachment 143472 [details]
> libvpd-2.2.6-1ubuntu1-focal.diff
>
> default comment

Looks good.

-Vasant

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1874646

Title:
  Update libvpd package to v2.2.7

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-power-systems/+bug/1874646/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1862751] Re: sig=0x806ec/20200609, Hard lockups using microcode releases 20191115 on Intel Whiskey Lake

2020-06-12 Thread You-Sheng Yang
** Summary changed:

- Hard lockups using microcode releases 20191115 on Intel Whiskey Lake
+ sig=0x806ec/20200609, Hard lockups using microcode releases 20191115 on Intel 
Whiskey Lake

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1862751

Title:
  sig=0x806ec/20200609, Hard lockups using microcode releases 20191115
  on Intel Whiskey Lake

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/1862751/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1829620] Re: i7-8565U, sig=0x806eb/20190514, intel-microcode on ASUS makes kernel stuck during loading initramfs on bionic-updates, bionic-security

2020-06-12 Thread You-Sheng Yang
** Summary changed:

- intel-microcode on ASUS makes kernel stuck during loading initramfs on 
bionic-updates, bionic-security
+ i7-8565U, sig=0x806eb/20190514, intel-microcode on ASUS makes kernel stuck 
during loading initramfs on bionic-updates, bionic-security

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1829620

Title:
  i7-8565U, sig=0x806eb/20190514, intel-microcode on ASUS makes kernel
  stuck during loading initramfs on bionic-updates, bionic-security

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/intel-microcode/+bug/1829620/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1834487] Re: Frequent crash at startup after upgrading intel-microcode package

2020-06-12 Thread You-Sheng Yang
Please try latest intel-microcode version *20200609* and attach
microcode info `dmesg |grep microcode` and `lscpu`.

** Changed in: intel-microcode (Ubuntu)
   Status: New => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1834487

Title:
  Frequent crash at startup after upgrading intel-microcode package

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/intel-microcode/+bug/1834487/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883235] Re: freez when using

2020-06-12 Thread Ubuntu Foundations Team Bug Bot
The attachment "System hang" seems to be a patch.  If it isn't, please
remove the "patch" flag from the attachment, remove the "patch" tag, and
if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by
~brian-murray, for any issues please contact him.]

** Tags added: patch

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883235

Title:
  freez when using

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1883235/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1870637] Re: Nvidia+modeset: Can't set 4K@60Hz: HDMI max TMDS frequency 300000KHz

2020-06-12 Thread Launchpad Bug Tracker
[Expired for xorg-server (Ubuntu) because there has been no activity for
60 days.]

** Changed in: xorg-server (Ubuntu)
   Status: Incomplete => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1870637

Title:
  Nvidia+modeset: Can't set 4K@60Hz: HDMI max TMDS frequency 30KHz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-435/+bug/1870637/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883002] Re: Dell Latitude 7300, i7-8665U, sig=0x806ec/20200609: hangs on Whiskey Lake

2020-06-12 Thread You-Sheng Yang
** Summary changed:

- intel-ucode 20200609: hangs on Whiskey Lake
+ Dell Latitude 7300, i7-8665U, sig=0x806ec/20200609: hangs on Whiskey Lake

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883002

Title:
  Dell Latitude 7300, i7-8665U, sig=0x806ec/20200609: hangs on Whiskey
  Lake

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/intel-microcode/+bug/1883002/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883065] Re: Dell Latitude/Precision, sig=0x806ec/20090609: Linux hangs without plugged in power cable

2020-06-12 Thread You-Sheng Yang
** Summary changed:

- Dell Latitude/Precision: Linux hangs without plugged in power cable
+ Dell Latitude/Precision, sig=0x806ec/20090609: Linux hangs without plugged in 
power cable

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883065

Title:
  Dell Latitude/Precision, sig=0x806ec/20090609: Linux hangs without
  plugged in power cable

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/intel-microcode/+bug/1883065/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1870637] Re: Nvidia+modeset: Can't set 4K@60Hz: HDMI max TMDS frequency 300000KHz

2020-06-12 Thread Launchpad Bug Tracker
[Expired for nvidia-graphics-drivers-440 (Ubuntu) because there has been
no activity for 60 days.]

** Changed in: nvidia-graphics-drivers-440 (Ubuntu)
   Status: Incomplete => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1870637

Title:
  Nvidia+modeset: Can't set 4K@60Hz: HDMI max TMDS frequency 30KHz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-435/+bug/1870637/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883336] Re: Dell Precision 7730, sig=0x906ea/20200609, System hangs when resuming from S3 if in battery mode

2020-06-12 Thread You-Sheng Yang
** Summary changed:

- Dell Precision 7730 System hangs when resuming from S3 if in battery mode
+ Dell Precision 7730, sig=0x906ea/20200609, System hangs when resuming from S3 
if in battery mode

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883336

Title:
  Dell Precision 7730, sig=0x906ea/20200609, System hangs when resuming
  from S3 if in battery mode

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/intel-microcode/+bug/1883336/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1870637] Re: Nvidia+modeset: Can't set 4K@60Hz: HDMI max TMDS frequency 300000KHz

2020-06-12 Thread Launchpad Bug Tracker
[Expired for nvidia-graphics-drivers-435 (Ubuntu) because there has been
no activity for 60 days.]

** Changed in: nvidia-graphics-drivers-435 (Ubuntu)
   Status: Incomplete => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1870637

Title:
  Nvidia+modeset: Can't set 4K@60Hz: HDMI max TMDS frequency 30KHz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-435/+bug/1870637/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1880663] Re: Dell Latitude 7300, sig=0x806eb/20200609, sometimes stuck at purple screen after grub and fails to boot up

2020-06-12 Thread You-Sheng Yang
** Summary changed:

- Dell Latitude 7300 ( cpu id 0x806eb) sometimes stuck at purple screen after 
grub and fails to boot up
+ Dell Latitude 7300, sig=0x806eb/20200609, sometimes stuck at purple screen 
after grub and fails to boot up

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1880663

Title:
  Dell Latitude 7300, sig=0x806eb/20200609, sometimes stuck at purple
  screen after grub and fails to boot up

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1880663/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1872477] Re: installation fail

2020-06-12 Thread Launchpad Bug Tracker
[Expired for ubiquity (Ubuntu) because there has been no activity for 60
days.]

** Changed in: ubiquity (Ubuntu)
   Status: Incomplete => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1872477

Title:
  installation fail

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1872477/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1872110] Re: [Samsung 100NZA] No sound

2020-06-12 Thread Launchpad Bug Tracker
[Expired for pulseaudio (Ubuntu) because there has been no activity for
60 days.]

** Changed in: pulseaudio (Ubuntu)
   Status: Incomplete => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1872110

Title:
  [Samsung 100NZA] No sound

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1872110/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1882943] Re: Dell Latitude 5591, i7-8850H, sig=0x906ea/20200609, Boot freezes silently after 'intel-microcode' upgrade

2020-06-12 Thread You-Sheng Yang
** Summary changed:

- Boot freezes silently after 'intel-microcode' upgrade
+ Dell Latitude 5591, i7-8850H, sig=0x906ea/20200609, Boot freezes silently 
after 'intel-microcode' upgrade

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1882943

Title:
  Dell Latitude 5591, i7-8850H, sig=0x906ea/20200609, Boot freezes
  silently after 'intel-microcode' upgrade

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/intel-microcode/+bug/1882943/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883343] [NEW] systemtap fails to build C due to __NR_compat_clock_getres define errors

2020-06-12 Thread nyanpasu64
Public bug reported:

I'm using a Raspberry Pi 3B running Ubuntu Server 20.04 arm64. If I try
to compile a systemtap file which probes "signal.send", I get multiple
definition warnings, and compilation fails because stap passes -Werror
to the compiler.


ubuntu@pi-ubuntu:~/bin$ cat empty.stap
probe signal.send {
  printf("signalled\n");
}

probe begin {
  printf("hi\n");
}


ubuntu@pi-ubuntu:~/bin$ sudo stap empty.stap
In file included from 
/tmp/stap8WrZMD/stap_57b83f2353a7c1704daf8d11fb82f111_59444_src.c:36:
/usr/share/systemtap/runtime/linux/compat_unistd.h:1876: error: 
"__NR_compat_clock_getres" redefined [-Werror]
 1876 | #define __NR_compat_clock_getres __NR_clock_getres
  |
In file included from 
/tmp/stap8WrZMD/stap_57b83f2353a7c1704daf8d11fb82f111_59444_src.c:35:
./arch/arm64/include/asm/unistd.h:29: note: this is the location of the 
previous definition
   29 | #define __NR_compat_clock_getres 264
  |
In file included from 
/tmp/stap8WrZMD/stap_57b83f2353a7c1704daf8d11fb82f111_59444_src.c:36:
/usr/share/systemtap/runtime/linux/compat_unistd.h:1877: error: 
"__NR_compat_clock_gettime" redefined [-Werror]
 1877 | #define __NR_compat_clock_gettime __NR_clock_gettime
  |
In file included from 
/tmp/stap8WrZMD/stap_57b83f2353a7c1704daf8d11fb82f111_59444_src.c:35:
./arch/arm64/include/asm/unistd.h:28: note: this is the location of the 
previous definition
   28 | #define __NR_compat_clock_gettime 263
  |
In file included from 
/tmp/stap8WrZMD/stap_57b83f2353a7c1704daf8d11fb82f111_59444_src.c:36:
/usr/share/systemtap/runtime/linux/compat_unistd.h:1958: error: 
"__NR_compat_gettimeofday" redefined [-Werror]
 1958 | #define __NR_compat_gettimeofday __NR_gettimeofday
  |
In file included from 
/tmp/stap8WrZMD/stap_57b83f2353a7c1704daf8d11fb82f111_59444_src.c:35:
./arch/arm64/include/asm/unistd.h:25: note: this is the location of the 
previous definition
   25 | #define __NR_compat_gettimeofday 78
  |
cc1: all warnings being treated as errors
make[1]: *** [scripts/Makefile.build:273: 
/tmp/stap8WrZMD/stap_57b83f2353a7c1704daf8d11fb82f111_59444_src.o] Error 1
make: *** [Makefile:1722: /tmp/stap8WrZMD] Error 2
WARNING: kbuild exited with status: 2
Pass 4: compilation failed.  [man error::pass4]
Tip: /usr/share/doc/systemtap/README.Debian should help you get started.


ubuntu@pi-ubuntu:~/bin$ lsb_release -rd
Description:Ubuntu 20.04 LTS
Release:20.04


ubuntu@pi-ubuntu:~/bin$ apt-cache policy systemtap
systemtap:
  Installed: 4.2-3
  Candidate: 4.2-3
  Version table:
 *** 4.2-3 500
500 http://ports.ubuntu.com/ubuntu-ports focal/universe arm64 Packages
100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: systemtap 4.2-3
ProcVersionSignature: User Name 5.4.0-1012.12-raspi 5.4.41
Uname: Linux 5.4.0-1012-raspi aarch64
ApportVersion: 2.20.11-0ubuntu27.2
Architecture: arm64
CasperMD5CheckResult: skip
Date: Sat Jun 13 03:41:44 2020
ImageMediaBuild: 20200423.1
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=
 LANG=C.UTF-8
 SHELL=/bin/bash
SourcePackage: systemtap
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: systemtap (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: apport-bug arm64 focal uec-images

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883343

Title:
  systemtap fails to build C due to __NR_compat_clock_getres define
  errors

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemtap/+bug/1883343/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883342] [NEW] when loading a jpeg picture

2020-06-12 Thread John Joseph
Public bug reported:

```
GNU Image Manipulation Program version 2.10.14
git-describe: GIMP_2_10_12-511-ga4f55d6c7e
C compiler:
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/7/lto-wrapper
OFFLOAD_TARGET_NAMES=nvptx-none
OFFLOAD_TARGET_DEFAULT=1
Target: x86_64-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu 
7.4.0-1ubuntu1~18.04.1' --with-bugurl=file:///usr/share/doc/gcc-7/README.Bugs 
--enable-languages=c,ada,c++,go,brig,d,fortran,objc,obj-c++ --prefix=/usr 
--with-gcc-major-version-only --program-suffix=-7 
--program-prefix=x86_64-linux-gnu- --enable-shared --enable-linker-build-id 
--libexecdir=/usr/lib --without-included-gettext --enable-threads=posix 
--libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu 
--enable-libstdcxx-debug --enable-libstdcxx-time=yes 
--with-default-libstdcxx-abi=new --enable-gnu-unique-object 
--disable-vtable-verify --enable-libmpx --enable-plugin --enable-default-pie 
--with-system-zlib --with-target-system-zlib --enable-objc-gc=auto 
--enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 
--with-multilib-list=m32,m64,mx32 --enable-multilib --with-tune=generic 
--enable-offload-targets=nvptx-none --without-cuda-driver 
--enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu 
--target=x86_64-linux-gnu
Thread model: posix
gcc version 7.4.0 (Ubuntu 7.4.0-1ubuntu1~18.04.1) 

using babl version 0.1.72 (compiled against version 0.1.72)
using GEGL version 0.4.18 (compiled against version 0.4.18)
using GLib version 2.56.4 (compiled against version 2.56.4)
using GdkPixbuf version 2.36.11 (compiled against version 2.36.11)
using GTK+ version 2.24.32 (compiled against version 2.24.32)
using Pango version 1.40.14 (compiled against version 1.40.14)
using Fontconfig version 2.12.6 (compiled against version 2.12.6)
using Cairo version 1.15.10 (compiled against version 1.15.10)

```
> fatal error: Segmentation fault

Stack trace:
```

# Stack traces obtained from PID 10525 - Thread 10525 #

[New LWP 10528]
[New LWP 10529]
[New LWP 10530]
[New LWP 10531]
[New LWP 10532]
[New LWP 10534]
[New LWP 10535]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
0x7fad40eef384 in __libc_read (fd=20, buf=0x7ffe00a84a90, nbytes=256) at 
../sysdeps/unix/sysv/linux/read.c:27
  Id   Target Id Frame 
* 1Thread 0x7fad45d24e00 (LWP 10525) "gimp-2.10" 0x7fad40eef384 in 
__libc_read (fd=20, buf=0x7ffe00a84a90, nbytes=256) at 
../sysdeps/unix/sysv/linux/read.c:27
  2Thread 0x7fad37a9a700 (LWP 10528) "worker" syscall () at 
../sysdeps/unix/sysv/linux/x86_64/syscall.S:38
  3Thread 0x7fad37299700 (LWP 10529) "worker" syscall () at 
../sysdeps/unix/sysv/linux/x86_64/syscall.S:38
  4Thread 0x7fad36a98700 (LWP 10530) "worker" syscall () at 
../sysdeps/unix/sysv/linux/x86_64/syscall.S:38
  5Thread 0x7fad2fdc3700 (LWP 10531) "gmain" 0x7fad40c01bf9 in 
__GI___poll (fds=0x55de9afa4270, nfds=2, timeout=3419) at 
../sysdeps/unix/sysv/linux/poll.c:29
  6Thread 0x7fad2f5c2700 (LWP 10532) "gdbus" 0x7fad40c01bf9 in 
__GI___poll (fds=0x55de9afb5f30, nfds=2, timeout=-1) at 
../sysdeps/unix/sysv/linux/poll.c:29
  7Thread 0x7fad10884700 (LWP 10534) "async" syscall () at 
../sysdeps/unix/sysv/linux/x86_64/syscall.S:38
  8Thread 0x7fad0bfff700 (LWP 10535) "pool" syscall () at 
../sysdeps/unix/sysv/linux/x86_64/syscall.S:38

Thread 8 (Thread 0x7fad0bfff700 (LWP 10535)):
#0  0x7fad40c08839 in syscall () at 
../sysdeps/unix/sysv/linux/x86_64/syscall.S:38
#1  0x7fad4173187a in g_cond_wait_until () at 
/usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x7fad416be571 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x7fad41713b14 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x7fad41713175 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x7fad40ee56db in start_thread (arg=0x7fad0bfff700) at 
pthread_create.c:463
pd = 0x7fad0bfff700
now = 
unwind_buf = {cancel_jmp_buf = {{jmp_buf = {140381207394048, 
-3381108156579861678, 140381207390464, 0, 94414572628128, 140728909451504, 
3335465230277913426, 3335308973382675282}, mask_was_saved = 0}}, priv = {pad = 
{0x0, 0x0, 0x0, 0x0}, data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
not_first_call = 
#6  0x7fad40c0e88f in clone () at 
../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 7 (Thread 0x7fad10884700 (LWP 10534)):
#0  0x7fad40c08839 in syscall () at 
../sysdeps/unix/sysv/linux/x86_64/syscall.S:38
#1  0x7fad4173175f in g_cond_wait () at 
/usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x55de98e0136c in  ()
#3  0x7fad41713175 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x7fad40ee56db in start_thread (arg=0x7fad10884700) at 
pthread_create.c:463
pd = 

[Bug 1883341] [NEW] package linux-image-4.15.0-55-generic 4.15.0-55.60~16.04.2 failed to install/upgrade: run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1

2020-06-12 Thread Modasir
Public bug reported:

Can't repair the broken linux kernel

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: linux-image-4.15.0-55-generic 4.15.0-55.60~16.04.2
ProcVersionSignature: Ubuntu 4.15.0-38.41~16.04.1-generic 4.15.18
Uname: Linux 4.15.0-38-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.19
Architecture: amd64
Date: Sat Jun 13 11:25:15 2020
DpkgHistoryLog:
 Start-Date: 2020-06-13  11:24:05
 Commandline: /usr/sbin/synaptic
 Requested-By: fjh (1000)
 Remove: linux-modules-extra-4.15.0-106-generic:amd64 (4.15.0-106.107~16.04.1)
ErrorMessage: run-parts: /etc/kernel/postinst.d/initramfs-tools exited with 
return code 1
InstallationDate: Installed on 2018-11-20 (570 days ago)
InstallationMedia: Ubuntu 16.04.5 LTS "Xenial Xerus" - Release amd64 (20180731)
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.4
 apt  1.2.29ubuntu0.1
SourcePackage: initramfs-tools
Title: package linux-image-4.15.0-55-generic 4.15.0-55.60~16.04.2 failed to 
install/upgrade: run-parts: /etc/kernel/postinst.d/initramfs-tools exited with 
return code 1
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: initramfs-tools (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package xenial

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883341

Title:
  package linux-image-4.15.0-55-generic 4.15.0-55.60~16.04.2 failed to
  install/upgrade: run-parts: /etc/kernel/postinst.d/initramfs-tools
  exited with return code 1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1883341/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1872108] Re: Bass not on working Lenovo ThinkPad X1 Carbon 7th gen running focal

2020-06-12 Thread Alejandro Miranda
thnak you ash, I switched to fedora 32 and no problem, I will wait until
Ubuntu resolve the problem

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1872108

Title:
  Bass not on working Lenovo ThinkPad X1 Carbon 7th gen running focal

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-ucm-conf/+bug/1872108/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1882991] Re: Kernel 5.4.0-37-generic leads to black screen after grub, 5.4.0-26-generic works normally

2020-06-12 Thread Derek
I can boot fine to either kernel (5.4.0.33 or .37) if nvidia driver is
not installed, using nouveau. But no matter what Nvidia driver I use (or
install method) I cannot get the NVidia driver reinstalled properly.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1882991

Title:
  Kernel 5.4.0-37-generic leads to black screen after grub,
  5.4.0-26-generic works normally

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1882991/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1877590] Autopkgtest regression report (gtk+3.0/3.24.20-0ubuntu1)

2020-06-12 Thread Ubuntu SRU Bot
All autopkgtests for the newly accepted gtk+3.0 (3.24.20-0ubuntu1) for focal 
have finished running.
The following regressions have been reported in tests triggered by the package:

ubiquity/unknown (armhf)


Please visit the excuses page listed below and investigate the failures, 
proceeding afterwards as per the StableReleaseUpdates policy regarding 
autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-
migration/focal/update_excuses.html#gtk+3.0

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1877590

Title:
  SRU the current 3.24.20 stable update

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1877590/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883235] Re: freez when using

2020-06-12 Thread Abir
System hang many times.

** Attachment added: "System hang"
   
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1883235/+attachment/5383410/+files/VID-20200613-WA.mp4

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883235

Title:
  freez when using

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1883235/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883338] [NEW] unattended-upgrades blocks apt

2020-06-12 Thread ssducf
Public bug reported:

Version: Ubuntu 18.04 and all prior versions that include unattended-
upgrades

Buggy behavior:

I boot a laptop that has been off for a while with the intent to install linux 
updates.
I type apt-get update; apt full-upgrade  and it fails, finding that unattended 
upgrades is running in the background for an extended period of time, but not 
actually running dpkg at all, just holding the lock, preventing me from running 
updates.


Expected behavior:

apt full-upgrade, the graphical update manager, and related commands
should either

1) Immediately (and silently?) abort whatever unattended-upgrades is
doing and proceed with running updates in the foreground

2) Display progress of updates currently running in the background,
waiting for them to finish, and then proceed with running additional
updates in the foreground

Note that it may be necessary to implement both behaviors, depending if
unattended-upgrades is just spinning or if it has actually started
running upgrades.

** Affects: unattended-upgrades (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883338

Title:
  unattended-upgrades blocks apt

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/unattended-upgrades/+bug/1883338/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1732807] Re: Ubuntu17.10/version:3.0.0-beta1: converting Flac to MP3: all tags are gone

2020-06-12 Thread Bill Crocker
Thank you for this advice. I may have done this wrong - see attached
file - but added 'rating', and 'grouping', to append_tag list and
neither Rating nor Grouping have a tag value in the converted mp3 files
in my testing.

I've noticed that the tag 'year' was already included in the source your
link points to, but this is one of the 3 tags missed in flac => mp3
conversions that are in the Mp3 examples I sent with my first inquiry
above.

Is it possible to follow how the flac => ogg conversions are correctly
converting all tags?

** Attachment added: "gstreamer chg  2020-06-13 14-18-24.png"
   
https://bugs.launchpad.net/soundconverter/+bug/1732807/+attachment/5383409/+files/gstreamer%20chg%20%202020-06-13%2014-18-24.png

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1732807

Title:
  Ubuntu17.10/version:3.0.0-beta1: converting Flac to MP3: all tags are
  gone

To manage notifications about this bug go to:
https://bugs.launchpad.net/soundconverter/+bug/1732807/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1783906] Re: Linux 4.15 and onwards fails to initialize some hard drives

2020-06-12 Thread Kristijan Žic 
I experience this issue on Ubuntu 20.04

$neofetch
OS: Ubuntu 20.04 LTS x86_64 
Kernel: 5.4.0-37-generic 
Uptime: 2 mins 
Packages: 2210 (dpkg), 36 (flatpak), 32 (snap) 
Shell: bash 5.0.16 
Resolution: 1920x1200, 1680x1050 
DE: GNOME 
WM: Mutter 
WM Theme: Adwaita 
Theme: Adwaita-dark [GTK2/3] 
Icons: Yaru [GTK2/3] 
Terminal: gnome-terminal 
CPU: AMD Ryzen Threadripper 1900X (16) @ 3.800GHz 
GPU: AMD ATI Radeon RX Vega 56/64 
Memory: 2642MiB / 15930MiB 


I have 2 Samsung NVME SSD-s
1 ssd is Ubuntu 20.04, 2 is Windows 10
Ubuntu 20.04 is on EXT4 (just to clarify that I didn't use ZFS on this machine)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1783906

Title:
  Linux 4.15 and onwards fails to initialize some hard drives

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1783906/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1850876] Re: CONFIG_DRM_V3D is disabled for linux-raspi2 of eoan

2020-06-12 Thread Hui Wang
5.4.0-1012.12 kernel set the CONFIG_DRM_V3D=m, so is the v3d.ko loaded
into the kernel? Our ubuntu image for raspi is

and please track this issue in this bug as well (the 5.4.0 kernel uses 
#1876862):
https://bugs.launchpad.net/ubuntu/+source/linux-raspi/+bug/1876862

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1850876

Title:
  CONFIG_DRM_V3D is disabled for linux-raspi2 of eoan

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux-raspi2/+bug/1850876/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1850876] Re: CONFIG_DRM_V3D is disabled for linux-raspi2 of eoan

2020-06-12 Thread Hui Wang
5.4.0-1012.12 kernel set the CONFIG_DRM_V3D=m, so is the v3d.ko loaded
into the kernel? Our ubuntu image of raspi is for server, there is no
desktop in the image, so if you don't manually install the desktop, I
guess the v3d will not be used.

and please track this issue in this bug as well (the 5.4.0 kernel uses 
#1876862):
https://bugs.launchpad.net/ubuntu/+source/linux-raspi/+bug/1876862

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1850876

Title:
  CONFIG_DRM_V3D is disabled for linux-raspi2 of eoan

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux-raspi2/+bug/1850876/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1881996] Re: Enable e1000e S0ix on Tiger Lake

2020-06-12 Thread Hsuan-Yu Lin
Discussion minutes from IRC #hwe (2020/06/12):
 
 15:37:35  khfeng: so, should the e1000e commits be rejected, 
according to your comment on the bug?
 15:39:18  tjaalton, depends on kentlin_office. If we care about the 
power consumption under s0ix, then probably should reject it
 15:40:02  ok, I'll drop it from the list for now
 15:40:27  tjaalton, khfeng, what commit
 15:41:05  kentlin_office, the one the prevents vPro systems from 
entering s0ix
 15:42:10  khfeng, oh.. we care about S0ix...
 15:42:43  khfeng, the patch is submitted by whom?
 15:44:52  kentlin_office, dunno
 15:45:02 <-- chih (c...@1-34-63-143.hinet-ip.hinet.net) has quit (Ping 
timeout: 121 seconds)
 15:45:29  khfeng, from upstream?
 15:45:31 --> chih (c...@61-220-137-34.hinet-ip.hinet.net) has joined #hwe
 15:45:55  kentlin_office, yea
 15:45:59  intel
 15:47:05  tjaalton, in latest Kernel? do you have but or git 
cold share with me? I want to write email to Intel contact why they send such 
commit...
 15:50:38  shane: ^
 15:55:04  kentlin_office: it's in linus's git tree now
 15:55:11  tjaalton: got it, have talked with kentlin_office
 15:55:51  what's the verdict?
 15:56:02  should I drop both
 16:06:53 <-- jeremysu (jerem...@61-220-137-37.hinet-ip.hinet.net) has quit 
(Ping timeout: 121 seconds)
 16:07:17 --> jeremysu (jerem...@61-220-137-37.hinet-ip.hinet.net) has joined 
#hwe
 16:08:06  khfeng: I can't find your e1000e commit in the trees where 
it was supposed to be applied already.. do you know what happened?
 16:08:19  not in focal at least
 16:09:28  tjaalton, "e1000e: Disable TSO for buffer overrun 
workaround" this one?
 16:09:34  yes
 16:11:38 --> ethanhsieh_home (et...@1-171-165-81.dynamic-ip.hinet.net) has 
joined #hwe
 16:13:00  perhaps I should ask the ones who applied it
 16:14:39  it's in bionic at least
 16:14:46  but not focal. probably a mistake
 16:14:54  khfeng: so, nevermind :)
 16:15:12  Ok :)
 16:15:30 <-- ethanhsieh_home (et...@1-171-165-81.dynamic-ip.hinet.net) has 
quit (Quit: Leaving)
 16:20:42 <-> alextu is now known as alextu-meeting
 16:25:43  vicamo: so, back to iommu.. I'm not really sure :D
 16:26:12  tjaalton: I saw you're merging "NAK: [PATCH 
0/2][SRU][B/E/F/U/OEM-OSP1-B/OEM-5.6] PCI: Avoid FLR for AMD Matisse/Starship 
HD Audio & USB 3.0"?
 16:26:40 --> hughchao_office (hughc...@1.general.hughchao.uk.vpn) has joined 
#hwe
 16:27:30  vicamo: oh, that was a mistake.. already replied to the 
correct thread
 16:27:54  khfeng: are you interested in that power button issue? are 
holding a conf call
 16:28:04  vicamo, sure
 16:28:06  tjaalton: ok, thanks
 16:28:59 <-- hugh_chao (hughc...@61-220-137-37.hinet-ip.hinet.net) has quit 
(Ping timeout: 121 seconds)
 16:31:39  khfeng: forwarded conf info for you
 16:32:00  shane: so what should I do with those patches?
 16:37:18  vicamo, joined via phonecall?
 16:37:21  tjaalton: sorry, wait a minute
 16:37:39  khfeng: yes
 16:43:40  tjaalton: Do you mean 
https://lists.ubuntu.com/archives/kernel-team/2020-June/110994.html ?
 16:47:15  kentlin_office, vicamo, ... what was that
 16:47:24  kentlin_office, purely wasting time
 16:47:30  shane: yes
 16:50:11  shane: I applied before reading the bug comment
 16:51:14  tjaalton: the commits are from here 
https://bugs.launchpad.net/somerville/+bug/1872029
 16:51:14  Bug #1872029: [Task] e1000e S0ix support for TGL  

 

 16:53:34  I know it's in upstream 5.8 tree
 16:54:11  both of these
 16:54:48  tjaalton: you want them to be cherry picked from master tree?
 16:55:31  AceLan: no, khfeng said the second patch causes issues
 16:58:18  shane: what did you decide after discussing with 
kentlin_office?
 16:59:21  tjaalton: kentlin_office says he will ask AceLan..
 16:59:52 <-- kyleN (knitzs...@c-73-123-35-110.hsd1.ma.comcast.net) has quit 
(Ping timeout: 121 seconds)
 17:01:27  humm
 17:02:00  haha
 17:02:34 --> kyleN (knitzs...@c-73-123-35-110.hsd1.ma.comcast.net) has joined 
#hwe
 17:02:44  and should I just apply that iommu patchset? guess we'll 
find out soon enough it the world blows up..
 17:03:20  khfeng: ^^ # from the e1000e commit description it says 
"Since ME systems do not support SLP_S0 in S0ix state, and S0ix entry and exit 
flows may cause errors on them" do you still think we shouldn't apply this 
commit?
 17:04:11  AceLan, so we need this patch to enter SLP_S0?
 17:04:26  AceLan, depends on if we want the systems reach s0ix
 17:04:30  AceLan, base on what commit say?
 17:04:38  kentlin_office, the patch _prevents_ s0ix
 17:04:55  kentlin_office: 
https://lists.ubuntu.com/archives/kernel-team/2020-June/110805.html
 17:06:54  AceLan, khfeng so only e1000e could not enter s0ix 
with this patch.. is that what it meant or the whole system?
 17:07:45  kentlin_office, ??
 17:08:32  kentlin_office: only the prevent the listed nic i217, i218, 
and i219 from entering s0ix
 17:10:40  kentlin_office, s0ix is an SoC state...
 17:11:11  khfeng: kentlin_office: I think we 

[Bug 1883336] [NEW] Dell Precision 7730 System hangs when resuming from S3 if in battery mode

2020-06-12 Thread AceLan Kao
Public bug reported:

Sku: Dell Precision 7730
BIOS: 1.12.1 (11/11/2019)
Kernel: 4.15.0-1081-oem & mainline 5.7.0

1. Boot up the system(with AC or Bat only)
2. enter S3, unplug AC if plugged, can't wake up the system
3. enter S3, plug AC, the system can be waken up by power button

Can't reproduce this issue with the intel-microcode=3.20180312.0~ubuntu18.04.1 
in bionic repo.
After upgrade this package to intel-microcode=3.20200609.0ubuntu0.18.04.1 or 
the previous version leads to the resume hang issue.

** Affects: intel-microcode (Ubuntu)
 Importance: Undecided
 Status: New

** Attachment added: "kern.log"
   https://bugs.launchpad.net/bugs/1883336/+attachment/5383407/+files/kern.log

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883336

Title:
  Dell Precision 7730 System hangs when resuming from S3 if in battery
  mode

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/intel-microcode/+bug/1883336/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883336] Re: Dell Precision 7730 System hangs when resuming from S3 if in battery mode

2020-06-12 Thread AceLan Kao
** Attachment added: "syslog"
   
https://bugs.launchpad.net/ubuntu/+source/intel-microcode/+bug/1883336/+attachment/5383408/+files/syslog

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883336

Title:
  Dell Precision 7730 System hangs when resuming from S3 if in battery
  mode

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/intel-microcode/+bug/1883336/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883316] Re: after apt upgrade wireguard is unable to build kernel module

2020-06-12 Thread Khodadad
Getting the same error on (Ubuntu 16.04 LTS, Xenial). /var/crash
/wireguard-dkms.0.crash contents below:


```
ProblemType: Package
DKMSBuildLog:
 DKMS make.log for wireguard-1.0.20200611 for kernel 4.4.0-177-generic (x86_64)
 Fri Jun 12 20:09:26 EDT 2020
 make: Entering directory '/usr/src/linux-headers-4.4.0-177-generic'
   LD  /var/lib/dkms/wireguard/1.0.20200611/build/built-in.o
   CC [M]  /var/lib/dkms/wireguard/1.0.20200611/build/main.o
   CC [M]  /var/lib/dkms/wireguard/1.0.20200611/build/noise.o
   CC [M]  /var/lib/dkms/wireguard/1.0.20200611/build/device.o
   CC [M]  /var/lib/dkms/wireguard/1.0.20200611/build/peer.o
   CC [M]  /var/lib/dkms/wireguard/1.0.20200611/build/timers.o
   CC [M]  /var/lib/dkms/wireguard/1.0.20200611/build/queueing.o
   CC [M]  /var/lib/dkms/wireguard/1.0.20200611/build/send.o
   CC [M]  /var/lib/dkms/wireguard/1.0.20200611/build/receive.o
   CC [M]  /var/lib/dkms/wireguard/1.0.20200611/build/socket.o
 /var/lib/dkms/wireguard/1.0.20200611/build/socket.c: In function ‘send6’:
 /var/lib/dkms/wireguard/1.0.20200611/build/socket.c:139:18: error: ‘const 
struct ipv6_stub’ has no member named ‘ipv6_dst_lookup_flow’
dst = ipv6_stub->ipv6_dst_lookup_flow(sock_net(sock), sock, ,
   ^
 scripts/Makefile.build:285: recipe for target 
'/var/lib/dkms/wireguard/1.0.20200611/build/socket.o' failed
 make[1]: *** [/var/lib/dkms/wireguard/1.0.20200611/build/socket.o] Error 1
 Makefile:1457: recipe for target 
'_module_/var/lib/dkms/wireguard/1.0.20200611/build' failed
 make: *** [_module_/var/lib/dkms/wireguard/1.0.20200611/build] Error 2
 make: Leaving directory '/usr/src/linux-headers-4.4.0-177-generic'
DKMSKernelVersion: 4.4.0-177-generic
Date: Fri Jun 12 20:09:36 2020
DuplicateSignature: 
dkms:wireguard-dkms:1.0.20200611-0ppa1~16.04:/var/lib/dkms/wireguard/1.0.20200611/build/socket.c:139:18:
 error: ‘const struct ipv6_stub’ has no member named ‘ipv6_dst_lookup_flow’
Package: wireguard-dkms 1.0.20200611-0ppa1~16.04
PackageVersion: 1.0.20200611-0ppa1~16.04
SourcePackage: wireguard-linux-compat
Title: wireguard-dkms 1.0.20200611-0ppa1~16.04: wireguard kernel module failed 
to build
```

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883316

Title:
  after apt upgrade wireguard is unable to build kernel module

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/wireguard/+bug/1883316/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1882988] Re: HTTP links in apps with dark theme are difficult to read

2020-06-12 Thread Rulon Oboev
** Summary changed:

- Links in Software updater with dark theme are difficult to read
+ HTTP links in apps with dark theme are difficult to read

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1882988

Title:
  HTTP links in apps with dark theme are difficult to read

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/yaru-theme/+bug/1882988/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883334] [NEW] Xorg freezes after Lock (win+L or via Menu>Lock)

2020-06-12 Thread Marcos R. Tosetti
Public bug reported:

This started to happen after installing the last update last week. If I
lock the screen (using either Win+L or opening the menu and clicking
Lock) the screen turns to black and it doesn't come back anymore. I know
the system is still operational since the NumLock button still responds
(turns on and off If I press it) and the HotSpot still works on my
phone, but the screen just doesn't come back from black. This wasn't an
issue before the update, it is very recent. Thank you very much!

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: xorg 1:7.7+19ubuntu14
ProcVersionSignature: Ubuntu 5.4.0-37.41-generic 5.4.41
Uname: Linux 5.4.0-37-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.2
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CasperMD5CheckResult: skip
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Fri Jun 12 22:51:13 2020
DistUpgraded: Fresh install
DistroCodename: focal
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 6.1.6, 5.4.0-33-generic, x86_64: installed
 virtualbox, 6.1.6, 5.4.0-37-generic, x86_64: installed
ExtraDebuggingInterest: Yes, if not too technical
GpuHangFrequency: Several times a day
GpuHangReproducibility: Yes, I can easily reproduce it
GpuHangStarted: Within the last week or two
GraphicsCard:
 Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 
0b) (prog-if 00 [VGA controller])
   Subsystem: Dell Haswell-ULT Integrated Graphics Controller [1028:0640]
   Subsystem: Dell Radeon R7 M260/M265 [1028:0640]
MachineType: Dell Inc. Inspiron 5447
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-37-generic 
root=UUID=45c56570-89cf-4b2d-8f15-ee1ce0d54f68 ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
Title: Xorg freeze
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/12/2014
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A05
dmi.board.name: 0MHP6R
dmi.board.vendor: Dell Inc.
dmi.board.version: A01
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A05
dmi.modalias: 
dmi:bvnDellInc.:bvrA05:bd08/12/2014:svnDellInc.:pnInspiron5447:pvrA05:rvnDellInc.:rn0MHP6R:rvrA01:cvnDellInc.:ct8:cvrA05:
dmi.product.family: 00
dmi.product.name: Inspiron 5447
dmi.product.sku: Inspiron 5447
dmi.product.version: A05
dmi.sys.vendor: Dell Inc.
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.102+git2006051830.5ab603~oibaf~f
version.libgl1-mesa-dri: libgl1-mesa-dri 20.2~git2006110730.27b7b8~oibaf~f
version.libgl1-mesa-glx: libgl1-mesa-glx 20.2~git2006110730.27b7b8~oibaf~f
version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug focal freeze third-party-packages ubuntu

** Description changed:

- This started to happen after I install the last update last week, at
- first it would occur a few times, but now is every time. If I lock the
- screen (using either Win+L or opening the menu e click Lock) the screen
- turns to black and it doesn't come back anymore. I know the system is
- still operational since the NumLock button still responds (turns on and
- off If I press it) and the HotSpot still works on my phone, but the
- screen just doesn't come back from black. This wasn't an issue before
- the update, it is very recent. Thank you very much!
+ This started to happen after installing the last update last week. If I
+ lock the screen (using either Win+L or opening the menu and clicking
+ Lock) the screen turns to black and it doesn't come back anymore. I know
+ the system is still operational since the NumLock button still responds
+ (turns on and off If I press it) and the HotSpot still works on my
+ phone, but the screen just doesn't come back from black. This wasn't an
+ issue before the update, it is very recent. Thank you very much!
  
  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: xorg 1:7.7+19ubuntu14
  ProcVersionSignature: Ubuntu 5.4.0-37.41-generic 5.4.41
  Uname: Linux 5.4.0-37-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.2
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Fri Jun 12 22:51:13 2020
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroVariant: ubuntu
  DkmsStatus:
-  virtualbox, 6.1.6, 5.4.0-33-generic, x86_64: installed
-  virtualbox, 6.1.6, 5.4.0-37-generic, x86_64: installed
+  virtualbox, 6.1.6, 5.4.0-33-generic, x86_64: installed
+  virtualbox, 6.1.6, 5.4.0-37-generic, x86_64: installed
  ExtraDebuggingInterest: Yes, if not too technical
  GpuHangFrequency: 

[Bug 1879485] Re: Automated Install does not set default user data

2020-06-12 Thread Dirk
Unfortunately, I still cannot login after running the installer.

You can replicate what I did with Virtualbox using this script: 
https://gist.github.com/wedi/cba7465ee8280c0e75f94d2ef024a82e
Probably you'll need to switch from Apple's hdiutil to cloud-localds or similar 
to create the seed image.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1879485

Title:
  Automated Install does not set default user data

To manage notifications about this bug go to:
https://bugs.launchpad.net/subiquity/+bug/1879485/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1766935] Re: Indicator Applet: Mouse Scrool Wheel Changes Volume in Wrong Direction

2020-06-12 Thread Christian
*** This bug is a duplicate of bug 1770511 ***
https://bugs.launchpad.net/bugs/1770511

** This bug has been marked a duplicate of bug 1770511
   Mouse wheel behavior in volume control is counterintuitive

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1766935

Title:
  Indicator Applet: Mouse Scrool Wheel Changes Volume in Wrong Direction

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-mate/+bug/1766935/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883317] Re: package ca-certificates 20190110ubuntu1.1 failed to install/upgrade: installed ca-certificates package post-installation script subprocess returned error exit status 128

2020-06-12 Thread Seth Arnold
** Also affects: debconf (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883317

Title:
  package ca-certificates 20190110ubuntu1.1 failed to install/upgrade:
  installed ca-certificates package post-installation script subprocess
  returned error exit status 128

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ca-certificates/+bug/1883317/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883040] Re: groovy daily won't boot anymore on some older BIOS boxes

2020-06-12 Thread Chris Guiver
summary:  no difference with dus `persistent' over dus `live`

I have written my last lubuntu [groovy] daily ISO (comment #11) using
`dus` (mkusb) however where for comment #11 it was written using the 'l'
option for 'live' media.. this time I selected "persistent"

In writing (dus) I selected msdos at the format option, default 50% for
persistent storage and it wrote.

On booting, on selecting either "Start Lubuntu - persistent" or "Start Lubuntu" 
the end result is the same
--
stdin: Not a typewriter
/init: line 49: can't open /dev/sr0: No medium found
/init: line 49: can't open /dev/sr0: No medium found
Unable to find a medium container a live file system
Attempt interactive netboot from a URL?
yes no (default yes): 
--

I booted the 'persistent' thumb-drive on hp 8200 & it booted fine..
(expected result as box isn't impacted by this issue)

I booted the 'persistent' thumb-drive on d755-5 (also impacted) and
other than seeing the `plymouth` lubuntu screen (which I do NOT see on
hp dc7700, but appears in my pasted video link as it was filmed on this
box) it ended with the same "Attempt interactive netboot' issue..

Possibly?? this proves `syslinux` is wrong package? (based on prior
comments)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883040

Title:
  groovy daily won't boot anymore on some older BIOS boxes

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/syslinux/+bug/1883040/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1882098] Re: Packagekit lets user install untrusted local packages in Bionic and Focal

2020-06-12 Thread Seth Arnold
Hello Sami, Esko,

I'm not very familiar with the packagekit or policykit frameworks, so
please forgive me if I'm far off course here with these thoughts:

- Is the [tld.univ.packagekit-deny] rule necessary? I'd hope that this
permission wouldn't be granted to anyone but admins.

- Are there other rules in other files that might have granted this
permission?

- Does it matter if the test users are in no groups? just their own
username-group? adm? sudo?

- Does polkit or packagekit have a way to see which rules allow or deny
any given request?

Thanks

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to the bug report.
https://bugs.launchpad.net/bugs/1882098

Title:
  Packagekit lets user install untrusted local packages in Bionic and
  Focal

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/packagekit/+bug/1882098/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1874272] Re: Stage "searching for obsolete software" takes a very long time (30 minutes)

2020-06-12 Thread Lincoln Phipps
I've got this right now and if I tail the /var/log/dist-upgrade/main.log
I have...

DEBUG package 'foo' produces an unwanted removal 'libomp5-10', skipping
DEBUG 'foo' scheduled for removal but not safe to remove, skipping

Where 'foo' changes and takes solid core 100% 20 seconds cpu to move to
next package. The libomp5-10 stays the same.

Upgrade is 19.10 to 20.04 using do-release-upgrade in a console.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1874272

Title:
  Stage "searching for obsolete software" takes a very long time (30
  minutes)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+bug/1874272/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883151] Re: [SRU] Hydrogen Bugfix - Update to 1.0.0-rc1

2020-06-12 Thread Erich Eickmeyer
Confirmed that, per the test case above, the issues this fixes have been
resolved.

** Tags removed: verification-needed-focal
** Tags added: verification-done verification-done-focal

** Changed in: hydrogen (Ubuntu Focal)
   Status: In Progress => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883151

Title:
  [SRU] Hydrogen Bugfix - Update to 1.0.0-rc1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/hydrogen/+bug/1883151/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1813541] Re: Shim uses wrong TFTP server IP in proxyDHCP mode

2020-06-12 Thread Steve Langasek
The upstream bug is still unresolved, and shim is highly security
sensitive code.  So we need to wait for an agreed upstream fix.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1813541

Title:
  Shim uses wrong TFTP server IP in proxyDHCP mode

To manage notifications about this bug go to:
https://bugs.launchpad.net/shim/+bug/1813541/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1872671] Re: [Focal] Policy files are missing

2020-06-12 Thread Launchpad Bug Tracker
This bug was fixed in the package horizon - 3:18.3.2-0ubuntu2

---
horizon (3:18.3.2-0ubuntu2) groovy; urgency=medium

  * d/p/fix-skipped-config-files.patch: Ensure that config files
are included in the package (LP: #1872671).

 -- Chris MacNaughton   Fri, 12 Jun
2020 11:20:25 +0100

** Changed in: horizon (Ubuntu)
   Status: In Progress => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1872671

Title:
  [Focal] Policy files are missing

To manage notifications about this bug go to:
https://bugs.launchpad.net/cloud-archive/+bug/1872671/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1881632] Re: esm security updates not reported by apt update-notifier

2020-06-12 Thread Launchpad Bug Tracker
This bug was fixed in the package update-notifier - 3.192.32

---
update-notifier (3.192.32) groovy; urgency=medium

  [ Chad Smith ]
  * data/apt_check.py: Update ESM security pockets names (LP: #1881632)
- the UbuntuESM pocket was renamed from -security to
  -infra-security
- new origin UbuntuESMApps, with a corresponding pocket of
  -apps-security

 -- Andreas Hasenack   Fri, 12 Jun 2020 11:21:25
-0300

** Changed in: update-notifier (Ubuntu)
   Status: In Progress => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1881632

Title:
  esm security updates not reported by apt update-notifier

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/update-notifier/+bug/1881632/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1873944] Re: [SRU] Upgrade rapid-photo-downloader to version 0.9.24

2020-06-12 Thread Erich Eickmeyer
** Changed in: rapid-photo-downloader (Ubuntu Groovy)
   Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1873944

Title:
  [SRU] Upgrade rapid-photo-downloader to version 0.9.24

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/rapid-photo-downloader/+bug/1873944/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1882098] Re: Packagekit lets user install untrusted local packages in Bionic and Focal

2020-06-12 Thread Seth Arnold
** Information type changed from Private Security to Public Security

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1882098

Title:
  Packagekit lets user install untrusted local packages in Bionic and
  Focal

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/packagekit/+bug/1882098/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1882098] [NEW] Packagekit lets user install untrusted local packages in Bionic and Focal

2020-06-12 Thread Launchpad Bug Tracker
*** This bug is a security vulnerability ***

You have been subscribed to a public security bug by Seth Arnold (seth-arnold):

We have packagekit configured to allow users to install trusted packages
from preconfigured repositories, but disallowed them to install any
untrusted packages.

The policykit configuration we use is following:

[tld.univ.packagekit]
Identity=unix-group:adm;
Action=org.freedesktop.packagekit.package-install;org.freedesktop.packagekit.package-reinstall;org.freedesktop.packagekit.package-remove;org.freedesktop.packagekit.system-sources-refresh;org.freedesktop.packagekit.system-update;org.freedesktop.packagekit.repair-system;
ResultAny=auth_self
ResultActive=auth_self
ResultInactive=auth_self

[tld.univ.packagekit-deny]
Identity=unix-user:*;
Action=org.freedesktop.packagekit.package-install-untrusted;
ResultAny=no

We would expect this to prevent users from installing local packages
downloaded from random repositories, however this does not seem to be
the case.

pkcon install-local random_package.deb will happily prompt for the user
to authenticate and will install the package, while pkcon --allow-
untrusted install-local random_package.deb will prompt for root
password, which the user does not have.

Our initial toughts was that the issue would be in packagekitd, but
after further investigations it looks like the issue could be in aptcc
backend.

We are more than happy to provide you with further details, but the
above should be enough to reproduce the issue.

** Affects: packagekit (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: bionic focal packagekit
-- 
Packagekit lets user install untrusted local packages in Bionic and Focal
https://bugs.launchpad.net/bugs/1882098
You received this bug notification because you are a member of Ubuntu Bugs, 
which is subscribed to the bug report.

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883090] Re: package apache2 2.4.41-4ubuntu3 failed to install/upgrade: el subproceso instalado paquete apache2 script post-installation devolvió el código de salida de error 1

2020-06-12 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: apache2 (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883090

Title:
  package apache2 2.4.41-4ubuntu3 failed to install/upgrade: el
  subproceso instalado paquete apache2 script post-installation devolvió
  el código de salida de error 1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apache2/+bug/1883090/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1874698] Re: [OMEN by HP Laptop 15-dh0xxx, Realtek ALC285, Black Mic, Left] Recording problem

2020-06-12 Thread hugh chao
GA kernel 5.4.0.38.41 is in proposed channel now, I will verify it with
alsa-ucm-conf 1.2.2-1ubuntu0.1 soon.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1874698

Title:
  [OMEN by HP Laptop 15-dh0xxx, Realtek ALC285, Black Mic, Left]
  Recording problem

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/1874698/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883331] [NEW] DEBIAN_FRONTEND=noninteractive results in failed installation

2020-06-12 Thread Bob Tanner
Public bug reported:

# lsb_release -rd 
Description:Ubuntu Focal Fossa (development branch)
Release:20.04

# apt-cache policy postfix
postfix:
  Installed: 3.4.10-1ubuntu1
  Candidate: 3.4.10-1ubuntu1
  Version table:
 *** 3.4.10-1ubuntu1 500
500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages
100 /var/lib/dpkg/status

# echo $DEBIAN_FRONTEND   
noninteractive

Preparing to unpack .../postfix_3.4.10-1ubuntu1_amd64.deb ...
Unpacking postfix (3.4.10-1ubuntu1) ...
Setting up postfix (3.4.10-1ubuntu1) ...
Adding group `postfix' (GID 109) ...
Done.
Adding system user `postfix' (UID 106) ...
Adding new user `postfix' (UID 106) with group `postfix' ...
Not creating home directory `/var/spool/postfix'.
Creating /etc/postfix/dynamicmaps.cf
Adding group `postdrop' (GID 110) ...
Done.
setting myhostname: ubuntu-20.04
setting alias maps
setting alias database
setting myorigin
setting destinations: $myhostname, ubuntu-20.04, localhost.04, , localhost
setting relayhost: 
setting mynetworks: 127.0.0.0/8 [:::127.0.0.0]/104 [::1]/128
setting mailbox_size_limit: 0
setting recipient_delimiter: +
setting inet_interfaces: all
setting inet_protocols: all
WARNING: /etc/aliases exists, but does not have a root alias.

Postfix (main.cf) is now set up with a default configuration.  If you need to 
make changes, edit /etc/postfix/main.cf (and others) as needed.  To view 
Postfix configuration values, see postconf(1).

After modifying main.cf, be sure to run 'systemctl reload postfix'.

Running newaliases
newaliases: warning: valid_hostname: numeric hostname: 04
newaliases: fatal: file /etc/postfix/main.cf: parameter mydomain: bad parameter 
value: 04
dpkg: error processing package postfix (--configure):
 installed postfix package post-installation script subprocess returned error 
exit status 75
Processing triggers for systemd (244.3-1ubuntu1) ...
Processing triggers for rsyslog (8.2001.0-1ubuntu1) ...
invoke-rc.d: policy-rc.d denied execution of try-restart.
Processing triggers for libc-bin (2.31-0ubuntu6) ...
Errors were encountered while processing:
 postfix
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@ubuntu-20:/# dpkg -l | grep postfix
iF  postfix   3.4.10-1ubuntu1 amd64
High-performance mail transport agent

** Affects: postfix (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883331

Title:
  DEBIAN_FRONTEND=noninteractive results in failed installation

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/postfix/+bug/1883331/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883330] [NEW] package desktop-file-utils 0.24-1ubuntu3 failed to install/upgrade: end of file on stdin at conffile prompt

2020-06-12 Thread James Melvin
Public bug reported:

I have no further details. This report was generated automatically.

ProblemType: Package
DistroRelease: Ubuntu 20.04
Package: desktop-file-utils 0.24-1ubuntu3
ProcVersionSignature: Ubuntu 5.4.0-33.37-generic 5.4.34
Uname: Linux 5.4.0-33-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.2
Architecture: amd64
CasperMD5CheckResult: skip
Date: Thu Jun 11 21:11:15 2020
ErrorMessage: end of file on stdin at conffile prompt
InstallationDate: Installed on 2020-06-07 (5 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
Python3Details: /usr/bin/python3.8, Python 3.8.2, python3-minimal, 
3.8.2-0ubuntu2
PythonDetails: N/A
RelatedPackageVersions:
 dpkg 1.19.7ubuntu3
 apt  2.0.2ubuntu0.1
SourcePackage: desktop-file-utils
Title: package desktop-file-utils 0.24-1ubuntu3 failed to install/upgrade: end 
of file on stdin at conffile prompt
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.gnome.defaults.list: 2020-06-10T07:12:26.122647

** Affects: desktop-file-utils (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package focal

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883330

Title:
  package desktop-file-utils 0.24-1ubuntu3 failed to install/upgrade:
  end of file on stdin at conffile prompt

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/desktop-file-utils/+bug/1883330/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1813541] Re: Shim uses wrong TFTP server IP in proxyDHCP mode

2020-06-12 Thread RouL
Over 1 year and 2 Ubuntu versions later (one of them LTS) and this
problem is still not fixed. Even with googling this took me hours to
figure out today. :/

Please fix this finally.

I'd submit a patch, but I didn't write any C code, since I was around
21. If anything, I'd probably make things worse. :D

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1813541

Title:
  Shim uses wrong TFTP server IP in proxyDHCP mode

To manage notifications about this bug go to:
https://bugs.launchpad.net/shim/+bug/1813541/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1874698] Re: [OMEN by HP Laptop 15-dh0xxx, Realtek ALC285, Black Mic, Left] Recording problem

2020-06-12 Thread Welly Wu
I own a late 2019 Computer Upgrade King Hewlett Packard Omen 15t and I
am running System76's Pop_OS! 20.04.0 64 bit LTS GNU/Linux. Looking at
this bug report, it looks like I am affected. I see that the latest
information is such that a fix was committed, but it has not been
released yet.

Is it possible that a future and updated Linux kernel version will be
released to include the necessary firmware, device drivers and updated
software package versions to fix the Realtek ALC285 sound card and
digital microphones so that they will work normally? Which specific
Linux kernel version and linux-firmware version is going to be needed
for the fix?

System76 chooses to use systemd-boot rather than GRUB2 used by Ubuntu. I
did research and I typed in sudo kernelstub -a
snd_hda_intel.dmic_detect=0 splash to be added to my Linux kernel
version 5.4.0-7634-generic AMD64 and it selected the snd_hd_intel
driver; the sound card is detected and audio is output through the
laptop's stereo speakers, but I realize that I have an Intel 9th
generation Core-i9 9880H mobile CPU which uses the Intel Cannon Lake PCH
cAVS for Audio-1 according to inxi -F results. Based on research, I need
the Sound Open Firmware, topology, updated software package versions for
ALSA and perhaps Pulse Audio and I should be using a newer Linux kernel
version above the current one that I am already using now.

According to my /etc/pulse/default.pa configuration file, I added these two 
lines:
load-module module-alsa-sink device=hw:0,0 channels=2
load-module module-alsa-source device=hw:0,6 channels=2

According to my /etc/modprobe.d/alsa-base.conf configuration file, I added this 
line:
options snd-hda-intel index=0 model=laptop-dmic

People should know that I also have a nVidia Geforce RTX 2080 Max-Q with
8 GB of GDDR6 VRAM mobile GPU on this HP Omen 15t gaming notebook PC.

How do I determine if I have a non-Intel HDMI output out of curiosity?
Can I safely assume that both my MiniDisplay Port 1.4 and HDMI 2.0b are
directed connected to my nVidia mobile GPU? Please let me know if it is
important for me to backup my HDMI.

The big question that I have to ask this community is whether it is
worth the effort and time for me to fix this on my own by downloading
the correct version of the Sound Open Firmware, topology, ALSA-ucm file
and a custom and newer Linux kernel version and learning how to install
it safely using systemd-boot on my own or should I let Canonical, Ltd.
and then System76 provide me with software updates in the future to fix
my sound card and digital microphone on my HP Omen 15t PC? If the latter
route is recommended for safety reasons since it seems obvious that I am
asking questions from the perspective of a new end user, then what
specific software packages and versions should I keep my eyes on via
future software updates to get an early idea that my sound card and
digital microphone will be fixed in the future?

What else do I need to know?

Thank you.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1874698

Title:
  [OMEN by HP Laptop 15-dh0xxx, Realtek ALC285, Black Mic, Left]
  Recording problem

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/1874698/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1713313] Re: Unable to launch pkexec'ed applications on Wayland session

2020-06-12 Thread Erich Eickmeyer
** No longer affects: ubuntustudio-default-settings (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1713313

Title:
  Unable to launch pkexec'ed applications on Wayland session

To manage notifications about this bug go to:
https://bugs.launchpad.net/backintime/+bug/1713313/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1865515] Re: Chainbooting from grub over the network to local shim breaks chain of trust

2020-06-12 Thread Lee Trager
By default an LXD VM boots from the disk first. However you can change
the boot order by adding "boot.priority" to your devices. The device
with the highest number boots first.

LXD devices config for booting off the boot disk.
devices:
  eth0:
name: eth0
nictype: bridged
parent: br0
type: nic
  root:
path: /
pool: default
size: "80"
type: disk

LXD devices config for booting off the network first.
devices:
  eth0:
boot.priority: "1"
name: eth0
nictype: bridged
parent: br0
type: nic
  root:
boot.priority: "0"
path: /
pool: default
size: "80"
type: disk

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1865515

Title:
  Chainbooting from grub over the network to local shim breaks chain of
  trust

To manage notifications about this bug go to:
https://bugs.launchpad.net/maas/+bug/1865515/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1881417] Re: -buildmode=pie not supported on riscv64

2020-06-12 Thread Steve Langasek
Hello Dimitri, or anyone else affected,

Accepted golang-1.14 into focal-proposed. The package will build now and
be available at
https://launchpad.net/ubuntu/+source/golang-1.14/1.14.3-2ubuntu2~20.04.1
in a few hours, and then in the -proposed repository.

Please help us by testing this new package.  See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how
to enable and use -proposed.  Your feedback will aid us getting this
update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested, what testing has been
performed on the package and change the tag from verification-needed-
focal to verification-done-focal. If it does not fix the bug for you,
please add a comment stating that, and change the tag to verification-
failed-focal. In either case, without details of your testing we will
not be able to proceed.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification .  Thank you in
advance for helping!

N.B. The updated package will be released to -updates after the bug(s)
fixed by this package have been verified and the package has been in
-proposed for a minimum of 7 days.

** Changed in: golang-1.14 (Ubuntu Focal)
   Status: New => Fix Committed

** Tags added: verification-needed verification-needed-focal

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1881417

Title:
  -buildmode=pie not supported on riscv64

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/golang-1.14/+bug/1881417/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1880040] Re: missing cgo support on riscv

2020-06-12 Thread Steve Langasek
Hello Michael, or anyone else affected,

Accepted golang-1.14 into focal-proposed. The package will build now and
be available at
https://launchpad.net/ubuntu/+source/golang-1.14/1.14.3-2ubuntu2~20.04.1
in a few hours, and then in the -proposed repository.

Please help us by testing this new package.  See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how
to enable and use -proposed.  Your feedback will aid us getting this
update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested, what testing has been
performed on the package and change the tag from verification-needed-
focal to verification-done-focal. If it does not fix the bug for you,
please add a comment stating that, and change the tag to verification-
failed-focal. In either case, without details of your testing we will
not be able to proceed.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification .  Thank you in
advance for helping!

N.B. The updated package will be released to -updates after the bug(s)
fixed by this package have been verified and the package has been in
-proposed for a minimum of 7 days.

** Changed in: golang-1.14 (Ubuntu Focal)
   Status: New => Fix Committed

** Tags added: verification-needed verification-needed-focal

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1880040

Title:
  missing cgo support on riscv

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/golang-1.14/+bug/1880040/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1878721] Re: memcached looks for SASL configuration at wrong path /etc/sasl2/memcached.conf/memcached.conf (18.04→20.04 regression)

2020-06-12 Thread Steve Langasek
why is this bug marked block-proposed?

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1878721

Title:
  memcached looks for SASL configuration at wrong path
  /etc/sasl2/memcached.conf/memcached.conf (18.04→20.04 regression)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/memcached/+bug/1878721/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1878721] Re: memcached looks for SASL configuration at wrong path /etc/sasl2/memcached.conf/memcached.conf (18.04→20.04 regression)

2020-06-12 Thread Steve Langasek
Hello Anders, or anyone else affected,

Accepted memcached into focal-proposed. The package will build now and
be available at
https://launchpad.net/ubuntu/+source/memcached/1.5.22-2ubuntu0.1 in a
few hours, and then in the -proposed repository.

Please help us by testing this new package.  See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how
to enable and use -proposed.  Your feedback will aid us getting this
update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested, what testing has been
performed on the package and change the tag from verification-needed-
focal to verification-done-focal. If it does not fix the bug for you,
please add a comment stating that, and change the tag to verification-
failed-focal. In either case, without details of your testing we will
not be able to proceed.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification .  Thank you in
advance for helping!

N.B. The updated package will be released to -updates after the bug(s)
fixed by this package have been verified and the package has been in
-proposed for a minimum of 7 days.

** Changed in: memcached (Ubuntu Focal)
   Status: Confirmed => Fix Committed

** Tags added: verification-needed verification-needed-focal

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1878721

Title:
  memcached looks for SASL configuration at wrong path
  /etc/sasl2/memcached.conf/memcached.conf (18.04→20.04 regression)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/memcached/+bug/1878721/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1881588] Re: pre-seeding lxd on Core appliances breaks console-conf user creation

2020-06-12 Thread Dimitri John Ledkov
** Changed in: snapd
   Status: Invalid => New

** Changed in: subiquity
   Status: New => Incomplete

** Changed in: subiquity (Ubuntu)
   Status: New => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1881588

Title:
  pre-seeding lxd on Core appliances breaks console-conf user creation

To manage notifications about this bug go to:
https://bugs.launchpad.net/snapd/+bug/1881588/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Re: [Bug 1877173] Re: Chromium 81.0.4044.122 crashes on remote ssh connection

2020-06-12 Thread mike Bernson
that fixes the --no-sandbox but still needs the
QT_X11_NO_MITSHM=1

also the --no-xshm works now.

This whole bug report shows my big problem with snaps.

In production I have a pin a version of chromium that works so that I can use
webdriver to access a number of site that I need to submit data to.

Once snap become in place I do not see any way to lock/pin a version of 
chromium that
works while the bug get fix.

How can problems like this be dealt with ?


On 6/12/20 10:52 AM, Olivier Tilloy wrote:
> https://bugs.chromium.org/p/chromium/issues/detail?id=1039560#c14
> suggests that this should be fixed in the latest 83 stable update.
>
> Would you mind testing that update from https://launchpad.net
> /~canonical-chromium-builds/+archive/ubuntu/stage and reporting whether
> the issue persists?
>
> I'd recommend disabling that PPA after the test, the updates will
> eventually be available in the Ubuntu archive.
>

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1877173

Title:
  Chromium 81.0.4044.122 crashes on remote ssh connection

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1877173/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1876951] Re: Ubuntu 20.04 - freeze on latest kernel

2020-06-12 Thread thrantir
I tried the latest official 20.04 kernel (5.0.37), freezed after about 5 
minutes. 
@kaihengfeng I downloaded the latest deb as you suggested, I'' try it now

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1876951

Title:
  Ubuntu 20.04 - freeze on latest kernel

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1876951/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1882991] Re: Kernel 5.4.0-37-generic leads to black screen after grub, 5.4.0-26-generic works normally

2020-06-12 Thread Derek
I ran `apport-bug` and copied it off to an SMB share, but am not sure
it's propert etiquette, or wise, to attach publicly.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1882991

Title:
  Kernel 5.4.0-37-generic leads to black screen after grub,
  5.4.0-26-generic works normally

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1882991/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1853277] Re: Lenovo ThinkBook 14-IML Touchpad not showing up in /proc/bus/input/devices

2020-06-12 Thread Khan Sharukh
Hi Guys,
I am constantly reading this forum as this is the only way to fix touchpad in 
Thinkbook 14 IML.


I managed to installed Ubuntu 20.04 on my Thinkbook with only using Keyboard 
but touchpad is not working what so ever.

I have latest BIOS and Kernel as suggested above but it is still not
working 

Guys, looking for a fix really soon.

Should I install old version of BIOS CJCN26WW.
Since couple of people have got luck with it.

But I don't want to mess up with the Laptop.
Please suggest me should I install old version of BIOS CJCN26WW.

Thanks
Khan Sharukh

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1853277

Title:
  Lenovo ThinkBook 14-IML Touchpad not showing up in
  /proc/bus/input/devices

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1853277/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1872108] Re: Bass not on working Lenovo ThinkPad X1 Carbon 7th gen running focal

2020-06-12 Thread Michele
Try this, it helped a lot on my X1 Yoga G4:
first install alsa-tools
# apt install alsa-tools
then run
# sudo hda-verb /dev/snd/hwC0D0 0x17 SET_CONNECT_SEL 1
borrowed from here
https://gist.github.com/hamidzr/dd81e429dc86f4327ded7a2030e7d7d9#gistcomment-3335436

I have absolutely no clue of how this works, and I hope there will be a better 
"official" fix soon, also because it's still just two channels, and volume 
cannot 
really be properly adjusted. However sound went from "crap" to "pretty decent".
Needs to be run after reboot (and probably suspend).

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1872108

Title:
  Bass not on working Lenovo ThinkPad X1 Carbon 7th gen running focal

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-ucm-conf/+bug/1872108/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1882991] Re: Kernel 5.4.0-37-generic leads to black screen after grub, 5.4.0-26-generic works normally

2020-06-12 Thread Derek
Vyron, thanks for the response.

I was able go to TTY2 (CTL-ALT-F2) and get the dpkg log from when I ran
`upgrade -y`; it is attached here. Not sure what else to look at or how
to TS from here.


** Attachment added: "list of upgraded packages with with 5.4.0-37 kernel"
   
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1882991/+attachment/5383379/+files/dpkg-upgraded.log

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1882991

Title:
  Kernel 5.4.0-37-generic leads to black screen after grub,
  5.4.0-26-generic works normally

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1882991/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883235] Re: freez when using

2020-06-12 Thread Seth Arnold
** Information type changed from Private Security to Public

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883235

Title:
  freez when using

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1883235/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1844626] Re: Please remove compiz-plugins-experimental from eoan-proposed

2020-06-12 Thread Brian Murray
** Also affects: compizconfig-python (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1844626

Title:
  Please remove compiz-plugins-experimental from eoan-proposed

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1844626/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1713313] Re: Unable to launch pkexec'ed applications on Wayland session

2020-06-12 Thread Sean Davis
** No longer affects: lightdm-gtk-greeter-settings

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1713313

Title:
  Unable to launch pkexec'ed applications on Wayland session

To manage notifications about this bug go to:
https://bugs.launchpad.net/backintime/+bug/1713313/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1876286] Re: Evolution reports "Error performing TLS handshake: Internal error in memory allocation."

2020-06-12 Thread tamille1
Also for me. It used to work, but now claws-mail is unable to read my
yahoo email. Running Mint 18.3 (Ubuntu Xenial).

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1876286

Title:
  Evolution reports "Error performing TLS handshake: Internal error in
  memory allocation."

To manage notifications about this bug go to:
https://bugs.launchpad.net/gnutls/+bug/1876286/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1882991] Re: Kernel 5.4.0-37-generic leads to black screen after grub, 5.4.0-26-generic works normally

2020-06-12 Thread Derek
** Changed in: linux (Ubuntu)
   Status: Invalid => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1882991

Title:
  Kernel 5.4.0-37-generic leads to black screen after grub,
  5.4.0-26-generic works normally

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1882991/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1881912] Re: SRU 1.64.3 to focal

2020-06-12 Thread Steve Langasek
Hello Marco, or anyone else affected,

Accepted gjs into focal-proposed. The package will build now and be
available at
https://launchpad.net/ubuntu/+source/gjs/1.64.3-1~ubuntu20.04.1 in a few
hours, and then in the -proposed repository.

Please help us by testing this new package.  See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how
to enable and use -proposed.  Your feedback will aid us getting this
update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested, what testing has been
performed on the package and change the tag from verification-needed-
focal to verification-done-focal. If it does not fix the bug for you,
please add a comment stating that, and change the tag to verification-
failed-focal. In either case, without details of your testing we will
not be able to proceed.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification .  Thank you in
advance for helping!

N.B. The updated package will be released to -updates after the bug(s)
fixed by this package have been verified and the package has been in
-proposed for a minimum of 7 days.

** Changed in: gjs (Ubuntu Focal)
   Status: New => Fix Committed

** Tags added: verification-needed verification-needed-focal

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1881912

Title:
  SRU 1.64.3 to focal

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gjs/+bug/1881912/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883151] Re: [SRU] Hydrogen Bugfix - Update to 1.0.0-rc1

2020-06-12 Thread Timo Aaltonen
** Tags added: verification-needed-focal

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883151

Title:
  [SRU] Hydrogen Bugfix - Update to 1.0.0-rc1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/hydrogen/+bug/1883151/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1881923] Re: No icons in file picker

2020-06-12 Thread AllesMeins
Thanks, this has solved it!

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1881923

Title:
  No icons in file picker

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1881923/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1882626] Re: libceres-dev Focal arm64 build failing with failed test

2020-06-12 Thread Kyle Fazzari
Tested using upstream ceres-solver's helloworld.cc example[1].

Unable to test for regressions on arm64 because the package wasn't
available there before -proposed:

$ sudo apt install libceres-dev
Reading package lists... Done
Building dependency tree   
Reading state information... Done
Package libceres-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libceres-dev' has no installation candidate


Alright, testing 1.14.0-4ubuntu1.1 from -proposed:

$ g++ helloworld.cc -lceres -I /usr/include/eigen3 -lglog
ubuntu@arm64-test:~/ceres-solver/examples$ ./a.out 
iter  cost  cost_change  |gradient|   |step|tr_ratio  tr_radius  
ls_iter  iter_time  total_time
   0  4.512500e+010.00e+009.50e+00   0.00e+00   0.00e+00  1.00e+04  
  01.32e-045.72e-04
   1  4.511598e-074.51e+019.50e-04   9.50e+00   1.00e+00  3.00e+04  
  12.02e-049.69e-04
   2  5.012552e-164.51e-073.17e-08   9.50e-04   1.00e+00  9.00e+04  
  15.43e-051.12e-03
Ceres Solver Report: Iterations: 3, Initial cost: 4.512500e+01, Final cost: 
5.012552e-16, Termination: CONVERGENCE
x : 0.5 -> 10


Looks great there. Moving on to regression testing on amd64, with version 
1.14.0-4ubuntu1:

$ g++ helloworld.cc -lceres -I /usr/include/eigen3 -lglog
$ ./a.out 
iter  cost  cost_change  |gradient|   |step|tr_ratio  tr_radius  
ls_iter  iter_time  total_time
   0  4.512500e+010.00e+009.50e+00   0.00e+00   0.00e+00  1.00e+04  
  07.41e-057.69e-04
   1  4.511598e-074.51e+019.50e-04   9.50e+00   1.00e+00  3.00e+04  
  11.34e-041.03e-03
   2  5.012552e-164.51e-073.17e-08   9.50e-04   1.00e+00  9.00e+04  
  19.05e-061.04e-03
Ceres Solver Report: Iterations: 3, Initial cost: 4.512500e+01, Final cost: 
5.012552e-16, Termination: CONVERGENCE
x : 0.5 -> 10


Now amd64, with version 1.14.0-4ubuntu1.1 from -proposed:

$ g++ helloworld.cc -lceres -I /usr/include/eigen3 -lglog
$ ./a.out 
iter  cost  cost_change  |gradient|   |step|tr_ratio  tr_radius  
ls_iter  iter_time  total_time
   0  4.512500e+010.00e+009.50e+00   0.00e+00   0.00e+00  1.00e+04  
  05.90e-054.02e-04
   1  4.511598e-074.51e+019.50e-04   9.50e+00   1.00e+00  3.00e+04  
  11.72e-046.28e-04
   2  5.012552e-164.51e-073.17e-08   9.50e-04   1.00e+00  9.00e+04  
  12.24e-056.74e-04
Ceres Solver Report: Iterations: 3, Initial cost: 4.512500e+01, Final cost: 
5.012552e-16, Termination: CONVERGENCE
x : 0.5 -> 10

Time is of course a smidge different, but results are the same, across
architectures and package versions. This looks good to me, thanks Brian!

[1]: https://github.com/ceres-solver/ceres-
solver/blob/master/examples/helloworld.cc

** Tags removed: verification-needed-focal
** Tags added: verification-done-focal

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1882626

Title:
  libceres-dev Focal arm64 build failing with failed test

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ceres-solver/+bug/1882626/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1881723] Re: Please merge 4.94-1 into groovy

2020-06-12 Thread Bryce Harrington
PPA with the merge:  
https://launchpad.net/~bryce/+archive/ubuntu/exim4-merge-v4o94-2
Uploaded to proposed: https://launchpad.net/ubuntu/+source/exim4/4.94-2ubuntu1

** Changed in: exim4 (Ubuntu)
   Importance: Undecided => High

** Changed in: exim4 (Ubuntu)
   Status: New => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1881723

Title:
  Please merge 4.94-1 into groovy

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/exim4/+bug/1881723/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1880172] Re: Touchpad is not detected on Lenovo IdeaPad 3 14IIL05 Core i3-1005G1 (81WD004MGE)

2020-06-12 Thread Ludovic LEMARINEL
*** This bug is a duplicate of bug 1878279 ***
https://bugs.launchpad.net/bugs/1878279

Last strange thing I've noticed :
in dmesg, I've got an error about irq not handled: 

[9.512884] irq 9: nobody cared (try booting with the "irqpoll" option)
[9.512888] CPU: 1 PID: 0 Comm: swapper/1 Not tainted 5.7.1-050701-generic 
#202006071230
[9.512888] Hardware name: LENOVO 81WD/LNVNB161216, BIOS EMCN14WW 05/11/2020
[9.512889] Call Trace:
[9.512890]  
[9.512895]  dump_stack+0x6d/0x9a
[9.512898]  __report_bad_irq+0x3a/0xaf
[9.512899]  note_interrupt.cold+0xb/0x61
[9.512900]  handle_irq_event_percpu+0x73/0x80
[9.512901]  handle_irq_event+0x3b/0x5a
[9.512902]  handle_fasteoi_irq+0x9c/0x150
[9.512904]  do_IRQ+0x55/0xe0
[9.512905]  common_interrupt+0xf/0xf
[9.512905]  
[9.512908] RIP: 0010:cpuidle_enter_state+0xca/0x3e0
[9.512909] Code: ff e8 da 60 7a ff 80 7d c7 00 74 17 9c 58 0f 1f 44 00 00 
f6 c4 02 0f 85 ea 02 00 00 31 ff e8 dd ed 80 ff fb 66 0f 1f 44 00 00 <45> 85 e4 
0f 88 3f 02 00 00 49 63 d4 4c 8b 7d d0 4c 2b 7d c8 48 8d
[9.512910] RSP: 0018:a936800e3e38 EFLAGS: 0246 ORIG_RAX: 
ffde
[9.512911] RAX: 8f6516c6d2c0 RBX: 8f6516c78a00 RCX: 001f
[9.512911] RDX:  RSI: 6b86e1b8 RDI: 
[9.512912] RBP: a936800e3e78 R08: 00023701fcd7 R09: 9cf6c420
[9.512912] R10: 8f6516c6bf84 R11: 8f6516c6bf64 R12: 0001
[9.512912] R13: 9cf6c420 R14: 0001 R15: 8f6516c78a00
[9.512915]  ? cpuidle_enter_state+0xa6/0x3e0
[9.512916]  cpuidle_enter+0x2e/0x40
[9.512917]  call_cpuidle+0x23/0x40
[9.512918]  do_idle+0x1e7/0x280
[9.512919]  cpu_startup_entry+0x20/0x30
[9.512921]  start_secondary+0x171/0x1d0
[9.512923]  secondary_startup_64+0xb6/0xc0
[9.512923] handlers:
[9.512926] [] acpi_irq

If I try to reboot with "irqpoll" I don't have this error anymore, but
another about iwlwifi and a "kernel panic" dump (not sure it's called as
this), and wifi doesn't work anymore, but I don't get more touchpad.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1880172

Title:
  Touchpad is not detected on  Lenovo IdeaPad 3 14IIL05  Core i3-1005G1
  (81WD004MGE)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux-signed-hwe/+bug/1880172/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1882402] Re: Ubuntu-drivers allows installation of (nvidia-340) drivers, which are broken/break things (Kubuntu 20.04)

2020-06-12 Thread Elroy Liddington
Re: updated logs - I did a fresh Kubuntu 20.04 install to USB stick
(NOTE: 'Download Updates' and 'Install Third Party Drivers' selected via
installer), rebooted, and was greeted by black screen, as per original
bug issue.

The Nvidia drivers were again installed that have issues.

So possibly buggy/incomplete nvidia drivers, but ubuntu-drivers was
still 'aware' of issues:

"
root@xxxubuntu-drivers list
ERROR:root:No "nvidia-dkms-340" can be found.
nvidia-340
"

I also did "apt-get update && apt-get upgrade" which upgraded a lot of
things, but reboot has no change to black screen.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1882402

Title:
  Ubuntu-drivers allows installation of (nvidia-340) drivers, which are
  broken/break things (Kubuntu 20.04)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-drivers-common/+bug/1882402/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1882823] Re: int3403 thermal INT3403:00

2020-06-12 Thread Alex Hung
I sent an email asking about 0x91 to mailing list. I will update here
when information is available.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1882823

Title:
  int3403 thermal INT3403:00

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1882823/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1882823] Re: int3403 thermal INT3403:00

2020-06-12 Thread Alex Hung
https://marc.info/?l=linux-pm=159199577712570=2

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1882823

Title:
  int3403 thermal INT3403:00

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1882823/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1880172] Re: Touchpad is not detected on Lenovo IdeaPad 3 14IIL05 Core i3-1005G1 (81WD004MGE)

2020-06-12 Thread Ludovic LEMARINEL
*** This bug is a duplicate of bug 1878279 ***
https://bugs.launchpad.net/bugs/1878279

I don't know if this is related  with this bug, but in my dmesg, I've
found some error messages with I2C controler :

[0.432347] pci :00:15.0: BAR 0: no space for [mem size 0x1000 64bit]
[0.432348] pci :00:15.0: BAR 0: failed to assign [mem size 0x1000 
64bit]
[0.432352] pci :00:15.1: BAR 0: no space for [mem size 0x1000 64bit]
[0.432353] pci :00:15.1: BAR 0: failed to assign [mem size 0x1000 
64bit]
[0.432356] pci :00:1f.5: BAR 0: no space for [mem size 0x1000]
[0.432358] pci :00:1f.5: BAR 0: trying firmware assignment [mem 
0xfe01-0xfe010fff]
[0.432360] pci :00:1f.5: BAR 0: [mem 0xfe01-0xfe010fff] conflicts 
with Reserved [mem 0xfc80-0xfe7f]
[0.432361] pci :00:1f.5: BAR 0: failed to assign [mem size 0x1000]
[0.432365] pci :00:1d.0: PCI bridge to [bus 01]
[0.432387] pci :00:1d.0:   bridge window [mem 0x8110-0x811f]

...

[2.375554] intel-lpss: probe of :00:15.0 failed with error -16
[2.392134] platform idma64.0: failed to claim resource 0: [mem 
0x0800-0x0fff]
[2.392136] intel-lpss :00:15.1: Failed to add idma64, fallback to PIO


According to lspci, those 2 devices addresses (00:15:0 and 15:1) are i2c 
controlers :
00:15.0 Serial bus controller [0c80]: Intel Corporation Ice Lake-LP Serial IO 
I2C Controller #0 (rev 30)
00:15.1 Serial bus controller [0c80]: Intel Corporation Ice Lake-LP Serial IO 
I2C Controller #1 (rev 30)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1880172

Title:
  Touchpad is not detected on  Lenovo IdeaPad 3 14IIL05  Core i3-1005G1
  (81WD004MGE)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux-signed-hwe/+bug/1880172/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1881120] Re: linux-oem-5.6-tools-common and -tools-host should be dropped

2020-06-12 Thread Timo Aaltonen
** Changed in: linux-oem-5.6 (Ubuntu Focal)
   Status: In Progress => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1881120

Title:
  linux-oem-5.6-tools-common and -tools-host should be dropped

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1881120/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1882402] ProcEnviron.txt

2020-06-12 Thread Elroy Liddington
apport information

** Attachment added: "ProcEnviron.txt"
   
https://bugs.launchpad.net/bugs/1882402/+attachment/5383376/+files/ProcEnviron.txt

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1882402

Title:
  Ubuntu-drivers allows installation of (nvidia-340) drivers, which are
  broken/break things (Kubuntu 20.04)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-drivers-common/+bug/1882402/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1882402] ProcCpuinfoMinimal.txt

2020-06-12 Thread Elroy Liddington
apport information

** Attachment added: "ProcCpuinfoMinimal.txt"
   
https://bugs.launchpad.net/bugs/1882402/+attachment/5383375/+files/ProcCpuinfoMinimal.txt

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1882402

Title:
  Ubuntu-drivers allows installation of (nvidia-340) drivers, which are
  broken/break things (Kubuntu 20.04)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-drivers-common/+bug/1882402/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1882402] UbuntuDriversDebug.txt

2020-06-12 Thread Elroy Liddington
apport information

** Attachment added: "UbuntuDriversDebug.txt"
   
https://bugs.launchpad.net/bugs/1882402/+attachment/5383377/+files/UbuntuDriversDebug.txt

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1882402

Title:
  Ubuntu-drivers allows installation of (nvidia-340) drivers, which are
  broken/break things (Kubuntu 20.04)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-drivers-common/+bug/1882402/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1881007] Re: [SRU] libreoffice 6.4.4 for focal

2020-06-12 Thread Olivier Tilloy
I think libreoffice does meet pretty well the requirements for
microrelease exception. The only point I'm not sure about is whether the
tests cover API/ABI stability, this should be researched and confirmed.

As stated in the description, upstream runs both automated and manual
testing for each new micro release (and the corresponding release
candidates).
https://wiki.documentfoundation.org/QA/Testing/Regression_Tests has some
information. Additionally the autopkgtests for the package are pretty
extensive.

We have a long history of SRUing libreoffice microreleases to LTSes,
predating my taking over the maintenance of this package in 2017.

I'll let Heather comment on the impact of bug #1869561 (its importance
is set to High, if that's any indication).

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1881007

Title:
  [SRU] libreoffice 6.4.4 for focal

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1881007/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1882402] Re: Ubuntu-drivers allows installation of (nvidia-340) drivers, which are broken/break things (Kubuntu 20.04)

2020-06-12 Thread Elroy Liddington
apport information

** Description changed:

  Ubuntu-drivers allows installation of (nvidia-340) drivers, which are
  broken/break things.
  
  Allowing ( :-P ) ubuntu-drivers to install nvidia-340 results in no GUI on 
reboot, only console available.
  X does appear to be running, but only a black screen.
  
  
  Kernel: 
  
  5.4.0-33.37-generic 5.4.34
  
  CPU:
  =
  processor   : 3
  vendor_id   : AuthenticAMD
  cpu family  : 23
  model   : 17
  model name  : AMD Ryzen 3 2200G with Radeon Vega Graphics
  stepping: 0
  
  GPU:
  ==
  01:00.0 VGA compatible controller: NVIDIA Corporation G96CGL [Quadro FX 580] 
(rev a1)
  0a:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] 
Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] (rev c8)
  
  
  Error:
  
  "
  root@X# ubuntu-drivers list
  ERROR:root:No "nvidia-dkms-340" can be found.
  nvidia-340
  "
  
  1) Expected action - running 'ubuntu-drivers' lists NO drivers being
  available, as allowing drivers to be installed that the installer
  seems(?) to know are broken/will break things, is illogical.
  
  2) Improvements - I had access to terminal (Ctrl-Alt Fxxx).
  Why is there not an 'uninstall' option for ubuntu-drivers?
  
  "
  root@XXX# ubuntu-drivers 
  
  Available commands:
 list: Show all driver packages which apply to the current system.
 list-oem: Show all OEM enablement packages which apply to this system
 devices: Show all devices which need drivers, and which packages apply to 
them.
 install: Install drivers that are appropriate for your hardware.
 debug: Print all available information and debug data about drivers.
  "
  
  Reproduction:
  ===
  1) ubuntu-drivers list
  
  2) which shows:
  
  "
  ERROR:root:No "nvidia-dkms-340" can be found.
  nvidia-340
  
  "
  3) ubuntu-drivers install nvidia-340
  
  4) Reboot ==> black screen, no login screen
  
  
  Solved problem by reinstall (later research showed that " apt-get purge 
*nvidia* " may have rolled-back changes, however 
  " ubuntu-drivers uninstall nvidia-340 " would be a LOT more user-friendly).
  --- 
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27.2
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: KDE
  DistroRelease: Ubuntu 20.04
  Package: ubuntu-drivers-common 1:0.8.1.1
  PackageArchitecture: amd64
  ProcVersionSignature: Ubuntu 5.4.0-37.41-generic 5.4.41
  Tags:  focal
  Uname: Linux 5.4.0-37-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups:
   
  _MarkForUpload: True
+ --- 
+ ProblemType: Bug
+ ApportVersion: 2.20.11-0ubuntu27.2
+ Architecture: amd64
+ CasperMD5CheckResult: skip
+ DistroRelease: Ubuntu 20.04
+ InstallationDate: Installed on 2020-06-12 (0 days ago)
+ InstallationMedia: Kubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
+ NonfreeKernelModules: nvidia
+ Package: ubuntu-drivers-common 1:0.8.1.1
+ PackageArchitecture: amd64
+ ProcVersionSignature: Ubuntu 5.4.0-37.41-generic 5.4.41
+ Tags:  focal
+ Uname: Linux 5.4.0-37-generic x86_64
+ UpgradeStatus: No upgrade log present (probably fresh install)
+ UserGroups:
+  
+ _MarkForUpload: True

** Attachment added: "Dependencies.txt"
   
https://bugs.launchpad.net/bugs/1882402/+attachment/5383374/+files/Dependencies.txt

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1882402

Title:
  Ubuntu-drivers allows installation of (nvidia-340) drivers, which are
  broken/break things (Kubuntu 20.04)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-drivers-common/+bug/1882402/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1798166] Re: “Mouse battery low” notification can't be disabled

2020-06-12 Thread Florian 'rephlex' Panzer
Some background: rechargeable batteries have 1.2V nominal (compared to
1.5V nominal for regular battteries). Any mouse will report levels
around 10%, although the batteries will run for *many* months.

So users of rechargeable batteries will experience notifications about
low levels basically after a few days of using a rechargeable battery.

Although you might very wel argue that "it's a hardware problem",
notifications about low mouse / keyboard battery should be optional, not
forced upon the user.

I have no way to disable the mouse / battery level alarm. (that is BUG
#1)

Furthermore, if i use DND (which i don't really want to use, but just
assumed), the mouse/keyboard alarms are the ONLY alarms that OVERRIDE
DND, to "using DND" is not a solution, and DND does in fact disturb in
some cases, which is BUG #2.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1798166

Title:
  “Mouse battery low” notification can't be disabled

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/1798166/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1798166] Re: “Mouse battery low” notification can't be disabled

2020-06-12 Thread Florian 'rephlex' Panzer
Device: /org/freedesktop/UPower/devices/mouse_hidpp_battery_0
  native-path:  hidpp_battery_0
  model:MX Keys Wireless Keyboard
  serial:   408a-9b-b6-52-57
  power supply: no
  updated:  Fr 12 Jun 2020 22:39:07 CEST (8 seconds ago)
  has history:  yes
  has statistics:   yes
  mouse
present: yes
rechargeable:yes
state:   discharging
warning-level:   low
battery-level:   low
percentage:  10% (should be ignored)
icon-name:  'battery-caution-symbolic'


** Attachment added: "Screenshot of the notification"
   
https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/1798166/+attachment/5383373/+files/Bildschirmfoto%20von%202020-06-12%2022-38-51.png

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1798166

Title:
  “Mouse battery low” notification can't be disabled

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/1798166/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1716656] Re: Plugins not loading

2020-06-12 Thread Daniel Berrange
Looking at the file list for the entangle package:

   https://packages.ubuntu.com/eoan/amd64/entangle/filelist

We can see that the plugin code simply isn't included at all.

Only the gschema files in /usr/share have been installed

The code and registration metadata from /usr/lib(64) are missing.

A proper install for a plugin install would have 4 files:

/usr/lib64/entangle/plugins/shooter/shooter.plugin
/usr/lib64/entangle/plugins/shooter/shooter.py
/usr/share/entangle/plugins/shooter/schemas/gschemas.compiled
/usr/share/entangle/plugins/shooter/schemas/org.entangle-photo.plugins.shooter.gschema.xml

NB, /usr/lib64 might be elsewhere on Ubuntu

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1716656

Title:
  Plugins not loading

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/entangle/+bug/1716656/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1874508] Re: FTBFS with llvm-10

2020-06-12 Thread Gianfranco Costamagna
** Also affects: ccls (Ubuntu Focal)
   Importance: Undecided
   Status: New

** Changed in: ccls (Ubuntu)
   Status: New => Fix Released

** Changed in: ccls (Ubuntu Focal)
   Status: New => In Progress

** Summary changed:

- FTBFS with llvm-10
+ [SRU] ccls: FTBFS with llvm-10

** Description changed:

- I find this package FTBFS in focal, because llvm-defaults is updated to
- 10.
+ [Impact] 
+ * the package in the archive currently FTBFS with llvm-default to 10
+ 
+ [Test Case]
+ * dpkg-buildpackage it
+ 
+ [Regression Potential] 
+ * minimal, the new release is fixing only this problem, and comes from Debian 
maintainer
+ 
+ [Other info]
+ I find this package FTBFS in focal, because llvm-defaults is updated to 10.
  
  https://launchpad.net/ubuntu/+source/ccls/0.20190823.5-1build1
  
  The new version in Debian(sid) can fix this.
  
  How does the SRU procedure work? Is this upstream microrelease suite for
  SRU?
  
  The diff looks quite minimal.
  
  ```
  diff -Nru ccls-0.20190823.5/debian/changelog 
ccls-0.20190823.6/debian/changelog
  --- ccls-0.20190823.5/debian/changelog  2019-11-13 00:25:32.0 +0800
  +++ ccls-0.20190823.6/debian/changelog  2020-04-22 15:03:08.0 +0800
  @@ -1,3 +1,11 @@
  +ccls (0.20190823.6-1) unstable; urgency=medium
  +
  +  * New upstream release 0.20190823.6
  +  * Update Standards-Version to 4.5.0 (no changes)
  +  * Run ccls index in autopkgtest
  +
  + -- Shengjing Zhu   Wed, 22 Apr 2020 15:03:08 +0800
  +
-  ccls (0.20190823.5-1) unstable; urgency=medium
-  
-* New upstream release 0.20190823.5
+  ccls (0.20190823.5-1) unstable; urgency=medium
+ 
+    * New upstream release 0.20190823.5
  diff -Nru ccls-0.20190823.5/debian/control ccls-0.20190823.6/debian/control
  --- ccls-0.20190823.5/debian/control2019-11-13 00:25:32.0 +0800
  +++ ccls-0.20190823.6/debian/control2020-04-22 15:03:08.0 +0800
  @@ -11,7 +11,7 @@
-   llvm-dev,
-   python3 ,
-   rapidjson-dev,
+   llvm-dev,
+   python3 ,
+   rapidjson-dev,
  -Standards-Version: 4.4.1
  +Standards-Version: 4.5.0
-  Homepage: https://github.com/MaskRay/ccls
-  Vcs-Browser: https://salsa.debian.org/zhsj/ccls
-  Vcs-Git: https://salsa.debian.org/zhsj/ccls.git
+  Homepage: https://github.com/MaskRay/ccls
+  Vcs-Browser: https://salsa.debian.org/zhsj/ccls
+  Vcs-Git: https://salsa.debian.org/zhsj/ccls.git
  diff -Nru ccls-0.20190823.5/debian/tests/lsp-test 
ccls-0.20190823.6/debian/tests/lsp-test
  --- ccls-0.20190823.5/debian/tests/lsp-test 2019-11-13 00:25:32.0 
+0800
  +++ ccls-0.20190823.6/debian/tests/lsp-test 2020-04-22 15:03:08.0 
+0800
  @@ -7,7 +7,7 @@
-  import subprocess
-  import time
-  
+  import subprocess
+  import time
+ 
  -
  +ccls = os.getenv("CCLS", "ccls")
-  path = os.path.dirname(os.path.realpath(__file__))
-  
-  tests = [
+  path = os.path.dirname(os.path.realpath(__file__))
+ 
+  tests = [
  @@ -118,17 +118,17 @@
-  return json.loads(f.read(size).decode())
-  
-  
+  return json.loads(f.read(size).decode())
+ 
  +subprocess.run([ccls, "-index=."], 
stderr=subprocess.STDOUT).check_returncode()
  +
-  with subprocess.Popen(
+  with subprocess.Popen(
  -[os.getenv("CCLS", "ccls"), "-v=-1"], stdin=subprocess.PIPE, 
stdout=subprocess.PIPE
  +[ccls, "-v=-1"], stdin=subprocess.PIPE, stdout=subprocess.PIPE
-  ) as proc:
-  for tt in tests:
-  method = tt[0]["method"]
-  print("Testing", method)
-  proc.stdin.write(encode(tt[0]))
-  proc.stdin.flush()
+  ) as proc:
+  for tt in tests:
+  method = tt[0]["method"]
+  print("Testing", method)
+  proc.stdin.write(encode(tt[0]))
+  proc.stdin.flush()
  -if method == "initialize":
  -# wait for ccls to finish indexing
  -time.sleep(2)
  +time.sleep(1)
-  got = read(proc.stdout)
-  if not tt[1] == got:
-  print("Expect:")
+  got = read(proc.stdout)
+  if not tt[1] == got:
+  print("Expect:")
  diff -Nru ccls-0.20190823.5/src/clang_tu.cc ccls-0.20190823.6/src/clang_tu.cc
  --- ccls-0.20190823.5/src/clang_tu.cc   2019-11-13 00:22:48.0 +0800
  +++ ccls-0.20190823.6/src/clang_tu.cc   2020-04-22 15:02:27.0 +0800
  @@ -8,6 +8,7 @@
-  
-  #include 
-  #include 
+ 
+  #include 
+  #include 
  +#include 
-  #include 
-  
-  using namespace clang;
+  #include 
+ 
+  using namespace clang;
  diff -Nru ccls-0.20190823.5/src/filesystem.cc 
ccls-0.20190823.6/src/filesystem.cc
  --- ccls-0.20190823.5/src/filesystem.cc 2019-11-13 00:22:48.0 +0800
  +++ ccls-0.20190823.6/src/filesystem.cc 2020-04-22 15:02:27.0 +0800
  @@ -31,7 +31,8 @@
-curr.pop_back();
-for (sys::fs::directory_iterator i(folder1, ec, false), e; i != e && 
!ec;
- i.increment(ec)) {
+    curr.pop_back();
+    for (sys::fs::directory_iterator i(folder1, ec, false), e; i != e && 
!ec;
+    

[Bug 1883309] Re: latest in a series of bugs. been trying to install ubuntu but haviung all sorts of problems

2020-06-12 Thread Ubuntu Foundations Team Bug Bot
Thank you for taking the time to report this bug and helping to make
Ubuntu better.  Reviewing your log files attached to this bug report it
seems that there is a problem with your installation media (CD/DVD).
You can verify the integrity of the Ubuntu ISO files you downloaded by
following the instructions at
https://help.ubuntu.com/community/HowToMD5SUM.  You might also retry
your installation with new media.  In the event that is is not in fact
an error with your installation media please set the bug's status back
to New.  Thanks and good luck!

[This is an automated message.  I apologize if it reached you
inappropriately; please just reply to this message indicating so.]

** Changed in: ubiquity (Ubuntu)
   Status: New => Incomplete

** Tags added: ident-mismatch

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883309

Title:
  latest in a series of bugs. been trying to install ubuntu but haviung
  all sorts of problems

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1883309/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883320] Re: [kvm] change check_enabled to /dev/kvm

2020-06-12 Thread Eric Desrochers
** Description changed:

- [Original Description]
+ [Impact]
  
  The KVM plugin get triggered in a container
  (e.g lxd) because of "/sys/module/kvm"
  inheritance from the kernel host.
  
  Not only it's a waste of sosreport time,
  but running it inside a container may
  unintentionally reveal details from its
  host. Which is a undesired behaviour.
  
  Switching to /dev/kvm, is more appropriate
  and follow current standard as used by tool
  such as cpu-checker (kvm-ok) for instance.
  
  And taking benefit of this change to get rid
  of the check_enabled() overwrite in favour of
  using "files=" trigger.
+ 
+ [Test Case]
+ 
+ * Run sosreport inside a LXD container
+ * The container will contain KVM information from its host (Iff its host as 
KVM installed)
+ 
+ [Regression Potential]
+ 
+ We only change the way the plugin gets triggered to use a most
+ conventional way.
+ 
+ If /dev/kvm exist, then exercise the kvm plugin.
+ 
+ No regression expected, but worse case scenario, it will only be
+ isolated and impact the KVM plugin to collect data properly as expected.
+ 
+ It won't cause any harm to others plugins nor sosreport core
+ functionalities itself.
+ 
+ The commit went through some upstream Travis testing which uses a shell
+ script called "simple.sh" to verify sosreport collection.
+ 
+ BTW, this same exact script is part of the sosreport autopkgtest, and will be 
run as part of the SRU to push this change.
+  
+ [Other Information]
+ 
+ * Upstream bug:
+ https://github.com/sosreport/sos/issues/2062
+ 
+ * Upstream commit:
+ 
https://github.com/sosreport/sos/pull/2063/commits/dc58a038c18ff3e838d883d4b31aad5dac7ea9e1

** Also affects: sosreport (Ubuntu Bionic)
   Importance: Undecided
   Status: New

** Also affects: sosreport (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Also affects: sosreport (Ubuntu Groovy)
   Importance: Undecided
 Assignee: Eric Desrochers (slashd)
   Status: In Progress

** Also affects: sosreport (Ubuntu Focal)
   Importance: Undecided
   Status: New

** Description changed:

  [Impact]
  
  The KVM plugin get triggered in a container
  (e.g lxd) because of "/sys/module/kvm"
  inheritance from the kernel host.
  
  Not only it's a waste of sosreport time,
  but running it inside a container may
  unintentionally reveal details from its
  host. Which is a undesired behaviour.
  
  Switching to /dev/kvm, is more appropriate
  and follow current standard as used by tool
  such as cpu-checker (kvm-ok) for instance.
  
  And taking benefit of this change to get rid
  of the check_enabled() overwrite in favour of
  using "files=" trigger.
  
  [Test Case]
  
  * Run sosreport inside a LXD container
  * The container will contain KVM information from its host (Iff its host as 
KVM installed)
  
  [Regression Potential]
  
  We only change the way the plugin gets triggered to use a most
  conventional way.
  
  If /dev/kvm exist, then exercise the kvm plugin.
  
  No regression expected, but worse case scenario, it will only be
  isolated and impact the KVM plugin to collect data properly as expected.
  
  It won't cause any harm to others plugins nor sosreport core
  functionalities itself.
  
- The commit went through some upstream Travis testing which uses a shell
+ The commit went through some upstream Travis testing which used a shell
  script called "simple.sh" to verify sosreport collection.
  
- BTW, this same exact script is part of the sosreport autopkgtest, and will be 
run as part of the SRU to push this change.
-  
+ BTW, this same exact script is part of the sosreport autopkgtest, and
+ will be run as part of the SRU to push this change.
+ 
  [Other Information]
  
  * Upstream bug:
  https://github.com/sosreport/sos/issues/2062
  
  * Upstream commit:
  
https://github.com/sosreport/sos/pull/2063/commits/dc58a038c18ff3e838d883d4b31aad5dac7ea9e1

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883320

Title:
  [kvm] change check_enabled to /dev/kvm

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/sosreport/+bug/1883320/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

  1   2   3   4   5   >