[Bug 1847105] Re: very slow disk creation, snapshotting

2020-09-22 Thread Christian Ehrhardt 
** Description changed:

- This is a regression in eoan for me. I use virt-manager to create vms,
- and I noticed that creating one now takes more than a minute.
+ [Impact]
+ 
+  * The defaults of virt-manager for disk allocation always worked fine
+when qcow2 had nothing but sparse support. So sparse=True vs
+sparse=False made no difference. So it always set sparse=False.
+Then qcow2 grows non-sparse support, and virt-manager is suddenly
+defaulting to it, which is not the intention.
+ 
+ 
+  * For upgraders from pre-Focal this was a regression in two ways:
+ a) allocation of qcow changed to non-sparse (fallocate based) 
+potentially consuming more space
+ b) depending on the underlying FS this made the allocation much 
+slower
+ 
+  * Fix by applying the upstream change that Defaults to sparse when 
+requested format isn't raw (for raw the assumption ill stay that 
+users do that for runtime performance, so non-sparse on those stays 
+as-is)
+ 
+ [Test Case]
+ 
+  * open virt-manager and create a new guest which includes creating a 
+new image for it
+* when clicking "finish" the image will be created (which e.g. on ZFS 
+  will take quite some time)
+* In the background grep ps output if the qemu-img call for qcow (the 
+  default) is using "preallocation=fallocate" (wrong) or 
+  "preallocation=metadata" (correct)
+ 
+ [Regression Potential]
+ 
+  * For upgraders from pre-focal it actually ensures behavior stays as is 
+(no change/regression there)
+  * For users of ZFS where the allocation was slow it fixes this 
+slowness.
+  * But for people using Focal all the time and on non-ZFS there will be 
+a behavior change in no more doing falloc pre-allocating the qemu 
+image. To be cleear there are four modes:
+1. no allocation
+2. metadata allocation - is initially larger but can improve 
+   performance when the image needs to grow
+3. falloc - preallocates space for image by calling posix_fallocate
+4. full - writes data to the underlying storage
+The fix changes the default from 3->2 which it always was and should 
+be. As the patch says: "If users want to override it, they can
+do it via custom created storage."
+(To be clear, upstream changed this as we fixed it here, so on 
+ further upgrades what we apply here will be the behavior anyway, it 
+ seems wrong to keep Focal the only one in between kept different)
+ 
+ [Other Info]
+  
+  * The slowness effect might be further mitigated by ZFS implementing 
+more falloc options (thanks Richard for that hint) but that won't be 
+in Focal.
+ 
+ 
+ 
+ 
+ This is a regression in eoan for me. I use virt-manager to create vms, and I 
noticed that creating one now takes more than a minute.
  
  Looking at the process listing while the backing disk is being created, I see 
this qemu-img command line:
  15658 ?Ssl0:00 /usr/sbin/libvirtd
  23726 ?Sl 0:04  \_ /usr/bin/qemu-img create -f qcow2 -o 
preallocation=falloc,compat=1.1,lazy_refcounts 
/var/lib/libvirt/images/live-server.qcow2 41943040K
  
  If I run qemu-img with that preallocation parameter set, even on bionic,
  then it also takes a very long time.
  
  On eoan, for comparison:
  andreas@nsn7:~$ time qemu-img create -f qcow2 no-prealloc-image.qcow2 40G
  Formatting 'no-prealloc-image.qcow2', fmt=qcow2 size=42949672960 
cluster_size=65536 lazy_refcounts=off refcount_bits=16
  
  real  0m0,016s
  user  0m0,010s
  sys   0m0,006s
- andreas@nsn7:~$ qemu-img info no-prealloc-image.qcow2 
+ andreas@nsn7:~$ qemu-img info no-prealloc-image.qcow2
  image: no-prealloc-image.qcow2
  file format: qcow2
  virtual size: 40G (42949672960 bytes)
  disk size: 17K
  cluster_size: 65536
  Format specific information:
- compat: 1.1
- lazy refcounts: false
- refcount bits: 16
- corrupt: false
- andreas@nsn7:~$ du -hs no-prealloc-image.qcow2 
+ compat: 1.1
+ lazy refcounts: false
+ refcount bits: 16
+ corrupt: false
+ andreas@nsn7:~$ du -hs no-prealloc-image.qcow2
  17K   no-prealloc-image.qcow2
- andreas@nsn7:~$ 
- 
+ andreas@nsn7:~$
  
  and now with preallocation=falloc:
  andreas@nsn7:~$ time qemu-img create -f qcow2 -o preallocation=falloc 
with-prealloc-image.qcow2 40G
  Formatting 'with-prealloc-image.qcow2', fmt=qcow2 size=42949672960 
cluster_size=65536 preallocation=falloc lazy_refcounts=off refcount_bits=16
  
  real  1m43,196s
  user  0m3,564s
  sys   1m26,720s
- andreas@nsn7:~$ qemu-img info with-prealloc-image.qcow2 
+ andreas@nsn7:~$ qemu-img info with-prealloc-image.qcow2
  image: with-prealloc-image.qcow2
  file format: qcow2
  virtual size: 40G (42949672960 bytes)
  disk size: 2.7M
  cluster_size: 65536
  Format specific information:
- compat: 1.1
- lazy refcounts: false
- refcount bits: 16
- corrupt: false
- andreas@nsn7:~$ du -hs with-prealloc-image.qcow2 
+ compat: 1.1
+ lazy 

[Bug 1886551] Re: wireshark trace decryption

2020-09-22 Thread Rohith Surabattula
Hi Lukasz,

I have tested the cifs-utils package from bionic-proposed and able to decrypt 
the wireshark traces.
Verification steps:
1)  Start TCPDUMP on port 445.
2)  Mount a file share.
3)  Use smbinfo keys to get the session id and key.
4)  Do some IO on file share.
5)  Stop TCPDUMP and open the pcap file in wireshark
6)  Copy the session id and key in preference section of SMB2 protocol.

smbinfo keys output:
sudo smbinfo keys /mnt/rohith/test.txt
SMB3.0 CCM encryption
Session Id:   09 02 00 ec 04 60 b0 83
Session Key:  15 b2 1f b0 41 ff fd 58 36 53 fa cd df d1 97 4b
Server Encryption Key:  80 0e 28 bc 13 02 2c 7a 7d 55 b1 33 22 43 03 8e
Server Decryption Key:  5f 92 26 87 b4 f8 08 da 41 88 f7 cd 95 e0 a9 25

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1886551

Title:
   wireshark trace decryption

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cifs-utils/+bug/1886551/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896316] Re: tracker-extract crashed with signal 31 in statx()

2020-09-22 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: tracker-miners (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1896316

Title:
  tracker-extract crashed with signal 31 in statx()

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/tracker-miners/+bug/1896316/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 849416]

2020-09-22 Thread Bugzilla-4
Yes, this is malformed MIME. Thunderbird should be able to handle it. It
does not, so it's a bug.

Iff I where 2 introduse malformation s IN my writting, u wud still
understend. As you should.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/849416

Title:
  text/calendar attachments are not shown at all

To manage notifications about this bug go to:
https://bugs.launchpad.net/seamonkey/+bug/849416/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 849416]

2020-09-22 Thread Stephane-gourichon-mozbugz
Thanks @MarkusKuhn for taking care of explaining.

I understand that it is vexing when users complain about a problem
caused by a bug in a third party program.

Still, thunderbird not displaying any hint feels wrong.

I'm also aware that https://en.wikipedia.org/wiki/Robustness_principle
can sometimes hurt. I guess the question can only be resolved
pragmatically, like "Do we have the power to force Microsoft Exchange to
fix that?", "Does implementing the wish cause costs, like extra code
complexity?" or "What happen if we refuse to do anything about this
problem experiences by users?".

Anyway, thanks again Markus for enlightening us.

> Don't use Microsoft Exchange if what you really want is proper
RFC822+MIME email. It never was. Spread the word.

I'm already self-hosted and since the hosting company of my freelancing
activity switched to MS Exchange I'm considering to self-host that, too,
for what it's worth.


> Repeat: this is a feature request for a workaround of a long-standing 
> Microsoft Exchange bug. This is not a Thunderbird bug.

I'm willing to change the field "Type: defect" to " Type: feature
request" but Bugzilla does not let me do that.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/849416

Title:
  text/calendar attachments are not shown at all

To manage notifications about this bug go to:
https://bugs.launchpad.net/seamonkey/+bug/849416/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 849416]

2020-09-22 Thread Stephane-gourichon-mozbugz
Same as Daniel here. I experienced this bug on Linux. 
Can reproduce it now by displaying sample e-mail from comment 4 ( 
https://bugzilla.mozilla.org/show_bug.cgi?id=505024#c4 ) on 68.10.0 (64 bits).

In my case I received automatic invitation e-mails which did not have
any text, just the calendar entry. They appeared as totally blank
e-mail, only showing the e-mail source code allowed me to realize there
was a calendar entry.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/849416

Title:
  text/calendar attachments are not shown at all

To manage notifications about this bug go to:
https://bugs.launchpad.net/seamonkey/+bug/849416/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 849416]

2020-09-22 Thread Bugzilla-4
It is not correct that this is only for "Windows XP". In my case, it is
Linux. So this bug likely affects all platforms. I couldn't fiugure out
how to add Linux as an affected platform for this bug.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/849416

Title:
  text/calendar attachments are not shown at all

To manage notifications about this bug go to:
https://bugs.launchpad.net/seamonkey/+bug/849416/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 849416]

2020-09-22 Thread Markus Kuhn
Dear newcomers to this issue. As explained above in [comment
122](https://bugzilla.mozilla.org/show_bug.cgi?id=505024#c122), this
issue is really a bug (violation of the MIME standard) **in the calendar
function of Microsoft Exchange** that sends these messages. Regarding
Thunderbird, this issue is a **feature request for a workaround for a
violation of the MIME standard by a Microsoft product**.

For history buffs: The underlying issue is that Microsoft Exchange was
originally designed to be an in-house X.400 mail server that added an
Internet (RFC822+MIME) email gateway only later as an after-thought.
X.400 only allows a flat list of attachments, but MIME allows (and
requires in this case) a hierarchical tree of a multipart/alternative
inside a multipart/mixed attachment. Microsoft still has not yet fully
resolved all the ancient early-1990s legacy of the in-house X.400 mail
product that eventually became Microsoft Exchange, and probably as a
result their Exchange Calendar function keeps sending out malformed
MIME. (To better understand the complex ways of how Microsoft Exchange
internally maps RFC822+MIME messages onto their own X.400-style message
objects, see [[MS-OXCMAIL]: RFC 2822 and MIME to Email Object Conversion
Algorithm](https://docs.microsoft.com/en-
us/openspecs/exchange_server_protocols/ms-oxcmail/b60d48db-183f-
4bf5-a908-f584e62cb2d4). Warning, this is not for the faint hearted.
Don't use Microsoft Exchange if what you really want is proper
RFC822+MIME email. It never was. Spread the word.)

Repeat: this is a feature request for a workaround of a long-standing
Microsoft Exchange bug. This is not a Thunderbird bug.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/849416

Title:
  text/calendar attachments are not shown at all

To manage notifications about this bug go to:
https://bugs.launchpad.net/seamonkey/+bug/849416/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 849416]

2020-09-22 Thread Worcester12345
It seems that the defacto is that this should work. Maybe it is time to
update the MIME standard to agree with what is reality.

Meanwhile, Thunderbird users are left holding the short straw.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/849416

Title:
  text/calendar attachments are not shown at all

To manage notifications about this bug go to:
https://bugs.launchpad.net/seamonkey/+bug/849416/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 940631]

2020-09-22 Thread Kai Engert
If you're on macOS, our workaround from bug 1610390 is not enabled
because of bug 1612456.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/940631

Title:
  Thunderbird asks three times for my master password

To manage notifications about this bug go to:
https://bugs.launchpad.net/thunderbird/+bug/940631/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 940631]

2020-09-22 Thread Jamesrome-alum
There used to be an addon that fixed this, but not sure it is still
there, and forget the name. But please, Mac users need a fix too.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/940631

Title:
  Thunderbird asks three times for my master password

To manage notifications about this bug go to:
https://bugs.launchpad.net/thunderbird/+bug/940631/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 940631]

2020-09-22 Thread Jamesrome-alum
Not fixed in 81.0b4 on a mac

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/940631

Title:
  Thunderbird asks three times for my master password

To manage notifications about this bug go to:
https://bugs.launchpad.net/thunderbird/+bug/940631/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 940631]

2020-09-22 Thread Mkmelin+mozilla
81.0b4 will be out in a day or a few

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/940631

Title:
  Thunderbird asks three times for my master password

To manage notifications about this bug go to:
https://bugs.launchpad.net/thunderbird/+bug/940631/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 849416]

2020-09-22 Thread Ben-bucksch
>  the ancient early-1990s legacy ... Exchange

I bet even today's Microsoft engineers fear that code.

> violation of the MIME standard in the calendar function of Microsoft
Exchange that sends these messages

Right. "Microsoft doesn't respect Internet standards" isn't new.
Thunderbird always had the policy to treat this as bug and fix it.

The reality is that people working in companies send these invitations,
to people inside and outside the company, and if you are unfortunate
enough to use Thunderbird without Lightning, you don't even see the
meeting time or location. Guess who the meeting organizer will blame?
Try arguing with him that Exchange has a bug.



That said, I know (comment 118, and from my own testing), the bug
appeared only if you use Thunderbird without Lighting. Since Thunderbird
78, Lightning is integrated into Thunderbird core. Can somebody
reproduce this bug in Thunderbird 78 with Lightning enabled?

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/849416

Title:
  text/calendar attachments are not shown at all

To manage notifications about this bug go to:
https://bugs.launchpad.net/seamonkey/+bug/849416/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1653351]

2020-09-22 Thread Bazuchan
I made a quick port of squib's extension for tb78:

https://github.com/bazuchan/thunderbird-deselect-on-delete
and will be published here: 
https://addons.thunderbird.net/ru/thunderbird/addon/deselect-on-delete-tb78/

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1653351

Title:
  Have option to not automatically open next email

To manage notifications about this bug go to:
https://bugs.launchpad.net/thunderbird/+bug/1653351/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1853007]

2020-09-22 Thread Virgo
It is not just Linux issue. Happens on Windows also. At Windows 10 2004,
Thunderbird 78.2.2 (but was also previous versions (68).

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1853007

Title:
  nsemail and nscopy files left in /tmp

To manage notifications about this bug go to:
https://bugs.launchpad.net/thunderbird/+bug/1853007/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1847105] Re: very slow disk creation, snapshotting

2020-09-22 Thread Launchpad Bug Tracker
** Merge proposal linked:
   
https://code.launchpad.net/~paelzer/ubuntu/+source/virt-manager/+git/virt-manager/+merge/391188

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1847105

Title:
  very slow disk creation, snapshotting

To manage notifications about this bug go to:
https://bugs.launchpad.net/virt-manager/+bug/1847105/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896482] Re: acpi event detection crashes

2020-09-22 Thread Alex Hung
Thanks mfo for helping out how to disable secure boot and install kernel

I uploaded a test kernel @
https://people.canonical.com/~alexhung/LP1896482/0a8c35897f60b202/

There are 17 patches so it requires 4 times to identify the fixing
kernel patch. The included patches are listed in ec_bisect1.log in the
above link.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1896482

Title:
  acpi event detection crashes

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1896482/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1894017] Re: Keyboard not working

2020-09-22 Thread Sam N
After testing out various kernels, I've found that the keyboard and
trackpad gain functionality in kernel 5.4.18-050418-generic.

No luck in the latest (5.8~) yet, but as 5.4 is a LTS kernel for now
I'll just stick with booting to 5.4.18 as that's only a few point
releases behind current stable anyway. Hope this info helps others.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1894017

Title:
  Keyboard not working

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1894017/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1890435] Re: gcc-10 breaks on armhf (flaky): internal compiler error: Segmentation fault

2020-09-22 Thread Christian Ehrhardt 
And again on the same :-/

cc -iquote /<>/b/qemu/linux-user/s390x -iquote linux-user/s390x 
-iquote /<>/tcg/arm -isystem /<>/linux-headers 
-isystem /<>/b/qemu/linux-headers -iquote . -iquote 
/<> -iquote /<>/accel/tcg -iquote 
/<>/include -iquote /<>/disas/libvixl 
-I/usr/include/pixman-1   -pthread -I/usr/include/glib-2.0 
-I/usr/lib/arm-linux-gnueabihf/glib-2.0/include -pthread 
-I/usr/include/glib-2.0 -I/usr/lib/arm-linux-gnueabihf/glib-2.0/include -fPIE 
-DPIE  -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE 
-Wstrict-prototypes -Wredundant-decls -Wall -Wundef -Wwrite-strings 
-Wmissing-prototypes -fno-strict-aliasing -fno-common -fwrapv -std=gnu99  -g 
-O2 -fdebug-prefix-map=/<>=. -fstack-protector-strong -Wformat 
-Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -Wexpansion-to-defined 
-Wendif-labels -Wno-shift-negative-value -Wno-missing-include-dirs -Wempty-body 
-Wnested-externs -Wformat-security -Wformat-y2k -Winit-self 
-Wignored-qualifiers -Wold-style-declaration -Wold-style-definition 
-Wtype-limits -fstack-protector-strong -I/usr/include/p11-kit-1  
-DSTRUCT_IOVEC_DEFINED  -I/usr/include/libpng16  
-I/<>/capstone/include -isystem ../linux-headers -iquote .. 
-iquote /<>/target/s390x -DNEED_CPU_H -iquote 
/<>/include -I/<>/linux-user/s390x 
-I/<>/linux-user/host/arm -I/<>/linux-user 
-Ilinux-user/s390x -MMD -MP -MT linux-user/s390x/signal.o -MF 
linux-user/s390x/signal.d -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -g   -c -o 
linux-user/s390x/signal.o /<>/linux-user/s390x/signal.c
The bug is not reproducible, so it is likely a hardware or OS problem.


There seems to be no pattern to it (e.g. on which source file it break), just a 
chance that increased probably on source size. But I wonder what else I could 
do on top of the canonistack build that I have tried - maybe concurrency?

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1890435

Title:
  gcc-10 breaks on armhf (flaky): internal compiler error: Segmentation
  fault

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gcc-10/+bug/1890435/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896419] Re: Comet Lake CPUID family:model:stepping 0x6:a5:2 (6:165:2) is not included

2020-09-22 Thread Leon Liao
I verified this bug on Dell G5-5500.

$ systemctl is-active thermald
active

$ sudo dpkg -l | grep thermald
ii  thermald   1.9.1-1ubuntu0.3  [..skip..]


** Tags removed: verification-needed-focal
** Tags added: verification-done-focal

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1896419

Title:
  Comet Lake CPUID family:model:stepping 0x6:a5:2 (6:165:2) is not
  included

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1896419/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1877000] Re: openjfx is missing native libraries for webkit and media

2020-09-22 Thread Tiago Stürmer Daitx
** Description changed:

- [Impact] 
+ [Impact]
  OpenJFX's media and webkit native libraries are missing from amd64 builds in 
Focal and Groovy. This is a regression from Bionic.
  
  This prevents applications that depend on these libraries from working
  correctly.
  
  [Test Case]
  The libjfxmedia.so and libjfxwebkit.so should be present in the 
libopenjfx-jni binary for all archs.
  
  One can see in the amd64 package listing for Focal [1,2] and Groovy
  [3,4] that libjfxmedia.so and libjfxwebkit.so are only available on
  arm64, armhf, ppc64el, and s390x.
  
  [1] 
https://packages.ubuntu.com/search?searchon=contents=libjfxmedia.so=exactfilename=focal=any
  [2] 
https://packages.ubuntu.com/search?searchon=contents=libjfxwebkit.so=exactfilename=focal=any
  [3] 
https://packages.ubuntu.com/search?searchon=contents=libjfxmedia.so=exactfilename=groovy=any
  [4] 
https://packages.ubuntu.com/search?searchon=contents=libjfxwebkit.so=exactfilename=groovy=any
  
- 
  Another possible test case is running pdfsam in the console to split a PDF 
file (after pdfsam bug 1887142 is fixed) and look if errors as:
  Caused by: java.lang.UnsatisfiedLinkError: no jfxmedia in java.library.path: 
[/usr/java/packages/lib, /usr/lib/x86_64-linux-gnu/jni, /lib/x86_64-linux-gnu, 
/usr/lib/x86_64-linux-gnu, /usr/lib/jni, /lib, /usr/lib]
  show up in the stdout. A sound should be played if everything works.
  
- 
- [Regression Potential] 
+ [Regression Potential]
  Enabling the native libraries will allow applications to use them again.
- * This can trigger errors in applications that were not detected while the 
libraries were missing.
+ * This can trigger errors in applications that hidden by the fact that there 
were no native libraries to use.
  * This can cause applications that use OpenJFX to fail to run or crash during 
runtime.
- It is unlikely that autopkgtest will detect such errors given that OpenJFX 
_did_ migrate when the native libraries were missing (and should have caused 
errors).
+ It is unlikely that autopkgtest will detect such errors given that OpenJFX 
_did_ migrate when the native libraries were missing (and that should have 
caused errors).
  
  [Other Info]
  
- 
  [Original Report]
  I'm trying to run BlueJ on Ubuntu 20.04 (fresh install), while the main app 
runs the editor refuses to start, looking at its logs apparently it can't find 
jfxwebkit. So I tried to search for it, and apparently it is present in the 
other architectures for Focal as well as all architectures in Eoan, Bionic and 
Xenial in the libopenjfx-jni package, but not for Focal amd64. The version of 
openjfx I have is 11.0.7+0-2ubuntu1. I have also attached BlueJ's log for 
reference.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1877000

Title:
  openjfx is missing native libraries for webkit and media

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openjfx/+bug/1877000/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1592853] Re: sshuttle doesn't autodetect python3 instead of 'python'

2020-09-22 Thread Chris Halse Rogers
Hello Eric, or anyone else affected,

Accepted sshuttle into bionic-proposed. The package will build now and
be available at
https://launchpad.net/ubuntu/+source/sshuttle/0.78.3-1ubuntu1.1 in a few
hours, and then in the -proposed repository.

Please help us by testing this new package.  See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how
to enable and use -proposed.  Your feedback will aid us getting this
update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested, what testing has been
performed on the package and change the tag from verification-needed-
bionic to verification-done-bionic. If it does not fix the bug for you,
please add a comment stating that, and change the tag to verification-
failed-bionic. In either case, without details of your testing we will
not be able to proceed.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification .  Thank you in
advance for helping!

N.B. The updated package will be released to -updates after the bug(s)
fixed by this package have been verified and the package has been in
-proposed for a minimum of 7 days.

** Changed in: sshuttle (Ubuntu Bionic)
   Status: In Progress => Fix Committed

** Tags added: verification-needed verification-needed-bionic

** Changed in: sshuttle (Ubuntu Xenial)
   Status: In Progress => Fix Committed

** Tags added: verification-needed-xenial

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1592853

Title:
  sshuttle doesn't autodetect python3 instead of 'python'

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/sshuttle/+bug/1592853/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1592853] Please test proposed package

2020-09-22 Thread Chris Halse Rogers
Hello Eric, or anyone else affected,

Accepted sshuttle into xenial-proposed. The package will build now and
be available at
https://launchpad.net/ubuntu/+source/sshuttle/0.76-1ubuntu1.1 in a few
hours, and then in the -proposed repository.

Please help us by testing this new package.  See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how
to enable and use -proposed.  Your feedback will aid us getting this
update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested, what testing has been
performed on the package and change the tag from verification-needed-
xenial to verification-done-xenial. If it does not fix the bug for you,
please add a comment stating that, and change the tag to verification-
failed-xenial. In either case, without details of your testing we will
not be able to proceed.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification .  Thank you in
advance for helping!

N.B. The updated package will be released to -updates after the bug(s)
fixed by this package have been verified and the package has been in
-proposed for a minimum of 7 days.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1592853

Title:
  sshuttle doesn't autodetect python3 instead of 'python'

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/sshuttle/+bug/1592853/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1873368] Re: ssshuttle server fails to connect endpoints with python 3.8

2020-09-22 Thread Chris Halse Rogers
Hello Dan, or anyone else affected,

Accepted sshuttle into bionic-proposed. The package will build now and
be available at
https://launchpad.net/ubuntu/+source/sshuttle/0.78.3-1ubuntu1.1 in a few
hours, and then in the -proposed repository.

Please help us by testing this new package.  See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how
to enable and use -proposed.  Your feedback will aid us getting this
update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested, what testing has been
performed on the package and change the tag from verification-needed-
bionic to verification-done-bionic. If it does not fix the bug for you,
please add a comment stating that, and change the tag to verification-
failed-bionic. In either case, without details of your testing we will
not be able to proceed.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification .  Thank you in
advance for helping!

N.B. The updated package will be released to -updates after the bug(s)
fixed by this package have been verified and the package has been in
-proposed for a minimum of 7 days.

** Changed in: sshuttle (Ubuntu Bionic)
   Status: In Progress => Fix Committed

** Tags added: verification-needed-bionic

** Changed in: sshuttle (Ubuntu Xenial)
   Status: In Progress => Fix Committed

** Tags added: verification-needed-xenial

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1873368

Title:
  ssshuttle server fails to connect endpoints with python 3.8

To manage notifications about this bug go to:
https://bugs.launchpad.net/sshuttle/+bug/1873368/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1873368] Please test proposed package

2020-09-22 Thread Chris Halse Rogers
Hello Dan, or anyone else affected,

Accepted sshuttle into xenial-proposed. The package will build now and
be available at
https://launchpad.net/ubuntu/+source/sshuttle/0.76-1ubuntu1.1 in a few
hours, and then in the -proposed repository.

Please help us by testing this new package.  See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how
to enable and use -proposed.  Your feedback will aid us getting this
update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested, what testing has been
performed on the package and change the tag from verification-needed-
xenial to verification-done-xenial. If it does not fix the bug for you,
please add a comment stating that, and change the tag to verification-
failed-xenial. In either case, without details of your testing we will
not be able to proceed.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification .  Thank you in
advance for helping!

N.B. The updated package will be released to -updates after the bug(s)
fixed by this package have been verified and the package has been in
-proposed for a minimum of 7 days.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1873368

Title:
  ssshuttle server fails to connect endpoints with python 3.8

To manage notifications about this bug go to:
https://bugs.launchpad.net/sshuttle/+bug/1873368/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896299] Re: remote requires netstat installed

2020-09-22 Thread Chris Halse Rogers
Hello Dan, or anyone else affected,

Accepted sshuttle into xenial-proposed. The package will build now and
be available at
https://launchpad.net/ubuntu/+source/sshuttle/0.76-1ubuntu1.1 in a few
hours, and then in the -proposed repository.

Please help us by testing this new package.  See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how
to enable and use -proposed.  Your feedback will aid us getting this
update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested, what testing has been
performed on the package and change the tag from verification-needed-
xenial to verification-done-xenial. If it does not fix the bug for you,
please add a comment stating that, and change the tag to verification-
failed-xenial. In either case, without details of your testing we will
not be able to proceed.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification .  Thank you in
advance for helping!

N.B. The updated package will be released to -updates after the bug(s)
fixed by this package have been verified and the package has been in
-proposed for a minimum of 7 days.

** Changed in: sshuttle (Ubuntu Xenial)
   Status: In Progress => Fix Committed

** Tags added: verification-needed verification-needed-xenial

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1896299

Title:
  remote requires netstat installed

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/sshuttle/+bug/1896299/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1870813] Re: Scilab does not start on bionic and focal

2020-09-22 Thread Tiago Stürmer Daitx
** Description changed:

  [Impact]
  Scilab does not start. This is a regression from an OpenJDK 11 update.
  
  SRU TEAM: please note that scilab runs OpenJDK 8 and since Bionic we have 
been forcing it to use OpenJDK 11 (see bug 1814133). Since the last Bionic and 
Focal update there have been fixes from both upstream and Debian to improve 
compatibility. Apart from those fixes I would like to bring additional fixes to 
our LTS releases and align them better with the one on Groovy (which works 
fine):
  * improved dependencies
  * appdata/desktop fixes to improve user experience
  * update from 6.0.1 to 6.0.2 in Bionic
- 
  
  [Test Case]
  On Bionic or Focal:
  
  Steps to reproduce:
  1. Install Scilab with `sudo apt-get install scilab`
  2. Try to launch Scilab from terminal by using command `scilab`
  
  Expected results:
  * Scilab started normally
  
  Actual results:
  * Scilab does not start, shows the following output in the terminal:
  
  $ scilab
  Picked up _JAVA_OPTIONS: 
-Djava.class.path=/usr/share/java/flexdock.jar:/usr/share/java/skinlf.jar:/usr/share/java/looks.jar:/usr/share/java/commons-logging.jar:/usr/share/java/jhall.jar:/usr/share/java/lucene-core-4.10.4.jar:/usr/share/java/lucene-analyzers-common-4.10.4.jar:/usr/share/java/lucene-queryparser-4.10.4.jar:/usr/share/maven-repo/org/freehep/freehep-util/debian/freehep-util-debian.jar:/usr/share/maven-repo/org/freehep/freehep-io/debian/freehep-io-debian.jar:/usr/share/maven-repo/org/freehep/freehep-graphicsio/debian/freehep-graphicsio-debian.jar:/usr/share/java/freehep-graphicsio-emf-2.1.jar:/usr/share/java/freehep-graphics2d-2.1.1.jar:/usr/share/java/jrosetta-API.jar:/usr/share/java/jrosetta-engine-1.0.4.jar:/usr/share/java/jgraphx.jar:/usr/share/java/jogl2.jar:/usr/share/java/gluegen2-rt.jar:/usr/share/java/jeuclid-core.jar:/usr/share/java/jlatexmath-fop-1.0.7.jar:/usr/share/java/fop.jar:/usr/share/java/saxon.jar:/usr/share/java/batik.jar:/usr/share/java/xml-apis-ext.jar:/usr/share/java/commons-io.jar:/usr/share/java/xmlgraphics-commons.jar:/usr/share/java/avalon-framework.jar:/usr/share/java/jlatexmath-1.0.7.jar:/usr/share/java/ecj.jar:/usr/share/java/javax.activation.jar:/usr/share/java/jaxb-runtime.jar:/usr/share/scilab/modules/jvm/jar/org.scilab.modules.jvm.jar:/usr/share/scilab/modules/completion/jar/org.scilab.modules.completion.jar:/usr/share/scilab/modules/graphic_export/jar/org.scilab.modules.graphic_export.jar:/usr/share/scilab/modules/external_objects_java/tests/libintl.jar:/usr/share/scilab/modules/external_objects_java/jar/org.scilab.modules.external_objects_java.jar:/usr/share/scilab/modules/scirenderer/jar/scirenderer.jar:/usr/share/scilab/modules/action_binding/jar/org.scilab.modules.action_binding.jar:/usr/share/scilab/modules/history_manager/jar/org.scilab.modules.history_manager.jar:/usr/share/scilab/modules/console/jar/org.scilab.modules.console.jar:/usr/share/scilab/modules/graphic_objects/jar/org.scilab.modules.graphic_objects.jar:/usr/share/scilab/modules/xcos/jar/org.scilab.modules.xcos.jar:/usr/share/scilab/modules/commons/jar/org.scilab.modules.commons.jar:/usr/share/scilab/modules/graph/jar/org.scilab.modules.graph.jar:/usr/share/scilab/modules/gui/jar/org.scilab.modules.gui.jar:/usr/share/scilab/modules/renderer/jar/org.scilab.modules.renderer.jar:/usr/share/scilab/modules/helptools/jar/scilab_ja_JP_help.jar:/usr/share/scilab/modules/helptools/jar/scilab_fr_FR_help.jar:/usr/share/scilab/modules/helptools/jar/scilab_pt_BR_help.jar:/usr/share/scilab/modules/helptools/jar/scilab_ru_RU_help.jar:/usr/share/scilab/modules/helptools/jar/scilab_en_US_help.jar:/usr/share/scilab/modules/helptools/jar/scilab_images.jar:/usr/share/scilab/modules/helptools/jar/org.scilab.modules.helptools.jar:/usr/share/scilab/modules/types/jar/org.scilab.modules.types.jar:/usr/share/scilab/modules/localization/jar/org.scilab.modules.localization.jar:/usr/share/scilab/modules/javasci/jar/org.scilab.modules.javasci.jar:/usr/share/scilab/modules/preferences/jar/org.scilab.modules.preferences.jar:/usr/share/scilab/modules/core/jar/org.scilab.modules.core.jar:/usr/share/scilab/modules/history_browser/jar/org.scilab.modules.history_browser.jar:/usr/share/scilab/modules/ui_data/jar/org.scilab.modules.ui_data.jar:/usr/share/scilab/modules/scinotes/jar/org.scilab.modules.scinotes.jar:
  WARNING: An illegal reflective access operation has occurred
  WARNING: Illegal reflective access by org.scilab.modules.jvm.LibraryPath 
(file:/usr/share/scilab/modules/jvm/jar/org.scilab.modules.jvm.jar) to field 
java.lang.ClassLoader.sys_paths
  WARNING: Please consider reporting this to the maintainers of 
org.scilab.modules.jvm.LibraryPath
  WARNING: Use --illegal-access=warn to enable warnings of further illegal 
reflective access operations
  WARNING: All illegal access operations will be denied in a future release
  Could not access to the Main Scilab Class:
  Exception in thread "main" java.lang.ExceptionInInitializerError
   at 

[Bug 1886854] Re: Race in load-module snap policy check in classic confinement

2020-09-22 Thread Ubuntu Foundations Team Bug Bot
The attachment "allow-classic.diff" seems to be a patch.  If it isn't,
please remove the "patch" flag from the attachment, remove the "patch"
tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the
team.

[This is an automated message performed by a Launchpad user owned by
~brian-murray, for any issues please contact him.]

** Tags added: patch

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1886854

Title:
  Race in load-module snap policy check in classic confinement

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1886854/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896538] Re: [X555UB, Realtek ALC256, Speaker, Internal] Playback problem

2020-09-22 Thread Daniel Letzeisen
*** This bug is a duplicate of bug 1896539 ***
https://bugs.launchpad.net/bugs/1896539

** This bug has been marked a duplicate of bug 1896539
   [X555UB, Realtek ALC256, Speaker, Internal] Playback problem

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1896538

Title:
  [X555UB, Realtek ALC256, Speaker, Internal] Playback problem

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+bug/1896538/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1329357] Re: package libktoblzcheck1c2a 1.39-1 failed to install/upgrade: el paquete libktoblzcheck1c2a no está listo para configurarse no se puede configurar (estado actual `half-installed')

2020-09-22 Thread Launchpad Bug Tracker
[Expired for libktoblzcheck (Ubuntu) because there has been no activity
for 60 days.]

** Changed in: libktoblzcheck (Ubuntu)
   Status: Incomplete => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1329357

Title:
  package libktoblzcheck1c2a 1.39-1 failed to install/upgrade: el
  paquete libktoblzcheck1c2a no está listo para configurarse  no se
  puede configurar (estado actual `half-installed')

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libktoblzcheck/+bug/1329357/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1887179] Re: can't update to newer version

2020-09-22 Thread Launchpad Bug Tracker
[Expired for ubuntu-release-upgrader (Ubuntu) because there has been no
activity for 60 days.]

** Changed in: ubuntu-release-upgrader (Ubuntu)
   Status: Incomplete => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1887179

Title:
  can't update to newer version

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+bug/1887179/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1887426] Re: "Error on do-release-upgrade -d 18.04 to 20.04 (mixed destop & server)"

2020-09-22 Thread Launchpad Bug Tracker
[Expired for ubuntu-release-upgrader (Ubuntu) because there has been no
activity for 60 days.]

** Changed in: ubuntu-release-upgrader (Ubuntu)
   Status: Incomplete => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1887426

Title:
  "Error on do-release-upgrade -d 18.04 to 20.04 (mixed destop &
  server)"

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+bug/1887426/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896717] [NEW] [FFE] notcurses 1.7.4 for ubuntu 20.10

2020-09-22 Thread nick black
Public bug reported:

Hello. I'd like to request a Feature Freeze Exception for 20.10 per the
instructions at
https://wiki.ubuntu.com/FreezeExceptionProcess#FeatureFreeze_for_new_upstream_versions.

Ubuntu 20.10 currently has notcurses 1.7.0, imported directly from
Debian (where I'm the maintainer, as well as the upstream author). This
is a kinda unfortunate pick; it has two annoying (though not
grave/serious) bugs, but more importantly lacks the recent 1.7.x API
changes, pursuant to 2.0 (to be released next month).

All year, I've claimed that Notcurses would commit to backwards
compatibility and API stability starting with the 2.0 release, and
retained free right to mutate the API until then. 1.7.4 (currently
available in Debian/Fedora/Arch) is the last expected release prior to
2.0. Its API is thus expected to be equal to the final, stable 2.0 API.
By importing 1.7.4 to 20.10, 20.10 will ship with the same API other
distros (and newer versions of Ubuntu) will be implementing. Given that
20.10 is the first Ubuntu to contain Notcurses, this means a sweetly
unified surface across all distros.

I have prepared a 1.7.4 for Ubuntu 20.10, and can upload it under the
Sponsorship Process. The 1.7.4 packages are available via
https://www.dsscaw.com/repos/apt/ubuntu/.

Testing: install the notcurses-bin package and run `notcurses-demo`. It
works fine. There's also an `autopkgtest` file in the `debian/` folder.
I'll attach the pbuilder output shortly.

Diff of upstream NEWS.md:

* 1.7.4 (2020-09-20)
  * All `_rgb_clipped()` functions have been renamed `_rgb8_clipped()`, to
match the changes made in 1.7.2. Sorry, I ought have done this before.
  * `ncplane_create()` has been introduced, taking a `struct ncplane_options`
parameter. This replaces `ncplane_aligned()`, and will replace
`ncplane_new()`. The latter ought be considered deprecated, and will be
removed in the future. To align a place as previously done with
`ncplane_aligned()`, use the `NCPLANE_OPTION_HORALIGNED` flag.
  * The `ncplane_options` struct includes a function pointer member,
`resizecb`. If not `NULL`, this function will be called after the parent
plane is resized. See `notcurses_plane.3` for more information.
  * `ncplane_resize_realign()` has been added, suitable for use as a
`resizecb`. It realigns the plane against its parent.
  * `NCCHANNEL_ALPHA_MASK` has been renamed `CHANNEL_ALPHA_MASK`, to match
the other declarations.

* 1.7.3 (2020-09-19)
  * API changes pursuant to 2.0 API finalization:
  * `mbswidth()` has been renamed `ncstrwidth()`.
  * The long-promised/dreaded Great Widget Review, normalizing behavior across
all widgets, has been effected. Sorry, there was no getting around this
one. Pretty much all widgets have slightly changed, because pretty much all
widgets previously behaved slightly differently:
 * `ncselector_create()` and `ncmultiselector_create()` now take ownership
   of the provided `ncplane`. On an error in these functions, the `ncplane`
   will be destroyed. Otherwise, the `ncplane` is destroyed by
   `ncselector_destroy()` or `ncmultiselector_destroy()`.
 * `ncselector_create()`, `ncmultiselector_create()`, and
   `ncreader_create()` no longer accept `int y, int x` placement
   parameters. Just place the `ncplane`.
 * `ncselector_options`, `ncmultiselector_options`, and `ncreel_options`
   have lost their `bgchannels` members. Just set the base character for
   the `ncplane`.
 * `ncreader_options` has lost its `echannels`, `eattrword`, `egc`,
   `physrows`, and `physcols` fields. Just set the base character and size
   for the `ncplane`.
  * Functions which set a 24-bit RGB value have had the suffix `g` replaced
with `g_rgb`. Functions which set three 8-bit RGB components have had the
suffix `rgb` replaced with `rgb8`. This was done because e.g.
`channels_set_fg()` and `channels_set_fchannel()` were indistinguishable on
sight. Failure to make the necessary conversions will result in compiler
errors. See https://github.com/dankamongmen/notcurses/issues/985.
  * Functions ending in `_stainable()` now end in `_stained()`.
  * `ncplane_putwc_stained()` and `ncplane_putwstr_stained()` have been
added in the interest of orthogonality.
  * `ncplane_new_named()` has been eliminated. `ncplane_new()` now takes a
`const char* name` argument. `ncplane_bound()` and `ncplane_bound_named()`
have both been eliminated. `ncplane_new()` now accepts an `ncplane*`
   instead of a `notcurses*`. All functionality exposed by the removed
functions is thus now present in `ncplane_new()`.
  * `ncplane_aligned_named()` has been removed. `ncplane_aligned()` now accepts
a `const char* name` argument.

* 1.7.2 (2020-09-09)
  * Exported `ncvisual_default_blitter()`, so that the effective value of
`NCBLIT_DEFAULT` can be determined.
  * Added `NCREADER_OPTION_CURSOR`, instructing the `ncreader` to make the
 

[Bug 1885527] Re: cloud-init regenerating ssh-keys

2020-09-22 Thread Launchpad Bug Tracker
[Expired for cloud-init (Ubuntu) because there has been no activity for
60 days.]

** Changed in: cloud-init (Ubuntu)
   Status: Incomplete => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1885527

Title:
  cloud-init regenerating ssh-keys

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cloud-init/+bug/1885527/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1888778] Re: LOTRO crashes on launch gnome-shell Jul 23 21:08:36 Window manager warning: Invalid WM_TRANSIENT_FOR window 0x4200007 specified for 0x4200008 (LotroLaunc).

2020-09-22 Thread Launchpad Bug Tracker
[Expired for Ubuntu because there has been no activity for 60 days.]

** Changed in: ubuntu
   Status: Incomplete => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1888778

Title:
  LOTRO crashes on launch gnome-shell Jul 23 21:08:36 Window manager
  warning: Invalid WM_TRANSIENT_FOR window 0x427 specified for
  0x428 (LotroLaunc).

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+bug/1888778/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1888523] Re: PCIe Bus Error device 8086:a298 spam

2020-09-22 Thread Launchpad Bug Tracker
[Expired for linux (Ubuntu) because there has been no activity for 60
days.]

** Changed in: linux (Ubuntu)
   Status: Incomplete => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1888523

Title:
  PCIe Bus Error device 8086:a298 spam

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1888523/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1877000] Re: openjfx is missing native libraries for webkit and media

2020-09-22 Thread Tiago Stürmer Daitx
** Also affects: openjfx (Ubuntu Focal)
   Importance: Undecided
   Status: New

** Changed in: openjfx (Ubuntu Focal)
   Status: New => Confirmed

** Changed in: openjfx (Ubuntu Focal)
   Importance: Undecided => Medium

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1877000

Title:
  openjfx is missing native libraries for webkit and media

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openjfx/+bug/1877000/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896716] Re: [SRU][OEM-5.6]Fix AMD system hang after re-plugin USBC-DP dongle

2020-09-22 Thread AaronMa
** Tags added: oem-priority originate-from-1895223 sutton

** Changed in: hwe-next
   Status: New => In Progress

** Changed in: hwe-next
   Importance: Undecided => Critical

** Changed in: hwe-next
 Assignee: (unassigned) => AaronMa (mapengyu)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1896716

Title:
  [SRU][OEM-5.6]Fix AMD system hang after re-plugin USBC-DP dongle

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/1896716/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1785060] Re: Evince cannot open cbr-files based on rar v5

2020-09-22 Thread linuxcub
"Expired" is a bad change! With Ubuntu 18.04 I could read any CBR file with 
Evince. Just installed Ubuntu 20.04 and Evince cannot do it any more!
I have a workaroud, but is this necessary to install Kubuntu's okular? These 
are quite some packages!
Does "expired" mean, I will never be able to read some CBR files with evince?

Thanks, siggi2

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1785060

Title:
  Evince cannot open cbr-files based on rar v5

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/evince/+bug/1785060/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896716] [NEW] [SRU][OEM-5.6]Fix AMD system hang after re-plugin USBC-DP dongle

2020-09-22 Thread AaronMa
Public bug reported:

[Impact]
After much times of re-plug USBC-DP dongle with external monitor,
AMD laptop will hang.

[Fix]
AMD GPU driver set the wrong link setting to DP port.
After initialize the DP setting, DP works fine.

[Test Case]
Verified on the target platform. no hang again.

[Regression Potential]
Low,
Upstream fix in 5.7 kernel, Verified with positive results.
Groovy already got this fix.

** Affects: linux-oem-5.6 (Ubuntu)
 Importance: Critical
 Status: In Progress

** Affects: linux-oem-5.6 (Ubuntu Focal)
 Importance: Critical
 Status: In Progress

** Also affects: linux-oem-5.6 (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Focal)
   Importance: Undecided
   Status: New

** Also affects: linux-oem-5.6 (Ubuntu Focal)
   Importance: Undecided
   Status: New

** Changed in: linux (Ubuntu Focal)
   Status: New => Invalid

** No longer affects: linux (Ubuntu)

** No longer affects: linux (Ubuntu Focal)

** Changed in: linux-oem-5.6 (Ubuntu Focal)
   Status: New => In Progress

** Changed in: linux-oem-5.6 (Ubuntu)
   Status: New => In Progress

** Changed in: linux-oem-5.6 (Ubuntu)
   Importance: Undecided => Critical

** Changed in: linux-oem-5.6 (Ubuntu Focal)
   Importance: Undecided => Critical

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1896716

Title:
  [SRU][OEM-5.6]Fix AMD system hang after re-plugin USBC-DP dongle

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux-oem-5.6/+bug/1896716/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1893624] Re: Ryzen 4800u, kernel 5.8.5 boot errors (AMD-Vi, ACPI, HDCP, Bluetooth)

2020-09-22 Thread Dehuan Xin
[6.146732] [drm:mod_hdcp_add_display_to_topology [amdgpu]] *ERROR*
Failed to add display topology, DTM TA is not initialized.

I'm also seeing this error on 5.8.0-19-generic kernel.
It's ThinkPad T14 gen1 device with 4750u CPU/GPU with HDMI display connected to 
the USB-C dock.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1893624

Title:
  Ryzen 4800u, kernel 5.8.5 boot errors (AMD-Vi, ACPI, HDCP, Bluetooth)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1893624/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1877000] Re: openjfx is missing native libraries for webkit and media

2020-09-22 Thread Launchpad Bug Tracker
This bug was fixed in the package openjfx - 11.0.7+0-5ubuntu1

---
openjfx (11.0.7+0-5ubuntu1) groovy; urgency=low

  * Merge from Debian unstable. Dropped python2 dependency.
  * debian/rules: when building arch and indep packages simultaneously (as
done in Ubuntu builders) the file gradle.properties copied in
override_dh_auto_configure-arch will be overwritten by
override_dh_auto_configure-indep preventing native libraries for media
and webkit from being build. (LP: #1877000)
  * Remove/revert patch to force NUM_COMPILE_THREADS=1.

openjfx (11.0.7+0-5) unstable; urgency=medium

  * Team upload.
  * Mark GST_API symbols as external. Closes: #969260.
  * Fix jsmin stream handling with Python 3.

openjfx (11.0.7+0-4) unstable; urgency=medium

  * Team upload.
  * Force NUM_COMPILE_THREADS=1

openjfx (11.0.7+0-3) unstable; urgency=medium

  * Team upload.
  * Build-depend on python3 (Closes: #937202, #967185)

openjfx (11.0.7+0-2ubuntu1) focal; urgency=medium

  * Merge with Debian; remaining changes:
- Build using python2.

openjfx (11.0.7+0-2) unstable; urgency=medium

  * Disable the Gradle version check when building only the arch all package
(Closes: #956585)
  * Enable the WebKit JIT on arm64

openjfx (11.0.7+0-1) unstable; urgency=medium

  * New upstream release
- Refreshed the patches
- Build depend on antlr4 instead of antlr3
- Fixed the compatibility with the version of Gradle in Debian
  * Standards-Version updated to 4.5.0

 -- Tiago Stürmer Daitx   Tue, 22 Sep 2020
21:05:26 +

** Changed in: openjfx (Ubuntu)
   Status: Confirmed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1877000

Title:
  openjfx is missing native libraries for webkit and media

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openjfx/+bug/1877000/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896714] [NEW] Use DIB Building Guest Images for OpenStack Trove

2020-09-22 Thread zhangss
Public bug reported:

Use DIB to Building Guest Images for OpenStack Trove failed.

export 
ELEMENTS_PATH=/root/tripleo-image-elements/elements:/root/trove-guest-image-elements/elements:/root/diskimage-builder/diskimage_builder/elements:/root/trove/integration/scripts/files/elements
export DISTRO="ubuntu"
export SERVICE_TYPE="mysql"
export DIB_CLOUD_INIT_DATASOURCES="ConfigDrive"
export DIB_APT_CONF_DIR=/etc/apt/apt.conf.d
export DIB_CLOUD_INIT_ETC_HOSTS=true
export QEMU_IMG_OPTIONS="--qemu-img-options compat=1.1"

(.venv) root@ubun16:~# ls /root/diskimage-builder/diskimage_builder/elements/
Display all 113 possibilities? (y or n)
(.venv) root@ubun16:~# ls 
/root/diskimage-builder/diskimage_builder/elements/ubuntu
ubuntu/   ubuntu-common/ubuntu-minimal/   
ubuntu-signed/ubuntu-systemd-container/
(.venv) root@ubun16:~# ls 
/root/diskimage-builder/diskimage_builder/elements/ubuntu/
element-deps  element-provides  environment.d  install.d  package-installs.yaml 
 pre-install.d  README.rst  root.d  test-elements
(.venv) root@ubun16:~# ls /root/diskimage-builder/diskimage_builder/elements/vm
element-deps  finalise.d  README.rst
(.venv) root@ubun16:~# ls 
/root/diskimage-builder/diskimage_builder/elements/cloud-init-datasources
install.d  README.rst
(.venv) root@ubun16:~# ls trove/integration/scripts/files/elements/ubuntu-guest
extra-data.d  install.d  post-install.d  pre-install.d
(.venv) root@ubun16:~# ls trove/integration/scripts/files/elements/ubuntu-mysql
pre-install.d
 
When I execute following command ,that report build failed.
openstack version is stein,build trove image in ubuntu 16.04,disk-image-build 
version is 3.3.1.
The link to the reference document is:
https://docs.openstack.org/trove/stein/admin/building_guest_images.html.

disk-image-create -a amd64 -o
"trove-${DISTRO}-${SERVICE_TYPE}-dev.qcow2" -x ${QEMU_IMG_OPTIONS}
${DISTRO} vm cloud-init-datasources ${DISTRO}-guest
${DISTRO}-${SERVICE_TYPE}

..
2020-09-23 03:14:06.946 | ++ export DISTRO_NAME=ubuntu
2020-09-23 03:14:06.946 | ++ DISTRO_NAME=ubuntu
2020-09-23 03:14:06.946 | ++ export DIB_RELEASE=bionic
2020-09-23 03:14:06.946 | ++ DIB_RELEASE=bionic
2020-09-23 03:14:06.946 | ++ export DIB_DEBIAN_COMPONENTS=main,universe
2020-09-23 03:14:06.946 | ++ DIB_DEBIAN_COMPONENTS=main,universe
2020-09-23 03:14:06.946 | ++ ARCH=amd64
2020-09-23 03:14:06.946 | ++ [[ arm64 armhf powerpc ppc64el s390x =~ amd64 ]]
2020-09-23 03:14:06.946 | ++ 
default_ubuntu_mirror=http://archive.ubuntu.com/ubuntu
2020-09-23 03:14:06.946 | ++ export 
DIB_DISTRIBUTION_MIRROR=http://archive.ubuntu.com/ubuntu
2020-09-23 03:14:06.946 | ++ 
DIB_DISTRIBUTION_MIRROR=http://archive.ubuntu.com/ubuntu
2020-09-23 03:14:06.946 | dib-run-parts Sourcing environment file 
/tmp/dib_build.shmG24Ae/hooks/extra-data.d/../environment.d/11-dib-install-type.bash
2020-09-23 03:14:06.948 | + source 
/tmp/dib_build.shmG24Ae/hooks/extra-data.d/../environment.d/11-dib-install-type.bash
2020-09-23 03:14:06.948 | ++ export DIB_DEFAULT_INSTALLTYPE=source
2020-09-23 03:14:06.948 | ++ DIB_DEFAULT_INSTALLTYPE=source
2020-09-23 03:14:06.948 | dib-run-parts Sourcing environment file 
/tmp/dib_build.shmG24Ae/hooks/extra-data.d/../environment.d/11-ubuntu-init-system.bash
2020-09-23 03:14:06.950 | + source 
/tmp/dib_build.shmG24Ae/hooks/extra-data.d/../environment.d/11-ubuntu-init-system.bash
2020-09-23 03:14:06.950 | ++ [[ bionic == \t\r\u\s\t\y ]]
2020-09-23 03:14:06.950 | ++ export DIB_INIT_SYSTEM=systemd
2020-09-23 03:14:06.950 | ++ DIB_INIT_SYSTEM=systemd
2020-09-23 03:14:06.950 | dib-run-parts Sourcing environment file 
/tmp/dib_build.shmG24Ae/hooks/extra-data.d/../environment.d/14-manifests
2020-09-23 03:14:06.952 | + source 
/tmp/dib_build.shmG24Ae/hooks/extra-data.d/../environment.d/14-manifests
2020-09-23 03:14:06.952 | ++ export DIB_MANIFEST_IMAGE_DIR=/etc/dib-manifests
2020-09-23 03:14:06.952 | ++ DIB_MANIFEST_IMAGE_DIR=/etc/dib-manifests
2020-09-23 03:14:06.952 | ++ export 
DIB_MANIFEST_SAVE_DIR=trove-ubuntu-mysql-dev.d/
2020-09-23 03:14:06.953 | ++ DIB_MANIFEST_SAVE_DIR=trove-ubuntu-mysql-dev.d/
2020-09-23 03:14:06.953 | dib-run-parts Sourcing environment file 
/tmp/dib_build.shmG24Ae/hooks/extra-data.d/../environment.d/15-block-device.bash
2020-09-23 03:14:06.955 | + source 
/tmp/dib_build.shmG24Ae/hooks/extra-data.d/../environment.d/15-block-device.bash
2020-09-23 03:14:06.955 | ++ [[ arm64 aarch64 =~ amd64 ]]
2020-09-23 03:14:06.955 | ++ export DIB_BLOCK_DEVICE=mbr
2020-09-23 03:14:06.955 | ++ DIB_BLOCK_DEVICE=mbr
2020-09-23 03:14:06.955 | dib-run-parts Sourcing environment file 
/tmp/dib_build.shmG24Ae/hooks/extra-data.d/../environment.d/99-cloud-init-datasources.bash
2020-09-23 03:14:06.957 | + source 
/tmp/dib_build.shmG24Ae/hooks/extra-data.d/../environment.d/99-cloud-init-datasources.bash
2020-09-23 03:14:06.957 | ++ export DIB_CLOUD_INIT_DATASOURCES=ConfigDrive
2020-09-23 03:14:06.957 | ++ DIB_CLOUD_INIT_DATASOURCES=ConfigDrive

[Bug 1873368] Re: ssshuttle server fails to connect endpoints with python 3.8

2020-09-22 Thread Chris Halse Rogers
Hello Dan, or anyone else affected,

Accepted sshuttle into focal-proposed. The package will build now and be
available at
https://launchpad.net/ubuntu/+source/sshuttle/0.78.5-1ubuntu1.1 in a few
hours, and then in the -proposed repository.

Please help us by testing this new package.  See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how
to enable and use -proposed.  Your feedback will aid us getting this
update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested, what testing has been
performed on the package and change the tag from verification-needed-
focal to verification-done-focal. If it does not fix the bug for you,
please add a comment stating that, and change the tag to verification-
failed-focal. In either case, without details of your testing we will
not be able to proceed.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification .  Thank you in
advance for helping!

N.B. The updated package will be released to -updates after the bug(s)
fixed by this package have been verified and the package has been in
-proposed for a minimum of 7 days.

** Changed in: sshuttle (Ubuntu Focal)
   Status: In Progress => Fix Committed

** Tags removed: verification-failed-focal
** Tags added: verification-needed verification-needed-focal

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1873368

Title:
  ssshuttle server fails to connect endpoints with python 3.8

To manage notifications about this bug go to:
https://bugs.launchpad.net/sshuttle/+bug/1873368/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896073] Re: SRU the current 2.3.6 stable update

2020-09-22 Thread Chris Halse Rogers
This doesn't really seem to be a bugfix only release? It's not clear to
me how introducing a new “tracker export” command is a bugfix - I could
be persuaded of this, as it sounds from the NEWS item that it might be
required for future upgrades?

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1896073

Title:
  SRU the current 2.3.6 stable update

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/tracker/+bug/1896073/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1798998] Re: Plank Doesnt Update on When Apps are Opened

2020-09-22 Thread funicorn
I use Ubuntu 20.04 in ubuntu:gnome-session. With the gnome-shell
extension named pixel-saver which integrates APP title-bar into the
gnome-shell dock enabled, plank won't show up when some APP is started
up. I have to switch to another APP to activate it.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1798998

Title:
  Plank Doesnt Update on When Apps are Opened

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntubudgie/+bug/1798998/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1872401] Re: vmx_nm_test in ubuntu_kvm_unit_tests interrupted on X-oracle-4.15 / X-KVM / B-KVM

2020-09-22 Thread Po-Hsu Lin
This is affecting the autovm# on Intel Cloud, node will be "PAUSED" when
hitting this issue.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1872401

Title:
  vmx_nm_test in ubuntu_kvm_unit_tests interrupted on X-oracle-4.15 /
  X-KVM / B-KVM

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-kernel-tests/+bug/1872401/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1893752] Re: Get the extended DPCD according to the related field in the DPCD registers.

2020-09-22 Thread koba
** Tags added: originate-from-1891458

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1893752

Title:
  Get the extended DPCD according to the related field in the DPCD
  registers.

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/1893752/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1873037] Re: autotalent plugin for audacity fails to load

2020-09-22 Thread Erich Eickmeyer
If that's the case, then the bug has been fixed in Audacity.
Unfortunately, there's no way of knowing which bug it is in order to do
a proper patch/backport unless someone can chime-in.

However, we'll need a new bug report since the OP is unable to reproduce
this bug on their current environment, and since proper bug information
was not gathered. Therefore, I'm removing this bug as affecting Audacity
and marking as invalid for autotalent.

@job-a-gorree, if you could possibly post a new bug by typing 'ubuntu-
bug audacity' in a terminal in order to collect the proper debugging
information, that would be great.

** No longer affects: audacity (Ubuntu)

** Changed in: autotalent (Ubuntu)
   Status: Won't Fix => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1873037

Title:
  autotalent plugin for audacity fails to load

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/autotalent/+bug/1873037/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1887142] Re: pdfsam won't run, has missing and conflicting dependencies

2020-09-22 Thread Launchpad Bug Tracker
This bug was fixed in the package pdfsam - 4.0.4-1ubuntu1

---
pdfsam (4.0.4-1ubuntu1) groovy; urgency=medium

  * Add dependency on el-api and libtomcat9-java, require newer
libsejda-java and libhibernate-validator-java. (LP: #1887142)

 -- Tiago Stürmer Daitx   Wed, 23 Sep 2020
00:40:25 +

** Changed in: pdfsam (Ubuntu)
   Status: Confirmed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1887142

Title:
  pdfsam won't run, has missing and conflicting dependencies

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libhibernate-validator-java/+bug/1887142/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1892783] Re: [SRU] libreoffice 6.4.6 for focal

2020-09-22 Thread Chris Halse Rogers
I see the AMD64 autopkgtests listed there have a failure due to timeout
on uitest-sw, but
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac
/autopkgtest-
focal/focal/amd64/libr/libreoffice/20200905_235254_13bfb@/log.gz appears
to have passed, so this is probably flaky, or at least a likely victim
of timeout under resource contention?

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1892783

Title:
  [SRU] libreoffice 6.4.6 for focal

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1892783/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896699] Re: Mounting a share in fstab fails with BAD_NETWORK_NAME

2020-09-22 Thread Chris Guiver
Thank you for taking the time to report this bug and helping to make
Ubuntu better.

Bug reporting is mostly about finding & fixing problems thus preventing
future users from hitting the same bug.

I suspect a Support site would be more appropriate, eg.
https://answers.launchpad.net/ubuntu. You can also find help with your
problem in the support forum of your local Ubuntu community
http://loco.ubuntu.com/ or asking at https://askubuntu.com or
https://ubuntuforums.org, or for more support options please look at
https://discourse.ubuntu.com/t/community-support/709

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1896699

Title:
  Mounting a share in fstab fails with BAD_NETWORK_NAME

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1896699/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896708] [NEW] [Infoway, Realtek ALC268, Speaker, Internal] No sound at all

2020-09-22 Thread Vitor Vecchi de Oliveira
Public bug reported:

Welcome to Linux Lite 4.8 vec
 
terça 22 setembro 2020, 23:24:41
Memory Usage: 1949/2992MB (65.14%)
Disk Usage: 19/22GB (91%)
Support - https://www.linuxliteos.com/forums/ (Right click, Open Link)
 
 vec  ~  pacmd
Welcome to PulseAudio 11.1! Use "help" for usage information.
>>> list-sinks
1 sink(s) available.
  * index: 0
name: 
driver: 
flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY 
DYNAMIC_LATENCY
state: RUNNING
suspend cause: 
priority: 9039
volume: front-left: 58327 /  89% / -3,04 dB,   front-right: 58327 /  
89% / -3,04 dB
balance 0,00
base volume: 65536 / 100% / 0,00 dB
volume steps: 65537
muted: no
current latency: 18,42 ms
max request: 3 KiB
max rewind: 64 KiB
monitor source: 0
sample spec: s16le 2ch 44100Hz
channel map: front-left,front-right
 Estéreo
used by: 1
linked by: 13
configured latency: 18,75 ms; range is 0,50 .. 371,52 ms
card: 0 
module: 6
properties:
alsa.resolution_bits = "16"
device.api = "alsa"
device.class = "sound"
alsa.class = "generic"
alsa.subclass = "generic-mix"
alsa.name = "ALC268 Analog"
alsa.id = "ALC268 Analog"
alsa.subdevice = "0"
alsa.subdevice_name = "subdevice #0"
alsa.device = "0"
alsa.card = "0"
alsa.card_name = "HDA Intel"
alsa.long_card_name = "HDA Intel at 0xf450 irq 28"
alsa.driver_name = "snd_hda_intel"
device.bus_path = "pci-:00:1b.0"
sysfs.path = "/devices/pci:00/:00:1b.0/sound/card0"
device.bus = "pci"
device.vendor.id = "8086"
device.vendor.name = "Intel Corporation"
device.product.id = "284b"
device.product.name = "82801H (ICH8 Family) HD Audio Controller"
device.form_factor = "internal"
device.string = "front:0"
device.buffering.buffer_size = "65536"
device.buffering.fragment_size = "32768"
device.access_mode = "mmap+timer"
device.profile.name = "analog-stereo"
device.profile.description = "Estéreo analógico"
device.description = "Áudio interno Estéreo analógico"
alsa.mixer_name = "Realtek ALC268"
alsa.components = "HDA:10ec0268,2f111509,0013 
HDA:14f12bfa,14f10001,0009"
module-udev-detect.discovered = "1"
device.icon_name = "audio-card-pci"
ports:
analog-output-speaker: Alto-falantes (priority 1, latency 
offset 0 usec, available: unknown)
properties:
device.icon_name = "audio-speakers"
analog-output-headphones: Fones de ouvidos (priority 9000, 
latency offset 0 usec, available: no)
properties:
device.icon_name = "audio-headphones"
active port: 
>>> 


Welcome to Linux Lite 4.8 vec
 
terça 22 setembro 2020, 23:25:29
Memory Usage: 1981/2992MB (66.21%)
Disk Usage: 19/22GB (91%)
Support - https://www.linuxliteos.com/forums/ (Right click, Open Link)
 
 vec  ~  sudo aplay -l
[sudo] senha para vec: 
 Lista de Dispositivos PLAYBACK Hardware 
placa 0: Intel [HDA Intel], dispositivo 0: ALC268 Analog [ALC268 Analog]
  Dispositivo secundário: 0/1
  Dispositivo secundário #0: subdevice #0
placa 0: Intel [HDA Intel], dispositivo 1: ALC268 Digital [ALC268 Digital]
  Dispositivo secundário: 1/1
  Dispositivo secundário #0: subdevice #0
 vec  ~  


Welcome to Linux Lite 4.8 vec
 
terça 22 setembro 2020, 23:26:41
Memory Usage: 1990/2992MB (66.51%)
Disk Usage: 19/22GB (91%)
Support - https://www.linuxliteos.com/forums/ (Right click, Open Link)
 
 vec  ~  find /lib/modules/`uname -r` | grep snd
/lib/modules/4.15.0-76-generic/kernel/sound/isa/sb/snd-sb-common.ko
/lib/modules/4.15.0-76-generic/kernel/sound/hda/ext/snd-hda-ext-core.ko
/lib/modules/4.15.0-76-generic/kernel/sound/hda/snd-hda-core.ko
/lib/modules/4.15.0-76-generic/kernel/sound/i2c/snd-i2c.ko
/lib/modules/4.15.0-76-generic/kernel/sound/i2c/other/snd-ak4117.ko
/lib/modules/4.15.0-76-generic/kernel/sound/i2c/other/snd-ak4xxx-adda.ko
/lib/modules/4.15.0-76-generic/kernel/sound/i2c/other/snd-ak4113.ko
/lib/modules/4.15.0-76-generic/kernel/sound/i2c/other/snd-ak4114.ko
/lib/modules/4.15.0-76-generic/kernel/sound/i2c/other/snd-pt2258.ko
/lib/modules/4.15.0-76-generic/kernel/sound/i2c/snd-cs8427.ko
/lib/modules/4.15.0-76-generic/kernel/sound/soc/snd-soc-core.ko
/lib/modules/4.15.0-76-generic/kernel/sound/soc/generic/snd-soc-simple-card-utils.ko

[Bug 1873037] Re: autotalent plugin for audacity fails to load

2020-09-22 Thread Eric Chu
Note, since the bug was filed, I've changed my environment.  Now running
on Groovy Gorilla (20.10).  I've re-installed both audacity and
autotalent, and the plugin seems to be loading file.

audacity: 2.4.2~dfsg0-3 amd64
autotalent: 0.2-6 amd64

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1873037

Title:
  autotalent plugin for audacity fails to load

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/audacity/+bug/1873037/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1894195] Re: FFe: Merge iptables 1.8.5-3 (main) from Debian sid (main)

2020-09-22 Thread Alex Murray
I have done the merge and uploaded it to the security-proposed PPA -
https://launchpad.net/~ubuntu-security-proposed/+archive/ubuntu/ppa -
and have confirmed the iptables autopkgtest tests all pass as well as
the ufw tests.

Oibaf - since you requested this, would you be able to also test this?

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1894195

Title:
  FFe: Merge iptables 1.8.5-3 (main) from Debian sid (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/iptables/+bug/1894195/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1887142] Re: pdfsam won't run, has missing and conflicting dependencies

2020-09-22 Thread Tiago Stürmer Daitx
** Description changed:

  [Impact]
  pdfsam fails to work due missing and conflicting dependencies.
  
  On Focal and Groovy libhibernate-validator-java has a runtime dependency
  on libel-api-java and an implementation of el-api. Both are usually
  provided when running under Java EE. On Java SE the application must
  take care of providing them - and pdfsam is missing these dependencies.
  
  The usual implementation of el-api on Maven projects is from Glassfish,
- but that has not yet been packaged. libtomcat9-java also provides one
- such implementation in tomcat9-jasper-el.jar which can be used instead.
+ but that has not yet been packaged. libtomcat9-embed-java also provides
+ one such implementation in tomcat9-embed-el.jar which can be used
+ instead.
  
  Also during build time pdfsam must create links of the jar files it
- needs for runtime: libel-api-java, libtomcat9-java, and classmate (new
+ needs for runtime: tomcat9-embed-el.jar and classmate.jar (a new
  dependency from libhibernate-validator-java).
  
  Only on Focal:
  * libsejda-java 3.2.84-1 depends on libgeronimo-validation-1.0-spec-java
  * libhibernate-validator-java depends on libgeronimo-validation-1.1-spec-java
  
  A Java application must has either 1.0 or 1.1 spec on its classpath,
  never both as they are incompatible. To fix this libsejda-java in Focal
  should be updated to 3.2.84-2 so everything depends on the 1.1 spec (ie.
  libgeronimo-validation-1.1-spec-java).
  
  [Test Case]
  1) On Focal and Groovy, install pdfsam and run it
  $ sudo apt get install -y pdfsam
  $ pdfsam
  2) Split a PDF
  
  Expected result:
  For the action to execute correctly.
  
  Actual result:
  The console shows a java stacktrace such as
  ERROR 15:56:04.873 org.pdfsam.UncaughtExceptionLogger[JavaFX Application 
Thread] Unexpected error
  org.sejda.eventstudio.exception.EventStudioException: Reflective method 
invocation exception
  ...
  
  [Regression Potential]
- * libseja-java:
+ * libseja-java backport:
  Moving from 1.0 to 1.1 spec might cause regressions on packages that depend 
on libsejda-java as now el-api (and its implementation) must be available on 
the classpath (default on Java EE). At this time the only package that depends 
on libsejda-java is pdfsam.
  
- * New dependency on libtomcat9-java (as an el-api provider):
- The usual implementation of el-api is from Glassfish, so using tomcat9 to 
provide this might introduce problems if it deviates from the spec (unlikely, 
as tomcat is also a Java EE provider).
- 
+ * New dependency on libtomcat9-embed-java (as an el-api provider):
+ The most common implementation of el-api is from Glassfish, so using tomcat9 
to provide this might introduce problems if it deviates from the spec 
(unlikely, as tomcat is also a Java EE provider).
  
  [Other Info]
+ 
  
  [Original Report]
  pdfsam does not produce an output file because of various java-exceptions.
  
  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: pdfsam 4.0.4-1
  ProcVersionSignature: Ubuntu 5.4.0-40.44-generic 5.4.44
  Uname: Linux 5.4.0-40-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.3
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: XFCE
  Date: Fri Jul 10 11:46:14 2020
  InstallationDate: Installed on 2019-09-09 (304 days ago)
  InstallationMedia: Xubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
  PackageArchitecture: all
  SourcePackage: pdfsam
  UpgradeStatus: No upgrade log present (probably fresh install)

** Description changed:

  [Impact]
  pdfsam fails to work due missing and conflicting dependencies.
  
  On Focal and Groovy libhibernate-validator-java has a runtime dependency
  on libel-api-java and an implementation of el-api. Both are usually
  provided when running under Java EE. On Java SE the application must
  take care of providing them - and pdfsam is missing these dependencies.
  
  The usual implementation of el-api on Maven projects is from Glassfish,
  but that has not yet been packaged. libtomcat9-embed-java also provides
  one such implementation in tomcat9-embed-el.jar which can be used
  instead.
  
  Also during build time pdfsam must create links of the jar files it
  needs for runtime: tomcat9-embed-el.jar and classmate.jar (a new
- dependency from libhibernate-validator-java).
+ dependency from libhibernate-validator-java) are missing from this list.
  
  Only on Focal:
  * libsejda-java 3.2.84-1 depends on libgeronimo-validation-1.0-spec-java
  * libhibernate-validator-java depends on libgeronimo-validation-1.1-spec-java
  
  A Java application must has either 1.0 or 1.1 spec on its classpath,
  never both as they are incompatible. To fix this libsejda-java in Focal
  should be updated to 3.2.84-2 so everything depends on the 1.1 spec (ie.
  libgeronimo-validation-1.1-spec-java).
  
  [Test Case]
  1) On Focal and Groovy, install pdfsam and run it
  $ sudo apt get install -y pdfsam
  $ pdfsam
  2) Split a PDF
  
  Expected result:
  For the action to 

[Bug 1896701] Re: [Errno 5] Input/output error

2020-09-22 Thread Chris Guiver
Thank you for taking the time to report this issue and helping to make
Ubuntu better.

This package failure looks like it was caused by bad ISO download,
corrupted install media, or device failure. eg. look in the logs and
you'll see messages like these :-

Sep 23 08:38:32 ubuntu kernel: [  585.707226] SQUASHFS error: zlib 
decompression failed, data probably corrupt
Sep 23 08:38:32 ubuntu kernel: [  585.707230] SQUASHFS error: 
squashfs_read_data failed to read block 0xcdae75c

Examining the information you have given us, this does not appear to be
a useful bug report so I am closing it, as it appears to be a bad ISO or
faulty device (inc. bad write-to-device). If you believe I'm in error,
please leave a comment explaining why and change the status back to
'New'. I suggest you verify your ISO download, and use the 'check disc
for defects' option to validate your media before install to ensure a
good download & write.

Possibly useful : https://tutorials.ubuntu.com/tutorial/tutorial-how-to-
verify-ubuntu#0 and
https://help.ubuntu.com/community/Installation/CDIntegrityCheck  (where
CD refers to your install media, be it CD, DVD, HDD, SSD, thumb-drive
etc)


** Changed in: ubiquity (Ubuntu)
   Status: New => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1896701

Title:
   [Errno 5] Input/output error

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1896701/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1874647] Re: [Ubuntu 20.04] Stale libvirt cache leads to VM startup failures

2020-09-22 Thread Chris Halse Rogers
This looks like it should be ready for release into focal-updates, but
it's unclear to me whether anyone has tested the packages currently in
focal-proposed?

I see that some PPA packages have been tested and confirmed to work, but
for SRUs we generally require that the actual packages that will end up
in -updates (ie: the packages in -proposed) be tested.

This is to avoid human error where the packages in a PPA are not exactly
the same code as that in -proposed, and also to avoid the rare cases
where some quirk of the build environment causes PPA builds to build
correctly but the archive packages to fail.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1874647

Title:
  [Ubuntu 20.04] Stale libvirt cache leads to VM startup failures

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-z-systems/+bug/1874647/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896701] [NEW] [Errno 5] Input/output error

2020-09-22 Thread Malik Ibrahim
Public bug reported:

The installer encountered an error copying files to the hard disk:

[Errno 5] Input/output error

This is often due to a faulty CD/DVD disk or drive, or a faulty hard
disk. It may help to clean the CD/DVD, to burn the CD/DVD at a lower
speed, to clean the CD/DVD drive lens (cleaning kits are often available
from electronics suppliers), to check whether the hard disk is old and
in need of replacement, or to move the system to a cooler environment.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubiquity 2.21.63.11
ProcVersionSignature: Ubuntu 4.15.0-112.113~16.04.1-generic 4.15.18
Uname: Linux 4.15.0-112-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.24
Architecture: amd64
CasperVersion: 1.376.2
Date: Tue Sep 22 21:40:59 2020
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper 
initrd=/casper/initrd quiet splash --- maybe-ubiquity
LiveMediaBuild: Ubuntu 16.04.7 LTS "Xenial Xerus" - Release amd64 (20200806)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: ubiquity (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug ubiquity-2.21.63.11 ubuntu xenial

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1896701

Title:
   [Errno 5] Input/output error

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1896701/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1887142] Re: libhibernate-validator-java should be backported to 4.3.4-1~18.04.1

2020-09-22 Thread Tiago Stürmer Daitx
** Description changed:

  [Impact]
- Debian started migrating from libgeronimo-validation-1.0-spec-java to 
libgeronimo-validation-1.1-spec-java quite a while ago. Unfortunately both 
packages implement different Bean Validation Specs and are not compatible, thus 
all reverse (build-)dependencies and reverse (build-)dependencies of these spec 
packages must rely solely on the 1.0 or 1.1 version to avoid FTBFS or runtime 
issues. This transition has not yet been completed on Debian and both Focal and 
Groovy ended up with mixed dependencies.
+ pdfsam fails to work due missing and conflicting dependencies.
  
- So far 2 packages seem to be affected by this and have regressed since Focal:
- 1) pdfsam  will start but can't split/merge/etc pdfs
- 2) libspring-java FTBFS
+ On Focal and Groovy libhibernate-validator-java has a runtime dependency
+ on libel-api-java and an implementation of el-api. Both are usually
+ provided when running under Java EE. On Java SE the application must
+ take care of providing them - and pdfsam is missing these dependencies.
  
- Both depend indirectly on  libgeronimo-validation-1.1-spec-java through
- libhibernate-validator-java.
+ The usual implementation of el-api on Maven projects is from Glassfish,
+ but that has not yet been packaged. libtomcat9-java also provides one
+ such implementation in tomcat9-jasper-el.jar which can be used instead.
  
- pdfsam depends on libgeronimo-validation-1.0-spec-java through libsejda-
- java, while libspring-java depends on 1.0 through through libspring-
- java.
+ Also during build time pdfsam must create links of the jar files it
+ needs for runtime: libel-api-java, libtomcat9-java, and classmate (new
+ dependency from libhibernate-validator-java).
  
- The easiest fix is to downgrade libhibernate-validator-java from 5.3.6-1
- to 4.3.4-1~18.04.1. Trying to update all dependencies to use
- libgeronimo-validation-1.1-spec-java is problematic, requires new
- packages, and even some dependencies that have not yet been packaged or
- tested well.
+ Only on Focal:
+ * libsejda-java 3.2.84-1 depends on libgeronimo-validation-1.0-spec-java
+ * libhibernate-validator-java depends on libgeronimo-validation-1.1-spec-java
+ 
+ A Java application must has either 1.0 or 1.1 spec on its classpath,
+ never both as they are incompatible. To fix this libsejda-java in Focal
+ should be updated to 3.2.84-2 so everything depends on the 1.1 spec (ie.
+ libgeronimo-validation-1.1-spec-java).
  
  [Test Case]
  1) On Focal and Groovy, install pdfsam and run it
  $ sudo apt get install -y pdfsam
  $ pdfsam
  2) Split a PDF
  
  Expected result:
  For the action to execute correctly.
  
  Actual result:
  The console shows a java stacktrace such as
  ERROR 15:56:04.873 org.pdfsam.UncaughtExceptionLogger[JavaFX Application 
Thread] Unexpected error
  org.sejda.eventstudio.exception.EventStudioException: Reflective method 
invocation exception
  ...
  
  [Regression Potential]
- I haven't found packages that depend on libhibernate-validator-java and on 
validation-1.1-spec-java directly or indirectly, but I haven't looked at a 
depth bigger than 3. If there are packages with (indirect) dependencies on both 
libhibernate-validator-java and libgeronimo-validation-1.1-spec-java they will 
regress after this change.
+ * libseja-java:
+ Moving from 1.0 to 1.1 spec might cause regressions on packages that depend 
on libsejda-java as now el-api (and its implementation) must be available on 
the classpath (default on Java EE). At this time the only package that depends 
on libsejda-java is pdfsam.
+ 
+ * New dependency on libtomcat9-java (as an el-api provider):
+ The usual implementation of el-api is from Glassfish, so using tomcat9 to 
provide this might introduce problems if it deviates from the spec (unlikely, 
as tomcat is also a Java EE provider).
+ 
  
  [Other Info]
-  * On Debian unstable a new package called libhibernate-validator4-java has 
been created to deal with this problem, but it is not enough and it is even 
blocking from moving to testing.
- * For pdfsam I tried to move libsejda-java to 1.1 spec, but as described in 
debian bug 942507 comment 10 it introduces new dependencies and one dependency 
on el-impl that is not packaged yet.
  
  [Original Report]
  pdfsam does not produce an output file because of various java-exceptions.
  
  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: pdfsam 4.0.4-1
  ProcVersionSignature: Ubuntu 5.4.0-40.44-generic 5.4.44
  Uname: Linux 5.4.0-40-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.3
  Architecture: amd64
  CasperMD5CheckResult: skip
  CurrentDesktop: XFCE
  Date: Fri Jul 10 11:46:14 2020
  InstallationDate: Installed on 2019-09-09 (304 days ago)
  InstallationMedia: Xubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
  PackageArchitecture: all
  SourcePackage: pdfsam
  UpgradeStatus: No upgrade log present (probably fresh install)

** Summary changed:

- libhibernate-validator-java should be 

[Bug 1886854] Re: Race in load-module snap policy check in classic confinement

2020-09-22 Thread James Henstridge
This is the in-progress fix I've been working on.  It does not quite
work right though: switching to an async hook for these commands is
resulting in the daemon killing the client on a protocol error.

This might be a problem with the hooks patch set itself.  I need to
investigate a bit further.

** Patch added: "allow-classic.diff"
   
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1886854/+attachment/5413365/+files/allow-classic.diff

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1886854

Title:
  Race in load-module snap policy check in classic confinement

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1886854/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896416] Re: screen locking no longer works

2020-09-22 Thread Avital Ostromich
** Also affects: gnome-shell (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to the bug report.
https://bugs.launchpad.net/bugs/1896416

Title:
  screen locking no longer works

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gdm3/+bug/1896416/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1887142] Re: libhibernate-validator-java should be backported to 4.3.4-1~18.04.1

2020-09-22 Thread Tiago Stürmer Daitx
Backporting libhibernate-validator-java didn't work as expected. While
the 4.3.4-1 deb binary from Focal (when it was still devel) works fine,
it no longer builds as it depended on jboss-logging 3.3. The newer
jboss-logging 3.4 does not provide the same classes and it has too many
reverse (build) dependencies to be feasible to downgrade.

Going the other way and updating libsejda-java to rely on 
libgeronimo-validation-1.1-spec-java requires some new dependencies (see debian 
bug 942507): 
* libel-api-java
* an el-api implementation, usually Glassfish, but it is not yet packaged, thus 
tomcat9-jasper-el.jar can be used
* libhibernate-validator-java >= 5.3.6-2 (as 5.3.6-1 is missing some runtime 
dependencies)

The first 2 dependencies come from libhibernate-validator-java 5.3.6,
but they are expected to be automatically provided by the Java EE
environment and don't show up as actual dependencies. Since pdfsam run
Java SE it must provide them.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1887142

Title:
  libhibernate-validator-java should be backported to 4.3.4-1~18.04.1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libhibernate-validator-java/+bug/1887142/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1887425] Re: php files now open by default in Chrome

2020-09-22 Thread Adolfo Jayme
** Package changed: meta-gnome3 (Ubuntu) => shared-mime-info (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1887425

Title:
  php files now open by default in Chrome

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/shared-mime-info/+bug/1887425/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896699] [NEW] Mounting a share in fstab fails with BAD_NETWORK_NAME

2020-09-22 Thread Daniel Essin
Public bug reported:

The following command works:
mount -t cifs //192.168.1.200/Drive_E /mnt/server_e -o 
credentials=/root/.smbcredentials_server 

The following fstab entry fails:
//server/Server_E /mnt/server_e   cifs   
uid=0,credentials=/root/.smbcredentials_server,file_mode=0755,dir_mode=0755,vers=2.1,sec=ntlmssp
  0  0

There is an entry in hosts for server. It also fails with 
//192.168.1.200/Server_E
Sometimes it says:
No dialect specified on mount. Default has changed to a more secure dialect, 
SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 
dialect to access old servers which do not support SMB3 (or SMB2.1) specify 
vers=1.0 on mount.
[ 2079.955734] CIFS VFS:  BAD_NETWORK_NAME: \\192.168.1.200\Server_E
CIFS VFS: cifs_mount failed w/return code = -2

trying vers=1.0 and vers=3.0 makes no difference.

There is no documentations of CIFS VFS error codes
There is no documentation of how to specify the SMB dialect.
People appear to have been having trouble with these things for at least the 
past 10 years.

I never had a problem with this on debian.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: samba 2:4.11.6+dfsg-0ubuntu1.4
ProcVersionSignature: Ubuntu 5.4.0-47.51-generic 5.4.55
Uname: Linux 5.4.0-47-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia ufsd
ApportVersion: 2.20.11-0ubuntu27.8
Architecture: amd64
CIFSMounts: /root/smb4k/192.168.1.200/Drive_E //192.168.1.200/Drive_E cifs   
rw,relatime,vers=3.1.1,cache=strict,username=essin,domain=WORKGROUP,uid=0,forceuid,gid=0,forcegid,addr=192.168.1.200,file_mode=0755,dir_mode=0755,soft,nounix,serverino,mapposix,rsize=4194304,wsize=4194304,bsize=1048576,echo_interval=60,actimeo=1
CasperMD5CheckResult: skip
CurrentDesktop: XFCE
Date: Tue Sep 22 17:35:02 2020
InstallationDate: Installed on 2020-09-18 (4 days ago)
InstallationMedia: Xubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SambaClientRegression: Yes
SourcePackage: samba
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: samba (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug focal

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1896699

Title:
  Mounting a share in fstab fails with BAD_NETWORK_NAME

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1896699/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1895839] Re: CVE-2020-24977

2020-09-22 Thread Avital Ostromich
** Description changed:

+ GNOME project libxml2 v2.9.10 and earlier have a global buffer over-read
+ vulnerability in xmlEncodeEntitiesInternal at libxml2/entities.c.
+ 
  https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-24977
  
- Upstream patch:
- 
https://gitlab.gnome.org/GNOME/libxml2/-/commit/8e7c20a1af8776677d7890f30b7a180567701a49
+ Upstream patch: 
+ 
https://gitlab.gnome.org/GNOME/libxml2/-/commit/50f06b3efb638efb0abd95dc62dca05ae67882c2
  
- GNOME project libxml2 v2.9.10 and earlier have a global buffer over-read
- vulnerability in xmlEncodeEntitiesInternal at libxml2/entities.c.
+ Bug report: https://gitlab.gnome.org/GNOME/libxml2/-/issues/178

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1895839

Title:
  CVE-2020-24977

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libxml2/+bug/1895839/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1895967] Re: Apparmor 3.0.0 does not load profiles in containers anymore

2020-09-22 Thread Alex Murray
Christian - thanks for your work on debugging this - can you please
remove the block-proposed tag if you are happy that 3.0.0~beta1-0ubuntu6
resolves this issue?

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1895967

Title:
  Apparmor 3.0.0 does not load profiles in containers anymore

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apparmor/+bug/1895967/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1511002] Re: Computer freezes/crashes while using GNOME

2020-09-22 Thread Bug Watch Updater
** Changed in: linux
   Status: Incomplete => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1511002

Title:
  Computer freezes/crashes while using GNOME

To manage notifications about this bug go to:
https://bugs.launchpad.net/linux/+bug/1511002/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1895839] Re: CVE-2020-24977

2020-09-22 Thread Avital Ostromich
** Description changed:

  https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-24977
  
  Upstream patch:
  
https://gitlab.gnome.org/GNOME/libxml2/-/commit/8e7c20a1af8776677d7890f30b7a180567701a49
+ 
+ GNOME project libxml2 v2.9.10 and earlier have a global buffer over-read
+ vulnerability in xmlEncodeEntitiesInternal at libxml2/entities.c.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1895839

Title:
  CVE-2020-24977

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libxml2/+bug/1895839/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896313] Re: package gir1.2-javascriptcoregtk-4.0:amd64 2.28.4-0ubuntu0.20.04.1 failed to install/upgrade: package is in a very bad inconsistent state; you should reinstall it before attempting

2020-09-22 Thread Apport retracing service
** Tags removed: need-duplicate-check

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to the bug report.
https://bugs.launchpad.net/bugs/1896313

Title:
  package gir1.2-javascriptcoregtk-4.0:amd64 2.28.4-0ubuntu0.20.04.1
  failed to install/upgrade: package is in a very bad inconsistent
  state; you should  reinstall it before attempting configuration

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/webkit2gtk/+bug/1896313/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1887943] Re: [SRU] TLS is not enabled for memcached>=1.5.13

2020-09-22 Thread Bryce Harrington
The test case is failing only on amd64, with this test case error:

1) Doctrine\Tests\Common\Cache\ChainCacheTest::testLifetime
Data should be expired
Failed asserting that true is false.

/tmp/autopkgtest.RGHUkG/build.W9o/src/tests/Doctrine/Tests/Common/Cache/CacheTest.php:286

I'm going to try re-running the test in case it's just something
intermittent.  From the package's test history looks like it's had
intermittent test failures in the past.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1887943

Title:
  [SRU] TLS is not enabled for memcached>=1.5.13

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/memcached/+bug/1887943/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1879024] Re: Error message : "Failed to scan - unable to connect to scanner" when using simple-scan

2020-09-22 Thread Igor Shabalov
Have exactly same error with Brother MFS-L8900CDW
Upgraded from 18.04.5 - was working well before upgrade.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1879024

Title:
  Error message : "Failed to scan - unable to connect to scanner" when
  using simple-scan

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/simple-scan/+bug/1879024/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896313] Re: package gir1.2-javascriptcoregtk-4.0:amd64 2.28.4-0ubuntu0.20.04.1 failed to install/upgrade: package is in a very bad inconsistent state; you should reinstall it before attempting

2020-09-22 Thread Avital Ostromich
Thanks for taking the time to report this bug and helping to make Ubuntu
better. We appreciate the difficulties you are facing, but this appears
to be a "regular" (non-security) bug.  I have unmarked it as a security
issue since this bug does not show evidence of allowing attackers to
cross privilege boundaries nor directly cause loss of data/privacy.
Please feel free to report any other bugs you may find.

** Information type changed from Private Security to Public Security

** Information type changed from Public Security to Public

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1896313

Title:
  package gir1.2-javascriptcoregtk-4.0:amd64 2.28.4-0ubuntu0.20.04.1
  failed to install/upgrade: package is in a very bad inconsistent
  state; you should  reinstall it before attempting configuration

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/webkit2gtk/+bug/1896313/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896316] Re: tracker-extract crashed with signal 31 in statx()

2020-09-22 Thread Avital Ostromich
Thanks for taking the time to report this bug and helping to make Ubuntu
better. We appreciate the difficulties you are facing, but this appears
to be a "regular" (non-security) bug.  I have unmarked it as a security
issue since this bug does not show evidence of allowing attackers to
cross privilege boundaries nor directly cause loss of data/privacy.
Please feel free to report any other bugs you may find.

** Attachment removed: "CoreDump.gz"
   
https://bugs.launchpad.net/ubuntu/+source/tracker-miners/+bug/1896316/+attachment/5412407/+files/CoreDump.gz

** Information type changed from Private Security to Public

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1896316

Title:
  tracker-extract crashed with signal 31 in statx()

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/tracker-miners/+bug/1896316/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1887943] Re: [SRU] TLS is not enabled for memcached>=1.5.13

2020-09-22 Thread Bryce Harrington
I got notices of some build failures:

riscv64:
https://launchpad.net/ubuntu/+source/memcached/1.5.22-2ubuntu0.2/+build/19959835/+files
/buildlog_ubuntu-focal-
riscv64.memcached_1.5.22-2ubuntu0.2_BUILDING.txt.gz

arm64:
https://launchpad.net/ubuntu/+source/memcached/1.5.22-2ubuntu0.2/+build/19959832/+files
/buildlog_ubuntu-focal-arm64.memcached_1.5.22-2ubuntu0.2_BUILDING.txt.gz

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1887943

Title:
  [SRU] TLS is not enabled for memcached>=1.5.13

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/memcached/+bug/1887943/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896313] [NEW] package gir1.2-javascriptcoregtk-4.0:amd64 2.28.4-0ubuntu0.20.04.1 failed to install/upgrade: package is in a very bad inconsistent state; you should reinstall it before attemptin

2020-09-22 Thread Launchpad Bug Tracker
*** This bug is a security vulnerability ***

You have been subscribed to a public security bug by Avital Ostromich (avital):

I cannot install or uninstall any apps.

ProblemType: Package
DistroRelease: Ubuntu 20.04
Package: gir1.2-javascriptcoregtk-4.0:amd64 2.28.4-0ubuntu0.20.04.1
ProcVersionSignature: Ubuntu 5.4.0-48.52-generic 5.4.60
Uname: Linux 5.4.0-48-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.9
Architecture: amd64
CasperMD5CheckResult: skip
Date: Sat Sep 19 14:35:44 2020
DuplicateSignature:
 package:gir1.2-javascriptcoregtk-4.0:amd64:2.28.4-0ubuntu0.20.04.1
 Setting up libnss3:amd64 (2:3.49.1-1ubuntu1.5) ...
 dpkg: error processing package gir1.2-javascriptcoregtk-4.0:amd64 
(--configure):
  package is in a very bad inconsistent state; you should
ErrorMessage: package is in a very bad inconsistent state; you should  
reinstall it before attempting configuration
InstallationDate: Installed on 2020-09-18 (0 days ago)
InstallationMedia: Ubuntu 20.04.1 LTS "Focal Fossa" - Release amd64 (20200731)
Python3Details: /usr/bin/python3.8, Python 3.8.2, python3-minimal, 
3.8.2-0ubuntu2
PythonDetails: N/A
RelatedPackageVersions:
 dpkg 1.19.7ubuntu3
 apt  2.0.3
SourcePackage: webkit2gtk
Title: package gir1.2-javascriptcoregtk-4.0:amd64 2.28.4-0ubuntu0.20.04.1 
failed to install/upgrade: package is in a very bad inconsistent state; you 
should  reinstall it before attempting configuration
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: webkit2gtk (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package focal need-duplicate-check
-- 
package gir1.2-javascriptcoregtk-4.0:amd64 2.28.4-0ubuntu0.20.04.1 failed to 
install/upgrade: package is in a very bad inconsistent state; you should  
reinstall it before attempting configuration
https://bugs.launchpad.net/bugs/1896313
You received this bug notification because you are a member of Ubuntu Bugs, 
which is subscribed to the bug report.

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1891673] Please test proposed package

2020-09-22 Thread Corey Bryant
Hello Edward, or anyone else affected,

Accepted neutron into rocky-proposed. The package will build now and be
available in the Ubuntu Cloud Archive in a few hours, and then in the
-proposed repository.

Please help us by testing this new package. To enable the -proposed
repository:

  sudo add-apt-repository cloud-archive:rocky-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested, and change the tag
from verification-rocky-needed to verification-rocky-done. If it does
not fix the bug for you, please add a comment stating that, and change
the tag to verification-rocky-failed. In either case, details of your
testing will help us make a better decision.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in
advance!

** Changed in: cloud-archive/rocky
   Status: Triaged => Fix Committed

** Tags added: verification-rocky-needed

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1891673

Title:
  qrouter ns ip rules not deleted when fip removed from vm

To manage notifications about this bug go to:
https://bugs.launchpad.net/cloud-archive/+bug/1891673/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1891673] Please test proposed package

2020-09-22 Thread Corey Bryant
Hello Edward, or anyone else affected,

Accepted neutron into queens-proposed. The package will build now and be
available in the Ubuntu Cloud Archive in a few hours, and then in the
-proposed repository.

Please help us by testing this new package. To enable the -proposed
repository:

  sudo add-apt-repository cloud-archive:queens-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested, and change the tag
from verification-queens-needed to verification-queens-done. If it does
not fix the bug for you, please add a comment stating that, and change
the tag to verification-queens-failed. In either case, details of your
testing will help us make a better decision.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in
advance!

** Changed in: cloud-archive/queens
   Status: Triaged => Fix Committed

** Tags added: verification-queens-needed

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1891673

Title:
  qrouter ns ip rules not deleted when fip removed from vm

To manage notifications about this bug go to:
https://bugs.launchpad.net/cloud-archive/+bug/1891673/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1891673] Please test proposed package

2020-09-22 Thread Corey Bryant
Hello Edward, or anyone else affected,

Accepted neutron into train-proposed. The package will build now and be
available in the Ubuntu Cloud Archive in a few hours, and then in the
-proposed repository.

Please help us by testing this new package. To enable the -proposed
repository:

  sudo add-apt-repository cloud-archive:train-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested, and change the tag
from verification-train-needed to verification-train-done. If it does
not fix the bug for you, please add a comment stating that, and change
the tag to verification-train-failed. In either case, details of your
testing will help us make a better decision.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in
advance!

** Tags added: verification-ussuri-needed

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1891673

Title:
  qrouter ns ip rules not deleted when fip removed from vm

To manage notifications about this bug go to:
https://bugs.launchpad.net/cloud-archive/+bug/1891673/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1891673] Please test proposed package

2020-09-22 Thread Corey Bryant
Hello Edward, or anyone else affected,

Accepted neutron into stein-proposed. The package will build now and be
available in the Ubuntu Cloud Archive in a few hours, and then in the
-proposed repository.

Please help us by testing this new package. To enable the -proposed
repository:

  sudo add-apt-repository cloud-archive:stein-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested, and change the tag
from verification-stein-needed to verification-stein-done. If it does
not fix the bug for you, please add a comment stating that, and change
the tag to verification-stein-failed. In either case, details of your
testing will help us make a better decision.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in
advance!

** Changed in: cloud-archive/stein
   Status: Triaged => Fix Committed

** Changed in: cloud-archive/train
   Status: Triaged => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1891673

Title:
  qrouter ns ip rules not deleted when fip removed from vm

To manage notifications about this bug go to:
https://bugs.launchpad.net/cloud-archive/+bug/1891673/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1891673] Please test proposed package

2020-09-22 Thread Corey Bryant
Hello Edward, or anyone else affected,

Accepted neutron into ussuri-proposed. The package will build now and be
available in the Ubuntu Cloud Archive in a few hours, and then in the
-proposed repository.

Please help us by testing this new package. To enable the -proposed
repository:

  sudo add-apt-repository cloud-archive:ussuri-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested, and change the tag
from verification-ussuri-needed to verification-ussuri-done. If it does
not fix the bug for you, please add a comment stating that, and change
the tag to verification-ussuri-failed. In either case, details of your
testing will help us make a better decision.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in
advance!

** Changed in: cloud-archive/ussuri
   Status: Triaged => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1891673

Title:
  qrouter ns ip rules not deleted when fip removed from vm

To manage notifications about this bug go to:
https://bugs.launchpad.net/cloud-archive/+bug/1891673/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Re: [Bug 1896482] Re: acpi event detection crashes

2020-09-22 Thread Jim Cline
ok, I can do that


On Tue, 22 Sep 2020, Mauricio Faria de Oliveira wrote:

> Hey Jim,
>
> That's very good news!
>
> I believe Alex should send you more test kernels,
> with different sets of patches included/removed,
> so to bisect/identify which specific patch(es)
> resolve the problem.
>
> If you could help with testing that as well,
> that would be great, so a smaller patch(set)
> can be put into the Ubuntu stable release(s).
>
> cheers,
> Mauricio
>
> -- 
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1896482
>
> Title:
>  acpi event detection crashes
>
> Status in linux package in Ubuntu:
>  Confirmed
>
> Bug description:
>  Right after booting, acpi lid open/close is detected as it should be
>  by the kernel, but some time later it crashes, so I have to manually
>  suspend the system.  The traceback is here:
>
>  Sep 20 11:35:33 laxmi kernel: [232492.303557] [ cut here 
> ]
>  Sep 20 11:35:33 laxmi kernel: [232492.303564] WARNING: CPU: 0 PID: 8302 at 
> kernel/workqueue.c:1416 __queue_work+0x337/0x3f0
>  Sep 20 11:35:33 laxmi kernel: [232492.303565] Modules linked in: ccm rfcomm 
> cmac algif_hash algif_skcipher af_alg bnep nls_iso8859_1 snd_soc_skl_hda_dsp 
> snd_hda_codec_hdmi snd_soc_hdac_hdmi snd_hda_codec_realtek snd_soc_dmic 
> snd_hda_codec_generic snd_sof_pci mei_hdcp x86_pkg_temp_thermal 
> intel_powerclamp intel_rapl_msr coretemp snd_sof_intel_hda_common 
> snd_soc_hdac_hda snd_sof_intel_hda kvm_intel snd_sof_intel_byt 
> snd_sof_intel_ipc kvm snd_sof snd_sof_xtensa_dsp snd_hda_ext_core 
> snd_soc_acpi_intel_match snd_soc_acpi snd_soc_core snd_compress ac97_bus 
> snd_pcm_dmaengine joydev crct10dif_pclmul ghash_clmulni_intel snd_hda_intel 
> aesni_intel snd_intel_dspcfg crypto_simd iwlmvm cryptd snd_hda_codec 
> glue_helper rapl mac80211 snd_hda_core snd_seq_midi snd_hwdep 
> snd_seq_midi_event libarc4 intel_cstate uvcvideo snd_rawmidi i915 snd_pcm 
> videobuf2_vmalloc input_leds thinkpad_acpi btusb videobuf2_memops serio_raw 
> btrtl videobuf2_v4l2 snd_seq btbcm btintel nvram videobuf2_common iwlwif!
 i processor_thermal_device bluetooth videodev
>  Sep 20 11:35:33 laxmi kernel: [232492.303600]  drm_kms_helper mc wmi_bmof 
> i2c_algo_bit intel_rapl_common fb_sys_fops ucsi_acpi intel_wmi_thunderbolt 
> ecdh_generic ledtrig_audio typec_ucsi mei_me syscopyarea hid_multitouch 
> snd_seq_device sysfillrect cfg80211 ecc sysimgblt mei intel_soc_dts_iosf 
> typec snd_timer snd soundcore int3403_thermal int340x_thermal_zone acpi_pad 
> intel_hid int3400_thermal acpi_thermal_rel sparse_keymap mac_hid sch_fq_codel 
> parport_pc ppdev lp parport drm ip_tables x_tables autofs4 hid_generic 
> crc32_pclmul nvme psmouse e1000e i2c_i801 thunderbolt intel_lpss_pci 
> intel_lpss nvme_core idma64 virt_dma i2c_hid hid wmi video pinctrl_cannonlake 
> pinctrl_intel
>  Sep 20 11:35:33 laxmi kernel: [232492.303628] CPU: 0 PID: 8302 Comm: 
> kworker/0:0 Not tainted 5.4.0-47-generic #51-Ubuntu
>  Sep 20 11:35:33 laxmi kernel: [232492.303629] Hardware name: LENOVO 
> 20U9001NUS/20U9001NUS, BIOS N2WET19W (1.09 ) 07/01/2020
>  Sep 20 11:35:33 laxmi kernel: [232492.303632] Workqueue: kec_query 
> acpi_ec_event_processor
>  Sep 20 11:35:33 laxmi kernel: [232492.303635] RIP: 
> 0010:__queue_work+0x337/0x3f0
>  Sep 20 11:35:33 laxmi kernel: [232492.303637] Code: ff 49 8b 9d a0 00 00 00 
> e9 aa fd ff ff 65 8b 05 e7 59 15 6d a9 00 01 1f 00 75 0f 65 48 8b 3c 25 c0 6b 
> 01 00 f6 47 24 20 75 25 <0f> 0b 48 83 c4 18 5b 41 5c 41 5d 41 5e 41 5f 5d c3 
> 0f 0b e9 fd fd
>  Sep 20 11:35:33 laxmi kernel: [232492.303638] RSP: 0018:b16bc0ebb8f8 
> EFLAGS: 00010087
>  Sep 20 11:35:33 laxmi kernel: [232492.303640] RAX: 9a2477432600 RBX: 
> 0002 RCX: 0004
>  Sep 20 11:35:33 laxmi kernel: [232492.303641] RDX: 9a2475af4a90 RSI: 
> 9a2475b03200 RDI: 9a2430215f00
>  Sep 20 11:35:33 laxmi kernel: [232492.303642] RBP: b16bc0ebb938 R08: 
>  R09: 0007
>  Sep 20 11:35:33 laxmi kernel: [232492.303643] R10: 9a24755ad678 R11: 
>  R12: 9a2475af4a00
>  Sep 20 11:35:33 laxmi kernel: [232492.303643] R13: 9a2475b03200 R14: 
> 2000 R15: 9a2475af4a90
>  Sep 20 11:35:33 laxmi kernel: [232492.303645] FS:  () 
> GS:9a247740() knlGS:
>  Sep 20 11:35:33 laxmi kernel: [232492.303646] CS:  0010 DS:  ES:  
> CR0: 80050033
>  Sep 20 11:35:33 laxmi kernel: [232492.303647] CR2: 00c42098b000 CR3: 
> 00018520a003 CR4: 003606f0
>  Sep 20 11:35:33 laxmi kernel: [232492.303648] Call Trace:
>  Sep 20 11:35:33 laxmi kernel: [232492.303654]  ? 
> acpi_os_release_lock+0xe/0x10
>  Sep 20 11:35:33 laxmi kernel: [232492.303657]  queue_work_on+0x3b/0x50
>  Sep 20 11:35:33 laxmi kernel: [232492.303659]  
> advance_transaction+0x2b9/0x620
>  Sep 20 11:35:33 laxmi kernel: [232492.303661]  

[Bug 1894323] Re: Add fence_aws fencing from v4.6.0 agent to Bionic

2020-09-22 Thread Rafael David Tinoco
I see that AWS has 2 fencing mechanisms:

- fence_aws using boto3 library (in fence-agents)
- fence_ec2 (in cluster-glue)

Bug:

https://bugs.launchpad.net/ubuntu/+source/cluster-glue/+bug/1895355

has brought fence_ec2 support to our cluster-glue package by backporting
needed patches. Perhaps that should also be checked for backport
(backporting fence_ec2 to Focal and Bionic if possible).

I opened the following bug for this:

https://bugs.launchpad.net/ubuntu/+source/cluster-glue/+bug/1896696

** Changed in: fence-agents (Ubuntu Bionic)
 Assignee: Rafael David Tinoco (rafaeldtinoco) => (unassigned)

** Changed in: fence-agents (Ubuntu Bionic)
   Importance: Undecided => Wishlist

** Changed in: fence-agents (Ubuntu Focal)
   Importance: Undecided => Wishlist

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1894323

Title:
  Add fence_aws fencing from v4.6.0 agent to Bionic

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/fence-agents/+bug/1894323/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896696] [NEW] Backport fence_ec2 support to Focal and Bionic

2020-09-22 Thread Rafael David Tinoco
Public bug reported:

In Bug:

https://bugs.launchpad.net/ubuntu/+source/cluster-glue/+bug/1895355

I have backported fixes and a new feature to cluster-glue:

# ec2 stonith agent support and fixes

7c84a6ae Fix EC2 stonith plugin
27e83692 Fix: stonith:ibmhmc: Add "managedsyspat" and "password" as supported 
parameters
[76138dfb Medium: external/ec2: Mitigate fence race (bsc#1088656)
6734e0d0 High: external/ec2: Avoid unicode errors and improve performance 
(bsc#1088656)
ba5710b3 Dev: external/ec2: Clean up whitespace
609cc386 Fix: stonith:external/ec2: Enforce en_US.UTF-8 locale when invoking 
aws client (bsc#1059171)
0f081f69 Medium: stonith: external/ec2: use target's uname as default for port
291a4378 Dev: stonith: external/ec2: protect unknown_are_stopped expansion
5cd5ffd2 Dev: stonith: external/ec2: add unknown_are_stopped to getconfignames
289e8fd3 Low: stonith: external/ec2: update name in the short description
b7bed186 Dev: update permissions for ec2
de5e068d High: stonith: external/ec2: new agent for aws/ec2

This bug is an attempt of backporting the agent to Focal and Bionic (LTS
releases).

** Affects: cluster-glue (Ubuntu)
 Importance: Undecided
 Status: Fix Released

** Affects: cluster-glue (Ubuntu Bionic)
 Importance: Wishlist
 Status: Confirmed

** Affects: cluster-glue (Ubuntu Focal)
 Importance: Wishlist
 Status: Confirmed

** Also affects: cluster-glue (Ubuntu Focal)
   Importance: Undecided
   Status: New

** Also affects: cluster-glue (Ubuntu Bionic)
   Importance: Undecided
   Status: New

** Changed in: cluster-glue (Ubuntu)
   Status: New => Fix Released

** Changed in: cluster-glue (Ubuntu Bionic)
   Status: New => Confirmed

** Changed in: cluster-glue (Ubuntu Focal)
   Status: New => Confirmed

** Changed in: cluster-glue (Ubuntu Bionic)
   Importance: Undecided => Wishlist

** Changed in: cluster-glue (Ubuntu Focal)
   Importance: Undecided => Wishlist

** Description changed:

  In Bug:
  
  https://bugs.launchpad.net/ubuntu/+source/cluster-glue/+bug/1895355
  
  I have backported fixes and a new feature to cluster-glue:
  
  # ec2 stonith agent support and fixes
  
- [FFE] 7c84a6ae Fix EC2 stonith plugin
- [FFE] 27e83692 Fix: stonith:ibmhmc: Add "managedsyspat" and "password" as 
supported parameters
- [FFE] 76138dfb Medium: external/ec2: Mitigate fence race (bsc#1088656)
- [FFE] 6734e0d0 High: external/ec2: Avoid unicode errors and improve 
performance (bsc#1088656)
- [FFE] ba5710b3 Dev: external/ec2: Clean up whitespace
- [FFE] 609cc386 Fix: stonith:external/ec2: Enforce en_US.UTF-8 locale when 
invoking aws client (bsc#1059171)
- [FFE] 0f081f69 Medium: stonith: external/ec2: use target's uname as default 
for port
- [FFE] 291a4378 Dev: stonith: external/ec2: protect unknown_are_stopped 
expansion
- [FFE] 5cd5ffd2 Dev: stonith: external/ec2: add unknown_are_stopped to 
getconfignames
- [FFE] 289e8fd3 Low: stonith: external/ec2: update name in the short 
description
- [FFE] b7bed186 Dev: update permissions for ec2
- [FFE] de5e068d High: stonith: external/ec2: new agent for aws/ec2
+ 7c84a6ae Fix EC2 stonith plugin
+ 27e83692 Fix: stonith:ibmhmc: Add "managedsyspat" and "password" as supported 
parameters
+ [76138dfb Medium: external/ec2: Mitigate fence race (bsc#1088656)
+ 6734e0d0 High: external/ec2: Avoid unicode errors and improve performance 
(bsc#1088656)
+ ba5710b3 Dev: external/ec2: Clean up whitespace
+ 609cc386 Fix: stonith:external/ec2: Enforce en_US.UTF-8 locale when invoking 
aws client (bsc#1059171)
+ 0f081f69 Medium: stonith: external/ec2: use target's uname as default for port
+ 291a4378 Dev: stonith: external/ec2: protect unknown_are_stopped expansion
+ 5cd5ffd2 Dev: stonith: external/ec2: add unknown_are_stopped to getconfignames
+ 289e8fd3 Low: stonith: external/ec2: update name in the short description
+ b7bed186 Dev: update permissions for ec2
+ de5e068d High: stonith: external/ec2: new agent for aws/ec2
  
  This bug is an attempt of backporting the agent to Focal and Bionic (LTS
  releases).

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1896696

Title:
  Backport fence_ec2 support to Focal and Bionic

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cluster-glue/+bug/1896696/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1889070] Re: [20.10 FEAT] Add LPAR fence agent to Pacemaker (fence-agents)

2020-09-22 Thread Rafael David Tinoco
** No longer affects: fence-agents (Ubuntu Groovy)

** Also affects: fence-agents (Ubuntu Bionic)
   Importance: Undecided
   Status: New

** Changed in: fence-agents (Ubuntu Bionic)
   Importance: Undecided => Wishlist

** Changed in: fence-agents (Ubuntu Focal)
   Importance: Undecided => Wishlist

** Changed in: fence-agents (Ubuntu Bionic)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1889070

Title:
  [20.10 FEAT] Add LPAR fence agent to Pacemaker (fence-agents)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-z-systems/+bug/1889070/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1894323] Re: Add fence_aws fencing from v4.6.0 agent to Bionic

2020-09-22 Thread Rafael David Tinoco
In bug:

https://bugs.launchpad.net/ubuntu/+source/fence-agents/+bug/1894325

I have synced v4.6.0-1 recently from Debian, and it includes fence_aws
and fence_ibmz:

- fence_aws agent being backported to Bionic (LP: #1894323)
- Add LPAR fence agent to Pacemaker (LP: #1889070)

So in this bug we should backport fence_aws to Focal and Bionic, if
possible.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1894323

Title:
  Add fence_aws fencing from v4.6.0 agent to Bionic

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/fence-agents/+bug/1894323/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1676328] Re: sssd_be is leaking memory

2020-09-22 Thread KK
Is this git release https://github.com/SSSD/sssd/releases/tag/sssd-
1_13_91 can be upgradable from `1.13.4-1ubuntu1.15` on ubuntu Xenial
16.04 LTS . I am facing memory leaks with this version on multiple
servers. Thanks

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1676328

Title:
  sssd_be is leaking memory

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/sssd/+bug/1676328/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1895526] Re: ocfs2 file system no longer write - "disk full" despite lots of free space

2020-09-22 Thread Rafael David Tinoco
Thanks a lot for catching up with this @mfo. And Richard for all the
tests.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1895526

Title:
  ocfs2 file system no longer write - "disk full" despite lots of free
  space

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1895526/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896367] Re: package ubuntu-software 3.36.1-0ubuntu0.20.04.0 failed to install/upgrade: problemas de dependencias - se deja sin configurar

2020-09-22 Thread Avital Ostromich
Thanks for taking the time to report this bug and helping to make Ubuntu
better. We appreciate the difficulties you are facing, but this appears
to be a "regular" (non-security) bug.  I have unmarked it as a security
issue since this bug does not show evidence of allowing attackers to
cross privilege boundaries nor directly cause loss of data/privacy.
Please feel free to report any other bugs you may find.

** Information type changed from Private Security to Public

** Package changed: ubuntu => gnome-software (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1896367

Title:
  package ubuntu-software 3.36.1-0ubuntu0.20.04.0 failed to
  install/upgrade: problemas de dependencias - se deja sin configurar

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-software/+bug/1896367/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896416] Re: screen locking no longer works

2020-09-22 Thread Avital Ostromich
** Information type changed from Private Security to Public Security

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1896416

Title:
  screen locking no longer works

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gdm3/+bug/1896416/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896416] [NEW] screen locking no longer works

2020-09-22 Thread Launchpad Bug Tracker
*** This bug is a security vulnerability ***

You have been subscribed to a public security bug by Avital Ostromich (avital):

in the last week, the gnome screen locking functionality stopped
working. I'm under the impression this is handled by gdm3, but if not,
please point me at the correct package.

in any case, now there's no lock icon in the power menu in the top
right, win-L does nothing, and trying to invoke manually with the gnome-
screensaver package times out after about a minute with the following
error:

$ gnome-screensaver-command -l

** (gnome-screensaver-command:212161): WARNING **: 18:46:25.014: unable to send 
message: Timeout was reached
** Message: 18:46:25.014: Did not receive a reply from the screensaver.


as well, if I suspend the system, on resume it dumps right back to the desktop 
without a prompt to re-authenticate, so this is a security issue.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: gdm3 3.34.1-1ubuntu1
ProcVersionSignature: Ubuntu 5.4.0-47.51-lowlatency 5.4.55
Uname: Linux 5.4.0-47-lowlatency x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair nvidia_modeset 
nvidia
ApportVersion: 2.20.11-0ubuntu27.8
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Sun Sep 20 18:47:40 2020
InstallationDate: Installed on 2020-07-15 (67 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
SourcePackage: gdm3
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: gdm3 (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug focal
-- 
screen locking no longer works
https://bugs.launchpad.net/bugs/1896416
You received this bug notification because you are a member of Ubuntu Bugs, 
which is subscribed to the bug report.

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896482] Re: acpi event detection crashes

2020-09-22 Thread Mauricio Faria de Oliveira
Hey Jim,

That's very good news!

I believe Alex should send you more test kernels, 
with different sets of patches included/removed,
so to bisect/identify which specific patch(es)
resolve the problem.

If you could help with testing that as well,
that would be great, so a smaller patch(set)
can be put into the Ubuntu stable release(s).

cheers,
Mauricio

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1896482

Title:
  acpi event detection crashes

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1896482/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1887338] Re: The gcc provided by gcc-10 package produces internal compiler errors not present in gcc version 10.1

2020-09-22 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: gcc-10 (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1887338

Title:
  The gcc provided by gcc-10 package produces internal compiler errors
  not present in gcc version 10.1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gcc-10/+bug/1887338/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896538] Re: [X555UB, Realtek ALC256, Speaker, Internal] Playback problem

2020-09-22 Thread Avital Ostromich
Thanks for taking the time to report this bug and helping to make Ubuntu
better. We appreciate the difficulties you are facing, but this appears
to be a "regular" (non-security) bug.  I have unmarked it as a security
issue since this bug does not show evidence of allowing attackers to
cross privilege boundaries nor directly cause loss of data/privacy.
Please feel free to report any other bugs you may find.

** Information type changed from Private Security to Public

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1896538

Title:
  [X555UB, Realtek ALC256, Speaker, Internal] Playback problem

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+bug/1896538/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1890716] Re: misidentifies .html file as Perl script when it contains JavaScript "use strict"

2020-09-22 Thread Alex A. D.
** Also affects: kde-cli-tools (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1890716

Title:
  misidentifies .html file as Perl script when it contains JavaScript
  "use strict"

To manage notifications about this bug go to:
https://bugs.launchpad.net/shared-mime-info/+bug/1890716/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1878419] Re: clean up breaks/replaces and packages that are no longer needed

2020-09-22 Thread Launchpad Bug Tracker
This bug was fixed in the package gnocchi - 4.3.5~git2020091516
.8ce26aeb-0ubuntu2

---
gnocchi (4.3.5~git2020091516.8ce26aeb-0ubuntu2) groovy; urgency=medium

  * d/control: Remove remaining Replaces of gnocchi-statsd (LP:
#1878419).

 -- Corey Bryant   Tue, 22 Sep 2020 15:46:37
-0400

** Changed in: gnocchi (Ubuntu)
   Status: In Progress => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1878419

Title:
  clean up breaks/replaces and packages that are no longer needed

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/aodh/+bug/1878419/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1857824] Re: kmimetypefinder5 misidentifies mimetype of python files containing certain strings

2020-09-22 Thread Kai Kasurinen
** Package changed: kde-cli-tools (Ubuntu) => shared-mime-info (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1857824

Title:
  kmimetypefinder5 misidentifies mimetype of python files containing
  certain strings

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/shared-mime-info/+bug/1857824/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1890716] Re: kmimetypefinder5 *.html reports wrong type

2020-09-22 Thread Kai Kasurinen
** Changed in: shared-mime-info (Ubuntu)
   Status: Invalid => New

** Bug watch added: Debian Bug tracker #887709
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=887709

** Also affects: shared-mime-info (Debian) via
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=887709
   Importance: Unknown
   Status: Unknown

** Summary changed:

- kmimetypefinder5 *.html reports wrong type
+ misidentifies .html file as Perl script when it contains JavaScript "use 
strict"

** Bug watch added: gitlab.freedesktop.org/xdg/shared-mime-info/-/issues #80
   https://gitlab.freedesktop.org/xdg/shared-mime-info/-/issues/80

** Also affects: shared-mime-info via
   https://gitlab.freedesktop.org/xdg/shared-mime-info/-/issues/80
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1890716

Title:
  misidentifies .html file as Perl script when it contains JavaScript
  "use strict"

To manage notifications about this bug go to:
https://bugs.launchpad.net/shared-mime-info/+bug/1890716/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1896682] Re: kmimetypefinder5 *.html reports wrong type

2020-09-22 Thread Kai Kasurinen
*** This bug is a duplicate of bug 1890716 ***
https://bugs.launchpad.net/bugs/1890716

** This bug has been marked a duplicate of bug 1890716
   kmimetypefinder5 *.html reports wrong type

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1896682

Title:
  kmimetypefinder5 *.html reports wrong type

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/kde-cli-tools/+bug/1896682/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

  1   2   3   4   5   >