[Bug 1925360] Re: SRU: backport the openjdk-15 security release to groovy

2021-04-26 Thread Matthias Klose
the binary packages for groovy were built in the openjdk-r/ppa ppa with
just the security pocket enabled, to be potentially be copied to the
security pocket.

the build looks good, and matches the one in hirsute.


** Tags removed: verification-needed verification-needed-groovy
** Tags added: verification-done verification-done-groovy

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1925360

Title:
  SRU: backport the openjdk-15 security release to groovy

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openjdk-15/+bug/1925360/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926249] Re: postcopy migration fails in hirsute (solved)

2021-04-26 Thread Christian Ehrhardt 
Also documented in https://askubuntu.com/questions/1334249/qemu-kvm-
postcopy-migration-fails-in-hirsute-v5-11-kernels-solved/1334250

Also added as known issue in https://discourse.ubuntu.com/t/hirsute-
hippo-release-notes/19221

I hope that this will help the case to be found by affected users.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926249

Title:
  postcopy migration fails in hirsute (solved)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/qemu/+bug/1926249/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926223] Re: Netboot Loading libc6-udeb failed for unknown reasons (focal) 2020-04-21

2021-04-26 Thread Marcel
I can confirm this bug. It bricked yesterday, right after the changes to the 
libc6-udeb package
https://launchpad.net/ubuntu/focal/amd64/libc6-udeb.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926223

Title:
  Netboot Loading libc6-udeb failed for unknown reasons (focal)
  2020-04-21

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1926223/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926249] [NEW] postcopy migration fails in hirsute (solved)

2021-04-26 Thread Christian Ehrhardt 
Public bug reported:

FYI: this is an intended change, can be overwritten via config and this
bug is mostly to have something puzzled users can find via search
engines to explain and solve their issue.

postcopy migration can in some cases be very useful
=> https://wiki.qemu.org/Features/PostCopyLiveMigration

But with Hirsute kernel being 5.11 that now contains the following upstream 
change
=> 
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=d0d4730ac2

Due to that postcopy migration will fail like:

+ lxc exec testkvm-focal-from -- virsh migrate --unsafe --live --postcopy 
--postcopy-after-precopy kvmguest-focal-postcopy qemu+ssh://10.85.93.248/system
error: internal error: unable to execute QEMU command 
'migrate-set-capabilities': Postcopy is not supported

This will also apply to e.g. a Focal-HWE kernel once on v5.11 or to
Focal userspaces in a container under a Hirsute kernel (that is the
example above).

This was done for security reasons, if you want/need to re-enable un-limited 
userfault handling to be able to use postcopy again you'd want/need to set the 
control knob to one like:
$ sudo sysctl -w "vm.unprivileged_userfaultfd=1"

** Affects: qemu (Ubuntu)
 Importance: Undecided
 Status: Invalid

** Changed in: qemu (Ubuntu)
   Status: New => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926249

Title:
  postcopy migration fails in hirsute (solved)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/qemu/+bug/1926249/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926218] Re: Disable or Remove FLoC features and the provider service

2021-04-26 Thread Olivier Tilloy
** Changed in: chromium-browser (Ubuntu)
   Status: New => Triaged

** Changed in: chromium-browser (Ubuntu)
   Importance: Undecided => High

** Changed in: chromium-browser (Ubuntu)
 Assignee: (unassigned) => Olivier Tilloy (osomon)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926218

Title:
  Disable or Remove FLoC features and the provider service

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1926218/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926248] [NEW] display scrambled - all packages

2021-04-26 Thread James Erwin
Public bug reported:

shortly after switching to kernel 5.8.0-50 on Apr 16, I got progressively worse 
display scrambling on all programs. Wrote to ubuntuforums.org Apr 19 but found 
no resolution. Thinking it was that kernel, I ran on 5.8.0-49 for a day without 
problem, then it too started the same display glitches. The problem progressed 
so far that I did a fresh system re-install on Apr 23. After, with the default 
kernel, 5.8.0-50, scrambling was worse than ever, almost unusable. Fortunately, 
the second kernel offered was 5.8.0-43. I have run on that kernel for 3 days 
now with no sign of the scrambling issue. 
The attached png shows static image corruption examples. The more dramatic 
strobing, spontaneous jumping from window to window, window re-mapping, video 
corruption etc., I was unable to capture.
Running Ubuntu 20.04.2 LTS

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: xorg 1:7.7+19ubuntu14
ProcVersionSignature: Ubuntu 5.8.0-43.49~20.04.1-generic 5.8.18
Uname: Linux 5.8.0-43-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.16
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CasperMD5CheckResult: skip
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Mon Apr 26 21:48:37 2021
DistUpgraded: Fresh install
DistroCodename: focal
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics 
Controller [8086:0412] (rev 06) (prog-if 00 [VGA controller])
   Subsystem: Dell Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics 
Controller [1028:0622]
InstallationDate: Installed on 2021-04-23 (3 days ago)
InstallationMedia: Ubuntu 20.04.2.0 LTS "Focal Fossa" - Release amd64 
(20210209.1)
MachineType: Dell Inc. Inspiron 3847
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.8.0-43-generic 
root=UUID=0fa2ade9-fdd6-4cfa-a153-0de2be1f39ae ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/29/2015
dmi.bios.release: 65.8
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A08
dmi.board.name: 088DT1
dmi.board.vendor: Dell Inc.
dmi.board.version: A01
dmi.chassis.type: 3
dmi.chassis.vendor: Dell Inc.
dmi.modalias: 
dmi:bvnDellInc.:bvrA08:bd06/29/2015:br65.8:svnDellInc.:pnInspiron3847:pvr:rvnDellInc.:rn088DT1:rvrA01:cvnDellInc.:ct3:cvr:
dmi.product.family: To be filled by O.E.M.
dmi.product.name: Inspiron 3847
dmi.product.sku: 0622
dmi.sys.vendor: Dell Inc.
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.102-1ubuntu1~20.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 20.2.6-0ubuntu0.20.04.1
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.9-2ubuntu1.2~20.04.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20200226-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug corruption focal ubuntu

** Attachment added: "static corruption examples"
   
https://bugs.launchpad.net/bugs/1926248/+attachment/5492641/+files/joint%20scramble%20examples.png

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926248

Title:
  display scrambled - all packages

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1926248/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1921754] Re: Add missing cpu feature bits in EPYC-Rome model

2021-04-26 Thread Christian Ehrhardt 
The regression tests are good as well with the only hiccups being the
known postcopy-after-precopy denial and a known bug in hirsute guest
kernels on s390x. Nothing new introduced by the changes as far as I can
see.

prep (x86_64): Pass   20  F/S/N  0/0/0 - RC 0 (10 min 38961 lin)
migrate (x86_64) : Pass  720  F/S/N 36/0/0 - RC 36 (444 min 776248 lin)
cross (x86_64)   : Pass   46  F/S/N  0/0/1 - RC 0 (53 min 72466 lin)
misc (x86_64): Pass  219  F/S/N  0/0/0 - RC 0 (87 min 120975 lin)

prep (s390x) : Pass   20  F/S/N  0/0/0 - RC 0 (10 min 26102 lin)
migrate (s390x)  : Pass  718  F/S/N 22/16/0 - RC 22 (501 min 582924 lin)
cross (s390x): Pass   46  F/S/N  0/0/1 - RC 0 (42 min 66256 lin)
misc (s390x) : Pass  199  F/S/N  2/0/0 - RC 2 (74 min 95916 lin)

** Tags removed: verification-needed verification-needed-groovy
** Tags added: verification-done verification-done-groovy

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1921754

Title:
  Add missing cpu feature bits in EPYC-Rome model

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libvirt/+bug/1921754/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1921880] Re: Add EPYC-Milan model

2021-04-26 Thread Christian Ehrhardt 
The regression tests are good as well with the only hiccups being the
known postcopy-after-precopy denial and a known bug in hirsute guest
kernels on s390x. Nothing new introduced by the changes as far as I can
see.

prep (x86_64): Pass   20  F/S/N  0/0/0 - RC 0 (10 min 38961 lin)
migrate (x86_64) : Pass  720  F/S/N 36/0/0 - RC 36 (444 min 776248 lin)
cross (x86_64)   : Pass   46  F/S/N  0/0/1 - RC 0 (53 min 72466 lin)
misc (x86_64): Pass  219  F/S/N  0/0/0 - RC 0 (87 min 120975 lin)

prep (s390x) : Pass   20  F/S/N  0/0/0 - RC 0 (10 min 26102 lin)
migrate (s390x)  : Pass  718  F/S/N 22/16/0 - RC 22 (501 min 582924 lin)
cross (s390x): Pass   46  F/S/N  0/0/1 - RC 0 (42 min 66256 lin)
misc (s390x) : Pass  199  F/S/N  2/0/0 - RC 2 (74 min 95916 lin)

** Tags removed: verification-needed verification-needed-groovy
** Tags added: verification-done verification-done-groovy

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1921880

Title:
  Add EPYC-Milan model

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libvirt/+bug/1921880/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1922907] Re: Unable to use Skylake capability on Cascadelake server

2021-04-26 Thread Christian Ehrhardt 
The regression tests are good as well with the only hiccups being the
known postcopy-after-precopy denial and a known bug in hirsute guest
kernels on s390x. Nothing new introduced by the changes as far as I can
see.

prep (x86_64): Pass   20  F/S/N  0/0/0 - RC 0 (10 min 38961 lin)
migrate (x86_64) : Pass  720  F/S/N 36/0/0 - RC 36 (444 min 776248 lin)
cross (x86_64)   : Pass   46  F/S/N  0/0/1 - RC 0 (53 min 72466 lin)
misc (x86_64): Pass  219  F/S/N  0/0/0 - RC 0 (87 min 120975 lin)

prep (s390x) : Pass   20  F/S/N  0/0/0 - RC 0 (10 min 26102 lin)
migrate (s390x)  : Pass  718  F/S/N 22/16/0 - RC 22 (501 min 582924 lin)
cross (s390x): Pass   46  F/S/N  0/0/1 - RC 0 (42 min 66256 lin)
misc (s390x) : Pass  199  F/S/N  2/0/0 - RC 2 (74 min 95916 lin)

** Tags removed: verification-needed verification-needed-focal
** Tags added: verification-done verification-done-focal

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1922907

Title:
  Unable to use Skylake capability on Cascadelake server

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libvirt/+bug/1922907/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1925010] Re: shim-signed 15.4 does not boot on EFI 1.10 systems

2021-04-26 Thread Steve Langasek
That is not the same issue.  Please file a separate bug report.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1925010

Title:
  shim-signed 15.4 does not boot on EFI 1.10 systems

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/shim/+bug/1925010/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883089] Re: [L3] floating IP failed to bind due to no agent gateway port(fip-ns)

2021-04-26 Thread Hemanth Nakkina
SRU Team,
 
The fix has 2 commits (referred stable/ussuri below)
https://review.opendev.org/c/openstack/neutron/+/779614
https://review.opendev.org/c/openstack/neutron/+/779613

779614 is already part of focal (latest ussuri stable point release on Apr 12)
Uploaded debdiff with changes from 779613

** Changed in: neutron (Ubuntu Focal)
 Assignee: (unassigned) => Hemanth Nakkina (hemanth-n)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883089

Title:
  [L3] floating IP failed to bind due to no agent gateway port(fip-ns)

To manage notifications about this bug go to:
https://bugs.launchpad.net/neutron/+bug/1883089/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883089] Re: [L3] floating IP failed to bind due to no agent gateway port(fip-ns)

2021-04-26 Thread Hemanth Nakkina
** Description changed:

  In patch [1] it introduced a binding of DB uniq constraint for L3
  agent gateway. In some extreme case the DvrFipGatewayPortAgentBinding
  is in DB while the gateway port not. The current code path only checks
  the binding existence which will pass a "None" port to the following
  code path that results an AttributeError.
  
  [1] https://review.opendev.org/#/c/702547/
- 
  
  Exception log:
  
  2020-06-11 15:39:28.361 1285214 INFO neutron.db.l3_dvr_db [None 
req-d6a41187-2495-46bf-a424-ab7195c0ecb1 - - - - -] Floating IP Agent Gateway 
port for network 3fcb7702-ae0b-46b4-807f-8ae94d656dd3 does not exist on host 
host-compute-1. Creating one.
  2020-06-11 15:39:28.370 1285214 DEBUG neutron.db.l3_dvr_db [None 
req-d6a41187-2495-46bf-a424-ab7195c0ecb1 - - - - -] Floating IP Agent Gateway 
port for network 3fcb7702-ae0b-46b4-807f-8ae94d656dd3 already exists on host 
host-compute-1. Probably it was just created by other worker. 
create_fip_agent_gw_port_if_not_exists 
/usr/lib/python2.7/site-packages/neutron/db/l3_dvr_db.py:927
  2020-06-11 15:39:28.390 1285214 DEBUG neutron.db.l3_dvr_db [None 
req-d6a41187-2495-46bf-a424-ab7195c0ecb1 - - - - -] Floating IP Agent Gateway 
port None found for the destination host: host-compute-1 
create_fip_agent_gw_port_if_not_exists 
/usr/lib/python2.7/site-packages/neutron/db/l3_dvr_db.py:933
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server [None 
req-d6a41187-2495-46bf-a424-ab7195c0ecb1 - - - - -] Exception during message 
handling: AttributeError: 'NoneType' object has no attribute 'get'
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server Traceback 
(most recent call last):
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server   File 
"/usr/lib/python2.7/site-packages/oslo_messaging/rpc/server.py", line 170, in 
_process_incoming
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server res = 
self.dispatcher.dispatch(message)
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server   File 
"/usr/lib/python2.7/site-packages/oslo_messaging/rpc/dispatcher.py", line 220, 
in dispatch
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server return 
self._do_dispatch(endpoint, method, ctxt, args)
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server   File 
"/usr/lib/python2.7/site-packages/oslo_messaging/rpc/dispatcher.py", line 190, 
in _do_dispatch
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server result = 
func(ctxt, **new_args)
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server   File 
"/usr/lib/python2.7/site-packages/neutron/db/api.py", line 91, in wrapped
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server 
setattr(e, '_RETRY_EXCEEDED', True)
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server   File 
"/usr/lib/python2.7/site-packages/oslo_utils/excutils.py", line 220, in __exit__
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server 
self.force_reraise()
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server   File 
"/usr/lib/python2.7/site-packages/oslo_utils/excutils.py", line 196, in 
force_reraise
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server 
six.reraise(self.type_, self.value, self.tb)
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server   File 
"/usr/lib/python2.7/site-packages/neutron/db/api.py", line 87, in wrapped
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server return 
f(*args, **kwargs)
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server   File 
"/usr/lib/python2.7/site-packages/oslo_db/api.py", line 147, in wrapper
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server 
ectxt.value = e.inner_exc
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server   File 
"/usr/lib/python2.7/site-packages/oslo_utils/excutils.py", line 220, in __exit__
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server 
self.force_reraise()
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server   File 
"/usr/lib/python2.7/site-packages/oslo_utils/excutils.py", line 196, in 
force_reraise
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server 
six.reraise(self.type_, self.value, self.tb)
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server   File 
"/usr/lib/python2.7/site-packages/oslo_db/api.py", line 135, in wrapper
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server return 
f(*args, **kwargs)
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server   File 
"/usr/lib/python2.7/site-packages/neutron/db/api.py", line 126, in wrapped
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server 
LOG.debug("Retry wrapper got retriable exception: %s", e)
  2020-06-11 15:39:28.391 1285214 ERROR oslo_messaging.rpc.server   File 
"/usr/lib/python2.7/site-packages/oslo_utils/excutils.py", line 220, 

[Bug 1926196] Re: Ubuntu 21.04 encrypted disk with zfs, fails to start/decrypt with recovery key

2021-04-26 Thread Sai Vinoba
Third attempt. Drops to busybox prompt.

** Attachment added: "Screenshot_ubuntu_2021-04-27_09:39:31.png"
   
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1926196/+attachment/5492638/+files/Screenshot_ubuntu_2021-04-27_09%3A39%3A31.png

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926196

Title:
  Ubuntu 21.04 encrypted disk with zfs, fails to start/decrypt with
  recovery key

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1926196/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1925964] Re: HP NC364T NIC with 20.04.2 LTS Issues

2021-04-26 Thread Kai-Heng Feng
So kernel 5.4 works and 5.8 is broken?

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1925964

Title:
  HP NC364T NIC with 20.04.2 LTS Issues

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1925964/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926196] Re: Ubuntu 21.04 encrypted disk with zfs, fails to start/decrypt with recovery key

2021-04-26 Thread Sai Vinoba
Second attempt. The error message is repeated twice (staked above the
previous). Normal?!

** Attachment added: "Screenshot_ubuntu_2021-04-27_09:38:41.png"
   
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1926196/+attachment/5492637/+files/Screenshot_ubuntu_2021-04-27_09%3A38%3A41.png

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926196

Title:
  Ubuntu 21.04 encrypted disk with zfs, fails to start/decrypt with
  recovery key

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1926196/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926244] [NEW] System Blinking and Menu Closing Autometically

2021-04-26 Thread Bapi Dey
Public bug reported:

This is youtube video of the bug -> https://youtu.be/Kna72p3smqI. 
Happing on ubuntu 21.04 amd.

** Affects: wayland (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926244

Title:
  System Blinking and Menu Closing Autometically

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/wayland/+bug/1926244/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926196] Re: Ubuntu 21.04 encrypted disk with zfs, fails to start/decrypt with recovery key

2021-04-26 Thread Sai Vinoba
First attempt.

** Attachment added: "Screenshot_ubuntu_2021-04-27_09:38:06.png"
   
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1926196/+attachment/5492636/+files/Screenshot_ubuntu_2021-04-27_09%3A38%3A06.png

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926196

Title:
  Ubuntu 21.04 encrypted disk with zfs, fails to start/decrypt with
  recovery key

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1926196/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1925010] Re: shim-signed 15.4 does not boot on EFI 1.10 systems

2021-04-26 Thread MikeMecanic
I have the same issue with secure boot enabled. Unsigned kernel
5.12-rc7+8 won't boot unless secure boot is disabled: invalid signature.
Mok manager is not responding. ThinkPad Kubuntu or Ubuntu 21.04.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1925010

Title:
  shim-signed 15.4 does not boot on EFI 1.10 systems

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/shim/+bug/1925010/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926196] Re: Ubuntu 21.04 encrypted disk with zfs, fails to start/decrypt with recovery key

2021-04-26 Thread Sai Vinoba
I tested with Xubuntu 21.04 iso and confirm the reported issue. Below is
what I tried.

1) Install with lvm+encryption option. 
2) Note down the recovery key. 
3) At next boot, use recovery key instead of passphrase that we set. 
4) The key unlocks the disk and we are able to login.
5) Once logged in, used 'luksChangekey' option to change the recovery key. 
Reboot.
6) Use the new (changed) recovery key. Key unlocks and able to boot into system.

Re-did the test but now with ZFS+encryption option. Step 3) fails to
unlock the disk if we use recovery key. After 3 failed attempts, we are
dropped to initramfs (busybox) prompt.

Decryption is OK if we use the passphrase we set.

Screenshots are attached below.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926196

Title:
  Ubuntu 21.04 encrypted disk with zfs, fails to start/decrypt with
  recovery key

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1926196/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926196] Re: Ubuntu 21.04 encrypted disk with zfs, fails to start/decrypt with recovery key

2021-04-26 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: ubiquity (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926196

Title:
  Ubuntu 21.04 encrypted disk with zfs, fails to start/decrypt with
  recovery key

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1926196/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1916727] Re: Second monitor not detected after kernel update for Ubuntu 20.04 LTS

2021-04-26 Thread Launchpad Bug Tracker
[Expired for linux (Ubuntu) because there has been no activity for 60
days.]

** Changed in: linux (Ubuntu)
   Status: Incomplete => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1916727

Title:
  Second monitor not detected after kernel update for Ubuntu 20.04 LTS

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1916727/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1923557] Re: CirrusLogic: The default input volume is "0%"

2021-04-26 Thread You-Sheng Yang
Upstream patch in
https://git.kernel.org/pub/scm/linux/kernel/git/tiwai/sound.git/commit/?id=0e853a9c3937caa9f13fdde547d6202f92457c2b

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1923557

Title:
  CirrusLogic: The default input volume is "0%"

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/1923557/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1925987] Re: crond is not stoped

2021-04-26 Thread Bapi Dey
** Summary changed:

- cornd is not stoped
+ crond is not stoped

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1925987

Title:
  crond is not stoped

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1925987/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883089] Re: [L3] floating IP failed to bind due to no agent gateway port(fip-ns)

2021-04-26 Thread Hemanth Nakkina
** Also affects: neutron (Ubuntu Impish)
   Importance: Undecided
   Status: New

** Also affects: neutron (Ubuntu Hirsute)
   Importance: Undecided
   Status: New

** Also affects: neutron (Ubuntu Groovy)
   Importance: Undecided
   Status: New

** Changed in: neutron (Ubuntu Impish)
   Status: New => Fix Released

** Changed in: neutron (Ubuntu Hirsute)
   Status: New => Fix Released

** Changed in: neutron (Ubuntu Groovy)
   Status: New => Fix Released

** Tags added: sts

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883089

Title:
  [L3] floating IP failed to bind due to no agent gateway port(fip-ns)

To manage notifications about this bug go to:
https://bugs.launchpad.net/neutron/+bug/1883089/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1924997] Re: CirrusLogic: Cracking noises appears in built-in speaker when output volume is set >80%

2021-04-26 Thread You-Sheng Yang
In Ubuntu-oem-5.10-5.10.0-1025.26.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1924997

Title:
  CirrusLogic: Cracking noises appears in built-in speaker when output
  volume is set >80%

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/1924997/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926050] Re: Web benchmark freezing and crashing the system

2021-04-26 Thread Kai-Heng Feng
** Also affects: mesa (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926050

Title:
  Web benchmark freezing and crashing the system

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1926050/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926236] Re: Fix The sound has noise while audio volume is maximum

2021-04-26 Thread koba
** Description changed:

  [Impact]
  The sound has noise while turning the audio volume to maximum
  
  [Fix]
- For VEGA & Polaris, need two patches(landed on mainline kernel) to fix and a 
modprobe 
+ For VEGA & Polaris, need two patches(landed on mainline kernel) to fix and a 
modprobe
  1.(50ceb1fe7a) drm/amd/pm: bug fix for pcie dpm, has landed on oem kernel.
- 2.(9d03730ecb) drm/amd/pm: workaround for audio noise issue.
- 3. #modprobe amdgpu ppfeaturemask=0xfff7bffb
+ 2.(9d03730ecb) drm/amd/pm: workaround for audio noise issue, has landed on 
oem kernel
+ 3. #modprobe amdgpu ppfeaturemask=0xfff7bffb.
  For Navi_1x, need smc firmware to fix.
  1. (4fe6e53b96 linux-firmware) amdgpu: update navi10 SMC firmware
  1. (8ab7abaf63 linux-firmware) amdgpu: update navi14 SMC firmware
  
  [Test]
  Verified on RKL platform with wx3200(Polaris series) and wx5500(Navi series).
  
  [Where problems could occur]
  Because disabling DPM, the power consumption would be higher.

** No longer affects: linux (Ubuntu)

** No longer affects: linux-oem-5.10 (Ubuntu)

** No longer affects: linux (Ubuntu Focal)

** No longer affects: linux (Ubuntu Impish)

** No longer affects: linux-oem-5.10 (Ubuntu Focal)

** No longer affects: linux-oem-5.10 (Ubuntu Impish)

** No longer affects: linux-firmware (Ubuntu Impish)

** Also affects: linux-firmware (Ubuntu Hirsute)
   Importance: Undecided
   Status: New

** Also affects: linux-firmware (Ubuntu Groovy)
   Importance: Undecided
   Status: New

** Also affects: linux-firmware (Ubuntu Bionic)
   Importance: Undecided
   Status: New

** Changed in: linux-firmware (Ubuntu Bionic)
 Assignee: (unassigned) => koba (kobako)

** Changed in: linux-firmware (Ubuntu Groovy)
 Assignee: (unassigned) => koba (kobako)

** Changed in: linux-firmware (Ubuntu Hirsute)
 Assignee: (unassigned) => koba (kobako)

** Changed in: linux-firmware (Ubuntu Bionic)
   Status: New => In Progress

** Changed in: linux-firmware (Ubuntu Groovy)
   Status: New => In Progress

** Changed in: linux-firmware (Ubuntu Hirsute)
   Status: New => In Progress

** Description changed:

  [Impact]
  The sound has noise while turning the audio volume to maximum
  
  [Fix]
  For VEGA & Polaris, need two patches(landed on mainline kernel) to fix and a 
modprobe
  1.(50ceb1fe7a) drm/amd/pm: bug fix for pcie dpm, has landed on oem kernel.
  2.(9d03730ecb) drm/amd/pm: workaround for audio noise issue, has landed on 
oem kernel
  3. #modprobe amdgpu ppfeaturemask=0xfff7bffb.
  For Navi_1x, need smc firmware to fix.
  1. (4fe6e53b96 linux-firmware) amdgpu: update navi10 SMC firmware
  1. (8ab7abaf63 linux-firmware) amdgpu: update navi14 SMC firmware
  
  [Test]
  Verified on RKL platform with wx3200(Polaris series) and wx5500(Navi series).
  
  [Where problems could occur]
- Because disabling DPM, the power consumption would be higher.
+ Because disabling DPM, the power consumption would be slightly higher.

** No longer affects: linux-firmware (Ubuntu Bionic)

** No longer affects: linux-firmware (Ubuntu Groovy)

** No longer affects: linux-firmware (Ubuntu Hirsute)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926236

Title:
  Fix The sound has noise while audio volume is maximum

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/1926236/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883089] Re: [L3] floating IP failed to bind due to no agent gateway port(fip-ns)

2021-04-26 Thread Hemanth Nakkina
** Also affects: neutron (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: neutron (Ubuntu Focal)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883089

Title:
  [L3] floating IP failed to bind due to no agent gateway port(fip-ns)

To manage notifications about this bug go to:
https://bugs.launchpad.net/neutron/+bug/1883089/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1923557] Re: CirrusLogic: The default input volume is "0%"

2021-04-26 Thread You-Sheng Yang
** Changed in: linux-oem-5.10 (Ubuntu Focal)
   Status: Incomplete => In Progress

** Changed in: linux (Ubuntu Hirsute)
   Status: Incomplete => In Progress

** Changed in: linux (Ubuntu)
   Status: Incomplete => In Progress

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1923557

Title:
  CirrusLogic: The default input volume is "0%"

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/1923557/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926241] [NEW] crash upgrade

2021-04-26 Thread Diep Vuong Thang
Public bug reported:

crash upgrade version

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ubuntu-release-upgrader-core 1:18.04.17
ProcVersionSignature: Ubuntu 4.15.0-45.48-generic 4.15.18
Uname: Linux 4.15.0-45-generic x86_64
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: ubuntu:GNOME
Date: Tue Apr 27 10:22:11 2021
InstallationDate: Installed on 2018-08-01 (1000 days ago)
InstallationMedia: Ubuntu 16.04.4 LTS "Xenial Xerus" - Release amd64 (20180228)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
UpgradeStatus: No upgrade log present (probably fresh install)
VarLogDistupgradeTermlog:

** Affects: ubuntu-release-upgrader (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug bionic dist-upgrade third-party-packages

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926241

Title:
  crash upgrade

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+bug/1926241/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1919951] Re: snap install seemed to crash the machine, reboot now put package management in a bad state

2021-04-26 Thread Doug Jacobs
I rebooted my VM a few times, and was able to remove chromium from Snap.
Not sure why it took more than one reboot but something eventually got
unstuck.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1919951

Title:
  snap install seemed to crash the machine, reboot now put package
  management in a bad state

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1919951/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926223] Re: Netboot Loading libc6-udeb failed for unknown reasons (focal) 2020-04-21

2021-04-26 Thread Chris Guiver
A known & trusted user reported the other bug fixed on 2020-03-18, but
the bug did not reach CONFIRMED status until 2020-03-20 (two days after
the 'fixed' report).

The other bug is still OPEN & has a CONFIRMED status.

This bug report has yet to be confirmed, so I'll treat it as unique.

Thank you for taking the time to report this bug and helping to make
Ubuntu better. Please execute the following command only once, as it
will automatically gather debugging information, in a terminal:

apport-collect 1926223

When reporting bugs in the future please use apport by using 'ubuntu-
bug' and the name of the package affected. You can learn more about this
functionality at https://wiki.ubuntu.com/ReportingBugs.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926223

Title:
  Netboot Loading libc6-udeb failed for unknown reasons (focal)
  2020-04-21

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1926223/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926181] Re: Ubuntu 21.04 boot fails on MacBook and iMac

2021-04-26 Thread Boudhayan Bhattacharya
Sounds like https://bugs.launchpad.net/ubuntu/+source/ubuntu-release-
upgrader/+bug/1924752/comments/6? Can you please check?

> On upgrading to Ubuntu 21.04 on both my MacBook and iMac after the intro 
> music 
> nothing happens. Left with a frozen blank screen. Only way out is to hold the 
> power button. Using efi boot.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926181

Title:
  Ubuntu 21.04 boot fails on MacBook and iMac

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+bug/1926181/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926240] [NEW] package firmware-b43-installer 1:019-4 failed to install/upgrade: installed firmware-b43-installer package post-installation script subprocess returned error exit status 1

2021-04-26 Thread deibys soca
Public bug reported:

En la actualización no se pudo actualizar el paquete
firmware-b43-installer

ProblemType: Package
DistroRelease: Ubuntu 20.04
Package: firmware-b43-installer 1:019-4
ProcVersionSignature: Ubuntu 5.4.0-72.80-generic 5.4.101
Uname: Linux 5.4.0-72-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.16
Architecture: amd64
CasperMD5CheckResult: skip
Date: Mon Apr 26 23:14:09 2021
ErrorMessage: installed firmware-b43-installer package post-installation script 
subprocess returned error exit status 1
InstallationDate: Installed on 2018-11-14 (894 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
PackageArchitecture: all
Python3Details: /usr/bin/python3.8, Python 3.8.5, python3-minimal, 
3.8.2-0ubuntu2
PythonDetails: /usr/bin/python2.7, Python 2.7.18, python-is-python2, 2.7.17-4
RelatedPackageVersions:
 dpkg 1.19.7ubuntu3
 apt  2.0.5
SourcePackage: b43-fwcutter
Title: package firmware-b43-installer 1:019-4 failed to install/upgrade: 
installed firmware-b43-installer package post-installation script subprocess 
returned error exit status 1
UpgradeStatus: Upgraded to focal on 2021-04-27 (0 days ago)

** Affects: b43-fwcutter (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package focal

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926240

Title:
  package firmware-b43-installer 1:019-4 failed to install/upgrade:
  installed firmware-b43-installer package post-installation script
  subprocess returned error exit status 1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/b43-fwcutter/+bug/1926240/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926240] Re: package firmware-b43-installer 1:019-4 failed to install/upgrade: installed firmware-b43-installer package post-installation script subprocess returned error exit status 1

2021-04-26 Thread Apport retracing service
** Tags removed: need-duplicate-check

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926240

Title:
  package firmware-b43-installer 1:019-4 failed to install/upgrade:
  installed firmware-b43-installer package post-installation script
  subprocess returned error exit status 1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/b43-fwcutter/+bug/1926240/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883315] Re: Showing esm update as installable when esm is disabled

2021-04-26 Thread Bryce Harrington
** Merge proposal linked:
   
https://code.launchpad.net/~chad.smith/ubuntu/+source/update-notifier/+git/update-notifier/+merge/401826

** Merge proposal linked:
   
https://code.launchpad.net/~chad.smith/ubuntu/+source/update-notifier/+git/update-notifier/+merge/401662

** Merge proposal linked:
   
https://code.launchpad.net/~lamoura/ubuntu/+source/update-notifier/+git/update-notifier/+merge/401657

** Merge proposal linked:
   
https://code.launchpad.net/~lamoura/ubuntu/+source/update-notifier/+git/update-notifier/+merge/401653

** Merge proposal linked:
   
https://code.launchpad.net/~lamoura/ubuntu/+source/update-notifier/+git/update-notifier/+merge/401473

** Changed in: update-notifier (Ubuntu Bionic)
   Status: New => In Progress

** Changed in: update-notifier (Ubuntu Focal)
   Status: New => In Progress

** Changed in: update-notifier (Ubuntu Hirsute)
   Status: New => In Progress

** Changed in: update-notifier (Ubuntu Impish)
   Status: New => In Progress

** Changed in: update-notifier (Ubuntu Bionic)
   Importance: Undecided => High

** Changed in: update-notifier (Ubuntu Focal)
   Importance: Undecided => High

** Changed in: update-notifier (Ubuntu Hirsute)
   Importance: Undecided => High

** Changed in: update-notifier (Ubuntu Impish)
   Importance: Undecided => High

** Description changed:

- I came across a scenario where the output of `/usr/lib/update-notifier
- /apt-check --human-readable` is showing some (not all) esm updates as
- being installable when esm itself is disabled:
+ [Impact]
+ when users are getting the message update-notifier message through apt-check 
they may find inconsistent behavior regarding ESM products. This is misleading 
since we will say to the users that they don't have ESM Infra, but they do have 
ESM infra packages that can be installed. This is poor marketing of our products
+ 
+ [Test case]
+ 
+ To reproduce the issue, you can:
+ 
+ 1. Launch the following old version of a xenial container:
+lxc launch 
ubuntu:f4c4c60a6b752a381288ae72a1689a9da00f8e03b732c8d1b8a8fcd1a8890800 dev-x
+ 
+ 2. Run apt update and install the updated version of update-notifier-common
+ 3. Add the ubuntu-advantage-tools ppa:
+https://code.launchpad.net/~ua-client/+archive/ubuntu/daily
+ 4. Install ubuntu-advantage-tools
+ 5. Install the latest version of uaclient from the stable ppa:
+https://launchpad.net/~ua-client/+archive/ubuntu/stable/
+ 6. Comment out all mentions of xenial-security in /etc/apt/source.list
+ 7. Run apt update
+ 8. Run /usr/lib/update-notifier/apt-check --human-readable
+ 9. See a message like this:
+
+ UA Infra: Extended Security Maintenance (ESM) is not enabled.
+ 
+ 256 packages can be updated.
+ 5 of these updates are fixed through UA Infra: ESM.
+ 5 of these updates are security updates.
+ To see these additional updates run: apt list --upgradable
+ 
+ Enable UA Infra: ESM to receive 5 additional security updates.
+ See https://ubuntu.com/security/esm or run: sudo ua status
+ 
+ 
+ To verify that the error is fixed:
+ 
+ 1.Perform all the stages above until step 8
+ 2 Install the new update-notifier from this ppa:
+   https://launchpad.net/~lamoura/+archive/ubuntu/update-notifier-test-ppa
+ 3. Run /usr/lib/update-notifier/apt-check --human-readable
+ 4. See a message like this:
+ 
+ 256 updates can be installed immediately.
+ 5 of these updates are security updates.
+ To see these additional updates run: apt list --upgradable
+ 
+ 5. We are now only showing ESM infra specific message if the distro is
+ ESM. To enforce that behavior, make the `is_esm_distro` function in
+ `/usr/lub/update-notifier/apt-check` return True, then you will see this
+ message:
+ 
+ UA Infra: Extended Security Maintenance (ESM) is not enabled.
+ 
+ 256 updates can be installed immediately.
+ 5 of these updates are security updates.
+ To see these additional updates run: apt list --upgradable
+ 
+ 5 additional security updates can be applied with UA Infra: ESM
+ Learn more about enabling UA Infra: ESM service at https://ubuntu.com/esm
+ 
+ That is now correct.
+ 
+ [Where problems could occur]
+ 
+ The changes in this package should only be seen when MOTD is getting a
+ new message. If that script fails for some reason, it seems that MOTD
+ will only not present the message, which is doesn't seem to be a system
+ critical issue. Additionally, we would potentially have tracebacks in
+ the update-notifier logs. Finally, if the logic is also incorrect, we
+ would be displying incorrect ESM messages to the user. But since we are
+ doing this now, as this bug shows, I don't think this is critical as
+ well.
+ 
+ [Discussion]
+ 
+ With ESM Apps going to production soon, we have decided to update the
+ messages delivered by update-notifier apt-check to address the package
+ count of ESM Apps and the possibility of installing more upgrades if the
+ user has ESM Apps disabled.
+ 
+ We are also updating other parts of the messaging as well. First, we only 

[Bug 1924766] Re: update-notifier does not handle ESM Apps in the apt-check script

2021-04-26 Thread Bryce Harrington
** Changed in: update-notifier (Ubuntu Bionic)
   Status: New => In Progress

** Changed in: update-notifier (Ubuntu Focal)
   Status: New => In Progress

** Changed in: update-notifier (Ubuntu Hirsute)
   Status: New => In Progress

** Changed in: update-notifier (Ubuntu Impish)
   Status: New => In Progress

** Changed in: update-notifier (Ubuntu Bionic)
   Importance: Undecided => High

** Changed in: update-notifier (Ubuntu Focal)
   Importance: Undecided => High

** Changed in: update-notifier (Ubuntu Hirsute)
   Importance: Undecided => High

** Changed in: update-notifier (Ubuntu Impish)
   Importance: Undecided => High

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1924766

Title:
  update-notifier does not handle ESM Apps in the apt-check script

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/update-notifier/+bug/1924766/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926208] Re: standard security upgrade counts should not include ESM packages

2021-04-26 Thread Bryce Harrington
** Merge proposal linked:
   
https://code.launchpad.net/~lamoura/ubuntu/+source/update-notifier/+git/update-notifier/+merge/401473

** Merge proposal linked:
   
https://code.launchpad.net/~lamoura/ubuntu/+source/update-notifier/+git/update-notifier/+merge/401653

** Merge proposal linked:
   
https://code.launchpad.net/~lamoura/ubuntu/+source/update-notifier/+git/update-notifier/+merge/401657

** Merge proposal linked:
   
https://code.launchpad.net/~chad.smith/ubuntu/+source/update-notifier/+git/update-notifier/+merge/401662

** Merge proposal linked:
   
https://code.launchpad.net/~chad.smith/ubuntu/+source/update-notifier/+git/update-notifier/+merge/401826

** Also affects: update-notifier (Ubuntu Groovy)
   Importance: Undecided
   Status: New

** Also affects: update-notifier (Ubuntu Bionic)
   Importance: Undecided
   Status: New

** Also affects: update-notifier (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Also affects: update-notifier (Ubuntu Focal)
   Importance: Undecided
   Status: New

** Also affects: update-notifier (Ubuntu Impish)
   Importance: Undecided
   Status: New

** Also affects: update-notifier (Ubuntu Hirsute)
   Importance: Undecided
   Status: New

** Changed in: update-notifier (Ubuntu Xenial)
   Status: New => In Progress

** Changed in: update-notifier (Ubuntu Bionic)
   Status: New => In Progress

** Changed in: update-notifier (Ubuntu Focal)
   Status: New => In Progress

** Changed in: update-notifier (Ubuntu Hirsute)
   Status: New => In Progress

** Changed in: update-notifier (Ubuntu Impish)
   Status: New => In Progress

** Changed in: update-notifier (Ubuntu Impish)
   Importance: Undecided => High

** Changed in: update-notifier (Ubuntu Hirsute)
   Importance: Undecided => High

** Changed in: update-notifier (Ubuntu Focal)
   Importance: Undecided => High

** Changed in: update-notifier (Ubuntu Bionic)
   Importance: Undecided => High

** Changed in: update-notifier (Ubuntu Xenial)
   Importance: Undecided => High

** Changed in: update-notifier (Ubuntu Xenial)
 Assignee: (unassigned) => Lucas Albuquerque Medeiros de Moura (lamoura)

** Changed in: update-notifier (Ubuntu Bionic)
 Assignee: (unassigned) => Lucas Albuquerque Medeiros de Moura (lamoura)

** Changed in: update-notifier (Ubuntu Focal)
 Assignee: (unassigned) => Lucas Albuquerque Medeiros de Moura (lamoura)

** Changed in: update-notifier (Ubuntu Hirsute)
 Assignee: (unassigned) => Chad Smith (chad.smith)

** Changed in: update-notifier (Ubuntu Impish)
 Assignee: (unassigned) => Chad Smith (chad.smith)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926208

Title:
  standard security upgrade counts should not include ESM packages

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/update-notifier/+bug/1926208/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926236] [NEW] Fix The sound has noise while audio volume is maximum

2021-04-26 Thread koba
Public bug reported:

[Impact]
The sound has noise while turning the audio volume to maximum

[Fix]
For VEGA & Polaris, need two patches(landed on mainline kernel) to fix and a 
modprobe 
1.(50ceb1fe7a) drm/amd/pm: bug fix for pcie dpm, has landed on oem kernel.
2.(9d03730ecb) drm/amd/pm: workaround for audio noise issue.
3. #modprobe amdgpu ppfeaturemask=0xfff7bffb
For Navi_1x, need smc firmware to fix.
1. (4fe6e53b96 linux-firmware) amdgpu: update navi10 SMC firmware
1. (8ab7abaf63 linux-firmware) amdgpu: update navi14 SMC firmware

[Test]
Verified on RKL platform with wx3200(Polaris series) and wx5500(Navi series).

[Where problems could occur]
Because disabling DPM, the power consumption would be higher.

** Affects: linux (Ubuntu)
 Importance: Undecided
 Assignee: koba (kobako)
 Status: In Progress

** Affects: linux-firmware (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: linux-oem-5.10 (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: linux (Ubuntu Focal)
 Importance: Undecided
 Status: New

** Affects: linux-firmware (Ubuntu Focal)
 Importance: Undecided
 Assignee: koba (kobako)
 Status: In Progress

** Affects: linux-oem-5.10 (Ubuntu Focal)
 Importance: Undecided
 Assignee: koba (kobako)
 Status: In Progress

** Affects: linux (Ubuntu Impish)
 Importance: Undecided
 Assignee: koba (kobako)
 Status: In Progress

** Affects: linux-firmware (Ubuntu Impish)
 Importance: Undecided
 Status: New

** Affects: linux-oem-5.10 (Ubuntu Impish)
 Importance: Undecided
 Status: New

** Also affects: linux-firmware (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: linux-firmware (Ubuntu Impish)
   Importance: Undecided
   Status: New

** Also affects: linux-oem-5.10 (Ubuntu Impish)
   Importance: Undecided
   Status: New

** Also affects: linux-firmware (Ubuntu Focal)
   Importance: Undecided
   Status: New

** Also affects: linux-oem-5.10 (Ubuntu Focal)
   Importance: Undecided
   Status: New

** Changed in: linux-firmware (Ubuntu Focal)
 Assignee: (unassigned) => koba (kobako)

** Changed in: linux-firmware (Ubuntu Focal)
 Assignee: koba (kobako) => (unassigned)

** Changed in: linux-firmware (Ubuntu Focal)
   Status: New => In Progress

** Changed in: linux-oem-5.10 (Ubuntu Focal)
   Status: New => In Progress

** Changed in: linux-firmware (Ubuntu Focal)
 Assignee: (unassigned) => koba (kobako)

** Changed in: linux-oem-5.10 (Ubuntu Focal)
 Assignee: (unassigned) => koba (kobako)

** Also affects: linux (Ubuntu)
   Importance: Undecided
   Status: New

** Changed in: linux (Ubuntu Impish)
   Status: New => In Progress

** Changed in: linux (Ubuntu Impish)
 Assignee: (unassigned) => koba (kobako)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926236

Title:
  Fix The sound has noise while audio volume is maximum

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1926236/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1924832] Re: evince output displays wrong in Adobe Reader

2021-04-26 Thread Randall Whitman
https://gitlab.gnome.org/GNOME/evince/-/issues/1594

** Bug watch added: gitlab.gnome.org/GNOME/evince/-/issues #1594
   https://gitlab.gnome.org/GNOME/evince/-/issues/1594

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1924832

Title:
  evince output displays wrong in Adobe Reader

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/evince/+bug/1924832/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1820768] Re: [SRU] support new cab and new docking firmware upgrade in fwupd 1.2.10

2021-04-26 Thread Yuan-Chen Cheng
** Description changed:

  * Impact
  
  Bios vendor is pushing to put the new design into cab file, and also new
- docking DW19 needs the new fwupd to support it.
+ docking WD19 needs the new fwupd to support it.
  
  That needs new fwupd to support.
  
  * Background:
   1. most user does firmware update via gnome-software and it talk to fwupd.
   2. only very very limited user will call /usr/bin/fwupdate from the command 
line.
   3. the new fwupd will need a new fwupd-signed. So we will remove 
fwupdate-signed.
  
  * Current test result before we have something in proposed channel:
   1. new fwupd works well with gnome-software, so we should be safe to go.
   2. for those very limited user, they can call /usr/lib/fwupd/fwupdate to 
replace /usr/bin/fwupdate. so it should be safe to remove fwupdate.
  
  * Test case
  
  A.
  1. install the new fwupd, and plugin the new docking - DW19.
  2. fwupdmgr get-devices and check if all internal device can properly show
  
  B.
  1. If you can get new cab file, try to use fwupdmgr install XX.cab to see if 
can work properly.
  
  C.
  1. If you can get a machine that have some firmware update pending, try to go 
gnome-software, and click refresh with the new fwupd, you should be able to see 
the pending firmware showed there. Which proves that it can properly be 
integrated with gnome. (ycheng-twn have a laptop with that condition, and he 
can verify that one
  
  D.
  1. Install an 18.04 Ubuntu Desktop system.
  2. Enable bionic-proposed.
  3. Run update-manager.
  4. Ensure that the fwupd and fwupd-signed packages are installed without 
error.
  5. Ensure that no files or directories from the old fwupdate package are left 
behind in /boot/efi/EFI/ubuntu, /var/lib/fwupdate, or /var/cache/fwupdate.
  
  * Regression potential
  
  Since the upstream maintainer is back up this upgrade, and he also works
  in a major computer vendor and works closely with the BIOS team, it
  should be fairly low risk.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1820768

Title:
  [SRU] support new cab and new docking firmware upgrade in fwupd 1.2.10

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1820768/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1924766] Re: update-notifier does not handle ESM Apps in the apt-check script

2021-04-26 Thread Bryce Harrington
** Merge proposal linked:
   
https://code.launchpad.net/~lamoura/ubuntu/+source/update-notifier/+git/update-notifier/+merge/401473

** Merge proposal linked:
   
https://code.launchpad.net/~lamoura/ubuntu/+source/update-notifier/+git/update-notifier/+merge/401653

** Merge proposal linked:
   
https://code.launchpad.net/~lamoura/ubuntu/+source/update-notifier/+git/update-notifier/+merge/401657

** Merge proposal linked:
   
https://code.launchpad.net/~chad.smith/ubuntu/+source/update-notifier/+git/update-notifier/+merge/401662

** Merge proposal linked:
   
https://code.launchpad.net/~chad.smith/ubuntu/+source/update-notifier/+git/update-notifier/+merge/401826

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1924766

Title:
  update-notifier does not handle ESM Apps in the apt-check script

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/update-notifier/+bug/1924766/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1834006] Re: cpuset_hotplug from controllers in ubuntu_ltp failed

2021-04-26 Thread Kelsey Skunberg
** Tags added: sru-20210412

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1834006

Title:
  cpuset_hotplug from controllers in ubuntu_ltp failed

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-kernel-tests/+bug/1834006/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926233] [NEW] Black screen after upgrade 20.04 -> 20.10

2021-04-26 Thread Simon Cornish
Public bug reported:

Installed 20.04.2 LTS,changed the updater settings and upgraded to 20.10
After boot GRUB is presented as normal
When selecting the default Ubuntu (or waiting the timeout) then blank screen 
occurs
Backlight is on but the boot does not proceed
I have tried editing the command line with combinations of acpi=off and/or 
nomodeset without effect.
Also, even if I remove spash & quiet there is still no output at all.

This bug was filed from a clean, updated 20.04 LTS because once I did
the upgrade there was no system available to report the bug from.

Here is something else: I tried the 20.10 and 21.04 desktop installers
(from USB stick) and the behaviour is exactly the same - get to GRUB,
select either Ubuntu or Ubuntu (safe graphics) and then just the black
screen.

I tried the 20.10 server and that could proceed to the text-based
installation.

Obviously the desired outcome in either the upgrade or installer
scenario is that the system boots in a usable manner!

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: ubuntu-release-upgrader-core 1:20.04.30
ProcVersionSignature: Ubuntu 5.8.0-50.56~20.04.1-generic 5.8.18
Uname: Linux 5.8.0-50-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.16
Architecture: amd64
CasperMD5CheckResult: skip
CrashDB: ubuntu
CurrentDesktop: ubuntu:GNOME
Date: Mon Apr 26 17:45:36 2021
InstallationDate: Installed on 2021-04-27 (0 days ago)
InstallationMedia: Ubuntu 20.04.2.0 LTS "Focal Fossa" - Release amd64 
(20210209.1)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntu-release-upgrader
Symptom: dist-upgrade
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: ubuntu-release-upgrader (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug dist-upgrade focal

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926233

Title:
  Black screen after upgrade 20.04 -> 20.10

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+bug/1926233/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926233] Re: Black screen after upgrade 20.04 -> 20.10

2021-04-26 Thread Simon Cornish
Machine is MSI Prestige 15 A10SC

** Attachment added: "dmidecode.txt"
   
https://bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+bug/1926233/+attachment/5492608/+files/dmidecode.txt

** Description changed:

  Installed 20.04.2 LTS,changed the updater settings and upgraded to 20.10
  After boot GRUB is presented as normal
  When selecting the default Ubuntu (or waiting the timeout) then blank screen 
occurs
  Backlight is on but the boot does not proceed
  I have tried editing the command line with combinations of acpi=off and/or 
nomodeset without effect.
  Also, even if I remove spash & quiet there is still no output at all.
  
  This bug was filed from a clean, updated 20.04 LTS because once I did
  the upgrade there was no system available to report the bug from.
  
  Here is something else: I tried the 20.10 and 21.04 desktop installers
  (from USB stick) and the behaviour is exactly the same - get to GRUB,
- select either Ubuntu or Ubuntu (safe graphics) and then just the back
+ select either Ubuntu or Ubuntu (safe graphics) and then just the black
  screen.
  
  I tried the 20.10 server and that could proceed to the text-based
  installation.
  
  Obviously the desired outcome in either the upgrade or installer
  scenario is that the system boots in a usable manner!
  
  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: ubuntu-release-upgrader-core 1:20.04.30
  ProcVersionSignature: Ubuntu 5.8.0-50.56~20.04.1-generic 5.8.18
  Uname: Linux 5.8.0-50-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27.16
  Architecture: amd64
  CasperMD5CheckResult: skip
  CrashDB: ubuntu
  CurrentDesktop: ubuntu:GNOME
  Date: Mon Apr 26 17:45:36 2021
  InstallationDate: Installed on 2021-04-27 (0 days ago)
  InstallationMedia: Ubuntu 20.04.2.0 LTS "Focal Fossa" - Release amd64 
(20210209.1)
  PackageArchitecture: all
  ProcEnviron:
-  TERM=xterm-256color
-  PATH=(custom, no user)
-  XDG_RUNTIME_DIR=
-  LANG=en_US.UTF-8
-  SHELL=/bin/bash
+  TERM=xterm-256color
+  PATH=(custom, no user)
+  XDG_RUNTIME_DIR=
+  LANG=en_US.UTF-8
+  SHELL=/bin/bash
  SourcePackage: ubuntu-release-upgrader
  Symptom: dist-upgrade
  UpgradeStatus: No upgrade log present (probably fresh install)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926233

Title:
  Black screen after upgrade 20.04 -> 20.10

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+bug/1926233/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926233] Re: Black screen after upgrade 20.04 -> 20.10

2021-04-26 Thread Simon Cornish
Gonna go out on a limb and guess this is a video problem so here is the output 
of lshw -c video
  *-display 
   description: VGA compatible controller
   product: Intel Corporation
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@:00:02.0
   version: 04
   width: 64 bits
   clock: 33MHz
   capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
   configuration: driver=i915 latency=0
   resources: irq:151 memory:d300-d3ff memory:3000-3fff 
ioport:4000(size=64) memory:c-d
  *-display
   description: 3D controller
   product: TU117M [GeForce GTX 1650 Mobile / Max-Q]
   vendor: NVIDIA Corporation
   physical id: 0
   bus info: pci@:02:00.0
   version: a1
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list rom
   configuration: driver=nouveau latency=0
   resources: irq:150 memory:d400-d4ff memory:9000-9fff 
memory:a000-a1ff ioport:3000(size=128) memory:d500-d507

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926233

Title:
  Black screen after upgrade 20.04 -> 20.10

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+bug/1926233/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1829984] Re: memcg_usage_in_bytes from controllers test suite in LTP failed

2021-04-26 Thread Kelsey Skunberg
** Tags added: sru-20210412

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1829984

Title:
  memcg_usage_in_bytes from controllers test suite in LTP failed

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-kernel-tests/+bug/1829984/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1829995] Re: getaddrinfo_01 from ipv6_lib test suite in LTP failed

2021-04-26 Thread Kelsey Skunberg
** Tags added: sru-20210412

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1829995

Title:
  getaddrinfo_01 from ipv6_lib test suite in LTP failed

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-kernel-tests/+bug/1829995/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1847982] Re: memcg_subgroup_charge from controllers in ubuntu_ltp failed on D/E

2021-04-26 Thread Kelsey Skunberg
** Tags added: sru-20210412

** Summary changed:

- memcg_subgroup_charge from controllers in ubuntu_ltp failed on D/E
+ memcg_subgroup_charge from controllers in ubuntu_ltp failed on D/E/F/G

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1847982

Title:
  memcg_subgroup_charge from controllers in ubuntu_ltp failed on D/E/F/G

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-kernel-tests/+bug/1847982/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1853610] Re: mkfs01_ext3_sh / mkfs01_ext4_sh / nm01_sh from commands test in ubuntu_ltp fails

2021-04-26 Thread Kelsey Skunberg
** Tags added: sru-20210412

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1853610

Title:
  mkfs01_ext3_sh / mkfs01_ext4_sh / nm01_sh from commands test in
  ubuntu_ltp fails

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-kernel-tests/+bug/1853610/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1878389] Re: tpci from kernel_misc in ubuntu_ltp failed with Test-case '13'

2021-04-26 Thread Kelsey Skunberg
** Tags added: sru-20210412

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1878389

Title:
  tpci from kernel_misc in ubuntu_ltp failed with Test-case '13'

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-kernel-tests/+bug/1878389/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926223] Re: Netboot Loading libc6-udeb failed for unknown reasons (focal) 2020-04-21

2021-04-26 Thread papamoose
** This bug is no longer a duplicate of bug 1867502
   Netboot Loading libc6-udeb failed for unknown reasons (focal)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926223

Title:
  Netboot Loading libc6-udeb failed for unknown reasons (focal)
  2020-04-21

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1926223/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926220] Re: Realteck realtek alc233 not detected combojack

2021-04-26 Thread Jeannuel Garcia
I fixed it adding this to the end of /etc/modprobe.d/alsa-base.conf

options snd-hda-intel dmic_detect=0
options snd-hda-intel model=alc233-eapd

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926220

Title:
  Realteck realtek alc233 not detected combojack

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1926220/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926225] ProcEnviron.txt

2021-04-26 Thread Gary
apport information

** Attachment added: "ProcEnviron.txt"
   
https://bugs.launchpad.net/bugs/1926225/+attachment/5492604/+files/ProcEnviron.txt

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926225

Title:
  Maxima fails to start with error message "The assertion realpath(s,o)
  on line 471 of main.c in function mbin failed: Invalid argument
  Aborted (core dumped)"

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/maxima/+bug/1926225/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926225] ProcCpuinfoMinimal.txt

2021-04-26 Thread Gary
apport information

** Attachment added: "ProcCpuinfoMinimal.txt"
   
https://bugs.launchpad.net/bugs/1926225/+attachment/5492603/+files/ProcCpuinfoMinimal.txt

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926225

Title:
  Maxima fails to start with error message "The assertion realpath(s,o)
  on line 471 of main.c in function mbin failed: Invalid argument
  Aborted (core dumped)"

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/maxima/+bug/1926225/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926225] Re: Maxima fails to start with error message "The assertion realpath(s, o) on line 471 of main.c in function mbin failed: Invalid argument Aborted (core dumped)"

2021-04-26 Thread Gary
apport information

** Tags added: apport-collected hirsute

** Description changed:

- Maxima is installed but when run from the terminal or called by wxmaxima
- or texmacs, fails to run with the error messaage "The assertion
- realpath(s,o) on line 471 of main.c in function mbin failed: Invalid
- argument Aborted (core dumped)"
+ Maxima is installed but when run from the terminal or called by wxmaxima or 
texmacs, fails to run with the error messaage "The assertion realpath(s,o) on 
line 471 of main.c in function mbin failed: Invalid argument Aborted (core 
dumped)"
+ --- 
+ ProblemType: Bug
+ ApportVersion: 2.20.11-0ubuntu65
+ Architecture: amd64
+ CasperMD5CheckResult: unknown
+ CurrentDesktop: XFCE
+ DistroRelease: Ubuntu 21.04
+ InstallationDate: Installed on 2021-01-21 (95 days ago)
+ InstallationMedia: Ubuntu 20.10 "Groovy Gorilla" - Release amd64 (20201022)
+ Package: maxima 5.44.0-2
+ PackageArchitecture: amd64
+ ProcVersionSignature: Ubuntu 5.11.0-16.17-generic 5.11.12
+ Tags:  hirsute
+ Uname: Linux 5.11.0-16-generic x86_64
+ UpgradeStatus: Upgraded to hirsute on 2021-04-25 (1 days ago)
+ UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
+ _MarkForUpload: True

** Attachment added: "Dependencies.txt"
   
https://bugs.launchpad.net/bugs/1926225/+attachment/5492602/+files/Dependencies.txt

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926225

Title:
  Maxima fails to start with error message "The assertion realpath(s,o)
  on line 471 of main.c in function mbin failed: Invalid argument
  Aborted (core dumped)"

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/maxima/+bug/1926225/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1520237] Re: Num LED state does not correspond with actual state after boot

2021-04-26 Thread kairo
yep

** Changed in: dconf (Ubuntu)
 Assignee: (unassigned) => kairo (karirax)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1520237

Title:
  Num LED state does not correspond with actual state after boot

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dconf/+bug/1520237/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1520237] Re: Num LED state does not correspond with actual state after boot

2021-04-26 Thread kairo
I confirm, same problem here

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1520237

Title:
  Num LED state does not correspond with actual state after boot

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dconf/+bug/1520237/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1880645] Re: icmp_redirect.sh in net from ubuntu_kernel_selftests failed on F-OEM-5.6 / G / H

2021-04-26 Thread Kelsey Skunberg
** Tags added: sru-20210412

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1880645

Title:
  icmp_redirect.sh in net from ubuntu_kernel_selftests failed on
  F-OEM-5.6 / G / H

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-kernel-tests/+bug/1880645/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1892213] Re: psock_snd.sh in net from ubuntu_kernel_selftests ADT failure with focal/linux

2021-04-26 Thread Kelsey Skunberg
** Tags added: sru-20210412

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1892213

Title:
  psock_snd.sh in net from ubuntu_kernel_selftests ADT failure with
  focal/linux

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-kernel-tests/+bug/1892213/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926223] Re: Netboot Loading libc6-udeb failed for unknown reasons (focal) 2020-04-21

2021-04-26 Thread papamoose
*** This bug is a duplicate of bug 1867502 ***
https://bugs.launchpad.net/bugs/1867502

While the bug seems to be identical to 1867502, because it was fixed
(2020-03-17) and working for a whole year and now (2021-04-21) broke
with the release of a new netboot image I would consider this a new bug.
The fix may be the same.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926223

Title:
  Netboot Loading libc6-udeb failed for unknown reasons (focal)
  2020-04-21

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1926223/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926166] Re: DEBOOTSTRAP_PROXY and --debootstrap-proxy are undocumented

2021-04-26 Thread Treviño
** Changed in: ubuntu-dev-tools (Ubuntu)
   Status: New => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926166

Title:
  DEBOOTSTRAP_PROXY and --debootstrap-proxy are  undocumented

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-dev-tools/+bug/1926166/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926225] Re: Maxima fails to start with error message "The assertion realpath(s, o) on line 471 of main.c in function mbin failed: Invalid argument Aborted (core dumped)"

2021-04-26 Thread Chris Guiver
Thank you for taking the time to report this bug and helping to make
Ubuntu better. Please execute the following command only once, as it
will automatically gather debugging information, in a terminal:

apport-collect 1926225

When reporting bugs in the future please use apport by using 'ubuntu-
bug' and the name of the package affected. You can learn more about this
functionality at https://wiki.ubuntu.com/ReportingBugs.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926225

Title:
  Maxima fails to start with error message "The assertion realpath(s,o)
  on line 471 of main.c in function mbin failed: Invalid argument
  Aborted (core dumped)"

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/maxima/+bug/1926225/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1921525] Re: Simutrans crashes on fresh install

2021-04-26 Thread FurretUber
I am facing a crash on this exact part of the loading process. The
workaround I found was to set LC_ALL=C to make the game run. The
backtrace is interesting: it seems related to the money_to_string
function, the money value being shown is pretty strange: 20.000.0,0.0

My system uses the pt_BR.UTF-8 locale.

The backtrace is gigantic, but only three steps are being shown, I
imagine I would need the correct debug packages to get more:

#0  __memmove_avx_unaligned_erms () at 
../sysdeps/x86_64/multiarch/memmove-vec-unaligned-erms.S:328
#1  0x558d978d in money_to_string(char*, double, bool) 
(p=0x7fffefff "", p@entry=0x7fffbaa0 "20.000.0,0.0", f=f@entry=20, 
show_decimal=show_decimal@entry=true) at utils/simstring.cc:107
j = 0
tmp = 
"20,00\000\353R\265\224z\333\033\000\000\000\000\000\000\000U\300dUUU\000\000\000\253:WUU\000\000\016\000\000\000\000\000\000\000\200\241\356UUU\000\000\243\001\a\000\034\352\005\000\020\020}\365\377\177\000\000\000\000\300\002#\002\000\000\377\177\000\000\000\000\000\000\v\000\000\000E\001\000\000\000\000\000\000#\002\000\000\001\000\000\000E\001\000\000\216\241\356UUU\000\000\000S\353R\265\224",
 
tp = 0x7fffb990 "20,00"
i = 
l = 18032
#2  0x5570b0ff in win_display_flush(double) (konto=20) at 
gui/simwin.cc:1704
buffer = 
"20.000.0,0.0\000\353.R\265\224.z\333\033.\000\000\000.\000\000\000.\000U\300.dUU.U\000\000.\000\253:.WUU.\000\000\016.\000\000\000.\000\000\000.\000\200\241.\356UU.U\000\000.\243\001\a.\000\034\352.\005\000\020.\020}\365.\377\177\000.\000\000\000.\300\002#.\002\000\000.\377\177\000.\000\000\000.\000\000\v.\000\000\000.E\001\000.\000\000\000.\000\000#.\002\000\000.\001\000\000.\000E\001.\000\000\216.\241\356U.UU\000.\000\000S.\353R\265.\224z\333.,,,.,,,.,,\000.S\353R.\265\224z.ۻ\000.\000\000\000.\000\000\000"...
disp_width = 
disp_height = 
menu_height = 
main_menu = 
old_inside_event_handling = 
time = 0x55a771e0  "Verão Junho 1 
1930  3:27am"
status_bar_height = 15
status_bar_y = 
status_bar_text_y = 547
status_bar_icon_y = 
tooltip_check = 
right_border = 
pos = {x = -1, y = -1, z = -1 '\377', static invalid = {x = -1, y = -1, 
z = -1 '\377', static invalid = }}
info = {capacity = 256, size = 9, buf = 0x55b1f240 " (T=1,00)"}
w_left = 
w_right = 
middle = 

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1921525

Title:
  Simutrans crashes on fresh install

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/simutrans/+bug/1921525/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1921525] Re: Simutrans crashes on fresh install

2021-04-26 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: simutrans (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1921525

Title:
  Simutrans crashes on fresh install

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/simutrans/+bug/1921525/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926220] Re: Realteck realtek alc233 not detected combojack

2021-04-26 Thread Ubuntu Foundations Team Bug Bot
** Package changed: ubuntu => alsa-driver (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926220

Title:
  Realteck realtek alc233 not detected combojack

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1926220/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926205] Re: graphic interface faulty

2021-04-26 Thread Ubuntu Foundations Team Bug Bot
** Package changed: ubuntu => xorg (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926205

Title:
  graphic interface faulty

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1926205/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926223] Re: Netboot Loading libc6-udeb failed for unknown reasons (focal) 2020-04-21

2021-04-26 Thread Chris Guiver
*** This bug is a duplicate of bug 1867502 ***
https://bugs.launchpad.net/bugs/1867502

** This bug has been marked a duplicate of bug 1867502
   Netboot Loading libc6-udeb failed for unknown reasons (focal)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926223

Title:
  Netboot Loading libc6-udeb failed for unknown reasons (focal)
  2020-04-21

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1926223/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926225] [NEW] Maxima fails to start with error message "The assertion realpath(s, o) on line 471 of main.c in function mbin failed: Invalid argument Aborted (core dumped)"

2021-04-26 Thread Gary
Public bug reported:

Maxima is installed but when run from the terminal or called by wxmaxima
or texmacs, fails to run with the error messaage "The assertion
realpath(s,o) on line 471 of main.c in function mbin failed: Invalid
argument Aborted (core dumped)"

** Affects: maxima (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926225

Title:
  Maxima fails to start with error message "The assertion realpath(s,o)
  on line 471 of main.c in function mbin failed: Invalid argument
  Aborted (core dumped)"

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/maxima/+bug/1926225/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926223] [NEW] Netboot Loading libc6-udeb failed for unknown reasons (focal) 2020-04-21

2021-04-26 Thread papamoose
Public bug reported:

With the netboot image from 2020-04-21
(http://archive.ubuntu.com/ubuntu/dists/focal/main/installer-
amd64/current/legacy-images/netboot/) it shows me following error at
partition disk space step

   [!!] Detect disks ?
  ? ?
  ? Failed to load installer component ?
  ? Loading libc6-udeb failed for unknown reasons. Aborting. ?
  ? ?
  ?   ?
  ? ?
  

I am unable to preseed install via PXE because of this.


This bug seems to be identical to previous reports which got fixed in the past.
https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1867502

** Affects: debian-installer (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926223

Title:
  Netboot Loading libc6-udeb failed for unknown reasons (focal)
  2020-04-21

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1926223/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926220] [NEW] Realteck realtek alc233 not detected combojack

2021-04-26 Thread Jeannuel Garcia
Public bug reported:

I dont know what happened but today I plugged my headset with mic and
didnt work. I can only listen audio but the mic from the headset is not
recognized, it was before. Ubuntu only recognizes the internal mic.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: alsa-base 1.0.25+dfsg-0ubuntu5
Uname: Linux 5.7.1-050701-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.11-0ubuntu27.16
Architecture: amd64
AudioDevicesInUse:
 USERPID ACCESS COMMAND
 /dev/snd/controlC1:  jeannuel   6836 F pulseaudio
 /dev/snd/controlC0:  jeannuel   6836 F pulseaudio
CasperMD5CheckResult: skip
CurrentDesktop: Budgie:GNOME
Date: Mon Apr 26 18:12:25 2021
InstallationDate: Installed on 2021-03-05 (52 days ago)
InstallationMedia: Ubuntu-Budgie 20.04.1 LTS "Focal Fossa" - Release amd64 
(20200731)
PackageArchitecture: all
SourcePackage: alsa-driver
Symptom: audio
Title: USB sound card not detected
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/26/2020
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: FX505GT.310
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: FX505GT
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No  Asset  Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrFX505GT.310:bd11/26/2020:svnASUSTeKCOMPUTERINC.:pnTUFGamingFX505GT_FX505GT:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnFX505GT:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.family: TUF Gaming
dmi.product.name: TUF Gaming FX505GT_FX505GT
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.
mtime.conffile..etc.modprobe.d.alsa-base.conf: 2021-04-26T18:10:44.580536

** Affects: ubuntu
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug focal

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926220

Title:
  Realteck realtek alc233 not detected combojack

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+bug/1926220/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1857664] Re: dconf-WARNING **: 21:50:58.669: Unable to open /var/lib/flatpak/exports/share/dconf/profile/user: Permission denied

2021-04-26 Thread Overmen Supermundane
1) Ubuntu 18.04
2) Mozilla Firefox 87.0


(/usr/lib/firefox/firefox:3680): dconf-WARNING **: 01:22:08.216: Unable to open 
/var/lib/flatpak/exports/share/dconf/profile/user: Permission denied

###!!! [Parent][RunMessage] Error: Channel closing: too late to
send/recv, messages will be lost

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1857664

Title:
  dconf-WARNING **: 21:50:58.669: Unable to open
  /var/lib/flatpak/exports/share/dconf/profile/user: Permission denied

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1857664/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1922937] Re: reading casper-md5check.json fails

2021-04-26 Thread Brian Murray
** Description changed:

- bdmurray@clean-hirsute-amd64:/tmp$ ubuntu-bug plymouth
+ [Impact]
+ Bugs reported by apport are not including information about the results of 
the md5 check of the installation media used. Additionally, users are presented 
with a traceback regarding the ubuntu hook which is used with all bug reports.
+ 
+ [Test Case]
+ 1) Boot an Ubuntu 20.04 LTS or Ubuntu 20.10 install
+ 2) Create the file /var/log/installer/caspter-md5check.json with mode 0600.
+ 3) Run 'ubuntu-bug coreutils'
  
  *** Collecting problem information
  
  The collected information can be sent to the developers to improve the
  application. This might take a few minutes.
  ..ERROR: hook /usr/share/apport/general-hooks/ubuntu.py crashed:
  Traceback (most recent call last):
-   File "/usr/lib/python3/dist-packages/apport/report.py", line 228, in 
_run_hook
- symb['add_info'](report, ui)
-   File "/usr/share/apport/general-hooks/ubuntu.py", line 84, in add_info
- apport.hookutils.attach_casper_md5check(report,
-   File "/usr/lib/python3/dist-packages/apport/hookutils.py", line 995, in 
attach_casper_md5check
- with open(location) as json_file:
+   File "/usr/lib/python3/dist-packages/apport/report.py", line 228, in 
_run_hook
+ symb['add_info'](report, ui)
+   File "/usr/share/apport/general-hooks/ubuntu.py", line 84, in add_info
+ apport.hookutils.attach_casper_md5check(report,
+   File "/usr/lib/python3/dist-packages/apport/hookutils.py", line 995, in 
attach_casper_md5check
+ with open(location) as json_file:
  PermissionError: [Errno 13] Permission denied: 
'/var/log/installer/casper-md5check.json'
+ 
+ [Where problems could occur]
+ We are switching to reading the file with attach_root_command_outputs which 
is a well tested function in apport so the only problem would be a result of 
the new code being added. This works well in Hirsute so there is little chance 
of their being an error.

** Changed in: apport (Ubuntu Focal)
   Status: New => In Progress

** Changed in: apport (Ubuntu Groovy)
   Status: New => In Progress

** Changed in: apport (Ubuntu Focal)
 Assignee: (unassigned) => Brian Murray (brian-murray)

** Changed in: apport (Ubuntu Groovy)
 Assignee: (unassigned) => Brian Murray (brian-murray)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1922937

Title:
  reading casper-md5check.json fails

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apport/+bug/1922937/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926030] Re: IR Remote Keys Repeat Many Times Starting with Kernel 5.8.0-49

2021-04-26 Thread Ted L
I emailed Matthias R and asked him to take a look at this bug report.
According to his reply in comment #20 above, the fix was successfully
applied to kernel 5.10 but should not have been backported since the
problem did not exist in kernels < 5.10.  A user on the MythTV forum is
successfully using kernel 5.10 with an IR remote with no issue.  The
problem in focal affecting many people occurred due to LP #1918516 as
referenced in Kernel SRU Workflow 1921052 (https://bugs.launchpad.net
/kernel-sru-workflow/+bug/1921052).  Thanks for anything that can be
done to fix this.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926030

Title:
  IR Remote Keys Repeat Many Times Starting with Kernel 5.8.0-49

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1926030/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1821415] Re: pkexec fails in a non-graphical environment

2021-04-26 Thread Brian Murray
** Description changed:

- The plymouth apport source package hooks wants to gather log files as
- the root user and apport provides a policy kit policy for collecting
- that information. This works fine in a graphical environment but not in
- a non-graphical one.
+ [Impact]
+ The plymouth apport source package hooks wants to gather log files as the 
root user and apport provides a policy kit policy for collecting that 
information. This works fine in a graphical environment but not in a 
non-graphical one.
  
- N.B. you first need to create a /var/log/plymouth-debug.log file for the
- plymouth apport package hook to actually trigger this.
- 
- ubuntu@disco:~$ ubuntu-bug plymouth
+ [Test Case]
+ 1) ssh into an Ubuntu Desktop install of Ubuntu 20.04 LTS or Ubuntu 20.10
+ 2) sudo touch /var/log/plymouth-debug.log
+ 3) ubuntu@disco:~$ ubuntu-bug plymouth
  
  *** Collecting problem information
  
  The collected information can be sent to the developers to improve the
  application. This might take a few minutes.
  .. AUTHENTICATING FOR com.ubuntu.apport.root-info ===
  Authentication is required to collect system information for this problem 
report
  Authenticating as: Ubuntu (ubuntu)
  Password: 
  polkit-agent-helper-1: error response to PolicyKit daemon: 
GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie
   AUTHENTICATION FAILED ===
  Error executing command as another user: Not authorized
  
  This incident has been reported.
  
- Subsequently, bug reports from servers will contain less information.
+ With the version of apport from -proposed you will not see the
+ "AUTHENTICATION FAILED" error and the plymouth-debug.log file will be
+ collected.
+ 
+ [Where Problems Could Occur]
+ It's possible that the spawned pkttyagent process does not get cleaned up 
properly and could be left running. When testing the SRU we should confirm it 
is not still running.

** Tags removed: rls-hh-incoming

** Changed in: policykit-1 (Ubuntu Focal)
   Status: New => Won't Fix

** Changed in: policykit-1 (Ubuntu Groovy)
   Status: New => Won't Fix

** Changed in: apport (Ubuntu Focal)
   Status: New => In Progress

** Changed in: apport (Ubuntu Groovy)
   Status: New => In Progress

** Changed in: apport (Ubuntu Focal)
 Assignee: (unassigned) => Brian Murray (brian-murray)

** Changed in: apport (Ubuntu Groovy)
 Assignee: (unassigned) => Brian Murray (brian-murray)

** Changed in: apport (Ubuntu Focal)
   Importance: Undecided => Medium

** Changed in: apport (Ubuntu Groovy)
   Importance: Undecided => Medium

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1821415

Title:
  pkexec fails in a non-graphical environment

To manage notifications about this bug go to:
https://bugs.launchpad.net/policykit-1/+bug/1821415/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926218] Re: Disable or Remove FLoC features and the provider service

2021-04-26 Thread Aurora
** Description changed:

  Disable or remove entire FLoc,
  - FLoC component
  - Any other FLoC functionalities shipped in Chromium
-- FLoC client-side determinations of cohorts
-- Any reporting of FLoC cohort determinations to Google (or otherwise) 
servers (i.e., the reporting used for k-anonymity cohort protections)
-- FLoC JS methods (i.e. document.interestCohort)
+    - FLoC client-side determinations of cohorts
+    - Any reporting of FLoC cohort determinations to Google (or otherwise) 
servers (i.e., the reporting used for k-anonymity cohort protections)
+    - FLoC JS methods (i.e. document.interestCohort)
  
  Brave, Vivaldi, Bromite have addressed FLoC issue and edge browser has 
disabled it
  Resources: https://github.com/brave/brave-core/pull/8468
+ https://answers.launchpad.net/ubuntu/+source/chromium-browser/+question/696632

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926218

Title:
  Disable or Remove FLoC features and the provider service

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1926218/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926081] Re: nr_writeback memory leak in kernel 4.15.0-137+

2021-04-26 Thread Guilherme G. Piccoli
Hi Andrew, thanks a lot for the very thorough bug report! This far
better than apport logs, you basically explained everything that is
going on plus what is need to fix it, much appreciated!

Based on upstream tree, I see the following 2 commits that carry Fixes
tag to the offender you pointed:

e27be240df53 ("mm: memcg: make sure memory.events is uptodate when waking 
pollers")
c3cc39118c36 ("mm: memcontrol: fix NR_WRITEBACK leak in memcg and system stats")

Did you manage to test with both commits? They don't appear to be present in 
linux-stable, which is unfortunate, especially since the offender *is* present 
in v4.14.y.
I'll try to cook a kernel with both fixes and submit them to the ML.

Cheers,


Guilherme

** Changed in: linux (Ubuntu)
   Status: Confirmed => In Progress

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926081

Title:
  nr_writeback memory leak in kernel 4.15.0-137+

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1926081/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926218] [NEW] Disable or Remove FLoC features and the provider service

2021-04-26 Thread Aurora
Public bug reported:

Disable or remove entire FLoc,
- FLoC component
- Any other FLoC functionalities shipped in Chromium
   - FLoC client-side determinations of cohorts
   - Any reporting of FLoC cohort determinations to Google (or otherwise) 
servers (i.e., the reporting used for k-anonymity cohort protections)
   - FLoC JS methods (i.e. document.interestCohort)

Brave, Vivaldi, Bromite have addressed FLoC issue and edge browser has disabled 
it
Resources: https://github.com/brave/brave-core/pull/8468

** Affects: chromium-browser (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926218

Title:
  Disable or Remove FLoC features and the provider service

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1926218/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926216] [NEW] drag and select does not work correctly on one monitor

2021-04-26 Thread Dan Plamadeala
Public bug reported:

1) hirsute hippo
2) 3.38.4-1ubuntu2
3) Being able to properly select the icons I have on one of my two monitors
4) On one of the monitors, drag and select works correctly, on the second one, 
however, it has a weird behaviour of selecting an incorrect area as seen in the 
video attached https://youtu.be/nC6pIn6uKgc

ProblemType: Bug
DistroRelease: Ubuntu 21.04
Package: gnome-shell 3.38.4-1ubuntu2
ProcVersionSignature: Ubuntu 5.11.0-16.17-generic 5.11.12
Uname: Linux 5.11.0-16-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.11-0ubuntu65
Architecture: amd64
CasperMD5CheckResult: pass
CurrentDesktop: ubuntu:GNOME
Date: Mon Apr 26 23:54:29 2021
DisplayManager: gdm3
InstallationDate: Installed on 2021-04-23 (3 days ago)
InstallationMedia: Ubuntu 21.04 "Hirsute Hippo" - Release amd64 (20210420)
RelatedPackageVersions: mutter-common 3.38.4-1ubuntu2
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: gnome-shell (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug hirsute

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926216

Title:
  drag and select does not work correctly on one monitor

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1926216/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1919143] Re: SRU mutter to 3.36.9

2021-04-26 Thread Christian Rauch
I updated via focal-proposed to mutter and gnome-shell version 3.36.9
(3.36.9-0ubuntu0.20.04.1) but unfortunately my original issue reported
at https://gitlab.gnome.org/GNOME/mutter/-/issues/1700 still persists.

** Bug watch added: gitlab.gnome.org/GNOME/mutter/-/issues #1700
   https://gitlab.gnome.org/GNOME/mutter/-/issues/1700

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1919143

Title:
  SRU mutter to 3.36.9

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/mutter/+bug/1919143/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1922937] Re: reading casper-md5check.json fails

2021-04-26 Thread Brian Murray
** Also affects: apport (Ubuntu Focal)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1922937

Title:
  reading casper-md5check.json fails

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apport/+bug/1922937/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Re: [Bug 1926039] Re: Ubuntu Desktop 20.04.2 Installer Clobbers Alternate Drive EFI System Parition

2021-04-26 Thread Wire
Hi Steve, thanks for responding to my report.

What I mean by clobber is that an existing ESP file BOOTx64.efi is
overwritten on a drive that is *not* the target for the installation.

I had used the 20.10 desktop installer previously with this same HW config
and did not see this effect, but in that case I chose "Do something else"
and arranged the target by hand.

Where things went awry was when I went to install another version of Ubuntu
20.04.2 LTS and accepted the installer's proposal to "Reinstall over
existing option" (forgive me if my memory isn't exact on Ubiquity wording
but I hope you get the gist). This resulted in unexpected change to the
non-target drive.

FURTHER VIEWS

I am not savvy on all the ins-and-outs of OS installation mgmt, what may
necessitate mucking with contents of a foreign ESP, nor why, how this may
be justified, but the end-user experience in my case was that a drive
unrelated to the requested installation was targeted and had a key boot
file overwritten so that when the installation was complete I no longer had
access (at boot) to the existing OS on the non-target drive.

When googling for similar experiences, there is a significant history of
Windows users who want to dual-boot who end up trapped and what lore is
required to get a Windows installer to re-construct the ESP after grub. I
also note that even in Linux lore, grub is a dark art :)

In my case I am playing with OpenCore, which maybe is an edge case not
considered by Ubiquity. I will add that IMO, in age of UEFI, boot mgmt
needs to be de-mystified and that Ubiquity designers could help everyone
with this by being a little less helpful in the installer and getting users
to pay attention to this historically arcane aspect of system config.

Thanks for reaching out to clarify and let me know if I can do anything
else to assist investigation.

/wire

On Mon, Apr 26, 2021 at 1:30 PM Steve Langasek <1926...@bugs.launchpad.net>
wrote:

> What exactly do you mean when you say "clobbers"?  The intended behavior
> is for ubiquity to reuse an existing ESP that it detects rather than
> unnecessarily creating a second one.  The word "clobber" to me implies
> that it has deleted the existing contents of the ESP; that should not
> happen and would be a bug.
>
> But the fact that the detected existing ESP is on a different drive than
> the Ubuntu root partition is not obviously disqualifying for us to reuse
> that ESP.  The ESP does not have to be on the same disk as the root
> partition, and it's not an obvious requirement that disks be independent
> from one another in the system.
>
> ** Changed in: ubiquity (Ubuntu)
>Status: New => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1926039
>
> Title:
>   Ubuntu Desktop 20.04.2 Installer Clobbers Alternate Drive EFI System
>   Parition
>
> Status in ubiquity package in Ubuntu:
>   Incomplete
>
> Bug description:
>   SITUATION
>
>   System with two drives and two existing OS installations:
>   Drive 1) Ubuntu Desktop 20.10
>   Drive 2) OpenCore
>
>   Re-installing Ubuntu Desktop (20.04.2 LTS) on Drive-1 overwrites the
>   EFI System Partition on Drove=2 when it has not been selected as the
>   install target.
>
>   BEHAVIOR
>
>   • The Ubuntu installer properly identifies Drive-1 as an existing
>   Ubuntu installation and offers to replace the installation.
>
>   • Accepting the offer of replacement installation progresses normally,
>   but when installation is complete, the existing other OS on Drive-2
>   drive is no longer bootable.
>
>   • Examining the non-target Drive-2 shows the EFI System Partition
>   EFI/BOOT folder has been overwritten with Ubuntu grub-specific files,
>   including the replacement of the non-target EFI/BOOT/BOOTx64.efi
>   OpenCore loader by a grub loader and addition of other grub boot
>   support files. Replacing the polluted ESP on Drive-2 restores access
>   to the other OS.
>
>   The non-target Drive-2 should not have been touched. For many users,
>   this behavior will appear to be the destruction of the non-target
>   drive with total data loss. BIOS boot options will report only grub
>   boot capability with no way to restore other OS function and they will
>   have no idea how restore the ESP and find their data.
>
>   This behavior makes trying Ubuntu a total disaster for new users and a
>   good scare for experienced users.
>
>   Affected system: Ubuntu Desktop 20.04.2 LTS installing to an existing
> Ubuntu Desktop 20.10.
>   Target drive-1 is SATA, single-boot Ubuntu 20.10
>   Non-target drive-2 is NVMe, OpenCore
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1926039/+subscriptions
>

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926039

Title:
  Ubuntu Desktop 20.04.2 Installer Clobbers 

[Bug 1883315] Re: Showing esm update as installable when esm is disabled

2021-04-26 Thread Bryce Harrington
** Changed in: update-notifier (Ubuntu Bionic)
 Assignee: (unassigned) => Lucas Albuquerque Medeiros de Moura (lamoura)

** Changed in: update-notifier (Ubuntu Focal)
 Assignee: (unassigned) => Lucas Albuquerque Medeiros de Moura (lamoura)

** Changed in: update-notifier (Ubuntu Hirsute)
 Assignee: (unassigned) => Chad Smith (chad.smith)

** Changed in: update-notifier (Ubuntu Impish)
 Assignee: (unassigned) => Chad Smith (chad.smith)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883315

Title:
  Showing esm update as installable when esm is disabled

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/update-notifier/+bug/1883315/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1924766] Re: update-notifier does not handle ESM Apps in the apt-check script

2021-04-26 Thread Bryce Harrington
** Changed in: update-notifier (Ubuntu Bionic)
 Assignee: (unassigned) => Lucas Albuquerque Medeiros de Moura (lamoura)

** Changed in: update-notifier (Ubuntu Focal)
 Assignee: (unassigned) => Lucas Albuquerque Medeiros de Moura (lamoura)

** Changed in: update-notifier (Ubuntu Hirsute)
 Assignee: (unassigned) => Chad Smith (chad.smith)

** Changed in: update-notifier (Ubuntu Impish)
 Assignee: (unassigned) => Chad Smith (chad.smith)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1924766

Title:
  update-notifier does not handle ESM Apps in the apt-check script

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/update-notifier/+bug/1924766/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1925421] Re: arm64 support

2021-04-26 Thread Khaled El Mously
** Description changed:

+ See
+ https://canonical.lightning.force.com/lightning/r/Case/5003z2BzFG4AAN/view
+ for more info
  
- https://canonical.lightning.force.com/lightning/r/Case/5003z2BzFG4AAN/view
+ 
+ [Impact]
+ No support for arm64 currently
+ 
+ 
+ [Fix]
+ Add arm64 support, including hardware support patches
+ 
+ [Test]
+ Confirm that it boots on desired arm64 hardware, as well as VMs
+ 
+ [Regression Potential]
+ This was never working on arm64 so there should be no risk of regression.
+ The requested changes included some refactorings of early memory 
initialization code (all arches) so this presents a small risk. The changes 
were tested on arm64 as well amd64.

** Also affects: linux-oracle (Ubuntu)
   Importance: Undecided
   Status: New

** No longer affects: linux (Ubuntu)

** Changed in: linux-oracle (Ubuntu)
   Status: New => In Progress

** Changed in: linux-oracle (Ubuntu)
 Assignee: (unassigned) => Khaled El Mously (kmously)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1925421

Title:
  arm64 support

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux-oracle/+bug/1925421/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926184] Re: locking/qrwlock: Fix ordering in queued_write_lock_slowpath()

2021-04-26 Thread Guilherme G. Piccoli
** Description changed:

- SRU Justification
  
  [Impact]
- 
- Out of order reads can fetch a NULL pointer causing a kernel crash.
- Affects kernels from v4.15 to v5.11.
+ * Out of order reads can fetch a NULL pointer causing a kernel crash. Affects 
kernels from v4.15 to v5.11.
  
  [Fix]
+ * commit 84a24bf8c52e ("locking/qrwlock: Fix ordering in 
queued_write_lock_slowpath()")
  
- commit 84a24bf8c52e66b7ac89ada5e3cfbe72d65c1896 ("locking/qrwlock: Fix
- ordering in queued_write_lock_slowpath()")
+ * For Bionic, we also require an additional patch: commit fcfdfe30e324
+ ("locking/barriers: Introduce smp_cond_load_relaxed() and
+ atomic_cond_read_relaxed()")
  
  [Where problems could occur]
  
- This is quite a subtle bug. It is more prevalent on arm64. Regression
+ * This is quite a subtle bug. It is more prevalent on arm64. Regression
  possibility seems quite low. The worst impact could be a minor performance 
degradation.

** Description changed:

- 
  [Impact]
  * Out of order reads can fetch a NULL pointer causing a kernel crash. Affects 
kernels from v4.15 to v5.11.
  
  [Fix]
  * commit 84a24bf8c52e ("locking/qrwlock: Fix ordering in 
queued_write_lock_slowpath()")
  
  * For Bionic, we also require an additional patch: commit fcfdfe30e324
  ("locking/barriers: Introduce smp_cond_load_relaxed() and
  atomic_cond_read_relaxed()")
  
  [Where problems could occur]
  
  * This is quite a subtle bug. It is more prevalent on arm64. Regression
  possibility seems quite low. The worst impact could be a minor performance 
degradation.
+ 
+ * Kernels 4.15 / 5.4 / 5.8 / 5.11 were successfully built and booted
+ with this patch. Also, by using ftrace we could see that the changed
+ function was executed with success multiple times.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926184

Title:
  locking/qrwlock: Fix ordering in queued_write_lock_slowpath()

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1926184/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926208] Re: standard security upgrade counts should not include ESM packages

2021-04-26 Thread Lucas Albuquerque Medeiros de Moura
** Description changed:

  [Impact]
  When users are looking at MOTD messages, they might find the text confusing, 
since we don't explicitly say that the security updates count are taking into 
consideration both standard security pockets and ESM pockets.
  
  [Test Case]
  1. Launch the a xenial container
- 2. Run apt update and install the updated version of update-notifier-common
- 3. Add the ubuntu-advantage-tools ppa:
+ 2. Add the ubuntu-advantage-tools ppa:
     https://code.launchpad.net/~ua-client/+archive/ubuntu/daily
- 4. Install ubuntu-advantage-tools
- 5. Install the latest version of uaclient from the stable ppa:
+ 3. Install ubuntu-advantage-tools
+ 4. Install the latest version of uaclient from the stable ppa:
     https://launchpad.net/~ua-client/+archive/ubuntu/stable/
- 6. Comment out all mentions of xenial-security/xenial-updates in 
/etc/apt/source.list
- 7. Run apt update
- 8. Install libkrad0:
+ 5. Comment out all mentions of xenial-security/xenial-updates in 
/etc/apt/source.list
+ 6. Run apt update
+ 7. Install libkrad0:
     apt install libkrad0=1.13.2+dfsg-5
- 9. Run /usr/lib/update-notifier/apt-check --human-readable
- 10. See a message like this:
+ 8. Run /usr/lib/update-notifier/apt-check --human-readable
+ 9. See a message like this:
  
  UA Infra: Extended Security Maintenance (ESM) is not enabled.
  
  UA Infra: Extended Security Maintenance (ESM) is enabled.
  
  3 packages can be updated.
  1 of these updates is fixed through UA Infra: ESM.
  1 of these updates is a security update.
  To see these additional updates run: apt list --upgradable
  
  To verify that the error is fixed:
  
- 1.Perform all the stages above until step 8
+ 1.Perform all the stages above until step 7
  2. Bring back xenial-security on source.list (we need because of the 
python3-distro-info dependency of update-notifier-common)
  3 Install the new update-notifier from this ppa:
    https://launchpad.net/~lamoura/+archive/ubuntu/update-notifier-test-ppa
  4. Remove xenial-security from source.list again
  5. Run /usr/lib/update-notifier/apt-check --human-readable and see a message 
like this:
  
  UA Infra: Extended Security Maintenance (ESM) is enabled.
  
  4 updates can be installed immediately.
  1 of these updates are UA Infra: ESM security updates.
  To see these additional updates run: apt list --upgradable
  
  That is now correct.
  
  [Where problems could occur]
  
  The changes in this package should only be seen when MOTD is getting a
  new message. If that script fails for some reason, it seems that MOTD
  will only not present the message, which is doesn't seem to be a system
  critical issue. Additionally, we would potentially have tracebacks in
  the update-notifier logs. Finally, if the logic is also incorrect, we
  would be displaying incorrect standard security messages to the user.
  
  [Discussion]
  Currently, we treat the upgrades coming from standard security pocket and ESM 
service with the same packaging count. This could be confusing, since we don't 
point that out in the current message that we have:
  
  5 updates can be installed immediately.
  5 of these updates are provide through UA Infrastructure ESM
  5 of these updates are security updates
  
  We believe this will be better if the message stated:
  5 updates can be installed immediately.
  5 of these updates are provide through UA Infrastructure ESM
  
  And if we had a situation like that:
  
  10 updates can be installed immediately.
  5 of these updates are provide through UA Infrastructure ESM
  8 of these updates are security updates
  
  We would change it to:
  
  10 updates can be installed immediately.
  5 of these updates are provide through UA Infrastructure ESM
  3 of these updates are standard security updates

** Description changed:

  [Impact]
  When users are looking at MOTD messages, they might find the text confusing, 
since we don't explicitly say that the security updates count are taking into 
consideration both standard security pockets and ESM pockets.
  
  [Test Case]
  1. Launch the a xenial container
  2. Add the ubuntu-advantage-tools ppa:
     https://code.launchpad.net/~ua-client/+archive/ubuntu/daily
  3. Install ubuntu-advantage-tools
- 4. Install the latest version of uaclient from the stable ppa:
-    https://launchpad.net/~ua-client/+archive/ubuntu/stable/
+ 4. Attach to ua subscription
  5. Comment out all mentions of xenial-security/xenial-updates in 
/etc/apt/source.list
  6. Run apt update
  7. Install libkrad0:
     apt install libkrad0=1.13.2+dfsg-5
  8. Run /usr/lib/update-notifier/apt-check --human-readable
  9. See a message like this:
  
- UA Infra: Extended Security Maintenance (ESM) is not enabled.
+ UA Infra: Extended Security Maintenance (ESM) is not enable4. Install the 
latest version of uaclient from the stable ppa:
+https://launchpad.net/~ua-client/+archive/ubuntu/stable/d.
  
  UA Infra: Extended Security Maintenance (ESM) is enabled.
  
  3 packages 

[Bug 1883315] Re: Showing esm update as installable when esm is disabled

2021-04-26 Thread Bryce Harrington
** Also affects: update-notifier (Ubuntu Impish)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883315

Title:
  Showing esm update as installable when esm is disabled

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/update-notifier/+bug/1883315/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1924766] Re: update-notifier does not handle ESM Apps in the apt-check script

2021-04-26 Thread Bryce Harrington
** Also affects: update-notifier (Ubuntu Impish)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1924766

Title:
  update-notifier does not handle ESM Apps in the apt-check script

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/update-notifier/+bug/1924766/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1918482] Re: Update for CVE-2021-21381

2021-04-26 Thread Andrew Hayzen
@Steve Beattie, was there any progress on this or anything I can do to
help ? Or is it just stuck in a queue of items to be reviewed? :-)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1918482

Title:
  Update for CVE-2021-21381

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/flatpak/+bug/1918482/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1925750] Re: Ubuntu 21.04 not loading correctly intel graphics driver

2021-04-26 Thread Seth Forshee
I honestly don't know much about how these dual-GPU systems work. I
suspect there must be some firmware interfaces for enabling/disabling
the discrete GPU, I have no idea whether those are standardized or
platform-specific. Assuming the kernel supports the interfaces for your
platform, I also don't know what userspace packages are necessary to
utilize those interfaces. You might want to try searching for
instructions for your specific machine.

You might also check the firmware setup, there may be options there
related to enabling/disabling the discrete graphics.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1925750

Title:
  Ubuntu 21.04 not loading correctly intel graphics driver

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gdm3/+bug/1925750/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1883315] Re: Showing esm update as installable when esm is disabled

2021-04-26 Thread Bryce Harrington
** Changed in: update-notifier (Ubuntu Xenial)
   Status: Triaged => In Progress

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1883315

Title:
  Showing esm update as installable when esm is disabled

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/update-notifier/+bug/1883315/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1924605] Re: Grub2 menu not loading - could not create MokListXRT: Out of Resources

2021-04-26 Thread Łukasz Piekarski
Thanks for clarifying things Julian.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1924605

Title:
  Grub2 menu not loading - could not create MokListXRT: Out of Resources

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1924605/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926208] Re: standard security upgrade counts should not include ESM packages

2021-04-26 Thread Lucas Albuquerque Medeiros de Moura
** Description changed:

  [Impact]
  When users are looking at MOTD messages, they might find the text confusing, 
since we don't explicitly say that the security updates count are taking into 
consideration both standard security pockets and ESM pockets.
  
  [Test Case]
  1. Launch the a xenial container
  2. Run apt update and install the updated version of update-notifier-common
  3. Add the ubuntu-advantage-tools ppa:
     https://code.launchpad.net/~ua-client/+archive/ubuntu/daily
  4. Install ubuntu-advantage-tools
  5. Install the latest version of uaclient from the stable ppa:
     https://launchpad.net/~ua-client/+archive/ubuntu/stable/
  6. Comment out all mentions of xenial-security/xenial-updates in 
/etc/apt/source.list
  7. Run apt update
  8. Install libkrad0:
     apt install libkrad0=1.13.2+dfsg-5
  9. Run /usr/lib/update-notifier/apt-check --human-readable
  10. See a message like this:
  
  UA Infra: Extended Security Maintenance (ESM) is not enabled.
  
  UA Infra: Extended Security Maintenance (ESM) is enabled.
  
  3 packages can be updated.
  1 of these updates is fixed through UA Infra: ESM.
  1 of these updates is a security update.
  To see these additional updates run: apt list --upgradable
  
  To verify that the error is fixed:
  
  1.Perform all the stages above until step 8
- 2 Install the new update-notifier from this ppa:
+ 2. Bring back xenial-security on source.list (we need because of the 
python3-distro-info dependency of update-notifier-common)
+ 3 Install the new update-notifier from this ppa:
    https://launchpad.net/~lamoura/+archive/ubuntu/update-notifier-test-ppa
- 3. Run /usr/lib/update-notifier/apt-check --human-readable
- 4. See a message like this:
+ 4. Remove xenial-security from source.list again
+ 5. Run /usr/lib/update-notifier/apt-check --human-readable and see a message 
like this:
+ 
  UA Infra: Extended Security Maintenance (ESM) is enabled.
  
  4 updates can be installed immediately.
  1 of these updates are UA Infra: ESM security updates.
  To see these additional updates run: apt list --upgradable
  
  That is now correct.
  
  [Where problems could occur]
  
  The changes in this package should only be seen when MOTD is getting a
  new message. If that script fails for some reason, it seems that MOTD
  will only not present the message, which is doesn't seem to be a system
  critical issue. Additionally, we would potentially have tracebacks in
  the update-notifier logs. Finally, if the logic is also incorrect, we
  would be displaying incorrect standard security messages to the user.
  
  [Discussion]
  Currently, we treat the upgrades coming from standard security pocket and ESM 
service with the same packaging count. This could be confusing, since we don't 
point that out in the current message that we have:
  
  5 updates can be installed immediately.
  5 of these updates are provide through UA Infrastructure ESM
  5 of these updates are security updates
  
  We believe this will be better if the message stated:
  5 updates can be installed immediately.
  5 of these updates are provide through UA Infrastructure ESM
  
  And if we had a situation like that:
  
  10 updates can be installed immediately.
  5 of these updates are provide through UA Infrastructure ESM
  8 of these updates are security updates
  
  We would change it to:
  
  10 updates can be installed immediately.
  5 of these updates are provide through UA Infrastructure ESM
  3 of these updates are standard security updates

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926208

Title:
  standard security upgrade counts should not include ESM packages

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/update-notifier/+bug/1926208/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1924766] Re: update-notifier does not handle ESM Apps in the apt-check script

2021-04-26 Thread Bryce Harrington
** Changed in: update-notifier (Ubuntu Xenial)
   Status: Triaged => In Progress

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1924766

Title:
  update-notifier does not handle ESM Apps in the apt-check script

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/update-notifier/+bug/1924766/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1925188] Re: Mozilla Firefox Multiple Vulnerabilities

2021-04-26 Thread Olivier Tilloy
** Changed in: firefox (Ubuntu)
   Status: In Progress => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to the bug report.
https://bugs.launchpad.net/bugs/1925188

Title:
  Mozilla Firefox Multiple Vulnerabilities

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1925188/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926143] Re: DNS resolution faulty over openconnect

2021-04-26 Thread Steve Langasek
So, your VPN provider is serving incorrect DNS information.  That's not
a bug in resolvconf.

Also, your bug report shows that you are using Ubuntu 20.04 LTS.
resolvconf has been deprecated in Ubuntu 20.04 LTS in favor of systemd-
resolved.

** Changed in: resolvconf (Ubuntu)
   Status: New => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926143

Title:
  DNS resolution faulty over openconnect

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/resolvconf/+bug/1926143/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926190] Re: Blue Screen booting MacBook Air after 21.04 Upgrade

2021-04-26 Thread Brian Murray
*** This bug is a duplicate of bug 1925010 ***
https://bugs.launchpad.net/bugs/1925010

** This bug has been marked a duplicate of bug 1925010
   shim-signed 15.4 does not boot on EFI 1.10 systems

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1926190

Title:
  Blue Screen booting MacBook Air after 21.04 Upgrade

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+bug/1926190/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1926208] [NEW] standard security upgrade counts should not include ESM packages

2021-04-26 Thread Lucas Albuquerque Medeiros de Moura
Public bug reported:

[Impact]
When users are looking at MOTD messages, they might find the text confusing, 
since we don't explicitly say that the security updates count are taking into 
consideration both standard security pockets and ESM pockets.

[Test Case]
1. Launch the a xenial container
2. Run apt update and install the updated version of update-notifier-common
3. Add the ubuntu-advantage-tools ppa:
   https://code.launchpad.net/~ua-client/+archive/ubuntu/daily
4. Install ubuntu-advantage-tools
5. Install the latest version of uaclient from the stable ppa:
   https://launchpad.net/~ua-client/+archive/ubuntu/stable/
6. Comment out all mentions of xenial-security/xenial-updates in 
/etc/apt/source.list
7. Run apt update
8. Install libkrad0:
   apt install libkrad0=1.13.2+dfsg-5
9. Run /usr/lib/update-notifier/apt-check --human-readable
10. See a message like this:

UA Infra: Extended Security Maintenance (ESM) is not enabled.

UA Infra: Extended Security Maintenance (ESM) is enabled.

3 packages can be updated.
1 of these updates is fixed through UA Infra: ESM.
1 of these updates is a security update.
To see these additional updates run: apt list --upgradable

To verify that the error is fixed:

1.Perform all the stages above until step 8
2 Install the new update-notifier from this ppa:
  https://launchpad.net/~lamoura/+archive/ubuntu/update-notifier-test-ppa
3. Run /usr/lib/update-notifier/apt-check --human-readable
4. See a message like this:
UA Infra: Extended Security Maintenance (ESM) is enabled.

4 updates can be installed immediately.
1 of these updates are UA Infra: ESM security updates.
To see these additional updates run: apt list --upgradable

That is now correct.

[Where problems could occur]

The changes in this package should only be seen when MOTD is getting a
new message. If that script fails for some reason, it seems that MOTD
will only not present the message, which is doesn't seem to be a system
critical issue. Additionally, we would potentially have tracebacks in
the update-notifier logs. Finally, if the logic is also incorrect, we
would be displaying incorrect standard security messages to the user.

[Discussion]
Currently, we treat the upgrades coming from standard security pocket and ESM 
service with the same packaging count. This could be confusing, since we don't 
point that out in the current message that we have:

5 updates can be installed immediately.
5 of these updates are provide through UA Infrastructure ESM
5 of these updates are security updates

We believe this will be better if the message stated:
5 updates can be installed immediately.
5 of these updates are provide through UA Infrastructure ESM

And if we had a situation like that:

10 updates can be installed immediately.
5 of these updates are provide through UA Infrastructure ESM
8 of these updates are security updates

We would change it to:

10 updates can be installed immediately.
5 of these updates are provide through UA Infrastructure ESM
3 of these updates are standard security updates

** Affects: update-notifier (Ubuntu)
 Importance: Undecided
 Status: New

** Description changed:

  [Impact]
  When users are looking at MOTD messages, they might find the text confusing, 
since we don't explicitly say that the security updates count are taking into 
consideration both standard security pockets and ESM pockets.
  
  [Test Case]
- 1. Launch the following old version of a xenial container:
-lxc launch 
ubuntu:f4c4c60a6b752a381288ae72a1689a9da00f8e03b732c8d1b8a8fcd1a8890800 dev-x
- 
+ 1. Launch the a xenial container
  2. Run apt update and install the updated version of update-notifier-common
  3. Add the ubuntu-advantage-tools ppa:
-https://code.launchpad.net/~ua-client/+archive/ubuntu/daily
+    https://code.launchpad.net/~ua-client/+archive/ubuntu/daily
  4. Install ubuntu-advantage-tools
  5. Install the latest version of uaclient from the stable ppa:
-https://launchpad.net/~ua-client/+archive/ubuntu/stable/
+    https://launchpad.net/~ua-client/+archive/ubuntu/stable/
  6. Comment out all mentions of xenial-security/xenial-updates in 
/etc/apt/source.list
  7. Run apt update
  8. Install libkrad0:
-apt install libkrad0=1.13.2+dfsg-5
+    apt install libkrad0=1.13.2+dfsg-5
  9. Run /usr/lib/update-notifier/apt-check --human-readable
  10. See a message like this:
  
  UA Infra: Extended Security Maintenance (ESM) is not enabled.
  
  UA Infra: Extended Security Maintenance (ESM) is enabled.
  
  3 packages can be updated.
  1 of these updates is fixed through UA Infra: ESM.
  1 of these updates is a security update.
  To see these additional updates run: apt list --upgradable
  
- 
  To verify that the error is fixed:
  
  1.Perform all the stages above until step 8
  2 Install the new update-notifier from this ppa:
-   https://launchpad.net/~lamoura/+archive/ubuntu/update-notifier-test-ppa
+   https://launchpad.net/~lamoura/+archive/ubuntu/update-notifier-test-ppa
  3. 

[Bug 1832021] Re: Checksum drop of metadata traffic on isolated networks with DPDK

2021-04-26 Thread Ubuntu Foundations Team Bug Bot
The attachment "neutron-dpdk-fix.debdiff" seems to be a debdiff.  The
ubuntu-sponsors team has been subscribed to the bug report so that they
can review and hopefully sponsor the debdiff.  If the attachment isn't a
patch, please remove the "patch" flag from the attachment, remove the
"patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe
the team.

[This is an automated message performed by a Launchpad user owned by
~brian-murray, for any issue please contact him.]

** Tags added: patch

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1832021

Title:
  Checksum drop of metadata traffic on isolated networks with DPDK

To manage notifications about this bug go to:
https://bugs.launchpad.net/charm-neutron-openvswitch/+bug/1832021/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

  1   2   3   4   5   >