[Bug 1915205] Re: CVE-2020-9366

2021-02-09 Thread Axel Beckert
Actually this never made it into any LTS release as only 4.7.x versions were affected and 18.04 has a 4.6.x version and 20.04 has 4.8.0. ** Bug watch added: Debian Bug tracker #950896 https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=950896 ** Also affects: screen (Debian) via

[Bug 1915205] Re: CVE-2020-9366

2021-02-09 Thread Axel Beckert
Marking as "fix release" as Ubuntu already has 4.8.0-1. ** Changed in: screen (Ubuntu) Status: New => Fix Released -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1915205 Title: CVE-2020-9366

[Bug 1796034] Re: lubuntu 18.10 falkon nouveau test on qutebrowser crashed with SIGSEGV in __GI_____strtoul_l_internal()

2021-01-30 Thread Axel Beckert
I assume that since https://bugs.debian.org/910317 is fixed for a long time, this issue is no more present either. Please file a new bug report if you still can reproduce this (or seeming identical) issues in recent versions of qutebrowser, e.g. 1.14.1 or 2.0.1 and above. ** Changed in:

[Bug 1723392] Re: Please update backuppc to 4.x release (now 4.2.1) - major improvements and lots of bugfixes

2021-01-02 Thread Axel Beckert
4.4.0-2 is in hirsute-proposed (and in Debian Testing). ** Changed in: backuppc (Ubuntu) Status: Confirmed => Fix Released -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1723392 Title:

[Bug 1907932] Re: irqtop emits a warning

2020-12-12 Thread Axel Beckert
Note: The cited commit and "fix" was in the package ruby, but the problem in ruby-curses still exists as ruby only silenced the deprecation warnings by default. ** Summary changed: - irqtop emits a warning + ruby-curses: Emits warning: "rb_safe_level will be removed in Ruby 3.0", affects at

[Bug 1907932] Re: irqtop emits a warning

2020-12-12 Thread Axel Beckert
This is an issue in ruby-curses, not irqtop. See https://bugs.debian.org /cgi-bin/bugreport.cgi?bug=958973 Interestingly this no more happens on Debian Unstable/Testing. This seems to have fixed upstream a few months ago: commit df3f52a6331f1a47af9933b77311a8650727d8d1 Author: nagachika

[Bug 1900008] Re: Sessions of screen does not keep running in background

2020-10-19 Thread Axel Beckert
@paelzer: This does not sound like exiting the last shell inside the screen session but closing the xterm/gnome-terminal/lxterminal etc. it is running in. (Back to "New" for that.) So in the end this sounds a lot like one of these annoying systemd bugs, e.g. similar to

[Bug 1888280] Re: dctrl-tools should be dependency of debian-goodies

2020-07-20 Thread Axel Beckert
Nope. It's exactly as it should be for packages with a collection of small tools like e.g. debian-goodies or devscripts: * Dependencies of all or at least most tools are in Depends. * Hard dependencies which just appear in one or very few tools are in Recommends. (Other tools in the package are

[Bug 1883983] Re: MD5 is comprehensively broken at this point

2020-06-17 Thread Axel Beckert
debsums uses MD5 because dpkg uses MD5. ** Also affects: dpkg (Ubuntu) Importance: Undecided Status: New ** Bug watch added: Debian Bug tracker #849377 https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=849377 ** Also affects: debsums (Debian) via

[Bug 1882366] Re: After Installed Oh My Zsh, in taskbar shortcut icon widgets dont have icons and can't open.

2020-06-06 Thread Axel Beckert
On a first glance, this looks more like an issue in oh-my-zsh than in zsh. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1882366 Title: After Installed Oh My Zsh, in taskbar shortcut icon widgets

[Bug 1875242] Re: Do not fail if using fping6 with -6 flag

2020-04-27 Thread Axel Beckert
Uploaded the fix to Debian Unstable. Should reach Ubuntu Groovy via automatic sync from Debian Unstable. ** Changed in: fping (Ubuntu) Status: New => Fix Committed ** Changed in: fping (Ubuntu) Assignee: (unassigned) => Axel Beckert (xtaran) -- You received this bug notifi

[Bug 1873423] Re: package zsh-common 5.8-3ubuntu1 failed to install/upgrade: conffile difference visualiser subprocess returned error exit status 127

2020-04-17 Thread Axel Beckert
It's not your .zshrc (which would be in your home directory) but the system's /etc/zsh/zshrc which has been deleted and tried to compare. This issue seems though unrelated to the deletion of /etc/zsh/zshrc, with which at coped properly: Configuration file '/etc/zsh/zshrc' ==> Deleted (by you or

[Bug 1098531] Re: Wrong path to global config files mentioned in man page

2020-02-16 Thread Axel Beckert
This has been fixed in 5.2-3ubuntu1 (i.e. with Yakkety) when these ubuntu-specific changes were dropped: * Drop yodl from Build-Depends. * prebuild docs. ** Changed in: zsh (Ubuntu) Status: New => Fix Released -- You received this bug notification because you are a member of Ubuntu

[Bug 1098531] Re: Wrong path to global config files mentioned in man page

2020-02-16 Thread Axel Beckert
** Tags added: xenial -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1098531 Title: Wrong path to global config files mentioned in man page To manage notifications about this bug go to:

[Bug 1860323] Re: fping not working if ipv6 is disabled

2020-01-20 Thread Axel Beckert
> There seems to be a fix on github... (since july 2018!) Yes, and according to the fping version you mentioned, you're running Ubuntu 18.04 Bionic from _April_ 2018. So that Ubuntu release was released before the bug was fixed upstream. Upgrading to a more recent version of Ubuntu will fix this

[Bug 1860323] Re: fping not working if ipv6 is disabled

2020-01-20 Thread Axel Beckert
** Tags added: bionic -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1860323 Title: fping not working if ipv6 is disabled To manage notifications about this bug go to:

[Bug 1859314] Re: aptitude deletes drivers manager(?)

2020-01-12 Thread Axel Beckert
** Changed in: aptitude (Ubuntu) Status: New => Incomplete -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1859314 Title: aptitude deletes drivers manager(?) To manage notifications about

Re: [Bug 1859314] [NEW] aptitude deletes drivers manager(?)

2020-01-12 Thread Axel Beckert
installed" flag, e.g. via "apt-mark auto". 2. The installation image already contained these flags for some reason, but since apt-get (and partially apt) doesn't automatically remove these packages, the creator of the image didn't care about these flags and this only surface

[Bug 1853458] Re: "host not found" when navigating to dev.lemmy.ml

2019-11-21 Thread Axel Beckert
I can confirm this behaviour with any hostname I tried (including e.g. www.google.com). The "problem" seems the interaction between links2 and "torsocks" (and also "torify" which does more or less the same). It surely not a DNS or TLD detection issue, because both, "links2

Re: [Bug 1851925] Re: Fresh install of aptitude is broken - missing dependency?

2019-11-10 Thread Axel Beckert
rds, Axel -- ,''`. | Axel Beckert , https://people.debian.org/~abe/ : :' : | Debian Developer, ftp.ch.debian.org Admin `. `' | 4096R: 2517 B724 C5F6 CA99 5329 6E61 2FF9 CD59 6126 16B5 `-| 1024D: F067 EA27 26B9 C3FC 1486 202E C09E 1D89 9593 0EDE -- You received this bug notificat

[Bug 1851925] Re: Fresh install of aptitude is broken - missing dependency?

2019-11-09 Thread Axel Beckert
** Changed in: aptitude (Ubuntu) Status: Incomplete => Invalid -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1851925 Title: Fresh install of aptitude is broken - missing dependency? To

[Bug 1851925] Re: Fresh install of aptitude is broken - missing dependency?

2019-11-09 Thread Axel Beckert
I'm sorry, but I can't reproduce this issue in a clean 18.04 chroot: aptitude is installed at version 0.8.10-6ubuntu1, too, and has a dependency on libsigc++-2.0-0v5 (version 2.10.0-2 installed as in your case) which contains /usr/lib/x86_64-linux-gnu/libsigc-2.0.so.0. And aptitude works for me.

[Bug 920968] Re: samba: FTBFS on Lucid with pbuilder or as user plus fakeroot: configure: WARNING: unrecognized options: --without-smbmount

2019-10-18 Thread Axel Beckert
** Summary changed: - FTBFS on Lucid with pbuilder or as user plus fakeroot: configure: WARNING: unrecognized options: --without-smbmount + samba: FTBFS on Lucid with pbuilder or as user plus fakeroot: configure: WARNING: unrecognized options: --without-smbmount -- You received this bug

[Bug 1832377] Re: Cannot handle firmware requirement not-child

2019-07-12 Thread Axel Beckert
** Bug watch added: Debian Bug tracker #931794 https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=931794 ** Also affects: fwupd (Debian) via https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=931794 Importance: Unknown Status: Unknown -- You received this bug notification because

[Bug 1832377] Re: Cannot handle firmware requirement not-child

2019-07-12 Thread Axel Beckert
@superm1: #1820768 looks completely unrelated to me. Additionally, this still happens with 1.2.6-1 as currently in Debian Unstable. This issue has been fixed upstream in https://github.com/hughsie/fwupd/pull/1144 (Original upstream bug report at https://github.com/hughsie/fwupd/issues/1139) **

[Bug 1830047] Re: iptables-netflow 2.3-5ubuntu1 ADT test failure with linux 5.2.0-0.1

2019-05-22 Thread Axel Beckert
Compilation with kernel 5.1 has been fixed upstream in https://github.com/aabc/ipt- netflow/commit/fd37b58a81c3df1f375fe784547b77b7a9d1ebc4. I don't know if this also fixes compilation with kernel 5.2 (i.e. if #1827106 really is a duplicate of this bug). -- You received this bug notification

[Bug 1827106] Re: iptables-netflow 2.3-5ubuntu1 ADT test failure with linux 5.1.0-1.1

2019-05-22 Thread Axel Beckert
*** This bug is a duplicate of bug 1830047 *** https://bugs.launchpad.net/bugs/1830047 This has been fixed upstream in https://github.com/aabc/ipt- netflow/commit/fd37b58a81c3df1f375fe784547b77b7a9d1ebc4. I don't know if this also fixes compilation with kernel 5.2. -- You received this bug

[Bug 1792544] Re: demotion of pcre3 (8.x) a.k.a pcre (without the 3) in favor of pcre2 (10.x)

2019-05-01 Thread Axel Beckert
zsh is not really fixed. Please see the changelog entry of 5.6.2-3 which states: * [92175749] Revert "Switch from the deprecated libpcre3 to the newer (!) libpcre2." libpcre2 is not a drop-in replacement and not detected by zsh's configure script. (Closes: #909084, reopens LP#1792544)

Re: [Bug 1819949] Re: ZSH not working

2019-03-19 Thread Axel Beckert
Hi Mohammad, Mohammad Shoriful Islam Ronju wrote: > ~/.zshenv is not there. debsums was not installed. I installed it and > attached the output. Thanks! Unfortunately I'm starting to run out of ideas what else could cause this issue. :-( Regards, Axel -- ,''`. | Axel B

Re: [Bug 1819949] Re: ZSH not working

2019-03-18 Thread Axel Beckert
u have debsums installed, does "debsums -e zsh-common" show any modified files under /etc/zsh/? Because "zsh -f" also skips them (or at least some of them). Regards, Axel -- ,''`. | Axel Beckert , https://people.debian.org/~abe/ : :' : | Debian Develope

Re: [Bug 1819949] Re: ZSH not working

2019-03-18 Thread Axel Beckert
mands generally work on Linux, too. Point is just that they don't undo things which have been commented out from .zshrc. Hence you need to start a new zsh everytime you comment out or remove something from your .zshrc. Regards, Axel -- ,''`. | Axel Beckert , https://people.debi

Re: [Bug 1819949] Re: ZSH not working

2019-03-18 Thread Axel Beckert
overkill if you can use "which" * The user shoudn't use usermod as root (sudo …) to change a user shell but chsh (as you did). * There's no need to reboot just to make a change of a user shell effective. Regards, Axel -- ,''`. | Axel Beckert , https://

[Bug 1819949] Re: ZSH not working

2019-03-18 Thread Axel Beckert
> Also followed this tutorial but same result. Which tutorial? There was no link except to the screen shot in your message... -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1819949 Title: ZSH not

[Bug 1819378] Re: package xymon 4.3.28-3build1 failed to install/upgrade: installed xymon package post-installation script subprocess returned error exit status 1

2019-03-15 Thread Axel Beckert
** Changed in: xymon (Ubuntu) Status: In Progress => Fix Committed -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1819378 Title: package xymon 4.3.28-3build1 failed to install/upgrade:

[Bug 1819378] Re: package xymon 4.3.28-3build1 failed to install/upgrade: installed xymon package post-installation script subprocess returned error exit status 1

2019-03-15 Thread Axel Beckert
l admin. And this is actually a case we definitely need to handle better. I've filed https://bugs.debian.org/924665 in Debian for that. P.S.: Thanks to Thomas' variant of this issue, I became aware of the fact that this issue might also happen if you just tried to clean up your /etc/ from seemingly u

[Bug 1819378] Re: package xymon 4.3.28-3build1 failed to install/upgrade: installed xymon package post-installation script subprocess returned error exit status 1

2019-03-15 Thread Axel Beckert
** Changed in: xymon (Ubuntu) Status: Confirmed => In Progress -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1819378 Title: package xymon 4.3.28-3build1 failed to install/upgrade: installed

[Bug 1800280] Re: Setting ZSH as login shell causes various issues because it doesn't source /etc/profile

2019-02-15 Thread Axel Beckert
> > What do you exactly mean by "setting ZSH as the default shell"? > > I just mean using chsh to set the default login shell. /bin/sh is left > unchanged. JFTR: "default" is still the wrong term for this. There is only _one_ login shell per user. "default" always suggests that there are others

[Bug 1813061] Re: iptables-netflow 2.3-5 ADT test failure with linux 5.0.0-1.2

2019-02-07 Thread Axel Beckert
Pull-request at upstream (with commits from someone with a canonical.com e-mail address :-): https://github.com/aabc/ipt-netflow/pull/110 -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1813061 Title:

[Bug 1813061] Re: iptables-netflow 2.3-5 ADT test failure with linux 5.0.0-1.2

2019-02-07 Thread Axel Beckert
** Changed in: iptables-netflow (Ubuntu) Assignee: (unassigned) => Axel Beckert (xtaran) ** Changed in: iptables-netflow (Ubuntu) Status: Confirmed => In Progress -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

[Bug 1813061] Re: iptables-netflow 2.3-5 ADT test failure with linux 5.0.0-1.2

2019-02-06 Thread Axel Beckert
Forwarded to upstream at https://github.com/aabc/ipt-netflow/issues/108 ** Bug watch added: github.com/aabc/ipt-netflow/issues #108 https://github.com/aabc/ipt-netflow/issues/108 -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

[Bug 1813061] Re: iptables-netflow 2.3-5 ADT test failure with linux 5.0.0-1.2

2019-02-06 Thread Axel Beckert
Attached a dkms.log from iptables-netflows-dkms 2.3-5 building against linux-headers-5.0.0-3-generic and linux-libc-dev version 5.0.0-3.4. Will report this issue to upstream. ** Attachment added: "dkms.log of building against linux 5.0.0-3.4"

[Bug 1813061] Re: iptables-netflow 2.3-5 ADT test failure with linux 5.0.0-1.2

2019-02-06 Thread Axel Beckert
I think I found them at https://launchpad.net/~canonical-kernel- team/+archive/ubuntu/unstable ** Changed in: iptables-netflow (Ubuntu) Status: Incomplete => New ** Changed in: iptables-netflow (Ubuntu) Status: New => Confirmed -- You received this bug notification because you

[Bug 1813061] Re: iptables-netflow 2.3-5 ADT test failure with linux 5.0.0-1.2

2019-02-06 Thread Axel Beckert
Where can I get these linux-*-5.0.0-1.2 packages for debugging this issue? Can't find them in a standard disco pbuilder chroot. And unfortunately the above download links don't seem to contain relevant artifacts like the DKMS build log. ** Changed in: iptables-netflow (Ubuntu) Status: New

[Bug 1812778] Re: internet connection randomly stops working

2019-01-22 Thread Axel Beckert
Why is network-manager running while wicd is being used? They likely interfere which each other. Does this also happen if you stop network- manager (i.e. "sudo service network-manager stop") and then connect to a wifi with wicd? (They're co-installable on purpose, to be able to switch between

[Bug 604750] Re: aptitude-gtk will not display Ubuntu changelogs

2018-11-27 Thread Axel Beckert
aptitude-gtk is long gone. Even Ubuntu 12.04 LTS Precise has the aptitude source package version (0.6.6-1 respectively 0.6.6-1ubuntu1) with which the aptitude-gtk binary package was dropped. And in case this issue was also present with aptitude-curses (which remained), this issue is at least

[Bug 1804442] Re: package wicd-daemon 1.7.4+tb2-6 failed to install/upgrade: installed wicd-daemon package post-installation script subprocess returned error exit status 1

2018-11-21 Thread Axel Beckert
Thanks for the bug report! JFTR: The line in the subject is not the error message but only the report _that_ something has failed. The actual error message is in DpkgTerminalLog.txt and the cause is this: Traceback (most recent call last): File "/usr/share/wicd/daemon/wicd-daemon.py", line

[Bug 1793903] Re: aptitude build-dep fails on virtual packages

2018-11-16 Thread Axel Beckert
Yes, this is a known, long-standing issue, tracked in Debian at https://bugs.debian.org/509100 (and some more duplicates of that bug report). ** Changed in: aptitude (Ubuntu) Status: New => Confirmed ** Bug watch added: Debian Bug tracker #509100

[Bug 1349031] Re: ping6 is not configurable over web ui

2018-11-13 Thread Axel Beckert
** Changed in: backuppc (Ubuntu) Status: In Progress => Fix Committed -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1349031 Title: ping6 is not configurable over web ui To manage

[Bug 1349031] Re: ping6 is not configurable over web ui

2018-11-13 Thread Axel Beckert
** Changed in: backuppc (Ubuntu) Status: New => In Progress ** Changed in: backuppc (Ubuntu) Assignee: (unassigned) => Axel Beckert (xtaran) -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.ne

Re: [Bug 1800280] [NEW] Setting ZSH as the default shell causes various issues because it doesn't source /etc/profile

2018-11-03 Thread Axel Beckert
which case. Regards, Axel -- ,''`. | Axel Beckert , https://people.debian.org/~abe/ : :' : | Debian Developer, ftp.ch.debian.org Admin `. `' | 4096R: 2517 B724 C5F6 CA99 5329 6E61 2FF9 CD59 6126 16B5 `-| 1024D: F067 EA27 26B9 C3FC 1486 202E C09E 1D89 9593 0EDE -

[Bug 518572] Re: Update funcoeszz version

2018-10-31 Thread Axel Beckert
15.5-1 is part of Ubuntu since at least 16.04 LTS Xenial. ** Changed in: funcoeszz (Ubuntu) Status: Incomplete => Fix Released -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/518572 Title:

[Bug 1798557] Re: xymon-client and snaps, client report gets red in disk, inode, misc states

2018-10-18 Thread Axel Beckert
Instead of looking at parts of the mount-point path, I implemented the exclusion in both packages by completely ignoring squashfs mounts as these are always read-only since it's a read-only file system. That way we might also catch similar cases with other container formats which also use

[Bug 1798557] Re: xymon-client and snaps, client report gets red in disk, inode, misc states

2018-10-18 Thread Axel Beckert
** Changed in: hobbit-plugins (Ubuntu) Status: New => Fix Committed -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1798557 Title: xymon-client and snaps, client report gets red in disk,

[Bug 1798557] Re: xymon-client and snaps, client report gets red in disk, inode, misc states

2018-10-18 Thread Axel Beckert
disk and inode checks are from the xymon package, the misc check is indeed from hobbit-plugins. ** Package changed: hobbit-plugins (Ubuntu) => xymon (Ubuntu) ** Also affects: hobbit-plugins (Ubuntu) Importance: Undecided Status: New ** Tags added: patch -- You received this bug

[Bug 1796034] Re: lubuntu 18.10 falkon nouveau test on qutebrowser crashed with SIGSEGV in __GI_____strtoul_l_internal()

2018-10-07 Thread Axel Beckert
This is very likely https://bugs.debian.org/910317 ("QtWebEngine in unstable is constantly crashing"). ** Bug watch added: Debian Bug tracker #910317 https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=910317 -- You received this bug notification because you are a member of Ubuntu Bugs, which

[Bug 1795289] Re: dphys-swapfile will not re-calculate swap file size or re-install

2018-10-04 Thread Axel Beckert
symptoms in the according Debian bug report at https://bugs.debian.org/906767 The issue was caused by a more picky dc (the command used to do the calculations) which was erroring out when piping a "q" command into it. Hence marking as duplicate of #1788681. Regards, Axe

Re: [Bug 1783564] Re: There is no Ncurses-Ruby package installed which is needed by TPP

2018-09-28 Thread Axel Beckert
*** This bug is a duplicate of bug 1775673 *** https://bugs.launchpad.net/bugs/1775673 Axel Beckert wrote: > And https://github.com/cbbrowne/tpp/issues/9 looks unrelated for me: > Completely different error message, C linking error (Github) vs ruby > module location error (her

Re: [Bug 1783564] Re: There is no Ncurses-Ruby package installed which is needed by TPP

2018-09-28 Thread Axel Beckert
*** This bug is a duplicate of bug 1775673 *** https://bugs.launchpad.net/bugs/1775673 Axel Beckert wrote: > No, if I remember correctly, "ruby-something" is the > RedHat/Fedora/CentOS way of naming ruby library packages while > Debian/Ubuntu uses "something-ruby&quo

[Bug 1775673] Re: ruby-ncurses is broken in ubuntu 18.04

2018-09-28 Thread Axel Beckert
** Also affects: tpp (Ubuntu) Importance: Undecided Status: New ** Changed in: tpp (Ubuntu) Status: New => Confirmed -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1775673 Title:

Re: [Bug 1783564] Re: There is no Ncurses-Ruby package installed which is needed by TPP

2018-09-28 Thread Axel Beckert
ly merge all these bug reports. Regards, Axel -- ,''`. | Axel Beckert , https://people.debian.org/~abe/ : :' : | Debian Developer, ftp.ch.debian.org Admin `. `' | 4096R: 2517 B724 C5F6 CA99 5329 6E61 2FF9 CD59 6126 16B5 `-| 1024D: F067 EA27 26B9 C3FC 1486 202E C09E 1D89 9593

[Bug 1787763] Re: ruby-ncurses is broken: try ruby -e 'require "ncurses"'

2018-09-28 Thread Axel Beckert
*** This bug is a duplicate of bug 1775673 *** https://bugs.launchpad.net/bugs/1775673 ** This bug has been marked a duplicate of bug 1775673 ruby-ncurses is broken in ubuntu 18.04 -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to

Re: [Bug 1783564] Re: There is no Ncurses-Ruby package installed which is needed by TPP

2018-09-28 Thread Axel Beckert
e Debian/Ubuntu uses "something-ruby". Regards, Axel -- ,''`. | Axel Beckert , https://people.debian.org/~abe/ : :' : | Debian Developer, ftp.ch.debian.org Admin `. `' | 4096R: 2517 B724 C5F6 CA99 5329 6E61 2FF9 CD59 6126 16B5 `-| 1024D: F067 EA27 26B9 C3FC 1486 202E

[Bug 1792544] Re: demotion of pcre3 in favor of pcre2

2018-09-18 Thread Axel Beckert
ck to Incomplete. I'll revert that commit from the recent 5.6.2-2 upload. Regards, Axel -- ,''`. | Axel Beckert , https://people.debian.org/~abe/ : :' : | Debian Developer, ftp.ch.debian.org Admin `. `' | 4096R: 2517 B724 C5F6 CA99 5329 6E61 2FF9 CD59 6126 16B5 `-|

[Bug 1792544] Re: demotion of pcre3 in favor of pcre2

2018-09-15 Thread Axel Beckert
zsh in Debian Unstable (5.6.2-1) seems to build fine if I exchange libpcre3-dev by libpcre2-dev in Build-Depends and Build-Using (via debian/rules). -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

[Bug 1789570] Re: debsums runs concurrently with unattended-upgrades which leads to false positives

2018-08-29 Thread Axel Beckert
Thanks for the bug report and feature idea/suggestion! Not yet sure if that option should be really added to debsums (the program), or be default inside the cron job(s) itself. Note to myself: I see there's a lot of code duplication in the cron jobs. (Never really looked at them since I took

[Bug 1788681] Re: changed exit code for 'dc' in Ubuntu Bionic

2018-08-23 Thread Axel Beckert
** Changed in: dphys-swapfile (Ubuntu) Status: In Progress => Fix Committed -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1788681 Title: changed exit code for 'dc' in Ubuntu Bionic To

[Bug 1788681] Re: changed exit code for 'dc' in Ubuntu Bionic

2018-08-23 Thread Axel Beckert
593 0EDE ** Tags added: bionic cosmic ** Changed in: dphys-swapfile (Ubuntu) Status: New => Confirmed ** Bug watch added: Debian Bug tracker #906767 https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=906767 ** Changed in: dphys-swapfile (Ubuntu) Assignee: (unassigned) =>

[Bug 1650890] Re: package dphys-swapfile 20100506-1 failed to install/upgrade: el subproceso instalado el script post-installation devolvió el código de salida de error 1

2018-08-13 Thread Axel Beckert
*** This bug is a duplicate of bug 1496216 *** https://bugs.launchpad.net/bugs/1496216 JFTR: #1496216 is fixed now. Thanks for reporting this issue despite being a duplicate, since it led me to the real cause. -- You received this bug notification because you are a member of Ubuntu Bugs,

[Bug 1496216] Re: package dphys-swapfile 20100506-1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

2018-08-12 Thread Axel Beckert
** Changed in: dphys-swapfile (Ubuntu) Status: Confirmed => Fix Committed ** Changed in: dphys-swapfile (Ubuntu) Assignee: (unassigned) => Axel Beckert (xtaran) -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

[Bug 1650890] Re: package dphys-swapfile 20100506-1 failed to install/upgrade: el subproceso instalado el script post-installation devolvió el código de salida de error 1

2018-08-12 Thread Axel Beckert
*** This bug is a duplicate of bug 1496216 *** https://bugs.launchpad.net/bugs/1496216 This is indeed a duplicate of #1496216. The timemout message is not visible in the dpkg terminal output there, but in the journal error messages. ** This bug has been marked a duplicate of bug 1496216

[Bug 1650890] Re: package dphys-swapfile 20100506-1 failed to install/upgrade: el subproceso instalado el script post-installation devolvió el código de salida de error 1

2018-08-08 Thread Axel Beckert
** Changed in: dphys-swapfile (Ubuntu) Status: New => In Progress ** Changed in: dphys-swapfile (Ubuntu) Assignee: (unassigned) => Axel Beckert (xtaran) -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

[Bug 1650890] Re: package dphys-swapfile 20100506-1 failed to install/upgrade: el subproceso instalado el script post-installation devolvió el código de salida de error 1

2018-08-08 Thread Axel Beckert
Another potential reason could be https://bugs.debian.org/cgi- bin/bugreport.cgi?bug=843160, but this seems to have been introduced in systemd 231 while this bug report seems to have been written with systemd 229 running. ** Bug watch added: Debian Bug tracker #843160

[Bug 1650890] Re: package dphys-swapfile 20100506-1 failed to install/upgrade: el subproceso instalado el script post-installation devolvió el código de salida de error 1

2018-08-08 Thread Axel Beckert
This might be the same issue as #1496216, just with a different locale. But this one has more details, maybe due to the newer systemd version. (There's though still a chance that these are different issues, hence not merging for now.) The primary issue is that systemd killed dphys-swapfile too

[Bug 1761997] Re: /var/run needs mode 777 in bionic

2018-07-26 Thread Axel Beckert
Thanks to Brian for his patience with the remote debugging session via Launchpad comments. And for the resulting HOWTO for reproducing the issue. :-) Given that Stretch's screen package is without libutempter, too, this might bite Debian with Stretch to Buster upgrades inside screen, too. I'm

[Bug 1783564] Re: There is no Ncurses-Ruby package installed which is needed by TPP

2018-07-25 Thread Axel Beckert
I can't reproduce this issue in a minimal Debian Unstable chroot, so it might be an ubuntu-specific issue. And https://github.com/cbbrowne/tpp/issues/9 looks unrelated for me: Completely different error message, C linking error (Github) vs ruby module location error (here). ** Bug watch added:

[Bug 1782639] Re: package flwm 1.02+git2015.10.03+7dbb30-6 failed to install/upgrade: installed flwm package post-installation script subprocess returned error exit status 255

2018-07-23 Thread Axel Beckert
This acutally seems to be an issue with the xchat package and flwm's trigger trips over xchat's malformed .desktop file. The relevant line from the DpkgTerminalLog.txt is: Exec key for 'XChat IRC' contains '%F', '%U' or '%D' at the wrong place A valid question is if flwm's trigger should bail

Re: [Bug 1761997] Re: /var/run needs mode 777 in bionic

2018-07-19 Thread Axel Beckert
creen has been unpacked, but not configured. Or did I understand your previous mail about screen in 16.04 being 2755? Regards, Axel (not Alex) -- ,''`. | Axel Beckert , https://people.debian.org/~abe/ : :' : | Debian Developer, ftp.ch.debian.org Admin `. `' | 4096R: 2517

Re: [Bug 1761997] Re: /var/run needs mode 777 in bionic

2018-07-19 Thread Axel Beckert
var/run/screen 0777 root utmp' > $override I assume that this is nothing which would make sense to add to future releases of Debian's screen package, or does it? Regards, Axel -- ,''`. | Axel Beckert , https://people.debian.org/~abe/ : :' : | Debian Developer, f

Re: [Bug 1761997] Re: /var/run needs mode 777 in bionic

2018-07-19 Thread Axel Beckert
t 9 Oct 4 2016 > /lib/systemd/system/screen-cleanup.service -> /dev/null Please also check the existence and contents of /etc/tmpfiles.d/screen-cleanup.conf before and after upgrading. Regards, Axel -- ,''`. | Axel Beckert , https://people.debian.org/~abe/ : :' :

[Bug 1781295] Re: CVE-2018-10895: Possible remote code execution via CSRF in qute://settings

2018-07-18 Thread Axel Beckert
** Tags added: community-security -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1781295 Title: CVE-2018-10895: Possible remote code execution via CSRF in qute://settings To manage notifications

[Bug 1782456] Re: [CVE] Remote code execution due to CSRF on the qute://settings page

2018-07-18 Thread Axel Beckert
*** This bug is a duplicate of bug 1781295 *** https://bugs.launchpad.net/bugs/1781295 ** This bug has been marked a duplicate of bug 1781295 CVE-2018-10895: Possible remote code execution via CSRF in qute://settings -- You received this bug notification because you are a member of

Re: [Bug 1761997] Re: /var/run needs mode 777 in bionic

2018-07-18 Thread Axel Beckert
issions recursively during dist-upgrade? Regards, Axel -- ,''`. | Axel Beckert , https://people.debian.org/~abe/ : :' : | Debian Developer, ftp.ch.debian.org Admin `. `' | 4096R: 2517 B724 C5F6 CA99 5329 6E61 2FF9 CD59 6126 16B5 `-| 1024D: F067 EA27 26B9 C3FC 1486 202E C09E 1D

[Bug 1781295] Re: CVE-2018-10895: Possible remote code execution via CSRF in qute://settings

2018-07-11 Thread Axel Beckert
Ok, since half an hour, Cosmic is fixed, probably due to the automatic sync from Debian Unstable. ** Tags removed: cosmic -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1781295 Title:

[Bug 1781295] Re: CVE-2018-10895: Possible remote code execution via CSRF in qute://settings

2018-07-11 Thread Axel Beckert
Meh, can't link this bug report to a CVE report as Launchpad claims that "CVE-2018-10895 is not a valid CVE number". But it obviously is. ** CVE added: https://cve.mitre.org/cgi-bin/cvename.cgi?name=2018-10895 -- You received this bug notification because you are a member of Ubuntu Bugs, which

[Bug 1781295] [NEW] CVE-2018-10895: Possible remote code execution via CSRF in qute://settings

2018-07-11 Thread Axel Beckert
*** This bug is a security vulnerability *** Public security bug reported: qutebrowser 1.0.0 to 1.4.0 allows websites to change configuration settings via the qute://settings page by using CSRF. E.g. via the editor setting, this can very likely lead to a remote code execution. This has been

[Bug 1777899] Re: "realloc(): invalid next size" when using autocomplete and rvm

2018-06-20 Thread Axel Beckert
JFTR: This is already fixed in zsh 5.5.1-1ubuntu1 in cosmic (as that commit was included in the upstream 5.5.1 release). So technically this is "fixed" in Ubuntu (generally). But since the request is explicitly for Ubuntu 18.04, someone with the proper permissions should update the "Affects"

[Bug 1761997] Re: /var/run needs mode 777 in bionic

2018-04-11 Thread Axel Beckert
until then. Feel free to reassign or -- if you can explain where the bug is -- reopen. (Note: To me this rather looks like a not yet run postinst or similar during a dist-upgrade.) Regards, Axel -- ,''`. | Axel Beckert <a...@debian.org>, https://people.debian.org/~abe/

[Bug 1370416] Re: Security updates are not marked as security

2018-04-08 Thread Axel Beckert
** Bug watch added: Debian Bug tracker #895217 https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=895217 ** Also affects: aptitude (Debian) via https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=895217 Importance: Unknown Status: Unknown -- You received this bug notification

Re: [Bug 75332] Re: aptitude has private package holds, should use dpkg

2018-04-08 Thread Axel Beckert
Hi, Rolf Leggewie wrote: > Is this still an issue? Depends. If you consider https://bugs.debian.org/137771 (as linked to and marked as "fix released") to be the Debian-equivalent of this bug report, it's fixed since 0.7.2-1 from September 2015. Regards, Axel -- ,

Re: [Bug 1370416] Re: Security updates are not marked as security

2018-04-08 Thread Axel Beckert
Regards, Axel (with his aptitude hat on) -- ,''`. | Axel Beckert <a...@debian.org>, https://people.debian.org/~abe/ : :' : | Debian Developer, ftp.ch.debian.org Admin `. `' | 4096R: 2517 B724 C5F6 CA99 5329 6E61 2FF9 CD59 6126 16B5 `-| 1024D: F067 EA27 26B9 C3FC 1486 202E C09E 1D8

[Bug 1747189] Re: aptitude does not respect package holding which set by `apt-mark hold`

2018-02-03 Thread Axel Beckert
*** This bug is a duplicate of bug 1747191 *** https://bugs.launchpad.net/bugs/1747191 ** This bug has been marked a duplicate of bug 1747191 after selecting "Actions -> Cancel pending actions" aptitude cancels package holding which set by `apt-mark hold` -- You received this bug

[Bug 1747191] Re: after selecting "Actions -> Cancel pending actions" aptitude cancels package holding which set by `apt-mark hold`

2018-02-03 Thread Axel Beckert
Yes, this has been fixed in aptitude 0.7.6 about 1.5 years ago. See https://bugs.debian.org/576319 for details. ** Bug watch added: Debian Bug tracker #576319 https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=576319 ** Changed in: aptitude (Ubuntu) Status: New => Fix Released ** Also

[Bug 493846] Re: German man page for aptitude is outdated

2017-12-25 Thread Axel Beckert
** Tags removed: amd64 -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/493846 Title: German man page for aptitude is outdated To manage notifications about this bug go to:

[Bug 1737564] Re: Disable button does not work

2017-12-11 Thread Axel Beckert
> P.S. Debian Stable has already updated to xymon_4.3.28-2 No, that's wrong. Debian Stretch (current stable) has been initially released with that version. And neither Debian (nor AFAIK) Ubuntu will update to newer upstream releases in stable releases unless there's a critical security issue

[Bug 1707979] Fwd: Re: [beyondgrep/ack2] Ubuntu Artful doesn't contain ack (nor ack-grep) (#652) [origin: notificati...@github.com]

2017-12-10 Thread Axel Beckert
The following comment by the main ack upstream developer in the according upstream ticket may give a hint where to look for the failure reason: - Forwarded message from Andy Lester (https://github.com/beyondgrep/ack2/issues/652#issuecomment-350527181) - Here's something interesting: Many

[Bug 1707979] Re: No ack or ack-grep in artful.

2017-12-09 Thread Axel Beckert
Using "pbuilder" I've set up a minimal chroot for Ubuntu 18.04 Bionic as of today. Inside that chroot, I installed autopkgtest, pkg-perl- autopkgtest and ack (version 2.18+dfsg-1, 2.19.01-1 doesn't seem to be on my mirror yet) from bionic-proposed and ran "autopkgtest ./ -- null" inside the

[Bug 1707979] Re: No ack or ack-grep in artful.

2017-12-08 Thread Axel Beckert
Hrm, no, the only upstream commit since 2.18 which mentions Ubuntu is https://github.com/beyondgrep/ack2/commit/66009a140a9d05302546bcd4c1d85fd5d66388f2 and that only fixes a lintian warning about misspellings (which we had overridden already in the Debian package). So I don't see any relation to

[Bug 123454] Re: ack provides no information about options usage.

2017-12-08 Thread Axel Beckert
This is a bug report against ack, the kanji converter, which has been removed from Ubuntu since before Ubuntu 14.04 LTS (Trusty) and replaced with ack, the grep for humans, in Ubuntu 17.04 Zesty. Hence closing. ** Changed in: ack (Ubuntu) Status: Confirmed => Fix Released -- You

[Bug 1707979] Re: No ack or ack-grep in artful.

2017-12-08 Thread Axel Beckert
Upstream said, he fixed the reason for this issue in his upstream release candidate 2.19_01 which I'll soon upload to Debian as 2.19.01-1. I'll close this bug report with that upload, so please reopen it, if this doesn't fix the issue. (Can't really test that beforehand as this issue seems

[Bug 1637220] Re: zsh has no /snap/bin in PATH

2017-11-12 Thread Axel Beckert
*** This bug is a duplicate of bug 1640514 *** https://bugs.launchpad.net/bugs/1640514 ** This bug has been marked a duplicate of bug 1640514 /snap/bin is not added to the PATH when using zsh -- You received this bug notification because you are a member of Ubuntu Bugs, which is

  1   2   3   4   5   6   7   >