[Bug 1908500] Re: libxslt.a missing from libxslt1-dev

2020-12-17 Thread Graham Inggs
It seems this was intentional, from debian/changelog:


libxslt (1.1.34-1) experimental; urgency=medium

  ...
  * Stop building and installing the static library.
  ...

 -- Mattia Rizzolo   Mon, 25 Nov 2019 19:22:08 +0100

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1908500

Title:
  libxslt.a missing from libxslt1-dev

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libxslt/+bug/1908500/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1686079] Re: python-asdf is broken on big endian architectures

2020-11-26 Thread Graham Inggs
Fixed in 2.6.0
https://github.com/asdf-format/asdf/pull/743

** Changed in: python-asdf (Ubuntu)
   Status: Confirmed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1686079

Title:
  python-asdf is broken on big endian architectures

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/python-asdf/+bug/1686079/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1887312] Re: [SRU] Cinnamon session doesn't shutdown until all apps close regardless if they act to Cinnamon's logout request

2020-11-23 Thread Graham Inggs
** Tags removed: verification-complete
** Tags added: verification-done verification-done-focal

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1887312

Title:
  [SRU] Cinnamon session doesn't shutdown until all apps close
  regardless if they act to Cinnamon's logout request

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cinnamon-session/+bug/1887312/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1900627] Re: installing nvidia-cuda-toolkit removes nvidia-driver-455

2020-10-20 Thread Graham Inggs
** Changed in: nvidia-cuda-toolkit (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1900627

Title:
  installing nvidia-cuda-toolkit  removes nvidia-driver-455

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-cuda-toolkit/+bug/1900627/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1887312] Re: [SRU] Cinnamon session doesn't shutdown until all apps close regardless if they act to Cinnamon's logout request

2020-10-18 Thread Graham Inggs
Uploaded, thanks.

** Changed in: cinnamon-session (Ubuntu Focal)
   Status: New => In Progress

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1887312

Title:
  [SRU] Cinnamon session doesn't shutdown until all apps close
  regardless if they act to Cinnamon's logout request

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cinnamon-session/+bug/1887312/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1895203] Re: r-cran-mice: autopkgtest failure

2020-10-18 Thread Graham Inggs
r-cran-broom.mixed and r-cran-cubelyr, a build-dependency of the former,
are both now in groovy NEW

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1895203

Title:
  r-cran-mice: autopkgtest failure

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/r-cran-mice/+bug/1895203/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1887312] Re: [SRU] Cinnamon session doesn't shutdown until all apps close regardless if they act to Cinnamon's logout request

2020-10-18 Thread Graham Inggs
Please trim your debdiff down to only what is needed.
Having unnecessary changes just makes things harder to review.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1887312

Title:
  [SRU] Cinnamon session doesn't shutdown until all apps close
  regardless if they act to Cinnamon's logout request

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cinnamon-session/+bug/1887312/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1861894] Re: autopkgtest failure on armhf due to stderr output

2020-10-05 Thread Graham Inggs
All of these packages, except shark which was removed from unstable, are
now in sync with Debian.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1861894

Title:
  autopkgtest failure on armhf due to stderr output

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ciftilib/+bug/1861894/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1887312] Re: [SRU] Cinnamon session doesn't shutdown until all apps close regardless if they act to Cinnamon's logout request

2020-10-04 Thread Graham Inggs
Joshua, there are some unnecessary changes in your debdiff (trailing
white space), e.g.

-case CSM_MANAGER_LOGOUT_SHUTDOWN_INTERACT:  
+case CSM_MANAGER_LOGOUT_SHUTDOWN_INTERACT:

-_finished_playing_logout_sound (ca_context *c, uint32_t id, int error, void 
*userdata) 
+_finished_playing_logout_sound (ca_context *c, uint32_t id, int error, void 
*userdata)

Would you please trim it down to only what's needed?

Also, this:

Bug: https://bugs.launchpad.net/ubuntu/+source/cinnamon-session/+bug/1887312
Bug-: https://github.com/linuxmint/cinnamon/issues/3752

should be:

Bug-Ubuntu: 
https://bugs.launchpad.net/ubuntu/+source/cinnamon-session/+bug/1887312
Bug: https://github.com/linuxmint/cinnamon/issues/3752

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1887312

Title:
  [SRU] Cinnamon session doesn't shutdown until all apps close
  regardless if they act to Cinnamon's logout request

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cinnamon-session/+bug/1887312/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1887312] Re: [SRU] Cinnamon session doesn't shutdown until all apps close regardless if they act to Cinnamon's logout request

2020-10-03 Thread Graham Inggs
Fixed in version 4.6.1 which is in groovy

https://github.com/linuxmint/cinnamon-session/commit/12454209ed5814cb8d45a5a5b376e5e330f00a95
https://salsa.debian.org/cinnamon-team/cinnamon-session/-/commit/1f3027dbf874c2cf4a18e7f95c7e654e13d34ecc

** Changed in: cinnamon-session (Ubuntu)
   Status: In Progress => Fix Released

** Also affects: cinnamon-session (Ubuntu Focal)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1887312

Title:
  [SRU] Cinnamon session doesn't shutdown until all apps close
  regardless if they act to Cinnamon's logout request

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cinnamon-session/+bug/1887312/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1766030] Re: CPU usage has a color with no description

2020-10-01 Thread Graham Inggs
Fix released in htop 3.0.0

If this is not the case, please open a new issue with the new upstream:
https://github.com/htop-dev/htop/issues

** Changed in: htop (Ubuntu)
   Status: Confirmed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1766030

Title:
  CPU usage has a color with no description

To manage notifications about this bug go to:
https://bugs.launchpad.net/htop/+bug/1766030/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1813556] Re: A potential bug of use of uninitialised variable

2020-10-01 Thread Graham Inggs
Fix released in htop 3.0.0

** Changed in: htop (Ubuntu)
   Status: Confirmed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to the bug report.
https://bugs.launchpad.net/bugs/1813556

Title:
  A potential bug of use of uninitialised variable

To manage notifications about this bug go to:
https://bugs.launchpad.net/htop/+bug/1813556/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1894218] Re: autopkgtest fails on armhf with Error: mdb_env_open: Cannot allocate memory

2020-09-09 Thread Graham Inggs
** Changed in: ncbi-blast+ (Ubuntu)
   Status: Triaged => Fix Released

** Changed in: kaptive (Ubuntu)
   Status: New => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1894218

Title:
  autopkgtest fails on armhf with Error: mdb_env_open: Cannot allocate
  memory

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/kaptive/+bug/1894218/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1894218] Re: autopkgtest fails on armhf with Error: mdb_env_open: Cannot allocate memory

2020-09-09 Thread Graham Inggs
Seems fixed in ncbi-blast+.  Sync'd.


ncbi-blast+ (2.10.0-3) unstable; urgency=medium

  * debian/patches/tune_32bit_lmdb_defaults: Tweak default map size expressions.
- For 64-bit platforms, use an explicit UL suffix on one factor to avoid
  overflow.
- For 32-bit platforms, avoid tying up quite so much address space, since
  opening a pair of databases is a distinct possibility.
- Generally parenthesize expressions per best macro practice.

 -- Aaron M. Ucko   Mon, 07 Sep 2020 21:15:02 -0400

ncbi-blast+ (2.10.0-2) unstable; urgency=high

  * debian/patches/support_gcc10: Additionally tweak ncbifile.cpp to avoid
narrowing errors on some platforms (i386, for one).
  * debian/patches/tune_32bit_lmdb_defaults (new): Conditionalize default
map size to avoid allocation failures on 32-bit platforms.
(Closes: #969608.)

 -- Aaron M. Ucko   Sun, 06 Sep 2020 23:07:37 -0400

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1894218

Title:
  autopkgtest fails on armhf with Error: mdb_env_open: Cannot allocate
  memory

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/kaptive/+bug/1894218/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1888440] Re: package libcublas10 10.1.243-3 failed to install/upgrade: trying to overwrite '/usr/lib/x86_64-linux-gnu/libnvblas.so.10', which is also in package libnvblas10:amd64 10.1.243-3

2020-07-22 Thread Graham Inggs
Hi

It looks like you are trying to upgrade to 10.2.2.89-1.  Where does this
version come from?

Unpacking libcublas10 (10.2.2.89-1) over (10.1.243-3)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1888440

Title:
  package libcublas10 10.1.243-3 failed to install/upgrade: trying to
  overwrite '/usr/lib/x86_64-linux-gnu/libnvblas.so.10', which is also
  in package libnvblas10:amd64 10.1.243-3

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-cuda-toolkit/+bug/1888440/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1860601] Re: [SRU] openblas: -Wl, -Bsymbolic-functions should be stripped from LDFLAGS

2020-06-18 Thread Graham Inggs
** Tags removed: verification-needed verification-needed-focal
** Tags added: verification-done verification-done-focal

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1860601

Title:
  [SRU] openblas: -Wl,-Bsymbolic-functions should be stripped from
  LDFLAGS

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/hypre/+bug/1860601/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1860601] Re: [SRU] openblas: -Wl, -Bsymbolic-functions should be stripped from LDFLAGS

2020-06-11 Thread Graham Inggs
The autopkgtests listed below all passed when retried.

gemma/0.98.1+dfsg-1 (arm64)
r-bioc-deseq2/unknown (armhf)
python-ltfatpy/unknown (armhf)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1860601

Title:
  [SRU] openblas: -Wl,-Bsymbolic-functions should be stripped from
  LDFLAGS

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/hypre/+bug/1860601/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1860601] Re: [SRU] openblas: -Wl, -Bsymbolic-functions should be stripped from LDFLAGS

2020-06-11 Thread Graham Inggs
** Description changed:

  [Impact]
  Users of GNU R and GNU Octave in Ubuntu 20.04 found that certain operations 
hang, never returning results.
  
  [Test Case]
  apt install r-base-core
  Rscript -e "example(solve)"
  apt install libopenblas-dev
  Rscript -e "example(solve)"
  
  Executing Rscript the first time should return results almost instantly.
  Installing libopenblas-dev ensures that libopenblas0-pthread is installed.
  If the bug is present, running Rscript the second time will hang.
  
  Another test case, using Octave, can be found in #1870138
  
  [Regression Potential]
  This fix is already present in lapack for some time, see Debian bug #722252
  In case of regression, users should be able to switch to alternate blas 
variants.
+ .
+ It may be possible that in fixing libopenblas0-pthread, libopenblas0-openmp 
and libopenblas0-serial might break in a similar way.
+ We should watch out for test timeouts or incorrect results.
+ Hopefully the autopkgtests will catch any of that.
  
  --
  
  openblas >= 0.3.7+ds-3 causes an autopkgtest regression in hypre on
  armhf on Ubuntu infrastructure.
  
  There was a major restructuring of the openblas packaging in Debian
  version 0.3.7+ds-2 uploaded to experimental.
  
  http://autopkgtest.ubuntu.com/packages/h/hypre/focal/armhf
  
  Running tests
  running TEST_ams ... autopkgtest [17:08:06]: ERROR: timed out on command
  
  I have tried to reproduce this error on a Debian porterbox (armhf chroot
  on arm64 kernel) and on a Raspberry Pi 3 (armhf focal-proposed chroot on
  focal arm64 kernel).  The autopkgtests using binaries from the archive
  are successful, and rebuilding the packages locally is fine too.
  
  While investigating, I found the same tests are run while building the hypre 
package.
  I uploaded the hypre package to my PPA with the following change:
  
  --- a/debian/control
  +++ b/debian/control
  @@ -10,8 +10,8 @@
    debhelper-compat (= 12),
    pkg-config,
    gfortran,
  - libblas-dev | libopenblas-dev | libatlas-base-dev | libblas.so,
  - liblapack-dev | libopenblas-dev | libatlas-base-dev | liblapack.so,
  + libopenblas-dev | libblas-dev | libatlas-base-dev | libblas.so,
  + libopenblas-dev | liblapack-dev | libatlas-base-dev | liblapack.so,
    libsuperlu-dev, libsuperlu-dist-dev,
    libltdl-dev,
    libtool,
  
  i.e. building the package with libopenblas-dev instead of libblas-dev
  and liblapack-dev.
  
  https://launchpad.net/~ginggs/+archive/ubuntu/testing/+sourcepub/10932575
  /+listing-archive-extra
  
  The builds across all architectures seemed to fail in the same way as the 
autopkgtests on armhf.
  TEST_ams would start, and eventually the build would time out.
  
  see e.g. the build log for amd64:
  
  https://launchpad.net/~ginggs/+archive/ubuntu/testing/+build/18567417/+files
  /buildlog_ubuntu-focal-amd64.hypre_2.18.2-1~ppa2_BUILDING.txt.gz
  
  Again, I was unable to reproduce this error locally on amd64 or armhf.
  
  This regression prevents openblas, yade, eckit, sdpa, openmolcas and
  bolt-lmm from migrating from -proposed.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1860601

Title:
  [SRU] openblas: -Wl,-Bsymbolic-functions should be stripped from
  LDFLAGS

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/hypre/+bug/1860601/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1860601] Re: [SRU] openblas: -Wl, -Bsymbolic-functions should be stripped from LDFLAGS

2020-06-02 Thread Graham Inggs
** Changed in: openblas (Ubuntu Focal)
   Status: Confirmed => In Progress

** Changed in: openblas (Ubuntu Focal)
 Assignee: (unassigned) => Graham Inggs (ginggs)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1860601

Title:
  [SRU] openblas: -Wl,-Bsymbolic-functions should be stripped from
  LDFLAGS

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/hypre/+bug/1860601/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1860601] Re: openblas: -Wl, -Bsymbolic-functions should be stripped from LDFLAGS

2020-06-02 Thread Graham Inggs
** Description changed:

+ [Impact]
+ Users of GNU R and GNU Octave in Ubuntu 20.04 found that certain operations 
hang, never returning results.
+ 
+ [Test Case]
+ apt install r-base-core
+ Rscript -e "example(solve)"
+ apt install libopenblas-dev
+ Rscript -e "example(solve)"
+ 
+ Executing Rscript the first time should return results almost instantly.
+ Installing libopenblas-dev ensures that libopenblas0-pthread is installed.
+ If the bug is present, running Rscript the second time will hang.
+ 
+ Another test case, using Octave, can be found in #1870138
+ 
+ [Regression Potential]
+ This fix is already present in lapack for some time, see Debian bug #722252
+ In case of regression, users should be able to switch to alternate blas 
variants.
+ 
+ --
+ 
  openblas >= 0.3.7+ds-3 causes an autopkgtest regression in hypre on
  armhf on Ubuntu infrastructure.
  
  There was a major restructuring of the openblas packaging in Debian
  version 0.3.7+ds-2 uploaded to experimental.
  
  http://autopkgtest.ubuntu.com/packages/h/hypre/focal/armhf
  
  Running tests
  running TEST_ams ... autopkgtest [17:08:06]: ERROR: timed out on command
  
  I have tried to reproduce this error on a Debian porterbox (armhf chroot
  on arm64 kernel) and on a Raspberry Pi 3 (armhf focal-proposed chroot on
  focal arm64 kernel).  The autopkgtests using binaries from the archive
  are successful, and rebuilding the packages locally is fine too.
  
  While investigating, I found the same tests are run while building the hypre 
package.
  I uploaded the hypre package to my PPA with the following change:
  
  --- a/debian/control
  +++ b/debian/control
  @@ -10,8 +10,8 @@
-   debhelper-compat (= 12),
-   pkg-config,
-   gfortran,
+   debhelper-compat (= 12),
+   pkg-config,
+   gfortran,
  - libblas-dev | libopenblas-dev | libatlas-base-dev | libblas.so,
  - liblapack-dev | libopenblas-dev | libatlas-base-dev | liblapack.so,
  + libopenblas-dev | libblas-dev | libatlas-base-dev | libblas.so,
  + libopenblas-dev | liblapack-dev | libatlas-base-dev | liblapack.so,
-   libsuperlu-dev, libsuperlu-dist-dev,
-   libltdl-dev,
-   libtool,
+   libsuperlu-dev, libsuperlu-dist-dev,
+   libltdl-dev,
+   libtool,
  
  i.e. building the package with libopenblas-dev instead of libblas-dev
  and liblapack-dev.
  
  https://launchpad.net/~ginggs/+archive/ubuntu/testing/+sourcepub/10932575
  /+listing-archive-extra
  
  The builds across all architectures seemed to fail in the same way as the 
autopkgtests on armhf.
  TEST_ams would start, and eventually the build would time out.
  
  see e.g. the build log for amd64:
  
  https://launchpad.net/~ginggs/+archive/ubuntu/testing/+build/18567417/+files
  /buildlog_ubuntu-focal-amd64.hypre_2.18.2-1~ppa2_BUILDING.txt.gz
  
  Again, I was unable to reproduce this error locally on amd64 or armhf.
  
  This regression prevents openblas, yade, eckit, sdpa, openmolcas and
  bolt-lmm from migrating from -proposed.

** Summary changed:

- openblas: -Wl,-Bsymbolic-functions should be stripped from LDFLAGS
+ [SRU] openblas: -Wl,-Bsymbolic-functions should be stripped from LDFLAGS

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1860601

Title:
  [SRU] openblas: -Wl,-Bsymbolic-functions should be stripped from
  LDFLAGS

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/hypre/+bug/1860601/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1860601] Re: openblas: -Wl, -Bsymbolic-functions should be stripped from LDFLAGS

2020-05-31 Thread Graham Inggs
** Summary changed:

- openblas: causes autopkgtest failure in hypre armhf
+ openblas: -Wl,-Bsymbolic-functions should be stripped from LDFLAGS

** Changed in: hypre (Ubuntu)
   Status: New => Invalid

** Also affects: hypre (Ubuntu Focal)
   Importance: Undecided
   Status: New

** Also affects: openblas (Ubuntu Focal)
   Importance: Undecided
   Status: New

** Changed in: hypre (Ubuntu Focal)
   Status: New => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1860601

Title:
  openblas: -Wl,-Bsymbolic-functions should be stripped from LDFLAGS

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/hypre/+bug/1860601/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1860601] Re: openblas: causes autopkgtest failure in hypre armhf

2020-05-30 Thread Graham Inggs
Confirming that rebuilding openblas 0.3.8+ds-1 in Focal with

export DEB_LDFLAGS_MAINT_STRIP="-Wl,-Bsymbolic-functions"

makes hypre autopkgtest pass on armhf.


** Bug watch added: Debian Bug tracker #961725
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=961725

** Also affects: openblas (Debian) via
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=961725
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1860601

Title:
  openblas: causes autopkgtest failure in hypre armhf

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/hypre/+bug/1860601/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1877845] Re: giac FTBFS on armhf

2020-05-28 Thread Graham Inggs
Now we have a build on armhf, but riscv64 fails, and it built successfully on 
2020-05-07:
https://launchpad.net/ubuntu/+source/giac/1.5.0.87+dfsg1-4build1/+build/19274957

Removing the riscv64 binaries would move the gsl transition forward.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1877845

Title:
  giac FTBFS on armhf

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/giac/+bug/1877845/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1880307] Re: Unsupported messages: MediaDice with emoticon field

2020-05-23 Thread Graham Inggs
I would say that is the expected behaviour of Telegram Desktop version
2.0.1.

I think the solution here would be backports:
https://wiki.ubuntu.com/UbuntuBackports
except that backports haven't been processed for a while, sadly.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1880307

Title:
  Unsupported messages: MediaDice with emoticon field

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/telegram-desktop/+bug/1880307/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1877845] Re: giac FTBFS on armhf

2020-05-20 Thread Graham Inggs
** Summary changed:

- Please RM giac armhf binaries
+ giac FTBFS on armhf

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1877845

Title:
  giac FTBFS on armhf

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/giac/+bug/1877845/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1877845] Re: Please RM giac armhf binaries

2020-05-20 Thread Graham Inggs
It turned out the Debian maintainer dropped d-workaround-armhf-hang.patch, 
which is still needed.
I filed Debian bug #961122.

Even with that patch replaced, the build still fails intermittently on armhf 
with:
FAIL: chk_fhan5


** Bug watch added: Debian Bug tracker #961122
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=961122

** Also affects: giac (Debian) via
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=961122
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1877845

Title:
  Please RM giac armhf binaries

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/giac/+bug/1877845/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1874219] Re: PC suspends after 20 minutes at the login screen

2020-05-18 Thread Graham Inggs
I've just set up a brand new workstation with Ubuntu Desktop 20.04, and
it does not seem to be affected.  It has been sitting at the login
screen for 8 hours and has not suspended.

Is it possible that only upgrades could be affected by this?

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1874219

Title:
   PC suspends after 20 minutes at the login screen

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1874219/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1874219] Re: PC suspends after 20 minutes at the login screen

2020-05-11 Thread Graham Inggs
@vanvugt: Thanks, 'sudo systemctl isolate multi-user.target' does
prevent the autosuspend.

Although it doesn't survive a reboot, so maybe if one needs something
more persistent:

  sudo systemctl set-default multi-user.target

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1874219

Title:
   PC suspends after 20 minutes at the login screen

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1874219/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1874219] Re: PC suspends after 20 minutes at the login screen

2020-05-11 Thread Graham Inggs
@vanvugt:  Enabling automatic login might do the trick, thanks.
Ideally, I'd like to figure out exactly which setting needs to be changed.  
I'll poke some more.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1874219

Title:
   PC suspends after 20 minutes at the login screen

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1874219/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1874219] Re: PC suspends after 20 minutes at the login screen

2020-05-11 Thread Graham Inggs
@seb128: As you wrote in LP: #1868260, having autosuspend on AC by
default is not a great user experience.

It's frustrating for those who want to leave their workstations running
and access them remotely during lockdown.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1874219

Title:
   PC suspends after 20 minutes at the login screen

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1874219/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1874219] Re: PC suspends after 20 minutes at the login screen

2020-05-11 Thread Graham Inggs
@marcustomlinson: Thanks, that seemed to copy over the settings, but that 
didn't help.
I guess then this is not quite the same as LP: #1759325, although the behaviour 
is similar.

I've also tried the following, to no avail:

sudo -u gdm dbus-launch gsettings set org.gnome.desktop.screensaver 
lock-enabled 'false'
sudo -u gdm dbus-launch gsettings set org.gnome.desktop.screensaver lock-delay 0
sudo -u gdm dbus-launch gsettings set org.gnome.desktop.session idle-delay 0

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1874219

Title:
   PC suspends after 20 minutes at the login screen

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1874219/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1877845] [NEW] Please RM giac armhf binaries

2020-05-10 Thread Graham Inggs
Public bug reported:

giac FTBFS on armhf (hangs during dh_auto_test).
Please remove giac armhf binaries from groovy.
The only reverse dependency is sagemath, which FTBFS on armhf anyway, see:
https://buildd.debian.org/status/package.php?p=sagemath=unstable


dh_auto_test -a -D check -- VERBOSE=1
cd check && make -j4 check VERBOSE=1
make[2]: Entering directory '/<>/giac-1.5.0.87+dfsg1/check'
make  check-TESTS
make[3]: Entering directory '/<>/giac-1.5.0.87+dfsg1/check'
make[4]: Entering directory '/<>/giac-1.5.0.87+dfsg1/check'
PASS: chk_partfrac
PASS: chk_factor
PASS: chk_limit
PASS: chk_integrate
PASS: chk_geo
PASS: chk_morley_demo
PASS: chk_xavier
PASS: chk_fhan2
PASS: chk_fhan3
PASS: chk_normalize
FAIL: chk_fhan5
PASS: chk_fhan4
PASS: chk_fhan6
PASS: chk_fhan0
PASS: chk_fhan1
PASS: chk_fhan8
PASS: chk_fhan12
PASS: chk_fhan13
PASS: chk_fhan14
PASS: chk_fhan15
PASS: chk_fhan17
PASS: chk_fhan16
PASS: chk_fhan19
PASS: chk_fhan20
PASS: chk_fhan21
PASS: chk_fhan18
PASS: chk_fhan7
PASS: chk_fhan11
PASS: chk_fhan9
make[4]: *** Deleting file 'chk_cas.log'
Terminated
E: Caught signal ‘Terminated’: terminating immediately
make[1]: *** [debian/rules:40: override_dh_auto_test-arch] Terminated
make: *** [debian/rules:7: build-arch] Terminated
make[3]: *** [Makefile:721: check-TESTS] Terminated
make[4]: *** [Makefile:774: chk_cas.log] Terminated
make[2]: *** [Makefile:997: check-am] Terminated
Build killed with signal TERM after 150 minutes of inactivity

** Affects: giac (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: update-excuse

** Tags added: update-excuse

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1877845

Title:
  Please RM giac armhf binaries

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/giac/+bug/1877845/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1870900] Re: Sync synaptic 0.90+nmu1 (universe) from Debian unstable (main)

2020-04-27 Thread Graham Inggs
** Bug watch added: Debian Bug tracker #958960
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=958960

** Also affects: synaptic (Debian) via
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=958960
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1870900

Title:
  Sync synaptic 0.90+nmu1 (universe) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/synaptic/+bug/1870900/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1874219] [NEW] PC suspends after 20 minutes at the login screen

2020-04-22 Thread Graham Inggs
Public bug reported:

Same as LP: #1759325 in Bionic, but this time affecting Focal.

After some update in the last month, my desktop PC now suspends after 20
minutes at the login screen.

I was able to override the setting for my user account by adjusting the
power settings in gnome-control-center. I see no obvious way of
overriding the default for the system.

Asking on IRC, I was pointed at LP: #1868260, but got no response there.

** Affects: gnome-settings-daemon (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1874219

Title:
   PC suspends after 20 minutes at the login screen

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/1874219/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1872121] Re: Sync yubioath-desktop 5.0.3-1 (universe) from Debian unstable (main)

2020-04-20 Thread Graham Inggs
This bug was fixed in the package yubioath-desktop - 5.0.3-1
Sponsored for Taowa Munene-Tardif (taowa)

---
yubioath-desktop (5.0.3-1) unstable; urgency=medium
  [ Taowa Munene-Tardif ]
  * New upstream version 5.0.3
  * No longer requires root to build

 -- Taowa Munene-Tardif   Thu, 16 Apr 2020 19:00:00
-0400

** Changed in: yubioath-desktop (Ubuntu)
   Status: In Progress => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1872121

Title:
  Sync yubioath-desktop 5.0.3-1 (universe) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/yubioath-desktop/+bug/1872121/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1873505] Re: Sync pdftk-java 3.0.9-1 (universe) from Debian unstable (main)

2020-04-18 Thread Graham Inggs
This bug was fixed in the package pdftk-java - 3.0.9-1
Sponsored for Amr Ibrahim (amribrahim1987)

---
pdftk-java (3.0.9-1) unstable; urgency=medium

  * New upstream version.
  * Update Standards-Version to 4.5.0.
  * debian/watch: Download .tar.gz file instead of .tar file.

 -- Johann Felix Soden   Wed, 15 Apr 2020 15:13:03
+0200

pdftk-java (3.0.8-1) unstable; urgency=medium

  * New upstream version (Closes: #945502, #956204).
  * Update Standards-Version to 4.4.1.

 -- Johann Felix Soden   Thu, 12 Dec 2019 17:27:35
+0100

** Changed in: pdftk-java (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1873505

Title:
  Sync pdftk-java 3.0.9-1 (universe) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pdftk-java/+bug/1873505/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1852425] Re: Build failure with glibc v2.30

2020-04-18 Thread Graham Inggs
** Bug watch added: Debian Bug tracker #946853
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=946853

** Also affects: ace (Debian) via
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=946853
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1852425

Title:
  Build failure with glibc v2.30

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ace/+bug/1852425/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1873445] Re: Sync ace 6.4.5+dfsg-1.1 (universe) from Debian unstable (main)

2020-04-18 Thread Graham Inggs
We already have that fix in Ubuntu.

ace (6.4.5+dfsg-1build3.1) focal; urgency=medium

  * debian/patches/git_stropts_build.patch:
- backport an upstream patch to fix the build with the new glibc
  (lp: #1852425)

 -- Sebastien Bacher   Mon, 16 Dec 2019 16:23:09
+0100

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1873445

Title:
  Sync ace 6.4.5+dfsg-1.1 (universe) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ace/+bug/1873445/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1870905] Re: Sync pulseaudio-dlna 0.5.3+git20200329-0.1 (universe) from Debian unstable (main)

2020-04-18 Thread Graham Inggs
sync'd.  please close this bug once pulseaudio-dlna has been accepted
https://launchpad.net/ubuntu/focal/+queue?queue_state=0

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1870905

Title:
  Sync pulseaudio-dlna 0.5.3+git20200329-0.1 (universe) from Debian
  unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio-dlna/+bug/1870905/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1869183] Re: singularity doesn't find python binary

2020-04-16 Thread Graham Inggs
singularity (1.0b1-2) unstable; urgency=medium

  * Make a source only upload

 -- Kari Pahula  Sun, 12 Apr 2020 17:39:46 +0300

singularity (1.0b1-1) unstable; urgency=medium

  * New upstream release (Closes: #947595)
  * Patch entry_points in setup.py
  * Standards-Version 4.5.0 (no changes necessary)
  * Upload to unstable

 -- Kari Pahula  Sat, 11 Apr 2020 20:12:52 +0300

singularity (1.0a1-2) experimental; urgency=medium

  * Add missing build-dep python3-setuptools (Closes: #947274)

 -- Kari Pahula  Tue, 31 Dec 2019 16:51:48 +0200

singularity (1.0a1-1) experimental; urgency=medium

  * New upstream release (Closes: #946381)
* Savegame handling has been rewritten (Closes: #490572, #904225)
* Better unicode handling of savegame names (Closes: #718447)
* Python3 support (Closes: #912519, #938488)
* Could not repeat real_cpu bug, presumably fixed (Closes: #570923)
  * Switch packaging from cdbs to dh
  * Standards-Version 4.4.1 and dh compat 12
  * Remove menu file
  * Removed patches

 -- Kari Pahula  Thu, 19 Dec 2019 14:57:15 +0200

** Changed in: singularity (Ubuntu)
   Status: Confirmed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1869183

Title:
  singularity doesn't find python binary

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/singularity/+bug/1869183/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1871579] Re: cbp2make package does not contain the binary for Focal 20.04

2020-04-16 Thread Graham Inggs
cbp2make (147+dfsg-3) unstable; urgency=medium

  * Team upload

  [ Jelmer Vernooij ]
  * Use secure copyright file specification URI.
  * Trim trailing whitespace.

  [ Graham Inggs ]
  * Rename build-arch to override_dh_auto_build-arch,
thanks Niels Thykier (Closes: #956372)
  * Switch to debhelper 12
  * Set Rules-Requires-Root: no
  * Set Vcs-Browser to canonical URI
  * Bump Standards-Version to 4.5.0, no changes

 -- Graham Inggs   Thu, 16 Apr 2020 09:35:31 +


** Changed in: cbp2make (Ubuntu)
   Status: Confirmed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1871579

Title:
  cbp2make package does not contain the binary for Focal 20.04

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cbp2make/+bug/1871579/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1872785] Re: [FFe] Sync singularity 1.0b1-2 (universe) from Debian unstable (main)

2020-04-16 Thread Graham Inggs
This bug was fixed in the package singularity - 1.0b1-2
Sponsored for Hans Joachim Desserud (hjd)

---
singularity (1.0b1-2) unstable; urgency=medium

  * Make a source only upload

 -- Kari Pahula   Sun, 12 Apr 2020 17:39:46 +0300

singularity (1.0b1-1) unstable; urgency=medium

  * New upstream release (Closes: #947595)
  * Patch entry_points in setup.py
  * Standards-Version 4.5.0 (no changes necessary)
  * Upload to unstable

 -- Kari Pahula   Sat, 11 Apr 2020 20:12:52 +0300

singularity (1.0a1-2) experimental; urgency=medium

  * Add missing build-dep python3-setuptools (Closes: #947274)

 -- Kari Pahula   Tue, 31 Dec 2019 16:51:48 +0200

singularity (1.0a1-1) experimental; urgency=medium

  * New upstream release (Closes: #946381)
* Savegame handling has been rewritten (Closes: #490572, #904225)
* Better unicode handling of savegame names (Closes: #718447)
* Python3 support (Closes: #912519, #938488)
* Could not repeat real_cpu bug, presumably fixed (Closes: #570923)
  * Switch packaging from cdbs to dh
  * Standards-Version 4.4.1 and dh compat 12
  * Remove menu file
  * Removed patches

 -- Kari Pahula   Thu, 19 Dec 2019 14:57:15 +0200

** Changed in: singularity (Ubuntu)
   Status: Confirmed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1872785

Title:
  [FFe] Sync singularity 1.0b1-2 (universe) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/singularity/+bug/1872785/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1870780] Re: Sync openmpi 4.0.3-1 (universe) from Debian unstable (main)

2020-04-15 Thread Graham Inggs
** Changed in: openmpi (Ubuntu)
   Status: New => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1870780

Title:
  Sync openmpi 4.0.3-1 (universe) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openmpi/+bug/1870780/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1870780] Re: Sync openmpi 4.0.3-1 (universe) from Debian unstable (main)

2020-04-15 Thread Graham Inggs
Some of the changes from Debian seem quite risky this late in the cycle.
I'm going to upgrade the version in Ubuntu from RC4 to 4.0.3 final and see how 
that goes.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1870780

Title:
  Sync openmpi 4.0.3-1 (universe) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openmpi/+bug/1870780/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1870780] Re: Sync openmpi 4.0.3-1 (universe) from Debian unstable (main)

2020-04-14 Thread Graham Inggs
More changelog entries:

openmpi (4.0.3-6) unstable; urgency=medium

  * libopenmpi-dev now depends on zlib1g-dev

 -- Alastair McKinstry   Sun, 12 Apr 2020 12:47:29
+0100

openmpi (4.0.3-5) unstable; urgency=medium

  * Fix autopkgtest scripts to run in right directory; dep on gcc, gfortran
  * Correct JAVA condition so its not built on hppa. Closes: #956161

 -- Alastair McKinstry   Fri, 10 Apr 2020 14:02:54
+0100

openmpi (4.0.3-4) unstable; urgency=medium

  * Hard-code GFORTRAN_VERSION as gfortran-mod-15 for the moment to avoid
pulling arch-dep stuff into openmpi-common (mpi wrappers)

 -- Alastair McKinstry   Wed, 08 Apr 2020 14:19:09
+0100

openmpi (4.0.3-3) unstable; urgency=medium

  * Fix broken link for libmpi_usempi_ignore_tkr.so

 -- Alastair McKinstry   Tue, 07 Apr 2020 13:56:17
+0100

openmpi (4.0.3-2) unstable; urgency=medium

  * Fix broken psm conditional that causes FTBFS on non-intel archs
  * Use gcc rather than patchelf to change sonames for gfortan libs;
patchelf causes ldconfig to create wierd files and breaks dwz
Closes: #955708
  * Ensure mpif*.h headers are also present in the fortran mod dir that
mpif90/mpif77 now searches. Closes: #955749

 -- Alastair McKinstry   Sun, 05 Apr 2020 11:56:15
+0100

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1870780

Title:
  Sync openmpi 4.0.3-1 (universe) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openmpi/+bug/1870780/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1870780] Re: Sync openmpi 4.0.3-1 (universe) from Debian unstable (main)

2020-04-14 Thread Graham Inggs
There are some autopkgtest regressions in Debian and none of the 4.0.3-x
uploads have migrated yet.

Migration status for openmpi (4.0.2-5 to 4.0.3-6): BLOCKED: Rejected/violates 
migration policy/introduces a regression
Issues preventing migration:
autopkgtest for dolfin/2019.1.0-10: amd64: Pass, arm64: Ignored failure
autopkgtest for gyoto/1.4.4-3: amd64: Regression ♻ , arm64: Regression ♻
autopkgtest for mpgrafic/0.3.18-1: amd64: Regression ♻ , arm64: Regression ♻
autopkgtest for openmpi/4.0.3-6: amd64: Pass, arm64: Ignored failure

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1870780

Title:
  Sync openmpi 4.0.3-1 (universe) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openmpi/+bug/1870780/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1872449] [NEW] gmap 2020-04-08+ds1-1 is no longer non-free

2020-04-13 Thread Graham Inggs
Public bug reported:

The latest upload of gmap 2020-04-08+ds1-1 changes Section: non-free/science to 
Section: science
 due to re-licensing by upstream.

Please move the package from multiverse to universe.

** Affects: gmap (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1872449

Title:
  gmap 2020-04-08+ds1-1 is no longer non-free

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gmap/+bug/1872449/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1869814] Re: ubuntu-docs build failure - possible solution

2020-04-11 Thread Graham Inggs
sync'd. please close this bug once libxml2 has been accepted
https://launchpad.net/ubuntu/focal/+queue?queue_state=1

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1869814

Title:
  ubuntu-docs build failure - possible solution

To manage notifications about this bug go to:
https://bugs.launchpad.net/libxml2/+bug/1869814/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1870768] Re: Please sync ogre-1.12 from debian sid

2020-04-11 Thread Graham Inggs
** Also affects: ogre-1.12 (Ubuntu)
   Importance: Undecided
   Status: New

** Changed in: ogre-1.12 (Ubuntu)
   Status: New => Fix Released

** Changed in: ogre (Ubuntu)
   Status: Confirmed => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1870768

Title:
  Please sync ogre-1.12 from debian sid

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ogre/+bug/1870768/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1870768] Re: Please sync ogre-1.12 from debian sid

2020-04-11 Thread Graham Inggs
sync'd. please close this bug once ogre-1.12 has been accepted
https://launchpad.net/ubuntu/focal/+queue?queue_state=0

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1870768

Title:
  Please sync ogre-1.12 from debian sid

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ogre/+bug/1870768/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1872121] Re: Sync yubioath-desktop 5.0.2-3 (universe) from Debian unstable (main)

2020-04-11 Thread Graham Inggs
** Changed in: yubioath-desktop (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1872121

Title:
  Sync yubioath-desktop 5.0.2-3 (universe) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/yubioath-desktop/+bug/1872121/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1787471] Re: Please upgrade yubioath-desktop to current version

2020-04-11 Thread Graham Inggs
** Changed in: yubioath-desktop (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1787471

Title:
  Please upgrade yubioath-desktop to current version

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/yubioath-desktop/+bug/1787471/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1872121] Re: Sync yubioath-desktop 5.0.2-3 (universe) from Debian unstable (main)

2020-04-10 Thread Graham Inggs
sync'd.  please close this bug once yubioath-desktop has been accepted
https://launchpad.net/ubuntu/focal/+queue?queue_state=0

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1872121

Title:
  Sync yubioath-desktop 5.0.2-3 (universe) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/yubioath-desktop/+bug/1872121/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1869833] Re: Please sync mksh 58-1 (universe) from Debian testing (main)

2020-04-10 Thread Graham Inggs
This bug was fixed in the package mksh - 58-1
Sponsored for Thorsten Glaser (mirabilos)

---
mksh (58-1) unstable; urgency=medium

  * New upstream release
- [tg] Improve code performance, quality, robustness and correctness
- [multiplexd] Add vi mode PgDn, similar to PgUp doing history search
- [tg] Build.sh fixup unreliable test -n / -z
- [multiplexd] Correct documentation of vi mode @c
- [tg] Update to UCD 13.0.0
- [tg] Use nanoseconds in test -nt / -ot (LP#1855325)
  * Work around debhelper issue #908845 (Niels Thykier)
  * Update lintian overrides

 -- Thorsten Glaser   Fri, 27 Mar 2020 12:59:25 +0100

** Changed in: mksh (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1869833

Title:
  Please sync mksh 58-1 (universe) from Debian testing (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/mksh/+bug/1869833/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1871097] Re: Please sync jupp 3.1.39-1 (universe) from Debian testing (main)

2020-04-10 Thread Graham Inggs
This bug was fixed in the package jupp - 3.1.39-1
Sponsored for Thorsten Glaser (mirabilos)

---
jupp (3.1.39-1) unstable; urgency=medium

  * Drop “IDE” .desktop category, it creates mismatched menu entries
  * Update maintainer script comments from latest manpages
  * New upstream release
  * Modernise packaging

 -- Thorsten Glaser   Fri, 27 Mar 2020 09:55:30 +0100

** Changed in: jupp (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1871097

Title:
  Please sync jupp 3.1.39-1 (universe) from Debian testing (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/jupp/+bug/1871097/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1871911] [NEW] FFe: Sync julia 1.4.0+dfsg-1 (universe) from Debian unstable

2020-04-09 Thread Graham Inggs
Public bug reported:

Sync julia 1.4.0+dfsg-1 (universe) from Debian unstable

Explanation of FeatureFreeze exception:
New language features
Language changes
Multi-threading changes
Build system changes
New library functions
New library features
Standard library changes
https://docs.julialang.org/en/v1.4.0/NEWS/

1.4.0 was released on 2020-03-21 after RC2 on 2020-02-24 and RC1 on
2020-01-23, and I believe it is well tested.

The julia package is in universe, is not seeded and the only reverse-
dependency is the cantor-backend-julia [amd64].

Upgrading to 1.4.0+dfsg-1 gains us a build on arm64.

1.4.0+dfsg-1 has not been uploaded to unstable yet, so depending on the
timing I might upload from salsa.debian.org as 1.4.0+dfsg-0ubuntu1 and
sync before the release of 20.04.

Changelog entries since current focal version 1.3.1+dfsg-1build1:

julia (1.4.0+dfsg-1) UNRELEASED; urgency=medium

  * New upstream version 1.4.0+dfsg

 -- Mo Zhou   Sun, 22 Mar 2020 16:13:58 +0800

** Affects: julia (Ubuntu)
 Importance: Wishlist
 Status: New

** Changed in: julia (Ubuntu)
   Importance: Undecided => Wishlist

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1871911

Title:
  FFe: Sync julia 1.4.0+dfsg-1 (universe) from Debian unstable

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/julia/+bug/1871911/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1870900] Re: Sync synaptic 0.90+nmu1 (universe) from Debian unstable (main)

2020-04-09 Thread Graham Inggs
synaptic 0.90+nmu1 FTBFS for me in Ubuntu.
It might need a merge or be fixed in Debian.


make[1]: Leaving directory '/<>/synaptic-0.90+nmu1'
   debian/rules override_dh_auto_build
make[1]: Entering directory '/<>/synaptic-0.90+nmu1'
# apply distro specific patches if we have them
if [ -e debian/patches/00list.Ubuntu ]; then \
  cp debian/patches/00list.Ubuntu debian/patches/00list;\
  dpatch apply-all;\
fi;
applying patch 01_ubuntu_changelog to ./ ... failed.
make[1]: *** [debian/rules:40: override_dh_auto_build] Error 1
make[1]: Leaving directory '/<>/synaptic-0.90+nmu1'
make: *** [debian/rules:16: build] Error 2
dpkg-buildpackage: error: debian/rules build subprocess returned exit status 2

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1870900

Title:
  Sync synaptic 0.90+nmu1 (universe) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/synaptic/+bug/1870900/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1867457] Re: Please sync rs 20200313-1 (universe) from Debian testing (main)

2020-04-09 Thread Graham Inggs
This bug was fixed in the package rs - 20200313-1
Sponsored for Thorsten Glaser (mirabilos)

---
rs (20200313-1) unstable; urgency=medium

  * New upstream release
  * Modernise packaging and introduce autopkgtests
  * The “Friday 13ᵗʰ” upload

 -- Thorsten Glaser   Fri, 13 Mar 2020 22:48:02 +0100

** Changed in: rs (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1867457

Title:
  Please sync rs 20200313-1 (universe) from Debian testing (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/rs/+bug/1867457/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1867384] Re: Sync deluge 2.0.3-2 (universe) from Debian unstable (main)

2020-04-09 Thread Graham Inggs
This bug was fixed in the package deluge - 2.0.3-2
Sponsored for Amr Ibrahim (amribrahim1987)

---
deluge (2.0.3-2) unstable; urgency=medium

  * debian/control:
   - Update version dependency on python3-libtorrent
 to >= 1.1.2.0 (Closes: #950573).
   - Drop transitional packages deluge-torrent and
 deluge-webui (Closes: #878385).
   - Bump Standards-Version to 4.5.0. 

 -- Andrew Starr-Bochicchio   Mon, 09 Mar 2020 21:09:37
-0400

** Changed in: deluge (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1867384

Title:
  Sync deluge 2.0.3-2 (universe) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/deluge/+bug/1867384/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1867094] Re: Sync jupyter-core 4.6.3-3 (universe) from Debian unstable (main)

2020-04-08 Thread Graham Inggs
It seems this has already been sync'd.

** Changed in: jupyter-core (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1867094

Title:
  Sync jupyter-core 4.6.3-3 (universe) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/jupyter-core/+bug/1867094/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1856795] Re: [SRU] X2Go Client broken by libssh CVE-2019-14889 fix

2020-04-06 Thread Graham Inggs
Hi Qianqian Fang
There is no version 4.1.2.1-0~1788~ubuntu14.04.1 in the Ubuntu repository.
I think you have installed a version from a PPA.
I suggest disabling the PPA, uninstalling x2goclient, and then installing 
x2goclient 4.0.5.1-1ubuntu0.16.04.1 from the Ubuntu repository.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1856795

Title:
  [SRU] X2Go Client broken by libssh CVE-2019-14889 fix

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/x2goclient/+bug/1856795/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1868260] Re: Change sleep-inactive-ac-timeout to 1200 to meet eStar 8 requirement

2020-04-06 Thread Graham Inggs
I have a desktop machine running Ubuntu 20.04 Beta and it suspends when left at 
the login screen.
As in LP: #1759325 , I'm able to adjust the settings for the logged in user, 
but not for the system.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1868260

Title:
  Change sleep-inactive-ac-timeout to 1200 to meet eStar 8 requirement

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1868260/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1861894] Re: autopkgtest failure on armhf due to stderr output

2020-03-17 Thread Graham Inggs
I checked, and autopkgtest does not currently allow the following:

Restrictions: allow-stderr [armhf]

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1861894

Title:
  autopkgtest failure on armhf due to stderr output

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ciftilib/+bug/1861894/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1861894] Re: autopkgtest failure on armhf due to stderr output

2020-03-17 Thread Graham Inggs
force-reset-test here does reduce coverage on armhf, but allow-stderr
would allow unexpected output on all other architectures.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1861894

Title:
  autopkgtest failure on armhf due to stderr output

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ciftilib/+bug/1861894/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1861894] Re: autopkgtest failure on armhf due to stderr output

2020-03-02 Thread Graham Inggs
# ignore GCC 7.1 notes on armhf
force-reset-test ciftilib/1.5.3-3/armhf
force-reset-test mathic/1.0~git20181123-1/armhf
force-reset-test primesieve/7.5+ds-3/armhf

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1861894

Title:
  autopkgtest failure on armhf due to stderr output

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ciftilib/+bug/1861894/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1865437] Re: satpy: autopkgtest unable to run on s390x

2020-03-02 Thread Graham Inggs
force-reset-test satpy/0.19.1-1/s390x

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1865437

Title:
  satpy: autopkgtest unable to run on s390x

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/python-pyproj/+bug/1865437/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1865437] [NEW] satpy: autopkgtest unable to run on s390x

2020-03-01 Thread Graham Inggs
Public bug reported:

satpy now has a test-dependency on python3-zarr which is not installable
on s390x due to python3-numcodecs not being available there

** Affects: python-pyproj (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: python-xarray (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: python3-defaults (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: satpy (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: update-excuse

** Tags added: update-excuse

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1865437

Title:
  satpy: autopkgtest unable to run on s390x

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/python-pyproj/+bug/1865437/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1865437] Re: satpy: autopkgtest unable to run on s390x

2020-03-01 Thread Graham Inggs
This blocks migration of:
satpy/0.19.1-3build1
python-xarray/0.15.0-2ubuntu2
python3-defaults/3.8.2-0ubuntu1
python-pyproj/2.5.0+ds-1

** Also affects: python-xarray (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: python3-defaults (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: python-pyproj (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1865437

Title:
  satpy: autopkgtest unable to run on s390x

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/python-pyproj/+bug/1865437/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1865426] [NEW] colmap: please RM ppc64el binaries

2020-03-01 Thread Graham Inggs
Public bug reported:

colmap does not build on ppc64el due to libceres-dev not being available
on this architecture.

Please remove the colmap ppc64el binaries from -release

** Affects: colmap (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: update-excuse

** Tags added: update-excuse

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1865426

Title:
  colmap: please RM ppc64el binaries

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/colmap/+bug/1865426/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1865225] Re: Eigen 3.3.7 headers throw deprecated-copy warnings in GCC9

2020-03-01 Thread Graham Inggs
eigen3 (3.3.7-2) unstable; urgency=medium

  * [56f108b] Fix some GCC-warnings. (Closes: #952801)
  * [11b3bac] Set compat-level to 12
  * [a184b0e] Set Sstandards-Version to 4.5.0
  * [a4addba] Wrap long lines in changelog entries: 3.3~alpha1-3.

 -- Anton Gladky   Sat, 29 Feb 2020 18:53:00 +0100

** Changed in: eigen3 (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1865225

Title:
  Eigen 3.3.7 headers throw deprecated-copy warnings in GCC9

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/eigen3/+bug/1865225/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1865225] Re: Eigen 3.3.7 headers throw deprecated-copy warnings in GCC9

2020-02-29 Thread Graham Inggs
** Bug watch added: Debian Bug tracker #952801
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=952801

** Also affects: eigen3 (Debian) via
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=952801
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1865225

Title:
  Eigen 3.3.7 headers throw deprecated-copy warnings in GCC9

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/eigen3/+bug/1865225/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1865225] Re: Eigen 3.3.7 headers throw deprecated-copy warnings in GCC9

2020-02-28 Thread Graham Inggs
Ubuntu continually import packages from Debian, so filing a bug in
Debian (and linking it to this bug) is the correct course of action.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1865225

Title:
  Eigen 3.3.7 headers throw deprecated-copy warnings in GCC9

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/eigen3/+bug/1865225/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1863891] Re: php-gettext: CVE-2016-6175

2020-02-24 Thread Graham Inggs
** Bug watch added: Debian Bug tracker #952435
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=952435

** Also affects: icingaweb2-module-nagvis (Debian) via
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=952435
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1863891

Title:
  php-gettext: CVE-2016-6175

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/icingaweb2-module-nagvis/+bug/1863891/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1863891] Re: php-gettext: CVE-2016-6175

2020-02-21 Thread Graham Inggs
icingaweb2-module-nagvis is stuck, unable to migrate in Debian.
I recommend removing it too.

** Also affects: icingaweb2-module-nagvis (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1863891

Title:
  php-gettext: CVE-2016-6175

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/icingaweb2-module-nagvis/+bug/1863891/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1860269] Re: kazoo: autopkgtest regression in -release

2020-02-19 Thread Graham Inggs
** Changed in: kazoo (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1860269

Title:
  kazoo: autopkgtest regression in -release

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/kazoo/+bug/1860269/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1863891] [NEW] php-gettext: CVE-2016-6175

2020-02-19 Thread Graham Inggs
Public bug reported:

Straight from the Debian bug:


the following vulnerability was published for php-gettext.

CVE-2016-6175[0]:
Use of eval too unrestrictive 

If you fix the vulnerability please also make sure to include the
CVE (Common Vulnerabilities & Exposures) id in your changelog entry.

For further information see:

[0] https://security-tracker.debian.org/tracker/CVE-2016-6175
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-6175
[1] https://bugs.launchpad.net/php-gettext/+bug/1606184


Please remove php-getttext from the archive

** Affects: nagvis (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: php-gettext (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: tt-rss (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: php-gettext (Debian)
 Importance: Unknown
 Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1863891

Title:
  php-gettext: CVE-2016-6175

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nagvis/+bug/1863891/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1863891] Re: php-gettext: CVE-2016-6175

2020-02-19 Thread Graham Inggs
cacti also had a reverse dependency on php-php-gettext, but that is
fixed in 1.2.9+ds1-1ubuntu1

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1863891

Title:
  php-gettext: CVE-2016-6175

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nagvis/+bug/1863891/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1863891] Re: php-gettext: CVE-2016-6175

2020-02-19 Thread Graham Inggs
reverse-depends -r unstable src:php-gettext
Reverse-Depends
* nagvis(for php-php-gettext)
* tt-rss(for php-php-gettext)


** Bug watch added: Debian Bug tracker #851771
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=851771

** Also affects: php-gettext (Debian) via
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=851771
   Importance: Unknown
   Status: Unknown

** Also affects: nagvis (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: tt-rss (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1863891

Title:
  php-gettext: CVE-2016-6175

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nagvis/+bug/1863891/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1863739] Re: [focal] cacti needs a merge from 1.2.4+ds1-2ubuntu3 to 1.2.9+ds1-1

2020-02-19 Thread Graham Inggs
I did a fresh install of cacti 1.2.4+ds1-2ubuntu3 on a machine running focal 
and confirmed that I could log in to the web ui.
I added your PPA and upgraded to 1.2.9+ds1-1ubuntu1, the web interface 
reflected the upgrade to 1.2.9.
I was able to remove the php-php-gettext package.
I rebooted and everything was still fine.

I think the only change needed is to mention in the changelog that the
'Replace php-php-gettext dependency' change was dropped.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1863739

Title:
  [focal] cacti needs a merge from 1.2.4+ds1-2ubuntu3 to 1.2.9+ds1-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cacti/+bug/1863739/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1863739] Re: [focal] cacti needs a merge from 1.2.4+ds1-2ubuntu3 to 1.2.9+ds1-1

2020-02-18 Thread Graham Inggs
I believe this change can be dropped:
Replace php-php-gettext dependency in order to fix translations

then php-gettext can be removed from Ubuntu, see Debian bug #851771

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1863739

Title:
  [focal] cacti needs a merge from 1.2.4+ds1-2ubuntu3 to 1.2.9+ds1-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cacti/+bug/1863739/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1863739] Re: [focal] cacti needs a merge from 1.2.4+ds1-2ubuntu3 to 1.2.9+ds1-1

2020-02-18 Thread Graham Inggs
cacti (1.2.6+ds1-2) unstable; urgency=medium

  * Translations were broken since 1.2.4+ds1-1. Import upstream solution
enabling the use of php-phpmyadmin-motranslator.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1863739

Title:
  [focal] cacti needs a merge from 1.2.4+ds1-2ubuntu3 to 1.2.9+ds1-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cacti/+bug/1863739/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1863596] [NEW] satpy: autopkgtests run out of memory

2020-02-17 Thread Graham Inggs
Public bug reported:

autopkgtests satpy >= 0.19.1 appear to run out of memory on the Ubuntu 
infrastructure, but pass on Debian CI and for me locally on amd64.
Please hint these tests or add satpy to the big_packages list.

https://ci.debian.net/packages/s/satpy/testing/amd64/

test_load_250m_cloud_mask_dataset 
(satpy.tests.reader_tests.test_modis_l2.TestModisL2)
Test loading 250m cloud mask. ... DEBUG:satpy.scene:Setting 'PPP_CONFIG_DIR' to 
'foo'
DEBUG:satpy.readers:Reading 
['/usr/lib/python3/dist-packages/satpy/etc/readers/modis_l2.yaml']
DEBUG:satpy.readers.yaml_reader:Assigning to modis_l2: 
['/tmp/tmpz6f7z407/MOD35_L2.A2020045.1719.061.2020045171907.hdf']
DEBUG:satpy.composites:Looking for composites config file modis.yaml
DEBUG:satpy.composites:Looking for composites config file visir.yaml
WARNING:satpy.readers.yaml_reader:Required file type 'hdf_eos_geo' not found or 
loaded for 'latitude'
WARNING:satpy.readers.yaml_reader:Required file type 'hdf_eos_geo' not found or 
loaded for 'longitude'
WARNING:satpy.readers.yaml_reader:Failed to load coordinates for 
'DatasetID(name='cloud_mask', wavelength=None, resolution=250, 
polarization=None, calibration=None, level=None, modifiers=())'
Killed
autopkgtest [17:19:09]: test python3: ---]
python3  FAIL non-zero exit status 137

** Affects: satpy (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: update-excuse

** Tags added: update-excuse

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1863596

Title:
  satpy: autopkgtests run out of memory

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/satpy/+bug/1863596/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1862875] Re: telegram version in ubuntu repo is EOL by upstream

2020-02-15 Thread Graham Inggs
Given there's a snap available:
https://snapcraft.io/telegram-desktop
and Ubuntu 20.04 LTS will be released soon, I'm marking this bug "Won't Fix".

This doesn't prevent anyone from preparing on a backport for 18.04
though.

** Changed in: telegram-desktop (Ubuntu)
   Status: New => Won't Fix

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1862875

Title:
  telegram version in ubuntu repo is EOL by upstream

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/telegram-desktop/+bug/1862875/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1861894] Re: autopkgtest failure on armhf due to stderr output

2020-02-04 Thread Graham Inggs
** Also affects: glbinding (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: globjects (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: fast5 (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: viennacl (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: mathicgb (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: memtailor (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: givaro (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: shark (Ubuntu)
   Importance: Undecided
   Status: New

** Description changed:

  Autopkgtests fail on armhf only due to output similar to the following
  on stderr:
  
  /usr/include/c++/9/bits/stl_algobase.h:438:5: note: parameter passing for 
argument of type ‘__gnu_cxx::__normal_iterator >’ changed in GCC 7.1
-   438 | __copy_move_a2(_II __first, _II __last, _OI __result)
-   | ^~
+   438 | __copy_move_a2(_II __first, _II __last, _OI __result)
+   | ^~
  /usr/include/c++/9/bits/stl_algobase.h:438:5: note: parameter passing for 
argument of type ‘__gnu_cxx::__normal_iterator >’ changed in GCC 7.1
+ 
+ 
+ https://gcc.gnu.org/bugzilla/show_bug.cgi?id=77728
+ 
+ https://wiki.ubuntu.com/GCC7

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1861894

Title:
  autopkgtest failure on armhf due to stderr output

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ciftilib/+bug/1861894/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1861894] Re: autopkgtest failure on armhf due to stderr output

2020-02-04 Thread Graham Inggs
# ignore GCC 7.1 notes on armhf
force-badtest ciftilib/1.5.3-3/armhf
force-badtest mathic/1.0~git20181123-1/armhf
force-badtest primesieve/7.5+ds-3/armhf

Keeping this bug open with the update-excuse tag should cause it to show
up on update_excuses if an update is required.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1861894

Title:
  autopkgtest failure on armhf due to stderr output

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ciftilib/+bug/1861894/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1861894] [NEW] autopkgtest failure on armhf due to stderr output

2020-02-04 Thread Graham Inggs
Public bug reported:

Autopkgtests fail on armhf only due to output similar to the following
on stderr:

/usr/include/c++/9/bits/stl_algobase.h:438:5: note: parameter passing for 
argument of type ‘__gnu_cxx::__normal_iterator >’ changed in GCC 7.1
  438 | __copy_move_a2(_II __first, _II __last, _OI __result)
  | ^~
/usr/include/c++/9/bits/stl_algobase.h:438:5: note: parameter passing for 
argument of type ‘__gnu_cxx::__normal_iterator >’ changed in GCC 7.1

** Affects: ciftilib (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: mathic (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: primesieve (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: update-excuse

** Tags added: update-excuse

** Also affects: primesieve (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: mathic (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1861894

Title:
  autopkgtest failure on armhf due to stderr output

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ciftilib/+bug/1861894/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1861673] [NEW] samtools: 1.10-3 autopkgtests run out of memory

2020-02-03 Thread Graham Inggs
Public bug reported:

since samtools/1.10-3, its autopkgtests run out of memory on Ubuntu 
infrastructure, but pass on Debian CI and for me locally on amd64.
Please hint these tests or add samtools to list to run in a huge instance.

https://ci.debian.net/packages/s/samtools/testing/amd64/


test_sort:
/tmp/autopkgtest.Mgxeg8/autopkgtest_tmp/samtools sort -@ 2 -t RG  
/tmp/autopkgtest.Mgxeg8/autopkgtest_tmp/test/dat/test_input_1_a.bam -O SAM -o -
ERR: samtools sort: couldn't allocate memory for bam_mem

.. failed ...

ERR: samtools sort: couldn't allocate memory for bam_mem

.. failed ...

test_collate:
/tmp/autopkgtest.Mgxeg8/autopkgtest_tmp/samtools collate 
--output-fmt=sam -O 
/tmp/autopkgtest.Mgxeg8/autopkgtest_tmp/test/dat/test_input_1_d.sam
ERR: samtools sort: couldn't allocate memory for bam_mem

.. failed ...

** Affects: htslib (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: samtools (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: update-excuse

** Tags added: update-excuse

** Also affects: htslib (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1861673

Title:
  samtools: 1.10-3 autopkgtests run out of memory

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/htslib/+bug/1861673/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1860648] Re: r-cran-parameters: autopkgtest regression in -release

2020-01-31 Thread Graham Inggs
** Changed in: r-cran-parameters (Ubuntu)
   Status: New => Fix Released

** Changed in: r-cran-testthat (Ubuntu)
   Status: New => Fix Released

** Changed in: r-cran-httr (Ubuntu)
   Status: New => Fix Released

** Changed in: r-cran-nfactors (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1860648

Title:
  r-cran-parameters: autopkgtest regression in -release

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/r-cran-httr/+bug/1860648/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1856795] Re: [SRU] X2Go Client broken by libssh CVE-2019-14889 fix

2020-01-28 Thread Graham Inggs
** Tags removed: verification-needed
** Tags added: verification-done

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1856795

Title:
  [SRU] X2Go Client broken by libssh CVE-2019-14889 fix

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/x2goclient/+bug/1856795/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1860327] Re: assimp's autopkg tests were added in 5.0, always failing on some archs

2020-01-25 Thread Graham Inggs
** Tags added: update-excuse

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1860327

Title:
  assimp's autopkg tests were added in 5.0, always failing on some archs

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/assimp/+bug/1860327/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1860648] Re: r-cran-parameters: autopkgtest regression in -release

2020-01-23 Thread Graham Inggs
** Also affects: r-cran-nfactors (Ubuntu)
   Importance: Undecided
   Status: New

** Description changed:

  The autopkgtests of r-cran-parameters/0.3.0-1 have regressed in -release
  on all architectures
  
  http://autopkgtest.ubuntu.com/packages/r/r-cran-parameters/focal/amd64
  
- This regression prevents the migration of r-cran-httr and r-cran-
- testthat
+ This regression prevents the migration of r-cran-httr, r-cran-nfactors
+ and r-cran-testthat

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1860648

Title:
  r-cran-parameters: autopkgtest regression in -release

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/r-cran-httr/+bug/1860648/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1860648] [NEW] r-cran-parameters: autopkgtest regression in -release

2020-01-23 Thread Graham Inggs
Public bug reported:

The autopkgtests of r-cran-parameters/0.3.0-1 have regressed in -release
on all architectures

http://autopkgtest.ubuntu.com/packages/r/r-cran-parameters/focal/amd64

This regression prevents the migration of r-cran-httr and r-cran-
testthat

** Affects: r-cran-httr (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: r-cran-parameters (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: r-cran-testthat (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: r-cran-parameters (Debian)
 Importance: Unknown
 Status: Unknown


** Tags: update-excuse

** Bug watch added: Debian Bug tracker #949659
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=949659

** Also affects: r-cran-parameters (Debian) via
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=949659
   Importance: Unknown
   Status: Unknown

** Summary changed:

- r-cran-paramters: autopkgtest regression in -release
+ r-cran-parameters: autopkgtest regression in -release

** Also affects: r-cran-httr (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: r-cran-testthat (Ubuntu)
   Importance: Undecided
   Status: New

** Tags added: update-excuse

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1860648

Title:
  r-cran-parameters: autopkgtest regression in -release

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/r-cran-httr/+bug/1860648/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1686079] Re: python-asdf is broken on big endian architectures

2020-01-23 Thread Graham Inggs
** Tags added: update-excuse

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1686079

Title:
  python-asdf is broken on big endian architectures

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/python-asdf/+bug/1686079/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1860128] Re: python-pyepsg: autopkgtest regression in -release

2020-01-22 Thread Graham Inggs
** Changed in: sphinx (Ubuntu)
   Status: New => Fix Released

** Changed in: pytest (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1860128

Title:
  python-pyepsg: autopkgtest regression in -release

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pytest/+bug/1860128/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1860269] Re: kazoo: autopkgtest regression in -release

2020-01-22 Thread Graham Inggs
** Changed in: nose (Ubuntu)
   Status: New => Fix Released

** Changed in: python-eventlet (Ubuntu)
   Status: New => Fix Released

** Changed in: six (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1860269

Title:
  kazoo: autopkgtest regression in -release

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/kazoo/+bug/1860269/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1860270] Re: python-bleach: autopkgtest regression in -release

2020-01-22 Thread Graham Inggs
** Changed in: python-webencodings (Ubuntu)
   Status: New => Fix Released

** Changed in: sphinx (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1860270

Title:
  python-bleach: autopkgtest regression in -release

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/python-bleach/+bug/1860270/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1856056] Re: libassuan: autopkgtest regression in -release on amd64

2020-01-22 Thread Graham Inggs
** Changed in: glibc (Ubuntu)
   Status: New => Fix Released

** Changed in: wine (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1856056

Title:
  libassuan: autopkgtest regression in -release on amd64

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/glibc/+bug/1856056/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1860601] [NEW] openblas: causes autopkgtest failure in hypre armhf

2020-01-22 Thread Graham Inggs
Public bug reported:

openblas >= 0.3.7+ds-3 causes an autopkgtest regression in hypre on
armhf on Ubuntu infrastructure.

There was a major restructuring of the openblas packaging in Debian
version 0.3.7+ds-2 uploaded to experimental.

http://autopkgtest.ubuntu.com/packages/h/hypre/focal/armhf

Running tests
running TEST_ams ... autopkgtest [17:08:06]: ERROR: timed out on command

I have tried to reproduce this error on a Debian porterbox (armhf chroot
on arm64 kernel) and on a Raspberry Pi 3 (armhf focal-proposed chroot on
focal arm64 kernel).  The autopkgtests using binaries from the archive
are successful, and rebuilding the packages locally is fine too.

While investigating, I found the same tests are run while building the hypre 
package.
I uploaded the hypre package to my PPA with the following change:

--- a/debian/control
+++ b/debian/control
@@ -10,8 +10,8 @@
  debhelper-compat (= 12),
  pkg-config,
  gfortran,
- libblas-dev | libopenblas-dev | libatlas-base-dev | libblas.so,
- liblapack-dev | libopenblas-dev | libatlas-base-dev | liblapack.so,
+ libopenblas-dev | libblas-dev | libatlas-base-dev | libblas.so,
+ libopenblas-dev | liblapack-dev | libatlas-base-dev | liblapack.so,
  libsuperlu-dev, libsuperlu-dist-dev,
  libltdl-dev,
  libtool,

i.e. building the package with libopenblas-dev instead of libblas-dev
and liblapack-dev.

https://launchpad.net/~ginggs/+archive/ubuntu/testing/+sourcepub/10932575
/+listing-archive-extra

The builds across all architectures seemed to fail in the same way as the 
autopkgtests on armhf.
TEST_ams would start, and eventually the build would time out.

see e.g. the build log for amd64:

https://launchpad.net/~ginggs/+archive/ubuntu/testing/+build/18567417/+files
/buildlog_ubuntu-focal-amd64.hypre_2.18.2-1~ppa2_BUILDING.txt.gz

Again, I was unable to reproduce this error locally on amd64 or armhf.

This regression prevents openblas, yade, eckit, sdpa, openmolcas and
bolt-lmm from migrating from -proposed.

** Affects: hypre (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: openblas (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: update-excuse

** Also affects: hypre (Ubuntu)
   Importance: Undecided
   Status: New

** Tags added: update-excuse

** Summary changed:

- openblas: cause autopkgtest failure in hypre armhf
+ openblas: causes autopkgtest failure in hypre armhf

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1860601

Title:
  openblas: causes autopkgtest failure in hypre armhf

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/hypre/+bug/1860601/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1860270] [NEW] python-bleach: autopkgtest regression in -release

2020-01-19 Thread Graham Inggs
Public bug reported:

python-bleach's autopkgtests have regressed in -release on all
architectures

This regression prevents the migration of sphinx and python-webencodings

** Affects: python-bleach (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: python-webencodings (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: sphinx (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: python-bleach (Debian)
 Importance: Unknown
 Status: Unknown


** Tags: update-excuse

** Bug watch added: Debian Bug tracker #949029
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=949029

** Also affects: python-bleach (Debian) via
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=949029
   Importance: Unknown
   Status: Unknown

** Also affects: sphinx (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: python-webencodings (Ubuntu)
   Importance: Undecided
   Status: New

** Tags added: update-excuse

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1860270

Title:
  python-bleach: autopkgtest regression in -release

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/python-bleach/+bug/1860270/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1860269] [NEW] kazoo: autopkgtest regression in -release

2020-01-19 Thread Graham Inggs
Public bug reported:

kazoo's autopkgtests have regressed in -release on all architectures

This regression prevents the migration of python-eventlet, six and nose

** Affects: kazoo (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: nose (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: python-eventlet (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: six (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: kazoo (Debian)
 Importance: Unknown
 Status: Unknown


** Tags: update-excuse

** Bug watch added: Debian Bug tracker #933631
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=933631

** Also affects: kazoo (Debian) via
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=933631
   Importance: Unknown
   Status: Unknown

** Also affects: python-eventlet (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: six (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: nose (Ubuntu)
   Importance: Undecided
   Status: New

** Tags added: update-excuse

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1860269

Title:
  kazoo: autopkgtest regression in -release

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/kazoo/+bug/1860269/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

  1   2   3   4   5   6   7   8   9   10   >