Re: [Bug 1700468] Re: "krb5-auth-dialog --auto" segfaults on startup

2017-07-07 Thread Guido Günther
On Thu, Jul 06, 2017 at 08:33:06PM -, Daniel Richard G. wrote: > Er... > > $ klist -v > klist: invalid option -- 'v' > Usage: klist [-e] [-V] [[-c] [-l] [-A] [-d] [-f] [-s] [-a [-n]]] [-k [-t] > [-K]] [name] > [...] > > Remember, the segfault occurs with a user that is

Re: [Bug 1700468] Re: "krb5-auth-dialog --auto" segfaults on startup

2017-07-06 Thread Guido Günther
Hi Daniel, On Wed, Jul 05, 2017 at 10:38:35PM -, Daniel Richard G. wrote: > Hi Guido, I think you mean "klist -V" (uppercase) :-) > > On the system in question, that returns > > $ klist -V > Kerberos 5 version 1.13.2 Thath's useful too but I meant "klist -v" to get your ticket

Re: [Bug 1700468] Re: "krb5-auth-dialog --auto" segfaults on startup

2017-07-03 Thread Guido Günther
Hi Daniel, On Fri, Jun 30, 2017 at 04:39:15AM -, Daniel Richard G. wrote: > Attached is a Valgrind log file produced from a debug build of k-a-d > version 3.20.0. > > All the errors appear to be accesses within freed memory... Yeah that look suspicious. Can you either post (or send via

Re: [Bug 1700468] Re: "krb5-auth-dialog --auto" segfaults on startup

2017-06-29 Thread Guido Günther
On Tue, Jun 27, 2017 at 07:49:07PM -, Daniel Richard G. wrote: > Hunh. How odd... I can't imagine that there would be something > particular to this system that is causing the crash. As you requested: > > skunk@darkstar:/tmp/krb5-auth-dialog-3.20.0/_build/src$ G_MESSAGES_DEBUG=all >

[Bug 1700468] Re: "krb5-auth-dialog --auto" segfaults on startup

2017-06-27 Thread Guido Günther
I can't reproduce here neither when linked against MIT (as in Debian) nor against heimdal (as in Xenial). Can you do a G_MESSAGES_DEBUG=all ./src/krb5-auth-dialog -a maybe this shows s.th. interesting before the crash. -- You received this bug notification because you are a member of

[Bug 1700468] Re: "krb5-auth-dialog --auto" segfaults on startup

2017-06-26 Thread Guido Günther
But it seems ka_krb5_context_init got called (you can check kcontext_valid == TRUE) so in this case it got corrupted. Any chance you can check 3.20? -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

[Bug 1633207] Re: VM fails to start with dac security driver added

2016-10-28 Thread Guido Günther
dfbc9a83 was necessary since libvirt changed the paths of the monitor socket in a89f05ba8df095875f5ec8a9065a585af63a010b. We had to switch from VIR_DOMAIN_DEF_PARSE_INACTIVE to active since we need the domain id (ctl->def->id) as it is part of the socket path now. It would probably o.k. to skip

[Bug 1311487] Re: krb5-auth-dialog does not start in 14.04

2014-07-07 Thread Guido Günther
This is also fixed in 3.12.0 upstream as well as in 3.12.0-1 in Debian. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1311487 Title: krb5-auth-dialog does not start in 14.04 To manage

[Bug 668849] Re: Bug#668849: Re: gbp does not support 2nd orig tarball

2013-06-04 Thread Guido Günther
On Tue, Jun 04, 2013 at 12:53:14PM -, Éric Piel wrote: Can anyone suggest a manual workaround to use multiple orig tarballs? I've tried to follow the workflow descibed in the upstream bug [1]. It seems to do the trick for keeping the sources and tarballs, but building fails (dpkg-source

[Bug 1112831] Re: git-buildpackage incorrectly handles --notify command line parameter

2013-02-02 Thread Guido Günther
That's actually a bug in the manpage. It's missing the --git- prefix: https://honk.sigxcpu.org/gitweb/?p=git- buildpackage.git;a=commit;h=80b5c649a62a9fc1297e2345654f94ef762572b3 -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

Re: [Bug 668849] Re: gbp does not support 2nd orig tarball

2011-02-02 Thread Guido Günther
On Wed, Feb 02, 2011 at 07:45:01AM -, Rolf Leggewie wrote: isdnutils in Debian experimental has this 2nd tarball now if you need a place to have a look. Git repo is at http://git.debian.org/?p=collab- maint/isdnutils.git I'll try to have a look during fosdem. #561071 has some more

Re: [Bug 668849] [NEW] gbp does not recreate 2nd orig tarball

2010-10-31 Thread Guido Günther
On Sat, Oct 30, 2010 at 07:00:33PM -, Rolf Leggewie wrote: Public bug reported: Binary package hint: git-buildpackage using a self-compiled, backported 0.5.4 package here (the latest I could backport to lucid) DebSrc3.0 allows for a second orig tarball, but gbp does not appear to

Re: [Bug 637286] Re: git-import-dsc merges to master despite --debian-branch

2010-10-31 Thread Guido Günther
On Sat, Oct 30, 2010 at 09:19:23PM -, Rolf Leggewie wrote: Is this the same problem as cd /tmp mkdir capifax wget wget http://capifax.v3v.de/dl/capifax-0.7.3.tar.bz2 cd capifax git init git-import-orig --pristine-tar --no-merge ../capifax-0.7.3.tar.bz2 which still creates the

Re: [Bug 615212] Re: heuristic to determine compression-format from HEAD of upstream branch can lead to incorrect result when upstream is not merged to master

2010-10-07 Thread Guido Günther
On Tue, Sep 14, 2010 at 10:41:25AM +0200, Guido Günther wrote: Attached (very lightly tested patch) fixes the issue for me. The fix for this is shipped in 0.5.9. Cheers, -- Guido -- heuristic to determine compression-format from HEAD of upstream branch can lead to incorrect result when

Re: [Bug 615212] Re: heuristic to determine compression-format from HEAD of upstream branch can lead to incorrect result when upstream is not merged to master

2010-10-07 Thread Guido Günther
On Tue, Sep 14, 2010 at 10:41:25AM +0200, Guido Günther wrote: Attached (very lightly tested patch) fixes the issue for me. The fix for this is shipped in 0.5.9. Cheers, -- Guido -- heuristic to determine compression-format from HEAD of upstream branch can lead to incorrect result when

[Bug 637286] Re: git-import-dsc merges to master despite --debian-branch

2010-10-07 Thread Guido Günther
This is fixed in 0.5.9 -- git-import-dsc merges to master despite --debian-branch https://bugs.launchpad.net/bugs/637286 You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. -- ubuntu-bugs mailing list ubuntu-bugs@lists.ubuntu.com

[Bug 638371] Re: git-import-dsc failed to import a dsc

2010-09-16 Thread Guido Günther
I've pushed a fix for a missing debian/rules to gbp's git. -- git-import-dsc failed to import a dsc https://bugs.launchpad.net/bugs/638371 You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. -- ubuntu-bugs mailing list

Re: [Bug 637286] Re: git-import-dsc merges to master despite --debian-branch

2010-09-14 Thread Guido Günther
On Tue, Sep 14, 2010 at 02:52:09AM -, Rolf Leggewie wrote: Are you planning to make another release to experimental anytime soon? I guess rather than backporting the fix to maverick I'd prefer to sync. Once Maverick has the fix, I'll seek an SRU exception for lucid. No, not that soon. I

Re: [Bug 637739] [NEW] improved heuristic for --upstream-branch

2010-09-14 Thread Guido Günther
On Tue, Sep 14, 2010 at 03:17:08AM -, Launchpad Bug Tracker wrote: You have been subscribed to a public bug by Rolf Leggewie (r0lf): Binary package hint: git-buildpackage the current default for gbp and friends is to use HEAD of the upstream branch for --upstream-branch. Thinking

[Bug 615212] Re: heuristic to determine compression-format from HEAD of upstream branch can lead to incorrect result when upstream is not merged to master

2010-09-14 Thread Guido Günther
I just noticed the issue after sending the last mail. The heuristic is to look at pristine-tar not upstream (basically since pristine-tar only supports a single branch) so we have to look at the commit messages. -- heuristic to determine compression-format from HEAD of upstream branch can lead

Re: [Bug 615212] Re: heuristic to determine compression-format from HEAD of upstream branch can lead to incorrect result when upstream is not merged to master

2010-09-14 Thread Guido Günther
Attached (very lightly tested patch) fixes the issue for me. -- Guido ** Patch added: 0001-Improve-compression-format-detection.patch https://bugs.launchpad.net/bugs/615212/+attachment/1582015/+files/0001-Improve-compression-format-detection.patch -- heuristic to determine

Re: [Bug 636862] [NEW] git-import-dscs creates merges instead of simple commits

2010-09-13 Thread Guido Günther
On Mon, Sep 13, 2010 at 06:43:25AM -, Rolf Leggewie wrote: Public bug reported: Binary package hint: git-buildpackage I've rebuilt 0.5.4 with 88afa6117ea4dd6b5d8fd88936afffb11c25ec47 reverted (Pass --multimaint-merge on to dch). The devscripts package in lucid is not recent enough.

Re: [Bug 615212] [NEW] gbp misses bz2 support

2010-09-13 Thread Guido Günther
On Mon, Sep 13, 2010 at 06:36:51AM -, Launchpad Bug Tracker wrote: You have been subscribed to a public bug by Rolf Leggewie (r0lf): Binary package hint: git-buildpackage gbp will create a new orig tar even when an orig.tar.bz2 is present See the manpage:

Re: [Bug 636862] Re: git-import-dscs creates merges instead of simple commits

2010-09-13 Thread Guido Günther
On Mon, Sep 13, 2010 at 10:02:52AM -, Rolf Leggewie wrote: unfortunately, f63c4ed85ca16a6869cf35bc9070e3c28163594e is not a straight-forward cherry-pick against 0.4.65ubuntu1 and I did not feel confident enough to resolve the conflicts. Personally, I'll just use the backported 0.5.4

Re: [Bug 615212] Re: gbp misses bz2 support

2010-09-13 Thread Guido Günther
On Mon, Sep 13, 2010 at 09:53:43AM -, Rolf Leggewie wrote: I guess a test-case would be to import with --pristine-tar the latest releases of isdnutils from Debian stable unstable and Ubuntu maverick. Debian stable: --upstream-branch=upstream debian-branch=master Debian unstable:

Re: [Bug 615212] Re: gbp misses bz2 support

2010-09-13 Thread Guido Günther
On Mon, Sep 13, 2010 at 01:35:12PM -, Rolf Leggewie wrote: ** Description changed: ** Description changed: Binary package hint: git-buildpackage - gbp will create a new orig tar even when an orig.tar.bz2 is present - - TEST CASE: - $ cd /tmp - $ dget -ud

Re: [Bug 615212] Re: gbp misses bz2 support

2010-09-13 Thread Guido Günther
On Mon, Sep 13, 2010 at 04:14:08PM -, Rolf Leggewie wrote: Günther, thank you for trying to reproduce this issue. But your test is way too simplistic ;-) Try the script I have attached now (took a little longer due to bug 637286 throwing me off course for a while). There no script at this

Re: [Bug 637286] [NEW] git-import-dsc merges to master despite --debian-branch

2010-09-13 Thread Guido Günther
On Mon, Sep 13, 2010 at 03:41:13PM -, Launchpad Bug Tracker wrote: You have been subscribed to a public bug by Rolf Leggewie (r0lf): Binary package hint: git-buildpackage git-import-dsc will merge to master even when --debian-branch is explicitly set. Run the attached script as a

Re: [Bug 637286] [NEW] git-import-dsc merges to master despite --debian-branch

2010-09-13 Thread Guido Günther
On Mon, Sep 13, 2010 at 03:41:13PM -, Launchpad Bug Tracker wrote: You have been subscribed to a public bug by Rolf Leggewie (r0lf): Binary package hint: git-buildpackage git-import-dsc will merge to master even when --debian-branch is explicitly set. Run the attached script as a

[Bug 615212] Re: gbp misses bz2 support

2010-09-13 Thread Guido Günther
Testcase fails with: $ sh -e lp615212-test-case.sh `isdnutils_3.12.20071127-0ubuntu6.dsc' - `isdnutils.old/isdnutils_3.12.20071127-0ubuntu6.dsc' `isdnutils_3.9.20060704+dfsg.1-2.dsc' - `isdnutils.old/isdnutils_3.9.20060704+dfsg.1-2.dsc' `isdnutils_3.9.20060704+dfsg.1-3.dsc' -

[Bug 615212] Re: gbp misses bz2 support

2010-09-13 Thread Guido Günther
Ignoring the error the outcome is expected: commit 40a16b8c1523282b8b53c034b5fa86b25b93473e Author: Guido Günther a...@sigxcpu.org Date: Mon Sep 13 21:05:24 2010 +0200 pristine-tar data for isdnutils_3.9.20060704.orig.tar.gz :00 100644 000... 8585744... A isdnutils_3.9.20060704

[Bug 615212] Re: gbp misses bz2 support

2010-08-13 Thread Guido Günther
bz2 support support is there since quiet some time now. It detects the compression type from the pristine-tar branch, it can also be given in the config file or on the command line. I'd be better if you could file the bugs in the Debian BTS since I usually don't check launchpad. -- gbp misses

[Bug 615211] Re: better support for dfsg packages

2010-08-13 Thread Guido Günther
That's what the upstream-branch option is for. You can put this in your per-repo gbp.conf. -- better support for dfsg packages https://bugs.launchpad.net/bugs/615211 You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. -- ubuntu-bugs

[Bug 403299] Re: sequential import fails

2010-08-13 Thread Guido Günther
git-import-dscs (note the extra s) will handle this for you. -- sequential import fails https://bugs.launchpad.net/bugs/403299 You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. -- ubuntu-bugs mailing list ubuntu-bugs@lists.ubuntu.com

[Bug 508949] Re: can't determine version number

2010-05-17 Thread Guido Günther
This was fixed some time ago in Debian: http://packages.debian.org/changelogs/pool/contrib/s/sapgui-package /sapgui-package_0.0.9/changelog -- can't determine version number https://bugs.launchpad.net/bugs/508949 You received this bug notification because you are a member of Ubuntu Bugs, which

[Bug 403299] Re: sequential import fails

2010-01-26 Thread Guido Günther
Works in Debian's 0.4.64. -- sequential import fails https://bugs.launchpad.net/bugs/403299 You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. -- ubuntu-bugs mailing list ubuntu-bugs@lists.ubuntu.com

[Bug 403299] Re: sequential import fails

2010-01-26 Thread Guido Günther
You need to change into the repo after the first import though (or use git-import-dsc*s*) -- sequential import fails https://bugs.launchpad.net/bugs/403299 You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. -- ubuntu-bugs mailing list

[Bug 264974] Re: Window Picker Applet in Ubuntu Netbook Remix doesn't work with vertical panel (on side)

2009-07-17 Thread Guido Günther
We also have this issue reported in Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=536868 ** Bug watch added: Debian Bug tracker #536868 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=536868 ** Also affects: window-picker-applet (Debian) via

[Bug 47994] Re: PowerBook G4 12 - Suspend to disk doesn't work

2008-09-12 Thread Guido Günther
I'm using two tiny scripts for hibernate in Debian, pbbuttonsd isn't needed, pm-utils can handle it: http://honk.sigxcpu.org/con/Suspend_to_Disk_with_a_Apple_Powerbook_G4_12_.html Maybe this helps. Gnome-power-manager forbidding hibernate altogether seems to be a different issue though, maybe

[Bug 73550] Re: Should dissappear when credentials are obtained through other mechanism

2008-06-09 Thread Guido Günther
This is fixed in Debian's krb5-auth-dialog among other things (currently in incoming). I've based the package on my current krb5-auth-dialog development branch at: git-clone http://honk.sigxcpu.org/git/krb5-auth-dialog.git/ See also: http://honk.sigxcpu.org/con/ This is from the Debian