[Bug 1794869] Re: ibus-daemon crashed with SIGABRT in g_assertion_message_expr()

2022-01-19 Thread Gunnar Hjalmarsson
*** This bug is a duplicate of bug 1545811 *** https://bugs.launchpad.net/bugs/1545811 The duplicate bug is old, and it's open now. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1794869 Title:

[Bug 1545811] Re: ibus-daemon crashed with SIGABRT in g_assertion_message()

2022-01-19 Thread Gunnar Hjalmarsson
** Information type changed from Private to Public -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1545811 Title: ibus-daemon crashed with SIGABRT in g_assertion_message() To manage notifications

[Bug 1956004] Re: [BPO] Backport opencpn 5.6.0 from Jammy

2022-01-18 Thread Gunnar Hjalmarsson
On 2022-01-18 22:53, Alec Leamas wrote: >> One oddity is that the orig.tar.xz file includes a debian/ folder > > WTF?! Something is rotten in pristine-tar, will check again. Thanks > for notifying. Note that I didn't grab orig.tar.xz from the repo, but simply downloaded it from the Ubuntu

[Bug 1956004] Re: [BPO] Backport opencpn 5.6.0 from Jammy

2022-01-18 Thread Gunnar Hjalmarsson
I sponsored this to focal-backports. One oddity is that the orig.tar.xz file includes a debian/ folder including a debian/compat file. I had to remove the d/compat file to be able to run debuild() successfully. @Alec: Please unsubscribe ~ubuntu-sponsors from this bug. -- You received this bug

[Bug 1948008] Re: Copying and pasting files between desktop and Nautilus does not work

2022-01-17 Thread Gunnar Hjalmarsson
I just accomplished the steps in the test plan on latest jammy, and couldn't reproduce the issue. The file I copied in Nautilus could successfully be pasted onto the desktop. @Dariusz: Should gnome-shell-extension-desktop-icons-ng be marked "Fix Released" for the development version? (If it's

[Bug 1932981] Re: desktop mouse selection appears on secondary monitor

2022-01-17 Thread Gunnar Hjalmarsson
Also upstream issue #151 is claimed to be fixed: https://gitlab.com/rastersoft/desktop-icons-ng/-/commit/3b70620a That commit made it to Ubuntu in 21.10. @Logan: Is the issue still present in Ubuntu 21.10 and/or jammy? ** Changed in: gnome-shell-extension-desktop-icons-ng (Ubuntu)

[Bug 1917044] Re: Allow launching more cumbersome than necessary

2022-01-15 Thread Gunnar Hjalmarsson
... and now fixed upstream: https://gitlab.com/rastersoft/desktop-icons-ng/-/commit/6efde4c1 The fix will make it to Ubuntu next time we upgrade to a new upstream release. @corrado: Thanks for your persistence on this matter, and sorry for being slow with understanding what you tried to say. :/

[Bug 1917044] Re: Allow launching more cumbersome than necessary

2022-01-15 Thread Gunnar Hjalmarsson
I submitted an upstream issue: https://gitlab.com/rastersoft/desktop-icons-ng/-/issues/201 ** Bug watch added: gitlab.com/rastersoft/desktop-icons-ng/-/issues #201 https://gitlab.com/rastersoft/desktop-icons-ng/-/issues/201 ** Bug watch added: gitlab.com/rastersoft/desktop-icons-ng/-/issues

[Bug 1917044] Re: Allow launching more cumbersome than necessary

2022-01-14 Thread Gunnar Hjalmarsson
Output when running ding.js from terminal and attempting "Allow Launching": gunnar@gunnar-ubuntu-dev:/usr/share/gnome-shell/extensions/d...@rastersoft.com$ ./ding.js Gjs-Message: 00:26:38.815: JS LOG: Error connecting to Nautilus GNOME nautilus 41.1 (gjs:4203): Gjs-CRITICAL **: 00:26:59.754: JS

[Bug 1917044] Re: Allow launching more cumbersome than necessary

2022-01-14 Thread Gunnar Hjalmarsson
From the onAllowDisallowLaunchingClicked() function https://salsa.debian.org/gnome-team/shell-extensions/gnome-shell- extension-desktop-icons-ng/-/blob/debian/master/fileItem.js#L483 the apparent intention is that selecting "Allow launching" should be sufficient. The equivalent function in

[Bug 1917044] Re: Allow launching does not work

2022-01-14 Thread Gunnar Hjalmarsson
On 2022-01-14 09:34, corrado venturini wrote: > In Ubuntu 20.04 with gnome-shell-extension-desktop-icons just allow > launching is enough. Confirmed. In 20.04 "Allow launching" seems to run "chmod u+x" or something in addition to the other stuff. The 20.04 solution is more convenient. When

[Bug 1956916] Re: Using xkb-options for switching input sources not reflected by the input source indicator in a wayland session

2022-01-14 Thread Gunnar Hjalmarsson
I tested some more, and the issue seems to be more complex than I indicated in comment #14. Some XKB shortcuts for switching input source work in both Wayland and Xorg. Examples are: i.e. if you define a single modifier key for the purpose it works. + is a problem on wayland at least, and

[Bug 1956916] Re: Using xkb-options for switching input sources not reflected by the input source indicator in a wayland session

2022-01-14 Thread Gunnar Hjalmarsson
** Summary changed: - [22.04] Unable to set Left Alt + Left Shift key combination to switch keyboard layouts + Using xkb-options for switching input sources not reflected by the input source indicator in a wayland session ** Changed in: gnome-control-center (Ubuntu) Importance: Undecided =>

[Bug 1956916] Re: [22.04] Unable to set Left Alt + Left Shift key combination to switch keyboard layouts

2022-01-13 Thread Gunnar Hjalmarsson
On 2022-01-13 03:25, Daniel van Vugt wrote: > Please report the bug to the developers at > https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues ... Or don't. I'm pretty sure this is not a gnome-control-center regression. gnome-control-center has never, at least not for many cycles,

[Bug 1917044] Re: Allow launching does not work

2022-01-12 Thread Gunnar Hjalmarsson
Isn't that discussion finalized upstream by now? Yes, the execute bit needs to be set, and in addition to that you need to explicitly allow launching. What problem is it that remains? ** Changed in: gnome-shell-extension-desktop-icons-ng (Ubuntu) Status: Confirmed => Incomplete -- You

[Bug 1956879] Re: Desktop icons disappeared

2022-01-09 Thread Gunnar Hjalmarsson
** Bug watch added: gitlab.com/rastersoft/desktop-icons-ng/-/issues #198 https://gitlab.com/rastersoft/desktop-icons-ng/-/issues/198 ** Also affects: gnome-shell-extension-desktop-icons-ng via https://gitlab.com/rastersoft/desktop-icons-ng/-/issues/198 Importance: Unknown Status:

[Bug 1956879] Re: Desktop icons disappeared

2022-01-09 Thread Gunnar Hjalmarsson
Thanks for your report! I still think there is a problem. Admittedly I'm not able to reproduce the behavior you describe. And my attempt to open "Extensions" segfaults: $ gnome-extensions-app free(): double free detected in tcache 2 Aborted (core dumped) (which is probably another bug) But

[Bug 1956414] Re: gnome-control-center crashed with "SIGFPE in g_hash_table_remove()" while setting up a printer

2022-01-06 Thread Gunnar Hjalmarsson
** Information type changed from Private to Public -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1956414 Title: gnome-control-center crashed with "SIGFPE in g_hash_table_remove()" while setting

[Bug 1871011] Re: USB scanning and printing broken on focal by ippusbxd (was: hpmud and ippusbxd conflict)

2022-01-05 Thread Gunnar Hjalmarsson
@Till: Would using the backports pocket be possible? If you backport a package to a release where it doesn't exist in the -release pocket, it effectively works as an SRU. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

[Bug 1956391] Re: Changing username from gnome-control-center does not change the user home directory or name within the OS

2022-01-04 Thread Gunnar Hjalmarsson
Apparently you didn't know there are two kinds of "username". While you can't change the login name easily after a user has been created, being able to change the display name (as shown on the login screen, for instance) is a reasonable feature. Possibly there is room for clarification in the UI.

[Bug 1956391] Re: Changing username from gnome-control-center does not change the user home directory or name within the OS

2022-01-04 Thread Gunnar Hjalmarsson
AFAIK you can't change the real username (login name) from gnome- control-center, only the display name (e.g. "full name"). How is the latter related to the home directory? ** Changed in: gnome-control-center (Ubuntu) Status: New => Incomplete -- You received this bug notification

[Bug 1327801] Re: Bightness and contrast settings have no effect

2021-12-27 Thread Gunnar Hjalmarsson
** Bug watch added: Debian Bug tracker #971725 https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=971725 ** Also affects: sane-backends (Debian) via https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=971725 Importance: Unknown Status: Unknown -- You received this bug notification

[Bug 1955803] Re: configure seems missing

2021-12-27 Thread Gunnar Hjalmarsson
This is a support request, not a bug report. Please try https://askubuntu.com or some other resource as mentioned here: https://ubuntu.com/support/community-support ** Changed in: glibc (Ubuntu) Status: New => Invalid -- You received this bug notification because you are a member of

[Bug 1327801] Re: Bightness and contrast settings have no effect

2021-12-26 Thread Gunnar Hjalmarsson
@Pat: This issue got upstream's attention at last. The upstream fix consists of two commits, and they apply fine in jammy (tested in the PPA), but would require some work for focal. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

[Bug 1908931] Re: Kubuntu 20.04 System Settings Online Accounts - unable to add Google account

2021-12-25 Thread Gunnar Hjalmarsson
@Marc: How can gnome-control-center be an affected package of a Kubuntu bug? -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1908931 Title: Kubuntu 20.04 System Settings Online Accounts - unable to

[Bug 1955534] Re: I am not able to change system settings.Suppose i go to settings and want to auto-hide the dock then it doesn't work i.e., whenever i click on OFF button , it goes into ON state but

2021-12-22 Thread Gunnar Hjalmarsson
Not a docs bug at least. Closing. ** Changed in: ubuntu-docs (Ubuntu) Status: New => Invalid -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1955534 Title: I am not able to change system

[Bug 1955461] Re: ibus-x11 crashed with SIGSEGV in __pthread_kill_implementation()

2021-12-21 Thread Gunnar Hjalmarsson
** Attachment removed: "CoreDump.gz" https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/1955461/+attachment/5548856/+files/CoreDump.gz ** Information type changed from Private to Public -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to

[Bug 1955428] Re: request la_VA locale

2021-12-21 Thread Gunnar Hjalmarsson
No, regular comments here won't be synced back upstream. It's the other way around. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1955428 Title: request la_VA locale To manage notifications about

[Bug 1955428] Re: request la_VA locale

2021-12-20 Thread Gunnar Hjalmarsson
Hi John! Thanks for your report. The locales provided by glibc are what Ubuntu use, so let's await the outcome of the upstream ticket. ** Package changed: langpack-locales (Ubuntu) => glibc (Ubuntu) ** Changed in: glibc (Ubuntu) Importance: Undecided => Wishlist ** Bug watch added:

[Bug 1892825] Re: update-locale not perform correctly sanity checks

2021-12-13 Thread Gunnar Hjalmarsson
I verified the test case using locales 2.31-0ubuntu9.4 from focal- proposed. ** Tags removed: verification-needed-focal ** Tags added: verification-done-focal -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

[Bug 1954429] Re: The required package for GNOME Classic not mentioned in docs

2021-12-11 Thread Gunnar Hjalmarsson
@Akbarkhon: No problem. A change was accepted into upstream master, so the page will be improved for Ubuntu soon. https://gitlab.gnome.org/GNOME/gnome-user-docs/-/commit/323bdf23 ** Changed in: gnome-user-docs (Ubuntu) Status: Confirmed => Fix Committed -- You received this bug

[Bug 1954429] Re: The required package for GNOME Classic not mentioned in docs

2021-12-10 Thread Gunnar Hjalmarsson
** Bug watch added: gitlab.gnome.org/GNOME/gnome-user-docs/-/issues #142 https://gitlab.gnome.org/GNOME/gnome-user-docs/-/issues/142 ** Changed in: gnome-user-docs Importance: Undecided => Unknown ** Changed in: gnome-user-docs Status: New => Unknown ** Changed in: gnome-user-docs

[Bug 1954429] Re: wrong description in documentation

2021-12-10 Thread Gunnar Hjalmarsson
To make GNOME Classic selectable on the login screen, the gnome-shell- extensions package needs to be installed which it is not by default. (No, Akbarkhon, vanilla-gnome-desktop is not necessary. Indeed it pulls gnome-shell-extensions, but it pulls a myriad of other packages too.) The

[Bug 1946794] Re: unity-tweak-tool: GLib-GIO-ERROR

2021-12-04 Thread Gunnar Hjalmarsson
I added some patch headers manually when sponsoring. Uploaded to jammy. ** Changed in: unity-tweak-tool (Ubuntu) Status: Confirmed => Fix Committed -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

[Bug 1945771] Re: freerdp2: Fail to build against OpenSSL 3.0

2021-12-01 Thread Gunnar Hjalmarsson
Sponsored to jammy. ** Changed in: freerdp2 (Ubuntu) Status: New => Fix Committed -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1945771 Title: freerdp2: Fail to build against OpenSSL 3.0

[Bug 1946193] Re: sbsigntool: Fail to build against OpenSSL 3.0

2021-11-29 Thread Gunnar Hjalmarsson
Sponsored to jammy. ** Changed in: sbsigntool (Ubuntu) Status: New => Fix Committed -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1946193 Title: sbsigntool: Fail to build against OpenSSL

[Bug 1952538] Re: Report a problem in Ubuntu page: Step 1: "nameofprogram" unclear

2021-11-28 Thread Gunnar Hjalmarsson
I pushed this commit: https://git.launchpad.net/~ubuntu-core-doc/ubuntu/+source/ubuntu- docs/commit/?id=7be57788 ** Changed in: ubuntu-docs (Ubuntu) Status: Triaged => Fix Committed ** Changed in: ubuntu-docs (Ubuntu) Assignee: (unassigned) => Gunnar Hjalmarsson (gunnarhj) -

[Bug 1952538] Re: Report a problem in Ubuntu page: Step 1: "nameofprogram" unclear

2021-11-28 Thread Gunnar Hjalmarsson
Or "" to be consistent with this: https://help.ubuntu.com/community/ReportingBugs#Reporting_non- crash_hardware_and_desktop_application_bugs -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1952538

[Bug 1952538] Re: Report a problem in Ubuntu page: Step 1: "nameofprogram" unclear

2021-11-28 Thread Gunnar Hjalmarsson
Thanks for your report. I agree that "nameofprogram" is ambiguous. Would "PACKAGENAME" be better? I.e. in your case: ubuntu-bug update-manager ** Changed in: ubuntu-docs (Ubuntu) Status: New => Triaged ** Changed in: ubuntu-docs (Ubuntu) Importance: Undecided => Medium -- You

[Bug 1951993] Re: libnet-ssleay-perl FTBFS

2021-11-25 Thread Gunnar Hjalmarsson
A new version of libnet-ssleay-perl is now in jammy-proposed, and with that aptdaemon could be built successfully. ** Changed in: libnet-ssleay-perl (Ubuntu) Status: New => Fix Released -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to

[Bug 1945768] Re: erlang: Fail to build against OpenSSL 3.0

2021-11-25 Thread Gunnar Hjalmarsson
Sponsored to jammy. ** Changed in: erlang (Ubuntu) Status: New => Fix Committed -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1945768 Title: erlang: Fail to build against OpenSSL 3.0 To

[Bug 1951993] Re: libnet-ssleay-perl FTBFS

2021-11-24 Thread Gunnar Hjalmarsson
> But now we have a libnet-ssleay-perl FTBFS to deal with. Hmm.. That seems to be bug #1945811, and it looks like merging libnet- ssleay-perl with Debian may fix it. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

[Bug 1951993] Re: aptdaemon FTBFS with python3.10

2021-11-24 Thread Gunnar Hjalmarsson
As an experiment I built libnet-ssleay-perl in a jammy-proposed PPA with the tests disabled. Then I could successfully build aptdaemon in that PPA. https://launchpad.net/~gunnarhj/+archive/ubuntu/aptdaemon3/+packages This confirms that the python-defer changes fix aptdaemon's original python

[Bug 1951993] Re: aptdaemon FTBFS with python3.10

2021-11-24 Thread Gunnar Hjalmarsson
Noticed that perl-openssl-defaults 5build2 provides perl-openssl-abi-3. So apparently we need a no-change rebuild against openssl3 also for libnet-ssleay-perl. I tried that in a PPA, but it failed to build (failed tests). Giving up for today. -- You received this bug notification because you

[Bug 1951993] Re: aptdaemon FTBFS with python3.10

2021-11-24 Thread Gunnar Hjalmarsson
I just retried (three times), but: The following packages have unmet dependencies: libnet-ssleay-perl : Depends: perl-openssl-abi-1.1 E: Unable to correct problems, you have held broken packages. Suddenly it can't resolve the virtual package perl-openssl-abi-1.1 (provided by

[Bug 1951993] Re: aptdaemon FTBFS with python3.10

2021-11-23 Thread Gunnar Hjalmarsson
** Tags added: rls-jj-incoming -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1951993 Title: aptdaemon FTBFS with python3.10 To manage notifications about this bug go to:

[Bug 1949924] Re: yelp crashes in wayland session with NVIDIA 470

2021-11-23 Thread Gunnar Hjalmarsson
signed) => Gunnar Hjalmarsson (gunnarhj) -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1949924 Title: yelp crashes in wayland session with NVIDIA 470 To manage notifications about this bug go

[Bug 1951985] Re: Fix some instances of deprecated code

2021-11-23 Thread Gunnar Hjalmarsson
There is a build problem with the aptdaemon upload: bug #1951993. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1951985 Title: Fix some instances of deprecated code To manage notifications about

[Bug 1951993] [NEW] aptdaemon FTBFS with python3.10

2021-11-23 Thread Gunnar Hjalmarsson
Public bug reported: This is the buildlog from the 1.1.1+bzr982-0ubuntu37 upload: https://launchpadlibrarian.net/570420275/buildlog_ubuntu-jammy- amd64.aptdaemon_1.1.1+bzr982-0ubuntu37_BUILDING.txt.gz This error: File "/usr/lib/python3/dist-packages/defer/__init__.py", line 263, in

[Bug 1951985] Re: Fix some instances of deprecated code

2021-11-23 Thread Gunnar Hjalmarsson
After the uploaded changes only this one is left: /usr/lib/python3/dist-packages/gi/overrides/Gdk.py:329: DeprecationWarning: Gdk.Cursor.new is deprecated return cls.new(*args, **kwds) Ignoring that for now under the assumption that the pygobject package is taken care of upstream. ** Changed

[Bug 1951985] [NEW] Fix some instances of deprecated code

2021-11-23 Thread Gunnar Hjalmarsson
Public bug reported: Attached please find the noise exposed if you run this command in terminal: PYTHONWARNINGS=d gnome-language-selector ** Affects: aptdaemon (Ubuntu) Importance: Low Assignee: Gunnar Hjalmarsson (gunnarhj) Status: In Progress ** Affects: language-selector

[Bug 1892014] Re: 18.04.14.7 regression: no alt_shift_toggle in XKBOPTIONS

2021-11-20 Thread Gunnar Hjalmarsson
Ubiquity? That sounds more like bug #1875062. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1892014 Title: 18.04.14.7 regression: no alt_shift_toggle in XKBOPTIONS To manage notifications about

[Bug 1950828] Re: ibus-daemon crashed with SIGABRT in g_mutex_clear().

2021-11-12 Thread Gunnar Hjalmarsson
** Attachment removed: "CoreDump.gz" https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/1950828/+attachment/5540511/+files/CoreDump.gz ** Information type changed from Private to Public -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to

[Bug 1950550] Re: language support app automatically installs firefox deb package (21.10)

2021-11-12 Thread Gunnar Hjalmarsson
Another related discussion: https://forum.snapcraft.io/t/firefox-snap-cannot-be-set-as-default- browser/26636 ** Also affects: firefox (Ubuntu) Importance: Undecided Status: New -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to

[Bug 1950550] Re: language support app automatically installs firefox deb package (21.10)

2021-11-11 Thread Gunnar Hjalmarsson
Thanks for your report. I can reproduce it on impish. When trying on jammy, I get another result though... It installs lynx instead of Firefox. :/ I think this has something to do with the virtual package www-browser. $ apt-cache show gimp-help-en | grep Depends Depends: gimp-help-common (=

[Bug 1950461] Re: Installing vino does not expose the screen sharing slider in Gnome Control Center

2021-11-10 Thread Gunnar Hjalmarsson
vino has been replaced with gnome-remote-desktop. https://help.ubuntu.com/stable/ubuntu-help/sharing-desktop.html ** Changed in: gnome-control-center (Ubuntu) Status: New => Invalid -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to

[Bug 1898005] Re: gnome-shell crashed with SIGABRT in st_bin_destroy: assertion failed: (priv->child == NULL) called from DesktopManager::_destroyDesktopIcons() [desktopManager.js:234]

2021-11-09 Thread Gunnar Hjalmarsson
From the buildlog: dpkg-source: info: applying desktopManager-Avoid-scheduling-multiple- _layoutChil.patch ** Tags removed: verification-needed verification-needed-focal ** Tags added: verification-done verification-done-focal -- You received this bug notification because you are a member of

[Bug 1949924] Re: yelp crashes in wayland session

2021-11-06 Thread Gunnar Hjalmarsson
This seems to be NVIDIA related (I'm using nvidia-driver-470). Downgrading the libnvidia-egl-wayland1 package to the version used in impish fixes the issue; hence it's a 1.1.9 regression. Setting GDK_BACKEND=x11, as mentioned in the upstream issue, works around the problem. ** Bug watch added:

[Bug 1946499] Re: SRU: GDebi - installation of deb-packages with gdebi-gtk not working at all

2021-11-06 Thread Gunnar Hjalmarsson
For the record: Version 0.64.2-3 of vte2.91, without 91_keep_fds.patch, has migrated to jammy. ** Also affects: vte2.91 (Ubuntu) Importance: Undecided Status: New ** Changed in: vte2.91 (Ubuntu) Status: New => Fix Released -- You received this bug notification because you are

[Bug 1950018] Re: package fonts-noto-extra 20200323-1build1~ubuntu20.04.1 failed to install/upgrade: Neue Datei »/var/lib/dpkg/info/fonts-noto-extra.list-new« kann nicht angelegt werden: Vorgang nicht

2021-11-05 Thread Gunnar Hjalmarsson
Thanks for your report. It sounds as a hardware issue, though. Please try to reinstall the package: sudo apt install --reinstall fonts-noto-extra and let us know if it helps. ** Changed in: fonts-noto (Ubuntu) Status: New => Incomplete -- You received this bug notification because you

[Bug 1898005] Re: gnome-shell crashed with SIGABRT in st_bin_destroy: assertion failed: (priv->child == NULL) called from DesktopManager::_destroyDesktopIcons() [desktopManager.js:234]

2021-11-05 Thread Gunnar Hjalmarsson
Correction of gnome-shell-extension-desktop-icons uploaded to focal unapproved queue. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1898005 Title: gnome-shell crashed with SIGABRT in

[Bug 1949924] Re: yelp crashes in wayland session

2021-11-04 Thread Gunnar Hjalmarsson
Downgrading yelp and libyelp0 to the impish version does not help, so it may well be a bug in some other package. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1949924 Title: yelp crashes in

[Bug 1949924] [NEW] yelp crashes in wayland session

2021-11-04 Thread Gunnar Hjalmarsson
Public bug reported: $ yelp yelp: ../src/wayland-thread.c:87: wlExternalApiLock: Assertion `!"failed to lock pthread mutex"' failed. Aborted (core dumped) This does not happen in Debian testing, and it also works as expected in an Ubuntu on Xorg session. ProblemType: Bug DistroRelease: Ubuntu

[Bug 1943823] Re: ruby2.7 ftbfs on ppc64el using GCC 11.2

2021-10-28 Thread Gunnar Hjalmarsson
Sounds good. Thanks for clarifying. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1943823 Title: ruby2.7 ftbfs on ppc64el using GCC 11.2 To manage notifications about this bug go to:

[Bug 1943823] Re: ruby2.7 ftbfs on ppc64el using GCC 11.2

2021-10-28 Thread Gunnar Hjalmarsson
The workaround seems to enforce other packages which builds with ruby to apply similar workarounds for ppc64el. Example: https://launchpad.net/ubuntu/+source/marisa/0.2.6-5ubuntu1 So I can think it's motivated to raise the importance of this bug. -- You received this bug notification because

[Bug 1948592] Re: Switching between workspaces is now Ctrl-Alt-Right or Left, no longer Up or Down

2021-10-25 Thread Gunnar Hjalmarsson
Thanks for your report. I suppose you mean this page: https://help.ubuntu.com/stable/ubuntu-help/shell-workspaces-switch.html That's actually an upstream issue, and it would be great if you could report it upstream too: https://gitlab.gnome.org/GNOME/gnome-user-docs/-/issues If you do, please

[Bug 1947790] Re: marisa FTBFS on ppc64el

2021-10-25 Thread Gunnar Hjalmarsson
** Tags removed: update-excuse -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1947790 Title: marisa FTBFS on ppc64el To manage notifications about this bug go to:

[Bug 1946969] Re: ibus-x11 does not start automatically

2021-10-24 Thread Gunnar Hjalmarsson
This was run on Debian testing (GNOME / Wayland): $ strings /proc/$(pidof ibus-engine-mozc)/environ | grep ^DISPLAY DISPLAY=:1 $ ls -l /tmp/.X11-unix/ total 0 srwxr-xr-x 1 gunnar gunnar 0 okt 24 19:35 X0 srwxr-xr-x 1 gunnar gunnar 0 okt 24 19:35 X1 srwxr-xr-x 1 Debian-gdm

[Bug 1947790] Re: marisa FTBFS on ppc64el

2021-10-24 Thread Gunnar Hjalmarsson
On 2021-10-24 07:31, Mitsuya Shibata wrote: > mkmf module in extconf.rb sets CC and some build related environment > variables. But this variables will not refer host system directly, > instead of this, mkmf refer to ruby embedded information. That is, > mkmf will set CC as same as compile to

[Bug 1947790] Re: marisa FTBFS on ppc64el

2021-10-23 Thread Gunnar Hjalmarsson
@Mitsuya: Hmm.. I didn't read your latest comment carefully enough. I changed debian/rules too, but now I see that only installing g++-10 would have been sufficient. Don't understand how, though. Isn't GCC 11 the default when both are present? -- You received this bug notification because you

[Bug 1947790] Re: marisa FTBFS on ppc64el

2021-10-23 Thread Gunnar Hjalmarsson
You are right Mitsuya. I uploaded with that change. https://launchpad.net/ubuntu/+source/marisa/0.2.6-3ubuntu3 Thanks again! ** Changed in: marisa (Ubuntu) Status: Confirmed => Fix Committed ** Changed in: marisa (Ubuntu) Assignee: (unassigned) => Gunnar Hjalmarsson (gu

[Bug 1947790] Re: marisa FTBFS on ppc64el

2021-10-23 Thread Gunnar Hjalmarsson
Thanks for the tip! The workaround for ruby was applied already in impish, but the marisa source which fails in jammy builds successfully in impish. https://launchpad.net/~gunnarhj/+archive/ubuntu/marisa/+packages So that would indicate that marisa fails for some other reason. Did you possibly

[Bug 1946499] Re: installation of deb-packages with gdebi-gtk shows "dpkg: error: unable to read filedescriptor flags for : Bad file descriptor" in gdebi t

2021-10-20 Thread Gunnar Hjalmarsson
On 2021-10-20 22:58, Dani Llewellyn wrote: > There are zero changes made to the strings themselves, only the line > numbers used to generate the templates changed. Thanks for explaining. Apparently I didn't look close enough. :/ Then I suppose we'd better use your small debdiff also for impish

[Bug 1926912] Re: 21.10 Impish gdebi Programm fehlt Paket?

2021-10-20 Thread Gunnar Hjalmarsson
*** This bug is a duplicate of bug 1926697 *** https://bugs.launchpad.net/bugs/1926697 ** This bug has been marked a duplicate of bug 1926697 gdebi-gtk does not start w msg 'Download failed' -- You received this bug notification because you are a member of Ubuntu Bugs, which is

[Bug 1926697] Re: gdebi does not start w msg 'Download failed'

2021-10-20 Thread Gunnar Hjalmarsson
I can confirm this bug in 21.04. However, I think it's about to be coincidentally fixed through the solution to bug #1946499. At least I can successfully open gdebi-gtk in jammy (without passing a .deb file as argument), and if the SRU of the other bug gets completed it ought to be fixed in 21.10

[Bug 1946499] Re: installation of deb-packages with gdebi-gtk shows "dpkg: error: unable to read filedescriptor flags for : Bad file descriptor" in gdebi t

2021-10-20 Thread Gunnar Hjalmarsson
It looks like also bug #1926697 is coincidentally about to be fixed through the fix of this bug. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1946499 Title: installation of deb-packages with

[Bug 1946499] Re: installation of deb-packages with gdebi-gtk shows "dpkg: error: unable to read filedescriptor flags for : Bad file descriptor" in gdebi t

2021-10-20 Thread Gunnar Hjalmarsson
My understanding is that it was intended for impish as well. If so, can somebody (@Norbert, @Martin, anyone...) please edit the bug description to comply with the SRU template: https://wiki.ubuntu.com/StableReleaseUpdates#SRU_Bug_Template Another thing: When uploading to Debian, I picked Dani's

[Bug 1947790] [NEW] marisa FTBFS on ppc64el

2021-10-19 Thread Gunnar Hjalmarsson
Public bug reported: marisa fails to build on ppc64el: # extconf.rb needs to exist library when configure cd bindings/ruby; ruby extconf.rb --with-opt-include=../../include \ --with-opt-lib=../../lib/marisa/.libs checking for -lmarisa... *** extconf.rb failed *** Could not create Makefile

[Bug 1947670] Re: /etc/profile.d/im-config_wayland.sh prevents sourcing /etc/profile

2021-10-19 Thread Gunnar Hjalmarsson
Correction: Uninstalling im-config may not be so easy on an Ubuntu system. So maybe you want to simply edit the script. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1947670 Title:

[Bug 1947670] Re: /etc/profile.d/im-config_wayland.sh prevents sourcing /etc/profile

2021-10-19 Thread Gunnar Hjalmarsson
-config (I assume you don't need it for the described purpose.) ** Changed in: im-config (Ubuntu) Importance: Undecided => Low ** Changed in: im-config (Ubuntu) Status: Incomplete => In Progress ** Changed in: im-config (Ubuntu) Assignee: (unassigned) => Gunnar Hjalmarsson

[Bug 1946499] Re: installation of deb-packages with gdebi-gtk shows "dpkg: error: unable to read filedescriptor flags for : Bad file descriptor" in gdebi t

2021-10-19 Thread Gunnar Hjalmarsson
@Nikola: If that issue happened also in 21.04, it's not the same issue as the one dealt with in this bug report. The latter is about a regression due to an upgrade of vte2.91. So you may want to submit a new bug report (with more details, exact error messages, etc.). -- You received this bug

[Bug 1947519] Re: Unless gedit is installed, "Appearance" causes control center to crash

2021-10-19 Thread Gunnar Hjalmarsson
I assumed that the patch was changed in version 1:40.0-1ubuntu4 for a reason, which made it natural to me to add the dependency. I understand that an alternative solution is to change it so it falls back to the previous behavior if the schema is missing. Please feel free to do that instead and

[Bug 1947670] Re: /etc/profile.d/im-config_wayland.sh prevents sourcing /etc/profile

2021-10-19 Thread Gunnar Hjalmarsson
Thanks for your report. The script is there to set some input method related env. variables in case of a wayland session. (If an X session, /etc/X11/Xsession.d/70im- config_launch is started via Xsession instead.) Can you please explain how it is a problem if no input method configuration is

[Bug 1947519] Re: Unless gedit is installed, "Appearance" causes control center to crash

2021-10-19 Thread Gunnar Hjalmarsson
Not sure what you mean by that, Daniel. By letting g-c-c depend on gedit-common, we make sure that the schema is never missing. If a user uninstalls gedit, gedit-common won't be uninstalled via "apt autoremove". Hence there is no need to figure out how to handle a missing schema graciously, is it?

[Bug 1892825] Re: update-locale not perform correctly sanity checks

2021-10-18 Thread Gunnar Hjalmarsson
@Michael: I could easily reproduce the issue at the time (a year ago). Good that it's about to be fixed. As you can see in comment #2 I first turned to Debian, but the response was a bit disappointing. Any chance that you can handle this on the Debian side too? -- You received this bug

[Bug 1947607] Re: Docs state to use ctrl-alt-shift-R to record screen recording, which will NEVER work correctly

2021-10-18 Thread Gunnar Hjalmarsson
Thanks for your report. It's not clear to me how that step-by-step page encourages users to "mis-use" the feature. Anyway, the page in question is from GNOME Help, and if you want to discuss its wording, I would recommend you to submit an upstream issue:

[Bug 1947519] Re: Unless gedit is installed, "Appearance" causes control center to crash

2021-10-18 Thread Gunnar Hjalmarsson
Pushed this commit: https://salsa.debian.org/gnome-team/gnome-control- center/-/commit/f685f0a6 ** Changed in: gnome-control-center (Ubuntu) Status: Triaged => In Progress ** Changed in: gnome-control-center (Ubuntu) Assignee: (unassigned) => Gunnar Hjalmarsson (gunnarhj) -

[Bug 1947519] Re: Unless gedit is installed, "Appearance" causes control center to crash

2021-10-18 Thread Gunnar Hjalmarsson
For the record: Using gedit's schema was introduced recently through this upload: https://launchpad.net/ubuntu/+source/gnome-control- center/1:40.0-1ubuntu4 -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

[Bug 1947519] Re: Unless gedit is installed, "Appearance" causes control center to crash

2021-10-18 Thread Gunnar Hjalmarsson
On 2021-10-18 11:34, Daniel van Vugt wrote: > Handling missing schemas without crashing is still possible, just > not elegant, in the gsettings API. I see. OTOH I suppose we want the UI to work as expected, not only prevent the crash. So without changing the patch, it looks to me as if letting

[Bug 1947519] Re: Unless gedit is installed, "Appearance" causes control center to crash

2021-10-18 Thread Gunnar Hjalmarsson
On 2021-10-18 11:46, Piotr Mitana wrote: > Actually gedit-common triggers gedit install as well: Yes, but you can uninstall gedit afterwards. Or: sudo apt install --no-install-recommends gedit-common > Still, isn't it a bit weird, that changing the wallpaper requires a > particular text editor

[Bug 1946610] Re: Settings won't open after update

2021-10-18 Thread Gunnar Hjalmarsson
*** This bug is a duplicate of bug 1947519 *** https://bugs.launchpad.net/bugs/1947519 ** Changed in: gnome-control-center (Ubuntu) Status: Incomplete => New ** This bug has been marked a duplicate of bug 1947519 Unless gedit is installed, "Appearance" causes control center to

[Bug 1947519] Re: Unless gedit is installed, "Appearance" causes control center to crash

2021-10-18 Thread Gunnar Hjalmarsson
This is due to Allow-tweaking-some-settings-for-Ubuntu-Dock.patch. Making g-c-c depend on gedit-common is one way to fix it. (AFAIU gedit itself does not need to be installed.) ** Changed in: gnome-control-center (Ubuntu) Status: New => Triaged -- You received this bug notification

[Bug 1946969] Re: ibus-x11 does not start automatically

2021-10-16 Thread Gunnar Hjalmarsson
Thanks for editing the description! Ok, then let's get the ball rolling. I uploaded the change to Debian unstable (to sync later) and to the impish unapproved queue. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

[Bug 1946969] Re: ibus-x11 does not start automatically

2021-10-16 Thread Gunnar Hjalmarsson
ozc (Ubuntu) Assignee: (unassigned) => Gunnar Hjalmarsson (gunnarhj) ** Changed in: mozc (Ubuntu Impish) Importance: Undecided => High ** Changed in: mozc (Ubuntu Impish) Status: New => In Progress ** Changed in: mozc (Ubuntu Impish) Assignee: (unassigned) => Gun

[Bug 1946969] Re: ibus-x11 does not start automatically

2021-10-15 Thread Gunnar Hjalmarsson
I submitted to involve the desktop team in the solution. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1946969 Title: ibus-x11 does not start automatically

[Bug 1946969] Re: ibus-x11 does not start automatically

2021-10-14 Thread Gunnar Hjalmarsson
I just found that this problem is not present in Debian testing, even if they have the same version of both mutter and ibus. Something seems to make Xwayland start at login, and hence ibus-x11 is also running. That speaks against using im-config to work around it, since im-config is used by both

[Bug 1892825] Re: update-locale not perform correctly sanity checks

2021-10-14 Thread Gunnar Hjalmarsson
Thanks Dan, I changed the MR in accordance with your suggestion. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1892825 Title: update-locale not perform correctly sanity checks To manage

[Bug 1946499] Re: installation of deb-packages with gdebi-gtk shows "dpkg: error: unable to read filedescriptor flags for : Bad file descriptor" in gdebi t

2021-10-14 Thread Gunnar Hjalmarsson
I just uploaded Dani's gdebi fix to Debian unstable. Tested it in a PPA first: https://launchpad.net/~gunnarhj/+archive/ubuntu/gdebi/+packages With that, and for impish+1, we will be able to sync the source from Debian for both gdebi and vte2.91. The gdebi change must of course be SRUed to

[Bug 1946499] Re: installation of deb-packages with gdebi-gtk shows "dpkg: error: unable to read filedescriptor flags for : Bad file descriptor" in gdebi t

2021-10-14 Thread Gunnar Hjalmarsson
@Dani: Needless to say I didn't see your patch before submitting my latest comment. This sounds very promising! :) And suddenly I understand why gdebi behaves differently in Ubuntu compared to Debian... Will test is in a minute. And yes, this means that we can simply start sync'ing vte2.91 from

[Bug 1946499] Re: installation of deb-packages with gdebi-gtk shows "dpkg: error: unable to read filedescriptor flags for : Bad file descriptor" in gdebi t

2021-10-14 Thread Gunnar Hjalmarsson
The downgrade idea would need to be approved by some leading member of Ubuntu's desktop team, and since 21.10 is released today, also the SRU team would need to approve it. (You already know what I think the answer will be.) It's correct that I have helped with some routine packaging of VTE a

  1   2   3   4   5   6   7   8   9   10   >