[Bug 1944385] Re: REGRESSION: After GRUB update, 32-bit Ubuntu is no more bootable

2021-09-23 Thread Julian Andres Klode
*** This bug is a duplicate of bug 1876737 *** https://bugs.launchpad.net/bugs/1876737 FWIW, the bug status should have been Won't fix and not Invalid, as the main bug. It's unfortunate your use case broke. Mixing multiple Ubuntu instances on a single machine is problematic (as there can

[Bug 1944385] Re: REGRESSION: After GRUB update, 32-bit Ubuntu is no more bootable

2021-09-23 Thread Julian Andres Klode
*** This bug is a duplicate of bug 1876737 *** https://bugs.launchpad.net/bugs/1876737 ** This bug has been marked a duplicate of bug 1876737 GRUB refuses to boot a 32-bit kernel when in EFI mode -- You received this bug notification because you are a member of Ubuntu Bugs, which is

[Bug 1943758] Re: package shim-signed 1.40.7+15.4-0ubuntu9 failed to install/upgrade: il sottoprocesso installato pacchetto shim-signed script post-installation ha restituito lo stato di errore 7

2021-09-23 Thread Julian Andres Klode
Various dkms weirdness "Error! The module acpi-call 1.1.0 is not currently installed." But there are also like 3 services failing to start in the log, so maybe the system is just misconfigured somewhere that affects all of them. The bug also indicates that EFI variables are not supported by the

[Bug 1944385] Re: REGRESSION: After GRUB update, 32-bit Ubuntu is no more bootable

2021-09-23 Thread Julian Andres Klode
Booting 32-bit linux kernels on 64-bit UEFI is unsupported. Preventing that unsupported combination from booting is a feature in recent grub versions, older versions erroneously let the boot continue despite the kernel possibly being unable to handle the addresses where UEFI services are located.

[Bug 1876034] Re: apt update crashes with "KeyError: 'suite'" in cnf-update-db if index compression is enabled

2021-09-23 Thread Julian Andres Klode
** Also affects: command-not-found (Ubuntu Focal) Importance: Undecided Status: New -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1876034 Title: apt update crashes with "KeyError:

[Bug 1876034] Re: apt update crashes with "KeyError: 'suite'" in cnf-update-db if index compression is enabled

2021-09-23 Thread Julian Andres Klode
** Description changed: - On all Ubuntu releases since at least 19.10, enabling compressed APT - package list storage with command-not-found installed leads to this - crash in the cnf-update-db hook called by apt update: + [Impact] + On all Ubuntu releases since at least 19.10, enabling

[Bug 1944419] Re: vim: impish missing in debchangelog.vim

2021-09-23 Thread Julian Andres Klode
sponsored ** Changed in: vim (Ubuntu) Status: In Progress => Fix Committed -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1944419 Title: vim: impish missing in debchangelog.vim To manage

[Bug 1943189] Re: "cannot refresh whilst network offline" bug

2021-09-17 Thread Julian Andres Klode
** Changed in: packagekit (Ubuntu Impish) Status: New => Fix Committed -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1943189 Title: "cannot refresh whilst network offline" bug To manage

[Bug 1943189] Re: "cannot refresh whilst network offline" bug

2021-09-17 Thread Julian Andres Klode
@Erich Does this need fixing in older releases as well? The description reads like it just affects impish, but I don't see why that would be the case. If so, can you provide the necessary info for an SRU as in https://wiki.ubuntu.com/StableReleaseUpdates#SRU_Bug_Template -- You received this bug

[Bug 1943557] Re: package grub-common 2.04-1ubuntu26.13 failed to install/upgrade: installed grub-common package post-installation script subprocess returned error exit status 1

2021-09-14 Thread Julian Andres Klode
What does run weekly is fstrim, and maybe that causes some corruption somewhere in your hardware chain. I'd do some hard disk stress testing. ** Changed in: grub2 (Ubuntu) Status: New => Incomplete -- You received this bug notification because you are a member of Ubuntu Bugs, which is

[Bug 1943557] Re: package grub-common 2.04-1ubuntu26.13 failed to install/upgrade: installed grub-common package post-installation script subprocess returned error exit status 1

2021-09-14 Thread Julian Andres Klode
It seems your /boot/grub/grubenv gets corrupted on a weekly basis then - It fails to find that first line: # head -1 /boot/grub/grubenv # GRUB Environment Block Deleting the file should get you started again. Maybe there is an issue with the PCIe card or the SSD causing the file(system) to get

[Bug 1943125] Re: devscripts breaks apt

2021-09-11 Thread Julian Andres Klode
*** This bug is a duplicate of bug 1943049 *** https://bugs.launchpad.net/bugs/1943049 ** This bug has been marked a duplicate of bug 1943049 Docker ubuntu:impish: Problem executing scripts DPkg::Post-Invoke 'rm -f /var/cache/apt/archives/*.deb /var/cache/apt/archives/partial/*.deb

[Bug 1943125] Re: devscripts breaks apt

2021-09-11 Thread Julian Andres Klode
It's once again a bug in container seccomp policy, the new clone3() syscall in glibc 2.34 is being denied with EPERM instead of ENOSYS. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1943125 Title:

[Bug 1943125] Re: devscripts breaks apt

2021-09-11 Thread Julian Andres Klode
See bug 1943049 for more details. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1943125 Title: devscripts breaks apt To manage notifications about this bug go to:

[Bug 1943049] Re: Docker ubuntu:impish: Problem executing scripts DPkg::Post-Invoke 'rm -f /var/cache/apt/archives/*.deb /var/cache/apt/archives/partial/*.deb /var/cache/apt/*.bin || true'

2021-09-11 Thread Julian Andres Klode
Disabling the clone3 call should only be a temporary workaround to get 21.10 released, this still must be fixed properly so it can be reenabled in 22.04. I feel like that docker change is working around a bug in crun/runc regarding the default seccomp policy and not the proper fix either. It will

[Bug 1916323] Re: tracker-extract crashed with signal 31 in __GI___fstatat64() from _nl_load_domain()

2021-09-10 Thread Julian Andres Klode
** Changed in: tracker-miners (Ubuntu) Assignee: Roshan Khaiju (khaiju) => (unassigned) -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1916323 Title: tracker-extract crashed with signal 31 in

[Bug 1937115] Re: Unable to boot/install Impish daily in UEFI boot mode

2021-09-10 Thread Julian Andres Klode
Marking as verified as per "Verification is not necessary for individual SRU releases." We did not touch any code paths involving shim-grub interaction, the fix here for disabling boot option parsing on removable media paths is valid across all releases, since the binary is the same. ** Tags

[Bug 1943183] Re: Suggests installing Extensions app from flatpak

2021-09-09 Thread Julian Andres Klode
** Bug watch added: Debian Bug tracker #994018 https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=994018 ** Also affects: gnome-tweaks (Debian) via https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=994018 Importance: Unknown Status: Unknown -- You received this bug notification

[Bug 1943183] [NEW] Suggests installing Extensions app from flatpak

2021-09-09 Thread Julian Andres Klode
Public bug reported: gnome-tweaks suggests installing the extensions app from flatpak if not provided by the distro. This is misleading, because (1) we ship the app and (2) I already had it installed. Instead it should tell me that it is installed, and if not, offer to install the app with

[Bug 1943049] Re: Docker ubuntu:impish: Problem executing scripts DPkg::Post-Invoke 'rm -f /var/cache/apt/archives/*.deb /var/cache/apt/archives/partial/*.deb /var/cache/apt/*.bin || true'

2021-09-09 Thread Julian Andres Klode
@fweimer Suggestion was to avoid use of clone3 to keep things working until container runtimes are fixed. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1943049 Title: Docker ubuntu:impish: Problem

[Bug 1943122] Re: Software update doesn't run autoremove so that update fails due to no disk space in /boot

2021-09-09 Thread Julian Andres Klode
update-manager offers removal since bionic update-manager (1:18.04.8) bionic; urgency=medium * Offer removal of unused autoremovable kernel packages (LP: #1624644, #1675079) -- Balint Reczey Wed, 21 Mar 2018 14:34:05 + Due to bug 1912718, the was broken for a short time in

[Bug 1943122] Re: Software update doesn't run autoremove so that update fails due to no disk space in /boot

2021-09-09 Thread Julian Andres Klode
** Changed in: update-manager (Ubuntu) Status: New => Incomplete -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1943122 Title: Software update doesn't run autoremove so that update fails due

[Bug 1943049] Re: Docker ubuntu:impish: Problem executing scripts DPkg::Post-Invoke 'rm -f /var/cache/apt/archives/*.deb /var/cache/apt/archives/partial/*.deb /var/cache/apt/*.bin || true'

2021-09-09 Thread Julian Andres Klode
Apparently there are fixed docker.io packages in https://launchpad.net/~pascallj/+archive/ubuntu/docker.io-clone3 Still leaves podman and other runc consumers in the cold, though? -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

[Bug 1943049] Re: Docker ubuntu:impish: Problem executing scripts DPkg::Post-Invoke 'rm -f /var/cache/apt/archives/*.deb /var/cache/apt/archives/partial/*.deb /var/cache/apt/*.bin || true'

2021-09-09 Thread Julian Andres Klode
Should we just disable clone3() in glibc for now? http://patches- tcwg.linaro.org/patch/58206/ ** Also affects: libpod (Ubuntu) Importance: Undecided Status: New -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

[Bug 1943049] Re: Docker ubuntu:impish: Problem executing scripts DPkg::Post-Invoke 'rm -f /var/cache/apt/archives/*.deb /var/cache/apt/archives/partial/*.deb /var/cache/apt/*.bin || true'

2021-09-09 Thread Julian Andres Klode
I thought runc was fixed to produce ENOSYS by now for unknown syscalls to avoid that mess. We can't have every glibc update breaking containers like this... 405 clone3({flags=CLONE_VM|CLONE_VFORK, exit_signal=SIGCHLD, stack=0x7fc77e3d3000, stack_size=0x9000}, 88) = -1 EPERM (Operation not

[Bug 1943049] Re: Docker ubuntu:impish: Problem executing scripts DPkg::Post-Invoke 'rm -f /var/cache/apt/archives/*.deb /var/cache/apt/archives/partial/*.deb /var/cache/apt/*.bin || true'

2021-09-09 Thread Julian Andres Klode
I thought runc was fixed to produce ENOSYS by now for unknown syscalls to avoid that mess. We can't have every glibc update breaking containers like this... 405 clone3({flags=CLONE_VM|CLONE_VFORK, exit_signal=SIGCHLD, stack=0x7fc77e3d3000, stack_size=0x9000}, 88) = -1 EPERM (Operation not

[Bug 1921134] Re: SBAT shim 15.4 release

2021-09-06 Thread Julian Andres Klode
Actually, the previous comment was for bionic this time. 1.37~18.04.10 / 15.4-0ubuntu7. fwupd loading has been tested in the fwupd sbat test case ** Tags removed: verification-needed verification-needed-bionic ** Tags added: verification-done verification-done-bionic -- You received this bug

[Bug 1921134] Re: SBAT shim 15.4 release

2021-09-06 Thread Julian Andres Klode
Most tests from focal and newer are valid on xenial too, as the binaries are the same. I hence just verified the interaction with xenial's mokutil and kernel keyring: * Tested enrolling MOK and modprobing vboxdrv module * Tested timeout and reset, modprobe after reset failed to find the key, as

[Bug 1939707] Re: FTBFS on impish

2021-09-06 Thread Julian Andres Klode
** Changed in: libuv1 (Ubuntu) Status: In Progress => Fix Committed -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1939707 Title: FTBFS on impish To manage notifications about this bug go

[Bug 1933826] Re: default file permissions on bootloader configuration

2021-09-02 Thread Julian Andres Klode
** Changed in: grub2 (Ubuntu Impish) Status: Confirmed => Fix Committed -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1933826 Title: default file permissions on bootloader configuration To

[Bug 1941963] Re: package shim-signed 1.40.7+15.4-0ubuntu9 failed to install/upgrade: kernel segfault. Hard lock

2021-08-30 Thread Julian Andres Klode
** Package changed: shim-signed (Ubuntu) => linux (Ubuntu) -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1941963 Title: package shim-signed 1.40.7+15.4-0ubuntu9 failed to install/upgrade: kernel

[Bug 1942001] Re: failure to compile on Kernel 5.13.9 Ubuntu 21.04

2021-08-30 Thread Julian Andres Klode
There is no ndiswrapper in 21.04. The last remaining 'supported' scenarios are kernels up to 5.4 on Ubuntu releases up to 20.04 ** Changed in: ndiswrapper (Ubuntu) Status: New => Invalid -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to

[Bug 1876034] Re: apt update crashes with "KeyError: 'suite'" in cnf-update-db if index compression is enabled

2021-08-26 Thread Julian Andres Klode
FWIW, Docker images do not install command-not-found and are intended for machine users, so it's not a place where you'd install it and notice that. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

[Bug 1929860] Re: initrdfail can result in resuming with different initrd images and hanging resume

2021-08-19 Thread Julian Andres Klode
** Also affects: grub2 (Ubuntu Bionic) Importance: Undecided Status: New -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1929860 Title: initrdfail can result in resuming with different

[Bug 1937115] Re: Unable to boot/install Impish daily in UEFI boot mode

2021-08-19 Thread Julian Andres Klode
** Also affects: shim (Ubuntu Xenial) Importance: Undecided Status: New ** Also affects: shim-signed (Ubuntu Xenial) Importance: Undecided Status: New ** Also affects: cd-boot-images-amd64 (Ubuntu Xenial) Importance: Undecided Status: New ** Also affects: shim

[Bug 1901553] Re: Improve documentation around initrdless boot

2021-08-19 Thread Julian Andres Klode
Retrying test 3 with UEFI and a virtio-scsci device, I succeed: The kernel panics, I then see GRUB_FORCE_PARTUUID set, initrdless boot failed. Attempting with initrd. and it boots fine ** Tags removed: verification-needed verification-needed-focal ** Tags added: verification-done

[Bug 1901553] Re: Improve documentation around initrdless boot

2021-08-19 Thread Julian Andres Klode
1. I upgraded grub2 to 2.04-1ubuntu26.13 from proposed using sudo apt install '?source-package(grub2)?installed'. It ran update-grub as postinst, and I saw the new message GRUB_FORCE_PARTUUID is set, will attempt initrdless boot 2. I rebooted, I see message from grub saying GRUB_FORCE_PARTUUID

[Bug 1940503] Re: Illegal instruction (core dumped) on apt update

2021-08-19 Thread Julian Andres Klode
This seems to be a bug in command-not-found, Python, or any of the libraries it used. For further investigation, we need a core dump from that process, did apport not prompt you for that? ** Package changed: apt (Ubuntu) => command-not-found (Ubuntu) ** Changed in: command-not-found (Ubuntu)

[Bug 1921134] Re: SBAT shim 15.4 release

2021-08-18 Thread Julian Andres Klode
** Tags removed: block-proposed-bionic ** Tags removed: block-proposed-groovy -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1921134 Title: SBAT shim 15.4 release To manage notifications about

[Bug 1940342] Re: Update-manager crashed

2021-08-18 Thread Julian Andres Klode
** Changed in: update-manager (Ubuntu) Assignee: Sheetal Sharma (sheetal0719) => (unassigned) -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1940342 Title: Update-manager crashed To manage

[Bug 1937115] Re: Unable to boot/install Impish daily in UEFI boot mode

2021-08-16 Thread Julian Andres Klode
Apparently shim is not pre-installed in focal, but installed from pool, so yes, file list is correct: /pool/main/s/shim-signed/shim-signed_1.40.7+15.4-0ubuntu9_amd64.deb So this is good, marking as verified then ** Tags removed: verification-needed verification-needed-focal ** Tags added:

[Bug 1937115] Re: Unable to boot/install Impish daily in UEFI boot mode

2021-08-16 Thread Julian Andres Klode
** No longer affects: cd-boot-images-amd64 (Ubuntu Focal) ** Changed in: cd-boot-images-amd64 (Ubuntu Impish) Status: Triaged => Fix Committed -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

[Bug 1925507] Re: grub-common: snapd autopkgtests fail on s390x

2021-08-16 Thread Julian Andres Klode
All autopkgtests have passed for the 2.04-1ubuntu26.13 ** Tags removed: verification-needed verification-needed-focal ** Tags added: verification-done verification-done-focal -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

[Bug 1937115] Re: Unable to boot/install Impish daily in UEFI boot mode

2021-08-15 Thread Julian Andres Klode
Please read Steve's comment, Leo. The images are not ready yet, they contain the old shim (the new one is inside the live system only). -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1937115 Title:

[Bug 1939544] Re: Merge the 1.1.1k version from Debian

2021-08-13 Thread Julian Andres Klode
** Changed in: openssl (Ubuntu) Status: In Progress => Fix Committed -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1939544 Title: Merge the 1.1.1k version from Debian To manage

[Bug 1901553] Re: Improve documentation around initrdless boot

2021-08-12 Thread Julian Andres Klode
** Also affects: grub2 (Ubuntu Focal) Importance: Undecided Status: New ** Changed in: grub2 (Ubuntu Focal) Milestone: None => ubuntu-20.04.3 ** Description changed: [Impact] + (sort of prerequisite of bug 1929860 to avoid having to edit the patches and possibly introduce bugs

[Bug 1925507] Re: grub-common: snapd autopkgtests fail on s390x

2021-08-12 Thread Julian Andres Klode
** Description changed: + [Impact] + Probably regression from #1901553, failing to install on s390x, info below. + + [Test plan] + Just ensure those tests don't fail like that + + [Regression potential] + grub units only start when /boot is mounted now, as they require /boot/grub/grub.cfg to

[Bug 1929860] Re: initrdfail can result in resuming with different initrd images and hanging resume

2021-08-12 Thread Julian Andres Klode
** Description changed: - Ubuntu Focal (and new releases) on AWS will normally boot without an - initrd image (just the microcode.cpio). There is a fallback mechanism to - reboot with the full initrd image when the boot fails to complete. The - grub environment variable "initrdfail" is used to

[Bug 1939665] Re: "apt-get update" fails if another instance is running

2021-08-12 Thread Julian Andres Klode
Please ignore Chris (well, do upgrade though, 20.10 is ld, it hasn't seen security updates in months) I understand your report, I only implemented lock waiting for the dpkg lock, not for the list lock that update holds. Note that apt-get generally doesn't wait for the lock, only apt does

[Bug 1641303] Re: Wish: apt shouldn't show kept-back packages within the list of upgradable

2021-08-12 Thread Julian Andres Klode
There's some misconception here; held back is a package-level flag. ALinuxUser: Just use pinning instead of holds to achieve that. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1641303 Title:

[Bug 1938163] Re: package shim-signed 1.50+15.4-0ubuntu7 failed to install/upgrade: installed shim-signed package post-installation script subprocess returned error exit status 1

2021-08-07 Thread Julian Andres Klode
There are three possible causes - firmware bug - kernel bug - user error (read-only variables), though why does that give I/O rather than ENOSPACE I'm going to reassign this one to linux for a check on the kernel side, but I suspect it's a firmware issue. ** Package changed: shim-signed

[Bug 1939152] Re: Shim can't USB boot on Dell XPS 9343

2021-08-06 Thread Julian Andres Klode
*** This bug is a duplicate of bug 1937115 *** https://bugs.launchpad.net/bugs/1937115 ** This bug has been marked a duplicate of bug 1937115 Unable to boot/install Impish daily in UEFI boot mode -- You received this bug notification because you are a member of Ubuntu Bugs, which is

[Bug 1937115] Re: Unable to boot/install Impish daily in UEFI boot mode

2021-08-06 Thread Julian Andres Klode
Springnuts: So if I understand you correctly, the ubuntu boot entry works for you. I think what happens is that Windows changes the boot order during boot, or the firmware forgets it, which is a bit outside our ability to fix. Unfortunately, I don't think I'm able to help you here. I don't see a

[Bug 1937115] Re: Unable to boot/install Impish daily in UEFI boot mode

2021-08-06 Thread Julian Andres Klode
** Description changed: [Impact] Removable media fail to boot on some machines due to garbage in firmware generated boot entries. This is a regression from LP: #1929471 introduced in shim 15.4-0ubuntu7. In addition we also cherry-pick https://github.com/rhboot/shim/pull/365 to fix a

[Bug 1937115] Re: Unable to boot/install Impish daily in UEFI boot mode

2021-08-05 Thread Julian Andres Klode
First we need to submit a shim for review and signing, then upload it, so later next week presumably. I just did the paperwork here for now :) -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1937115

[Bug 1937115] Re: Unable to boot/install Impish daily in UEFI boot mode

2021-08-05 Thread Julian Andres Klode
** Description changed: - Testing Ubuntu Impish daily ISO= http://cdimage.ubuntu.com/daily- - live/20210721/impish-desktop-amd64.iso + [Impact] + Removable media fail to boot on some machines due to garbage in firmware generated boot entries. + + In addition we also cherry-pick

[Bug 1938753] Re: package pulseaudio-utils 1:14.2-2ubuntu2 failed to install/upgrade: Versuch, ┬╗/usr/share/bash-completion/completions/pulseaudio┬ź zu ├╝berschreiben, welches auch in Paket pulseaudio 1:

2021-08-04 Thread Julian Andres Klode
@vanvugt low is really grossly inappropriate here. This breaks upgrades, and just because you got lucky now fixing it with apt install -f doesn't mean it'll work tomorrow. ** Changed in: pulseaudio (Ubuntu) Importance: Low => High -- You received this bug notification because you are a

[Bug 1938774] Re: Update to 15.4 results in shim being marked for autoremoval

2021-08-03 Thread Julian Andres Klode
To add more detail, sorry for the brevity, the shim-signed package took over the remaining files in the shim package, and the shim package itself is hence no longer needed. The reason for that is that those files (mm*.efi and fb*.efi) were previously signed by an ephemeral key at build time, but

[Bug 1938774] Re: Update to 15.4 results in shim being marked for autoremoval

2021-08-03 Thread Julian Andres Klode
This is expected. ** Changed in: shim-signed (Ubuntu) Status: New => Incomplete ** Changed in: shim-signed (Ubuntu) Status: Incomplete => Invalid ** Changed in: shim (Ubuntu) Status: New => Invalid -- You received this bug notification because you are a member of Ubuntu

[Bug 1938724] Re: uses aptdaemon

2021-08-02 Thread Julian Andres Klode
Sorry, this is a dupe of 1673258, but LP is timing out -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1938724 Title: uses aptdaemon To manage notifications about this bug go to:

[Bug 1938724] Re: uses aptdaemon

2021-08-02 Thread Julian Andres Klode
aptdaemon at the moment is barely kept alive for update-manager, I'm hopeful the other components can make use of PackageKit instead and don't need the ability to calculate dependency problem solutions themselves. -- You received this bug notification because you are a member of Ubuntu Bugs,

[Bug 1938724] [NEW] uses aptdaemon

2021-08-02 Thread Julian Andres Klode
Public bug reported: aptdaemon is not a maintained component, please use PackageKit. ** Affects: apturl (Ubuntu) Importance: Undecided Status: New ** Affects: language-selector (Ubuntu) Importance: Undecided Status: New ** Affects: lubuntu-update-notifier (Ubuntu)

[Bug 1673258] Re: Remove aptdaemon and drop or port its reverse-dependencies

2021-08-02 Thread Julian Andres Klode
** Changed in: sessioninstaller (Ubuntu) Status: New => Fix Released ** Also affects: oem-config (Ubuntu) Importance: Undecided Status: New ** Also affects: lubuntu-update-notifier (Ubuntu) Importance: Undecided Status: New -- You received this bug notification

[Bug 1938641] Re: Without sessioninstaller (org.freedesktop.PackageKit dbus service provider) user is unable to install applications to handle unknown filetypes

2021-08-02 Thread Julian Andres Klode
** Also affects: ubuntu-mate Importance: Undecided Status: New -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1938641 Title: Without sessioninstaller (org.freedesktop.PackageKit dbus

[Bug 1938641] Re: Without sessioninstaller (org.freedesktop.PackageKit dbus service provider) user is unable to install applications to handle unknown filetypes

2021-08-02 Thread Julian Andres Klode
Please stop bouncing the bug. You are free to add bug tasks for packages that miss necessary AppStream metadata. A return of sessioninstaller is _not_ acceptable. ** Package changed: sessioninstaller (Ubuntu) => librecad (Ubuntu) ** No longer affects: ubuntu-mate-meta (Ubuntu) ** No longer

[Bug 1889057] Re: shares-admin can't install services - failed to install package: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.PackageKit was not provided by any .s

2021-08-02 Thread Julian Andres Klode
I have no idea why gnome-software doesn't find this for you, the bug is confusingly written. The bug description suggests it is not installed, then the comment suggests it is installed and not working? Anyway, gnome-software should work here. And ubuntu-mate meta packages should have the correct

[Bug 1938641] Re: Without sessioninstaller (org.freedesktop.PackageKit dbus service provider) user is unable to install applications to handle unknown filetypes

2021-08-02 Thread Julian Andres Klode
In your example, LibreCAD does not ship AppStream metadata, so if you want to see it, add some. ** Summary changed: - Without sessioninstaller (org.freedesktop.PackageKit dbus service provider) user is unable to install applications to handle unknown filetypes + librecad missing AppStream data

[Bug 1938699] Re: cpu-checker: riscv64 build missing

2021-08-02 Thread Julian Andres Klode
cpu-checker (0.7-1.2) experimental; urgency=medium will be synced shortly with those changes ** Changed in: cpu-checker (Ubuntu) Status: New => Fix Committed -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

[Bug 1938641] Re: Without sessioninstaller (org.freedesktop.PackageKit dbus service provider) user is unable to install applications to handle unknown filetypes

2021-08-02 Thread Julian Andres Klode
Note that if you want to have a different installer tool for that, you also need to have a gnome-software replacement for normal installing, as gnome-software also installs the session handler. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to

[Bug 1938641] Re: Without sessioninstaller (org.freedesktop.PackageKit dbus service provider) user is unable to install applications to handle unknown filetypes

2021-08-02 Thread Julian Andres Klode
sessioninstaller is dead, please do not revive it. If you don't like gnome-software, you are welcome to write another PackageKit frontend. Check with Xubuntu if they agree with you. It shouldn't be _too_ hard. Our goal is still to get rid of aptdaemon. We are not able to support it, it's rotten.

[Bug 1642255] Re: package redis-server 2:3.0.6-1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

2021-08-02 Thread Julian Andres Klode
The service failed here. Probably a configuration issue or something else local, can't say why: Job for redis-server.service failed because a timeout was exceeded. See "systemctl status redis-server.service" and "journalctl -xe" for details. ** Changed in: redis (Ubuntu) Status:

[Bug 1938582] Re: efitools does not build on RISC-V

2021-08-02 Thread Julian Andres Klode
** Changed in: efitools (Ubuntu) Status: New => In Progress -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1938582 Title: efitools does not build on RISC-V To manage notifications about this

[Bug 1938641] Re: Without sessioninstaller (org.freedesktop.PackageKit dbus service provider) user is unable to install applications to handle unknown filetypes

2021-08-02 Thread Julian Andres Klode
*** This bug is a duplicate of bug 1889057 *** https://bugs.launchpad.net/bugs/1889057 Is PackageKit not installed? I can't say. Please go check, it's not a bug on our side, but the MATE side. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed

[Bug 1889057] Re: shares-admin can't install services - failed to install package: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.PackageKit was not provided by any .s

2021-08-02 Thread Julian Andres Klode
It's MATE's job to provide a session installer based on PackageKit, GNOME uses GNOME Software. ** Changed in: sessioninstaller (Ubuntu) Status: Confirmed => Won't Fix ** Also affects: ubuntu-mate-meta (Ubuntu) Importance: Undecided Status: New ** No longer affects:

[Bug 1938635] Re: update-grub fails when having multiple encrypted zfs root datasets

2021-08-02 Thread Julian Andres Klode
** Changed in: grub2 (Ubuntu) Status: New => Triaged -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1938635 Title: update-grub fails when having multiple encrypted zfs root datasets To

[Bug 1938641] Re: Without sessioninstaller (org.freedesktop.PackageKit dbus service provider) user is unable to install applications to handle unknown filetypes

2021-08-02 Thread Julian Andres Klode
*** This bug is a duplicate of bug 1889057 *** https://bugs.launchpad.net/bugs/1889057 sessioninstaller is dead, use PackageKit. ** Changed in: sessioninstaller (Ubuntu) Status: New => Won't Fix ** This bug has been marked a duplicate of bug 1889057 shares-admin can't install

[Bug 1938043] Re: ubuntu-security-status

2021-07-30 Thread Julian Andres Klode
** Changed in: update-manager (Ubuntu Focal) Status: Incomplete => Triaged -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1938043 Title: ubuntu-security-status To manage notifications about

[Bug 1920724] Re: Upgrade focal/libjcat to version 0.1.3-2 and MIR it

2021-07-30 Thread Julian Andres Klode
** Tags removed: verification-needed ** Tags added: verification-done -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1920724 Title: Upgrade focal/libjcat to version 0.1.3-2 and MIR it To manage

[Bug 1934209] Re: Dell dock USB4 module need fwupd 1.5.11

2021-07-30 Thread Julian Andres Klode
** Tags removed: verification-needed ** Tags added: verification-done -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1934209 Title: Dell dock USB4 module need fwupd 1.5.11 To manage notifications

[Bug 1921539] Re: Add support for SBAT

2021-07-30 Thread Julian Andres Klode
According to bug 1934209: Verification passed on Focal Secure boot on shim-signed: 1.40.6+15.4-0ubuntu7 (proposed channel, sbat applied) fwupd: 1.5.11-0ubuntu1~20.04.2 (propsoed channel, sbat applied) ** Tags removed: verification-needed verification-needed-focal ** Tags added:

[Bug 1937115] Re: Unable to boot/install Impish daily in UEFI boot mode

2021-07-30 Thread Julian Andres Klode
@sudodos, @leok You can do that in an installed Ubuntu system, on a non- impish live media, heck in any other Linux distro. We need the new shim for 20.04.3, and this is the sorta blocker, hence the focal tag. -- You received this bug notification because you are a member of Ubuntu Bugs, which

[Bug 1937115] Re: Unable to boot/install Impish daily in UEFI boot mode

2021-07-29 Thread Julian Andres Klode
Hi folks, we don't need reports of what works and what doesn't. We already know that only live media are affected - installed systems usually don't boot via removable media path - but if they do, they go via fallback loader binary which works around the issue as it does not interpret its

[Bug 1937115] Re: Unable to boot/install Impish daily in UEFI boot mode

2021-07-29 Thread Julian Andres Klode
** Changed in: shim (Ubuntu Impish) Status: Incomplete => Triaged ** Changed in: shim (Ubuntu Impish) Status: Triaged => In Progress ** Changed in: cd-boot-images-amd64 (Ubuntu Impish) Status: Confirmed => Triaged -- You received this bug notification because you are a

[Bug 1938324] Re: gnu-efi does not support RISC-V

2021-07-29 Thread Julian Andres Klode
Yeah, that's not the right way. Then it would be 3.0.13-0ubuntu1, and not changed in the upstream version. Which is OK too, but I went ahead and imported a git-archive export as 3.0.13+git20210716.269ef9d-1 in the Debian repository and uploaded that to experimental with any-riscv64 (and any-ia64)

[Bug 1938324] Re: gnu-efi does not support RISC-V

2021-07-29 Thread Julian Andres Klode
Do we need a snapshot past 3.0.13 for this? I'd prefer to use releases, to be honest. The upstream versioning for snapshots should really be something like 3.0.13+git.. Doing this properly in the git repo (https://salsa.debian.org/efi- team/gnu-efi) would be nice, and then upload to experimental

[Bug 1937115] Re: Unable to boot/install Impish daily in UEFI boot mode

2021-07-29 Thread Julian Andres Klode
I'd still like to see efibootmgr -v output from affected machines, for the boot entry that failed to boot. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1937115 Title: Unable to boot/install Impish

[Bug 1938389] Re: package operation fails but gives no reason why

2021-07-29 Thread Julian Andres Klode
You can read /var/log/apt/term.log yourself. Embedding that nicely seems hard, but then again, apport should have shown you the messages when you reported the bug? As the log tells you, you have installed the postfix mail server, but configured an invalid hostname "04": newaliases: warning:

[Bug 1921134] Re: SBAT shim 15.4 release

2021-07-26 Thread Julian Andres Klode
Most tests from focal and newer are valid on xenial too, as the binaries are the same. I hence just verified the interaction with xenial's mokutil and kernel keyring: * Tested enrolling MOK and modprobing vboxdrv module * Tested timeout and reset, modprobe after reset failed to find the key, as

[Bug 1921134] Re: SBAT shim 15.4 release

2021-07-26 Thread Julian Andres Klode
Verified the shim on focal. * xnox verified windows booting on hirsute, binaries are same * I verified maas style chained netbooting * Verified the interactions with mokutil + Verified loading dkms modules + Verified end2end IRL boot on ThinkPad X230 with ZFS - Did not verify actual Maas boot,

[Bug 1928434] Re: shim-signed does not boot on EFI 2.40 by Apple

2021-07-26 Thread Julian Andres Klode
** Tags removed: block-proposed-focal -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1928434 Title: shim-signed does not boot on EFI 2.40 by Apple To manage notifications about this bug go to:

[Bug 1929854] Re: Vital and critical configuration files get overridden by system updates without warning

2021-07-26 Thread Julian Andres Klode
Please don't modify that in /etc/grub.d, set GRUB_RECORDFAIL_TIMEOUT=5 in the /etc/default/grub file (or in an /etc/default/grub.d snippet). /etc/grub.d file changes are last resort, that file changes and incorporating those changes with your own ones will be annoying. -- You received this bug

[Bug 1929471] Re: Shim apparently fails to run fwupd64 (hirsute regression?)

2021-07-26 Thread Julian Andres Klode
So, the regression potential is wrong and the fallback code I was thinking of does not exist. This seems to have caused a regression in bug 1937115. This will affect some systems that contain garbage in default boot order entries that still gets parsed as a valid second stage loader. This should

[Bug 1937115] Re: Unable to boot/install Impish daily in UEFI boot mode

2021-07-26 Thread Julian Andres Klode
I have posted a work around for this issue upstream: https://github.com/rhboot/shim/pull/393 This will add a 2s delay on invalid filenames or not found files, and then fallback to the default loader. Hence it's still a good idea to parse the load options properly to avoid the errors in the first

[Bug 1937115] Re: Unable to boot/install Impish daily in UEFI boot mode

2021-07-26 Thread Julian Andres Klode
Please also include the output of efibootmgr -v on those systems. There is likely garbage in the boot loader entries the UEFI generated for those devices. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

[Bug 1937115] Re: Unable to boot/install Impish daily in UEFI boot mode

2021-07-26 Thread Julian Andres Klode
Seems to be an issue with shim / the UEFI firmware on those machines. Could be a regression from the load option parsing, but confused as to how we end up trying to boot a non existing file instead of falling back. Could also be memory corruption (shim pull #365). Need to mokutil --set-verbosity

[Bug 1929471] Re: Shim apparently fails to run fwupd64 (hirsute regression?)

2021-07-23 Thread Julian Andres Klode
OK so I'm actually going to mark this as verified, since I verified the load option parsing fix in 15.4-0ubuntu7 that makes it find the correct binaries, and will leave the verification of the fwupd's SBAT stuff to the fwupd SRUs. ** Tags removed: verification-needed verification-needed-bionic

[Bug 1931136] Re: Don't unhook ExitBootServices() when EBS protection is disabled

2021-07-23 Thread Julian Andres Klode
In lieu of other releases not being hirsute, I just did the "exit from grub returns to shell" test from inside the EFI shell with 15.4-0ubuntu7, which passed. I also accidentally did a MAAS-style PXE shim -> PXE grub -> ESP shim -> ESP grub chainboot which worked fine. We are going to do more

[Bug 1856422] Re: always call mokutil with --timeout -1 when enrolling dkms keys

2021-07-23 Thread Julian Andres Klode
The verification from 16.04.9 is also valid for 16.04.10, as only the shim binaries changed, and not the scripts ** Tags removed: verification-needed verification-needed-xenial ** Tags added: verification-done verification-done-xenial -- You received this bug notification because you are a

[Bug 1898729] Re: shim can end up being removed

2021-07-23 Thread Julian Andres Klode
Verification looks the same for focal (1.40.6+15.4-0ubuntu7) ** Tags removed: verification-needed verification-needed-focal ** Tags added: verification-done verification-done-focal -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

[Bug 1898729] Re: shim can end up being removed

2021-07-23 Thread Julian Andres Klode
bionic is good, as soon as I add the bionic-proposed sources.list entry (containing 1.37~18.04.10), the package is treated as essential. # apt autoremove Reading package lists... Done Building dependency tree Reading state information... Done

  1   2   3   4   5   6   7   8   9   10   >