[Bug 1096984] [NEW] Wrong device for the / mount point

2013-01-07 Thread Andreas Hasenack
Public bug reported: quantal lxc 0.8.0~rc1-4ubuntu39 kernel 3.5.0-21-generic using lvm on the host I came back from holidays and found this problem. Not sure if it's related to a recent update of the system, I was updating it regularly in the past 3 weeks I was away but I haven't tried any

[Bug 1096984] Re: Wrong device for the / mount point

2013-01-07 Thread Andreas Hasenack
*** This bug is a duplicate of bug 1060404 *** https://bugs.launchpad.net/bugs/1060404 Thanks a lot for the explanation :) -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to lxc in Ubuntu. https://bugs.launchpad.net/bugs/1096984

[Bug 1060404] Re: update-grub runs and fails in containers

2013-01-08 Thread Andreas Hasenack
Any idea if this will be fixed for precise, or is it too risky? -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to lxc in Ubuntu. https://bugs.launchpad.net/bugs/1060404 Title: update-grub runs and fails in containers To manage

[Bug 1060404] Re: update-grub runs and fails in containers

2013-01-08 Thread Andreas Hasenack
Right, grub, and for now my workaround is to remove grub-pc if I'm in a container. -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to lxc in Ubuntu. https://bugs.launchpad.net/bugs/1060404 Title: update-grub runs and fails in

[Bug 1060404] Re: update-grub runs and fails in containers

2013-01-22 Thread Andreas Hasenack
I installed the version from precise-updates on a precise lxc, which didn't have grub-pc before. It worked for me. Here is the output: (...) Processing triggers for ureadahead ... Setting up libfreetype6 (2.4.8-1ubuntu2.1) ... Setting up gettext-base (0.18.1.1-5ubuntu3) ... Setting up libfuse2

[Bug 1060404] Re: update-grub runs and fails in containers

2013-01-22 Thread Andreas Hasenack
Agreed. -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to lxc in Ubuntu. https://bugs.launchpad.net/bugs/1060404 Title: update-grub runs and fails in containers To manage notifications about this bug go to:

[Bug 1060404] Re: update-grub runs and fails in containers

2013-01-22 Thread Andreas Hasenack
Output when NOT running on LXC (a linode machine in this case): (...) Preparing to replace grub-pc 1.99-21ubuntu3.7 (using .../grub-pc_1.99-21ubuntu3.8_i386.deb) ... Unpacking replacement grub-pc ... Preparing to replace grub-pc-bin 1.99-21ubuntu3.7 (using

[Bug 1078217] Re: zookeeper connection is not using exponential backoff

2013-02-04 Thread Andreas Hasenack
*** This bug is a duplicate of bug 1073083 *** https://bugs.launchpad.net/bugs/1073083 ** This bug has been marked a duplicate of bug 1073083 Non-responsive zookeeper leads to spinning agent and traceback -- You received this bug notification because you are a member of Ubuntu Server

[Bug 1126378] Re: SchedulerHostFilterNotFound: Scheduler Host Filter AvailabilityZoneFilter, CapacityFilter, CapabilitiesFilter could not be found.

2013-02-20 Thread Andreas Hasenack
I also have this problem in my deployment. cinder packages are at 2013.1~g2-0ubuntu2~cloud0 -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to cinder in Ubuntu. https://bugs.launchpad.net/bugs/1126378 Title:

[Bug 1157708] [NEW] No good logging by default

2013-03-20 Thread Andreas Hasenack
Public bug reported: python-django-horizon2013.1.g3-0ubuntu2~cloud0 By default, there is no useful logging done by horizon in the ubuntu package. For example, I'm getting a plain 500 (System Error) when logging in on my newly deployed horizon, and /var/log/apache/* has nothing

[Bug 1157708] Re: No good logging by default

2013-03-20 Thread Andreas Hasenack
This is invalid. Turns our the backtrace was in the other dashboard unit (HA setup). I don't know why it was over there, but it was, and I didn't have to enable debugging. ** Changed in: horizon (Ubuntu) Status: New = Invalid -- You received this bug notification because you are a member

[Bug 1157918] [NEW] Network selection tab when starting instance renders incorrectly

2013-03-20 Thread Andreas Hasenack
Public bug reported: python-django-horizon2013.1.g3-0ubuntu2~cloud0 See attached screenshot. When you start an instance via the GUI, one of the tabs is for the network selection. It works, in the sense that I can select a network, but the UI has rendering issues. ** Affects:

[Bug 904248] Re: python-central build-dependencies in main

2011-12-14 Thread Andreas Hasenack
** Changed in: landscape-client (Ubuntu Precise) Assignee: Landscape (landscape) = Andreas Hasenack (ahasenack) -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to cloud-init in Ubuntu. https://bugs.launchpad.net/bugs/904248 Title

[Bug 904248] Re: python-central build-dependencies in main

2011-12-14 Thread Andreas Hasenack
** Also affects: landscape-client Importance: Undecided Status: New ** Changed in: landscape-client Importance: Undecided = Medium ** Changed in: landscape-client Milestone: None = backlog ** Changed in: landscape-client Assignee: (unassigned) = Andreas Hasenack (ahasenack

[Bug 904248] Re: python-central build-dependencies in main

2011-12-16 Thread Andreas Hasenack
So, using this in build-depends apparently doesn't work: (...), python-dev (= 2.6.6-3~) | python-central | python-support, python-dev, (...) I got a natty build instance that pulled in both python-dev 2.7.x and python-central. I thought it would pull in only the first one that satisfied the

[Bug 841672] Re: ssh-add does not always unlock ssh keys

2012-01-31 Thread Andreas Hasenack
Very annoying, I run ssh-add and am still prompted for the passphrase by some GUI tool. -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to openssh in Ubuntu. https://bugs.launchpad.net/bugs/841672 Title: ssh-add does not always unlock

[Bug 930430] Re: lxc-ls requires root access after deploying an LXC instance

2012-08-13 Thread Andreas Hasenack
Hi Jamie, I started seeing this with juju 0.5.1+bzr563-0juju2~precise1, to which I recently upgraded. With 0.5+bzr531-0ubuntu1.2 (also in precise) it works. -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to lxc in Ubuntu.

[Bug 1006553] Re: local provider machine agent uses 100% CPU after host reboot

2012-09-11 Thread Andreas Hasenack
This burns my lap everyday on precise :( -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to juju in Ubuntu. https://bugs.launchpad.net/bugs/1006553 Title: local provider machine agent uses 100% CPU after host reboot To manage

[Bug 155947] Re: ldap config causes Ubuntu to hang at login

2008-04-21 Thread Andreas Hasenack
I believe that soft is a better default for nss_ldap. FWIW, Mandriva has been using this patch for quite a while now: http://svn.mandriva.com/cgi-bin//viewvc.cgi/packages/cooker/nss_ldap/current/SOURCES/nss_ldap-250-bind_policy_default_soft.patch?revision=5975view=markup However, I note that the

[Bug 155947] Re: ldap config causes Ubuntu to hang at login

2008-04-21 Thread Andreas Hasenack
We really need to set this bind_policy to soft, or else the machine just won't boot. It stops at klogd. I just tried with hardy. So, after setting it to soft using a rescue disk, boot proceeded as normal. I didn't even touch the timeouts. Now, the ldap user obviously can't login yet in my

[Bug 155947] Re: ldap config causes Ubuntu to hang at login

2008-04-21 Thread Andreas Hasenack
As expected, using a wired connection instead of wireless allows any user to login at the gdm prompt, local or ldap, because the network is up by then in this case. -- ldap config causes Ubuntu to hang at login https://bugs.launchpad.net/bugs/155947 You received this bug notification because

[Bug 39249] Re: (Dapper) can't create /var/lib/dhcp3/dhclient.eth0.leases: Permission denied

2008-06-02 Thread Andreas Hasenack
Same for me on hardy, although I cannot be sure anymore if it was a hardy install from the start or a dapper upgrade. dhcp 4110 0.0 0.0 2436 784 ?Ss 10:16 0:00 dhclient3 -e IF_METRIC=100 -pf /var/run/dhclient.eth1.pid -lf /var/lib/dhcp3/dhclient.eth1.leases eth1 # ls -la

[Bug 584497] Re: The EC2 endpoint should be HTTPS by default

2010-11-22 Thread Andreas Hasenack
** Changed in: landscape Milestone: 10.11 = 10.12 -- The EC2 endpoint should be HTTPS by default https://bugs.launchpad.net/bugs/584497 You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to eucalyptus in ubuntu. -- Ubuntu-server-bugs

[Bug 719547] [NEW] euca2ools doesn't parse EC2_URL correctly

2011-02-15 Thread Andreas Hasenack
Public bug reported: Binary package hint: euca2ools The EC2_URL shell variable holds an URL to an EC2 or Eucalyptus endpoint. There is a problem with the URL parsing code where, if said URL doesn't contain a port number, it thinks the whole URL is a hostname. Example (with fake keys on

[Bug 739694] [NEW] KeyError: 'handler'

2011-03-21 Thread Andreas Hasenack
Public bug reported: Binary package hint: cloud-init Got this in the console output of natty when booting up natty with landscape-client info in user-data: WARN:consuming user data failed! Traceback (most recent call last): File /usr/bin/cloud-init, line 180, in module main() File

[Bug 739694] Re: KeyError: 'handler'

2011-03-21 Thread Andreas Hasenack
workaround to use after the instance started: - apply patch: === modified file 'cloudinit/__init__.py' --- cloudinit/__init__.py 2011-02-07 19:36:33 + +++ cloudinit/__init__.py 2011-03-21 20:18:27 + @@ -363,7 +363,7 @@ self.handlercount=self.handlercount+1

[Bug 427842] [NEW] [karmic] frontend DB needs ACLs for base= and cn=schema

2009-09-11 Thread Andreas Hasenack
Public bug reported: The current installation of slapd doesn't allow for searches in the empty base (dn=) and the schema entries. These are needed by several client tools to, among other things: - check what the server schema is (luma, apache directory studio) - discover what the server

[Bug 427842] Re: [karmic] frontend DB needs ACLs for base= and cn=schema

2009-09-11 Thread Andreas Hasenack
IIRC that's the way it is by default with slapd.conf, so we are keeping the same privileges in cn=config. The base was meant to be readable by everyone because it advertises the capabilities of the server. Without it, for example, a client can't know if the server supports START TLS or not. And

[Bug 427842] Re: [karmic] frontend DB needs ACLs for base= and cn=schema

2009-09-11 Thread Andreas Hasenack
FWIW, I tried Luma and Apache Directory Studio and both first authenticate and then check for the schema, so their search for the schema is an authenticated one. -- [karmic] frontend DB needs ACLs for base= and cn=schema https://bugs.launchpad.net/bugs/427842 You received this bug notification

[Bug 227344] Re: bind-dlz und ldap api

2009-09-11 Thread Andreas Hasenack
This is not fixed in Karmic. ** Changed in: bind9 (Ubuntu) Status: Fix Released = Confirmed ** Summary changed: - bind-dlz und ldap api + bind-dlz and ldap api: invalid use of % character -- bind-dlz and ldap api: invalid use of % character https://bugs.launchpad.net/bugs/227344 You

[Bug 227344] Re: bind-dlz und ldap api

2009-09-11 Thread Andreas Hasenack
I just downloaded DLZ 0.7.0 from sourceforge and they don't have this change applied either. What has it been, more than a year now? Has upstream stopped developing this? -- bind-dlz and ldap api: invalid use of % character https://bugs.launchpad.net/bugs/227344 You received this bug

[Bug 227344] Re: bind-dlz and ldap api: invalid use of % character

2009-09-11 Thread Andreas Hasenack
Just to clarify, the comment about it being a year is about the fix going into upstream, not about this bug report. I'm worried why upstream hasn't released a fixed version yet, that's all. -- bind-dlz and ldap api: invalid use of % character https://bugs.launchpad.net/bugs/227344 You received

[Bug 427842] Re: [karmic] frontend DB needs ACLs for base= and cn=schema

2009-09-14 Thread Andreas Hasenack
** Description changed: The current installation of slapd doesn't allow for searches in the empty base (dn=) and the schema entries. These are needed by several client tools to, among other things: - check what the server schema is (luma, apache directory studio) - discover what the

[Bug 608623] Re: euca-revoke removes the wrong group authorization

2010-07-22 Thread Andreas Hasenack
It also happens when using Landscape to manage the security groups of a UEC installation, so it looks like a server bug and not a client one. ** Also affects: eucalyptus Importance: Undecided Status: New -- euca-revoke removes the wrong group authorization

[Bug 608623] [NEW] euca-revoke removes the wrong group authorization

2010-07-22 Thread Andreas Hasenack
Public bug reported: Binary package hint: euca2ools I have a security group and have authorized traffic from two other groups to it, web and lds: andr...@nsn2:~$ euca-describe-groups ssh GROUP admin ssh Allows 22/tcp from everywhere PERMISSION admin ssh ALLOWS tcp 22

[Bug 656738] Re: landscape fails to restart apache2 after upgrade

2010-10-13 Thread Andreas Hasenack
I think there is nothing we can do in landscape then about it, or landscape-client. I'm re-targeting this bug against apache. ** Changed in: landscape-client (Ubuntu) Status: Incomplete = Invalid ** Also affects: apache2 (Ubuntu) Importance: Undecided Status: New ** Summary

[Bug 656738] Re: apache2 restart fails, but exit code is zero

2010-10-14 Thread Andreas Hasenack
It's a race. The OP mentioned it's a busy server: However this fails, because under load it takes time for apache to stop. -- apache2 restart fails, but exit code is zero https://bugs.launchpad.net/bugs/656738 You received this bug notification because you are a member of Ubuntu Server Team,

[Bug 584497] Re: The EC2 endpoint should be HTTPS by default

2010-10-26 Thread Andreas Hasenack
** Changed in: landscape Milestone: 1.6.0 = 10.11 -- The EC2 endpoint should be HTTPS by default https://bugs.launchpad.net/bugs/584497 You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to eucalyptus in ubuntu. -- Ubuntu-server-bugs

[Bug 445619] [NEW] [karmic] slapd should start before kerberos kdc and admin servers, possibly others

2009-10-07 Thread Andreas Hasenack
Public bug reported: slapd 2.4.18-0ubuntu1 krb5-kdc-ldap 1.7dfsg~beta3-1 bind9 1:9.6.1.dfsg.P1-3 dhcp3-server 3.1.2-1ubuntu5 Currently in Karmic, we have slapd starting at 19 and the mit kerberos admin and kdc servers at 18. If the kerberos server is using the openldap backend, it will

[Bug 485026] [NEW] [karmic] slapd hangs at 100% cpu and is unkillable

2009-11-18 Thread Andreas Hasenack
Public bug reported: slapd-2.4.18-0ubuntu1 Steps to reproduce: 1. apt-get install slapd 2. ldapmodify -H ldapi:/// -Y EXTERNAL base.ldif (file attached to this ticket) 3. the ldapmodify hangs and slapd consumes all available cpu 4. slapd can now only be killed with the -9 signal I tried to

[Bug 485026] Re: [karmic] slapd hangs at 100% cpu and is unkillable

2009-11-18 Thread Andreas Hasenack
** Attachment added: base.ldif http://launchpadlibrarian.net/35834912/base.ldif -- [karmic] slapd hangs at 100% cpu and is unkillable https://bugs.launchpad.net/bugs/485026 You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to openldap in

[Bug 485026] Re: [karmic] slapd hangs at 100% cpu and is unkillable

2009-11-18 Thread Andreas Hasenack
Interesting, looks like ordering is an issue. In this order, slapd hangs: adding new entry olcOverlay=refint,olcDatabase={1}hdb,cn=config adding new entry olcOverlay=syncprov,olcDatabase={1}hdb,cn=config adding new entry o=example,c=us HANGS In this other order, it works: adding new entry

[Bug 485026] Re: [karmic] slapd hangs at 100% cpu and is unkillable

2009-11-18 Thread Andreas Hasenack
I just built a 2.4.19 package for karmic and it exhibits the same problem. -- [karmic] slapd hangs at 100% cpu and is unkillable https://bugs.launchpad.net/bugs/485026 You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to openldap in ubuntu.

[Bug 485026] Re: [karmic] slapd hangs at 100% cpu and is unkillable

2009-11-30 Thread Andreas Hasenack
It also happens with openldap-2.4.20 which was just released. -- [karmic] slapd hangs at 100% cpu and is unkillable https://bugs.launchpad.net/bugs/485026 You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to openldap in ubuntu. --

[Bug 485026] Re: [karmic] slapd hangs at 100% cpu and is unkillable

2009-12-01 Thread Andreas Hasenack
Attached is a gdb backtrace with debugging symbols from the hung process. I'll also attach the output of slapd -d -1, and probably open a bug upstream. ** Attachment added: thread-apply-all-bt-full.txt http://launchpadlibrarian.net/36294997/thread-apply-all-bt-full.txt -- [karmic] slapd

[Bug 485026] Re: [karmic] slapd hangs at 100% cpu and is unkillable

2009-12-01 Thread Andreas Hasenack
And now the slapd -d -1 output ** Attachment added: slapd-debug-output.txt.bz2 http://launchpadlibrarian.net/36295000/slapd-debug-output.txt.bz2 -- [karmic] slapd hangs at 100% cpu and is unkillable https://bugs.launchpad.net/bugs/485026 You received this bug notification because you are a

[Bug 485026] Re: [karmic] slapd hangs at 100% cpu and is unkillable

2009-12-01 Thread Andreas Hasenack
To help upstream to reproduce this bug, I'm also attaching a tarball containing the whole slapd.d contents as they are before running the ldapmodify command that triggers the issue. There is no database yet defined except the cn=config one. ** Attachment added: slapd.d.tar.bz2

[Bug 485026] Re: [karmic] slapd hangs at 100% cpu and is unkillable

2009-12-01 Thread Andreas Hasenack
ITS 6408 filed upstream -- [karmic] slapd hangs at 100% cpu and is unkillable https://bugs.launchpad.net/bugs/485026 You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to openldap in ubuntu. -- Ubuntu-server-bugs mailing list

[Bug 485026] Re: [karmic] slapd hangs at 100% cpu and is unkillable

2009-12-02 Thread Andreas Hasenack
I applied the diff the Howard mentioned (http://www.openldap.org/devel/cvsweb.cgi/servers/slapd/bconfig.c.diff?r1=1.401r2=1.402hideattic=1sortbydate=0) to 2.4.20 and now it works! Thanks! ** Changed in: openldap Status: New = Fix Committed -- [karmic] slapd hangs at 100% cpu and is

[Bug 485026] Re: [karmic] slapd hangs at 100% cpu and is unkillable

2009-12-02 Thread Andreas Hasenack
The same patch also worked in 2.4.18, but it applied with some offsets. ** Summary changed: - [karmic] slapd hangs at 100% cpu and is unkillable + [karmic] [PATCH] slapd hangs at 100% cpu and is unkillable -- [karmic] [PATCH] slapd hangs at 100% cpu and is unkillable

[Bug 494084] Re: arch parameter is not passed by the image proxy during image install from store

2010-04-08 Thread Andreas Hasenack
I see in the web UI that the disk size for this type of VM (small) is 5Gb. Is that it? IIRC, I at one point had it set to a lower value, but then the VMs wouldn't start, so I changed it to 5Gb a while ago. then you should have swap, so what did you mean by they don't have swap? I mean

[Bug 539231] Re: -t option isn't available in python-vm-builder 0.12.2-0ubuntu3

2010-04-09 Thread Andreas Hasenack
Yes, please don't break backwards compatbility anymore. I'm a big fan of partitioning, and my / partition is small. ubuntu-vm-builder is now barfing in lucid that -t is not available, and it runs out of disk space when using /tmp. It also doesn't seem to honor TMPDIR. -- -t option isn't

[Bug 1181334] Re: i386 required to install amd64

2014-02-21 Thread Andreas Hasenack
We also got hit by this with 1.4+bzr1693+dfsg-0ubuntu2.2~ctools0 on precise. Had to enable i386. -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to maas in Ubuntu. https://bugs.launchpad.net/bugs/1181334 Title: i386 required to install

[Bug 1274210] Re: Creation of LXC bridge in 1.17.0 fails

2014-02-25 Thread Andreas Hasenack
This fix is not enough. brigde-utils is installed too late, or service networking restart is called too soon. -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to juju-core in Ubuntu. https://bugs.launchpad.net/bugs/1274210 Title:

[Bug 1271144] Re: br0 not brought up by cloud-init script with MAAS provider

2014-03-19 Thread Andreas Hasenack
I applied this patch and it worked: === modified file 'provider/maas/environ.go' --- provider/maas/environ.gorevid:tarmac-20140314141156-nsn5oeamfi31t1ct +++ provider/maas/environ.go2014-03-19 16:54:28 + @@ -266,7 +266,13 @@ userdata, err := environs.ComposeUserData(

[Bug 1271144] Re: br0 not brought up by cloud-init script with MAAS provider

2014-03-19 Thread Andreas Hasenack
ahasenack hazmat: remember the br0 not coming up bug on the bootstrap node? There were two cloud-init configs involved, right? Because br0 does get up in services deployed to new machines, just not in the bootstrap one ahasenack hinting that the one used for bootstrap is different than the rest

[Bug 1299588] Re: LXC permission denied issue with 1.17.7

2014-04-01 Thread Andreas Hasenack
It's happening for me too. I used the manual provider + kapil's digital ocean plugin. I deployed ubuntu to a new machine, and then another service to lxc on that machine. machine log is attached, this is the last part: 2014-04-01 22:39:27 INFO juju.utils.apt apt.go:126 Running: [apt-get

[Bug 1299588] Re: LXC permission denied issue with 1.17.7

2014-04-01 Thread Andreas Hasenack
Deploying a containerized service to the bootstrap node works, i.e.: juju deploy ubuntu --to lxc:0 -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to juju-core in Ubuntu. https://bugs.launchpad.net/bugs/1299588 Title: LXC permission

[Bug 1299588] Re: LXC permission denied issue with 1.17.7

2014-04-01 Thread Andreas Hasenack
Same thing happened on AWS. Steps to reproduce: juju bootstrap juju deploy ubuntu juju deploy ubuntu --to lxc:1 juju ssh 1 tail -f /var/log/juju/machine-1.log You'll see: (...) 2014-04-01 23:22:36 DEBUG juju.worker.logger logger.go:60 logger setup 2014-04-01 23:22:36 DEBUG

[Bug 1274720] Re: screen crashed with SIGSEGV

2014-04-23 Thread Andreas Hasenack
I get it to crash when I run: rm -rf ~/.byobu byobu-screen hit ctrl-a c -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to screen in Ubuntu. https://bugs.launchpad.net/bugs/1274720 Title: screen crashed with SIGSEGV To manage

[Bug 1274720] Re: [SRU] screen server process can be crashed by byobu

2014-04-24 Thread Andreas Hasenack
Same here, ctrl-a *always* triggers the menu, even after I have already made a selection. Please don't upload this to -updates. -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to byobu in Ubuntu. https://bugs.launchpad.net/bugs/1274720

[Bug 1271144] Re: br0 not brought up by cloud-init script with MAAS provider

2014-04-25 Thread Andreas Hasenack
As a counterpoint, it worked for me with juju 1.18.1: $ juju status environment: scapestack machines: 0: agent-state: started agent-version: 1.18.1 dns-name: some.node instance-id: /MAAS/api/1.0/nodes/node-some-uuid series: precise services: {} $ juju ssh 0 ifconfig br0 br0

[Bug 1274720] Re: [SRU] screen server process can be crashed by byobu

2014-04-28 Thread Andreas Hasenack
ctrl-a always brings up the menu on 5.77-0ubuntu1.1. Please don't upload this to updates. -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to byobu in Ubuntu. https://bugs.launchpad.net/bugs/1274720 Title: [SRU] screen server process

[Bug 1302962] Re: Syslog suggests problem with MAAS DHCP lease file creation

2014-05-09 Thread Andreas Hasenack
I saw this too yesterday. The dhcpd.leases file is owned by root:root, the dhcpd daemon runs as dhcp (which isn't a problem as long as it has an open file handle), but the directory /var/lib/maas/dhcp is root:root. I changed the directory permissions to dhcpd:dhcpd and restarted maas's dhcpd, but

[Bug 1302962] Re: Syslog suggests problem with MAAS DHCP lease file creation

2014-05-09 Thread Andreas Hasenack
** Tags added: landscape -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to maas in Ubuntu. https://bugs.launchpad.net/bugs/1302962 Title: Syslog suggests problem with MAAS DHCP lease file creation To manage notifications about this

[Bug 1326477] [NEW] charm get doesn't work unless you login to launchpad with bzr

2014-06-04 Thread Andreas Hasenack
Public bug reported: $ charm get ntp You have not informed bzr of your Launchpad ID, and you must do this to write to Launchpad or access private data. See bzr help launchpad-login. You have not informed bzr of your Launchpad ID, and you must do this to

[Bug 1271144] Re: br0 not brought up by cloud-init script with MAAS provider

2014-07-01 Thread Andreas Hasenack
We are deploying lxc to bootstrap daily, using 1.5.1+bzr2269-0ubuntu0.1 from trusty-updates. Which one are you using? -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to juju-core in Ubuntu. https://bugs.launchpad.net/bugs/1271144 Title:

[Bug 1271144] Re: br0 not brought up by cloud-init script with MAAS provider

2014-07-18 Thread Andreas Hasenack
1.20.1 is in the juju stable ppa: sudo add-apt-repository ppa:juju/stable -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to juju-core in Ubuntu. https://bugs.launchpad.net/bugs/1271144 Title: br0 not brought up by cloud-init script

[Bug 1300507] Re: Rabbit password is reset on every upgrade which forces lockstep cluster restarts

2014-07-22 Thread Andreas Hasenack
Why is the rabbit password changed anyway? -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to maas in Ubuntu. https://bugs.launchpad.net/bugs/1300507 Title: Rabbit password is reset on every upgrade which forces lockstep cluster

[Bug 1274720] Re: [SRU] screen server process can be crashed by byobu

2014-07-30 Thread Andreas Hasenack
5.77-0ubuntu1.2 from trusty-proposed works for me, thanks! -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to byobu in Ubuntu. https://bugs.launchpad.net/bugs/1274720 Title: [SRU] screen server process can be crashed by byobu To

[Bug 1353734] [NEW] Permission denied when creating semaphore in container

2014-08-06 Thread Andreas Hasenack
Public bug reported: Deployed a precise host on canonistack, then a precise container inside that host: andreas@nsn7:~$ juju status environment: andreas-canonistack2 machines: 0: agent-state: started agent-version: 1.20.3 dns-name: 10.55.32.177 instance-id:

[Bug 1353734] Re: Permission denied when creating semaphore in container

2014-08-06 Thread Andreas Hasenack
I did the same deployment with the local provider, on my trusty host, and the precise container allowed that python snipped to be executed as a regular user without problems. -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to lxc in

[Bug 1300507] Re: Rabbit password is reset on every upgrade which forces lockstep cluster restarts

2014-08-12 Thread Andreas Hasenack
Same here on another machine. Rabbit was full of these: =ERROR REPORT 12-Aug-2014::19:18:59 === closing AMQP connection 0.4488.0 (10.96.0.10:36895 - 10.96.0.10:5672): {handshake_error,starting,0, {amqp_error,access_refused, AMQPLAIN login refused:

[Bug 1357103] [NEW] apparmor denied a golang build inside a container

2014-08-14 Thread Andreas Hasenack
Public bug reported: First, the error, while building a package inside a precise container: (...) make[1]: Entering directory `/home/ubuntu/deb/landscape-server-13.09.3~bzr544' GOPATH=/home/ubuntu/deb/landscape-server-13.09.3~bzr544/src/landscape/go /usr/bin/go install launchpad.net/gocheck

[Bug 1357103] Re: apparmor denied a golang build inside a container

2014-08-14 Thread Andreas Hasenack
I believe the bug has the necessary log snippets, marking as confirmed. ** Changed in: linux (Ubuntu) Status: Incomplete = Confirmed -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to lxc in Ubuntu.

[Bug 1357103] Re: apparmor denied a golang build inside a container

2014-08-18 Thread Andreas Hasenack
It's not happening anymore. I tried the same dpkg build command just a bit later and it just worked... :( Do you think a race is involved and I was lucky? -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to lxc in Ubuntu.

Re: [Bug 1156932] Re: User can't modify security-group-rule via nova-api if there are duplicated security group name

2014-09-08 Thread Andreas Hasenack
If you do it with the (duplicated) name instead of the id, does it crash? On Mon, Sep 8, 2014 at 7:21 AM, Sanjay Kumar Singh sanjay6.si...@tcs.com wrote: nova secgroup-list is returing id of security-group. So I don't see any problem in modifying security-group-rule group with id. nova

[Bug 1087183] Re: MaaS cloud-init configuration specifies 'manage_etc_hosts: localhost'

2014-09-17 Thread Andreas Hasenack
About Scott's (a) point, the debian document says you should have host.domain in /etc/hosts if the system has a permanent address, and the host.domain line should be for that address, not 127.0.1.1: For a system with a permanent IP address, that permanent IP address should be used here instead

[Bug 1087183] Re: MaaS cloud-init configuration specifies 'manage_etc_hosts: localhost'

2014-09-17 Thread Andreas Hasenack
Can someone mark the pyjuju task as won't fix? -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to maas in Ubuntu. https://bugs.launchpad.net/bugs/1087183 Title: MaaS cloud-init configuration specifies 'manage_etc_hosts: localhost' To

[Bug 1087183] Re: MaaS cloud-init configuration specifies 'manage_etc_hosts: localhost'

2014-09-18 Thread Andreas Hasenack
** Tags added: landscape -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to maas in Ubuntu. https://bugs.launchpad.net/bugs/1087183 Title: MaaS cloud-init configuration specifies 'manage_etc_hosts: localhost' To manage notifications

[Bug 1300507] Re: Rabbit password is reset on every upgrade which forces lockstep cluster restarts

2014-09-26 Thread Andreas Hasenack
Hi neel, unlikely. A timeout usually means a network connectivity problem. If it were a password problem, you would get an immediate error and it would say the credentials are incorrect. -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to

[Bug 1357103] Re: apparmor denied a golang build inside a container

2014-10-09 Thread Andreas Hasenack
I couldn't reproduce it before, with the same kernel. It's a race of some kind and I was unlucky. -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to lxc in Ubuntu. https://bugs.launchpad.net/bugs/1357103 Title: apparmor denied a golang

[Bug 1357103] Re: apparmor denied a golang build inside a container

2014-10-10 Thread Andreas Hasenack
Works for me, thanks. -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to lxc in Ubuntu. https://bugs.launchpad.net/bugs/1357103 Title: apparmor denied a golang build inside a container To manage notifications about this bug go to:

[Bug 1382632] [NEW] Insecure key file permissions

2014-10-17 Thread Andreas Hasenack
Public bug reported: openstack-dashboard 1:2014.2-0ubuntu1~cloud0 from http://ppa.launchpad.net/ubuntu-cloud-archive/juno-staging/ubuntu/ Got this during installation with the charm: (...) 2014-10-17 17:17:07 INFO install Setting up openstack-dashboard (1:2014.2-0ubuntu1~cloud0) ... 2014-10-17

[Bug 1382632] Re: Insecure key file permissions

2014-10-17 Thread Andreas Hasenack
The secret_key file is created when python manage.py collectstatic is run, it seems. We have two packages that run this command in postinst: openstack- dashboard-ubuntu-theme and openstack-dashboard. In this scenario, -ubuntu-theme is installed first. It runs that command in postinst, the file is

[Bug 1382632] Re: Insecure key file permissions

2014-10-23 Thread Andreas Hasenack
Of course the problem isn't that it is run twice :) I said above that in the first run the file is created with the incorrect permissions, and then the second run barfs at that :) -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to

[Bug 1382632] Re: Insecure key file permissions

2014-10-27 Thread Andreas Hasenack
How do we get this on trusty? Or the MAAS PPA perhaps? -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to horizon in Ubuntu. https://bugs.launchpad.net/bugs/1382632 Title: Insecure key file permissions To manage notifications about

[Bug 225820] Re: dapper: memleak in either hal, dbus or python bindings

2008-11-06 Thread Andreas Hasenack
** Changed in: landscape Target: mountainview-pre-1 = mountainview -- dapper: memleak in either hal, dbus or python bindings https://bugs.launchpad.net/bugs/225820 You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. -- ubuntu-bugs

[Bug 271767] Re: logrotate script needs to redirect stderr too

2008-11-06 Thread Andreas Hasenack
No client release in this milestone, so pushing for the next one. ** Changed in: landscape Target: thames+1 = mountainview-pre-1 -- logrotate script needs to redirect stderr too https://bugs.launchpad.net/bugs/271767 You received this bug notification because you are a member of Ubuntu

[Bug 295377] Re: package landscape-common 1.0.23-0ubuntu0.8.10.1 failed to install/upgrade:

2008-11-08 Thread Andreas Hasenack
*** This bug is a duplicate of bug 238755 *** https://bugs.launchpad.net/bugs/238755 This is the error from the logs: Setting up landscape-common (1.0.23-0ubuntu0.8.10.1) ... Your account has expired; please contact your system administrator chfn: PAM authentication failed adduser:

[Bug 288116] Re: python-smartpm file overwrite with smartpm-core

2008-10-31 Thread Andreas Hasenack
** Changed in: landscape Target: thames = thames+1 ** Also affects: landscape-client Importance: Undecided Status: New ** Changed in: landscape-client Importance: Undecided = Low -- python-smartpm file overwrite with smartpm-core https://bugs.launchpad.net/bugs/288116 You

[Bug 277682] Re: (dapper, feisty, gutsy, hardy)-intrepid upgrade doesn't upgrade landscape-client

2008-10-31 Thread Andreas Hasenack
** Changed in: landscape Status: Fix Committed = Fix Released -- (dapper,feisty,gutsy,hardy)-intrepid upgrade doesn't upgrade landscape-client https://bugs.launchpad.net/bugs/277682 You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

[Bug 273605] Re: Incorrect variable in warning

2008-10-31 Thread Andreas Hasenack
** Changed in: landscape-client Status: Fix Committed = Fix Released ** Changed in: landscape Status: Fix Committed = Fix Released -- Incorrect variable in warning https://bugs.launchpad.net/bugs/273605 You received this bug notification because you are a member of Ubuntu Bugs,

[Bug 271767] Re: logrotate script needs to redirect stderr too

2008-10-31 Thread Andreas Hasenack
** Changed in: landscape Target: thames = thames+1 -- logrotate script needs to redirect stderr too https://bugs.launchpad.net/bugs/271767 You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. -- ubuntu-bugs mailing list

[Bug 291282] Re: package landscape-common 1.0.23-0ubuntu0.8.10.1 failed to install/upgrade: subprocess post-installation script killed by signal (Interrupt)

2008-10-31 Thread Andreas Hasenack
You mean apt hang, right? Do you remember if your root account was locked sometime ago using passwd -l? -- package landscape-common 1.0.23-0ubuntu0.8.10.1 failed to install/upgrade: subprocess post-installation script killed by signal (Interrupt) https://bugs.launchpad.net/bugs/291282 You

[Bug 292472] Re: package landscape-common 1.0.23-0ubuntu0.8.10.1 failed to install/upgrade:

2008-11-02 Thread Andreas Hasenack
*** This bug is a duplicate of bug 238755 *** https://bugs.launchpad.net/bugs/238755 Hello, thanks for your report. This is the relevant part of the logs: Setting up landscape-common (1.0.23-0ubuntu0.8.10.1) ... Your account has expired; please contact your system administrator chfn: PAM

[Bug 292643] Re: client reports wrong location of error log

2008-11-04 Thread Andreas Hasenack
Correct. When using update-motd to display the sysinfo output, the tool runs as root, and so the logs are in the central location in /var/log/landscape. When run everytime the user logs in, it runs with the user privileges, which means the logs are then located in ~/.landscape/sysinfo.log. **

[Bug 291282] Re: landscape-common post script stuck

2008-11-04 Thread Andreas Hasenack
This may be the same as bug #277038 ** Summary changed: - package landscape-common 1.0.23-0ubuntu0.8.10.1 failed to install/upgrade: subprocess post-installation script killed by signal (Interrupt) + landscape-common post script stuck -- landscape-common post script stuck

[Bug 273545] Re: package landscape-common 1.0.21-0ubuntu1 failed to install/upgrade: trying to overwrite `/usr/lib/python2.5/site-packages/landscape/patch.py', which is also in package landscape-clien

2008-11-04 Thread Andreas Hasenack
*** This bug is a duplicate of bug 270131 *** https://bugs.launchpad.net/bugs/270131 ** This bug is no longer a duplicate of bug 268039 landscape-client 1.0.18-0ubuntu1 install stopped at useradd/chfn ** This bug has been marked a duplicate of bug 270131 update-manager hangs due to

[Bug 268066] Re: dpkg: error processing landscape-client (--configure)

2008-11-04 Thread Andreas Hasenack
*** This bug is a duplicate of bug 270131 *** https://bugs.launchpad.net/bugs/270131 ** This bug is no longer a duplicate of bug 268039 landscape-client 1.0.18-0ubuntu1 install stopped at useradd/chfn ** This bug has been marked a duplicate of bug 270131 update-manager hangs due to

  1   2   3   4   5   6   7   8   9   10   >