[Bug 1098294] [NEW] Use of uninitialized value $admin in string eq at ...

2013-01-10 Thread Daniel Richard G.
Public bug reported: When I install krb5-config 2.3 (along with some other Kerberos-related packages) on Ubuntu Quantal, I see this: [...] Get:8 http://$APTHOST/ubuntu/ quantal/universe krb5-user amd64 1.10.1+dfsg-2 [114 kB] Get:9 http://$APTHOST/ubuntu/ quantal/universe kstart amd64 4.1-2

[Bug 1131383] [NEW] Wishlist: $SSH_AUTH_SOCK in $XDG_RUNTIME_DIR

2013-02-21 Thread Daniel Richard G.
Public bug reported: This is a wishlist item for openssh-client 6.0p1-3ubuntu1 in Ubuntu Quantal. Now that XDG_RUNTIME_DIR support is available, it would be nice if the /etc/X11/Xsession.d/90x11-common_ssh-agent X session startup script would check to see if the variable is set, and if so, pass

[Bug 334374] Re: libnss-ldap should not depend on libpam-ldap

2013-04-25 Thread Daniel Richard G.
** Also affects: ldap-auth-client (Ubuntu) Importance: Undecided Status: New -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to libnss-ldap in Ubuntu. https://bugs.launchpad.net/bugs/334374 Title: libnss-ldap should not

[Bug 334374] Re: libnss-ldap should not depend on libpam-ldap

2013-04-25 Thread Daniel Richard G.
I think Thierry's solution in comment #10 is the way to go. It's appropriate for ldap-auth-client to depend on libpam-ldap, because that's the intent of the metapackage. But ldap-auth-config provides /etc/ldap.conf, which you need whether or not you're using LDAP for authentication. (That package

[Bug 334374] Re: libnss-ldap should not depend on libpam-ldap

2013-04-26 Thread Daniel Richard G.
Robie, thanks for commenting. Note that the ldap-auth-config package does not preclude alternate forms of managing /etc/ldap.conf. It won't touch an existing config file, nor complain if the one it creates is modified. Also, while this package does not exist in Debian, the file is still created

[Bug 483928]

2011-11-27 Thread Daniel Richard G.
(In reply to comment #38) I haven't seen this one before. The text you included indicates that ssh-keyscan was processing a Protocol 2 key and it should be using the modified code to do it. Is there any way that you could send me a traceback when the failure occurs? I'll do that, when I'm

[Bug 483928]

2011-12-01 Thread Daniel Richard G.
Okay, I tried Ubuntu's packaging of OpenSSH (version 1:5.8p1-7ubuntu1) with your patch, and it powered through everything. Here is a list of all the error messages I received: A.B.C.D: Connection closed by remote host Connection closed by A.B.C.D Connection to A.B.C.D timed out while waiting to

[Bug 483928]

2011-12-01 Thread Daniel Richard G.
(In reply to comment #41) The number of ways that key access can be terminated keeps increasing, doesn't it? I hope it won't be necessary to enumerate them all before this bug can be closed! My oops. I have had my focus redirected to other projects and, besides, I'm very lazy (;-}).

[Bug 483928]

2012-12-05 Thread Daniel Richard G.
I don't think anyone will fault you for having more momentous matters to attend to! As it is, I've gone without doing a network scan for that long anyway. Thanks for formally submitting the patch; hopefully this issue will be put to rest soon. Best of luck with the transition to a retired life,

[Bug 483928]

2012-12-05 Thread Daniel Richard G.
And a year later, this issue still afflicts OpenSSH 6.1p1 (as packaged by Ubuntu). Aab's patch still applies, if fuzzily, and still hardens up ssh-keyscan so that it can deal with my company's network. -- You received this bug notification because you are a member of Ubuntu Server Team, which is

[Bug 236830] Re: cifs does not support kerberos authentication

2008-11-17 Thread Daniel Richard G.
Unfortunately, CIFS with Kerberos auth is broken in Intrepid, due to bug 298208. Has anyone here gotten the upcall business to work in 8.10? -- cifs does not support kerberos authentication https://bugs.launchpad.net/bugs/236830 You received this bug notification because you are a member of

[Bug 300221] [NEW] Add Recommends: keyutils to smbfs

2008-11-20 Thread Daniel Richard G.
Public bug reported: Binary package hint: smbfs Looking at smbfs 2:3.2.3-1ubuntu3 in Intrepid. Samba's CIFS kernel module (as invoked via mount.cifs(8), in smbfs) makes use of the kernel's new request-key infrastructure, but there is nothing at the package-description level to indicate the

[Bug 660105] Re: when deflate is enabled, please also compress CSS and JS by default?

2011-02-01 Thread Daniel Richard G.
I think this would need an explicit decision to de-support IE6, as far as compressed JS is concerned. (I can't remember offhand which clients couldn't handle compressed CSS; was it anything newer than Netscape 4?) http://www.cforcoding.com/2009/05/supercharging-javascript-part-6.html

[Bug 711465] [NEW] mod_rewrite directives in Location section confusingly disable rewrites in .htaccess

2011-02-01 Thread Daniel Richard G.
Public bug reported: Binary package hint: apache2.2-bin Reporting this against version 2.2.16-1ubuntu3.1 in Maverick. I have apache2 configured in the following way: 1. mod_rewrite is enabled; 2. AllowOverride All is set (on /var/www) to enable the use of .htaccess files; 3. RewriteEngine On

[Bug 711465] Re: mod_rewrite directives in Location section confusingly disable rewrites in .htaccess

2011-02-01 Thread Daniel Richard G.
Adding RewriteOptions inherit doesn't seem to have any effect, whether in the Location section or the .htaccess file. Besides, looking at the documentation... inherit - This forces the current configuration to inherit the configuration of the parent. In per-virtual-server context, this means that

[Bug 483928] Re: ssh-keyscan(1) exits prematurely on some non-fatal errors

2011-02-22 Thread Daniel Richard G.
I'm still seeing this with openssh-client 1:5.5p1-4ubuntu5. From a makefile that invokes ssh-keyscan -v: [...] debug1: SSH2_MSG_KEX_DH_GEX_INIT sent debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY debug1: match: OpenSSH_3.6.1p2 pat OpenSSH_3.* # A.B.C.D SSH-1.99-OpenSSH_3.6.1p2 debug1: Enabling

[Bug 483928] Re: ssh-keyscan(1) exits prematurely on some non-fatal errors

2011-02-22 Thread Daniel Richard G.
** Bug watch added: OpenSSH Portable Bugzilla #1213 https://bugzilla.mindrot.org/show_bug.cgi?id=1213 ** Also affects: openssh via https://bugzilla.mindrot.org/show_bug.cgi?id=1213 Importance: Unknown Status: Unknown -- You received this bug notification because you are a member

[Bug 382832] Re: Need comment for line added to /etc/ldap.conf by nssldap-update-ignoreusers(8)

2011-03-14 Thread Daniel Richard G.
Yes, I'm afraid. Joshua's patch has not yet been committed (as of Natty). -- You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to libnss-ldap in ubuntu. https://bugs.launchpad.net/bugs/382832 Title: Need comment for line added to

[Bug 382832] [NEW] Need comment for line added to /etc/ldap.conf by nssldap-update-ignoreusers(8)

2009-06-02 Thread Daniel Richard G.
Public bug reported: Binary package hint: libnss-ldap (This is an issue as of libnss-ldap 261-2.1ubuntu1 in Ubuntu Jaunty.) The nss_initgroups_ignoreusers line added by nssldap-update- ignoreusers(8) to the end of /etc/ldap.conf needs a comment at least indicating what added it. For those who

[Bug 400776] [NEW] ssh-keyscan(1) hangs if broken server does partial handshake

2009-07-17 Thread Daniel Richard G.
Public bug reported: Binary package hint: openssh-client This concerns openssh-client 1:5.1p1-5ubuntu1 in Ubuntu Jaunty. I use ssh-keyscan(1) at a company site to create a global ssh_known_hosts file. I've found, however, that the program comes to a halt when it scans one particular system, an

[Bug 334374] Re: libnss-ldap should not depend on libpam-ldap

2009-08-16 Thread Daniel Richard G.
This bug report needs a visual aid. ** Attachment added: Current dependency graph (black edge = Depends, red edge = Recommends) http://launchpadlibrarian.net/30386089/depgraph.png -- libnss-ldap should not depend on libpam-ldap https://bugs.launchpad.net/bugs/334374 You received this bug

[Bug 382832] Re: Need comment for line added to /etc/ldap.conf by nssldap-update-ignoreusers(8)

2010-09-23 Thread Daniel Richard G.
Yep! That's the idea. I would tack on the (8) man-section suffix to the program name, but at any rate, this is all that's needed. -- Need comment for line added to /etc/ldap.conf by nssldap-update-ignoreusers(8) https://bugs.launchpad.net/bugs/382832 You received this bug notification because

[Bug 400776] Re: ssh-keyscan(1) hangs if broken server does partial handshake

2009-10-15 Thread Daniel Richard G.
The system in question, along with several others, was recently decommissioned and cannot be brought back online. (Honestly, we don't even know which physical machine it was.) This bug was trivially reproducible at the time that the report was filed, but I no longer have the means of doing so.

[Bug 452461] [NEW] Cannot elide admin_servers from debconf config

2009-10-15 Thread Daniel Richard G.
Public bug reported: Binary package hint: krb5-config I want to set up /etc/krb5.conf via debconf so that the file specifies kdc for my Kerberos realm, but not admin_server (nor kpasswd) because I want those to be found via DNS. If I do the logical thing, however---give a value for

[Bug 452461] Re: Cannot elide admin_servers from debconf config

2009-11-01 Thread Daniel Richard G.
Sorry for not following up sooner. I want to set up my /etc/krb5.conf file via debconf, as is currently implemented, but I want to do things a little differently from what the scripts have been written to do. Normally, you'd specify something like this in debconf:

[Bug 452461] Re: Cannot elide admin_servers from debconf config

2009-11-01 Thread Daniel Richard G.
Please let me know if any further information is needed. ** Changed in: kerberos-configs (Ubuntu) Status: Incomplete = New -- Cannot elide admin_servers from debconf config https://bugs.launchpad.net/bugs/452461 You received this bug notification because you are a member of Ubuntu Server

[Bug 483928] [NEW] ssh-keyscan(1) exits prematurely on some non-fatal errors

2009-11-16 Thread Daniel Richard G.
Public bug reported: Binary package hint: openssh-client This concerns openssh-client 1:5.1p1-5ubuntu1 in Karmic. I am using ssh-keyscan(1) for its intended purpose: building an ssh_known_hosts file for a large network. Most of the hosts on this network are well-maintained systems, with

[Bug 536930] [NEW] Password changing fails when krb5 pam-config is not first

2010-03-10 Thread Daniel Richard G.
Public bug reported: This concerns libpam-krb5 3.15-1 in Karmic. If you use the krb5 profile for pam-auth-update, password changing works correctly---unless another profile goes above it, and the Password clause is used instead of Password-Initial. (I simulated this by bumping the priority down

[Bug 369575] Re: Why is /usr/share/pam-configs/krb5 specifying minimum_uid= ?

2010-03-30 Thread Daniel Richard G.
Can we get minimum_uid out of pam-configs/krb5 for Lucid? -- Why is /usr/share/pam-configs/krb5 specifying minimum_uid= ? https://bugs.launchpad.net/bugs/369575 You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to kerberos-configs in ubuntu.

[Bug 382832] Re: Need comment for line added to /etc/ldap.conf by nssldap-update-ignoreusers(8)

2010-03-30 Thread Daniel Richard G.
Hi Dustin. I just noticed you're the author of nssldap-update- ignoreusers(8) ^_^ Does this look like a reasonable thing to add? -- Need comment for line added to /etc/ldap.conf by nssldap-update-ignoreusers(8) https://bugs.launchpad.net/bugs/382832 You received this bug notification because

[Bug 369575] Re: Why is /usr/share/pam-configs/krb5 specifying minimum_uid= ?

2010-03-30 Thread Daniel Richard G.
I know this isn't a big deal in the larger scheme of things, but it's the difference between being able to use the stock krb5 profile, and having to maintain a custom one. (And remember, the current behavior involves headaches if you have any non-root local users.) Please bring this up with Sam

[Bug 369575] Re: Why is /usr/share/pam-configs/krb5 specifying minimum_uid= ?

2010-03-30 Thread Daniel Richard G.
No no, the goal is not to have Kerberos users with uid 1000. It's to push minimum_uid higher, so that you can have normal 1000-something-uid local users authenticate without any Kerberos interaction. Same argument as for the root user and ignore_root. As for doing the upgrade, isn't

[Bug 369575] Re: Why is /usr/share/pam-configs/krb5 specifying minimum_uid= ?

2010-03-30 Thread Daniel Richard G.
What about just punting on upgrades altogether, and putting in the rearranged config only on a new install? Could that be done with appropriate postinst magic? Alternately, you could pop up a big scary debconf warning... there's ample precedent for that. -- Why is /usr/share/pam-configs/krb5

[Bug 369575] Re: Why is /usr/share/pam-configs/krb5 specifying minimum_uid= ?

2010-03-31 Thread Daniel Richard G.
You can see why I'm pushing on this. It's pay now, or pay later... no real gain in waiting :-] Ah, yes, users who've been dist-upgrading their Ubuntu installs since Warty... I guess there's no such thing as temporary postinst logic, if those need to be handled. A warning wouldn't be so bad. The

[Bug 369575] Re: Why is /usr/share/pam-configs/krb5 specifying minimum_uid= ?

2010-03-31 Thread Daniel Richard G.
Thought about the upgrade process a bit. How about this: 1. kerberos-configs starts generating new krb5.conf files with minimum_uid=1000. Then a little later... 2. libpam-krb5 has minimum_uid removed from pam-configs/krb5. On upgrade, it checks to see if this is in krb5.conf. If yes, great. If

[Bug 369575] Re: Why is /usr/share/pam-configs/krb5 specifying minimum_uid= ?

2010-04-07 Thread Daniel Richard G.
Isn't it possible to use debconf to change around the enabled profiles, via the libpam-runtime/profiles selection? Steve: I'm not sure I understand what you mean by automatically apply ... by the same mechanism. I can set minimum_uid in krb5.conf, but I also have to toss the minimum_uid= options

[Bug 369575] Re: Why is /usr/share/pam-configs/krb5 specifying minimum_uid= ?

2010-04-12 Thread Daniel Richard G.
But I suppose that's what NEWS.Debian is for. You could also stick in a debconf notice, like what x11-common had for a while (Major possible upgrade issues). Right -- if you're already distributing a krb5.conf with this setting, surely the same mechanism could be used to override the PAM

[Bug 369575] Re: Why is /usr/share/pam-configs/krb5 specifying minimum_uid= ?

2010-04-13 Thread Daniel Richard G.
I guess I'm a bit baffled by why fixing your PAM configuration is a workaround but installing a custom krb5.conf is a desired configuration step. krb5.conf is a config file under /etc. That's the ideal place to make configuration changes. As it is, right now, adding the minimum_uid bit involves

[Bug 369575] Re: Why is /usr/share/pam-configs/krb5 specifying minimum_uid= ?

2010-04-13 Thread Daniel Richard G.
They may want to, but I don't think the added complexity of debconf solely for what I believe is a rarely-used option makes sense. [...] I don't think debconf offers much benefit here. Fair enough, though I hope you're not suggesting direct modification of the /etc/pam.d/common-* files as a

[Bug 369575] Re: Why is /usr/share/pam-configs/krb5 specifying minimum_uid= ?

2010-04-13 Thread Daniel Richard G.
No, it's persistent unless you disable pam_krb5 entirely. Have you tried it? Yeah, where pam-auth-update asks you Override local changes to /etc/pam.d/common-*? I see the man page says something about preserving module options, but if I add an option to (say) common-auth, and re-run p-a-u, the

[Bug 369575] Re: Why is /usr/share/pam-configs/krb5 specifying minimum_uid= ?

2010-04-13 Thread Daniel Richard G.
Er, how is it silent when pam-auth-update asks you a question? Silent, in the sense that when you run p-a-u, it doesn't indicate that the common-* files have been modified in any way; it just presents you with the same checkbox-list of profiles. You leave everything as-is, hit OK, look at the

[Bug 369575] Re: Why is /usr/share/pam-configs/krb5 specifying minimum_uid= ?

2010-05-14 Thread Daniel Richard G.
Happy to give it a try, Steve. I just commented in that bug report. This is a potential solution, but putting aside the tricky case of what happens if the common-* files have customized options, and then the PAM profile changes?, another problem with this approach is the fragility of the

[Bug 369575] Re: Why is /usr/share/pam-configs/krb5 specifying minimum_uid= ?

2010-05-15 Thread Daniel Richard G.
I don't think moving parts of the user configuration out of the config files is acceptable, and if you disable and then re-enable a module, I don't see any reason that the config options *should* be sticky. I wasn't so much proposing an alternative, just going over the shortcomings I see of this

[Bug 26814] This issue should have been solved long ago

2006-09-12 Thread Daniel Richard G.
My system is a Dell 2350 with a PCI graphics board. The onboard Intel AGP video is unused. The Dell BIOS is buggy: when the system boots via PCI video, it leaves the onboard AGP video in a semi-catatonic state. Subsequently, if Linux attempts to load the intel-agp kernel module (or was it

[Bug 49538] Edit - Setup - Other Options: instant segfault on amd64

2006-06-12 Thread Daniel Richard G.
Public bug reported: [I tried submitting this via reportbug(1), but it appears to have been bitbucketed.] Xmbdfed on amd64 segfaults when one attempts to bring up the Other Options dialog. GDB gives some interesting telemetry: Program received signal SIGSEGV, Segmentation fault.

[Bug 26814] Re: hangs on starting hotplug subsystems when pci video is on

2006-10-10 Thread Daniel Richard G.
The dapper live-CD still hangs the system during startup. I haven't tried a prerelease edgy live-CD, but haven't seen anything to suggest that the problem's fixed there. -- hangs on starting hotplug subsystems when pci video is on https://launchpad.net/bugs/26814 -- ubuntu-bugs mailing list

[Bug 294840] Re: F6 menu behaviour is confusing

2008-11-06 Thread Daniel Richard G.
Huh! First time I've ever seen that F6*2 menu. I use expert mode so that I can... * select a 104-key PC keyboard model, instead of an international 105-key (I don't know why it defaults to the latter) * enable login as root, and not create a normal user account (for a system that will have

[Bug 294840] Re: F6 menu behaviour is confusing

2008-11-06 Thread Daniel Richard G.
On the more general point of a confusing F6*2 menu, I'd like to point out that the F4 (Modes) menu is not all that unrelated, in that both address variations of the normal install process. Might it help to unify these two? The F4 menu is a choice of one out of four options, whereas F6*2 is a set

[Bug 254472] Re: Hardy alternate CD does not support cli or cli-expert boot methods

2008-11-06 Thread Daniel Richard G.
Bug persists in the Intrepid alternate install CD. -- Hardy alternate CD does not support cli or cli-expert boot methods https://bugs.launchpad.net/bugs/254472 You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. -- ubuntu-bugs mailing list

[Bug 270512] Re: openssh-client could suggest xauth rather than recommend it

2008-11-06 Thread Daniel Richard G.
Bug 51774 is about silent-failure behavior when forwarding X11 without xauth(1) on the remote side, which is a separate issue. Colin, you yourself said that a package dependency doesn't address that, and I agree. I also agree with Thierry's premise that those X11-related packages should not be

[Bug 295441] [NEW] pam-auth-update does not correctly process a valid profile file

2008-11-07 Thread Daniel Richard G.
Public bug reported: Binary package hint: libpam-runtime Working with libpam-runtime 1.0.1-4ubuntu5 in intrepid. I've put together a profile for pam-auth-update to use. For some reason, it doesn't like the session-related fields I have, despite them appearing to be well-formed. Attached is a

[Bug 295441] Re: pam-auth-update does not correctly process a valid profile file

2008-11-07 Thread Daniel Richard G.
** Attachment added: pam-auth-update input file http://launchpadlibrarian.net/19481610/bug -- pam-auth-update does not correctly process a valid profile file https://bugs.launchpad.net/bugs/295441 You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed

[Bug 295444] [NEW] dpkg-reconfigure libpam-runtime does not respect debconf frontend

2008-11-07 Thread Daniel Richard G.
Public bug reported: Binary package hint: libpam-runtime This concerns libpam-runtime 1.0.1-4ubuntu5 in intrepid. Run dpkg-reconfigure -f editor libpam-runtime. Why does the dialog interface come up when we explicitly asked otherwise? ** Affects: pam (Ubuntu) Importance: Undecided

[Bug 295444] Re: dpkg-reconfigure libpam-runtime does not respect debconf frontend

2008-11-08 Thread Daniel Richard G.
Reassigning to debconf. ** Changed in: debconf (Ubuntu) Sourcepackagename: pam = debconf Status: Invalid = New -- dpkg-reconfigure libpam-runtime does not respect debconf frontend https://bugs.launchpad.net/bugs/295444 You received this bug notification because you are a member of Ubuntu

[Bug 295871] [NEW] Does not accept first-entered debconf value for hesiod/rhs

2008-11-09 Thread Daniel Richard G.
Public bug reported: Binary package hint: libhesiod0 Concerning libhesiod0 3.0.2-18.2 in intrepid. This is likely related to bug 277223. When installing libhesiod0, the first time that its debconf dialog comes up, whatever value you enter as the Hesiod domain for searches is discarded---rhs is

[Bug 293313] [NEW] CLI install pulls in xauth (and other X11 deps)

2008-11-03 Thread Daniel Richard G.
Public bug reported: Binary package hint: debian-installer I am installing Intrepid with an F6 - Other options command line of file=/cdrom/preseed/cli.seed priority=low initrd=/install/initrd.gz quiet -- to install only the ubuntu-standard base system. After the install is finished, the

[Bug 293944] [NEW] Need better support for adding site-local certificates

2008-11-04 Thread Daniel Richard G.
Public bug reported: Binary package hint: ca-certificates A wishlist item for ca-certificates 20080514-0ubuntu1 in intrepid: I'm putting together a system image for a small corporate site. I am placing files under /usr/local/, and occasionally symlinking these into /etc, /usr, etc. as necessary

[Bug 284181] [NEW] m-a -t uses tput(1) and terminal escape sequences incorrectly

2008-10-15 Thread Daniel Richard G.
Public bug reported: Binary package hint: module-assistant This is module-assistant 0.10.11ubuntu1 in hardy. module-assistant, in --text-mode, typically uses terminal escape sequences to highlight certain lines in its output (e.g. the dpkg -Ei ... invocation). However, it does two things

[Bug 284548] [NEW] Typo causes invocation of apt-get-y instead of apt-get -y

2008-10-16 Thread Daniel Richard G.
Public bug reported: Binary package hint: module-assistant This concerns module-assistant 0.10.11ubuntu1, in hardy. A type in the module-assistant script causes a nonexistent program apt- get-y to be invoked (when the --non-inter option is given), instead of apt-get -y (note the space before

[Bug 287342] [NEW] Development package does not include libxslt.m4

2008-10-21 Thread Daniel Richard G.
Public bug reported: This report concerns libxslt1-dev 1.1.22-1ubuntu1.2 in hardy. An install tree of libxslt normally includes the file $(PREFIX)/share/aclocal/libxslt.m4. The Ubuntu libxslt1-dev package does not, even though the closely related libxml2-dev package does: $ dpkg -L libxml2-dev

[Bug 49538] Re: Edit - Setup - Other Options: instant segfault on amd64

2008-04-23 Thread Daniel Richard G.
xmbdfed has been superseded upstream by gbdfed, and is no longer even in the Ubuntu package repository (it is now a dummy package depending on gbdfed). This bug report is therefore moot. ** Changed in: xmbdfed (Ubuntu) Status: Incomplete = Invalid -- Edit - Setup - Other Options: instant

[Bug 184852] dpkg-reconfigure --all invokes update-initramfs(8) multiple times

2008-01-21 Thread Daniel Richard G.
Public bug reported: Binary package hint: initramfs-tools On a minimal text-mode-only install of Gutsy (i.e. ubuntu-minimal + ubuntu-standard), dpkg-reconfigure --all causes update-initramfs(8) to be invoked no less than 10 times. Moreover, this was running on a fairly old (Pentium II) system,

[Bug 184908] updmap-sys fails on install due to missing dvips35.map file

2008-01-21 Thread Daniel Richard G.
Public bug reported: Binary package hint: lmodern On an Ubuntu Gutsy system, installing a full TeX/LaTeX suite in one go: BEGIN TERMINAL SESSION apt-get install lmodern tetex-doc-nonfree tetex-extra texlive-generic-extra texpower [...] Setting up lmodern (1.010x-3) ... warning:

[Bug 254472] [NEW] Hardy alternate CD does not support cli or cli-expert boot methods

2008-08-03 Thread Daniel Richard G.
Public bug reported: [Note: I am not sure that this bug is filed under the correct package. Please correct if needed.] The Hardy alternate install CD has an ISOLINUX boot menu that initially lists the following boot methods: install expert cli cli-expert The cli and cli-expert

[Bug 184852] Re: dpkg-reconfigure --all invokes update-initramfs(8) multiple times

2008-08-05 Thread Daniel Richard G.
Bug persists in Hardy. In an ubuntu-minimal install, dpkg-reconfigure --all invokes update- initramfs(8) six times, with the first three instances seemingly occurring one right after the other. [EMAIL PROTECTED]:~# dpkg-reconfigure --all * Stopping ACPI services...

[Bug 261711] [NEW] portmap does not honor preseeded debconf value

2008-08-26 Thread Daniel Richard G.
Public bug reported: Binary package hint: portmap Version: 6.0-4 (Ubuntu 8.04.1) I am making use of debconf preseeding, via debconf-get-selections(1) + debconf-set-selections(1). Among the selections specified this way is portmap's bind to loopback address setting, which I want to set to YES

[Bug 262089] [NEW] Preseeded debconf value for fontconfig/subpixel_rendering is not honored

2008-08-27 Thread Daniel Richard G.
Public bug reported: Binary package hint: fontconfig-config Version: 2.5.0-2ubuntu3 I am using debconf-get-selections(1) + debconf-set-selections(1) to preseed configuration settings on a newly-installed Ubuntu Hardy 8.04.1 system (starting with ubuntu-standard, preseeding, and then installing

[Bug 343798] [NEW] Consider adding GlobalSign CA certificate

2009-03-16 Thread Daniel Richard G.
Public bug reported: Binary package hint: ca-certificates The Adobe Open Source site has an SVN-via-HTTPS server up and running at https://opensource.adobe.com/svn/opensource/flex/sdk/ On an up-to-date Ubuntu Intrepid system, connecting to this server with the svn(1) client yields Error

[Bug 208267] Re: openjdk-6 path should be added to java_home

2009-03-17 Thread Daniel Richard G.
This bug is still present in Intrepid, and modifying /etc/eclipse/java_home still works around it. -- openjdk-6 path should be added to java_home https://bugs.launchpad.net/bugs/208267 You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. --

[Bug 309163] Re: Open File dialog fails with inexplicable Please select a file to open error

2009-03-19 Thread Daniel Richard G.
Paul, I can't reproduce the problem with this new build, but... it's linked against Lesstif, instead of the OpenMotif library. That changes things completely---and the upstream doesn't seem too fond of the idea, as the program prints nedit: WARNING: This version of NEdit is built

[Bug 325827] Re: raid array wont work after Hostname change

2009-02-16 Thread Daniel Richard G.
This is not a bug. Please review the --homehost= option in the mdadm(8) man page. In a nutshell: Your RAID devices store the hostname in the superblock, so that when mdadm --assemble is called, it only assembles RAID devices that belong to the running host. (The rationale is that if you, for some

[Bug 330399] [NEW] HOMEHOST system does not work inside initrd

2009-02-16 Thread Daniel Richard G.
Public bug reported: Binary package hint: mdadm This concerns mdadm 2.6.7-3ubuntu8 in Intrepid. I have a system with / on a RAID1 device. /etc/mdadm/mdadm.conf specifies HOMEHOST system, and no information on the structure of the RAID1 device. (The intent, of course, is to have mdadm

[Bug 325827] Re: raid array wont work after Hostname change

2009-02-17 Thread Daniel Richard G.
Good luck with your RAID setup, and !saludos desde Boston! Closing this bug as Invalid, to keep things nice and organized. ** Changed in: mdadm (Ubuntu) Status: New = Invalid -- raid array wont work after Hostname change https://bugs.launchpad.net/bugs/325827 You received this bug

[Bug 280414] Re: Installing mdadm also installs citadel-common, etc.

2009-02-17 Thread Daniel Richard G.
You can avoid pulling in any of the mail stuff by passing --no-install- recommends to apt-get(8). -- Installing mdadm also installs citadel-common, etc. https://bugs.launchpad.net/bugs/280414 You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to

[Bug 309163] Re: Open File dialog fails with inexplicable Please select a file to open error

2009-02-17 Thread Daniel Richard G.
Daniel, do you also get the error when you can normally open the file? So far, no. The error messages, and being able to open the file normally, are mutually exclusive. -- Open File dialog fails with inexplicable Please select a file to open error https://bugs.launchpad.net/bugs/309163 You

[Bug 331251] [NEW] Enable and document support for AutoConfig/MCD

2009-02-18 Thread Daniel Richard G.
Public bug reported: Binary package hint: firefox-3.0 Mozilla Firefox provides a mechanism allowing centralized auto- configuration known as AutoConfig, or Mission Control Desktop. Some references: https://developer.mozilla.org/en/MCD,_Mission_Control_Desktop_AKA_AutoConfig

[Bug 331443] [NEW] /etc/init.d/gdm reload fails when gdm is not running

2009-02-19 Thread Daniel Richard G.
Public bug reported: Binary package hint: gdm The gdm init script reload action is invoked when installing other packages that affect the configuration. However, if gdm is not running, the script does not behave in a very graceful manner. Observe: # /etc/init.d/gdm reload * Reloading GNOME

[Bug 331812] [NEW] Group-owned static interfaces do not work

2009-02-19 Thread Daniel Richard G.
Public bug reported: Binary package hint: virtualbox-ose This concerns virtualbox-ose 2.0.4-dfsg-0ubuntu1 in Ubuntu Intrepid. VBoxAddIF allows you to create an interface for use by a group (as opposed to a single user) with the -g option. This creates an entry in /etc/vbox/interfaces like the

[Bug 309163] Re: Open File dialog fails with inexplicable Please select a file to open error

2009-02-11 Thread Daniel Richard G.
Hi Paul, Attached is a screenshot more or less illustrating the error. NEdit was invoked from the terminal (the errors are too numerous to fit even in that tall window), and gives an error dialog attempting to open start.html. Note that the X/Motif errors begin as soon as you hit Ctrl+O, and

[Bug 328929] [NEW] Initial blank line in debian/control confuses pyversions -r

2009-02-12 Thread Daniel Richard G.
Public bug reported: Binary package hint: python-minimal This report concerns python-minimal 2.5.2-1ubuntu1 in Intrepid. I have a Debian package source tree. The debian/control file has the following layout: begin blank line Source: Section: Priority: Maintainer: Build-Depends:

[Bug 270043] Re: intrepid - rm: cannot remove `md0-': Read-only file system

2009-02-15 Thread Daniel Richard G.
The libsensors4 package has a similar problem. See bug #329792. -- intrepid - rm: cannot remove `md0-': Read-only file system https://bugs.launchpad.net/bugs/270043 You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. -- ubuntu-bugs mailing

[Bug 329792] [NEW] Read-only file system errors during install

2009-02-15 Thread Daniel Richard G.
Public bug reported: Binary package hint: libsensors4 This concerns libsensors4 version 1:3.0.2-1ubuntu2 in Intrepid. On installing libsensors4 for the first time, I see the following (excerpted) in the output of apt-get: begin Setting up libsensors4 (1:3.0.2-1ubuntu2) ... udev active,

[Bug 366293] [NEW] Non-existent i18n files lead to needless server failover

2009-04-24 Thread Daniel Richard G.
Public bug reported: Binary package hint: apt-cacher I have an apt-cacher setup in which the main path_map element lists two servers, in the following order: ubuntu.media.mit.edu/ubuntu us.archive.ubuntu.com/ubuntu I.e. a random mirror server, and the official Ubuntu US archive server.

[Bug 366293] Re: Non-existent i18n files lead to needless server failover

2009-04-25 Thread Daniel Richard G.
Hmm... I don't think this is the same bug. Given the Connection reset by peer errors in the Debian bug, and the maintainer's trouble in reproducing it, it looks like more of a network-fault kind of issue. This bug is getting at a problem with the program's behavior as intended. -- Non-existent

[Bug 295441] Re: pam-auth-update does not correctly process a valid profile file

2009-04-20 Thread Daniel Richard G.
Martin, I have libpam-runtime 1.0.1-4ubuntu5.5 on Intrepid here. My report from 2009-03-25 still stands. Can you please fix those Perl warnings? -- pam-auth-update does not correctly process a valid profile file https://bugs.launchpad.net/bugs/295441 You received this bug notification because

[Bug 364665] [NEW] pam-auth-update spews Perl warnings while processing a valid profile file

2009-04-21 Thread Daniel Richard G.
Public bug reported: Binary package hint: libpam-runtime This bug report is an offshoot of bug #295441. pam-auth-update (from libpam-runtime 1.0.1-4ubuntu5.5 in Intrepid) no longer generates an invalid PAM config file, but it is still producing copious Perl warnings while processing the attached

[Bug 295441] Re: pam-auth-update does not correctly process a valid profile file

2009-04-21 Thread Daniel Richard G.
Bug #364665 created: pam-auth-update spews Perl warnings while processing a valid profile file -- pam-auth-update does not correctly process a valid profile file https://bugs.launchpad.net/bugs/295441 You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed

[Bug 295441] Re: pam-auth-update does not correctly process a valid profile file

2009-03-25 Thread Daniel Richard G.
pam-auth-update(8) from intrepid-proposed is no longer generating invalid PAM config files, but it still prints a spew of Perl warnings when invoked: # /usr/sbin/pam-auth-update Use of uninitialized value $3 in split at /usr/sbin/pam-auth-update line 607, CURRENT line 27. Use of uninitialized

[Bug 184908] Re: updmap-sys fails on install due to missing dvips35.map file

2009-04-08 Thread Daniel Richard G.
This bug no longer occurs on Jaunty, nor on (I think) Intrepid, so I'm closing it. Please reopen if it is observed again. ** Changed in: lmodern (Ubuntu) Status: Confirmed = Invalid -- updmap-sys fails on install due to missing dvips35.map file https://bugs.launchpad.net/bugs/184908 You

[Bug 351288] [NEW] mdadm.postinst fails because /dev/MAKEDEV is not present

2009-03-29 Thread Daniel Richard G.
Public bug reported: Binary package hint: mdadm In the course of installing mdadm on the Jaunty beta, I see this: Setting up mdadm (2.6.7.1-1ubuntu8) ... Generating array device nodes... /var/lib/dpkg/info/mdadm.postinst:170: /dev/MAKEDEV: not found failed. Generating mdadm.conf... done.

[Bug 236830] Re: cifs does not support kerberos authentication

2008-11-17 Thread Daniel Richard G.
Unfortunately, CIFS with Kerberos auth is broken in Intrepid, due to bug 298208. Has anyone here gotten the upcall business to work in 8.10? -- cifs does not support kerberos authentication https://bugs.launchpad.net/bugs/236830 You received this bug notification because you are a member of

[Bug 299749] [NEW] Installer unconditionally asks for PCMCIA options in expert mode

2008-11-18 Thread Daniel Richard G.
Public bug reported: Binary package hint: debian-installer Installing Intrepid on a desktop machine in expert mode. At various points during the install (e.g. detecting and mounting the CD-ROM), the following exchange takes place: 1. Installer asks Start PC card services? 2. I say No. 3.

[Bug 300221] [NEW] Add Recommends: keyutils to smbfs

2008-11-20 Thread Daniel Richard G.
Public bug reported: Binary package hint: smbfs Looking at smbfs 2:3.2.3-1ubuntu3 in Intrepid. Samba's CIFS kernel module (as invoked via mount.cifs(8), in smbfs) makes use of the kernel's new request-key infrastructure, but there is nothing at the package-description level to indicate the

[Bug 309784] [NEW] Blank screen, unresponsive console when starting full-screen OpenGL apps

2008-12-19 Thread Daniel Richard G.
Public bug reported: Binary package hint: xserver-xorg-video-intel This concerns xserver-xorg-video-intel 2:2.4.1-1ubuntu10 in Intrepid. I have a bog-standard Dell Optiplex 755 corporate PC with Intel onboard video. When I start a full-screen OpenGL application, such as Openarena or Kobo

[Bug 309784] Re: Blank screen, unresponsive console when starting full-screen OpenGL apps

2008-12-19 Thread Daniel Richard G.
** Attachment added: Output of lspci -vvnn http://launchpadlibrarian.net/20581326/lspci-vvnn-output.txt -- Blank screen, unresponsive console when starting full-screen OpenGL apps https://bugs.launchpad.net/bugs/309784 You received this bug notification because you are a member of Ubuntu

[Bug 309784] Re: Blank screen, unresponsive console when starting full-screen OpenGL apps

2008-12-19 Thread Daniel Richard G.
The program was started right before the Error in I830WaitLpRing() line. ** Attachment added: X server log file, running Kobo Deluxe http://launchpadlibrarian.net/20581352/Xorg.0.log.kobodl.txt -- Blank screen, unresponsive console when starting full-screen OpenGL apps

[Bug 309784] Re: Blank screen, unresponsive console when starting full-screen OpenGL apps

2008-12-19 Thread Daniel Richard G.
Again, look for the Error in I830WaitLpRing() line. ** Attachment added: X server log file, running Openarena http://launchpadlibrarian.net/20581366/Xorg.0.log.openarena.txt -- Blank screen, unresponsive console when starting full-screen OpenGL apps https://bugs.launchpad.net/bugs/309784 You

[Bug 309784] Re: Blank screen, unresponsive console when starting full-screen OpenGL apps

2008-12-19 Thread Daniel Richard G.
** Attachment added: The error dialog observed after killing Xorg with SIGQUIT http://launchpadlibrarian.net/20581399/x-error-dialog.png -- Blank screen, unresponsive console when starting full-screen OpenGL apps https://bugs.launchpad.net/bugs/309784 You received this bug notification

[Bug 309784] Re: Blank screen, unresponsive console when starting full-screen OpenGL apps

2008-12-19 Thread Daniel Richard G.
This time, the server at least behaved. This log file is not truncated. ** Attachment added: X server log file containing the error quoted in the above dialog http://launchpadlibrarian.net/20581524/Xorg.0.log.restart.txt -- Blank screen, unresponsive console when starting full-screen OpenGL

[Bug 309784] Re: Blank screen, unresponsive console when starting full-screen OpenGL apps

2008-12-19 Thread Daniel Richard G.
A few more details that may be of interest: * All the above results were obtained without a desktop environment, or even a window manager. Programs were invoked from a lone XTerm, launched from a bare-bones ~/.xsession script. * The OpenGL programs start without a problem in the first X11

  1   2   3   4   5   6   7   8   9   >