[Bug 1815415] Re: please update libseccomp for newer kernel syscalls

2019-03-11 Thread Launchpad Bug Tracker
This bug was fixed in the package libseccomp - 2.3.1-2.1ubuntu4.1 --- libseccomp (2.3.1-2.1ubuntu4.1) bionic; urgency=medium * d/p/lp-1755250-add-the-statx-syscall.patch: add statx support (LP: #1755250) * d/p/lp-1815415-*: Add syscalls up to kernel 4.15 (LP: #1815415) --

[Bug 1815415] Re: please update libseccomp for newer kernel syscalls

2019-02-28 Thread Christian Ehrhardt 
Added improved test ordering to the description ** Description changed: [Impact]  * The libseccomp library provides an easy to use, platform independent,    interface to the Linux Kernel's syscall filtering mechanism. But it can    only "control" those syscalls it knows about.

[Bug 1815415] Re: please update libseccomp for newer kernel syscalls

2019-02-28 Thread Christian Ehrhardt 
Testing as-is $ ${ADTTMP}/exe ./debian/tests/data/newcodes.filter /bin/date; echo $? DEBUG: seccomp_load_filters ./debian/tests/data/newcodes.filter failed to find preadv2 seccomp_load_filters failed with -1 1 Update to version in proposed: $ sudo apt install libseccomp2/bionic-proposed Reading

[Bug 1815415] Re: please update libseccomp for newer kernel syscalls

2019-02-27 Thread Brian Murray
Hello Christian, or anyone else affected, Accepted libseccomp into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libseccomp/2.3.1-2.1ubuntu4.1 in a few hours, and then in the -proposed repository. Please help us by testing this new package.

[Bug 1815415] Re: please update libseccomp for newer kernel syscalls

2019-02-12 Thread Seth Arnold
Thanks Christian, very thorough. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1815415 Title: please update libseccomp for newer kernel syscalls To manage notifications about this bug go to:

[Bug 1815415] Re: please update libseccomp for newer kernel syscalls

2019-02-12 Thread Christian Ehrhardt 
All pre-checks and tests complete, and uploaded to the SRU review queue -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1815415 Title: please update libseccomp for newer kernel syscalls To manage

[Bug 1815415] Re: please update libseccomp for newer kernel syscalls

2019-02-12 Thread Christian Ehrhardt 
FYI (to find it easier) logs of the new build: - autopkgtest with new version https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic-ci-train-ppa-service-3640/bionic/amd64/libs/libseccomp/20190211_095659_0b835@/log.gz - build time tests

[Bug 1815415] Re: please update libseccomp for newer kernel syscalls

2019-02-12 Thread Christian Ehrhardt 
Thanks for the reviews - I'll have to come up with some tests on my own then ... In general there already are build time tests and autopkgtests in the package. So coverage of "old calls" for regressions is already good. Fortunately the autopkgtests seem to be extendable for an explicit

Re: [Bug 1815415] Re: please update libseccomp for newer kernel syscalls

2019-02-11 Thread Seth Arnold
On Mon, Feb 11, 2019 at 07:38:28AM -, Christian Ehrhardt  wrote: > @Seth / @Tyler - Hi, you asked for the change, but I'd want to ask for > something as well :-) Do you have any testcases from your security work > that we could reuse here to check the SRU for SRU verification? It doesn't

[Bug 1815415] Re: please update libseccomp for newer kernel syscalls

2019-02-11 Thread Seth Arnold
Sorry about the question about s390 syscalls in unrelated syscall tables; that patch accurately reflected upstream's code. Looks good to me, thanks. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

[Bug 1815415] Re: please update libseccomp for newer kernel syscalls

2019-02-11 Thread Launchpad Bug Tracker
** Merge proposal linked: https://code.launchpad.net/~paelzer/ubuntu/+source/libseccomp/+git/libseccomp/+merge/362906 -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1815415 Title: please update

[Bug 1815415] Re: please update libseccomp for newer kernel syscalls

2019-02-11 Thread Christian Ehrhardt 
I combined the requested changes in the PPA [1] and version ~ppa2 is building now. Later autopkgtests will be kicked on bileto [2] to pre- check those as well. I updated the MP for re-review accordingly. [1]: https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/3640 [2]:

[Bug 1815415] Re: please update libseccomp for newer kernel syscalls

2019-02-11 Thread Christian Ehrhardt 
Combining all those also allows us to take the changes (since they only add definitions the only context they had were "each other) without any backport noise. ** Description changed: [Impact]  * The libseccomp library provides an easy to use, platform independent,    interface to the

[Bug 1815415] Re: please update libseccomp for newer kernel syscalls

2019-02-10 Thread Christian Ehrhardt 
** Description changed: [Impact]  * The libseccomp library provides an easy to use, platform independent,    interface to the Linux Kernel's syscall filtering mechanism. But it can    only "control" those syscalls it knows about. Therefore staying up to    date with newer kernels is

[Bug 1815415] Re: please update libseccomp for newer kernel syscalls

2019-02-10 Thread Christian Ehrhardt 
@Seth / @Tyler - Hi, you asked for the change, but I'd want to ask for something as well :-) Do you have any testcases from your security work that we could reuse here to check the SRU for SRU verification? ** Description changed: + [Impact] + + * The libseccomp library provides an easy to

[Bug 1815415] Re: please update libseccomp for newer kernel syscalls

2019-02-10 Thread Christian Ehrhardt 
Disco and Cosmic already contain those changes ** Also affects: libseccomp (Ubuntu Cosmic) Importance: Undecided Status: New ** Also affects: libseccomp (Ubuntu Bionic) Importance: Undecided Status: New ** Changed in: libseccomp (Ubuntu) Status: New => Fix Released