[Bug 1864571] Re: SRU ubuntu-dev-tools

2020-08-25 Thread Scott Moser
I'm pretty sure this change caused bug 1892879 also. basically, the python-ubuntudevtools package is empty. -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1864571 Title: SRU ubuntu-dev-tools To

[Bug 1864571] Re: SRU ubuntu-dev-tools

2020-08-07 Thread Francis Ginther
** Tags added: id-5f2c28248092a887b8599665 -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1864571 Title: SRU ubuntu-dev-tools To manage notifications about this bug go to:

[Bug 1864571] Re: SRU ubuntu-dev-tools

2020-08-06 Thread Brian Murray
** Tags removed: rls-bb-incoming rls-gg-incoming verification-needed ** Tags added: regression-update -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1864571 Title: SRU ubuntu-dev-tools To manage

[Bug 1864571] Re: SRU ubuntu-dev-tools

2020-07-07 Thread Matthias Klose
this introduces a regression for ubuntu-archive-tools: $ ./change-override -c main -S Traceback (most recent call last): File "./change-override", line 26, in from ubuntutools.question import YesNoQuestion ImportError: No module named ubuntutools.question ** Changed in: ubuntu-dev-tools

[Bug 1864571] Re: SRU ubuntu-dev-tools

2020-06-30 Thread Launchpad Bug Tracker
This bug was fixed in the package ubuntu-dev-tools - 0.175~18.04.1 --- ubuntu-dev-tools (0.175~18.04.1) bionic; urgency=medium * Backport to bionic. (LP: #1864571) * Relax debhelper dependency. * Restore (and test) python-ubuntudevtools package. * Invoke pylint in

[Bug 1864571] Re: SRU ubuntu-dev-tools

2020-06-29 Thread Steve Langasek
** Tags removed: verification-needed-bionic ** Tags added: verification-done-bionic -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1864571 Title: SRU ubuntu-dev-tools To manage notifications about

[Bug 1864571] Re: SRU ubuntu-dev-tools

2020-06-23 Thread Steve Langasek
This package has passed its autopkgtests, which was determined to be sufficient for SRU. Marking verification-done. ** Tags removed: verification-needed-bionic ** Tags added: verification-done-bionic ** Tags removed: removal-candidate verification-done-bionic ** Tags added:

[Bug 1864571] Re: SRU ubuntu-dev-tools

2020-04-09 Thread Mathew Hodson
** Changed in: ubuntu-dev-tools (Ubuntu) Status: Invalid => Fix Released -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1864571 Title: SRU ubuntu-dev-tools To manage notifications about this

[Bug 1864571] Re: SRU ubuntu-dev-tools

2020-03-23 Thread Brian Murray
Hello Steve, or anyone else affected, Accepted ubuntu-dev-tools into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-dev- tools/0.175~18.04.1 in a few hours, and then in the -proposed repository. Please help us by testing this new

[Bug 1864571] Re: SRU ubuntu-dev-tools

2020-03-13 Thread Francis Ginther
** Tags added: id-5e34b1277b10d0770615b317 -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1864571 Title: SRU ubuntu-dev-tools To manage notifications about this bug go to:

[Bug 1864571] Re: SRU ubuntu-dev-tools

2020-03-11 Thread Michael Hudson-Doyle
I'm uploading another version to UNAPPROVED, this time restoring python- ubuntutools. I had to patch it a bit to get the tests to pass under Python 2, nothing deep though. It does make it all a bit harder to be confident in though (the binaries use Python 3 in my upload, at least). ** Changed in:

[Bug 1864571] Re: SRU ubuntu-dev-tools

2020-02-28 Thread Dan Streetman
well ok, i see this was uploaded anyway...hope nobody was using python- ubuntutools in bionic, and ever needs an update to that binary pkg :-/ -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1864571

Re: [Bug 1864571] Re: SRU ubuntu-dev-tools

2020-02-26 Thread Steve Langasek
On Wed, Feb 26, 2020 at 01:56:24PM -, Mattia Rizzolo wrote: > This is the kind of things backports should be used for. Backports are not used by default, and the backports archive is for when you want to give users the choice of the old vs the new behavior. My argument is that for a

[Bug 1864571] Re: SRU ubuntu-dev-tools

2020-02-26 Thread Mattia Rizzolo
This is the kind of things backports should be used for. Are there no chances for a new backports team to appear and maintain those pockets? Or, have the backports work like in debian when regular maintainers/developers upload and the team just checks the versioning is correct… -- You

Re: [Bug 1864571] Re: SRU ubuntu-dev-tools

2020-02-25 Thread Steve Langasek
On Tue, Feb 25, 2020 at 01:08:38PM -, Dan Streetman wrote: > ubuntu-dev-tools in focal have py2 support removed, but bionic still > supports py2. Are you suggesting adding py2 support back in for the > bionic backport? I wasn't suggesting it, because I hadn't realized there were bits exposed

[Bug 1864571] Re: SRU ubuntu-dev-tools

2020-02-25 Thread Dan Streetman
ubuntu-dev-tools in focal have py2 support removed, but bionic still supports py2. Are you suggesting adding py2 support back in for the bionic backport? -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

[Bug 1864571] Re: SRU ubuntu-dev-tools

2020-02-24 Thread Michael Hudson-Doyle
** Also affects: ubuntu-dev-tools (Ubuntu Bionic) Importance: Undecided Status: New ** Changed in: ubuntu-dev-tools (Ubuntu) Status: New => Invalid -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu.

[Bug 1864571] Re: SRU ubuntu-dev-tools

2020-02-24 Thread Michael Hudson-Doyle
** Description changed: [SRU justification] The ubuntu-dev-tools package is primarily of interest to Ubuntu developers, providing tools for interacting with the Ubuntu archive and Ubuntu developer-centric services. Developers should have consistent behavior from these tools, regardless of